CompuTec.ProcessForce.API.Actions.Adjustments Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | CreateAdjustment |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


CreateAdjustment Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Actions.Adjustments
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class CreateAdjustment
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CreateAdjustment
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class CreateAdjustment
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CreateAdjustment
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Actions.Adjustments.CreateAdjustment
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CreateAdjustment Members
CompuTec.ProcessForce.API.Actions.Adjustments Namespace


CreateAdjustment Members

CreateAdjustment Class Methods Fields Properties See Also

The following tables list the members exposed by the CreateAdjustment type.

Properties
 | Name | Description
Public property | AdjustLineNum |
Public property | DocDate |
Public property | ManufacturingOrderDocEntry |
Public property | RefDate |
Top
Methods
 | Name | Description
Public method | DoAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | Token |
Top
See Also

Reference

CreateAdjustment Class
CompuTec.ProcessForce.API.Actions.Adjustments Namespace


CreateAdjustment Properties

CreateAdjustment Class See Also

The following tables list the members exposed by the CreateAdjustment type.

Properties
 | Name | Description
Public property | AdjustLineNum |
Public property | DocDate |
Public property | ManufacturingOrderDocEntry |
Public property | RefDate |
Top
See Also

Reference

CreateAdjustment Class
CompuTec.ProcessForce.API.Actions.Adjustments Namespace


CreateAdjustment.AdjustLineNum Property

See Also

Namespace: CompuTec.ProcessForce.API.Actions.Adjustments
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property AdjustLineNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int AdjustLineNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int AdjustLineNum {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get AdjustLineNum() : int;
public function set AdjustLineNum(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CreateAdjustment Class
CreateAdjustment Members
CompuTec.ProcessForce.API.Actions.Adjustments Namespace


CreateAdjustment.DocDate Property

Namespace: CompuTec.ProcessForce.API.Actions.Adjustments
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DocDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime DocDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime DocDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocDate() : DateTime;
public function set DocDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CreateAdjustment Class
CreateAdjustment Members
CompuTec.ProcessForce.API.Actions.Adjustments Namespace


CreateAdjustment.ManufacturingOrderDocEntry Property

Namespace: CompuTec.ProcessForce.API.Actions.Adjustments
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ManufacturingOrderDocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int ManufacturingOrderDocEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int ManufacturingOrderDocEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ManufacturingOrderDocEntry() : int;
public function set ManufacturingOrderDocEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CreateAdjustment Class
CreateAdjustment Members
CompuTec.ProcessForce.API.Actions.Adjustments Namespace


CreateAdjustment.RefDate Property

Namespace: CompuTec.ProcessForce.API.Actions.Adjustments
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property RefDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime RefDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime RefDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get RefDate() : DateTime;
public function set RefDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CreateAdjustment Class
CreateAdjustment Members
CompuTec.ProcessForce.API.Actions.Adjustments Namespace


CreateAdjustment Methods

CreateAdjustment Class See Also

The following tables list the members exposed by the CreateAdjustment type.

Methods
 | Name | Description
Public method | DoAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

CreateAdjustment Class
CompuTec.ProcessForce.API.Actions.Adjustments Namespace


CreateAdjustment.DoAction Method

Namespace: CompuTec.ProcessForce.API.Actions.Adjustments
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub DoAction()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void DoAction()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void DoAction()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DoAction();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CreateAdjustment Class
CreateAdjustment Members
CompuTec.ProcessForce.API.Actions.Adjustments Namespace


CreateAdjustment Fields

CreateAdjustment Class See Also

The following tables list the members exposed by the CreateAdjustment type.

Fields
 | Name | Description
Public field | Token |
Top
See Also

Reference

CreateAdjustment Class
CompuTec.ProcessForce.API.Actions.Adjustments Namespace


Token Field

Namespace: CompuTec.ProcessForce.API.Actions.Adjustments
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Token As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Token
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ Token;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Token : String
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CreateAdjustment Class
CreateAdjustment Members
CompuTec.ProcessForce.API.Actions.Adjustments Namespace


CompuTec.ProcessForce.API.Actions.CopyFromDocument Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ICopyFromDocument |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ICopyFromDocument Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Actions.CopyFromDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ICopyFromDocument
    Inherits IPFAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICopyFromDocument : IPFAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ICopyFromDocument : public IPFAction^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICopyFromDocument
   implements IPFAction
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICopyFromDocument Members
CompuTec.ProcessForce.API.Actions.CopyFromDocument Namespace


ICopyFromDocument Members

ICopyFromDocument Interface Methods Properties See Also

The following tables list the members exposed by the ICopyFromDocument type.

Properties
 | Name | Description
Public property | sourceDocument |
Public property | targetDocument |
Top
Methods
 | Name | Description
Public method | DoAction | (Overloaded)
Public method | GetCreatedDocumentReferences | This method returns Created Document References while do action (inherited from IPFAction).
Top
See Also

Reference

ICopyFromDocument Interface
CompuTec.ProcessForce.API.Actions.CopyFromDocument Namespace


ICopyFromDocument Properties

ICopyFromDocument Interface See Also

The following tables list the members exposed by the ICopyFromDocument type.

Properties
 | Name | Description
Public property | sourceDocument |
Public property | targetDocument |
Top
See Also

Reference

ICopyFromDocument Interface
CompuTec.ProcessForce.API.Actions.CopyFromDocument Namespace


ICopyFromDocument.sourceDocument Property

Namespace: CompuTec.ProcessForce.API.Actions.CopyFromDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property sourceDocument() As Object
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
object sourceDocument {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property object^ sourceDocument {
 object^ get( );
 void set(
   object^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get sourceDocument() : object;
function set sourceDocument(value : object);
This language is not supported or no code example is available.

Property Value

Type: object
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICopyFromDocument Interface
ICopyFromDocument Members
CompuTec.ProcessForce.API.Actions.CopyFromDocument Namespace


ICopyFromDocument.targetDocument Property

Namespace: CompuTec.ProcessForce.API.Actions.CopyFromDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property targetDocument() As Object
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
object targetDocument {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property object^ targetDocument {
 object^ get( );
 void set(
   object^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get targetDocument() : object;
function set targetDocument(value : object);
This language is not supported or no code example is available.

Property Value

Type: object
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICopyFromDocument Interface
ICopyFromDocument Members
CompuTec.ProcessForce.API.Actions.CopyFromDocument Namespace


ICopyFromDocument Methods

ICopyFromDocument Interface See Also

The following tables list the members exposed by the ICopyFromDocument type.

Methods
 | Name | Description
Public method | DoAction | (Overloaded)
Public method | GetCreatedDocumentReferences | This method returns Created Document References while do action (inherited from IPFAction).
Top
See Also

Reference

ICopyFromDocument Interface
CompuTec.ProcessForce.API.Actions.CopyFromDocument Namespace


ICopyFromDocument.DoAction Method

ICopyFromDocument Interface See Also

Overload List
Name | Description
DoAction(out object) | Excecutes an action (inherited from IPFAction).
DoAction() |
See Also

Reference

ICopyFromDocument Interface
ICopyFromDocument Members
CompuTec.ProcessForce.API.Actions.CopyFromDocument Namespace


IPFAction.GetCreatedDocumentReferences Method

This method returns Created Document References while do action

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetCreatedDocumentReferences() As List(Of DocRef)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<DocRef> GetCreatedDocumentReferences()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

List<DocRef^>^ GetCreatedDocumentReferences()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Return Value

Type: List<DocRef>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPFAction Interface
IPFAction Members
CompuTec.ProcessForce.API.Core Namespace


CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | AdjustDocumentDetails |
Top
Interfaces
 | Name | Description
Public interface | ICreateAdjustment |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


AdjustDocumentDetails Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class AdjustDocumentDetails
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class AdjustDocumentDetails
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class AdjustDocumentDetails
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class AdjustDocumentDetails
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Actions.CreateAdjustment.AdjustDocumentDetails
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AdjustDocumentDetails Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


AdjustDocumentDetails Members

AdjustDocumentDetails Class Methods Fields See Also

The following tables list the members exposed by the AdjustDocumentDetails type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
Name | Description
DocMemo |
JrnlMemo |
TaxDate |
documentsDate |
seriesForDocuments |
seriesForIssueForProduction |
seriesForJournalEntries |
seriesForReceiptFromProduction |
Top
See Also

Reference

AdjustDocumentDetails Class
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


AdjustDocumentDetails Methods

AdjustDocumentDetails Class See Also

The following tables list the members exposed by the AdjustDocumentDetails type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

AdjustDocumentDetails Class
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


AdjustDocumentDetails Fields

AdjustDocumentDetails Class See Also

The following tables list the members exposed by the AdjustDocumentDetails type.

Fields
Name | Description
DocMemo |
JrnlMemo |
TaxDate |
documentsDate |
seriesForDocuments |
seriesForIssueForProduction |
seriesForJournalEntries |
seriesForReceiptFromProduction |
Top
See Also

Reference

AdjustDocumentDetails Class
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


DocMemo Field

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared DocMemo As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string DocMemo
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ DocMemo;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static DocMemo : String
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AdjustDocumentDetails Class
AdjustDocumentDetails Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


JrnlMemo Field

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared JrnlMemo As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string JrnlMemo
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ JrnlMemo;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static JrnlMemo : String
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AdjustDocumentDetails Class
AdjustDocumentDetails Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


TaxDate Field

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared TaxDate As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static DateTime TaxDate
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static DateTime TaxDate;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static TaxDate : DateTime
This language is not supported or no code example is available.

Field Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AdjustDocumentDetails Class
AdjustDocumentDetails Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


documentsDate Field

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared documentsDate As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static DateTime documentsDate
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static DateTime documentsDate;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static documentsDate : DateTime
This language is not supported or no code example is available.

Field Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AdjustDocumentDetails Class
AdjustDocumentDetails Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


seriesForDocuments Field

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Shadows seriesForDocuments As Dictionary(Of String, Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
new public static Dictionary<string, int> seriesForDocuments
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static Dictionary<String^, int>^ seriesForDocuments;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Field Value

Type: Dictionary<string, int>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AdjustDocumentDetails Class
AdjustDocumentDetails Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


seriesForIssueForProduction Field

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared seriesForIssueForProduction As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool seriesForIssueForProduction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool seriesForIssueForProduction;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static seriesForIssueForProduction : boolean
This language is not supported or no code example is available.

Field Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AdjustDocumentDetails Class
AdjustDocumentDetails Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


seriesForJournalEntries Field

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared seriesForJournalEntries As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool seriesForJournalEntries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool seriesForJournalEntries;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static seriesForJournalEntries : boolean
This language is not supported or no code example is available.

Field Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AdjustDocumentDetails Class
AdjustDocumentDetails Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


seriesForReceiptFromProduction Field

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared seriesForReceiptFromProduction As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool seriesForReceiptFromProduction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool seriesForReceiptFromProduction;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static seriesForReceiptFromProduction : boolean
This language is not supported or no code example is available.

Field Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AdjustDocumentDetails Class
AdjustDocumentDetails Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


ICreateAdjustment Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ICreateAdjustment
    Inherits IPFAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICreateAdjustment : IPFAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ICreateAdjustment : public IPFAction^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICreateAdjustment
   implements IPFAction
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateAdjustment Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


ICreateAdjustment Members

ICreateAdjustment Interface Methods Properties See Also

The following tables list the members exposed by the ICreateAdjustment type.

Properties
 | Name | Description
Public property | AdjustmentType | Type of adjusted document
Public property | DocMemo |
Public property | ItemCode | Master key of an item
Public property | JrnlMemo |
Public property | ManufacturingOrder | Manufacturing Order document
Public property | OperEntry | DocEntry of adjusted document
Public property | OperLine | Line Id from adjusted document
Public property | RecordSet | RecordSet that holds all documents to adjust
Public property | TaxDate |
Public property | documentsDate |
Public property | seriesForIssueForProduction |
Public property | seriesForJournalEntries |
Public property | seriesForReceiptFromProduction |
Top
Methods
 | Name | Description
Public method | DoAction | Excecutes an action (inherited from IPFAction).
Public method | GetCreatedDocumentReferences | This method returns Created Document References while do action (inherited from IPFAction).
Top
See Also

Reference

ICreateAdjustment Interface
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


ICreateAdjustment Properties

ICreateAdjustment Interface See Also

The following tables list the members exposed by the ICreateAdjustment type.

Properties
 | Name | Description
Public property | AdjustmentType | Type of adjusted document
Public property | DocMemo |
Public property | ItemCode | Master key of an item
Public property | JrnlMemo |
Public property | ManufacturingOrder | Manufacturing Order document
Public property | OperEntry | DocEntry of adjusted document
Public property | OperLine | Line Id from adjusted document
Public property | RecordSet | RecordSet that holds all documents to adjust
Public property | TaxDate |
Public property | documentsDate |
Public property | seriesForIssueForProduction |
Public property | seriesForJournalEntries |
Public property | seriesForReceiptFromProduction |
Top
See Also

Reference

ICreateAdjustment Interface
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


ICreateAdjustment.AdjustmentType Property

Type of adjusted document

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property AdjustmentType() As AdjustmentType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
AdjustmentType AdjustmentType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property AdjustmentType AdjustmentType {
 AdjustmentType get( );
 void set(
   AdjustmentType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get AdjustmentType() : AdjustmentType;
function set AdjustmentType(value : AdjustmentType);
This language is not supported or no code example is available.

Property Value

Type: AdjustmentType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateAdjustment Interface
ICreateAdjustment Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


ICreateAdjustment.DocMemo Property

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DocMemo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DocMemo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DocMemo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocMemo() : String;
function set DocMemo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateAdjustment Interface
ICreateAdjustment Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


ICreateAdjustment.ItemCode Property

Master key of an item

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ItemCode() : String;
function set ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateAdjustment Interface
ICreateAdjustment Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


ICreateAdjustment.JrnlMemo Property

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property JrnlMemo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string JrnlMemo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ JrnlMemo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get JrnlMemo() : String;
function set JrnlMemo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateAdjustment Interface
ICreateAdjustment Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


ICreateAdjustment.ManufacturingOrder Property

Manufacturing Order document

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ManufacturingOrder() As IManufacturingOrder
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IManufacturingOrder ManufacturingOrder {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IManufacturingOrder^ ManufacturingOrder {
 IManufacturingOrder^ get( );
 void set(
   IManufacturingOrder^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ManufacturingOrder() : IManufacturingOrder;
function set ManufacturingOrder(value : IManufacturingOrder);
This language is not supported or no code example is available.

Property Value

Type: IManufacturingOrder
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateAdjustment Interface
ICreateAdjustment Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


ICreateAdjustment.OperEntry Property

DocEntry of adjusted document

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property OperEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int OperEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int OperEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OperEntry() : int;
function set OperEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateAdjustment Interface
ICreateAdjustment Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


ICreateAdjustment.OperLine Property

Line Id from adjusted document

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property OperLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int OperLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int OperLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OperLine() : int;
function set OperLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateAdjustment Interface
ICreateAdjustment Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


ICreateAdjustment.RecordSet Property

RecordSet that holds all documents to adjust

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property RecordSet() As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset RecordSet {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property CTRecordset^ RecordSet {
 CTRecordset^ get( );
 void set(
   CTRecordset^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RecordSet() : CTRecordset;
function set RecordSet(value : CTRecordset);
This language is not supported or no code example is available.

Property Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateAdjustment Interface
ICreateAdjustment Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


ICreateAdjustment.TaxDate Property

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property TaxDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime TaxDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime TaxDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get TaxDate() : DateTime;
function set TaxDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateAdjustment Interface
ICreateAdjustment Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


ICreateAdjustment.documentsDate Property

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property documentsDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime documentsDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime documentsDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get documentsDate() : DateTime;
function set documentsDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateAdjustment Interface
ICreateAdjustment Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


ICreateAdjustment.seriesForIssueForProduction Property

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property seriesForIssueForProduction() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int seriesForIssueForProduction {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int seriesForIssueForProduction {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get seriesForIssueForProduction() : int;
function set seriesForIssueForProduction(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateAdjustment Interface
ICreateAdjustment Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


ICreateAdjustment.seriesForJournalEntries Property

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property seriesForJournalEntries() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int seriesForJournalEntries {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int seriesForJournalEntries {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get seriesForJournalEntries() : int;
function set seriesForJournalEntries(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateAdjustment Interface
ICreateAdjustment Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


ICreateAdjustment.seriesForReceiptFromProduction Property

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property seriesForReceiptFromProduction() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int seriesForReceiptFromProduction {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int seriesForReceiptFromProduction {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get seriesForReceiptFromProduction() : int;
function set seriesForReceiptFromProduction(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateAdjustment Interface
ICreateAdjustment Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


ICreateAdjustment Methods

ICreateAdjustment Interface See Also

The following tables list the members exposed by the ICreateAdjustment type.

Methods
 | Name | Description
Public method | DoAction | Excecutes an action (inherited from IPFAction).
Public method | GetCreatedDocumentReferences | This method returns Created Document References while do action (inherited from IPFAction).
Top
See Also

Reference

ICreateAdjustment Interface
CompuTec.ProcessForce.API.Actions.CreateAdjustment Namespace


IPFAction.DoAction Method

Excecutes an action

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function DoAction( _
   ByRef documentNumer As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool DoAction(
   out object documentNumer
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool DoAction(
   object^& documentNumer
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function DoAction(
    documentNumer : object
) : boolean;
This language is not supported or no code example is available.

Parameters

documentNumer

Type: object

Newly added DocEntry

Return Value

Type: bool

Success

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPFAction Interface
IPFAction Members
CompuTec.ProcessForce.API.Core Namespace


CompuTec.ProcessForce.API.Actions.CreateAdjustment.HelpStructures Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | AdjustmentEnums |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


AdjustmentEnums Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment.HelpStructures
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class AdjustmentEnums
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class AdjustmentEnums
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class AdjustmentEnums
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class AdjustmentEnums
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Actions.CreateAdjustment.HelpStructures.AdjustmentEnums
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AdjustmentEnums Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment.HelpStructures Namespace


AdjustmentEnums Members

AdjustmentEnums Class Methods See Also

The following tables list the members exposed by the AdjustmentEnums type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Enumerations
 | Name | Description
Public enumeration | AdjustmentType |
Top
See Also

Reference

AdjustmentEnums Class
CompuTec.ProcessForce.API.Actions.CreateAdjustment.HelpStructures Namespace


AdjustmentType Enumeration

Namespace: CompuTec.ProcessForce.API.Actions.CreateAdjustment.HelpStructures
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Null |
GoodsIssue |
GoodsReceipt |
See Also

Reference

AdjustmentEnums Class
AdjustmentEnums Members
CompuTec.ProcessForce.API.Actions.CreateAdjustment.HelpStructures Namespace


AdjustmentEnums Methods

AdjustmentEnums Class See Also

The following tables list the members exposed by the AdjustmentEnums type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

AdjustmentEnums Class
CompuTec.ProcessForce.API.Actions.CreateAdjustment.HelpStructures Namespace


CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ICreateDeliveryFromPickOrder |
Top
Structures
 | Name | Description
Public structure | ResultData |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ICreateDeliveryFromPickOrder Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ICreateDeliveryFromPickOrder
    Inherits IPFAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICreateDeliveryFromPickOrder : IPFAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ICreateDeliveryFromPickOrder : public IPFAction^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICreateDeliveryFromPickOrder
   implements IPFAction
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateDeliveryFromPickOrder Members
CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder Namespace


ICreateDeliveryFromPickOrder Members

ICreateDeliveryFromPickOrder Interface Methods Properties See Also

The following tables list the members exposed by the ICreateDeliveryFromPickOrder type.

Properties
 | Name | Description
Public property | DocDate |
Public property | DocumentMemo |
Public property | DocumentSeries |
Public property | PickOrderID |
Public property | TaxDate |
Top
Methods
 | Name | Description
Public method | DoAction | Excecutes an action (inherited from IPFAction).
Public method | GetCreatedDocumentReferences | This method returns Created Document References while do action (inherited from IPFAction).
Top
See Also

Reference

ICreateDeliveryFromPickOrder Interface
CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder Namespace


ICreateDeliveryFromPickOrder Properties

ICreateDeliveryFromPickOrder Interface See Also

The following tables list the members exposed by the ICreateDeliveryFromPickOrder type.

Properties
 | Name | Description
Public property | DocDate |
Public property | DocumentMemo |
Public property | DocumentSeries |
Public property | PickOrderID |
Public property | TaxDate |
Top
See Also

Reference

ICreateDeliveryFromPickOrder Interface
CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder Namespace


ICreateDeliveryFromPickOrder.DocDate Property

Namespace: CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DocDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime DocDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime DocDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocDate() : DateTime;
function set DocDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateDeliveryFromPickOrder Interface
ICreateDeliveryFromPickOrder Members
CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder Namespace


ICreateDeliveryFromPickOrder.DocumentMemo Property

Namespace: CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DocumentMemo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DocumentMemo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DocumentMemo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocumentMemo() : String;
function set DocumentMemo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateDeliveryFromPickOrder Interface
ICreateDeliveryFromPickOrder Members
CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder Namespace


ICreateDeliveryFromPickOrder.DocumentSeries Property

Namespace: CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DocumentSeries() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocumentSeries {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocumentSeries {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocumentSeries() : int;
function set DocumentSeries(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateDeliveryFromPickOrder Interface
ICreateDeliveryFromPickOrder Members
CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder Namespace


ICreateDeliveryFromPickOrder.PickOrderID Property

Namespace: CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property PickOrderID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int PickOrderID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int PickOrderID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get PickOrderID() : int;
function set PickOrderID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateDeliveryFromPickOrder Interface
ICreateDeliveryFromPickOrder Members
CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder Namespace


ICreateDeliveryFromPickOrder.TaxDate Property

Namespace: CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property TaxDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime TaxDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime TaxDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get TaxDate() : DateTime;
function set TaxDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateDeliveryFromPickOrder Interface
ICreateDeliveryFromPickOrder Members
CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder Namespace


ICreateDeliveryFromPickOrder Methods

ICreateDeliveryFromPickOrder Interface See Also

The following tables list the members exposed by the ICreateDeliveryFromPickOrder type.

Methods
 | Name | Description
Public method | DoAction | Excecutes an action (inherited from IPFAction).
Public method | GetCreatedDocumentReferences | This method returns Created Document References while do action (inherited from IPFAction).
Top
See Also

Reference

ICreateDeliveryFromPickOrder Interface
CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder Namespace


ResultData Structure

Members See Also

Namespace: CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Structure ResultData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public struct ResultData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public value struct ResultData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript suports the use of structures, but not the declaration of new ones.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResultData Members
CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder Namespace


ResultData Members

ResultData Structure Properties See Also

The following tables list the members exposed by the ResultData type.

Properties
 | Name | Description
Public property | FailureReason |
Public property | WasDocumentAdded |
Top
See Also

Reference

ResultData Structure
CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder Namespace


ResultData Properties

ResultData Structure See Also

The following tables list the members exposed by the ResultData type.

Properties
 | Name | Description
Public property | FailureReason |
Public property | WasDocumentAdded |
Top
See Also

Reference

ResultData Structure
CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder Namespace


ResultData.FailureReason Property

Namespace: CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property FailureReason() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string FailureReason {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ FailureReason {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get FailureReason() : String;
public function set FailureReason(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResultData Structure
ResultData Members
CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder Namespace


ResultData.WasDocumentAdded Property

Namespace: CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property WasDocumentAdded() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool WasDocumentAdded {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool WasDocumentAdded {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get WasDocumentAdded() : boolean;
public function set WasDocumentAdded(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResultData Structure
ResultData Members
CompuTec.ProcessForce.API.Actions.CreateDeliveryFromPickOrder Namespace


CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ICreateGoodsIssueFromPickOrderBasedOnProductionIssue | This object is used for creating Goods Issue From PickOrder Based On Production Issue practicly it creates Good Issue of an items from related manufacturing order
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Interface

Members See Also

This object is used for creating Goods Issue From PickOrder Based On Production Issue practicly it creates Good Issue of an items from related manufacturing order

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ICreateGoodsIssueFromPickOrderBasedOnProductionIssue
    Inherits IPFAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICreateGoodsIssueFromPickOrderBasedOnProductionIssue : IPFAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ICreateGoodsIssueFromPickOrderBasedOnProductionIssue : public IPFAction^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICreateGoodsIssueFromPickOrderBasedOnProductionIssue
   implements IPFAction
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Members
CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue Namespace


ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Members

ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Interface Methods Properties See Also

This object is used for creating Goods Issue From PickOrder Based On Production Issue practicly it creates Good Issue of an items from related manufacturing order

The following tables list the members exposed by the ICreateGoodsIssueFromPickOrderBasedOnProductionIssue type.

Properties
 | Name | Description
Public property | DocDate | Goods Issue DocDate
Public property | DocumentMemo | Goods Issue Memo
Public property | GeExitSeries | Goods Issue Document Series
Public property | JurnalEntrySeries | Jurnal Series of an Extra Jurnal Entry
Public property | JurnalMemo | Jurnal Entry Memo for extra jurnal entry
Public property | PickOrderID | PickOrder DocEntry witch we want to issue
Public property | TaxDate | Goods Issue TaxDate
Top
Methods
 | Name | Description
Public method | DoAction | (Overloaded) Goods issue only for listed lines in line references parameter
Public method | GetCreatedDocumentReferences | This method returns Created Document References while do action (inherited from IPFAction).
Top
See Also

Reference

ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Interface
CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue Namespace


ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Properties

ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Interface See Also

The following tables list the members exposed by the ICreateGoodsIssueFromPickOrderBasedOnProductionIssue type.

Properties
 | Name | Description
Public property | DocDate | Goods Issue DocDate
Public property | DocumentMemo | Goods Issue Memo
Public property | GeExitSeries | Goods Issue Document Series
Public property | JurnalEntrySeries | Jurnal Series of an Extra Jurnal Entry
Public property | JurnalMemo | Jurnal Entry Memo for extra jurnal entry
Public property | PickOrderID | PickOrder DocEntry witch we want to issue
Public property | TaxDate | Goods Issue TaxDate
Top
See Also

Reference

ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Interface
CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue Namespace


ICreateGoodsIssueFromPickOrderBasedOnProductionIssue.DocDate Property

Goods Issue DocDate

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DocDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime DocDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime DocDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocDate() : DateTime;
function set DocDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Interface
ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Members
CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue Namespace


ICreateGoodsIssueFromPickOrderBasedOnProductionIssue.DocumentMemo Property

Goods Issue Memo

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DocumentMemo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DocumentMemo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DocumentMemo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocumentMemo() : String;
function set DocumentMemo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Interface
ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Members
CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue Namespace


ICreateGoodsIssueFromPickOrderBasedOnProductionIssue.GeExitSeries Property

Goods Issue Document Series

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property GeExitSeries() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GeExitSeries {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int GeExitSeries {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get GeExitSeries() : int;
function set GeExitSeries(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Interface
ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Members
CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue Namespace


ICreateGoodsIssueFromPickOrderBasedOnProductionIssue.JurnalEntrySeries Property

Jurnal Series of an Extra Jurnal Entry

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property JurnalEntrySeries() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int JurnalEntrySeries {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int JurnalEntrySeries {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get JurnalEntrySeries() : int;
function set JurnalEntrySeries(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Interface
ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Members
CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue Namespace


ICreateGoodsIssueFromPickOrderBasedOnProductionIssue.JurnalMemo Property

Jurnal Entry Memo for extra jurnal entry

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property JurnalMemo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string JurnalMemo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ JurnalMemo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get JurnalMemo() : String;
function set JurnalMemo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Interface
ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Members
CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue Namespace


ICreateGoodsIssueFromPickOrderBasedOnProductionIssue.PickOrderID Property

PickOrder DocEntry witch we want to issue

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property PickOrderID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int PickOrderID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int PickOrderID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get PickOrderID() : int;
function set PickOrderID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Interface
ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Members
CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue Namespace


ICreateGoodsIssueFromPickOrderBasedOnProductionIssue.TaxDate Property

Goods Issue TaxDate

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property TaxDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime TaxDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime TaxDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get TaxDate() : DateTime;
function set TaxDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Interface
ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Members
CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue Namespace


ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Methods

ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Interface See Also

The following tables list the members exposed by the ICreateGoodsIssueFromPickOrderBasedOnProductionIssue type.

Methods
 | Name | Description
Public method | DoAction | (Overloaded) Goods issue only for listed lines in line references parameter
Public method | GetCreatedDocumentReferences | This method returns Created Document References while do action (inherited from IPFAction).
Top
See Also

Reference

ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Interface
CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue Namespace


ICreateGoodsIssueFromPickOrderBasedOnProductionIssue.DoAction Method

ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Interface See Also

Goods issue only for listed lines in line references parameter

Overload List
Name | Description
DoAction(out object) | Excecutes an action (inherited from IPFAction).
DoAction(out object, IEnumerable<Int32>) | Goods issue only for listed lines in line references parameter
See Also

Reference

ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Interface
ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Members
CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue Namespace


CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | ManufacturiongOrderIsClosedException |
Public class | QuantityToLowForBackflushItemsException |
Top
Interfaces
 | Name | Description
Public interface | ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt | Object For Creating final production Goods Receipt This action is based on Pick Receipt Document
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ManufacturiongOrderIsClosedException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class ManufacturiongOrderIsClosedException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class ManufacturiongOrderIsClosedException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class ManufacturiongOrderIsClosedException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class ManufacturiongOrderIsClosedException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt.ManufacturiongOrderIsClosedException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ManufacturiongOrderIsClosedException Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ManufacturiongOrderIsClosedException Members

ManufacturiongOrderIsClosedException Class Constructors Methods Properties See Also

The following tables list the members exposed by the ManufacturiongOrderIsClosedException type.

Constructors
 | Name | Description
Public constructor | ManufacturiongOrderIsClosedException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ManufacturiongOrderIsClosedException Class
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ManufacturiongOrderIsClosedException Constructor

ManufacturiongOrderIsClosedException Class See Also

Overload List
Name | Description
ManufacturiongOrderIsClosedException() |
ManufacturiongOrderIsClosedException(string) |
ManufacturiongOrderIsClosedException(string, Exception) |
See Also

Reference

ManufacturiongOrderIsClosedException Class
ManufacturiongOrderIsClosedException Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ManufacturiongOrderIsClosedException Properties

ManufacturiongOrderIsClosedException Class See Also

The following tables list the members exposed by the ManufacturiongOrderIsClosedException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

ManufacturiongOrderIsClosedException Class
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ManufacturiongOrderIsClosedException Methods

ManufacturiongOrderIsClosedException Class See Also

The following tables list the members exposed by the ManufacturiongOrderIsClosedException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ManufacturiongOrderIsClosedException Class
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


QuantityToLowForBackflushItemsException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class QuantityToLowForBackflushItemsException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class QuantityToLowForBackflushItemsException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class QuantityToLowForBackflushItemsException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class QuantityToLowForBackflushItemsException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt.QuantityToLowForBackflushItemsException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QuantityToLowForBackflushItemsException Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


QuantityToLowForBackflushItemsException Members

QuantityToLowForBackflushItemsException Class Constructors Methods Properties See Also

The following tables list the members exposed by the QuantityToLowForBackflushItemsException type.

Constructors
 | Name | Description
Public constructor | QuantityToLowForBackflushItemsException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

QuantityToLowForBackflushItemsException Class
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


QuantityToLowForBackflushItemsException Constructor

QuantityToLowForBackflushItemsException Class See Also

Overload List
Name | Description
QuantityToLowForBackflushItemsException() |
QuantityToLowForBackflushItemsException(string) |
QuantityToLowForBackflushItemsException(string, Exception) |
See Also

Reference

QuantityToLowForBackflushItemsException Class
QuantityToLowForBackflushItemsException Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


QuantityToLowForBackflushItemsException Properties

QuantityToLowForBackflushItemsException Class See Also

The following tables list the members exposed by the QuantityToLowForBackflushItemsException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

QuantityToLowForBackflushItemsException Class
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


QuantityToLowForBackflushItemsException Methods

QuantityToLowForBackflushItemsException Class See Also

The following tables list the members exposed by the QuantityToLowForBackflushItemsException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

QuantityToLowForBackflushItemsException Class
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Interface

Members See Also

Object For Creating final production Goods Receipt This action is based on Pick Receipt Document

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
    Inherits IPFAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt : IPFAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt : public IPFAction^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
   implements IPFAction
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Members

ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Interface Methods Properties See Also

Object For Creating final production Goods Receipt This action is based on Pick Receipt Document

The following tables list the members exposed by the ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt type.

Properties
 | Name | Description
Public property | BackFlushEntrySeries | Series for Backflush Godds Receipt Document
Public property | BackFlushExitSeries | Series fro Backflush Gods Issue Document
Public property | DocDate | Goods Receipt DocDate -mandatory
Public property | DocumentMemo | Goods Receipt Memo
Public property | GenEntrySeries | Series for Godds Receipt Document
Public property | JurnalEntrySeries | Series for Extra Jurnal Entry
Public property | JurnalMemo | Memo of an Extra jurnal Entry
Public property | PickReceiptID | Pick Receipt DocEntry
Public property | TaxDate | Goods Receipt Tax Date -mandatory
Top
Methods
 | Name | Description
Public method | DoAction | (Overloaded) Goods Receipt only for listed lines in line references parameter
Public method | GetCreatedDocumentReferences | This method returns Created Document References while do action (inherited from IPFAction).
Top
See Also

Reference

ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Interface
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Properties

ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Interface See Also

The following tables list the members exposed by the ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt type.

Properties
 | Name | Description
Public property | BackFlushEntrySeries | Series for Backflush Godds Receipt Document
Public property | BackFlushExitSeries | Series fro Backflush Gods Issue Document
Public property | DocDate | Goods Receipt DocDate -mandatory
Public property | DocumentMemo | Goods Receipt Memo
Public property | GenEntrySeries | Series for Godds Receipt Document
Public property | JurnalEntrySeries | Series for Extra Jurnal Entry
Public property | JurnalMemo | Memo of an Extra jurnal Entry
Public property | PickReceiptID | Pick Receipt DocEntry
Public property | TaxDate | Goods Receipt Tax Date -mandatory
Top
See Also

Reference

ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Interface
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt.BackFlushEntrySeries Property

Series for Backflush Godds Receipt Document

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BackFlushEntrySeries() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int BackFlushEntrySeries {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int BackFlushEntrySeries {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BackFlushEntrySeries() : int;
function set BackFlushEntrySeries(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Interface
ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt.BackFlushExitSeries Property

Series fro Backflush Gods Issue Document

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BackFlushExitSeries() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int BackFlushExitSeries {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int BackFlushExitSeries {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BackFlushExitSeries() : int;
function set BackFlushExitSeries(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Interface
ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt.DocDate Property

Goods Receipt DocDate -mandatory

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DocDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime DocDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime DocDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocDate() : DateTime;
function set DocDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Interface
ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt.DocumentMemo Property

Goods Receipt Memo

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DocumentMemo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DocumentMemo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DocumentMemo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocumentMemo() : String;
function set DocumentMemo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Interface
ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt.GenEntrySeries Property

Series for Godds Receipt Document

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property GenEntrySeries() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GenEntrySeries {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int GenEntrySeries {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get GenEntrySeries() : int;
function set GenEntrySeries(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Interface
ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt.JurnalEntrySeries Property

Series for Extra Jurnal Entry

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property JurnalEntrySeries() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int JurnalEntrySeries {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int JurnalEntrySeries {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get JurnalEntrySeries() : int;
function set JurnalEntrySeries(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Interface
ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt.JurnalMemo Property

Memo of an Extra jurnal Entry

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property JurnalMemo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string JurnalMemo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ JurnalMemo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get JurnalMemo() : String;
function set JurnalMemo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Interface
ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt.PickReceiptID Property

Pick Receipt DocEntry

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property PickReceiptID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int PickReceiptID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int PickReceiptID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get PickReceiptID() : int;
function set PickReceiptID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Interface
ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt.TaxDate Property

Goods Receipt Tax Date -mandatory

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property TaxDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime TaxDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime TaxDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get TaxDate() : DateTime;
function set TaxDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Interface
ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Methods

ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Interface See Also

The following tables list the members exposed by the ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt type.

Methods
 | Name | Description
Public method | DoAction | (Overloaded) Goods Receipt only for listed lines in line references parameter
Public method | GetCreatedDocumentReferences | This method returns Created Document References while do action (inherited from IPFAction).
Top
See Also

Reference

ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Interface
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt.DoAction Method

ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Interface See Also

Goods Receipt only for listed lines in line references parameter

Overload List
Name | Description
DoAction(out object) | Excecutes an action (inherited from IPFAction).
DoAction(out object, IEnumerable<Int32>) | Goods Receipt only for listed lines in line references parameter
See Also

Reference

ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Interface
ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


CompuTec.ProcessForce.API.Actions.CreatePickOrderForProductionIssue Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ICreatePickOrderForProductionIssue | This Action Create PickOrderDocument For one or several manufacturing order
Top
Enumerations
 | Name | Description
Public enumeration | OutputType |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ICreatePickOrderForProductionIssue Interface

Members See Also

This Action Create PickOrderDocument For one or several manufacturing order

Namespace: CompuTec.ProcessForce.API.Actions.CreatePickOrderForProductionIssue
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ICreatePickOrderForProductionIssue
    Inherits IPFAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICreatePickOrderForProductionIssue : IPFAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ICreatePickOrderForProductionIssue : public IPFAction^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICreatePickOrderForProductionIssue
   implements IPFAction
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreatePickOrderForProductionIssue Members
CompuTec.ProcessForce.API.Actions.CreatePickOrderForProductionIssue Namespace


ICreatePickOrderForProductionIssue Members

ICreatePickOrderForProductionIssue Interface Methods Properties See Also

This Action Create PickOrderDocument For one or several manufacturing order

The following tables list the members exposed by the ICreatePickOrderForProductionIssue type.

Properties
 | Name | Description
Public property | Return_type | Output Type [Obsolete must use PickOrder]
Public property | Rework |
Top
Methods
 | Name | Description
Public method | AddMORDocEntry | You must add DocEntry of MOR documents from witch you will create pick order
Public method | DoAction | (Overloaded) Create Pick Order For specific Items on Manufacturing Order
Public method | GetCreatedDocumentReferences | This method returns Created Document References while do action (inherited from IPFAction).
Top
See Also

Reference

ICreatePickOrderForProductionIssue Interface
CompuTec.ProcessForce.API.Actions.CreatePickOrderForProductionIssue Namespace


ICreatePickOrderForProductionIssue Properties

ICreatePickOrderForProductionIssue Interface See Also

The following tables list the members exposed by the ICreatePickOrderForProductionIssue type.

Properties
 | Name | Description
Public property | Return_type | Output Type [Obsolete must use PickOrder]
Public property | Rework |
Top
See Also

Reference

ICreatePickOrderForProductionIssue Interface
CompuTec.ProcessForce.API.Actions.CreatePickOrderForProductionIssue Namespace


ICreatePickOrderForProductionIssue.Return_type Property

Output Type [Obsolete must use PickOrder]

Namespace: CompuTec.ProcessForce.API.Actions.CreatePickOrderForProductionIssue
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Return_type() As OutputType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
OutputType Return_type {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property OutputType Return_type {
 OutputType get( );
 void set(
   OutputType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Return_type() : OutputType;
function set Return_type(value : OutputType);
This language is not supported or no code example is available.

Property Value

Type: OutputType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreatePickOrderForProductionIssue Interface
ICreatePickOrderForProductionIssue Members
CompuTec.ProcessForce.API.Actions.CreatePickOrderForProductionIssue Namespace


ICreatePickOrderForProductionIssue.Rework Property

Namespace: CompuTec.ProcessForce.API.Actions.CreatePickOrderForProductionIssue
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Rework() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool Rework {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool Rework {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Rework() : boolean;
function set Rework(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreatePickOrderForProductionIssue Interface
ICreatePickOrderForProductionIssue Members
CompuTec.ProcessForce.API.Actions.CreatePickOrderForProductionIssue Namespace


ICreatePickOrderForProductionIssue Methods

ICreatePickOrderForProductionIssue Interface See Also

The following tables list the members exposed by the ICreatePickOrderForProductionIssue type.

Methods
 | Name | Description
Public method | AddMORDocEntry | You must add DocEntry of MOR documents from witch you will create pick order
Public method | DoAction | (Overloaded) Create Pick Order For specific Items on Manufacturing Order
Public method | GetCreatedDocumentReferences | This method returns Created Document References while do action (inherited from IPFAction).
Top
See Also

Reference

ICreatePickOrderForProductionIssue Interface
CompuTec.ProcessForce.API.Actions.CreatePickOrderForProductionIssue Namespace


ICreatePickOrderForProductionIssue.AddMORDocEntry Method

You must add DocEntry of MOR documents from witch you will create pick order

Namespace: CompuTec.ProcessForce.API.Actions.CreatePickOrderForProductionIssue
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub AddMORDocEntry( _
   ByVal DocEntry As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void AddMORDocEntry(
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void AddMORDocEntry(
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function AddMORDocEntry(
    DocEntry : int
);
This language is not supported or no code example is available.

Parameters

DocEntry

Type: int

MOR DocEntry

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreatePickOrderForProductionIssue Interface
ICreatePickOrderForProductionIssue Members
CompuTec.ProcessForce.API.Actions.CreatePickOrderForProductionIssue Namespace


ICreatePickOrderForProductionIssue.DoAction Method

ICreatePickOrderForProductionIssue Interface See Also

Create Pick Order For specific Items on Manufacturing Order

Overload List
Name | Description
DoAction(out object) | Excecutes an action (inherited from IPFAction).
DoAction(Dictionary<Int32List<Int32>>) | Create Pick Order For specific Items on Manufacturing Order
See Also

Reference

ICreatePickOrderForProductionIssue Interface
ICreatePickOrderForProductionIssue Members
CompuTec.ProcessForce.API.Actions.CreatePickOrderForProductionIssue Namespace


OutputType Enumeration

Namespace: CompuTec.ProcessForce.API.Actions.CreatePickOrderForProductionIssue
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Draft |
PickOrder |
See Also

Reference

CompuTec.ProcessForce.API.Actions.CreatePickOrderForProductionIssue Namespace


CompuTec.ProcessForce.API.Actions.CreatePickReceiptForProductionReceipt Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ICreatePickReceiptForProductionReceipt | Object That creates PickReceipt Document For Manufacturing Order or Orders
Top
Enumerations
 | Name | Description
Public enumeration | PickOrderdReceiptType |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ICreatePickReceiptForProductionReceipt Interface

Members See Also

Object That creates PickReceipt Document For Manufacturing Order or Orders

Namespace: CompuTec.ProcessForce.API.Actions.CreatePickReceiptForProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ICreatePickReceiptForProductionReceipt
    Inherits IPFAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICreatePickReceiptForProductionReceipt : IPFAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ICreatePickReceiptForProductionReceipt : public IPFAction^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICreatePickReceiptForProductionReceipt
   implements IPFAction
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreatePickReceiptForProductionReceipt Members
CompuTec.ProcessForce.API.Actions.CreatePickReceiptForProductionReceipt Namespace


ICreatePickReceiptForProductionReceipt Members

ICreatePickReceiptForProductionReceipt Interface Methods Properties See Also

Object That creates PickReceipt Document For Manufacturing Order or Orders

The following tables list the members exposed by the ICreatePickReceiptForProductionReceipt type.

Properties
 | Name | Description
Public property | ReceiptType | What Ytpe Of Items You Want to add to Pick Receipt Final good, or Scraps or Cooproducts
Top
Methods
 | Name | Description
Public method | AddManufacturingOrderDocEntry | Adds Manufacturing Order Doc Entry
Public method | DoAction | (Overloaded) This Extends starndard Do Action By Allowing to determine what items will apeare on Pick List
Public method | GetCreatedDocumentReferences | This method returns Created Document References while do action (inherited from IPFAction).
Top
See Also

Reference

ICreatePickReceiptForProductionReceipt Interface
CompuTec.ProcessForce.API.Actions.CreatePickReceiptForProductionReceipt Namespace


ICreatePickReceiptForProductionReceipt Properties

ICreatePickReceiptForProductionReceipt Interface See Also

The following tables list the members exposed by the ICreatePickReceiptForProductionReceipt type.

Properties
 | Name | Description
Public property | ReceiptType | What Ytpe Of Items You Want to add to Pick Receipt Final good, or Scraps or Cooproducts
Top
See Also

Reference

ICreatePickReceiptForProductionReceipt Interface
CompuTec.ProcessForce.API.Actions.CreatePickReceiptForProductionReceipt Namespace


ICreatePickReceiptForProductionReceipt.ReceiptType Property

What Ytpe Of Items You Want to add to Pick Receipt Final good, or Scraps or Cooproducts

Namespace: CompuTec.ProcessForce.API.Actions.CreatePickReceiptForProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ReceiptType() As PickOrderdReceiptType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
PickOrderdReceiptType ReceiptType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property PickOrderdReceiptType ReceiptType {
 PickOrderdReceiptType get( );
 void set(
   PickOrderdReceiptType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ReceiptType() : PickOrderdReceiptType;
function set ReceiptType(value : PickOrderdReceiptType);
This language is not supported or no code example is available.

Property Value

Type: PickOrderdReceiptType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreatePickReceiptForProductionReceipt Interface
ICreatePickReceiptForProductionReceipt Members
CompuTec.ProcessForce.API.Actions.CreatePickReceiptForProductionReceipt Namespace


ICreatePickReceiptForProductionReceipt Methods

ICreatePickReceiptForProductionReceipt Interface See Also

The following tables list the members exposed by the ICreatePickReceiptForProductionReceipt type.

Methods
 | Name | Description
Public method | AddManufacturingOrderDocEntry | Adds Manufacturing Order Doc Entry
Public method | DoAction | (Overloaded) This Extends starndard Do Action By Allowing to determine what items will apeare on Pick List
Public method | GetCreatedDocumentReferences | This method returns Created Document References while do action (inherited from IPFAction).
Top
See Also

Reference

ICreatePickReceiptForProductionReceipt Interface
CompuTec.ProcessForce.API.Actions.CreatePickReceiptForProductionReceipt Namespace


ICreatePickReceiptForProductionReceipt.AddManufacturingOrderDocEntry Method

Adds Manufacturing Order Doc Entry

Namespace: CompuTec.ProcessForce.API.Actions.CreatePickReceiptForProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub AddManufacturingOrderDocEntry( _
   ByVal DocEntry As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void AddManufacturingOrderDocEntry(
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void AddManufacturingOrderDocEntry(
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function AddManufacturingOrderDocEntry(
    DocEntry : int
);
This language is not supported or no code example is available.

Parameters

DocEntry

Type: int

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreatePickReceiptForProductionReceipt Interface
ICreatePickReceiptForProductionReceipt Members
CompuTec.ProcessForce.API.Actions.CreatePickReceiptForProductionReceipt Namespace


ICreatePickReceiptForProductionReceipt.DoAction Method

ICreatePickReceiptForProductionReceipt Interface See Also

This Extends starndard Do Action By Allowing to determine what items will apeare on Pick List

Overload List
Name | Description
DoAction(out object) | Excecutes an action (inherited from IPFAction).
DoAction(Dictionary<Int32List<Int32>>, Dictionary<Int32List<Int32>>, bool) | This Extends starndard Do Action By Allowing to determine what items will apeare on Pick List
See Also

Reference

ICreatePickReceiptForProductionReceipt Interface
ICreatePickReceiptForProductionReceipt Members
CompuTec.ProcessForce.API.Actions.CreatePickReceiptForProductionReceipt Namespace


PickOrderdReceiptType Enumeration

Namespace: CompuTec.ProcessForce.API.Actions.CreatePickReceiptForProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
FinalGood |
Scraps |
Coproducts |
All |
See Also

Reference

CompuTec.ProcessForce.API.Actions.CreatePickReceiptForProductionReceipt Namespace


CompuTec.ProcessForce.API.Actions.CreateSubContractingProcurmentDocuments Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ICreateSubContractingProcurmentDocuments |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ICreateSubContractingProcurmentDocuments Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Actions.CreateSubContractingProcurmentDocuments
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ICreateSubContractingProcurmentDocuments
    Inherits IPFAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICreateSubContractingProcurmentDocuments : IPFAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ICreateSubContractingProcurmentDocuments : public IPFAction^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICreateSubContractingProcurmentDocuments
   implements IPFAction
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateSubContractingProcurmentDocuments Members
CompuTec.ProcessForce.API.Actions.CreateSubContractingProcurmentDocuments Namespace


ICreateSubContractingProcurmentDocuments Members

ICreateSubContractingProcurmentDocuments Interface Methods Properties See Also

The following tables list the members exposed by the ICreateSubContractingProcurmentDocuments type.

Properties
 | Name | Description
Public property | ManufacturingDocEntry |
Top
Methods
 | Name | Description
Public method | DoAction | Excecutes an action (inherited from IPFAction).
Public method | GetCreatedDocumentReferences | This method returns Created Document References while do action (inherited from IPFAction).
Top
See Also

Reference

ICreateSubContractingProcurmentDocuments Interface
CompuTec.ProcessForce.API.Actions.CreateSubContractingProcurmentDocuments Namespace


ICreateSubContractingProcurmentDocuments Properties

ICreateSubContractingProcurmentDocuments Interface See Also

The following tables list the members exposed by the ICreateSubContractingProcurmentDocuments type.

Properties
 | Name | Description
Public property | ManufacturingDocEntry |
Top
See Also

Reference

ICreateSubContractingProcurmentDocuments Interface
CompuTec.ProcessForce.API.Actions.CreateSubContractingProcurmentDocuments Namespace


ICreateSubContractingProcurmentDocuments.ManufacturingDocEntry Property

Namespace: CompuTec.ProcessForce.API.Actions.CreateSubContractingProcurmentDocuments
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ManufacturingDocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int ManufacturingDocEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int ManufacturingDocEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ManufacturingDocEntry() : int;
function set ManufacturingDocEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateSubContractingProcurmentDocuments Interface
ICreateSubContractingProcurmentDocuments Members
CompuTec.ProcessForce.API.Actions.CreateSubContractingProcurmentDocuments Namespace


ICreateSubContractingProcurmentDocuments Methods

ICreateSubContractingProcurmentDocuments Interface See Also

The following tables list the members exposed by the ICreateSubContractingProcurmentDocuments type.

Methods
 | Name | Description
Public method | DoAction | Excecutes an action (inherited from IPFAction).
Public method | GetCreatedDocumentReferences | This method returns Created Document References while do action (inherited from IPFAction).
Top
See Also

Reference

ICreateSubContractingProcurmentDocuments Interface
CompuTec.ProcessForce.API.Actions.CreateSubContractingProcurmentDocuments Namespace


CompuTec.ProcessForce.API.Actions.Exceptions Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | LineReferencesCannotBeEmptyException |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


LineReferencesCannotBeEmptyException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Actions.Exceptions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class LineReferencesCannotBeEmptyException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class LineReferencesCannotBeEmptyException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class LineReferencesCannotBeEmptyException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class LineReferencesCannotBeEmptyException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Actions.Exceptions.LineReferencesCannotBeEmptyException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LineReferencesCannotBeEmptyException Members
CompuTec.ProcessForce.API.Actions.Exceptions Namespace


LineReferencesCannotBeEmptyException Members

LineReferencesCannotBeEmptyException Class Constructors Methods Properties See Also

The following tables list the members exposed by the LineReferencesCannotBeEmptyException type.

Constructors
 | Name | Description
Public constructor | LineReferencesCannotBeEmptyException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

LineReferencesCannotBeEmptyException Class
CompuTec.ProcessForce.API.Actions.Exceptions Namespace


LineReferencesCannotBeEmptyException Constructor

LineReferencesCannotBeEmptyException Class See Also

Overload List
Name | Description
LineReferencesCannotBeEmptyException() |
LineReferencesCannotBeEmptyException(string) |
LineReferencesCannotBeEmptyException(string, Exception) |
See Also

Reference

LineReferencesCannotBeEmptyException Class
LineReferencesCannotBeEmptyException Members
CompuTec.ProcessForce.API.Actions.Exceptions Namespace


LineReferencesCannotBeEmptyException Properties

LineReferencesCannotBeEmptyException Class See Also

The following tables list the members exposed by the LineReferencesCannotBeEmptyException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

LineReferencesCannotBeEmptyException Class
CompuTec.ProcessForce.API.Actions.Exceptions Namespace


LineReferencesCannotBeEmptyException Methods

LineReferencesCannotBeEmptyException Class See Also

The following tables list the members exposed by the LineReferencesCannotBeEmptyException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

LineReferencesCannotBeEmptyException Class
CompuTec.ProcessForce.API.Actions.Exceptions Namespace


CompuTec.ProcessForce.API.Assigners.Base Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | DocumentNotFoundException |
Public class | OperationFailedException |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


DocumentNotFoundException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Assigners.Base
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class DocumentNotFoundException
    Inherits ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DocumentNotFoundException : ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class DocumentNotFoundException : public ApplicationException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DocumentNotFoundException
   extends ApplicationException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
CompuTec.ProcessForce.API.Assigners.Base.DocumentNotFoundException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentNotFoundException Members
CompuTec.ProcessForce.API.Assigners.Base Namespace


DocumentNotFoundException Members

DocumentNotFoundException Class Constructors Methods Properties See Also

The following tables list the members exposed by the DocumentNotFoundException type.

Constructors
 | Name | Description
Public constructor | DocumentNotFoundException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

DocumentNotFoundException Class
CompuTec.ProcessForce.API.Assigners.Base Namespace


DocumentNotFoundException Constructor

DocumentNotFoundException Class See Also

Overload List
Name | Description
DocumentNotFoundException(string) |
DocumentNotFoundException(string, Exception) |
See Also

Reference

DocumentNotFoundException Class
DocumentNotFoundException Members
CompuTec.ProcessForce.API.Assigners.Base Namespace


DocumentNotFoundException Properties

DocumentNotFoundException Class See Also

The following tables list the members exposed by the DocumentNotFoundException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

DocumentNotFoundException Class
CompuTec.ProcessForce.API.Assigners.Base Namespace


DocumentNotFoundException Methods

DocumentNotFoundException Class See Also

The following tables list the members exposed by the DocumentNotFoundException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

DocumentNotFoundException Class
CompuTec.ProcessForce.API.Assigners.Base Namespace


OperationFailedException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Assigners.Base
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class OperationFailedException
    Inherits ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class OperationFailedException : ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class OperationFailedException : public ApplicationException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class OperationFailedException
   extends ApplicationException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
CompuTec.ProcessForce.API.Assigners.Base.OperationFailedException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OperationFailedException Members
CompuTec.ProcessForce.API.Assigners.Base Namespace


OperationFailedException Members

OperationFailedException Class Constructors Methods Properties See Also

The following tables list the members exposed by the OperationFailedException type.

Constructors
 | Name | Description
Public constructor | OperationFailedException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

OperationFailedException Class
CompuTec.ProcessForce.API.Assigners.Base Namespace


OperationFailedException Constructor

OperationFailedException Class See Also

Overload List
Name | Description
OperationFailedException(string) |
OperationFailedException(string, Exception) |
See Also

Reference

OperationFailedException Class
OperationFailedException Members
CompuTec.ProcessForce.API.Assigners.Base Namespace


OperationFailedException Properties

OperationFailedException Class See Also

The following tables list the members exposed by the OperationFailedException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

OperationFailedException Class
CompuTec.ProcessForce.API.Assigners.Base Namespace


OperationFailedException Methods

OperationFailedException Class See Also

The following tables list the members exposed by the OperationFailedException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

OperationFailedException Class
CompuTec.ProcessForce.API.Assigners.Base Namespace


CompuTec.ProcessForce.API.Assigners.PickAssigner Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | PickAssignerException |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


PickAssignerException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Assigners.PickAssigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class PickAssignerException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class PickAssignerException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class PickAssignerException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class PickAssignerException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Assigners.PickAssigner.PickAssignerException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAssignerException Members
CompuTec.ProcessForce.API.Assigners.PickAssigner Namespace


PickAssignerException Members

PickAssignerException Class Constructors Methods Properties See Also

The following tables list the members exposed by the PickAssignerException type.

Constructors
 | Name | Description
Public constructor | PickAssignerException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

PickAssignerException Class
CompuTec.ProcessForce.API.Assigners.PickAssigner Namespace


PickAssignerException Constructor

PickAssignerException Class See Also

Overload List
Name | Description
PickAssignerException() |
PickAssignerException(string) |
PickAssignerException(string, Exception) |
See Also

Reference

PickAssignerException Class
PickAssignerException Members
CompuTec.ProcessForce.API.Assigners.PickAssigner Namespace


PickAssignerException Properties

PickAssignerException Class See Also

The following tables list the members exposed by the PickAssignerException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

PickAssignerException Class
CompuTec.ProcessForce.API.Assigners.PickAssigner Namespace


PickAssignerException Methods

PickAssignerException Class See Also

The following tables list the members exposed by the PickAssignerException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

PickAssignerException Class
CompuTec.ProcessForce.API.Assigners.PickAssigner Namespace


CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IBaseOperationRelation |
Public interface | IRoutingOperationRelationsHelper |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IBaseOperationRelation Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Common.RoutingOperationRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IBaseOperationRelation
    Inherits IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IBaseOperationRelation : IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IBaseOperationRelation : public IUDOChildBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IBaseOperationRelation
   implements IUDOChildBean
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBaseOperationRelation Members
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IBaseOperationRelation Members

IBaseOperationRelation Interface Methods Properties See Also

The following tables list the members exposed by the IBaseOperationRelation type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_HasRelations |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OprCode |
Public property | U_OprOverlayCode | Operation Overlay Code
Public property | U_OprOverlayId | Operation Overlay ID
Public property | U_OprOverlayQty | Operation Overlay Quantity
Public property | U_OprSequence | Operation Sequence
Public property | U_RelationType | Specifies Relation Type
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

IBaseOperationRelation Interface
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IBaseOperationRelation Properties

IBaseOperationRelation Interface See Also

The following tables list the members exposed by the IBaseOperationRelation type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_HasRelations |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OprCode |
Public property | U_OprOverlayCode | Operation Overlay Code
Public property | U_OprOverlayId | Operation Overlay ID
Public property | U_OprOverlayQty | Operation Overlay Quantity
Public property | U_OprSequence | Operation Sequence
Public property | U_RelationType | Specifies Relation Type
Top
See Also

Reference

IBaseOperationRelation Interface
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IUDOChildBean.Count Property

Number of Childs

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Count() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int Count {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int Count {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Count() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOChildBean Interface
IUDOChildBean Members
CompuTec.ProcessForce.API.Core Namespace


IUDOChildBean.CurrentChild Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CurrentChild() As IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
IUDOChildBean CurrentChild {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property IUDOChildBean^ CurrentChild {
 IUDOChildBean^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CurrentChild() : IUDOChildBean;
This language is not supported or no code example is available.

Property Value

Type: IUDOChildBean
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOChildBean Interface
IUDOChildBean Members
CompuTec.ProcessForce.API.Core Namespace


IUDOChildBean.UDFItems Property

UDF Items for current object

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UDFItems() As IUDFItems
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
IUDFItems UDFItems {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property IUDFItems^ UDFItems {
 IUDFItems^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UDFItems() : IUDFItems;
This language is not supported or no code example is available.

Property Value

Type: IUDFItems
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOChildBean Interface
IUDOChildBean Members
CompuTec.ProcessForce.API.Core Namespace


IBaseOperationRelation.U_HasRelations Property

Namespace: CompuTec.ProcessForce.API.Common.RoutingOperationRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_HasRelations() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_HasRelations {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_HasRelations {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_HasRelations() : YesNoType;
function set U_HasRelations(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBaseOperationRelation Interface
IBaseOperationRelation Members
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IUDOChildBean.U_LineNum Property

Gets ProcessForce Line Num

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property U_LineNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
int U_LineNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property int U_LineNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get U_LineNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOChildBean Interface
IUDOChildBean Members
CompuTec.ProcessForce.API.Core Namespace


IBaseOperationRelation.U_OprCode Property

Namespace: CompuTec.ProcessForce.API.Common.RoutingOperationRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprCode() : String;
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBaseOperationRelation Interface
IBaseOperationRelation Members
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IBaseOperationRelation.U_OprOverlayCode Property

Operation Overlay Code

Namespace: CompuTec.ProcessForce.API.Common.RoutingOperationRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprOverlayCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprOverlayCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprOverlayCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprOverlayCode() : String;
function set U_OprOverlayCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBaseOperationRelation Interface
IBaseOperationRelation Members
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IBaseOperationRelation.U_OprOverlayId Property

Operation Overlay ID

Namespace: CompuTec.ProcessForce.API.Common.RoutingOperationRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprOverlayId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_OprOverlayId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_OprOverlayId {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprOverlayId() : int;
function set U_OprOverlayId(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBaseOperationRelation Interface
IBaseOperationRelation Members
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IBaseOperationRelation.U_OprOverlayQty Property

Operation Overlay Quantity

Namespace: CompuTec.ProcessForce.API.Common.RoutingOperationRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprOverlayQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_OprOverlayQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_OprOverlayQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprOverlayQty() : double;
function set U_OprOverlayQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBaseOperationRelation Interface
IBaseOperationRelation Members
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IBaseOperationRelation.U_OprSequence Property

Operation Sequence

Namespace: CompuTec.ProcessForce.API.Common.RoutingOperationRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprSequence() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_OprSequence {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_OprSequence {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprSequence() : int;
function set U_OprSequence(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBaseOperationRelation Interface
IBaseOperationRelation Members
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IBaseOperationRelation.U_RelationType Property

Specifies Relation Type

Namespace: CompuTec.ProcessForce.API.Common.RoutingOperationRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RelationType() As OperationRelationType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
OperationRelationType U_RelationType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property OperationRelationType U_RelationType {
 OperationRelationType get( );
 void set(
   OperationRelationType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RelationType() : OperationRelationType;
function set U_RelationType(value : OperationRelationType);
This language is not supported or no code example is available.

Property Value

Type: OperationRelationType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBaseOperationRelation Interface
IBaseOperationRelation Members
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IBaseOperationRelation Methods

IBaseOperationRelation Interface See Also

The following tables list the members exposed by the IBaseOperationRelation type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

IBaseOperationRelation Interface
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IUDOChildBean.Add Method

Adds Row ot the end

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function Add() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Add()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int Add()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Add() : int;
This language is not supported or no code example is available.

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOChildBean Interface
IUDOChildBean Members
CompuTec.ProcessForce.API.Core Namespace


IUDOChildBean.AddRowAtPos Method

Adds Row At specific position

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function AddRowAtPos( _
   ByVal pos As Integer _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int AddRowAtPos(
   int pos
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int AddRowAtPos(
   int pos
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function AddRowAtPos(
    pos : int
) : int;
This language is not supported or no code example is available.

Parameters

pos

Type: int

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOChildBean Interface
IUDOChildBean Members
CompuTec.ProcessForce.API.Core Namespace


IUDOChildBean.Clear Method

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Clear()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Clear()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Clear()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Clear();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOChildBean Interface
IUDOChildBean Members
CompuTec.ProcessForce.API.Core Namespace


IUDOChildBean.DelRowAtPos Method

Del rows of specific Position

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function DelRowAtPos( _
   ByVal pos As Integer _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DelRowAtPos(
   int pos
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int DelRowAtPos(
   int pos
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function DelRowAtPos(
    pos : int
) : int;
This language is not supported or no code example is available.

Parameters

pos

Type: int

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOChildBean Interface
IUDOChildBean Members
CompuTec.ProcessForce.API.Core Namespace


IUDOChildBean.SetCurrentLine Method

Sets Line on specific Position from o to Count

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub SetCurrentLine( _
   ByVal LineNum As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void SetCurrentLine(
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void SetCurrentLine(
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function SetCurrentLine(
    LineNum : int
);
This language is not supported or no code example is available.

Parameters

LineNum

Type: int

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOChildBean Interface
IUDOChildBean Members
CompuTec.ProcessForce.API.Core Namespace


IRoutingOperationRelationsHelper Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Common.RoutingOperationRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IRoutingOperationRelationsHelper
    Inherits IUDOChildBean, _
             IEnumerable(Of IRoutingOperationRelationsHelper)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IRoutingOperationRelationsHelper : IUDOChildBean,
   IEnumerable<IRoutingOperationRelationsHelper>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IRoutingOperationRelationsHelper : public IUDOChildBean^,
   public IEnumerable<IRoutingOperationRelationsHelper^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationRelationsHelper Members
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IRoutingOperationRelationsHelper Members

IRoutingOperationRelationsHelper Interface Methods Properties See Also

The following tables list the members exposed by the IRoutingOperationRelationsHelper type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | OprCode |
Public property | OprName |
Public property | OprSeq |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_POprLine |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | FillLinesForOperation |
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IRoutingOperationRelationsHelper Interface
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IRoutingOperationRelationsHelper Properties

IRoutingOperationRelationsHelper Interface See Also

The following tables list the members exposed by the IRoutingOperationRelationsHelper type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | OprCode |
Public property | OprName |
Public property | OprSeq |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_POprLine |
Top
See Also

Reference

IRoutingOperationRelationsHelper Interface
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IRoutingOperationRelationsHelper.OprCode Property

Namespace: CompuTec.ProcessForce.API.Common.RoutingOperationRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string OprCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ OprCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OprCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationRelationsHelper Interface
IRoutingOperationRelationsHelper Members
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IRoutingOperationRelationsHelper.OprName Property

Namespace: CompuTec.ProcessForce.API.Common.RoutingOperationRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property OprName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string OprName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ OprName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OprName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationRelationsHelper Interface
IRoutingOperationRelationsHelper Members
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IRoutingOperationRelationsHelper.OprSeq Property

Namespace: CompuTec.ProcessForce.API.Common.RoutingOperationRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property OprSeq() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int OprSeq {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int OprSeq {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OprSeq() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationRelationsHelper Interface
IRoutingOperationRelationsHelper Members
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IRoutingOperationRelationsHelper.U_BaseLine Property

Namespace: CompuTec.ProcessForce.API.Common.RoutingOperationRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLine() : int;
function set U_BaseLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationRelationsHelper Interface
IRoutingOperationRelationsHelper Members
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IRoutingOperationRelationsHelper.U_POprLine Property

Namespace: CompuTec.ProcessForce.API.Common.RoutingOperationRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_POprLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_POprLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_POprLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_POprLine() : int;
function set U_POprLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationRelationsHelper Interface
IRoutingOperationRelationsHelper Members
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IRoutingOperationRelationsHelper Methods

IRoutingOperationRelationsHelper Interface See Also

The following tables list the members exposed by the IRoutingOperationRelationsHelper type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | FillLinesForOperation |
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IRoutingOperationRelationsHelper Interface
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


IRoutingOperationRelationsHelper.FillLinesForOperation Method

Namespace: CompuTec.ProcessForce.API.Common.RoutingOperationRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub FillLinesForOperation( _
   ByVal U_BaseLine As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void FillLinesForOperation(
   int U_BaseLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void FillLinesForOperation(
   int U_BaseLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function FillLinesForOperation(
    U_BaseLine : int
);
This language is not supported or no code example is available.

Parameters

U_BaseLine

Type: int

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationRelationsHelper Interface
IRoutingOperationRelationsHelper Members
CompuTec.ProcessForce.API.Common.RoutingOperationRelations Namespace


CompuTec.ProcessForce.API.Core.Factory Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | UdoFactoryClass | This Class Create an Empty UDo Object With Binded generalService To it After you create your UdoObject You have to add new type in ObjectType enum and create a CreateImplementation
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


UdoFactoryClass Class

Members See Also

This Class Create an Empty UDo Object With Binded generalService To it After you create your UdoObject You have to add new type in ObjectType enum and create a CreateImplementation

Namespace: CompuTec.ProcessForce.API.Core.Factory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class UdoFactoryClass
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class UdoFactoryClass
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class UdoFactoryClass
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class UdoFactoryClass
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Core.Factory.UdoFactoryClass
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UdoFactoryClass Members
CompuTec.ProcessForce.API.Core.Factory Namespace


UdoFactoryClass Members

UdoFactoryClass Class Methods See Also

This Class Create an Empty UDo Object With Binded generalService To it After you create your UdoObject You have to add new type in ObjectType enum and create a CreateImplementation

The following tables list the members exposed by the UdoFactoryClass type.

Methods
 | Name | Description
 | CreateAction | This methood creates Actions
 | CreateDocument | This Methood creates ProcessForce Documents
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

UdoFactoryClass Class
CompuTec.ProcessForce.API.Core.Factory Namespace


UdoFactoryClass Methods

UdoFactoryClass Class See Also

The following tables list the members exposed by the UdoFactoryClass type.

Methods
 | Name | Description
 | CreateAction | This methood creates Actions
 | CreateDocument | This Methood creates ProcessForce Documents
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

UdoFactoryClass Class
CompuTec.ProcessForce.API.Core.Factory Namespace


UdoFactoryClass.CreateAction Method

This methood creates Actions

Namespace: CompuTec.ProcessForce.API.Core.Factory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function CreateAction( _
   ByVal token As String, _
   ByVal type As ActionType _
) As Object
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static object CreateAction(
   string token,
   ActionType type
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static object^ CreateAction(
   String^ token,
   ActionType type
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function CreateAction(
    token : String,
    type : ActionType
) : object;
This language is not supported or no code example is available.

Parameters

token

Type: string

type

Type: ActionType

Return Value

Type: object
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UdoFactoryClass Class
UdoFactoryClass Members
CompuTec.ProcessForce.API.Core.Factory Namespace


UdoFactoryClass.CreateDocument Method

This Methood creates ProcessForce Documents

Namespace: CompuTec.ProcessForce.API.Core.Factory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function CreateDocument( _
   ByVal token As String, _
   ByVal type As ObjectTypes _
) As Object
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static object CreateDocument(
   string token,
   ObjectTypes type
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static object^ CreateDocument(
   String^ token,
   ObjectTypes type
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function CreateDocument(
    token : String,
    type : ObjectTypes
) : object;
This language is not supported or no code example is available.

Parameters

token

Type: string

type

Type: ObjectTypes

Return Value

Type: object
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UdoFactoryClass Class
UdoFactoryClass Members
CompuTec.ProcessForce.API.Core.Factory Namespace


CompuTec.ProcessForce.API.Core.Structures Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | BasicValueValidatorException |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


BasicValueValidatorException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Core.Structures
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class BasicValueValidatorException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class BasicValueValidatorException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class BasicValueValidatorException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class BasicValueValidatorException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Core.Structures.BasicValueValidatorException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BasicValueValidatorException Members
CompuTec.ProcessForce.API.Core.Structures Namespace


BasicValueValidatorException Members

BasicValueValidatorException Class Constructors Methods Properties See Also

The following tables list the members exposed by the BasicValueValidatorException type.

Constructors
 | Name | Description
Public constructor | BasicValueValidatorException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BasicValueValidatorException Class
CompuTec.ProcessForce.API.Core.Structures Namespace


BasicValueValidatorException Constructor

BasicValueValidatorException Class See Also

Overload List
Name | Description
BasicValueValidatorException() |
BasicValueValidatorException(string) |
BasicValueValidatorException(string, Exception) |
See Also

Reference

BasicValueValidatorException Class
BasicValueValidatorException Members
CompuTec.ProcessForce.API.Core.Structures Namespace


BasicValueValidatorException Properties

BasicValueValidatorException Class See Also

The following tables list the members exposed by the BasicValueValidatorException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

BasicValueValidatorException Class
CompuTec.ProcessForce.API.Core.Structures Namespace


BasicValueValidatorException Methods

BasicValueValidatorException Class See Also

The following tables list the members exposed by the BasicValueValidatorException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BasicValueValidatorException Class
CompuTec.ProcessForce.API.Core.Structures Namespace


CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | All |
Public class | ComplexType |
Public class | Element | AutoGenerated XML structure for SAP UDO Object
Public class | Schema |
Public class | Sequence |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


All Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<XmlRoot(ElementName = "all", Namespace = "http://www.w3.org/2001/XMLSchema")> _
Public Class All
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlRoot(ElementName = "all", Namespace = "http://www.w3.org/2001/XMLSchema")]
public class All
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlRoot(ElementName = "all", Namespace = "http://www.w3.org/2001/XMLSchema")]
public ref class All
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   XmlRoot(ElementName = "all", Namespace = "http://www.w3.org/2001/XMLSchema")
class All
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure.All
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

All Members
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


All Members

All Class Methods Properties See Also

The following tables list the members exposed by the All type.

Properties
 | Name | Description
Public property | Element |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

All Class
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


All Properties

All Class See Also

The following tables list the members exposed by the All type.

Properties
 | Name | Description
Public property | Element |
Top
See Also

Reference

All Class
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


All.Element Property

Namespace: CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<XmlElement(ElementName = "element", Namespace = "http://www.w3.org/2001/XMLSchema")> _
Public Property Element() As List(Of Element)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlElement(ElementName = "element", Namespace = "http://www.w3.org/2001/XMLSchema")]
public List<Element> Element {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlElement(ElementName = "element", Namespace = "http://www.w3.org/2001/XMLSchema")]
public:
property List<Element^>^ Element {
 List<Element^>^ get( );
 void set(
   List<Element^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<Element>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

All Class
All Members
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


All Methods

All Class See Also

The following tables list the members exposed by the All type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

All Class
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


ComplexType Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<XmlRoot(ElementName = "complexType", Namespace = "http://www.w3.org/2001/XMLSchema")> _
Public Class ComplexType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlRoot(ElementName = "complexType", Namespace = "http://www.w3.org/2001/XMLSchema")]
public class ComplexType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlRoot(ElementName = "complexType", Namespace = "http://www.w3.org/2001/XMLSchema")]
public ref class ComplexType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   XmlRoot(ElementName = "complexType", Namespace = "http://www.w3.org/2001/XMLSchema")
class ComplexType
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure.ComplexType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ComplexType Members
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


ComplexType Members

ComplexType Class Methods Properties See Also

The following tables list the members exposed by the ComplexType type.

Properties
 | Name | Description
Public property | All |
Public property | Sequence |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ComplexType Class
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


ComplexType Properties

ComplexType Class See Also

The following tables list the members exposed by the ComplexType type.

Properties
 | Name | Description
Public property | All |
Public property | Sequence |
Top
See Also

Reference

ComplexType Class
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


ComplexType.All Property

Namespace: CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<XmlElement(ElementName = "all", Namespace = "http://www.w3.org/2001/XMLSchema")> _
Public Property All() As All
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlElement(ElementName = "all", Namespace = "http://www.w3.org/2001/XMLSchema")]
public All All {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlElement(ElementName = "all", Namespace = "http://www.w3.org/2001/XMLSchema")]
public:
property All^ All {
 All^ get( );
 void set(
   All^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   XmlElement(ElementName = "all", Namespace = "http://www.w3.org/2001/XMLSchema")
function get All() : All;
public
   XmlElement(ElementName = "all", Namespace = "http://www.w3.org/2001/XMLSchema")
function set All(value : All);
This language is not supported or no code example is available.

Property Value

Type: All
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ComplexType Class
ComplexType Members
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


ComplexType.Sequence Property

Namespace: CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<XmlElement(ElementName = "sequence", Namespace = "http://www.w3.org/2001/XMLSchema")> _
Public Property Sequence() As Sequence
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlElement(ElementName = "sequence", Namespace = "http://www.w3.org/2001/XMLSchema")]
public Sequence Sequence {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlElement(ElementName = "sequence", Namespace = "http://www.w3.org/2001/XMLSchema")]
public:
property Sequence^ Sequence {
 Sequence^ get( );
 void set(
   Sequence^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   XmlElement(ElementName = "sequence", Namespace = "http://www.w3.org/2001/XMLSchema")
function get Sequence() : Sequence;
public
   XmlElement(ElementName = "sequence", Namespace = "http://www.w3.org/2001/XMLSchema")
function set Sequence(value : Sequence);
This language is not supported or no code example is available.

Property Value

Type: Sequence
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ComplexType Class
ComplexType Members
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


ComplexType Methods

ComplexType Class See Also

The following tables list the members exposed by the ComplexType type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ComplexType Class
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Element Class

Members See Also

AutoGenerated XML structure for SAP UDO Object

Namespace: CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<XmlRoot(ElementName = "element", Namespace = "http://www.w3.org/2001/XMLSchema")> _
Public Class Element
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlRoot(ElementName = "element", Namespace = "http://www.w3.org/2001/XMLSchema")]
public class Element
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlRoot(ElementName = "element", Namespace = "http://www.w3.org/2001/XMLSchema")]
public ref class Element
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   XmlRoot(ElementName = "element", Namespace = "http://www.w3.org/2001/XMLSchema")
class Element
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure.Element
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Element Members
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Element Members

Element Class Methods Properties See Also

AutoGenerated XML structure for SAP UDO Object

The following tables list the members exposed by the Element type.

Properties
 | Name | Description
Public property | ComplexType |
Public property | MinOccurs |
Public property | Name |
Public property | Type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Element Class
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Element Properties

Element Class See Also

The following tables list the members exposed by the Element type.

Properties
 | Name | Description
Public property | ComplexType |
Public property | MinOccurs |
Public property | Name |
Public property | Type |
Top
See Also

Reference

Element Class
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Element.ComplexType Property

Namespace: CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<XmlElement(ElementName = "complexType", Namespace = "http://www.w3.org/2001/XMLSchema")> _
Public Property ComplexType() As ComplexType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlElement(ElementName = "complexType", Namespace = "http://www.w3.org/2001/XMLSchema")]
public ComplexType ComplexType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlElement(ElementName = "complexType", Namespace = "http://www.w3.org/2001/XMLSchema")]
public:
property ComplexType^ ComplexType {
 ComplexType^ get( );
 void set(
   ComplexType^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   XmlElement(ElementName = "complexType", Namespace = "http://www.w3.org/2001/XMLSchema")
function get ComplexType() : ComplexType;
public
   XmlElement(ElementName = "complexType", Namespace = "http://www.w3.org/2001/XMLSchema")
function set ComplexType(value : ComplexType);
This language is not supported or no code example is available.

Property Value

Type: ComplexType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Element Class
Element Members
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Element.MinOccurs Property

Namespace: CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Xml(AttributeName = "minOccurs")> _
Public Property MinOccurs() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Xml(AttributeName = "minOccurs")]
public string MinOccurs {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Xml(AttributeName = "minOccurs")]
public:
property String^ MinOccurs {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Xml(AttributeName = "minOccurs")
function get MinOccurs() : String;
public
   Xml(AttributeName = "minOccurs")
function set MinOccurs(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Element Class
Element Members
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Element.Name Property

Namespace: CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Xml(AttributeName = "name")> _
Public Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Xml(AttributeName = "name")]
public string Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Xml(AttributeName = "name")]
public:
property String^ Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Xml(AttributeName = "name")
function get Name() : String;
public
   Xml(AttributeName = "name")
function set Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Element Class
Element Members
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Element.Type Property

Namespace: CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Xml(AttributeName = "type")> _
Public Property Type() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Xml(AttributeName = "type")]
public string Type {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Xml(AttributeName = "type")]
public:
property String^ Type {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Xml(AttributeName = "type")
function get Type() : String;
public
   Xml(AttributeName = "type")
function set Type(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Element Class
Element Members
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Element Methods

Element Class See Also

The following tables list the members exposed by the Element type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Element Class
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Schema Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
<XmlRoot(ElementName = "schema", Namespace = "http://www.w3.org/2001/XMLSchema")> _
Public Class Schema
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
[XmlRoot(ElementName = "schema", Namespace = "http://www.w3.org/2001/XMLSchema")]
public class Schema
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
[XmlRoot(ElementName = "schema", Namespace = "http://www.w3.org/2001/XMLSchema")]
public ref class Schema
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
   XmlRoot(ElementName = "schema", Namespace = "http://www.w3.org/2001/XMLSchema")
class Schema
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure.Schema
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Schema Members
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Schema Members

Schema Class Methods Properties See Also

The following tables list the members exposed by the Schema type.

Properties
 | Name | Description
Public property | Element |
Public property | ElementFormDefault |
Public property | Xmlns |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Schema Class
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Schema Properties

Schema Class See Also

The following tables list the members exposed by the Schema type.

Properties
 | Name | Description
Public property | Element |
Public property | ElementFormDefault |
Public property | Xmlns |
Top
See Also

Reference

Schema Class
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Schema.Element Property

Namespace: CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<XmlElement(ElementName = "element", Namespace = "http://www.w3.org/2001/XMLSchema")> _
Public Property Element() As Element
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlElement(ElementName = "element", Namespace = "http://www.w3.org/2001/XMLSchema")]
public Element Element {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlElement(ElementName = "element", Namespace = "http://www.w3.org/2001/XMLSchema")]
public:
property Element^ Element {
 Element^ get( );
 void set(
   Element^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   XmlElement(ElementName = "element", Namespace = "http://www.w3.org/2001/XMLSchema")
function get Element() : Element;
public
   XmlElement(ElementName = "element", Namespace = "http://www.w3.org/2001/XMLSchema")
function set Element(value : Element);
This language is not supported or no code example is available.

Property Value

Type: Element
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Schema Class
Schema Members
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Schema.ElementFormDefault Property

Namespace: CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Xml(AttributeName = "elementFormDefault")> _
Public Property ElementFormDefault() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Xml(AttributeName = "elementFormDefault")]
public string ElementFormDefault {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Xml(AttributeName = "elementFormDefault")]
public:
property String^ ElementFormDefault {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Xml(AttributeName = "elementFormDefault")
function get ElementFormDefault() : String;
public
   Xml(AttributeName = "elementFormDefault")
function set ElementFormDefault(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Schema Class
Schema Members
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Schema.Xmlns Property

Namespace: CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Xml(AttributeName = "xmlns")> _
Public Property Xmlns() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Xml(AttributeName = "xmlns")]
public string Xmlns {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Xml(AttributeName = "xmlns")]
public:
property String^ Xmlns {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Xml(AttributeName = "xmlns")
function get Xmlns() : String;
public
   Xml(AttributeName = "xmlns")
function set Xmlns(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Schema Class
Schema Members
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Schema Methods

Schema Class See Also

The following tables list the members exposed by the Schema type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Schema Class
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Sequence Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<XmlRoot(ElementName = "sequence", Namespace = "http://www.w3.org/2001/XMLSchema")> _
Public Class Sequence
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlRoot(ElementName = "sequence", Namespace = "http://www.w3.org/2001/XMLSchema")]
public class Sequence
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlRoot(ElementName = "sequence", Namespace = "http://www.w3.org/2001/XMLSchema")]
public ref class Sequence
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   XmlRoot(ElementName = "sequence", Namespace = "http://www.w3.org/2001/XMLSchema")
class Sequence
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure.Sequence
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Sequence Members
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Sequence Members

Sequence Class Methods Properties See Also

The following tables list the members exposed by the Sequence type.

Properties
 | Name | Description
Public property | Element |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Sequence Class
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Sequence Properties

Sequence Class See Also

The following tables list the members exposed by the Sequence type.

Properties
 | Name | Description
Public property | Element |
Top
See Also

Reference

Sequence Class
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Sequence.Element Property

Namespace: CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<XmlElement(ElementName = "element", Namespace = "http://www.w3.org/2001/XMLSchema")> _
Public Property Element() As Element
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlElement(ElementName = "element", Namespace = "http://www.w3.org/2001/XMLSchema")]
public Element Element {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlElement(ElementName = "element", Namespace = "http://www.w3.org/2001/XMLSchema")]
public:
property Element^ Element {
 Element^ get( );
 void set(
   Element^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   XmlElement(ElementName = "element", Namespace = "http://www.w3.org/2001/XMLSchema")
function get Element() : Element;
public
   XmlElement(ElementName = "element", Namespace = "http://www.w3.org/2001/XMLSchema")
function set Element(value : Element);
This language is not supported or no code example is available.

Property Value

Type: Element
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Sequence Class
Sequence Members
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


Sequence Methods

Sequence Class See Also

The following tables list the members exposed by the Sequence type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Sequence Class
CompuTec.ProcessForce.API.Core.Temporary.UDOXmlStructure Namespace


CompuTec.ProcessForce.API.Costing.Data Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | Revision | Represents the revision of an item.
Public class | RollOverItem | Represents a roll-over structure of an item.
Public class | RollingUpBillOfMaterials | Represents the data of a rolling-up bill of materials.
Top
Enumerations
 | Name | Description
Public enumeration | ValuationMethod | Contains a set of available valuation methods.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


Revision Class

Members See Also

Represents the revision of an item.

Namespace: CompuTec.ProcessForce.API.Costing.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class Revision
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Revision
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class Revision
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Revision
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Costing.Data.Revision
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Revision Members
CompuTec.ProcessForce.API.Costing.Data Namespace


Revision Members

Revision Class Constructors Methods Properties See Also

Represents the revision of an item.

The following tables list the members exposed by the Revision type.

Constructors
 | Name | Description
Public constructor | Revision | (Overloaded) Initializes a new instance of the Revision class.
Top
Properties
 | Name | Description
Public property | Code | Gets or sets revision code.
Public property | IsDefault | Determines whether the revision is a default revision for a roll-over process.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Revision Class
CompuTec.ProcessForce.API.Costing.Data Namespace


Revision Constructor

Revision Class See Also

Initializes a new instance of the Revision class.

Overload List
Name | Description
Revision() | Initializes a new instance of the Revision class.
Revision(string, bool) | Initializes a new instance of the Revision class.
See Also

Reference

Revision Class
Revision Members
CompuTec.ProcessForce.API.Costing.Data Namespace


Revision Properties

Revision Class See Also

The following tables list the members exposed by the Revision type.

Properties
 | Name | Description
Public property | Code | Gets or sets revision code.
Public property | IsDefault | Determines whether the revision is a default revision for a roll-over process.
Top
See Also

Reference

Revision Class
CompuTec.ProcessForce.API.Costing.Data Namespace


Revision.Code Property

Gets or sets revision code.

Namespace: CompuTec.ProcessForce.API.Costing.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Code() : String;
public function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Revision Class
Revision Members
CompuTec.ProcessForce.API.Costing.Data Namespace


Revision.IsDefault Property

Determines whether the revision is a default revision for a roll-over process.

Namespace: CompuTec.ProcessForce.API.Costing.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property IsDefault() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool IsDefault {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool IsDefault {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get IsDefault() : boolean;
public function set IsDefault(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Revision Class
Revision Members
CompuTec.ProcessForce.API.Costing.Data Namespace


Revision Methods

Revision Class See Also

The following tables list the members exposed by the Revision type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Revision Class
CompuTec.ProcessForce.API.Costing.Data Namespace


RollOverItem Class

Members See Also

Represents a roll-over structure of an item.

Namespace: CompuTec.ProcessForce.API.Costing.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class RollOverItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RollOverItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class RollOverItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RollOverItem
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Costing.Data.RollOverItem
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollOverItem Members
CompuTec.ProcessForce.API.Costing.Data Namespace


RollOverItem Members

RollOverItem Class Constructors Methods Properties See Also

Represents a roll-over structure of an item.

The following tables list the members exposed by the RollOverItem type.

Constructors
 | Name | Description
Public constructor | RollOverItem | (Overloaded) Initializes a new instance of the RollOverItem class.
Top
Properties
 | Name | Description
Public property | ItemCode | Gets or sets the item code.
Public property | Revisions | Gets or sets a collection of revisions.
Public property | ValuationMethod | Gets or sets the valuation method of item.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetRollOverItem |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

RollOverItem Class
CompuTec.ProcessForce.API.Costing.Data Namespace


RollOverItem Constructor

RollOverItem Class See Also

Initializes a new instance of the RollOverItem class.

Overload List
Name | Description
RollOverItem() | Initializes a new instance of the RollOverItem class.
RollOverItem(string, List<Revision>, ValuationMethod) | Initializes a new instance of the RollOverItem class.
See Also

Reference

RollOverItem Class
RollOverItem Members
CompuTec.ProcessForce.API.Costing.Data Namespace


RollOverItem Properties

RollOverItem Class See Also

The following tables list the members exposed by the RollOverItem type.

Properties
 | Name | Description
Public property | ItemCode | Gets or sets the item code.
Public property | Revisions | Gets or sets a collection of revisions.
Public property | ValuationMethod | Gets or sets the valuation method of item.
Top
See Also

Reference

RollOverItem Class
CompuTec.ProcessForce.API.Costing.Data Namespace


RollOverItem.ItemCode Property

Gets or sets the item code.

Namespace: CompuTec.ProcessForce.API.Costing.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ItemCode() : String;
public function set ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollOverItem Class
RollOverItem Members
CompuTec.ProcessForce.API.Costing.Data Namespace


RollOverItem.Revisions Property

Gets or sets a collection of revisions.

Namespace: CompuTec.ProcessForce.API.Costing.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Revisions() As List(Of Revision)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<Revision> Revisions {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<Revision^>^ Revisions {
 List<Revision^>^ get( );
 void set(
   List<Revision^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<Revision>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollOverItem Class
RollOverItem Members
CompuTec.ProcessForce.API.Costing.Data Namespace


RollOverItem.ValuationMethod Property

Gets or sets the valuation method of item.

Namespace: CompuTec.ProcessForce.API.Costing.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ValuationMethod() As ValuationMethod
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ValuationMethod ValuationMethod {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property ValuationMethod ValuationMethod {
 ValuationMethod get( );
 void set(
   ValuationMethod value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ValuationMethod() : ValuationMethod;
public function set ValuationMethod(value : ValuationMethod);
This language is not supported or no code example is available.

Property Value

Type: ValuationMethod
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollOverItem Class
RollOverItem Members
CompuTec.ProcessForce.API.Costing.Data Namespace


RollOverItem Methods

RollOverItem Class See Also

The following tables list the members exposed by the RollOverItem type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetRollOverItem |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

RollOverItem Class
CompuTec.ProcessForce.API.Costing.Data Namespace


RollOverItem.GetRollOverItem Method

Namespace: CompuTec.ProcessForce.API.Costing.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetRollOverItem( _
   ByVal token As String, _
   ByVal ItemCode As String _
) As RollOverItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static RollOverItem GetRollOverItem(
   string token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static RollOverItem^ GetRollOverItem(
   String^ token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetRollOverItem(
    token : String,
    ItemCode : String
) : RollOverItem;
This language is not supported or no code example is available.

Parameters

token

Type: string

ItemCode

Type: string

Return Value

Type: RollOverItem
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollOverItem Class
RollOverItem Members
CompuTec.ProcessForce.API.Costing.Data Namespace


RollingUpBillOfMaterials Class

Members See Also

Represents the data of a rolling-up bill of materials.

Namespace: CompuTec.ProcessForce.API.Costing.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class RollingUpBillOfMaterials
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RollingUpBillOfMaterials
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class RollingUpBillOfMaterials
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RollingUpBillOfMaterials
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Costing.Data.RollingUpBillOfMaterials
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollingUpBillOfMaterials Members
CompuTec.ProcessForce.API.Costing.Data Namespace


RollingUpBillOfMaterials Members

RollingUpBillOfMaterials Class Constructors Methods Properties See Also

Represents the data of a rolling-up bill of materials.

The following tables list the members exposed by the RollingUpBillOfMaterials type.

Constructors
 | Name | Description
Public constructor | RollingUpBillOfMaterials | (Overloaded) Initializes a new instance of RollingUpBillOfMaterials object.
Top
Properties
 | Name | Description
Public property | ItemCode | Gets or sets item code.
Public property | RevisionCode | Gets or sets revision code.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

RollingUpBillOfMaterials Class
CompuTec.ProcessForce.API.Costing.Data Namespace


RollingUpBillOfMaterials Constructor

RollingUpBillOfMaterials Class See Also

Initializes a new instance of RollingUpBillOfMaterials object.

Overload List
Name | Description
RollingUpBillOfMaterials() | Initializes a new instance of RollingUpBillOfMaterials object.
RollingUpBillOfMaterials(string, string) | Initializes a new instance of RollingUpBillOfMaterials object
See Also

Reference

RollingUpBillOfMaterials Class
RollingUpBillOfMaterials Members
CompuTec.ProcessForce.API.Costing.Data Namespace


RollingUpBillOfMaterials Properties

RollingUpBillOfMaterials Class See Also

The following tables list the members exposed by the RollingUpBillOfMaterials type.

Properties
 | Name | Description
Public property | ItemCode | Gets or sets item code.
Public property | RevisionCode | Gets or sets revision code.
Top
See Also

Reference

RollingUpBillOfMaterials Class
CompuTec.ProcessForce.API.Costing.Data Namespace


RollingUpBillOfMaterials.ItemCode Property

Gets or sets item code.

Namespace: CompuTec.ProcessForce.API.Costing.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ItemCode() : String;
public function set ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollingUpBillOfMaterials Class
RollingUpBillOfMaterials Members
CompuTec.ProcessForce.API.Costing.Data Namespace


RollingUpBillOfMaterials.RevisionCode Property

Gets or sets revision code.

Namespace: CompuTec.ProcessForce.API.Costing.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property RevisionCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string RevisionCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ RevisionCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get RevisionCode() : String;
public function set RevisionCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollingUpBillOfMaterials Class
RollingUpBillOfMaterials Members
CompuTec.ProcessForce.API.Costing.Data Namespace


RollingUpBillOfMaterials Methods

RollingUpBillOfMaterials Class See Also

The following tables list the members exposed by the RollingUpBillOfMaterials type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

RollingUpBillOfMaterials Class
CompuTec.ProcessForce.API.Costing.Data Namespace


ValuationMethod Enumeration

Contains a set of available valuation methods.

Namespace: CompuTec.ProcessForce.API.Costing.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Standard | Standard.
MovingAverage | Moving average.
FIFO | FIFO.
BatchSerialNo | Batch / Serial no.
Unknown | Unknown valuation method.
See Also

Reference

CompuTec.ProcessForce.API.Costing.Data Namespace


CompuTec.ProcessForce.API.Costing.Executors Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | CostRollOverExecutor | Executes the cost roll-over process.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


CostRollOverExecutor Class

Members See Also

Executes the cost roll-over process.

Namespace: CompuTec.ProcessForce.API.Costing.Executors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class CostRollOverExecutor
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CostRollOverExecutor
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class CostRollOverExecutor
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CostRollOverExecutor
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Costing.Executors.CostRollOverExecutor
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostRollOverExecutor Members
CompuTec.ProcessForce.API.Costing.Executors Namespace


CostRollOverExecutor Members

CostRollOverExecutor Class Constructors Methods Properties See Also

Executes the cost roll-over process.

The following tables list the members exposed by the CostRollOverExecutor type.

Constructors
 | Name | Description
Public constructor | CostRollOverExecutor | (Overloaded) Initializes a new instance of the CostRollOverExecutor class.
Top
Properties
 | Name | Description
Public property | FromCostCategory | Gets or sets a source cost category.
Public property | Item | Gets or sets an item.
Public property | ToCostCategory | Gets or sets a destination cost category.
Public property | Warehouses | Gets or sets a collection of warehouses.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | Execute | Executes the roll-over process for an item.
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetIsItemCostManagedPerWarehouse | Determines whether item cost is managed per warehouse.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

CostRollOverExecutor Class
CompuTec.ProcessForce.API.Costing.Executors Namespace


CostRollOverExecutor Constructor

CostRollOverExecutor Class See Also

Initializes a new instance of the CostRollOverExecutor class.

Overload List
Name | Description
CostRollOverExecutor(string) | Initializes a new instance of the CostRollOverExecutor class.
CostRollOverExecutor(string, RollOverItem, List<String>, string, string) | Initializes a new instance of the CostRollOverExecutor class.
See Also

Reference

CostRollOverExecutor Class
CostRollOverExecutor Members
CompuTec.ProcessForce.API.Costing.Executors Namespace


CostRollOverExecutor Properties

CostRollOverExecutor Class See Also

The following tables list the members exposed by the CostRollOverExecutor type.

Properties
 | Name | Description
Public property | FromCostCategory | Gets or sets a source cost category.
Public property | Item | Gets or sets an item.
Public property | ToCostCategory | Gets or sets a destination cost category.
Public property | Warehouses | Gets or sets a collection of warehouses.
Top
See Also

Reference

CostRollOverExecutor Class
CompuTec.ProcessForce.API.Costing.Executors Namespace


CostRollOverExecutor.FromCostCategory Property

Gets or sets a source cost category.

Namespace: CompuTec.ProcessForce.API.Costing.Executors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property FromCostCategory() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string FromCostCategory {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ FromCostCategory {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get FromCostCategory() : String;
public function set FromCostCategory(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostRollOverExecutor Class
CostRollOverExecutor Members
CompuTec.ProcessForce.API.Costing.Executors Namespace


CostRollOverExecutor.Item Property

Gets or sets an item.

Namespace: CompuTec.ProcessForce.API.Costing.Executors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Item() As RollOverItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RollOverItem Item {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property RollOverItem^ Item {
 RollOverItem^ get( );
 void set(
   RollOverItem^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Item() : RollOverItem;
public function set Item(value : RollOverItem);
This language is not supported or no code example is available.

Property Value

Type: RollOverItem
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostRollOverExecutor Class
CostRollOverExecutor Members
CompuTec.ProcessForce.API.Costing.Executors Namespace


CostRollOverExecutor.ToCostCategory Property

Gets or sets a destination cost category.

Namespace: CompuTec.ProcessForce.API.Costing.Executors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ToCostCategory() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ToCostCategory {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ToCostCategory {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ToCostCategory() : String;
public function set ToCostCategory(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostRollOverExecutor Class
CostRollOverExecutor Members
CompuTec.ProcessForce.API.Costing.Executors Namespace


CostRollOverExecutor.Warehouses Property

Gets or sets a collection of warehouses.

Namespace: CompuTec.ProcessForce.API.Costing.Executors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Warehouses() As List(Of String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<string> Warehouses {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<String^>^ Warehouses {
 List<String^>^ get( );
 void set(
   List<String^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<string>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostRollOverExecutor Class
CostRollOverExecutor Members
CompuTec.ProcessForce.API.Costing.Executors Namespace


CostRollOverExecutor Methods

CostRollOverExecutor Class See Also

The following tables list the members exposed by the CostRollOverExecutor type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | Execute | Executes the roll-over process for an item.
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetIsItemCostManagedPerWarehouse | Determines whether item cost is managed per warehouse.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

CostRollOverExecutor Class
CompuTec.ProcessForce.API.Costing.Executors Namespace


CostRollOverExecutor.Execute Method

Executes the roll-over process for an item.

Namespace: CompuTec.ProcessForce.API.Costing.Executors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function Execute( _
   ByVal rollOverResourceCosting As Boolean _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Result Execute(
   bool rollOverResourceCosting
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Result^ Execute(
   bool rollOverResourceCosting
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Execute(
    rollOverResourceCosting : boolean
) : Result;
This language is not supported or no code example is available.

Parameters

rollOverResourceCosting

Type: bool

Determines whether or not to perform a Roll-Over for the Resource Costing data.

Return Value

Type: Result

Execution result.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostRollOverExecutor Class
CostRollOverExecutor Members
CompuTec.ProcessForce.API.Costing.Executors Namespace


CostRollOverExecutor.GetIsItemCostManagedPerWarehouse Method

Determines whether item cost is managed per warehouse.

Namespace: CompuTec.ProcessForce.API.Costing.Executors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetIsItemCostManagedPerWarehouse( _
   ByVal Token As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool GetIsItemCostManagedPerWarehouse(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool GetIsItemCostManagedPerWarehouse(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetIsItemCostManagedPerWarehouse(
    Token : String
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostRollOverExecutor Class
CostRollOverExecutor Members
CompuTec.ProcessForce.API.Costing.Executors Namespace


CompuTec.ProcessForce.API.Costing.Extractors Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | BillOfMaterialsExtractionException | The exception that is thrown when the data of a bill of materials could not be extracted.
Public class | BillOfMaterialsInitializationException | The exception that is thrown when the data of a bill of materials could not be initialized.
Public class | ComponentCheckingException | The exception that is thrown when a bill of materials' component could not be checked against its own bill of materials structure existence.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


BillOfMaterialsExtractionException Class

Members See Also

The exception that is thrown when the data of a bill of materials could not be extracted.

Namespace: CompuTec.ProcessForce.API.Costing.Extractors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BillOfMaterialsExtractionException
    Inherits ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BillOfMaterialsExtractionException : ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BillOfMaterialsExtractionException : public ApplicationException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BillOfMaterialsExtractionException
   extends ApplicationException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
CompuTec.ProcessForce.API.Costing.Extractors.BillOfMaterialsExtractionException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialsExtractionException Members
CompuTec.ProcessForce.API.Costing.Extractors Namespace


BillOfMaterialsExtractionException Members

BillOfMaterialsExtractionException Class Constructors Methods Properties See Also

The exception that is thrown when the data of a bill of materials could not be extracted.

The following tables list the members exposed by the BillOfMaterialsExtractionException type.

Constructors
 | Name | Description
Public constructor | BillOfMaterialsExtractionException | (Overloaded) Initializes a new instance of BillOfMaterialsExtractionException class with a specified error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BillOfMaterialsExtractionException Class
CompuTec.ProcessForce.API.Costing.Extractors Namespace


BillOfMaterialsExtractionException Constructor

BillOfMaterialsExtractionException Class See Also

Initializes a new instance of BillOfMaterialsExtractionException class with a specified error message.

Overload List
Name | Description
BillOfMaterialsExtractionException(string) | Initializes a new instance of BillOfMaterialsExtractionException class with a specified error message.
BillOfMaterialsExtractionException(string, Exception) | Initializes a new instance of BillOfMaterialsExtractionException class with a specified error message and a reference to the inner exception that is the cause of this exception.
See Also

Reference

BillOfMaterialsExtractionException Class
BillOfMaterialsExtractionException Members
CompuTec.ProcessForce.API.Costing.Extractors Namespace


BillOfMaterialsExtractionException Properties

BillOfMaterialsExtractionException Class See Also

The following tables list the members exposed by the BillOfMaterialsExtractionException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

BillOfMaterialsExtractionException Class
CompuTec.ProcessForce.API.Costing.Extractors Namespace


BillOfMaterialsExtractionException Methods

BillOfMaterialsExtractionException Class See Also

The following tables list the members exposed by the BillOfMaterialsExtractionException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BillOfMaterialsExtractionException Class
CompuTec.ProcessForce.API.Costing.Extractors Namespace


BillOfMaterialsInitializationException Class

Members See Also

The exception that is thrown when the data of a bill of materials could not be initialized.

Namespace: CompuTec.ProcessForce.API.Costing.Extractors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BillOfMaterialsInitializationException
    Inherits ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BillOfMaterialsInitializationException : ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BillOfMaterialsInitializationException : public ApplicationException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BillOfMaterialsInitializationException
   extends ApplicationException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
CompuTec.ProcessForce.API.Costing.Extractors.BillOfMaterialsInitializationException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialsInitializationException Members
CompuTec.ProcessForce.API.Costing.Extractors Namespace


BillOfMaterialsInitializationException Members

BillOfMaterialsInitializationException Class Constructors Methods Properties See Also

The exception that is thrown when the data of a bill of materials could not be initialized.

The following tables list the members exposed by the BillOfMaterialsInitializationException type.

Constructors
 | Name | Description
Public constructor | BillOfMaterialsInitializationException | (Overloaded) Initializes a new instance of BillOfMaterialsInitializationException class with a specified error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BillOfMaterialsInitializationException Class
CompuTec.ProcessForce.API.Costing.Extractors Namespace


BillOfMaterialsInitializationException Constructor

BillOfMaterialsInitializationException Class See Also

Initializes a new instance of BillOfMaterialsInitializationException class with a specified error message.

Overload List
Name | Description
BillOfMaterialsInitializationException(string) | Initializes a new instance of BillOfMaterialsInitializationException class with a specified error message.
BillOfMaterialsInitializationException(string, Exception) | Initializes a new instance of BillOfMaterialsInitializationException class with a specified error message and a reference to the inner exception that is the cause of this exception.
See Also

Reference

BillOfMaterialsInitializationException Class
BillOfMaterialsInitializationException Members
CompuTec.ProcessForce.API.Costing.Extractors Namespace


BillOfMaterialsInitializationException Properties

BillOfMaterialsInitializationException Class See Also

The following tables list the members exposed by the BillOfMaterialsInitializationException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

BillOfMaterialsInitializationException Class
CompuTec.ProcessForce.API.Costing.Extractors Namespace


BillOfMaterialsInitializationException Methods

BillOfMaterialsInitializationException Class See Also

The following tables list the members exposed by the BillOfMaterialsInitializationException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BillOfMaterialsInitializationException Class
CompuTec.ProcessForce.API.Costing.Extractors Namespace


ComponentCheckingException Class

Members See Also

The exception that is thrown when a bill of materials' component could not be checked against its own bill of materials structure existence.

Namespace: CompuTec.ProcessForce.API.Costing.Extractors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ComponentCheckingException
    Inherits ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ComponentCheckingException : ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ComponentCheckingException : public ApplicationException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ComponentCheckingException
   extends ApplicationException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
CompuTec.ProcessForce.API.Costing.Extractors.ComponentCheckingException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ComponentCheckingException Members
CompuTec.ProcessForce.API.Costing.Extractors Namespace


ComponentCheckingException Members

ComponentCheckingException Class Constructors Methods Properties See Also

The exception that is thrown when a bill of materials' component could not be checked against its own bill of materials structure existence.

The following tables list the members exposed by the ComponentCheckingException type.

Constructors
 | Name | Description
Public constructor | ComponentCheckingException | (Overloaded) Initializes a new instance of ComponentCheckingException class with a specified error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ComponentCheckingException Class
CompuTec.ProcessForce.API.Costing.Extractors Namespace


ComponentCheckingException Constructor

ComponentCheckingException Class See Also

Initializes a new instance of ComponentCheckingException class with a specified error message.

Overload List
Name | Description
ComponentCheckingException(string) | Initializes a new instance of ComponentCheckingException class with a specified error message.
ComponentCheckingException(string, Exception) | Initializes a new instance of ComponentCheckingException class with a specified error message and a reference to the inner exception that is the cause of this exception.
See Also

Reference

ComponentCheckingException Class
ComponentCheckingException Members
CompuTec.ProcessForce.API.Costing.Extractors Namespace


ComponentCheckingException Properties

ComponentCheckingException Class See Also

The following tables list the members exposed by the ComponentCheckingException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

ComponentCheckingException Class
CompuTec.ProcessForce.API.Costing.Extractors Namespace


ComponentCheckingException Methods

ComponentCheckingException Class See Also

The following tables list the members exposed by the ComponentCheckingException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ComponentCheckingException Class
CompuTec.ProcessForce.API.Costing.Extractors Namespace


CompuTec.ProcessForce.API.Costing.Performers Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | RollOverPerformer | Performs the roll-over process.
Public class | RollUpPerformer | Performs the roll-up process.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


RollOverPerformer Class

Members See Also

Performs the roll-over process.

Namespace: CompuTec.ProcessForce.API.Costing.Performers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class RollOverPerformer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RollOverPerformer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class RollOverPerformer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RollOverPerformer
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Costing.Performers.RollOverPerformer
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollOverPerformer Members
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollOverPerformer Members

RollOverPerformer Class Constructors Methods Properties See Also

Performs the roll-over process.

The following tables list the members exposed by the RollOverPerformer type.

Constructors
 | Name | Description
Public constructor | RollOverPerformer | Initializes a static instance of RollOverPerformer class.
Top
Properties
 | Name | Description
Public property | FromCostCategory | Gets or sets a source cost category.
Public property | Items | Gets or sets a colleciton of items.
Public property | ToCostCategory | Gets or sets a destination cost category.
Public property | Warehouses | Gets or sets a collection of warehouses.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetIsItemCostManagedPerWarehouse | Determines whether item cost is managed per warehouse.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

RollOverPerformer Class
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollOverPerformer Constructor

Initializes a static instance of RollOverPerformer class.

Namespace: CompuTec.ProcessForce.API.Costing.Performers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String, _
   ByVal items As List(Of RollOverItem), _
   ByVal warehouses As List(Of String), _
   ByVal fromCostCategory As String, _
   ByVal toCostCategory As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RollOverPerformer(
   string token,
   List<RollOverItem> items,
   List<string> warehouses,
   string fromCostCategory,
   string toCostCategory
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RollOverPerformer(
   String^ token,
   List<RollOverItem^>^ items,
   List<String^>^ warehouses,
   String^ fromCostCategory,
   String^ toCostCategory
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

items

Type: List<RollOverItem>

Items for which the roll-over process must be performed.

warehouses

Type: List<string>

Warehouses for which the roll-over process must be performed.

fromCostCategory

Type: string

Source cost category.

toCostCategory

Type: string

Destination cost category.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollOverPerformer Class
RollOverPerformer Members
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollOverPerformer Properties

RollOverPerformer Class See Also

The following tables list the members exposed by the RollOverPerformer type.

Properties
 | Name | Description
Public property | FromCostCategory | Gets or sets a source cost category.
Public property | Items | Gets or sets a colleciton of items.
Public property | ToCostCategory | Gets or sets a destination cost category.
Public property | Warehouses | Gets or sets a collection of warehouses.
Top
See Also

Reference

RollOverPerformer Class
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollOverPerformer.FromCostCategory Property

Gets or sets a source cost category.

Namespace: CompuTec.ProcessForce.API.Costing.Performers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property FromCostCategory() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string FromCostCategory {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ FromCostCategory {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get FromCostCategory() : String;
public function set FromCostCategory(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollOverPerformer Class
RollOverPerformer Members
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollOverPerformer.Items Property

Gets or sets a colleciton of items.

Namespace: CompuTec.ProcessForce.API.Costing.Performers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Items() As List(Of RollOverItem)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<RollOverItem> Items {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<RollOverItem^>^ Items {
 List<RollOverItem^>^ get( );
 void set(
   List<RollOverItem^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<RollOverItem>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollOverPerformer Class
RollOverPerformer Members
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollOverPerformer.ToCostCategory Property

Gets or sets a destination cost category.

Namespace: CompuTec.ProcessForce.API.Costing.Performers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ToCostCategory() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ToCostCategory {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ToCostCategory {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ToCostCategory() : String;
public function set ToCostCategory(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollOverPerformer Class
RollOverPerformer Members
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollOverPerformer.Warehouses Property

Gets or sets a collection of warehouses.

Namespace: CompuTec.ProcessForce.API.Costing.Performers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Warehouses() As List(Of String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<string> Warehouses {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<String^>^ Warehouses {
 List<String^>^ get( );
 void set(
   List<String^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<string>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollOverPerformer Class
RollOverPerformer Members
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollOverPerformer Methods

RollOverPerformer Class See Also

The following tables list the members exposed by the RollOverPerformer type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetIsItemCostManagedPerWarehouse | Determines whether item cost is managed per warehouse.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

RollOverPerformer Class
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollOverPerformer.GetIsItemCostManagedPerWarehouse Method

Determines whether item cost is managed per warehouse.

Namespace: CompuTec.ProcessForce.API.Costing.Performers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetIsItemCostManagedPerWarehouse( _
   ByVal Token As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool GetIsItemCostManagedPerWarehouse(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool GetIsItemCostManagedPerWarehouse(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetIsItemCostManagedPerWarehouse(
    Token : String
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollOverPerformer Class
RollOverPerformer Members
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollUpPerformer Class

Members See Also

Performs the roll-up process.

Namespace: CompuTec.ProcessForce.API.Costing.Performers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class RollUpPerformer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RollUpPerformer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class RollUpPerformer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RollUpPerformer
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Costing.Performers.RollUpPerformer
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollUpPerformer Members
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollUpPerformer Members

RollUpPerformer Class Constructors Methods Properties See Also

Performs the roll-up process.

The following tables list the members exposed by the RollUpPerformer type.

Constructors
 | Name | Description
Public constructor | RollUpPerformer | (Overloaded) Initializes a new instance of RollUpPerformer class.
Top
Properties
 | Name | Description
Public property | BillOfMaterials | Gets or sets a collection of bill of materials to be rolled-up.
Public property | CostCategory | Gets or sets cost category.
Public property | RawMaterials | Gets or sets a collection of raw materials to be rolled-up.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetIsItemCostManagedPerWarehouse | Determines whether item cost is managed per warehouse.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | RollUp | Performs roll-up process.
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

RollUpPerformer Class
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollUpPerformer Constructor

RollUpPerformer Class See Also

Initializes a new instance of RollUpPerformer class.

Overload List
Name | Description
RollUpPerformer(string) | Initializes a new instance of RollUpPerformer class.
RollUpPerformer(string, List<RollingUpBillOfMaterials>, List<String>, string) | Initializes a new instance of RollUpPerformer class.
See Also

Reference

RollUpPerformer Class
RollUpPerformer Members
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollUpPerformer Properties

RollUpPerformer Class See Also

The following tables list the members exposed by the RollUpPerformer type.

Properties
 | Name | Description
Public property | BillOfMaterials | Gets or sets a collection of bill of materials to be rolled-up.
Public property | CostCategory | Gets or sets cost category.
Public property | RawMaterials | Gets or sets a collection of raw materials to be rolled-up.
Top
See Also

Reference

RollUpPerformer Class
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollUpPerformer.BillOfMaterials Property

Gets or sets a collection of bill of materials to be rolled-up.

Namespace: CompuTec.ProcessForce.API.Costing.Performers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property BillOfMaterials() As List(Of RollingUpBillOfMaterials)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<RollingUpBillOfMaterials> BillOfMaterials {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<RollingUpBillOfMaterials^>^ BillOfMaterials {
 List<RollingUpBillOfMaterials^>^ get( );
 void set(
   List<RollingUpBillOfMaterials^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<RollingUpBillOfMaterials>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollUpPerformer Class
RollUpPerformer Members
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollUpPerformer.CostCategory Property

Gets or sets cost category.

Namespace: CompuTec.ProcessForce.API.Costing.Performers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property CostCategory() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string CostCategory {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ CostCategory {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get CostCategory() : String;
public function set CostCategory(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollUpPerformer Class
RollUpPerformer Members
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollUpPerformer.RawMaterials Property

Gets or sets a collection of raw materials to be rolled-up.

Namespace: CompuTec.ProcessForce.API.Costing.Performers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property RawMaterials() As List(Of String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<string> RawMaterials {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<String^>^ RawMaterials {
 List<String^>^ get( );
 void set(
   List<String^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<string>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollUpPerformer Class
RollUpPerformer Members
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollUpPerformer Methods

RollUpPerformer Class See Also

The following tables list the members exposed by the RollUpPerformer type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetIsItemCostManagedPerWarehouse | Determines whether item cost is managed per warehouse.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | RollUp | Performs roll-up process.
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

RollUpPerformer Class
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollUpPerformer.GetIsItemCostManagedPerWarehouse Method

Determines whether item cost is managed per warehouse.

Namespace: CompuTec.ProcessForce.API.Costing.Performers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetIsItemCostManagedPerWarehouse( _
   ByVal Token As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool GetIsItemCostManagedPerWarehouse(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool GetIsItemCostManagedPerWarehouse(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetIsItemCostManagedPerWarehouse(
    Token : String
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollUpPerformer Class
RollUpPerformer Members
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollUpPerformer.RollUp Method

Performs roll-up process.

Namespace: CompuTec.ProcessForce.API.Costing.Performers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function RollUp( _
   ByVal warehouses As List(Of String), _
   ByVal rollUpOverStructure As Boolean, _
   ByVal useFinalGoodBatchSize As Boolean, _
   ByVal items As List(Of RollingUpBillOfMaterials) _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Result RollUp(
   List<string> warehouses,
   bool rollUpOverStructure,
   bool useFinalGoodBatchSize,
   List<RollingUpBillOfMaterials> items
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Result^ RollUp(
   List<String^>^ warehouses,
   bool rollUpOverStructure,
   bool useFinalGoodBatchSize,
   List<RollingUpBillOfMaterials^>^ items
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

warehouses

Type: List<string>

A collection of warehouses for which the roll-up process must be performed.

rollUpOverStructure

Type: bool

Determines whether or not the roll-up must be performed over the structure.

useFinalGoodBatchSize

Type: bool

Determines whether or not use the Batch Size defined for a Final Good product. By default this option is set to false.

items

Type: List<RollingUpBillOfMaterials>

Return Value

Type: Result

Roll-up result.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollUpPerformer Class
RollUpPerformer Members
CompuTec.ProcessForce.API.Costing.Performers Namespace


CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | ItemCodeOrSystemNumberMissMuchException |
Top
Interfaces
 | Name | Description
Public interface | IAdditionalBatchDetails | Additional Batch Details Informations holds and record for batch treacebility. This object can be updated but can`t be added. You can create AdditionalBatchDetails via company class
Public interface | IAdditionalBatchDetailsAttachments | Attachment for additional batch details object
Public interface | IAdditionalBatchDetailsProperties | Properties for additional batch details object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ItemCodeOrSystemNumberMissMuchException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class ItemCodeOrSystemNumberMissMuchException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class ItemCodeOrSystemNumberMissMuchException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class ItemCodeOrSystemNumberMissMuchException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class ItemCodeOrSystemNumberMissMuchException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails.ItemCodeOrSystemNumberMissMuchException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCodeOrSystemNumberMissMuchException Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


ItemCodeOrSystemNumberMissMuchException Members

ItemCodeOrSystemNumberMissMuchException Class Constructors Methods Properties See Also

The following tables list the members exposed by the ItemCodeOrSystemNumberMissMuchException type.

Constructors
 | Name | Description
Public constructor | ItemCodeOrSystemNumberMissMuchException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ItemCodeOrSystemNumberMissMuchException Class
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


ItemCodeOrSystemNumberMissMuchException Constructor

ItemCodeOrSystemNumberMissMuchException Class See Also

Overload List
Name | Description
ItemCodeOrSystemNumberMissMuchException() |
ItemCodeOrSystemNumberMissMuchException(string) |
ItemCodeOrSystemNumberMissMuchException(string, Exception) |
See Also

Reference

ItemCodeOrSystemNumberMissMuchException Class
ItemCodeOrSystemNumberMissMuchException Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


ItemCodeOrSystemNumberMissMuchException Properties

ItemCodeOrSystemNumberMissMuchException Class See Also

The following tables list the members exposed by the ItemCodeOrSystemNumberMissMuchException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

ItemCodeOrSystemNumberMissMuchException Class
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


ItemCodeOrSystemNumberMissMuchException Methods

ItemCodeOrSystemNumberMissMuchException Class See Also

The following tables list the members exposed by the ItemCodeOrSystemNumberMissMuchException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ItemCodeOrSystemNumberMissMuchException Class
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails Interface

Members See Also

Additional Batch Details Informations holds and record for batch treacebility. This object can be updated but can`t be added. You can create AdditionalBatchDetails via company class

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "AdditionalBatchDetails", TableName = "@CT_PF_OABT", ExludedHttpMethods = "POST,DELETE")> _
Public Interface IAdditionalBatchDetails
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "AdditionalBatchDetails", TableName = "@CT_PF_OABT", ExludedHttpMethods = "POST,DELETE")]
public interface IAdditionalBatchDetails : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "AdditionalBatchDetails", TableName = "@CT_PF_OABT", ExludedHttpMethods = "POST,DELETE")]
public interface class IAdditionalBatchDetails : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "AdditionalBatchDetails", TableName = "@CT_PF_OABT", ExludedHttpMethods = "POST,DELETE")
interface IAdditionalBatchDetails
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OABT
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails Members

IAdditionalBatchDetails Interface Methods Properties See Also

Additional Batch Details Informations holds and record for batch treacebility. This object can be updated but can`t be added. You can create AdditionalBatchDetails via company class

The following tables list the members exposed by the IAdditionalBatchDetails type.

Properties
 | Name | Description
Public property | Attachments |
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Properties |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_AdmDate |
Public property | U_BaseEntry | Base Entry - DocEntry of Document that Creates this Batch -Read only
Public property | U_BaseType | Typo of document that creates this Batch - -Read only
Public property | U_BestBefDate |
Public property | U_ConsDate | Consume By Date
Public property | U_DistNumber |
Public property | U_ExpiryDate | Expiry Date
Public property | U_ExpiryTime | Expiry Time
Public property | U_InDate | Inspection Date
Public property | U_ItemCode | Item Code of Item -read only
Public property | U_LotNumber |
Public property | U_LstInDate | Last Inspection Date
Public property | U_MnfDocEntry | Manufacturing Doc Entry if it was from production -Read only
Public property | U_MnfSerial | Dist Number Read Only
Public property | U_Notes |
Public property | U_NxtInDate | Next Inspection Date
Public property | U_Origin |
Public property | U_QCADate |
Public property | U_QCAction |
Public property | U_QCSDate |
Public property | U_QCStatus |
Public property | U_Remarks |
Public property | U_Revision | Item Revision.Filled if item was created in production Process
Public property | U_RevisionDesc | Item Revision Description filled if item was created in production Process
Public property | U_Status |
Public property | U_SupNumber |
Public property | U_SysNumber | System Number of Sap Batch Detail OBTN -read only
Public property | U_VndDate | Vendor Date
Public property | U_WCoDate | Warning Propr Consume Date
Public property | U_WExDate | Warning Propr Expire Date
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByItemCodeAndDistNumber |
Public method | GetByItemCodeAndSysNumber |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IAdditionalBatchDetails Interface
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails Properties

IAdditionalBatchDetails Interface See Also

The following tables list the members exposed by the IAdditionalBatchDetails type.

Properties
 | Name | Description
Public property | Attachments |
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Properties |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_AdmDate |
Public property | U_BaseEntry | Base Entry - DocEntry of Document that Creates this Batch -Read only
Public property | U_BaseType | Typo of document that creates this Batch - -Read only
Public property | U_BestBefDate |
Public property | U_ConsDate | Consume By Date
Public property | U_DistNumber |
Public property | U_ExpiryDate | Expiry Date
Public property | U_ExpiryTime | Expiry Time
Public property | U_InDate | Inspection Date
Public property | U_ItemCode | Item Code of Item -read only
Public property | U_LotNumber |
Public property | U_LstInDate | Last Inspection Date
Public property | U_MnfDocEntry | Manufacturing Doc Entry if it was from production -Read only
Public property | U_MnfSerial | Dist Number Read Only
Public property | U_Notes |
Public property | U_NxtInDate | Next Inspection Date
Public property | U_Origin |
Public property | U_QCADate |
Public property | U_QCAction |
Public property | U_QCSDate |
Public property | U_QCStatus |
Public property | U_Remarks |
Public property | U_Revision | Item Revision.Filled if item was created in production Process
Public property | U_RevisionDesc | Item Revision Description filled if item was created in production Process
Public property | U_Status |
Public property | U_SupNumber |
Public property | U_SysNumber | System Number of Sap Batch Detail OBTN -read only
Public property | U_VndDate | Vendor Date
Public property | U_WCoDate | Warning Propr Consume Date
Public property | U_WExDate | Warning Propr Expire Date
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
See Also

Reference

IAdditionalBatchDetails Interface
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.Attachments Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Attachments() As IAdditionalBatchDetailsAttachments
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IAdditionalBatchDetailsAttachments Attachments {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IAdditionalBatchDetailsAttachments^ Attachments {
 IAdditionalBatchDetailsAttachments^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Attachments() : IAdditionalBatchDetailsAttachments;
This language is not supported or no code example is available.

Property Value

Type: IAdditionalBatchDetailsAttachments
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IUDOBean.ErrorDescription Property

Error Information if any

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property ErrorDescription() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string ErrorDescription {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ ErrorDescription {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get ErrorDescription() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOBean Interface
IUDOBean Members
CompuTec.ProcessForce.API.Core Namespace


IAdditionalBatchDetails.Properties Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Properties() As IAdditionalBatchDetailsProperties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IAdditionalBatchDetailsProperties Properties {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IAdditionalBatchDetailsProperties^ Properties {
 IAdditionalBatchDetailsProperties^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Properties() : IAdditionalBatchDetailsProperties;
This language is not supported or no code example is available.

Property Value

Type: IAdditionalBatchDetailsProperties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IUDOBean.Token Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Token() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Token {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Token {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Token() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOBean Interface
IUDOBean Members
CompuTec.ProcessForce.API.Core Namespace


IUDOBean.UDFItems Property

User Defined Items

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UDFItems() As IUDFItems
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
IUDFItems UDFItems {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property IUDFItems^ UDFItems {
 IUDFItems^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UDFItems() : IUDFItems;
This language is not supported or no code example is available.

Property Value

Type: IUDFItems
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOBean Interface
IUDOBean Members
CompuTec.ProcessForce.API.Core Namespace


IAdditionalBatchDetails.U_AdmDate Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AdmDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_AdmDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_AdmDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AdmDate() : DateTime;
function set U_AdmDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_BaseEntry Property

Base Entry - DocEntry of Document that Creates this Batch -Read only

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BaseEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_BaseType Property

Typo of document that creates this Batch - -Read only

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BaseType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BaseType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BaseType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseType() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_BestBefDate Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BestBefDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_BestBefDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_BestBefDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BestBefDate() : DateTime;
function set U_BestBefDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_ConsDate Property

Consume By Date

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ConsDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ConsDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ConsDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ConsDate() : DateTime;
function set U_ConsDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_DistNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_DistNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DistNumber {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DistNumber {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DistNumber() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_ExpiryDate Property

Expiry Date

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ExpiryDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ExpiryDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ExpiryDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ExpiryDate() : DateTime;
function set U_ExpiryDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_ExpiryTime Property

Expiry Time

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ExpiryTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ExpiryTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ExpiryTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ExpiryTime() : DateTime;
function set U_ExpiryTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_InDate Property

Inspection Date

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_InDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_InDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InDate() : DateTime;
function set U_InDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_ItemCode Property

Item Code of Item -read only

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_LotNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LotNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LotNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LotNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LotNumber() : String;
function set U_LotNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_LstInDate Property

Last Inspection Date

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LstInDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_LstInDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_LstInDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LstInDate() : DateTime;
function set U_LstInDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_MnfDocEntry Property

Manufacturing Doc Entry if it was from production -Read only

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_MnfDocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_MnfDocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_MnfDocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MnfDocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_MnfSerial Property

Dist Number Read Only

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MnfSerial() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MnfSerial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MnfSerial {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MnfSerial() : String;
function set U_MnfSerial(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_Notes Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Notes() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Notes {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Notes {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Notes() : String;
function set U_Notes(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_NxtInDate Property

Next Inspection Date

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_NxtInDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_NxtInDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_NxtInDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_NxtInDate() : DateTime;
function set U_NxtInDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_Origin Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Origin() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Origin {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Origin {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Origin() : String;
function set U_Origin(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_QCADate Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_QCADate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_QCADate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_QCADate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QCADate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_QCAction Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QCAction() As QCAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
QCAction U_QCAction {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property QCAction U_QCAction {
 QCAction get( );
 void set(
   QCAction value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QCAction() : QCAction;
function set U_QCAction(value : QCAction);
This language is not supported or no code example is available.

Property Value

Type: QCAction
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_QCSDate Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QCSDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_QCSDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_QCSDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QCSDate() : DateTime;
function set U_QCSDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_QCStatus Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QCStatus() As QCStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
QCStatus U_QCStatus {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property QCStatus U_QCStatus {
 QCStatus get( );
 void set(
   QCStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QCStatus() : QCStatus;
function set U_QCStatus(value : QCStatus);
This language is not supported or no code example is available.

Property Value

Type: QCStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_Revision Property

Item Revision.Filled if item was created in production Process

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Revision() : String;
function set U_Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_RevisionDesc Property

Item Revision Description filled if item was created in production Process

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RevisionDesc() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevisionDesc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevisionDesc {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevisionDesc() : String;
function set U_RevisionDesc(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_Status Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Status() As BatchStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
BatchStatus U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property BatchStatus U_Status {
 BatchStatus get( );
 void set(
   BatchStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Status() : BatchStatus;
function set U_Status(value : BatchStatus);
This language is not supported or no code example is available.

Property Value

Type: BatchStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_SupNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SupNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SupNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SupNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SupNumber() : String;
function set U_SupNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_SysNumber Property

System Number of Sap Batch Detail OBTN -read only

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_SysNumber() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SysNumber {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SysNumber {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SysNumber() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_VndDate Property

Vendor Date

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_VndDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_VndDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VndDate() : DateTime;
function set U_VndDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_WCoDate Property

Warning Propr Consume Date

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WCoDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_WCoDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_WCoDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WCoDate() : DateTime;
function set U_WCoDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.U_WExDate Property

Warning Propr Expire Date

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WExDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_WExDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_WExDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WExDate() : DateTime;
function set U_WExDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IUDOBean.UdoLogTableName Property

Gets Correspondend Log Table name in databse

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UdoLogTableName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string UdoLogTableName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ UdoLogTableName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UdoLogTableName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOBean Interface
IUDOBean Members
CompuTec.ProcessForce.API.Core Namespace


IUDOBean.UdoName Property

gets UDOName of current object

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UdoName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string UdoName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ UdoName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UdoName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOBean Interface
IUDOBean Members
CompuTec.ProcessForce.API.Core Namespace


IUDOBean.UdoTableName Property

Gets Correspondend Table name in databse

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UdoTableName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string UdoTableName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ UdoTableName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UdoTableName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOBean Interface
IUDOBean Members
CompuTec.ProcessForce.API.Core Namespace


IAdditionalBatchDetails Methods

IAdditionalBatchDetails Interface See Also

The following tables list the members exposed by the IAdditionalBatchDetails type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByItemCodeAndDistNumber |
Public method | GetByItemCodeAndSysNumber |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IAdditionalBatchDetails Interface
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IUDOBean.Add Method

methood adds Object To Database

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function Add() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Add()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int Add()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Add() : int;
This language is not supported or no code example is available.

Return Value

Type: int

0 - sucess

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOBean Interface
IUDOBean Members
CompuTec.ProcessForce.API.Core Namespace


IUDOBean.CanDelete Method

Gets Can Delete information

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CanDelete() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool CanDelete()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool CanDelete()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CanDelete() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool

Returns true if object can be deleted

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOBean Interface
IUDOBean Members
CompuTec.ProcessForce.API.Core Namespace


IUDOBean.Clean Method

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Clean()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Clean()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Clean()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Clean();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOBean Interface
IUDOBean Members
CompuTec.ProcessForce.API.Core Namespace


IUDOBean.Delete Method

Deletes an object

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function Delete() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Delete()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int Delete()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Delete() : int;
This language is not supported or no code example is available.

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOBean Interface
IUDOBean Members
CompuTec.ProcessForce.API.Core Namespace


IUDOBean.GetAsXML Method

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAsXML( _
   Optional ByVal onlyFilledRows As Boolean = true _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string GetAsXML(
   bool onlyFilledRows = true
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

String^ GetAsXML(
   bool onlyFilledRows
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetAsXML(
    onlyFilledRows : boolean
) : String;
This language is not supported or no code example is available.

Parameters

onlyFilledRows

Type: bool

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOBean Interface
IUDOBean Members
CompuTec.ProcessForce.API.Core Namespace


IAdditionalBatchDetails.GetByItemCodeAndDistNumber Method

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByItemCodeAndDistNumber( _
   ByVal ItemCode As String, _
   ByVal DistNumber As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByItemCodeAndDistNumber(
   string ItemCode,
   string DistNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByItemCodeAndDistNumber(
   String^ ItemCode,
   String^ DistNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByItemCodeAndDistNumber(
    ItemCode : String,
    DistNumber : String
) : int;
This language is not supported or no code example is available.

Parameters

ItemCode

Type: string

DistNumber

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetails.GetByItemCodeAndSysNumber Method

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByItemCodeAndSysNumber( _
   ByVal ItemCode As String, _
   ByVal SysNumber As Integer _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByItemCodeAndSysNumber(
   string ItemCode,
   int SysNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByItemCodeAndSysNumber(
   String^ ItemCode,
   int SysNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByItemCodeAndSysNumber(
    ItemCode : String,
    SysNumber : int
) : int;
This language is not supported or no code example is available.

Parameters

ItemCode

Type: string

SysNumber

Type: int

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetails Interface
IAdditionalBatchDetails Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IUDOBean.GetByKey Method

Loads object with values From Database

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByKey( _
   ByVal key As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByKey(
   string key
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByKey(
   String^ key
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByKey(
    key : String
) : int;
This language is not supported or no code example is available.

Parameters

key

Type: string

master Key Code or Docentry

Return Value

Type: int

0 if success

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOBean Interface
IUDOBean Members
CompuTec.ProcessForce.API.Core Namespace


IUDOBean.GetLastObjectCode Method

Returns Object Code form newly added item

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetLastObjectCode() As Object
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
object GetLastObjectCode()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

object^ GetLastObjectCode()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetLastObjectCode() : object;
This language is not supported or no code example is available.

Return Value

Type: object
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOBean Interface
IUDOBean Members
CompuTec.ProcessForce.API.Core Namespace


IUDOBean.RefreshHeaderData Method

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function RefreshHeaderData() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool RefreshHeaderData()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool RefreshHeaderData()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function RefreshHeaderData() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOBean Interface
IUDOBean Members
CompuTec.ProcessForce.API.Core Namespace


IUDOBean.Update Method

Update An object

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function Update() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Update()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int Update()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Update() : int;
This language is not supported or no code example is available.

Return Value

Type: int

0 - if succeded

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOBean Interface
IUDOBean Members
CompuTec.ProcessForce.API.Core Namespace


IAdditionalBatchDetailsAttachments Interface

Members See Also

Attachment for additional batch details object

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IAdditionalBatchDetailsAttachments
    Inherits IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IAdditionalBatchDetailsAttachments : IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IAdditionalBatchDetailsAttachments : public IUDOChildBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IAdditionalBatchDetailsAttachments
   implements IUDOChildBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ABT6
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsAttachments Members

IAdditionalBatchDetailsAttachments Interface Methods Properties See Also

Attachment for additional batch details object

The following tables list the members exposed by the IAdditionalBatchDetailsAttachments type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AttDate |
Public property | U_AttFileName |
Public property | U_AttPath |
Public property | U_BPCode |
Public property | U_BPName |
Public property | U_CertificateDate |
Public property | U_CertificateNo |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

IAdditionalBatchDetailsAttachments Interface
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsAttachments Properties

IAdditionalBatchDetailsAttachments Interface See Also

The following tables list the members exposed by the IAdditionalBatchDetailsAttachments type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AttDate |
Public property | U_AttFileName |
Public property | U_AttPath |
Public property | U_BPCode |
Public property | U_BPName |
Public property | U_CertificateDate |
Public property | U_CertificateNo |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
See Also

Reference

IAdditionalBatchDetailsAttachments Interface
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsAttachments.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsAttachments Interface
IAdditionalBatchDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsAttachments.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsAttachments Interface
IAdditionalBatchDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsAttachments.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsAttachments Interface
IAdditionalBatchDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsAttachments.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsAttachments Interface
IAdditionalBatchDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsAttachments.U_AttDate Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_AttDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_AttDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttDate() : DateTime;
function set U_AttDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsAttachments Interface
IAdditionalBatchDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsAttachments.U_AttFileName Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttFileName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AttFileName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AttFileName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttFileName() : String;
function set U_AttFileName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsAttachments Interface
IAdditionalBatchDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsAttachments.U_AttPath Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttPath() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AttPath {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AttPath {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttPath() : String;
function set U_AttPath(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsAttachments Interface
IAdditionalBatchDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsAttachments.U_BPCode Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BPCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BPCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BPCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BPCode() : String;
function set U_BPCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsAttachments Interface
IAdditionalBatchDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsAttachments.U_BPName Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BPName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BPName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BPName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BPName() : String;
function set U_BPName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsAttachments Interface
IAdditionalBatchDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsAttachments.U_CertificateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CertificateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_CertificateDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_CertificateDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CertificateDate() : DateTime;
function set U_CertificateDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsAttachments Interface
IAdditionalBatchDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsAttachments.U_CertificateNo Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CertificateNo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CertificateNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CertificateNo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CertificateNo() : String;
function set U_CertificateNo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsAttachments Interface
IAdditionalBatchDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsAttachments Methods

IAdditionalBatchDetailsAttachments Interface See Also

The following tables list the members exposed by the IAdditionalBatchDetailsAttachments type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

IAdditionalBatchDetailsAttachments Interface
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsProperties Interface

Members See Also

Properties for additional batch details object

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IAdditionalBatchDetailsProperties
    Inherits IUDOChildBean, _
             IEnumerable(Of IAdditionalBatchDetailsProperties)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IAdditionalBatchDetailsProperties : IUDOChildBean,
   IEnumerable<IAdditionalBatchDetailsProperties>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IAdditionalBatchDetailsProperties : public IUDOChildBean^,
   public IEnumerable<IAdditionalBatchDetailsProperties^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_ABT1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsProperties Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsProperties Members

IAdditionalBatchDetailsProperties Interface Methods Properties See Also

Properties for additional batch details object

The following tables list the members exposed by the IAdditionalBatchDetailsProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ActualValue | Actual Value
Public property | U_ActualWordValue |
Public property | U_Expression | Type Of Condition
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PrpCode |
Public property | U_RangeValueFrom |
Public property | U_RangeValueTo |
Public property | U_WordCode | Reference Code
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IAdditionalBatchDetailsProperties Interface
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsProperties Properties

IAdditionalBatchDetailsProperties Interface See Also

The following tables list the members exposed by the IAdditionalBatchDetailsProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ActualValue | Actual Value
Public property | U_ActualWordValue |
Public property | U_Expression | Type Of Condition
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PrpCode |
Public property | U_RangeValueFrom |
Public property | U_RangeValueTo |
Public property | U_WordCode | Reference Code
Top
See Also

Reference

IAdditionalBatchDetailsProperties Interface
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsProperties.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsProperties Interface
IAdditionalBatchDetailsProperties Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsProperties.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsProperties Interface
IAdditionalBatchDetailsProperties Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsProperties.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsProperties Interface
IAdditionalBatchDetailsProperties Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsProperties.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsProperties Interface
IAdditionalBatchDetailsProperties Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsProperties.U_ActualValue Property

Actual Value

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActualValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ActualValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ActualValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActualValue() : double;
function set U_ActualValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsProperties Interface
IAdditionalBatchDetailsProperties Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsProperties.U_ActualWordValue Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActualWordValue() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ActualWordValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ActualWordValue {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActualWordValue() : String;
function set U_ActualWordValue(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsProperties Interface
IAdditionalBatchDetailsProperties Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsProperties.U_Expression Property

Type Of Condition

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Expression() As ConditionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ConditionType U_Expression {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ConditionType U_Expression {
 ConditionType get( );
 void set(
   ConditionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Expression() : ConditionType;
function set U_Expression(value : ConditionType);
This language is not supported or no code example is available.

Property Value

Type: ConditionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsProperties Interface
IAdditionalBatchDetailsProperties Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsProperties.U_PrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpCode() : String;
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsProperties Interface
IAdditionalBatchDetailsProperties Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsProperties.U_RangeValueFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RangeValueFrom() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RangeValueFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RangeValueFrom {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RangeValueFrom() : double;
function set U_RangeValueFrom(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsProperties Interface
IAdditionalBatchDetailsProperties Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsProperties.U_RangeValueTo Property

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RangeValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RangeValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RangeValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RangeValueTo() : double;
function set U_RangeValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsProperties Interface
IAdditionalBatchDetailsProperties Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsProperties.U_WordCode Property

Reference Code

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdditionalBatchDetailsProperties Interface
IAdditionalBatchDetailsProperties Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


IAdditionalBatchDetailsProperties Methods

IAdditionalBatchDetailsProperties Interface See Also

The following tables list the members exposed by the IAdditionalBatchDetailsProperties type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IAdditionalBatchDetailsProperties Interface
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IBatchTemplate | Batch template object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IBatchTemplate Interface

Members See Also

Batch template object

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "BatchTemplate", TableName = "@CT_PF_OBTM", UDOVersion = "UDO_10")> _
Public Interface IBatchTemplate
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "BatchTemplate", TableName = "@CT_PF_OBTM", UDOVersion = "UDO_10")]
public interface IBatchTemplate : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "BatchTemplate", TableName = "@CT_PF_OBTM", UDOVersion = "UDO_10")]
public interface class IBatchTemplate : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "BatchTemplate", TableName = "@CT_PF_OBTM", UDOVersion = "UDO_10")
interface IBatchTemplate
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OBTM
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate Members

IBatchTemplate Interface Methods Properties See Also

Batch template object

The following tables list the members exposed by the IBatchTemplate type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code | Batch template Code - Mandatory
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Counter | Counter - Next value to generate
Public property | U_DateFormat | Format of date parameter fex. yyyy-MM-dd
Public property | U_Remarks | Remarks
Public property | U_SuppCounter | Counter - Next value to generate
Public property | U_SuppDateFormat | Format of date parameter fex. yyyy-MM-dd
Public property | U_SuppTemplate | Barch Template fex 'prefix'+%Counter%+'sufix'
Public property | U_Template | Barch Template fex 'prefix'+%Counter%+'sufix'
Public property | U_TemplateName | Template Name
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IBatchTemplate Interface
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate Properties

IBatchTemplate Interface See Also

The following tables list the members exposed by the IBatchTemplate type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code | Batch template Code - Mandatory
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Counter | Counter - Next value to generate
Public property | U_DateFormat | Format of date parameter fex. yyyy-MM-dd
Public property | U_Remarks | Remarks
Public property | U_SuppCounter | Counter - Next value to generate
Public property | U_SuppDateFormat | Format of date parameter fex. yyyy-MM-dd
Public property | U_SuppTemplate | Barch Template fex 'prefix'+%Counter%+'sufix'
Public property | U_Template | Barch Template fex 'prefix'+%Counter%+'sufix'
Public property | U_TemplateName | Template Name
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IBatchTemplate Interface
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.Code Property

Batch template Code - Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.U_Counter Property

Counter - Next value to generate

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Counter() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_Counter {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_Counter {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Counter() : int;
function set U_Counter(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.U_DateFormat Property

Format of date parameter fex. yyyy-MM-dd

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DateFormat() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DateFormat {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DateFormat {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DateFormat() : String;
function set U_DateFormat(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.U_Remarks Property

Remarks

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.U_SuppCounter Property

Counter - Next value to generate

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SuppCounter() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SuppCounter {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SuppCounter {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SuppCounter() : int;
function set U_SuppCounter(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.U_SuppDateFormat Property

Format of date parameter fex. yyyy-MM-dd

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SuppDateFormat() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SuppDateFormat {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SuppDateFormat {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SuppDateFormat() : String;
function set U_SuppDateFormat(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.U_SuppTemplate Property

Barch Template fex 'prefix'+%Counter%+'sufix'

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SuppTemplate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SuppTemplate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SuppTemplate {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SuppTemplate() : String;
function set U_SuppTemplate(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.U_Template Property

Barch Template fex 'prefix'+%Counter%+'sufix'

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Template() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Template {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Template {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Template() : String;
function set U_Template(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.U_TemplateName Property

Template Name

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_TemplateName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_TemplateName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_TemplateName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_TemplateName() : String;

   AppEngineProperty(Required = true)
function set U_TemplateName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.BatchTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchTemplate Interface
IBatchTemplate Members
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


IBatchTemplate Methods

IBatchTemplate Interface See Also

The following tables list the members exposed by the IBatchTemplate type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IBatchTemplate Interface
CompuTec.ProcessForce.API.Documents.BatchTemplate Namespace


CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | BillOfMaterialValidationException |
Public class | ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion |
Public class | OperationOverlayValueRnageException |
Public class | OperationResourceInvalidCycleValueException |
Public class | RelatedOverlayOperationDetectedException |
Public class | ResourceTimesNotValidException |
Public class | RevisonMissingForBOMException |
Public class | RevisonMissingForChildException |
Public class | WarehouseNotSetForItemException |
Top
Interfaces
 | Name | Description
Public interface | IBillOfMaterial | Bill of material object
Public interface | IBillOfMaterialAttachments | Attachments for bill of material object
Public interface | IBillOfMaterialCoProducts | Coproducts for bill of material object
Public interface | IBillOfMaterialItems | Items for bill of material object
Public interface | IBillOfMaterialPhantoms | Phantoms for bill of material object
Public interface | IBillOfMaterialRouting | Routings for bill of material object
Public interface | IBillOfMaterialRoutingOperationInputOutput | Input output for routing operations for bill of material object
Public interface | IBillOfMaterialRoutingOperationInputOutputProperties | Input output properties for routing operations for bill of material object
Public interface | IBillOfMaterialRoutingOperationProperties | Properties of routing operations for bill of material object
Public interface | IBillOfMaterialRoutingOperationRelations | Relations for routing operations for bill of material object
Public interface | IBillOfMaterialRoutingOperationResourceProperties | Resource properties for routing operations for bill of material object
Public interface | IBillOfMaterialRoutingOperationResources | Resources for routing operations for bill of material object
Public interface | IBillOfMaterialRoutingOperations | Routing operations for bill of material object
Public interface | IBillOfMaterialScraps | Scraps for bill of material object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


BillOfMaterialValidationException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BillOfMaterialValidationException
    Inherits UDOException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BillOfMaterialValidationException : UDOException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BillOfMaterialValidationException : public UDOException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BillOfMaterialValidationException
   extends UDOException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Core.UDOException
CompuTec.ProcessForce.API.Documents.BillOfMaterials.BillOfMaterialValidationException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialValidationException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


BillOfMaterialValidationException Members

BillOfMaterialValidationException Class Constructors Methods Properties See Also

The following tables list the members exposed by the BillOfMaterialValidationException type.

Constructors
 | Name | Description
Public constructor | BillOfMaterialValidationException |
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | ObjectCode | (inherited from UDOException).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BillOfMaterialValidationException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


BillOfMaterialValidationException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BillOfMaterialValidationException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BillOfMaterialValidationException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BillOfMaterialValidationException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialValidationException Class
BillOfMaterialValidationException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


BillOfMaterialValidationException Properties

BillOfMaterialValidationException Class See Also

The following tables list the members exposed by the BillOfMaterialValidationException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | ObjectCode | (inherited from UDOException).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

BillOfMaterialValidationException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


UDOException.ObjectCode Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ObjectCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ObjectCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ObjectCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ObjectCode() : String;
public function set ObjectCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UDOException Class
UDOException Members
CompuTec.ProcessForce.API.Core Namespace


BillOfMaterialValidationException Methods

BillOfMaterialValidationException Class See Also

The following tables list the members exposed by the BillOfMaterialValidationException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BillOfMaterialValidationException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.BillOfMaterials.ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Members

ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Class Constructors Methods Properties See Also

The following tables list the members exposed by the ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion type.

Constructors
 | Name | Description
Public constructor | ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Constructor

ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Class See Also

Overload List
Name | Description
ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion() |
ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion(SerializationInfo, StreamingContext) |
ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion(string) |
ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion(string, Exception) |
See Also

Reference

ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Class
ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Properties

ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Class See Also

The following tables list the members exposed by the ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Methods

ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Class See Also

The following tables list the members exposed by the ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


OperationOverlayValueRnageException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class OperationOverlayValueRnageException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class OperationOverlayValueRnageException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class OperationOverlayValueRnageException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class OperationOverlayValueRnageException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.BillOfMaterials.OperationOverlayValueRnageException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OperationOverlayValueRnageException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


OperationOverlayValueRnageException Members

OperationOverlayValueRnageException Class Constructors Methods Properties See Also

The following tables list the members exposed by the OperationOverlayValueRnageException type.

Constructors
 | Name | Description
Public constructor | OperationOverlayValueRnageException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

OperationOverlayValueRnageException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


OperationOverlayValueRnageException Constructor

OperationOverlayValueRnageException Class See Also

Overload List
Name | Description
OperationOverlayValueRnageException() |
OperationOverlayValueRnageException(string) |
OperationOverlayValueRnageException(string, Exception) |
See Also

Reference

OperationOverlayValueRnageException Class
OperationOverlayValueRnageException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


OperationOverlayValueRnageException Properties

OperationOverlayValueRnageException Class See Also

The following tables list the members exposed by the OperationOverlayValueRnageException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

OperationOverlayValueRnageException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


OperationOverlayValueRnageException Methods

OperationOverlayValueRnageException Class See Also

The following tables list the members exposed by the OperationOverlayValueRnageException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

OperationOverlayValueRnageException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


OperationResourceInvalidCycleValueException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class OperationResourceInvalidCycleValueException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class OperationResourceInvalidCycleValueException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class OperationResourceInvalidCycleValueException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class OperationResourceInvalidCycleValueException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.BillOfMaterials.OperationResourceInvalidCycleValueException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OperationResourceInvalidCycleValueException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


OperationResourceInvalidCycleValueException Members

OperationResourceInvalidCycleValueException Class Constructors Methods Properties See Also

The following tables list the members exposed by the OperationResourceInvalidCycleValueException type.

Constructors
 | Name | Description
Public constructor | OperationResourceInvalidCycleValueException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

OperationResourceInvalidCycleValueException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


OperationResourceInvalidCycleValueException Constructor

OperationResourceInvalidCycleValueException Class See Also

Overload List
Name | Description
OperationResourceInvalidCycleValueException() |
OperationResourceInvalidCycleValueException(string) |
OperationResourceInvalidCycleValueException(string, Exception) |
See Also

Reference

OperationResourceInvalidCycleValueException Class
OperationResourceInvalidCycleValueException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


OperationResourceInvalidCycleValueException Properties

OperationResourceInvalidCycleValueException Class See Also

The following tables list the members exposed by the OperationResourceInvalidCycleValueException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

OperationResourceInvalidCycleValueException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


OperationResourceInvalidCycleValueException Methods

OperationResourceInvalidCycleValueException Class See Also

The following tables list the members exposed by the OperationResourceInvalidCycleValueException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

OperationResourceInvalidCycleValueException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RelatedOverlayOperationDetectedException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class RelatedOverlayOperationDetectedException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class RelatedOverlayOperationDetectedException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class RelatedOverlayOperationDetectedException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class RelatedOverlayOperationDetectedException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.BillOfMaterials.RelatedOverlayOperationDetectedException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RelatedOverlayOperationDetectedException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RelatedOverlayOperationDetectedException Members

RelatedOverlayOperationDetectedException Class Constructors Methods Properties See Also

The following tables list the members exposed by the RelatedOverlayOperationDetectedException type.

Constructors
 | Name | Description
Public constructor | RelatedOverlayOperationDetectedException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

RelatedOverlayOperationDetectedException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RelatedOverlayOperationDetectedException Constructor

RelatedOverlayOperationDetectedException Class See Also

Overload List
Name | Description
RelatedOverlayOperationDetectedException() |
RelatedOverlayOperationDetectedException(string) |
RelatedOverlayOperationDetectedException(string, Exception) |
See Also

Reference

RelatedOverlayOperationDetectedException Class
RelatedOverlayOperationDetectedException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RelatedOverlayOperationDetectedException Properties

RelatedOverlayOperationDetectedException Class See Also

The following tables list the members exposed by the RelatedOverlayOperationDetectedException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

RelatedOverlayOperationDetectedException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RelatedOverlayOperationDetectedException Methods

RelatedOverlayOperationDetectedException Class See Also

The following tables list the members exposed by the RelatedOverlayOperationDetectedException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

RelatedOverlayOperationDetectedException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


ResourceTimesNotValidException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class ResourceTimesNotValidException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class ResourceTimesNotValidException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class ResourceTimesNotValidException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class ResourceTimesNotValidException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.BillOfMaterials.ResourceTimesNotValidException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceTimesNotValidException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


ResourceTimesNotValidException Members

ResourceTimesNotValidException Class Constructors Methods Properties See Also

The following tables list the members exposed by the ResourceTimesNotValidException type.

Constructors
 | Name | Description
Public constructor | ResourceTimesNotValidException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ResourceTimesNotValidException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


ResourceTimesNotValidException Constructor

ResourceTimesNotValidException Class See Also

Overload List
Name | Description
ResourceTimesNotValidException() |
ResourceTimesNotValidException(string) |
ResourceTimesNotValidException(string, Exception) |
See Also

Reference

ResourceTimesNotValidException Class
ResourceTimesNotValidException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


ResourceTimesNotValidException Properties

ResourceTimesNotValidException Class See Also

The following tables list the members exposed by the ResourceTimesNotValidException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

ResourceTimesNotValidException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


ResourceTimesNotValidException Methods

ResourceTimesNotValidException Class See Also

The following tables list the members exposed by the ResourceTimesNotValidException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ResourceTimesNotValidException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RevisonMissingForBOMException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class RevisonMissingForBOMException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class RevisonMissingForBOMException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class RevisonMissingForBOMException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class RevisonMissingForBOMException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.BillOfMaterials.RevisonMissingForBOMException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RevisonMissingForBOMException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RevisonMissingForBOMException Members

RevisonMissingForBOMException Class Constructors Methods Properties See Also

The following tables list the members exposed by the RevisonMissingForBOMException type.

Constructors
 | Name | Description
Public constructor | RevisonMissingForBOMException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

RevisonMissingForBOMException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RevisonMissingForBOMException Constructor

RevisonMissingForBOMException Class See Also

Overload List
Name | Description
RevisonMissingForBOMException() |
RevisonMissingForBOMException(string) |
RevisonMissingForBOMException(string, Exception) |
See Also

Reference

RevisonMissingForBOMException Class
RevisonMissingForBOMException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RevisonMissingForBOMException Properties

RevisonMissingForBOMException Class See Also

The following tables list the members exposed by the RevisonMissingForBOMException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

RevisonMissingForBOMException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RevisonMissingForBOMException Methods

RevisonMissingForBOMException Class See Also

The following tables list the members exposed by the RevisonMissingForBOMException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

RevisonMissingForBOMException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RevisonMissingForChildException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class RevisonMissingForChildException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class RevisonMissingForChildException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class RevisonMissingForChildException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class RevisonMissingForChildException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.BillOfMaterials.RevisonMissingForChildException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RevisonMissingForChildException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RevisonMissingForChildException Members

RevisonMissingForChildException Class Constructors Methods Properties See Also

The following tables list the members exposed by the RevisonMissingForChildException type.

Constructors
 | Name | Description
Public constructor | RevisonMissingForChildException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

RevisonMissingForChildException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RevisonMissingForChildException Constructor

RevisonMissingForChildException Class See Also

Overload List
Name | Description
RevisonMissingForChildException() |
RevisonMissingForChildException(string) |
RevisonMissingForChildException(string, Exception) |
See Also

Reference

RevisonMissingForChildException Class
RevisonMissingForChildException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RevisonMissingForChildException Properties

RevisonMissingForChildException Class See Also

The following tables list the members exposed by the RevisonMissingForChildException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

RevisonMissingForChildException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RevisonMissingForChildException Methods

RevisonMissingForChildException Class See Also

The following tables list the members exposed by the RevisonMissingForChildException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

RevisonMissingForChildException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


WarehouseNotSetForItemException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class WarehouseNotSetForItemException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class WarehouseNotSetForItemException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class WarehouseNotSetForItemException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class WarehouseNotSetForItemException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.BillOfMaterials.WarehouseNotSetForItemException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WarehouseNotSetForItemException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


WarehouseNotSetForItemException Members

WarehouseNotSetForItemException Class Constructors Methods Properties See Also

The following tables list the members exposed by the WarehouseNotSetForItemException type.

Constructors
 | Name | Description
Public constructor | WarehouseNotSetForItemException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

WarehouseNotSetForItemException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


WarehouseNotSetForItemException Constructor

WarehouseNotSetForItemException Class See Also

Overload List
Name | Description
WarehouseNotSetForItemException() |
WarehouseNotSetForItemException(string) |
WarehouseNotSetForItemException(string, Exception) |
See Also

Reference

WarehouseNotSetForItemException Class
WarehouseNotSetForItemException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


WarehouseNotSetForItemException Properties

WarehouseNotSetForItemException Class See Also

The following tables list the members exposed by the WarehouseNotSetForItemException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

WarehouseNotSetForItemException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


WarehouseNotSetForItemException Methods

WarehouseNotSetForItemException Class See Also

The following tables list the members exposed by the WarehouseNotSetForItemException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

WarehouseNotSetForItemException Class
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial Interface

Members See Also

Bill of material object

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "BillOfMaterial", TableName = "@CT_PF_OBOM")> _
Public Interface IBillOfMaterial
    Inherits IExtendedUDO, _
             IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "BillOfMaterial", TableName = "@CT_PF_OBOM")]
public interface IBillOfMaterial : IExtendedUDO,
   IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "BillOfMaterial", TableName = "@CT_PF_OBOM")]
public interface class IBillOfMaterial : public IExtendedUDO^,
   public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "BillOfMaterial", TableName = "@CT_PF_OBOM")
interface IBillOfMaterial
   implements IExtendedUDO,
              IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OBOM
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial Members

IBillOfMaterial Interface Methods Properties See Also

Bill of material object

The following tables list the members exposed by the IBillOfMaterial type.

Properties
 | Name | Description
Public property | Attachments | Bill of Materials lines: Attachments
Public property | Canceled |
Public property | CoProducts | Bill of Materials lines: CoProducts
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_ItemName | Item Name.
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Items | Bill of Materials lines: Items
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Phantoms | Bill of Materials lines: Phantoms
Public property | RoutingOperationProperties | Bill of Materials lines: Routing operatons properties
Public property | RoutingOperationResources | Bill of Materials lines: Routing operation resources
Public property | RoutingOperations | Bill of Materials lines: Routing operations
Public property | Routings | Bill of Materials lines: Routings
Public property | RoutingsOperationInputOutput | Bill of Materials lines: Routings operation input/output
Public property | RoutingsOperationInputOutputProperties | Bill of Materials lines: Routings operation input/output properties
Public property | RoutingsOperationRelation |
Public property | RoutingsOperationResourceProperties | Bill of Materials lines: Routings operations resource properties
Public property | Scraps | Bill of Materials lines: Scraps
Public property | Token | (inherited from IUDOBean).
Public property | TotalQuantity | This is calculated in the flhy
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_BatchSize | // Parameters of Bill of Materials' Dimensions //
Public property | U_Browser | Field that allows to browse records via Itemc Code and Revision
Public property | U_CoproductFormula |
Public property | U_Currency | Currency
Public property | U_Description | Item Name . Description . Changing this filed is alloweg it will only change name of ItemDescription This Value will be Copy to MOR document as U_Description
Public property | U_Factor | Factor
Public property | U_Instructions |
Public property | U_InventoryUoM | Unit of measure
Public property | U_ItemCode | Main key of Item Master Data
Public property | U_ItemFormula |
Public property | U_OccrCode | Distribution Rule or Cost Centre code
Public property | U_OcrCode | Distribution Rule or Cost Centre code in Dimension 1
Public property | U_OcrCode2 | Distribution Rule or Cost Centre code in Dimension 2
Public property | U_OcrCode3 | Distribution Rule or Cost Centre code in Dimension 3
Public property | U_OcrCode4 | Distribution Rule or Cost Centre code in Dimension 4
Public property | U_OcrCode5 | Distribution Rule or Cost Centre code in Dimension 5
Public property | U_Price | Price
Public property | U_PriceList | Price list
Public property | U_ProdType |
Public property | U_Project | Project code
Public property | U_Quantity | Quantity
Public property | U_Remarks |
Public property | U_Revision | Revision
Public property | U_ScrapFormula |
Public property | U_WhsCode | Warehouse code
Public property | U_Yield |
Public property | U_YieldFormula |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByItemCodeAndRevision | Get Bill of Material Code by ItemCode and Revision
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetCalculationQuantity |
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RecalcFormulas | Connect Function to Activate Recalculation Engine on object (inherited from IExtendedUDO).
Public method | RecalcFormulasNew | (inherited from IExtendedUDO).
Public method | RecalcRequired | (Overloaded) (inherited from IExtendedUDO).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | SynchronizeSAPBOM |
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IBillOfMaterial Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial Properties

IBillOfMaterial Interface See Also

The following tables list the members exposed by the IBillOfMaterial type.

Properties
 | Name | Description
Public property | Attachments | Bill of Materials lines: Attachments
Public property | Canceled |
Public property | CoProducts | Bill of Materials lines: CoProducts
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_ItemName | Item Name.
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Items | Bill of Materials lines: Items
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Phantoms | Bill of Materials lines: Phantoms
Public property | RoutingOperationProperties | Bill of Materials lines: Routing operatons properties
Public property | RoutingOperationResources | Bill of Materials lines: Routing operation resources
Public property | RoutingOperations | Bill of Materials lines: Routing operations
Public property | Routings | Bill of Materials lines: Routings
Public property | RoutingsOperationInputOutput | Bill of Materials lines: Routings operation input/output
Public property | RoutingsOperationInputOutputProperties | Bill of Materials lines: Routings operation input/output properties
Public property | RoutingsOperationRelation |
Public property | RoutingsOperationResourceProperties | Bill of Materials lines: Routings operations resource properties
Public property | Scraps | Bill of Materials lines: Scraps
Public property | Token | (inherited from IUDOBean).
Public property | TotalQuantity | This is calculated in the flhy
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_BatchSize | // Parameters of Bill of Materials' Dimensions //
Public property | U_Browser | Field that allows to browse records via Itemc Code and Revision
Public property | U_CoproductFormula |
Public property | U_Currency | Currency
Public property | U_Description | Item Name . Description . Changing this filed is alloweg it will only change name of ItemDescription This Value will be Copy to MOR document as U_Description
Public property | U_Factor | Factor
Public property | U_Instructions |
Public property | U_InventoryUoM | Unit of measure
Public property | U_ItemCode | Main key of Item Master Data
Public property | U_ItemFormula |
Public property | U_OccrCode | Distribution Rule or Cost Centre code
Public property | U_OcrCode | Distribution Rule or Cost Centre code in Dimension 1
Public property | U_OcrCode2 | Distribution Rule or Cost Centre code in Dimension 2
Public property | U_OcrCode3 | Distribution Rule or Cost Centre code in Dimension 3
Public property | U_OcrCode4 | Distribution Rule or Cost Centre code in Dimension 4
Public property | U_OcrCode5 | Distribution Rule or Cost Centre code in Dimension 5
Public property | U_Price | Price
Public property | U_PriceList | Price list
Public property | U_ProdType |
Public property | U_Project | Project code
Public property | U_Quantity | Quantity
Public property | U_Remarks |
Public property | U_Revision | Revision
Public property | U_ScrapFormula |
Public property | U_WhsCode | Warehouse code
Public property | U_Yield |
Public property | U_YieldFormula |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IBillOfMaterial Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.Attachments Property

Bill of Materials lines: Attachments

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Attachments() As IBillOfMaterialAttachments
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBillOfMaterialAttachments Attachments {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBillOfMaterialAttachments^ Attachments {
 IBillOfMaterialAttachments^ get( );
 void set(
   IBillOfMaterialAttachments^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Attachments() : IBillOfMaterialAttachments;
function set Attachments(value : IBillOfMaterialAttachments);
This language is not supported or no code example is available.

Property Value

Type: IBillOfMaterialAttachments
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.CoProducts Property

Bill of Materials lines: CoProducts

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property CoProducts() As IBillOfMaterialCoProducts
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBillOfMaterialCoProducts CoProducts {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBillOfMaterialCoProducts^ CoProducts {
 IBillOfMaterialCoProducts^ get( );
 void set(
   IBillOfMaterialCoProducts^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CoProducts() : IBillOfMaterialCoProducts;
function set CoProducts(value : IBillOfMaterialCoProducts);
This language is not supported or no code example is available.

Property Value

Type: IBillOfMaterialCoProducts
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.DS_ItemName Property

Item Name.

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_ItemName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_ItemName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_ItemName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.Items Property

Bill of Materials lines: Items

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Items() As IBillOfMaterialItems
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBillOfMaterialItems Items {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBillOfMaterialItems^ Items {
 IBillOfMaterialItems^ get( );
 void set(
   IBillOfMaterialItems^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Items() : IBillOfMaterialItems;
function set Items(value : IBillOfMaterialItems);
This language is not supported or no code example is available.

Property Value

Type: IBillOfMaterialItems
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.Phantoms Property

Bill of Materials lines: Phantoms

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Phantoms() As IBillOfMaterialPhantoms
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBillOfMaterialPhantoms Phantoms {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBillOfMaterialPhantoms^ Phantoms {
 IBillOfMaterialPhantoms^ get( );
 void set(
   IBillOfMaterialPhantoms^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Phantoms() : IBillOfMaterialPhantoms;
function set Phantoms(value : IBillOfMaterialPhantoms);
This language is not supported or no code example is available.

Property Value

Type: IBillOfMaterialPhantoms
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.RoutingOperationProperties Property

Bill of Materials lines: Routing operatons properties

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RoutingOperationProperties() As IBillOfMaterialRoutingOperationProperties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBillOfMaterialRoutingOperationProperties RoutingOperationProperties {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBillOfMaterialRoutingOperationProperties^ RoutingOperationProperties {
 IBillOfMaterialRoutingOperationProperties^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RoutingOperationProperties() : IBillOfMaterialRoutingOperationProperties;
This language is not supported or no code example is available.

Property Value

Type: IBillOfMaterialRoutingOperationProperties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.RoutingOperationResources Property

Bill of Materials lines: Routing operation resources

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property RoutingOperationResources() As IBillOfMaterialRoutingOperationResources
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBillOfMaterialRoutingOperationResources RoutingOperationResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBillOfMaterialRoutingOperationResources^ RoutingOperationResources {
 IBillOfMaterialRoutingOperationResources^ get( );
 void set(
   IBillOfMaterialRoutingOperationResources^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RoutingOperationResources() : IBillOfMaterialRoutingOperationResources;
function set RoutingOperationResources(value : IBillOfMaterialRoutingOperationResources);
This language is not supported or no code example is available.

Property Value

Type: IBillOfMaterialRoutingOperationResources
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.RoutingOperations Property

Bill of Materials lines: Routing operations

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property RoutingOperations() As IBillOfMaterialRoutingOperations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBillOfMaterialRoutingOperations RoutingOperations {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBillOfMaterialRoutingOperations^ RoutingOperations {
 IBillOfMaterialRoutingOperations^ get( );
 void set(
   IBillOfMaterialRoutingOperations^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RoutingOperations() : IBillOfMaterialRoutingOperations;
function set RoutingOperations(value : IBillOfMaterialRoutingOperations);
This language is not supported or no code example is available.

Property Value

Type: IBillOfMaterialRoutingOperations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.Routings Property

Bill of Materials lines: Routings

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Routings() As IBillOfMaterialRouting
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBillOfMaterialRouting Routings {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBillOfMaterialRouting^ Routings {
 IBillOfMaterialRouting^ get( );
 void set(
   IBillOfMaterialRouting^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Routings() : IBillOfMaterialRouting;
function set Routings(value : IBillOfMaterialRouting);
This language is not supported or no code example is available.

Property Value

Type: IBillOfMaterialRouting
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.RoutingsOperationInputOutput Property

Bill of Materials lines: Routings operation input/output

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RoutingsOperationInputOutput() As IBillOfMaterialRoutingOperationInputOutput
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBillOfMaterialRoutingOperationInputOutput RoutingsOperationInputOutput {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBillOfMaterialRoutingOperationInputOutput^ RoutingsOperationInputOutput {
 IBillOfMaterialRoutingOperationInputOutput^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RoutingsOperationInputOutput() : IBillOfMaterialRoutingOperationInputOutput;
This language is not supported or no code example is available.

Property Value

Type: IBillOfMaterialRoutingOperationInputOutput
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.RoutingsOperationInputOutputProperties Property

Bill of Materials lines: Routings operation input/output properties

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RoutingsOperationInputOutputProperties() As IBillOfMaterialRoutingOperationInputOutputProperties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBillOfMaterialRoutingOperationInputOutputProperties RoutingsOperationInputOutputProperties {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBillOfMaterialRoutingOperationInputOutputProperties^ RoutingsOperationInputOutputProperties {
 IBillOfMaterialRoutingOperationInputOutputProperties^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RoutingsOperationInputOutputProperties() : IBillOfMaterialRoutingOperationInputOutputProperties;
This language is not supported or no code example is available.

Property Value

Type: IBillOfMaterialRoutingOperationInputOutputProperties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.RoutingsOperationRelation Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RoutingsOperationRelation() As IBillOfMaterialRoutingOperationRelations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBillOfMaterialRoutingOperationRelations RoutingsOperationRelation {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBillOfMaterialRoutingOperationRelations^ RoutingsOperationRelation {
 IBillOfMaterialRoutingOperationRelations^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RoutingsOperationRelation() : IBillOfMaterialRoutingOperationRelations;
This language is not supported or no code example is available.

Property Value

Type: IBillOfMaterialRoutingOperationRelations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.RoutingsOperationResourceProperties Property

Bill of Materials lines: Routings operations resource properties

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RoutingsOperationResourceProperties() As IBillOfMaterialRoutingOperationResourceProperties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBillOfMaterialRoutingOperationResourceProperties RoutingsOperationResourceProperties {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBillOfMaterialRoutingOperationResourceProperties^ RoutingsOperationResourceProperties {
 IBillOfMaterialRoutingOperationResourceProperties^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RoutingsOperationResourceProperties() : IBillOfMaterialRoutingOperationResourceProperties;
This language is not supported or no code example is available.

Property Value

Type: IBillOfMaterialRoutingOperationResourceProperties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.Scraps Property

Bill of Materials lines: Scraps

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Scraps() As IBillOfMaterialScraps
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBillOfMaterialScraps Scraps {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBillOfMaterialScraps^ Scraps {
 IBillOfMaterialScraps^ get( );
 void set(
   IBillOfMaterialScraps^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Scraps() : IBillOfMaterialScraps;
function set Scraps(value : IBillOfMaterialScraps);
This language is not supported or no code example is available.

Property Value

Type: IBillOfMaterialScraps
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.TotalQuantity Property

This is calculated in the flhy

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property TotalQuantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double TotalQuantity {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double TotalQuantity {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get TotalQuantity() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_BatchSize Property

// Parameters of Bill of Materials' Dimensions //

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BatchSize() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_BatchSize {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_BatchSize {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchSize() : double;
function set U_BatchSize(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_Browser Property

Field that allows to browse records via Itemc Code and Revision

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Browser() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Browser {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Browser {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Browser() : String;
function set U_Browser(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_CoproductFormula Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CoproductFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CoproductFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CoproductFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CoproductFormula() : String;
function set U_CoproductFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_Currency Property

Currency

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Currency() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Currency {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Currency {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Currency() : String;
function set U_Currency(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_Description Property

Item Name . Description . Changing this filed is alloweg it will only change name of ItemDescription This Value will be Copy to MOR document as U_Description

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Description() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Description {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Description {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Description() : String;
function set U_Description(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_Factor Property

Factor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Factor() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Factor {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Factor {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Factor() : double;
function set U_Factor(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_Instructions Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Instructions() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Instructions {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Instructions {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Instructions() : String;
function set U_Instructions(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_InventoryUoM Property

Unit of measure

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InventoryUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InventoryUoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InventoryUoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InventoryUoM() : String;
function set U_InventoryUoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_ItemCode Property

Main key of Item Master Data

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2, Required = true)> _
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, Required = true)]
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, Required = true)]

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2, Required = true)
function get U_ItemCode() : String;

   AppEngineProperty(Priority = 2, Required = true)
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_ItemFormula Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemFormula() : String;
function set U_ItemFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_OccrCode Property

Distribution Rule or Cost Centre code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OccrCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OccrCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OccrCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OccrCode() : String;
function set U_OccrCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_OcrCode Property

Distribution Rule or Cost Centre code in Dimension 1

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode() : String;
function set U_OcrCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_OcrCode2 Property

Distribution Rule or Cost Centre code in Dimension 2

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode2() : String;
function set U_OcrCode2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_OcrCode3 Property

Distribution Rule or Cost Centre code in Dimension 3

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode3() : String;
function set U_OcrCode3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_OcrCode4 Property

Distribution Rule or Cost Centre code in Dimension 4

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode4() : String;
function set U_OcrCode4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_OcrCode5 Property

Distribution Rule or Cost Centre code in Dimension 5

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode5() : String;
function set U_OcrCode5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_Price Property

Price

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Price() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Price {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Price {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Price() : double;
function set U_Price(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_PriceList Property

Price list

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PriceList() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_PriceList {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_PriceList {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PriceList() : int;
function set U_PriceList(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_ProdType Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ProdType() As ProductionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ProductionType U_ProdType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ProductionType U_ProdType {
 ProductionType get( );
 void set(
   ProductionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ProdType() : ProductionType;
function set U_ProdType(value : ProductionType);
This language is not supported or no code example is available.

Property Value

Type: ProductionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_Project Property

Project code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Project() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Project {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Project {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Project() : String;
function set U_Project(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_Quantity Property

Quantity

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_Revision Property

Revision

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Revision() : String;
function set U_Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_ScrapFormula Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ScrapFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ScrapFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ScrapFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ScrapFormula() : String;
function set U_ScrapFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_WhsCode Property

Warehouse code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Autogenerate = true)> _
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Autogenerate = true)]
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Autogenerate = true)]

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Autogenerate = true)
function get U_WhsCode() : String;

   AppEngineProperty(Autogenerate = true)
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_Yield Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Yield() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Yield {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Yield {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Yield() : double;
function set U_Yield(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.U_YieldFormula Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_YieldFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_YieldFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_YieldFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_YieldFormula() : String;
function set U_YieldFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial Methods

IBillOfMaterial Interface See Also

The following tables list the members exposed by the IBillOfMaterial type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByItemCodeAndRevision | Get Bill of Material Code by ItemCode and Revision
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetCalculationQuantity |
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RecalcFormulas | Connect Function to Activate Recalculation Engine on object (inherited from IExtendedUDO).
Public method | RecalcFormulasNew | (inherited from IExtendedUDO).
Public method | RecalcRequired | (Overloaded) (inherited from IExtendedUDO).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | SynchronizeSAPBOM |
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IBillOfMaterial Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.GetByItemCodeAndRevision Method

Get Bill of Material Code by ItemCode and Revision

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByItemCodeAndRevision( _
   ByVal itemCode As String, _
   ByVal revision As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByItemCodeAndRevision(
   string itemCode,
   string revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByItemCodeAndRevision(
   String^ itemCode,
   String^ revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByItemCodeAndRevision(
    itemCode : String,
    revision : String
) : int;
This language is not supported or no code example is available.

Parameters

itemCode

Type: string

revision

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterial.GetCalculationQuantity Method

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetCalculationQuantity( _
   ByVal rtgCode As String, _
   ByVal rtgOprCode As Integer _
) As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double GetCalculationQuantity(
   string rtgCode,
   int rtgOprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

double GetCalculationQuantity(
   String^ rtgCode,
   int rtgOprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetCalculationQuantity(
    rtgCode : String,
    rtgOprCode : int
) : double;
This language is not supported or no code example is available.

Parameters

rtgCode

Type: string

rtgOprCode

Type: int

Return Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IExtendedUDO.RecalcFormulas Method

Connect Function to Activate Recalculation Engine on object

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub RecalcFormulas()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void RecalcFormulas()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void RecalcFormulas()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function RecalcFormulas();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExtendedUDO Interface
IExtendedUDO Members
CompuTec.ProcessForce.API.Core Namespace


IExtendedUDO.RecalcFormulasNew Method

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub RecalcFormulasNew()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void RecalcFormulasNew()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void RecalcFormulasNew()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function RecalcFormulasNew();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExtendedUDO Interface
IExtendedUDO Members
CompuTec.ProcessForce.API.Core Namespace


IExtendedUDO.RecalcRequired Method

IExtendedUDO Interface See Also

Overload List
Name | Description
RecalcRequired() |
RecalcRequired(string, string, int) |
See Also

Reference

IExtendedUDO Interface
IExtendedUDO Members
CompuTec.ProcessForce.API.Core Namespace


IBillOfMaterial.SynchronizeSAPBOM Method

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub SynchronizeSAPBOM( _
   ByVal success As Boolean, _
   ByVal token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void SynchronizeSAPBOM(
   bool success,
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void SynchronizeSAPBOM(
   bool success,
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function SynchronizeSAPBOM(
    success : boolean,
    token : String
);
This language is not supported or no code example is available.

Parameters

success

Type: bool

token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterial Interface
IBillOfMaterial Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialAttachments Interface

Members See Also

Attachments for bill of material object

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IBillOfMaterialAttachments
    Inherits IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IBillOfMaterialAttachments : IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IBillOfMaterialAttachments : public IUDOChildBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IBillOfMaterialAttachments
   implements IUDOChildBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_BOM7
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialAttachments Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialAttachments Members

IBillOfMaterialAttachments Interface Methods Properties See Also

Attachments for bill of material object

The following tables list the members exposed by the IBillOfMaterialAttachments type.

Properties
 | Name | Description
Public property | BaseBillOfMaterial | Parent object of Bill of Material
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AttDate |
Public property | U_AttFileName |
Public property | U_AttPath |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

IBillOfMaterialAttachments Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialAttachments Properties

IBillOfMaterialAttachments Interface See Also

The following tables list the members exposed by the IBillOfMaterialAttachments type.

Properties
 | Name | Description
Public property | BaseBillOfMaterial | Parent object of Bill of Material
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AttDate |
Public property | U_AttFileName |
Public property | U_AttPath |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
See Also

Reference

IBillOfMaterialAttachments Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialAttachments.BaseBillOfMaterial Property

Parent object of Bill of Material

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BaseBillOfMaterial() As IBillOfMaterial
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBillOfMaterial BaseBillOfMaterial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBillOfMaterial^ BaseBillOfMaterial {
 IBillOfMaterial^ get( );
 void set(
   IBillOfMaterial^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BaseBillOfMaterial() : IBillOfMaterial;
function set BaseBillOfMaterial(value : IBillOfMaterial);
This language is not supported or no code example is available.

Property Value

Type: IBillOfMaterial
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialAttachments Interface
IBillOfMaterialAttachments Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialAttachments.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialAttachments Interface
IBillOfMaterialAttachments Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialAttachments.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialAttachments Interface
IBillOfMaterialAttachments Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialAttachments.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialAttachments Interface
IBillOfMaterialAttachments Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialAttachments.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialAttachments Interface
IBillOfMaterialAttachments Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialAttachments.U_AttDate Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_AttDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_AttDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttDate() : DateTime;
function set U_AttDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialAttachments Interface
IBillOfMaterialAttachments Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialAttachments.U_AttFileName Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttFileName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AttFileName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AttFileName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttFileName() : String;
function set U_AttFileName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialAttachments Interface
IBillOfMaterialAttachments Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialAttachments.U_AttPath Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttPath() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AttPath {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AttPath {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttPath() : String;
function set U_AttPath(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialAttachments Interface
IBillOfMaterialAttachments Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialAttachments Methods

IBillOfMaterialAttachments Interface See Also

The following tables list the members exposed by the IBillOfMaterialAttachments type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

IBillOfMaterialAttachments Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts Interface

Members See Also

Coproducts for bill of material object

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IBillOfMaterialCoProducts
    Inherits IUDOChildBean, _
             IEnumerable(Of IBillOfMaterialCoProducts)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IBillOfMaterialCoProducts : IUDOChildBean,
   IEnumerable<IBillOfMaterialCoProducts>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IBillOfMaterialCoProducts : public IUDOChildBean^,
   public IEnumerable<IBillOfMaterialCoProducts^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_BOM3
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts Members

IBillOfMaterialCoProducts Interface Methods Properties See Also

Coproducts for bill of material object

The following tables list the members exposed by the IBillOfMaterialCoProducts type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_ItemName | Gets the item name.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BatchResult | Batch Result based on specific formula used in Costing read-only
Public property | U_Description | CoProduct's Description
Public property | U_Factor | CoProduct's Factor
Public property | U_FactorDescription | CoProduct's Factor's Description
Public property | U_Formula | CoProduct's Formula to calculate result
Public property | U_InventoryUoM | CoProduct's Unit of measure
Public property | U_IssueType | CoProduct's Issue Type
Public property | U_ItemCode | CoProduct's ItemCode
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OcrCode | CoProduct's Distribution Rule or Cost Centre code in Dimension 1
Public property | U_OcrCode2 | CoProduct's Distribution Rule or Cost Centre code in Dimension 2
Public property | U_OcrCode3 | CoProduct's Distribution Rule or Cost Centre code in Dimension 3
Public property | U_OcrCode4 | CoProduct's Distribution Rule or Cost Centre code in Dimension 4
Public property | U_OcrCode5 | CoProduct's Distribution Rule or Cost Centre code in Dimension 5
Public property | U_Project | CoProduct's Project code
Public property | U_Quantity | CoProduct's Quantity
Public property | U_Remarks | CoProduct's Remarks
Public property | U_Result | CoProduct's Result based on specific formula
Public property | U_Revision | CoProduct's Revision code
Public property | U_Sequence | CoProduct's Sequence number
Public property | U_WhsCode | CoProduct's Warehouse Code
Public property | U_Yield |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialCoProducts Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts Properties

IBillOfMaterialCoProducts Interface See Also

The following tables list the members exposed by the IBillOfMaterialCoProducts type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_ItemName | Gets the item name.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BatchResult | Batch Result based on specific formula used in Costing read-only
Public property | U_Description | CoProduct's Description
Public property | U_Factor | CoProduct's Factor
Public property | U_FactorDescription | CoProduct's Factor's Description
Public property | U_Formula | CoProduct's Formula to calculate result
Public property | U_InventoryUoM | CoProduct's Unit of measure
Public property | U_IssueType | CoProduct's Issue Type
Public property | U_ItemCode | CoProduct's ItemCode
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OcrCode | CoProduct's Distribution Rule or Cost Centre code in Dimension 1
Public property | U_OcrCode2 | CoProduct's Distribution Rule or Cost Centre code in Dimension 2
Public property | U_OcrCode3 | CoProduct's Distribution Rule or Cost Centre code in Dimension 3
Public property | U_OcrCode4 | CoProduct's Distribution Rule or Cost Centre code in Dimension 4
Public property | U_OcrCode5 | CoProduct's Distribution Rule or Cost Centre code in Dimension 5
Public property | U_Project | CoProduct's Project code
Public property | U_Quantity | CoProduct's Quantity
Public property | U_Remarks | CoProduct's Remarks
Public property | U_Result | CoProduct's Result based on specific formula
Public property | U_Revision | CoProduct's Revision code
Public property | U_Sequence | CoProduct's Sequence number
Public property | U_WhsCode | CoProduct's Warehouse Code
Public property | U_Yield |
Top
See Also

Reference

IBillOfMaterialCoProducts Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.DS_ItemName Property

Gets the item name.

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property DS_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
string DS_ItemName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property String^ DS_ItemName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get DS_ItemName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_BatchResult Property

Batch Result based on specific formula used in Costing read-only

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BatchResult() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_BatchResult {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_BatchResult {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchResult() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_Description Property

CoProduct's Description

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Description() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Description {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Description {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Description() : String;
function set U_Description(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_Factor Property

CoProduct's Factor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Factor() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Factor {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Factor {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Factor() : double;
function set U_Factor(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_FactorDescription Property

CoProduct's Factor's Description

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FactorDescription() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FactorDescription {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FactorDescription {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FactorDescription() : String;
function set U_FactorDescription(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_Formula Property

CoProduct's Formula to calculate result

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Formula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Formula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Formula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Formula() : String;
function set U_Formula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_InventoryUoM Property

CoProduct's Unit of measure

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InventoryUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InventoryUoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InventoryUoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InventoryUoM() : String;
function set U_InventoryUoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_IssueType Property

CoProduct's Issue Type

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IssueType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_IssueType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_IssueType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IssueType() : String;
function set U_IssueType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_ItemCode Property

CoProduct's ItemCode

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 1)> _
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 1)]
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 1)]

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 1)
function get U_ItemCode() : String;

   AppEngineProperty(Priority = 1)
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_OcrCode Property

CoProduct's Distribution Rule or Cost Centre code in Dimension 1

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode() : String;
function set U_OcrCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_OcrCode2 Property

CoProduct's Distribution Rule or Cost Centre code in Dimension 2

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode2() : String;
function set U_OcrCode2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_OcrCode3 Property

CoProduct's Distribution Rule or Cost Centre code in Dimension 3

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode3() : String;
function set U_OcrCode3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_OcrCode4 Property

CoProduct's Distribution Rule or Cost Centre code in Dimension 4

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode4() : String;
function set U_OcrCode4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_OcrCode5 Property

CoProduct's Distribution Rule or Cost Centre code in Dimension 5

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode5() : String;
function set U_OcrCode5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_Project Property

CoProduct's Project code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Project() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Project {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Project {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Project() : String;
function set U_Project(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_Quantity Property

CoProduct's Quantity

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_Remarks Property

CoProduct's Remarks

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_Result Property

CoProduct's Result based on specific formula

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Result() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Result {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Result {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Result() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_Revision Property

CoProduct's Revision code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property U_Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string U_Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ U_Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_Revision() : String;

   AppEnginePropertyIgnore()
function set U_Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_Sequence Property

CoProduct's Sequence number

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Sequence() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_Sequence {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_Sequence {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Sequence() : int;
function set U_Sequence(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_WhsCode Property

CoProduct's Warehouse Code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts.U_Yield Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Autogenerate = true)> _
Property U_Yield() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Autogenerate = true)]
double U_Yield {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Autogenerate = true)]

property double U_Yield {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Autogenerate = true)
function get U_Yield() : double;

   AppEngineProperty(Autogenerate = true)
function set U_Yield(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialCoProducts Interface
IBillOfMaterialCoProducts Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialCoProducts Methods

IBillOfMaterialCoProducts Interface See Also

The following tables list the members exposed by the IBillOfMaterialCoProducts type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialCoProducts Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems Interface

Members See Also

Items for bill of material object

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IBillOfMaterialItems
    Inherits IUDOChildBean, _
             IEnumerable(Of IBillOfMaterialItems)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IBillOfMaterialItems : IUDOChildBean,
   IEnumerable<IBillOfMaterialItems>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IBillOfMaterialItems : public IUDOChildBean^,
   public IEnumerable<IBillOfMaterialItems^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_BOM1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems Members

IBillOfMaterialItems Interface Methods Properties See Also

Items for bill of material object

The following tables list the members exposed by the IBillOfMaterialItems type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_ItemName | Gets the item name.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BatchResult | Batch Result based on specific formula used in Costing read-only
Public property | U_Currency | Item's Currency
Public property | U_Description | Item's Description
Public property | U_Factor | Item's Factor
Public property | U_FactorDescription | Item's Factor's Description
Public property | U_Formula | Item's Formula to calculate result
Public property | U_InventoryUoM | Item's Unit of measure
Public property | U_IssueType | Item's Issue Type
Public property | U_ItemCode | Item's ItemCode
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OccrCode | Distribution Rule or Cost Centre code
Public property | U_OcrCode | Item's Distribution Rule or Cost Centre code in Dimension 1
Public property | U_OcrCode2 | Item's Distribution Rule or Cost Centre code in Dimension 2
Public property | U_OcrCode3 | Item's Distribution Rule or Cost Centre code in Dimension 3
Public property | U_OcrCode4 | Item's Distribution Rule or Cost Centre code in Dimension 4
Public property | U_OcrCode5 | Item's Distribution Rule or Cost Centre code in Dimension 3
Public property | U_Price | Item's Price
Public property | U_PriceList | Item's Price List
Public property | U_Project | Item's Project code
Public property | U_Quantity | Item's Quantity
Public property | U_Remarks | Item's Remarks
Public property | U_Result | Item's Result based on specific formula
Public property | U_Revision |
Public property | U_ScrapPercentage | Item's Percentage of Scraps
Public property | U_Sequence | Item's Sequence number
Public property | U_SubRecepitItem | Item name
Public property | U_WhsCode | Item's Warehouse Code
Public property | U_Yield |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialItems Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems Properties

IBillOfMaterialItems Interface See Also

The following tables list the members exposed by the IBillOfMaterialItems type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_ItemName | Gets the item name.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BatchResult | Batch Result based on specific formula used in Costing read-only
Public property | U_Currency | Item's Currency
Public property | U_Description | Item's Description
Public property | U_Factor | Item's Factor
Public property | U_FactorDescription | Item's Factor's Description
Public property | U_Formula | Item's Formula to calculate result
Public property | U_InventoryUoM | Item's Unit of measure
Public property | U_IssueType | Item's Issue Type
Public property | U_ItemCode | Item's ItemCode
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OccrCode | Distribution Rule or Cost Centre code
Public property | U_OcrCode | Item's Distribution Rule or Cost Centre code in Dimension 1
Public property | U_OcrCode2 | Item's Distribution Rule or Cost Centre code in Dimension 2
Public property | U_OcrCode3 | Item's Distribution Rule or Cost Centre code in Dimension 3
Public property | U_OcrCode4 | Item's Distribution Rule or Cost Centre code in Dimension 4
Public property | U_OcrCode5 | Item's Distribution Rule or Cost Centre code in Dimension 3
Public property | U_Price | Item's Price
Public property | U_PriceList | Item's Price List
Public property | U_Project | Item's Project code
Public property | U_Quantity | Item's Quantity
Public property | U_Remarks | Item's Remarks
Public property | U_Result | Item's Result based on specific formula
Public property | U_Revision |
Public property | U_ScrapPercentage | Item's Percentage of Scraps
Public property | U_Sequence | Item's Sequence number
Public property | U_SubRecepitItem | Item name
Public property | U_WhsCode | Item's Warehouse Code
Public property | U_Yield |
Top
See Also

Reference

IBillOfMaterialItems Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.DS_ItemName Property

Gets the item name.

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property DS_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
string DS_ItemName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property String^ DS_ItemName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get DS_ItemName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_BatchResult Property

Batch Result based on specific formula used in Costing read-only

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BatchResult() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_BatchResult {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_BatchResult {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchResult() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_Currency Property

Item's Currency

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Currency() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Currency {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Currency {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Currency() : String;
function set U_Currency(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_Description Property

Item's Description

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Description() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Description {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Description {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Description() : String;
function set U_Description(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_Factor Property

Item's Factor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Factor() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Factor {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Factor {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Factor() : double;
function set U_Factor(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_FactorDescription Property

Item's Factor's Description

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FactorDescription() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FactorDescription {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FactorDescription {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FactorDescription() : String;
function set U_FactorDescription(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_Formula Property

Item's Formula to calculate result

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Formula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Formula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Formula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Formula() : String;
function set U_Formula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_InventoryUoM Property

Item's Unit of measure

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InventoryUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InventoryUoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InventoryUoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InventoryUoM() : String;
function set U_InventoryUoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_IssueType Property

Item's Issue Type

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IssueType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_IssueType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_IssueType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IssueType() : String;
function set U_IssueType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_ItemCode Property

Item's ItemCode

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2)> _
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2)
function get U_ItemCode() : String;

   AppEngineProperty(Priority = 2)
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_OccrCode Property

Distribution Rule or Cost Centre code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OccrCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OccrCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OccrCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OccrCode() : String;
function set U_OccrCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_OcrCode Property

Item's Distribution Rule or Cost Centre code in Dimension 1

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode() : String;
function set U_OcrCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_OcrCode2 Property

Item's Distribution Rule or Cost Centre code in Dimension 2

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode2() : String;
function set U_OcrCode2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_OcrCode3 Property

Item's Distribution Rule or Cost Centre code in Dimension 3

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode3() : String;
function set U_OcrCode3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_OcrCode4 Property

Item's Distribution Rule or Cost Centre code in Dimension 4

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode4() : String;
function set U_OcrCode4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_OcrCode5 Property

Item's Distribution Rule or Cost Centre code in Dimension 3

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode5() : String;
function set U_OcrCode5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_Price Property

Item's Price

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Price() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Price {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Price {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Price() : double;
function set U_Price(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_PriceList Property

Item's Price List

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PriceList() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_PriceList {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_PriceList {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PriceList() : int;
function set U_PriceList(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_Project Property

Item's Project code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Project() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Project {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Project {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Project() : String;
function set U_Project(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_Quantity Property

Item's Quantity

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Autogenerate = true)> _
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Autogenerate = true)]
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Autogenerate = true)]

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Autogenerate = true)
function get U_Quantity() : double;

   AppEngineProperty(Autogenerate = true)
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_Remarks Property

Item's Remarks

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_Result Property

Item's Result based on specific formula

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Result() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Result {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Result {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Result() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_Revision Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 3)> _
Property U_Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3)]
string U_Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3)]

property String^ U_Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 3)
function get U_Revision() : String;

   AppEngineProperty(Priority = 3)
function set U_Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_ScrapPercentage Property

Item's Percentage of Scraps

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ScrapPercentage() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ScrapPercentage {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ScrapPercentage {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ScrapPercentage() : double;
function set U_ScrapPercentage(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_Sequence Property

Item's Sequence number

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Sequence() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_Sequence {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_Sequence {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Sequence() : int;
function set U_Sequence(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_SubRecepitItem Property

Item name

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SubRecepitItem() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_SubRecepitItem {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_SubRecepitItem {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SubRecepitItem() : YesNoType;
function set U_SubRecepitItem(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_WhsCode Property

Item's Warehouse Code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Autogenerate = true)> _
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Autogenerate = true)]
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Autogenerate = true)]

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Autogenerate = true)
function get U_WhsCode() : String;

   AppEngineProperty(Autogenerate = true)
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems.U_Yield Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Autogenerate = true)> _
Property U_Yield() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Autogenerate = true)]
double U_Yield {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Autogenerate = true)]

property double U_Yield {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Autogenerate = true)
function get U_Yield() : double;

   AppEngineProperty(Autogenerate = true)
function set U_Yield(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialItems Interface
IBillOfMaterialItems Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialItems Methods

IBillOfMaterialItems Interface See Also

The following tables list the members exposed by the IBillOfMaterialItems type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialItems Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms Interface

Members See Also

Phantoms for bill of material object

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IBillOfMaterialPhantoms
    Inherits IUDOChildBean, _
             IEnumerable(Of IBillOfMaterialPhantoms)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IBillOfMaterialPhantoms : IUDOChildBean,
   IEnumerable<IBillOfMaterialPhantoms>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IBillOfMaterialPhantoms : public IUDOChildBean^,
   public IEnumerable<IBillOfMaterialPhantoms^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_BOM5
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialPhantoms Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms Members

IBillOfMaterialPhantoms Interface Methods Properties See Also

Phantoms for bill of material object

The following tables list the members exposed by the IBillOfMaterialPhantoms type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_ItemName | Gets the item name.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | RevisionName | // Phantom's Item Name //
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BatchResult | Batch Result based on specific formula used in Costing read-only
Public property | U_Description | Phantom's Description
Public property | U_Factor | Phantom's Factor
Public property | U_FactorDescription | Phantom's Factor's Description
Public property | U_Formula | Phantom's Formula to calculate result
Public property | U_InventoryUoM | Item's Unit of measure
Public property | U_ItemCode | Phantom's ItemCode
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Quantity | Phantom's Quantity
Public property | U_Remarks | Phantom's Remarks
Public property | U_Result | Phantom's Result based on specific formula
Public property | U_Revision |
Public property | U_Sequence | Phantom's Sequence number
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialPhantoms Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms Properties

IBillOfMaterialPhantoms Interface See Also

The following tables list the members exposed by the IBillOfMaterialPhantoms type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_ItemName | Gets the item name.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | RevisionName | // Phantom's Item Name //
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BatchResult | Batch Result based on specific formula used in Costing read-only
Public property | U_Description | Phantom's Description
Public property | U_Factor | Phantom's Factor
Public property | U_FactorDescription | Phantom's Factor's Description
Public property | U_Formula | Phantom's Formula to calculate result
Public property | U_InventoryUoM | Item's Unit of measure
Public property | U_ItemCode | Phantom's ItemCode
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Quantity | Phantom's Quantity
Public property | U_Remarks | Phantom's Remarks
Public property | U_Result | Phantom's Result based on specific formula
Public property | U_Revision |
Public property | U_Sequence | Phantom's Sequence number
Top
See Also

Reference

IBillOfMaterialPhantoms Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialPhantoms Interface
IBillOfMaterialPhantoms Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms.DS_ItemName Property

Gets the item name.

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property DS_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
string DS_ItemName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property String^ DS_ItemName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get DS_ItemName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialPhantoms Interface
IBillOfMaterialPhantoms Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialPhantoms Interface
IBillOfMaterialPhantoms Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialPhantoms Interface
IBillOfMaterialPhantoms Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialPhantoms Interface
IBillOfMaterialPhantoms Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms.RevisionName Property

// Phantom's Item Name //

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property RevisionName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string RevisionName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ RevisionName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get RevisionName() : String;

   AppEnginePropertyIgnore()
function set RevisionName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialPhantoms Interface
IBillOfMaterialPhantoms Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms.U_BatchResult Property

Batch Result based on specific formula used in Costing read-only

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BatchResult() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_BatchResult {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_BatchResult {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchResult() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialPhantoms Interface
IBillOfMaterialPhantoms Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms.U_Description Property

Phantom's Description

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Description() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Description {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Description {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Description() : String;
function set U_Description(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialPhantoms Interface
IBillOfMaterialPhantoms Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms.U_Factor Property

Phantom's Factor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Factor() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Factor {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Factor {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Factor() : double;
function set U_Factor(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialPhantoms Interface
IBillOfMaterialPhantoms Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms.U_FactorDescription Property

Phantom's Factor's Description

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FactorDescription() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FactorDescription {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FactorDescription {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FactorDescription() : String;
function set U_FactorDescription(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialPhantoms Interface
IBillOfMaterialPhantoms Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms.U_Formula Property

Phantom's Formula to calculate result

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Formula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Formula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Formula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Formula() : String;
function set U_Formula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialPhantoms Interface
IBillOfMaterialPhantoms Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms.U_InventoryUoM Property

Item's Unit of measure

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InventoryUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InventoryUoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InventoryUoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InventoryUoM() : String;
function set U_InventoryUoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialPhantoms Interface
IBillOfMaterialPhantoms Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms.U_ItemCode Property

Phantom's ItemCode

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2)> _
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2)
function get U_ItemCode() : String;

   AppEngineProperty(Priority = 2)
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialPhantoms Interface
IBillOfMaterialPhantoms Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms.U_Quantity Property

Phantom's Quantity

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialPhantoms Interface
IBillOfMaterialPhantoms Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms.U_Remarks Property

Phantom's Remarks

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialPhantoms Interface
IBillOfMaterialPhantoms Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms.U_Result Property

Phantom's Result based on specific formula

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Result() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Result {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Result {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Result() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialPhantoms Interface
IBillOfMaterialPhantoms Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms.U_Revision Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property U_Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string U_Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ U_Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_Revision() : String;

   AppEnginePropertyIgnore()
function set U_Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialPhantoms Interface
IBillOfMaterialPhantoms Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms.U_Sequence Property

Phantom's Sequence number

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Sequence() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_Sequence {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_Sequence {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Sequence() : int;
function set U_Sequence(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialPhantoms Interface
IBillOfMaterialPhantoms Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialPhantoms Methods

IBillOfMaterialPhantoms Interface See Also

The following tables list the members exposed by the IBillOfMaterialPhantoms type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialPhantoms Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRouting Interface

Members See Also

Routings for bill of material object

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IBillOfMaterialRouting
    Inherits IUDOChildBean, _
             IEnumerable(Of IBillOfMaterialRouting)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IBillOfMaterialRouting : IUDOChildBean,
   IEnumerable<IBillOfMaterialRouting>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IBillOfMaterialRouting : public IUDOChildBean^,
   public IEnumerable<IBillOfMaterialRouting^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_BOM11
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRouting Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRouting Members

IBillOfMaterialRouting Interface Methods Properties See Also

Routings for bill of material object

The following tables list the members exposed by the IBillOfMaterialRouting type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | RtgNameDS | Routing Name
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BomCode | Bom Code ( Key)
Public property | U_IsDefault | Y,N Is this routing is default, Only One routing can be set as default
Public property | U_IsRollUpDefault | Determines if routing is used as default during the roll-up process for bill of materials that are semi-goods for a finished-good bill of materials.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_NextRtgOprCode |
Public property | U_RevCode | Revision Code (Key)
Public property | U_RtgCode | Routing Code (key)
Public property | U_TechInstructions |
Public property | U_ValidF |
Public property | U_ValidT |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialRouting Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRouting Properties

IBillOfMaterialRouting Interface See Also

The following tables list the members exposed by the IBillOfMaterialRouting type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | RtgNameDS | Routing Name
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BomCode | Bom Code ( Key)
Public property | U_IsDefault | Y,N Is this routing is default, Only One routing can be set as default
Public property | U_IsRollUpDefault | Determines if routing is used as default during the roll-up process for bill of materials that are semi-goods for a finished-good bill of materials.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_NextRtgOprCode |
Public property | U_RevCode | Revision Code (Key)
Public property | U_RtgCode | Routing Code (key)
Public property | U_TechInstructions |
Public property | U_ValidF |
Public property | U_ValidT |
Top
See Also

Reference

IBillOfMaterialRouting Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRouting.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRouting Interface
IBillOfMaterialRouting Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRouting.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRouting Interface
IBillOfMaterialRouting Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRouting.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRouting Interface
IBillOfMaterialRouting Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRouting.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRouting Interface
IBillOfMaterialRouting Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRouting.RtgNameDS Property

Routing Name

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RtgNameDS() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string RtgNameDS {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ RtgNameDS {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RtgNameDS() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRouting Interface
IBillOfMaterialRouting Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRouting.U_BomCode Property

Bom Code ( Key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property U_BomCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string U_BomCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ U_BomCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_BomCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRouting Interface
IBillOfMaterialRouting Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRouting.U_IsDefault Property

Y,N Is this routing is default, Only One routing can be set as default

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IsDefault() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_IsDefault {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_IsDefault {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IsDefault() : String;
function set U_IsDefault(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRouting Interface
IBillOfMaterialRouting Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRouting.U_IsRollUpDefault Property

Determines if routing is used as default during the roll-up process for bill of materials that are semi-goods for a finished-good bill of materials.

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IsRollUpDefault() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_IsRollUpDefault {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_IsRollUpDefault {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IsRollUpDefault() : String;
function set U_IsRollUpDefault(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRouting Interface
IBillOfMaterialRouting Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRouting.U_NextRtgOprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_NextRtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_NextRtgOprCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_NextRtgOprCode {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_NextRtgOprCode() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRouting Interface
IBillOfMaterialRouting Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRouting.U_RevCode Property

Revision Code (Key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string U_RevCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ U_RevCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_RevCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRouting Interface
IBillOfMaterialRouting Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRouting.U_RtgCode Property

Routing Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RtgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RtgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgCode() : String;
function set U_RtgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRouting Interface
IBillOfMaterialRouting Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRouting.U_TechInstructions Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TechInstructions() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TechInstructions {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TechInstructions {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TechInstructions() : String;
function set U_TechInstructions(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRouting Interface
IBillOfMaterialRouting Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRouting.U_ValidF Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidF() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidF {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidF {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidF() : DateTime;
function set U_ValidF(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRouting Interface
IBillOfMaterialRouting Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRouting.U_ValidT Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidT() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidT {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidT {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidT() : DateTime;
function set U_ValidT(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRouting Interface
IBillOfMaterialRouting Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRouting Methods

IBillOfMaterialRouting Interface See Also

The following tables list the members exposed by the IBillOfMaterialRouting type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialRouting Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutput Interface

Members See Also

Input output for routing operations for bill of material object

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean(Parent = "IBillOfMaterialRoutingOperations")> _
Public Interface IBillOfMaterialRoutingOperationInputOutput
    Inherits IUDOChildBean, _
             IEnumerable(Of IBillOfMaterialRoutingOperationInputOutput)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IBillOfMaterialRoutingOperations")]
public interface IBillOfMaterialRoutingOperationInputOutput : IUDOChildBean,
   IEnumerable<IBillOfMaterialRoutingOperationInputOutput>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IBillOfMaterialRoutingOperations")]
public interface class IBillOfMaterialRoutingOperationInputOutput : public IUDOChildBean^,
   public IEnumerable<IBillOfMaterialRoutingOperationInputOutput^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_BOM14
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutput Members

IBillOfMaterialRoutingOperationInputOutput Interface Methods Properties See Also

Input output for routing operations for bill of material object

The following tables list the members exposed by the IBillOfMaterialRoutingOperationInputOutput type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine | U_LineNum of selected Item
Public property | U_BomCode | BOM Code (key)
Public property | U_Direction | Direction In Or Out
Public property | U_IOOprCode | Key for this InputOutput binding
Public property | U_InTimeCalc | This filed fetermines if time calculation form operation us took from current Operation Only One I/O item can be selected for each operation. If there is no selected I/O Item Quantity Form header is took.
Public property | U_ItemCode | Item Code
Public property | U_ItemType | Scrap Item Coproduct Item ot Items
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OprCode | Operation Code
Public property | U_RevCode | Revision Code (key)
Public property | U_RtgCode | Routing Code (key)
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Object belongs to concreat operation
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialRoutingOperationInputOutput Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutput Properties

IBillOfMaterialRoutingOperationInputOutput Interface See Also

The following tables list the members exposed by the IBillOfMaterialRoutingOperationInputOutput type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine | U_LineNum of selected Item
Public property | U_BomCode | BOM Code (key)
Public property | U_Direction | Direction In Or Out
Public property | U_IOOprCode | Key for this InputOutput binding
Public property | U_InTimeCalc | This filed fetermines if time calculation form operation us took from current Operation Only One I/O item can be selected for each operation. If there is no selected I/O Item Quantity Form header is took.
Public property | U_ItemCode | Item Code
Public property | U_ItemType | Scrap Item Coproduct Item ot Items
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OprCode | Operation Code
Public property | U_RevCode | Revision Code (key)
Public property | U_RtgCode | Routing Code (key)
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Object belongs to concreat operation
Top
See Also

Reference

IBillOfMaterialRoutingOperationInputOutput Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutput.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutput Interface
IBillOfMaterialRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutput.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutput Interface
IBillOfMaterialRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutput.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutput Interface
IBillOfMaterialRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutput.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutput Interface
IBillOfMaterialRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutput.U_BaseLine Property

U_LineNum of selected Item

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 7)> _
Property U_BaseLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 7)]
int U_BaseLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 7)]

property int U_BaseLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 7)
function get U_BaseLine() : int;

   AppEngineProperty(Priority = 7)
function set U_BaseLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutput Interface
IBillOfMaterialRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutput.U_BomCode Property

BOM Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property U_BomCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string U_BomCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ U_BomCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_BomCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutput Interface
IBillOfMaterialRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutput.U_Direction Property

Direction In Or Out

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Direction() As ItemDirection
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ItemDirection U_Direction {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ItemDirection U_Direction {
 ItemDirection get( );
 void set(
   ItemDirection value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Direction() : ItemDirection;
function set U_Direction(value : ItemDirection);
This language is not supported or no code example is available.

Property Value

Type: ItemDirection
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutput Interface
IBillOfMaterialRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutput.U_IOOprCode Property

Key for this InputOutput binding

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 5)> _
ReadOnly Property U_IOOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 5)]
int U_IOOprCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 5)]

property int U_IOOprCode {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 5)
function get U_IOOprCode() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutput Interface
IBillOfMaterialRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutput.U_InTimeCalc Property

This filed fetermines if time calculation form operation us took from current Operation Only One I/O item can be selected for each operation. If there is no selected I/O Item Quantity Form header is took.

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InTimeCalc() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_InTimeCalc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_InTimeCalc {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InTimeCalc() : YesNoType;
function set U_InTimeCalc(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutput Interface
IBillOfMaterialRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutput.U_ItemCode Property

Item Code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 6)> _
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 6)]
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 6)]

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 6)
function get U_ItemCode() : String;

   AppEngineProperty(Priority = 6)
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutput Interface
IBillOfMaterialRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutput.U_ItemType Property

Scrap Item Coproduct Item ot Items

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 6)> _
Property U_ItemType() As ManufacturingComponentType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 6)]
ManufacturingComponentType U_ItemType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 6)]

property ManufacturingComponentType U_ItemType {
 ManufacturingComponentType get( );
 void set(
   ManufacturingComponentType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 6)
function get U_ItemType() : ManufacturingComponentType;

   AppEngineProperty(Priority = 6)
function set U_ItemType(value : ManufacturingComponentType);
This language is not supported or no code example is available.

Property Value

Type: ManufacturingComponentType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutput Interface
IBillOfMaterialRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutput.U_OprCode Property

Operation Code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 4,ParentKey = "U_OprCode")> _
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4,ParentKey = "U_OprCode")]
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4,ParentKey = "U_OprCode")]

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 4,ParentKey = "U_OprCode")
function get U_OprCode() : String;

   AppEngineProperty(Priority = 4,ParentKey = "U_OprCode")
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutput Interface
IBillOfMaterialRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutput.U_RevCode Property

Revision Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string U_RevCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ U_RevCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_RevCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutput Interface
IBillOfMaterialRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutput.U_RtgCode Property

Routing Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")> _
Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")]
string U_RtgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")]

property String^ U_RtgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")
function get U_RtgCode() : String;

   AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")
function set U_RtgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutput Interface
IBillOfMaterialRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutput.U_RtgOprCode Property

Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Object belongs to concreat operation

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 3,ParentKey = "U_RtgOprCode")> _
Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3,ParentKey = "U_RtgOprCode")]
int U_RtgOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3,ParentKey = "U_RtgOprCode")]

property int U_RtgOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 3,ParentKey = "U_RtgOprCode")
function get U_RtgOprCode() : int;

   AppEngineProperty(Priority = 3,ParentKey = "U_RtgOprCode")
function set U_RtgOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutput Interface
IBillOfMaterialRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutput Methods

IBillOfMaterialRoutingOperationInputOutput Interface See Also

The following tables list the members exposed by the IBillOfMaterialRoutingOperationInputOutput type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialRoutingOperationInputOutput Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties Interface

Members See Also

Input output properties for routing operations for bill of material object

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean(Parent = "IBillOfMaterialRoutingOperationInputOutput")> _
Public Interface IBillOfMaterialRoutingOperationInputOutputProperties
    Inherits IUDOChildBean, _
             IEnumerable(Of IBillOfMaterialRoutingOperationInputOutputProperties)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IBillOfMaterialRoutingOperationInputOutput")]
public interface IBillOfMaterialRoutingOperationInputOutputProperties : IUDOChildBean,
   IEnumerable<IBillOfMaterialRoutingOperationInputOutputProperties>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IBillOfMaterialRoutingOperationInputOutput")]
public interface class IBillOfMaterialRoutingOperationInputOutputProperties : public IUDOChildBean^,
   public IEnumerable<IBillOfMaterialRoutingOperationInputOutputProperties^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_BOM15
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties Members

IBillOfMaterialRoutingOperationInputOutputProperties Interface Methods Properties See Also

Input output properties for routing operations for bill of material object

The following tables list the members exposed by the IBillOfMaterialRoutingOperationInputOutputProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BomCode | BOM Code (key)
Public property | U_IOOprCode | Input Output Operation Code key for specific I/O binding
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OprCode | Operation code
Public property | U_PrpCode | I/O PropertyCode
Public property | U_PrpConType | Type of value
Public property | U_PrpConValue | Property Value
Public property | U_PrpConValueTo | Property Value To...
Public property | U_Remarks | Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RtgCode | Routing Code {key
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Object belongs to concreat operation
Public property | U_UnitOfMeasure | Unit Of Measure
Public property | U_WordCode | Word code
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties Properties

IBillOfMaterialRoutingOperationInputOutputProperties Interface See Also

The following tables list the members exposed by the IBillOfMaterialRoutingOperationInputOutputProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BomCode | BOM Code (key)
Public property | U_IOOprCode | Input Output Operation Code key for specific I/O binding
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OprCode | Operation code
Public property | U_PrpCode | I/O PropertyCode
Public property | U_PrpConType | Type of value
Public property | U_PrpConValue | Property Value
Public property | U_PrpConValueTo | Property Value To...
Public property | U_Remarks | Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RtgCode | Routing Code {key
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Object belongs to concreat operation
Public property | U_UnitOfMeasure | Unit Of Measure
Public property | U_WordCode | Word code
Top
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
IBillOfMaterialRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
IBillOfMaterialRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
IBillOfMaterialRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
IBillOfMaterialRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties.U_BomCode Property

BOM Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property U_BomCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string U_BomCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ U_BomCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_BomCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
IBillOfMaterialRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties.U_IOOprCode Property

Input Output Operation Code key for specific I/O binding

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 5,ParentKey = "U_IOOprCode")> _
Property U_IOOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 5,ParentKey = "U_IOOprCode")]
int U_IOOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 5,ParentKey = "U_IOOprCode")]

property int U_IOOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 5,ParentKey = "U_IOOprCode")
function get U_IOOprCode() : int;

   AppEngineProperty(Priority = 5,ParentKey = "U_IOOprCode")
function set U_IOOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
IBillOfMaterialRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties.U_OprCode Property

Operation code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprCode() : String;
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
IBillOfMaterialRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties.U_PrpCode Property

I/O PropertyCode

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 6)> _
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 6)]
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 6)]

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 6)
function get U_PrpCode() : String;

   AppEngineProperty(Priority = 6)
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
IBillOfMaterialRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties.U_PrpConType Property

Type of value

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConType() As ConditionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ConditionType U_PrpConType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ConditionType U_PrpConType {
 ConditionType get( );
 void set(
   ConditionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConType() : ConditionType;
function set U_PrpConType(value : ConditionType);
This language is not supported or no code example is available.

Property Value

Type: ConditionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
IBillOfMaterialRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties.U_PrpConValue Property

Property Value

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValue() : double;
function set U_PrpConValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
IBillOfMaterialRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties.U_PrpConValueTo Property

Property Value To...

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValueTo() : double;
function set U_PrpConValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
IBillOfMaterialRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties.U_Remarks Property

Remarks

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
IBillOfMaterialRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties.U_RevCode Property

Revision Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string U_RevCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ U_RevCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_RevCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
IBillOfMaterialRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties.U_RtgCode Property

Routing Code {key

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")> _
Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")]
string U_RtgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")]

property String^ U_RtgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")
function get U_RtgCode() : String;

   AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")
function set U_RtgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
IBillOfMaterialRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties.U_RtgOprCode Property

Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Object belongs to concreat operation

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")> _
Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")]
int U_RtgOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")]

property int U_RtgOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")
function get U_RtgOprCode() : int;

   AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")
function set U_RtgOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
IBillOfMaterialRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties.U_UnitOfMeasure Property

Unit Of Measure

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UnitOfMeasure {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UnitOfMeasure {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UnitOfMeasure() : String;
function set U_UnitOfMeasure(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
IBillOfMaterialRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties.U_WordCode Property

Word code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
IBillOfMaterialRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationInputOutputProperties Methods

IBillOfMaterialRoutingOperationInputOutputProperties Interface See Also

The following tables list the members exposed by the IBillOfMaterialRoutingOperationInputOutputProperties type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialRoutingOperationInputOutputProperties Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties Interface

Members See Also

Properties of routing operations for bill of material object

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean(Parent = "IBillOfMaterialRoutingOperations")> _
Public Interface IBillOfMaterialRoutingOperationProperties
    Inherits IUDOChildBean, _
             IEnumerable(Of IBillOfMaterialRoutingOperationProperties)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IBillOfMaterialRoutingOperations")]
public interface IBillOfMaterialRoutingOperationProperties : IUDOChildBean,
   IEnumerable<IBillOfMaterialRoutingOperationProperties>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IBillOfMaterialRoutingOperations")]
public interface class IBillOfMaterialRoutingOperationProperties : public IUDOChildBean^,
   public IEnumerable<IBillOfMaterialRoutingOperationProperties^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_BOM13
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties Members

IBillOfMaterialRoutingOperationProperties Interface Methods Properties See Also

Properties of routing operations for bill of material object

The following tables list the members exposed by the IBillOfMaterialRoutingOperationProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BomCode | Bom Code (key)
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OprCode | Operation Code(key) -Mandatory
Public property | U_PrpCode | Property Code (key) -Mandatory
Public property | U_PrpConType | Type of Property
Public property | U_PrpConValue | Value Of Property
Public property | U_PrpConValueTo | VAlue To of Property
Public property | U_Remarks | Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RtgCode | Routing Code(key) -Mandatory
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that ThisObject belongs to concreat operation -Mandatory
Public property | U_UnitOfMeasure | Unit Of measure
Public property | U_WordCode | Word code
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialRoutingOperationProperties Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties Properties

IBillOfMaterialRoutingOperationProperties Interface See Also

The following tables list the members exposed by the IBillOfMaterialRoutingOperationProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BomCode | Bom Code (key)
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OprCode | Operation Code(key) -Mandatory
Public property | U_PrpCode | Property Code (key) -Mandatory
Public property | U_PrpConType | Type of Property
Public property | U_PrpConValue | Value Of Property
Public property | U_PrpConValueTo | VAlue To of Property
Public property | U_Remarks | Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RtgCode | Routing Code(key) -Mandatory
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that ThisObject belongs to concreat operation -Mandatory
Public property | U_UnitOfMeasure | Unit Of measure
Public property | U_WordCode | Word code
Top
See Also

Reference

IBillOfMaterialRoutingOperationProperties Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationProperties Interface
IBillOfMaterialRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationProperties Interface
IBillOfMaterialRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationProperties Interface
IBillOfMaterialRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationProperties Interface
IBillOfMaterialRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties.U_BomCode Property

Bom Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property U_BomCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string U_BomCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ U_BomCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_BomCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationProperties Interface
IBillOfMaterialRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties.U_OprCode Property

Operation Code(key) -Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprCode() : String;
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationProperties Interface
IBillOfMaterialRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties.U_PrpCode Property

Property Code (key) -Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 5)> _
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 5)]
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 5)]

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 5)
function get U_PrpCode() : String;

   AppEngineProperty(Priority = 5)
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationProperties Interface
IBillOfMaterialRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties.U_PrpConType Property

Type of Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConType() As ConditionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ConditionType U_PrpConType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ConditionType U_PrpConType {
 ConditionType get( );
 void set(
   ConditionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConType() : ConditionType;
function set U_PrpConType(value : ConditionType);
This language is not supported or no code example is available.

Property Value

Type: ConditionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationProperties Interface
IBillOfMaterialRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties.U_PrpConValue Property

Value Of Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValue() : double;
function set U_PrpConValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationProperties Interface
IBillOfMaterialRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties.U_PrpConValueTo Property

VAlue To of Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValueTo() : double;
function set U_PrpConValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationProperties Interface
IBillOfMaterialRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties.U_Remarks Property

Remarks

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationProperties Interface
IBillOfMaterialRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties.U_RevCode Property

Revision Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string U_RevCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ U_RevCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_RevCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationProperties Interface
IBillOfMaterialRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties.U_RtgCode Property

Routing Code(key) -Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")> _
Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")]
string U_RtgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")]

property String^ U_RtgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")
function get U_RtgCode() : String;

   AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")
function set U_RtgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationProperties Interface
IBillOfMaterialRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties.U_RtgOprCode Property

Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that ThisObject belongs to concreat operation -Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 3,ParentKey = "U_RtgOprCode")> _
Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3,ParentKey = "U_RtgOprCode")]
int U_RtgOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3,ParentKey = "U_RtgOprCode")]

property int U_RtgOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 3,ParentKey = "U_RtgOprCode")
function get U_RtgOprCode() : int;

   AppEngineProperty(Priority = 3,ParentKey = "U_RtgOprCode")
function set U_RtgOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationProperties Interface
IBillOfMaterialRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties.U_UnitOfMeasure Property

Unit Of measure

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UnitOfMeasure {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UnitOfMeasure {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UnitOfMeasure() : String;
function set U_UnitOfMeasure(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationProperties Interface
IBillOfMaterialRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties.U_WordCode Property

Word code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationProperties Interface
IBillOfMaterialRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationProperties Methods

IBillOfMaterialRoutingOperationProperties Interface See Also

The following tables list the members exposed by the IBillOfMaterialRoutingOperationProperties type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialRoutingOperationProperties Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationRelations Interface

Members See Also

Relations for routing operations for bill of material object

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IBillOfMaterialRoutingOperationRelations
    Inherits IUDOChildBean, _
             IEnumerable(Of IBillOfMaterialRoutingOperationRelations)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IBillOfMaterialRoutingOperationRelations : IUDOChildBean,
   IEnumerable<IBillOfMaterialRoutingOperationRelations>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IBillOfMaterialRoutingOperationRelations : public IUDOChildBean^,
   public IEnumerable<IBillOfMaterialRoutingOperationRelations^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_BOM20
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationRelations Members

IBillOfMaterialRoutingOperationRelations Interface Methods Properties See Also

Relations for routing operations for bill of material object

The following tables list the members exposed by the IBillOfMaterialRoutingOperationRelations type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine | Reference to U_LineNum Operation for witch we want to define predacessors
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_POprLine | Reference to Operation U_LineNUm witch is predacessor
Public property | U_RtgCode | Routing Code (key)
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialRoutingOperationRelations Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationRelations Properties

IBillOfMaterialRoutingOperationRelations Interface See Also

The following tables list the members exposed by the IBillOfMaterialRoutingOperationRelations type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine | Reference to U_LineNum Operation for witch we want to define predacessors
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_POprLine | Reference to Operation U_LineNUm witch is predacessor
Public property | U_RtgCode | Routing Code (key)
Top
See Also

Reference

IBillOfMaterialRoutingOperationRelations Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationRelations.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationRelations Interface
IBillOfMaterialRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationRelations.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationRelations Interface
IBillOfMaterialRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationRelations.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationRelations Interface
IBillOfMaterialRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationRelations.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationRelations Interface
IBillOfMaterialRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationRelations.U_BaseLine Property

Reference to U_LineNum Operation for witch we want to define predacessors

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 3)> _
Property U_BaseLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3)]
int U_BaseLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3)]

property int U_BaseLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 3)
function get U_BaseLine() : int;

   AppEngineProperty(Priority = 3)
function set U_BaseLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationRelations Interface
IBillOfMaterialRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationRelations.U_POprLine Property

Reference to Operation U_LineNUm witch is predacessor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 4)> _
Property U_POprLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4)]
int U_POprLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4)]

property int U_POprLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 4)
function get U_POprLine() : int;

   AppEngineProperty(Priority = 4)
function set U_POprLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationRelations Interface
IBillOfMaterialRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationRelations.U_RtgCode Property

Routing Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2)> _
Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]
string U_RtgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]

property String^ U_RtgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2)
function get U_RtgCode() : String;

   AppEngineProperty(Priority = 2)
function set U_RtgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationRelations Interface
IBillOfMaterialRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationRelations Methods

IBillOfMaterialRoutingOperationRelations Interface See Also

The following tables list the members exposed by the IBillOfMaterialRoutingOperationRelations type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialRoutingOperationRelations Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties Interface

Members See Also

Resource properties for routing operations for bill of material object

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean(Parent = "IBillOfMaterialRoutingOperationResources")> _
Public Interface IBillOfMaterialRoutingOperationResourceProperties
    Inherits IUDOChildBean, _
             IEnumerable(Of IBillOfMaterialRoutingOperationResourceProperties)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IBillOfMaterialRoutingOperationResources")]
public interface IBillOfMaterialRoutingOperationResourceProperties : IUDOChildBean,
   IEnumerable<IBillOfMaterialRoutingOperationResourceProperties>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IBillOfMaterialRoutingOperationResources")]
public interface class IBillOfMaterialRoutingOperationResourceProperties : public IUDOChildBean^,
   public IEnumerable<IBillOfMaterialRoutingOperationResourceProperties^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_BOM17
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties Members

IBillOfMaterialRoutingOperationResourceProperties Interface Methods Properties See Also

Resource properties for routing operations for bill of material object

The following tables list the members exposed by the IBillOfMaterialRoutingOperationResourceProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BomCode | BOM Code (key)
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OprCode | Operation Code (key)
Public property | U_PrpCode | Property Code
Public property | U_PrpConType | Property Type
Public property | U_PrpConValue | Property value
Public property | U_PrpConValueTo | Property Value To..
Public property | U_Remarks | Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RtOpRscCode | Routin Operation Resource ID (key for specific Resource in specific Operation ) must be filled It tels us that This Object belongs to concreat Resource
Public property | U_RtgCode | Routing Code (key)
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Object belongs to concreat operation
Public property | U_UnitOfMeasure | Unit Of Measure
Public property | U_WordCode | Word code
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties Properties

IBillOfMaterialRoutingOperationResourceProperties Interface See Also

The following tables list the members exposed by the IBillOfMaterialRoutingOperationResourceProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BomCode | BOM Code (key)
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OprCode | Operation Code (key)
Public property | U_PrpCode | Property Code
Public property | U_PrpConType | Property Type
Public property | U_PrpConValue | Property value
Public property | U_PrpConValueTo | Property Value To..
Public property | U_Remarks | Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RtOpRscCode | Routin Operation Resource ID (key for specific Resource in specific Operation ) must be filled It tels us that This Object belongs to concreat Resource
Public property | U_RtgCode | Routing Code (key)
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Object belongs to concreat operation
Public property | U_UnitOfMeasure | Unit Of Measure
Public property | U_WordCode | Word code
Top
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
IBillOfMaterialRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
IBillOfMaterialRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
IBillOfMaterialRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
IBillOfMaterialRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties.U_BomCode Property

BOM Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property U_BomCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string U_BomCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ U_BomCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_BomCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
IBillOfMaterialRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties.U_OprCode Property

Operation Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprCode() : String;
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
IBillOfMaterialRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties.U_PrpCode Property

Property Code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 6)> _
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 6)]
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 6)]

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 6)
function get U_PrpCode() : String;

   AppEngineProperty(Priority = 6)
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
IBillOfMaterialRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties.U_PrpConType Property

Property Type

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConType() As ConditionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ConditionType U_PrpConType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ConditionType U_PrpConType {
 ConditionType get( );
 void set(
   ConditionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConType() : ConditionType;
function set U_PrpConType(value : ConditionType);
This language is not supported or no code example is available.

Property Value

Type: ConditionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
IBillOfMaterialRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties.U_PrpConValue Property

Property value

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValue() : double;
function set U_PrpConValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
IBillOfMaterialRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties.U_PrpConValueTo Property

Property Value To..

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValueTo() : double;
function set U_PrpConValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
IBillOfMaterialRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties.U_Remarks Property

Remarks

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
IBillOfMaterialRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties.U_RevCode Property

Revision Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string U_RevCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ U_RevCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_RevCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
IBillOfMaterialRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties.U_RtOpRscCode Property

Routin Operation Resource ID (key for specific Resource in specific Operation ) must be filled It tels us that This Object belongs to concreat Resource

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprRscCode")> _
Property U_RtOpRscCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprRscCode")]
int U_RtOpRscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprRscCode")]

property int U_RtOpRscCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprRscCode")
function get U_RtOpRscCode() : int;

   AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprRscCode")
function set U_RtOpRscCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
IBillOfMaterialRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties.U_RtgCode Property

Routing Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")> _
Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")]
string U_RtgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")]

property String^ U_RtgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")
function get U_RtgCode() : String;

   AppEngineProperty(Priority = 2,ParentKey = "U_RtgCode")
function set U_RtgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
IBillOfMaterialRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties.U_RtgOprCode Property

Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Object belongs to concreat operation

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 1, ParentKey = "U_RtgOprCode")> _
Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 1, ParentKey = "U_RtgOprCode")]
int U_RtgOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 1, ParentKey = "U_RtgOprCode")]

property int U_RtgOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 1, ParentKey = "U_RtgOprCode")
function get U_RtgOprCode() : int;

   AppEngineProperty(Priority = 1, ParentKey = "U_RtgOprCode")
function set U_RtgOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
IBillOfMaterialRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties.U_UnitOfMeasure Property

Unit Of Measure

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UnitOfMeasure {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UnitOfMeasure {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UnitOfMeasure() : String;
function set U_UnitOfMeasure(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
IBillOfMaterialRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties.U_WordCode Property

Word code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
IBillOfMaterialRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResourceProperties Methods

IBillOfMaterialRoutingOperationResourceProperties Interface See Also

The following tables list the members exposed by the IBillOfMaterialRoutingOperationResourceProperties type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialRoutingOperationResourceProperties Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources Interface

Members See Also

Resources for routing operations for bill of material object

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean(Parent = "IBillOfMaterialRoutingOperations")> _
Public Interface IBillOfMaterialRoutingOperationResources
    Inherits IUDOChildBean, _
             IEnumerable(Of IBillOfMaterialRoutingOperationResources)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IBillOfMaterialRoutingOperations")]
public interface IBillOfMaterialRoutingOperationResources : IUDOChildBean,
   IEnumerable<IBillOfMaterialRoutingOperationResources>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IBillOfMaterialRoutingOperations")]
public interface class IBillOfMaterialRoutingOperationResources : public IUDOChildBean^,
   public IEnumerable<IBillOfMaterialRoutingOperationResources^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_BOM16
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources Members

IBillOfMaterialRoutingOperationResources Interface Methods Properties See Also

Resources for routing operations for bill of material object

The following tables list the members exposed by the IBillOfMaterialRoutingOperationResources type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_QueueTimeInHours |
Public property | DS_RunTimeInHours |
Public property | DS_SetupTimeInHours |
Public property | DS_StockTimeInHours |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BomCode | Bom Code Key
Public property | U_CycleCap | Cycle Capacity the maximum quantity that can used in a sigle production Cycle
Public property | U_HasCycles | Is this Resource works in cycles
Public property | U_IsDefault | Is This Resource is default
Public property | U_IssueType | Issue Type
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MachineCode | Machine Code if Resource type is Machine this Filed is mandatory
Public property | U_NrOfResources | Nuber Of Resources this value will be cppied to Manufacturing order if User selects Current resource.
Public property | U_OcrCode |
Public property | U_OcrCode2 |
Public property | U_OcrCode3 |
Public property | U_OcrCode4 |
Public property | U_OcrCode5 |
Public property | U_OprCode | Operation Code (key)
Public property | U_Project |
Public property | U_QueueRate | Queue Rate
Public property | U_QueueTime | Queue Time
Public property | U_QueueTotal | Total seconds for queue based on Batch Size
Public property | U_Remarks | Resource Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RscCode | Resource Code (key)
Public property | U_RscType | Resource Type Read-Only
Public property | U_RtgCode | Routing Code(key)
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Resource belongs to concreat operation
Public property | U_RtgOprRscCode | Automaticly Generated key For this Operation
Public property | U_RunRate | Run Rate
Public property | U_RunTime | Run Time
Public property | U_RunTotal | Total seconds for Run based on Batch Size
Public property | U_SetupRate | SetupRate
Public property | U_SetupTime | SetipTime
Public property | U_SetupTotal | Total seconds for setup based on Batch Size
Public property | U_StockRate | StockRate
Public property | U_StockTime | Stock Time
Public property | U_StockTotal | Total seconds for stock based on Batch Size
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources Properties

IBillOfMaterialRoutingOperationResources Interface See Also

The following tables list the members exposed by the IBillOfMaterialRoutingOperationResources type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_QueueTimeInHours |
Public property | DS_RunTimeInHours |
Public property | DS_SetupTimeInHours |
Public property | DS_StockTimeInHours |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BomCode | Bom Code Key
Public property | U_CycleCap | Cycle Capacity the maximum quantity that can used in a sigle production Cycle
Public property | U_HasCycles | Is this Resource works in cycles
Public property | U_IsDefault | Is This Resource is default
Public property | U_IssueType | Issue Type
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MachineCode | Machine Code if Resource type is Machine this Filed is mandatory
Public property | U_NrOfResources | Nuber Of Resources this value will be cppied to Manufacturing order if User selects Current resource.
Public property | U_OcrCode |
Public property | U_OcrCode2 |
Public property | U_OcrCode3 |
Public property | U_OcrCode4 |
Public property | U_OcrCode5 |
Public property | U_OprCode | Operation Code (key)
Public property | U_Project |
Public property | U_QueueRate | Queue Rate
Public property | U_QueueTime | Queue Time
Public property | U_QueueTotal | Total seconds for queue based on Batch Size
Public property | U_Remarks | Resource Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RscCode | Resource Code (key)
Public property | U_RscType | Resource Type Read-Only
Public property | U_RtgCode | Routing Code(key)
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Resource belongs to concreat operation
Public property | U_RtgOprRscCode | Automaticly Generated key For this Operation
Public property | U_RunRate | Run Rate
Public property | U_RunTime | Run Time
Public property | U_RunTotal | Total seconds for Run based on Batch Size
Public property | U_SetupRate | SetupRate
Public property | U_SetupTime | SetipTime
Public property | U_SetupTotal | Total seconds for setup based on Batch Size
Public property | U_StockRate | StockRate
Public property | U_StockTime | Stock Time
Public property | U_StockTotal | Total seconds for stock based on Batch Size
Top
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.DS_QueueTimeInHours Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_QueueTimeInHours() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_QueueTimeInHours {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_QueueTimeInHours {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_QueueTimeInHours() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.DS_RunTimeInHours Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_RunTimeInHours() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_RunTimeInHours {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_RunTimeInHours {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_RunTimeInHours() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.DS_SetupTimeInHours Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_SetupTimeInHours() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_SetupTimeInHours {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_SetupTimeInHours {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_SetupTimeInHours() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.DS_StockTimeInHours Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_StockTimeInHours() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_StockTimeInHours {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_StockTimeInHours {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_StockTimeInHours() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_BomCode Property

Bom Code Key

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BomCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BomCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BomCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BomCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_CycleCap Property

Cycle Capacity the maximum quantity that can used in a sigle production Cycle

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CycleCap() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_CycleCap {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_CycleCap {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CycleCap() : double;
function set U_CycleCap(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_HasCycles Property

Is this Resource works in cycles

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_HasCycles() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_HasCycles {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_HasCycles {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_HasCycles() : YesNoType;
function set U_HasCycles(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_IsDefault Property

Is This Resource is default

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IsDefault() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_IsDefault {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_IsDefault {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IsDefault() : String;
function set U_IsDefault(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_IssueType Property

Issue Type

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IssueType() As IssueType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IssueType U_IssueType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IssueType U_IssueType {
 IssueType get( );
 void set(
   IssueType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IssueType() : IssueType;
function set U_IssueType(value : IssueType);
This language is not supported or no code example is available.

Property Value

Type: IssueType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_MachineCode Property

Machine Code if Resource type is Machine this Filed is mandatory

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MachineCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MachineCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MachineCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MachineCode() : String;
function set U_MachineCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_NrOfResources Property

Nuber Of Resources this value will be cppied to Manufacturing order if User selects Current resource.

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_NrOfResources() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_NrOfResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_NrOfResources {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_NrOfResources() : int;
function set U_NrOfResources(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_OcrCode Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode() : String;
function set U_OcrCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_OcrCode2 Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode2() : String;
function set U_OcrCode2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_OcrCode3 Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode3() : String;
function set U_OcrCode3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_OcrCode4 Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode4() : String;
function set U_OcrCode4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_OcrCode5 Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode5() : String;
function set U_OcrCode5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_OprCode Property

Operation Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 4)> _
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4)]
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4)]

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 4)
function get U_OprCode() : String;

   AppEngineProperty(Priority = 4)
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_Project Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Project() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Project {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Project {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Project() : String;
function set U_Project(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_QueueRate Property

Queue Rate

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QueueRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_QueueRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_QueueRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueRate() : RateType;
function set U_QueueRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_QueueTime Property

Queue Time

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QueueTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_QueueTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_QueueTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueTime() : double;
function set U_QueueTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_QueueTotal Property

Total seconds for queue based on Batch Size

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<TimeSpanType()> _
ReadOnly Property U_QueueTotal() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[TimeSpanType()]
TimeSpan U_QueueTotal {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[TimeSpanType()]

property TimeSpan U_QueueTotal {
 TimeSpan get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   TimeSpanType()
function get U_QueueTotal() : TimeSpan;
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_Remarks Property

Resource Remarks

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_RevCode Property

Revision Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_RscCode Property

Resource Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 6)> _
Property U_RscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 6)]
string U_RscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 6)]

property String^ U_RscCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 6)
function get U_RscCode() : String;

   AppEngineProperty(Priority = 6)
function set U_RscCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_RscType Property

Resource Type Read-Only

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RscType() As ResourceType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ResourceType U_RscType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ResourceType U_RscType {
 ResourceType get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscType() : ResourceType;
This language is not supported or no code example is available.

Property Value

Type: ResourceType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_RtgCode Property

Routing Code(key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")> _
Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")]
string U_RtgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")]

property String^ U_RtgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")
function get U_RtgCode() : String;

   AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")
function set U_RtgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_RtgOprCode Property

Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Resource belongs to concreat operation

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")> _
Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")]
int U_RtgOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")]

property int U_RtgOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")
function get U_RtgOprCode() : int;

   AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")
function set U_RtgOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_RtgOprRscCode Property

Automaticly Generated key For this Operation

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 5)> _
ReadOnly Property U_RtgOprRscCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 5)]
int U_RtgOprRscCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 5)]

property int U_RtgOprRscCode {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 5)
function get U_RtgOprRscCode() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_RunRate Property

Run Rate

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RunRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_RunRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_RunRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunRate() : RateType;
function set U_RunRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_RunTime Property

Run Time

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RunTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RunTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RunTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunTime() : double;
function set U_RunTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_RunTotal Property

Total seconds for Run based on Batch Size

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<TimeSpanType()> _
ReadOnly Property U_RunTotal() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[TimeSpanType()]
TimeSpan U_RunTotal {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[TimeSpanType()]

property TimeSpan U_RunTotal {
 TimeSpan get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   TimeSpanType()
function get U_RunTotal() : TimeSpan;
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_SetupRate Property

SetupRate

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SetupRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_SetupRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_SetupRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupRate() : RateType;
function set U_SetupRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_SetupTime Property

SetipTime

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SetupTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_SetupTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_SetupTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupTime() : double;
function set U_SetupTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_SetupTotal Property

Total seconds for setup based on Batch Size

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<TimeSpanType()> _
ReadOnly Property U_SetupTotal() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[TimeSpanType()]
TimeSpan U_SetupTotal {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[TimeSpanType()]

property TimeSpan U_SetupTotal {
 TimeSpan get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   TimeSpanType()
function get U_SetupTotal() : TimeSpan;
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_StockRate Property

StockRate

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StockRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_StockRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_StockRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockRate() : RateType;
function set U_StockRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_StockTime Property

Stock Time

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StockTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_StockTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_StockTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockTime() : double;
function set U_StockTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources.U_StockTotal Property

Total seconds for stock based on Batch Size

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<TimeSpanType()> _
ReadOnly Property U_StockTotal() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[TimeSpanType()]
TimeSpan U_StockTotal {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[TimeSpanType()]

property TimeSpan U_StockTotal {
 TimeSpan get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   TimeSpanType()
function get U_StockTotal() : TimeSpan;
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
IBillOfMaterialRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperationResources Methods

IBillOfMaterialRoutingOperationResources Interface See Also

The following tables list the members exposed by the IBillOfMaterialRoutingOperationResources type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialRoutingOperationResources Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations Interface

Members See Also

Routing operations for bill of material object

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean(Parent = "IBillOfMaterialRouting")> _
Public Interface IBillOfMaterialRoutingOperations
    Inherits IUDOChildBean, _
             IEnumerable(Of IBillOfMaterialRoutingOperations), _
             IBaseOperationRelation
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IBillOfMaterialRouting")]
public interface IBillOfMaterialRoutingOperations : IUDOChildBean,
   IEnumerable<IBillOfMaterialRoutingOperations>,
   IBaseOperationRelation
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IBillOfMaterialRouting")]
public interface class IBillOfMaterialRoutingOperations : public IUDOChildBean^,
   public IEnumerable<IBillOfMaterialRoutingOperations^>^,
   public IBaseOperationRelation^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_BOM12
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations Members

IBillOfMaterialRoutingOperations Interface Methods Properties See Also

Routing operations for bill of material object

The following tables list the members exposed by the IBillOfMaterialRoutingOperations type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BomCode | Bom Code (key)
Public property | U_ForceExecOrder |
Public property | U_HasRelations | Returns Yes if Operation has declared Relations
Public property | U_IgnoreYield | Ignore Yield
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OprCode | Operation Code
Public property | U_OprOverlayCode | Overlapping Operation Code
Public property | U_OprOverlayId | Id for Overlapping Operation
Public property | U_OprOverlayQty | Overlapping Quantity
Public property | U_OprSequence | Operation Sequence
Public property | U_QCActive | Returns Yes if Quality Control is Active
Public property | U_RelationType | Specifies Relation Type
Public property | U_Remarks | Operation Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RtgCode | Routing Code (key)
Public property | U_RtgOprCode | Routing Operation Key this is automaticly generated after fillinf U_RtgCode and U_OprCode it is Key for this operation int this routing
Public property | U_TestProtocolNo | Returns Test Protocol No
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialRoutingOperations Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations Properties

IBillOfMaterialRoutingOperations Interface See Also

The following tables list the members exposed by the IBillOfMaterialRoutingOperations type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BomCode | Bom Code (key)
Public property | U_ForceExecOrder |
Public property | U_HasRelations | Returns Yes if Operation has declared Relations
Public property | U_IgnoreYield | Ignore Yield
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OprCode | Operation Code
Public property | U_OprOverlayCode | Overlapping Operation Code
Public property | U_OprOverlayId | Id for Overlapping Operation
Public property | U_OprOverlayQty | Overlapping Quantity
Public property | U_OprSequence | Operation Sequence
Public property | U_QCActive | Returns Yes if Quality Control is Active
Public property | U_RelationType | Specifies Relation Type
Public property | U_Remarks | Operation Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RtgCode | Routing Code (key)
Public property | U_RtgOprCode | Routing Operation Key this is automaticly generated after fillinf U_RtgCode and U_OprCode it is Key for this operation int this routing
Public property | U_TestProtocolNo | Returns Test Protocol No
Top
See Also

Reference

IBillOfMaterialRoutingOperations Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.U_BomCode Property

Bom Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property U_BomCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string U_BomCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ U_BomCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_BomCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.U_ForceExecOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ForceExecOrder() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_ForceExecOrder {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_ForceExecOrder {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ForceExecOrder() : YesNoType;
function set U_ForceExecOrder(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.U_HasRelations Property

Returns Yes if Operation has declared Relations

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_HasRelations() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_HasRelations {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_HasRelations {
 YesNoType get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_HasRelations() : YesNoType;
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.U_IgnoreYield Property

Ignore Yield

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IgnoreYield() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_IgnoreYield {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_IgnoreYield {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IgnoreYield() : YesNoType;
function set U_IgnoreYield(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.U_OprCode Property

Operation Code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 4)> _
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4)]
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4)]

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 4)
function get U_OprCode() : String;

   AppEngineProperty(Priority = 4)
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.U_OprOverlayCode Property

Overlapping Operation Code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 6)> _
Property U_OprOverlayCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 6)]
string U_OprOverlayCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 6)]

property String^ U_OprOverlayCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 6)
function get U_OprOverlayCode() : String;

   AppEngineProperty(Priority = 6)
function set U_OprOverlayCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.U_OprOverlayId Property

Id for Overlapping Operation

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 7)> _
Property U_OprOverlayId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 7)]
int U_OprOverlayId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 7)]

property int U_OprOverlayId {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 7)
function get U_OprOverlayId() : int;

   AppEngineProperty(Priority = 7)
function set U_OprOverlayId(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.U_OprOverlayQty Property

Overlapping Quantity

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprOverlayQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_OprOverlayQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_OprOverlayQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprOverlayQty() : double;
function set U_OprOverlayQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.U_OprSequence Property

Operation Sequence

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 5)> _
Property U_OprSequence() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 5)]
int U_OprSequence {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 5)]

property int U_OprSequence {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 5)
function get U_OprSequence() : int;

   AppEngineProperty(Priority = 5)
function set U_OprSequence(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.U_QCActive Property

Returns Yes if Quality Control is Active

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QCActive() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_QCActive {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_QCActive {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QCActive() : YesNoType;
function set U_QCActive(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.U_RelationType Property

Specifies Relation Type

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RelationType() As OperationRelationType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
OperationRelationType U_RelationType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property OperationRelationType U_RelationType {
 OperationRelationType get( );
 void set(
   OperationRelationType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RelationType() : OperationRelationType;
function set U_RelationType(value : OperationRelationType);
This language is not supported or no code example is available.

Property Value

Type: OperationRelationType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.U_Remarks Property

Operation Remarks

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.U_RevCode Property

Revision Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string U_RevCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ U_RevCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_RevCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.U_RtgCode Property

Routing Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 1, ParentKey = "U_RtgCode")> _
Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 1, ParentKey = "U_RtgCode")]
string U_RtgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 1, ParentKey = "U_RtgCode")]

property String^ U_RtgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 1, ParentKey = "U_RtgCode")
function get U_RtgCode() : String;

   AppEngineProperty(Priority = 1, ParentKey = "U_RtgCode")
function set U_RtgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.U_RtgOprCode Property

Routing Operation Key this is automaticly generated after fillinf U_RtgCode and U_OprCode it is Key for this operation int this routing

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RtgOprCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RtgOprCode {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgOprCode() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations.U_TestProtocolNo Property

Returns Test Protocol No

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestProtocolNo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TestProtocolNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TestProtocolNo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestProtocolNo() : String;
function set U_TestProtocolNo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialRoutingOperations Interface
IBillOfMaterialRoutingOperations Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialRoutingOperations Methods

IBillOfMaterialRoutingOperations Interface See Also

The following tables list the members exposed by the IBillOfMaterialRoutingOperations type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialRoutingOperations Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps Interface

Members See Also

Scraps for bill of material object

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IBillOfMaterialScraps
    Inherits IUDOChildBean, _
             IEnumerable(Of IBillOfMaterialScraps)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IBillOfMaterialScraps : IUDOChildBean,
   IEnumerable<IBillOfMaterialScraps>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IBillOfMaterialScraps : public IUDOChildBean^,
   public IEnumerable<IBillOfMaterialScraps^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_BOM4
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps Members

IBillOfMaterialScraps Interface Methods Properties See Also

Scraps for bill of material object

The following tables list the members exposed by the IBillOfMaterialScraps type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_ItemName | Gets the item name.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BatchResult | Batch Result based on specific formula used in Costing read-only
Public property | U_Description | Item's Description
Public property | U_Factor | Item's Factor
Public property | U_FactorDescription | Item's Factor's Description
Public property | U_Formula | Item's Formula to calculate result
Public property | U_InventoryUoM | Item's Unit of measure
Public property | U_IssueType | Item's Issue Type
Public property | U_ItemCode | Item's ItemCode
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OcrCode | Item's Distribution Rule or Cost Centre code in Dimension 1
Public property | U_OcrCode2 | Item's Distribution Rule or Cost Centre code in Dimension 2
Public property | U_OcrCode3 | Item's Distribution Rule or Cost Centre code in Dimension 3
Public property | U_OcrCode4 | Item's Distribution Rule or Cost Centre code in Dimension 4
Public property | U_OcrCode5 | Item's Distribution Rule or Cost Centre code in Dimension 5
Public property | U_Project | Item's Project code
Public property | U_Quantity | Item's Quantity
Public property | U_Remarks | Item's Remarks
Public property | U_Result | Item's Result based on specific formula
Public property | U_Revision | Item's Revision code
Public property | U_Sequence | Item's Sequence number
Public property | U_Type | Item's type
Public property | U_WhsCode | Item's Warehouse Code
Public property | U_Yield |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialScraps Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps Properties

IBillOfMaterialScraps Interface See Also

The following tables list the members exposed by the IBillOfMaterialScraps type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_ItemName | Gets the item name.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BatchResult | Batch Result based on specific formula used in Costing read-only
Public property | U_Description | Item's Description
Public property | U_Factor | Item's Factor
Public property | U_FactorDescription | Item's Factor's Description
Public property | U_Formula | Item's Formula to calculate result
Public property | U_InventoryUoM | Item's Unit of measure
Public property | U_IssueType | Item's Issue Type
Public property | U_ItemCode | Item's ItemCode
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OcrCode | Item's Distribution Rule or Cost Centre code in Dimension 1
Public property | U_OcrCode2 | Item's Distribution Rule or Cost Centre code in Dimension 2
Public property | U_OcrCode3 | Item's Distribution Rule or Cost Centre code in Dimension 3
Public property | U_OcrCode4 | Item's Distribution Rule or Cost Centre code in Dimension 4
Public property | U_OcrCode5 | Item's Distribution Rule or Cost Centre code in Dimension 5
Public property | U_Project | Item's Project code
Public property | U_Quantity | Item's Quantity
Public property | U_Remarks | Item's Remarks
Public property | U_Result | Item's Result based on specific formula
Public property | U_Revision | Item's Revision code
Public property | U_Sequence | Item's Sequence number
Public property | U_Type | Item's type
Public property | U_WhsCode | Item's Warehouse Code
Public property | U_Yield |
Top
See Also

Reference

IBillOfMaterialScraps Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.DS_ItemName Property

Gets the item name.

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property DS_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
string DS_ItemName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property String^ DS_ItemName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get DS_ItemName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_BatchResult Property

Batch Result based on specific formula used in Costing read-only

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BatchResult() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_BatchResult {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_BatchResult {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchResult() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_Description Property

Item's Description

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Description() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Description {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Description {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Description() : String;
function set U_Description(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_Factor Property

Item's Factor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Factor() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Factor {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Factor {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Factor() : double;
function set U_Factor(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_FactorDescription Property

Item's Factor's Description

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FactorDescription() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FactorDescription {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FactorDescription {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FactorDescription() : String;
function set U_FactorDescription(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_Formula Property

Item's Formula to calculate result

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Formula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Formula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Formula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Formula() : String;
function set U_Formula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_InventoryUoM Property

Item's Unit of measure

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InventoryUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InventoryUoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InventoryUoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InventoryUoM() : String;
function set U_InventoryUoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_IssueType Property

Item's Issue Type

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IssueType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_IssueType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_IssueType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IssueType() : String;
function set U_IssueType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_ItemCode Property

Item's ItemCode

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2)> _
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2)
function get U_ItemCode() : String;

   AppEngineProperty(Priority = 2)
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_OcrCode Property

Item's Distribution Rule or Cost Centre code in Dimension 1

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode() : String;
function set U_OcrCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_OcrCode2 Property

Item's Distribution Rule or Cost Centre code in Dimension 2

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode2() : String;
function set U_OcrCode2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_OcrCode3 Property

Item's Distribution Rule or Cost Centre code in Dimension 3

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode3() : String;
function set U_OcrCode3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_OcrCode4 Property

Item's Distribution Rule or Cost Centre code in Dimension 4

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode4() : String;
function set U_OcrCode4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_OcrCode5 Property

Item's Distribution Rule or Cost Centre code in Dimension 5

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode5() : String;
function set U_OcrCode5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_Project Property

Item's Project code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Project() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Project {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Project {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Project() : String;
function set U_Project(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_Quantity Property

Item's Quantity

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_Remarks Property

Item's Remarks

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_Result Property

Item's Result based on specific formula

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Result() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Result {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Result {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Result() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_Revision Property

Item's Revision code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 3)> _
Property U_Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3)]
string U_Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3)]

property String^ U_Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 3)
function get U_Revision() : String;

   AppEngineProperty(Priority = 3)
function set U_Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_Sequence Property

Item's Sequence number

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Sequence() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_Sequence {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_Sequence {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Sequence() : int;
function set U_Sequence(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_Type Property

Item's type

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Type() As ScrapType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ScrapType U_Type {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ScrapType U_Type {
 ScrapType get( );
 void set(
   ScrapType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Type() : ScrapType;
function set U_Type(value : ScrapType);
This language is not supported or no code example is available.

Property Value

Type: ScrapType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_WhsCode Property

Item's Warehouse Code

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps.U_Yield Property

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Autogenerate = true)> _
Property U_Yield() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Autogenerate = true)]
double U_Yield {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Autogenerate = true)]

property double U_Yield {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Autogenerate = true)
function get U_Yield() : double;

   AppEngineProperty(Autogenerate = true)
function set U_Yield(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBillOfMaterialScraps Interface
IBillOfMaterialScraps Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


IBillOfMaterialScraps Methods

IBillOfMaterialScraps Interface See Also

The following tables list the members exposed by the IBillOfMaterialScraps type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBillOfMaterialScraps Interface
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IBusinessPartnerRelations |
Public interface | IBusinessPartnerRelationsThridLevel |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IBusinessPartnerRelations Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IBusinessPartnerRelations
    Inherits IUDOChildBean, _
             IEnumerable(Of IBusinessPartnerRelations)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IBusinessPartnerRelations : IUDOChildBean,
   IEnumerable<IBusinessPartnerRelations>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IBusinessPartnerRelations : public IUDOChildBean^,
   public IEnumerable<IBusinessPartnerRelations^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBusinessPartnerRelations Members
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


IBusinessPartnerRelations Members

IBusinessPartnerRelations Interface Methods Properties See Also

The following tables list the members exposed by the IBusinessPartnerRelations type.

Properties
 | Name | Description
Public property | CardName |
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_CardCode |
Public property | U_Expression |
Public property | U_FromDate |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ToDate |
Public property | U_ValueFrom |
Public property | U_ValueTo |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBusinessPartnerRelations Interface
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


IBusinessPartnerRelations Properties

IBusinessPartnerRelations Interface See Also

The following tables list the members exposed by the IBusinessPartnerRelations type.

Properties
 | Name | Description
Public property | CardName |
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_CardCode |
Public property | U_Expression |
Public property | U_FromDate |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ToDate |
Public property | U_ValueFrom |
Public property | U_ValueTo |
Top
See Also

Reference

IBusinessPartnerRelations Interface
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


IBusinessPartnerRelations.CardName Property

Namespace: CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property CardName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string CardName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ CardName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CardName() : String;
function set CardName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBusinessPartnerRelations Interface
IBusinessPartnerRelations Members
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


IBusinessPartnerRelations.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBusinessPartnerRelations Interface
IBusinessPartnerRelations Members
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


IBusinessPartnerRelations.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBusinessPartnerRelations Interface
IBusinessPartnerRelations Members
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


IBusinessPartnerRelations.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBusinessPartnerRelations Interface
IBusinessPartnerRelations Members
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


IBusinessPartnerRelations.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBusinessPartnerRelations Interface
IBusinessPartnerRelations Members
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


IBusinessPartnerRelations.U_CardCode Property

Namespace: CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_CardCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_CardCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_CardCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_CardCode() : String;

   AppEngineProperty(Required = true)
function set U_CardCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBusinessPartnerRelations Interface
IBusinessPartnerRelations Members
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


IBusinessPartnerRelations.U_Expression Property

Namespace: CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Expression() As ConditionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ConditionType U_Expression {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ConditionType U_Expression {
 ConditionType get( );
 void set(
   ConditionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Expression() : ConditionType;
function set U_Expression(value : ConditionType);
This language is not supported or no code example is available.

Property Value

Type: ConditionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBusinessPartnerRelations Interface
IBusinessPartnerRelations Members
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


IBusinessPartnerRelations.U_FromDate Property

Namespace: CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FromDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_FromDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_FromDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FromDate() : DateTime;
function set U_FromDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBusinessPartnerRelations Interface
IBusinessPartnerRelations Members
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


IBusinessPartnerRelations.U_ToDate Property

Namespace: CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ToDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ToDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ToDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ToDate() : DateTime;
function set U_ToDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBusinessPartnerRelations Interface
IBusinessPartnerRelations Members
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


IBusinessPartnerRelations.U_ValueFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValueFrom() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ValueFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ValueFrom {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValueFrom() : double;
function set U_ValueFrom(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBusinessPartnerRelations Interface
IBusinessPartnerRelations Members
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


IBusinessPartnerRelations.U_ValueTo Property

Namespace: CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValueTo() : double;
function set U_ValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBusinessPartnerRelations Interface
IBusinessPartnerRelations Members
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


IBusinessPartnerRelations Methods

IBusinessPartnerRelations Interface See Also

The following tables list the members exposed by the IBusinessPartnerRelations type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBusinessPartnerRelations Interface
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


IBusinessPartnerRelationsThridLevel Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IBusinessPartnerRelationsThridLevel
    Inherits IBusinessPartnerRelations, _
             IEnumerable(Of IBusinessPartnerRelationsThridLevel)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IBusinessPartnerRelationsThridLevel : IBusinessPartnerRelations,
   IEnumerable<IBusinessPartnerRelationsThridLevel>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IBusinessPartnerRelationsThridLevel : public IBusinessPartnerRelations^,
   public IEnumerable<IBusinessPartnerRelationsThridLevel^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBusinessPartnerRelationsThridLevel Members
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


IBusinessPartnerRelationsThridLevel Members

IBusinessPartnerRelationsThridLevel Interface Methods Properties See Also

The following tables list the members exposed by the IBusinessPartnerRelationsThridLevel type.

Properties
 | Name | Description
Public property | CardName | (inherited from IBusinessPartnerRelations).
Public property | Code | (inherited from IBusinessPartnerRelations).
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId | (inherited from IBusinessPartnerRelations).
Public property | LogInst | (inherited from IBusinessPartnerRelations).
Public property | Object | (inherited from IBusinessPartnerRelations).
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLineNum |
Public property | U_CardCode | (inherited from IBusinessPartnerRelations).
Public property | U_Expression | (inherited from IBusinessPartnerRelations).
Public property | U_FromDate | (inherited from IBusinessPartnerRelations).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ToDate | (inherited from IBusinessPartnerRelations).
Public property | U_ValueFrom | (inherited from IBusinessPartnerRelations).
Public property | U_ValueTo | (inherited from IBusinessPartnerRelations).
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBusinessPartnerRelationsThridLevel Interface
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


IBusinessPartnerRelationsThridLevel Properties

IBusinessPartnerRelationsThridLevel Interface See Also

The following tables list the members exposed by the IBusinessPartnerRelationsThridLevel type.

Properties
 | Name | Description
Public property | CardName | (inherited from IBusinessPartnerRelations).
Public property | Code | (inherited from IBusinessPartnerRelations).
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId | (inherited from IBusinessPartnerRelations).
Public property | LogInst | (inherited from IBusinessPartnerRelations).
Public property | Object | (inherited from IBusinessPartnerRelations).
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLineNum |
Public property | U_CardCode | (inherited from IBusinessPartnerRelations).
Public property | U_Expression | (inherited from IBusinessPartnerRelations).
Public property | U_FromDate | (inherited from IBusinessPartnerRelations).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ToDate | (inherited from IBusinessPartnerRelations).
Public property | U_ValueFrom | (inherited from IBusinessPartnerRelations).
Public property | U_ValueTo | (inherited from IBusinessPartnerRelations).
Top
See Also

Reference

IBusinessPartnerRelationsThridLevel Interface
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


IBusinessPartnerRelationsThridLevel.U_BaseLineNum Property

Namespace: CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLineNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLineNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLineNum {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLineNum() : int;
function set U_BaseLineNum(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBusinessPartnerRelationsThridLevel Interface
IBusinessPartnerRelationsThridLevel Members
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


IBusinessPartnerRelationsThridLevel Methods

IBusinessPartnerRelationsThridLevel Interface See Also

The following tables list the members exposed by the IBusinessPartnerRelationsThridLevel type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IBusinessPartnerRelationsThridLevel Interface
CompuTec.ProcessForce.API.Documents.BusinessPartnerRelations Namespace


CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ICalendarTemplate |
Public interface | ICalendarTemplateHolidays |
Public interface | ICalendarTemplateWorkingHours |
Public interface | ICalendarTemplateWorkingHoursExceptions |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ICalendarTemplate Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "CalendarTemplate", TableName = "@CT_PF_OCTL", UDOVersion = "UDO_10")> _
Public Interface ICalendarTemplate
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "CalendarTemplate", TableName = "@CT_PF_OCTL", UDOVersion = "UDO_10")]
public interface ICalendarTemplate : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "CalendarTemplate", TableName = "@CT_PF_OCTL", UDOVersion = "UDO_10")]
public interface class ICalendarTemplate : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "CalendarTemplate", TableName = "@CT_PF_OCTL", UDOVersion = "UDO_10")
interface ICalendarTemplate
   implements IUDOBean
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate Members

ICalendarTemplate Interface Methods Properties See Also

The following tables list the members exposed by the ICalendarTemplate type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code | Calendar template object
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_TotalWorkingHoursTime | Gets the total time for defined working hours.
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Holidays |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_TemplateCode |
Public property | U_TemplateName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Public property | WorkingHours |
Public property | WorkingHoursExceptions |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ICalendarTemplate Interface
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate Properties

ICalendarTemplate Interface See Also

The following tables list the members exposed by the ICalendarTemplate type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code | Calendar template object
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_TotalWorkingHoursTime | Gets the total time for defined working hours.
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Holidays |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_TemplateCode |
Public property | U_TemplateName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Public property | WorkingHours |
Public property | WorkingHoursExceptions |
Top
See Also

Reference

ICalendarTemplate Interface
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.Code Property

Calendar template object

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Name of table in database
CT_PF_OCTL
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.DS_TotalWorkingHoursTime Property

Gets the total time for defined working hours.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_TotalWorkingHoursTime() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_TotalWorkingHoursTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_TotalWorkingHoursTime {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_TotalWorkingHoursTime() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.Holidays Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Holidays() As ICalendarTemplateHolidays
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ICalendarTemplateHolidays Holidays {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ICalendarTemplateHolidays^ Holidays {
 ICalendarTemplateHolidays^ get( );
 void set(
   ICalendarTemplateHolidays^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Holidays() : ICalendarTemplateHolidays;
function set Holidays(value : ICalendarTemplateHolidays);
This language is not supported or no code example is available.

Property Value

Type: ICalendarTemplateHolidays
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.U_TemplateCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_TemplateCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_TemplateCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_TemplateCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_TemplateCode() : String;

   AppEngineProperty(Required = true)
function set U_TemplateCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.U_TemplateName Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TemplateName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TemplateName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TemplateName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TemplateName() : String;
function set U_TemplateName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.WorkingHours Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property WorkingHours() As ICalendarTemplateWorkingHours
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ICalendarTemplateWorkingHours WorkingHours {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ICalendarTemplateWorkingHours^ WorkingHours {
 ICalendarTemplateWorkingHours^ get( );
 void set(
   ICalendarTemplateWorkingHours^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WorkingHours() : ICalendarTemplateWorkingHours;
function set WorkingHours(value : ICalendarTemplateWorkingHours);
This language is not supported or no code example is available.

Property Value

Type: ICalendarTemplateWorkingHours
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate.WorkingHoursExceptions Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property WorkingHoursExceptions() As ICalendarTemplateWorkingHoursExceptions
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ICalendarTemplateWorkingHoursExceptions WorkingHoursExceptions {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ICalendarTemplateWorkingHoursExceptions^ WorkingHoursExceptions {
 ICalendarTemplateWorkingHoursExceptions^ get( );
 void set(
   ICalendarTemplateWorkingHoursExceptions^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WorkingHoursExceptions() : ICalendarTemplateWorkingHoursExceptions;
function set WorkingHoursExceptions(value : ICalendarTemplateWorkingHoursExceptions);
This language is not supported or no code example is available.

Property Value

Type: ICalendarTemplateWorkingHoursExceptions
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplate Interface
ICalendarTemplate Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplate Methods

ICalendarTemplate Interface See Also

The following tables list the members exposed by the ICalendarTemplate type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ICalendarTemplate Interface
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateHolidays Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ICalendarTemplateHolidays
    Inherits IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICalendarTemplateHolidays : IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ICalendarTemplateHolidays : public IUDOChildBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICalendarTemplateHolidays
   implements IUDOChildBean
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateHolidays Members

ICalendarTemplateHolidays Interface Methods Properties See Also

The following tables list the members exposed by the ICalendarTemplateHolidays type.

Properties
 | Name | Description
Public property | Code | Holidays of calendar template object
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Date |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Remarks |
Public property | U_TemplateCode |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

ICalendarTemplateHolidays Interface
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateHolidays Properties

ICalendarTemplateHolidays Interface See Also

The following tables list the members exposed by the ICalendarTemplateHolidays type.

Properties
 | Name | Description
Public property | Code | Holidays of calendar template object
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Date |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Remarks |
Public property | U_TemplateCode |
Top
See Also

Reference

ICalendarTemplateHolidays Interface
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateHolidays.Code Property

Holidays of calendar template object

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Name of table in database
CT_PF_CTL3
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateHolidays Interface
ICalendarTemplateHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateHolidays.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateHolidays Interface
ICalendarTemplateHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateHolidays.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateHolidays Interface
ICalendarTemplateHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateHolidays.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateHolidays Interface
ICalendarTemplateHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateHolidays.U_Date Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Date() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Date {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Date {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Date() : DateTime;
function set U_Date(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateHolidays Interface
ICalendarTemplateHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateHolidays.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateHolidays Interface
ICalendarTemplateHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateHolidays.U_TemplateCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TemplateCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TemplateCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TemplateCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TemplateCode() : String;
function set U_TemplateCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateHolidays Interface
ICalendarTemplateHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateHolidays Methods

ICalendarTemplateHolidays Interface See Also

The following tables list the members exposed by the ICalendarTemplateHolidays type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

ICalendarTemplateHolidays Interface
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHours Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ICalendarTemplateWorkingHours
    Inherits IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICalendarTemplateWorkingHours : IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ICalendarTemplateWorkingHours : public IUDOChildBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICalendarTemplateWorkingHours
   implements IUDOChildBean
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHours Members

ICalendarTemplateWorkingHours Interface Methods Properties See Also

The following tables list the members exposed by the ICalendarTemplateWorkingHours type.

Properties
 | Name | Description
Public property | Code | Working hours of calendar template object
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_TotalTime | Gets the total time
Public property | DS_TotalTimeHours | Gets the hours of total time.
Public property | DS_TotalTimeMinutes | Gets the minutes of total time.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Day |
Public property | U_FromTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_TemplateCode |
Public property | U_ToTime |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

ICalendarTemplateWorkingHours Interface
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHours Properties

ICalendarTemplateWorkingHours Interface See Also

The following tables list the members exposed by the ICalendarTemplateWorkingHours type.

Properties
 | Name | Description
Public property | Code | Working hours of calendar template object
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_TotalTime | Gets the total time
Public property | DS_TotalTimeHours | Gets the hours of total time.
Public property | DS_TotalTimeMinutes | Gets the minutes of total time.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Day |
Public property | U_FromTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_TemplateCode |
Public property | U_ToTime |
Top
See Also

Reference

ICalendarTemplateWorkingHours Interface
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHours.Code Property

Working hours of calendar template object

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Name of table in database
CT_PF_CTL1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHours Interface
ICalendarTemplateWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHours.DS_TotalTime Property

Gets the total time

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_TotalTime() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_TotalTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_TotalTime {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_TotalTime() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHours Interface
ICalendarTemplateWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHours.DS_TotalTimeHours Property

Gets the hours of total time.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_TotalTimeHours() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DS_TotalTimeHours {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DS_TotalTimeHours {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_TotalTimeHours() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHours Interface
ICalendarTemplateWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHours.DS_TotalTimeMinutes Property

Gets the minutes of total time.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_TotalTimeMinutes() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DS_TotalTimeMinutes {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DS_TotalTimeMinutes {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_TotalTimeMinutes() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHours Interface
ICalendarTemplateWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHours.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHours Interface
ICalendarTemplateWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHours.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHours Interface
ICalendarTemplateWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHours.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHours Interface
ICalendarTemplateWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHours.U_Day Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Day() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Day {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Day {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Day() : String;
function set U_Day(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHours Interface
ICalendarTemplateWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHours.U_FromTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FromTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_FromTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_FromTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FromTime() : DateTime;
function set U_FromTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHours Interface
ICalendarTemplateWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHours.U_TemplateCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TemplateCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TemplateCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TemplateCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TemplateCode() : String;
function set U_TemplateCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHours Interface
ICalendarTemplateWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHours.U_ToTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ToTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ToTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ToTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ToTime() : DateTime;
function set U_ToTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHours Interface
ICalendarTemplateWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHours Methods

ICalendarTemplateWorkingHours Interface See Also

The following tables list the members exposed by the ICalendarTemplateWorkingHours type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

ICalendarTemplateWorkingHours Interface
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHoursExceptions Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ICalendarTemplateWorkingHoursExceptions
    Inherits IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICalendarTemplateWorkingHoursExceptions : IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ICalendarTemplateWorkingHoursExceptions : public IUDOChildBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICalendarTemplateWorkingHoursExceptions
   implements IUDOChildBean
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHoursExceptions Members

ICalendarTemplateWorkingHoursExceptions Interface Methods Properties See Also

The following tables list the members exposed by the ICalendarTemplateWorkingHoursExceptions type.

Properties
 | Name | Description
Public property | Code | Working hours exceptions of calendar template object
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Date |
Public property | U_FromTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Remarks |
Public property | U_TemplateCode |
Public property | U_ToTime |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

ICalendarTemplateWorkingHoursExceptions Interface
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHoursExceptions Properties

ICalendarTemplateWorkingHoursExceptions Interface See Also

The following tables list the members exposed by the ICalendarTemplateWorkingHoursExceptions type.

Properties
 | Name | Description
Public property | Code | Working hours exceptions of calendar template object
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Date |
Public property | U_FromTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Remarks |
Public property | U_TemplateCode |
Public property | U_ToTime |
Top
See Also

Reference

ICalendarTemplateWorkingHoursExceptions Interface
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHoursExceptions.Code Property

Working hours exceptions of calendar template object

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Name of table in database
CT_PF_CTL2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHoursExceptions Interface
ICalendarTemplateWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHoursExceptions.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHoursExceptions Interface
ICalendarTemplateWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHoursExceptions.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHoursExceptions Interface
ICalendarTemplateWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHoursExceptions.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHoursExceptions Interface
ICalendarTemplateWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHoursExceptions.U_Date Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Date() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Date {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Date {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Date() : DateTime;
function set U_Date(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHoursExceptions Interface
ICalendarTemplateWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHoursExceptions.U_FromTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FromTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_FromTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_FromTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FromTime() : DateTime;
function set U_FromTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHoursExceptions Interface
ICalendarTemplateWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHoursExceptions.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHoursExceptions Interface
ICalendarTemplateWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHoursExceptions.U_TemplateCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TemplateCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TemplateCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TemplateCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TemplateCode() : String;
function set U_TemplateCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHoursExceptions Interface
ICalendarTemplateWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHoursExceptions.U_ToTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ToTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ToTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ToTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ToTime() : DateTime;
function set U_ToTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICalendarTemplateWorkingHoursExceptions Interface
ICalendarTemplateWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


ICalendarTemplateWorkingHoursExceptions Methods

ICalendarTemplateWorkingHoursExceptions Interface See Also

The following tables list the members exposed by the ICalendarTemplateWorkingHoursExceptions type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

ICalendarTemplateWorkingHoursExceptions Interface
CompuTec.ProcessForce.API.Documents.Calendars.CalendarTemplate Namespace


CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IEmployeeCalendar | Employee calendar object
Public interface | IEmployeeCalendarHolidays | Holidays for employee calendar object
Public interface | IEmployeeCalendarWorkingHours | Working hours for employee calendar object
Public interface | IEmployeeCalendarWorkingHoursExceptions | Working hours exception for employee calendar object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IEmployeeCalendar Interface

Members See Also

Employee calendar object

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "EmployeeCalendar", TableName = "@CT_PF_OECL", UDOVersion = "UDO_10")> _
Public Interface IEmployeeCalendar
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "EmployeeCalendar", TableName = "@CT_PF_OECL", UDOVersion = "UDO_10")]
public interface IEmployeeCalendar : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "EmployeeCalendar", TableName = "@CT_PF_OECL", UDOVersion = "UDO_10")]
public interface class IEmployeeCalendar : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "EmployeeCalendar", TableName = "@CT_PF_OECL", UDOVersion = "UDO_10")
interface IEmployeeCalendar
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OECL
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar Members

IEmployeeCalendar Interface Methods Properties See Also

Employee calendar object

The following tables list the members exposed by the IEmployeeCalendar type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_EmployeeFirstName |
Public property | DS_EmployeeLastName |
Public property | DS_EmployeeSecondName |
Public property | DS_TotalWorkingHoursTime | Gets the total time for defined working hours.
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Holidays |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_EmployeeId |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Public property | WorkingHours |
Public property | WorkingHoursExceptions |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByEmployeeId |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IEmployeeCalendar Interface
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar Properties

IEmployeeCalendar Interface See Also

The following tables list the members exposed by the IEmployeeCalendar type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_EmployeeFirstName |
Public property | DS_EmployeeLastName |
Public property | DS_EmployeeSecondName |
Public property | DS_TotalWorkingHoursTime | Gets the total time for defined working hours.
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Holidays |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_EmployeeId |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Public property | WorkingHours |
Public property | WorkingHoursExceptions |
Top
See Also

Reference

IEmployeeCalendar Interface
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.DS_EmployeeFirstName Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_EmployeeFirstName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_EmployeeFirstName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_EmployeeFirstName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_EmployeeFirstName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.DS_EmployeeLastName Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_EmployeeLastName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_EmployeeLastName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_EmployeeLastName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_EmployeeLastName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.DS_EmployeeSecondName Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_EmployeeSecondName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_EmployeeSecondName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_EmployeeSecondName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_EmployeeSecondName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.DS_TotalWorkingHoursTime Property

Gets the total time for defined working hours.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_TotalWorkingHoursTime() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_TotalWorkingHoursTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_TotalWorkingHoursTime {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_TotalWorkingHoursTime() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.Holidays Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Holidays() As IEmployeeCalendarHolidays
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IEmployeeCalendarHolidays Holidays {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IEmployeeCalendarHolidays^ Holidays {
 IEmployeeCalendarHolidays^ get( );
 void set(
   IEmployeeCalendarHolidays^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Holidays() : IEmployeeCalendarHolidays;
function set Holidays(value : IEmployeeCalendarHolidays);
This language is not supported or no code example is available.

Property Value

Type: IEmployeeCalendarHolidays
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.U_EmployeeId Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_EmployeeId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
int U_EmployeeId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property int U_EmployeeId {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_EmployeeId() : int;

   AppEngineProperty(Required = true)
function set U_EmployeeId(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.WorkingHours Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property WorkingHours() As IEmployeeCalendarWorkingHours
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IEmployeeCalendarWorkingHours WorkingHours {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IEmployeeCalendarWorkingHours^ WorkingHours {
 IEmployeeCalendarWorkingHours^ get( );
 void set(
   IEmployeeCalendarWorkingHours^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WorkingHours() : IEmployeeCalendarWorkingHours;
function set WorkingHours(value : IEmployeeCalendarWorkingHours);
This language is not supported or no code example is available.

Property Value

Type: IEmployeeCalendarWorkingHours
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.WorkingHoursExceptions Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property WorkingHoursExceptions() As IEmployeeCalendarWorkingHoursExceptions
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IEmployeeCalendarWorkingHoursExceptions WorkingHoursExceptions {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IEmployeeCalendarWorkingHoursExceptions^ WorkingHoursExceptions {
 IEmployeeCalendarWorkingHoursExceptions^ get( );
 void set(
   IEmployeeCalendarWorkingHoursExceptions^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WorkingHoursExceptions() : IEmployeeCalendarWorkingHoursExceptions;
function set WorkingHoursExceptions(value : IEmployeeCalendarWorkingHoursExceptions);
This language is not supported or no code example is available.

Property Value

Type: IEmployeeCalendarWorkingHoursExceptions
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar Methods

IEmployeeCalendar Interface See Also

The following tables list the members exposed by the IEmployeeCalendar type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByEmployeeId |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IEmployeeCalendar Interface
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendar.GetByEmployeeId Method

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByEmployeeId( _
   ByVal employeeId As Integer _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool GetByEmployeeId(
   int employeeId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool GetByEmployeeId(
   int employeeId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByEmployeeId(
    employeeId : int
) : boolean;
This language is not supported or no code example is available.

Parameters

employeeId

Type: int

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendar Interface
IEmployeeCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarHolidays Interface

Members See Also

Holidays for employee calendar object

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IEmployeeCalendarHolidays
    Inherits IUDOChildBean, _
             IEnumerable(Of IEmployeeCalendarHolidays)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IEmployeeCalendarHolidays : IUDOChildBean,
   IEnumerable<IEmployeeCalendarHolidays>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IEmployeeCalendarHolidays : public IUDOChildBean^,
   public IEnumerable<IEmployeeCalendarHolidays^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_ECL3
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarHolidays Members

IEmployeeCalendarHolidays Interface Methods Properties See Also

Holidays for employee calendar object

The following tables list the members exposed by the IEmployeeCalendarHolidays type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Date |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ParentCode |
Public property | U_Remarks |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IEmployeeCalendarHolidays Interface
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarHolidays Properties

IEmployeeCalendarHolidays Interface See Also

The following tables list the members exposed by the IEmployeeCalendarHolidays type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Date |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ParentCode |
Public property | U_Remarks |
Top
See Also

Reference

IEmployeeCalendarHolidays Interface
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarHolidays.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarHolidays Interface
IEmployeeCalendarHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarHolidays.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarHolidays Interface
IEmployeeCalendarHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarHolidays.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarHolidays Interface
IEmployeeCalendarHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarHolidays.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarHolidays Interface
IEmployeeCalendarHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarHolidays.U_Date Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Date() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Date {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Date {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Date() : DateTime;
function set U_Date(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarHolidays Interface
IEmployeeCalendarHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarHolidays.U_ParentCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ParentCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ParentCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ParentCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ParentCode() : String;
function set U_ParentCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarHolidays Interface
IEmployeeCalendarHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarHolidays.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarHolidays Interface
IEmployeeCalendarHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarHolidays Methods

IEmployeeCalendarHolidays Interface See Also

The following tables list the members exposed by the IEmployeeCalendarHolidays type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IEmployeeCalendarHolidays Interface
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHours Interface

Members See Also

Working hours for employee calendar object

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IEmployeeCalendarWorkingHours
    Inherits IUDOChildBean, _
             IEnumerable(Of IEmployeeCalendarWorkingHours)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IEmployeeCalendarWorkingHours : IUDOChildBean,
   IEnumerable<IEmployeeCalendarWorkingHours>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IEmployeeCalendarWorkingHours : public IUDOChildBean^,
   public IEnumerable<IEmployeeCalendarWorkingHours^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_ECL1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHours Members

IEmployeeCalendarWorkingHours Interface Methods Properties See Also

Working hours for employee calendar object

The following tables list the members exposed by the IEmployeeCalendarWorkingHours type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_TotalTime | Gets the total time
Public property | DS_TotalTimeHours | Gets the hours of total time.
Public property | DS_TotalTimeMinutes | Gets the minutes of total time.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Day |
Public property | U_FromTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ParentCode |
Public property | U_ToTime |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IEmployeeCalendarWorkingHours Interface
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHours Properties

IEmployeeCalendarWorkingHours Interface See Also

The following tables list the members exposed by the IEmployeeCalendarWorkingHours type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_TotalTime | Gets the total time
Public property | DS_TotalTimeHours | Gets the hours of total time.
Public property | DS_TotalTimeMinutes | Gets the minutes of total time.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Day |
Public property | U_FromTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ParentCode |
Public property | U_ToTime |
Top
See Also

Reference

IEmployeeCalendarWorkingHours Interface
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHours.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHours Interface
IEmployeeCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHours.DS_TotalTime Property

Gets the total time

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_TotalTime() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_TotalTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_TotalTime {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_TotalTime() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHours Interface
IEmployeeCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHours.DS_TotalTimeHours Property

Gets the hours of total time.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_TotalTimeHours() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DS_TotalTimeHours {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DS_TotalTimeHours {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_TotalTimeHours() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHours Interface
IEmployeeCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHours.DS_TotalTimeMinutes Property

Gets the minutes of total time.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_TotalTimeMinutes() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DS_TotalTimeMinutes {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DS_TotalTimeMinutes {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_TotalTimeMinutes() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHours Interface
IEmployeeCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHours.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHours Interface
IEmployeeCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHours.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHours Interface
IEmployeeCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHours.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHours Interface
IEmployeeCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHours.U_Day Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Day() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Day {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Day {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Day() : String;
function set U_Day(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHours Interface
IEmployeeCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHours.U_FromTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FromTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_FromTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_FromTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FromTime() : DateTime;
function set U_FromTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHours Interface
IEmployeeCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHours.U_ParentCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ParentCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ParentCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ParentCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ParentCode() : String;
function set U_ParentCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHours Interface
IEmployeeCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHours.U_ToTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ToTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ToTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ToTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ToTime() : DateTime;
function set U_ToTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHours Interface
IEmployeeCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHours Methods

IEmployeeCalendarWorkingHours Interface See Also

The following tables list the members exposed by the IEmployeeCalendarWorkingHours type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IEmployeeCalendarWorkingHours Interface
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHoursExceptions Interface

Members See Also

Working hours exception for employee calendar object

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IEmployeeCalendarWorkingHoursExceptions
    Inherits IUDOChildBean, _
             IEnumerable(Of IEmployeeCalendarWorkingHoursExceptions)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IEmployeeCalendarWorkingHoursExceptions : IUDOChildBean,
   IEnumerable<IEmployeeCalendarWorkingHoursExceptions>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IEmployeeCalendarWorkingHoursExceptions : public IUDOChildBean^,
   public IEnumerable<IEmployeeCalendarWorkingHoursExceptions^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_ECL2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHoursExceptions Members

IEmployeeCalendarWorkingHoursExceptions Interface Methods Properties See Also

Working hours exception for employee calendar object

The following tables list the members exposed by the IEmployeeCalendarWorkingHoursExceptions type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Date |
Public property | U_FromTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ParentCode |
Public property | U_Remarks |
Public property | U_ToTime |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IEmployeeCalendarWorkingHoursExceptions Interface
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHoursExceptions Properties

IEmployeeCalendarWorkingHoursExceptions Interface See Also

The following tables list the members exposed by the IEmployeeCalendarWorkingHoursExceptions type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Date |
Public property | U_FromTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ParentCode |
Public property | U_Remarks |
Public property | U_ToTime |
Top
See Also

Reference

IEmployeeCalendarWorkingHoursExceptions Interface
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHoursExceptions.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHoursExceptions Interface
IEmployeeCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHoursExceptions.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHoursExceptions Interface
IEmployeeCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHoursExceptions.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHoursExceptions Interface
IEmployeeCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHoursExceptions.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHoursExceptions Interface
IEmployeeCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHoursExceptions.U_Date Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Date() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Date {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Date {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Date() : DateTime;
function set U_Date(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHoursExceptions Interface
IEmployeeCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHoursExceptions.U_FromTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FromTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_FromTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_FromTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FromTime() : DateTime;
function set U_FromTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHoursExceptions Interface
IEmployeeCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHoursExceptions.U_ParentCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ParentCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ParentCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ParentCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ParentCode() : String;
function set U_ParentCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHoursExceptions Interface
IEmployeeCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHoursExceptions.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHoursExceptions Interface
IEmployeeCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHoursExceptions.U_ToTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ToTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ToTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ToTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ToTime() : DateTime;
function set U_ToTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IEmployeeCalendarWorkingHoursExceptions Interface
IEmployeeCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


IEmployeeCalendarWorkingHoursExceptions Methods

IEmployeeCalendarWorkingHoursExceptions Interface See Also

The following tables list the members exposed by the IEmployeeCalendarWorkingHoursExceptions type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IEmployeeCalendarWorkingHoursExceptions Interface
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar Namespace


CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | EmployeeCalendarDateConfiguration | Represents an ordered structure of the employee's calendar.
Public class | TimeRange | Represents a time range.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


EmployeeCalendarDateConfiguration Class

Members See Also

Represents an ordered structure of the employee's calendar.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class EmployeeCalendarDateConfiguration
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class EmployeeCalendarDateConfiguration
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class EmployeeCalendarDateConfiguration
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class EmployeeCalendarDateConfiguration
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History.EmployeeCalendarDateConfiguration
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EmployeeCalendarDateConfiguration Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History Namespace


EmployeeCalendarDateConfiguration Members

EmployeeCalendarDateConfiguration Class Constructors Methods Properties See Also

Represents an ordered structure of the employee's calendar.

The following tables list the members exposed by the EmployeeCalendarDateConfiguration type.

Constructors
 | Name | Description
Public constructor | EmployeeCalendarDateConfiguration | Initializes a new instance of the EmployeeCalendarDateConfiguration class.
Top
Properties
 | Name | Description
Public property | Exceptions | Gets a collection of exceptions.
Public property | Holidays | Gets a collection of holidays.
Public property | WorkingDays | Gets a collection of working days.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

EmployeeCalendarDateConfiguration Class
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History Namespace


EmployeeCalendarDateConfiguration Constructor

Initializes a new instance of the EmployeeCalendarDateConfiguration class.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String, _
   ByVal employeeId As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public EmployeeCalendarDateConfiguration(
   string token,
   int employeeId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
EmployeeCalendarDateConfiguration(
   String^ token,
   int employeeId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function EmployeeCalendarDateConfiguration(
    token : String,
    employeeId : int
);
This language is not supported or no code example is available.

Parameters

token

Type: string

employeeId

Type: int

Employee ID.

Exceptions
Exception type | Condition
InvalidEmployeeIdException | InvalidEmployeeIdException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EmployeeCalendarDateConfiguration Class
EmployeeCalendarDateConfiguration Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History Namespace


EmployeeCalendarDateConfiguration Properties

EmployeeCalendarDateConfiguration Class See Also

The following tables list the members exposed by the EmployeeCalendarDateConfiguration type.

Properties
 | Name | Description
Public property | Exceptions | Gets a collection of exceptions.
Public property | Holidays | Gets a collection of holidays.
Public property | WorkingDays | Gets a collection of working days.
Top
See Also

Reference

EmployeeCalendarDateConfiguration Class
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History Namespace


EmployeeCalendarDateConfiguration.Exceptions Property

Gets a collection of exceptions.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property Exceptions() As Dictionary(Of Date, List(Of TimeRange))
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Dictionary<DateTime, List<TimeRange>> Exceptions {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Dictionary<DateTime, List<TimeRange^>^>^ Exceptions {
 Dictionary<DateTime, List<TimeRange^>^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: Dictionary<DateTime, List<TimeRange>>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EmployeeCalendarDateConfiguration Class
EmployeeCalendarDateConfiguration Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History Namespace


EmployeeCalendarDateConfiguration.Holidays Property

Gets a collection of holidays.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property Holidays() As List(Of Date)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<DateTime> Holidays {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<DateTime>^ Holidays {
 List<DateTime>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<DateTime>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EmployeeCalendarDateConfiguration Class
EmployeeCalendarDateConfiguration Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History Namespace


EmployeeCalendarDateConfiguration.WorkingDays Property

Gets a collection of working days.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property WorkingDays() As Dictionary(Of DayOfWeek, List(Of TimeRange))
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Dictionary<DayOfWeek, List<TimeRange>> WorkingDays {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Dictionary<DayOfWeek, List<TimeRange^>^>^ WorkingDays {
 Dictionary<DayOfWeek, List<TimeRange^>^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: Dictionary<DayOfWeek, List<TimeRange>>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EmployeeCalendarDateConfiguration Class
EmployeeCalendarDateConfiguration Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History Namespace


EmployeeCalendarDateConfiguration Methods

EmployeeCalendarDateConfiguration Class See Also

The following tables list the members exposed by the EmployeeCalendarDateConfiguration type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

EmployeeCalendarDateConfiguration Class
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History Namespace


TimeRange Class

Members See Also

Represents a time range.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class TimeRange
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class TimeRange
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class TimeRange
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class TimeRange
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History.TimeRange
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeRange Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History Namespace


TimeRange Members

TimeRange Class Constructors Methods Properties See Also

Represents a time range.

The following tables list the members exposed by the TimeRange type.

Constructors
 | Name | Description
Public constructor | TimeRange | Initializes a new instance of the TimeRange class.
Top
Properties
 | Name | Description
Public property | EndTime | Gets or sets end time.
Public property | StartTime | Gets or sets start time.
Top
Methods
 | Name | Description
Public method | CheckTimeBetweenRange | Checks whether time is between the time range.
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

TimeRange Class
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History Namespace


TimeRange Constructor

Initializes a new instance of the TimeRange class.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal startTime As TimeSpan, _
   ByVal endTime As TimeSpan _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeRange(
   TimeSpan startTime,
   TimeSpan endTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeRange(
   TimeSpan startTime,
   TimeSpan endTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function TimeRange(
    startTime : TimeSpan,
    endTime : TimeSpan
);
This language is not supported or no code example is available.

Parameters

startTime

Type: TimeSpan

Start time.

endTime

Type: TimeSpan

End time.

Exceptions
Exception type | Condition
InvalidTimeRangeException | InvalidTimeRangeException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeRange Class
TimeRange Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History Namespace


TimeRange Properties

TimeRange Class See Also

The following tables list the members exposed by the TimeRange type.

Properties
 | Name | Description
Public property | EndTime | Gets or sets end time.
Public property | StartTime | Gets or sets start time.
Top
See Also

Reference

TimeRange Class
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History Namespace


TimeRange.EndTime Property

Gets or sets end time.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property EndTime() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan EndTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property TimeSpan EndTime {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get EndTime() : TimeSpan;
public function set EndTime(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeRange Class
TimeRange Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History Namespace


TimeRange.StartTime Property

Gets or sets start time.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property StartTime() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan StartTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property TimeSpan StartTime {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get StartTime() : TimeSpan;
public function set StartTime(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeRange Class
TimeRange Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History Namespace


TimeRange Methods

TimeRange Class See Also

The following tables list the members exposed by the TimeRange type.

Methods
 | Name | Description
Public method | CheckTimeBetweenRange | Checks whether time is between the time range.
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

TimeRange Class
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History Namespace


TimeRange.CheckTimeBetweenRange Method

Checks whether time is between the time range.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CheckTimeBetweenRange( _
   ByVal time As TimeSpan _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool CheckTimeBetweenRange(
   TimeSpan time
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool CheckTimeBetweenRange(
   TimeSpan time
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CheckTimeBetweenRange(
    time : TimeSpan
) : boolean;
This language is not supported or no code example is available.

Parameters

time

Type: TimeSpan

System.TimeSpan object that represents a time for checking.

Return Value

Type: bool

true if given time is between the time range; otherwise false is returned.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeRange Class
TimeRange Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.History Namespace


CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.Updater Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | EmployeeCalendarUpdater | Updates calendar entries for the employees based on a calendar template.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


EmployeeCalendarUpdater Class

Members See Also

Updates calendar entries for the employees based on a calendar template.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.Updater
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class EmployeeCalendarUpdater
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class EmployeeCalendarUpdater
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class EmployeeCalendarUpdater
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class EmployeeCalendarUpdater
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.Updater.EmployeeCalendarUpdater
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EmployeeCalendarUpdater Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.Updater Namespace


EmployeeCalendarUpdater Members

EmployeeCalendarUpdater Class Constructors Methods Properties See Also

Updates calendar entries for the employees based on a calendar template.

The following tables list the members exposed by the EmployeeCalendarUpdater type.

Constructors
 | Name | Description
Public constructor | EmployeeCalendarUpdater | (Overloaded) Initializes a new instance of the EmployeeCalendarUpdater class.
Top
Properties
 | Name | Description
Public property | ErrorMessage | Gets or sets the message of the latest error.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | Update | Updates employee calendar entries.
Top
See Also

Reference

EmployeeCalendarUpdater Class
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.Updater Namespace


EmployeeCalendarUpdater Constructor

EmployeeCalendarUpdater Class See Also

Initializes a new instance of the EmployeeCalendarUpdater class.

Overload List
Name | Description
EmployeeCalendarUpdater(string) | Initializes a new instance of the EmployeeCalendarUpdater class.
EmployeeCalendarUpdater(string, string, List<Int32>) | Initializes a new instance of the EmployeeCalendarUpdater class.
See Also

Reference

EmployeeCalendarUpdater Class
EmployeeCalendarUpdater Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.Updater Namespace


EmployeeCalendarUpdater Properties

EmployeeCalendarUpdater Class See Also

The following tables list the members exposed by the EmployeeCalendarUpdater type.

Properties
 | Name | Description
Public property | ErrorMessage | Gets or sets the message of the latest error.
Top
See Also

Reference

EmployeeCalendarUpdater Class
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.Updater Namespace


EmployeeCalendarUpdater.ErrorMessage Property

Gets or sets the message of the latest error.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.Updater
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ErrorMessage() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ErrorMessage {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ErrorMessage {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ErrorMessage() : String;
public function set ErrorMessage(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EmployeeCalendarUpdater Class
EmployeeCalendarUpdater Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.Updater Namespace


EmployeeCalendarUpdater Methods

EmployeeCalendarUpdater Class See Also

The following tables list the members exposed by the EmployeeCalendarUpdater type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | Update | Updates employee calendar entries.
Top
See Also

Reference

EmployeeCalendarUpdater Class
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.Updater Namespace


EmployeeCalendarUpdater.Update Method

Updates employee calendar entries.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.Updater
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function Update() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool Update()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool Update()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Update() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool

true if the updates of all employee calendar entries has been finished succesfully; otherwise false is returned.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EmployeeCalendarUpdater Class
EmployeeCalendarUpdater Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.Updater Namespace


CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IResourceCalendar | Resource calendar object
Public interface | IResourceCalendarHolidays | Holidays for resource calendar object
Public interface | IResourceCalendarWorkingHours | Working hours for resource calendar object
Public interface | IResourceCalendarWorkingHoursExceptions | Working hours exceptions for resource calendar object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IResourceCalendar Interface

Members See Also

Resource calendar object

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ResourceCalendar", TableName = "@CT_PF_ORCL", UDOVersion = "UDO_10")> _
Public Interface IResourceCalendar
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ResourceCalendar", TableName = "@CT_PF_ORCL", UDOVersion = "UDO_10")]
public interface IResourceCalendar : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ResourceCalendar", TableName = "@CT_PF_ORCL", UDOVersion = "UDO_10")]
public interface class IResourceCalendar : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ResourceCalendar", TableName = "@CT_PF_ORCL", UDOVersion = "UDO_10")
interface IResourceCalendar
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ORCL
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar Members

IResourceCalendar Interface Methods Properties See Also

Resource calendar object

The following tables list the members exposed by the IResourceCalendar type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_ResourceName |
Public property | DS_ResourceTableCode |
Public property | DS_TotalWorkingHoursTime | Gets the total time for defined working hours.
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | HasContinousCalendar |
Public property | Holidays |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_ResourceCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Public property | WorkingHours |
Public property | WorkingHoursExceptions |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetByResourceCode |
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IResourceCalendar Interface
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar Properties

IResourceCalendar Interface See Also

The following tables list the members exposed by the IResourceCalendar type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_ResourceName |
Public property | DS_ResourceTableCode |
Public property | DS_TotalWorkingHoursTime | Gets the total time for defined working hours.
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | HasContinousCalendar |
Public property | Holidays |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_ResourceCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Public property | WorkingHours |
Public property | WorkingHoursExceptions |
Top
See Also

Reference

IResourceCalendar Interface
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.DS_ResourceName Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_ResourceName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_ResourceName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_ResourceName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_ResourceName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.DS_ResourceTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_ResourceTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_ResourceTableCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_ResourceTableCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_ResourceTableCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.DS_TotalWorkingHoursTime Property

Gets the total time for defined working hours.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_TotalWorkingHoursTime() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_TotalWorkingHoursTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_TotalWorkingHoursTime {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_TotalWorkingHoursTime() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.HasContinousCalendar Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property HasContinousCalendar() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool HasContinousCalendar {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool HasContinousCalendar {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get HasContinousCalendar() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.Holidays Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Holidays() As IResourceCalendarHolidays
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IResourceCalendarHolidays Holidays {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IResourceCalendarHolidays^ Holidays {
 IResourceCalendarHolidays^ get( );
 void set(
   IResourceCalendarHolidays^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Holidays() : IResourceCalendarHolidays;
function set Holidays(value : IResourceCalendarHolidays);
This language is not supported or no code example is available.

Property Value

Type: IResourceCalendarHolidays
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.U_ResourceCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_ResourceCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_ResourceCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_ResourceCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_ResourceCode() : String;

   AppEngineProperty(Required = true)
function set U_ResourceCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.WorkingHours Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property WorkingHours() As IResourceCalendarWorkingHours
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IResourceCalendarWorkingHours WorkingHours {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IResourceCalendarWorkingHours^ WorkingHours {
 IResourceCalendarWorkingHours^ get( );
 void set(
   IResourceCalendarWorkingHours^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WorkingHours() : IResourceCalendarWorkingHours;
function set WorkingHours(value : IResourceCalendarWorkingHours);
This language is not supported or no code example is available.

Property Value

Type: IResourceCalendarWorkingHours
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.WorkingHoursExceptions Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property WorkingHoursExceptions() As IResourceCalendarWorkingHoursExceptions
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IResourceCalendarWorkingHoursExceptions WorkingHoursExceptions {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IResourceCalendarWorkingHoursExceptions^ WorkingHoursExceptions {
 IResourceCalendarWorkingHoursExceptions^ get( );
 void set(
   IResourceCalendarWorkingHoursExceptions^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WorkingHoursExceptions() : IResourceCalendarWorkingHoursExceptions;
function set WorkingHoursExceptions(value : IResourceCalendarWorkingHoursExceptions);
This language is not supported or no code example is available.

Property Value

Type: IResourceCalendarWorkingHoursExceptions
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar Methods

IResourceCalendar Interface See Also

The following tables list the members exposed by the IResourceCalendar type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetByResourceCode |
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IResourceCalendar Interface
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendar.GetByResourceCode Method

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByResourceCode( _
   ByVal resourceCode As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool GetByResourceCode(
   string resourceCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool GetByResourceCode(
   String^ resourceCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByResourceCode(
    resourceCode : String
) : boolean;
This language is not supported or no code example is available.

Parameters

resourceCode

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendar Interface
IResourceCalendar Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarHolidays Interface

Members See Also

Holidays for resource calendar object

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IResourceCalendarHolidays
    Inherits IUDOChildBean, _
             IEnumerable(Of IResourceCalendarHolidays)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IResourceCalendarHolidays : IUDOChildBean,
   IEnumerable<IResourceCalendarHolidays>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IResourceCalendarHolidays : public IUDOChildBean^,
   public IEnumerable<IResourceCalendarHolidays^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_RCL3
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarHolidays Members

IResourceCalendarHolidays Interface Methods Properties See Also

Holidays for resource calendar object

The following tables list the members exposed by the IResourceCalendarHolidays type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Date |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ParentCode |
Public property | U_Remarks |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IResourceCalendarHolidays Interface
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarHolidays Properties

IResourceCalendarHolidays Interface See Also

The following tables list the members exposed by the IResourceCalendarHolidays type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Date |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ParentCode |
Public property | U_Remarks |
Top
See Also

Reference

IResourceCalendarHolidays Interface
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarHolidays.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarHolidays Interface
IResourceCalendarHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarHolidays.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarHolidays Interface
IResourceCalendarHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarHolidays.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarHolidays Interface
IResourceCalendarHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarHolidays.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarHolidays Interface
IResourceCalendarHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarHolidays.U_Date Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Date() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Date {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Date {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Date() : DateTime;
function set U_Date(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarHolidays Interface
IResourceCalendarHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarHolidays.U_ParentCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ParentCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ParentCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ParentCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ParentCode() : String;
function set U_ParentCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarHolidays Interface
IResourceCalendarHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarHolidays.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarHolidays Interface
IResourceCalendarHolidays Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarHolidays Methods

IResourceCalendarHolidays Interface See Also

The following tables list the members exposed by the IResourceCalendarHolidays type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IResourceCalendarHolidays Interface
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHours Interface

Members See Also

Working hours for resource calendar object

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IResourceCalendarWorkingHours
    Inherits IUDOChildBean, _
             IEnumerable(Of IResourceCalendarWorkingHours)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IResourceCalendarWorkingHours : IUDOChildBean,
   IEnumerable<IResourceCalendarWorkingHours>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IResourceCalendarWorkingHours : public IUDOChildBean^,
   public IEnumerable<IResourceCalendarWorkingHours^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_RCL1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHours Members

IResourceCalendarWorkingHours Interface Methods Properties See Also

Working hours for resource calendar object

The following tables list the members exposed by the IResourceCalendarWorkingHours type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_TotalTime | Gets the total time
Public property | DS_TotalTimeHours | Gets the hours of total time.
Public property | DS_TotalTimeMinutes | Gets the minutes of total time.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Day |
Public property | U_FromTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ParentCode |
Public property | U_ToTime |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IResourceCalendarWorkingHours Interface
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHours Properties

IResourceCalendarWorkingHours Interface See Also

The following tables list the members exposed by the IResourceCalendarWorkingHours type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_TotalTime | Gets the total time
Public property | DS_TotalTimeHours | Gets the hours of total time.
Public property | DS_TotalTimeMinutes | Gets the minutes of total time.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Day |
Public property | U_FromTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ParentCode |
Public property | U_ToTime |
Top
See Also

Reference

IResourceCalendarWorkingHours Interface
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHours.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHours Interface
IResourceCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHours.DS_TotalTime Property

Gets the total time

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_TotalTime() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_TotalTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_TotalTime {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_TotalTime() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHours Interface
IResourceCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHours.DS_TotalTimeHours Property

Gets the hours of total time.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_TotalTimeHours() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DS_TotalTimeHours {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DS_TotalTimeHours {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_TotalTimeHours() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHours Interface
IResourceCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHours.DS_TotalTimeMinutes Property

Gets the minutes of total time.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_TotalTimeMinutes() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DS_TotalTimeMinutes {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DS_TotalTimeMinutes {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_TotalTimeMinutes() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHours Interface
IResourceCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHours.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHours Interface
IResourceCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHours.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHours Interface
IResourceCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHours.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHours Interface
IResourceCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHours.U_Day Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Day() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Day {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Day {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Day() : String;
function set U_Day(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHours Interface
IResourceCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHours.U_FromTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FromTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_FromTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_FromTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FromTime() : DateTime;
function set U_FromTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHours Interface
IResourceCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHours.U_ParentCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ParentCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ParentCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ParentCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ParentCode() : String;
function set U_ParentCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHours Interface
IResourceCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHours.U_ToTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ToTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ToTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ToTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ToTime() : DateTime;
function set U_ToTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHours Interface
IResourceCalendarWorkingHours Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHours Methods

IResourceCalendarWorkingHours Interface See Also

The following tables list the members exposed by the IResourceCalendarWorkingHours type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IResourceCalendarWorkingHours Interface
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHoursExceptions Interface

Members See Also

Working hours exceptions for resource calendar object

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IResourceCalendarWorkingHoursExceptions
    Inherits IUDOChildBean, _
             IEnumerable(Of IResourceCalendarWorkingHoursExceptions)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IResourceCalendarWorkingHoursExceptions : IUDOChildBean,
   IEnumerable<IResourceCalendarWorkingHoursExceptions>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IResourceCalendarWorkingHoursExceptions : public IUDOChildBean^,
   public IEnumerable<IResourceCalendarWorkingHoursExceptions^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_RCL2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHoursExceptions Members

IResourceCalendarWorkingHoursExceptions Interface Methods Properties See Also

Working hours exceptions for resource calendar object

The following tables list the members exposed by the IResourceCalendarWorkingHoursExceptions type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Date |
Public property | U_FromTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ParentCode |
Public property | U_Remarks |
Public property | U_ToTime |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IResourceCalendarWorkingHoursExceptions Interface
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHoursExceptions Properties

IResourceCalendarWorkingHoursExceptions Interface See Also

The following tables list the members exposed by the IResourceCalendarWorkingHoursExceptions type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Date |
Public property | U_FromTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ParentCode |
Public property | U_Remarks |
Public property | U_ToTime |
Top
See Also

Reference

IResourceCalendarWorkingHoursExceptions Interface
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHoursExceptions.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHoursExceptions Interface
IResourceCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHoursExceptions.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHoursExceptions Interface
IResourceCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHoursExceptions.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHoursExceptions Interface
IResourceCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHoursExceptions.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHoursExceptions Interface
IResourceCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHoursExceptions.U_Date Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Date() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Date {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Date {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Date() : DateTime;
function set U_Date(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHoursExceptions Interface
IResourceCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHoursExceptions.U_FromTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FromTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_FromTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_FromTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FromTime() : DateTime;
function set U_FromTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHoursExceptions Interface
IResourceCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHoursExceptions.U_ParentCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ParentCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ParentCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ParentCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ParentCode() : String;
function set U_ParentCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHoursExceptions Interface
IResourceCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHoursExceptions.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHoursExceptions Interface
IResourceCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHoursExceptions.U_ToTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ToTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ToTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ToTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ToTime() : DateTime;
function set U_ToTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCalendarWorkingHoursExceptions Interface
IResourceCalendarWorkingHoursExceptions Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


IResourceCalendarWorkingHoursExceptions Methods

IResourceCalendarWorkingHoursExceptions Interface See Also

The following tables list the members exposed by the IResourceCalendarWorkingHoursExceptions type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IResourceCalendarWorkingHoursExceptions Interface
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar Namespace


CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | ResourceCalendarDateConfiguration | Represents an ordered structure of the resource's calendar.
Public class | TimeRange | Represents a time range.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ResourceCalendarDateConfiguration Class

Members See Also

Represents an ordered structure of the resource's calendar.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ResourceCalendarDateConfiguration
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ResourceCalendarDateConfiguration
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ResourceCalendarDateConfiguration
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ResourceCalendarDateConfiguration
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History.ResourceCalendarDateConfiguration
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCalendarDateConfiguration Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History Namespace


ResourceCalendarDateConfiguration Members

ResourceCalendarDateConfiguration Class Constructors Methods Properties See Also

Represents an ordered structure of the resource's calendar.

The following tables list the members exposed by the ResourceCalendarDateConfiguration type.

Constructors
 | Name | Description
Public constructor | ResourceCalendarDateConfiguration | Initializes a new instance of the ResourceCalendarDateConfiguration class.
Top
Properties
 | Name | Description
Public property | Exceptions | Gets a collection of exceptions.
Public property | Holidays | Gets a collection of holidays.
Public property | WorkingDays | Gets a collection of working days.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ResourceCalendarDateConfiguration Class
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History Namespace


ResourceCalendarDateConfiguration Constructor

Initializes a new instance of the ResourceCalendarDateConfiguration class.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String, _
   ByVal resourceCode As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceCalendarDateConfiguration(
   string token,
   string resourceCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceCalendarDateConfiguration(
   String^ token,
   String^ resourceCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceCalendarDateConfiguration(
    token : String,
    resourceCode : String
);
This language is not supported or no code example is available.

Parameters

token

Type: string

resourceCode

Type: string

Resource code.

Exceptions
Exception type | Condition
InvalidResourceCodeException | InvalidResourceCodeException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCalendarDateConfiguration Class
ResourceCalendarDateConfiguration Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History Namespace


ResourceCalendarDateConfiguration Properties

ResourceCalendarDateConfiguration Class See Also

The following tables list the members exposed by the ResourceCalendarDateConfiguration type.

Properties
 | Name | Description
Public property | Exceptions | Gets a collection of exceptions.
Public property | Holidays | Gets a collection of holidays.
Public property | WorkingDays | Gets a collection of working days.
Top
See Also

Reference

ResourceCalendarDateConfiguration Class
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History Namespace


ResourceCalendarDateConfiguration.Exceptions Property

Gets a collection of exceptions.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property Exceptions() As Dictionary(Of Date, List(Of TimeRange))
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Dictionary<DateTime, List<TimeRange>> Exceptions {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Dictionary<DateTime, List<TimeRange^>^>^ Exceptions {
 Dictionary<DateTime, List<TimeRange^>^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: Dictionary<DateTime, List<TimeRange>>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCalendarDateConfiguration Class
ResourceCalendarDateConfiguration Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History Namespace


ResourceCalendarDateConfiguration.Holidays Property

Gets a collection of holidays.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property Holidays() As List(Of Date)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<DateTime> Holidays {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<DateTime>^ Holidays {
 List<DateTime>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<DateTime>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCalendarDateConfiguration Class
ResourceCalendarDateConfiguration Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History Namespace


ResourceCalendarDateConfiguration.WorkingDays Property

Gets a collection of working days.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property WorkingDays() As Dictionary(Of DayOfWeek, List(Of TimeRange))
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Dictionary<DayOfWeek, List<TimeRange>> WorkingDays {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Dictionary<DayOfWeek, List<TimeRange^>^>^ WorkingDays {
 Dictionary<DayOfWeek, List<TimeRange^>^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: Dictionary<DayOfWeek, List<TimeRange>>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCalendarDateConfiguration Class
ResourceCalendarDateConfiguration Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History Namespace


ResourceCalendarDateConfiguration Methods

ResourceCalendarDateConfiguration Class See Also

The following tables list the members exposed by the ResourceCalendarDateConfiguration type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ResourceCalendarDateConfiguration Class
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History Namespace


TimeRange Class

Members See Also

Represents a time range.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class TimeRange
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class TimeRange
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class TimeRange
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class TimeRange
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History.TimeRange
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeRange Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History Namespace


TimeRange Members

TimeRange Class Constructors Methods Properties See Also

Represents a time range.

The following tables list the members exposed by the TimeRange type.

Constructors
 | Name | Description
Public constructor | TimeRange | Initializes a new instance of the TimeRange class.
Top
Properties
 | Name | Description
Public property | EndTime | Gets or sets end time.
Public property | StartTime | Gets or sets start time.
Top
Methods
 | Name | Description
Public method | CheckTimeBetweenRange | Checks whether time is between the time range.
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

TimeRange Class
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History Namespace


TimeRange Constructor

Initializes a new instance of the TimeRange class.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal startTime As TimeSpan, _
   ByVal endTime As TimeSpan _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeRange(
   TimeSpan startTime,
   TimeSpan endTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeRange(
   TimeSpan startTime,
   TimeSpan endTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function TimeRange(
    startTime : TimeSpan,
    endTime : TimeSpan
);
This language is not supported or no code example is available.

Parameters

startTime

Type: TimeSpan

Start time.

endTime

Type: TimeSpan

End time.

Exceptions
Exception type | Condition
InvalidTimeRangeException | InvalidTimeRangeException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeRange Class
TimeRange Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History Namespace


TimeRange Properties

TimeRange Class See Also

The following tables list the members exposed by the TimeRange type.

Properties
 | Name | Description
Public property | EndTime | Gets or sets end time.
Public property | StartTime | Gets or sets start time.
Top
See Also

Reference

TimeRange Class
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History Namespace


TimeRange.EndTime Property

Gets or sets end time.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property EndTime() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan EndTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property TimeSpan EndTime {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get EndTime() : TimeSpan;
public function set EndTime(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeRange Class
TimeRange Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History Namespace


TimeRange.StartTime Property

Gets or sets start time.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property StartTime() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan StartTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property TimeSpan StartTime {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get StartTime() : TimeSpan;
public function set StartTime(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeRange Class
TimeRange Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History Namespace


TimeRange Methods

TimeRange Class See Also

The following tables list the members exposed by the TimeRange type.

Methods
 | Name | Description
Public method | CheckTimeBetweenRange | Checks whether time is between the time range.
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

TimeRange Class
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History Namespace


TimeRange.CheckTimeBetweenRange Method

Checks whether time is between the time range.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CheckTimeBetweenRange( _
   ByVal time As TimeSpan _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool CheckTimeBetweenRange(
   TimeSpan time
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool CheckTimeBetweenRange(
   TimeSpan time
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CheckTimeBetweenRange(
    time : TimeSpan
) : boolean;
This language is not supported or no code example is available.

Parameters

time

Type: TimeSpan

System.TimeSpan object that represents a time for checking.

Return Value

Type: bool

true if given time is between the time range; otherwise false is returned.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeRange Class
TimeRange Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.History Namespace


CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.Updater Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | ResourceCalendarUpdater | Updates calendar entries for the resources based on a calendar template.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ResourceCalendarUpdater Class

Members See Also

Updates calendar entries for the resources based on a calendar template.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.Updater
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ResourceCalendarUpdater
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ResourceCalendarUpdater
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ResourceCalendarUpdater
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ResourceCalendarUpdater
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.Updater.ResourceCalendarUpdater
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCalendarUpdater Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.Updater Namespace


ResourceCalendarUpdater Members

ResourceCalendarUpdater Class Constructors Methods Properties See Also

Updates calendar entries for the resources based on a calendar template.

The following tables list the members exposed by the ResourceCalendarUpdater type.

Constructors
 | Name | Description
Public constructor | ResourceCalendarUpdater | (Overloaded) Initializes a new instance of the ResourceCalendarUpdater class.
Top
Properties
 | Name | Description
Public property | ErrorMessage | Gets or sets the message of the latest error.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | Update | Updates resource calendar entries.
Top
See Also

Reference

ResourceCalendarUpdater Class
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.Updater Namespace


ResourceCalendarUpdater Constructor

ResourceCalendarUpdater Class See Also

Initializes a new instance of the ResourceCalendarUpdater class.

Overload List
Name | Description
ResourceCalendarUpdater(string, string, List<String>) | Initializes a new instance of the ResourceCalendarUpdater class.
ResourceCalendarUpdater(string) | Initializes a new instance of the ResourceCalendarUpdater class.
See Also

Reference

ResourceCalendarUpdater Class
ResourceCalendarUpdater Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.Updater Namespace


ResourceCalendarUpdater Properties

ResourceCalendarUpdater Class See Also

The following tables list the members exposed by the ResourceCalendarUpdater type.

Properties
 | Name | Description
Public property | ErrorMessage | Gets or sets the message of the latest error.
Top
See Also

Reference

ResourceCalendarUpdater Class
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.Updater Namespace


ResourceCalendarUpdater.ErrorMessage Property

Gets or sets the message of the latest error.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.Updater
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ErrorMessage() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ErrorMessage {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ErrorMessage {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ErrorMessage() : String;
public function set ErrorMessage(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCalendarUpdater Class
ResourceCalendarUpdater Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.Updater Namespace


ResourceCalendarUpdater Methods

ResourceCalendarUpdater Class See Also

The following tables list the members exposed by the ResourceCalendarUpdater type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | Update | Updates resource calendar entries.
Top
See Also

Reference

ResourceCalendarUpdater Class
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.Updater Namespace


ResourceCalendarUpdater.Update Method

Updates resource calendar entries.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.Updater
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function Update() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool Update()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool Update()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Update() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool

true if the updates of all resource calendar entries has been finished succesfully; otherwise false is returned.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCalendarUpdater Class
ResourceCalendarUpdater Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.Updater Namespace


CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ICapacityCalendar | Capacity calendar resources object
Public interface | ICapacityCalendarPeriods | Periods of capacity calendar resources object
Public interface | ICapacityCalendarResources | Resources of capacity calendar resources object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ICapacityCalendar Interface

Members See Also

Capacity calendar resources object

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "CapacityCalendar", TableName = "@CT_PF_OCAL", UDOVersion = "UDO_10")> _
Public Interface ICapacityCalendar
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "CapacityCalendar", TableName = "@CT_PF_OCAL", UDOVersion = "UDO_10")]
public interface ICapacityCalendar : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "CapacityCalendar", TableName = "@CT_PF_OCAL", UDOVersion = "UDO_10")]
public interface class ICapacityCalendar : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "CapacityCalendar", TableName = "@CT_PF_OCAL", UDOVersion = "UDO_10")
interface ICapacityCalendar
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OCAL
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendar Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar Members

ICapacityCalendar Interface Methods Properties See Also

Capacity calendar resources object

The following tables list the members exposed by the ICapacityCalendar type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Periods |
Public property | Resources |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_CalCode |
Public property | U_CalName |
Public property | U_CalRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ICapacityCalendar Interface
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar Properties

ICapacityCalendar Interface See Also

The following tables list the members exposed by the ICapacityCalendar type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Periods |
Public property | Resources |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_CalCode |
Public property | U_CalName |
Public property | U_CalRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

ICapacityCalendar Interface
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendar Interface
ICapacityCalendar Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendar Interface
ICapacityCalendar Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendar Interface
ICapacityCalendar Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendar Interface
ICapacityCalendar Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendar Interface
ICapacityCalendar Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendar Interface
ICapacityCalendar Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendar Interface
ICapacityCalendar Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendar Interface
ICapacityCalendar Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendar Interface
ICapacityCalendar Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar.Periods Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Periods() As ICapacityCalendarPeriods
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ICapacityCalendarPeriods Periods {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ICapacityCalendarPeriods^ Periods {
 ICapacityCalendarPeriods^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Periods() : ICapacityCalendarPeriods;
This language is not supported or no code example is available.

Property Value

Type: ICapacityCalendarPeriods
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendar Interface
ICapacityCalendar Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar.Resources Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Resources() As ICapacityCalendarResources
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ICapacityCalendarResources Resources {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ICapacityCalendarResources^ Resources {
 ICapacityCalendarResources^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Resources() : ICapacityCalendarResources;
This language is not supported or no code example is available.

Property Value

Type: ICapacityCalendarResources
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendar Interface
ICapacityCalendar Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendar Interface
ICapacityCalendar Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar.U_CalCode Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_CalCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_CalCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_CalCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_CalCode() : String;

   AppEngineProperty(Required = true)
function set U_CalCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendar Interface
ICapacityCalendar Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar.U_CalName Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CalName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CalName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CalName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CalName() : String;
function set U_CalName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendar Interface
ICapacityCalendar Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar.U_CalRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CalRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CalRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CalRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CalRemarks() : String;
function set U_CalRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendar Interface
ICapacityCalendar Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendar Interface
ICapacityCalendar Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendar Interface
ICapacityCalendar Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendar Interface
ICapacityCalendar Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendar Methods

ICapacityCalendar Interface See Also

The following tables list the members exposed by the ICapacityCalendar type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ICapacityCalendar Interface
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarPeriods Interface

Members See Also

Periods of capacity calendar resources object

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface ICapacityCalendarPeriods
    Inherits IUDOChildBean, _
             IEnumerable(Of ICapacityCalendarPeriods)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface ICapacityCalendarPeriods : IUDOChildBean,
   IEnumerable<ICapacityCalendarPeriods>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class ICapacityCalendarPeriods : public IUDOChildBean^,
   public IEnumerable<ICapacityCalendarPeriods^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_CAL2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarPeriods Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarPeriods Members

ICapacityCalendarPeriods Interface Methods Properties See Also

Periods of capacity calendar resources object

The following tables list the members exposed by the ICapacityCalendarPeriods type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Availability |
Public property | U_CalCode |
Public property | U_CalPrdCode |
Public property | U_EndDate |
Public property | U_EndTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_StartDate |
Public property | U_StartTime |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ICapacityCalendarPeriods Interface
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarPeriods Properties

ICapacityCalendarPeriods Interface See Also

The following tables list the members exposed by the ICapacityCalendarPeriods type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Availability |
Public property | U_CalCode |
Public property | U_CalPrdCode |
Public property | U_EndDate |
Public property | U_EndTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_StartDate |
Public property | U_StartTime |
Top
See Also

Reference

ICapacityCalendarPeriods Interface
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarPeriods.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarPeriods Interface
ICapacityCalendarPeriods Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarPeriods.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarPeriods Interface
ICapacityCalendarPeriods Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarPeriods.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarPeriods Interface
ICapacityCalendarPeriods Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarPeriods.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarPeriods Interface
ICapacityCalendarPeriods Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarPeriods.U_Availability Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Availability() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Availability {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Availability {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Availability() : double;
function set U_Availability(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarPeriods Interface
ICapacityCalendarPeriods Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarPeriods.U_CalCode Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_CalCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_CalCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_CalCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_CalCode() : String;

   AppEngineProperty(Required = true)
function set U_CalCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarPeriods Interface
ICapacityCalendarPeriods Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarPeriods.U_CalPrdCode Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CalPrdCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_CalPrdCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_CalPrdCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CalPrdCode() : int;
function set U_CalPrdCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarPeriods Interface
ICapacityCalendarPeriods Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarPeriods.U_EndDate Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_EndDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_EndDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EndDate() : DateTime;
function set U_EndDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarPeriods Interface
ICapacityCalendarPeriods Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarPeriods.U_EndTime Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EndTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_EndTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_EndTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EndTime() : DateTime;
function set U_EndTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarPeriods Interface
ICapacityCalendarPeriods Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarPeriods.U_StartDate Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StartDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StartDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StartDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StartDate() : DateTime;
function set U_StartDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarPeriods Interface
ICapacityCalendarPeriods Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarPeriods.U_StartTime Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StartTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StartTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StartTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StartTime() : DateTime;
function set U_StartTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarPeriods Interface
ICapacityCalendarPeriods Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarPeriods Methods

ICapacityCalendarPeriods Interface See Also

The following tables list the members exposed by the ICapacityCalendarPeriods type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ICapacityCalendarPeriods Interface
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarResources Interface

Members See Also

Resources of capacity calendar resources object

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface ICapacityCalendarResources
    Inherits IUDOChildBean, _
             IEnumerable(Of ICapacityCalendarResources)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface ICapacityCalendarResources : IUDOChildBean,
   IEnumerable<ICapacityCalendarResources>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class ICapacityCalendarResources : public IUDOChildBean^,
   public IEnumerable<ICapacityCalendarResources^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_CAL1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarResources Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarResources Members

ICapacityCalendarResources Interface Methods Properties See Also

Resources of capacity calendar resources object

The following tables list the members exposed by the ICapacityCalendarResources type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_RscName |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_CalCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_RscCode |
Public property | U_RscRemarks |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ICapacityCalendarResources Interface
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarResources Properties

ICapacityCalendarResources Interface See Also

The following tables list the members exposed by the ICapacityCalendarResources type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_RscName |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_CalCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_RscCode |
Public property | U_RscRemarks |
Top
See Also

Reference

ICapacityCalendarResources Interface
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarResources.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarResources Interface
ICapacityCalendarResources Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarResources.DS_RscName Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_RscName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_RscName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_RscName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_RscName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarResources Interface
ICapacityCalendarResources Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarResources.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarResources Interface
ICapacityCalendarResources Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarResources.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarResources Interface
ICapacityCalendarResources Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarResources.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarResources Interface
ICapacityCalendarResources Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarResources.U_CalCode Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_CalCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_CalCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_CalCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_CalCode() : String;

   AppEngineProperty(Required = true)
function set U_CalCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarResources Interface
ICapacityCalendarResources Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarResources.U_RscCode Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCode() : String;
function set U_RscCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarResources Interface
ICapacityCalendarResources Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarResources.U_RscRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.CapacityCalendar
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscRemarks() : String;
function set U_RscRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICapacityCalendarResources Interface
ICapacityCalendarResources Members
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


ICapacityCalendarResources Methods

ICapacityCalendarResources Interface See Also

The following tables list the members exposed by the ICapacityCalendarResources type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ICapacityCalendarResources Interface
CompuTec.ProcessForce.API.Documents.CapacityCalendar Namespace


CompuTec.ProcessForce.API.Documents.CostCategory Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ICostCategory | Cost category object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ICostCategory Interface

Members See Also

Cost category object

Namespace: CompuTec.ProcessForce.API.Documents.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ICostCategory
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICostCategory : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ICostCategory : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICostCategory
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PC_OCCT
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Members
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


ICostCategory Members

ICostCategory Interface Methods Properties See Also

Cost category object

The following tables list the members exposed by the ICostCategory type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ICostCategory Interface
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


ICostCategory Properties

ICostCategory Interface See Also

The following tables list the members exposed by the ICostCategory type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

ICostCategory Interface
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


ICostCategory.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


ICostCategory.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


ICostCategory.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


ICostCategory.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


ICostCategory.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


ICostCategory.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


ICostCategory.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


ICostCategory.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


ICostCategory.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


ICostCategory.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


ICostCategory.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


ICostCategory.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


ICostCategory.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


ICostCategory.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


ICostCategory.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


ICostCategory.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


ICostCategory Methods

ICostCategory Interface See Also

The following tables list the members exposed by the ICostCategory type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ICostCategory Interface
CompuTec.ProcessForce.API.Documents.CostCategory Namespace


CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ICostCategory | Cost category object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ICostCategory Interface

Members See Also

Cost category object

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "CostCategory", TableName = "@CT_PF_OCCT", UDOVersion = "UDO_10")> _
Public Interface ICostCategory
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "CostCategory", TableName = "@CT_PF_OCCT", UDOVersion = "UDO_10")]
public interface ICostCategory : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "CostCategory", TableName = "@CT_PF_OCCT", UDOVersion = "UDO_10")]
public interface class ICostCategory : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "CostCategory", TableName = "@CT_PF_OCCT", UDOVersion = "UDO_10")
interface ICostCategory
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OCCT
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory Members

ICostCategory Interface Methods Properties See Also

Cost category object

The following tables list the members exposed by the ICostCategory type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Active | Determines if cost category is active.
Public property | U_CostCode | Gets or sets cost category code.
Public property | U_CostName | Gets or sets cost category name.
Public property | U_Default | Determines if cost category is a default cost category.
Public property | U_PFDBVersion | Gets or sets ProcessForce database version.
Public property | U_PFVersion | Gets or sets ProcessForce version.
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByCostCategoryCode | Gets cost category data.
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ICostCategory Interface
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory Properties

ICostCategory Interface See Also

The following tables list the members exposed by the ICostCategory type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Active | Determines if cost category is active.
Public property | U_CostCode | Gets or sets cost category code.
Public property | U_CostName | Gets or sets cost category name.
Public property | U_Default | Determines if cost category is a default cost category.
Public property | U_PFDBVersion | Gets or sets ProcessForce database version.
Public property | U_PFVersion | Gets or sets ProcessForce version.
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

ICostCategory Interface
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.U_Active Property

Determines if cost category is active.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Active() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Active {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Active {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Active() : String;
function set U_Active(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.U_CostCode Property

Gets or sets cost category code.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_CostCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_CostCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_CostCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_CostCode() : String;

   AppEngineProperty(Required = true)
function set U_CostCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.U_CostName Property

Gets or sets cost category name.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CostName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CostName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CostName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CostName() : String;
function set U_CostName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.U_Default Property

Determines if cost category is a default cost category.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Default() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Default {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Default {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Default() : String;
function set U_Default(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.U_PFDBVersion Property

Gets or sets ProcessForce database version.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.U_PFVersion Property

Gets or sets ProcessForce version.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory Methods

ICostCategory Interface See Also

The following tables list the members exposed by the ICostCategory type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByCostCategoryCode | Gets cost category data.
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ICostCategory Interface
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


ICostCategory.GetByCostCategoryCode Method

Gets cost category data.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostCategory
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByCostCategoryCode( _
   ByVal costCategoryCode As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool GetByCostCategoryCode(
   string costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool GetByCostCategoryCode(
   String^ costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByCostCategoryCode(
    costCategoryCode : String
) : boolean;
This language is not supported or no code example is available.

Parameters

costCategoryCode

Type: string

Cost category code.

Return Value

Type: bool

A Boolean value that indicates whether cost category data has been retrieved successfully (true) or not (false).

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostCategory Interface
ICostCategory Members
CompuTec.ProcessForce.API.Documents.Costing.CostCategory Namespace


CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | CostsComparisonConstants |
Top
Interfaces
 | Name | Description
Public interface | ICostsComparison |
Public interface | IExampleBatchSizes |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


CostsComparisonConstants Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class CostsComparisonConstants
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CostsComparisonConstants
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class CostsComparisonConstants
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CostsComparisonConstants
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison.CostsComparisonConstants
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostsComparisonConstants Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


CostsComparisonConstants Members

CostsComparisonConstants Class Methods Fields See Also

The following tables list the members exposed by the CostsComparisonConstants type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | ExampleBatchSizes |
Top
See Also

Reference

CostsComparisonConstants Class
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


CostsComparisonConstants Methods

CostsComparisonConstants Class See Also

The following tables list the members exposed by the CostsComparisonConstants type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

CostsComparisonConstants Class
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


CostsComparisonConstants Fields

CostsComparisonConstants Class See Also

The following tables list the members exposed by the CostsComparisonConstants type.

Fields
 | Name | Description
Public field | ExampleBatchSizes |
Top
See Also

Reference

CostsComparisonConstants Class
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ExampleBatchSizes Field

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ExampleBatchSizes As String = "CT_PF_CMP1"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ExampleBatchSizes = @"CT_PF_CMP1"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ExampleBatchSizes = "CT_PF_CMP1";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ExampleBatchSizes : String = "CT_PF_CMP1"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostsComparisonConstants Class
CostsComparisonConstants Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "CostsComparison", TableName = "@CT_PF_OCMP", UDOVersion = "UDO_10")> _
Public Interface ICostsComparison
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "CostsComparison", TableName = "@CT_PF_OCMP", UDOVersion = "UDO_10")]
public interface ICostsComparison : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "CostsComparison", TableName = "@CT_PF_OCMP", UDOVersion = "UDO_10")]
public interface class ICostsComparison : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "CostsComparison", TableName = "@CT_PF_OCMP", UDOVersion = "UDO_10")
interface ICostsComparison
   implements IUDOBean
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison Members

ICostsComparison Interface Methods Properties See Also

The following tables list the members exposed by the ICostsComparison type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_BillOfMaterialsCode |
Public property | DS_DefaultBillOfMaterialsBatchSize |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | ExampleBatchSizes |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_CostCategoryCode |
Public property | U_ItemCode |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_RevisionCode |
Public property | U_RoutingCode |
Public property | U_Sorting |
Public property | U_UseFGBatchSize |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | Refresh | Refreshes the costs for all batch size entries.
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ICostsComparison Interface
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison Properties

ICostsComparison Interface See Also

The following tables list the members exposed by the ICostsComparison type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_BillOfMaterialsCode |
Public property | DS_DefaultBillOfMaterialsBatchSize |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | ExampleBatchSizes |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_CostCategoryCode |
Public property | U_ItemCode |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_RevisionCode |
Public property | U_RoutingCode |
Public property | U_Sorting |
Public property | U_UseFGBatchSize |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

ICostsComparison Interface
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.DS_BillOfMaterialsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_BillOfMaterialsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_BillOfMaterialsCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_BillOfMaterialsCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_BillOfMaterialsCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.DS_DefaultBillOfMaterialsBatchSize Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_DefaultBillOfMaterialsBatchSize() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
double DS_DefaultBillOfMaterialsBatchSize {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property double DS_DefaultBillOfMaterialsBatchSize {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_DefaultBillOfMaterialsBatchSize() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.ExampleBatchSizes Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ExampleBatchSizes() As IExampleBatchSizes
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IExampleBatchSizes ExampleBatchSizes {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IExampleBatchSizes^ ExampleBatchSizes {
 IExampleBatchSizes^ get( );
 void set(
   IExampleBatchSizes^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ExampleBatchSizes() : IExampleBatchSizes;
function set ExampleBatchSizes(value : IExampleBatchSizes);
This language is not supported or no code example is available.

Property Value

Type: IExampleBatchSizes
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.U_CostCategoryCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CostCategoryCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CostCategoryCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CostCategoryCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CostCategoryCode() : String;
function set U_CostCategoryCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_ItemCode() : String;

   AppEngineProperty(Required = true)
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.U_RevisionCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RevisionCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevisionCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevisionCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevisionCode() : String;
function set U_RevisionCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.U_RoutingCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RoutingCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RoutingCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RoutingCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RoutingCode() : String;
function set U_RoutingCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.U_Sorting Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Sorting() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Sorting {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Sorting {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Sorting() : String;
function set U_Sorting(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.U_UseFGBatchSize Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UseFGBatchSize() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UseFGBatchSize {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UseFGBatchSize {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UseFGBatchSize() : String;
function set U_UseFGBatchSize(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison Methods

ICostsComparison Interface See Also

The following tables list the members exposed by the ICostsComparison type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | Refresh | Refreshes the costs for all batch size entries.
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ICostsComparison Interface
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


ICostsComparison.Refresh Method

Refreshes the costs for all batch size entries.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Refresh()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Refresh()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Refresh()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Refresh();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostsComparison Interface
ICostsComparison Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


IExampleBatchSizes Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IExampleBatchSizes
    Inherits IUDOChildBean, _
             IEnumerable(Of IExampleBatchSizes)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IExampleBatchSizes : IUDOChildBean,
   IEnumerable<IExampleBatchSizes>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IExampleBatchSizes : public IUDOChildBean^,
   public IEnumerable<IExampleBatchSizes^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExampleBatchSizes Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


IExampleBatchSizes Members

IExampleBatchSizes Interface Methods Properties See Also

The following tables list the members exposed by the IExampleBatchSizes type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BatchSize |
Public property | U_Description |
Public property | U_IsDefault |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_TCFixOH |
Public property | U_TCMaterial |
Public property | U_TCResources |
Public property | U_TCTotal |
Public property | U_TCVarOH |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IExampleBatchSizes Interface
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


IExampleBatchSizes Properties

IExampleBatchSizes Interface See Also

The following tables list the members exposed by the IExampleBatchSizes type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BatchSize |
Public property | U_Description |
Public property | U_IsDefault |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_TCFixOH |
Public property | U_TCMaterial |
Public property | U_TCResources |
Public property | U_TCTotal |
Public property | U_TCVarOH |
Top
See Also

Reference

IExampleBatchSizes Interface
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


IExampleBatchSizes.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExampleBatchSizes Interface
IExampleBatchSizes Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


IExampleBatchSizes.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExampleBatchSizes Interface
IExampleBatchSizes Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


IExampleBatchSizes.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExampleBatchSizes Interface
IExampleBatchSizes Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


IExampleBatchSizes.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExampleBatchSizes Interface
IExampleBatchSizes Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


IExampleBatchSizes.U_BatchSize Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BatchSize() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_BatchSize {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_BatchSize {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchSize() : double;
function set U_BatchSize(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExampleBatchSizes Interface
IExampleBatchSizes Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


IExampleBatchSizes.U_Description Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Description() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Description {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Description {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Description() : String;
function set U_Description(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExampleBatchSizes Interface
IExampleBatchSizes Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


IExampleBatchSizes.U_IsDefault Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IsDefault() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_IsDefault {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_IsDefault {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IsDefault() : String;
function set U_IsDefault(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExampleBatchSizes Interface
IExampleBatchSizes Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


IExampleBatchSizes.U_TCFixOH Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TCFixOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_TCFixOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_TCFixOH {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TCFixOH() : double;
function set U_TCFixOH(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExampleBatchSizes Interface
IExampleBatchSizes Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


IExampleBatchSizes.U_TCMaterial Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TCMaterial() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_TCMaterial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_TCMaterial {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TCMaterial() : double;
function set U_TCMaterial(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExampleBatchSizes Interface
IExampleBatchSizes Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


IExampleBatchSizes.U_TCResources Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TCResources() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_TCResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_TCResources {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TCResources() : double;
function set U_TCResources(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExampleBatchSizes Interface
IExampleBatchSizes Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


IExampleBatchSizes.U_TCTotal Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TCTotal() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_TCTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_TCTotal {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TCTotal() : double;
function set U_TCTotal(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExampleBatchSizes Interface
IExampleBatchSizes Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


IExampleBatchSizes.U_TCVarOH Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.CostsComparison
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TCVarOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_TCVarOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_TCVarOH {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TCVarOH() : double;
function set U_TCVarOH(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExampleBatchSizes Interface
IExampleBatchSizes Members
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


IExampleBatchSizes Methods

IExampleBatchSizes Interface See Also

The following tables list the members exposed by the IExampleBatchSizes type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IExampleBatchSizes Interface
CompuTec.ProcessForce.API.Documents.Costing.CostsComparison Namespace


CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | BomComponent | Represents the data of a Bill of Materials component.
Public class | ItemCostingGuiTools | Contains a set of tool methods used on Item Costing form.
Public class | ItemCostingHelper |
Top
Interfaces
 | Name | Description
Public interface | IItemCosting | Item costing object
Public interface | IItemCostingCoproducts | Coproducts for item costing object
Public interface | IItemCostingCostingDetails | Costing details for item costing object
Public interface | IItemCostingOverheadCosts | Overhead costs for item costing object
Public interface | IItemCostingRolledCost | Rolled cost of item costing object
Public interface | IItemCostingRolledCostPrecision | Rolled cost precision of item costing object
Public interface | IItemCostingScrap | Scrap of item costing object
Top
Enumerations
 | Name | Description
Public enumeration | OverheadSubtype |
Public enumeration | OverheadType |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


BomComponent Class

Members See Also

Represents the data of a Bill of Materials component.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BomComponent
    Implements IEquatable(Of BomComponent)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BomComponent : IEquatable<BomComponent>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BomComponent  : public IEquatable<BomComponent^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting.BomComponent
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BomComponent Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


BomComponent Members

BomComponent Class Constructors Methods Properties See Also

Represents the data of a Bill of Materials component.

The following tables list the members exposed by the BomComponent type.

Constructors
 | Name | Description
Public constructor | BomComponent | (Overloaded) Initializes a new instance of BomComponent object.
Top
Properties
 | Name | Description
Public property | ItemCode | Gets or sets an item code.
Public property | Sequence | Gets or sets a sequence no.
Top
Methods
 | Name | Description
Public method | Equals | (Overloaded)
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

BomComponent Class
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


BomComponent Constructor

BomComponent Class See Also

Initializes a new instance of BomComponent object.

Overload List
Name | Description
BomComponent() | Initializes a new instance of BomComponent object.
BomComponent(int, string) | Initializes a new instance of BomComponent object.
See Also

Reference

BomComponent Class
BomComponent Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


BomComponent Properties

BomComponent Class See Also

The following tables list the members exposed by the BomComponent type.

Properties
 | Name | Description
Public property | ItemCode | Gets or sets an item code.
Public property | Sequence | Gets or sets a sequence no.
Top
See Also

Reference

BomComponent Class
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


BomComponent.ItemCode Property

Gets or sets an item code.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ItemCode() : String;
public function set ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BomComponent Class
BomComponent Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


BomComponent.Sequence Property

Gets or sets a sequence no.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Sequence() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int Sequence {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int Sequence {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Sequence() : int;
public function set Sequence(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BomComponent Class
BomComponent Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


BomComponent Methods

BomComponent Class See Also

The following tables list the members exposed by the BomComponent type.

Methods
 | Name | Description
Public method | Equals | (Overloaded)
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

BomComponent Class
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


BomComponent.Equals Method

BomComponent Class See Also

Overload List
Name | Description
Equals(Object) | Determines whether the specified object is equal to the current object. (System.Object).
Equals(BomComponent) |
See Also

Reference

BomComponent Class
BomComponent Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


ItemCostingGuiTools Class

Members See Also

Contains a set of tool methods used on Item Costing form.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ItemCostingGuiTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemCostingGuiTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ItemCostingGuiTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemCostingGuiTools
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting.ItemCostingGuiTools
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingGuiTools Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


ItemCostingGuiTools Members

ItemCostingGuiTools Class Methods See Also

Contains a set of tool methods used on Item Costing form.

The following tables list the members exposed by the ItemCostingGuiTools type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | SetCoproductsColumns | Sets the enabled/disabled state for coproducts columns.
 | SetCostingDetailsColumns | Sets the enabled/disabled state for costing details columns.
 | SetCostingDetailsMatrix | Sets the Costing Details related SAPbouiCOM.Matrix object based on the Costing Details data.
 | SetScrapColumns | Sets the enabled/disabled state for scrap columns.
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
 | UpdateCoproductsScrapTypes | Updates the types of coproducts and scrap data.
 | UpdateCostingDetailsTypes | Updates the types of costing details data.
Top
See Also

Reference

ItemCostingGuiTools Class
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


ItemCostingGuiTools Methods

ItemCostingGuiTools Class See Also

The following tables list the members exposed by the ItemCostingGuiTools type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | SetCoproductsColumns | Sets the enabled/disabled state for coproducts columns.
 | SetCostingDetailsColumns | Sets the enabled/disabled state for costing details columns.
 | SetCostingDetailsMatrix | Sets the Costing Details related SAPbouiCOM.Matrix object based on the Costing Details data.
 | SetScrapColumns | Sets the enabled/disabled state for scrap columns.
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
 | UpdateCoproductsScrapTypes | Updates the types of coproducts and scrap data.
 | UpdateCostingDetailsTypes | Updates the types of costing details data.
Top
See Also

Reference

ItemCostingGuiTools Class
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


ItemCostingGuiTools.SetCoproductsColumns Method

Sets the enabled/disabled state for coproducts columns.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub SetCoproductsColumns( _
   ByVal form As DisposableForm, _
   ByVal udo As IItemCosting _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void SetCoproductsColumns(
   DisposableForm form,
   IItemCosting udo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void SetCoproductsColumns(
   DisposableForm^ form,
   IItemCosting^ udo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function SetCoproductsColumns(
    form : DisposableForm,
    udo : IItemCosting
);
This language is not supported or no code example is available.

Parameters

form

Type: DisposableForm

SAPbouiCOM.Form object.

udo

Type: IItemCosting

Item Costing UDO object.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingGuiTools Class
ItemCostingGuiTools Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


ItemCostingGuiTools.SetCostingDetailsColumns Method

Sets the enabled/disabled state for costing details columns.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub SetCostingDetailsColumns( _
   ByVal form As DisposableForm, _
   ByVal udo As IItemCosting _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void SetCostingDetailsColumns(
   DisposableForm form,
   IItemCosting udo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void SetCostingDetailsColumns(
   DisposableForm^ form,
   IItemCosting^ udo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function SetCostingDetailsColumns(
    form : DisposableForm,
    udo : IItemCosting
);
This language is not supported or no code example is available.

Parameters

form

Type: DisposableForm

SAPbouiCOM.Form object.

udo

Type: IItemCosting

Item Costing UDO object.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingGuiTools Class
ItemCostingGuiTools Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


ItemCostingGuiTools.SetCostingDetailsMatrix Method

Sets the Costing Details related SAPbouiCOM.Matrix object based on the Costing Details data.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub SetCostingDetailsMatrix( _
   ByVal form As DisposableForm, _
   ByVal udo As IItemCosting _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void SetCostingDetailsMatrix(
   DisposableForm form,
   IItemCosting udo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void SetCostingDetailsMatrix(
   DisposableForm^ form,
   IItemCosting^ udo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function SetCostingDetailsMatrix(
    form : DisposableForm,
    udo : IItemCosting
);
This language is not supported or no code example is available.

Parameters

form

Type: DisposableForm

SAPbouiCOM.Form object that represents Item Costing form.

udo

Type: IItemCosting

Item Costing data.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingGuiTools Class
ItemCostingGuiTools Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


ItemCostingGuiTools.SetScrapColumns Method

Sets the enabled/disabled state for scrap columns.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub SetScrapColumns( _
   ByVal form As DisposableForm, _
   ByVal udo As IItemCosting _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void SetScrapColumns(
   DisposableForm form,
   IItemCosting udo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void SetScrapColumns(
   DisposableForm^ form,
   IItemCosting^ udo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function SetScrapColumns(
    form : DisposableForm,
    udo : IItemCosting
);
This language is not supported or no code example is available.

Parameters

form

Type: DisposableForm

SAPbouiCOM.Form object.

udo

Type: IItemCosting

Item Costing UDO object.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingGuiTools Class
ItemCostingGuiTools Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


ItemCostingGuiTools.UpdateCoproductsScrapTypes Method

Updates the types of coproducts and scrap data.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub UpdateCoproductsScrapTypes( _
   ByVal udo As IItemCosting _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void UpdateCoproductsScrapTypes(
   IItemCosting udo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void UpdateCoproductsScrapTypes(
   IItemCosting^ udo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function UpdateCoproductsScrapTypes(
    udo : IItemCosting
);
This language is not supported or no code example is available.

Parameters

udo

Type: IItemCosting

Item costing data.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingGuiTools Class
ItemCostingGuiTools Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


ItemCostingGuiTools.UpdateCostingDetailsTypes Method

Updates the types of costing details data.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub UpdateCostingDetailsTypes( _
   ByVal udo As IItemCosting _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void UpdateCostingDetailsTypes(
   IItemCosting udo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void UpdateCostingDetailsTypes(
   IItemCosting^ udo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function UpdateCostingDetailsTypes(
    udo : IItemCosting
);
This language is not supported or no code example is available.

Parameters

udo

Type: IItemCosting

Item costing data.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingGuiTools Class
ItemCostingGuiTools Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


ItemCostingHelper Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ItemCostingHelper
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemCostingHelper
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ItemCostingHelper
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemCostingHelper
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting.ItemCostingHelper
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingHelper Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


ItemCostingHelper Members

ItemCostingHelper Class Methods See Also

The following tables list the members exposed by the ItemCostingHelper type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | GetCostForBOM |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Classes
 | Name | Description
Public class | CostingDetails |
Top
See Also

Reference

ItemCostingHelper Class
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


CostingDetails Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class CostingDetails
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CostingDetails
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class CostingDetails
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CostingDetails
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting.ItemCostingHelper.CostingDetails
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


CostingDetails Members

CostingDetails Class Methods Properties See Also

The following tables list the members exposed by the CostingDetails type.

Properties
 | Name | Description
Public property | FixedCostOverHead |
Public property | IsPhantom |
Public property | ItemCode |
Public property | MaterialCost |
Public property | ResourceCost |
Public property | Revision |
Public property | VariableCostOverhead |
Public property | WhsCode |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

CostingDetails Class
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


CostingDetails Properties

CostingDetails Class See Also

The following tables list the members exposed by the CostingDetails type.

Properties
 | Name | Description
Public property | FixedCostOverHead |
Public property | IsPhantom |
Public property | ItemCode |
Public property | MaterialCost |
Public property | ResourceCost |
Public property | Revision |
Public property | VariableCostOverhead |
Public property | WhsCode |
Top
See Also

Reference

CostingDetails Class
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


CostingDetails.FixedCostOverHead Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property FixedCostOverHead() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double FixedCostOverHead {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property double FixedCostOverHead {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get FixedCostOverHead() : double;
public function set FixedCostOverHead(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingDetails Class
CostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


CostingDetails.IsPhantom Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property IsPhantom() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool IsPhantom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool IsPhantom {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get IsPhantom() : boolean;
public function set IsPhantom(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingDetails Class
CostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


CostingDetails.ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ItemCode() : String;
public function set ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingDetails Class
CostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


CostingDetails.MaterialCost Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property MaterialCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double MaterialCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property double MaterialCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get MaterialCost() : double;
public function set MaterialCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingDetails Class
CostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


CostingDetails.ResourceCost Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ResourceCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double ResourceCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property double ResourceCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ResourceCost() : double;
public function set ResourceCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingDetails Class
CostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


CostingDetails.Revision Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Revision() : String;
public function set Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingDetails Class
CostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


CostingDetails.VariableCostOverhead Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property VariableCostOverhead() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double VariableCostOverhead {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property double VariableCostOverhead {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get VariableCostOverhead() : double;
public function set VariableCostOverhead(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingDetails Class
CostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


CostingDetails.WhsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get WhsCode() : String;
public function set WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingDetails Class
CostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


CostingDetails Methods

CostingDetails Class See Also

The following tables list the members exposed by the CostingDetails type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

CostingDetails Class
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


ItemCostingHelper Methods

ItemCostingHelper Class See Also

The following tables list the members exposed by the ItemCostingHelper type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | GetCostForBOM |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ItemCostingHelper Class
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


ItemCostingHelper.GetCostForBOM Method

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetCostForBOM( _
   ByVal itemCode As String, _
   ByVal revisionCode As String, _
   ByVal Token As String _
) As List(Of CostingDetails)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static List<CostingDetails> GetCostForBOM(
   string itemCode,
   string revisionCode,
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static List<CostingDetails^>^ GetCostForBOM(
   String^ itemCode,
   String^ revisionCode,
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

itemCode

Type: string

revisionCode

Type: string

Token

Type: string

Return Value

Type: List<CostingDetails>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingHelper Class
ItemCostingHelper Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting Interface

Members See Also

Item costing object

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ItemCosting", TableName = "@CT_PF_OITC",  UDOVersion = "UDO_10", ExludedHttpMethods = "POST,DELETE")> _
Public Interface IItemCosting
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemCosting", TableName = "@CT_PF_OITC",  UDOVersion = "UDO_10", ExludedHttpMethods = "POST,DELETE")]
public interface IItemCosting : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemCosting", TableName = "@CT_PF_OITC",  UDOVersion = "UDO_10", ExludedHttpMethods = "POST,DELETE")]
public interface class IItemCosting : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ItemCosting", TableName = "@CT_PF_OITC",  UDOVersion = "UDO_10", ExludedHttpMethods = "POST,DELETE")
interface IItemCosting
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OITC
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting Members

IItemCosting Interface Methods Properties See Also

Item costing object

The following tables list the members exposed by the IItemCosting type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | Coproducts | Gets or sets coproducts.
Public property | CostingDetails | Gets or sets costing details.
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_BatchSize | Gets the batch size.
Public property | DS_BomTableCode | Gets bill of Materials database ID.
Public property | DS_CostCategoryTableCode | Gets cost category database ID.
Public property | DS_DefaultRoutingCode | Gets the code of a default routing for this item.
Public property | DS_IsBom | Determines if the item has its own bill of materials structure.
Public property | DS_IsBomString | Determines whether or not a BOM structure is created for the item.
Public property | DS_IsDefaultRevision | Determines whether or not the revision is a default revision for this item.
Public property | DS_IsPhantom | Determines whether or not the item is a phantom.
Public property | DS_ItemName | Gets item name.
Public property | DS_ItemUoM | Gets item unit of measure.
Public property | DS_ItemValuationMethod | Gets item valuation method.
Public property | DS_ItemValuationMethodName | Gets item valuation method name.
Public property | DS_MrpType | Gets the MRP type of an item.
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | OverheadCosts | Gets or sets rolled cost with increased precision.
Public property | RolledCostPrecision | Gets or sets rolled cost with increased precision.
Public property | Scrap | Gets or sets scrap.
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_CostCategoryCode | Gets or sets cost category code.
Public property | U_ItemCode | Gets or sets item code.
Public property | U_OptCostBatchSize | Gets or sets the optimal costing batch size.
Public property | U_PFDBVersion | Gets or sets ProcessForce database version.
Public property | U_PFVersion | Gets or sets ProcessForce version.
Public property | U_RevCode | Gets or sets revision code.
Public property | U_Sorting | Gets or sets the sorting value.
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | CheckRollUpCompliance | Checks item costing data against using its rolled cost data defined for a particular warehouse during the roll-up of parent bill of materials.
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | Get | Gets item costing data by item, revision and cost category.
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | NeutralizeRolledCosts | (Overloaded) Neutralizes tje rolled costs.
Public method | RecalculateCostingDetails | Recalculates the costing details.
Public method | RecalculateRolledCosts | (Overloaded) Recalculates the rolled costs.
Public method | RecalculateRolledCostsForWarehouse | Recalculates the Rolled Costs data for a specified warehouse.
Public method | Refresh | Refreshes the costing data based on roll-up routines.
Public method | Refresh2 | Refreshes the costing data based on roll-up routines.
Public method | RefreshCostingDetailsPrices | Refreshes the costing details prices.
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Revaluate | (Overloaded) Revaluates the item costing data for defined warehouses.
Public method | RollUp | Performs a roll-up according to raw material criteria for provided warehouses.
Public method | SynchronizeCoproducts | Synchronizes the coproducts.
Public method | SynchronizeRoutings | Synchronizes the routings.
Public method | SynchronizeScrap | Synchronizes the scrap.
Public method | SynchronizeWarehouses | Synchronizes the item warehouses.
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemCosting Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting Properties

IItemCosting Interface See Also

The following tables list the members exposed by the IItemCosting type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | Coproducts | Gets or sets coproducts.
Public property | CostingDetails | Gets or sets costing details.
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_BatchSize | Gets the batch size.
Public property | DS_BomTableCode | Gets bill of Materials database ID.
Public property | DS_CostCategoryTableCode | Gets cost category database ID.
Public property | DS_DefaultRoutingCode | Gets the code of a default routing for this item.
Public property | DS_IsBom | Determines if the item has its own bill of materials structure.
Public property | DS_IsBomString | Determines whether or not a BOM structure is created for the item.
Public property | DS_IsDefaultRevision | Determines whether or not the revision is a default revision for this item.
Public property | DS_IsPhantom | Determines whether or not the item is a phantom.
Public property | DS_ItemName | Gets item name.
Public property | DS_ItemUoM | Gets item unit of measure.
Public property | DS_ItemValuationMethod | Gets item valuation method.
Public property | DS_ItemValuationMethodName | Gets item valuation method name.
Public property | DS_MrpType | Gets the MRP type of an item.
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | OverheadCosts | Gets or sets rolled cost with increased precision.
Public property | RolledCostPrecision | Gets or sets rolled cost with increased precision.
Public property | Scrap | Gets or sets scrap.
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_CostCategoryCode | Gets or sets cost category code.
Public property | U_ItemCode | Gets or sets item code.
Public property | U_OptCostBatchSize | Gets or sets the optimal costing batch size.
Public property | U_PFDBVersion | Gets or sets ProcessForce database version.
Public property | U_PFVersion | Gets or sets ProcessForce version.
Public property | U_RevCode | Gets or sets revision code.
Public property | U_Sorting | Gets or sets the sorting value.
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IItemCosting Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.Coproducts Property

Gets or sets coproducts.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Coproducts() As IItemCostingCoproducts
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemCostingCoproducts Coproducts {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemCostingCoproducts^ Coproducts {
 IItemCostingCoproducts^ get( );
 void set(
   IItemCostingCoproducts^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Coproducts() : IItemCostingCoproducts;
function set Coproducts(value : IItemCostingCoproducts);
This language is not supported or no code example is available.

Property Value

Type: IItemCostingCoproducts
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.CostingDetails Property

Gets or sets costing details.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property CostingDetails() As IItemCostingCostingDetails
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemCostingCostingDetails CostingDetails {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemCostingCostingDetails^ CostingDetails {
 IItemCostingCostingDetails^ get( );
 void set(
   IItemCostingCostingDetails^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CostingDetails() : IItemCostingCostingDetails;
function set CostingDetails(value : IItemCostingCostingDetails);
This language is not supported or no code example is available.

Property Value

Type: IItemCostingCostingDetails
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.DS_BatchSize Property

Gets the batch size.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_BatchSize() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
double DS_BatchSize {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property double DS_BatchSize {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_BatchSize() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.DS_BomTableCode Property

Gets bill of Materials database ID.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_BomTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_BomTableCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_BomTableCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_BomTableCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.DS_CostCategoryTableCode Property

Gets cost category database ID.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_CostCategoryTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_CostCategoryTableCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_CostCategoryTableCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_CostCategoryTableCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.DS_DefaultRoutingCode Property

Gets the code of a default routing for this item.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_DefaultRoutingCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_DefaultRoutingCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_DefaultRoutingCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_DefaultRoutingCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.DS_IsBom Property

Determines if the item has its own bill of materials structure.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_IsBom() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
bool DS_IsBom {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property bool DS_IsBom {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_IsBom() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.DS_IsBomString Property

Determines whether or not a BOM structure is created for the item.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_IsBomString() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_IsBomString {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_IsBomString {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_IsBomString() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.DS_IsDefaultRevision Property

Determines whether or not the revision is a default revision for this item.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_IsDefaultRevision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_IsDefaultRevision {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_IsDefaultRevision {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_IsDefaultRevision() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.DS_IsPhantom Property

Determines whether or not the item is a phantom.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_IsPhantom() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
bool DS_IsPhantom {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property bool DS_IsPhantom {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_IsPhantom() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.DS_ItemName Property

Gets item name.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.DS_ItemUoM Property

Gets item unit of measure.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_ItemUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemUoM {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemUoM {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemUoM() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.DS_ItemValuationMethod Property

Gets item valuation method.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_ItemValuationMethod() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemValuationMethod {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemValuationMethod {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemValuationMethod() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.DS_ItemValuationMethodName Property

Gets item valuation method name.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_ItemValuationMethodName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemValuationMethodName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemValuationMethodName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemValuationMethodName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.DS_MrpType Property

Gets the MRP type of an item.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_MrpType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_MrpType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_MrpType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_MrpType() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.OverheadCosts Property

Gets or sets rolled cost with increased precision.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property OverheadCosts() As IItemCostingOverheadCosts
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemCostingOverheadCosts OverheadCosts {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemCostingOverheadCosts^ OverheadCosts {
 IItemCostingOverheadCosts^ get( );
 void set(
   IItemCostingOverheadCosts^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OverheadCosts() : IItemCostingOverheadCosts;
function set OverheadCosts(value : IItemCostingOverheadCosts);
This language is not supported or no code example is available.

Property Value

Type: IItemCostingOverheadCosts
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.RolledCostPrecision Property

Gets or sets rolled cost with increased precision.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property RolledCostPrecision() As IItemCostingRolledCostPrecision
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemCostingRolledCostPrecision RolledCostPrecision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemCostingRolledCostPrecision^ RolledCostPrecision {
 IItemCostingRolledCostPrecision^ get( );
 void set(
   IItemCostingRolledCostPrecision^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RolledCostPrecision() : IItemCostingRolledCostPrecision;
function set RolledCostPrecision(value : IItemCostingRolledCostPrecision);
This language is not supported or no code example is available.

Property Value

Type: IItemCostingRolledCostPrecision
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.Scrap Property

Gets or sets scrap.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Scrap() As IItemCostingScrap
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemCostingScrap Scrap {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemCostingScrap^ Scrap {
 IItemCostingScrap^ get( );
 void set(
   IItemCostingScrap^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Scrap() : IItemCostingScrap;
function set Scrap(value : IItemCostingScrap);
This language is not supported or no code example is available.

Property Value

Type: IItemCostingScrap
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.U_CostCategoryCode Property

Gets or sets cost category code.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CostCategoryCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CostCategoryCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CostCategoryCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CostCategoryCode() : String;
function set U_CostCategoryCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.U_ItemCode Property

Gets or sets item code.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_ItemCode() : String;

   AppEngineProperty(Required = true)
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.U_OptCostBatchSize Property

Gets or sets the optimal costing batch size.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OptCostBatchSize() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_OptCostBatchSize {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_OptCostBatchSize {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OptCostBatchSize() : double;
function set U_OptCostBatchSize(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.U_PFDBVersion Property

Gets or sets ProcessForce database version.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.U_PFVersion Property

Gets or sets ProcessForce version.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.U_RevCode Property

Gets or sets revision code.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevCode() : String;
function set U_RevCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.U_Sorting Property

Gets or sets the sorting value.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Sorting() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Sorting {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Sorting {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Sorting() : String;
function set U_Sorting(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting Methods

IItemCosting Interface See Also

The following tables list the members exposed by the IItemCosting type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | CheckRollUpCompliance | Checks item costing data against using its rolled cost data defined for a particular warehouse during the roll-up of parent bill of materials.
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | Get | Gets item costing data by item, revision and cost category.
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | NeutralizeRolledCosts | (Overloaded) Neutralizes tje rolled costs.
Public method | RecalculateCostingDetails | Recalculates the costing details.
Public method | RecalculateRolledCosts | (Overloaded) Recalculates the rolled costs.
Public method | RecalculateRolledCostsForWarehouse | Recalculates the Rolled Costs data for a specified warehouse.
Public method | Refresh | Refreshes the costing data based on roll-up routines.
Public method | Refresh2 | Refreshes the costing data based on roll-up routines.
Public method | RefreshCostingDetailsPrices | Refreshes the costing details prices.
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Revaluate | (Overloaded) Revaluates the item costing data for defined warehouses.
Public method | RollUp | Performs a roll-up according to raw material criteria for provided warehouses.
Public method | SynchronizeCoproducts | Synchronizes the coproducts.
Public method | SynchronizeRoutings | Synchronizes the routings.
Public method | SynchronizeScrap | Synchronizes the scrap.
Public method | SynchronizeWarehouses | Synchronizes the item warehouses.
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemCosting Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.CheckRollUpCompliance Method

Checks item costing data against using its rolled cost data defined for a particular warehouse during the roll-up of parent bill of materials.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CheckRollUpCompliance( _
   Optional ByVal warehouseCode As String = "" _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool CheckRollUpCompliance(
   string warehouseCode = ""
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool CheckRollUpCompliance(
   String^ warehouseCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CheckRollUpCompliance(
    warehouseCode : String
) : boolean;
This language is not supported or no code example is available.

Parameters

warehouseCode

Type: string

Warehouse code.

Return Value

Type: bool

true if rolled cost can be used during the roll-up of parent bill of materials; otherwise false is returned.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.Get Method

Gets item costing data by item, revision and cost category.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function Get( _
   ByVal itemCode As String, _
   ByVal revisionCode As String, _
   ByVal costCategoryCode As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool Get(
   string itemCode,
   string revisionCode,
   string costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool Get(
   String^ itemCode,
   String^ revisionCode,
   String^ costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Get(
    itemCode : String,
    revisionCode : String,
    costCategoryCode : String
) : boolean;
This language is not supported or no code example is available.

Parameters

itemCode

Type: string

Item code.

revisionCode

Type: string

Revision code.

costCategoryCode

Type: string

Cost category code.

Return Value

Type: bool

true if item costing data has been retrieved successfully; otherwise false is returned.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.NeutralizeRolledCosts Method

IItemCosting Interface See Also

Neutralizes tje rolled costs.

Overload List
Name | Description
NeutralizeRolledCosts() | Neutralizes tje rolled costs.
NeutralizeRolledCosts(List<String>) | Neutralizes the rolled costs for provided warehouses.
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.RecalculateCostingDetails Method

Recalculates the costing details.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub RecalculateCostingDetails()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void RecalculateCostingDetails()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void RecalculateCostingDetails()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function RecalculateCostingDetails();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.RecalculateRolledCosts Method

IItemCosting Interface See Also

Recalculates the rolled costs.

Overload List
Name | Description
RecalculateRolledCosts() | Recalculates the rolled costs.
RecalculateRolledCosts(List<String>) | Recalculates the rolled costs for provided warehouses.
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.RecalculateRolledCostsForWarehouse Method

Recalculates the Rolled Costs data for a specified warehouse.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub RecalculateRolledCostsForWarehouse( _
   ByVal whsCode As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void RecalculateRolledCostsForWarehouse(
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void RecalculateRolledCostsForWarehouse(
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function RecalculateRolledCostsForWarehouse(
    whsCode : String
);
This language is not supported or no code example is available.

Parameters

whsCode

Type: string

Warehouse code.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.Refresh Method

Refreshes the costing data based on roll-up routines.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function Refresh() As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Result Refresh()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Result^ Refresh()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Refresh() : Result;
This language is not supported or no code example is available.

Return Value

Type: Result

The result of performed roll-up process.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.Refresh2 Method

Refreshes the costing data based on roll-up routines.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function Refresh2() As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Result Refresh2()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Result^ Refresh2()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Refresh2() : Result;
This language is not supported or no code example is available.

Return Value

Type: Result

The result of performed roll-up process.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.RefreshCostingDetailsPrices Method

Refreshes the costing details prices.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub RefreshCostingDetailsPrices()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void RefreshCostingDetailsPrices()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void RefreshCostingDetailsPrices()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function RefreshCostingDetailsPrices();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.Revaluate Method

IItemCosting Interface See Also

Revaluates the item costing data for defined warehouses.

Overload List
Name | Description
Revaluate(double) | Revaluates the item costing data for all warehouses.
Revaluate(double, string) | Revaluates the item costing data for defined warehouses.
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.RollUp Method

Performs a roll-up according to raw material criteria for provided warehouses.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function RollUp( _
   Optional ByVal warehouses As List(Of String) = null _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Result RollUp(
   List<string> warehouses = null
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Result^ RollUp(
   List<String^>^ warehouses
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

warehouses

Type: List<string>

Warehouses for which the roll-up must be performed.

Return Value

Type: Result

Roll-up result.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.SynchronizeCoproducts Method

Synchronizes the coproducts.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function SynchronizeCoproducts( _
   ByVal coproductsToBeAdded As List(Of String), _
   ByVal coproductsToBeRemoved As List(Of String) _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Result SynchronizeCoproducts(
   List<string> coproductsToBeAdded,
   List<string> coproductsToBeRemoved
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Result^ SynchronizeCoproducts(
   List<String^>^ coproductsToBeAdded,
   List<String^>^ coproductsToBeRemoved
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

coproductsToBeAdded

Type: List<string>

A collection of coproducts that will be added to item costing during the synchronization.

coproductsToBeRemoved

Type: List<string>

A collection of coproducts that will be removed from item costing during the synchronization.

Return Value

Type: Result

Synchronization result.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.SynchronizeRoutings Method

Synchronizes the routings.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function SynchronizeRoutings( _
   ByVal routingsToBeAdded As List(Of String), _
   ByVal routingsToBeRemoved As List(Of String) _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Result SynchronizeRoutings(
   List<string> routingsToBeAdded,
   List<string> routingsToBeRemoved
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Result^ SynchronizeRoutings(
   List<String^>^ routingsToBeAdded,
   List<String^>^ routingsToBeRemoved
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

routingsToBeAdded

Type: List<string>

A collection of routings that will be added to item costing during the synchronization.

routingsToBeRemoved

Type: List<string>

A collection of routings that will be removed from item costing during the synchronization.

Return Value

Type: Result

Synchronization result.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.SynchronizeScrap Method

Synchronizes the scrap.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function SynchronizeScrap( _
   ByVal scrapToBeAdded As List(Of String), _
   ByVal scrapToBeRemoved As List(Of String) _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Result SynchronizeScrap(
   List<string> scrapToBeAdded,
   List<string> scrapToBeRemoved
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Result^ SynchronizeScrap(
   List<String^>^ scrapToBeAdded,
   List<String^>^ scrapToBeRemoved
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

scrapToBeAdded

Type: List<string>

A collection of scrap that will be added to item costing during the synchronization.

scrapToBeRemoved

Type: List<string>

A collection of scrap that will be removed from item costing during the synchronization.

Return Value

Type: Result

Synchronization result.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.SynchronizeWarehouses Method

Synchronizes the item warehouses.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function SynchronizeWarehouses( _
   ByVal warehousesToBeAdded As List(Of String), _
   ByVal warehousesToBeRemoved As List(Of String) _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Result SynchronizeWarehouses(
   List<string> warehousesToBeAdded,
   List<string> warehousesToBeRemoved
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Result^ SynchronizeWarehouses(
   List<String^>^ warehousesToBeAdded,
   List<String^>^ warehousesToBeRemoved
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

warehousesToBeAdded

Type: List<string>

A collection of warehouses that will be added to item costing during the synchronization.

warehousesToBeRemoved

Type: List<string>

A collection of warehouses that will be removed from item costing during the synchronization.

Return Value

Type: Result

Synchronization result.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts Interface

Members See Also

Coproducts for item costing object

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemCostingCoproducts
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemCostingCoproducts)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemCostingCoproducts : IUDOChildBean,
   IEnumerable<IItemCostingCoproducts>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemCostingCoproducts : public IUDOChildBean^,
   public IEnumerable<IItemCostingCoproducts^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_ITC2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts Members

IItemCostingCoproducts Interface Methods Properties See Also

Coproducts for item costing object

The following tables list the members exposed by the IItemCostingCoproducts type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_IsUsed | Determines if the entry is currently in use.
Public property | DS_ItemName | Gets item name.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_FixOH | Gets or sets fixed O/H.
Public property | U_FixOHPrct | Gets or sets fixed O/H %.
Public property | U_FixOHPrctValue | Gets or sets fixed O/H % value.
Public property | U_ItemCode | Gets or sets item code.
Public property | U_ItemCost | Gets or sets item cost.
Public property | U_ItemCostPrct | Gets or sets item cost %.
Public property | U_ItemCostPrctValue | Gets or sets item cost % value.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PriceList | Gets or sets price list.
Public property | U_Remarks | Gets or sets remarks.
Public property | U_RscCost | Gets or sets resource cost.
Public property | U_RscCostPrct | Gets or sets resource cost %.
Public property | U_RscCostPrctValue | Gets or sets resource cost % value.
Public property | U_SequenceNo | Gets or sets sequence no.
Public property | U_Type | Gets or sets type.
Public property | U_Use | Determines if the entry is currently in use.
Public property | U_VarOH | Gets or sets variable O/H.
Public property | U_VarOHPrct | Gets or sets variable O/H %.
Public property | U_VarOHPrctValue | Variable O/H % value.
Public property | U_WhenZero | Gets or sets a default cost when item cost is 0.
Public property | U_WhsCode | Gets or sets warehouse code.
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | Neutralize | Neutralizes coproducts data.
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemCostingCoproducts Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts Properties

IItemCostingCoproducts Interface See Also

The following tables list the members exposed by the IItemCostingCoproducts type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_IsUsed | Determines if the entry is currently in use.
Public property | DS_ItemName | Gets item name.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_FixOH | Gets or sets fixed O/H.
Public property | U_FixOHPrct | Gets or sets fixed O/H %.
Public property | U_FixOHPrctValue | Gets or sets fixed O/H % value.
Public property | U_ItemCode | Gets or sets item code.
Public property | U_ItemCost | Gets or sets item cost.
Public property | U_ItemCostPrct | Gets or sets item cost %.
Public property | U_ItemCostPrctValue | Gets or sets item cost % value.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PriceList | Gets or sets price list.
Public property | U_Remarks | Gets or sets remarks.
Public property | U_RscCost | Gets or sets resource cost.
Public property | U_RscCostPrct | Gets or sets resource cost %.
Public property | U_RscCostPrctValue | Gets or sets resource cost % value.
Public property | U_SequenceNo | Gets or sets sequence no.
Public property | U_Type | Gets or sets type.
Public property | U_Use | Determines if the entry is currently in use.
Public property | U_VarOH | Gets or sets variable O/H.
Public property | U_VarOHPrct | Gets or sets variable O/H %.
Public property | U_VarOHPrctValue | Variable O/H % value.
Public property | U_WhenZero | Gets or sets a default cost when item cost is 0.
Public property | U_WhsCode | Gets or sets warehouse code.
Top
See Also

Reference

IItemCostingCoproducts Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.DS_IsUsed Property

Determines if the entry is currently in use.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_IsUsed() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
bool DS_IsUsed {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property bool DS_IsUsed {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_IsUsed() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.DS_ItemName Property

Gets item name.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_FixOH Property

Gets or sets fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FixOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixOH {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixOH() : double;
function set U_FixOH(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_FixOHPrct Property

Gets or sets fixed O/H %.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FixOHPrct() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixOHPrct {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixOHPrct {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixOHPrct() : double;
function set U_FixOHPrct(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_FixOHPrctValue Property

Gets or sets fixed O/H % value.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FixOHPrctValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixOHPrctValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixOHPrctValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixOHPrctValue() : double;
function set U_FixOHPrctValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_ItemCode Property

Gets or sets item code.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_ItemCost Property

Gets or sets item cost.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ItemCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ItemCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCost() : double;
function set U_ItemCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_ItemCostPrct Property

Gets or sets item cost %.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCostPrct() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ItemCostPrct {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ItemCostPrct {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCostPrct() : double;
function set U_ItemCostPrct(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_ItemCostPrctValue Property

Gets or sets item cost % value.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCostPrctValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ItemCostPrctValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ItemCostPrctValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCostPrctValue() : double;
function set U_ItemCostPrctValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_PriceList Property

Gets or sets price list.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PriceList() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PriceList {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PriceList {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PriceList() : String;
function set U_PriceList(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_Remarks Property

Gets or sets remarks.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_RscCost Property

Gets or sets resource cost.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RscCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RscCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCost() : double;
function set U_RscCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_RscCostPrct Property

Gets or sets resource cost %.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCostPrct() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RscCostPrct {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RscCostPrct {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCostPrct() : double;
function set U_RscCostPrct(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_RscCostPrctValue Property

Gets or sets resource cost % value.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCostPrctValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RscCostPrctValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RscCostPrctValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCostPrctValue() : double;
function set U_RscCostPrctValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_SequenceNo Property

Gets or sets sequence no.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SequenceNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SequenceNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SequenceNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SequenceNo() : int;
function set U_SequenceNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_Type Property

Gets or sets type.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Type() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Type {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Type {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Type() : String;
function set U_Type(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_Use Property

Determines if the entry is currently in use.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Use() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Use {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Use {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Use() : String;
function set U_Use(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_VarOH Property

Gets or sets variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VarOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VarOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VarOH {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VarOH() : double;
function set U_VarOH(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_VarOHPrct Property

Gets or sets variable O/H %.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VarOHPrct() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VarOHPrct {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VarOHPrct {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VarOHPrct() : double;
function set U_VarOHPrct(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_VarOHPrctValue Property

Variable O/H % value.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VarOHPrctValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VarOHPrctValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VarOHPrctValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VarOHPrctValue() : double;
function set U_VarOHPrctValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_WhenZero Property

Gets or sets a default cost when item cost is 0.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhenZero() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_WhenZero {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_WhenZero {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhenZero() : double;
function set U_WhenZero(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.U_WhsCode Property

Gets or sets warehouse code.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts Methods

IItemCostingCoproducts Interface See Also

The following tables list the members exposed by the IItemCostingCoproducts type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | Neutralize | Neutralizes coproducts data.
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemCostingCoproducts Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCoproducts.Neutralize Method

Neutralizes coproducts data.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Neutralize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Neutralize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Neutralize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Neutralize();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCoproducts Interface
IItemCostingCoproducts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails Interface

Members See Also

Costing details for item costing object

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemCostingCostingDetails
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemCostingCostingDetails)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemCostingCostingDetails : IUDOChildBean,
   IEnumerable<IItemCostingCostingDetails>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemCostingCostingDetails : public IUDOChildBean^,
   public IEnumerable<IItemCostingCostingDetails^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_ITC1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails Members

IItemCostingCostingDetails Interface Methods Properties See Also

Costing details for item costing object

The following tables list the members exposed by the IItemCostingCostingDetails type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_IsItemOnStock | Determines if the item is currently on the warehouse stock.
Public property | DS_IsRollUpCompliant | Determines if the entry will be considered during the roll-up calculation.
Public property | DS_IsUsed | Determines if the entry is currently in use.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_FixOH | Gets or sets fixed O/H.
Public property | U_FixOHOther | Gets or sets fixed O/H other.
Public property | U_FixOHPrct | Gets or sets fixed O/H %.
Public property | U_FixOHPrctCost | Gets or sets fixed O/H % cost.
Public property | U_FixOHSubTotal | Gets or sets fixed O/H sub-total.
Public property | U_ItemCost | Gets or sets item cost.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PriceList | Gets or sets price list.
Public property | U_Remarks | Gets or sets remarks.
Public property | U_Total | Gets or sets total.
Public property | U_Type | Gets or sets type.
Public property | U_Use | Determines if the entry is currently in use.
Public property | U_VarOH | Gets or sets variable O/H.
Public property | U_VarOHOther | Gets or sets variable O/H other.
Public property | U_VarOHPrct | Gets or sets variable O/H %.
Public property | U_VarOHPrctCost | Gets or sets variable O/H % cost.
Public property | U_VarOHSubTotal | Gets or sets variable O/H sub-total.
Public property | U_WhenZero | Gets or sets a default cost when item cost is 0.
Public property | U_WhsCode | Gets or sets warehouse code.
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | Neutralize | Neutralizes costing details data.
Public method | Recalculate | Recalculates costing details values.
Public method | RefreshPrice | Refreshes costing details price.
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemCostingCostingDetails Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails Properties

IItemCostingCostingDetails Interface See Also

The following tables list the members exposed by the IItemCostingCostingDetails type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_IsItemOnStock | Determines if the item is currently on the warehouse stock.
Public property | DS_IsRollUpCompliant | Determines if the entry will be considered during the roll-up calculation.
Public property | DS_IsUsed | Determines if the entry is currently in use.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_FixOH | Gets or sets fixed O/H.
Public property | U_FixOHOther | Gets or sets fixed O/H other.
Public property | U_FixOHPrct | Gets or sets fixed O/H %.
Public property | U_FixOHPrctCost | Gets or sets fixed O/H % cost.
Public property | U_FixOHSubTotal | Gets or sets fixed O/H sub-total.
Public property | U_ItemCost | Gets or sets item cost.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PriceList | Gets or sets price list.
Public property | U_Remarks | Gets or sets remarks.
Public property | U_Total | Gets or sets total.
Public property | U_Type | Gets or sets type.
Public property | U_Use | Determines if the entry is currently in use.
Public property | U_VarOH | Gets or sets variable O/H.
Public property | U_VarOHOther | Gets or sets variable O/H other.
Public property | U_VarOHPrct | Gets or sets variable O/H %.
Public property | U_VarOHPrctCost | Gets or sets variable O/H % cost.
Public property | U_VarOHSubTotal | Gets or sets variable O/H sub-total.
Public property | U_WhenZero | Gets or sets a default cost when item cost is 0.
Public property | U_WhsCode | Gets or sets warehouse code.
Top
See Also

Reference

IItemCostingCostingDetails Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.DS_IsItemOnStock Property

Determines if the item is currently on the warehouse stock.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_IsItemOnStock() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
bool DS_IsItemOnStock {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property bool DS_IsItemOnStock {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_IsItemOnStock() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.DS_IsRollUpCompliant Property

Determines if the entry will be considered during the roll-up calculation.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_IsRollUpCompliant() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
bool DS_IsRollUpCompliant {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property bool DS_IsRollUpCompliant {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_IsRollUpCompliant() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.DS_IsUsed Property

Determines if the entry is currently in use.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_IsUsed() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
bool DS_IsUsed {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property bool DS_IsUsed {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_IsUsed() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.U_FixOH Property

Gets or sets fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FixOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixOH {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixOH() : double;
function set U_FixOH(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.U_FixOHOther Property

Gets or sets fixed O/H other.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FixOHOther() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixOHOther {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixOHOther {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixOHOther() : double;
function set U_FixOHOther(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.U_FixOHPrct Property

Gets or sets fixed O/H %.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FixOHPrct() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixOHPrct {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixOHPrct {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixOHPrct() : double;
function set U_FixOHPrct(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.U_FixOHPrctCost Property

Gets or sets fixed O/H % cost.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FixOHPrctCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixOHPrctCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixOHPrctCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixOHPrctCost() : double;
function set U_FixOHPrctCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.U_FixOHSubTotal Property

Gets or sets fixed O/H sub-total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FixOHSubTotal() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixOHSubTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixOHSubTotal {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixOHSubTotal() : double;
function set U_FixOHSubTotal(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.U_ItemCost Property

Gets or sets item cost.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ItemCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ItemCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCost() : double;
function set U_ItemCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.U_PriceList Property

Gets or sets price list.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PriceList() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PriceList {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PriceList {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PriceList() : String;
function set U_PriceList(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.U_Remarks Property

Gets or sets remarks.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.U_Total Property

Gets or sets total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Total() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Total {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Total {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Total() : double;
function set U_Total(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.U_Type Property

Gets or sets type.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Type() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Type {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Type {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Type() : String;
function set U_Type(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.U_Use Property

Determines if the entry is currently in use.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Use() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Use {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Use {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Use() : String;
function set U_Use(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.U_VarOH Property

Gets or sets variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VarOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VarOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VarOH {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VarOH() : double;
function set U_VarOH(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.U_VarOHOther Property

Gets or sets variable O/H other.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VarOHOther() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VarOHOther {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VarOHOther {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VarOHOther() : double;
function set U_VarOHOther(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.U_VarOHPrct Property

Gets or sets variable O/H %.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VarOHPrct() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VarOHPrct {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VarOHPrct {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VarOHPrct() : double;
function set U_VarOHPrct(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.U_VarOHPrctCost Property

Gets or sets variable O/H % cost.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VarOHPrctCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VarOHPrctCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VarOHPrctCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VarOHPrctCost() : double;
function set U_VarOHPrctCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.U_VarOHSubTotal Property

Gets or sets variable O/H sub-total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VarOHSubTotal() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VarOHSubTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VarOHSubTotal {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VarOHSubTotal() : double;
function set U_VarOHSubTotal(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.U_WhenZero Property

Gets or sets a default cost when item cost is 0.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhenZero() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_WhenZero {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_WhenZero {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhenZero() : double;
function set U_WhenZero(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.U_WhsCode Property

Gets or sets warehouse code.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails Methods

IItemCostingCostingDetails Interface See Also

The following tables list the members exposed by the IItemCostingCostingDetails type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | Neutralize | Neutralizes costing details data.
Public method | Recalculate | Recalculates costing details values.
Public method | RefreshPrice | Refreshes costing details price.
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemCostingCostingDetails Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.Neutralize Method

Neutralizes costing details data.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Neutralize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Neutralize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Neutralize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Neutralize();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.Recalculate Method

Recalculates costing details values.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Recalculate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Recalculate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Recalculate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Recalculate();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingCostingDetails.RefreshPrice Method

Refreshes costing details price.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub RefreshPrice()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void RefreshPrice()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void RefreshPrice()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function RefreshPrice();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingCostingDetails Interface
IItemCostingCostingDetails Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingOverheadCosts Interface

Members See Also

Overhead costs for item costing object

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemCostingOverheadCosts
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemCostingOverheadCosts)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemCostingOverheadCosts : IUDOChildBean,
   IEnumerable<IItemCostingOverheadCosts>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemCostingOverheadCosts : public IUDOChildBean^,
   public IEnumerable<IItemCostingOverheadCosts^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_ITC6
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingOverheadCosts Members

IItemCostingOverheadCosts Interface Methods Properties See Also

Overhead costs for item costing object

The following tables list the members exposed by the IItemCostingOverheadCosts type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_IsRowFilled | Determines whether or not the row is filled.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OverheadSubtype | Gets or sets overhead costs subtype.
Public property | U_OverheadType | Gets or sets overhead costs type.
Public property | U_OverheadTypeCode | Gets or sets overhead costs code.
Public property | U_OverheadTypeName | Gets or sets overhead costs name.
Public property | U_Value | Gets or sets the costs value.
Public property | U_WhsCode | Gets or sets warehouse code.
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemCostingOverheadCosts Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingOverheadCosts Properties

IItemCostingOverheadCosts Interface See Also

The following tables list the members exposed by the IItemCostingOverheadCosts type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_IsRowFilled | Determines whether or not the row is filled.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OverheadSubtype | Gets or sets overhead costs subtype.
Public property | U_OverheadType | Gets or sets overhead costs type.
Public property | U_OverheadTypeCode | Gets or sets overhead costs code.
Public property | U_OverheadTypeName | Gets or sets overhead costs name.
Public property | U_Value | Gets or sets the costs value.
Public property | U_WhsCode | Gets or sets warehouse code.
Top
See Also

Reference

IItemCostingOverheadCosts Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingOverheadCosts.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingOverheadCosts Interface
IItemCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingOverheadCosts.DS_IsRowFilled Property

Determines whether or not the row is filled.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_IsRowFilled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
bool DS_IsRowFilled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property bool DS_IsRowFilled {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_IsRowFilled() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingOverheadCosts Interface
IItemCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingOverheadCosts.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingOverheadCosts Interface
IItemCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingOverheadCosts.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingOverheadCosts Interface
IItemCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingOverheadCosts.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingOverheadCosts Interface
IItemCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingOverheadCosts.U_OverheadSubtype Property

Gets or sets overhead costs subtype.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OverheadSubtype() As OverheadSubtype
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
OverheadSubtype U_OverheadSubtype {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property OverheadSubtype U_OverheadSubtype {
 OverheadSubtype get( );
 void set(
   OverheadSubtype value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OverheadSubtype() : OverheadSubtype;
function set U_OverheadSubtype(value : OverheadSubtype);
This language is not supported or no code example is available.

Property Value

Type: OverheadSubtype
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingOverheadCosts Interface
IItemCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingOverheadCosts.U_OverheadType Property

Gets or sets overhead costs type.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OverheadType() As OverheadType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
OverheadType U_OverheadType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property OverheadType U_OverheadType {
 OverheadType get( );
 void set(
   OverheadType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OverheadType() : OverheadType;
function set U_OverheadType(value : OverheadType);
This language is not supported or no code example is available.

Property Value

Type: OverheadType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingOverheadCosts Interface
IItemCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingOverheadCosts.U_OverheadTypeCode Property

Gets or sets overhead costs code.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OverheadTypeCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OverheadTypeCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OverheadTypeCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OverheadTypeCode() : String;
function set U_OverheadTypeCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingOverheadCosts Interface
IItemCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingOverheadCosts.U_OverheadTypeName Property

Gets or sets overhead costs name.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OverheadTypeName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OverheadTypeName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OverheadTypeName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OverheadTypeName() : String;
function set U_OverheadTypeName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingOverheadCosts Interface
IItemCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingOverheadCosts.U_Value Property

Gets or sets the costs value.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Value() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Value {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Value {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Value() : double;
function set U_Value(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingOverheadCosts Interface
IItemCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingOverheadCosts.U_WhsCode Property

Gets or sets warehouse code.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingOverheadCosts Interface
IItemCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingOverheadCosts Methods

IItemCostingOverheadCosts Interface See Also

The following tables list the members exposed by the IItemCostingOverheadCosts type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemCostingOverheadCosts Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost Interface

Members See Also

Rolled cost of item costing object

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IItemCostingRolledCost
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemCostingRolledCost)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IItemCostingRolledCost : IUDOChildBean,
   IEnumerable<IItemCostingRolledCost>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IItemCostingRolledCost : public IUDOChildBean^,
   public IEnumerable<IItemCostingRolledCost^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_ITC4
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost Members

IItemCostingRolledCost Interface Methods Properties See Also

Rolled cost of item costing object

The following tables list the members exposed by the IItemCostingRolledCost type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_IsUsed | Determines if the entry is currently in use.
Public property | DS_RoutingTableCode | Gets or sets routing database ID.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ATLFixOH | Gets or sets ATL fixed O/H.
Public property | U_ATLMaterial | Gets or sets ATL material.
Public property | U_ATLResources | Gets or sets ATL resources.
Public property | U_ATLTotal | Gets or sets ATL total.
Public property | U_ATLVarOH | Gets or sets ATL variable O/H.
Public property | U_CAFixOH | Gets or sets CA fixed O/H.
Public property | U_CAMaterial | Gets or sets CA material.
Public property | U_CAResources | Gets or sets CA resources.
Public property | U_CATotal | Gets or sets CA total.
Public property | U_CAVarOH | Gets or sets CA variable O/H.
Public property | U_LLFixOH | Gets or sets LL fixed O/H.
Public property | U_LLMaterial | Gets or sets LL material.
Public property | U_LLResources | Gets or sets LL resources.
Public property | U_LLTotal | Gets or sets LL total.
Public property | U_LLVarOH | Gets or sets LL variable O/H.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_RtgCode | Gets or sets routing code.
Public property | U_TCFixOH | Gets or sets TC fixed O/H.
Public property | U_TCMaterial | Gets or sets TC material.
Public property | U_TCResources | Gets or sets TC resources.
Public property | U_TCTotal | Gets or sets TC total.
Public property | U_TCVarOH | Gets or sets TC variable O/H.
Public property | U_Use | Determines if the entry is currently in use.
Public property | U_WhsCode | Gets or sets warehouse code.
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | Neutralize | Neutralizes rolled cost data.
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemCostingRolledCost Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost Properties

IItemCostingRolledCost Interface See Also

The following tables list the members exposed by the IItemCostingRolledCost type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_IsUsed | Determines if the entry is currently in use.
Public property | DS_RoutingTableCode | Gets or sets routing database ID.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ATLFixOH | Gets or sets ATL fixed O/H.
Public property | U_ATLMaterial | Gets or sets ATL material.
Public property | U_ATLResources | Gets or sets ATL resources.
Public property | U_ATLTotal | Gets or sets ATL total.
Public property | U_ATLVarOH | Gets or sets ATL variable O/H.
Public property | U_CAFixOH | Gets or sets CA fixed O/H.
Public property | U_CAMaterial | Gets or sets CA material.
Public property | U_CAResources | Gets or sets CA resources.
Public property | U_CATotal | Gets or sets CA total.
Public property | U_CAVarOH | Gets or sets CA variable O/H.
Public property | U_LLFixOH | Gets or sets LL fixed O/H.
Public property | U_LLMaterial | Gets or sets LL material.
Public property | U_LLResources | Gets or sets LL resources.
Public property | U_LLTotal | Gets or sets LL total.
Public property | U_LLVarOH | Gets or sets LL variable O/H.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_RtgCode | Gets or sets routing code.
Public property | U_TCFixOH | Gets or sets TC fixed O/H.
Public property | U_TCMaterial | Gets or sets TC material.
Public property | U_TCResources | Gets or sets TC resources.
Public property | U_TCTotal | Gets or sets TC total.
Public property | U_TCVarOH | Gets or sets TC variable O/H.
Public property | U_Use | Determines if the entry is currently in use.
Public property | U_WhsCode | Gets or sets warehouse code.
Top
See Also

Reference

IItemCostingRolledCost Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.DS_IsUsed Property

Determines if the entry is currently in use.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_IsUsed() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool DS_IsUsed {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool DS_IsUsed {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_IsUsed() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.DS_RoutingTableCode Property

Gets or sets routing database ID.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_RoutingTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_RoutingTableCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_RoutingTableCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_RoutingTableCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_ATLFixOH Property

Gets or sets ATL fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ATLFixOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ATLFixOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ATLFixOH {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ATLFixOH() : double;
function set U_ATLFixOH(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_ATLMaterial Property

Gets or sets ATL material.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ATLMaterial() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ATLMaterial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ATLMaterial {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ATLMaterial() : double;
function set U_ATLMaterial(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_ATLResources Property

Gets or sets ATL resources.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ATLResources() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ATLResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ATLResources {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ATLResources() : double;
function set U_ATLResources(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_ATLTotal Property

Gets or sets ATL total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ATLTotal() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ATLTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ATLTotal {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ATLTotal() : double;
function set U_ATLTotal(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_ATLVarOH Property

Gets or sets ATL variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ATLVarOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ATLVarOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ATLVarOH {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ATLVarOH() : double;
function set U_ATLVarOH(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_CAFixOH Property

Gets or sets CA fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CAFixOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_CAFixOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_CAFixOH {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CAFixOH() : double;
function set U_CAFixOH(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_CAMaterial Property

Gets or sets CA material.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CAMaterial() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_CAMaterial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_CAMaterial {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CAMaterial() : double;
function set U_CAMaterial(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_CAResources Property

Gets or sets CA resources.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CAResources() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_CAResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_CAResources {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CAResources() : double;
function set U_CAResources(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_CATotal Property

Gets or sets CA total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CATotal() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_CATotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_CATotal {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CATotal() : double;
function set U_CATotal(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_CAVarOH Property

Gets or sets CA variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CAVarOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_CAVarOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_CAVarOH {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CAVarOH() : double;
function set U_CAVarOH(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_LLFixOH Property

Gets or sets LL fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LLFixOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_LLFixOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_LLFixOH {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LLFixOH() : double;
function set U_LLFixOH(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_LLMaterial Property

Gets or sets LL material.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LLMaterial() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_LLMaterial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_LLMaterial {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LLMaterial() : double;
function set U_LLMaterial(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_LLResources Property

Gets or sets LL resources.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LLResources() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_LLResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_LLResources {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LLResources() : double;
function set U_LLResources(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_LLTotal Property

Gets or sets LL total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LLTotal() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_LLTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_LLTotal {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LLTotal() : double;
function set U_LLTotal(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_LLVarOH Property

Gets or sets LL variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LLVarOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_LLVarOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_LLVarOH {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LLVarOH() : double;
function set U_LLVarOH(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_RtgCode Property

Gets or sets routing code.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RtgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RtgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgCode() : String;
function set U_RtgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_TCFixOH Property

Gets or sets TC fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TCFixOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_TCFixOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_TCFixOH {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TCFixOH() : double;
function set U_TCFixOH(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_TCMaterial Property

Gets or sets TC material.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TCMaterial() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_TCMaterial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_TCMaterial {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TCMaterial() : double;
function set U_TCMaterial(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_TCResources Property

Gets or sets TC resources.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TCResources() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_TCResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_TCResources {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TCResources() : double;
function set U_TCResources(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_TCTotal Property

Gets or sets TC total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TCTotal() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_TCTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_TCTotal {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TCTotal() : double;
function set U_TCTotal(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_TCVarOH Property

Gets or sets TC variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TCVarOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_TCVarOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_TCVarOH {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TCVarOH() : double;
function set U_TCVarOH(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_Use Property

Determines if the entry is currently in use.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Use() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Use {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Use {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Use() : String;
function set U_Use(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.U_WhsCode Property

Gets or sets warehouse code.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost Methods

IItemCostingRolledCost Interface See Also

The following tables list the members exposed by the IItemCostingRolledCost type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | Neutralize | Neutralizes rolled cost data.
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemCostingRolledCost Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCost.Neutralize Method

Neutralizes rolled cost data.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Neutralize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Neutralize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Neutralize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Neutralize();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCost Interface
IItemCostingRolledCost Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision Interface

Members See Also

Rolled cost precision of item costing object

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemCostingRolledCostPrecision
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemCostingRolledCostPrecision)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemCostingRolledCostPrecision : IUDOChildBean,
   IEnumerable<IItemCostingRolledCostPrecision>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemCostingRolledCostPrecision : public IUDOChildBean^,
   public IEnumerable<IItemCostingRolledCostPrecision^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_ITC5
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision Members

IItemCostingRolledCostPrecision Interface Methods Properties See Also

Rolled cost precision of item costing object

The following tables list the members exposed by the IItemCostingRolledCostPrecision type.

Properties
 | Name | Description
Public property | ATLFixOH | Gets or sets ATL fixed O/H.
Public property | ATLMaterial | Gets or sets ATL material.
Public property | ATLResources | Gets or sets ATL resources.
Public property | ATLTotal | Gets or sets ATL total.
Public property | ATLVarOH | Gets or sets ATL variable O/H.
Public property | CAFixOH | Gets or sets CA fixed O/H.
Public property | CAMaterial | Gets or sets CA material.
Public property | CAResources | Gets or sets CA resources.
Public property | CATotal | Gets or sets CA total.
Public property | CAVarOH | Gets or sets CA variable O/H.
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_ATLFixOH | Gets ATL Fixed O/H.
Public property | DS_ATLMaterial | Gets ATL Material.
Public property | DS_ATLResources | Gets ATL Resources.
Public property | DS_ATLTotal | Gets ATL Total.
Public property | DS_ATLVarOH | Gets ATL Variable O/H.
Public property | DS_CAFixOH | Gets CA Fixed O/H.
Public property | DS_CAMaterial | Gets CA Material.
Public property | DS_CAResources | Gets CA Resources.
Public property | DS_CATotal | Gets CA Total.
Public property | DS_CAVarOH | Gets CA Variable O/H.
Public property | DS_IsUsed | Determines if the entry is currently in use.
Public property | DS_LLFixOH | Gets LL Fixed O/H.
Public property | DS_LLMaterial | Gets LL Material.
Public property | DS_LLResources | Gets LL Resources.
Public property | DS_LLTotal | Gets LL Total.
Public property | DS_LLVarOH | Gets LL Variable O/H.
Public property | DS_RoutingTableCode | Gets or sets routing database ID.
Public property | DS_TCFixOH | Gets TC Fixed O/H.
Public property | DS_TCMaterial | Gets TC Material.
Public property | DS_TCResources | Gets TC Resources.
Public property | DS_TCTotal | Gets TC Total.
Public property | DS_TCVarOH | Gets TC Variable O/H.
Public property | LLFixOH | Gets or sets LL fixed O/H.
Public property | LLMaterial | Gets or sets LL material.
Public property | LLResources | Gets or sets LL resources.
Public property | LLTotal | Gets or sets LL total.
Public property | LLVarOH | Gets or sets LL variable O/H.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | TCFixOH | Gets or sets TC fixed O/H.
Public property | TCMaterial | Gets or sets TC material.
Public property | TCResources | Gets or sets TC resources.
Public property | TCTotal | Gets or sets TC total.
Public property | TCVarOH | Gets or sets TC variable O/H.
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ATLFixOH | Gets or sets ATL fixed O/H.
Public property | U_ATLMaterial | Gets or sets ATL material.
Public property | U_ATLResources | Gets or sets ATL resources.
Public property | U_ATLTotal | Gets or sets ATL total.
Public property | U_ATLVarOH | Gets or sets ATL variable O/H.
Public property | U_CAFixOH | Gets or sets CA fixed O/H.
Public property | U_CAMaterial | Gets or sets CA material.
Public property | U_CAResources | Gets or sets CA resources.
Public property | U_CATotal | Gets or sets CA total.
Public property | U_CAVarOH | Gets or sets CA variable O/H.
Public property | U_LLFixOH | Gets or sets LL fixed O/H.
Public property | U_LLMaterial | Gets or sets LL material.
Public property | U_LLResources | Gets or sets LL resources.
Public property | U_LLTotal | Gets or sets LL total.
Public property | U_LLVarOH | Gets or sets LL variable O/H.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_RtgCode | Gets or sets routing code.
Public property | U_TCFixOH | Gets or sets TC fixed O/H.
Public property | U_TCMaterial | Gets or sets TC material.
Public property | U_TCResources | Gets or sets TC resources.
Public property | U_TCTotal | Gets or sets TC total.
Public property | U_TCVarOH | Gets or sets TC variable O/H.
Public property | U_Use | Determines if the entry is currently in use.
Public property | U_WhsCode | Gets or sets warehouse code.
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | Neutralize | Neutralizes rolled cost data.
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemCostingRolledCostPrecision Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision Properties

IItemCostingRolledCostPrecision Interface See Also

The following tables list the members exposed by the IItemCostingRolledCostPrecision type.

Properties
 | Name | Description
Public property | ATLFixOH | Gets or sets ATL fixed O/H.
Public property | ATLMaterial | Gets or sets ATL material.
Public property | ATLResources | Gets or sets ATL resources.
Public property | ATLTotal | Gets or sets ATL total.
Public property | ATLVarOH | Gets or sets ATL variable O/H.
Public property | CAFixOH | Gets or sets CA fixed O/H.
Public property | CAMaterial | Gets or sets CA material.
Public property | CAResources | Gets or sets CA resources.
Public property | CATotal | Gets or sets CA total.
Public property | CAVarOH | Gets or sets CA variable O/H.
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_ATLFixOH | Gets ATL Fixed O/H.
Public property | DS_ATLMaterial | Gets ATL Material.
Public property | DS_ATLResources | Gets ATL Resources.
Public property | DS_ATLTotal | Gets ATL Total.
Public property | DS_ATLVarOH | Gets ATL Variable O/H.
Public property | DS_CAFixOH | Gets CA Fixed O/H.
Public property | DS_CAMaterial | Gets CA Material.
Public property | DS_CAResources | Gets CA Resources.
Public property | DS_CATotal | Gets CA Total.
Public property | DS_CAVarOH | Gets CA Variable O/H.
Public property | DS_IsUsed | Determines if the entry is currently in use.
Public property | DS_LLFixOH | Gets LL Fixed O/H.
Public property | DS_LLMaterial | Gets LL Material.
Public property | DS_LLResources | Gets LL Resources.
Public property | DS_LLTotal | Gets LL Total.
Public property | DS_LLVarOH | Gets LL Variable O/H.
Public property | DS_RoutingTableCode | Gets or sets routing database ID.
Public property | DS_TCFixOH | Gets TC Fixed O/H.
Public property | DS_TCMaterial | Gets TC Material.
Public property | DS_TCResources | Gets TC Resources.
Public property | DS_TCTotal | Gets TC Total.
Public property | DS_TCVarOH | Gets TC Variable O/H.
Public property | LLFixOH | Gets or sets LL fixed O/H.
Public property | LLMaterial | Gets or sets LL material.
Public property | LLResources | Gets or sets LL resources.
Public property | LLTotal | Gets or sets LL total.
Public property | LLVarOH | Gets or sets LL variable O/H.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | TCFixOH | Gets or sets TC fixed O/H.
Public property | TCMaterial | Gets or sets TC material.
Public property | TCResources | Gets or sets TC resources.
Public property | TCTotal | Gets or sets TC total.
Public property | TCVarOH | Gets or sets TC variable O/H.
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ATLFixOH | Gets or sets ATL fixed O/H.
Public property | U_ATLMaterial | Gets or sets ATL material.
Public property | U_ATLResources | Gets or sets ATL resources.
Public property | U_ATLTotal | Gets or sets ATL total.
Public property | U_ATLVarOH | Gets or sets ATL variable O/H.
Public property | U_CAFixOH | Gets or sets CA fixed O/H.
Public property | U_CAMaterial | Gets or sets CA material.
Public property | U_CAResources | Gets or sets CA resources.
Public property | U_CATotal | Gets or sets CA total.
Public property | U_CAVarOH | Gets or sets CA variable O/H.
Public property | U_LLFixOH | Gets or sets LL fixed O/H.
Public property | U_LLMaterial | Gets or sets LL material.
Public property | U_LLResources | Gets or sets LL resources.
Public property | U_LLTotal | Gets or sets LL total.
Public property | U_LLVarOH | Gets or sets LL variable O/H.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_RtgCode | Gets or sets routing code.
Public property | U_TCFixOH | Gets or sets TC fixed O/H.
Public property | U_TCMaterial | Gets or sets TC material.
Public property | U_TCResources | Gets or sets TC resources.
Public property | U_TCTotal | Gets or sets TC total.
Public property | U_TCVarOH | Gets or sets TC variable O/H.
Public property | U_Use | Determines if the entry is currently in use.
Public property | U_WhsCode | Gets or sets warehouse code.
Top
See Also

Reference

IItemCostingRolledCostPrecision Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.ATLFixOH Property

Gets or sets ATL fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ATLFixOH() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal ATLFixOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal ATLFixOH {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ATLFixOH() : decimal;
function set ATLFixOH(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.ATLMaterial Property

Gets or sets ATL material.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ATLMaterial() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal ATLMaterial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal ATLMaterial {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ATLMaterial() : decimal;
function set ATLMaterial(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.ATLResources Property

Gets or sets ATL resources.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ATLResources() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal ATLResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal ATLResources {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ATLResources() : decimal;
function set ATLResources(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.ATLTotal Property

Gets or sets ATL total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ATLTotal() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal ATLTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal ATLTotal {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ATLTotal() : decimal;
function set ATLTotal(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.ATLVarOH Property

Gets or sets ATL variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ATLVarOH() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal ATLVarOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal ATLVarOH {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ATLVarOH() : decimal;
function set ATLVarOH(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.CAFixOH Property

Gets or sets CA fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property CAFixOH() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal CAFixOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal CAFixOH {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CAFixOH() : decimal;
function set CAFixOH(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.CAMaterial Property

Gets or sets CA material.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property CAMaterial() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal CAMaterial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal CAMaterial {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CAMaterial() : decimal;
function set CAMaterial(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.CAResources Property

Gets or sets CA resources.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property CAResources() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal CAResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal CAResources {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CAResources() : decimal;
function set CAResources(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.CATotal Property

Gets or sets CA total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property CATotal() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal CATotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal CATotal {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CATotal() : decimal;
function set CATotal(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.CAVarOH Property

Gets or sets CA variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property CAVarOH() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal CAVarOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal CAVarOH {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CAVarOH() : decimal;
function set CAVarOH(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_ATLFixOH Property

Gets ATL Fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_ATLFixOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_ATLFixOH {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_ATLFixOH {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_ATLFixOH() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_ATLMaterial Property

Gets ATL Material.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_ATLMaterial() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_ATLMaterial {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_ATLMaterial {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_ATLMaterial() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_ATLResources Property

Gets ATL Resources.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_ATLResources() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_ATLResources {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_ATLResources {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_ATLResources() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_ATLTotal Property

Gets ATL Total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_ATLTotal() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_ATLTotal {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_ATLTotal {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_ATLTotal() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_ATLVarOH Property

Gets ATL Variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_ATLVarOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_ATLVarOH {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_ATLVarOH {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_ATLVarOH() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_CAFixOH Property

Gets CA Fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_CAFixOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_CAFixOH {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_CAFixOH {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_CAFixOH() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_CAMaterial Property

Gets CA Material.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_CAMaterial() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_CAMaterial {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_CAMaterial {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_CAMaterial() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_CAResources Property

Gets CA Resources.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_CAResources() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_CAResources {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_CAResources {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_CAResources() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_CATotal Property

Gets CA Total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_CATotal() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_CATotal {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_CATotal {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_CATotal() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_CAVarOH Property

Gets CA Variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_CAVarOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_CAVarOH {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_CAVarOH {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_CAVarOH() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_IsUsed Property

Determines if the entry is currently in use.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_IsUsed() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
bool DS_IsUsed {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property bool DS_IsUsed {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_IsUsed() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_LLFixOH Property

Gets LL Fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_LLFixOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_LLFixOH {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_LLFixOH {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_LLFixOH() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_LLMaterial Property

Gets LL Material.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_LLMaterial() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_LLMaterial {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_LLMaterial {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_LLMaterial() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_LLResources Property

Gets LL Resources.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_LLResources() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_LLResources {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_LLResources {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_LLResources() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_LLTotal Property

Gets LL Total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_LLTotal() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_LLTotal {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_LLTotal {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_LLTotal() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_LLVarOH Property

Gets LL Variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_LLVarOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_LLVarOH {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_LLVarOH {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_LLVarOH() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_RoutingTableCode Property

Gets or sets routing database ID.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_RoutingTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_RoutingTableCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_RoutingTableCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_RoutingTableCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_TCFixOH Property

Gets TC Fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_TCFixOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_TCFixOH {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_TCFixOH {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_TCFixOH() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_TCMaterial Property

Gets TC Material.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_TCMaterial() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_TCMaterial {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_TCMaterial {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_TCMaterial() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_TCResources Property

Gets TC Resources.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_TCResources() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_TCResources {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_TCResources {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_TCResources() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_TCTotal Property

Gets TC Total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_TCTotal() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_TCTotal {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_TCTotal {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_TCTotal() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.DS_TCVarOH Property

Gets TC Variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_TCVarOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_TCVarOH {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_TCVarOH {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_TCVarOH() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.LLFixOH Property

Gets or sets LL fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property LLFixOH() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal LLFixOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal LLFixOH {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LLFixOH() : decimal;
function set LLFixOH(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.LLMaterial Property

Gets or sets LL material.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property LLMaterial() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal LLMaterial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal LLMaterial {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LLMaterial() : decimal;
function set LLMaterial(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.LLResources Property

Gets or sets LL resources.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property LLResources() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal LLResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal LLResources {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LLResources() : decimal;
function set LLResources(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.LLTotal Property

Gets or sets LL total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property LLTotal() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal LLTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal LLTotal {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LLTotal() : decimal;
function set LLTotal(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.LLVarOH Property

Gets or sets LL variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property LLVarOH() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal LLVarOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal LLVarOH {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LLVarOH() : decimal;
function set LLVarOH(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.TCFixOH Property

Gets or sets TC fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property TCFixOH() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal TCFixOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal TCFixOH {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get TCFixOH() : decimal;
function set TCFixOH(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.TCMaterial Property

Gets or sets TC material.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property TCMaterial() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal TCMaterial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal TCMaterial {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get TCMaterial() : decimal;
function set TCMaterial(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.TCResources Property

Gets or sets TC resources.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property TCResources() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal TCResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal TCResources {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get TCResources() : decimal;
function set TCResources(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.TCTotal Property

Gets or sets TC total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property TCTotal() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal TCTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal TCTotal {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get TCTotal() : decimal;
function set TCTotal(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.TCVarOH Property

Gets or sets TC variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property TCVarOH() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal TCVarOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal TCVarOH {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get TCVarOH() : decimal;
function set TCVarOH(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_ATLFixOH Property

Gets or sets ATL fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ATLFixOH() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ATLFixOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ATLFixOH {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ATLFixOH() : String;
function set U_ATLFixOH(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_ATLMaterial Property

Gets or sets ATL material.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ATLMaterial() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ATLMaterial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ATLMaterial {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ATLMaterial() : String;
function set U_ATLMaterial(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_ATLResources Property

Gets or sets ATL resources.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ATLResources() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ATLResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ATLResources {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ATLResources() : String;
function set U_ATLResources(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_ATLTotal Property

Gets or sets ATL total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ATLTotal() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ATLTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ATLTotal {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ATLTotal() : String;
function set U_ATLTotal(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_ATLVarOH Property

Gets or sets ATL variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ATLVarOH() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ATLVarOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ATLVarOH {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ATLVarOH() : String;
function set U_ATLVarOH(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_CAFixOH Property

Gets or sets CA fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CAFixOH() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CAFixOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CAFixOH {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CAFixOH() : String;
function set U_CAFixOH(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_CAMaterial Property

Gets or sets CA material.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CAMaterial() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CAMaterial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CAMaterial {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CAMaterial() : String;
function set U_CAMaterial(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_CAResources Property

Gets or sets CA resources.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CAResources() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CAResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CAResources {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CAResources() : String;
function set U_CAResources(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_CATotal Property

Gets or sets CA total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CATotal() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CATotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CATotal {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CATotal() : String;
function set U_CATotal(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_CAVarOH Property

Gets or sets CA variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CAVarOH() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CAVarOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CAVarOH {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CAVarOH() : String;
function set U_CAVarOH(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_LLFixOH Property

Gets or sets LL fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LLFixOH() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LLFixOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LLFixOH {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LLFixOH() : String;
function set U_LLFixOH(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_LLMaterial Property

Gets or sets LL material.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LLMaterial() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LLMaterial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LLMaterial {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LLMaterial() : String;
function set U_LLMaterial(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_LLResources Property

Gets or sets LL resources.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LLResources() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LLResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LLResources {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LLResources() : String;
function set U_LLResources(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_LLTotal Property

Gets or sets LL total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LLTotal() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LLTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LLTotal {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LLTotal() : String;
function set U_LLTotal(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_LLVarOH Property

Gets or sets LL variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LLVarOH() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LLVarOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LLVarOH {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LLVarOH() : String;
function set U_LLVarOH(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_RtgCode Property

Gets or sets routing code.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RtgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RtgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgCode() : String;
function set U_RtgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_TCFixOH Property

Gets or sets TC fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TCFixOH() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TCFixOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TCFixOH {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TCFixOH() : String;
function set U_TCFixOH(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_TCMaterial Property

Gets or sets TC material.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TCMaterial() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TCMaterial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TCMaterial {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TCMaterial() : String;
function set U_TCMaterial(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_TCResources Property

Gets or sets TC resources.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TCResources() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TCResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TCResources {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TCResources() : String;
function set U_TCResources(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_TCTotal Property

Gets or sets TC total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TCTotal() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TCTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TCTotal {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TCTotal() : String;
function set U_TCTotal(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_TCVarOH Property

Gets or sets TC variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TCVarOH() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TCVarOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TCVarOH {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TCVarOH() : String;
function set U_TCVarOH(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_Use Property

Determines if the entry is currently in use.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Use() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Use {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Use {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Use() : String;
function set U_Use(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.U_WhsCode Property

Gets or sets warehouse code.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision Methods

IItemCostingRolledCostPrecision Interface See Also

The following tables list the members exposed by the IItemCostingRolledCostPrecision type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | Neutralize | Neutralizes rolled cost data.
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemCostingRolledCostPrecision Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingRolledCostPrecision.Neutralize Method

Neutralizes rolled cost data.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Neutralize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Neutralize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Neutralize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Neutralize();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingRolledCostPrecision Interface
IItemCostingRolledCostPrecision Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap Interface

Members See Also

Scrap of item costing object

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemCostingScrap
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemCostingScrap)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemCostingScrap : IUDOChildBean,
   IEnumerable<IItemCostingScrap>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemCostingScrap : public IUDOChildBean^,
   public IEnumerable<IItemCostingScrap^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_ITC3
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap Members

IItemCostingScrap Interface Methods Properties See Also

Scrap of item costing object

The following tables list the members exposed by the IItemCostingScrap type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_IsUsed | Determines if the entry is currently in use.
Public property | DS_ItemName | Gets item name.
Public property | DS_ScrapType | Gets scrap type.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_FixOH | Gets or sets fixed O/H.
Public property | U_FixOHPrct | Gets or sets fixed O/H %.
Public property | U_FixOHPrctValue | Gets or sets fixed O/H % value.
Public property | U_ItemCode | Gets or sets item code.
Public property | U_ItemCost | Gets or sets item cost.
Public property | U_ItemCostPrct | Gets or sets item cost %.
Public property | U_ItemCostPrctValue | Gets or sets item cost % value.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PriceList | Gets or sets price list.
Public property | U_Remarks | Gets or sets remarks.
Public property | U_RscCost | Gets or sets resource cost.
Public property | U_RscCostPrct | Gets or sets resource cost %.
Public property | U_RscCostPrctValue | Gets or sets resource cost % value.
Public property | U_SequenceNo | Gets or sets sequence no.
Public property | U_Type | Gets or sets type.
Public property | U_Use | Determines if the entry is currently in use.
Public property | U_VarOH | Gets or sets variable O/H.
Public property | U_VarOHPrct | Gets or sets variable O/H %.
Public property | U_VarOHPrctValue | Gets or sets variable O/H % value.
Public property | U_WhenZero | Gets or sets a default cost when item cost is 0.
Public property | U_WhsCode | Gets or sets warehouse code.
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | Neutralize | Neutralizes scrap data.
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemCostingScrap Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap Properties

IItemCostingScrap Interface See Also

The following tables list the members exposed by the IItemCostingScrap type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_IsUsed | Determines if the entry is currently in use.
Public property | DS_ItemName | Gets item name.
Public property | DS_ScrapType | Gets scrap type.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_FixOH | Gets or sets fixed O/H.
Public property | U_FixOHPrct | Gets or sets fixed O/H %.
Public property | U_FixOHPrctValue | Gets or sets fixed O/H % value.
Public property | U_ItemCode | Gets or sets item code.
Public property | U_ItemCost | Gets or sets item cost.
Public property | U_ItemCostPrct | Gets or sets item cost %.
Public property | U_ItemCostPrctValue | Gets or sets item cost % value.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PriceList | Gets or sets price list.
Public property | U_Remarks | Gets or sets remarks.
Public property | U_RscCost | Gets or sets resource cost.
Public property | U_RscCostPrct | Gets or sets resource cost %.
Public property | U_RscCostPrctValue | Gets or sets resource cost % value.
Public property | U_SequenceNo | Gets or sets sequence no.
Public property | U_Type | Gets or sets type.
Public property | U_Use | Determines if the entry is currently in use.
Public property | U_VarOH | Gets or sets variable O/H.
Public property | U_VarOHPrct | Gets or sets variable O/H %.
Public property | U_VarOHPrctValue | Gets or sets variable O/H % value.
Public property | U_WhenZero | Gets or sets a default cost when item cost is 0.
Public property | U_WhsCode | Gets or sets warehouse code.
Top
See Also

Reference

IItemCostingScrap Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.DS_IsUsed Property

Determines if the entry is currently in use.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_IsUsed() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
bool DS_IsUsed {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property bool DS_IsUsed {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_IsUsed() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.DS_ItemName Property

Gets item name.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.DS_ScrapType Property

Gets scrap type.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_ScrapType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ScrapType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ScrapType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ScrapType() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_FixOH Property

Gets or sets fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FixOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixOH {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixOH() : double;
function set U_FixOH(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_FixOHPrct Property

Gets or sets fixed O/H %.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FixOHPrct() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixOHPrct {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixOHPrct {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixOHPrct() : double;
function set U_FixOHPrct(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_FixOHPrctValue Property

Gets or sets fixed O/H % value.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FixOHPrctValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixOHPrctValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixOHPrctValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixOHPrctValue() : double;
function set U_FixOHPrctValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_ItemCode Property

Gets or sets item code.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_ItemCost Property

Gets or sets item cost.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ItemCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ItemCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCost() : double;
function set U_ItemCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_ItemCostPrct Property

Gets or sets item cost %.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCostPrct() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ItemCostPrct {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ItemCostPrct {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCostPrct() : double;
function set U_ItemCostPrct(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_ItemCostPrctValue Property

Gets or sets item cost % value.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCostPrctValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ItemCostPrctValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ItemCostPrctValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCostPrctValue() : double;
function set U_ItemCostPrctValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_PriceList Property

Gets or sets price list.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PriceList() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PriceList {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PriceList {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PriceList() : String;
function set U_PriceList(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_Remarks Property

Gets or sets remarks.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_RscCost Property

Gets or sets resource cost.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RscCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RscCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCost() : double;
function set U_RscCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_RscCostPrct Property

Gets or sets resource cost %.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCostPrct() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RscCostPrct {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RscCostPrct {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCostPrct() : double;
function set U_RscCostPrct(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_RscCostPrctValue Property

Gets or sets resource cost % value.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCostPrctValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RscCostPrctValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RscCostPrctValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCostPrctValue() : double;
function set U_RscCostPrctValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_SequenceNo Property

Gets or sets sequence no.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SequenceNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SequenceNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SequenceNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SequenceNo() : int;
function set U_SequenceNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_Type Property

Gets or sets type.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Type() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Type {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Type {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Type() : String;
function set U_Type(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_Use Property

Determines if the entry is currently in use.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Use() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Use {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Use {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Use() : String;
function set U_Use(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_VarOH Property

Gets or sets variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VarOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VarOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VarOH {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VarOH() : double;
function set U_VarOH(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_VarOHPrct Property

Gets or sets variable O/H %.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VarOHPrct() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VarOHPrct {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VarOHPrct {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VarOHPrct() : double;
function set U_VarOHPrct(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_VarOHPrctValue Property

Gets or sets variable O/H % value.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VarOHPrctValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VarOHPrctValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VarOHPrctValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VarOHPrctValue() : double;
function set U_VarOHPrctValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_WhenZero Property

Gets or sets a default cost when item cost is 0.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhenZero() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_WhenZero {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_WhenZero {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhenZero() : double;
function set U_WhenZero(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.U_WhsCode Property

Gets or sets warehouse code.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap Methods

IItemCostingScrap Interface See Also

The following tables list the members exposed by the IItemCostingScrap type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | Neutralize | Neutralizes scrap data.
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemCostingScrap Interface
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCostingScrap.Neutralize Method

Neutralizes scrap data.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Neutralize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Neutralize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Neutralize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Neutralize();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCostingScrap Interface
IItemCostingScrap Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


OverheadSubtype Enumeration

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Unknown |
Fixed |
FixedOther |
Variable |
VariableOther |
FixedPercentage |
VariablePercentage |
See Also

Reference

CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


OverheadType Enumeration

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Unknown |
Fixed |
Variable |
See Also

Reference

CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | ResourceCostingGuiTools |
Top
Interfaces
 | Name | Description
Public interface | IResourceCosting | Resource costing object
Public interface | IResourceCostingCosts | Costs for resource costing object
Public interface | IResourceCostingOverheadCosts | Represents the detailed overhead costs for resource.
Top
Enumerations
 | Name | Description
Public enumeration | OverheadSubtype |
Public enumeration | OverheadType |
Public enumeration | ResourceTimeType |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ResourceCostingGuiTools Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ResourceCostingGuiTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ResourceCostingGuiTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ResourceCostingGuiTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ResourceCostingGuiTools
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting.ResourceCostingGuiTools
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCostingGuiTools Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


ResourceCostingGuiTools Members

ResourceCostingGuiTools Class Methods See Also

The following tables list the members exposed by the ResourceCostingGuiTools type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | IsEditingEnabled | Determines whether or not the editing of the Resource Costing entries for the 000 cost category is enabled.
 | SetCostsMatrix | Sets the Costs related SAPbouiCOM.Matrix object on the Resource Costing form.
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ResourceCostingGuiTools Class
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


ResourceCostingGuiTools Methods

ResourceCostingGuiTools Class See Also

The following tables list the members exposed by the ResourceCostingGuiTools type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | IsEditingEnabled | Determines whether or not the editing of the Resource Costing entries for the 000 cost category is enabled.
 | SetCostsMatrix | Sets the Costs related SAPbouiCOM.Matrix object on the Resource Costing form.
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ResourceCostingGuiTools Class
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


ResourceCostingGuiTools.IsEditingEnabled Method

Determines whether or not the editing of the Resource Costing entries for the 000 cost category is enabled.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function IsEditingEnabled( _
   ByVal Token As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool IsEditingEnabled(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool IsEditingEnabled(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function IsEditingEnabled(
    Token : String
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: bool

true if the editing of the Resource Costing entries for the 000 cost category is enabled; otherwise, false

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCostingGuiTools Class
ResourceCostingGuiTools Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


ResourceCostingGuiTools.SetCostsMatrix Method

Sets the Costs related SAPbouiCOM.Matrix object on the Resource Costing form.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub SetCostsMatrix( _
   ByVal form As Form, _
   ByVal enable As Boolean _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void SetCostsMatrix(
   Form form,
   bool enable
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void SetCostsMatrix(
   Form^ form,
   bool enable
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function SetCostsMatrix(
    form : Form,
    enable : boolean
);
This language is not supported or no code example is available.

Parameters

form

Type: Form

SAPbouiCOM.Form object that represents an instance of the Resource Costing form.

enable

Type: bool

Determines whether all editable columns must be enabled or disabled.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCostingGuiTools Class
ResourceCostingGuiTools Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting Interface

Members See Also

Resource costing object

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ResourceCosting", TableName = "@CT_PF_ORCT", UDOVersion = "UDO_10", ExludedHttpMethods = "POST,DELETE")> _
Public Interface IResourceCosting
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ResourceCosting", TableName = "@CT_PF_ORCT", UDOVersion = "UDO_10", ExludedHttpMethods = "POST,DELETE")]
public interface IResourceCosting : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ResourceCosting", TableName = "@CT_PF_ORCT", UDOVersion = "UDO_10", ExludedHttpMethods = "POST,DELETE")]
public interface class IResourceCosting : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ResourceCosting", TableName = "@CT_PF_ORCT", UDOVersion = "UDO_10", ExludedHttpMethods = "POST,DELETE")
interface IResourceCosting
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ORCT
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting Members

IResourceCosting Interface Methods Properties See Also

Resource costing object

The following tables list the members exposed by the IResourceCosting type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | Costs | Gets or sets the costs.
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_CostCategoryTableCode | Gets cost category database ID.
Public property | DS_ResourceTableCode | Gets resource database ID.
Public property | DS_RscName | Gets resource name.
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | OverheadCosts | Gets or sets the overhead costs.
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_CostCategoryCode | Gets or sets cost category code.
Public property | U_PFDBVersion | Gets or sets ProcessForce database version.
Public property | U_PFVersion | Gets or sets ProcessForce version.
Public property | U_RscCode | Gets or sets resource code.
Public property | U_Sorting | Gets or sets the sorting value.
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | Get | Gets resource costing data by resource code and cost category code.
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IResourceCosting Interface
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting Properties

IResourceCosting Interface See Also

The following tables list the members exposed by the IResourceCosting type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | Costs | Gets or sets the costs.
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_CostCategoryTableCode | Gets cost category database ID.
Public property | DS_ResourceTableCode | Gets resource database ID.
Public property | DS_RscName | Gets resource name.
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | OverheadCosts | Gets or sets the overhead costs.
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_CostCategoryCode | Gets or sets cost category code.
Public property | U_PFDBVersion | Gets or sets ProcessForce database version.
Public property | U_PFVersion | Gets or sets ProcessForce version.
Public property | U_RscCode | Gets or sets resource code.
Public property | U_Sorting | Gets or sets the sorting value.
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IResourceCosting Interface
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.Costs Property

Gets or sets the costs.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Costs() As IResourceCostingCosts
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IResourceCostingCosts Costs {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IResourceCostingCosts^ Costs {
 IResourceCostingCosts^ get( );
 void set(
   IResourceCostingCosts^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Costs() : IResourceCostingCosts;
function set Costs(value : IResourceCostingCosts);
This language is not supported or no code example is available.

Property Value

Type: IResourceCostingCosts
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.DS_CostCategoryTableCode Property

Gets cost category database ID.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_CostCategoryTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_CostCategoryTableCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_CostCategoryTableCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_CostCategoryTableCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.DS_ResourceTableCode Property

Gets resource database ID.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_ResourceTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ResourceTableCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ResourceTableCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ResourceTableCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.DS_RscName Property

Gets resource name.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_RscName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_RscName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_RscName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_RscName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.OverheadCosts Property

Gets or sets the overhead costs.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property OverheadCosts() As IResourceCostingOverheadCosts
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IResourceCostingOverheadCosts OverheadCosts {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IResourceCostingOverheadCosts^ OverheadCosts {
 IResourceCostingOverheadCosts^ get( );
 void set(
   IResourceCostingOverheadCosts^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OverheadCosts() : IResourceCostingOverheadCosts;
function set OverheadCosts(value : IResourceCostingOverheadCosts);
This language is not supported or no code example is available.

Property Value

Type: IResourceCostingOverheadCosts
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.U_CostCategoryCode Property

Gets or sets cost category code.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CostCategoryCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CostCategoryCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CostCategoryCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CostCategoryCode() : String;
function set U_CostCategoryCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.U_PFDBVersion Property

Gets or sets ProcessForce database version.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.U_PFVersion Property

Gets or sets ProcessForce version.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.U_RscCode Property

Gets or sets resource code.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_RscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_RscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_RscCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_RscCode() : String;

   AppEngineProperty(Required = true)
function set U_RscCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.U_Sorting Property

Gets or sets the sorting value.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Sorting() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Sorting {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Sorting {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Sorting() : String;
function set U_Sorting(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting Methods

IResourceCosting Interface See Also

The following tables list the members exposed by the IResourceCosting type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | Get | Gets resource costing data by resource code and cost category code.
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IResourceCosting Interface
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCosting.Get Method

Gets resource costing data by resource code and cost category code.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function Get( _
   ByVal resourceCode As String, _
   ByVal costCategoryCode As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool Get(
   string resourceCode,
   string costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool Get(
   String^ resourceCode,
   String^ costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Get(
    resourceCode : String,
    costCategoryCode : String
) : boolean;
This language is not supported or no code example is available.

Parameters

resourceCode

Type: string

Resource code.

costCategoryCode

Type: string

Cost category code.

Return Value

Type: bool

true if resource costing data has been retrieved successfully; otherwise false is returned.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCosting Interface
IResourceCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts Interface

Members See Also

Costs for resource costing object

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IResourceCostingCosts
    Inherits IUDOChildBean, _
             IEnumerable(Of IResourceCostingCosts)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IResourceCostingCosts : IUDOChildBean,
   IEnumerable<IResourceCostingCosts>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IResourceCostingCosts : public IUDOChildBean^,
   public IEnumerable<IResourceCostingCosts^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_RCT1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts Members

IResourceCostingCosts Interface Methods Properties See Also

Costs for resource costing object

The following tables list the members exposed by the IResourceCostingCosts type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_CostType | Gets or sets cost type.
Public property | U_FixOH | Gets or sets fixed O/H.
Public property | U_FixOHOther | Gets or sets fixed O/H other.
Public property | U_FixOHPrct | Gets or sets fixed O/H %.
Public property | U_FixOHPrctCost | Gets or sets fixed O/H % cost.
Public property | U_FixOHSubTotal | Gets or sets fixed O/H sub-total.
Public property | U_HourRate | Gets or sets hourly rate.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Remarks | Gets or sets remarks.
Public property | U_Total | Gets or sets total.
Public property | U_VarOH | Gets or sets variable O/H.
Public property | U_VarOHOther | Gets or sets variable O/H other.
Public property | U_VarOHPrct | Gets or sets variable O/H %.
Public property | U_VarOHPrctCost | Gets or sets variable O/H % cost.
Public property | U_VarOHSubTotal | Gets or sets variable O/H sub-total.
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IResourceCostingCosts Interface
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts Properties

IResourceCostingCosts Interface See Also

The following tables list the members exposed by the IResourceCostingCosts type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_CostType | Gets or sets cost type.
Public property | U_FixOH | Gets or sets fixed O/H.
Public property | U_FixOHOther | Gets or sets fixed O/H other.
Public property | U_FixOHPrct | Gets or sets fixed O/H %.
Public property | U_FixOHPrctCost | Gets or sets fixed O/H % cost.
Public property | U_FixOHSubTotal | Gets or sets fixed O/H sub-total.
Public property | U_HourRate | Gets or sets hourly rate.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Remarks | Gets or sets remarks.
Public property | U_Total | Gets or sets total.
Public property | U_VarOH | Gets or sets variable O/H.
Public property | U_VarOHOther | Gets or sets variable O/H other.
Public property | U_VarOHPrct | Gets or sets variable O/H %.
Public property | U_VarOHPrctCost | Gets or sets variable O/H % cost.
Public property | U_VarOHSubTotal | Gets or sets variable O/H sub-total.
Top
See Also

Reference

IResourceCostingCosts Interface
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingCosts Interface
IResourceCostingCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingCosts Interface
IResourceCostingCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingCosts Interface
IResourceCostingCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingCosts Interface
IResourceCostingCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts.U_CostType Property

Gets or sets cost type.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CostType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CostType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CostType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CostType() : String;
function set U_CostType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingCosts Interface
IResourceCostingCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts.U_FixOH Property

Gets or sets fixed O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FixOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixOH {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixOH() : double;
function set U_FixOH(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingCosts Interface
IResourceCostingCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts.U_FixOHOther Property

Gets or sets fixed O/H other.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FixOHOther() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixOHOther {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixOHOther {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixOHOther() : double;
function set U_FixOHOther(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingCosts Interface
IResourceCostingCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts.U_FixOHPrct Property

Gets or sets fixed O/H %.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FixOHPrct() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixOHPrct {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixOHPrct {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixOHPrct() : double;
function set U_FixOHPrct(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingCosts Interface
IResourceCostingCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts.U_FixOHPrctCost Property

Gets or sets fixed O/H % cost.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FixOHPrctCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixOHPrctCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixOHPrctCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixOHPrctCost() : double;
function set U_FixOHPrctCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingCosts Interface
IResourceCostingCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts.U_FixOHSubTotal Property

Gets or sets fixed O/H sub-total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FixOHSubTotal() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixOHSubTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixOHSubTotal {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixOHSubTotal() : double;
function set U_FixOHSubTotal(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingCosts Interface
IResourceCostingCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts.U_HourRate Property

Gets or sets hourly rate.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_HourRate() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_HourRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_HourRate {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_HourRate() : double;
function set U_HourRate(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingCosts Interface
IResourceCostingCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts.U_Remarks Property

Gets or sets remarks.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingCosts Interface
IResourceCostingCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts.U_Total Property

Gets or sets total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Total() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Total {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Total {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Total() : double;
function set U_Total(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingCosts Interface
IResourceCostingCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts.U_VarOH Property

Gets or sets variable O/H.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VarOH() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VarOH {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VarOH {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VarOH() : double;
function set U_VarOH(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingCosts Interface
IResourceCostingCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts.U_VarOHOther Property

Gets or sets variable O/H other.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VarOHOther() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VarOHOther {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VarOHOther {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VarOHOther() : double;
function set U_VarOHOther(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingCosts Interface
IResourceCostingCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts.U_VarOHPrct Property

Gets or sets variable O/H %.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VarOHPrct() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VarOHPrct {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VarOHPrct {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VarOHPrct() : double;
function set U_VarOHPrct(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingCosts Interface
IResourceCostingCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts.U_VarOHPrctCost Property

Gets or sets variable O/H % cost.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VarOHPrctCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VarOHPrctCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VarOHPrctCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VarOHPrctCost() : double;
function set U_VarOHPrctCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingCosts Interface
IResourceCostingCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts.U_VarOHSubTotal Property

Gets or sets variable O/H sub-total.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VarOHSubTotal() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VarOHSubTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VarOHSubTotal {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VarOHSubTotal() : double;
function set U_VarOHSubTotal(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingCosts Interface
IResourceCostingCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingCosts Methods

IResourceCostingCosts Interface See Also

The following tables list the members exposed by the IResourceCostingCosts type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IResourceCostingCosts Interface
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingOverheadCosts Interface

Members See Also

Represents the detailed overhead costs for resource.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IResourceCostingOverheadCosts
    Inherits IUDOChildBean, _
             IEnumerable(Of IResourceCostingOverheadCosts)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IResourceCostingOverheadCosts : IUDOChildBean,
   IEnumerable<IResourceCostingOverheadCosts>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IResourceCostingOverheadCosts : public IUDOChildBean^,
   public IEnumerable<IResourceCostingOverheadCosts^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_RCT2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingOverheadCosts Members

IResourceCostingOverheadCosts Interface Methods Properties See Also

Represents the detailed overhead costs for resource.

The following tables list the members exposed by the IResourceCostingOverheadCosts type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_IsRowFilled | Determines whether or not the row is filled.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OverheadSubtype | Gets or sets the overhead subtype.
Public property | U_OverheadType | Gets or sets the overhead type.
Public property | U_OverheadTypeCode | Gets or sets the code of overhead entry.
Public property | U_OverheadTypeName | Gets or sets the description of overhead entry.
Public property | U_ResourceTimeType | Gets or sets the time type of resource.
Public property | U_Value | Gets or sets the cost value.
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IResourceCostingOverheadCosts Interface
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingOverheadCosts Properties

IResourceCostingOverheadCosts Interface See Also

The following tables list the members exposed by the IResourceCostingOverheadCosts type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_IsRowFilled | Determines whether or not the row is filled.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OverheadSubtype | Gets or sets the overhead subtype.
Public property | U_OverheadType | Gets or sets the overhead type.
Public property | U_OverheadTypeCode | Gets or sets the code of overhead entry.
Public property | U_OverheadTypeName | Gets or sets the description of overhead entry.
Public property | U_ResourceTimeType | Gets or sets the time type of resource.
Public property | U_Value | Gets or sets the cost value.
Top
See Also

Reference

IResourceCostingOverheadCosts Interface
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingOverheadCosts.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingOverheadCosts Interface
IResourceCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingOverheadCosts.DS_IsRowFilled Property

Determines whether or not the row is filled.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_IsRowFilled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
bool DS_IsRowFilled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property bool DS_IsRowFilled {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_IsRowFilled() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingOverheadCosts Interface
IResourceCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingOverheadCosts.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingOverheadCosts Interface
IResourceCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingOverheadCosts.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingOverheadCosts Interface
IResourceCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingOverheadCosts.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingOverheadCosts Interface
IResourceCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingOverheadCosts.U_OverheadSubtype Property

Gets or sets the overhead subtype.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OverheadSubtype() As OverheadSubtype
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
OverheadSubtype U_OverheadSubtype {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property OverheadSubtype U_OverheadSubtype {
 OverheadSubtype get( );
 void set(
   OverheadSubtype value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OverheadSubtype() : OverheadSubtype;
function set U_OverheadSubtype(value : OverheadSubtype);
This language is not supported or no code example is available.

Property Value

Type: OverheadSubtype
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingOverheadCosts Interface
IResourceCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingOverheadCosts.U_OverheadType Property

Gets or sets the overhead type.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OverheadType() As OverheadType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
OverheadType U_OverheadType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property OverheadType U_OverheadType {
 OverheadType get( );
 void set(
   OverheadType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OverheadType() : OverheadType;
function set U_OverheadType(value : OverheadType);
This language is not supported or no code example is available.

Property Value

Type: OverheadType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingOverheadCosts Interface
IResourceCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingOverheadCosts.U_OverheadTypeCode Property

Gets or sets the code of overhead entry.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OverheadTypeCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OverheadTypeCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OverheadTypeCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OverheadTypeCode() : String;
function set U_OverheadTypeCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingOverheadCosts Interface
IResourceCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingOverheadCosts.U_OverheadTypeName Property

Gets or sets the description of overhead entry.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OverheadTypeName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OverheadTypeName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OverheadTypeName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OverheadTypeName() : String;
function set U_OverheadTypeName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingOverheadCosts Interface
IResourceCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingOverheadCosts.U_ResourceTimeType Property

Gets or sets the time type of resource.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ResourceTimeType() As ResourceTimeType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ResourceTimeType U_ResourceTimeType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ResourceTimeType U_ResourceTimeType {
 ResourceTimeType get( );
 void set(
   ResourceTimeType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ResourceTimeType() : ResourceTimeType;
function set U_ResourceTimeType(value : ResourceTimeType);
This language is not supported or no code example is available.

Property Value

Type: ResourceTimeType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingOverheadCosts Interface
IResourceCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingOverheadCosts.U_Value Property

Gets or sets the cost value.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Value() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Value {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Value {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Value() : double;
function set U_Value(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCostingOverheadCosts Interface
IResourceCostingOverheadCosts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


IResourceCostingOverheadCosts Methods

IResourceCostingOverheadCosts Interface See Also

The following tables list the members exposed by the IResourceCostingOverheadCosts type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IResourceCostingOverheadCosts Interface
CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


OverheadSubtype Enumeration

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Unknown |
Fixed |
FixedOther |
Variable |
VariableOther |
FixedPercentage |
VariablePercentage |
See Also

Reference

CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


OverheadType Enumeration

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Unknown |
Fixed |
Variable |
See Also

Reference

CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


ResourceTimeType Enumeration

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Unknown |
Queue |
Setup |
Run |
Stock |
See Also

Reference

CompuTec.ProcessForce.API.Documents.Costing.ResourceCosting Namespace


CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IResourcesAccounting | Resource accounting object
Public interface | IResourcesAccountingAccounts | Accounts for resource accounting object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IResourcesAccounting Interface

Members See Also

Resource accounting object

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ResourcesAccounting", TableName = "@CT_PF_ORAC", UDOVersion = "UDO_10")> _
Public Interface IResourcesAccounting
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ResourcesAccounting", TableName = "@CT_PF_ORAC", UDOVersion = "UDO_10")]
public interface IResourcesAccounting : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ResourcesAccounting", TableName = "@CT_PF_ORAC", UDOVersion = "UDO_10")]
public interface class IResourcesAccounting : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ResourcesAccounting", TableName = "@CT_PF_ORAC", UDOVersion = "UDO_10")
interface IResourcesAccounting
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ORAC
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccounting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting Members

IResourcesAccounting Interface Methods Properties See Also

Resource accounting object

The following tables list the members exposed by the IResourcesAccounting type.

Properties
 | Name | Description
Public property | AccountCFLIdList |
Public property | Accounts |
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IResourcesAccounting Interface
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting Properties

IResourcesAccounting Interface See Also

The following tables list the members exposed by the IResourcesAccounting type.

Properties
 | Name | Description
Public property | AccountCFLIdList |
Public property | Accounts |
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IResourcesAccounting Interface
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting.AccountCFLIdList Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property AccountCFLIdList() As List(Of String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<string> AccountCFLIdList {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property List<String^>^ AccountCFLIdList {
 List<String^>^ get( );
 void set(
   List<String^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<string>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccounting Interface
IResourcesAccounting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting.Accounts Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Accounts() As IResourcesAccountingAccounts
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IResourcesAccountingAccounts Accounts {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IResourcesAccountingAccounts^ Accounts {
 IResourcesAccountingAccounts^ get( );
 void set(
   IResourcesAccountingAccounts^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Accounts() : IResourcesAccountingAccounts;
function set Accounts(value : IResourcesAccountingAccounts);
This language is not supported or no code example is available.

Property Value

Type: IResourcesAccountingAccounts
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccounting Interface
IResourcesAccounting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccounting Interface
IResourcesAccounting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccounting Interface
IResourcesAccounting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccounting Interface
IResourcesAccounting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccounting Interface
IResourcesAccounting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccounting Interface
IResourcesAccounting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccounting Interface
IResourcesAccounting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccounting Interface
IResourcesAccounting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
function set Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccounting Interface
IResourcesAccounting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccounting Interface
IResourcesAccounting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccounting Interface
IResourcesAccounting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccounting Interface
IResourcesAccounting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccounting Interface
IResourcesAccounting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccounting Interface
IResourcesAccounting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccounting Interface
IResourcesAccounting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccounting Interface
IResourcesAccounting Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccounting Methods

IResourcesAccounting Interface See Also

The following tables list the members exposed by the IResourcesAccounting type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IResourcesAccounting Interface
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts Interface

Members See Also

Accounts for resource accounting object

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IResourcesAccountingAccounts
    Inherits IUDOChildBean, _
             IEnumerable(Of IResourcesAccountingAccounts)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IResourcesAccountingAccounts : IUDOChildBean,
   IEnumerable<IResourcesAccountingAccounts>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IResourcesAccountingAccounts : public IUDOChildBean^,
   public IEnumerable<IResourcesAccountingAccounts^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_RAC1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts Members

IResourcesAccountingAccounts Interface Methods Properties See Also

Accounts for resource accounting object

The following tables list the members exposed by the IResourcesAccountingAccounts type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_QueueTA |
Public property | U_QueueTFOA |
Public property | U_QueueTFOVA |
Public property | U_QueueTVA |
Public property | U_QueueTVOA |
Public property | U_QueueTVOVA |
Public property | U_RunTA |
Public property | U_RunTFOA |
Public property | U_RunTFOVA |
Public property | U_RunTVA |
Public property | U_RunTVOA |
Public property | U_RunTVOVA |
Public property | U_SetupTA |
Public property | U_SetupTFOA |
Public property | U_SetupTFOVA |
Public property | U_SetupTVA |
Public property | U_SetupTVOA |
Public property | U_SetupTVOVA |
Public property | U_StockTA |
Public property | U_StockTFOA |
Public property | U_StockTFOVA |
Public property | U_StockTVA |
Public property | U_StockTVOA |
Public property | U_StockTVOVA |
Public property | U_Title |
Public property | U_WIP |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IResourcesAccountingAccounts Interface
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts Properties

IResourcesAccountingAccounts Interface See Also

The following tables list the members exposed by the IResourcesAccountingAccounts type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_QueueTA |
Public property | U_QueueTFOA |
Public property | U_QueueTFOVA |
Public property | U_QueueTVA |
Public property | U_QueueTVOA |
Public property | U_QueueTVOVA |
Public property | U_RunTA |
Public property | U_RunTFOA |
Public property | U_RunTFOVA |
Public property | U_RunTVA |
Public property | U_RunTVOA |
Public property | U_RunTVOVA |
Public property | U_SetupTA |
Public property | U_SetupTFOA |
Public property | U_SetupTFOVA |
Public property | U_SetupTVA |
Public property | U_SetupTVOA |
Public property | U_SetupTVOVA |
Public property | U_StockTA |
Public property | U_StockTFOA |
Public property | U_StockTFOVA |
Public property | U_StockTVA |
Public property | U_StockTVOA |
Public property | U_StockTVOVA |
Public property | U_Title |
Public property | U_WIP |
Top
See Also

Reference

IResourcesAccountingAccounts Interface
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_QueueTA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QueueTA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_QueueTA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_QueueTA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueTA() : String;
function set U_QueueTA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_QueueTFOA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QueueTFOA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_QueueTFOA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_QueueTFOA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueTFOA() : String;
function set U_QueueTFOA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_QueueTFOVA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QueueTFOVA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_QueueTFOVA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_QueueTFOVA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueTFOVA() : String;
function set U_QueueTFOVA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_QueueTVA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QueueTVA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_QueueTVA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_QueueTVA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueTVA() : String;
function set U_QueueTVA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_QueueTVOA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QueueTVOA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_QueueTVOA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_QueueTVOA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueTVOA() : String;
function set U_QueueTVOA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_QueueTVOVA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QueueTVOVA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_QueueTVOVA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_QueueTVOVA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueTVOVA() : String;
function set U_QueueTVOVA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_RunTA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RunTA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RunTA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RunTA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunTA() : String;
function set U_RunTA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_RunTFOA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RunTFOA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RunTFOA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RunTFOA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunTFOA() : String;
function set U_RunTFOA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_RunTFOVA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RunTFOVA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RunTFOVA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RunTFOVA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunTFOVA() : String;
function set U_RunTFOVA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_RunTVA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RunTVA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RunTVA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RunTVA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunTVA() : String;
function set U_RunTVA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_RunTVOA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RunTVOA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RunTVOA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RunTVOA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunTVOA() : String;
function set U_RunTVOA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_RunTVOVA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RunTVOVA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RunTVOVA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RunTVOVA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunTVOVA() : String;
function set U_RunTVOVA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_SetupTA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SetupTA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SetupTA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SetupTA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupTA() : String;
function set U_SetupTA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_SetupTFOA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SetupTFOA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SetupTFOA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SetupTFOA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupTFOA() : String;
function set U_SetupTFOA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_SetupTFOVA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SetupTFOVA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SetupTFOVA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SetupTFOVA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupTFOVA() : String;
function set U_SetupTFOVA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_SetupTVA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SetupTVA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SetupTVA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SetupTVA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupTVA() : String;
function set U_SetupTVA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_SetupTVOA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SetupTVOA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SetupTVOA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SetupTVOA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupTVOA() : String;
function set U_SetupTVOA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_SetupTVOVA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SetupTVOVA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SetupTVOVA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SetupTVOVA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupTVOVA() : String;
function set U_SetupTVOVA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_StockTA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StockTA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_StockTA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_StockTA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockTA() : String;
function set U_StockTA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_StockTFOA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StockTFOA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_StockTFOA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_StockTFOA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockTFOA() : String;
function set U_StockTFOA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_StockTFOVA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StockTFOVA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_StockTFOVA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_StockTFOVA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockTFOVA() : String;
function set U_StockTFOVA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_StockTVA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StockTVA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_StockTVA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_StockTVA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockTVA() : String;
function set U_StockTVA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_StockTVOA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StockTVOA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_StockTVOA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_StockTVOA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockTVOA() : String;
function set U_StockTVOA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_StockTVOVA Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StockTVOVA() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_StockTVOVA {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_StockTVOVA {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockTVOVA() : String;
function set U_StockTVOVA(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_Title Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Title() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Title {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Title {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Title() : String;
function set U_Title(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts.U_WIP Property

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WIP() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WIP {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WIP {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WIP() : String;
function set U_WIP(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcesAccountingAccounts Interface
IResourcesAccountingAccounts Members
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


IResourcesAccountingAccounts Methods

IResourcesAccountingAccounts Interface See Also

The following tables list the members exposed by the IResourcesAccountingAccounts type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IResourcesAccountingAccounts Interface
CompuTec.ProcessForce.API.Documents.Costing.ResourcesAccounting Namespace


CompuTec.ProcessForce.API.Documents.Costing.Restoration Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | ItemCostingRestorer | Restores missing item costing data.
Public class | ResourceCostingRestorer | Restores missing resource costing data.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ItemCostingRestorer Class

Members See Also

Restores missing item costing data.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ItemCostingRestorer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemCostingRestorer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ItemCostingRestorer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemCostingRestorer
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.Costing.Restoration.ItemCostingRestorer
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorer Members
CompuTec.ProcessForce.API.Documents.Costing.Restoration Namespace


ItemCostingRestorer Members

ItemCostingRestorer Class Constructors Methods See Also

Restores missing item costing data.

The following tables list the members exposed by the ItemCostingRestorer type.

Constructors
 | Name | Description
Public constructor | ItemCostingRestorer | Initializes a new instance of the ItemCostingRestorer class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Restore | Restores missing item costing data.
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ItemCostingRestorer Class
CompuTec.ProcessForce.API.Documents.Costing.Restoration Namespace


ItemCostingRestorer Constructor

Initializes a new instance of the ItemCostingRestorer class.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemCostingRestorer(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemCostingRestorer(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemCostingRestorer(
    token : String
);
This language is not supported or no code example is available.

Parameters

token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorer Class
ItemCostingRestorer Members
CompuTec.ProcessForce.API.Documents.Costing.Restoration Namespace


ItemCostingRestorer Methods

ItemCostingRestorer Class See Also

The following tables list the members exposed by the ItemCostingRestorer type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Restore | Restores missing item costing data.
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ItemCostingRestorer Class
CompuTec.ProcessForce.API.Documents.Costing.Restoration Namespace


ItemCostingRestorer.Restore Method

Restores missing item costing data.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function Restore() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool Restore()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool Restore()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Restore() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool

true if the data was restored successfully; otherwise false.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorer Class
ItemCostingRestorer Members
CompuTec.ProcessForce.API.Documents.Costing.Restoration Namespace


ResourceCostingRestorer Class

Members See Also

Restores missing resource costing data.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ResourceCostingRestorer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ResourceCostingRestorer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ResourceCostingRestorer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ResourceCostingRestorer
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.Costing.Restoration.ResourceCostingRestorer
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCostingRestorer Members
CompuTec.ProcessForce.API.Documents.Costing.Restoration Namespace


ResourceCostingRestorer Members

ResourceCostingRestorer Class Constructors Methods See Also

Restores missing resource costing data.

The following tables list the members exposed by the ResourceCostingRestorer type.

Constructors
 | Name | Description
Public constructor | ResourceCostingRestorer | Initializes a new instance of ResourceCostingRestorer class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Restore | Restores missing resource costing data.
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ResourceCostingRestorer Class
CompuTec.ProcessForce.API.Documents.Costing.Restoration Namespace


ResourceCostingRestorer Constructor

Initializes a new instance of ResourceCostingRestorer class.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceCostingRestorer(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceCostingRestorer(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceCostingRestorer(
    token : String
);
This language is not supported or no code example is available.

Parameters

token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCostingRestorer Class
ResourceCostingRestorer Members
CompuTec.ProcessForce.API.Documents.Costing.Restoration Namespace


ResourceCostingRestorer Methods

ResourceCostingRestorer Class See Also

The following tables list the members exposed by the ResourceCostingRestorer type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Restore | Restores missing resource costing data.
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ResourceCostingRestorer Class
CompuTec.ProcessForce.API.Documents.Costing.Restoration Namespace


ResourceCostingRestorer.Restore Method

Restores missing resource costing data.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function Restore() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool Restore()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool Restore()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Restore() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool

true if the data was restored successfully; otherwise false is returned.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCostingRestorer Class
ResourceCostingRestorer Members
CompuTec.ProcessForce.API.Documents.Costing.Restoration Namespace


CompuTec.ProcessForce.API.Documents.Costing.Synchronization Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | CostCategorySynchronizer | Synchronizes the cost category data.
Public class | ItemCostingSynchronizer | Synchronizes the item costing data.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


CostCategorySynchronizer Class

Members See Also

Synchronizes the cost category data.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class CostCategorySynchronizer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CostCategorySynchronizer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class CostCategorySynchronizer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CostCategorySynchronizer
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.Costing.Synchronization.CostCategorySynchronizer
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostCategorySynchronizer Members
CompuTec.ProcessForce.API.Documents.Costing.Synchronization Namespace


CostCategorySynchronizer Members

CostCategorySynchronizer Class Constructors Methods See Also

Synchronizes the cost category data.

The following tables list the members exposed by the CostCategorySynchronizer type.

Constructors
 | Name | Description
Public constructor | CostCategorySynchronizer | Initializes a new instance of the CostCategorySynchronizer class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Synchronize | Synchronizes the cost categories.
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

CostCategorySynchronizer Class
CompuTec.ProcessForce.API.Documents.Costing.Synchronization Namespace


CostCategorySynchronizer Constructor

Initializes a new instance of the CostCategorySynchronizer class.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CostCategorySynchronizer(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CostCategorySynchronizer(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CostCategorySynchronizer(
    token : String
);
This language is not supported or no code example is available.

Parameters

token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostCategorySynchronizer Class
CostCategorySynchronizer Members
CompuTec.ProcessForce.API.Documents.Costing.Synchronization Namespace


CostCategorySynchronizer Methods

CostCategorySynchronizer Class See Also

The following tables list the members exposed by the CostCategorySynchronizer type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Synchronize | Synchronizes the cost categories.
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

CostCategorySynchronizer Class
CompuTec.ProcessForce.API.Documents.Costing.Synchronization Namespace


CostCategorySynchronizer.Synchronize Method

Synchronizes the cost categories.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function Synchronize() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool Synchronize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool Synchronize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Synchronize() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool

true if the synchronization has been completed successfully; otherwise false is returned.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostCategorySynchronizer Class
CostCategorySynchronizer Members
CompuTec.ProcessForce.API.Documents.Costing.Synchronization Namespace


ItemCostingSynchronizer Class

Members See Also

Synchronizes the item costing data.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ItemCostingSynchronizer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemCostingSynchronizer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ItemCostingSynchronizer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemCostingSynchronizer
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.Costing.Synchronization.ItemCostingSynchronizer
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingSynchronizer Members
CompuTec.ProcessForce.API.Documents.Costing.Synchronization Namespace


ItemCostingSynchronizer Members

ItemCostingSynchronizer Class Constructors Methods See Also

Synchronizes the item costing data.

The following tables list the members exposed by the ItemCostingSynchronizer type.

Constructors
 | Name | Description
Public constructor | ItemCostingSynchronizer | Initializes a new instance of ItemCostingSynchronizer class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | SynchronizeBillOfMaterials | Synchronizes the bill of materials related item costing.
Public method | SynchronizeWarehouses | (Overloaded) Synchronizes the warehouses for an item costing entries.
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ItemCostingSynchronizer Class
CompuTec.ProcessForce.API.Documents.Costing.Synchronization Namespace


ItemCostingSynchronizer Constructor

Initializes a new instance of ItemCostingSynchronizer class.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemCostingSynchronizer(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemCostingSynchronizer(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemCostingSynchronizer(
    token : String
);
This language is not supported or no code example is available.

Parameters

token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingSynchronizer Class
ItemCostingSynchronizer Members
CompuTec.ProcessForce.API.Documents.Costing.Synchronization Namespace


ItemCostingSynchronizer Methods

ItemCostingSynchronizer Class See Also

The following tables list the members exposed by the ItemCostingSynchronizer type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | SynchronizeBillOfMaterials | Synchronizes the bill of materials related item costing.
Public method | SynchronizeWarehouses | (Overloaded) Synchronizes the warehouses for an item costing entries.
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ItemCostingSynchronizer Class
CompuTec.ProcessForce.API.Documents.Costing.Synchronization Namespace


ItemCostingSynchronizer.SynchronizeBillOfMaterials Method

Synchronizes the bill of materials related item costing.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function SynchronizeBillOfMaterials( _
   ByVal itemCode As String, _
   ByVal revision As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool SynchronizeBillOfMaterials(
   string itemCode,
   string revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool SynchronizeBillOfMaterials(
   String^ itemCode,
   String^ revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SynchronizeBillOfMaterials(
    itemCode : String,
    revision : String
) : boolean;
This language is not supported or no code example is available.

Parameters

itemCode

Type: string

Item code.

revision

Type: string

Revision.

Return Value

Type: bool

true if the synchronization has been completed successfully; otherwise false is returned.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingSynchronizer Class
ItemCostingSynchronizer Members
CompuTec.ProcessForce.API.Documents.Costing.Synchronization Namespace


ItemCostingSynchronizer.SynchronizeWarehouses Method

ItemCostingSynchronizer Class See Also

Synchronizes the warehouses for an item costing entries.

Overload List
Name | Description
SynchronizeWarehouses() | Synchronizes the warehouses for an item costing entries.
SynchronizeWarehouses(string) | Synchronizes the warehouses for an item costing entries.
See Also

Reference

ItemCostingSynchronizer Class
ItemCostingSynchronizer Members
CompuTec.ProcessForce.API.Documents.Costing.Synchronization Namespace


CompuTec.ProcessForce.API.Documents.DistributionRules Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IDimension |
Public interface | IDimensions |
Public interface | IDistributionRules |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IDimension Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.DistributionRules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IDimension
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IDimension
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IDimension
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IDimension
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDimension Members
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDimension Members

IDimension Interface Properties See Also

The following tables list the members exposed by the IDimension type.

Properties
 | Name | Description
Public property | Description |
Public property | IsActive |
Public property | MatrixColumnCFLCode |
Public property | MatrixColumnCode |
Public property | MatrixColumnLinkedObjectCode |
Public property | MatrixColumnName |
Public property | MatrixColumnType |
Public property | MatrixColumnUDSUID |
Public property | TableColumnCode |
Top
See Also

Reference

IDimension Interface
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDimension Properties

IDimension Interface See Also

The following tables list the members exposed by the IDimension type.

Properties
 | Name | Description
Public property | Description |
Public property | IsActive |
Public property | MatrixColumnCFLCode |
Public property | MatrixColumnCode |
Public property | MatrixColumnLinkedObjectCode |
Public property | MatrixColumnName |
Public property | MatrixColumnType |
Public property | MatrixColumnUDSUID |
Public property | TableColumnCode |
Top
See Also

Reference

IDimension Interface
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDimension.Description Property

Namespace: CompuTec.ProcessForce.API.Documents.DistributionRules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Description() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Description {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Description {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Description() : String;
function set Description(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDimension Interface
IDimension Members
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDimension.IsActive Property

Namespace: CompuTec.ProcessForce.API.Documents.DistributionRules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property IsActive() As BoYesNoEnum
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
BoYesNoEnum IsActive {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property BoYesNoEnum IsActive {
 BoYesNoEnum get( );
 void set(
   BoYesNoEnum value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get IsActive() : BoYesNoEnum;
function set IsActive(value : BoYesNoEnum);
This language is not supported or no code example is available.

Property Value

Type: BoYesNoEnum
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDimension Interface
IDimension Members
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDimension.MatrixColumnCFLCode Property

Namespace: CompuTec.ProcessForce.API.Documents.DistributionRules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property MatrixColumnCFLCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string MatrixColumnCFLCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ MatrixColumnCFLCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get MatrixColumnCFLCode() : String;
function set MatrixColumnCFLCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDimension Interface
IDimension Members
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDimension.MatrixColumnCode Property

Namespace: CompuTec.ProcessForce.API.Documents.DistributionRules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property MatrixColumnCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string MatrixColumnCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ MatrixColumnCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get MatrixColumnCode() : String;
function set MatrixColumnCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDimension Interface
IDimension Members
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDimension.MatrixColumnLinkedObjectCode Property

Namespace: CompuTec.ProcessForce.API.Documents.DistributionRules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property MatrixColumnLinkedObjectCode() As BoLinkedObject
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
BoLinkedObject MatrixColumnLinkedObjectCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property BoLinkedObject MatrixColumnLinkedObjectCode {
 BoLinkedObject get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get MatrixColumnLinkedObjectCode() : BoLinkedObject;
This language is not supported or no code example is available.

Property Value

Type: BoLinkedObject
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDimension Interface
IDimension Members
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDimension.MatrixColumnName Property

Namespace: CompuTec.ProcessForce.API.Documents.DistributionRules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property MatrixColumnName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string MatrixColumnName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ MatrixColumnName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get MatrixColumnName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDimension Interface
IDimension Members
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDimension.MatrixColumnType Property

Namespace: CompuTec.ProcessForce.API.Documents.DistributionRules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property MatrixColumnType() As BoFormItemTypes
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
BoFormItemTypes MatrixColumnType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property BoFormItemTypes MatrixColumnType {
 BoFormItemTypes get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get MatrixColumnType() : BoFormItemTypes;
This language is not supported or no code example is available.

Property Value

Type: BoFormItemTypes
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDimension Interface
IDimension Members
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDimension.MatrixColumnUDSUID Property

Namespace: CompuTec.ProcessForce.API.Documents.DistributionRules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property MatrixColumnUDSUID() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string MatrixColumnUDSUID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ MatrixColumnUDSUID {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get MatrixColumnUDSUID() : String;
function set MatrixColumnUDSUID(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDimension Interface
IDimension Members
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDimension.TableColumnCode Property

Namespace: CompuTec.ProcessForce.API.Documents.DistributionRules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property TableColumnCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string TableColumnCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ TableColumnCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get TableColumnCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDimension Interface
IDimension Members
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDimensions Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.DistributionRules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IDimensions
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IDimensions
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IDimensions
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IDimensions
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDimensions Members
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDimensions Members

IDimensions Interface Properties See Also

The following tables list the members exposed by the IDimensions type.

Properties
 | Name | Description
Public property | DimensionNumber |
Public property | DimensionsList |
Public property | GridUid |
Public property | MatixStyle |
Public property | UDSColumn |
Top
See Also

Reference

IDimensions Interface
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDimensions Properties

IDimensions Interface See Also

The following tables list the members exposed by the IDimensions type.

Properties
 | Name | Description
Public property | DimensionNumber |
Public property | DimensionsList |
Public property | GridUid |
Public property | MatixStyle |
Public property | UDSColumn |
Top
See Also

Reference

IDimensions Interface
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDimensions.DimensionNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.DistributionRules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DimensionNumber() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DimensionNumber {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DimensionNumber {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DimensionNumber() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDimensions Interface
IDimensions Members
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDimensions.DimensionsList Property

Namespace: CompuTec.ProcessForce.API.Documents.DistributionRules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DimensionsList() As Dictionary(Of Integer, IDimension)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Dictionary<int, IDimension> DimensionsList {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Dictionary<int, IDimension^>^ DimensionsList {
 Dictionary<int, IDimension^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: Dictionary<int, IDimension>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDimensions Interface
IDimensions Members
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDimensions.GridUid Property

Namespace: CompuTec.ProcessForce.API.Documents.DistributionRules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property GridUid() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string GridUid {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ GridUid {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get GridUid() : String;
function set GridUid(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDimensions Interface
IDimensions Members
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDimensions.MatixStyle Property

Namespace: CompuTec.ProcessForce.API.Documents.DistributionRules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property MatixStyle() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool MatixStyle {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool MatixStyle {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get MatixStyle() : boolean;
function set MatixStyle(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDimensions Interface
IDimensions Members
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDimensions.UDSColumn Property

Namespace: CompuTec.ProcessForce.API.Documents.DistributionRules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UDSColumn() As IDimension
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IDimension UDSColumn {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IDimension^ UDSColumn {
 IDimension^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UDSColumn() : IDimension;
This language is not supported or no code example is available.

Property Value

Type: IDimension
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDimensions Interface
IDimensions Members
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDistributionRules Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.DistributionRules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IDistributionRules
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IDistributionRules
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IDistributionRules
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IDistributionRules
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDistributionRules Members
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDistributionRules Members

IDistributionRules Interface Methods Properties See Also

The following tables list the members exposed by the IDistributionRules type.

Properties
 | Name | Description
Public property | ChildBeansList |
Top
Methods
 | Name | Description
Public method | LoadUdoObject |
Top
See Also

Reference

IDistributionRules Interface
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDistributionRules Properties

IDistributionRules Interface See Also

The following tables list the members exposed by the IDistributionRules type.

Properties
 | Name | Description
Public property | ChildBeansList |
Top
See Also

Reference

IDistributionRules Interface
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDistributionRules.ChildBeansList Property

Namespace: CompuTec.ProcessForce.API.Documents.DistributionRules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property ChildBeansList() As Dictionary(Of String, IDimensions)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Dictionary<string, IDimensions> ChildBeansList {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Dictionary<String^, IDimensions^>^ ChildBeansList {
 Dictionary<String^, IDimensions^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: Dictionary<string, IDimensions>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDistributionRules Interface
IDistributionRules Members
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDistributionRules Methods

IDistributionRules Interface See Also

The following tables list the members exposed by the IDistributionRules type.

Methods
 | Name | Description
Public method | LoadUdoObject |
Top
See Also

Reference

IDistributionRules Interface
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


IDistributionRules.LoadUdoObject Method

Namespace: CompuTec.ProcessForce.API.Documents.DistributionRules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub LoadUdoObject( _
   ByVal udoObject As IUDOBean _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void LoadUdoObject(
   IUDOBean udoObject
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void LoadUdoObject(
   IUDOBean^ udoObject
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function LoadUdoObject(
    udoObject : IUDOBean
);
This language is not supported or no code example is available.

Parameters

udoObject

Type: IUDOBean

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDistributionRules Interface
IDistributionRules Members
CompuTec.ProcessForce.API.Documents.DistributionRules Namespace


CompuTec.ProcessForce.API.Documents.DownTime Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IDownTime | Downtime document
Public interface | IDownTimeLines | Reasons for downtime document
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IDownTime Interface

Members See Also

Downtime document

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "DownTime", TableName = "@CT_PF_ODTM")> _
Public Interface IDownTime
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "DownTime", TableName = "@CT_PF_ODTM")]
public interface IDownTime : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "DownTime", TableName = "@CT_PF_ODTM")]
public interface class IDownTime : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "DownTime", TableName = "@CT_PF_ODTM")
interface IDownTime
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ODTM
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime Members

IDownTime Interface Methods Properties See Also

Downtime document

The following tables list the members exposed by the IDownTime type.

Properties
 | Name | Description
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Reasons |
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_BaseCode |
Public property | U_ClosedBy |
Public property | U_DocDate |
Public property | U_EndDate |
Public property | U_EndTime |
Public property | U_MorDE |
Public property | U_MorDN |
Public property | U_OprCode |
Public property | U_Remarks |
Public property | U_ReporterID |
Public property | U_RscCode |
Public property | U_RscLine |
Public property | U_StartDate |
Public property | U_StartTime |
Public property | U_Status |
Public property | U_TechnicID |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IDownTime Interface
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime Properties

IDownTime Interface See Also

The following tables list the members exposed by the IDownTime type.

Properties
 | Name | Description
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Reasons |
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_BaseCode |
Public property | U_ClosedBy |
Public property | U_DocDate |
Public property | U_EndDate |
Public property | U_EndTime |
Public property | U_MorDE |
Public property | U_MorDN |
Public property | U_OprCode |
Public property | U_Remarks |
Public property | U_ReporterID |
Public property | U_RscCode |
Public property | U_RscLine |
Public property | U_StartDate |
Public property | U_StartTime |
Public property | U_Status |
Public property | U_TechnicID |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IDownTime Interface
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.DocNum Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.Handwrtten Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Handwrtten() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Handwrtten {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Handwrtten {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Handwrtten() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.Instance Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Instance() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Instance {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Instance {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Instance() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.Period Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Period() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Period {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Period {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Period() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.Reasons Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Reasons() As IDownTimeLines
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IDownTimeLines Reasons {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IDownTimeLines^ Reasons {
 IDownTimeLines^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Reasons() : IDownTimeLines;
This language is not supported or no code example is available.

Property Value

Type: IDownTimeLines
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.Series Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Series() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Series {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Series {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Series() : int;
function set Series(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.Status Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Status {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Status {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Status() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.U_BaseCode Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BaseCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BaseCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseCode() : String;
function set U_BaseCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.U_ClosedBy Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ClosedBy() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ClosedBy {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ClosedBy {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ClosedBy() : int;
function set U_ClosedBy(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.U_DocDate Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_DocDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
DateTime U_DocDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property DateTime U_DocDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_DocDate() : DateTime;

   AppEngineProperty(Required = true)
function set U_DocDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.U_EndDate Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_EndDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_EndDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EndDate() : DateTime;
function set U_EndDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.U_EndTime Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EndTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_EndTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_EndTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EndTime() : DateTime;
function set U_EndTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.U_MorDE Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MorDE() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_MorDE {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_MorDE {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MorDE() : int;
function set U_MorDE(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.U_MorDN Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MorDN() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_MorDN {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_MorDN {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MorDN() : int;
function set U_MorDN(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.U_OprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprCode() : String;
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.U_ReporterID Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReporterID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ReporterID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ReporterID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReporterID() : int;
function set U_ReporterID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.U_RscCode Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCode() : String;
function set U_RscCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.U_RscLine Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RscLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RscLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscLine() : int;
function set U_RscLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.U_StartDate Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_StartDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
DateTime U_StartDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property DateTime U_StartDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_StartDate() : DateTime;

   AppEngineProperty(Required = true)
function set U_StartDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.U_StartTime Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StartTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StartTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StartTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StartTime() : DateTime;
function set U_StartTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.U_Status Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Status() As DownTimeStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DownTimeStatus U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DownTimeStatus U_Status {
 DownTimeStatus get( );
 void set(
   DownTimeStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Status() : DownTimeStatus;
function set U_Status(value : DownTimeStatus);
This language is not supported or no code example is available.

Property Value

Type: DownTimeStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.U_TechnicID Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TechnicID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_TechnicID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_TechnicID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TechnicID() : int;
function set U_TechnicID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTime Interface
IDownTime Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTime Methods

IDownTime Interface See Also

The following tables list the members exposed by the IDownTime type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IDownTime Interface
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTimeLines Interface

Members See Also

Reasons for downtime document

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IDownTimeLines
    Inherits IUDOChildBean, _
             IEnumerable(Of IDownTimeLines)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IDownTimeLines : IUDOChildBean,
   IEnumerable<IDownTimeLines>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IDownTimeLines : public IUDOChildBean^,
   public IEnumerable<IDownTimeLines^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_DTM1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTimeLines Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTimeLines Members

IDownTimeLines Interface Methods Properties See Also

Reasons for downtime document

The following tables list the members exposed by the IDownTimeLines type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ReasonCode | Reason Code
Public property | U_Remarks | Remarks
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IDownTimeLines Interface
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTimeLines Properties

IDownTimeLines Interface See Also

The following tables list the members exposed by the IDownTimeLines type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ReasonCode | Reason Code
Public property | U_Remarks | Remarks
Top
See Also

Reference

IDownTimeLines Interface
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTimeLines.U_ReasonCode Property

Reason Code

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReasonCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ReasonCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ReasonCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReasonCode() : String;
function set U_ReasonCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTimeLines Interface
IDownTimeLines Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTimeLines.U_Remarks Property

Remarks

Namespace: CompuTec.ProcessForce.API.Documents.DownTime
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTimeLines Interface
IDownTimeLines Members
CompuTec.ProcessForce.API.Documents.DownTime Namespace


IDownTimeLines Methods

IDownTimeLines Interface See Also

The following tables list the members exposed by the IDownTimeLines type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IDownTimeLines Interface
CompuTec.ProcessForce.API.Documents.DownTime Namespace


CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IDraftDocumentAuthorization | Draft document authorization object
Public interface | IDraftDocumentAuthorizationItemCodes | Item codes for draft document authorization object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IDraftDocumentAuthorization Interface

Members See Also

Draft document authorization object

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IDraftDocumentAuthorization
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IDraftDocumentAuthorization : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IDraftDocumentAuthorization : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IDraftDocumentAuthorization
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ODDA
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorization Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization Members

IDraftDocumentAuthorization Interface Methods Properties See Also

Draft document authorization object

The following tables list the members exposed by the IDraftDocumentAuthorization type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | ItemCodes |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_DocEntry |
Public property | U_DocType |
Public property | U_IsAuthorized |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IDraftDocumentAuthorization Interface
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization Properties

IDraftDocumentAuthorization Interface See Also

The following tables list the members exposed by the IDraftDocumentAuthorization type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | ItemCodes |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_DocEntry |
Public property | U_DocType |
Public property | U_IsAuthorized |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IDraftDocumentAuthorization Interface
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorization Interface
IDraftDocumentAuthorization Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorization Interface
IDraftDocumentAuthorization Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorization Interface
IDraftDocumentAuthorization Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorization Interface
IDraftDocumentAuthorization Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorization Interface
IDraftDocumentAuthorization Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorization Interface
IDraftDocumentAuthorization Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization.ItemCodes Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property ItemCodes() As IDraftDocumentAuthorizationItemCodes
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IDraftDocumentAuthorizationItemCodes ItemCodes {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IDraftDocumentAuthorizationItemCodes^ ItemCodes {
 IDraftDocumentAuthorizationItemCodes^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ItemCodes() : IDraftDocumentAuthorizationItemCodes;
This language is not supported or no code example is available.

Property Value

Type: IDraftDocumentAuthorizationItemCodes
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorization Interface
IDraftDocumentAuthorization Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorization Interface
IDraftDocumentAuthorization Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorization Interface
IDraftDocumentAuthorization Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorization Interface
IDraftDocumentAuthorization Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorization Interface
IDraftDocumentAuthorization Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization.U_DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_DocEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_DocEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DocEntry() : int;
function set U_DocEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorization Interface
IDraftDocumentAuthorization Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization.U_DocType Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DocType() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_DocType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_DocType {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DocType() : int;
function set U_DocType(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorization Interface
IDraftDocumentAuthorization Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization.U_IsAuthorized Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IsAuthorized() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_IsAuthorized {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_IsAuthorized {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IsAuthorized() : String;
function set U_IsAuthorized(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorization Interface
IDraftDocumentAuthorization Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorization Interface
IDraftDocumentAuthorization Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorization Interface
IDraftDocumentAuthorization Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorization Interface
IDraftDocumentAuthorization Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorization Methods

IDraftDocumentAuthorization Interface See Also

The following tables list the members exposed by the IDraftDocumentAuthorization type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IDraftDocumentAuthorization Interface
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorizationItemCodes Interface

Members See Also

Item codes for draft document authorization object

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IDraftDocumentAuthorizationItemCodes
    Inherits IUDOChildBean, _
             IEnumerable(Of IDraftDocumentAuthorizationItemCodes)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IDraftDocumentAuthorizationItemCodes : IUDOChildBean,
   IEnumerable<IDraftDocumentAuthorizationItemCodes>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IDraftDocumentAuthorizationItemCodes : public IUDOChildBean^,
   public IEnumerable<IDraftDocumentAuthorizationItemCodes^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_DDA1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorizationItemCodes Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorizationItemCodes Members

IDraftDocumentAuthorizationItemCodes Interface Methods Properties See Also

Item codes for draft document authorization object

The following tables list the members exposed by the IDraftDocumentAuthorizationItemCodes type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ItemCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IDraftDocumentAuthorizationItemCodes Interface
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorizationItemCodes Properties

IDraftDocumentAuthorizationItemCodes Interface See Also

The following tables list the members exposed by the IDraftDocumentAuthorizationItemCodes type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ItemCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
See Also

Reference

IDraftDocumentAuthorizationItemCodes Interface
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorizationItemCodes.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorizationItemCodes Interface
IDraftDocumentAuthorizationItemCodes Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorizationItemCodes.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorizationItemCodes Interface
IDraftDocumentAuthorizationItemCodes Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorizationItemCodes.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorizationItemCodes Interface
IDraftDocumentAuthorizationItemCodes Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorizationItemCodes.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorizationItemCodes Interface
IDraftDocumentAuthorizationItemCodes Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorizationItemCodes.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDraftDocumentAuthorizationItemCodes Interface
IDraftDocumentAuthorizationItemCodes Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


IDraftDocumentAuthorizationItemCodes Methods

IDraftDocumentAuthorizationItemCodes Interface See Also

The following tables list the members exposed by the IDraftDocumentAuthorizationItemCodes type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IDraftDocumentAuthorizationItemCodes Interface
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization Namespace


CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | BatchNumber | Represents the data of Batches and Serial Numbers relevant for SAP Business One's documents.
Public class | DraftDocument | Represents the data of a single record stored in Draft Document Authorization table.
Public class | DraftDocumentAuthorizationManager | Manages the authorization of SAP Business One's Draft documents.
Public class | DraftDocumentAuthorizationState | Represents the available states for Draft Documents.
Public class | StockTransferData | Represents a data of transferring item master data within the SAP Business One's Stock Transfer document.
Public class | StockTransferDocument | Represents a data of the SAP Business One's Stock Transfer document.
Top
Enumerations
 | Name | Description
Public enumeration | DraftDocumentType | Represents the types of SAP Business One's documents.
Public enumeration | StockTransferDataManagementType | Represents the available options of Item Master Data management.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


BatchNumber Class

Members See Also

Represents the data of Batches and Serial Numbers relevant for SAP Business One's documents.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BatchNumber
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BatchNumber
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BatchNumber
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BatchNumber
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager.BatchNumber
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumber Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


BatchNumber Members

BatchNumber Class Constructors Methods Properties See Also

Represents the data of Batches and Serial Numbers relevant for SAP Business One's documents.

The following tables list the members exposed by the BatchNumber type.

Constructors
 | Name | Description
Public constructor | BatchNumber | Initializes a new instance of CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.BatchNumber object.
Top
Properties
 | Name | Description
Public property | BnDistNumber | Gets or sets the Batch Number value of Batch Number.
Public property | Quantity | Gets or sets the quantity assigned for batch number.
Public property | SnDistNumber | Gets or sets the Internal Serial Number value of Serial Number.
Public property | SnLotNumber | Gets or sets the Batch ID value of Serial Number.
Public property | SnMnfNumber | Gets or sets the Manufacturer Serial Number value of Serial Number.
Public property | SnSysNumber | Gets or sets the System Serial Number value of Serial Number.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

BatchNumber Class
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


BatchNumber Constructor

Initializes a new instance of CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.BatchNumber object.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal snSysNumber As Integer, _
   ByVal snDistNumber As String, _
   ByVal snMnfNumber As String, _
   ByVal snLotNumber As String, _
   ByVal bnDistNumber As String, _
   ByVal quantity As Double _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchNumber(
   int snSysNumber,
   string snDistNumber,
   string snMnfNumber,
   string snLotNumber,
   string bnDistNumber,
   double quantity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchNumber(
   int snSysNumber,
   String^ snDistNumber,
   String^ snMnfNumber,
   String^ snLotNumber,
   String^ bnDistNumber,
   double quantity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchNumber(
    snSysNumber : int,
    snDistNumber : String,
    snMnfNumber : String,
    snLotNumber : String,
    bnDistNumber : String,
    quantity : double
);
This language is not supported or no code example is available.

Parameters

snSysNumber

Type: int

System Serial Number property value of Serial Number.

snDistNumber

Type: string

Internal Serial Number property value of Serial Number.

snMnfNumber

Type: string

Manufacturer Serial Number property value of Serial Number.

snLotNumber

Type: string

Batch ID property value of Serial Number.

bnDistNumber

Type: string

Batch Number property value of the Batch.

quantity

Type: double

The quantity of Item Master Data assigned for batch number.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumber Class
BatchNumber Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


BatchNumber Properties

BatchNumber Class See Also

The following tables list the members exposed by the BatchNumber type.

Properties
 | Name | Description
Public property | BnDistNumber | Gets or sets the Batch Number value of Batch Number.
Public property | Quantity | Gets or sets the quantity assigned for batch number.
Public property | SnDistNumber | Gets or sets the Internal Serial Number value of Serial Number.
Public property | SnLotNumber | Gets or sets the Batch ID value of Serial Number.
Public property | SnMnfNumber | Gets or sets the Manufacturer Serial Number value of Serial Number.
Public property | SnSysNumber | Gets or sets the System Serial Number value of Serial Number.
Top
See Also

Reference

BatchNumber Class
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


BatchNumber.BnDistNumber Property

Gets or sets the Batch Number value of Batch Number.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property BnDistNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string BnDistNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ BnDistNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get BnDistNumber() : String;
public function set BnDistNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumber Class
BatchNumber Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


BatchNumber.Quantity Property

Gets or sets the quantity assigned for batch number.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property double Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Quantity() : double;
public function set Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumber Class
BatchNumber Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


BatchNumber.SnDistNumber Property

Gets or sets the Internal Serial Number value of Serial Number.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SnDistNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string SnDistNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ SnDistNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SnDistNumber() : String;
public function set SnDistNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumber Class
BatchNumber Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


BatchNumber.SnLotNumber Property

Gets or sets the Batch ID value of Serial Number.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SnLotNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string SnLotNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ SnLotNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SnLotNumber() : String;
public function set SnLotNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumber Class
BatchNumber Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


BatchNumber.SnMnfNumber Property

Gets or sets the Manufacturer Serial Number value of Serial Number.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SnMnfNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string SnMnfNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ SnMnfNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SnMnfNumber() : String;
public function set SnMnfNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumber Class
BatchNumber Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


BatchNumber.SnSysNumber Property

Gets or sets the System Serial Number value of Serial Number.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SnSysNumber() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int SnSysNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int SnSysNumber {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SnSysNumber() : int;
public function set SnSysNumber(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumber Class
BatchNumber Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


BatchNumber Methods

BatchNumber Class See Also

The following tables list the members exposed by the BatchNumber type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

BatchNumber Class
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocument Class

Members See Also

Represents the data of a single record stored in Draft Document Authorization table.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class DraftDocument
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DraftDocument
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class DraftDocument
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DraftDocument
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager.DraftDocument
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DraftDocument Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocument Members

DraftDocument Class Constructors Methods Properties See Also

Represents the data of a single record stored in Draft Document Authorization table.

The following tables list the members exposed by the DraftDocument type.

Constructors
 | Name | Description
Public constructor | DraftDocument | Initializes a new instance of CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.DraftDocument object.
Top
Properties
 | Name | Description
Public property | DocumentEntry | Gets or sets the unique identifier of Draft Document.
Public property | DocumentType | Gets or sets the type of Draft Document.
Public property | IsAuthorized | Gets or sets the authorization status for a Draft Document.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

DraftDocument Class
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocument Constructor

Initializes a new instance of CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.DraftDocument object.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal docEntry As Integer, _
   ByVal docType As Integer, _
   ByVal isAuthorized As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DraftDocument(
   int docEntry,
   int docType,
   string isAuthorized
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DraftDocument(
   int docEntry,
   int docType,
   String^ isAuthorized
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DraftDocument(
    docEntry : int,
    docType : int,
    isAuthorized : String
);
This language is not supported or no code example is available.

Parameters

docEntry

Type: int

The unique identifier of Draft Document.

docType

Type: int

The type of Draft Document.

isAuthorized

Type: string

Indicates wheter Draft Document is already authorized or not.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DraftDocument Class
DraftDocument Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocument Properties

DraftDocument Class See Also

The following tables list the members exposed by the DraftDocument type.

Properties
 | Name | Description
Public property | DocumentEntry | Gets or sets the unique identifier of Draft Document.
Public property | DocumentType | Gets or sets the type of Draft Document.
Public property | IsAuthorized | Gets or sets the authorization status for a Draft Document.
Top
See Also

Reference

DraftDocument Class
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocument.DocumentEntry Property

Gets or sets the unique identifier of Draft Document.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DocumentEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int DocumentEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int DocumentEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocumentEntry() : int;
public function set DocumentEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DraftDocument Class
DraftDocument Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocument.DocumentType Property

Gets or sets the type of Draft Document.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DocumentType() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int DocumentType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int DocumentType {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocumentType() : int;
public function set DocumentType(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DraftDocument Class
DraftDocument Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocument.IsAuthorized Property

Gets or sets the authorization status for a Draft Document.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property IsAuthorized() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string IsAuthorized {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ IsAuthorized {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get IsAuthorized() : String;
public function set IsAuthorized(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DraftDocument Class
DraftDocument Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocument Methods

DraftDocument Class See Also

The following tables list the members exposed by the DraftDocument type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

DraftDocument Class
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocumentAuthorizationManager Class

Members See Also

Manages the authorization of SAP Business One's Draft documents.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class DraftDocumentAuthorizationManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DraftDocumentAuthorizationManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class DraftDocumentAuthorizationManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DraftDocumentAuthorizationManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager.DraftDocumentAuthorizationManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DraftDocumentAuthorizationManager Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocumentAuthorizationManager Members

DraftDocumentAuthorizationManager Class Methods See Also

Manages the authorization of SAP Business One's Draft documents.

The following tables list the members exposed by the DraftDocumentAuthorizationManager type.

Methods
 | Name | Description
 | AuthorizeDraftDocument | Authorizes and creates a new SAP Business One's document based on its draft data.
 | CreateDraftDocument | Creates a new SAP Business One's Draft Stock Transfer document.
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | ExtractLicensePlateCodeFromOITMCode | Extracts the License Plate Code from Item Master Data's Item Code.
 | GetAuthorizationCode | Gets the Draft Document Authorization Code value for a particular set of U_DocEntry and U_DocType values.
 | GetDraftDocuments | Gets the data of all Draft Documents from the Draft Document Authorization table.
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetNonAuthorizedDraftDocuments | Gets the data of non authorized Draft Documents from the Draft Document Authorization table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
 | ValidateDraftDocument | Validates the data of SAP Business One's Draft Stock Transfer document.
Top
See Also

Reference

DraftDocumentAuthorizationManager Class
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocumentAuthorizationManager Methods

DraftDocumentAuthorizationManager Class See Also

The following tables list the members exposed by the DraftDocumentAuthorizationManager type.

Methods
 | Name | Description
 | AuthorizeDraftDocument | Authorizes and creates a new SAP Business One's document based on its draft data.
 | CreateDraftDocument | Creates a new SAP Business One's Draft Stock Transfer document.
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | ExtractLicensePlateCodeFromOITMCode | Extracts the License Plate Code from Item Master Data's Item Code.
 | GetAuthorizationCode | Gets the Draft Document Authorization Code value for a particular set of U_DocEntry and U_DocType values.
 | GetDraftDocuments | Gets the data of all Draft Documents from the Draft Document Authorization table.
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetNonAuthorizedDraftDocuments | Gets the data of non authorized Draft Documents from the Draft Document Authorization table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
 | ValidateDraftDocument | Validates the data of SAP Business One's Draft Stock Transfer document.
Top
See Also

Reference

DraftDocumentAuthorizationManager Class
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocumentAuthorizationManager.AuthorizeDraftDocument Method

Authorizes and creates a new SAP Business One's document based on its draft data.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function AuthorizeDraftDocument( _
   ByVal Token As String, _
   ByVal docEntry As Integer, _
   ByVal docType As DraftDocumentType _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool AuthorizeDraftDocument(
   string Token,
   int docEntry,
   DraftDocumentType docType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool AuthorizeDraftDocument(
   String^ Token,
   int docEntry,
   DraftDocumentType docType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function AuthorizeDraftDocument(
    Token : String,
    docEntry : int,
    docType : DraftDocumentType
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

docEntry

Type: int

docType

Type: DraftDocumentType

The type of a Draft document.

Return Value

Type: bool

A Boolean value that indicates whether the SAP Business One's document was successfully authorized and created or not.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DraftDocumentAuthorizationManager Class
DraftDocumentAuthorizationManager Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocumentAuthorizationManager.CreateDraftDocument Method

Creates a new SAP Business One's Draft Stock Transfer document.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function CreateDraftDocument( _
   ByVal Token As String, _
   ByVal draftDocument As StockTransferDocument _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool CreateDraftDocument(
   string Token,
   StockTransferDocument draftDocument
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool CreateDraftDocument(
   String^ Token,
   StockTransferDocument^ draftDocument
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function CreateDraftDocument(
    Token : String,
    draftDocument : StockTransferDocument
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

draftDocument

Type: StockTransferDocument

The data for a new Draft Stock Transfer document.

Return Value

Type: bool

A Boolean value that indicates whether the Draft Stock Transfer document was successfully created or not.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DraftDocumentAuthorizationManager Class
DraftDocumentAuthorizationManager Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocumentAuthorizationManager.ExtractLicensePlateCodeFromOITMCode Method

Extracts the License Plate Code from Item Master Data's Item Code.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function ExtractLicensePlateCodeFromOITMCode( _
   ByVal itemMasterDataCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string ExtractLicensePlateCodeFromOITMCode(
   string itemMasterDataCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ ExtractLicensePlateCodeFromOITMCode(
   String^ itemMasterDataCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function ExtractLicensePlateCodeFromOITMCode(
    itemMasterDataCode : String
) : String;
This language is not supported or no code example is available.

Parameters

itemMasterDataCode

Type: string

The Item Code value of Item Master Data.

Return Value

Type: string

The extracted License Plate Code.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DraftDocumentAuthorizationManager Class
DraftDocumentAuthorizationManager Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocumentAuthorizationManager.GetAuthorizationCode Method

Gets the Draft Document Authorization Code value for a particular set of U_DocEntry and U_DocType values.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetAuthorizationCode( _
   ByVal token As String, _
   ByVal docEntry As Integer, _
   ByVal docType As DraftDocumentType _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetAuthorizationCode(
   string token,
   int docEntry,
   DraftDocumentType docType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetAuthorizationCode(
   String^ token,
   int docEntry,
   DraftDocumentType docType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetAuthorizationCode(
    token : String,
    docEntry : int,
    docType : DraftDocumentType
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntry

Type: int

The unique identifier of a Draft Document.

docType

Type: DraftDocumentType

The type of a Draft Document.

Return Value

Type: string

The Draft Document Authorization Code value. If there is no record that matches given criteria, an empty string is returned.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DraftDocumentAuthorizationManager Class
DraftDocumentAuthorizationManager Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocumentAuthorizationManager.GetDraftDocuments Method

Gets the data of all Draft Documents from the Draft Document Authorization table.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetDraftDocuments() As List(Of DraftDocument)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static List<DraftDocument> GetDraftDocuments()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static List<DraftDocument^>^ GetDraftDocuments()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Return Value

Type: List<DraftDocument>

A generic collection of Draft Documents data.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DraftDocumentAuthorizationManager Class
DraftDocumentAuthorizationManager Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocumentAuthorizationManager.GetNonAuthorizedDraftDocuments Method

Gets the data of non authorized Draft Documents from the Draft Document Authorization table.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetNonAuthorizedDraftDocuments() As List(Of DraftDocument)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static List<DraftDocument> GetNonAuthorizedDraftDocuments()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static List<DraftDocument^>^ GetNonAuthorizedDraftDocuments()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Return Value

Type: List<DraftDocument>

A generic collection of Draft Documents data.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DraftDocumentAuthorizationManager Class
DraftDocumentAuthorizationManager Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocumentAuthorizationManager.ValidateDraftDocument Method

Validates the data of SAP Business One's Draft Stock Transfer document.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function ValidateDraftDocument( _
   ByVal Token As String, _
   ByVal draftDocument As StockTransferDocument _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool ValidateDraftDocument(
   string Token,
   StockTransferDocument draftDocument
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool ValidateDraftDocument(
   String^ Token,
   StockTransferDocument^ draftDocument
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function ValidateDraftDocument(
    Token : String,
    draftDocument : StockTransferDocument
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

draftDocument

Type: StockTransferDocument

The data of a Draft Stock Transfer document for validation.

Return Value

Type: bool

A Boolean value that indicates whether the data of a Draft Stock Transfer document is valid or not.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DraftDocumentAuthorizationManager Class
DraftDocumentAuthorizationManager Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocumentAuthorizationState Class

Members See Also

Represents the available states for Draft Documents.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class DraftDocumentAuthorizationState
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DraftDocumentAuthorizationState
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class DraftDocumentAuthorizationState
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DraftDocumentAuthorizationState
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager.DraftDocumentAuthorizationState
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DraftDocumentAuthorizationState Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocumentAuthorizationState Members

DraftDocumentAuthorizationState Class Methods Fields See Also

Represents the available states for Draft Documents.

The following tables list the members exposed by the DraftDocumentAuthorizationState type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | Authorized | Already authorized Draft Document.
Public field | NonAuthorized | Non authorized Draft Document.
Top
See Also

Reference

DraftDocumentAuthorizationState Class
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocumentAuthorizationState Methods

DraftDocumentAuthorizationState Class See Also

The following tables list the members exposed by the DraftDocumentAuthorizationState type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

DraftDocumentAuthorizationState Class
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocumentAuthorizationState Fields

DraftDocumentAuthorizationState Class See Also

The following tables list the members exposed by the DraftDocumentAuthorizationState type.

Fields
 | Name | Description
Public field | Authorized | Already authorized Draft Document.
Public field | NonAuthorized | Non authorized Draft Document.
Top
See Also

Reference

DraftDocumentAuthorizationState Class
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


Authorized Field

Already authorized Draft Document.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Authorized As String = "Y"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Authorized = @"Y"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Authorized = "Y";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Authorized : String = "Y"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DraftDocumentAuthorizationState Class
DraftDocumentAuthorizationState Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


NonAuthorized Field

Non authorized Draft Document.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const NonAuthorized As String = "N"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string NonAuthorized = @"N"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ NonAuthorized = "N";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const NonAuthorized : String = "N"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DraftDocumentAuthorizationState Class
DraftDocumentAuthorizationState Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferData Class

Members See Also

Represents a data of transferring item master data within the SAP Business One's Stock Transfer document.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class StockTransferData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class StockTransferData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class StockTransferData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class StockTransferData
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager.StockTransferData
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferData Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferData Members

StockTransferData Class Constructors Methods Properties See Also

Represents a data of transferring item master data within the SAP Business One's Stock Transfer document.

The following tables list the members exposed by the StockTransferData type.

Constructors
 | Name | Description
Public constructor | StockTransferData | (Overloaded) Initializes a new instance of CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.StockTransferData object.
Top
Properties
 | Name | Description
Public property | BatchNumbers | Gets or sets the batch number data for an item master data.
Public property | DestinationWarehouseCode | Gets or sets a code of destination warehouse.
Public property | IsLicensePlate | Gets or sets a type for given item code.
Public property | ItemCode | Gets or sets a code of transferring item master data.
Public property | ManagementType | Gets or sets the management type by which the item master data is managed by.
Public property | Quantity | Gets or sets a quantity for transferring item master data.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

StockTransferData Class
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferData Constructor

StockTransferData Class See Also

Initializes a new instance of CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.StockTransferData object.

Overload List
Name | Description
StockTransferData(string, string, bool, double) | Initializes a new instance of CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.StockTransferData object.
StockTransferData(string, string, bool, double, StockTransferDataManagementType) | Initializes a new instance of CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.StockTransferData object.
StockTransferData(string, string, bool, double, StockTransferDataManagementType, List<BatchNumber>) | Initializes a new instance of CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.StockTransferData object.
See Also

Reference

StockTransferData Class
StockTransferData Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferData Properties

StockTransferData Class See Also

The following tables list the members exposed by the StockTransferData type.

Properties
 | Name | Description
Public property | BatchNumbers | Gets or sets the batch number data for an item master data.
Public property | DestinationWarehouseCode | Gets or sets a code of destination warehouse.
Public property | IsLicensePlate | Gets or sets a type for given item code.
Public property | ItemCode | Gets or sets a code of transferring item master data.
Public property | ManagementType | Gets or sets the management type by which the item master data is managed by.
Public property | Quantity | Gets or sets a quantity for transferring item master data.
Top
See Also

Reference

StockTransferData Class
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferData.BatchNumbers Property

Gets or sets the batch number data for an item master data.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property BatchNumbers() As List(Of BatchNumber)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<BatchNumber> BatchNumbers {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<BatchNumber^>^ BatchNumbers {
 List<BatchNumber^>^ get( );
 void set(
   List<BatchNumber^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<BatchNumber>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferData Class
StockTransferData Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferData.DestinationWarehouseCode Property

Gets or sets a code of destination warehouse.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DestinationWarehouseCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DestinationWarehouseCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DestinationWarehouseCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DestinationWarehouseCode() : String;
public function set DestinationWarehouseCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferData Class
StockTransferData Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferData.IsLicensePlate Property

Gets or sets a type for given item code.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property IsLicensePlate() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool IsLicensePlate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool IsLicensePlate {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get IsLicensePlate() : boolean;
public function set IsLicensePlate(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferData Class
StockTransferData Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferData.ItemCode Property

Gets or sets a code of transferring item master data.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ItemCode() : String;
public function set ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferData Class
StockTransferData Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferData.ManagementType Property

Gets or sets the management type by which the item master data is managed by.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ManagementType() As StockTransferDataManagementType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public StockTransferDataManagementType ManagementType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property StockTransferDataManagementType ManagementType {
 StockTransferDataManagementType get( );
 void set(
   StockTransferDataManagementType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ManagementType() : StockTransferDataManagementType;
public function set ManagementType(value : StockTransferDataManagementType);
This language is not supported or no code example is available.

Property Value

Type: StockTransferDataManagementType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferData Class
StockTransferData Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferData.Quantity Property

Gets or sets a quantity for transferring item master data.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property double Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Quantity() : double;
public function set Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferData Class
StockTransferData Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferData Methods

StockTransferData Class See Also

The following tables list the members exposed by the StockTransferData type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

StockTransferData Class
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferDocument Class

Members See Also

Represents a data of the SAP Business One's Stock Transfer document.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class StockTransferDocument
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class StockTransferDocument
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class StockTransferDocument
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class StockTransferDocument
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager.StockTransferDocument
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferDocument Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferDocument Members

StockTransferDocument Class Constructors Methods Properties See Also

Represents a data of the SAP Business One's Stock Transfer document.

The following tables list the members exposed by the StockTransferDocument type.

Constructors
 | Name | Description
Public constructor | StockTransferDocument | Initializes a new instance of CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.StockTransferDocument object.
Top
Properties
 | Name | Description
Public property | Data | Gets or sets a generic collection of item master data defined within the Stock Transfer document.
Public property | DocumentDate | Gets or sets a date of the Stock Transfer document.
Public property | SourceWarehouseCode | Gets or sets a code of the source warehouse.
Public property | TaxDate | Gets or sets a tax date of the Stock Transfer document.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

StockTransferDocument Class
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferDocument Constructor

Initializes a new instance of CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.StockTransferDocument object.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal srcWhsCode As String, _
   ByVal docDate As Date, _
   ByVal taxDate As Date, _
   ByVal data As List(Of StockTransferData) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public StockTransferDocument(
   string srcWhsCode,
   DateTime docDate,
   DateTime taxDate,
   List<StockTransferData> data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
StockTransferDocument(
   String^ srcWhsCode,
   DateTime docDate,
   DateTime taxDate,
   List<StockTransferData^>^ data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

srcWhsCode

Type: string

A code of source warehouse from Stock Transfer document.

docDate

Type: DateTime

A date of Stock Transfer document.

taxDate

Type: DateTime

A tax date of Stock Transfer document.

data

Type: List<StockTransferData>

A generic collection of item master data defined within the Stock Transfer document.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferDocument Class
StockTransferDocument Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferDocument Properties

StockTransferDocument Class See Also

The following tables list the members exposed by the StockTransferDocument type.

Properties
 | Name | Description
Public property | Data | Gets or sets a generic collection of item master data defined within the Stock Transfer document.
Public property | DocumentDate | Gets or sets a date of the Stock Transfer document.
Public property | SourceWarehouseCode | Gets or sets a code of the source warehouse.
Public property | TaxDate | Gets or sets a tax date of the Stock Transfer document.
Top
See Also

Reference

StockTransferDocument Class
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferDocument.Data Property

Gets or sets a generic collection of item master data defined within the Stock Transfer document.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Data() As List(Of StockTransferData)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<StockTransferData> Data {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<StockTransferData^>^ Data {
 List<StockTransferData^>^ get( );
 void set(
   List<StockTransferData^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<StockTransferData>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferDocument Class
StockTransferDocument Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferDocument.DocumentDate Property

Gets or sets a date of the Stock Transfer document.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DocumentDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime DocumentDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime DocumentDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocumentDate() : DateTime;
public function set DocumentDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferDocument Class
StockTransferDocument Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferDocument.SourceWarehouseCode Property

Gets or sets a code of the source warehouse.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SourceWarehouseCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string SourceWarehouseCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ SourceWarehouseCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SourceWarehouseCode() : String;
public function set SourceWarehouseCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferDocument Class
StockTransferDocument Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferDocument.TaxDate Property

Gets or sets a tax date of the Stock Transfer document.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property TaxDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime TaxDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime TaxDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get TaxDate() : DateTime;
public function set TaxDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferDocument Class
StockTransferDocument Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferDocument Methods

StockTransferDocument Class See Also

The following tables list the members exposed by the StockTransferDocument type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

StockTransferDocument Class
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


DraftDocumentType Enumeration

Represents the types of SAP Business One's documents.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
StockTransfer | Stock Transfer document.
See Also

Reference

CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferDataManagementType Enumeration

Represents the available options of Item Master Data management.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
None | Item Master Data is not managed either by serial numbers and batches.
SerialNumbers | Item Master Data is managed by serial numbers.
Batches | Item Master Data is managed by batches.
See Also

Reference

CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


CompuTec.ProcessForce.API.Documents.ExpiryDateEvalTemplate Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IExpiryDateEvalTemplate | Expiry date of eval template object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IExpiryDateEvalTemplate Interface

Members See Also

Expiry date of eval template object

Namespace: CompuTec.ProcessForce.API.Documents.ExpiryDateEvalTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ExpiryDateEvalTemplate", TableName = "@CT_PF_OEET")> _
Public Interface IExpiryDateEvalTemplate
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ExpiryDateEvalTemplate", TableName = "@CT_PF_OEET")]
public interface IExpiryDateEvalTemplate : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ExpiryDateEvalTemplate", TableName = "@CT_PF_OEET")]
public interface class IExpiryDateEvalTemplate : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ExpiryDateEvalTemplate", TableName = "@CT_PF_OEET")
interface IExpiryDateEvalTemplate
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OEET
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExpiryDateEvalTemplate Members
CompuTec.ProcessForce.API.Documents.ExpiryDateEvalTemplate Namespace


IExpiryDateEvalTemplate Members

IExpiryDateEvalTemplate Interface Methods Properties See Also

Expiry date of eval template object

The following tables list the members exposed by the IExpiryDateEvalTemplate type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Remarks |
Public property | U_Template |
Public property | U_TemplateName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IExpiryDateEvalTemplate Interface
CompuTec.ProcessForce.API.Documents.ExpiryDateEvalTemplate Namespace


IExpiryDateEvalTemplate Properties

IExpiryDateEvalTemplate Interface See Also

The following tables list the members exposed by the IExpiryDateEvalTemplate type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Remarks |
Public property | U_Template |
Public property | U_TemplateName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
See Also

Reference

IExpiryDateEvalTemplate Interface
CompuTec.ProcessForce.API.Documents.ExpiryDateEvalTemplate Namespace


IExpiryDateEvalTemplate.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ExpiryDateEvalTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExpiryDateEvalTemplate Interface
IExpiryDateEvalTemplate Members
CompuTec.ProcessForce.API.Documents.ExpiryDateEvalTemplate Namespace


IExpiryDateEvalTemplate.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.ExpiryDateEvalTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExpiryDateEvalTemplate Interface
IExpiryDateEvalTemplate Members
CompuTec.ProcessForce.API.Documents.ExpiryDateEvalTemplate Namespace


IExpiryDateEvalTemplate.U_Template Property

Namespace: CompuTec.ProcessForce.API.Documents.ExpiryDateEvalTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Template() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Template {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Template {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Template() : String;
function set U_Template(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExpiryDateEvalTemplate Interface
IExpiryDateEvalTemplate Members
CompuTec.ProcessForce.API.Documents.ExpiryDateEvalTemplate Namespace


IExpiryDateEvalTemplate.U_TemplateName Property

Namespace: CompuTec.ProcessForce.API.Documents.ExpiryDateEvalTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TemplateName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TemplateName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TemplateName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TemplateName() : String;
function set U_TemplateName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExpiryDateEvalTemplate Interface
IExpiryDateEvalTemplate Members
CompuTec.ProcessForce.API.Documents.ExpiryDateEvalTemplate Namespace


IExpiryDateEvalTemplate Methods

IExpiryDateEvalTemplate Interface See Also

The following tables list the members exposed by the IExpiryDateEvalTemplate type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IExpiryDateEvalTemplate Interface
CompuTec.ProcessForce.API.Documents.ExpiryDateEvalTemplate Namespace


CompuTec.ProcessForce.API.Documents.HelpConfig Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IHelpConfig | Help config object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IHelpConfig Interface

Members See Also

Help config object

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "HelpConfig", TableName = "@CT_PF_OHCF")> _
Public Interface IHelpConfig
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "HelpConfig", TableName = "@CT_PF_OHCF")]
public interface IHelpConfig : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "HelpConfig", TableName = "@CT_PF_OHCF")]
public interface class IHelpConfig : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "HelpConfig", TableName = "@CT_PF_OHCF")
interface IHelpConfig
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OHCF
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig Members

IHelpConfig Interface Methods Properties See Also

Help config object

The following tables list the members exposed by the IHelpConfig type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_FormType |
Public property | U_HelpFilePath |
Public property | U_ItemUniqueId |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByFormTypeItemUid | Gets the data of Help Config UDO object by the form's type and item's unique ID values.
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IHelpConfig Interface
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig Properties

IHelpConfig Interface See Also

The following tables list the members exposed by the IHelpConfig type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_FormType |
Public property | U_HelpFilePath |
Public property | U_ItemUniqueId |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IHelpConfig Interface
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Interface
IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Interface
IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Interface
IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Interface
IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Interface
IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Interface
IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Interface
IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Interface
IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Interface
IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Interface
IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig.U_FormType Property

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FormType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FormType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FormType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FormType() : String;
function set U_FormType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Interface
IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig.U_HelpFilePath Property

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_HelpFilePath() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_HelpFilePath {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_HelpFilePath {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_HelpFilePath() : String;
function set U_HelpFilePath(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Interface
IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig.U_ItemUniqueId Property

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemUniqueId() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemUniqueId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemUniqueId {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemUniqueId() : String;
function set U_ItemUniqueId(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Interface
IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Interface
IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Interface
IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Interface
IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Interface
IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Interface
IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig Methods

IHelpConfig Interface See Also

The following tables list the members exposed by the IHelpConfig type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByFormTypeItemUid | Gets the data of Help Config UDO object by the form's type and item's unique ID values.
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IHelpConfig Interface
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


IHelpConfig.GetByFormTypeItemUid Method

Gets the data of Help Config UDO object by the form's type and item's unique ID values.

Namespace: CompuTec.ProcessForce.API.Documents.HelpConfig
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByFormTypeItemUid( _
   ByVal formType As String, _
   ByVal itemUniqueId As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool GetByFormTypeItemUid(
   string formType,
   string itemUniqueId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool GetByFormTypeItemUid(
   String^ formType,
   String^ itemUniqueId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByFormTypeItemUid(
    formType : String,
    itemUniqueId : String
) : boolean;
This language is not supported or no code example is available.

Parameters

formType

Type: string

The type of a SAPbouiCOM.Form object.

itemUniqueId

Type: string

The unique ID value of SAPbouiCOM.Item object.

Return Value

Type: bool

A Boolean value that indicates whether the data was successfully loaded or not.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IHelpConfig Interface
IHelpConfig Members
CompuTec.ProcessForce.API.Documents.HelpConfig Namespace


CompuTec.ProcessForce.API.Documents.Ingredients Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IAllergen | Allergen object
Public interface | IIngredientAllergens | Allergens of ingredient object
Public interface | IIngredientCategory | Ingredient category object
Public interface | IIngredientCertificates | Certificates of ingredient object
Public interface | IIngredientClassification | Ingredient classification object
Public interface | IIngredientClassificationType | Classification type for ingredient class object
Public interface | IIngredientClassifications | Classification of ingredient object
Public interface | IIngredientDailyValueIngredients | Ingredients for daily value of ingredients object
Public interface | IIngredientDailyValueMasterData | Daily value of ingredient object
Public interface | IIngredientMasterData | Ingredient object
Public interface | IIngredientSpecifications | Specification of ingredient object
Public interface | IIngredientTemplate | Ingredient template object
Public interface | IIngredientTemplateIngredients | Ingredient template for ingredients object
Public interface | IIngredientTemplateNutrients | Nutrients for ingredient template object
Public interface | IItemIngredientData | Item ingredient data object
Public interface | IItemIngredientDataAllergens | Allergens for item ingredient data object
Public interface | IItemIngredientDataCertificates | Certificates of item ingredient data object
Public interface | IItemIngredientDataClassifications | Classifications of item ingredient data object
Public interface | IItemIngredientDataIngredients | Ingredients of item ingredient data object
Public interface | IItemIngredientDataNutrients | Nutrients of item ingredient data object
Public interface | IItemIngredientDataSpecifications | Specifications of item ingredient data object
Public interface | INutrient | Nutrient object
Top
Enumerations
 | Name | Description
Public enumeration | IngredientClasificationStatus |
Public enumeration | IngredientCondition |
Public enumeration | IngredientSpecificationStatus |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IAllergen Interface

Members See Also

Allergen object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "Allergen", TableName = "@CT_PF_OALG", UDOVersion = "UDO_10")> _
Public Interface IAllergen
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Allergen", TableName = "@CT_PF_OALG", UDOVersion = "UDO_10")]
public interface IAllergen : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Allergen", TableName = "@CT_PF_OALG", UDOVersion = "UDO_10")]
public interface class IAllergen : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "Allergen", TableName = "@CT_PF_OALG", UDOVersion = "UDO_10")
interface IAllergen
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OALG
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen Members

IAllergen Interface Methods Properties See Also

Allergen object

The following tables list the members exposed by the IAllergen type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Code |
Public property | U_Name |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByAlgCode |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IAllergen Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen Properties

IAllergen Interface See Also

The following tables list the members exposed by the IAllergen type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Code |
Public property | U_Name |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IAllergen Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Interface
IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Interface
IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Interface
IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Interface
IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Interface
IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Interface
IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Interface
IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Interface
IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Interface
IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Interface
IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen.U_Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_Code() : String;

   AppEngineProperty(Required = true)
function set U_Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Interface
IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen.U_Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Name() : String;
function set U_Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Interface
IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Interface
IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Interface
IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Interface
IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Interface
IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Interface
IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Interface
IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen Methods

IAllergen Interface See Also

The following tables list the members exposed by the IAllergen type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByAlgCode |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IAllergen Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IAllergen.GetByAlgCode Method

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByAlgCode( _
   ByVal code As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByAlgCode(
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByAlgCode(
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByAlgCode(
    code : String
) : int;
This language is not supported or no code example is available.

Parameters

code

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAllergen Interface
IAllergen Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientAllergens Interface

Members See Also

Allergens of ingredient object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IIngredientAllergens
    Inherits IUDOChildBean, _
             IEnumerable(Of IIngredientAllergens)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IIngredientAllergens : IUDOChildBean,
   IEnumerable<IIngredientAllergens>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IIngredientAllergens : public IUDOChildBean^,
   public IEnumerable<IIngredientAllergens^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IMD1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientAllergens Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientAllergens Members

IIngredientAllergens Interface Methods Properties See Also

Allergens of ingredient object

The following tables list the members exposed by the IIngredientAllergens type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AlgCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IIngredientAllergens Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientAllergens Properties

IIngredientAllergens Interface See Also

The following tables list the members exposed by the IIngredientAllergens type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AlgCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
See Also

Reference

IIngredientAllergens Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientAllergens.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientAllergens Interface
IIngredientAllergens Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientAllergens.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientAllergens Interface
IIngredientAllergens Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientAllergens.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientAllergens Interface
IIngredientAllergens Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientAllergens.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientAllergens Interface
IIngredientAllergens Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientAllergens.U_AlgCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_AlgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_AlgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_AlgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_AlgCode() : String;

   AppEngineProperty(Required = true)
function set U_AlgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientAllergens Interface
IIngredientAllergens Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientAllergens Methods

IIngredientAllergens Interface See Also

The following tables list the members exposed by the IIngredientAllergens type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IIngredientAllergens Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory Interface

Members See Also

Ingredient category object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "IngredientCategory", TableName = "@CT_PF_OIGC", UDOVersion = "UDO_10")> _
Public Interface IIngredientCategory
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "IngredientCategory", TableName = "@CT_PF_OIGC", UDOVersion = "UDO_10")]
public interface IIngredientCategory : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "IngredientCategory", TableName = "@CT_PF_OIGC", UDOVersion = "UDO_10")]
public interface class IIngredientCategory : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "IngredientCategory", TableName = "@CT_PF_OIGC", UDOVersion = "UDO_10")
interface IIngredientCategory
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OIGC
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory Members

IIngredientCategory Interface Methods Properties See Also

Ingredient category object

The following tables list the members exposed by the IIngredientCategory type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Code |
Public property | U_Name |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByCatCode |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IIngredientCategory Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory Properties

IIngredientCategory Interface See Also

The following tables list the members exposed by the IIngredientCategory type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Code |
Public property | U_Name |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IIngredientCategory Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Interface
IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Interface
IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Interface
IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Interface
IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Interface
IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Interface
IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Interface
IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Interface
IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Interface
IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Interface
IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory.U_Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_Code() : String;

   AppEngineProperty(Required = true)
function set U_Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Interface
IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory.U_Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Name() : String;
function set U_Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Interface
IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Interface
IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Interface
IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Interface
IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Interface
IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Interface
IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Interface
IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory Methods

IIngredientCategory Interface See Also

The following tables list the members exposed by the IIngredientCategory type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByCatCode |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IIngredientCategory Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCategory.GetByCatCode Method

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByCatCode( _
   ByVal code As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByCatCode(
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByCatCode(
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByCatCode(
    code : String
) : int;
This language is not supported or no code example is available.

Parameters

code

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCategory Interface
IIngredientCategory Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCertificates Interface

Members See Also

Certificates of ingredient object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IIngredientCertificates
    Inherits IUDOChildBean, _
             IEnumerable(Of IIngredientCertificates)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IIngredientCertificates : IUDOChildBean,
   IEnumerable<IIngredientCertificates>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IIngredientCertificates : public IUDOChildBean^,
   public IEnumerable<IIngredientCertificates^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IMD3
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCertificates Members

IIngredientCertificates Interface Methods Properties See Also

Certificates of ingredient object

The following tables list the members exposed by the IIngredientCertificates type.

Properties
 | Name | Description
Public property | BusinessPartnerName |
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Attachment |
Public property | U_BPCode |
Public property | U_CertDate |
Public property | U_CertNum |
Public property | U_ClassCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Remarks |
Public property | U_StatDate |
Public property | U_Status |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IIngredientCertificates Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCertificates Properties

IIngredientCertificates Interface See Also

The following tables list the members exposed by the IIngredientCertificates type.

Properties
 | Name | Description
Public property | BusinessPartnerName |
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Attachment |
Public property | U_BPCode |
Public property | U_CertDate |
Public property | U_CertNum |
Public property | U_ClassCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Remarks |
Public property | U_StatDate |
Public property | U_Status |
Top
See Also

Reference

IIngredientCertificates Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCertificates.BusinessPartnerName Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property BusinessPartnerName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string BusinessPartnerName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ BusinessPartnerName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BusinessPartnerName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCertificates Interface
IIngredientCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCertificates.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCertificates Interface
IIngredientCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCertificates.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCertificates Interface
IIngredientCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCertificates.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCertificates Interface
IIngredientCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCertificates.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCertificates Interface
IIngredientCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCertificates.U_Attachment Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Attachment() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Attachment {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Attachment {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Attachment() : String;
function set U_Attachment(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCertificates Interface
IIngredientCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCertificates.U_BPCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BPCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BPCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BPCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BPCode() : String;
function set U_BPCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCertificates Interface
IIngredientCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCertificates.U_CertDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CertDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_CertDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_CertDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CertDate() : DateTime;
function set U_CertDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCertificates Interface
IIngredientCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCertificates.U_CertNum Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CertNum() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CertNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CertNum {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CertNum() : String;
function set U_CertNum(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCertificates Interface
IIngredientCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCertificates.U_ClassCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ClassCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ClassCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ClassCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ClassCode() : String;
function set U_ClassCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCertificates Interface
IIngredientCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCertificates.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCertificates Interface
IIngredientCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCertificates.U_StatDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StatDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StatDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StatDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StatDate() : DateTime;
function set U_StatDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCertificates Interface
IIngredientCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCertificates.U_Status Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Status() As IngredientClasificationStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IngredientClasificationStatus U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IngredientClasificationStatus U_Status {
 IngredientClasificationStatus get( );
 void set(
   IngredientClasificationStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Status() : IngredientClasificationStatus;
function set U_Status(value : IngredientClasificationStatus);
This language is not supported or no code example is available.

Property Value

Type: IngredientClasificationStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientCertificates Interface
IIngredientCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientCertificates Methods

IIngredientCertificates Interface See Also

The following tables list the members exposed by the IIngredientCertificates type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IIngredientCertificates Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification Interface

Members See Also

Ingredient classification object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "IngredientClassification", TableName = "@CT_PF_OICS", UDOVersion = "UDO_10")> _
Public Interface IIngredientClassification
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "IngredientClassification", TableName = "@CT_PF_OICS", UDOVersion = "UDO_10")]
public interface IIngredientClassification : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "IngredientClassification", TableName = "@CT_PF_OICS", UDOVersion = "UDO_10")]
public interface class IIngredientClassification : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "IngredientClassification", TableName = "@CT_PF_OICS", UDOVersion = "UDO_10")
interface IIngredientClassification
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OICS
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification Members

IIngredientClassification Interface Methods Properties See Also

Ingredient classification object

The following tables list the members exposed by the IIngredientClassification type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ClassType |
Public property | U_Code |
Public property | U_Desc |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByCode |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IIngredientClassification Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification Properties

IIngredientClassification Interface See Also

The following tables list the members exposed by the IIngredientClassification type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ClassType |
Public property | U_Code |
Public property | U_Desc |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IIngredientClassification Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<TimeType()> _
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[TimeType()]
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[TimeType()]
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   TimeType()
   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.U_ClassType Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ClassType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ClassType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ClassType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ClassType() : String;
function set U_ClassType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.U_Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_Code() : String;

   AppEngineProperty(Required = true)
function set U_Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.U_Desc Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Desc() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Desc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Desc {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Desc() : String;
function set U_Desc(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification Methods

IIngredientClassification Interface See Also

The following tables list the members exposed by the IIngredientClassification type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByCode |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IIngredientClassification Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassification.GetByCode Method

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByCode( _
   ByVal code As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByCode(
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByCode(
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByCode(
    code : String
) : int;
This language is not supported or no code example is available.

Parameters

code

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassification Interface
IIngredientClassification Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType Interface

Members See Also

Classification type for ingredient class object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "IngredientClassificationType", TableName = "@CT_PF_OICT")> _
Public Interface IIngredientClassificationType
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "IngredientClassificationType", TableName = "@CT_PF_OICT")]
public interface IIngredientClassificationType : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "IngredientClassificationType", TableName = "@CT_PF_OICT")]
public interface class IIngredientClassificationType : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "IngredientClassificationType", TableName = "@CT_PF_OICT")
interface IIngredientClassificationType
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OICT
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType Members

IIngredientClassificationType Interface Methods Properties See Also

Classification type for ingredient class object

The following tables list the members exposed by the IIngredientClassificationType type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Code |
Public property | U_Desc |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByCode |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IIngredientClassificationType Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType Properties

IIngredientClassificationType Interface See Also

The following tables list the members exposed by the IIngredientClassificationType type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Code |
Public property | U_Desc |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IIngredientClassificationType Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Interface
IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Interface
IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Interface
IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Interface
IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Interface
IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Interface
IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Interface
IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Interface
IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Interface
IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Interface
IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType.U_Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_Code() : String;

   AppEngineProperty(Required = true)
function set U_Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Interface
IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType.U_Desc Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Desc() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Desc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Desc {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Desc() : String;
function set U_Desc(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Interface
IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Interface
IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Interface
IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Interface
IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Interface
IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Interface
IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Interface
IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType Methods

IIngredientClassificationType Interface See Also

The following tables list the members exposed by the IIngredientClassificationType type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByCode |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IIngredientClassificationType Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassificationType.GetByCode Method

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByCode( _
   ByVal code As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByCode(
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByCode(
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByCode(
    code : String
) : int;
This language is not supported or no code example is available.

Parameters

code

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassificationType Interface
IIngredientClassificationType Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassifications Interface

Members See Also

Classification of ingredient object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IIngredientClassifications
    Inherits IUDOChildBean, _
             IEnumerable(Of IIngredientClassifications)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IIngredientClassifications : IUDOChildBean,
   IEnumerable<IIngredientClassifications>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IIngredientClassifications : public IUDOChildBean^,
   public IEnumerable<IIngredientClassifications^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IMD2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassifications Members

IIngredientClassifications Interface Methods Properties See Also

Classification of ingredient object

The following tables list the members exposed by the IIngredientClassifications type.

Properties
 | Name | Description
Public property | ClassificationName |
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ClassCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IIngredientClassifications Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassifications Properties

IIngredientClassifications Interface See Also

The following tables list the members exposed by the IIngredientClassifications type.

Properties
 | Name | Description
Public property | ClassificationName |
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ClassCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
See Also

Reference

IIngredientClassifications Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassifications.ClassificationName Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property ClassificationName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string ClassificationName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ ClassificationName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ClassificationName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassifications Interface
IIngredientClassifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassifications.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassifications Interface
IIngredientClassifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassifications.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassifications Interface
IIngredientClassifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassifications.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassifications Interface
IIngredientClassifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassifications.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassifications Interface
IIngredientClassifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassifications.U_ClassCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_ClassCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_ClassCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_ClassCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_ClassCode() : String;

   AppEngineProperty(Required = true)
function set U_ClassCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientClassifications Interface
IIngredientClassifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientClassifications Methods

IIngredientClassifications Interface See Also

The following tables list the members exposed by the IIngredientClassifications type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IIngredientClassifications Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueIngredients Interface

Members See Also

Ingredients for daily value of ingredients object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IIngredientDailyValueIngredients
    Inherits IUDOChildBean, _
             IEnumerable(Of IIngredientDailyValueIngredients)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IIngredientDailyValueIngredients : IUDOChildBean,
   IEnumerable<IIngredientDailyValueIngredients>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IIngredientDailyValueIngredients : public IUDOChildBean^,
   public IEnumerable<IIngredientDailyValueIngredients^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IDV1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueIngredients Members

IIngredientDailyValueIngredients Interface Methods Properties See Also

Ingredients for daily value of ingredients object

The following tables list the members exposed by the IIngredientDailyValueIngredients type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_DailyValue |
Public property | U_IdgCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Remarks |
Public property | U_Uom |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IIngredientDailyValueIngredients Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueIngredients Properties

IIngredientDailyValueIngredients Interface See Also

The following tables list the members exposed by the IIngredientDailyValueIngredients type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_DailyValue |
Public property | U_IdgCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Remarks |
Public property | U_Uom |
Top
See Also

Reference

IIngredientDailyValueIngredients Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueIngredients.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueIngredients Interface
IIngredientDailyValueIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueIngredients.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueIngredients Interface
IIngredientDailyValueIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueIngredients.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueIngredients Interface
IIngredientDailyValueIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueIngredients.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueIngredients Interface
IIngredientDailyValueIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueIngredients.U_DailyValue Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DailyValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_DailyValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_DailyValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DailyValue() : double;
function set U_DailyValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueIngredients Interface
IIngredientDailyValueIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueIngredients.U_IdgCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IdgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_IdgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_IdgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IdgCode() : String;
function set U_IdgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueIngredients Interface
IIngredientDailyValueIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueIngredients.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueIngredients Interface
IIngredientDailyValueIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueIngredients.U_Uom Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Uom() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Uom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Uom {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Uom() : String;
function set U_Uom(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueIngredients Interface
IIngredientDailyValueIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueIngredients Methods

IIngredientDailyValueIngredients Interface See Also

The following tables list the members exposed by the IIngredientDailyValueIngredients type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IIngredientDailyValueIngredients Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData Interface

Members See Also

Daily value of ingredient object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "IngredientDailyValue", TableName = "@CT_PF_OIDV", UDOVersion = "UDO_10")> _
Public Interface IIngredientDailyValueMasterData
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "IngredientDailyValue", TableName = "@CT_PF_OIDV", UDOVersion = "UDO_10")]
public interface IIngredientDailyValueMasterData : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "IngredientDailyValue", TableName = "@CT_PF_OIDV", UDOVersion = "UDO_10")]
public interface class IIngredientDailyValueMasterData : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "IngredientDailyValue", TableName = "@CT_PF_OIDV", UDOVersion = "UDO_10")
interface IIngredientDailyValueMasterData
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OIDV
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData Members

IIngredientDailyValueMasterData Interface Methods Properties See Also

Daily value of ingredient object

The following tables list the members exposed by the IIngredientDailyValueMasterData type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Ingredients |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Code |
Public property | U_Name |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Clone |
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IIngredientDailyValueMasterData Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData Properties

IIngredientDailyValueMasterData Interface See Also

The following tables list the members exposed by the IIngredientDailyValueMasterData type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Ingredients |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Code |
Public property | U_Name |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IIngredientDailyValueMasterData Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.Ingredients Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Ingredients() As IIngredientDailyValueIngredients
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IIngredientDailyValueIngredients Ingredients {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IIngredientDailyValueIngredients^ Ingredients {
 IIngredientDailyValueIngredients^ get( );
 void set(
   IIngredientDailyValueIngredients^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Ingredients() : IIngredientDailyValueIngredients;
function set Ingredients(value : IIngredientDailyValueIngredients);
This language is not supported or no code example is available.

Property Value

Type: IIngredientDailyValueIngredients
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.U_Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Code() : String;
function set U_Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.U_Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Name() : String;
function set U_Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData Methods

IIngredientDailyValueMasterData Interface See Also

The following tables list the members exposed by the IIngredientDailyValueMasterData type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Clone |
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IIngredientDailyValueMasterData Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientDailyValueMasterData.Clone Method

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Clone()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Clone()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Clone()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Clone();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientDailyValueMasterData Interface
IIngredientDailyValueMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData Interface

Members See Also

Ingredient object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "IngredientMasterData", TableName = "@CT_PF_OIMD", UDOVersion = "UDO_10")> _
Public Interface IIngredientMasterData
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "IngredientMasterData", TableName = "@CT_PF_OIMD", UDOVersion = "UDO_10")]
public interface IIngredientMasterData : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "IngredientMasterData", TableName = "@CT_PF_OIMD", UDOVersion = "UDO_10")]
public interface class IIngredientMasterData : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "IngredientMasterData", TableName = "@CT_PF_OIMD", UDOVersion = "UDO_10")
interface IIngredientMasterData
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OIMD
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData Members

IIngredientMasterData Interface Methods Properties See Also

Ingredient object

The following tables list the members exposed by the IIngredientMasterData type.

Properties
 | Name | Description
Public property | Allergens |
Public property | Canceled |
Public property | Certificates |
Public property | Classifications | return ingredient classifications
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | IngredientCategory | returns ingredient Category
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Specifications |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_AltCode |
Public property | U_Category |
Public property | U_Code |
Public property | U_Desc |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | U_UoM |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByIgdCode |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IIngredientMasterData Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData Properties

IIngredientMasterData Interface See Also

The following tables list the members exposed by the IIngredientMasterData type.

Properties
 | Name | Description
Public property | Allergens |
Public property | Canceled |
Public property | Certificates |
Public property | Classifications | return ingredient classifications
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | IngredientCategory | returns ingredient Category
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Specifications |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_AltCode |
Public property | U_Category |
Public property | U_Code |
Public property | U_Desc |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | U_UoM |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IIngredientMasterData Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.Allergens Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Allergens() As IIngredientAllergens
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IIngredientAllergens Allergens {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IIngredientAllergens^ Allergens {
 IIngredientAllergens^ get( );
 void set(
   IIngredientAllergens^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Allergens() : IIngredientAllergens;
function set Allergens(value : IIngredientAllergens);
This language is not supported or no code example is available.

Property Value

Type: IIngredientAllergens
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.Certificates Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Certificates() As IIngredientCertificates
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IIngredientCertificates Certificates {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IIngredientCertificates^ Certificates {
 IIngredientCertificates^ get( );
 void set(
   IIngredientCertificates^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Certificates() : IIngredientCertificates;
function set Certificates(value : IIngredientCertificates);
This language is not supported or no code example is available.

Property Value

Type: IIngredientCertificates
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.Classifications Property

return ingredient classifications

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Classifications() As IIngredientClassifications
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IIngredientClassifications Classifications {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IIngredientClassifications^ Classifications {
 IIngredientClassifications^ get( );
 void set(
   IIngredientClassifications^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Classifications() : IIngredientClassifications;
function set Classifications(value : IIngredientClassifications);
This language is not supported or no code example is available.

Property Value

Type: IIngredientClassifications
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.IngredientCategory Property

returns ingredient Category

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property IngredientCategory() As IIngredientCategory
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IIngredientCategory IngredientCategory {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IIngredientCategory^ IngredientCategory {
 IIngredientCategory^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get IngredientCategory() : IIngredientCategory;
This language is not supported or no code example is available.

Property Value

Type: IIngredientCategory
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.Specifications Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Specifications() As IIngredientSpecifications
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IIngredientSpecifications Specifications {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IIngredientSpecifications^ Specifications {
 IIngredientSpecifications^ get( );
 void set(
   IIngredientSpecifications^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Specifications() : IIngredientSpecifications;
function set Specifications(value : IIngredientSpecifications);
This language is not supported or no code example is available.

Property Value

Type: IIngredientSpecifications
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.U_AltCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AltCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AltCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AltCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AltCode() : String;
function set U_AltCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.U_Category Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Category() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Category {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Category {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Category() : String;
function set U_Category(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.U_Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_Code() : String;

   AppEngineProperty(Required = true)
function set U_Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.U_Desc Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Desc() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Desc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Desc {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Desc() : String;
function set U_Desc(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.U_UoM Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UoM() : String;
function set U_UoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData Methods

IIngredientMasterData Interface See Also

The following tables list the members exposed by the IIngredientMasterData type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByIgdCode |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IIngredientMasterData Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientMasterData.GetByIgdCode Method

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByIgdCode( _
   ByVal code As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByIgdCode(
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByIgdCode(
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByIgdCode(
    code : String
) : int;
This language is not supported or no code example is available.

Parameters

code

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientMasterData Interface
IIngredientMasterData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientSpecifications Interface

Members See Also

Specification of ingredient object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IIngredientSpecifications
    Inherits IUDOChildBean, _
             IEnumerable(Of IIngredientSpecifications)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IIngredientSpecifications : IUDOChildBean,
   IEnumerable<IIngredientSpecifications>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IIngredientSpecifications : public IUDOChildBean^,
   public IEnumerable<IIngredientSpecifications^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IMD4
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientSpecifications Members

IIngredientSpecifications Interface Methods Properties See Also

Specification of ingredient object

The following tables list the members exposed by the IIngredientSpecifications type.

Properties
 | Name | Description
Public property | BPName |
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Attachment |
Public property | U_BPCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Remarks |
Public property | U_SpecDate |
Public property | U_SpecNum |
Public property | U_StatDate |
Public property | U_Status |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IIngredientSpecifications Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientSpecifications Properties

IIngredientSpecifications Interface See Also

The following tables list the members exposed by the IIngredientSpecifications type.

Properties
 | Name | Description
Public property | BPName |
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Attachment |
Public property | U_BPCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Remarks |
Public property | U_SpecDate |
Public property | U_SpecNum |
Public property | U_StatDate |
Public property | U_Status |
Top
See Also

Reference

IIngredientSpecifications Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientSpecifications.BPName Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property BPName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string BPName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ BPName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BPName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientSpecifications Interface
IIngredientSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientSpecifications.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientSpecifications Interface
IIngredientSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientSpecifications.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientSpecifications Interface
IIngredientSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientSpecifications.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientSpecifications Interface
IIngredientSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientSpecifications.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientSpecifications Interface
IIngredientSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientSpecifications.U_Attachment Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Attachment() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Attachment {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Attachment {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Attachment() : String;
function set U_Attachment(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientSpecifications Interface
IIngredientSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientSpecifications.U_BPCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BPCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BPCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BPCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BPCode() : String;
function set U_BPCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientSpecifications Interface
IIngredientSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientSpecifications.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientSpecifications Interface
IIngredientSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientSpecifications.U_SpecDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SpecDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_SpecDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_SpecDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SpecDate() : DateTime;
function set U_SpecDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientSpecifications Interface
IIngredientSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientSpecifications.U_SpecNum Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SpecNum() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SpecNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SpecNum {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SpecNum() : String;
function set U_SpecNum(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientSpecifications Interface
IIngredientSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientSpecifications.U_StatDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StatDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StatDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StatDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StatDate() : DateTime;
function set U_StatDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientSpecifications Interface
IIngredientSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientSpecifications.U_Status Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Status() As IngredientSpecificationStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IngredientSpecificationStatus U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IngredientSpecificationStatus U_Status {
 IngredientSpecificationStatus get( );
 void set(
   IngredientSpecificationStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Status() : IngredientSpecificationStatus;
function set U_Status(value : IngredientSpecificationStatus);
This language is not supported or no code example is available.

Property Value

Type: IngredientSpecificationStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientSpecifications Interface
IIngredientSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientSpecifications Methods

IIngredientSpecifications Interface See Also

The following tables list the members exposed by the IIngredientSpecifications type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IIngredientSpecifications Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate Interface

Members See Also

Ingredient template object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "IngredientTemplate", TableName = "@CT_PF_OIGT", UDOVersion = "UDO_10")> _
Public Interface IIngredientTemplate
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "IngredientTemplate", TableName = "@CT_PF_OIGT", UDOVersion = "UDO_10")]
public interface IIngredientTemplate : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "IngredientTemplate", TableName = "@CT_PF_OIGT", UDOVersion = "UDO_10")]
public interface class IIngredientTemplate : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "IngredientTemplate", TableName = "@CT_PF_OIGT", UDOVersion = "UDO_10")
interface IIngredientTemplate
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OIGT
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate Members

IIngredientTemplate Interface Methods Properties See Also

Ingredient template object

The following tables list the members exposed by the IIngredientTemplate type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Ingredients |
Public property | LogInst |
Public property | Name |
Public property | Nutrients |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Code |
Public property | U_Name |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetByTmplCode |
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IIngredientTemplate Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate Properties

IIngredientTemplate Interface See Also

The following tables list the members exposed by the IIngredientTemplate type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Ingredients |
Public property | LogInst |
Public property | Name |
Public property | Nutrients |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Code |
Public property | U_Name |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IIngredientTemplate Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.Ingredients Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Ingredients() As IIngredientTemplateIngredients
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IIngredientTemplateIngredients Ingredients {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IIngredientTemplateIngredients^ Ingredients {
 IIngredientTemplateIngredients^ get( );
 void set(
   IIngredientTemplateIngredients^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Ingredients() : IIngredientTemplateIngredients;
function set Ingredients(value : IIngredientTemplateIngredients);
This language is not supported or no code example is available.

Property Value

Type: IIngredientTemplateIngredients
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.Nutrients Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Nutrients() As IIngredientTemplateNutrients
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IIngredientTemplateNutrients Nutrients {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IIngredientTemplateNutrients^ Nutrients {
 IIngredientTemplateNutrients^ get( );
 void set(
   IIngredientTemplateNutrients^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Nutrients() : IIngredientTemplateNutrients;
function set Nutrients(value : IIngredientTemplateNutrients);
This language is not supported or no code example is available.

Property Value

Type: IIngredientTemplateNutrients
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.U_Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_Code() : String;

   AppEngineProperty(Required = true)
function set U_Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.U_Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Name() : String;
function set U_Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate Methods

IIngredientTemplate Interface See Also

The following tables list the members exposed by the IIngredientTemplate type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetByTmplCode |
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IIngredientTemplate Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplate.GetByTmplCode Method

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByTmplCode( _
   ByVal code As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByTmplCode(
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByTmplCode(
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByTmplCode(
    code : String
) : int;
This language is not supported or no code example is available.

Parameters

code

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplate Interface
IIngredientTemplate Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateIngredients Interface

Members See Also

Ingredient template for ingredients object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IIngredientTemplateIngredients
    Inherits IUDOChildBean, _
             IEnumerable(Of IIngredientTemplateIngredients)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IIngredientTemplateIngredients : IUDOChildBean,
   IEnumerable<IIngredientTemplateIngredients>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IIngredientTemplateIngredients : public IUDOChildBean^,
   public IEnumerable<IIngredientTemplateIngredients^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IGT1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateIngredients Members

IIngredientTemplateIngredients Interface Methods Properties See Also

Ingredient template for ingredients object

The following tables list the members exposed by the IIngredientTemplateIngredients type.

Properties
 | Name | Description
Public property | AlternativeCode |
Public property | CategoryCode | return ingredient Category code. it is code for use for GetByKey method
Public property | CategoryName | returns Ingredient Category Name.
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | IngredientCode | returns ingredient Code. It is used for GetByKey method.
Public property | IngredientDescription |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_IgdCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Value |
Public property | UoM |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IIngredientTemplateIngredients Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateIngredients Properties

IIngredientTemplateIngredients Interface See Also

The following tables list the members exposed by the IIngredientTemplateIngredients type.

Properties
 | Name | Description
Public property | AlternativeCode |
Public property | CategoryCode | return ingredient Category code. it is code for use for GetByKey method
Public property | CategoryName | returns Ingredient Category Name.
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | IngredientCode | returns ingredient Code. It is used for GetByKey method.
Public property | IngredientDescription |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_IgdCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Value |
Public property | UoM |
Top
See Also

Reference

IIngredientTemplateIngredients Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateIngredients.AlternativeCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property AlternativeCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string AlternativeCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ AlternativeCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get AlternativeCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateIngredients Interface
IIngredientTemplateIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateIngredients.CategoryCode Property

return ingredient Category code. it is code for use for GetByKey method

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property CategoryCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string CategoryCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ CategoryCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CategoryCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateIngredients Interface
IIngredientTemplateIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateIngredients.CategoryName Property

returns Ingredient Category Name.

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property CategoryName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string CategoryName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ CategoryName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CategoryName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateIngredients Interface
IIngredientTemplateIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateIngredients.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateIngredients Interface
IIngredientTemplateIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateIngredients.IngredientCode Property

returns ingredient Code. It is used for GetByKey method.

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property IngredientCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string IngredientCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ IngredientCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get IngredientCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateIngredients Interface
IIngredientTemplateIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateIngredients.IngredientDescription Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property IngredientDescription() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string IngredientDescription {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ IngredientDescription {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get IngredientDescription() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateIngredients Interface
IIngredientTemplateIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateIngredients.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateIngredients Interface
IIngredientTemplateIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateIngredients.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateIngredients Interface
IIngredientTemplateIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateIngredients.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateIngredients Interface
IIngredientTemplateIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateIngredients.U_IgdCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_IgdCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_IgdCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_IgdCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_IgdCode() : String;

   AppEngineProperty(Required = true)
function set U_IgdCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateIngredients Interface
IIngredientTemplateIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateIngredients.U_Value Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Value() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Value {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Value {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Value() : double;
function set U_Value(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateIngredients Interface
IIngredientTemplateIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateIngredients.UoM Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string UoM {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ UoM {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UoM() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateIngredients Interface
IIngredientTemplateIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateIngredients Methods

IIngredientTemplateIngredients Interface See Also

The following tables list the members exposed by the IIngredientTemplateIngredients type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IIngredientTemplateIngredients Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateNutrients Interface

Members See Also

Nutrients for ingredient template object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IIngredientTemplateNutrients
    Inherits IUDOChildBean, _
             IEnumerable(Of IIngredientTemplateNutrients)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IIngredientTemplateNutrients : IUDOChildBean,
   IEnumerable<IIngredientTemplateNutrients>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IIngredientTemplateNutrients : public IUDOChildBean^,
   public IEnumerable<IIngredientTemplateNutrients^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IGT2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateNutrients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateNutrients Members

IIngredientTemplateNutrients Interface Methods Properties See Also

Nutrients for ingredient template object

The following tables list the members exposed by the IIngredientTemplateNutrients type.

Properties
 | Name | Description
Public property | Category |
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_NutCode |
Public property | U_Value |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IIngredientTemplateNutrients Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateNutrients Properties

IIngredientTemplateNutrients Interface See Also

The following tables list the members exposed by the IIngredientTemplateNutrients type.

Properties
 | Name | Description
Public property | Category |
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_NutCode |
Public property | U_Value |
Top
See Also

Reference

IIngredientTemplateNutrients Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateNutrients.Category Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Category() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Category {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Category {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Category() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateNutrients Interface
IIngredientTemplateNutrients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateNutrients.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateNutrients Interface
IIngredientTemplateNutrients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateNutrients.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateNutrients Interface
IIngredientTemplateNutrients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateNutrients.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateNutrients Interface
IIngredientTemplateNutrients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateNutrients.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateNutrients Interface
IIngredientTemplateNutrients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateNutrients.U_NutCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_NutCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_NutCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_NutCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_NutCode() : String;

   AppEngineProperty(Required = true)
function set U_NutCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateNutrients Interface
IIngredientTemplateNutrients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateNutrients.U_Value Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Value() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Value {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Value {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Value() : double;
function set U_Value(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientTemplateNutrients Interface
IIngredientTemplateNutrients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IIngredientTemplateNutrients Methods

IIngredientTemplateNutrients Interface See Also

The following tables list the members exposed by the IIngredientTemplateNutrients type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IIngredientTemplateNutrients Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData Interface

Members See Also

Item ingredient data object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ItemIngredientData", TableName = "@CT_PF_OIID", UDOVersion = "UDO_10")> _
Public Interface IItemIngredientData
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemIngredientData", TableName = "@CT_PF_OIID", UDOVersion = "UDO_10")]
public interface IItemIngredientData : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemIngredientData", TableName = "@CT_PF_OIID", UDOVersion = "UDO_10")]
public interface class IItemIngredientData : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ItemIngredientData", TableName = "@CT_PF_OIID", UDOVersion = "UDO_10")
interface IItemIngredientData
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OIID
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData Members

IItemIngredientData Interface Methods Properties See Also

Item ingredient data object

The following tables list the members exposed by the IItemIngredientData type.

Properties
 | Name | Description
Public property | Allergens |
Public property | Canceled |
Public property | Certificates |
Public property | Classifications |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | EnergyInKJoules |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Ingredients |
Public property | InventoryUoM |
Public property | ItemName |
Public property | LogInst |
Public property | Name |
Public property | Nutrients |
Public property | Object |
Public property | Specifications |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_AltCode |
Public property | U_AltUoM |
Public property | U_Category |
Public property | U_IgdTmpl |
Public property | U_IntakeCode |
Public property | U_ItemCode |
Public property | U_KCal |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Quantity |
Public property | U_Remarks |
Public property | U_Revision |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByCodeAndRevision |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Rollup |
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemIngredientData Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData Properties

IItemIngredientData Interface See Also

The following tables list the members exposed by the IItemIngredientData type.

Properties
 | Name | Description
Public property | Allergens |
Public property | Canceled |
Public property | Certificates |
Public property | Classifications |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | EnergyInKJoules |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Ingredients |
Public property | InventoryUoM |
Public property | ItemName |
Public property | LogInst |
Public property | Name |
Public property | Nutrients |
Public property | Object |
Public property | Specifications |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_AltCode |
Public property | U_AltUoM |
Public property | U_Category |
Public property | U_IgdTmpl |
Public property | U_IntakeCode |
Public property | U_ItemCode |
Public property | U_KCal |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Quantity |
Public property | U_Remarks |
Public property | U_Revision |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IItemIngredientData Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.Allergens Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Allergens() As IItemIngredientDataAllergens
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemIngredientDataAllergens Allergens {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemIngredientDataAllergens^ Allergens {
 IItemIngredientDataAllergens^ get( );
 void set(
   IItemIngredientDataAllergens^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Allergens() : IItemIngredientDataAllergens;
function set Allergens(value : IItemIngredientDataAllergens);
This language is not supported or no code example is available.

Property Value

Type: IItemIngredientDataAllergens
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.Certificates Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Certificates() As IItemIngredientDataCertificates
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemIngredientDataCertificates Certificates {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemIngredientDataCertificates^ Certificates {
 IItemIngredientDataCertificates^ get( );
 void set(
   IItemIngredientDataCertificates^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Certificates() : IItemIngredientDataCertificates;
function set Certificates(value : IItemIngredientDataCertificates);
This language is not supported or no code example is available.

Property Value

Type: IItemIngredientDataCertificates
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.Classifications Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Classifications() As IItemIngredientDataClassifications
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemIngredientDataClassifications Classifications {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemIngredientDataClassifications^ Classifications {
 IItemIngredientDataClassifications^ get( );
 void set(
   IItemIngredientDataClassifications^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Classifications() : IItemIngredientDataClassifications;
function set Classifications(value : IItemIngredientDataClassifications);
This language is not supported or no code example is available.

Property Value

Type: IItemIngredientDataClassifications
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.EnergyInKJoules Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property EnergyInKJoules() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double EnergyInKJoules {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double EnergyInKJoules {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get EnergyInKJoules() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.Ingredients Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Ingredients() As IItemIngredientDataIngredients
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemIngredientDataIngredients Ingredients {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemIngredientDataIngredients^ Ingredients {
 IItemIngredientDataIngredients^ get( );
 void set(
   IItemIngredientDataIngredients^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Ingredients() : IItemIngredientDataIngredients;
function set Ingredients(value : IItemIngredientDataIngredients);
This language is not supported or no code example is available.

Property Value

Type: IItemIngredientDataIngredients
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.InventoryUoM Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property InventoryUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string InventoryUoM {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ InventoryUoM {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get InventoryUoM() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.ItemName Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string ItemName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ ItemName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ItemName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.Nutrients Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Nutrients() As IItemIngredientDataNutrients
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemIngredientDataNutrients Nutrients {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemIngredientDataNutrients^ Nutrients {
 IItemIngredientDataNutrients^ get( );
 void set(
   IItemIngredientDataNutrients^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Nutrients() : IItemIngredientDataNutrients;
function set Nutrients(value : IItemIngredientDataNutrients);
This language is not supported or no code example is available.

Property Value

Type: IItemIngredientDataNutrients
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.Specifications Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Specifications() As IItemIngredientDataSpecifications
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemIngredientDataSpecifications Specifications {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemIngredientDataSpecifications^ Specifications {
 IItemIngredientDataSpecifications^ get( );
 void set(
   IItemIngredientDataSpecifications^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Specifications() : IItemIngredientDataSpecifications;
function set Specifications(value : IItemIngredientDataSpecifications);
This language is not supported or no code example is available.

Property Value

Type: IItemIngredientDataSpecifications
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.U_AltCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AltCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AltCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AltCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AltCode() : String;
function set U_AltCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.U_AltUoM Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AltUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AltUoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AltUoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AltUoM() : String;
function set U_AltUoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.U_Category Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Category() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Category {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Category {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Category() : String;
function set U_Category(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.U_IgdTmpl Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IgdTmpl() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_IgdTmpl {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_IgdTmpl {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IgdTmpl() : String;
function set U_IgdTmpl(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.U_IntakeCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IntakeCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_IntakeCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_IntakeCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IntakeCode() : String;
function set U_IntakeCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_ItemCode() : String;

   AppEngineProperty(Required = true)
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.U_KCal Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_KCal() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_KCal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_KCal {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_KCal() : double;
function set U_KCal(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.U_Quantity Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.U_Revision Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Revision() : String;
function set U_Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData Methods

IItemIngredientData Interface See Also

The following tables list the members exposed by the IItemIngredientData type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByCodeAndRevision |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Rollup |
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemIngredientData Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.GetByCodeAndRevision Method

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByCodeAndRevision( _
   ByVal itemCode As String, _
   ByVal revision As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByCodeAndRevision(
   string itemCode,
   string revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByCodeAndRevision(
   String^ itemCode,
   String^ revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByCodeAndRevision(
    itemCode : String,
    revision : String
) : int;
This language is not supported or no code example is available.

Parameters

itemCode

Type: string

revision

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientData.Rollup Method

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function Rollup() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool Rollup()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool Rollup()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Rollup() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientData Interface
IItemIngredientData Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataAllergens Interface

Members See Also

Allergens for item ingredient data object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemIngredientDataAllergens
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemIngredientDataAllergens)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemIngredientDataAllergens : IUDOChildBean,
   IEnumerable<IItemIngredientDataAllergens>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemIngredientDataAllergens : public IUDOChildBean^,
   public IEnumerable<IItemIngredientDataAllergens^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IID3
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataAllergens Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataAllergens Members

IItemIngredientDataAllergens Interface Methods Properties See Also

Allergens for item ingredient data object

The following tables list the members exposed by the IItemIngredientDataAllergens type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AlgCode |
Public property | U_CrossCtmn |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemIngredientDataAllergens Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataAllergens Properties

IItemIngredientDataAllergens Interface See Also

The following tables list the members exposed by the IItemIngredientDataAllergens type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AlgCode |
Public property | U_CrossCtmn |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
See Also

Reference

IItemIngredientDataAllergens Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataAllergens.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataAllergens Interface
IItemIngredientDataAllergens Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataAllergens.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataAllergens Interface
IItemIngredientDataAllergens Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataAllergens.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataAllergens Interface
IItemIngredientDataAllergens Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataAllergens.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataAllergens Interface
IItemIngredientDataAllergens Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataAllergens.U_AlgCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_AlgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_AlgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_AlgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_AlgCode() : String;

   AppEngineProperty(Required = true)
function set U_AlgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataAllergens Interface
IItemIngredientDataAllergens Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataAllergens.U_CrossCtmn Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CrossCtmn() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_CrossCtmn {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_CrossCtmn {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CrossCtmn() : YesNoType;
function set U_CrossCtmn(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataAllergens Interface
IItemIngredientDataAllergens Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataAllergens Methods

IItemIngredientDataAllergens Interface See Also

The following tables list the members exposed by the IItemIngredientDataAllergens type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemIngredientDataAllergens Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataCertificates Interface

Members See Also

Certificates of item ingredient data object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemIngredientDataCertificates
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemIngredientDataCertificates)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemIngredientDataCertificates : IUDOChildBean,
   IEnumerable<IItemIngredientDataCertificates>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemIngredientDataCertificates : public IUDOChildBean^,
   public IEnumerable<IItemIngredientDataCertificates^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IID5
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataCertificates Members

IItemIngredientDataCertificates Interface Methods Properties See Also

Certificates of item ingredient data object

The following tables list the members exposed by the IItemIngredientDataCertificates type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Attachment |
Public property | U_BPCode |
Public property | U_CertDate |
Public property | U_CertNum |
Public property | U_ClassCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Remarks |
Public property | U_StatDate |
Public property | U_Status |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemIngredientDataCertificates Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataCertificates Properties

IItemIngredientDataCertificates Interface See Also

The following tables list the members exposed by the IItemIngredientDataCertificates type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Attachment |
Public property | U_BPCode |
Public property | U_CertDate |
Public property | U_CertNum |
Public property | U_ClassCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Remarks |
Public property | U_StatDate |
Public property | U_Status |
Top
See Also

Reference

IItemIngredientDataCertificates Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataCertificates.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataCertificates Interface
IItemIngredientDataCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataCertificates.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataCertificates Interface
IItemIngredientDataCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataCertificates.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataCertificates Interface
IItemIngredientDataCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataCertificates.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataCertificates Interface
IItemIngredientDataCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataCertificates.U_Attachment Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Attachment() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Attachment {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Attachment {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Attachment() : String;
function set U_Attachment(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataCertificates Interface
IItemIngredientDataCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataCertificates.U_BPCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_BPCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_BPCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_BPCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_BPCode() : String;

   AppEngineProperty(Required = true)
function set U_BPCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataCertificates Interface
IItemIngredientDataCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataCertificates.U_CertDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CertDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_CertDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_CertDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CertDate() : DateTime;
function set U_CertDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataCertificates Interface
IItemIngredientDataCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataCertificates.U_CertNum Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CertNum() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CertNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CertNum {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CertNum() : String;
function set U_CertNum(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataCertificates Interface
IItemIngredientDataCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataCertificates.U_ClassCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ClassCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ClassCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ClassCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ClassCode() : String;
function set U_ClassCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataCertificates Interface
IItemIngredientDataCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataCertificates.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataCertificates Interface
IItemIngredientDataCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataCertificates.U_StatDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StatDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StatDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StatDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StatDate() : DateTime;
function set U_StatDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataCertificates Interface
IItemIngredientDataCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataCertificates.U_Status Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Status() As IngredientClasificationStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IngredientClasificationStatus U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IngredientClasificationStatus U_Status {
 IngredientClasificationStatus get( );
 void set(
   IngredientClasificationStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Status() : IngredientClasificationStatus;
function set U_Status(value : IngredientClasificationStatus);
This language is not supported or no code example is available.

Property Value

Type: IngredientClasificationStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataCertificates Interface
IItemIngredientDataCertificates Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataCertificates Methods

IItemIngredientDataCertificates Interface See Also

The following tables list the members exposed by the IItemIngredientDataCertificates type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemIngredientDataCertificates Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataClassifications Interface

Members See Also

Classifications of item ingredient data object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemIngredientDataClassifications
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemIngredientDataClassifications)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemIngredientDataClassifications : IUDOChildBean,
   IEnumerable<IItemIngredientDataClassifications>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemIngredientDataClassifications : public IUDOChildBean^,
   public IEnumerable<IItemIngredientDataClassifications^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IID4
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataClassifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataClassifications Members

IItemIngredientDataClassifications Interface Methods Properties See Also

Classifications of item ingredient data object

The following tables list the members exposed by the IItemIngredientDataClassifications type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ClassCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemIngredientDataClassifications Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataClassifications Properties

IItemIngredientDataClassifications Interface See Also

The following tables list the members exposed by the IItemIngredientDataClassifications type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ClassCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
See Also

Reference

IItemIngredientDataClassifications Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataClassifications.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataClassifications Interface
IItemIngredientDataClassifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataClassifications.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataClassifications Interface
IItemIngredientDataClassifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataClassifications.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataClassifications Interface
IItemIngredientDataClassifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataClassifications.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataClassifications Interface
IItemIngredientDataClassifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataClassifications.U_ClassCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_ClassCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_ClassCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_ClassCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_ClassCode() : String;

   AppEngineProperty(Required = true)
function set U_ClassCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataClassifications Interface
IItemIngredientDataClassifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataClassifications Methods

IItemIngredientDataClassifications Interface See Also

The following tables list the members exposed by the IItemIngredientDataClassifications type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemIngredientDataClassifications Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataIngredients Interface

Members See Also

Ingredients of item ingredient data object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemIngredientDataIngredients
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemIngredientDataIngredients)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemIngredientDataIngredients : IUDOChildBean,
   IEnumerable<IItemIngredientDataIngredients>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemIngredientDataIngredients : public IUDOChildBean^,
   public IEnumerable<IItemIngredientDataIngredients^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IID1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataIngredients Members

IItemIngredientDataIngredients Interface Methods Properties See Also

Ingredients of item ingredient data object

The following tables list the members exposed by the IItemIngredientDataIngredients type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Condition |
Public property | U_IgdCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Value |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemIngredientDataIngredients Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataIngredients Properties

IItemIngredientDataIngredients Interface See Also

The following tables list the members exposed by the IItemIngredientDataIngredients type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Condition |
Public property | U_IgdCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Value |
Top
See Also

Reference

IItemIngredientDataIngredients Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataIngredients.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataIngredients Interface
IItemIngredientDataIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataIngredients.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataIngredients Interface
IItemIngredientDataIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataIngredients.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataIngredients Interface
IItemIngredientDataIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataIngredients.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataIngredients Interface
IItemIngredientDataIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataIngredients.U_Condition Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Condition() As IngredientCondition
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IngredientCondition U_Condition {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IngredientCondition U_Condition {
 IngredientCondition get( );
 void set(
   IngredientCondition value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Condition() : IngredientCondition;
function set U_Condition(value : IngredientCondition);
This language is not supported or no code example is available.

Property Value

Type: IngredientCondition
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataIngredients Interface
IItemIngredientDataIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataIngredients.U_IgdCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_IgdCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_IgdCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_IgdCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_IgdCode() : String;

   AppEngineProperty(Required = true)
function set U_IgdCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataIngredients Interface
IItemIngredientDataIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataIngredients.U_Value Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Value() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Value {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Value {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Value() : double;
function set U_Value(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataIngredients Interface
IItemIngredientDataIngredients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataIngredients Methods

IItemIngredientDataIngredients Interface See Also

The following tables list the members exposed by the IItemIngredientDataIngredients type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemIngredientDataIngredients Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataNutrients Interface

Members See Also

Nutrients of item ingredient data object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemIngredientDataNutrients
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemIngredientDataNutrients)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemIngredientDataNutrients : IUDOChildBean,
   IEnumerable<IItemIngredientDataNutrients>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemIngredientDataNutrients : public IUDOChildBean^,
   public IEnumerable<IItemIngredientDataNutrients^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IID2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataNutrients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataNutrients Members

IItemIngredientDataNutrients Interface Methods Properties See Also

Nutrients of item ingredient data object

The following tables list the members exposed by the IItemIngredientDataNutrients type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_NutCode |
Public property | U_Value |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemIngredientDataNutrients Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataNutrients Properties

IItemIngredientDataNutrients Interface See Also

The following tables list the members exposed by the IItemIngredientDataNutrients type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_NutCode |
Public property | U_Value |
Top
See Also

Reference

IItemIngredientDataNutrients Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataNutrients.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataNutrients Interface
IItemIngredientDataNutrients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataNutrients.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataNutrients Interface
IItemIngredientDataNutrients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataNutrients.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataNutrients Interface
IItemIngredientDataNutrients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataNutrients.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataNutrients Interface
IItemIngredientDataNutrients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataNutrients.U_NutCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_NutCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_NutCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_NutCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_NutCode() : String;

   AppEngineProperty(Required = true)
function set U_NutCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataNutrients Interface
IItemIngredientDataNutrients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataNutrients.U_Value Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Value() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Value {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Value {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Value() : double;
function set U_Value(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataNutrients Interface
IItemIngredientDataNutrients Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataNutrients Methods

IItemIngredientDataNutrients Interface See Also

The following tables list the members exposed by the IItemIngredientDataNutrients type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemIngredientDataNutrients Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataSpecifications Interface

Members See Also

Specifications of item ingredient data object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemIngredientDataSpecifications
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemIngredientDataSpecifications)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemIngredientDataSpecifications : IUDOChildBean,
   IEnumerable<IItemIngredientDataSpecifications>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemIngredientDataSpecifications : public IUDOChildBean^,
   public IEnumerable<IItemIngredientDataSpecifications^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IID6
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataSpecifications Members

IItemIngredientDataSpecifications Interface Methods Properties See Also

Specifications of item ingredient data object

The following tables list the members exposed by the IItemIngredientDataSpecifications type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Attachment |
Public property | U_BPCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Remarks |
Public property | U_SpecDate |
Public property | U_SpecNum |
Public property | U_StatDate |
Public property | U_Status |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemIngredientDataSpecifications Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataSpecifications Properties

IItemIngredientDataSpecifications Interface See Also

The following tables list the members exposed by the IItemIngredientDataSpecifications type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Attachment |
Public property | U_BPCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Remarks |
Public property | U_SpecDate |
Public property | U_SpecNum |
Public property | U_StatDate |
Public property | U_Status |
Top
See Also

Reference

IItemIngredientDataSpecifications Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataSpecifications.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataSpecifications Interface
IItemIngredientDataSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataSpecifications.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataSpecifications Interface
IItemIngredientDataSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataSpecifications.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataSpecifications Interface
IItemIngredientDataSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataSpecifications.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataSpecifications Interface
IItemIngredientDataSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataSpecifications.U_Attachment Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Attachment() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Attachment {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Attachment {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Attachment() : String;
function set U_Attachment(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataSpecifications Interface
IItemIngredientDataSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataSpecifications.U_BPCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_BPCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_BPCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_BPCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_BPCode() : String;

   AppEngineProperty(Required = true)
function set U_BPCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataSpecifications Interface
IItemIngredientDataSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataSpecifications.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataSpecifications Interface
IItemIngredientDataSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataSpecifications.U_SpecDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SpecDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_SpecDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_SpecDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SpecDate() : DateTime;
function set U_SpecDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataSpecifications Interface
IItemIngredientDataSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataSpecifications.U_SpecNum Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SpecNum() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SpecNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SpecNum {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SpecNum() : String;
function set U_SpecNum(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataSpecifications Interface
IItemIngredientDataSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataSpecifications.U_StatDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StatDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StatDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StatDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StatDate() : DateTime;
function set U_StatDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataSpecifications Interface
IItemIngredientDataSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataSpecifications.U_Status Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Status {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Status() : String;
function set U_Status(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemIngredientDataSpecifications Interface
IItemIngredientDataSpecifications Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IItemIngredientDataSpecifications Methods

IItemIngredientDataSpecifications Interface See Also

The following tables list the members exposed by the IItemIngredientDataSpecifications type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemIngredientDataSpecifications Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient Interface

Members See Also

Nutrient object

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "Nutrient", TableName = "@CT_PF_ONUT", UDOVersion = "UDO_10")> _
Public Interface INutrient
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Nutrient", TableName = "@CT_PF_ONUT", UDOVersion = "UDO_10")]
public interface INutrient : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Nutrient", TableName = "@CT_PF_ONUT", UDOVersion = "UDO_10")]
public interface class INutrient : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "Nutrient", TableName = "@CT_PF_ONUT", UDOVersion = "UDO_10")
interface INutrient
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ONUT
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient Members

INutrient Interface Methods Properties See Also

Nutrient object

The following tables list the members exposed by the INutrient type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_AltCode |
Public property | U_CatCode |
Public property | U_Code |
Public property | U_Desc |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | U_UoM |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByCode |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

INutrient Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient Properties

INutrient Interface See Also

The following tables list the members exposed by the INutrient type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_AltCode |
Public property | U_CatCode |
Public property | U_Code |
Public property | U_Desc |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | U_UoM |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

INutrient Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.U_AltCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AltCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AltCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AltCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AltCode() : String;
function set U_AltCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.U_CatCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CatCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CatCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CatCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CatCode() : String;
function set U_CatCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.U_Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_Code() : String;

   AppEngineProperty(Required = true)
function set U_Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.U_Desc Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Desc() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Desc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Desc {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Desc() : String;
function set U_Desc(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.U_UoM Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UoM() : String;
function set U_UoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient Methods

INutrient Interface See Also

The following tables list the members exposed by the INutrient type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByCode |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

INutrient Interface
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


INutrient.GetByCode Method

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByCode( _
   ByVal code As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByCode(
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByCode(
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByCode(
    code : String
) : int;
This language is not supported or no code example is available.

Parameters

code

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INutrient Interface
INutrient Members
CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IngredientClasificationStatus Enumeration

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
NotApproved |
Pending |
Approved |
See Also

Reference

CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IngredientCondition Enumeration

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Equal |
LessThan |
GreaterThan |
See Also

Reference

CompuTec.ProcessForce.API.Documents.Ingredients Namespace


IngredientSpecificationStatus Enumeration

Namespace: CompuTec.ProcessForce.API.Documents.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
NotApproved |
Pending |
Approved |
See Also

Reference

CompuTec.ProcessForce.API.Documents.Ingredients Namespace


CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IInputOutputCheckList | Input Output checklist object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IInputOutputCheckList Interface

Members See Also

Input Output checklist object

Namespace: CompuTec.ProcessForce.API.Documents.InputOutputCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "InputOutputCheckList", TableName = "@CT_PF_OIOCH")> _
Public Interface IInputOutputCheckList
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "InputOutputCheckList", TableName = "@CT_PF_OIOCH")]
public interface IInputOutputCheckList : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "InputOutputCheckList", TableName = "@CT_PF_OIOCH")]
public interface class IInputOutputCheckList : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "InputOutputCheckList", TableName = "@CT_PF_OIOCH")
interface IInputOutputCheckList
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OIOCH
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputOutputCheckList Members
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList Members

IInputOutputCheckList Interface Methods Properties See Also

Input Output checklist object

The following tables list the members exposed by the IInputOutputCheckList type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Name |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Checked |
Public property | U_CurrentRemarks |
Public property | U_CurrentWordCode |
Public property | U_Direction |
Public property | U_EmplID |
Public property | U_ItemCode |
Public property | U_MorEntry |
Public property | U_OprCode |
Public property | U_PrpCode |
Public property | U_Remarks |
Public property | U_RscCode |
Public property | U_RtgCode |
Public property | U_RtgOprCode |
Public property | U_RtopRscCode |
Public property | U_Value |
Public property | U_WordCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IInputOutputCheckList Interface
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList Properties

IInputOutputCheckList Interface See Also

The following tables list the members exposed by the IInputOutputCheckList type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Name |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Checked |
Public property | U_CurrentRemarks |
Public property | U_CurrentWordCode |
Public property | U_Direction |
Public property | U_EmplID |
Public property | U_ItemCode |
Public property | U_MorEntry |
Public property | U_OprCode |
Public property | U_PrpCode |
Public property | U_Remarks |
Public property | U_RscCode |
Public property | U_RtgCode |
Public property | U_RtgOprCode |
Public property | U_RtopRscCode |
Public property | U_Value |
Public property | U_WordCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
See Also

Reference

IInputOutputCheckList Interface
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.InputOutputCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputOutputCheckList Interface
IInputOutputCheckList Members
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.InputOutputCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
function set Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputOutputCheckList Interface
IInputOutputCheckList Members
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList.U_Checked Property

Namespace: CompuTec.ProcessForce.API.Documents.InputOutputCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Checked() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Checked {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Checked {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Checked() : YesNoType;
function set U_Checked(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputOutputCheckList Interface
IInputOutputCheckList Members
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList.U_CurrentRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.InputOutputCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CurrentRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CurrentRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CurrentRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CurrentRemarks() : String;
function set U_CurrentRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputOutputCheckList Interface
IInputOutputCheckList Members
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList.U_CurrentWordCode Property

Namespace: CompuTec.ProcessForce.API.Documents.InputOutputCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CurrentWordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CurrentWordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CurrentWordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CurrentWordCode() : String;
function set U_CurrentWordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputOutputCheckList Interface
IInputOutputCheckList Members
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList.U_Direction Property

Namespace: CompuTec.ProcessForce.API.Documents.InputOutputCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Direction() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Direction {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Direction {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Direction() : String;
function set U_Direction(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputOutputCheckList Interface
IInputOutputCheckList Members
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList.U_EmplID Property

Namespace: CompuTec.ProcessForce.API.Documents.InputOutputCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EmplID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_EmplID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_EmplID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EmplID() : int;
function set U_EmplID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputOutputCheckList Interface
IInputOutputCheckList Members
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.InputOutputCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputOutputCheckList Interface
IInputOutputCheckList Members
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList.U_MorEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.InputOutputCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MorEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_MorEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_MorEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MorEntry() : int;
function set U_MorEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputOutputCheckList Interface
IInputOutputCheckList Members
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList.U_OprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.InputOutputCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprCode() : String;
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputOutputCheckList Interface
IInputOutputCheckList Members
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList.U_PrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.InputOutputCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpCode() : String;
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputOutputCheckList Interface
IInputOutputCheckList Members
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.InputOutputCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputOutputCheckList Interface
IInputOutputCheckList Members
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList.U_RscCode Property

Namespace: CompuTec.ProcessForce.API.Documents.InputOutputCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCode() : String;
function set U_RscCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputOutputCheckList Interface
IInputOutputCheckList Members
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList.U_RtgCode Property

Namespace: CompuTec.ProcessForce.API.Documents.InputOutputCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RtgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RtgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgCode() : String;
function set U_RtgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputOutputCheckList Interface
IInputOutputCheckList Members
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList.U_RtgOprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.InputOutputCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RtgOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RtgOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgOprCode() : int;
function set U_RtgOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputOutputCheckList Interface
IInputOutputCheckList Members
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList.U_RtopRscCode Property

Namespace: CompuTec.ProcessForce.API.Documents.InputOutputCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtopRscCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RtopRscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RtopRscCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtopRscCode() : int;
function set U_RtopRscCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputOutputCheckList Interface
IInputOutputCheckList Members
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList.U_Value Property

Namespace: CompuTec.ProcessForce.API.Documents.InputOutputCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Value() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Value {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Value {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Value() : double;
function set U_Value(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputOutputCheckList Interface
IInputOutputCheckList Members
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList.U_WordCode Property

Namespace: CompuTec.ProcessForce.API.Documents.InputOutputCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputOutputCheckList Interface
IInputOutputCheckList Members
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


IInputOutputCheckList Methods

IInputOutputCheckList Interface See Also

The following tables list the members exposed by the IInputOutputCheckList type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IInputOutputCheckList Interface
CompuTec.ProcessForce.API.Documents.InputOutputCheckList Namespace


CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | InventoryRegistryConsts |
Top
Interfaces
 | Name | Description
Public interface | IInventoryRegister | Inventory register document
Public interface | IInventoryRegisterLines | Lines for inventory register document
Top
Enumerations
 | Name | Description
Public enumeration | InventoryRegisterStatus |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


InventoryRegistryConsts Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class InventoryRegistryConsts
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class InventoryRegistryConsts
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class InventoryRegistryConsts
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class InventoryRegistryConsts
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.InventoryRegister.InventoryRegistryConsts
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InventoryRegistryConsts Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


InventoryRegistryConsts Members

InventoryRegistryConsts Class Methods Fields See Also

The following tables list the members exposed by the InventoryRegistryConsts type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | Lines |
Top
See Also

Reference

InventoryRegistryConsts Class
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


InventoryRegistryConsts Methods

InventoryRegistryConsts Class See Also

The following tables list the members exposed by the InventoryRegistryConsts type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

InventoryRegistryConsts Class
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


InventoryRegistryConsts Fields

InventoryRegistryConsts Class See Also

The following tables list the members exposed by the InventoryRegistryConsts type.

Fields
 | Name | Description
Public field | Lines |
Top
See Also

Reference

InventoryRegistryConsts Class
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


Lines Field

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Lines As String = "Lines"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Lines = @"Lines"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Lines = "Lines";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Lines : String = "Lines"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InventoryRegistryConsts Class
InventoryRegistryConsts Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister Interface

Members See Also

Inventory register document

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "InventoryRegistry", TableName = "@CT_PF_OIRG", UDOVersion = "UDO_10")> _
Public Interface IInventoryRegister
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "InventoryRegistry", TableName = "@CT_PF_OIRG", UDOVersion = "UDO_10")]
public interface IInventoryRegister : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "InventoryRegistry", TableName = "@CT_PF_OIRG", UDOVersion = "UDO_10")]
public interface class IInventoryRegister : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "InventoryRegistry", TableName = "@CT_PF_OIRG", UDOVersion = "UDO_10")
interface IInventoryRegister
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OIRG
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister Members

IInventoryRegister Interface Methods Properties See Also

Inventory register document

The following tables list the members exposed by the IInventoryRegister type.

Properties
 | Name | Description
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | Lines |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_DocDate |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Status |
Public property | U_TrgDocEnt |
Public property | U_TrgDocTpe |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IInventoryRegister Interface
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister Properties

IInventoryRegister Interface See Also

The following tables list the members exposed by the IInventoryRegister type.

Properties
 | Name | Description
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | Lines |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_DocDate |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Status |
Public property | U_TrgDocEnt |
Public property | U_TrgDocTpe |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IInventoryRegister Interface
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.DocNum Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.Handwrtten Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Handwrtten() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Handwrtten {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Handwrtten {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Handwrtten() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.Instance Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Instance() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Instance {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Instance {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Instance() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.Lines Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Lines() As IInventoryRegisterLines
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IInventoryRegisterLines Lines {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IInventoryRegisterLines^ Lines {
 IInventoryRegisterLines^ get( );
 void set(
   IInventoryRegisterLines^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Lines() : IInventoryRegisterLines;
function set Lines(value : IInventoryRegisterLines);
This language is not supported or no code example is available.

Property Value

Type: IInventoryRegisterLines
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.Period Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Period() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Period {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Period {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Period() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.Series Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Series() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Series {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Series {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Series() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.Status Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Status {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Status {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Status() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.U_DocDate Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DocDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_DocDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_DocDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DocDate() : DateTime;
function set U_DocDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.U_Status Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Status() As InventoryRegisterStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
InventoryRegisterStatus U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property InventoryRegisterStatus U_Status {
 InventoryRegisterStatus get( );
 void set(
   InventoryRegisterStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Status() : InventoryRegisterStatus;
function set U_Status(value : InventoryRegisterStatus);
This language is not supported or no code example is available.

Property Value

Type: InventoryRegisterStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.U_TrgDocEnt Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TrgDocEnt() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_TrgDocEnt {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_TrgDocEnt {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TrgDocEnt() : int;
function set U_TrgDocEnt(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.U_TrgDocTpe Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TrgDocTpe() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_TrgDocTpe {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_TrgDocTpe {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TrgDocTpe() : int;
function set U_TrgDocTpe(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegister Interface
IInventoryRegister Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegister Methods

IInventoryRegister Interface See Also

The following tables list the members exposed by the IInventoryRegister type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IInventoryRegister Interface
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegisterLines Interface

Members See Also

Lines for inventory register document

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IInventoryRegisterLines
    Inherits IUDOChildBean, _
             IEnumerable(Of IInventoryRegisterLines)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IInventoryRegisterLines : IUDOChildBean,
   IEnumerable<IInventoryRegisterLines>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IInventoryRegisterLines : public IUDOChildBean^,
   public IEnumerable<IInventoryRegisterLines^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IRG1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegisterLines Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegisterLines Members

IInventoryRegisterLines Interface Methods Properties See Also

Lines for inventory register document

The following tables list the members exposed by the IInventoryRegisterLines type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Batch |
Public property | U_ItemCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_LplCode |
Public property | U_Quantity |
Public property | U_WhsCode |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IInventoryRegisterLines Interface
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegisterLines Properties

IInventoryRegisterLines Interface See Also

The following tables list the members exposed by the IInventoryRegisterLines type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Batch |
Public property | U_ItemCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_LplCode |
Public property | U_Quantity |
Public property | U_WhsCode |
Public property | VisOrder |
Top
See Also

Reference

IInventoryRegisterLines Interface
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegisterLines.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegisterLines Interface
IInventoryRegisterLines Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegisterLines.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegisterLines Interface
IInventoryRegisterLines Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegisterLines.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegisterLines Interface
IInventoryRegisterLines Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegisterLines.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegisterLines Interface
IInventoryRegisterLines Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegisterLines.U_Batch Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Batch() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Batch {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Batch {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Batch() : String;
function set U_Batch(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegisterLines Interface
IInventoryRegisterLines Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegisterLines.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_ItemCode() : String;

   AppEngineProperty(Required = true)
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegisterLines Interface
IInventoryRegisterLines Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegisterLines.U_LplCode Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LplCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LplCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LplCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LplCode() : String;
function set U_LplCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegisterLines Interface
IInventoryRegisterLines Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegisterLines.U_Quantity Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegisterLines Interface
IInventoryRegisterLines Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegisterLines.U_WhsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegisterLines Interface
IInventoryRegisterLines Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegisterLines.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInventoryRegisterLines Interface
IInventoryRegisterLines Members
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


IInventoryRegisterLines Methods

IInventoryRegisterLines Interface See Also

The following tables list the members exposed by the IInventoryRegisterLines type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IInventoryRegisterLines Interface
CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


InventoryRegisterStatus Enumeration

Namespace: CompuTec.ProcessForce.API.Documents.InventoryRegister
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Open |
Close |
ManualClose |
See Also

Reference

CompuTec.ProcessForce.API.Documents.InventoryRegister Namespace


CompuTec.ProcessForce.API.Documents.ItemClassification Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IItemClassification | Item classification object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IItemClassification Interface

Members See Also

Item classification object

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ItemClassification", TableName = "@CT_PF_OICL", UDOVersion = "UDO_10")> _
Public Interface IItemClassification
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemClassification", TableName = "@CT_PF_OICL", UDOVersion = "UDO_10")]
public interface IItemClassification : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemClassification", TableName = "@CT_PF_OICL", UDOVersion = "UDO_10")]
public interface class IItemClassification : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ItemClassification", TableName = "@CT_PF_OICL", UDOVersion = "UDO_10")
interface IItemClassification
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OICL
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification Members

IItemClassification Interface Methods Properties See Also

Item classification object

The following tables list the members exposed by the IItemClassification type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | GroupName |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ClsCode | Classification Code - Mandatory
Public property | U_ClsName | Classification Name
Public property | U_GrpCode | Classification Group Cde
Public property | U_MSDS |
Public property | U_Other |
Public property | U_PickLists |
Public property | U_ProdOrders |
Public property | U_PurOrders |
Public property | U_Remarks | Remarks
Public property | U_Returns |
Public property | U_ShipDoc |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByClsCode |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemClassification Interface
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification Properties

IItemClassification Interface See Also

The following tables list the members exposed by the IItemClassification type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | GroupName |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ClsCode | Classification Code - Mandatory
Public property | U_ClsName | Classification Name
Public property | U_GrpCode | Classification Group Cde
Public property | U_MSDS |
Public property | U_Other |
Public property | U_PickLists |
Public property | U_ProdOrders |
Public property | U_PurOrders |
Public property | U_Remarks | Remarks
Public property | U_Returns |
Public property | U_ShipDoc |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IItemClassification Interface
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.GroupName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property GroupName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string GroupName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ GroupName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get GroupName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.U_ClsCode Property

Classification Code - Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_ClsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_ClsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_ClsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_ClsCode() : String;

   AppEngineProperty(Required = true)
function set U_ClsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.U_ClsName Property

Classification Name

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ClsName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ClsName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ClsName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ClsName() : String;
function set U_ClsName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.U_GrpCode Property

Classification Group Cde

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpCode() : String;
function set U_GrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.U_MSDS Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MSDS() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_MSDS {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_MSDS {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MSDS() : YesNoType;
function set U_MSDS(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.U_Other Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Other() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Other {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Other {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Other() : YesNoType;
function set U_Other(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.U_PickLists Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PickLists() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_PickLists {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_PickLists {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PickLists() : YesNoType;
function set U_PickLists(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.U_ProdOrders Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ProdOrders() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_ProdOrders {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_ProdOrders {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ProdOrders() : YesNoType;
function set U_ProdOrders(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.U_PurOrders Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PurOrders() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_PurOrders {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_PurOrders {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PurOrders() : YesNoType;
function set U_PurOrders(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.U_Remarks Property

Remarks

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.U_Returns Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Returns() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Returns {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Returns {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Returns() : YesNoType;
function set U_Returns(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.U_ShipDoc Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ShipDoc() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_ShipDoc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_ShipDoc {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ShipDoc() : YesNoType;
function set U_ShipDoc(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification Methods

IItemClassification Interface See Also

The following tables list the members exposed by the IItemClassification type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByClsCode |
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemClassification Interface
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


IItemClassification.GetByClsCode Method

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassification
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByClsCode( _
   ByVal ClsCode As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByClsCode(
   string ClsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByClsCode(
   String^ ClsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByClsCode(
    ClsCode : String
) : int;
This language is not supported or no code example is available.

Parameters

ClsCode

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassification Interface
IItemClassification Members
CompuTec.ProcessForce.API.Documents.ItemClassification Namespace


CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IItemClassificationGroup | Item Classification Group Object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IItemClassificationGroup Interface

Members See Also

Item Classification Group Object

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassificationGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ItemClassificationGroup", TableName = "@CT_PF_OICG", UDOVersion = "UDO_10")> _
Public Interface IItemClassificationGroup
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemClassificationGroup", TableName = "@CT_PF_OICG", UDOVersion = "UDO_10")]
public interface IItemClassificationGroup : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemClassificationGroup", TableName = "@CT_PF_OICG", UDOVersion = "UDO_10")]
public interface class IItemClassificationGroup : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ItemClassificationGroup", TableName = "@CT_PF_OICG", UDOVersion = "UDO_10")
interface IItemClassificationGroup
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OICG
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassificationGroup Members
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


IItemClassificationGroup Members

IItemClassificationGroup Interface Methods Properties See Also

Item Classification Group Object

The following tables list the members exposed by the IItemClassificationGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode | Item Classification Group Code - Mandatory
Public property | U_GrpDescription | Classification Group Description
Public property | U_GrpName | Classification Group Name
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemClassificationGroup Interface
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


IItemClassificationGroup Properties

IItemClassificationGroup Interface See Also

The following tables list the members exposed by the IItemClassificationGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode | Item Classification Group Code - Mandatory
Public property | U_GrpDescription | Classification Group Description
Public property | U_GrpName | Classification Group Name
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IItemClassificationGroup Interface
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


IItemClassificationGroup.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassificationGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassificationGroup Interface
IItemClassificationGroup Members
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


IItemClassificationGroup.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassificationGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassificationGroup Interface
IItemClassificationGroup Members
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


IItemClassificationGroup.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassificationGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassificationGroup Interface
IItemClassificationGroup Members
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


IItemClassificationGroup.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassificationGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassificationGroup Interface
IItemClassificationGroup Members
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


IItemClassificationGroup.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassificationGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassificationGroup Interface
IItemClassificationGroup Members
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


IItemClassificationGroup.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassificationGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassificationGroup Interface
IItemClassificationGroup Members
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


IItemClassificationGroup.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassificationGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassificationGroup Interface
IItemClassificationGroup Members
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


IItemClassificationGroup.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassificationGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassificationGroup Interface
IItemClassificationGroup Members
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


IItemClassificationGroup.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassificationGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassificationGroup Interface
IItemClassificationGroup Members
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


IItemClassificationGroup.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassificationGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassificationGroup Interface
IItemClassificationGroup Members
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


IItemClassificationGroup.U_GrpCode Property

Item Classification Group Code - Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassificationGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_GrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_GrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_GrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_GrpCode() : String;

   AppEngineProperty(Required = true)
function set U_GrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassificationGroup Interface
IItemClassificationGroup Members
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


IItemClassificationGroup.U_GrpDescription Property

Classification Group Description

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassificationGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpDescription() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpDescription {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpDescription {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpDescription() : String;
function set U_GrpDescription(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassificationGroup Interface
IItemClassificationGroup Members
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


IItemClassificationGroup.U_GrpName Property

Classification Group Name

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassificationGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpName() : String;
function set U_GrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassificationGroup Interface
IItemClassificationGroup Members
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


IItemClassificationGroup.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassificationGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassificationGroup Interface
IItemClassificationGroup Members
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


IItemClassificationGroup.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassificationGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassificationGroup Interface
IItemClassificationGroup Members
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


IItemClassificationGroup.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemClassificationGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemClassificationGroup Interface
IItemClassificationGroup Members
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


IItemClassificationGroup Methods

IItemClassificationGroup Interface See Also

The following tables list the members exposed by the IItemClassificationGroup type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemClassificationGroup Interface
CompuTec.ProcessForce.API.Documents.ItemClassificationGroup Namespace


CompuTec.ProcessForce.API.Documents.ItemDetails Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | BatchOrSerialTemplateMissingException |
Public class | ItemDetailsMustHaveOneDefaultRevisionException |
Public class | ItemDetailsMustHaveOneDefaultRevisionForMrpException |
Public class | ItemDetailsUsedInBOMAsParentException |
Public class | ShelfTimeFormatException |
Public class | WarningDatesMismatchException |
Top
Interfaces
 | Name | Description
Public interface | IItemDetails | Object For Describing Item Details Informations This Object Is Creating Automaticly When Item Master Data is Added to SAP DataBase
Public interface | IItemDetailsAttachments | Attachments of item details object
Public interface | IItemDetailsClassifications | Classification of item details object
Public interface | IItemDetailsGroups | Groups of item details object
Public interface | IItemDetailsInventoryLines | Revision of item details object
Public interface | IItemDetailsOrigins | Origins of item details object
Public interface | IItemDetailsPhrases | Phrases of item details object
Public interface | IItemDetailsProperties | Properties of item details object
Public interface | IItemDetailsRevisions | Revision of item details object
Public interface | IItemDetailsTexts | Text of item details object
Top
Enumerations
 | Name | Description
Public enumeration | RevisionStatus | Revision Status Used in ItemDetails- Revisons
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


BatchOrSerialTemplateMissingException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class BatchOrSerialTemplateMissingException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class BatchOrSerialTemplateMissingException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class BatchOrSerialTemplateMissingException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class BatchOrSerialTemplateMissingException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.ItemDetails.BatchOrSerialTemplateMissingException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchOrSerialTemplateMissingException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


BatchOrSerialTemplateMissingException Members

BatchOrSerialTemplateMissingException Class Constructors Methods Properties See Also

The following tables list the members exposed by the BatchOrSerialTemplateMissingException type.

Constructors
 | Name | Description
Public constructor | BatchOrSerialTemplateMissingException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BatchOrSerialTemplateMissingException Class
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


BatchOrSerialTemplateMissingException Constructor

BatchOrSerialTemplateMissingException Class See Also

Overload List
Name | Description
BatchOrSerialTemplateMissingException() |
BatchOrSerialTemplateMissingException(string) |
BatchOrSerialTemplateMissingException(string, Exception) |
See Also

Reference

BatchOrSerialTemplateMissingException Class
BatchOrSerialTemplateMissingException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


BatchOrSerialTemplateMissingException Properties

BatchOrSerialTemplateMissingException Class See Also

The following tables list the members exposed by the BatchOrSerialTemplateMissingException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

BatchOrSerialTemplateMissingException Class
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


BatchOrSerialTemplateMissingException Methods

BatchOrSerialTemplateMissingException Class See Also

The following tables list the members exposed by the BatchOrSerialTemplateMissingException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BatchOrSerialTemplateMissingException Class
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsMustHaveOneDefaultRevisionException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class ItemDetailsMustHaveOneDefaultRevisionException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class ItemDetailsMustHaveOneDefaultRevisionException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class ItemDetailsMustHaveOneDefaultRevisionException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class ItemDetailsMustHaveOneDefaultRevisionException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.ItemDetails.ItemDetailsMustHaveOneDefaultRevisionException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsMustHaveOneDefaultRevisionException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsMustHaveOneDefaultRevisionException Members

ItemDetailsMustHaveOneDefaultRevisionException Class Constructors Methods Properties See Also

The following tables list the members exposed by the ItemDetailsMustHaveOneDefaultRevisionException type.

Constructors
 | Name | Description
Public constructor | ItemDetailsMustHaveOneDefaultRevisionException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ItemDetailsMustHaveOneDefaultRevisionException Class
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsMustHaveOneDefaultRevisionException Constructor

ItemDetailsMustHaveOneDefaultRevisionException Class See Also

Overload List
Name | Description
ItemDetailsMustHaveOneDefaultRevisionException() |
ItemDetailsMustHaveOneDefaultRevisionException(string) |
ItemDetailsMustHaveOneDefaultRevisionException(string, Exception) |
See Also

Reference

ItemDetailsMustHaveOneDefaultRevisionException Class
ItemDetailsMustHaveOneDefaultRevisionException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsMustHaveOneDefaultRevisionException Properties

ItemDetailsMustHaveOneDefaultRevisionException Class See Also

The following tables list the members exposed by the ItemDetailsMustHaveOneDefaultRevisionException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

ItemDetailsMustHaveOneDefaultRevisionException Class
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsMustHaveOneDefaultRevisionException Methods

ItemDetailsMustHaveOneDefaultRevisionException Class See Also

The following tables list the members exposed by the ItemDetailsMustHaveOneDefaultRevisionException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ItemDetailsMustHaveOneDefaultRevisionException Class
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsMustHaveOneDefaultRevisionForMrpException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class ItemDetailsMustHaveOneDefaultRevisionForMrpException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class ItemDetailsMustHaveOneDefaultRevisionForMrpException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class ItemDetailsMustHaveOneDefaultRevisionForMrpException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class ItemDetailsMustHaveOneDefaultRevisionForMrpException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.ItemDetails.ItemDetailsMustHaveOneDefaultRevisionForMrpException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsMustHaveOneDefaultRevisionForMrpException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsMustHaveOneDefaultRevisionForMrpException Members

ItemDetailsMustHaveOneDefaultRevisionForMrpException Class Constructors Methods Properties See Also

The following tables list the members exposed by the ItemDetailsMustHaveOneDefaultRevisionForMrpException type.

Constructors
 | Name | Description
Public constructor | ItemDetailsMustHaveOneDefaultRevisionForMrpException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ItemDetailsMustHaveOneDefaultRevisionForMrpException Class
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsMustHaveOneDefaultRevisionForMrpException Constructor

ItemDetailsMustHaveOneDefaultRevisionForMrpException Class See Also

Overload List
Name | Description
ItemDetailsMustHaveOneDefaultRevisionForMrpException() |
ItemDetailsMustHaveOneDefaultRevisionForMrpException(string) |
ItemDetailsMustHaveOneDefaultRevisionForMrpException(string, Exception) |
See Also

Reference

ItemDetailsMustHaveOneDefaultRevisionForMrpException Class
ItemDetailsMustHaveOneDefaultRevisionForMrpException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsMustHaveOneDefaultRevisionForMrpException Properties

ItemDetailsMustHaveOneDefaultRevisionForMrpException Class See Also

The following tables list the members exposed by the ItemDetailsMustHaveOneDefaultRevisionForMrpException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

ItemDetailsMustHaveOneDefaultRevisionForMrpException Class
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsMustHaveOneDefaultRevisionForMrpException Methods

ItemDetailsMustHaveOneDefaultRevisionForMrpException Class See Also

The following tables list the members exposed by the ItemDetailsMustHaveOneDefaultRevisionForMrpException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ItemDetailsMustHaveOneDefaultRevisionForMrpException Class
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsUsedInBOMAsParentException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class ItemDetailsUsedInBOMAsParentException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class ItemDetailsUsedInBOMAsParentException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class ItemDetailsUsedInBOMAsParentException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class ItemDetailsUsedInBOMAsParentException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.ItemDetails.ItemDetailsUsedInBOMAsParentException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsUsedInBOMAsParentException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsUsedInBOMAsParentException Members

ItemDetailsUsedInBOMAsParentException Class Constructors Methods Properties See Also

The following tables list the members exposed by the ItemDetailsUsedInBOMAsParentException type.

Constructors
 | Name | Description
Public constructor | ItemDetailsUsedInBOMAsParentException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ItemDetailsUsedInBOMAsParentException Class
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsUsedInBOMAsParentException Constructor

ItemDetailsUsedInBOMAsParentException Class See Also

Overload List
Name | Description
ItemDetailsUsedInBOMAsParentException() |
ItemDetailsUsedInBOMAsParentException(string) |
ItemDetailsUsedInBOMAsParentException(string, Exception) |
See Also

Reference

ItemDetailsUsedInBOMAsParentException Class
ItemDetailsUsedInBOMAsParentException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsUsedInBOMAsParentException Properties

ItemDetailsUsedInBOMAsParentException Class See Also

The following tables list the members exposed by the ItemDetailsUsedInBOMAsParentException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

ItemDetailsUsedInBOMAsParentException Class
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsUsedInBOMAsParentException Methods

ItemDetailsUsedInBOMAsParentException Class See Also

The following tables list the members exposed by the ItemDetailsUsedInBOMAsParentException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ItemDetailsUsedInBOMAsParentException Class
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ShelfTimeFormatException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class ShelfTimeFormatException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class ShelfTimeFormatException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class ShelfTimeFormatException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class ShelfTimeFormatException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.ItemDetails.ShelfTimeFormatException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ShelfTimeFormatException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ShelfTimeFormatException Members

ShelfTimeFormatException Class Constructors Methods Properties See Also

The following tables list the members exposed by the ShelfTimeFormatException type.

Constructors
 | Name | Description
Public constructor | ShelfTimeFormatException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ShelfTimeFormatException Class
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ShelfTimeFormatException Constructor

ShelfTimeFormatException Class See Also

Overload List
Name | Description
ShelfTimeFormatException() |
ShelfTimeFormatException(string) |
ShelfTimeFormatException(string, Exception) |
See Also

Reference

ShelfTimeFormatException Class
ShelfTimeFormatException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ShelfTimeFormatException Properties

ShelfTimeFormatException Class See Also

The following tables list the members exposed by the ShelfTimeFormatException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

ShelfTimeFormatException Class
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ShelfTimeFormatException Methods

ShelfTimeFormatException Class See Also

The following tables list the members exposed by the ShelfTimeFormatException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ShelfTimeFormatException Class
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


WarningDatesMismatchException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class WarningDatesMismatchException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class WarningDatesMismatchException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class WarningDatesMismatchException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class WarningDatesMismatchException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.ItemDetails.WarningDatesMismatchException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WarningDatesMismatchException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


WarningDatesMismatchException Members

WarningDatesMismatchException Class Constructors Methods Properties See Also

The following tables list the members exposed by the WarningDatesMismatchException type.

Constructors
 | Name | Description
Public constructor | WarningDatesMismatchException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

WarningDatesMismatchException Class
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


WarningDatesMismatchException Constructor

WarningDatesMismatchException Class See Also

Overload List
Name | Description
WarningDatesMismatchException() |
WarningDatesMismatchException(string) |
WarningDatesMismatchException(string, Exception) |
See Also

Reference

WarningDatesMismatchException Class
WarningDatesMismatchException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


WarningDatesMismatchException Properties

WarningDatesMismatchException Class See Also

The following tables list the members exposed by the WarningDatesMismatchException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

WarningDatesMismatchException Class
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


WarningDatesMismatchException Methods

WarningDatesMismatchException Class See Also

The following tables list the members exposed by the WarningDatesMismatchException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

WarningDatesMismatchException Class
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails Interface

Members See Also

Object For Describing Item Details Informations This Object Is Creating Automaticly When Item Master Data is Added to SAP DataBase

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ItemDetails", TableName = "@CT_PF_OIDT", ExludedHttpMethods = "POST")> _
Public Interface IItemDetails
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemDetails", TableName = "@CT_PF_OIDT", ExludedHttpMethods = "POST")]
public interface IItemDetails : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemDetails", TableName = "@CT_PF_OIDT", ExludedHttpMethods = "POST")]
public interface class IItemDetails : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ItemDetails", TableName = "@CT_PF_OIDT", ExludedHttpMethods = "POST")
interface IItemDetails
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OIDT
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails Members

IItemDetails Interface Methods Properties See Also

Object For Describing Item Details Informations This Object Is Creating Automaticly When Item Master Data is Added to SAP DataBase

The following tables list the members exposed by the IItemDetails type.

Properties
 | Name | Description
Public property | Attachments | Item Details Attachments Lines
Public property | BusinessPartnerRelations |
Public property | CFG_RestoreItemCosting | Determines whether the item costing data must be resynchronized while the item details data is added or updated.
Public property | Canceled |
Public property | Classifications | Item Details Classifications Lines
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_ItemName | Gets the name of an item master data.
Public property | DS_UnitOfMeasure | Gets the unit of measure of an item master data.
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Groups | Item Details Groups Lines
Public property | InventoryLines |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Origins |
Public property | Phrases | Item Details Phrases Lines
Public property | Properties | Item Detals Properies Lines
Public property | Revisions | Item Details Revions Lines
Public property | Texts | Item Details Texts Lines
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_AcptLowerQty | if the quantity of items in the warehouse is lower than the quantity you want to issue then issue only the quantity that is available in the warehouse
Public property | U_BatchQueue | Batch Queue Type Form Backflush Item on Receipt From Production
Public property | U_BatchSize | Gets or sets the batch size.
Public property | U_BtchTmpl | Item Detail Batch Template Specific Batch Template Can be set on this level
Public property | U_ConsWarn | Warning Prior Consume days
Public property | U_Consume | Consume by Date
Public property | U_DftOrigin |
Public property | U_ExpTmpl |
Public property | U_ExpTyp |
Public property | U_ExpWarn | Warning Prior Expiry Days
Public property | U_Expiry | Expiry Date
Public property | U_IgnoreYield |
Public property | U_Inherit | Inheit BatchDetails From Item Group
Public property | U_InheritBatch | Inherit batch Teplate from Item Group
Public property | U_InheritQueue |
Public property | U_InheritSerial | Inherit Serial Teplate from Item Group
Public property | U_InheritStatus |
Public property | U_InspDays | Days between Inspection
Public property | U_ItemCode | item Code of Correspondent Item Master Data
Public property | U_PFDfBS |
Public property | U_PFDfQCS |
Public property | U_Remarks | Item Details Remarks
Public property | U_SapDfBS |
Public property | U_SapDfQCS |
Public property | U_ShelfTime |
Public property | U_SrlTmpl | ItemDetails Serial Template
Public property | U_Yield |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByItemCode | Gets the item details data by item code value.
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemDetails Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails Properties

IItemDetails Interface See Also

The following tables list the members exposed by the IItemDetails type.

Properties
 | Name | Description
Public property | Attachments | Item Details Attachments Lines
Public property | BusinessPartnerRelations |
Public property | CFG_RestoreItemCosting | Determines whether the item costing data must be resynchronized while the item details data is added or updated.
Public property | Canceled |
Public property | Classifications | Item Details Classifications Lines
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_ItemName | Gets the name of an item master data.
Public property | DS_UnitOfMeasure | Gets the unit of measure of an item master data.
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Groups | Item Details Groups Lines
Public property | InventoryLines |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Origins |
Public property | Phrases | Item Details Phrases Lines
Public property | Properties | Item Detals Properies Lines
Public property | Revisions | Item Details Revions Lines
Public property | Texts | Item Details Texts Lines
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_AcptLowerQty | if the quantity of items in the warehouse is lower than the quantity you want to issue then issue only the quantity that is available in the warehouse
Public property | U_BatchQueue | Batch Queue Type Form Backflush Item on Receipt From Production
Public property | U_BatchSize | Gets or sets the batch size.
Public property | U_BtchTmpl | Item Detail Batch Template Specific Batch Template Can be set on this level
Public property | U_ConsWarn | Warning Prior Consume days
Public property | U_Consume | Consume by Date
Public property | U_DftOrigin |
Public property | U_ExpTmpl |
Public property | U_ExpTyp |
Public property | U_ExpWarn | Warning Prior Expiry Days
Public property | U_Expiry | Expiry Date
Public property | U_IgnoreYield |
Public property | U_Inherit | Inheit BatchDetails From Item Group
Public property | U_InheritBatch | Inherit batch Teplate from Item Group
Public property | U_InheritQueue |
Public property | U_InheritSerial | Inherit Serial Teplate from Item Group
Public property | U_InheritStatus |
Public property | U_InspDays | Days between Inspection
Public property | U_ItemCode | item Code of Correspondent Item Master Data
Public property | U_PFDfBS |
Public property | U_PFDfQCS |
Public property | U_Remarks | Item Details Remarks
Public property | U_SapDfBS |
Public property | U_SapDfQCS |
Public property | U_ShelfTime |
Public property | U_SrlTmpl | ItemDetails Serial Template
Public property | U_Yield |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IItemDetails Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.Attachments Property

Item Details Attachments Lines

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Attachments() As IItemDetailsAttachments
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemDetailsAttachments Attachments {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemDetailsAttachments^ Attachments {
 IItemDetailsAttachments^ get( );
 void set(
   IItemDetailsAttachments^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Attachments() : IItemDetailsAttachments;
function set Attachments(value : IItemDetailsAttachments);
This language is not supported or no code example is available.

Property Value

Type: IItemDetailsAttachments
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.BusinessPartnerRelations Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BusinessPartnerRelations() As IBusinessPartnerRelationsThridLevel
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBusinessPartnerRelationsThridLevel BusinessPartnerRelations {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBusinessPartnerRelationsThridLevel^ BusinessPartnerRelations {
 IBusinessPartnerRelationsThridLevel^ get( );
 void set(
   IBusinessPartnerRelationsThridLevel^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BusinessPartnerRelations() : IBusinessPartnerRelationsThridLevel;
function set BusinessPartnerRelations(value : IBusinessPartnerRelationsThridLevel);
This language is not supported or no code example is available.

Property Value

Type: IBusinessPartnerRelationsThridLevel
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.CFG_RestoreItemCosting Property

Determines whether the item costing data must be resynchronized while the item details data is added or updated.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property CFG_RestoreItemCosting() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string CFG_RestoreItemCosting {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ CFG_RestoreItemCosting {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CFG_RestoreItemCosting() : String;

   AppEnginePropertyIgnore()
function set CFG_RestoreItemCosting(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.Classifications Property

Item Details Classifications Lines

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Classifications() As IItemDetailsClassifications
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemDetailsClassifications Classifications {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemDetailsClassifications^ Classifications {
 IItemDetailsClassifications^ get( );
 void set(
   IItemDetailsClassifications^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Classifications() : IItemDetailsClassifications;
function set Classifications(value : IItemDetailsClassifications);
This language is not supported or no code example is available.

Property Value

Type: IItemDetailsClassifications
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.DS_ItemName Property

Gets the name of an item master data.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.DS_UnitOfMeasure Property

Gets the unit of measure of an item master data.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_UnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_UnitOfMeasure {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_UnitOfMeasure {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_UnitOfMeasure() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.Groups Property

Item Details Groups Lines

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Groups() As IItemDetailsGroups
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemDetailsGroups Groups {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemDetailsGroups^ Groups {
 IItemDetailsGroups^ get( );
 void set(
   IItemDetailsGroups^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Groups() : IItemDetailsGroups;
function set Groups(value : IItemDetailsGroups);
This language is not supported or no code example is available.

Property Value

Type: IItemDetailsGroups
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.InventoryLines Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property InventoryLines() As IItemDetailsInventoryLines
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemDetailsInventoryLines InventoryLines {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemDetailsInventoryLines^ InventoryLines {
 IItemDetailsInventoryLines^ get( );
 void set(
   IItemDetailsInventoryLines^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get InventoryLines() : IItemDetailsInventoryLines;
function set InventoryLines(value : IItemDetailsInventoryLines);
This language is not supported or no code example is available.

Property Value

Type: IItemDetailsInventoryLines
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.Origins Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Origins() As IItemDetailsOrigins
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemDetailsOrigins Origins {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemDetailsOrigins^ Origins {
 IItemDetailsOrigins^ get( );
 void set(
   IItemDetailsOrigins^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Origins() : IItemDetailsOrigins;
function set Origins(value : IItemDetailsOrigins);
This language is not supported or no code example is available.

Property Value

Type: IItemDetailsOrigins
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.Phrases Property

Item Details Phrases Lines

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Phrases() As IItemDetailsPhrases
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemDetailsPhrases Phrases {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemDetailsPhrases^ Phrases {
 IItemDetailsPhrases^ get( );
 void set(
   IItemDetailsPhrases^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Phrases() : IItemDetailsPhrases;
function set Phrases(value : IItemDetailsPhrases);
This language is not supported or no code example is available.

Property Value

Type: IItemDetailsPhrases
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.Properties Property

Item Detals Properies Lines

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Properties() As IItemDetailsProperties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemDetailsProperties Properties {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemDetailsProperties^ Properties {
 IItemDetailsProperties^ get( );
 void set(
   IItemDetailsProperties^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Properties() : IItemDetailsProperties;
function set Properties(value : IItemDetailsProperties);
This language is not supported or no code example is available.

Property Value

Type: IItemDetailsProperties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.Revisions Property

Item Details Revions Lines

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Revisions() As IItemDetailsRevisions
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemDetailsRevisions Revisions {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemDetailsRevisions^ Revisions {
 IItemDetailsRevisions^ get( );
 void set(
   IItemDetailsRevisions^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Revisions() : IItemDetailsRevisions;
function set Revisions(value : IItemDetailsRevisions);
This language is not supported or no code example is available.

Property Value

Type: IItemDetailsRevisions
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.Texts Property

Item Details Texts Lines

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Texts() As IItemDetailsTexts
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemDetailsTexts Texts {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemDetailsTexts^ Texts {
 IItemDetailsTexts^ get( );
 void set(
   IItemDetailsTexts^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Texts() : IItemDetailsTexts;
function set Texts(value : IItemDetailsTexts);
This language is not supported or no code example is available.

Property Value

Type: IItemDetailsTexts
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_AcptLowerQty Property

if the quantity of items in the warehouse is lower than the quantity you want to issue then issue only the quantity that is available in the warehouse

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AcptLowerQty() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_AcptLowerQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_AcptLowerQty {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AcptLowerQty() : YesNoType;
function set U_AcptLowerQty(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_BatchQueue Property

Batch Queue Type Form Backflush Item on Receipt From Production

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BatchQueue() As BatchQueueType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
BatchQueueType U_BatchQueue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property BatchQueueType U_BatchQueue {
 BatchQueueType get( );
 void set(
   BatchQueueType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchQueue() : BatchQueueType;
function set U_BatchQueue(value : BatchQueueType);
This language is not supported or no code example is available.

Property Value

Type: BatchQueueType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_BatchSize Property

Gets or sets the batch size.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BatchSize() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_BatchSize {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_BatchSize {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchSize() : double;
function set U_BatchSize(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_BtchTmpl Property

Item Detail Batch Template Specific Batch Template Can be set on this level

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BtchTmpl() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BtchTmpl {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BtchTmpl {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BtchTmpl() : String;
function set U_BtchTmpl(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_ConsWarn Property

Warning Prior Consume days

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ConsWarn() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ConsWarn {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ConsWarn {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ConsWarn() : int;
function set U_ConsWarn(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_Consume Property

Consume by Date

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Consume() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Consume {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Consume {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Consume() : YesNoType;
function set U_Consume(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_DftOrigin Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DftOrigin() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DftOrigin {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DftOrigin {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DftOrigin() : String;
function set U_DftOrigin(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_ExpTmpl Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ExpTmpl() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ExpTmpl {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ExpTmpl {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ExpTmpl() : String;
function set U_ExpTmpl(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_ExpTyp Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ExpTyp() As ExpiryDateEvaluation
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ExpiryDateEvaluation U_ExpTyp {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ExpiryDateEvaluation U_ExpTyp {
 ExpiryDateEvaluation get( );
 void set(
   ExpiryDateEvaluation value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ExpTyp() : ExpiryDateEvaluation;
function set U_ExpTyp(value : ExpiryDateEvaluation);
This language is not supported or no code example is available.

Property Value

Type: ExpiryDateEvaluation
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_ExpWarn Property

Warning Prior Expiry Days

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ExpWarn() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ExpWarn {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ExpWarn {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ExpWarn() : int;
function set U_ExpWarn(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_Expiry Property

Expiry Date

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Expiry() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Expiry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Expiry {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Expiry() : YesNoType;
function set U_Expiry(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_IgnoreYield Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IgnoreYield() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_IgnoreYield {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_IgnoreYield {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IgnoreYield() : YesNoType;
function set U_IgnoreYield(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_Inherit Property

Inheit BatchDetails From Item Group

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Inherit() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Inherit {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Inherit {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Inherit() : YesNoType;
function set U_Inherit(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_InheritBatch Property

Inherit batch Teplate from Item Group

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InheritBatch() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_InheritBatch {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_InheritBatch {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InheritBatch() : YesNoType;
function set U_InheritBatch(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_InheritQueue Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InheritQueue() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_InheritQueue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_InheritQueue {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InheritQueue() : YesNoType;
function set U_InheritQueue(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_InheritSerial Property

Inherit Serial Teplate from Item Group

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InheritSerial() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_InheritSerial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_InheritSerial {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InheritSerial() : YesNoType;
function set U_InheritSerial(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_InheritStatus Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InheritStatus() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_InheritStatus {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_InheritStatus {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InheritStatus() : YesNoType;
function set U_InheritStatus(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_InspDays Property

Days between Inspection

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InspDays() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_InspDays {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_InspDays {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InspDays() : int;
function set U_InspDays(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_ItemCode Property

item Code of Correspondent Item Master Data

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2, Required = true)> _
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, Required = true)]
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, Required = true)]

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2, Required = true)
function get U_ItemCode() : String;

   AppEngineProperty(Priority = 2, Required = true)
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_PFDfBS Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDfBS() As BatchStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
BatchStatus U_PFDfBS {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property BatchStatus U_PFDfBS {
 BatchStatus get( );
 void set(
   BatchStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDfBS() : BatchStatus;
function set U_PFDfBS(value : BatchStatus);
This language is not supported or no code example is available.

Property Value

Type: BatchStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_PFDfQCS Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDfQCS() As QCStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
QCStatus U_PFDfQCS {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property QCStatus U_PFDfQCS {
 QCStatus get( );
 void set(
   QCStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDfQCS() : QCStatus;
function set U_PFDfQCS(value : QCStatus);
This language is not supported or no code example is available.

Property Value

Type: QCStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_Remarks Property

Item Details Remarks

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_SapDfBS Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SapDfBS() As BatchStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
BatchStatus U_SapDfBS {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property BatchStatus U_SapDfBS {
 BatchStatus get( );
 void set(
   BatchStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SapDfBS() : BatchStatus;
function set U_SapDfBS(value : BatchStatus);
This language is not supported or no code example is available.

Property Value

Type: BatchStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_SapDfQCS Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SapDfQCS() As QCStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
QCStatus U_SapDfQCS {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property QCStatus U_SapDfQCS {
 QCStatus get( );
 void set(
   QCStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SapDfQCS() : QCStatus;
function set U_SapDfQCS(value : QCStatus);
This language is not supported or no code example is available.

Property Value

Type: QCStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_ShelfTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ShelfTime() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ShelfTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ShelfTime {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ShelfTime() : String;
function set U_ShelfTime(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_SrlTmpl Property

ItemDetails Serial Template

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SrlTmpl() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SrlTmpl {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SrlTmpl {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SrlTmpl() : String;
function set U_SrlTmpl(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.U_Yield Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Yield() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Yield {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Yield {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Yield() : double;
function set U_Yield(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails Methods

IItemDetails Interface See Also

The following tables list the members exposed by the IItemDetails type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByItemCode | Gets the item details data by item code value.
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemDetails Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetails.GetByItemCode Method

Gets the item details data by item code value.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByItemCode( _
   ByVal itemCode As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool GetByItemCode(
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool GetByItemCode(
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByItemCode(
    itemCode : String
) : boolean;
This language is not supported or no code example is available.

Parameters

itemCode

Type: string

The code value of an item master data.

Return Value

Type: bool

true if data was loaded successfully; otherwise, false.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetails Interface
IItemDetails Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsAttachments Interface

Members See Also

Attachments of item details object

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IItemDetailsAttachments
    Inherits IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IItemDetailsAttachments : IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IItemDetailsAttachments : public IUDOChildBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IItemDetailsAttachments
   implements IUDOChildBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_IDT2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsAttachments Members

IItemDetailsAttachments Interface Methods Properties See Also

Attachments of item details object

The following tables list the members exposed by the IItemDetailsAttachments type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AttDate |
Public property | U_AttFileName |
Public property | U_AttPath |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

IItemDetailsAttachments Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsAttachments Properties

IItemDetailsAttachments Interface See Also

The following tables list the members exposed by the IItemDetailsAttachments type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AttDate |
Public property | U_AttFileName |
Public property | U_AttPath |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
See Also

Reference

IItemDetailsAttachments Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsAttachments.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsAttachments Interface
IItemDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsAttachments.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsAttachments Interface
IItemDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsAttachments.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsAttachments Interface
IItemDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsAttachments.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsAttachments Interface
IItemDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsAttachments.U_AttDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_AttDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_AttDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttDate() : DateTime;
function set U_AttDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsAttachments Interface
IItemDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsAttachments.U_AttFileName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttFileName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AttFileName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AttFileName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttFileName() : String;
function set U_AttFileName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsAttachments Interface
IItemDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsAttachments.U_AttPath Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttPath() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AttPath {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AttPath {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttPath() : String;
function set U_AttPath(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsAttachments Interface
IItemDetailsAttachments Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsAttachments Methods

IItemDetailsAttachments Interface See Also

The following tables list the members exposed by the IItemDetailsAttachments type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

IItemDetailsAttachments Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications Interface

Members See Also

Classification of item details object

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemDetailsClassifications
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemDetailsClassifications)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemDetailsClassifications : IUDOChildBean,
   IEnumerable<IItemDetailsClassifications>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemDetailsClassifications : public IUDOChildBean^,
   public IEnumerable<IItemDetailsClassifications^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IDT3
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsClassifications Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications Members

IItemDetailsClassifications Interface Methods Properties See Also

Classification of item details object

The following tables list the members exposed by the IItemDetailsClassifications type.

Properties
 | Name | Description
Public property | ClassificationName |
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AddDate |
Public property | U_ClsCode |
Public property | U_FromDate |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MSDS |
Public property | U_Other |
Public property | U_PickLists |
Public property | U_ProdOrders |
Public property | U_PurOrders |
Public property | U_Returns |
Public property | U_ShipDoc |
Public property | U_ToDate |
Public property | U_UpdateDate |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemDetailsClassifications Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications Properties

IItemDetailsClassifications Interface See Also

The following tables list the members exposed by the IItemDetailsClassifications type.

Properties
 | Name | Description
Public property | ClassificationName |
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AddDate |
Public property | U_ClsCode |
Public property | U_FromDate |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MSDS |
Public property | U_Other |
Public property | U_PickLists |
Public property | U_ProdOrders |
Public property | U_PurOrders |
Public property | U_Returns |
Public property | U_ShipDoc |
Public property | U_ToDate |
Public property | U_UpdateDate |
Top
See Also

Reference

IItemDetailsClassifications Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications.ClassificationName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ClassificationName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string ClassificationName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ ClassificationName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ClassificationName() : String;
function set ClassificationName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsClassifications Interface
IItemDetailsClassifications Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsClassifications Interface
IItemDetailsClassifications Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsClassifications Interface
IItemDetailsClassifications Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsClassifications Interface
IItemDetailsClassifications Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsClassifications Interface
IItemDetailsClassifications Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications.U_AddDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AddDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_AddDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_AddDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AddDate() : DateTime;
function set U_AddDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsClassifications Interface
IItemDetailsClassifications Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications.U_ClsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2)> _
Property U_ClsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]
string U_ClsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]

property String^ U_ClsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2)
function get U_ClsCode() : String;

   AppEngineProperty(Priority = 2)
function set U_ClsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsClassifications Interface
IItemDetailsClassifications Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications.U_FromDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FromDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_FromDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_FromDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FromDate() : DateTime;
function set U_FromDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsClassifications Interface
IItemDetailsClassifications Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications.U_MSDS Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MSDS() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_MSDS {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_MSDS {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MSDS() : YesNoType;
function set U_MSDS(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsClassifications Interface
IItemDetailsClassifications Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications.U_Other Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Other() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Other {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Other {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Other() : YesNoType;
function set U_Other(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsClassifications Interface
IItemDetailsClassifications Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications.U_PickLists Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PickLists() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_PickLists {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_PickLists {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PickLists() : YesNoType;
function set U_PickLists(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsClassifications Interface
IItemDetailsClassifications Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications.U_ProdOrders Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ProdOrders() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_ProdOrders {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_ProdOrders {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ProdOrders() : YesNoType;
function set U_ProdOrders(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsClassifications Interface
IItemDetailsClassifications Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications.U_PurOrders Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PurOrders() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_PurOrders {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_PurOrders {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PurOrders() : YesNoType;
function set U_PurOrders(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsClassifications Interface
IItemDetailsClassifications Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications.U_Returns Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Returns() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Returns {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Returns {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Returns() : YesNoType;
function set U_Returns(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsClassifications Interface
IItemDetailsClassifications Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications.U_ShipDoc Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ShipDoc() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_ShipDoc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_ShipDoc {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ShipDoc() : YesNoType;
function set U_ShipDoc(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsClassifications Interface
IItemDetailsClassifications Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications.U_ToDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ToDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ToDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ToDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ToDate() : DateTime;
function set U_ToDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsClassifications Interface
IItemDetailsClassifications Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications.U_UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_UpdateDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_UpdateDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UpdateDate() : DateTime;
function set U_UpdateDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsClassifications Interface
IItemDetailsClassifications Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsClassifications Methods

IItemDetailsClassifications Interface See Also

The following tables list the members exposed by the IItemDetailsClassifications type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemDetailsClassifications Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups Interface

Members See Also

Groups of item details object

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemDetailsGroups
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemDetailsGroups)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemDetailsGroups : IUDOChildBean,
   IEnumerable<IItemDetailsGroups>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemDetailsGroups : public IUDOChildBean^,
   public IEnumerable<IItemDetailsGroups^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IDT5
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsGroups Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups Members

IItemDetailsGroups Interface Methods Properties See Also

Groups of item details object

The following tables list the members exposed by the IItemDetailsGroups type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | GroupName |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AddDate |
Public property | U_FromDate |
Public property | U_GrpCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MSDS |
Public property | U_Other |
Public property | U_PickLists |
Public property | U_ProdOrders |
Public property | U_PurOrders |
Public property | U_Returns |
Public property | U_ShipDoc |
Public property | U_ToDate |
Public property | U_UpdateDate |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemDetailsGroups Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups Properties

IItemDetailsGroups Interface See Also

The following tables list the members exposed by the IItemDetailsGroups type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | GroupName |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AddDate |
Public property | U_FromDate |
Public property | U_GrpCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MSDS |
Public property | U_Other |
Public property | U_PickLists |
Public property | U_ProdOrders |
Public property | U_PurOrders |
Public property | U_Returns |
Public property | U_ShipDoc |
Public property | U_ToDate |
Public property | U_UpdateDate |
Top
See Also

Reference

IItemDetailsGroups Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsGroups Interface
IItemDetailsGroups Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups.GroupName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property GroupName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string GroupName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ GroupName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get GroupName() : String;
function set GroupName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsGroups Interface
IItemDetailsGroups Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsGroups Interface
IItemDetailsGroups Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsGroups Interface
IItemDetailsGroups Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsGroups Interface
IItemDetailsGroups Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups.U_AddDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AddDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_AddDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_AddDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AddDate() : DateTime;
function set U_AddDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsGroups Interface
IItemDetailsGroups Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups.U_FromDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FromDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_FromDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_FromDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FromDate() : DateTime;
function set U_FromDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsGroups Interface
IItemDetailsGroups Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups.U_GrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2)> _
Property U_GrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]
string U_GrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]

property String^ U_GrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2)
function get U_GrpCode() : String;

   AppEngineProperty(Priority = 2)
function set U_GrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsGroups Interface
IItemDetailsGroups Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups.U_MSDS Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MSDS() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MSDS {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MSDS {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MSDS() : String;
function set U_MSDS(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsGroups Interface
IItemDetailsGroups Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups.U_Other Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Other() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Other {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Other {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Other() : String;
function set U_Other(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsGroups Interface
IItemDetailsGroups Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups.U_PickLists Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PickLists() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PickLists {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PickLists {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PickLists() : String;
function set U_PickLists(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsGroups Interface
IItemDetailsGroups Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups.U_ProdOrders Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ProdOrders() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ProdOrders {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ProdOrders {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ProdOrders() : String;
function set U_ProdOrders(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsGroups Interface
IItemDetailsGroups Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups.U_PurOrders Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PurOrders() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PurOrders {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PurOrders {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PurOrders() : String;
function set U_PurOrders(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsGroups Interface
IItemDetailsGroups Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups.U_Returns Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Returns() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Returns {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Returns {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Returns() : String;
function set U_Returns(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsGroups Interface
IItemDetailsGroups Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups.U_ShipDoc Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ShipDoc() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ShipDoc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ShipDoc {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ShipDoc() : String;
function set U_ShipDoc(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsGroups Interface
IItemDetailsGroups Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups.U_ToDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ToDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ToDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ToDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ToDate() : DateTime;
function set U_ToDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsGroups Interface
IItemDetailsGroups Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups.U_UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_UpdateDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_UpdateDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UpdateDate() : DateTime;
function set U_UpdateDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsGroups Interface
IItemDetailsGroups Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsGroups Methods

IItemDetailsGroups Interface See Also

The following tables list the members exposed by the IItemDetailsGroups type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemDetailsGroups Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsInventoryLines Interface

Members See Also

Revision of item details object

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemDetailsInventoryLines
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemDetailsInventoryLines)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemDetailsInventoryLines : IUDOChildBean,
   IEnumerable<IItemDetailsInventoryLines>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemDetailsInventoryLines : public IUDOChildBean^,
   public IEnumerable<IItemDetailsInventoryLines^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IDT13
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsInventoryLines Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsInventoryLines Members

IItemDetailsInventoryLines Interface Methods Properties See Also

Revision of item details object

The following tables list the members exposed by the IItemDetailsInventoryLines type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_WhsName |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MaxStock |
Public property | U_MinStock |
Public property | U_ParentItemCode |
Public property | U_ReqStock |
Public property | U_RevisionCode |
Public property | U_WhsCode |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemDetailsInventoryLines Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsInventoryLines Properties

IItemDetailsInventoryLines Interface See Also

The following tables list the members exposed by the IItemDetailsInventoryLines type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_WhsName |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MaxStock |
Public property | U_MinStock |
Public property | U_ParentItemCode |
Public property | U_ReqStock |
Public property | U_RevisionCode |
Public property | U_WhsCode |
Top
See Also

Reference

IItemDetailsInventoryLines Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsInventoryLines.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsInventoryLines Interface
IItemDetailsInventoryLines Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsInventoryLines.DS_WhsName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_WhsName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_WhsName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_WhsName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_WhsName() : String;

   AppEnginePropertyIgnore()
function set DS_WhsName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsInventoryLines Interface
IItemDetailsInventoryLines Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsInventoryLines.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsInventoryLines Interface
IItemDetailsInventoryLines Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsInventoryLines.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsInventoryLines Interface
IItemDetailsInventoryLines Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsInventoryLines.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsInventoryLines Interface
IItemDetailsInventoryLines Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsInventoryLines.U_MaxStock Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MaxStock() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_MaxStock {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_MaxStock {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MaxStock() : double;
function set U_MaxStock(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsInventoryLines Interface
IItemDetailsInventoryLines Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsInventoryLines.U_MinStock Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MinStock() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_MinStock {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_MinStock {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MinStock() : double;
function set U_MinStock(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsInventoryLines Interface
IItemDetailsInventoryLines Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsInventoryLines.U_ParentItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ParentItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ParentItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ParentItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ParentItemCode() : String;
function set U_ParentItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsInventoryLines Interface
IItemDetailsInventoryLines Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsInventoryLines.U_ReqStock Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReqStock() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ReqStock {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ReqStock {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReqStock() : double;
function set U_ReqStock(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsInventoryLines Interface
IItemDetailsInventoryLines Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsInventoryLines.U_RevisionCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RevisionCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevisionCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevisionCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevisionCode() : String;
function set U_RevisionCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsInventoryLines Interface
IItemDetailsInventoryLines Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsInventoryLines.U_WhsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsInventoryLines Interface
IItemDetailsInventoryLines Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsInventoryLines Methods

IItemDetailsInventoryLines Interface See Also

The following tables list the members exposed by the IItemDetailsInventoryLines type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemDetailsInventoryLines Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsOrigins Interface

Members See Also

Origins of item details object

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemDetailsOrigins
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemDetailsOrigins)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemDetailsOrigins : IUDOChildBean,
   IEnumerable<IItemDetailsOrigins>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemDetailsOrigins : public IUDOChildBean^,
   public IEnumerable<IItemDetailsOrigins^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IDT12
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsOrigins Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsOrigins Members

IItemDetailsOrigins Interface Methods Properties See Also

Origins of item details object

The following tables list the members exposed by the IItemDetailsOrigins type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_CountryCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemDetailsOrigins Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsOrigins Properties

IItemDetailsOrigins Interface See Also

The following tables list the members exposed by the IItemDetailsOrigins type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_CountryCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
See Also

Reference

IItemDetailsOrigins Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsOrigins.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsOrigins Interface
IItemDetailsOrigins Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsOrigins.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsOrigins Interface
IItemDetailsOrigins Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsOrigins.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsOrigins Interface
IItemDetailsOrigins Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsOrigins.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsOrigins Interface
IItemDetailsOrigins Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsOrigins.U_CountryCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CountryCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CountryCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CountryCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CountryCode() : String;
function set U_CountryCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsOrigins Interface
IItemDetailsOrigins Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsOrigins Methods

IItemDetailsOrigins Interface See Also

The following tables list the members exposed by the IItemDetailsOrigins type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemDetailsOrigins Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases Interface

Members See Also

Phrases of item details object

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemDetailsPhrases
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemDetailsPhrases)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemDetailsPhrases : IUDOChildBean,
   IEnumerable<IItemDetailsPhrases>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemDetailsPhrases : public IUDOChildBean^,
   public IEnumerable<IItemDetailsPhrases^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IDT6
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsPhrases Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases Members

IItemDetailsPhrases Interface Methods Properties See Also

Phrases of item details object

The following tables list the members exposed by the IItemDetailsPhrases type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | PhraseName |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AddDate |
Public property | U_FromDate |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MSDS |
Public property | U_Other |
Public property | U_PhCode |
Public property | U_PickLists |
Public property | U_ProdOrders |
Public property | U_PurOrders |
Public property | U_Returns |
Public property | U_ShipDoc |
Public property | U_ToDate |
Public property | U_UpdateDate |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemDetailsPhrases Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases Properties

IItemDetailsPhrases Interface See Also

The following tables list the members exposed by the IItemDetailsPhrases type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | PhraseName |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AddDate |
Public property | U_FromDate |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MSDS |
Public property | U_Other |
Public property | U_PhCode |
Public property | U_PickLists |
Public property | U_ProdOrders |
Public property | U_PurOrders |
Public property | U_Returns |
Public property | U_ShipDoc |
Public property | U_ToDate |
Public property | U_UpdateDate |
Top
See Also

Reference

IItemDetailsPhrases Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsPhrases Interface
IItemDetailsPhrases Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsPhrases Interface
IItemDetailsPhrases Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsPhrases Interface
IItemDetailsPhrases Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsPhrases Interface
IItemDetailsPhrases Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases.PhraseName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property PhraseName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string PhraseName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ PhraseName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get PhraseName() : String;
function set PhraseName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsPhrases Interface
IItemDetailsPhrases Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases.U_AddDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AddDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_AddDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_AddDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AddDate() : DateTime;
function set U_AddDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsPhrases Interface
IItemDetailsPhrases Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases.U_FromDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FromDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_FromDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_FromDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FromDate() : DateTime;
function set U_FromDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsPhrases Interface
IItemDetailsPhrases Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases.U_MSDS Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MSDS() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MSDS {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MSDS {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MSDS() : String;
function set U_MSDS(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsPhrases Interface
IItemDetailsPhrases Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases.U_Other Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Other() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Other {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Other {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Other() : String;
function set U_Other(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsPhrases Interface
IItemDetailsPhrases Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases.U_PhCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2)> _
Property U_PhCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]
string U_PhCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]

property String^ U_PhCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2)
function get U_PhCode() : String;

   AppEngineProperty(Priority = 2)
function set U_PhCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsPhrases Interface
IItemDetailsPhrases Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases.U_PickLists Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PickLists() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PickLists {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PickLists {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PickLists() : String;
function set U_PickLists(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsPhrases Interface
IItemDetailsPhrases Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases.U_ProdOrders Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ProdOrders() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ProdOrders {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ProdOrders {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ProdOrders() : String;
function set U_ProdOrders(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsPhrases Interface
IItemDetailsPhrases Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases.U_PurOrders Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PurOrders() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PurOrders {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PurOrders {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PurOrders() : String;
function set U_PurOrders(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsPhrases Interface
IItemDetailsPhrases Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases.U_Returns Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Returns() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Returns {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Returns {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Returns() : String;
function set U_Returns(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsPhrases Interface
IItemDetailsPhrases Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases.U_ShipDoc Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ShipDoc() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ShipDoc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ShipDoc {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ShipDoc() : String;
function set U_ShipDoc(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsPhrases Interface
IItemDetailsPhrases Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases.U_ToDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ToDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ToDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ToDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ToDate() : DateTime;
function set U_ToDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsPhrases Interface
IItemDetailsPhrases Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases.U_UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_UpdateDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_UpdateDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UpdateDate() : DateTime;
function set U_UpdateDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsPhrases Interface
IItemDetailsPhrases Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsPhrases Methods

IItemDetailsPhrases Interface See Also

The following tables list the members exposed by the IItemDetailsPhrases type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemDetailsPhrases Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsProperties Interface

Members See Also

Properties of item details object

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemDetailsProperties
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemDetailsProperties)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemDetailsProperties : IUDOChildBean,
   IEnumerable<IItemDetailsProperties>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemDetailsProperties : public IUDOChildBean^,
   public IEnumerable<IItemDetailsProperties^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IDT4
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsProperties Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsProperties Members

IItemDetailsProperties Interface Methods Properties See Also

Properties of item details object

The following tables list the members exposed by the IItemDetailsProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_PrpAddDate |
Public property | DS_PrpName |
Public property | DS_PrpUoM |
Public property | DS_PrpUpdateDate |
Public property | DS_WordName |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Expression |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PrpCode |
Public property | U_RangeValueFrom |
Public property | U_RangeValueTo |
Public property | U_Remarks |
Public property | U_WordCode |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemDetailsProperties Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsProperties Properties

IItemDetailsProperties Interface See Also

The following tables list the members exposed by the IItemDetailsProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_PrpAddDate |
Public property | DS_PrpName |
Public property | DS_PrpUoM |
Public property | DS_PrpUpdateDate |
Public property | DS_WordName |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Expression |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PrpCode |
Public property | U_RangeValueFrom |
Public property | U_RangeValueTo |
Public property | U_Remarks |
Public property | U_WordCode |
Top
See Also

Reference

IItemDetailsProperties Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsProperties.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsProperties Interface
IItemDetailsProperties Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsProperties.DS_PrpAddDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_PrpAddDate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_PrpAddDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_PrpAddDate {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_PrpAddDate() : String;

   AppEnginePropertyIgnore()
function set DS_PrpAddDate(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsProperties Interface
IItemDetailsProperties Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsProperties.DS_PrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_PrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_PrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_PrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_PrpName() : String;

   AppEnginePropertyIgnore()
function set DS_PrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsProperties Interface
IItemDetailsProperties Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsProperties.DS_PrpUoM Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_PrpUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_PrpUoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_PrpUoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_PrpUoM() : String;

   AppEnginePropertyIgnore()
function set DS_PrpUoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsProperties Interface
IItemDetailsProperties Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsProperties.DS_PrpUpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_PrpUpdateDate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_PrpUpdateDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_PrpUpdateDate {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_PrpUpdateDate() : String;

   AppEnginePropertyIgnore()
function set DS_PrpUpdateDate(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsProperties Interface
IItemDetailsProperties Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsProperties.DS_WordName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_WordName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_WordName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_WordName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_WordName() : String;

   AppEnginePropertyIgnore()
function set DS_WordName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsProperties Interface
IItemDetailsProperties Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsProperties.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsProperties Interface
IItemDetailsProperties Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsProperties.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsProperties Interface
IItemDetailsProperties Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsProperties.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsProperties Interface
IItemDetailsProperties Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsProperties.U_Expression Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Expression() As ConditionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ConditionType U_Expression {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ConditionType U_Expression {
 ConditionType get( );
 void set(
   ConditionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Expression() : ConditionType;
function set U_Expression(value : ConditionType);
This language is not supported or no code example is available.

Property Value

Type: ConditionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsProperties Interface
IItemDetailsProperties Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsProperties.U_PrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2)> _
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2)
function get U_PrpCode() : String;

   AppEngineProperty(Priority = 2)
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsProperties Interface
IItemDetailsProperties Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsProperties.U_RangeValueFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RangeValueFrom() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RangeValueFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RangeValueFrom {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RangeValueFrom() : double;
function set U_RangeValueFrom(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsProperties Interface
IItemDetailsProperties Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsProperties.U_RangeValueTo Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RangeValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RangeValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RangeValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RangeValueTo() : double;
function set U_RangeValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsProperties Interface
IItemDetailsProperties Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsProperties.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsProperties Interface
IItemDetailsProperties Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsProperties.U_WordCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsProperties Interface
IItemDetailsProperties Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsProperties Methods

IItemDetailsProperties Interface See Also

The following tables list the members exposed by the IItemDetailsProperties type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemDetailsProperties Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions Interface

Members See Also

Revision of item details object

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemDetailsRevisions
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemDetailsRevisions)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemDetailsRevisions : IUDOChildBean,
   IEnumerable<IItemDetailsRevisions>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemDetailsRevisions : public IUDOChildBean^,
   public IEnumerable<IItemDetailsRevisions^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IDT1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions Members

IItemDetailsRevisions Interface Methods Properties See Also

Revision of item details object

The following tables list the members exposed by the IItemDetailsRevisions type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Code | revision Code Mandatory
Public property | U_Default |
Public property | U_Description | Revision Description
Public property | U_ForcePrimaryDemand |
Public property | U_ILeadTime | Internal lead time, one of the place for this value to be set (as hierarchy on Connect shows). Format is days:hours:minutes.
Public property | U_InternalLeadTimeTransfer |
Public property | U_IsCostingDefault | Determines whether revision is a default revision that is considered during the roll-over process for a default cost category.
Public property | U_IsMrpDefault | Indicates if the Bill of Materials document created for a combination of an Item Master Data and Revision Code is set as a default for the MRP process or not.
Public property | U_LeadTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ManagInvByWhs |
Public property | U_MatPhantom | Determines wheather material item is treated like a phantom ( explodes) on Manufacturing Order
Public property | U_MaxOrderQty |
Public property | U_MaxStock |
Public property | U_MinOrderQty |
Public property | U_MinStock |
Public property | U_OrderInterval |
Public property | U_OrderMultiple |
Public property | U_ParentItemCode |
Public property | U_PlanerI |
Public property | U_PlanerII |
Public property | U_PlanningMethod |
Public property | U_ProcurementMethod |
Public property | U_Remarks | Remarks
Public property | U_ReqStock |
Public property | U_Status | Revision status mandatory
Public property | U_ToleranceDays |
Public property | U_UseItmPerPurchUnit |
Public property | U_ValidFrom | Dalid From Date madatory
Public property | U_ValidTo | Valid To Date mandatory
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemDetailsRevisions Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions Properties

IItemDetailsRevisions Interface See Also

The following tables list the members exposed by the IItemDetailsRevisions type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Code | revision Code Mandatory
Public property | U_Default |
Public property | U_Description | Revision Description
Public property | U_ForcePrimaryDemand |
Public property | U_ILeadTime | Internal lead time, one of the place for this value to be set (as hierarchy on Connect shows). Format is days:hours:minutes.
Public property | U_InternalLeadTimeTransfer |
Public property | U_IsCostingDefault | Determines whether revision is a default revision that is considered during the roll-over process for a default cost category.
Public property | U_IsMrpDefault | Indicates if the Bill of Materials document created for a combination of an Item Master Data and Revision Code is set as a default for the MRP process or not.
Public property | U_LeadTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ManagInvByWhs |
Public property | U_MatPhantom | Determines wheather material item is treated like a phantom ( explodes) on Manufacturing Order
Public property | U_MaxOrderQty |
Public property | U_MaxStock |
Public property | U_MinOrderQty |
Public property | U_MinStock |
Public property | U_OrderInterval |
Public property | U_OrderMultiple |
Public property | U_ParentItemCode |
Public property | U_PlanerI |
Public property | U_PlanerII |
Public property | U_PlanningMethod |
Public property | U_ProcurementMethod |
Public property | U_Remarks | Remarks
Public property | U_ReqStock |
Public property | U_Status | Revision status mandatory
Public property | U_ToleranceDays |
Public property | U_UseItmPerPurchUnit |
Public property | U_ValidFrom | Dalid From Date madatory
Public property | U_ValidTo | Valid To Date mandatory
Top
See Also

Reference

IItemDetailsRevisions Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_Code Property

revision Code Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2)> _
Property U_Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]
string U_Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]

property String^ U_Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2)
function get U_Code() : String;

   AppEngineProperty(Priority = 2)
function set U_Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_Default Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Default() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Default {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Default {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Default() : YesNoType;
function set U_Default(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_Description Property

Revision Description

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Description() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Description {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Description {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Description() : String;
function set U_Description(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_ForcePrimaryDemand Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ForcePrimaryDemand() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_ForcePrimaryDemand {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_ForcePrimaryDemand {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ForcePrimaryDemand() : YesNoType;
function set U_ForcePrimaryDemand(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_ILeadTime Property

Internal lead time, one of the place for this value to be set (as hierarchy on Connect shows). Format is days:hours:minutes.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ILeadTime() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ILeadTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ILeadTime {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ILeadTime() : String;
function set U_ILeadTime(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_InternalLeadTimeTransfer Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InternalLeadTimeTransfer() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_InternalLeadTimeTransfer {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_InternalLeadTimeTransfer {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InternalLeadTimeTransfer() : int;
function set U_InternalLeadTimeTransfer(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_IsCostingDefault Property

Determines whether revision is a default revision that is considered during the roll-over process for a default cost category.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IsCostingDefault() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_IsCostingDefault {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_IsCostingDefault {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IsCostingDefault() : YesNoType;
function set U_IsCostingDefault(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_IsMrpDefault Property

Indicates if the Bill of Materials document created for a combination of an Item Master Data and Revision Code is set as a default for the MRP process or not.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IsMrpDefault() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_IsMrpDefault {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_IsMrpDefault {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IsMrpDefault() : YesNoType;
function set U_IsMrpDefault(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_LeadTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LeadTime() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_LeadTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_LeadTime {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LeadTime() : int;
function set U_LeadTime(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_ManagInvByWhs Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ManagInvByWhs() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_ManagInvByWhs {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_ManagInvByWhs {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ManagInvByWhs() : YesNoType;
function set U_ManagInvByWhs(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_MatPhantom Property

Determines wheather material item is treated like a phantom ( explodes) on Manufacturing Order

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MatPhantom() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_MatPhantom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_MatPhantom {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MatPhantom() : YesNoType;
function set U_MatPhantom(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_MaxOrderQty Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MaxOrderQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_MaxOrderQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_MaxOrderQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MaxOrderQty() : double;
function set U_MaxOrderQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_MaxStock Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MaxStock() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_MaxStock {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_MaxStock {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MaxStock() : double;
function set U_MaxStock(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_MinOrderQty Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MinOrderQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_MinOrderQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_MinOrderQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MinOrderQty() : double;
function set U_MinOrderQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_MinStock Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MinStock() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_MinStock {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_MinStock {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MinStock() : double;
function set U_MinStock(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_OrderInterval Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OrderInterval() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_OrderInterval {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_OrderInterval {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OrderInterval() : int;
function set U_OrderInterval(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_OrderMultiple Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OrderMultiple() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_OrderMultiple {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_OrderMultiple {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OrderMultiple() : double;
function set U_OrderMultiple(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_ParentItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ParentItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ParentItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ParentItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ParentItemCode() : String;
function set U_ParentItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_PlanerI Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PlanerI() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_PlanerI {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_PlanerI {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PlanerI() : int;
function set U_PlanerI(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_PlanerII Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PlanerII() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_PlanerII {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_PlanerII {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PlanerII() : int;
function set U_PlanerII(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_PlanningMethod Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PlanningMethod() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PlanningMethod {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PlanningMethod {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PlanningMethod() : String;
function set U_PlanningMethod(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_ProcurementMethod Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ProcurementMethod() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ProcurementMethod {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ProcurementMethod {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ProcurementMethod() : String;
function set U_ProcurementMethod(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_Remarks Property

Remarks

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_ReqStock Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReqStock() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ReqStock {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ReqStock {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReqStock() : double;
function set U_ReqStock(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_Status Property

Revision status mandatory

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Status() As RevisionStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RevisionStatus U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RevisionStatus U_Status {
 RevisionStatus get( );
 void set(
   RevisionStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Status() : RevisionStatus;
function set U_Status(value : RevisionStatus);
This language is not supported or no code example is available.

Property Value

Type: RevisionStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_ToleranceDays Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ToleranceDays() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ToleranceDays {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ToleranceDays {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ToleranceDays() : int;
function set U_ToleranceDays(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_UseItmPerPurchUnit Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UseItmPerPurchUnit() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_UseItmPerPurchUnit {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_UseItmPerPurchUnit {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UseItmPerPurchUnit() : YesNoType;
function set U_UseItmPerPurchUnit(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_ValidFrom Property

Dalid From Date madatory

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidFrom() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidFrom {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidFrom() : DateTime;
function set U_ValidFrom(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions.U_ValidTo Property

Valid To Date mandatory

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidTo() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidTo {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidTo() : DateTime;
function set U_ValidTo(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsRevisions Interface
IItemDetailsRevisions Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsRevisions Methods

IItemDetailsRevisions Interface See Also

The following tables list the members exposed by the IItemDetailsRevisions type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemDetailsRevisions Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts Interface

Members See Also

Text of item details object

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemDetailsTexts
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemDetailsTexts)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemDetailsTexts : IUDOChildBean,
   IEnumerable<IItemDetailsTexts>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemDetailsTexts : public IUDOChildBean^,
   public IEnumerable<IItemDetailsTexts^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IDT7
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsTexts Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts Members

IItemDetailsTexts Interface Methods Properties See Also

Text of item details object

The following tables list the members exposed by the IItemDetailsTexts type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | TextName |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AddDate |
Public property | U_FromDate |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MSDS |
Public property | U_Other |
Public property | U_PickLists |
Public property | U_ProdOrders |
Public property | U_PurOrders |
Public property | U_Returns |
Public property | U_ShipDoc |
Public property | U_ToDate |
Public property | U_TxtCode |
Public property | U_UpdateDate |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemDetailsTexts Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts Properties

IItemDetailsTexts Interface See Also

The following tables list the members exposed by the IItemDetailsTexts type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | TextName |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AddDate |
Public property | U_FromDate |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MSDS |
Public property | U_Other |
Public property | U_PickLists |
Public property | U_ProdOrders |
Public property | U_PurOrders |
Public property | U_Returns |
Public property | U_ShipDoc |
Public property | U_ToDate |
Public property | U_TxtCode |
Public property | U_UpdateDate |
Top
See Also

Reference

IItemDetailsTexts Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsTexts Interface
IItemDetailsTexts Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsTexts Interface
IItemDetailsTexts Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsTexts Interface
IItemDetailsTexts Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsTexts Interface
IItemDetailsTexts Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts.TextName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property TextName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string TextName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ TextName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get TextName() : String;
function set TextName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsTexts Interface
IItemDetailsTexts Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts.U_AddDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AddDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_AddDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_AddDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AddDate() : DateTime;
function set U_AddDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsTexts Interface
IItemDetailsTexts Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts.U_FromDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FromDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_FromDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_FromDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FromDate() : DateTime;
function set U_FromDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsTexts Interface
IItemDetailsTexts Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts.U_MSDS Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MSDS() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MSDS {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MSDS {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MSDS() : String;
function set U_MSDS(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsTexts Interface
IItemDetailsTexts Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts.U_Other Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Other() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Other {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Other {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Other() : String;
function set U_Other(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsTexts Interface
IItemDetailsTexts Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts.U_PickLists Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PickLists() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PickLists {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PickLists {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PickLists() : String;
function set U_PickLists(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsTexts Interface
IItemDetailsTexts Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts.U_ProdOrders Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ProdOrders() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ProdOrders {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ProdOrders {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ProdOrders() : String;
function set U_ProdOrders(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsTexts Interface
IItemDetailsTexts Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts.U_PurOrders Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PurOrders() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PurOrders {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PurOrders {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PurOrders() : String;
function set U_PurOrders(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsTexts Interface
IItemDetailsTexts Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts.U_Returns Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Returns() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Returns {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Returns {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Returns() : String;
function set U_Returns(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsTexts Interface
IItemDetailsTexts Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts.U_ShipDoc Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ShipDoc() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ShipDoc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ShipDoc {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ShipDoc() : String;
function set U_ShipDoc(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsTexts Interface
IItemDetailsTexts Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts.U_ToDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ToDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ToDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ToDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ToDate() : DateTime;
function set U_ToDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsTexts Interface
IItemDetailsTexts Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts.U_TxtCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2)> _
Property U_TxtCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]
string U_TxtCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2)]

property String^ U_TxtCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2)
function get U_TxtCode() : String;

   AppEngineProperty(Priority = 2)
function set U_TxtCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsTexts Interface
IItemDetailsTexts Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts.U_UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_UpdateDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_UpdateDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UpdateDate() : DateTime;
function set U_UpdateDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsTexts Interface
IItemDetailsTexts Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


IItemDetailsTexts Methods

IItemDetailsTexts Interface See Also

The following tables list the members exposed by the IItemDetailsTexts type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemDetailsTexts Interface
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


RevisionStatus Enumeration

Revision Status Used in ItemDetails- Revisons

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Active | Active ACT
BeingPhrasedOut | Being Phrased Out -BPO
Engineering | Engineering ENG
Obsolete | Obsolete OBS
See Also

Reference

CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IPreferredVendors | Preferred vendors object
Public interface | IPreferredVendorsRows | Preferred vendors rows object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IPreferredVendors Interface

Members See Also

Preferred vendors object

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "PreferredVendors", TableName = "@CT_PF_OPVR", UDOVersion = "UDO_10")> _
Public Interface IPreferredVendors
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "PreferredVendors", TableName = "@CT_PF_OPVR", UDOVersion = "UDO_10")]
public interface IPreferredVendors : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "PreferredVendors", TableName = "@CT_PF_OPVR", UDOVersion = "UDO_10")]
public interface class IPreferredVendors : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "PreferredVendors", TableName = "@CT_PF_OPVR", UDOVersion = "UDO_10")
interface IPreferredVendors
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OPVR
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors Members

IPreferredVendors Interface Methods Properties See Also

Preferred vendors object

The following tables list the members exposed by the IPreferredVendors type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Rows | Gets or sets the vendors data.
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ItemCode | Gets or sets the item code.
Public property | U_PFDBVersion | Gets or sets the ProcessForce database version.
Public property | U_PFVersion | Gets or sets the ProcessForce version.
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Public property | ValidatePeriodsPercentage | Determines whether or not the total percentage should be validated across defined periods.
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetDefaultVendorCode | Gets the code of the default vendor.
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | GetRemainingPercentage | Gets the remaining percentage for the current period.
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | SetDefaultVendor | (Overloaded) Sets the default vendor by its row number.
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IPreferredVendors Interface
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors Properties

IPreferredVendors Interface See Also

The following tables list the members exposed by the IPreferredVendors type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Rows | Gets or sets the vendors data.
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ItemCode | Gets or sets the item code.
Public property | U_PFDBVersion | Gets or sets the ProcessForce database version.
Public property | U_PFVersion | Gets or sets the ProcessForce version.
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Public property | ValidatePeriodsPercentage | Determines whether or not the total percentage should be validated across defined periods.
Top
See Also

Reference

IPreferredVendors Interface
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.Rows Property

Gets or sets the vendors data.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Rows() As IPreferredVendorsRows
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IPreferredVendorsRows Rows {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IPreferredVendorsRows^ Rows {
 IPreferredVendorsRows^ get( );
 void set(
   IPreferredVendorsRows^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Rows() : IPreferredVendorsRows;
function set Rows(value : IPreferredVendorsRows);
This language is not supported or no code example is available.

Property Value

Type: IPreferredVendorsRows
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.U_ItemCode Property

Gets or sets the item code.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.U_PFDBVersion Property

Gets or sets the ProcessForce database version.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get U_PFDBVersion() : String;

   AppEnginePropertyReadOnly()
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.U_PFVersion Property

Gets or sets the ProcessForce version.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get U_PFVersion() : String;

   AppEnginePropertyReadOnly()
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.ValidatePeriodsPercentage Property

Determines whether or not the total percentage should be validated across defined periods.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ValidatePeriodsPercentage() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool ValidatePeriodsPercentage {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool ValidatePeriodsPercentage {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ValidatePeriodsPercentage() : boolean;
function set ValidatePeriodsPercentage(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors Methods

IPreferredVendors Interface See Also

The following tables list the members exposed by the IPreferredVendors type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetDefaultVendorCode | Gets the code of the default vendor.
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | GetRemainingPercentage | Gets the remaining percentage for the current period.
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | SetDefaultVendor | (Overloaded) Sets the default vendor by its row number.
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IPreferredVendors Interface
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.GetDefaultVendorCode Method

Gets the code of the default vendor.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetDefaultVendorCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string GetDefaultVendorCode()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

String^ GetDefaultVendorCode()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetDefaultVendorCode() : String;
This language is not supported or no code example is available.

Return Value

Type: string

String object that represents the code of the default vendor.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.GetRemainingPercentage Method

Gets the remaining percentage for the current period.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetRemainingPercentage() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double GetRemainingPercentage()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

double GetRemainingPercentage()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetRemainingPercentage() : double;
This language is not supported or no code example is available.

Return Value

Type: double

System.Double that represents the remaining percentage.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.SetDefaultVendor Method

IPreferredVendors Interface See Also

Sets the default vendor by its row number.

Overload List
Name | Description
SetDefaultVendor(int) | Sets the default vendor by its row number.
SetDefaultVendor(string) | Sets the default vendor by its code.
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendorsRows Interface

Members See Also

Preferred vendors rows object

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IPreferredVendorsRows
    Inherits IUDOChildBean, _
             IEnumerable(Of IPreferredVendorsRows)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IPreferredVendorsRows : IUDOChildBean,
   IEnumerable<IPreferredVendorsRows>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IPreferredVendorsRows : public IUDOChildBean^,
   public IEnumerable<IPreferredVendorsRows^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_PVR1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendorsRows Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendorsRows Members

IPreferredVendorsRows Interface Methods Properties See Also

Preferred vendors rows object

The following tables list the members exposed by the IPreferredVendorsRows type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_LastPurchasePrice | Gets the last purchase price.
Public property | DS_PriceListName | Gets the price list name.
Public property | DS_PriceListPrice | Gets the price defined for a price list.
Public property | DS_VendorName | Gets or sets the vendor name.
Public property | IsFilled | Gets an indication whether or not the row is filled.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_EndDate | Gets or sets the end date.
Public property | U_IsDefault | Gets or sets the indication whether or not the vendor code is default.
Public property | U_ItemCode | Gets or sets the item code.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Percentage | Gets or sets the percentage.
Public property | U_StartDate | Gets or sets the start date.
Public property | U_VendorCode | Gets or sets the vendor code.
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPreferredVendorsRows Interface
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendorsRows Properties

IPreferredVendorsRows Interface See Also

The following tables list the members exposed by the IPreferredVendorsRows type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_LastPurchasePrice | Gets the last purchase price.
Public property | DS_PriceListName | Gets the price list name.
Public property | DS_PriceListPrice | Gets the price defined for a price list.
Public property | DS_VendorName | Gets or sets the vendor name.
Public property | IsFilled | Gets an indication whether or not the row is filled.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_EndDate | Gets or sets the end date.
Public property | U_IsDefault | Gets or sets the indication whether or not the vendor code is default.
Public property | U_ItemCode | Gets or sets the item code.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Percentage | Gets or sets the percentage.
Public property | U_StartDate | Gets or sets the start date.
Public property | U_VendorCode | Gets or sets the vendor code.
Top
See Also

Reference

IPreferredVendorsRows Interface
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendorsRows.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendorsRows Interface
IPreferredVendorsRows Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendorsRows.DS_LastPurchasePrice Property

Gets the last purchase price.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_LastPurchasePrice() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_LastPurchasePrice {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_LastPurchasePrice {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_LastPurchasePrice() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendorsRows Interface
IPreferredVendorsRows Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendorsRows.DS_PriceListName Property

Gets the price list name.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_PriceListName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_PriceListName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_PriceListName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_PriceListName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendorsRows Interface
IPreferredVendorsRows Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendorsRows.DS_PriceListPrice Property

Gets the price defined for a price list.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_PriceListPrice() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double DS_PriceListPrice {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double DS_PriceListPrice {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_PriceListPrice() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendorsRows Interface
IPreferredVendorsRows Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendorsRows.DS_VendorName Property

Gets or sets the vendor name.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_VendorName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_VendorName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_VendorName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_VendorName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendorsRows Interface
IPreferredVendorsRows Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendorsRows.IsFilled Property

Gets an indication whether or not the row is filled.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property IsFilled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
bool IsFilled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property bool IsFilled {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get IsFilled() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendorsRows Interface
IPreferredVendorsRows Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendorsRows.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendorsRows Interface
IPreferredVendorsRows Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendorsRows.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendorsRows Interface
IPreferredVendorsRows Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendorsRows.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendorsRows Interface
IPreferredVendorsRows Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendorsRows.U_EndDate Property

Gets or sets the end date.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_EndDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_EndDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EndDate() : DateTime;
function set U_EndDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendorsRows Interface
IPreferredVendorsRows Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendorsRows.U_IsDefault Property

Gets or sets the indication whether or not the vendor code is default.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IsDefault() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_IsDefault {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_IsDefault {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IsDefault() : YesNoType;
function set U_IsDefault(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendorsRows Interface
IPreferredVendorsRows Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendorsRows.U_ItemCode Property

Gets or sets the item code.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendorsRows Interface
IPreferredVendorsRows Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendorsRows.U_Percentage Property

Gets or sets the percentage.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Percentage() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Percentage {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Percentage {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Percentage() : double;
function set U_Percentage(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendorsRows Interface
IPreferredVendorsRows Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendorsRows.U_StartDate Property

Gets or sets the start date.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StartDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StartDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StartDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StartDate() : DateTime;
function set U_StartDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendorsRows Interface
IPreferredVendorsRows Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendorsRows.U_VendorCode Property

Gets or sets the vendor code.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VendorCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_VendorCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_VendorCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VendorCode() : String;
function set U_VendorCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendorsRows Interface
IPreferredVendorsRows Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendorsRows Methods

IPreferredVendorsRows Interface See Also

The following tables list the members exposed by the IPreferredVendorsRows type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPreferredVendorsRows Interface
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


CompuTec.ProcessForce.API.Documents.ItemGroup Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IItemGroup | Item group object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IItemGroup Interface

Members See Also

Item group object

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ItemGroup", TableName = "@CT_PF_OIGR")> _
Public Interface IItemGroup
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemGroup", TableName = "@CT_PF_OIGR")]
public interface IItemGroup : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemGroup", TableName = "@CT_PF_OIGR")]
public interface class IItemGroup : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ItemGroup", TableName = "@CT_PF_OIGR")
interface IItemGroup
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OIGR
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup Members

IItemGroup Interface Methods Properties See Also

Item group object

The following tables list the members exposed by the IItemGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | GroupName |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GGrpCode |
Public property | U_GrpCode |
Public property | U_GrpName |
Public property | U_MSDS |
Public property | U_Other |
Public property | U_PickLists |
Public property | U_ProdOrders |
Public property | U_PurOrders |
Public property | U_Remarks |
Public property | U_Returns |
Public property | U_ShipDoc |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemGroup Interface
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup Properties

IItemGroup Interface See Also

The following tables list the members exposed by the IItemGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | GroupName |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GGrpCode |
Public property | U_GrpCode |
Public property | U_GrpName |
Public property | U_MSDS |
Public property | U_Other |
Public property | U_PickLists |
Public property | U_ProdOrders |
Public property | U_PurOrders |
Public property | U_Remarks |
Public property | U_Returns |
Public property | U_ShipDoc |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IItemGroup Interface
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.GroupName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property GroupName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string GroupName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ GroupName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get GroupName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.U_GGrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GGrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GGrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GGrpCode() : String;
function set U_GGrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.U_GrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_GrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_GrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_GrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_GrpCode() : String;

   AppEngineProperty(Required = true)
function set U_GrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.U_GrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpName() : String;
function set U_GrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.U_MSDS Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MSDS() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MSDS {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MSDS {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MSDS() : String;
function set U_MSDS(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.U_Other Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Other() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Other {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Other {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Other() : String;
function set U_Other(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.U_PickLists Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PickLists() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PickLists {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PickLists {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PickLists() : String;
function set U_PickLists(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.U_ProdOrders Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ProdOrders() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ProdOrders {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ProdOrders {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ProdOrders() : String;
function set U_ProdOrders(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.U_PurOrders Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PurOrders() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PurOrders {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PurOrders {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PurOrders() : String;
function set U_PurOrders(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.U_Returns Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Returns() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Returns {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Returns {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Returns() : String;
function set U_Returns(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.U_ShipDoc Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ShipDoc() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ShipDoc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ShipDoc {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ShipDoc() : String;
function set U_ShipDoc(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroup Interface
IItemGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


IItemGroup Methods

IItemGroup Interface See Also

The following tables list the members exposed by the IItemGroup type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemGroup Interface
CompuTec.ProcessForce.API.Documents.ItemGroup Namespace


CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IItemGroupGroup | Item group group object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IItemGroupGroup Interface

Members See Also

Item group group object

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroupGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ItemGroupGroup", TableName = "@CT_PF_OIGG", UDOVersion = "UDO_10")> _
Public Interface IItemGroupGroup
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemGroupGroup", TableName = "@CT_PF_OIGG", UDOVersion = "UDO_10")]
public interface IItemGroupGroup : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemGroupGroup", TableName = "@CT_PF_OIGG", UDOVersion = "UDO_10")]
public interface class IItemGroupGroup : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ItemGroupGroup", TableName = "@CT_PF_OIGG", UDOVersion = "UDO_10")
interface IItemGroupGroup
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OIGG
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroupGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


IItemGroupGroup Members

IItemGroupGroup Interface Methods Properties See Also

Item group group object

The following tables list the members exposed by the IItemGroupGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode |
Public property | U_GrpDescription |
Public property | U_GrpName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemGroupGroup Interface
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


IItemGroupGroup Properties

IItemGroupGroup Interface See Also

The following tables list the members exposed by the IItemGroupGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode |
Public property | U_GrpDescription |
Public property | U_GrpName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IItemGroupGroup Interface
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


IItemGroupGroup.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroupGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroupGroup Interface
IItemGroupGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


IItemGroupGroup.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroupGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroupGroup Interface
IItemGroupGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


IItemGroupGroup.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroupGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroupGroup Interface
IItemGroupGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


IItemGroupGroup.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroupGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroupGroup Interface
IItemGroupGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


IItemGroupGroup.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroupGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroupGroup Interface
IItemGroupGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


IItemGroupGroup.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroupGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroupGroup Interface
IItemGroupGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


IItemGroupGroup.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroupGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroupGroup Interface
IItemGroupGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


IItemGroupGroup.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroupGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroupGroup Interface
IItemGroupGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


IItemGroupGroup.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroupGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroupGroup Interface
IItemGroupGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


IItemGroupGroup.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroupGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroupGroup Interface
IItemGroupGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


IItemGroupGroup.U_GrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroupGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_GrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_GrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_GrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_GrpCode() : String;

   AppEngineProperty(Required = true)
function set U_GrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroupGroup Interface
IItemGroupGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


IItemGroupGroup.U_GrpDescription Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroupGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpDescription() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpDescription {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpDescription {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpDescription() : String;
function set U_GrpDescription(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroupGroup Interface
IItemGroupGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


IItemGroupGroup.U_GrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroupGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpName() : String;
function set U_GrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroupGroup Interface
IItemGroupGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


IItemGroupGroup.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroupGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroupGroup Interface
IItemGroupGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


IItemGroupGroup.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroupGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroupGroup Interface
IItemGroupGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


IItemGroupGroup.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemGroupGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemGroupGroup Interface
IItemGroupGroup Members
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


IItemGroupGroup Methods

IItemGroupGroup Interface See Also

The following tables list the members exposed by the IItemGroupGroup type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemGroupGroup Interface
CompuTec.ProcessForce.API.Documents.ItemGroupGroup Namespace


CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IItemPhrase | Item phrase object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IItemPhrase Interface

Members See Also

Item phrase object

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ItemPhrases", TableName = "@CT_PF_OIPH", UDOVersion = "UDO_10")> _
Public Interface IItemPhrase
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemPhrases", TableName = "@CT_PF_OIPH", UDOVersion = "UDO_10")]
public interface IItemPhrase : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemPhrases", TableName = "@CT_PF_OIPH", UDOVersion = "UDO_10")]
public interface class IItemPhrase : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ItemPhrases", TableName = "@CT_PF_OIPH", UDOVersion = "UDO_10")
interface IItemPhrase
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OIPH
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase Members

IItemPhrase Interface Methods Properties See Also

Item phrase object

The following tables list the members exposed by the IItemPhrase type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | GroupName |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode |
Public property | U_MSDS |
Public property | U_Other |
Public property | U_PhCode |
Public property | U_PhName |
Public property | U_PickLists |
Public property | U_ProdOrders |
Public property | U_PurOrders |
Public property | U_Remarks |
Public property | U_Returns |
Public property | U_ShipDoc |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemPhrase Interface
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase Properties

IItemPhrase Interface See Also

The following tables list the members exposed by the IItemPhrase type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | GroupName |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode |
Public property | U_MSDS |
Public property | U_Other |
Public property | U_PhCode |
Public property | U_PhName |
Public property | U_PickLists |
Public property | U_ProdOrders |
Public property | U_PurOrders |
Public property | U_Remarks |
Public property | U_Returns |
Public property | U_ShipDoc |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IItemPhrase Interface
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.GroupName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property GroupName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string GroupName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ GroupName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get GroupName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.U_GrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpCode() : String;
function set U_GrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.U_MSDS Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MSDS() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MSDS {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MSDS {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MSDS() : String;
function set U_MSDS(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.U_Other Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Other() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Other {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Other {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Other() : String;
function set U_Other(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.U_PhCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_PhCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_PhCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_PhCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_PhCode() : String;

   AppEngineProperty(Required = true)
function set U_PhCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.U_PhName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PhName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PhName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PhName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PhName() : String;
function set U_PhName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.U_PickLists Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PickLists() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PickLists {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PickLists {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PickLists() : String;
function set U_PickLists(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.U_ProdOrders Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ProdOrders() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ProdOrders {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ProdOrders {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ProdOrders() : String;
function set U_ProdOrders(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.U_PurOrders Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PurOrders() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PurOrders {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PurOrders {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PurOrders() : String;
function set U_PurOrders(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.U_Returns Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Returns() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Returns {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Returns {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Returns() : String;
function set U_Returns(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.U_ShipDoc Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ShipDoc() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ShipDoc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ShipDoc {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ShipDoc() : String;
function set U_ShipDoc(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhrase
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhrase Interface
IItemPhrase Members
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


IItemPhrase Methods

IItemPhrase Interface See Also

The following tables list the members exposed by the IItemPhrase type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemPhrase Interface
CompuTec.ProcessForce.API.Documents.ItemPhrase Namespace


CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IItemPhraseGroup | Item phrase group object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IItemPhraseGroup Interface

Members See Also

Item phrase group object

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhraseGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ItemPhrasesGroup", TableName = "@CT_PF_OIHG", UDOVersion = "UDO_10")> _
Public Interface IItemPhraseGroup
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemPhrasesGroup", TableName = "@CT_PF_OIHG", UDOVersion = "UDO_10")]
public interface IItemPhraseGroup : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemPhrasesGroup", TableName = "@CT_PF_OIHG", UDOVersion = "UDO_10")]
public interface class IItemPhraseGroup : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ItemPhrasesGroup", TableName = "@CT_PF_OIHG", UDOVersion = "UDO_10")
interface IItemPhraseGroup
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OIHG
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhraseGroup Members
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


IItemPhraseGroup Members

IItemPhraseGroup Interface Methods Properties See Also

Item phrase group object

The following tables list the members exposed by the IItemPhraseGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode |
Public property | U_GrpDescription |
Public property | U_GrpName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemPhraseGroup Interface
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


IItemPhraseGroup Properties

IItemPhraseGroup Interface See Also

The following tables list the members exposed by the IItemPhraseGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode |
Public property | U_GrpDescription |
Public property | U_GrpName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IItemPhraseGroup Interface
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


IItemPhraseGroup.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhraseGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhraseGroup Interface
IItemPhraseGroup Members
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


IItemPhraseGroup.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhraseGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhraseGroup Interface
IItemPhraseGroup Members
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


IItemPhraseGroup.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhraseGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhraseGroup Interface
IItemPhraseGroup Members
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


IItemPhraseGroup.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhraseGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhraseGroup Interface
IItemPhraseGroup Members
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


IItemPhraseGroup.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhraseGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhraseGroup Interface
IItemPhraseGroup Members
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


IItemPhraseGroup.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhraseGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhraseGroup Interface
IItemPhraseGroup Members
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


IItemPhraseGroup.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhraseGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhraseGroup Interface
IItemPhraseGroup Members
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


IItemPhraseGroup.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhraseGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhraseGroup Interface
IItemPhraseGroup Members
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


IItemPhraseGroup.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhraseGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhraseGroup Interface
IItemPhraseGroup Members
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


IItemPhraseGroup.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhraseGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhraseGroup Interface
IItemPhraseGroup Members
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


IItemPhraseGroup.U_GrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhraseGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_GrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_GrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_GrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_GrpCode() : String;

   AppEngineProperty(Required = true)
function set U_GrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhraseGroup Interface
IItemPhraseGroup Members
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


IItemPhraseGroup.U_GrpDescription Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhraseGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpDescription() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpDescription {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpDescription {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpDescription() : String;
function set U_GrpDescription(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhraseGroup Interface
IItemPhraseGroup Members
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


IItemPhraseGroup.U_GrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhraseGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpName() : String;
function set U_GrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhraseGroup Interface
IItemPhraseGroup Members
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


IItemPhraseGroup.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhraseGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhraseGroup Interface
IItemPhraseGroup Members
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


IItemPhraseGroup.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhraseGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhraseGroup Interface
IItemPhraseGroup Members
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


IItemPhraseGroup.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPhraseGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPhraseGroup Interface
IItemPhraseGroup Members
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


IItemPhraseGroup Methods

IItemPhraseGroup Interface See Also

The following tables list the members exposed by the IItemPhraseGroup type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemPhraseGroup Interface
CompuTec.ProcessForce.API.Documents.ItemPhraseGroup Namespace


CompuTec.ProcessForce.API.Documents.ItemProperty Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IItemProperty | Item property object
Public interface | IItemPropertyWords | Item property words object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IItemProperty Interface

Members See Also

Item property object

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ItemProperty", TableName = "@CT_PF_OIPR", UDOVersion = "UDO_10")> _
Public Interface IItemProperty
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemProperty", TableName = "@CT_PF_OIPR", UDOVersion = "UDO_10")]
public interface IItemProperty : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemProperty", TableName = "@CT_PF_OIPR", UDOVersion = "UDO_10")]
public interface class IItemProperty : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ItemProperty", TableName = "@CT_PF_OIPR", UDOVersion = "UDO_10")
interface IItemProperty
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OIPR
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty Members

IItemProperty Interface Methods Properties See Also

Item property object

The following tables list the members exposed by the IItemProperty type.

Properties
 | Name | Description
Public property | BusinessPartnerRelations |
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_GrpDesc |
Public property | DS_GrpName |
Public property | DS_SubGrpCode |
Public property | DS_SubGrpDesc |
Public property | DS_SubGrpName |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode |
Public property | U_IsQcTesting |
Public property | U_MSDS |
Public property | U_Other |
Public property | U_PickLists |
Public property | U_ProdOrders |
Public property | U_PrpCode |
Public property | U_PrpDesc |
Public property | U_PrpName |
Public property | U_PurOrders |
Public property | U_Returns |
Public property | U_ShipDoc |
Public property | U_SubGrpLineNo |
Public property | U_UoM |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Public property | Words |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemProperty Interface
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty Properties

IItemProperty Interface See Also

The following tables list the members exposed by the IItemProperty type.

Properties
 | Name | Description
Public property | BusinessPartnerRelations |
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_GrpDesc |
Public property | DS_GrpName |
Public property | DS_SubGrpCode |
Public property | DS_SubGrpDesc |
Public property | DS_SubGrpName |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode |
Public property | U_IsQcTesting |
Public property | U_MSDS |
Public property | U_Other |
Public property | U_PickLists |
Public property | U_ProdOrders |
Public property | U_PrpCode |
Public property | U_PrpDesc |
Public property | U_PrpName |
Public property | U_PurOrders |
Public property | U_Returns |
Public property | U_ShipDoc |
Public property | U_SubGrpLineNo |
Public property | U_UoM |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Public property | Words |
Top
See Also

Reference

IItemProperty Interface
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.BusinessPartnerRelations Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BusinessPartnerRelations() As IBusinessPartnerRelations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBusinessPartnerRelations BusinessPartnerRelations {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBusinessPartnerRelations^ BusinessPartnerRelations {
 IBusinessPartnerRelations^ get( );
 void set(
   IBusinessPartnerRelations^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BusinessPartnerRelations() : IBusinessPartnerRelations;
function set BusinessPartnerRelations(value : IBusinessPartnerRelations);
This language is not supported or no code example is available.

Property Value

Type: IBusinessPartnerRelations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.DS_GrpDesc Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_GrpDesc() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_GrpDesc {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_GrpDesc {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_GrpDesc() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.DS_GrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_GrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_GrpName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_GrpName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_GrpName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.DS_SubGrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_SubGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_SubGrpCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_SubGrpCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_SubGrpCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.DS_SubGrpDesc Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_SubGrpDesc() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_SubGrpDesc {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_SubGrpDesc {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_SubGrpDesc() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.DS_SubGrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_SubGrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_SubGrpName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_SubGrpName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_SubGrpName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.U_GrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpCode() : String;
function set U_GrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.U_IsQcTesting Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IsQcTesting() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_IsQcTesting {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_IsQcTesting {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IsQcTesting() : String;
function set U_IsQcTesting(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.U_MSDS Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MSDS() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MSDS {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MSDS {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MSDS() : String;
function set U_MSDS(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.U_Other Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Other() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Other {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Other {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Other() : String;
function set U_Other(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.U_PickLists Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PickLists() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PickLists {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PickLists {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PickLists() : String;
function set U_PickLists(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.U_ProdOrders Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ProdOrders() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ProdOrders {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ProdOrders {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ProdOrders() : String;
function set U_ProdOrders(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.U_PrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_PrpCode() : String;

   AppEngineProperty(Required = true)
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.U_PrpDesc Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpDesc() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpDesc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpDesc {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpDesc() : String;
function set U_PrpDesc(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.U_PrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpName() : String;
function set U_PrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.U_PurOrders Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PurOrders() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PurOrders {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PurOrders {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PurOrders() : String;
function set U_PurOrders(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.U_Returns Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Returns() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Returns {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Returns {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Returns() : String;
function set U_Returns(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.U_ShipDoc Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ShipDoc() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ShipDoc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ShipDoc {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ShipDoc() : String;
function set U_ShipDoc(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.U_SubGrpLineNo Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SubGrpLineNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SubGrpLineNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SubGrpLineNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SubGrpLineNo() : int;
function set U_SubGrpLineNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.U_UoM Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UoM() : String;
function set U_UoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty.Words Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Words() As IItemPropertyWords
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemPropertyWords Words {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemPropertyWords^ Words {
 IItemPropertyWords^ get( );
 void set(
   IItemPropertyWords^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Words() : IItemPropertyWords;
function set Words(value : IItemPropertyWords);
This language is not supported or no code example is available.

Property Value

Type: IItemPropertyWords
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemProperty Interface
IItemProperty Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemProperty Methods

IItemProperty Interface See Also

The following tables list the members exposed by the IItemProperty type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemProperty Interface
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemPropertyWords Interface

Members See Also

Item property words object

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemPropertyWords
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemPropertyWords)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemPropertyWords : IUDOChildBean,
   IEnumerable<IItemPropertyWords>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemPropertyWords : public IUDOChildBean^,
   public IEnumerable<IItemPropertyWords^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IPR1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyWords Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemPropertyWords Members

IItemPropertyWords Interface Methods Properties See Also

Item property words object

The following tables list the members exposed by the IItemPropertyWords type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_WordName |
Public property | DS_WordRemarks |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_WordCode |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemPropertyWords Interface
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemPropertyWords Properties

IItemPropertyWords Interface See Also

The following tables list the members exposed by the IItemPropertyWords type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_WordName |
Public property | DS_WordRemarks |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_WordCode |
Top
See Also

Reference

IItemPropertyWords Interface
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemPropertyWords.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyWords Interface
IItemPropertyWords Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemPropertyWords.DS_WordName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_WordName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_WordName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_WordName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_WordName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyWords Interface
IItemPropertyWords Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemPropertyWords.DS_WordRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_WordRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_WordRemarks {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_WordRemarks {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_WordRemarks() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyWords Interface
IItemPropertyWords Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemPropertyWords.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyWords Interface
IItemPropertyWords Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemPropertyWords.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyWords Interface
IItemPropertyWords Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemPropertyWords.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyWords Interface
IItemPropertyWords Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemPropertyWords.U_WordCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyWords Interface
IItemPropertyWords Members
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


IItemPropertyWords Methods

IItemPropertyWords Interface See Also

The following tables list the members exposed by the IItemPropertyWords type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemPropertyWords Interface
CompuTec.ProcessForce.API.Documents.ItemProperty Namespace


CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IItemPropertyCheckList | Item property checklist object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IItemPropertyCheckList Interface

Members See Also

Item property checklist object

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ItemPropertyCheckList", TableName = "@CT_PF_OICH")> _
Public Interface IItemPropertyCheckList
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemPropertyCheckList", TableName = "@CT_PF_OICH")]
public interface IItemPropertyCheckList : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemPropertyCheckList", TableName = "@CT_PF_OICH")]
public interface class IItemPropertyCheckList : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ItemPropertyCheckList", TableName = "@CT_PF_OICH")
interface IItemPropertyCheckList
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OICH
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyCheckList Members
CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList Namespace


IItemPropertyCheckList Members

IItemPropertyCheckList Interface Methods Properties See Also

Item property checklist object

The following tables list the members exposed by the IItemPropertyCheckList type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Name |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Checked |
Public property | U_CurrentRemarks |
Public property | U_CurrentWordCode |
Public property | U_EmplID |
Public property | U_MorEntry |
Public property | U_OprCode |
Public property | U_PrpCode |
Public property | U_Remarks |
Public property | U_RscCode |
Public property | U_RscLine |
Public property | U_Value |
Public property | U_WordCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemPropertyCheckList Interface
CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList Namespace


IItemPropertyCheckList Properties

IItemPropertyCheckList Interface See Also

The following tables list the members exposed by the IItemPropertyCheckList type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Name |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Checked |
Public property | U_CurrentRemarks |
Public property | U_CurrentWordCode |
Public property | U_EmplID |
Public property | U_MorEntry |
Public property | U_OprCode |
Public property | U_PrpCode |
Public property | U_Remarks |
Public property | U_RscCode |
Public property | U_RscLine |
Public property | U_Value |
Public property | U_WordCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
See Also

Reference

IItemPropertyCheckList Interface
CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList Namespace


IItemPropertyCheckList.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyCheckList Interface
IItemPropertyCheckList Members
CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList Namespace


IItemPropertyCheckList.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
function set Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyCheckList Interface
IItemPropertyCheckList Members
CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList Namespace


IItemPropertyCheckList.U_Checked Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Checked() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Checked {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Checked {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Checked() : YesNoType;
function set U_Checked(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyCheckList Interface
IItemPropertyCheckList Members
CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList Namespace


IItemPropertyCheckList.U_CurrentRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CurrentRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CurrentRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CurrentRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CurrentRemarks() : String;
function set U_CurrentRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyCheckList Interface
IItemPropertyCheckList Members
CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList Namespace


IItemPropertyCheckList.U_CurrentWordCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CurrentWordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CurrentWordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CurrentWordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CurrentWordCode() : String;
function set U_CurrentWordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyCheckList Interface
IItemPropertyCheckList Members
CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList Namespace


IItemPropertyCheckList.U_EmplID Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EmplID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_EmplID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_EmplID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EmplID() : int;
function set U_EmplID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyCheckList Interface
IItemPropertyCheckList Members
CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList Namespace


IItemPropertyCheckList.U_MorEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MorEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_MorEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_MorEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MorEntry() : int;
function set U_MorEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyCheckList Interface
IItemPropertyCheckList Members
CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList Namespace


IItemPropertyCheckList.U_OprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprCode() : String;
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyCheckList Interface
IItemPropertyCheckList Members
CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList Namespace


IItemPropertyCheckList.U_PrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpCode() : String;
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyCheckList Interface
IItemPropertyCheckList Members
CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList Namespace


IItemPropertyCheckList.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyCheckList Interface
IItemPropertyCheckList Members
CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList Namespace


IItemPropertyCheckList.U_RscCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCode() : String;
function set U_RscCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyCheckList Interface
IItemPropertyCheckList Members
CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList Namespace


IItemPropertyCheckList.U_RscLine Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RscLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RscLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscLine() : int;
function set U_RscLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyCheckList Interface
IItemPropertyCheckList Members
CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList Namespace


IItemPropertyCheckList.U_Value Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Value() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Value {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Value {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Value() : double;
function set U_Value(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyCheckList Interface
IItemPropertyCheckList Members
CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList Namespace


IItemPropertyCheckList.U_WordCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyCheckList Interface
IItemPropertyCheckList Members
CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList Namespace


IItemPropertyCheckList Methods

IItemPropertyCheckList Interface See Also

The following tables list the members exposed by the IItemPropertyCheckList type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemPropertyCheckList Interface
CompuTec.ProcessForce.API.Documents.ItemPropertyCheckList Namespace


CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IItemPropertyGroup | Item property group object
Public interface | IItemPropertyGroupSubgroups | Subgroups of item property group object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IItemPropertyGroup Interface

Members See Also

Item property group object

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ItemPropertyGroup", TableName = "@CT_PF_OIPG", UDOVersion = "UDO_10")> _
Public Interface IItemPropertyGroup
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemPropertyGroup", TableName = "@CT_PF_OIPG", UDOVersion = "UDO_10")]
public interface IItemPropertyGroup : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemPropertyGroup", TableName = "@CT_PF_OIPG", UDOVersion = "UDO_10")]
public interface class IItemPropertyGroup : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ItemPropertyGroup", TableName = "@CT_PF_OIPG", UDOVersion = "UDO_10")
interface IItemPropertyGroup
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OIPG
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroup Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup Members

IItemPropertyGroup Interface Methods Properties See Also

Item property group object

The following tables list the members exposed by the IItemPropertyGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Subgroups |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode |
Public property | U_GrpDescription |
Public property | U_GrpName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemPropertyGroup Interface
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup Properties

IItemPropertyGroup Interface See Also

The following tables list the members exposed by the IItemPropertyGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Subgroups |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode |
Public property | U_GrpDescription |
Public property | U_GrpName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IItemPropertyGroup Interface
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroup Interface
IItemPropertyGroup Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroup Interface
IItemPropertyGroup Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroup Interface
IItemPropertyGroup Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroup Interface
IItemPropertyGroup Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroup Interface
IItemPropertyGroup Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroup Interface
IItemPropertyGroup Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroup Interface
IItemPropertyGroup Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroup Interface
IItemPropertyGroup Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroup Interface
IItemPropertyGroup Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup.Subgroups Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Subgroups() As IItemPropertyGroupSubgroups
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemPropertyGroupSubgroups Subgroups {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemPropertyGroupSubgroups^ Subgroups {
 IItemPropertyGroupSubgroups^ get( );
 void set(
   IItemPropertyGroupSubgroups^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Subgroups() : IItemPropertyGroupSubgroups;
function set Subgroups(value : IItemPropertyGroupSubgroups);
This language is not supported or no code example is available.

Property Value

Type: IItemPropertyGroupSubgroups
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroup Interface
IItemPropertyGroup Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroup Interface
IItemPropertyGroup Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup.U_GrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_GrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_GrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_GrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_GrpCode() : String;

   AppEngineProperty(Required = true)
function set U_GrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroup Interface
IItemPropertyGroup Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup.U_GrpDescription Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpDescription() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpDescription {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpDescription {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpDescription() : String;
function set U_GrpDescription(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroup Interface
IItemPropertyGroup Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup.U_GrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpName() : String;
function set U_GrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroup Interface
IItemPropertyGroup Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroup Interface
IItemPropertyGroup Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroup Interface
IItemPropertyGroup Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroup Interface
IItemPropertyGroup Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroup Methods

IItemPropertyGroup Interface See Also

The following tables list the members exposed by the IItemPropertyGroup type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemPropertyGroup Interface
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroupSubgroups Interface

Members See Also

Subgroups of item property group object

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IItemPropertyGroupSubgroups
    Inherits IUDOChildBean, _
             IEnumerable(Of IItemPropertyGroupSubgroups)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IItemPropertyGroupSubgroups : IUDOChildBean,
   IEnumerable<IItemPropertyGroupSubgroups>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IItemPropertyGroupSubgroups : public IUDOChildBean^,
   public IEnumerable<IItemPropertyGroupSubgroups^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IPG1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroupSubgroups Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroupSubgroups Members

IItemPropertyGroupSubgroups Interface Methods Properties See Also

Subgroups of item property group object

The following tables list the members exposed by the IItemPropertyGroupSubgroups type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_SubGrpCode |
Public property | U_SubGrpDescription |
Public property | U_SubGrpName |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemPropertyGroupSubgroups Interface
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroupSubgroups Properties

IItemPropertyGroupSubgroups Interface See Also

The following tables list the members exposed by the IItemPropertyGroupSubgroups type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_SubGrpCode |
Public property | U_SubGrpDescription |
Public property | U_SubGrpName |
Top
See Also

Reference

IItemPropertyGroupSubgroups Interface
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroupSubgroups.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroupSubgroups Interface
IItemPropertyGroupSubgroups Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroupSubgroups.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroupSubgroups Interface
IItemPropertyGroupSubgroups Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroupSubgroups.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroupSubgroups Interface
IItemPropertyGroupSubgroups Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroupSubgroups.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroupSubgroups Interface
IItemPropertyGroupSubgroups Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroupSubgroups.U_SubGrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SubGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SubGrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SubGrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SubGrpCode() : String;
function set U_SubGrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroupSubgroups Interface
IItemPropertyGroupSubgroups Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroupSubgroups.U_SubGrpDescription Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SubGrpDescription() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SubGrpDescription {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SubGrpDescription {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SubGrpDescription() : String;
function set U_SubGrpDescription(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroupSubgroups Interface
IItemPropertyGroupSubgroups Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroupSubgroups.U_SubGrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SubGrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SubGrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SubGrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SubGrpName() : String;
function set U_SubGrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemPropertyGroupSubgroups Interface
IItemPropertyGroupSubgroups Members
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


IItemPropertyGroupSubgroups Methods

IItemPropertyGroupSubgroups Interface See Also

The following tables list the members exposed by the IItemPropertyGroupSubgroups type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IItemPropertyGroupSubgroups Interface
CompuTec.ProcessForce.API.Documents.ItemPropertyGroup Namespace


CompuTec.ProcessForce.API.Documents.ItemText Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IItemText | Item text object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IItemText Interface

Members See Also

Item text object

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ItemText", TableName = "@CT_PF_OITX", UDOVersion = "UDO_10")> _
Public Interface IItemText
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemText", TableName = "@CT_PF_OITX", UDOVersion = "UDO_10")]
public interface IItemText : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemText", TableName = "@CT_PF_OITX", UDOVersion = "UDO_10")]
public interface class IItemText : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ItemText", TableName = "@CT_PF_OITX", UDOVersion = "UDO_10")
interface IItemText
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OITX
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText Members

IItemText Interface Methods Properties See Also

Item text object

The following tables list the members exposed by the IItemText type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_GrName |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode |
Public property | U_MSDS |
Public property | U_Other |
Public property | U_PickLists |
Public property | U_ProdOrders |
Public property | U_PurOrders |
Public property | U_Remarks |
Public property | U_Returns |
Public property | U_ShipDoc |
Public property | U_TxtCode |
Public property | U_TxtName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemText Interface
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText Properties

IItemText Interface See Also

The following tables list the members exposed by the IItemText type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_GrName |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode |
Public property | U_MSDS |
Public property | U_Other |
Public property | U_PickLists |
Public property | U_ProdOrders |
Public property | U_PurOrders |
Public property | U_Remarks |
Public property | U_Returns |
Public property | U_ShipDoc |
Public property | U_TxtCode |
Public property | U_TxtName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IItemText Interface
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.DS_GrName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_GrName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_GrName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_GrName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_GrName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.U_GrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpCode() : String;
function set U_GrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.U_MSDS Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MSDS() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MSDS {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MSDS {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MSDS() : String;
function set U_MSDS(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.U_Other Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Other() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Other {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Other {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Other() : String;
function set U_Other(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.U_PickLists Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PickLists() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PickLists {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PickLists {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PickLists() : String;
function set U_PickLists(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.U_ProdOrders Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ProdOrders() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ProdOrders {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ProdOrders {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ProdOrders() : String;
function set U_ProdOrders(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.U_PurOrders Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PurOrders() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PurOrders {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PurOrders {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PurOrders() : String;
function set U_PurOrders(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.U_Returns Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Returns() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Returns {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Returns {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Returns() : String;
function set U_Returns(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.U_ShipDoc Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ShipDoc() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ShipDoc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ShipDoc {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ShipDoc() : String;
function set U_ShipDoc(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.U_TxtCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_TxtCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_TxtCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_TxtCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_TxtCode() : String;

   AppEngineProperty(Required = true)
function set U_TxtCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.U_TxtName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TxtName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TxtName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TxtName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TxtName() : String;
function set U_TxtName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemText
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemText Interface
IItemText Members
CompuTec.ProcessForce.API.Documents.ItemText Namespace


IItemText Methods

IItemText Interface See Also

The following tables list the members exposed by the IItemText type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemText Interface
CompuTec.ProcessForce.API.Documents.ItemText Namespace


CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IItemTextGroup | Item text group object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IItemTextGroup Interface

Members See Also

Item text group object

Namespace: CompuTec.ProcessForce.API.Documents.ItemTextGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ItemTextGroup", TableName = "@CT_PF_OITG", UDOVersion = "UDO_10")> _
Public Interface IItemTextGroup
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemTextGroup", TableName = "@CT_PF_OITG", UDOVersion = "UDO_10")]
public interface IItemTextGroup : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ItemTextGroup", TableName = "@CT_PF_OITG", UDOVersion = "UDO_10")]
public interface class IItemTextGroup : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ItemTextGroup", TableName = "@CT_PF_OITG", UDOVersion = "UDO_10")
interface IItemTextGroup
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OITG
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemTextGroup Members
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


IItemTextGroup Members

IItemTextGroup Interface Methods Properties See Also

Item text group object

The following tables list the members exposed by the IItemTextGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode |
Public property | U_GrpDescription |
Public property | U_GrpName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemTextGroup Interface
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


IItemTextGroup Properties

IItemTextGroup Interface See Also

The following tables list the members exposed by the IItemTextGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode |
Public property | U_GrpDescription |
Public property | U_GrpName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IItemTextGroup Interface
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


IItemTextGroup.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemTextGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemTextGroup Interface
IItemTextGroup Members
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


IItemTextGroup.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemTextGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemTextGroup Interface
IItemTextGroup Members
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


IItemTextGroup.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemTextGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemTextGroup Interface
IItemTextGroup Members
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


IItemTextGroup.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemTextGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemTextGroup Interface
IItemTextGroup Members
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


IItemTextGroup.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemTextGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemTextGroup Interface
IItemTextGroup Members
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


IItemTextGroup.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemTextGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemTextGroup Interface
IItemTextGroup Members
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


IItemTextGroup.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemTextGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemTextGroup Interface
IItemTextGroup Members
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


IItemTextGroup.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemTextGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemTextGroup Interface
IItemTextGroup Members
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


IItemTextGroup.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemTextGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemTextGroup Interface
IItemTextGroup Members
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


IItemTextGroup.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemTextGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemTextGroup Interface
IItemTextGroup Members
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


IItemTextGroup.U_GrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemTextGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_GrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_GrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_GrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_GrpCode() : String;

   AppEngineProperty(Required = true)
function set U_GrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemTextGroup Interface
IItemTextGroup Members
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


IItemTextGroup.U_GrpDescription Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemTextGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpDescription() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpDescription {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpDescription {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpDescription() : String;
function set U_GrpDescription(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemTextGroup Interface
IItemTextGroup Members
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


IItemTextGroup.U_GrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemTextGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpName() : String;
function set U_GrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemTextGroup Interface
IItemTextGroup Members
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


IItemTextGroup.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemTextGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemTextGroup Interface
IItemTextGroup Members
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


IItemTextGroup.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemTextGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemTextGroup Interface
IItemTextGroup Members
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


IItemTextGroup.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.ItemTextGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemTextGroup Interface
IItemTextGroup Members
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


IItemTextGroup Methods

IItemTextGroup Interface See Also

The following tables list the members exposed by the IItemTextGroup type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IItemTextGroup Interface
CompuTec.ProcessForce.API.Documents.ItemTextGroup Namespace


CompuTec.ProcessForce.API.Documents.Label Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ILabel | Label object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ILabel Interface

Members See Also

Label object

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "Label", TableName = "@CT_PF_OLAB", UDOVersion = "UDO_10")> _
Public Interface ILabel
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Label", TableName = "@CT_PF_OLAB", UDOVersion = "UDO_10")]
public interface ILabel : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Label", TableName = "@CT_PF_OLAB", UDOVersion = "UDO_10")]
public interface class ILabel : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "Label", TableName = "@CT_PF_OLAB", UDOVersion = "UDO_10")
interface ILabel
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OLAB
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel Members

ILabel Interface Methods Properties See Also

Label object

The following tables list the members exposed by the ILabel type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_FileName |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_LabelCode |
Public property | U_LabelName |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetData | Gets the Base64 data of a label.
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | LoadFromFile | Loads the label layout data from a file.
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ILabel Interface
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel Properties

ILabel Interface See Also

The following tables list the members exposed by the ILabel type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_FileName |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_LabelCode |
Public property | U_LabelName |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

ILabel Interface
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Interface
ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Interface
ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Interface
ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Interface
ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel.DS_FileName Property

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_FileName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_FileName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_FileName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_FileName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Interface
ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Interface
ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Interface
ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Interface
ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Interface
ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Interface
ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Interface
ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel.U_LabelCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LabelCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LabelCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LabelCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LabelCode() : String;
function set U_LabelCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Interface
ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel.U_LabelName Property

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LabelName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LabelName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LabelName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LabelName() : String;
function set U_LabelName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Interface
ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Interface
ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Interface
ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Interface
ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Interface
ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel Methods

ILabel Interface See Also

The following tables list the members exposed by the ILabel type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetData | Gets the Base64 data of a label.
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | LoadFromFile | Loads the label layout data from a file.
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ILabel Interface
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel.GetData Method

Gets the Base64 data of a label.

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetData() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string GetData()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

String^ GetData()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetData() : String;
This language is not supported or no code example is available.

Return Value

Type: string

The string representation of label layout data.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Interface
ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


ILabel.LoadFromFile Method

Loads the label layout data from a file.

Namespace: CompuTec.ProcessForce.API.Documents.Label
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function LoadFromFile( _
   ByVal filePath As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool LoadFromFile(
   string filePath
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool LoadFromFile(
   String^ filePath
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function LoadFromFile(
    filePath : String
) : boolean;
This language is not supported or no code example is available.

Parameters

filePath

Type: string

A path to file with label layout data.

Return Value

Type: bool

A Boolean value that indicates whether the file data was successfully loaded or not.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabel Interface
ILabel Members
CompuTec.ProcessForce.API.Documents.Label Namespace


CompuTec.ProcessForce.API.Documents.LabourGroup Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ILabourGroup | Labour group object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ILabourGroup Interface

Members See Also

Labour group object

Namespace: CompuTec.ProcessForce.API.Documents.LabourGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "LabourGroup", TableName = "@CT_PC_OLGR", UDOVersion = "UDO_10")> _
Public Interface ILabourGroup
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "LabourGroup", TableName = "@CT_PC_OLGR", UDOVersion = "UDO_10")]
public interface ILabourGroup : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "LabourGroup", TableName = "@CT_PC_OLGR", UDOVersion = "UDO_10")]
public interface class ILabourGroup : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "LabourGroup", TableName = "@CT_PC_OLGR", UDOVersion = "UDO_10")
interface ILabourGroup
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PC_OLGR
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabourGroup Members
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


ILabourGroup Members

ILabourGroup Interface Methods Properties See Also

Labour group object

The following tables list the members exposed by the ILabourGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpType |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ILabourGroup Interface
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


ILabourGroup Properties

ILabourGroup Interface See Also

The following tables list the members exposed by the ILabourGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpType |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

ILabourGroup Interface
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


ILabourGroup.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.LabourGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabourGroup Interface
ILabourGroup Members
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


ILabourGroup.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.LabourGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabourGroup Interface
ILabourGroup Members
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


ILabourGroup.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.LabourGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabourGroup Interface
ILabourGroup Members
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


ILabourGroup.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.LabourGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabourGroup Interface
ILabourGroup Members
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


ILabourGroup.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.LabourGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabourGroup Interface
ILabourGroup Members
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


ILabourGroup.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.LabourGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabourGroup Interface
ILabourGroup Members
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


ILabourGroup.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.LabourGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabourGroup Interface
ILabourGroup Members
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


ILabourGroup.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.LabourGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabourGroup Interface
ILabourGroup Members
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


ILabourGroup.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.LabourGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabourGroup Interface
ILabourGroup Members
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


ILabourGroup.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.LabourGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabourGroup Interface
ILabourGroup Members
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


ILabourGroup.U_GrpType Property

Namespace: CompuTec.ProcessForce.API.Documents.LabourGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpType() : String;
function set U_GrpType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabourGroup Interface
ILabourGroup Members
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


ILabourGroup.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.LabourGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabourGroup Interface
ILabourGroup Members
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


ILabourGroup.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.LabourGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabourGroup Interface
ILabourGroup Members
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


ILabourGroup.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.LabourGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabourGroup Interface
ILabourGroup Members
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


ILabourGroup.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.LabourGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabourGroup Interface
ILabourGroup Members
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


ILabourGroup.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.LabourGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILabourGroup Interface
ILabourGroup Members
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


ILabourGroup Methods

ILabourGroup Interface See Also

The following tables list the members exposed by the ILabourGroup type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ILabourGroup Interface
CompuTec.ProcessForce.API.Documents.LabourGroup Namespace


CompuTec.ProcessForce.API.Documents.LicencePlate Namespace

Batch numbers for license plate object

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)
Name of table in database
CT_PF_LPL2
Classes
 | Name | Description
 | LicencePlateManager |
Public class | LicencePlateStatusConstants |
Public class | ManageType |
Top
Interfaces
 | Name | Description
Public interface | ILicencePlate | License plate object
Public interface | ILicencePlateBatchNumbers |
Public interface | ILicencePlateItems |
Public interface | ILicencePlateSerialNumbers |
Top
Structures
 | Name | Description
Public structure | BatchNumber |
Public structure | SerialNumber |
Top
Enumerations
 | Name | Description
Public enumeration | LicencePlateStatus | Represents a collection of available statuses for License Plates.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


LicencePlateManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class LicencePlateManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static class LicencePlateManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class LicencePlateManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class LicencePlateManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.LicencePlate.LicencePlateManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LicencePlateManager Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


LicencePlateManager Members

LicencePlateManager Class Methods See Also

The following tables list the members exposed by the LicencePlateManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | ExtractLicencePlateCodeFromOITMCode | Extracts License Plate Code from ItemMasterData ItemCode
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetLicencePlateCode |
 | GetLicencePlatePrefix | Gets License Plate prefix from configuration object.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

LicencePlateManager Class
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


LicencePlateManager Methods

LicencePlateManager Class See Also

The following tables list the members exposed by the LicencePlateManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | ExtractLicencePlateCodeFromOITMCode | Extracts License Plate Code from ItemMasterData ItemCode
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetLicencePlateCode |
 | GetLicencePlatePrefix | Gets License Plate prefix from configuration object.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

LicencePlateManager Class
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


LicencePlateManager.ExtractLicencePlateCodeFromOITMCode Method

Extracts License Plate Code from ItemMasterData ItemCode

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function ExtractLicencePlateCodeFromOITMCode( _
   ByVal itemMasterDataCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string ExtractLicencePlateCodeFromOITMCode(
   string itemMasterDataCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ ExtractLicencePlateCodeFromOITMCode(
   String^ itemMasterDataCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function ExtractLicencePlateCodeFromOITMCode(
    itemMasterDataCode : String
) : String;
This language is not supported or no code example is available.

Parameters

itemMasterDataCode

Type: string

ItemMasterData ItemCode

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LicencePlateManager Class
LicencePlateManager Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


LicencePlateManager.GetLicencePlateCode Method

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetLicencePlateCode( _
   ByVal token As String, _
   ByVal licensePlateCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetLicencePlateCode(
   string token,
   string licensePlateCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetLicencePlateCode(
   String^ token,
   String^ licensePlateCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetLicencePlateCode(
    token : String,
    licensePlateCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

licensePlateCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LicencePlateManager Class
LicencePlateManager Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


LicencePlateManager.GetLicencePlatePrefix Method

Gets License Plate prefix from configuration object.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetLicencePlatePrefix( _
   ByVal Token As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetLicencePlatePrefix(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetLicencePlatePrefix(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetLicencePlatePrefix(
    Token : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: string

A License Plate prefix.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LicencePlateManager Class
LicencePlateManager Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


LicencePlateStatusConstants Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class LicencePlateStatusConstants
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class LicencePlateStatusConstants
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class LicencePlateStatusConstants
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class LicencePlateStatusConstants
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.LicencePlate.LicencePlateStatusConstants
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LicencePlateStatusConstants Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


LicencePlateStatusConstants Members

LicencePlateStatusConstants Class Methods Fields See Also

The following tables list the members exposed by the LicencePlateStatusConstants type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
Name | Description
InProgess |
RegisteredStatus |
TEMP |
UnregisteredStatus |
Top
See Also

Reference

LicencePlateStatusConstants Class
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


LicencePlateStatusConstants Methods

LicencePlateStatusConstants Class See Also

The following tables list the members exposed by the LicencePlateStatusConstants type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

LicencePlateStatusConstants Class
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


LicencePlateStatusConstants Fields

LicencePlateStatusConstants Class See Also

The following tables list the members exposed by the LicencePlateStatusConstants type.

Fields
Name | Description
InProgess |
RegisteredStatus |
TEMP |
UnregisteredStatus |
Top
See Also

Reference

LicencePlateStatusConstants Class
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


InProgess Field

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared InProgess As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string InProgess
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ InProgess;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static InProgess : String
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LicencePlateStatusConstants Class
LicencePlateStatusConstants Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


RegisteredStatus Field

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared RegisteredStatus As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string RegisteredStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ RegisteredStatus;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static RegisteredStatus : String
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LicencePlateStatusConstants Class
LicencePlateStatusConstants Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


TEMP Field

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared TEMP As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string TEMP
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ TEMP;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static TEMP : String
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LicencePlateStatusConstants Class
LicencePlateStatusConstants Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


UnregisteredStatus Field

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared UnregisteredStatus As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string UnregisteredStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ UnregisteredStatus;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static UnregisteredStatus : String
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LicencePlateStatusConstants Class
LicencePlateStatusConstants Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ManageType Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public NotInheritable Class ManageType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public sealed class ManageType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ManageType sealed
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public final class ManageType
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.LicencePlate.ManageType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ManageType Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ManageType Members

ManageType Class Methods Fields See Also

The following tables list the members exposed by the ManageType type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | BATCH_NUMBERS |
Public field | NONE |
Public field | SERIAL_NUMBERS |
Top
See Also

Reference

ManageType Class
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ManageType Methods

ManageType Class See Also

The following tables list the members exposed by the ManageType type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ManageType Class
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ManageType Fields

ManageType Class See Also

The following tables list the members exposed by the ManageType type.

Fields
 | Name | Description
Public field | BATCH_NUMBERS |
Public field | NONE |
Public field | SERIAL_NUMBERS |
Top
See Also

Reference

ManageType Class
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


BATCH_NUMBERS Field

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const BATCH_NUMBERS As String = "BatchNumbers"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string BATCH_NUMBERS = @"BatchNumbers"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ BATCH_NUMBERS = "BatchNumbers";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const BATCH_NUMBERS : String = "BatchNumbers"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ManageType Class
ManageType Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


NONE Field

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const NONE As String = "None"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string NONE = @"None"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ NONE = "None";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const NONE : String = "None"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ManageType Class
ManageType Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


SERIAL_NUMBERS Field

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const SERIAL_NUMBERS As String = "SerialNumbers"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string SERIAL_NUMBERS = @"SerialNumbers"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ SERIAL_NUMBERS = "SerialNumbers";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const SERIAL_NUMBERS : String = "SerialNumbers"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ManageType Class
ManageType Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate Interface

Members See Also

License plate object

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "LicensePlate", TableName = "@CT_PF_OLPL")> _
Public Interface ILicencePlate
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "LicensePlate", TableName = "@CT_PF_OLPL")]
public interface ILicencePlate : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "LicensePlate", TableName = "@CT_PF_OLPL")]
public interface class ILicencePlate : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "LicensePlate", TableName = "@CT_PF_OLPL")
interface ILicencePlate
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OLPL
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate Members

ILicencePlate Interface Methods Properties See Also

License plate object

The following tables list the members exposed by the ILicencePlate type.

Properties
 | Name | Description
Public property | BatchNumbers | License Plate lines: Batch Numbers
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Items | License Plate lines: Items
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | OutType |
Public property | SerialNumbers | License Plate lines: Serial Numbers
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrossWgt |
Public property | U_IsSavedInDatabase | Specifies if License Plate is saved in database.
Public property | U_LplCode | Uniquely identifies an entry in License Plate table.
Public property | U_LplGrpCode | License Plate group code.
Public property | U_Name | License Plate name.
Public property | U_Remarks | Remarks
Public property | U_Status | License Plate status.
Public property | U_WhsCode | Specifies Warehouse for the License Plate.
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | ChangeWarehouseCode | Registers a change of Warehouse for a License Plate.
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetByLplCode | Saves Virtual License Plate as standard License Plate. Do not use it on License Plate.
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | GetLicencePlateStatus | Gets the current status of a License Plate.
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Register | Registers the License Plate.
Public method | Unregister | Unregisters the License Plate.
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ILicencePlate Interface
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate Properties

ILicencePlate Interface See Also

The following tables list the members exposed by the ILicencePlate type.

Properties
 | Name | Description
Public property | BatchNumbers | License Plate lines: Batch Numbers
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Items | License Plate lines: Items
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | OutType |
Public property | SerialNumbers | License Plate lines: Serial Numbers
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrossWgt |
Public property | U_IsSavedInDatabase | Specifies if License Plate is saved in database.
Public property | U_LplCode | Uniquely identifies an entry in License Plate table.
Public property | U_LplGrpCode | License Plate group code.
Public property | U_Name | License Plate name.
Public property | U_Remarks | Remarks
Public property | U_Status | License Plate status.
Public property | U_WhsCode | Specifies Warehouse for the License Plate.
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

ILicencePlate Interface
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.BatchNumbers Property

License Plate lines: Batch Numbers

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BatchNumbers() As ILicencePlateBatchNumbers
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ILicencePlateBatchNumbers BatchNumbers {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ILicencePlateBatchNumbers^ BatchNumbers {
 ILicencePlateBatchNumbers^ get( );
 void set(
   ILicencePlateBatchNumbers^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BatchNumbers() : ILicencePlateBatchNumbers;
function set BatchNumbers(value : ILicencePlateBatchNumbers);
This language is not supported or no code example is available.

Property Value

Type: ILicencePlateBatchNumbers
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.Items Property

License Plate lines: Items

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Items() As ILicencePlateItems
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ILicencePlateItems Items {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ILicencePlateItems^ Items {
 ILicencePlateItems^ get( );
 void set(
   ILicencePlateItems^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Items() : ILicencePlateItems;
function set Items(value : ILicencePlateItems);
This language is not supported or no code example is available.

Property Value

Type: ILicencePlateItems
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.OutType Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property OutType() As PF_LplOutType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
PF_LplOutType OutType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property PF_LplOutType OutType {
 PF_LplOutType get( );
 void set(
   PF_LplOutType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OutType() : PF_LplOutType;
function set OutType(value : PF_LplOutType);
This language is not supported or no code example is available.

Property Value

Type: PF_LplOutType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.SerialNumbers Property

License Plate lines: Serial Numbers

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property SerialNumbers() As ILicencePlateSerialNumbers
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ILicencePlateSerialNumbers SerialNumbers {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ILicencePlateSerialNumbers^ SerialNumbers {
 ILicencePlateSerialNumbers^ get( );
 void set(
   ILicencePlateSerialNumbers^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get SerialNumbers() : ILicencePlateSerialNumbers;
function set SerialNumbers(value : ILicencePlateSerialNumbers);
This language is not supported or no code example is available.

Property Value

Type: ILicencePlateSerialNumbers
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.U_GrossWgt Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrossWgt() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_GrossWgt {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_GrossWgt {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrossWgt() : double;
function set U_GrossWgt(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.U_IsSavedInDatabase Property

Specifies if License Plate is saved in database.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IsSavedInDatabase() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool U_IsSavedInDatabase {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool U_IsSavedInDatabase {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IsSavedInDatabase() : boolean;
function set U_IsSavedInDatabase(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.U_LplCode Property

Uniquely identifies an entry in License Plate table.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
ReadOnly Property U_LplCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_LplCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_LplCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_LplCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.U_LplGrpCode Property

License Plate group code.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LplGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LplGrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LplGrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LplGrpCode() : String;
function set U_LplGrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.U_Name Property

License Plate name.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Name() : String;
function set U_Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.U_Remarks Property

Remarks

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.U_Status Property

License Plate status.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Status {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Status() : String;
function set U_Status(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.U_WhsCode Property

Specifies Warehouse for the License Plate.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate Methods

ILicencePlate Interface See Also

The following tables list the members exposed by the ILicencePlate type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | ChangeWarehouseCode | Registers a change of Warehouse for a License Plate.
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetByLplCode | Saves Virtual License Plate as standard License Plate. Do not use it on License Plate.
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | GetLicencePlateStatus | Gets the current status of a License Plate.
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Register | Registers the License Plate.
Public method | Unregister | Unregisters the License Plate.
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ILicencePlate Interface
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.ChangeWarehouseCode Method

Registers a change of Warehouse for a License Plate.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function ChangeWarehouseCode( _
   ByVal whsCode As String, _
   ByVal inputQuantity As Boolean _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool ChangeWarehouseCode(
   string whsCode,
   bool inputQuantity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool ChangeWarehouseCode(
   String^ whsCode,
   bool inputQuantity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function ChangeWarehouseCode(
    whsCode : String,
    inputQuantity : boolean
) : boolean;
This language is not supported or no code example is available.

Parameters

whsCode

Type: string

A code of the warehouse.

inputQuantity

Type: bool

Indicates wheter the quantity is the input or output quantity.

Return Value

Type: bool

A Boolean value that indicates wheter the unregistering operation has been completed successfully or not.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.GetByLplCode Method

Saves Virtual License Plate as standard License Plate. Do not use it on License Plate.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByLplCode( _
   ByVal lplCode As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByLplCode(
   string lplCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByLplCode(
   String^ lplCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByLplCode(
    lplCode : String
) : int;
This language is not supported or no code example is available.

Parameters

lplCode

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.GetLicencePlateStatus Method

Gets the current status of a License Plate.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetLicencePlateStatus() As LicencePlateStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
LicencePlateStatus GetLicencePlateStatus()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

LicencePlateStatus GetLicencePlateStatus()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetLicencePlateStatus() : LicencePlateStatus;
This language is not supported or no code example is available.

Return Value

Type: LicencePlateStatus

The CompuTec.ProcessForce.API.Documents.LicensePlate.LicensePlateStatus value.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.Register Method

Registers the License Plate.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function Register() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool Register()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool Register()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Register() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool

A Boolean value that indicates wheter the registering operation has been completed successfully or not.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlate.Unregister Method

Unregisters the License Plate.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function Unregister() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool Unregister()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool Unregister()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Unregister() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool

A Boolean value that indicates wheter the unregistering operation has been completed successfully or not.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlate Interface
ILicencePlate Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateBatchNumbers Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface ILicencePlateBatchNumbers
    Inherits IUDOChildBean, _
             IEnumerable(Of ILicencePlateBatchNumbers)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface ILicencePlateBatchNumbers : IUDOChildBean,
   IEnumerable<ILicencePlateBatchNumbers>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class ILicencePlateBatchNumbers : public IUDOChildBean^,
   public IEnumerable<ILicencePlateBatchNumbers^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateBatchNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateBatchNumbers Members

ILicencePlateBatchNumbers Interface Methods Properties See Also

The following tables list the members exposed by the ILicencePlateBatchNumbers type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | QtySelected |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BnDistNumber | Batch number name.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_LplBatchNumCode | Uniquely identifies an entry in License Plate Batch Numbers table. For internal use only.
Public property | U_LplCode | Key to the License Plate table.
Public property | U_LplItmsCode | Key to the License Plate Items table.
Public property | U_Qty | Batch Number quantity selected for License Plate.
Public property | XQty |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ILicencePlateBatchNumbers Interface
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateBatchNumbers Properties

ILicencePlateBatchNumbers Interface See Also

The following tables list the members exposed by the ILicencePlateBatchNumbers type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | QtySelected |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BnDistNumber | Batch number name.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_LplBatchNumCode | Uniquely identifies an entry in License Plate Batch Numbers table. For internal use only.
Public property | U_LplCode | Key to the License Plate table.
Public property | U_LplItmsCode | Key to the License Plate Items table.
Public property | U_Qty | Batch Number quantity selected for License Plate.
Public property | XQty |
Top
See Also

Reference

ILicencePlateBatchNumbers Interface
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateBatchNumbers.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateBatchNumbers Interface
ILicencePlateBatchNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateBatchNumbers.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateBatchNumbers Interface
ILicencePlateBatchNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateBatchNumbers.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateBatchNumbers Interface
ILicencePlateBatchNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateBatchNumbers.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateBatchNumbers Interface
ILicencePlateBatchNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateBatchNumbers.QtySelected Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property QtySelected() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double QtySelected {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double QtySelected {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get QtySelected() : double;
function set QtySelected(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateBatchNumbers Interface
ILicencePlateBatchNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateBatchNumbers.U_BnDistNumber Property

Batch number name.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BnDistNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BnDistNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BnDistNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BnDistNumber() : String;
function set U_BnDistNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateBatchNumbers Interface
ILicencePlateBatchNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateBatchNumbers.U_LplBatchNumCode Property

Uniquely identifies an entry in License Plate Batch Numbers table. For internal use only.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LplBatchNumCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_LplBatchNumCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_LplBatchNumCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LplBatchNumCode() : int;
function set U_LplBatchNumCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateBatchNumbers Interface
ILicencePlateBatchNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateBatchNumbers.U_LplCode Property

Key to the License Plate table.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
ReadOnly Property U_LplCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_LplCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_LplCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_LplCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateBatchNumbers Interface
ILicencePlateBatchNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateBatchNumbers.U_LplItmsCode Property

Key to the License Plate Items table.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LplItmsCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_LplItmsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_LplItmsCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LplItmsCode() : int;
function set U_LplItmsCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateBatchNumbers Interface
ILicencePlateBatchNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateBatchNumbers.U_Qty Property

Batch Number quantity selected for License Plate.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Qty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Qty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Qty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Qty() : double;
function set U_Qty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateBatchNumbers Interface
ILicencePlateBatchNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateBatchNumbers.XQty Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property XQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double XQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double XQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get XQty() : double;
function set XQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateBatchNumbers Interface
ILicencePlateBatchNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateBatchNumbers Methods

ILicencePlateBatchNumbers Interface See Also

The following tables list the members exposed by the ILicencePlateBatchNumbers type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ILicencePlateBatchNumbers Interface
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ILicencePlateItems
    Inherits IUDOChildBean, _
             IEnumerable(Of ILicencePlateItems)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ILicencePlateItems : IUDOChildBean,
   IEnumerable<ILicencePlateItems>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ILicencePlateItems : public IUDOChildBean^,
   public IEnumerable<ILicencePlateItems^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateItems Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems Members

ILicencePlateItems Interface Methods Properties See Also

The following tables list the members exposed by the ILicencePlateItems type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DsRowNum |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_IsClosed |
Public property | U_ItemCode | ItemCode for an item as specified in ItemMasterData.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_LplCode | Key to the License Plate table.
Public property | U_LplComp | Specifies if an item is itself a license plate.
Public property | U_LplItmsCode | Key to the License Plate batch numbers and License Plate serial numbers tables.
Public property | U_MngType | Specifies manage type for an item.
Public property | U_Qty | The amount of an item that will put on a license plate.
Public property | U_QtyLeft | Amount which remains. This value is the difference between quantity value for an item and amount which has been already selected.
Public property | U_QtySel | Amount which has been selected.
Public property | WhsCode | Obsolete.
Public property | XQty |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ILicencePlateItems Interface
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems Properties

ILicencePlateItems Interface See Also

The following tables list the members exposed by the ILicencePlateItems type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DsRowNum |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_IsClosed |
Public property | U_ItemCode | ItemCode for an item as specified in ItemMasterData.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_LplCode | Key to the License Plate table.
Public property | U_LplComp | Specifies if an item is itself a license plate.
Public property | U_LplItmsCode | Key to the License Plate batch numbers and License Plate serial numbers tables.
Public property | U_MngType | Specifies manage type for an item.
Public property | U_Qty | The amount of an item that will put on a license plate.
Public property | U_QtyLeft | Amount which remains. This value is the difference between quantity value for an item and amount which has been already selected.
Public property | U_QtySel | Amount which has been selected.
Public property | WhsCode | Obsolete.
Public property | XQty |
Top
See Also

Reference

ILicencePlateItems Interface
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateItems Interface
ILicencePlateItems Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems.DsRowNum Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DsRowNum() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DsRowNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DsRowNum {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DsRowNum() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateItems Interface
ILicencePlateItems Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateItems Interface
ILicencePlateItems Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateItems Interface
ILicencePlateItems Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateItems Interface
ILicencePlateItems Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems.U_IsClosed Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IsClosed() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool U_IsClosed {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool U_IsClosed {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IsClosed() : boolean;
function set U_IsClosed(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateItems Interface
ILicencePlateItems Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems.U_ItemCode Property

ItemCode for an item as specified in ItemMasterData.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateItems Interface
ILicencePlateItems Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems.U_LplCode Property

Key to the License Plate table.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_LplCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LplCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LplCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LplCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateItems Interface
ILicencePlateItems Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems.U_LplComp Property

Specifies if an item is itself a license plate.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LplComp() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_LplComp {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_LplComp {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LplComp() : int;
function set U_LplComp(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateItems Interface
ILicencePlateItems Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems.U_LplItmsCode Property

Key to the License Plate batch numbers and License Plate serial numbers tables.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LplItmsCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_LplItmsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_LplItmsCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LplItmsCode() : int;
function set U_LplItmsCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateItems Interface
ILicencePlateItems Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems.U_MngType Property

Specifies manage type for an item.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MngType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MngType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MngType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MngType() : String;
function set U_MngType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateItems Interface
ILicencePlateItems Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems.U_Qty Property

The amount of an item that will put on a license plate.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Qty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Qty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Qty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Qty() : double;
function set U_Qty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateItems Interface
ILicencePlateItems Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems.U_QtyLeft Property

Amount which remains. This value is the difference between quantity value for an item and amount which has been already selected.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QtyLeft() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_QtyLeft {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_QtyLeft {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QtyLeft() : double;
function set U_QtyLeft(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateItems Interface
ILicencePlateItems Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems.U_QtySel Property

Amount which has been selected.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QtySel() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_QtySel {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_QtySel {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QtySel() : double;
function set U_QtySel(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateItems Interface
ILicencePlateItems Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems.WhsCode Property

Obsolete.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WhsCode() : String;
function set WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateItems Interface
ILicencePlateItems Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems.XQty Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property XQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double XQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double XQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get XQty() : double;
function set XQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateItems Interface
ILicencePlateItems Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateItems Methods

ILicencePlateItems Interface See Also

The following tables list the members exposed by the ILicencePlateItems type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ILicencePlateItems Interface
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateSerialNumbers Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ILicencePlateSerialNumbers
    Inherits IUDOChildBean, _
             IEnumerable(Of ILicencePlateSerialNumbers)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ILicencePlateSerialNumbers : IUDOChildBean,
   IEnumerable<ILicencePlateSerialNumbers>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ILicencePlateSerialNumbers : public IUDOChildBean^,
   public IEnumerable<ILicencePlateSerialNumbers^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateSerialNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateSerialNumbers Members

ILicencePlateSerialNumbers Interface Methods Properties See Also

The following tables list the members exposed by the ILicencePlateSerialNumbers type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | Picked | For information Purpose only it should be hide from DIUsers
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_LplCode | Key to the License Plate table.
Public property | U_LplItmsCode | Key to the License Plate Items table.
Public property | U_LplSerialNumCode | Uniquely identifies an entry in License Plate Serial Numbers table. For internal use only.
Public property | U_SnDistNumber | Internal Serial Number name.
Public property | U_SnLotNumber | Unique Batch Number name.
Public property | U_SnMnfSerial | Manufacturer's serial number name.
Public property | U_SnSysNumber | Uniquely identifies Serial Number.
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ILicencePlateSerialNumbers Interface
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateSerialNumbers Properties

ILicencePlateSerialNumbers Interface See Also

The following tables list the members exposed by the ILicencePlateSerialNumbers type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | Picked | For information Purpose only it should be hide from DIUsers
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_LplCode | Key to the License Plate table.
Public property | U_LplItmsCode | Key to the License Plate Items table.
Public property | U_LplSerialNumCode | Uniquely identifies an entry in License Plate Serial Numbers table. For internal use only.
Public property | U_SnDistNumber | Internal Serial Number name.
Public property | U_SnLotNumber | Unique Batch Number name.
Public property | U_SnMnfSerial | Manufacturer's serial number name.
Public property | U_SnSysNumber | Uniquely identifies Serial Number.
Top
See Also

Reference

ILicencePlateSerialNumbers Interface
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateSerialNumbers.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateSerialNumbers Interface
ILicencePlateSerialNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateSerialNumbers.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateSerialNumbers Interface
ILicencePlateSerialNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateSerialNumbers.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateSerialNumbers Interface
ILicencePlateSerialNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateSerialNumbers.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateSerialNumbers Interface
ILicencePlateSerialNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateSerialNumbers.Picked Property

For information Purpose only it should be hide from DIUsers

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Picked() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool Picked {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool Picked {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Picked() : boolean;
function set Picked(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateSerialNumbers Interface
ILicencePlateSerialNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateSerialNumbers.U_LplCode Property

Key to the License Plate table.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_LplCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LplCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LplCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LplCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateSerialNumbers Interface
ILicencePlateSerialNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateSerialNumbers.U_LplItmsCode Property

Key to the License Plate Items table.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LplItmsCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_LplItmsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_LplItmsCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LplItmsCode() : int;
function set U_LplItmsCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateSerialNumbers Interface
ILicencePlateSerialNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateSerialNumbers.U_LplSerialNumCode Property

Uniquely identifies an entry in License Plate Serial Numbers table. For internal use only.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LplSerialNumCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_LplSerialNumCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_LplSerialNumCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LplSerialNumCode() : int;
function set U_LplSerialNumCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateSerialNumbers Interface
ILicencePlateSerialNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateSerialNumbers.U_SnDistNumber Property

Internal Serial Number name.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SnDistNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SnDistNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SnDistNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SnDistNumber() : String;
function set U_SnDistNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateSerialNumbers Interface
ILicencePlateSerialNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateSerialNumbers.U_SnLotNumber Property

Unique Batch Number name.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SnLotNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SnLotNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SnLotNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SnLotNumber() : String;
function set U_SnLotNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateSerialNumbers Interface
ILicencePlateSerialNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateSerialNumbers.U_SnMnfSerial Property

Manufacturer's serial number name.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SnMnfSerial() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SnMnfSerial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SnMnfSerial {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SnMnfSerial() : String;
function set U_SnMnfSerial(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateSerialNumbers Interface
ILicencePlateSerialNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateSerialNumbers.U_SnSysNumber Property

Uniquely identifies Serial Number.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SnSysNumber() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SnSysNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SnSysNumber {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SnSysNumber() : int;
function set U_SnSysNumber(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateSerialNumbers Interface
ILicencePlateSerialNumbers Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


ILicencePlateSerialNumbers Methods

ILicencePlateSerialNumbers Interface See Also

The following tables list the members exposed by the ILicencePlateSerialNumbers type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ILicencePlateSerialNumbers Interface
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


BatchNumber Structure

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Structure BatchNumber
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public struct BatchNumber
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public value struct BatchNumber
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript suports the use of structures, but not the declaration of new ones.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumber Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


BatchNumber Members

BatchNumber Structure Properties See Also

The following tables list the members exposed by the BatchNumber type.

Properties
 | Name | Description
Public property | DistNum |
Public property | ItemCode |
Public property | LotNumber |
Public property | MnfSerial |
Public property | WhsCode |
Top
See Also

Reference

BatchNumber Structure
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


BatchNumber Properties

BatchNumber Structure See Also

The following tables list the members exposed by the BatchNumber type.

Properties
 | Name | Description
Public property | DistNum |
Public property | ItemCode |
Public property | LotNumber |
Public property | MnfSerial |
Public property | WhsCode |
Top
See Also

Reference

BatchNumber Structure
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


BatchNumber.DistNum Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DistNum() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DistNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DistNum {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DistNum() : String;
public function set DistNum(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumber Structure
BatchNumber Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


BatchNumber.ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ItemCode() : String;
public function set ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumber Structure
BatchNumber Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


BatchNumber.LotNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property LotNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string LotNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ LotNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get LotNumber() : String;
public function set LotNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumber Structure
BatchNumber Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


BatchNumber.MnfSerial Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property MnfSerial() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string MnfSerial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ MnfSerial {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get MnfSerial() : String;
public function set MnfSerial(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumber Structure
BatchNumber Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


BatchNumber.WhsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get WhsCode() : String;
public function set WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumber Structure
BatchNumber Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


SerialNumber Structure

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Structure SerialNumber
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public struct SerialNumber
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public value struct SerialNumber
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript suports the use of structures, but not the declaration of new ones.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SerialNumber Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


SerialNumber Members

SerialNumber Structure Properties See Also

The following tables list the members exposed by the SerialNumber type.

Properties
 | Name | Description
Public property | DistNum |
Public property | ItemCode |
Public property | LotNumber |
Public property | MnfSerial |
Public property | WhsCode |
Top
See Also

Reference

SerialNumber Structure
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


SerialNumber Properties

SerialNumber Structure See Also

The following tables list the members exposed by the SerialNumber type.

Properties
 | Name | Description
Public property | DistNum |
Public property | ItemCode |
Public property | LotNumber |
Public property | MnfSerial |
Public property | WhsCode |
Top
See Also

Reference

SerialNumber Structure
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


SerialNumber.DistNum Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DistNum() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DistNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DistNum {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DistNum() : String;
public function set DistNum(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SerialNumber Structure
SerialNumber Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


SerialNumber.ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ItemCode() : String;
public function set ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SerialNumber Structure
SerialNumber Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


SerialNumber.LotNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property LotNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string LotNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ LotNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get LotNumber() : String;
public function set LotNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SerialNumber Structure
SerialNumber Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


SerialNumber.MnfSerial Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property MnfSerial() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string MnfSerial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ MnfSerial {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get MnfSerial() : String;
public function set MnfSerial(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SerialNumber Structure
SerialNumber Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


SerialNumber.WhsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get WhsCode() : String;
public function set WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SerialNumber Structure
SerialNumber Members
CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


LicencePlateStatus Enumeration

Represents a collection of available statuses for License Plates.

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Registered | Registration of a License Plate.
Unregistered | Unregistration of a License Plate.
Unknown | Unknown status.
InProgress |
See Also

Reference

CompuTec.ProcessForce.API.Documents.LicencePlate Namespace


CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace

License plate group object

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)
Name of table in database
CT_PF_OLPG
Interfaces
 | Name | Description
Public interface | ILicencePlateGroup |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ILicencePlateGroup Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlateGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "LicensePlateGroup", TableName = "@CT_PF_OLPG")> _
Public Interface ILicencePlateGroup
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "LicensePlateGroup", TableName = "@CT_PF_OLPG")]
public interface ILicencePlateGroup : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "LicensePlateGroup", TableName = "@CT_PF_OLPG")]
public interface class ILicencePlateGroup : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "LicensePlateGroup", TableName = "@CT_PF_OLPG")
interface ILicencePlateGroup
   implements IUDOBean
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateGroup Members
CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace


ILicencePlateGroup Members

ILicencePlateGroup Interface Methods Properties See Also

The following tables list the members exposed by the ILicencePlateGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_LplGrpCode |
Public property | U_LplGrpName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ILicencePlateGroup Interface
CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace


ILicencePlateGroup Properties

ILicencePlateGroup Interface See Also

The following tables list the members exposed by the ILicencePlateGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_LplGrpCode |
Public property | U_LplGrpName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

ILicencePlateGroup Interface
CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace


ILicencePlateGroup.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlateGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateGroup Interface
ILicencePlateGroup Members
CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace


ILicencePlateGroup.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlateGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateGroup Interface
ILicencePlateGroup Members
CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace


ILicencePlateGroup.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlateGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateGroup Interface
ILicencePlateGroup Members
CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace


ILicencePlateGroup.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlateGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateGroup Interface
ILicencePlateGroup Members
CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace


ILicencePlateGroup.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlateGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateGroup Interface
ILicencePlateGroup Members
CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace


ILicencePlateGroup.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlateGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateGroup Interface
ILicencePlateGroup Members
CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace


ILicencePlateGroup.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlateGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateGroup Interface
ILicencePlateGroup Members
CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace


ILicencePlateGroup.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlateGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateGroup Interface
ILicencePlateGroup Members
CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace


ILicencePlateGroup.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlateGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateGroup Interface
ILicencePlateGroup Members
CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace


ILicencePlateGroup.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlateGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateGroup Interface
ILicencePlateGroup Members
CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace


ILicencePlateGroup.U_LplGrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlateGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_LplGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_LplGrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_LplGrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_LplGrpCode() : String;

   AppEngineProperty(Required = true)
function set U_LplGrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateGroup Interface
ILicencePlateGroup Members
CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace


ILicencePlateGroup.U_LplGrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlateGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LplGrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LplGrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LplGrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LplGrpName() : String;
function set U_LplGrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateGroup Interface
ILicencePlateGroup Members
CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace


ILicencePlateGroup.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlateGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateGroup Interface
ILicencePlateGroup Members
CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace


ILicencePlateGroup.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlateGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateGroup Interface
ILicencePlateGroup Members
CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace


ILicencePlateGroup.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.LicencePlateGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILicencePlateGroup Interface
ILicencePlateGroup Members
CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace


ILicencePlateGroup Methods

ILicencePlateGroup Interface See Also

The following tables list the members exposed by the ILicencePlateGroup type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ILicencePlateGroup Interface
CompuTec.ProcessForce.API.Documents.LicencePlateGroup Namespace


CompuTec.ProcessForce.API.Documents.MRP.Forecast Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IRows | Forecast rows.
Top
Enumerations
 | Name | Description
Public enumeration | ViewType | Represents the available view types for forecasts.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IRows Interface

Members See Also

Forecast rows.

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Forecast
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IRows
    Inherits IUDOChildBean, _
             IEnumerable(Of IRows)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IRows : IUDOChildBean,
   IEnumerable<IRows>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IRows : public IUDOChildBean^,
   public IEnumerable<IRows^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRows Members
CompuTec.ProcessForce.API.Documents.MRP.Forecast Namespace


IRows Members

IRows Interface Methods Properties See Also

Forecast rows.

The following tables list the members exposed by the IRows type.

Properties
 | Name | Description
Public property | Code | Code.
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId | Line ID.
Public property | LogInst | History instance ID.
Public property | Object | UDO object ID.
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BranchCode | Branch code.
Public property | U_Date | Date.
Public property | U_ItemCode | Item code.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Quantity | Quantity.
Public property | U_RevCode | Revision code.
Public property | U_WhsCode | Warehouse code.
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IRows Interface
CompuTec.ProcessForce.API.Documents.MRP.Forecast Namespace


IRows Properties

IRows Interface See Also

The following tables list the members exposed by the IRows type.

Properties
 | Name | Description
Public property | Code | Code.
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId | Line ID.
Public property | LogInst | History instance ID.
Public property | Object | UDO object ID.
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BranchCode | Branch code.
Public property | U_Date | Date.
Public property | U_ItemCode | Item code.
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Quantity | Quantity.
Public property | U_RevCode | Revision code.
Public property | U_WhsCode | Warehouse code.
Top
See Also

Reference

IRows Interface
CompuTec.ProcessForce.API.Documents.MRP.Forecast Namespace


IRows.Code Property

Code.

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Forecast
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRows Interface
IRows Members
CompuTec.ProcessForce.API.Documents.MRP.Forecast Namespace


IRows.LineId Property

Line ID.

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Forecast
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRows Interface
IRows Members
CompuTec.ProcessForce.API.Documents.MRP.Forecast Namespace


IRows.LogInst Property

History instance ID.

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Forecast
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRows Interface
IRows Members
CompuTec.ProcessForce.API.Documents.MRP.Forecast Namespace


IRows.Object Property

UDO object ID.

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Forecast
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRows Interface
IRows Members
CompuTec.ProcessForce.API.Documents.MRP.Forecast Namespace


IRows.U_BranchCode Property

Branch code.

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Forecast
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BranchCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BranchCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BranchCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BranchCode() : String;
function set U_BranchCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRows Interface
IRows Members
CompuTec.ProcessForce.API.Documents.MRP.Forecast Namespace


IRows.U_Date Property

Date.

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Forecast
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Date() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Date {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Date {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Date() : DateTime;
function set U_Date(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRows Interface
IRows Members
CompuTec.ProcessForce.API.Documents.MRP.Forecast Namespace


IRows.U_ItemCode Property

Item code.

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Forecast
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRows Interface
IRows Members
CompuTec.ProcessForce.API.Documents.MRP.Forecast Namespace


IRows.U_Quantity Property

Quantity.

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Forecast
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRows Interface
IRows Members
CompuTec.ProcessForce.API.Documents.MRP.Forecast Namespace


IRows.U_RevCode Property

Revision code.

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Forecast
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevCode() : String;
function set U_RevCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRows Interface
IRows Members
CompuTec.ProcessForce.API.Documents.MRP.Forecast Namespace


IRows.U_WhsCode Property

Warehouse code.

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Forecast
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRows Interface
IRows Members
CompuTec.ProcessForce.API.Documents.MRP.Forecast Namespace


IRows Methods

IRows Interface See Also

The following tables list the members exposed by the IRows type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IRows Interface
CompuTec.ProcessForce.API.Documents.MRP.Forecast Namespace


ViewType Enumeration

Represents the available view types for forecasts.

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Forecast
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Daily | Daily view.
Weekly | Weekly view.
Monthly | Monthly view.
See Also

Reference

CompuTec.ProcessForce.API.Documents.MRP.Forecast Namespace


CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IScanarioItems |
Public interface | IScenario |
Public interface | IScenarioForecast |
Public interface | IScenarioRestrictions |
Public interface | IScenarioWhsInfo |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IScanarioItems Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IScanarioItems
    Inherits IUDOChildBean, _
             IEnumerable(Of IScanarioItems)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IScanarioItems : IUDOChildBean,
   IEnumerable<IScanarioItems>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IScanarioItems : public IUDOChildBean^,
   public IEnumerable<IScanarioItems^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScanarioItems Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScanarioItems Members

IScanarioItems Interface Methods Properties See Also

The following tables list the members exposed by the IScanarioItems type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_ComponentWarehouse |
Public property | DS_ItemName |
Public property | DS_LeadTime |
Public property | DS_MinimumOrderQty |
Public property | DS_OrderInterval |
Public property | DS_OrderMultiple |
Public property | DS_ProcurementMethod |
Public property | DS_ToleranceDay |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ItemCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Revision |
Public property | U_Selected |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IScanarioItems Interface
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScanarioItems Properties

IScanarioItems Interface See Also

The following tables list the members exposed by the IScanarioItems type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_ComponentWarehouse |
Public property | DS_ItemName |
Public property | DS_LeadTime |
Public property | DS_MinimumOrderQty |
Public property | DS_OrderInterval |
Public property | DS_OrderMultiple |
Public property | DS_ProcurementMethod |
Public property | DS_ToleranceDay |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ItemCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Revision |
Public property | U_Selected |
Top
See Also

Reference

IScanarioItems Interface
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScanarioItems.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScanarioItems Interface
IScanarioItems Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScanarioItems.DS_ComponentWarehouse Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property DS_ComponentWarehouse() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
string DS_ComponentWarehouse {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property String^ DS_ComponentWarehouse {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get DS_ComponentWarehouse() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScanarioItems Interface
IScanarioItems Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScanarioItems.DS_ItemName Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property DS_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
string DS_ItemName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property String^ DS_ItemName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get DS_ItemName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScanarioItems Interface
IScanarioItems Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScanarioItems.DS_LeadTime Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property DS_LeadTime() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
int DS_LeadTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property int DS_LeadTime {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get DS_LeadTime() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScanarioItems Interface
IScanarioItems Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScanarioItems.DS_MinimumOrderQty Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property DS_MinimumOrderQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
double DS_MinimumOrderQty {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property double DS_MinimumOrderQty {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get DS_MinimumOrderQty() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScanarioItems Interface
IScanarioItems Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScanarioItems.DS_OrderInterval Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property DS_OrderInterval() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
string DS_OrderInterval {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property String^ DS_OrderInterval {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get DS_OrderInterval() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScanarioItems Interface
IScanarioItems Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScanarioItems.DS_OrderMultiple Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property DS_OrderMultiple() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
double DS_OrderMultiple {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property double DS_OrderMultiple {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get DS_OrderMultiple() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScanarioItems Interface
IScanarioItems Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScanarioItems.DS_ProcurementMethod Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property DS_ProcurementMethod() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
string DS_ProcurementMethod {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property String^ DS_ProcurementMethod {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get DS_ProcurementMethod() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScanarioItems Interface
IScanarioItems Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScanarioItems.DS_ToleranceDay Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property DS_ToleranceDay() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
int DS_ToleranceDay {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property int DS_ToleranceDay {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get DS_ToleranceDay() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScanarioItems Interface
IScanarioItems Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScanarioItems.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScanarioItems Interface
IScanarioItems Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScanarioItems.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScanarioItems Interface
IScanarioItems Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScanarioItems.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScanarioItems Interface
IScanarioItems Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScanarioItems.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScanarioItems Interface
IScanarioItems Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScanarioItems.U_Revision Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Revision() : String;
function set U_Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScanarioItems Interface
IScanarioItems Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScanarioItems.U_Selected Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_Selected() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_Selected {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_Selected {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_Selected() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_Selected(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScanarioItems Interface
IScanarioItems Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScanarioItems Methods

IScanarioItems Interface See Also

The following tables list the members exposed by the IScanarioItems type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IScanarioItems Interface
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "Scenario", TableName = "@CT_PF_OSCE")> _
Public Interface IScenario
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Scenario", TableName = "@CT_PF_OSCE")]
public interface IScenario : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Scenario", TableName = "@CT_PF_OSCE")]
public interface class IScenario : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "Scenario", TableName = "@CT_PF_OSCE")
interface IScenario
   implements IUDOBean
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario Members

IScenario Interface Methods Properties See Also

The following tables list the members exposed by the IScenario type.

Properties
 | Name | Description
Public property | Code |
Public property | DS_UpdatedBy |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Forecasts |
Public property | Items |
Public property | Name |
Public property | Restrictions |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_AllItems |
Public property | U_BPLId |
Public property | U_BatchExpDate |
Public property | U_BatchExpFrom |
Public property | U_BatchExpTo |
Public property | U_BatchLocked |
Public property | U_BatchNotAcc |
Public property | U_BatchReleased |
Public property | U_ConsHolidaysProd |
Public property | U_ConsHolidaysPur |
Public property | U_ConsUpSO |
Public property | U_DispItmNoReq |
Public property | U_DispSelctItemOnly |
Public property | U_EndDate |
Public property | U_ExclOnItems |
Public property | U_Forecast |
Public property | U_IgnoreCumulativeLT |
Public property | U_IncHisData |
Public property | U_IncludeRevision |
Public property | U_InvTrReq |
Public property | U_LastExecutedDate |
Public property | U_LeadTimeForMakeItems |
Public property | U_MRPMode |
Public property | U_ManOrdr |
Public property | U_PAgreements |
Public property | U_Period |
Public property | U_PeriodLength |
Public property | U_Planner1Level |
Public property | U_Planner2Level |
Public property | U_PurOrder |
Public property | U_PurQuot |
Public property | U_PurReq |
Public property | U_RcmConsumeMtd |
Public property | U_RcmDaysBack |
Public property | U_RcmDaysFwrd |
Public property | U_RcmDefWhse |
Public property | U_RcmMOR |
Public property | U_RcmPO |
Public property | U_RcmSaved |
Public property | U_RcmWTRQ |
Public property | U_ReForecast |
Public property | U_ReInvLvl |
Public property | U_ReInvTrReq |
Public property | U_ReItems |
Public property | U_ReManOrdr |
Public property | U_RePAgreements |
Public property | U_RePurOrder |
Public property | U_RePurQuot |
Public property | U_RePurReq |
Public property | U_ReRecPur |
Public property | U_ReRecSales |
Public property | U_ReResrvInv |
Public property | U_ReSAgreements |
Public property | U_ReSalsOrdr |
Public property | U_ReSalsQuot |
Public property | U_RecPur |
Public property | U_RecSales |
Public property | U_ReservationProps |
Public property | U_ReserveInvoice |
Public property | U_Result |
Public property | U_SAgreements |
Public property | U_SalesOrder |
Public property | U_SalesQuotation |
Public property | U_ScenarioOwner |
Public property | U_Simulation |
Public property | U_SortBy |
Public property | U_StartDate |
Public property | U_Status |
Public property | U_UseInternalLeadTime |
Public property | U_UserSign2 |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | Warehouses |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IScenario Interface
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario Properties

IScenario Interface See Also

The following tables list the members exposed by the IScenario type.

Properties
 | Name | Description
Public property | Code |
Public property | DS_UpdatedBy |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Forecasts |
Public property | Items |
Public property | Name |
Public property | Restrictions |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_AllItems |
Public property | U_BPLId |
Public property | U_BatchExpDate |
Public property | U_BatchExpFrom |
Public property | U_BatchExpTo |
Public property | U_BatchLocked |
Public property | U_BatchNotAcc |
Public property | U_BatchReleased |
Public property | U_ConsHolidaysProd |
Public property | U_ConsHolidaysPur |
Public property | U_ConsUpSO |
Public property | U_DispItmNoReq |
Public property | U_DispSelctItemOnly |
Public property | U_EndDate |
Public property | U_ExclOnItems |
Public property | U_Forecast |
Public property | U_IgnoreCumulativeLT |
Public property | U_IncHisData |
Public property | U_IncludeRevision |
Public property | U_InvTrReq |
Public property | U_LastExecutedDate |
Public property | U_LeadTimeForMakeItems |
Public property | U_MRPMode |
Public property | U_ManOrdr |
Public property | U_PAgreements |
Public property | U_Period |
Public property | U_PeriodLength |
Public property | U_Planner1Level |
Public property | U_Planner2Level |
Public property | U_PurOrder |
Public property | U_PurQuot |
Public property | U_PurReq |
Public property | U_RcmConsumeMtd |
Public property | U_RcmDaysBack |
Public property | U_RcmDaysFwrd |
Public property | U_RcmDefWhse |
Public property | U_RcmMOR |
Public property | U_RcmPO |
Public property | U_RcmSaved |
Public property | U_RcmWTRQ |
Public property | U_ReForecast |
Public property | U_ReInvLvl |
Public property | U_ReInvTrReq |
Public property | U_ReItems |
Public property | U_ReManOrdr |
Public property | U_RePAgreements |
Public property | U_RePurOrder |
Public property | U_RePurQuot |
Public property | U_RePurReq |
Public property | U_ReRecPur |
Public property | U_ReRecSales |
Public property | U_ReResrvInv |
Public property | U_ReSAgreements |
Public property | U_ReSalsOrdr |
Public property | U_ReSalsQuot |
Public property | U_RecPur |
Public property | U_RecSales |
Public property | U_ReservationProps |
Public property | U_ReserveInvoice |
Public property | U_Result |
Public property | U_SAgreements |
Public property | U_SalesOrder |
Public property | U_SalesQuotation |
Public property | U_ScenarioOwner |
Public property | U_Simulation |
Public property | U_SortBy |
Public property | U_StartDate |
Public property | U_Status |
Public property | U_UseInternalLeadTime |
Public property | U_UserSign2 |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | Warehouses |
Top
See Also

Reference

IScenario Interface
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.DS_UpdatedBy Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property DS_UpdatedBy() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
string DS_UpdatedBy {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property String^ DS_UpdatedBy {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get DS_UpdatedBy() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.Forecasts Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Forecasts() As IScenarioForecast
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IScenarioForecast Forecasts {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IScenarioForecast^ Forecasts {
 IScenarioForecast^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Forecasts() : IScenarioForecast;
This language is not supported or no code example is available.

Property Value

Type: IScenarioForecast
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.Items Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Items() As IScanarioItems
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IScanarioItems Items {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IScanarioItems^ Items {
 IScanarioItems^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Items() : IScanarioItems;
This language is not supported or no code example is available.

Property Value

Type: IScanarioItems
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
function set Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.Restrictions Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Restrictions() As IScenarioRestrictions
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IScenarioRestrictions Restrictions {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IScenarioRestrictions^ Restrictions {
 IScenarioRestrictions^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Restrictions() : IScenarioRestrictions;
This language is not supported or no code example is available.

Property Value

Type: IScenarioRestrictions
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_AllItems Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_AllItems() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_AllItems {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_AllItems {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_AllItems() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_AllItems(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_BPLId Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BPLId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BPLId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BPLId {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BPLId() : int;
function set U_BPLId(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_BatchExpDate Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BatchExpDate() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_BatchExpDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_BatchExpDate {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchExpDate() : YesNoType;
function set U_BatchExpDate(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_BatchExpFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BatchExpFrom() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_BatchExpFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_BatchExpFrom {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchExpFrom() : DateTime;
function set U_BatchExpFrom(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_BatchExpTo Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BatchExpTo() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_BatchExpTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_BatchExpTo {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchExpTo() : DateTime;
function set U_BatchExpTo(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_BatchLocked Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_BatchLocked() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_BatchLocked {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_BatchLocked {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_BatchLocked() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_BatchLocked(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_BatchNotAcc Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_BatchNotAcc() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_BatchNotAcc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_BatchNotAcc {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_BatchNotAcc() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_BatchNotAcc(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_BatchReleased Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_BatchReleased() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_BatchReleased {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_BatchReleased {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_BatchReleased() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_BatchReleased(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_ConsHolidaysProd Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_ConsHolidaysProd() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_ConsHolidaysProd {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_ConsHolidaysProd {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_ConsHolidaysProd() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_ConsHolidaysProd(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_ConsHolidaysPur Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_ConsHolidaysPur() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_ConsHolidaysPur {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_ConsHolidaysPur {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_ConsHolidaysPur() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_ConsHolidaysPur(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_ConsUpSO Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_ConsUpSO() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_ConsUpSO {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_ConsUpSO {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_ConsUpSO() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_ConsUpSO(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_DispItmNoReq Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DispItmNoReq() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_DispItmNoReq {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_DispItmNoReq {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DispItmNoReq() : YesNoType;
function set U_DispItmNoReq(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_DispSelctItemOnly Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DispSelctItemOnly() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_DispSelctItemOnly {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_DispSelctItemOnly {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DispSelctItemOnly() : YesNoType;
function set U_DispSelctItemOnly(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_EndDate Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_EndDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_EndDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EndDate() : DateTime;
function set U_EndDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_ExclOnItems Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ExclOnItems() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_ExclOnItems {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_ExclOnItems {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ExclOnItems() : YesNoType;
function set U_ExclOnItems(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_Forecast Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_Forecast() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_Forecast {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_Forecast {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_Forecast() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_Forecast(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_IgnoreCumulativeLT Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IgnoreCumulativeLT() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_IgnoreCumulativeLT {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_IgnoreCumulativeLT {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IgnoreCumulativeLT() : YesNoType;
function set U_IgnoreCumulativeLT(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_IncHisData Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_IncHisData() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_IncHisData {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_IncHisData {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_IncHisData() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_IncHisData(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_IncludeRevision Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.Yes)> _
Property U_IncludeRevision() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.Yes)]
YesNoType U_IncludeRevision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.Yes)]

property YesNoType U_IncludeRevision {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.Yes)
function get U_IncludeRevision() : YesNoType;

   DefaultValue(YesNoType.Yes)
function set U_IncludeRevision(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_InvTrReq Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_InvTrReq() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_InvTrReq {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_InvTrReq {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_InvTrReq() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_InvTrReq(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_LastExecutedDate Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
Property U_LastExecutedDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
DateTime U_LastExecutedDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property DateTime U_LastExecutedDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get U_LastExecutedDate() : DateTime;

   AppEnginePropertyReadOnly()
function set U_LastExecutedDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_LeadTimeForMakeItems Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LeadTimeForMakeItems() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_LeadTimeForMakeItems {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_LeadTimeForMakeItems {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LeadTimeForMakeItems() : YesNoType;
function set U_LeadTimeForMakeItems(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_MRPMode Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(MRPMode.ByCompany)> _
Property U_MRPMode() As MRPMode
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(MRPMode.ByCompany)]
MRPMode U_MRPMode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(MRPMode.ByCompany)]

property MRPMode U_MRPMode {
 MRPMode get( );
 void set(
   MRPMode value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(MRPMode.ByCompany)
function get U_MRPMode() : MRPMode;

   DefaultValue(MRPMode.ByCompany)
function set U_MRPMode(value : MRPMode);
This language is not supported or no code example is available.

Property Value

Type: MRPMode
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_ManOrdr Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_ManOrdr() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_ManOrdr {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_ManOrdr {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_ManOrdr() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_ManOrdr(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_PAgreements Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_PAgreements() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_PAgreements {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_PAgreements {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_PAgreements() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_PAgreements(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_Period Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(MRPPeriod.Day)> _
Property U_Period() As MRPPeriod
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(MRPPeriod.Day)]
MRPPeriod U_Period {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(MRPPeriod.Day)]

property MRPPeriod U_Period {
 MRPPeriod get( );
 void set(
   MRPPeriod value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(MRPPeriod.Day)
function get U_Period() : MRPPeriod;

   DefaultValue(MRPPeriod.Day)
function set U_Period(value : MRPPeriod);
This language is not supported or no code example is available.

Property Value

Type: MRPPeriod
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_PeriodLength Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
Property U_PeriodLength() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
int U_PeriodLength {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property int U_PeriodLength {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get U_PeriodLength() : int;

   AppEnginePropertyReadOnly()
function set U_PeriodLength(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_Planner1Level Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Planner1Level() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_Planner1Level {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_Planner1Level {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Planner1Level() : int;
function set U_Planner1Level(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_Planner2Level Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Planner2Level() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_Planner2Level {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_Planner2Level {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Planner2Level() : int;
function set U_Planner2Level(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_PurOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_PurOrder() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_PurOrder {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_PurOrder {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_PurOrder() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_PurOrder(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_PurQuot Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_PurQuot() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_PurQuot {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_PurQuot {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_PurQuot() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_PurQuot(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_PurReq Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_PurReq() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_PurReq {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_PurReq {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_PurReq() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_PurReq(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_RcmConsumeMtd Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(MRPConsumtionMethod.backwardForward)> _
Property U_RcmConsumeMtd() As MRPConsumtionMethod
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(MRPConsumtionMethod.backwardForward)]
MRPConsumtionMethod U_RcmConsumeMtd {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(MRPConsumtionMethod.backwardForward)]

property MRPConsumtionMethod U_RcmConsumeMtd {
 MRPConsumtionMethod get( );
 void set(
   MRPConsumtionMethod value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(MRPConsumtionMethod.backwardForward)
function get U_RcmConsumeMtd() : MRPConsumtionMethod;

   DefaultValue(MRPConsumtionMethod.backwardForward)
function set U_RcmConsumeMtd(value : MRPConsumtionMethod);
This language is not supported or no code example is available.

Property Value

Type: MRPConsumtionMethod
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_RcmDaysBack Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RcmDaysBack() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RcmDaysBack {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RcmDaysBack {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RcmDaysBack() : int;
function set U_RcmDaysBack(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_RcmDaysFwrd Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RcmDaysFwrd() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RcmDaysFwrd {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RcmDaysFwrd {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RcmDaysFwrd() : int;
function set U_RcmDaysFwrd(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_RcmDefWhse Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.Yes)> _
Property U_RcmDefWhse() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.Yes)]
YesNoType U_RcmDefWhse {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.Yes)]

property YesNoType U_RcmDefWhse {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.Yes)
function get U_RcmDefWhse() : YesNoType;

   DefaultValue(YesNoType.Yes)
function set U_RcmDefWhse(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_RcmMOR Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.Yes)> _
Property U_RcmMOR() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.Yes)]
YesNoType U_RcmMOR {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.Yes)]

property YesNoType U_RcmMOR {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.Yes)
function get U_RcmMOR() : YesNoType;

   DefaultValue(YesNoType.Yes)
function set U_RcmMOR(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_RcmPO Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_RcmPO() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_RcmPO {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_RcmPO {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_RcmPO() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_RcmPO(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_RcmSaved Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_RcmSaved() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_RcmSaved {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_RcmSaved {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_RcmSaved() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_RcmSaved(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_RcmWTRQ Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_RcmWTRQ() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_RcmWTRQ {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_RcmWTRQ {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_RcmWTRQ() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_RcmWTRQ(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_ReForecast Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_ReForecast() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_ReForecast {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_ReForecast {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_ReForecast() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_ReForecast(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_ReInvLvl Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReInvLvl() As MRPRecomendationInventoryLevel
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
MRPRecomendationInventoryLevel U_ReInvLvl {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property MRPRecomendationInventoryLevel U_ReInvLvl {
 MRPRecomendationInventoryLevel get( );
 void set(
   MRPRecomendationInventoryLevel value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReInvLvl() : MRPRecomendationInventoryLevel;
function set U_ReInvLvl(value : MRPRecomendationInventoryLevel);
This language is not supported or no code example is available.

Property Value

Type: MRPRecomendationInventoryLevel
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_ReInvTrReq Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_ReInvTrReq() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_ReInvTrReq {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_ReInvTrReq {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_ReInvTrReq() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_ReInvTrReq(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_ReItems Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_ReItems() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_ReItems {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_ReItems {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_ReItems() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_ReItems(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_ReManOrdr Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_ReManOrdr() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_ReManOrdr {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_ReManOrdr {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_ReManOrdr() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_ReManOrdr(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_RePAgreements Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_RePAgreements() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_RePAgreements {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_RePAgreements {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_RePAgreements() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_RePAgreements(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_RePurOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_RePurOrder() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_RePurOrder {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_RePurOrder {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_RePurOrder() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_RePurOrder(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_RePurQuot Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_RePurQuot() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_RePurQuot {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_RePurQuot {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_RePurQuot() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_RePurQuot(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_RePurReq Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_RePurReq() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_RePurReq {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_RePurReq {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_RePurReq() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_RePurReq(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_ReRecPur Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_ReRecPur() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_ReRecPur {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_ReRecPur {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_ReRecPur() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_ReRecPur(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_ReRecSales Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_ReRecSales() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_ReRecSales {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_ReRecSales {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_ReRecSales() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_ReRecSales(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_ReResrvInv Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_ReResrvInv() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_ReResrvInv {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_ReResrvInv {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_ReResrvInv() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_ReResrvInv(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_ReSAgreements Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_ReSAgreements() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_ReSAgreements {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_ReSAgreements {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_ReSAgreements() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_ReSAgreements(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_ReSalsOrdr Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_ReSalsOrdr() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_ReSalsOrdr {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_ReSalsOrdr {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_ReSalsOrdr() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_ReSalsOrdr(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_ReSalsQuot Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_ReSalsQuot() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_ReSalsQuot {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_ReSalsQuot {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_ReSalsQuot() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_ReSalsQuot(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_RecPur Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_RecPur() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_RecPur {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_RecPur {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_RecPur() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_RecPur(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_RecSales Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_RecSales() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_RecSales {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_RecSales {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_RecSales() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_RecSales(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_ReservationProps Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_ReservationProps() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_ReservationProps {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_ReservationProps {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_ReservationProps() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_ReservationProps(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_ReserveInvoice Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_ReserveInvoice() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_ReserveInvoice {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_ReserveInvoice {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_ReserveInvoice() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_ReserveInvoice(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_Result Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
Property U_Result() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
string U_Result {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property String^ U_Result {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get U_Result() : String;

   AppEnginePropertyReadOnly()
function set U_Result(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_SAgreements Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_SAgreements() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_SAgreements {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_SAgreements {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_SAgreements() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_SAgreements(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_SalesOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_SalesOrder() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_SalesOrder {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_SalesOrder {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_SalesOrder() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_SalesOrder(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_SalesQuotation Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_SalesQuotation() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_SalesQuotation {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_SalesQuotation {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_SalesQuotation() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_SalesQuotation(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_ScenarioOwner Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ScenarioOwner() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ScenarioOwner {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ScenarioOwner {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ScenarioOwner() : int;
function set U_ScenarioOwner(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_Simulation Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Simulation() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Simulation {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Simulation {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Simulation() : YesNoType;
function set U_Simulation(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_SortBy Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SortBy() As MRPSortBy
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
MRPSortBy U_SortBy {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property MRPSortBy U_SortBy {
 MRPSortBy get( );
 void set(
   MRPSortBy value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SortBy() : MRPSortBy;
function set U_SortBy(value : MRPSortBy);
This language is not supported or no code example is available.

Property Value

Type: MRPSortBy
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_StartDate Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StartDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StartDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StartDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StartDate() : DateTime;
function set U_StartDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_Status Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
Property U_Status() As MRPStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
MRPStatus U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property MRPStatus U_Status {
 MRPStatus get( );
 void set(
   MRPStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get U_Status() : MRPStatus;

   AppEnginePropertyReadOnly()
function set U_Status(value : MRPStatus);
This language is not supported or no code example is available.

Property Value

Type: MRPStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_UseInternalLeadTime Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.Yes)> _
Property U_UseInternalLeadTime() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.Yes)]
YesNoType U_UseInternalLeadTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.Yes)]

property YesNoType U_UseInternalLeadTime {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.Yes)
function get U_UseInternalLeadTime() : YesNoType;

   DefaultValue(YesNoType.Yes)
function set U_UseInternalLeadTime(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.U_UserSign2 Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
Property U_UserSign2() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
int U_UserSign2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property int U_UserSign2 {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get U_UserSign2() : int;

   AppEnginePropertyReadOnly()
function set U_UserSign2(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;

   AppEnginePropertyIgnore()
function set UpdateDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario.Warehouses Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Warehouses() As IScenarioWhsInfo
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IScenarioWhsInfo Warehouses {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IScenarioWhsInfo^ Warehouses {
 IScenarioWhsInfo^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Warehouses() : IScenarioWhsInfo;
This language is not supported or no code example is available.

Property Value

Type: IScenarioWhsInfo
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenario Interface
IScenario Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenario Methods

IScenario Interface See Also

The following tables list the members exposed by the IScenario type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IScenario Interface
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioForecast Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IScenarioForecast
    Inherits IUDOChildBean, _
             IEnumerable(Of IScenarioForecast)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IScenarioForecast : IUDOChildBean,
   IEnumerable<IScenarioForecast>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IScenarioForecast : public IUDOChildBean^,
   public IEnumerable<IScenarioForecast^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioForecast Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioForecast Members

IScenarioForecast Interface Methods Properties See Also

The following tables list the members exposed by the IScenarioForecast type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_EndDate |
Public property | DS_ForecastName |
Public property | DS_StartDate |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ForecastCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Selected |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IScenarioForecast Interface
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioForecast Properties

IScenarioForecast Interface See Also

The following tables list the members exposed by the IScenarioForecast type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_EndDate |
Public property | DS_ForecastName |
Public property | DS_StartDate |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ForecastCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Selected |
Top
See Also

Reference

IScenarioForecast Interface
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioForecast.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioForecast Interface
IScenarioForecast Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioForecast.DS_EndDate Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_EndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime DS_EndDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime DS_EndDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_EndDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioForecast Interface
IScenarioForecast Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioForecast.DS_ForecastName Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_ForecastName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_ForecastName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_ForecastName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_ForecastName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioForecast Interface
IScenarioForecast Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioForecast.DS_StartDate Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property DS_StartDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
DateTime DS_StartDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property DateTime DS_StartDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get DS_StartDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioForecast Interface
IScenarioForecast Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioForecast.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioForecast Interface
IScenarioForecast Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioForecast.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioForecast Interface
IScenarioForecast Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioForecast.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioForecast Interface
IScenarioForecast Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioForecast.U_ForecastCode Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ForecastCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ForecastCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ForecastCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ForecastCode() : String;
function set U_ForecastCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioForecast Interface
IScenarioForecast Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioForecast.U_Selected Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_Selected() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_Selected {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_Selected {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_Selected() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_Selected(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioForecast Interface
IScenarioForecast Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioForecast Methods

IScenarioForecast Interface See Also

The following tables list the members exposed by the IScenarioForecast type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IScenarioForecast Interface
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IScenarioRestrictions
    Inherits IUDOChildBean, _
             IEnumerable(Of IScenarioRestrictions)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IScenarioRestrictions : IUDOChildBean,
   IEnumerable<IScenarioRestrictions>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IScenarioRestrictions : public IUDOChildBean^,
   public IEnumerable<IScenarioRestrictions^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioRestrictions Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions Members

IScenarioRestrictions Interface Methods Properties See Also

The following tables list the members exposed by the IScenarioRestrictions type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_CardCode |
Public property | DS_DocDueDate |
Public property | DS_DocumentDate |
Public property | DS_DocumentNumber |
Public property | DS_EndDate |
Public property | DS_Requester |
Public property | DS_RequiredDate |
Public property | DS_StartDate |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BpType |
Public property | U_Code |
Public property | U_DocEntry |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ObjectCode |
Public property | U_Selected |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IScenarioRestrictions Interface
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions Properties

IScenarioRestrictions Interface See Also

The following tables list the members exposed by the IScenarioRestrictions type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_CardCode |
Public property | DS_DocDueDate |
Public property | DS_DocumentDate |
Public property | DS_DocumentNumber |
Public property | DS_EndDate |
Public property | DS_Requester |
Public property | DS_RequiredDate |
Public property | DS_StartDate |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BpType |
Public property | U_Code |
Public property | U_DocEntry |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_ObjectCode |
Public property | U_Selected |
Top
See Also

Reference

IScenarioRestrictions Interface
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioRestrictions Interface
IScenarioRestrictions Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions.DS_CardCode Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property DS_CardCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
string DS_CardCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property String^ DS_CardCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get DS_CardCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioRestrictions Interface
IScenarioRestrictions Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions.DS_DocDueDate Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_DocDueDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime DS_DocDueDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime DS_DocDueDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_DocDueDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioRestrictions Interface
IScenarioRestrictions Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions.DS_DocumentDate Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_DocumentDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime DS_DocumentDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime DS_DocumentDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_DocumentDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioRestrictions Interface
IScenarioRestrictions Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions.DS_DocumentNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property DS_DocumentNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
string DS_DocumentNumber {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property String^ DS_DocumentNumber {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get DS_DocumentNumber() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioRestrictions Interface
IScenarioRestrictions Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions.DS_EndDate Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_EndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime DS_EndDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime DS_EndDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_EndDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioRestrictions Interface
IScenarioRestrictions Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions.DS_Requester Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property DS_Requester() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
string DS_Requester {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property String^ DS_Requester {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get DS_Requester() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioRestrictions Interface
IScenarioRestrictions Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions.DS_RequiredDate Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_RequiredDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime DS_RequiredDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime DS_RequiredDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_RequiredDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioRestrictions Interface
IScenarioRestrictions Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions.DS_StartDate Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_StartDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime DS_StartDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime DS_StartDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_StartDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioRestrictions Interface
IScenarioRestrictions Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioRestrictions Interface
IScenarioRestrictions Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioRestrictions Interface
IScenarioRestrictions Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioRestrictions Interface
IScenarioRestrictions Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions.U_BpType Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BpType() As CardType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CardType U_BpType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property CardType U_BpType {
 CardType get( );
 void set(
   CardType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BpType() : CardType;
function set U_BpType(value : CardType);
This language is not supported or no code example is available.

Property Value

Type: CardType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioRestrictions Interface
IScenarioRestrictions Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions.U_Code Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Code() : String;
function set U_Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioRestrictions Interface
IScenarioRestrictions Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions.U_DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_DocEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_DocEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DocEntry() : int;
function set U_DocEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioRestrictions Interface
IScenarioRestrictions Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions.U_ObjectCode Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ObjectCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ObjectCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ObjectCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ObjectCode() : String;
function set U_ObjectCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioRestrictions Interface
IScenarioRestrictions Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions.U_Selected Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_Selected() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_Selected {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_Selected {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_Selected() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_Selected(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioRestrictions Interface
IScenarioRestrictions Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioRestrictions Methods

IScenarioRestrictions Interface See Also

The following tables list the members exposed by the IScenarioRestrictions type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IScenarioRestrictions Interface
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IScenarioWhsInfo
    Inherits IUDOChildBean, _
             IEnumerable(Of IScenarioWhsInfo)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IScenarioWhsInfo : IUDOChildBean,
   IEnumerable<IScenarioWhsInfo>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IScenarioWhsInfo : public IUDOChildBean^,
   public IEnumerable<IScenarioWhsInfo^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioWhsInfo Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo Members

IScenarioWhsInfo Interface Methods Properties See Also

The following tables list the members exposed by the IScenarioWhsInfo type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_Location |
Public property | DS_WhsName |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BatchExpDate |
Public property | U_BatchExpFrom |
Public property | U_BatchExpTo |
Public property | U_BatchLocked |
Public property | U_BatchNotAcc |
Public property | U_BatchReleased |
Public property | U_Demand |
Public property | U_InclInventory |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Supply |
Public property | U_WhsCode |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IScenarioWhsInfo Interface
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo Properties

IScenarioWhsInfo Interface See Also

The following tables list the members exposed by the IScenarioWhsInfo type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_Location |
Public property | DS_WhsName |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BatchExpDate |
Public property | U_BatchExpFrom |
Public property | U_BatchExpTo |
Public property | U_BatchLocked |
Public property | U_BatchNotAcc |
Public property | U_BatchReleased |
Public property | U_Demand |
Public property | U_InclInventory |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Supply |
Public property | U_WhsCode |
Top
See Also

Reference

IScenarioWhsInfo Interface
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioWhsInfo Interface
IScenarioWhsInfo Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo.DS_Location Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property DS_Location() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
string DS_Location {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property String^ DS_Location {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get DS_Location() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioWhsInfo Interface
IScenarioWhsInfo Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo.DS_WhsName Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property DS_WhsName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
string DS_WhsName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property String^ DS_WhsName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get DS_WhsName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioWhsInfo Interface
IScenarioWhsInfo Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioWhsInfo Interface
IScenarioWhsInfo Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioWhsInfo Interface
IScenarioWhsInfo Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioWhsInfo Interface
IScenarioWhsInfo Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo.U_BatchExpDate Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BatchExpDate() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_BatchExpDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_BatchExpDate {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchExpDate() : YesNoType;
function set U_BatchExpDate(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioWhsInfo Interface
IScenarioWhsInfo Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo.U_BatchExpFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BatchExpFrom() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_BatchExpFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_BatchExpFrom {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchExpFrom() : DateTime;
function set U_BatchExpFrom(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioWhsInfo Interface
IScenarioWhsInfo Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo.U_BatchExpTo Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BatchExpTo() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_BatchExpTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_BatchExpTo {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchExpTo() : DateTime;
function set U_BatchExpTo(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioWhsInfo Interface
IScenarioWhsInfo Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo.U_BatchLocked Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_BatchLocked() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_BatchLocked {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_BatchLocked {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_BatchLocked() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_BatchLocked(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioWhsInfo Interface
IScenarioWhsInfo Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo.U_BatchNotAcc Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_BatchNotAcc() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_BatchNotAcc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_BatchNotAcc {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_BatchNotAcc() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_BatchNotAcc(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioWhsInfo Interface
IScenarioWhsInfo Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo.U_BatchReleased Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_BatchReleased() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_BatchReleased {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_BatchReleased {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_BatchReleased() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_BatchReleased(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioWhsInfo Interface
IScenarioWhsInfo Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo.U_Demand Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.Yes)> _
Property U_Demand() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.Yes)]
YesNoType U_Demand {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.Yes)]

property YesNoType U_Demand {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.Yes)
function get U_Demand() : YesNoType;

   DefaultValue(YesNoType.Yes)
function set U_Demand(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioWhsInfo Interface
IScenarioWhsInfo Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo.U_InclInventory Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.No)> _
Property U_InclInventory() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]
YesNoType U_InclInventory {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.No)]

property YesNoType U_InclInventory {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.No)
function get U_InclInventory() : YesNoType;

   DefaultValue(YesNoType.No)
function set U_InclInventory(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioWhsInfo Interface
IScenarioWhsInfo Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo.U_Supply Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DefaultValue(YesNoType.Yes)> _
Property U_Supply() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.Yes)]
YesNoType U_Supply {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DefaultValue(YesNoType.Yes)]

property YesNoType U_Supply {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   DefaultValue(YesNoType.Yes)
function get U_Supply() : YesNoType;

   DefaultValue(YesNoType.Yes)
function set U_Supply(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioWhsInfo Interface
IScenarioWhsInfo Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo.U_WhsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.MRP.Scenario
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScenarioWhsInfo Interface
IScenarioWhsInfo Members
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


IScenarioWhsInfo Methods

IScenarioWhsInfo Interface See Also

The following tables list the members exposed by the IScenarioWhsInfo type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IScenarioWhsInfo Interface
CompuTec.ProcessForce.API.Documents.MRP.Scenario Namespace


CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IMRPOrderRecomendations |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IMRPOrderRecomendations Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "MRPOrderRecomendation", TableName = "@CT_PF_OMRC")> _
Public Interface IMRPOrderRecomendations
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "MRPOrderRecomendation", TableName = "@CT_PF_OMRC")]
public interface IMRPOrderRecomendations : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "MRPOrderRecomendation", TableName = "@CT_PF_OMRC")]
public interface class IMRPOrderRecomendations : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "MRPOrderRecomendation", TableName = "@CT_PF_OMRC")
interface IMRPOrderRecomendations
   implements IUDOBean
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations Members

IMRPOrderRecomendations Interface Methods Properties See Also

The following tables list the members exposed by the IMRPOrderRecomendations type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_CardCode |
Public property | U_DocumentType |
Public property | U_DueDate |
Public property | U_DueTime |
Public property | U_InvntQty |
Public property | U_InvntUoM |
Public property | U_ItemCode |
Public property | U_OpenInvntQty |
Public property | U_Opened |
Public property | U_RecToken |
Public property | U_RecomendationDate |
Public property | U_RecomendationTime |
Public property | U_Remarks |
Public property | U_Revision |
Public property | U_ScenarioCode |
Public property | U_ToWhsCode |
Public property | U_WhsCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IMRPOrderRecomendations Interface
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations Properties

IMRPOrderRecomendations Interface See Also

The following tables list the members exposed by the IMRPOrderRecomendations type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_CardCode |
Public property | U_DocumentType |
Public property | U_DueDate |
Public property | U_DueTime |
Public property | U_InvntQty |
Public property | U_InvntUoM |
Public property | U_ItemCode |
Public property | U_OpenInvntQty |
Public property | U_Opened |
Public property | U_RecToken |
Public property | U_RecomendationDate |
Public property | U_RecomendationTime |
Public property | U_Remarks |
Public property | U_Revision |
Public property | U_ScenarioCode |
Public property | U_ToWhsCode |
Public property | U_WhsCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IMRPOrderRecomendations Interface
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.U_CardCode Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CardCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CardCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CardCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CardCode() : String;
function set U_CardCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.U_DocumentType Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DocumentType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DocumentType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DocumentType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DocumentType() : String;
function set U_DocumentType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.U_DueDate Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DueDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_DueDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_DueDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DueDate() : DateTime;
function set U_DueDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.U_DueTime Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<TimeType()> _
Property U_DueTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[TimeType()]
DateTime U_DueTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[TimeType()]

property DateTime U_DueTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   TimeType()
function get U_DueTime() : DateTime;

   TimeType()
function set U_DueTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.U_InvntQty Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InvntQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_InvntQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_InvntQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InvntQty() : double;
function set U_InvntQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.U_InvntUoM Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InvntUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InvntUoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InvntUoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InvntUoM() : String;
function set U_InvntUoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.U_OpenInvntQty Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OpenInvntQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_OpenInvntQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_OpenInvntQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OpenInvntQty() : double;
function set U_OpenInvntQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.U_Opened Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<EnumType(new int[] { 1, 2 }, new string[] { "Y", "N" }, 1)> _
<DefaultValue(YesNoType.Yes)> _
Property U_Opened() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[EnumType(new int[] { 1, 2 }, new string[] { "Y", "N" }, 1)]
[DefaultValue(YesNoType.Yes)]
YesNoType U_Opened {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[EnumType(new int[] { 1, 2 }, new string[] { "Y", "N" }, 1)]
[DefaultValue(YesNoType.Yes)]

property YesNoType U_Opened {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   EnumType(new int[] { 1, 2 }, new string[] { "Y", "N" }, 1)
   DefaultValue(YesNoType.Yes)
function get U_Opened() : YesNoType;

   EnumType(new int[] { 1, 2 }, new string[] { "Y", "N" }, 1)
   DefaultValue(YesNoType.Yes)
function set U_Opened(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.U_RecToken Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RecToken() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RecToken {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RecToken {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RecToken() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.U_RecomendationDate Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RecomendationDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_RecomendationDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_RecomendationDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RecomendationDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.U_RecomendationTime Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<TimeType()> _
ReadOnly Property U_RecomendationTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[TimeType()]
DateTime U_RecomendationTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[TimeType()]

property DateTime U_RecomendationTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   TimeType()
function get U_RecomendationTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.U_Revision Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Revision() : String;
function set U_Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.U_ScenarioCode Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ScenarioCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ScenarioCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ScenarioCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ScenarioCode() : String;
function set U_ScenarioCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.U_ToWhsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ToWhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ToWhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ToWhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ToWhsCode() : String;
function set U_ToWhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.U_WhsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPOrderRecomendations Interface
IMRPOrderRecomendations Members
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


IMRPOrderRecomendations Methods

IMRPOrderRecomendations Interface See Also

The following tables list the members exposed by the IMRPOrderRecomendations type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IMRPOrderRecomendations Interface
CompuTec.ProcessForce.API.Documents.MRPOrderRecomendations Namespace


CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | BillOfMaterialsNotExistsException |
Public class | BillOfMaterialsNotValidException |
Public class | BillOfMaterialsRevisionsMismmatchException |
Public class | CantChangeBillOfMateriaCodeInThisStatusException |
Public class | CantChangeRevisionRelatedTransactionDetectedException |
Public class | InvalidRevisionException |
Public class | ManufacturingAdvancedRelationsModel |
Public class | NotValidItemException |
Public class | ResourceAlternative |
Public class | ResourceExistsForOperationException |
Public class | RunTimeIsZeroException |
Top
Interfaces
 | Name | Description
Public interface | IManufacturingOrder | Manufacturing Order document
Public interface | IManufacturingOrderAttachments | Attachment of manufacturing order document
Public interface | IManufacturingOrderCoproducts | Coproducts of manufacturing order document
Public interface | IManufacturingOrderDocuments | Documents of manufacturing order document
Public interface | IManufacturingOrderItems | Items of manufacturing order document
Public interface | IManufacturingOrderOperationTimes | Operation times of manufacturing order document
Public interface | IManufacturingOrderPhantoms | Phantoms of manufacturing order document
Public interface | IManufacturingOrderRoutingOperationInputOutput | Input output of routing operations for manufacturing order document
Public interface | IManufacturingOrderRoutingOperationInputOutputProperties | Properties of input output of routing operations for manufacturing order document
Public interface | IManufacturingOrderRoutingOperationProperties | Properties of routing operations for manufacturing order document
Public interface | IManufacturingOrderRoutingOperationRelations | Relations of routing operations for manufacturing order document
Public interface | IManufacturingOrderRoutingOperationResourceProperties | Properties of resources for routing operations for manufacturing order document
Public interface | IManufacturingOrderRoutingOperationResources | Resources for routing operations for manufacturing order document
Public interface | IManufacturingOrderRoutingOperations | Routing operations for manufacturing order document
Public interface | IManufacturingOrderSalesOrders | Sales orders of manufacturing order document
Public interface | IManufacturingOrderScraps | Scraps of manufacturing order document
Top
Enumerations
 | Name | Description
Public enumeration | PFOperationStatus |
Public enumeration | PF_MORSchedulingMthd | Descripes Types of Scheduling Methood
Public enumeration | SplitMode |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


BillOfMaterialsNotExistsException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BillOfMaterialsNotExistsException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BillOfMaterialsNotExistsException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BillOfMaterialsNotExistsException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BillOfMaterialsNotExistsException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.BillOfMaterialsNotExistsException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialsNotExistsException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsNotExistsException Members

BillOfMaterialsNotExistsException Class Constructors Methods Properties See Also

The following tables list the members exposed by the BillOfMaterialsNotExistsException type.

Constructors
 | Name | Description
Public constructor | BillOfMaterialsNotExistsException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BillOfMaterialsNotExistsException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsNotExistsException Constructor

BillOfMaterialsNotExistsException Class See Also

Overload List
Name | Description
BillOfMaterialsNotExistsException() |
BillOfMaterialsNotExistsException(string) |
BillOfMaterialsNotExistsException(string, Exception) |
See Also

Reference

BillOfMaterialsNotExistsException Class
BillOfMaterialsNotExistsException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsNotExistsException Properties

BillOfMaterialsNotExistsException Class See Also

The following tables list the members exposed by the BillOfMaterialsNotExistsException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

BillOfMaterialsNotExistsException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsNotExistsException Methods

BillOfMaterialsNotExistsException Class See Also

The following tables list the members exposed by the BillOfMaterialsNotExistsException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BillOfMaterialsNotExistsException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsNotValidException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BillOfMaterialsNotValidException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BillOfMaterialsNotValidException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BillOfMaterialsNotValidException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BillOfMaterialsNotValidException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.BillOfMaterialsNotValidException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialsNotValidException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsNotValidException Members

BillOfMaterialsNotValidException Class Constructors Methods Properties See Also

The following tables list the members exposed by the BillOfMaterialsNotValidException type.

Constructors
 | Name | Description
Public constructor | BillOfMaterialsNotValidException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BillOfMaterialsNotValidException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsNotValidException Constructor

BillOfMaterialsNotValidException Class See Also

Overload List
Name | Description
BillOfMaterialsNotValidException() |
BillOfMaterialsNotValidException(SerializationInfo, StreamingContext) |
BillOfMaterialsNotValidException(string) |
BillOfMaterialsNotValidException(string, Exception) |
See Also

Reference

BillOfMaterialsNotValidException Class
BillOfMaterialsNotValidException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsNotValidException Properties

BillOfMaterialsNotValidException Class See Also

The following tables list the members exposed by the BillOfMaterialsNotValidException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

BillOfMaterialsNotValidException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsNotValidException Methods

BillOfMaterialsNotValidException Class See Also

The following tables list the members exposed by the BillOfMaterialsNotValidException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BillOfMaterialsNotValidException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsRevisionsMismmatchException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class BillOfMaterialsRevisionsMismmatchException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class BillOfMaterialsRevisionsMismmatchException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class BillOfMaterialsRevisionsMismmatchException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class BillOfMaterialsRevisionsMismmatchException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.BillOfMaterialsRevisionsMismmatchException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialsRevisionsMismmatchException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsRevisionsMismmatchException Members

BillOfMaterialsRevisionsMismmatchException Class Constructors Methods Properties See Also

The following tables list the members exposed by the BillOfMaterialsRevisionsMismmatchException type.

Constructors
 | Name | Description
Public constructor | BillOfMaterialsRevisionsMismmatchException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BillOfMaterialsRevisionsMismmatchException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsRevisionsMismmatchException Constructor

BillOfMaterialsRevisionsMismmatchException Class See Also

Overload List
Name | Description
BillOfMaterialsRevisionsMismmatchException() |
BillOfMaterialsRevisionsMismmatchException(string) |
BillOfMaterialsRevisionsMismmatchException(string, Exception) |
See Also

Reference

BillOfMaterialsRevisionsMismmatchException Class
BillOfMaterialsRevisionsMismmatchException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsRevisionsMismmatchException Properties

BillOfMaterialsRevisionsMismmatchException Class See Also

The following tables list the members exposed by the BillOfMaterialsRevisionsMismmatchException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

BillOfMaterialsRevisionsMismmatchException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsRevisionsMismmatchException Methods

BillOfMaterialsRevisionsMismmatchException Class See Also

The following tables list the members exposed by the BillOfMaterialsRevisionsMismmatchException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BillOfMaterialsRevisionsMismmatchException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


CantChangeBillOfMateriaCodeInThisStatusException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class CantChangeBillOfMateriaCodeInThisStatusException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CantChangeBillOfMateriaCodeInThisStatusException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class CantChangeBillOfMateriaCodeInThisStatusException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CantChangeBillOfMateriaCodeInThisStatusException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.CantChangeBillOfMateriaCodeInThisStatusException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantChangeBillOfMateriaCodeInThisStatusException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


CantChangeBillOfMateriaCodeInThisStatusException Members

CantChangeBillOfMateriaCodeInThisStatusException Class Constructors Methods Properties See Also

The following tables list the members exposed by the CantChangeBillOfMateriaCodeInThisStatusException type.

Constructors
 | Name | Description
Public constructor | CantChangeBillOfMateriaCodeInThisStatusException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

CantChangeBillOfMateriaCodeInThisStatusException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


CantChangeBillOfMateriaCodeInThisStatusException Constructor

CantChangeBillOfMateriaCodeInThisStatusException Class See Also

Overload List
Name | Description
CantChangeBillOfMateriaCodeInThisStatusException(string) |
CantChangeBillOfMateriaCodeInThisStatusException(string, Exception) |
CantChangeBillOfMateriaCodeInThisStatusException() |
See Also

Reference

CantChangeBillOfMateriaCodeInThisStatusException Class
CantChangeBillOfMateriaCodeInThisStatusException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


CantChangeBillOfMateriaCodeInThisStatusException Properties

CantChangeBillOfMateriaCodeInThisStatusException Class See Also

The following tables list the members exposed by the CantChangeBillOfMateriaCodeInThisStatusException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

CantChangeBillOfMateriaCodeInThisStatusException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


CantChangeBillOfMateriaCodeInThisStatusException Methods

CantChangeBillOfMateriaCodeInThisStatusException Class See Also

The following tables list the members exposed by the CantChangeBillOfMateriaCodeInThisStatusException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

CantChangeBillOfMateriaCodeInThisStatusException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


CantChangeRevisionRelatedTransactionDetectedException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class CantChangeRevisionRelatedTransactionDetectedException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class CantChangeRevisionRelatedTransactionDetectedException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class CantChangeRevisionRelatedTransactionDetectedException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class CantChangeRevisionRelatedTransactionDetectedException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.CantChangeRevisionRelatedTransactionDetectedException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantChangeRevisionRelatedTransactionDetectedException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


CantChangeRevisionRelatedTransactionDetectedException Members

CantChangeRevisionRelatedTransactionDetectedException Class Constructors Methods Properties See Also

The following tables list the members exposed by the CantChangeRevisionRelatedTransactionDetectedException type.

Constructors
 | Name | Description
Public constructor | CantChangeRevisionRelatedTransactionDetectedException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

CantChangeRevisionRelatedTransactionDetectedException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


CantChangeRevisionRelatedTransactionDetectedException Constructor

CantChangeRevisionRelatedTransactionDetectedException Class See Also

Overload List
Name | Description
CantChangeRevisionRelatedTransactionDetectedException() |
CantChangeRevisionRelatedTransactionDetectedException(string) |
CantChangeRevisionRelatedTransactionDetectedException(string, Exception) |
See Also

Reference

CantChangeRevisionRelatedTransactionDetectedException Class
CantChangeRevisionRelatedTransactionDetectedException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


CantChangeRevisionRelatedTransactionDetectedException Properties

CantChangeRevisionRelatedTransactionDetectedException Class See Also

The following tables list the members exposed by the CantChangeRevisionRelatedTransactionDetectedException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

CantChangeRevisionRelatedTransactionDetectedException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


CantChangeRevisionRelatedTransactionDetectedException Methods

CantChangeRevisionRelatedTransactionDetectedException Class See Also

The following tables list the members exposed by the CantChangeRevisionRelatedTransactionDetectedException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

CantChangeRevisionRelatedTransactionDetectedException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


InvalidRevisionException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class InvalidRevisionException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class InvalidRevisionException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class InvalidRevisionException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class InvalidRevisionException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.InvalidRevisionException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InvalidRevisionException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


InvalidRevisionException Members

InvalidRevisionException Class Constructors Methods Properties See Also

The following tables list the members exposed by the InvalidRevisionException type.

Constructors
 | Name | Description
Public constructor | InvalidRevisionException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

InvalidRevisionException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


InvalidRevisionException Constructor

InvalidRevisionException Class See Also

Overload List
Name | Description
InvalidRevisionException() |
InvalidRevisionException(string) |
See Also

Reference

InvalidRevisionException Class
InvalidRevisionException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


InvalidRevisionException Properties

InvalidRevisionException Class See Also

The following tables list the members exposed by the InvalidRevisionException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

InvalidRevisionException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


InvalidRevisionException Methods

InvalidRevisionException Class See Also

The following tables list the members exposed by the InvalidRevisionException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

InvalidRevisionException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ManufacturingAdvancedRelationsModel Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ManufacturingAdvancedRelationsModel
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ManufacturingAdvancedRelationsModel
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ManufacturingAdvancedRelationsModel
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ManufacturingAdvancedRelationsModel
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.ManufacturingAdvancedRelationsModel
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ManufacturingAdvancedRelationsModel Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ManufacturingAdvancedRelationsModel Members

ManufacturingAdvancedRelationsModel Class Constructors Methods Properties See Also

The following tables list the members exposed by the ManufacturingAdvancedRelationsModel type.

Constructors
 | Name | Description
Public constructor | ManufacturingAdvancedRelationsModel |
Top
Properties
 | Name | Description
Public property | relationsToBeCreated |
Public property | relationsToBeDeleted |
Public property | relationsToBeUpdated |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsSomethingToBeUpdated |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Classes
 | Name | Description
Public class | RelationPackage |
Top
See Also

Reference

ManufacturingAdvancedRelationsModel Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


RelationPackage Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class RelationPackage
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RelationPackage
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class RelationPackage
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RelationPackage
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.ManufacturingAdvancedRelationsModel.RelationPackage
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RelationPackage Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


RelationPackage Members

RelationPackage Class Constructors Methods Properties See Also

The following tables list the members exposed by the RelationPackage type.

Constructors
 | Name | Description
Public constructor | RelationPackage | (Overloaded)
Top
Properties
 | Name | Description
Public property | relation |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

RelationPackage Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


RelationPackage Constructor

RelationPackage Class See Also

Overload List
Name | Description
RelationPackage() |
RelationPackage(IManufacturingRelations, IManufacturingOrder, IManufacturingOrder) |
RelationPackage(IManufacturingRelations, string) |
See Also

Reference

RelationPackage Class
RelationPackage Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


RelationPackage Properties

RelationPackage Class See Also

The following tables list the members exposed by the RelationPackage type.

Properties
 | Name | Description
Public property | relation |
Top
See Also

Reference

RelationPackage Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


RelationPackage.relation Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property relation() As IManufacturingRelations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IManufacturingRelations relation {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IManufacturingRelations^ relation {
 IManufacturingRelations^ get( );
 void set(
   IManufacturingRelations^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get relation() : IManufacturingRelations;
public function set relation(value : IManufacturingRelations);
This language is not supported or no code example is available.

Property Value

Type: IManufacturingRelations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RelationPackage Class
RelationPackage Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


RelationPackage Methods

RelationPackage Class See Also

The following tables list the members exposed by the RelationPackage type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

RelationPackage Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ManufacturingAdvancedRelationsModel Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ManufacturingAdvancedRelationsModel()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ManufacturingAdvancedRelationsModel()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ManufacturingAdvancedRelationsModel();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ManufacturingAdvancedRelationsModel Class
ManufacturingAdvancedRelationsModel Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ManufacturingAdvancedRelationsModel Properties

ManufacturingAdvancedRelationsModel Class See Also

The following tables list the members exposed by the ManufacturingAdvancedRelationsModel type.

Properties
 | Name | Description
Public property | relationsToBeCreated |
Public property | relationsToBeDeleted |
Public property | relationsToBeUpdated |
Top
See Also

Reference

ManufacturingAdvancedRelationsModel Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ManufacturingAdvancedRelationsModel.relationsToBeCreated Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property relationsToBeCreated() As List(Of RelationPackage)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<RelationPackage> relationsToBeCreated {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<RelationPackage^>^ relationsToBeCreated {
 List<RelationPackage^>^ get( );
 void set(
   List<RelationPackage^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<RelationPackage>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ManufacturingAdvancedRelationsModel Class
ManufacturingAdvancedRelationsModel Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ManufacturingAdvancedRelationsModel.relationsToBeDeleted Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property relationsToBeDeleted() As List(Of String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<string> relationsToBeDeleted {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<String^>^ relationsToBeDeleted {
 List<String^>^ get( );
 void set(
   List<String^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<string>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ManufacturingAdvancedRelationsModel Class
ManufacturingAdvancedRelationsModel Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ManufacturingAdvancedRelationsModel.relationsToBeUpdated Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property relationsToBeUpdated() As Dictionary(Of String, Double)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Dictionary<string, double> relationsToBeUpdated {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Dictionary<String^, double>^ relationsToBeUpdated {
 Dictionary<String^, double>^ get( );
 void set(
   Dictionary<String^, double>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: Dictionary<string, double>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ManufacturingAdvancedRelationsModel Class
ManufacturingAdvancedRelationsModel Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ManufacturingAdvancedRelationsModel Methods

ManufacturingAdvancedRelationsModel Class See Also

The following tables list the members exposed by the ManufacturingAdvancedRelationsModel type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsSomethingToBeUpdated |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ManufacturingAdvancedRelationsModel Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ManufacturingAdvancedRelationsModel.IsSomethingToBeUpdated Method

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function IsSomethingToBeUpdated() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool IsSomethingToBeUpdated()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool IsSomethingToBeUpdated()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function IsSomethingToBeUpdated() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ManufacturingAdvancedRelationsModel Class
ManufacturingAdvancedRelationsModel Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


NotValidItemException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class NotValidItemException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class NotValidItemException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class NotValidItemException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class NotValidItemException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.NotValidItemException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

NotValidItemException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


NotValidItemException Members

NotValidItemException Class Constructors Methods Properties See Also

The following tables list the members exposed by the NotValidItemException type.

Constructors
 | Name | Description
Public constructor | NotValidItemException |
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

NotValidItemException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


NotValidItemException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public NotValidItemException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
NotValidItemException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function NotValidItemException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

NotValidItemException Class
NotValidItemException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


NotValidItemException Properties

NotValidItemException Class See Also

The following tables list the members exposed by the NotValidItemException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

NotValidItemException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


NotValidItemException Methods

NotValidItemException Class See Also

The following tables list the members exposed by the NotValidItemException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

NotValidItemException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ResourceAlternative
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ResourceAlternative
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ResourceAlternative
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ResourceAlternative
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.ResourceAlternative
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative Members

ResourceAlternative Class Constructors Methods Properties See Also

The following tables list the members exposed by the ResourceAlternative type.

Constructors
 | Name | Description
Public constructor | ResourceAlternative | (Overloaded)
Top
Properties
 | Name | Description
Public property | CycleCap |
Public property | Default |
Public property | HasCycles |
Public property | Infinite |
Public property | NrOfResources |
Public property | QueueRate |
Public property | QueueTime |
Public property | QueueTotal |
Public property | ReferenceForMachine |
Public property | Resource |
Public property | ResourceType |
Public property | RunRate |
Public property | RunTime |
Public property | RunTotal |
Public property | SetupAndRunTotal |
Public property | SetupRate |
Public property | SetupTime |
Public property | SetupTotal |
Public property | StockRate |
Public property | StockTime |
Public property | StockTotal |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ResourceAlternative Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative Constructor

ResourceAlternative Class See Also

Overload List
Name | Description
ResourceAlternative() |
ResourceAlternative(string) |
ResourceAlternative(string, ResourceType, bool, bool, string) |
ResourceAlternative(string, ResourceType, bool, bool, string, double, RateType, double, RateType, double, RateType, double, RateType, YesNoType, double, int, TimeSpan, TimeSpan, TimeSpan, TimeSpan, TimeSpan) |
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative Properties

ResourceAlternative Class See Also

The following tables list the members exposed by the ResourceAlternative type.

Properties
 | Name | Description
Public property | CycleCap |
Public property | Default |
Public property | HasCycles |
Public property | Infinite |
Public property | NrOfResources |
Public property | QueueRate |
Public property | QueueTime |
Public property | QueueTotal |
Public property | ReferenceForMachine |
Public property | Resource |
Public property | ResourceType |
Public property | RunRate |
Public property | RunTime |
Public property | RunTotal |
Public property | SetupAndRunTotal |
Public property | SetupRate |
Public property | SetupTime |
Public property | SetupTotal |
Public property | StockRate |
Public property | StockTime |
Public property | StockTotal |
Top
See Also

Reference

ResourceAlternative Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.CycleCap Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property CycleCap() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double CycleCap {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property double CycleCap {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get CycleCap() : double;
public function set CycleCap(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.Default Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Default() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool Default {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool Default {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Default() : boolean;
public function set Default(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.HasCycles Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property HasCycles() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public YesNoType HasCycles {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property YesNoType HasCycles {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get HasCycles() : YesNoType;
public function set HasCycles(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.Infinite Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Infinite() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool Infinite {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool Infinite {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Infinite() : boolean;
public function set Infinite(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.NrOfResources Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property NrOfResources() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int NrOfResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int NrOfResources {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get NrOfResources() : int;
public function set NrOfResources(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.QueueRate Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property QueueRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RateType QueueRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property RateType QueueRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get QueueRate() : RateType;
public function set QueueRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.QueueTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property QueueTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double QueueTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property double QueueTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get QueueTime() : double;
public function set QueueTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.QueueTotal Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property QueueTotal() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan QueueTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property TimeSpan QueueTotal {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get QueueTotal() : TimeSpan;
public function set QueueTotal(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.ReferenceForMachine Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ReferenceForMachine() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ReferenceForMachine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ReferenceForMachine {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ReferenceForMachine() : String;
public function set ReferenceForMachine(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.Resource Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Resource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Resource {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Resource {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Resource() : String;
public function set Resource(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.ResourceType Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ResourceType() As ResourceType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceType ResourceType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property ResourceType ResourceType {
 ResourceType get( );
 void set(
   ResourceType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ResourceType() : ResourceType;
public function set ResourceType(value : ResourceType);
This language is not supported or no code example is available.

Property Value

Type: ResourceType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.RunRate Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property RunRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RateType RunRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property RateType RunRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get RunRate() : RateType;
public function set RunRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.RunTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property RunTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double RunTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property double RunTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get RunTime() : double;
public function set RunTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.RunTotal Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property RunTotal() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan RunTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property TimeSpan RunTotal {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get RunTotal() : TimeSpan;
public function set RunTotal(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.SetupAndRunTotal Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SetupAndRunTotal() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan SetupAndRunTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property TimeSpan SetupAndRunTotal {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SetupAndRunTotal() : TimeSpan;
public function set SetupAndRunTotal(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.SetupRate Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SetupRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RateType SetupRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property RateType SetupRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SetupRate() : RateType;
public function set SetupRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.SetupTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SetupTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double SetupTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property double SetupTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SetupTime() : double;
public function set SetupTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.SetupTotal Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SetupTotal() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan SetupTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property TimeSpan SetupTotal {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SetupTotal() : TimeSpan;
public function set SetupTotal(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.StockRate Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property StockRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RateType StockRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property RateType StockRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get StockRate() : RateType;
public function set StockRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.StockTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property StockTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double StockTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property double StockTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get StockTime() : double;
public function set StockTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative.StockTotal Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property StockTotal() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan StockTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property TimeSpan StockTotal {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get StockTotal() : TimeSpan;
public function set StockTotal(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative Methods

ResourceAlternative Class See Also

The following tables list the members exposed by the ResourceAlternative type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ResourceAlternative Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceExistsForOperationException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class ResourceExistsForOperationException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class ResourceExistsForOperationException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class ResourceExistsForOperationException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class ResourceExistsForOperationException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.ResourceExistsForOperationException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceExistsForOperationException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceExistsForOperationException Members

ResourceExistsForOperationException Class Constructors Methods Properties See Also

The following tables list the members exposed by the ResourceExistsForOperationException type.

Constructors
 | Name | Description
Public constructor | ResourceExistsForOperationException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ResourceExistsForOperationException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceExistsForOperationException Constructor

ResourceExistsForOperationException Class See Also

Overload List
Name | Description
ResourceExistsForOperationException() |
ResourceExistsForOperationException(string) |
ResourceExistsForOperationException(string, Exception) |
See Also

Reference

ResourceExistsForOperationException Class
ResourceExistsForOperationException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceExistsForOperationException Properties

ResourceExistsForOperationException Class See Also

The following tables list the members exposed by the ResourceExistsForOperationException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

ResourceExistsForOperationException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceExistsForOperationException Methods

ResourceExistsForOperationException Class See Also

The following tables list the members exposed by the ResourceExistsForOperationException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ResourceExistsForOperationException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


RunTimeIsZeroException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class RunTimeIsZeroException
    Inherits UDOException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RunTimeIsZeroException : UDOException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class RunTimeIsZeroException : public UDOException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RunTimeIsZeroException
   extends UDOException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Core.UDOException
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.RunTimeIsZeroException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RunTimeIsZeroException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


RunTimeIsZeroException Members

RunTimeIsZeroException Class Constructors Methods Properties See Also

The following tables list the members exposed by the RunTimeIsZeroException type.

Constructors
 | Name | Description
Public constructor | RunTimeIsZeroException |
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | ObjectCode | (inherited from UDOException).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

RunTimeIsZeroException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


RunTimeIsZeroException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RunTimeIsZeroException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RunTimeIsZeroException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RunTimeIsZeroException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RunTimeIsZeroException Class
RunTimeIsZeroException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


RunTimeIsZeroException Properties

RunTimeIsZeroException Class See Also

The following tables list the members exposed by the RunTimeIsZeroException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | ObjectCode | (inherited from UDOException).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

RunTimeIsZeroException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


RunTimeIsZeroException Methods

RunTimeIsZeroException Class See Also

The following tables list the members exposed by the RunTimeIsZeroException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

RunTimeIsZeroException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder Interface

Members See Also

Manufacturing Order document

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ManufacturingOrder", TableName = "@CT_PF_OMOR", ExludedHttpMethods = "DELETE")> _
Public Interface IManufacturingOrder
    Inherits IExtendedUDO, _
             IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ManufacturingOrder", TableName = "@CT_PF_OMOR", ExludedHttpMethods = "DELETE")]
public interface IManufacturingOrder : IExtendedUDO,
   IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ManufacturingOrder", TableName = "@CT_PF_OMOR", ExludedHttpMethods = "DELETE")]
public interface class IManufacturingOrder : public IExtendedUDO^,
   public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ManufacturingOrder", TableName = "@CT_PF_OMOR", ExludedHttpMethods = "DELETE")
interface IManufacturingOrder
   implements IExtendedUDO,
              IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OMOR
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder Members

IManufacturingOrder Interface Methods Properties See Also

Manufacturing Order document

The following tables list the members exposed by the IManufacturingOrder type.

Properties
 | Name | Description
Public property | Attachments | Manufacturing Order Lines: Attachments
Public property | Canceled |
Public property | Coproducts | Manufacturing Order Lines: CoProducts
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DimensionsParams | Manufacturing Order params of distribution rules dimensions
Public property | DocEntry |
Public property | DocNum |
Public property | Documents | Manufacturing Order Lines: Documents
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | Items | Manufacturing Order Lines: Items
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Phantoms | Manufacturing Order Lines: Phantoms
Public property | RecalculateManufacturingTimes |
Public property | RevisionName | The origin type for synchronized SAPbobsCOM.ProductionOrders object.
Public property | RoutingOperationInputOutput | Manufacturing Order Lines: Routing Operation Input/Output
Public property | RoutingOperationInputOutputProperties | Manufacturing Order Lines: Routing Operation Input/Output Properties
Public property | RoutingOperationProperties | Manufacturing Order Lines: Routing Operation Properties
Public property | RoutingOperationRelations |
Public property | RoutingOperationResourceProperties | Manufacturing Order Lines: Routing Operation Resource Properties
Public property | RoutingOperationResources | Manufacturing Order Lines: Routing Operation Resources
Public property | RoutingOperations | Manufacturing Order Lines: Routing Operations
Public property | SalesOrders | Manufacturing Order Lines: Sales Orders
Public property | Scraps | Manufacturing Order Lines: Scraps
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_AbsManTime | Abosolute Manufacturing Time Span -Read Only
Public property | U_ActCost |
Public property | U_ActualQty | Manufacturing Order actual quantity
Public property | U_ActualYield |
Public property | U_BOMCode | Bill of Material code which Manufacturing Order bases on
Public property | U_BatchSize | Batch Size - read only
Public property | U_Classification |
Public property | U_CloseDate | Close Date used when closing MOR as Journal entry posting date
Public property | U_CoproductFormula |
Public property | U_CoproductYield |
Public property | U_CostTotal |
Public property | U_Description | Manufacturing Order finished article description
Public property | U_DistNumber | Batch number holded in MOR is used if Create Batch on Mor Start is enabled i general settings.
Public property | U_Factor | Manufacturing Order factor
Public property | U_FixedCost |
Public property | U_Freeze | Freezes whole manufacturing order on Gant Chart
Public property | U_Instructions |
Public property | U_InventoryUoM | Manufacturing Order unit of measure
Public property | U_ItemCode | Manufacturing Order finished article code
Public property | U_ItemCost |
Public property | U_ItemFormula |
Public property | U_ItemResources |
Public property | U_ItemYield |
Public property | U_JrnlTransId |
Public property | U_OcrCode | Manufacturing Order distribution rule or cost centre code in dimension 1
Public property | U_OcrCode2 | Manufacturing Order distribution rule or cost centre code in dimension 2
Public property | U_OcrCode3 | Manufacturing Order distribution rule or cost centre code in dimension 3
Public property | U_OcrCode4 | Manufacturing Order distribution rule or cost centre code in dimension 4
Public property | U_OcrCode5 | Manufacturing Order distribution rule or cost centre code in dimension 5
Public property | U_ParentMorDocEntry | Parent Manufacturing DocEntry
Public property | U_ParentMorDocNum | Parent Manufacturing DocNum
Public property | U_PlannedEndDate | Manufacturing Order planned end date
Public property | U_PlannedEndTime | Manufacturing Order Planed End Time
Public property | U_PlannedStartDate | Manufacturing Order planned start date
Public property | U_PlannedStartTime | Manufacturing Order Planed Start Time
Public property | U_Price | Manufacturing Order price
Public property | U_Priority | Manufacturing Order priority
Public property | U_ProdType |
Public property | U_Project | Manufacturing Order project code
Public property | U_Quantity | Manufacturing Order quantity
Public property | U_Remarks | Remarks Field For Manufacturing Order
Public property | U_RequiredDate | Manufacturing Order required date
Public property | U_RequiredTime | Manufacturing Order required date
Public property | U_Revision | Manufacturing Order revision code
Public property | U_RevisionName |
Public property | U_ReworkQty | Quantity of reworked items Read only
Public property | U_RtgCode | Manufacturing Order routing code
Public property | U_RtgName |
Public property | U_SchedulingMtd | Manufacturing Order scheduling method
Public property | U_ScrapFormula |
Public property | U_ScrapYield |
Public property | U_Status | Manufacturing Order status
Public property | U_SubcontractorCode | Subcontractor Code Must be filed whetn U_ProdType is set to External
Public property | U_TechInstructions |
Public property | U_TotalQty |
Public property | U_VariableCost |
Public property | U_Warehouse | Manufacturing Order warehouse code
Public property | U_Yield |
Public property | U_YieldFormula |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CalculateManufacturingTimes |
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Clone |
Public method | CreateManufacturingOrdersForSemiProducts | (Overloaded) This method Creates Manufacturing Orders For Semi Products
Public method | CreateProcurmentDocumentForService | Creates Draft for Procrment Document Based On manufacturing Order
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RecalcFormulas | Connect Function to Activate Recalculation Engine on object (inherited from IExtendedUDO).
Public method | RecalcFormulasNew | (inherited from IExtendedUDO).
Public method | RecalcRequired | (Overloaded) (inherited from IExtendedUDO).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IManufacturingOrder Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder Properties

IManufacturingOrder Interface See Also

The following tables list the members exposed by the IManufacturingOrder type.

Properties
 | Name | Description
Public property | Attachments | Manufacturing Order Lines: Attachments
Public property | Canceled |
Public property | Coproducts | Manufacturing Order Lines: CoProducts
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DimensionsParams | Manufacturing Order params of distribution rules dimensions
Public property | DocEntry |
Public property | DocNum |
Public property | Documents | Manufacturing Order Lines: Documents
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | Items | Manufacturing Order Lines: Items
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Phantoms | Manufacturing Order Lines: Phantoms
Public property | RecalculateManufacturingTimes |
Public property | RevisionName | The origin type for synchronized SAPbobsCOM.ProductionOrders object.
Public property | RoutingOperationInputOutput | Manufacturing Order Lines: Routing Operation Input/Output
Public property | RoutingOperationInputOutputProperties | Manufacturing Order Lines: Routing Operation Input/Output Properties
Public property | RoutingOperationProperties | Manufacturing Order Lines: Routing Operation Properties
Public property | RoutingOperationRelations |
Public property | RoutingOperationResourceProperties | Manufacturing Order Lines: Routing Operation Resource Properties
Public property | RoutingOperationResources | Manufacturing Order Lines: Routing Operation Resources
Public property | RoutingOperations | Manufacturing Order Lines: Routing Operations
Public property | SalesOrders | Manufacturing Order Lines: Sales Orders
Public property | Scraps | Manufacturing Order Lines: Scraps
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_AbsManTime | Abosolute Manufacturing Time Span -Read Only
Public property | U_ActCost |
Public property | U_ActualQty | Manufacturing Order actual quantity
Public property | U_ActualYield |
Public property | U_BOMCode | Bill of Material code which Manufacturing Order bases on
Public property | U_BatchSize | Batch Size - read only
Public property | U_Classification |
Public property | U_CloseDate | Close Date used when closing MOR as Journal entry posting date
Public property | U_CoproductFormula |
Public property | U_CoproductYield |
Public property | U_CostTotal |
Public property | U_Description | Manufacturing Order finished article description
Public property | U_DistNumber | Batch number holded in MOR is used if Create Batch on Mor Start is enabled i general settings.
Public property | U_Factor | Manufacturing Order factor
Public property | U_FixedCost |
Public property | U_Freeze | Freezes whole manufacturing order on Gant Chart
Public property | U_Instructions |
Public property | U_InventoryUoM | Manufacturing Order unit of measure
Public property | U_ItemCode | Manufacturing Order finished article code
Public property | U_ItemCost |
Public property | U_ItemFormula |
Public property | U_ItemResources |
Public property | U_ItemYield |
Public property | U_JrnlTransId |
Public property | U_OcrCode | Manufacturing Order distribution rule or cost centre code in dimension 1
Public property | U_OcrCode2 | Manufacturing Order distribution rule or cost centre code in dimension 2
Public property | U_OcrCode3 | Manufacturing Order distribution rule or cost centre code in dimension 3
Public property | U_OcrCode4 | Manufacturing Order distribution rule or cost centre code in dimension 4
Public property | U_OcrCode5 | Manufacturing Order distribution rule or cost centre code in dimension 5
Public property | U_ParentMorDocEntry | Parent Manufacturing DocEntry
Public property | U_ParentMorDocNum | Parent Manufacturing DocNum
Public property | U_PlannedEndDate | Manufacturing Order planned end date
Public property | U_PlannedEndTime | Manufacturing Order Planed End Time
Public property | U_PlannedStartDate | Manufacturing Order planned start date
Public property | U_PlannedStartTime | Manufacturing Order Planed Start Time
Public property | U_Price | Manufacturing Order price
Public property | U_Priority | Manufacturing Order priority
Public property | U_ProdType |
Public property | U_Project | Manufacturing Order project code
Public property | U_Quantity | Manufacturing Order quantity
Public property | U_Remarks | Remarks Field For Manufacturing Order
Public property | U_RequiredDate | Manufacturing Order required date
Public property | U_RequiredTime | Manufacturing Order required date
Public property | U_Revision | Manufacturing Order revision code
Public property | U_RevisionName |
Public property | U_ReworkQty | Quantity of reworked items Read only
Public property | U_RtgCode | Manufacturing Order routing code
Public property | U_RtgName |
Public property | U_SchedulingMtd | Manufacturing Order scheduling method
Public property | U_ScrapFormula |
Public property | U_ScrapYield |
Public property | U_Status | Manufacturing Order status
Public property | U_SubcontractorCode | Subcontractor Code Must be filed whetn U_ProdType is set to External
Public property | U_TechInstructions |
Public property | U_TotalQty |
Public property | U_VariableCost |
Public property | U_Warehouse | Manufacturing Order warehouse code
Public property | U_Yield |
Public property | U_YieldFormula |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IManufacturingOrder Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.Attachments Property

Manufacturing Order Lines: Attachments

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Attachments() As IManufacturingOrderAttachments
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IManufacturingOrderAttachments Attachments {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IManufacturingOrderAttachments^ Attachments {
 IManufacturingOrderAttachments^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Attachments() : IManufacturingOrderAttachments;
This language is not supported or no code example is available.

Property Value

Type: IManufacturingOrderAttachments
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.Coproducts Property

Manufacturing Order Lines: CoProducts

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Coproducts() As IManufacturingOrderCoproducts
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IManufacturingOrderCoproducts Coproducts {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IManufacturingOrderCoproducts^ Coproducts {
 IManufacturingOrderCoproducts^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Coproducts() : IManufacturingOrderCoproducts;
This language is not supported or no code example is available.

Property Value

Type: IManufacturingOrderCoproducts
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.DimensionsParams Property

Manufacturing Order params of distribution rules dimensions

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DimensionsParams() As Dictionary(Of String, IDimensions)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Dictionary<string, IDimensions> DimensionsParams {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Dictionary<String^, IDimensions^>^ DimensionsParams {
 Dictionary<String^, IDimensions^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: Dictionary<string, IDimensions>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.DocNum Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.Documents Property

Manufacturing Order Lines: Documents

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Documents() As IManufacturingOrderDocuments
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IManufacturingOrderDocuments Documents {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IManufacturingOrderDocuments^ Documents {
 IManufacturingOrderDocuments^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Documents() : IManufacturingOrderDocuments;
This language is not supported or no code example is available.

Property Value

Type: IManufacturingOrderDocuments
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.Handwrtten Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Handwrtten() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Handwrtten {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Handwrtten {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Handwrtten() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.Instance Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Instance() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Instance {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Instance {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Instance() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.Items Property

Manufacturing Order Lines: Items

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Items() As IManufacturingOrderItems
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IManufacturingOrderItems Items {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IManufacturingOrderItems^ Items {
 IManufacturingOrderItems^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Items() : IManufacturingOrderItems;
This language is not supported or no code example is available.

Property Value

Type: IManufacturingOrderItems
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.Period Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Period() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Period {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Period {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Period() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.Phantoms Property

Manufacturing Order Lines: Phantoms

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Phantoms() As IManufacturingOrderPhantoms
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IManufacturingOrderPhantoms Phantoms {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IManufacturingOrderPhantoms^ Phantoms {
 IManufacturingOrderPhantoms^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Phantoms() : IManufacturingOrderPhantoms;
This language is not supported or no code example is available.

Property Value

Type: IManufacturingOrderPhantoms
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.RecalculateManufacturingTimes Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property RecalculateManufacturingTimes() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool RecalculateManufacturingTimes {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool RecalculateManufacturingTimes {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RecalculateManufacturingTimes() : boolean;
function set RecalculateManufacturingTimes(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.RevisionName Property

The origin type for synchronized SAPbobsCOM.ProductionOrders object.

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RevisionName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string RevisionName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ RevisionName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RevisionName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.RoutingOperationInputOutput Property

Manufacturing Order Lines: Routing Operation Input/Output

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RoutingOperationInputOutput() As IManufacturingOrderRoutingOperationInputOutput
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IManufacturingOrderRoutingOperationInputOutput RoutingOperationInputOutput {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IManufacturingOrderRoutingOperationInputOutput^ RoutingOperationInputOutput {
 IManufacturingOrderRoutingOperationInputOutput^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RoutingOperationInputOutput() : IManufacturingOrderRoutingOperationInputOutput;
This language is not supported or no code example is available.

Property Value

Type: IManufacturingOrderRoutingOperationInputOutput
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.RoutingOperationInputOutputProperties Property

Manufacturing Order Lines: Routing Operation Input/Output Properties

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RoutingOperationInputOutputProperties() As IManufacturingOrderRoutingOperationInputOutputProperties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IManufacturingOrderRoutingOperationInputOutputProperties RoutingOperationInputOutputProperties {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IManufacturingOrderRoutingOperationInputOutputProperties^ RoutingOperationInputOutputProperties {
 IManufacturingOrderRoutingOperationInputOutputProperties^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RoutingOperationInputOutputProperties() : IManufacturingOrderRoutingOperationInputOutputProperties;
This language is not supported or no code example is available.

Property Value

Type: IManufacturingOrderRoutingOperationInputOutputProperties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.RoutingOperationProperties Property

Manufacturing Order Lines: Routing Operation Properties

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RoutingOperationProperties() As IManufacturingOrderRoutingOperationProperties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IManufacturingOrderRoutingOperationProperties RoutingOperationProperties {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IManufacturingOrderRoutingOperationProperties^ RoutingOperationProperties {
 IManufacturingOrderRoutingOperationProperties^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RoutingOperationProperties() : IManufacturingOrderRoutingOperationProperties;
This language is not supported or no code example is available.

Property Value

Type: IManufacturingOrderRoutingOperationProperties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.RoutingOperationRelations Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RoutingOperationRelations() As IManufacturingOrderRoutingOperationRelations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IManufacturingOrderRoutingOperationRelations RoutingOperationRelations {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IManufacturingOrderRoutingOperationRelations^ RoutingOperationRelations {
 IManufacturingOrderRoutingOperationRelations^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RoutingOperationRelations() : IManufacturingOrderRoutingOperationRelations;
This language is not supported or no code example is available.

Property Value

Type: IManufacturingOrderRoutingOperationRelations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.RoutingOperationResourceProperties Property

Manufacturing Order Lines: Routing Operation Resource Properties

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RoutingOperationResourceProperties() As IManufacturingOrderRoutingOperationResourceProperties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IManufacturingOrderRoutingOperationResourceProperties RoutingOperationResourceProperties {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IManufacturingOrderRoutingOperationResourceProperties^ RoutingOperationResourceProperties {
 IManufacturingOrderRoutingOperationResourceProperties^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RoutingOperationResourceProperties() : IManufacturingOrderRoutingOperationResourceProperties;
This language is not supported or no code example is available.

Property Value

Type: IManufacturingOrderRoutingOperationResourceProperties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.RoutingOperationResources Property

Manufacturing Order Lines: Routing Operation Resources

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RoutingOperationResources() As IManufacturingOrderRoutingOperationResources
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IManufacturingOrderRoutingOperationResources RoutingOperationResources {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IManufacturingOrderRoutingOperationResources^ RoutingOperationResources {
 IManufacturingOrderRoutingOperationResources^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RoutingOperationResources() : IManufacturingOrderRoutingOperationResources;
This language is not supported or no code example is available.

Property Value

Type: IManufacturingOrderRoutingOperationResources
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.RoutingOperations Property

Manufacturing Order Lines: Routing Operations

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RoutingOperations() As IManufacturingOrderRoutingOperations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IManufacturingOrderRoutingOperations RoutingOperations {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IManufacturingOrderRoutingOperations^ RoutingOperations {
 IManufacturingOrderRoutingOperations^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RoutingOperations() : IManufacturingOrderRoutingOperations;
This language is not supported or no code example is available.

Property Value

Type: IManufacturingOrderRoutingOperations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.SalesOrders Property

Manufacturing Order Lines: Sales Orders

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property SalesOrders() As IManufacturingOrderSalesOrders
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IManufacturingOrderSalesOrders SalesOrders {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IManufacturingOrderSalesOrders^ SalesOrders {
 IManufacturingOrderSalesOrders^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get SalesOrders() : IManufacturingOrderSalesOrders;
This language is not supported or no code example is available.

Property Value

Type: IManufacturingOrderSalesOrders
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.Scraps Property

Manufacturing Order Lines: Scraps

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Scraps() As IManufacturingOrderScraps
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IManufacturingOrderScraps Scraps {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IManufacturingOrderScraps^ Scraps {
 IManufacturingOrderScraps^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Scraps() : IManufacturingOrderScraps;
This language is not supported or no code example is available.

Property Value

Type: IManufacturingOrderScraps
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.Series Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Series() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Series {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Series {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Series() : int;
function set Series(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.Status Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Status {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Status {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Status() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_AbsManTime Property

Abosolute Manufacturing Time Span -Read Only

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AbsManTime() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan U_AbsManTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan U_AbsManTime {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AbsManTime() : TimeSpan;
function set U_AbsManTime(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_ActCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
Property U_ActCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
double U_ActCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property double U_ActCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get U_ActCost() : double;

   AppEnginePropertyReadOnly()
function set U_ActCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_ActualQty Property

Manufacturing Order actual quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property U_ActualQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
double U_ActualQty {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property double U_ActualQty {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get U_ActualQty() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_ActualYield Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_ActualYield() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ActualYield {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ActualYield {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActualYield() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_BOMCode Property

Bill of Material code which Manufacturing Order bases on

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BOMCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BOMCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BOMCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BOMCode() : String;
function set U_BOMCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_BatchSize Property

Batch Size - read only

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BatchSize() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_BatchSize {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_BatchSize {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchSize() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_Classification Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Classification() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Classification {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Classification {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Classification() : String;
function set U_Classification(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_CloseDate Property

Close Date used when closing MOR as Journal entry posting date

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CloseDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_CloseDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_CloseDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CloseDate() : DateTime;
function set U_CloseDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_CoproductFormula Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CoproductFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CoproductFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CoproductFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CoproductFormula() : String;
function set U_CoproductFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_CoproductYield Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CoproductYield() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_CoproductYield {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_CoproductYield {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CoproductYield() : double;
function set U_CoproductYield(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_CostTotal Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CostTotal() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_CostTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_CostTotal {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CostTotal() : double;
function set U_CostTotal(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_Description Property

Manufacturing Order finished article description

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Description() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Description {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Description {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Description() : String;
function set U_Description(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_DistNumber Property

Batch number holded in MOR is used if Create Batch on Mor Start is enabled i general settings.

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DistNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DistNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DistNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DistNumber() : String;
function set U_DistNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_Factor Property

Manufacturing Order factor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Factor() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Factor {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Factor {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Factor() : double;
function set U_Factor(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_FixedCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
Property U_FixedCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
double U_FixedCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property double U_FixedCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get U_FixedCost() : double;

   AppEnginePropertyReadOnly()
function set U_FixedCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_Freeze Property

Freezes whole manufacturing order on Gant Chart

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Freeze() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Freeze {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Freeze {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Freeze() : YesNoType;
function set U_Freeze(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_Instructions Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Instructions() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Instructions {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Instructions {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Instructions() : String;
function set U_Instructions(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_InventoryUoM Property

Manufacturing Order unit of measure

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
Property U_InventoryUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
string U_InventoryUoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property String^ U_InventoryUoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get U_InventoryUoM() : String;

   AppEnginePropertyReadOnly()
function set U_InventoryUoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_ItemCode Property

Manufacturing Order finished article code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_ItemCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ItemCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ItemCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCost() : double;
function set U_ItemCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_ItemFormula Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemFormula() : String;
function set U_ItemFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_ItemResources Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemResources() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ItemResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ItemResources {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemResources() : double;
function set U_ItemResources(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_ItemYield Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemYield() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ItemYield {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ItemYield {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemYield() : double;
function set U_ItemYield(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_JrnlTransId Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_JrnlTransId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_JrnlTransId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_JrnlTransId {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_JrnlTransId() : int;
function set U_JrnlTransId(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_OcrCode Property

Manufacturing Order distribution rule or cost centre code in dimension 1

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode() : String;
function set U_OcrCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_OcrCode2 Property

Manufacturing Order distribution rule or cost centre code in dimension 2

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode2() : String;
function set U_OcrCode2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_OcrCode3 Property

Manufacturing Order distribution rule or cost centre code in dimension 3

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode3() : String;
function set U_OcrCode3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_OcrCode4 Property

Manufacturing Order distribution rule or cost centre code in dimension 4

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode4() : String;
function set U_OcrCode4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_OcrCode5 Property

Manufacturing Order distribution rule or cost centre code in dimension 5

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode5() : String;
function set U_OcrCode5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_ParentMorDocEntry Property

Parent Manufacturing DocEntry

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ParentMorDocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ParentMorDocEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ParentMorDocEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ParentMorDocEntry() : int;
function set U_ParentMorDocEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_ParentMorDocNum Property

Parent Manufacturing DocNum

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ParentMorDocNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ParentMorDocNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ParentMorDocNum {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ParentMorDocNum() : int;
function set U_ParentMorDocNum(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_PlannedEndDate Property

Manufacturing Order planned end date

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PlannedEndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_PlannedEndDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_PlannedEndDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PlannedEndDate() : DateTime;
function set U_PlannedEndDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_PlannedEndTime Property

Manufacturing Order Planed End Time

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PlannedEndTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_PlannedEndTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_PlannedEndTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PlannedEndTime() : DateTime;
function set U_PlannedEndTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_PlannedStartDate Property

Manufacturing Order planned start date

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PlannedStartDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_PlannedStartDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_PlannedStartDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PlannedStartDate() : DateTime;
function set U_PlannedStartDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_PlannedStartTime Property

Manufacturing Order Planed Start Time

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PlannedStartTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_PlannedStartTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_PlannedStartTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PlannedStartTime() : DateTime;
function set U_PlannedStartTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_Price Property

Manufacturing Order price

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Price() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Price {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Price {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Price() : double;
function set U_Price(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_Priority Property

Manufacturing Order priority

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Priority() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_Priority {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_Priority {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Priority() : int;
function set U_Priority(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_ProdType Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ProdType() As ProductionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ProductionType U_ProdType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ProductionType U_ProdType {
 ProductionType get( );
 void set(
   ProductionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ProdType() : ProductionType;
function set U_ProdType(value : ProductionType);
This language is not supported or no code example is available.

Property Value

Type: ProductionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_Project Property

Manufacturing Order project code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Project() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Project {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Project {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Project() : String;
function set U_Project(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_Quantity Property

Manufacturing Order quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_Remarks Property

Remarks Field For Manufacturing Order

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_RequiredDate Property

Manufacturing Order required date

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RequiredDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_RequiredDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_RequiredDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RequiredDate() : DateTime;
function set U_RequiredDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_RequiredTime Property

Manufacturing Order required date

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RequiredTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_RequiredTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_RequiredTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RequiredTime() : DateTime;
function set U_RequiredTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_Revision Property

Manufacturing Order revision code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Revision() : String;
function set U_Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_RevisionName Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RevisionName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevisionName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevisionName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevisionName() : String;
function set U_RevisionName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_ReworkQty Property

Quantity of reworked items Read only

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_ReworkQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ReworkQty {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ReworkQty {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReworkQty() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_RtgCode Property

Manufacturing Order routing code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RtgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RtgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgCode() : String;
function set U_RtgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_RtgName Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RtgName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RtgName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgName() : String;
function set U_RtgName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_SchedulingMtd Property

Manufacturing Order scheduling method

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SchedulingMtd() As PF_MORSchedulingMthd
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
PF_MORSchedulingMthd U_SchedulingMtd {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property PF_MORSchedulingMthd U_SchedulingMtd {
 PF_MORSchedulingMthd get( );
 void set(
   PF_MORSchedulingMthd value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SchedulingMtd() : PF_MORSchedulingMthd;
function set U_SchedulingMtd(value : PF_MORSchedulingMthd);
This language is not supported or no code example is available.

Property Value

Type: PF_MORSchedulingMthd
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_ScrapFormula Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ScrapFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ScrapFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ScrapFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ScrapFormula() : String;
function set U_ScrapFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_ScrapYield Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ScrapYield() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ScrapYield {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ScrapYield {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ScrapYield() : double;
function set U_ScrapYield(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_Status Property

Manufacturing Order status

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Status() As ManufacturingOrderStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ManufacturingOrderStatus U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ManufacturingOrderStatus U_Status {
 ManufacturingOrderStatus get( );
 void set(
   ManufacturingOrderStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Status() : ManufacturingOrderStatus;
function set U_Status(value : ManufacturingOrderStatus);
This language is not supported or no code example is available.

Property Value

Type: ManufacturingOrderStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_SubcontractorCode Property

Subcontractor Code Must be filed whetn U_ProdType is set to External

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SubcontractorCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SubcontractorCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SubcontractorCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SubcontractorCode() : String;
function set U_SubcontractorCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_TechInstructions Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TechInstructions() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TechInstructions {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TechInstructions {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TechInstructions() : String;
function set U_TechInstructions(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_TotalQty Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_TotalQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_TotalQty {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_TotalQty {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TotalQty() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_VariableCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
Property U_VariableCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
double U_VariableCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property double U_VariableCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get U_VariableCost() : double;

   AppEnginePropertyReadOnly()
function set U_VariableCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_Warehouse Property

Manufacturing Order warehouse code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Warehouse() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Warehouse {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Warehouse {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Warehouse() : String;
function set U_Warehouse(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_Yield Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Yield() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Yield {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Yield {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Yield() : double;
function set U_Yield(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.U_YieldFormula Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_YieldFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_YieldFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_YieldFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_YieldFormula() : String;
function set U_YieldFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder Methods

IManufacturingOrder Interface See Also

The following tables list the members exposed by the IManufacturingOrder type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CalculateManufacturingTimes |
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Clone |
Public method | CreateManufacturingOrdersForSemiProducts | (Overloaded) This method Creates Manufacturing Orders For Semi Products
Public method | CreateProcurmentDocumentForService | Creates Draft for Procrment Document Based On manufacturing Order
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RecalcFormulas | Connect Function to Activate Recalculation Engine on object (inherited from IExtendedUDO).
Public method | RecalcFormulasNew | (inherited from IExtendedUDO).
Public method | RecalcRequired | (Overloaded) (inherited from IExtendedUDO).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IManufacturingOrder Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.CalculateManufacturingTimes Method

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub CalculateManufacturingTimes( _
   Optional ByVal changeStatus As Boolean = true _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void CalculateManufacturingTimes(
   bool changeStatus = true
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void CalculateManufacturingTimes(
   bool changeStatus
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CalculateManufacturingTimes(
    changeStatus : boolean
);
This language is not supported or no code example is available.

Parameters

changeStatus

Type: bool

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.Clone Method

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Clone()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Clone()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Clone()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Clone();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.CreateManufacturingOrdersForSemiProducts Method

IManufacturingOrder Interface See Also

This method Creates Manufacturing Orders For Semi Products

Overload List
Name | Description
CreateManufacturingOrdersForSemiProducts() | This method Creates Manufacturing Orders For Semi Products
CreateManufacturingOrdersForSemiProducts(int[]) | Create ManufacturingOrders for semi product
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrder.CreateProcurmentDocumentForService Method

Creates Draft for Procrment Document Based On manufacturing Order

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CreateProcurmentDocumentForService( _
   ByVal documentType As ProcurmentDocumentType, _
   ByRef errorList As List(Of String) _
) As List(Of Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<int> CreateProcurmentDocumentForService(
   ProcurmentDocumentType documentType,
   out List<string> errorList
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

List<int>^ CreateProcurmentDocumentForService(
   ProcurmentDocumentType documentType,
   List<String^>^& errorList
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

documentType

Type: ProcurmentDocumentType

Type of Document

errorList

Type: List<string>

Return Value

Type: List<int>

List of Created Docentrys of Draft Documents

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderAttachments Interface

Members See Also

Attachment of manufacturing order document

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IManufacturingOrderAttachments
    Inherits IUDOChildBean, _
             IEnumerable(Of IManufacturingOrderAttachments)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IManufacturingOrderAttachments : IUDOChildBean,
   IEnumerable<IManufacturingOrderAttachments>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IManufacturingOrderAttachments : public IUDOChildBean^,
   public IEnumerable<IManufacturingOrderAttachments^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_MOR19
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderAttachments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderAttachments Members

IManufacturingOrderAttachments Interface Methods Properties See Also

Attachment of manufacturing order document

The following tables list the members exposed by the IManufacturingOrderAttachments type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AttDate |
Public property | U_AttFileName |
Public property | U_AttPath |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderAttachments Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderAttachments Properties

IManufacturingOrderAttachments Interface See Also

The following tables list the members exposed by the IManufacturingOrderAttachments type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AttDate |
Public property | U_AttFileName |
Public property | U_AttPath |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | VisOrder |
Top
See Also

Reference

IManufacturingOrderAttachments Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderAttachments.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderAttachments Interface
IManufacturingOrderAttachments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderAttachments.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderAttachments Interface
IManufacturingOrderAttachments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderAttachments.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderAttachments Interface
IManufacturingOrderAttachments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderAttachments.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderAttachments Interface
IManufacturingOrderAttachments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderAttachments.U_AttDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_AttDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_AttDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttDate() : DateTime;
function set U_AttDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderAttachments Interface
IManufacturingOrderAttachments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderAttachments.U_AttFileName Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttFileName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AttFileName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AttFileName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttFileName() : String;
function set U_AttFileName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderAttachments Interface
IManufacturingOrderAttachments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderAttachments.U_AttPath Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttPath() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AttPath {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AttPath {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttPath() : String;
function set U_AttPath(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderAttachments Interface
IManufacturingOrderAttachments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderAttachments.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderAttachments Interface
IManufacturingOrderAttachments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderAttachments Methods

IManufacturingOrderAttachments Interface See Also

The following tables list the members exposed by the IManufacturingOrderAttachments type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderAttachments Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts Interface

Members See Also

Coproducts of manufacturing order document

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IManufacturingOrderCoproducts
    Inherits IUDOChildBean, _
             IEnumerable(Of IManufacturingOrderCoproducts)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IManufacturingOrderCoproducts : IUDOChildBean,
   IEnumerable<IManufacturingOrderCoproducts>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IManufacturingOrderCoproducts : public IUDOChildBean^,
   public IEnumerable<IManufacturingOrderCoproducts^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_MOR1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts Members

IManufacturingOrderCoproducts Interface Methods Properties See Also

Coproducts of manufacturing order document

The following tables list the members exposed by the IManufacturingOrderCoproducts type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | DsRowNum |
Public property | ItemName | Item Name
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | RevisionName |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ActCost |
Public property | U_ActualQty | CoProduct's Actual Quantity
Public property | U_BaseLine | CoProduct's Base Line number
Public property | U_BaseQty | CoProduct's Base Quantity
Public property | U_BatchResult | Batch Result based on specific formula used in Costing read-only
Public property | U_CostTotal |
Public property | U_Description | CoProduct's Description
Public property | U_Editable | Editable
Public property | U_EndDate | End date.
Public property | U_Factor | CoProduct's Factor
Public property | U_FactorDescription | CoProduct's Factor's Description
Public property | U_FixedCost |
Public property | U_Formula | CoProduct's Formula to calculate result
Public property | U_InventoryUoM | CoProduct's Unit of measure
Public property | U_IssueType | CoProduct's Issue Type
Public property | U_ItemCode | CoProduct's ItemCode
Public property | U_ItemCost |
Public property | U_ItemResources |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Locked | User Data Source that holds Distribution Rules or Cost Centres codes
Public property | U_OcrCode | CoProduct's Distribution Rule or Cost Centre code in Dimension 1
Public property | U_OcrCode2 | CoProduct's Distribution Rule or Cost Centre code in Dimension 2
Public property | U_OcrCode3 | CoProduct's Distribution Rule or Cost Centre code in Dimension 3
Public property | U_OcrCode4 | CoProduct's Distribution Rule or Cost Centre code in Dimension 4
Public property | U_OcrCode5 | CoProduct's Distribution Rule or Cost Centre code in Dimension 5
Public property | U_Origin |
Public property | U_PlannedQty | CoProduct's Planned Quantity
Public property | U_Price | CoProduct's Price
Public property | U_Project | CoProduct's Project code
Public property | U_Quantity | CoProduct's Quantity
Public property | U_Remarks | CoProduct's Remarks
Public property | U_Result | CoProduct's Result based on specific formula
Public property | U_Revision |
Public property | U_Sequence | CoProduct's Sequence number
Public property | U_StartDate | Start date.
Public property | U_Type | CoProduct's Type
Public property | U_VariableCost |
Public property | U_WhsCode | CoProduct's Warehouse Code
Public property | U_Yield |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderCoproducts Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts Properties

IManufacturingOrderCoproducts Interface See Also

The following tables list the members exposed by the IManufacturingOrderCoproducts type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | DsRowNum |
Public property | ItemName | Item Name
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | RevisionName |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ActCost |
Public property | U_ActualQty | CoProduct's Actual Quantity
Public property | U_BaseLine | CoProduct's Base Line number
Public property | U_BaseQty | CoProduct's Base Quantity
Public property | U_BatchResult | Batch Result based on specific formula used in Costing read-only
Public property | U_CostTotal |
Public property | U_Description | CoProduct's Description
Public property | U_Editable | Editable
Public property | U_EndDate | End date.
Public property | U_Factor | CoProduct's Factor
Public property | U_FactorDescription | CoProduct's Factor's Description
Public property | U_FixedCost |
Public property | U_Formula | CoProduct's Formula to calculate result
Public property | U_InventoryUoM | CoProduct's Unit of measure
Public property | U_IssueType | CoProduct's Issue Type
Public property | U_ItemCode | CoProduct's ItemCode
Public property | U_ItemCost |
Public property | U_ItemResources |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Locked | User Data Source that holds Distribution Rules or Cost Centres codes
Public property | U_OcrCode | CoProduct's Distribution Rule or Cost Centre code in Dimension 1
Public property | U_OcrCode2 | CoProduct's Distribution Rule or Cost Centre code in Dimension 2
Public property | U_OcrCode3 | CoProduct's Distribution Rule or Cost Centre code in Dimension 3
Public property | U_OcrCode4 | CoProduct's Distribution Rule or Cost Centre code in Dimension 4
Public property | U_OcrCode5 | CoProduct's Distribution Rule or Cost Centre code in Dimension 5
Public property | U_Origin |
Public property | U_PlannedQty | CoProduct's Planned Quantity
Public property | U_Price | CoProduct's Price
Public property | U_Project | CoProduct's Project code
Public property | U_Quantity | CoProduct's Quantity
Public property | U_Remarks | CoProduct's Remarks
Public property | U_Result | CoProduct's Result based on specific formula
Public property | U_Revision |
Public property | U_Sequence | CoProduct's Sequence number
Public property | U_StartDate | Start date.
Public property | U_Type | CoProduct's Type
Public property | U_VariableCost |
Public property | U_WhsCode | CoProduct's Warehouse Code
Public property | U_Yield |
Public property | VisOrder |
Top
See Also

Reference

IManufacturingOrderCoproducts Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.DsRowNum Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DsRowNum() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DsRowNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DsRowNum {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DsRowNum() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.ItemName Property

Item Name

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string ItemName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ ItemName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ItemName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.RevisionName Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property RevisionName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string RevisionName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ RevisionName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get RevisionName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_ActCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ActCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ActCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActCost() : double;
function set U_ActCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_ActualQty Property

CoProduct's Actual Quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActualQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ActualQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ActualQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActualQty() : double;
function set U_ActualQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_BaseLine Property

CoProduct's Base Line number

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLine() : int;
function set U_BaseLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_BaseQty Property

CoProduct's Base Quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_BaseQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_BaseQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseQty() : double;
function set U_BaseQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_BatchResult Property

Batch Result based on specific formula used in Costing read-only

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BatchResult() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_BatchResult {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_BatchResult {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchResult() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_CostTotal Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CostTotal() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_CostTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_CostTotal {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CostTotal() : double;
function set U_CostTotal(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_Description Property

CoProduct's Description

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Description() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Description {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Description {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Description() : String;
function set U_Description(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_Editable Property

Editable

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Editable() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Editable {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Editable {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Editable() : String;
function set U_Editable(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_EndDate Property

End date.

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_EndDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_EndDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EndDate() : DateTime;
function set U_EndDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_Factor Property

CoProduct's Factor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Factor() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Factor {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Factor {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Factor() : double;
function set U_Factor(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_FactorDescription Property

CoProduct's Factor's Description

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FactorDescription() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FactorDescription {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FactorDescription {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FactorDescription() : String;
function set U_FactorDescription(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_FixedCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FixedCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixedCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixedCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixedCost() : double;
function set U_FixedCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_Formula Property

CoProduct's Formula to calculate result

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Formula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Formula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Formula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Formula() : String;
function set U_Formula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_InventoryUoM Property

CoProduct's Unit of measure

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InventoryUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InventoryUoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InventoryUoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InventoryUoM() : String;
function set U_InventoryUoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_IssueType Property

CoProduct's Issue Type

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IssueType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_IssueType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_IssueType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IssueType() : String;
function set U_IssueType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_ItemCode Property

CoProduct's ItemCode

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_ItemCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ItemCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ItemCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCost() : double;
function set U_ItemCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_ItemResources Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemResources() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ItemResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ItemResources {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemResources() : double;
function set U_ItemResources(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_Locked Property

User Data Source that holds Distribution Rules or Cost Centres codes

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Locked() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Locked {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Locked {
 YesNoType get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Locked() : YesNoType;
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_OcrCode Property

CoProduct's Distribution Rule or Cost Centre code in Dimension 1

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode() : String;
function set U_OcrCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_OcrCode2 Property

CoProduct's Distribution Rule or Cost Centre code in Dimension 2

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode2() : String;
function set U_OcrCode2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_OcrCode3 Property

CoProduct's Distribution Rule or Cost Centre code in Dimension 3

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode3() : String;
function set U_OcrCode3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_OcrCode4 Property

CoProduct's Distribution Rule or Cost Centre code in Dimension 4

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode4() : String;
function set U_OcrCode4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_OcrCode5 Property

CoProduct's Distribution Rule or Cost Centre code in Dimension 5

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode5() : String;
function set U_OcrCode5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_Origin Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Origin() As ItemOriginType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ItemOriginType U_Origin {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ItemOriginType U_Origin {
 ItemOriginType get( );
 void set(
   ItemOriginType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Origin() : ItemOriginType;
function set U_Origin(value : ItemOriginType);
This language is not supported or no code example is available.

Property Value

Type: ItemOriginType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_PlannedQty Property

CoProduct's Planned Quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PlannedQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PlannedQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PlannedQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PlannedQty() : double;
function set U_PlannedQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_Price Property

CoProduct's Price

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Price() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Price {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Price {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Price() : double;
function set U_Price(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_Project Property

CoProduct's Project code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Project() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Project {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Project {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Project() : String;
function set U_Project(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_Quantity Property

CoProduct's Quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_Remarks Property

CoProduct's Remarks

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_Result Property

CoProduct's Result based on specific formula

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Result() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Result {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Result {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Result() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_Revision Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Revision() : String;
function set U_Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_Sequence Property

CoProduct's Sequence number

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Sequence() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_Sequence {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_Sequence {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Sequence() : int;
function set U_Sequence(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_StartDate Property

Start date.

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StartDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StartDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StartDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StartDate() : DateTime;
function set U_StartDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_Type Property

CoProduct's Type

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Type() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Type {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Type {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Type() : String;
function set U_Type(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_VariableCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VariableCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VariableCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VariableCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VariableCost() : double;
function set U_VariableCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_WhsCode Property

CoProduct's Warehouse Code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.U_Yield Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Yield() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Yield {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Yield {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Yield() : double;
function set U_Yield(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderCoproducts Interface
IManufacturingOrderCoproducts Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderCoproducts Methods

IManufacturingOrderCoproducts Interface See Also

The following tables list the members exposed by the IManufacturingOrderCoproducts type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderCoproducts Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments Interface

Members See Also

Documents of manufacturing order document

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IManufacturingOrderDocuments
    Inherits IUDOChildBean, _
             IEnumerable(Of IManufacturingOrderDocuments)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IManufacturingOrderDocuments : IUDOChildBean,
   IEnumerable<IManufacturingOrderDocuments>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IManufacturingOrderDocuments : public IUDOChildBean^,
   public IEnumerable<IManufacturingOrderDocuments^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_MOR5
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments Members

IManufacturingOrderDocuments Interface Methods Properties See Also

Documents of manufacturing order document

The following tables list the members exposed by the IManufacturingOrderDocuments type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AdjustEntry | Number of adjusted document (key)
Public property | U_AdjustLine | Line number from adjusted document
Public property | U_AdjustType | Type of adjusted document (number from Business Object Type list)
Public property | U_BaseEntry | BaseEntry
Public property | U_BaseLine | BaseLine
Public property | U_BaseType | BaseType
Public property | U_DocSeries | Document's series
Public property | U_ItemCode | Code of Item, Scrap or CoProduct
Public property | U_ItemLine | Line number from Manufacturing Order Lines (Items, Scraps or CoProducts)
Public property | U_ItemType | Item type (Item, Scrap or CoProduct)
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OperDocNum | Document's DocNum
Public property | U_OperEntry | Document'a DocEntry (key)
Public property | U_OperLine | Document's line number
Public property | U_OperType | Document's type (number from Business Object Type list)
Public property | U_PickEntry | Main Key of Pick Order or Pick Receipt (key)
Public property | U_PickLine | Line number in Pick Order or Pick Receipt
Public property | U_PickType | Pick Type
Public property | U_Quantity | Quantity of item in specific document line
Public property | U_ResidualQty | Residual Quantity
Public property | U_SetlTransId | Transaction ID of settlement cost by type (key)
Public property | U_TimeEntry |
Public property | U_WhsCode | Warehouse Code in specific document line
Public property | U_revTransId | Transaction ID of reversal (key)
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | IsRowFilled | This method checks if row is filled with data or empty.
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderDocuments Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments Properties

IManufacturingOrderDocuments Interface See Also

The following tables list the members exposed by the IManufacturingOrderDocuments type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AdjustEntry | Number of adjusted document (key)
Public property | U_AdjustLine | Line number from adjusted document
Public property | U_AdjustType | Type of adjusted document (number from Business Object Type list)
Public property | U_BaseEntry | BaseEntry
Public property | U_BaseLine | BaseLine
Public property | U_BaseType | BaseType
Public property | U_DocSeries | Document's series
Public property | U_ItemCode | Code of Item, Scrap or CoProduct
Public property | U_ItemLine | Line number from Manufacturing Order Lines (Items, Scraps or CoProducts)
Public property | U_ItemType | Item type (Item, Scrap or CoProduct)
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OperDocNum | Document's DocNum
Public property | U_OperEntry | Document'a DocEntry (key)
Public property | U_OperLine | Document's line number
Public property | U_OperType | Document's type (number from Business Object Type list)
Public property | U_PickEntry | Main Key of Pick Order or Pick Receipt (key)
Public property | U_PickLine | Line number in Pick Order or Pick Receipt
Public property | U_PickType | Pick Type
Public property | U_Quantity | Quantity of item in specific document line
Public property | U_ResidualQty | Residual Quantity
Public property | U_SetlTransId | Transaction ID of settlement cost by type (key)
Public property | U_TimeEntry |
Public property | U_WhsCode | Warehouse Code in specific document line
Public property | U_revTransId | Transaction ID of reversal (key)
Public property | VisOrder |
Top
See Also

Reference

IManufacturingOrderDocuments Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_AdjustEntry Property

Number of adjusted document (key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_AdjustEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_AdjustEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_AdjustEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AdjustEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_AdjustLine Property

Line number from adjusted document

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_AdjustLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_AdjustLine {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_AdjustLine {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AdjustLine() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_AdjustType Property

Type of adjusted document (number from Business Object Type list)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_AdjustType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AdjustType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AdjustType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AdjustType() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_BaseEntry Property

BaseEntry

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BaseEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_BaseLine Property

BaseLine

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BaseLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLine {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLine {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLine() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_BaseType Property

BaseType

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BaseType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BaseType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BaseType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseType() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_DocSeries Property

Document's series

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_DocSeries() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DocSeries {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DocSeries {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DocSeries() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_ItemCode Property

Code of Item, Scrap or CoProduct

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_ItemLine Property

Line number from Manufacturing Order Lines (Items, Scraps or CoProducts)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_ItemLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ItemLine {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ItemLine {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemLine() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_ItemType Property

Item type (Item, Scrap or CoProduct)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_ItemType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemType() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_OperDocNum Property

Document's DocNum

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_OperDocNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_OperDocNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_OperDocNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OperDocNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_OperEntry Property

Document'a DocEntry (key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_OperEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_OperEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_OperEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OperEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_OperLine Property

Document's line number

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_OperLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_OperLine {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_OperLine {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OperLine() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_OperType Property

Document's type (number from Business Object Type list)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_OperType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OperType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OperType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OperType() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_PickEntry Property

Main Key of Pick Order or Pick Receipt (key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_PickEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_PickEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_PickEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PickEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_PickLine Property

Line number in Pick Order or Pick Receipt

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_PickLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_PickLine {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_PickLine {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PickLine() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_PickType Property

Pick Type

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_PickType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PickType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PickType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PickType() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_Quantity Property

Quantity of item in specific document line

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_ResidualQty Property

Residual Quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_ResidualQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ResidualQty {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ResidualQty {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ResidualQty() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_SetlTransId Property

Transaction ID of settlement cost by type (key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_SetlTransId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SetlTransId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SetlTransId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetlTransId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_TimeEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_TimeEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_TimeEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_TimeEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TimeEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_WhsCode Property

Warehouse Code in specific document line

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.U_revTransId Property

Transaction ID of reversal (key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_revTransId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_revTransId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_revTransId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_revTransId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments Methods

IManufacturingOrderDocuments Interface See Also

The following tables list the members exposed by the IManufacturingOrderDocuments type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | IsRowFilled | This method checks if row is filled with data or empty.
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderDocuments Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderDocuments.IsRowFilled Method

This method checks if row is filled with data or empty.

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function IsRowFilled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool IsRowFilled()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool IsRowFilled()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function IsRowFilled() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderDocuments Interface
IManufacturingOrderDocuments Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems Interface

Members See Also

Items of manufacturing order document

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IManufacturingOrderItems
    Inherits IUDOChildBean, _
             IEnumerable(Of IManufacturingOrderItems)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IManufacturingOrderItems : IUDOChildBean,
   IEnumerable<IManufacturingOrderItems>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IManufacturingOrderItems : public IUDOChildBean^,
   public IEnumerable<IManufacturingOrderItems^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_MOR3
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems Members

IManufacturingOrderItems Interface Methods Properties See Also

Items of manufacturing order document

The following tables list the members exposed by the IManufacturingOrderItems type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | DsRowNum |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AcptLowerQty | if the quantity of items in the warehouse is lower than the quantity you want to issue then issue only the quantity that is available in the warehouse
Public property | U_ActCost |
Public property | U_ActualQty | Item's Actual Quantity
Public property | U_BOMBaseCode | BOMBaseCode for Phantom Item
Public property | U_BaseLine | Item's Base Line number
Public property | U_BaseQty | Item's Base Quantity
Public property | U_BatchResult | Batch Result based on specific formula used in Costing read-only
Public property | U_CostTotal | Cost Total Items.U_CostTotal = Items.U_ItemCost + Items.U_ItemResources + Items.U_FixedCost + Items.U_VariableCost;
Public property | U_Description | Item's Description
Public property | U_Editable | Editable
Public property | U_EndDate | End date.
Public property | U_Factor | Item's Factor
Public property | U_FactorDescription | Item's Factor's Description
Public property | U_FixedCost |
Public property | U_Formula | Item's Formula to calculate result
Public property | U_InventoryUoM | Item's Unit of measure
Public property | U_IssueType | Item's Issue Type
Public property | U_ItemCode | Item's ItemCode
Public property | U_ItemCost |
Public property | U_ItemResources |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Locked | if you choose yes, then the residual amount from previous issue (where there was not enough items in the warehouse) will be filled up
Public property | U_OcrCode | Item's Distribution Rule or Cost Center code in Dimension 1
Public property | U_OcrCode2 | Item's Distribution Rule or Cost Center code in Dimension 2
Public property | U_OcrCode3 | Item's Distribution Rule or Cost Center code in Dimension 3
Public property | U_OcrCode4 | Item's Distribution Rule or Cost Center code in Dimension 4
Public property | U_OcrCode5 | Item's Distribution Rule or Cost Center code in Dimension 5
Public property | U_Origin |
Public property | U_PlannedQty | Item's Planned Quantity
Public property | U_Project | Item's Project code
Public property | U_Quantity | Item's Quantity
Public property | U_Remarks | Item's Remarks
Public property | U_ResidualQty | Residual Quantity
Public property | U_Result | Item's Result based on specific formula
Public property | U_Revision |
Public property | U_ScrapPercentage | Item's Percentage of Scraps
Public property | U_Sequence | Item's Sequence number
Public property | U_StartDate | Start date.
Public property | U_SubRecepitItem |
Public property | U_Type | Type
Public property | U_VariableCost |
Public property | U_WhsCode | Item's Warehouse Code
Public property | U_Yield |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | CanExplode | Returns True when item Contains Phantom wich must explode
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | ExplodePhantom | Executes Exposion of current Phantom
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderItems Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems Properties

IManufacturingOrderItems Interface See Also

The following tables list the members exposed by the IManufacturingOrderItems type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | DsRowNum |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AcptLowerQty | if the quantity of items in the warehouse is lower than the quantity you want to issue then issue only the quantity that is available in the warehouse
Public property | U_ActCost |
Public property | U_ActualQty | Item's Actual Quantity
Public property | U_BOMBaseCode | BOMBaseCode for Phantom Item
Public property | U_BaseLine | Item's Base Line number
Public property | U_BaseQty | Item's Base Quantity
Public property | U_BatchResult | Batch Result based on specific formula used in Costing read-only
Public property | U_CostTotal | Cost Total Items.U_CostTotal = Items.U_ItemCost + Items.U_ItemResources + Items.U_FixedCost + Items.U_VariableCost;
Public property | U_Description | Item's Description
Public property | U_Editable | Editable
Public property | U_EndDate | End date.
Public property | U_Factor | Item's Factor
Public property | U_FactorDescription | Item's Factor's Description
Public property | U_FixedCost |
Public property | U_Formula | Item's Formula to calculate result
Public property | U_InventoryUoM | Item's Unit of measure
Public property | U_IssueType | Item's Issue Type
Public property | U_ItemCode | Item's ItemCode
Public property | U_ItemCost |
Public property | U_ItemResources |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Locked | if you choose yes, then the residual amount from previous issue (where there was not enough items in the warehouse) will be filled up
Public property | U_OcrCode | Item's Distribution Rule or Cost Center code in Dimension 1
Public property | U_OcrCode2 | Item's Distribution Rule or Cost Center code in Dimension 2
Public property | U_OcrCode3 | Item's Distribution Rule or Cost Center code in Dimension 3
Public property | U_OcrCode4 | Item's Distribution Rule or Cost Center code in Dimension 4
Public property | U_OcrCode5 | Item's Distribution Rule or Cost Center code in Dimension 5
Public property | U_Origin |
Public property | U_PlannedQty | Item's Planned Quantity
Public property | U_Project | Item's Project code
Public property | U_Quantity | Item's Quantity
Public property | U_Remarks | Item's Remarks
Public property | U_ResidualQty | Residual Quantity
Public property | U_Result | Item's Result based on specific formula
Public property | U_Revision |
Public property | U_ScrapPercentage | Item's Percentage of Scraps
Public property | U_Sequence | Item's Sequence number
Public property | U_StartDate | Start date.
Public property | U_SubRecepitItem |
Public property | U_Type | Type
Public property | U_VariableCost |
Public property | U_WhsCode | Item's Warehouse Code
Public property | U_Yield |
Public property | VisOrder |
Top
See Also

Reference

IManufacturingOrderItems Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.DsRowNum Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DsRowNum() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DsRowNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DsRowNum {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DsRowNum() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_AcptLowerQty Property

if the quantity of items in the warehouse is lower than the quantity you want to issue then issue only the quantity that is available in the warehouse

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AcptLowerQty() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_AcptLowerQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_AcptLowerQty {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AcptLowerQty() : YesNoType;
function set U_AcptLowerQty(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_ActCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ActCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ActCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActCost() : double;
function set U_ActCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_ActualQty Property

Item's Actual Quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_ActualQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ActualQty {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ActualQty {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActualQty() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_BOMBaseCode Property

BOMBaseCode for Phantom Item

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BOMBaseCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BOMBaseCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BOMBaseCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BOMBaseCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_BaseLine Property

Item's Base Line number

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLine() : int;
function set U_BaseLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_BaseQty Property

Item's Base Quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BaseQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_BaseQty {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_BaseQty {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseQty() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_BatchResult Property

Batch Result based on specific formula used in Costing read-only

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BatchResult() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_BatchResult {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_BatchResult {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchResult() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_CostTotal Property

Cost Total Items.U_CostTotal = Items.U_ItemCost + Items.U_ItemResources + Items.U_FixedCost + Items.U_VariableCost;

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CostTotal() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_CostTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_CostTotal {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CostTotal() : double;
function set U_CostTotal(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_Description Property

Item's Description

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Description() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Description {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Description {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Description() : String;
function set U_Description(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_Editable Property

Editable

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Editable() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Editable {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Editable {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Editable() : String;
function set U_Editable(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_EndDate Property

End date.

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_EndDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_EndDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EndDate() : DateTime;
function set U_EndDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_Factor Property

Item's Factor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Factor() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Factor {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Factor {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Factor() : double;
function set U_Factor(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_FactorDescription Property

Item's Factor's Description

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FactorDescription() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FactorDescription {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FactorDescription {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FactorDescription() : String;
function set U_FactorDescription(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_FixedCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FixedCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixedCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixedCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixedCost() : double;
function set U_FixedCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_Formula Property

Item's Formula to calculate result

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Formula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Formula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Formula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Formula() : String;
function set U_Formula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_InventoryUoM Property

Item's Unit of measure

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InventoryUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InventoryUoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InventoryUoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InventoryUoM() : String;
function set U_InventoryUoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_IssueType Property

Item's Issue Type

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IssueType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_IssueType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_IssueType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IssueType() : String;
function set U_IssueType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_ItemCode Property

Item's ItemCode

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_ItemCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ItemCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ItemCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCost() : double;
function set U_ItemCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_ItemResources Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemResources() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ItemResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ItemResources {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemResources() : double;
function set U_ItemResources(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_Locked Property

if you choose yes, then the residual amount from previous issue (where there was not enough items in the warehouse) will be filled up

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Locked() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Locked {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Locked {
 YesNoType get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Locked() : YesNoType;
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_OcrCode Property

Item's Distribution Rule or Cost Center code in Dimension 1

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode() : String;
function set U_OcrCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_OcrCode2 Property

Item's Distribution Rule or Cost Center code in Dimension 2

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode2() : String;
function set U_OcrCode2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_OcrCode3 Property

Item's Distribution Rule or Cost Center code in Dimension 3

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode3() : String;
function set U_OcrCode3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_OcrCode4 Property

Item's Distribution Rule or Cost Center code in Dimension 4

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode4() : String;
function set U_OcrCode4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_OcrCode5 Property

Item's Distribution Rule or Cost Center code in Dimension 5

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode5() : String;
function set U_OcrCode5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_Origin Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Origin() As ItemOriginType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ItemOriginType U_Origin {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ItemOriginType U_Origin {
 ItemOriginType get( );
 void set(
   ItemOriginType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Origin() : ItemOriginType;
function set U_Origin(value : ItemOriginType);
This language is not supported or no code example is available.

Property Value

Type: ItemOriginType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_PlannedQty Property

Item's Planned Quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PlannedQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PlannedQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PlannedQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PlannedQty() : double;
function set U_PlannedQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_Project Property

Item's Project code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Project() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Project {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Project {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Project() : String;
function set U_Project(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_Quantity Property

Item's Quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_Remarks Property

Item's Remarks

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_ResidualQty Property

Residual Quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_ResidualQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ResidualQty {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ResidualQty {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ResidualQty() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_Result Property

Item's Result based on specific formula

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Result() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Result {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Result {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Result() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_Revision Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Revision() : String;
function set U_Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_ScrapPercentage Property

Item's Percentage of Scraps

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ScrapPercentage() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ScrapPercentage {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ScrapPercentage {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ScrapPercentage() : double;
function set U_ScrapPercentage(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_Sequence Property

Item's Sequence number

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Sequence() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_Sequence {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_Sequence {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Sequence() : int;
function set U_Sequence(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_StartDate Property

Start date.

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StartDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StartDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StartDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StartDate() : DateTime;
function set U_StartDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_SubRecepitItem Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SubRecepitItem() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_SubRecepitItem {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_SubRecepitItem {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SubRecepitItem() : YesNoType;
function set U_SubRecepitItem(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_Type Property

Type

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Type() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Type {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Type {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Type() : String;
function set U_Type(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_VariableCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VariableCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VariableCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VariableCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VariableCost() : double;
function set U_VariableCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_WhsCode Property

Item's Warehouse Code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.U_Yield Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Autogenerate = true)> _
Property U_Yield() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Autogenerate = true)]
double U_Yield {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Autogenerate = true)]

property double U_Yield {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Autogenerate = true)
function get U_Yield() : double;

   AppEngineProperty(Autogenerate = true)
function set U_Yield(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems Methods

IManufacturingOrderItems Interface See Also

The following tables list the members exposed by the IManufacturingOrderItems type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | CanExplode | Returns True when item Contains Phantom wich must explode
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | ExplodePhantom | Executes Exposion of current Phantom
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderItems Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.CanExplode Method

Returns True when item Contains Phantom wich must explode

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CanExplode() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool CanExplode()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool CanExplode()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CanExplode() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderItems.ExplodePhantom Method

Executes Exposion of current Phantom

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub ExplodePhantom()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void ExplodePhantom()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void ExplodePhantom()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function ExplodePhantom();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderItems Interface
IManufacturingOrderItems Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes Interface

Members See Also

Operation times of manufacturing order document

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IManufacturingOrderOperationTimes
    Inherits IUDOChildBean, _
             IEnumerable(Of IManufacturingOrderOperationTimes)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IManufacturingOrderOperationTimes : IUDOChildBean,
   IEnumerable<IManufacturingOrderOperationTimes>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IManufacturingOrderOperationTimes : public IUDOChildBean^,
   public IEnumerable<IManufacturingOrderOperationTimes^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_MOR18
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderOperationTimes Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes Members

IManufacturingOrderOperationTimes Interface Methods Properties See Also

Operation times of manufacturing order document

The following tables list the members exposed by the IManufacturingOrderOperationTimes type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ActualRunTime |
Public property | U_ActualSetpTime |
Public property | U_Dimension1 |
Public property | U_Dimension2 |
Public property | U_Dimension3 |
Public property | U_Dimension4 |
Public property | U_Dimension5 |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PercRTComplete |
Public property | U_PercSTComplete |
Public property | U_Project |
Public property | U_RemainingSTime |
Public property | U_remainingRTime |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderOperationTimes Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes Properties

IManufacturingOrderOperationTimes Interface See Also

The following tables list the members exposed by the IManufacturingOrderOperationTimes type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ActualRunTime |
Public property | U_ActualSetpTime |
Public property | U_Dimension1 |
Public property | U_Dimension2 |
Public property | U_Dimension3 |
Public property | U_Dimension4 |
Public property | U_Dimension5 |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PercRTComplete |
Public property | U_PercSTComplete |
Public property | U_Project |
Public property | U_RemainingSTime |
Public property | U_remainingRTime |
Public property | VisOrder |
Top
See Also

Reference

IManufacturingOrderOperationTimes Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderOperationTimes Interface
IManufacturingOrderOperationTimes Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderOperationTimes Interface
IManufacturingOrderOperationTimes Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderOperationTimes Interface
IManufacturingOrderOperationTimes Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderOperationTimes Interface
IManufacturingOrderOperationTimes Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes.U_ActualRunTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActualRunTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ActualRunTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ActualRunTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActualRunTime() : double;
function set U_ActualRunTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderOperationTimes Interface
IManufacturingOrderOperationTimes Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes.U_ActualSetpTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActualSetpTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ActualSetpTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ActualSetpTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActualSetpTime() : double;
function set U_ActualSetpTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderOperationTimes Interface
IManufacturingOrderOperationTimes Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes.U_Dimension1 Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Dimension1() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Dimension1 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Dimension1 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Dimension1() : String;
function set U_Dimension1(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderOperationTimes Interface
IManufacturingOrderOperationTimes Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes.U_Dimension2 Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Dimension2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Dimension2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Dimension2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Dimension2() : String;
function set U_Dimension2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderOperationTimes Interface
IManufacturingOrderOperationTimes Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes.U_Dimension3 Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Dimension3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Dimension3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Dimension3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Dimension3() : String;
function set U_Dimension3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderOperationTimes Interface
IManufacturingOrderOperationTimes Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes.U_Dimension4 Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Dimension4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Dimension4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Dimension4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Dimension4() : String;
function set U_Dimension4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderOperationTimes Interface
IManufacturingOrderOperationTimes Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes.U_Dimension5 Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Dimension5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Dimension5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Dimension5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Dimension5() : String;
function set U_Dimension5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderOperationTimes Interface
IManufacturingOrderOperationTimes Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes.U_PercRTComplete Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PercRTComplete() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PercRTComplete {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PercRTComplete {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PercRTComplete() : double;
function set U_PercRTComplete(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderOperationTimes Interface
IManufacturingOrderOperationTimes Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes.U_PercSTComplete Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PercSTComplete() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PercSTComplete {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PercSTComplete {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PercSTComplete() : double;
function set U_PercSTComplete(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderOperationTimes Interface
IManufacturingOrderOperationTimes Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes.U_Project Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Project() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Project {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Project {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Project() : String;
function set U_Project(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderOperationTimes Interface
IManufacturingOrderOperationTimes Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes.U_RemainingSTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RemainingSTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RemainingSTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RemainingSTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RemainingSTime() : double;
function set U_RemainingSTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderOperationTimes Interface
IManufacturingOrderOperationTimes Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes.U_remainingRTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_remainingRTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_remainingRTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_remainingRTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_remainingRTime() : double;
function set U_remainingRTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderOperationTimes Interface
IManufacturingOrderOperationTimes Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderOperationTimes Interface
IManufacturingOrderOperationTimes Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderOperationTimes Methods

IManufacturingOrderOperationTimes Interface See Also

The following tables list the members exposed by the IManufacturingOrderOperationTimes type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderOperationTimes Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms Interface

Members See Also

Phantoms of manufacturing order document

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IManufacturingOrderPhantoms
    Inherits IUDOChildBean, _
             IEnumerable(Of IManufacturingOrderPhantoms)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IManufacturingOrderPhantoms : IUDOChildBean,
   IEnumerable<IManufacturingOrderPhantoms>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IManufacturingOrderPhantoms : public IUDOChildBean^,
   public IEnumerable<IManufacturingOrderPhantoms^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_MOR2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms Members

IManufacturingOrderPhantoms Interface Methods Properties See Also

Phantoms of manufacturing order document

The following tables list the members exposed by the IManufacturingOrderPhantoms type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | DsRowNum |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ActualQty | Phantom's Actual Quantity
Public property | U_BaseLine | Phantom's Base Line number
Public property | U_BatchResult | Batch Result based on specific formula used in Costing read-only
Public property | U_Description | Phantom's Description
Public property | U_Editable | Editable
Public property | U_Factor | Phantom's Factor
Public property | U_FactorDescription | Phantom's Factor's Description
Public property | U_Formula | Phantom's Formula to calculate result
Public property | U_InventoryUoM | Phantom's Unit of measure
Public property | U_IssueType | Phantom's Issue Type
Public property | U_ItemCode | Phantom's ItemCode
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Origin |
Public property | U_Quantity | Phantom's Quantity
Public property | U_Remarks | Phantom's Remarks
Public property | U_Result | Phantom's Result based on specific formula
Public property | U_Revision |
Public property | U_Sequence | Phantom's Sequence number
Public property | U_Type | Type
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderPhantoms Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms Properties

IManufacturingOrderPhantoms Interface See Also

The following tables list the members exposed by the IManufacturingOrderPhantoms type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | DsRowNum |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ActualQty | Phantom's Actual Quantity
Public property | U_BaseLine | Phantom's Base Line number
Public property | U_BatchResult | Batch Result based on specific formula used in Costing read-only
Public property | U_Description | Phantom's Description
Public property | U_Editable | Editable
Public property | U_Factor | Phantom's Factor
Public property | U_FactorDescription | Phantom's Factor's Description
Public property | U_Formula | Phantom's Formula to calculate result
Public property | U_InventoryUoM | Phantom's Unit of measure
Public property | U_IssueType | Phantom's Issue Type
Public property | U_ItemCode | Phantom's ItemCode
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Origin |
Public property | U_Quantity | Phantom's Quantity
Public property | U_Remarks | Phantom's Remarks
Public property | U_Result | Phantom's Result based on specific formula
Public property | U_Revision |
Public property | U_Sequence | Phantom's Sequence number
Public property | U_Type | Type
Public property | VisOrder |
Top
See Also

Reference

IManufacturingOrderPhantoms Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.DsRowNum Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DsRowNum() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DsRowNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DsRowNum {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DsRowNum() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.U_ActualQty Property

Phantom's Actual Quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActualQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ActualQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ActualQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActualQty() : double;
function set U_ActualQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.U_BaseLine Property

Phantom's Base Line number

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLine() : int;
function set U_BaseLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.U_BatchResult Property

Batch Result based on specific formula used in Costing read-only

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BatchResult() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_BatchResult {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_BatchResult {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchResult() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.U_Description Property

Phantom's Description

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Description() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Description {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Description {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Description() : String;
function set U_Description(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.U_Editable Property

Editable

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Editable() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Editable {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Editable {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Editable() : String;
function set U_Editable(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.U_Factor Property

Phantom's Factor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Factor() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Factor {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Factor {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Factor() : double;
function set U_Factor(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.U_FactorDescription Property

Phantom's Factor's Description

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FactorDescription() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FactorDescription {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FactorDescription {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FactorDescription() : String;
function set U_FactorDescription(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.U_Formula Property

Phantom's Formula to calculate result

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Formula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Formula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Formula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Formula() : String;
function set U_Formula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.U_InventoryUoM Property

Phantom's Unit of measure

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InventoryUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InventoryUoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InventoryUoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InventoryUoM() : String;
function set U_InventoryUoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.U_IssueType Property

Phantom's Issue Type

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IssueType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_IssueType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_IssueType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IssueType() : String;
function set U_IssueType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.U_ItemCode Property

Phantom's ItemCode

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.U_Origin Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Origin() As ItemOriginType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ItemOriginType U_Origin {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ItemOriginType U_Origin {
 ItemOriginType get( );
 void set(
   ItemOriginType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Origin() : ItemOriginType;
function set U_Origin(value : ItemOriginType);
This language is not supported or no code example is available.

Property Value

Type: ItemOriginType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.U_Quantity Property

Phantom's Quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.U_Remarks Property

Phantom's Remarks

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.U_Result Property

Phantom's Result based on specific formula

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Result() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Result {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Result {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Result() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.U_Revision Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Revision() : String;
function set U_Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.U_Sequence Property

Phantom's Sequence number

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Sequence() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_Sequence {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_Sequence {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Sequence() : int;
function set U_Sequence(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.U_Type Property

Type

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Type() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Type {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Type {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Type() : String;
function set U_Type(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderPhantoms Interface
IManufacturingOrderPhantoms Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderPhantoms Methods

IManufacturingOrderPhantoms Interface See Also

The following tables list the members exposed by the IManufacturingOrderPhantoms type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderPhantoms Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput Interface

Members See Also

Input output of routing operations for manufacturing order document

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean(Parent = "IManufacturingOrderRoutingOperations")> _
Public Interface IManufacturingOrderRoutingOperationInputOutput
    Inherits IUDOChildBean, _
             IEnumerable(Of IManufacturingOrderRoutingOperationInputOutput)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IManufacturingOrderRoutingOperations")]
public interface IManufacturingOrderRoutingOperationInputOutput : IUDOChildBean,
   IEnumerable<IManufacturingOrderRoutingOperationInputOutput>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IManufacturingOrderRoutingOperations")]
public interface class IManufacturingOrderRoutingOperationInputOutput : public IUDOChildBean^,
   public IEnumerable<IManufacturingOrderRoutingOperationInputOutput^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_MOR14
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput Members

IManufacturingOrderRoutingOperationInputOutput Interface Methods Properties See Also

Input output of routing operations for manufacturing order document

The following tables list the members exposed by the IManufacturingOrderRoutingOperationInputOutput type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine | U_LineNum of selected Item
Public property | U_Direction | Direction In Or Out
Public property | U_IOOprCode | Key for this InputOutput binding
Public property | U_InTimeCalc | This filed fetermines if time calculation form operation us took from current Operation Only One I/O item can be selected for each operation. If there is no selected I/O Item Quantity Form header is took.
Public property | U_ItemCode | Item Code
Public property | U_ItemType | Scrap Item Coproduct Item ot Items
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MorCode | MOR Code
Public property | U_OprCode | Operation Code
Public property | U_RevCode | Revision Code (key)
Public property | U_RtgCode | Routing Code (key)
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Object belongs to concreat operation
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput Properties

IManufacturingOrderRoutingOperationInputOutput Interface See Also

The following tables list the members exposed by the IManufacturingOrderRoutingOperationInputOutput type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine | U_LineNum of selected Item
Public property | U_Direction | Direction In Or Out
Public property | U_IOOprCode | Key for this InputOutput binding
Public property | U_InTimeCalc | This filed fetermines if time calculation form operation us took from current Operation Only One I/O item can be selected for each operation. If there is no selected I/O Item Quantity Form header is took.
Public property | U_ItemCode | Item Code
Public property | U_ItemType | Scrap Item Coproduct Item ot Items
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MorCode | MOR Code
Public property | U_OprCode | Operation Code
Public property | U_RevCode | Revision Code (key)
Public property | U_RtgCode | Routing Code (key)
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Object belongs to concreat operation
Public property | VisOrder |
Top
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Interface
IManufacturingOrderRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Interface
IManufacturingOrderRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Interface
IManufacturingOrderRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Interface
IManufacturingOrderRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput.U_BaseLine Property

U_LineNum of selected Item

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLine() : int;
function set U_BaseLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Interface
IManufacturingOrderRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput.U_Direction Property

Direction In Or Out

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Direction() As ItemDirection
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ItemDirection U_Direction {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ItemDirection U_Direction {
 ItemDirection get( );
 void set(
   ItemDirection value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Direction() : ItemDirection;
function set U_Direction(value : ItemDirection);
This language is not supported or no code example is available.

Property Value

Type: ItemDirection
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Interface
IManufacturingOrderRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput.U_IOOprCode Property

Key for this InputOutput binding

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IOOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_IOOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_IOOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IOOprCode() : int;
function set U_IOOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Interface
IManufacturingOrderRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput.U_InTimeCalc Property

This filed fetermines if time calculation form operation us took from current Operation Only One I/O item can be selected for each operation. If there is no selected I/O Item Quantity Form header is took.

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InTimeCalc() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_InTimeCalc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_InTimeCalc {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InTimeCalc() : YesNoType;
function set U_InTimeCalc(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Interface
IManufacturingOrderRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput.U_ItemCode Property

Item Code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Interface
IManufacturingOrderRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput.U_ItemType Property

Scrap Item Coproduct Item ot Items

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemType() As ManufacturingComponentType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ManufacturingComponentType U_ItemType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ManufacturingComponentType U_ItemType {
 ManufacturingComponentType get( );
 void set(
   ManufacturingComponentType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemType() : ManufacturingComponentType;
function set U_ItemType(value : ManufacturingComponentType);
This language is not supported or no code example is available.

Property Value

Type: ManufacturingComponentType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Interface
IManufacturingOrderRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput.U_MorCode Property

MOR Code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_MorCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MorCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MorCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MorCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Interface
IManufacturingOrderRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput.U_OprCode Property

Operation Code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")> _
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")]
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")]

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")
function get U_OprCode() : String;

   AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Interface
IManufacturingOrderRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput.U_RevCode Property

Revision Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Interface
IManufacturingOrderRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput.U_RtgCode Property

Routing Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")> _
ReadOnly Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")]
string U_RtgCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")]

property String^ U_RtgCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")
function get U_RtgCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Interface
IManufacturingOrderRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput.U_RtgOprCode Property

Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Object belongs to concreat operation

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")> _
Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")]
int U_RtgOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")]

property int U_RtgOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")
function get U_RtgOprCode() : int;

   AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")
function set U_RtgOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Interface
IManufacturingOrderRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Interface
IManufacturingOrderRoutingOperationInputOutput Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutput Methods

IManufacturingOrderRoutingOperationInputOutput Interface See Also

The following tables list the members exposed by the IManufacturingOrderRoutingOperationInputOutput type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderRoutingOperationInputOutput Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties Interface

Members See Also

Properties of input output of routing operations for manufacturing order document

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean(Parent = "IManufacturingOrderRoutingOperationInputOutput")> _
Public Interface IManufacturingOrderRoutingOperationInputOutputProperties
    Inherits IUDOChildBean, _
             IEnumerable(Of IManufacturingOrderRoutingOperationInputOutputProperties)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IManufacturingOrderRoutingOperationInputOutput")]
public interface IManufacturingOrderRoutingOperationInputOutputProperties : IUDOChildBean,
   IEnumerable<IManufacturingOrderRoutingOperationInputOutputProperties>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IManufacturingOrderRoutingOperationInputOutput")]
public interface class IManufacturingOrderRoutingOperationInputOutputProperties : public IUDOChildBean^,
   public IEnumerable<IManufacturingOrderRoutingOperationInputOutputProperties^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_MOR15
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties Members

IManufacturingOrderRoutingOperationInputOutputProperties Interface Methods Properties See Also

Properties of input output of routing operations for manufacturing order document

The following tables list the members exposed by the IManufacturingOrderRoutingOperationInputOutputProperties type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_IOOprCode | Input Output Operation Code key for specific I/O binding
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MorCode | MOR Code (key)
Public property | U_OprCode | Operation code
Public property | U_PrpCode | I/O PropertyCode
Public property | U_PrpConType | Type of value
Public property | U_PrpConValue | Property Value
Public property | U_PrpConValueTo | Property Value To...
Public property | U_Remarks | Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RtgCode | Routing Code {key
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Object belongs to concreat operation
Public property | U_UnitOfMeasure | Unit Of Measure
Public property | U_WordCode | Word Code
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties Properties

IManufacturingOrderRoutingOperationInputOutputProperties Interface See Also

The following tables list the members exposed by the IManufacturingOrderRoutingOperationInputOutputProperties type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_IOOprCode | Input Output Operation Code key for specific I/O binding
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MorCode | MOR Code (key)
Public property | U_OprCode | Operation code
Public property | U_PrpCode | I/O PropertyCode
Public property | U_PrpConType | Type of value
Public property | U_PrpConValue | Property Value
Public property | U_PrpConValueTo | Property Value To...
Public property | U_Remarks | Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RtgCode | Routing Code {key
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Object belongs to concreat operation
Public property | U_UnitOfMeasure | Unit Of Measure
Public property | U_WordCode | Word Code
Public property | VisOrder |
Top
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
IManufacturingOrderRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
IManufacturingOrderRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
IManufacturingOrderRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
IManufacturingOrderRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties.U_IOOprCode Property

Input Output Operation Code key for specific I/O binding

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 4, ParentKey = "U_IOOprCode")> _
Property U_IOOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_IOOprCode")]
int U_IOOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_IOOprCode")]

property int U_IOOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 4, ParentKey = "U_IOOprCode")
function get U_IOOprCode() : int;

   AppEngineProperty(Priority = 4, ParentKey = "U_IOOprCode")
function set U_IOOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
IManufacturingOrderRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties.U_MorCode Property

MOR Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_MorCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MorCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MorCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MorCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
IManufacturingOrderRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties.U_OprCode Property

Operation code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")> _
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")]
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")]

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")
function get U_OprCode() : String;

   AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
IManufacturingOrderRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties.U_PrpCode Property

I/O PropertyCode

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpCode() : String;
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
IManufacturingOrderRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties.U_PrpConType Property

Type of value

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConType() As ConditionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ConditionType U_PrpConType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ConditionType U_PrpConType {
 ConditionType get( );
 void set(
   ConditionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConType() : ConditionType;
function set U_PrpConType(value : ConditionType);
This language is not supported or no code example is available.

Property Value

Type: ConditionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
IManufacturingOrderRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties.U_PrpConValue Property

Property Value

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValue() : double;
function set U_PrpConValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
IManufacturingOrderRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties.U_PrpConValueTo Property

Property Value To...

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValueTo() : double;
function set U_PrpConValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
IManufacturingOrderRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties.U_Remarks Property

Remarks

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
IManufacturingOrderRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties.U_RevCode Property

Revision Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
IManufacturingOrderRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties.U_RtgCode Property

Routing Code {key

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")> _
ReadOnly Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")]
string U_RtgCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")]

property String^ U_RtgCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")
function get U_RtgCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
IManufacturingOrderRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties.U_RtgOprCode Property

Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Object belongs to concreat operation

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")> _
Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")]
int U_RtgOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")]

property int U_RtgOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")
function get U_RtgOprCode() : int;

   AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")
function set U_RtgOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
IManufacturingOrderRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties.U_UnitOfMeasure Property

Unit Of Measure

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UnitOfMeasure {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UnitOfMeasure {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UnitOfMeasure() : String;
function set U_UnitOfMeasure(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
IManufacturingOrderRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties.U_WordCode Property

Word Code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
IManufacturingOrderRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
IManufacturingOrderRoutingOperationInputOutputProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationInputOutputProperties Methods

IManufacturingOrderRoutingOperationInputOutputProperties Interface See Also

The following tables list the members exposed by the IManufacturingOrderRoutingOperationInputOutputProperties type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderRoutingOperationInputOutputProperties Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties Interface

Members See Also

Properties of routing operations for manufacturing order document

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean(Parent = "IManufacturingOrderRoutingOperations")> _
Public Interface IManufacturingOrderRoutingOperationProperties
    Inherits IUDOChildBean, _
             IEnumerable(Of IManufacturingOrderRoutingOperationProperties)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IManufacturingOrderRoutingOperations")]
public interface IManufacturingOrderRoutingOperationProperties : IUDOChildBean,
   IEnumerable<IManufacturingOrderRoutingOperationProperties>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IManufacturingOrderRoutingOperations")]
public interface class IManufacturingOrderRoutingOperationProperties : public IUDOChildBean^,
   public IEnumerable<IManufacturingOrderRoutingOperationProperties^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_MOR13
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties Members

IManufacturingOrderRoutingOperationProperties Interface Methods Properties See Also

Properties of routing operations for manufacturing order document

The following tables list the members exposed by the IManufacturingOrderRoutingOperationProperties type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MorCode | MOR Code
Public property | U_OprCode | Operation Code(key)
Public property | U_PrpCode | Property Code (key)
Public property | U_PrpConType | Type of Property
Public property | U_PrpConValue | Value Of Property
Public property | U_PrpConValueTo | VAlue To of Property
Public property | U_Remarks | Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RtgCode | Routing Code(key)
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that ThisObject belongs to concreat operation
Public property | U_UnitOfMeasure | Unit Of measure
Public property | U_WordCode | Word code
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties Properties

IManufacturingOrderRoutingOperationProperties Interface See Also

The following tables list the members exposed by the IManufacturingOrderRoutingOperationProperties type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MorCode | MOR Code
Public property | U_OprCode | Operation Code(key)
Public property | U_PrpCode | Property Code (key)
Public property | U_PrpConType | Type of Property
Public property | U_PrpConValue | Value Of Property
Public property | U_PrpConValueTo | VAlue To of Property
Public property | U_Remarks | Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RtgCode | Routing Code(key)
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that ThisObject belongs to concreat operation
Public property | U_UnitOfMeasure | Unit Of measure
Public property | U_WordCode | Word code
Public property | VisOrder |
Top
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
IManufacturingOrderRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
IManufacturingOrderRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
IManufacturingOrderRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
IManufacturingOrderRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties.U_MorCode Property

MOR Code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_MorCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MorCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MorCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MorCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
IManufacturingOrderRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties.U_OprCode Property

Operation Code(key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")> _
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")]
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")]

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")
function get U_OprCode() : String;

   AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
IManufacturingOrderRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties.U_PrpCode Property

Property Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpCode() : String;
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
IManufacturingOrderRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties.U_PrpConType Property

Type of Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConType() As ConditionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ConditionType U_PrpConType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ConditionType U_PrpConType {
 ConditionType get( );
 void set(
   ConditionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConType() : ConditionType;
function set U_PrpConType(value : ConditionType);
This language is not supported or no code example is available.

Property Value

Type: ConditionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
IManufacturingOrderRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties.U_PrpConValue Property

Value Of Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValue() : double;
function set U_PrpConValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
IManufacturingOrderRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties.U_PrpConValueTo Property

VAlue To of Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValueTo() : double;
function set U_PrpConValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
IManufacturingOrderRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties.U_Remarks Property

Remarks

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
IManufacturingOrderRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties.U_RevCode Property

Revision Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
IManufacturingOrderRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties.U_RtgCode Property

Routing Code(key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")> _
ReadOnly Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")]
string U_RtgCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")]

property String^ U_RtgCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")
function get U_RtgCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
IManufacturingOrderRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties.U_RtgOprCode Property

Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that ThisObject belongs to concreat operation

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")> _
Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")]
int U_RtgOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")]

property int U_RtgOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")
function get U_RtgOprCode() : int;

   AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")
function set U_RtgOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
IManufacturingOrderRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties.U_UnitOfMeasure Property

Unit Of measure

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UnitOfMeasure {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UnitOfMeasure {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UnitOfMeasure() : String;
function set U_UnitOfMeasure(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
IManufacturingOrderRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties.U_WordCode Property

Word code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
IManufacturingOrderRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
IManufacturingOrderRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationProperties Methods

IManufacturingOrderRoutingOperationProperties Interface See Also

The following tables list the members exposed by the IManufacturingOrderRoutingOperationProperties type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderRoutingOperationProperties Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationRelations Interface

Members See Also

Relations of routing operations for manufacturing order document

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IManufacturingOrderRoutingOperationRelations
    Inherits IUDOChildBean, _
             IEnumerable(Of IManufacturingOrderRoutingOperationRelations)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IManufacturingOrderRoutingOperationRelations : IUDOChildBean,
   IEnumerable<IManufacturingOrderRoutingOperationRelations>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IManufacturingOrderRoutingOperationRelations : public IUDOChildBean^,
   public IEnumerable<IManufacturingOrderRoutingOperationRelations^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_MOR20
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationRelations Members

IManufacturingOrderRoutingOperationRelations Interface Methods Properties See Also

Relations of routing operations for manufacturing order document

The following tables list the members exposed by the IManufacturingOrderRoutingOperationRelations type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine | Reference to U_LineNum Operation for witch we want to define predacessors
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_POprLine | Reference to Operation U_LineNUm witch is predacessor
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderRoutingOperationRelations Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationRelations Properties

IManufacturingOrderRoutingOperationRelations Interface See Also

The following tables list the members exposed by the IManufacturingOrderRoutingOperationRelations type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine | Reference to U_LineNum Operation for witch we want to define predacessors
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_POprLine | Reference to Operation U_LineNUm witch is predacessor
Public property | VisOrder |
Top
See Also

Reference

IManufacturingOrderRoutingOperationRelations Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationRelations.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationRelations Interface
IManufacturingOrderRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationRelations.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationRelations Interface
IManufacturingOrderRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationRelations.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationRelations Interface
IManufacturingOrderRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationRelations.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationRelations Interface
IManufacturingOrderRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationRelations.U_BaseLine Property

Reference to U_LineNum Operation for witch we want to define predacessors

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLine() : int;
function set U_BaseLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationRelations Interface
IManufacturingOrderRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationRelations.U_POprLine Property

Reference to Operation U_LineNUm witch is predacessor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_POprLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_POprLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_POprLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_POprLine() : int;
function set U_POprLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationRelations Interface
IManufacturingOrderRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationRelations.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationRelations Interface
IManufacturingOrderRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationRelations Methods

IManufacturingOrderRoutingOperationRelations Interface See Also

The following tables list the members exposed by the IManufacturingOrderRoutingOperationRelations type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderRoutingOperationRelations Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties Interface

Members See Also

Properties of resources for routing operations for manufacturing order document

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean(Parent = "IManufacturingOrderRoutingOperationResources")> _
Public Interface IManufacturingOrderRoutingOperationResourceProperties
    Inherits IUDOChildBean, _
             IEnumerable(Of IManufacturingOrderRoutingOperationResourceProperties)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IManufacturingOrderRoutingOperationResources")]
public interface IManufacturingOrderRoutingOperationResourceProperties : IUDOChildBean,
   IEnumerable<IManufacturingOrderRoutingOperationResourceProperties>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IManufacturingOrderRoutingOperationResources")]
public interface class IManufacturingOrderRoutingOperationResourceProperties : public IUDOChildBean^,
   public IEnumerable<IManufacturingOrderRoutingOperationResourceProperties^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_MOR17
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties Members

IManufacturingOrderRoutingOperationResourceProperties Interface Methods Properties See Also

Properties of resources for routing operations for manufacturing order document

The following tables list the members exposed by the IManufacturingOrderRoutingOperationResourceProperties type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MorCode | MOR Code
Public property | U_OprCode | Operation Code (key) -Mandatory
Public property | U_PrpCode | Property Code -Mandatory
Public property | U_PrpConType | Property Type
Public property | U_PrpConValue | Property value
Public property | U_PrpConValueTo | Property Value To..
Public property | U_Remarks | Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RtOpRscCode | Routin Operation Resource ID (key for specific Resource in specific Operation ) must be filled It tels us that This Object belongs to concreat Resource -Mandatory
Public property | U_RtgCode | Routing Code (key)
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Object belongs to concreat operation -Mandatory
Public property | U_UnitOfMeasure | Unit Of Measure
Public property | U_WordCode | Word code
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties Properties

IManufacturingOrderRoutingOperationResourceProperties Interface See Also

The following tables list the members exposed by the IManufacturingOrderRoutingOperationResourceProperties type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MorCode | MOR Code
Public property | U_OprCode | Operation Code (key) -Mandatory
Public property | U_PrpCode | Property Code -Mandatory
Public property | U_PrpConType | Property Type
Public property | U_PrpConValue | Property value
Public property | U_PrpConValueTo | Property Value To..
Public property | U_Remarks | Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RtOpRscCode | Routin Operation Resource ID (key for specific Resource in specific Operation ) must be filled It tels us that This Object belongs to concreat Resource -Mandatory
Public property | U_RtgCode | Routing Code (key)
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Object belongs to concreat operation -Mandatory
Public property | U_UnitOfMeasure | Unit Of Measure
Public property | U_WordCode | Word code
Public property | VisOrder |
Top
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
IManufacturingOrderRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
IManufacturingOrderRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
IManufacturingOrderRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
IManufacturingOrderRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties.U_MorCode Property

MOR Code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_MorCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MorCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MorCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MorCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
IManufacturingOrderRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties.U_OprCode Property

Operation Code (key) -Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")> _
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")]
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")]

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")
function get U_OprCode() : String;

   AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
IManufacturingOrderRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties.U_PrpCode Property

Property Code -Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpCode() : String;
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
IManufacturingOrderRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties.U_PrpConType Property

Property Type

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConType() As ConditionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ConditionType U_PrpConType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ConditionType U_PrpConType {
 ConditionType get( );
 void set(
   ConditionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConType() : ConditionType;
function set U_PrpConType(value : ConditionType);
This language is not supported or no code example is available.

Property Value

Type: ConditionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
IManufacturingOrderRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties.U_PrpConValue Property

Property value

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValue() : double;
function set U_PrpConValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
IManufacturingOrderRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties.U_PrpConValueTo Property

Property Value To..

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValueTo() : double;
function set U_PrpConValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
IManufacturingOrderRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties.U_Remarks Property

Remarks

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
IManufacturingOrderRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties.U_RevCode Property

Revision Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
IManufacturingOrderRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties.U_RtOpRscCode Property

Routin Operation Resource ID (key for specific Resource in specific Operation ) must be filled It tels us that This Object belongs to concreat Resource -Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtOpRscCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RtOpRscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RtOpRscCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtOpRscCode() : int;
function set U_RtOpRscCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
IManufacturingOrderRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties.U_RtgCode Property

Routing Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")> _
ReadOnly Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")]
string U_RtgCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")]

property String^ U_RtgCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")
function get U_RtgCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
IManufacturingOrderRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties.U_RtgOprCode Property

Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Object belongs to concreat operation -Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")> _
Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")]
int U_RtgOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")]

property int U_RtgOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")
function get U_RtgOprCode() : int;

   AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")
function set U_RtgOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
IManufacturingOrderRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties.U_UnitOfMeasure Property

Unit Of Measure

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UnitOfMeasure {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UnitOfMeasure {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UnitOfMeasure() : String;
function set U_UnitOfMeasure(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
IManufacturingOrderRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties.U_WordCode Property

Word code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
IManufacturingOrderRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
IManufacturingOrderRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResourceProperties Methods

IManufacturingOrderRoutingOperationResourceProperties Interface See Also

The following tables list the members exposed by the IManufacturingOrderRoutingOperationResourceProperties type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderRoutingOperationResourceProperties Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources Interface

Members See Also

Resources for routing operations for manufacturing order document

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean(Parent = "IManufacturingOrderRoutingOperations")> _
Public Interface IManufacturingOrderRoutingOperationResources
    Inherits IUDOChildBean, _
             IEnumerable(Of IManufacturingOrderRoutingOperationResources)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IManufacturingOrderRoutingOperations")]
public interface IManufacturingOrderRoutingOperationResources : IUDOChildBean,
   IEnumerable<IManufacturingOrderRoutingOperationResources>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IManufacturingOrderRoutingOperations")]
public interface class IManufacturingOrderRoutingOperationResources : public IUDOChildBean^,
   public IEnumerable<IManufacturingOrderRoutingOperationResources^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_MOR16
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources Members

IManufacturingOrderRoutingOperationResources Interface Methods Properties See Also

Resources for routing operations for manufacturing order document

The following tables list the members exposed by the IManufacturingOrderRoutingOperationResources type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | QueueStartDateStartTime |
Public property | ResourceName |
Public property | RunTimeStartDateStartTime |
Public property | SetupStartDateStartTime |
Public property | StockStartDateStartTime |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ActCost |
Public property | U_ActQueue |
Public property | U_ActRun |
Public property | U_ActSetup |
Public property | U_ActStock |
Public property | U_Active | If Resource is active it is changed while rescheduling Manufacturing Order all times
Public property | U_BaseRscLine | Base Resource Line Num if Resource is splited after reschedulng
Public property | U_CycleCap | Cycle Capacity
Public property | U_Freeze |
Public property | U_HasCycles | Is this Resource works in cycles
Public property | U_IssueType | Issue Type
Public property | U_LFixedCost |
Public property | U_LTimeCost |
Public property | U_LVariableCost |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MachineCode | Machine Code if Resource type is Machine this Filed is mandatory
Public property | U_MachineLineNum | machine U_LineNum Value
Public property | U_MorCode | MOR Code
Public property | U_NrOfResources | Nuber Of Resources
Public property | U_OcrCode |
Public property | U_OcrCode2 |
Public property | U_OcrCode3 |
Public property | U_OcrCode4 |
Public property | U_OcrCode5 |
Public property | U_OprCode | Operation Code (key)
Public property | U_Project |
Public property | U_QFixedCost |
Public property | U_QTimeCost |
Public property | U_QVariableCost |
Public property | U_Qty | Quentity pre resource
Public property | U_QueueEndDate | Queue End date - ReadOnly
Public property | U_QueueEndTime | Queue End time- ReadOnly
Public property | U_QueueRate | Queue Rate
Public property | U_QueueStartDate | Queue start date - ReadOnly
Public property | U_QueueStartTime | Queue start time- ReadOnly
Public property | U_QueueTime | Queue Time
Public property | U_QueueTotal | Queue Time Span- ReadOnly
Public property | U_RFixedCost |
Public property | U_RTimeCost |
Public property | U_RVariableCost |
Public property | U_Remarks | Resource Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RscCode | ResourceCode
Public property | U_RscType | Resource Type Read-Only
Public property | U_RtgCode | Routing Code(key)
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Resource belongs to concreat operation
Public property | U_RtgOprRscCode | Automaticly Generated key For this Operation
Public property | U_RunEndDate | Run End date - ReadOnly
Public property | U_RunEndTime | Run End time- ReadOnly
Public property | U_RunRate | Run Rate
Public property | U_RunStartDate | Run start date - ReadOnly
Public property | U_RunStartTime | Run start time- ReadOnly
Public property | U_RunTime | Run Time
Public property | U_RunTotal | Run Time Span- ReadOnly
Public property | U_SFixedCost |
Public property | U_STimeCost |
Public property | U_SVariableCost |
Public property | U_SetupEndDate | Setup End date - ReadOnly
Public property | U_SetupEndTime | Setup End time- ReadOnly
Public property | U_SetupRate | SetupRate
Public property | U_SetupStartDate | Setup start date - ReadOnly
Public property | U_SetupStartTime | Setup start time- ReadOnly
Public property | U_SetupTime | SetipTime
Public property | U_SetupTotal | SetiupTime Span- ReadOnly
Public property | U_StockEndDate | Stock End date - ReadOnly
Public property | U_StockEndTime | Stock End time- ReadOnly
Public property | U_StockRate | StockRate
Public property | U_StockStartDate | Stock start date - ReadOnly
Public property | U_StockStartTime | Stock start time- ReadOnly
Public property | U_StockTime | Stock Time
Public property | U_StockTotal | Stock Time Span- ReadOnly
Public property | U_TotalSeconds | TotalOperationTime RunTime StockTime SetupTime QueueTime - ReadOnly
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources Properties

IManufacturingOrderRoutingOperationResources Interface See Also

The following tables list the members exposed by the IManufacturingOrderRoutingOperationResources type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | QueueStartDateStartTime |
Public property | ResourceName |
Public property | RunTimeStartDateStartTime |
Public property | SetupStartDateStartTime |
Public property | StockStartDateStartTime |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ActCost |
Public property | U_ActQueue |
Public property | U_ActRun |
Public property | U_ActSetup |
Public property | U_ActStock |
Public property | U_Active | If Resource is active it is changed while rescheduling Manufacturing Order all times
Public property | U_BaseRscLine | Base Resource Line Num if Resource is splited after reschedulng
Public property | U_CycleCap | Cycle Capacity
Public property | U_Freeze |
Public property | U_HasCycles | Is this Resource works in cycles
Public property | U_IssueType | Issue Type
Public property | U_LFixedCost |
Public property | U_LTimeCost |
Public property | U_LVariableCost |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MachineCode | Machine Code if Resource type is Machine this Filed is mandatory
Public property | U_MachineLineNum | machine U_LineNum Value
Public property | U_MorCode | MOR Code
Public property | U_NrOfResources | Nuber Of Resources
Public property | U_OcrCode |
Public property | U_OcrCode2 |
Public property | U_OcrCode3 |
Public property | U_OcrCode4 |
Public property | U_OcrCode5 |
Public property | U_OprCode | Operation Code (key)
Public property | U_Project |
Public property | U_QFixedCost |
Public property | U_QTimeCost |
Public property | U_QVariableCost |
Public property | U_Qty | Quentity pre resource
Public property | U_QueueEndDate | Queue End date - ReadOnly
Public property | U_QueueEndTime | Queue End time- ReadOnly
Public property | U_QueueRate | Queue Rate
Public property | U_QueueStartDate | Queue start date - ReadOnly
Public property | U_QueueStartTime | Queue start time- ReadOnly
Public property | U_QueueTime | Queue Time
Public property | U_QueueTotal | Queue Time Span- ReadOnly
Public property | U_RFixedCost |
Public property | U_RTimeCost |
Public property | U_RVariableCost |
Public property | U_Remarks | Resource Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RscCode | ResourceCode
Public property | U_RscType | Resource Type Read-Only
Public property | U_RtgCode | Routing Code(key)
Public property | U_RtgOprCode | Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Resource belongs to concreat operation
Public property | U_RtgOprRscCode | Automaticly Generated key For this Operation
Public property | U_RunEndDate | Run End date - ReadOnly
Public property | U_RunEndTime | Run End time- ReadOnly
Public property | U_RunRate | Run Rate
Public property | U_RunStartDate | Run start date - ReadOnly
Public property | U_RunStartTime | Run start time- ReadOnly
Public property | U_RunTime | Run Time
Public property | U_RunTotal | Run Time Span- ReadOnly
Public property | U_SFixedCost |
Public property | U_STimeCost |
Public property | U_SVariableCost |
Public property | U_SetupEndDate | Setup End date - ReadOnly
Public property | U_SetupEndTime | Setup End time- ReadOnly
Public property | U_SetupRate | SetupRate
Public property | U_SetupStartDate | Setup start date - ReadOnly
Public property | U_SetupStartTime | Setup start time- ReadOnly
Public property | U_SetupTime | SetipTime
Public property | U_SetupTotal | SetiupTime Span- ReadOnly
Public property | U_StockEndDate | Stock End date - ReadOnly
Public property | U_StockEndTime | Stock End time- ReadOnly
Public property | U_StockRate | StockRate
Public property | U_StockStartDate | Stock start date - ReadOnly
Public property | U_StockStartTime | Stock start time- ReadOnly
Public property | U_StockTime | Stock Time
Public property | U_StockTotal | Stock Time Span- ReadOnly
Public property | U_TotalSeconds | TotalOperationTime RunTime StockTime SetupTime QueueTime - ReadOnly
Public property | VisOrder |
Top
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.QueueStartDateStartTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property QueueStartDateStartTime() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string QueueStartDateStartTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ QueueStartDateStartTime {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get QueueStartDateStartTime() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.ResourceName Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property ResourceName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string ResourceName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ ResourceName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ResourceName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.RunTimeStartDateStartTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RunTimeStartDateStartTime() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string RunTimeStartDateStartTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ RunTimeStartDateStartTime {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RunTimeStartDateStartTime() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.SetupStartDateStartTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property SetupStartDateStartTime() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string SetupStartDateStartTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ SetupStartDateStartTime {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get SetupStartDateStartTime() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.StockStartDateStartTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property StockStartDateStartTime() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string StockStartDateStartTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ StockStartDateStartTime {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get StockStartDateStartTime() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_ActCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ActCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ActCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActCost() : double;
function set U_ActCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_ActQueue Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActQueue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ActQueue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ActQueue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActQueue() : double;
function set U_ActQueue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_ActRun Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActRun() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ActRun {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ActRun {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActRun() : double;
function set U_ActRun(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_ActSetup Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActSetup() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ActSetup {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ActSetup {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActSetup() : double;
function set U_ActSetup(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_ActStock Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActStock() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ActStock {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ActStock {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActStock() : double;
function set U_ActStock(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_Active Property

If Resource is active it is changed while rescheduling Manufacturing Order all times

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Active() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Active {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Active {
 YesNoType get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Active() : YesNoType;
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_BaseRscLine Property

Base Resource Line Num if Resource is splited after reschedulng

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BaseRscLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseRscLine {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseRscLine {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseRscLine() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_CycleCap Property

Cycle Capacity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CycleCap() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_CycleCap {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_CycleCap {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CycleCap() : double;
function set U_CycleCap(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_Freeze Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Freeze() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Freeze {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Freeze {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Freeze() : YesNoType;
function set U_Freeze(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_HasCycles Property

Is this Resource works in cycles

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_HasCycles() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_HasCycles {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_HasCycles {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_HasCycles() : YesNoType;
function set U_HasCycles(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_IssueType Property

Issue Type

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IssueType() As IssueType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IssueType U_IssueType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IssueType U_IssueType {
 IssueType get( );
 void set(
   IssueType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IssueType() : IssueType;
function set U_IssueType(value : IssueType);
This language is not supported or no code example is available.

Property Value

Type: IssueType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_LFixedCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LFixedCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_LFixedCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_LFixedCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LFixedCost() : double;
function set U_LFixedCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_LTimeCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LTimeCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_LTimeCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_LTimeCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LTimeCost() : double;
function set U_LTimeCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_LVariableCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LVariableCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_LVariableCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_LVariableCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LVariableCost() : double;
function set U_LVariableCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_MachineCode Property

Machine Code if Resource type is Machine this Filed is mandatory

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MachineCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MachineCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MachineCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MachineCode() : String;
function set U_MachineCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_MachineLineNum Property

machine U_LineNum Value

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MachineLineNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_MachineLineNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_MachineLineNum {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MachineLineNum() : int;
function set U_MachineLineNum(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_MorCode Property

MOR Code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_MorCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MorCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MorCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MorCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_NrOfResources Property

Nuber Of Resources

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_NrOfResources() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_NrOfResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_NrOfResources {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_NrOfResources() : int;
function set U_NrOfResources(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_OcrCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode() : String;
function set U_OcrCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_OcrCode2 Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode2() : String;
function set U_OcrCode2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_OcrCode3 Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode3() : String;
function set U_OcrCode3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_OcrCode4 Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode4() : String;
function set U_OcrCode4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_OcrCode5 Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode5() : String;
function set U_OcrCode5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_OprCode Property

Operation Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")> _
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")]
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")]

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")
function get U_OprCode() : String;

   AppEngineProperty(Priority = 4, ParentKey = "U_OprCode")
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_Project Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Project() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Project {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Project {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Project() : String;
function set U_Project(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_QFixedCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QFixedCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_QFixedCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_QFixedCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QFixedCost() : double;
function set U_QFixedCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_QTimeCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QTimeCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_QTimeCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_QTimeCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QTimeCost() : double;
function set U_QTimeCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_QVariableCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QVariableCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_QVariableCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_QVariableCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QVariableCost() : double;
function set U_QVariableCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_Qty Property

Quentity pre resource

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Qty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Qty {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Qty {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Qty() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_QueueEndDate Property

Queue End date - ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_QueueEndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_QueueEndDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_QueueEndDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueEndDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_QueueEndTime Property

Queue End time- ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_QueueEndTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_QueueEndTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_QueueEndTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueEndTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_QueueRate Property

Queue Rate

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QueueRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_QueueRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_QueueRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueRate() : RateType;
function set U_QueueRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_QueueStartDate Property

Queue start date - ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_QueueStartDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_QueueStartDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_QueueStartDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueStartDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_QueueStartTime Property

Queue start time- ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_QueueStartTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_QueueStartTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_QueueStartTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueStartTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_QueueTime Property

Queue Time

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QueueTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_QueueTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_QueueTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueTime() : double;
function set U_QueueTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_QueueTotal Property

Queue Time Span- ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_QueueTotal() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan U_QueueTotal {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan U_QueueTotal {
 TimeSpan get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueTotal() : TimeSpan;
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_RFixedCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RFixedCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RFixedCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RFixedCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RFixedCost() : double;
function set U_RFixedCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_RTimeCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RTimeCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RTimeCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RTimeCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RTimeCost() : double;
function set U_RTimeCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_RVariableCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RVariableCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RVariableCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RVariableCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RVariableCost() : double;
function set U_RVariableCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_Remarks Property

Resource Remarks

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_RevCode Property

Revision Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_RscCode Property

ResourceCode

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCode() : String;
function set U_RscCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_RscType Property

Resource Type Read-Only

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RscType() As ResourceType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ResourceType U_RscType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ResourceType U_RscType {
 ResourceType get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscType() : ResourceType;
This language is not supported or no code example is available.

Property Value

Type: ResourceType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_RtgCode Property

Routing Code(key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")> _
ReadOnly Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")]
string U_RtgCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")]

property String^ U_RtgCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")
function get U_RtgCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_RtgOprCode Property

Routing Operation ID (key for specific operation in specific Routing ) mmust be filled. It tels us that This Resource belongs to concreat operation

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")> _
Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")]
int U_RtgOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")]

property int U_RtgOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")
function get U_RtgOprCode() : int;

   AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")
function set U_RtgOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_RtgOprRscCode Property

Automaticly Generated key For this Operation

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RtgOprRscCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RtgOprRscCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RtgOprRscCode {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgOprRscCode() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_RunEndDate Property

Run End date - ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RunEndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_RunEndDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_RunEndDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunEndDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_RunEndTime Property

Run End time- ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RunEndTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_RunEndTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_RunEndTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunEndTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_RunRate Property

Run Rate

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RunRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_RunRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_RunRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunRate() : RateType;
function set U_RunRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_RunStartDate Property

Run start date - ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RunStartDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_RunStartDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_RunStartDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunStartDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_RunStartTime Property

Run start time- ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RunStartTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_RunStartTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_RunStartTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunStartTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_RunTime Property

Run Time

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RunTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RunTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RunTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunTime() : double;
function set U_RunTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_RunTotal Property

Run Time Span- ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RunTotal() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan U_RunTotal {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan U_RunTotal {
 TimeSpan get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunTotal() : TimeSpan;
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_SFixedCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SFixedCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_SFixedCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_SFixedCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SFixedCost() : double;
function set U_SFixedCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_STimeCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_STimeCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_STimeCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_STimeCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_STimeCost() : double;
function set U_STimeCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_SVariableCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SVariableCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_SVariableCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_SVariableCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SVariableCost() : double;
function set U_SVariableCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_SetupEndDate Property

Setup End date - ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_SetupEndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_SetupEndDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_SetupEndDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupEndDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_SetupEndTime Property

Setup End time- ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_SetupEndTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_SetupEndTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_SetupEndTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupEndTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_SetupRate Property

SetupRate

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SetupRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_SetupRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_SetupRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupRate() : RateType;
function set U_SetupRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_SetupStartDate Property

Setup start date - ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_SetupStartDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_SetupStartDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_SetupStartDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupStartDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_SetupStartTime Property

Setup start time- ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_SetupStartTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_SetupStartTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_SetupStartTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupStartTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_SetupTime Property

SetipTime

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SetupTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_SetupTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_SetupTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupTime() : double;
function set U_SetupTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_SetupTotal Property

SetiupTime Span- ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_SetupTotal() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan U_SetupTotal {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan U_SetupTotal {
 TimeSpan get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupTotal() : TimeSpan;
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_StockEndDate Property

Stock End date - ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_StockEndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StockEndDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StockEndDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockEndDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_StockEndTime Property

Stock End time- ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_StockEndTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StockEndTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StockEndTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockEndTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_StockRate Property

StockRate

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StockRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_StockRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_StockRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockRate() : RateType;
function set U_StockRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_StockStartDate Property

Stock start date - ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_StockStartDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StockStartDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StockStartDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockStartDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_StockStartTime Property

Stock start time- ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_StockStartTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StockStartTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StockStartTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockStartTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_StockTime Property

Stock Time

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StockTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_StockTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_StockTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockTime() : double;
function set U_StockTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_StockTotal Property

Stock Time Span- ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_StockTotal() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan U_StockTotal {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan U_StockTotal {
 TimeSpan get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockTotal() : TimeSpan;
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.U_TotalSeconds Property

TotalOperationTime RunTime StockTime SetupTime QueueTime - ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_TotalSeconds() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan U_TotalSeconds {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan U_TotalSeconds {
 TimeSpan get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TotalSeconds() : TimeSpan;
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
IManufacturingOrderRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperationResources Methods

IManufacturingOrderRoutingOperationResources Interface See Also

The following tables list the members exposed by the IManufacturingOrderRoutingOperationResources type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderRoutingOperationResources Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations Interface

Members See Also

Routing operations for manufacturing order document

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IManufacturingOrderRoutingOperations
    Inherits IUDOChildBean, _
             IEnumerable(Of IManufacturingOrderRoutingOperations), _
             IBaseOperationRelation
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IManufacturingOrderRoutingOperations : IUDOChildBean,
   IEnumerable<IManufacturingOrderRoutingOperations>,
   IBaseOperationRelation
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IManufacturingOrderRoutingOperations : public IUDOChildBean^,
   public IEnumerable<IManufacturingOrderRoutingOperations^>^,
   public IBaseOperationRelation^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_MOR12
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations Members

IManufacturingOrderRoutingOperations Interface Methods Properties See Also

Routing operations for manufacturing order document

The following tables list the members exposed by the IManufacturingOrderRoutingOperations type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | OperationName | Operation Name- ReadOnly
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine | Line Num of Correspondend Operation from Bom if it was copied from Bom
Public property | U_BaseMorCode | Base Bom Item Code
Public property | U_BaseRevCode | Base Bom Revision Code
Public property | U_BaseRtgCode | Routing Code
Public property | U_BaseRtgOprCode | Base Bom RtgOprCode
Public property | U_ForceExecOrder | Returns Yes if Force Execution Order is required
Public property | U_HasRelations | Returns Yes if Operation has declared Relations
Public property | U_IgnoreYield |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MorCode | MOR Code (key)
Public property | U_OperEndDate |
Public property | U_OperEndTime |
Public property | U_OperStartDate |
Public property | U_OperStartTime |
Public property | U_OprCode | Operation Code
Public property | U_OprOverlayCode | Overlapping Operation Code
Public property | U_OprOverlayId | Id for Overlapping Operation
Public property | U_OprOverlayQty | Overlapping Quantity
Public property | U_OprSequence | Operation Sequence
Public property | U_Origin |
Public property | U_QCActive | Returns Yes if Quality Control is Active
Public property | U_QCTestDocEntry | QC Test DocEntry
Public property | U_RelationType | Specifies Relation Type
Public property | U_Remarks | Operation Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RtgCode | Routing Code (key)
Public property | U_RtgOprCode | Routing Operation Key this is automaticly generated after fillinf U_RtgCode and U_OprCode it is Key for this operation int this routing
Public property | U_Status | operation Status
Public property | U_TestProtocolNo | Test Protocol No
Public property | U_TotalSeconds |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | GetCalucationQuantity |
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderRoutingOperations Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations Properties

IManufacturingOrderRoutingOperations Interface See Also

The following tables list the members exposed by the IManufacturingOrderRoutingOperations type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | OperationName | Operation Name- ReadOnly
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine | Line Num of Correspondend Operation from Bom if it was copied from Bom
Public property | U_BaseMorCode | Base Bom Item Code
Public property | U_BaseRevCode | Base Bom Revision Code
Public property | U_BaseRtgCode | Routing Code
Public property | U_BaseRtgOprCode | Base Bom RtgOprCode
Public property | U_ForceExecOrder | Returns Yes if Force Execution Order is required
Public property | U_HasRelations | Returns Yes if Operation has declared Relations
Public property | U_IgnoreYield |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MorCode | MOR Code (key)
Public property | U_OperEndDate |
Public property | U_OperEndTime |
Public property | U_OperStartDate |
Public property | U_OperStartTime |
Public property | U_OprCode | Operation Code
Public property | U_OprOverlayCode | Overlapping Operation Code
Public property | U_OprOverlayId | Id for Overlapping Operation
Public property | U_OprOverlayQty | Overlapping Quantity
Public property | U_OprSequence | Operation Sequence
Public property | U_Origin |
Public property | U_QCActive | Returns Yes if Quality Control is Active
Public property | U_QCTestDocEntry | QC Test DocEntry
Public property | U_RelationType | Specifies Relation Type
Public property | U_Remarks | Operation Remarks
Public property | U_RevCode | Revision Code (key)
Public property | U_RtgCode | Routing Code (key)
Public property | U_RtgOprCode | Routing Operation Key this is automaticly generated after fillinf U_RtgCode and U_OprCode it is Key for this operation int this routing
Public property | U_Status | operation Status
Public property | U_TestProtocolNo | Test Protocol No
Public property | U_TotalSeconds |
Public property | VisOrder |
Top
See Also

Reference

IManufacturingOrderRoutingOperations Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.OperationName Property

Operation Name- ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property OperationName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string OperationName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ OperationName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get OperationName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_BaseLine Property

Line Num of Correspondend Operation from Bom if it was copied from Bom

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLine() : int;
function set U_BaseLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_BaseMorCode Property

Base Bom Item Code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BaseMorCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BaseMorCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BaseMorCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseMorCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_BaseRevCode Property

Base Bom Revision Code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BaseRevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BaseRevCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BaseRevCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseRevCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_BaseRtgCode Property

Routing Code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BaseRtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BaseRtgCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BaseRtgCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseRtgCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_BaseRtgOprCode Property

Base Bom RtgOprCode

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BaseRtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseRtgOprCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseRtgOprCode {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseRtgOprCode() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_ForceExecOrder Property

Returns Yes if Force Execution Order is required

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ForceExecOrder() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_ForceExecOrder {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_ForceExecOrder {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ForceExecOrder() : YesNoType;
function set U_ForceExecOrder(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_HasRelations Property

Returns Yes if Operation has declared Relations

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_HasRelations() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_HasRelations {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_HasRelations {
 YesNoType get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_HasRelations() : YesNoType;
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_IgnoreYield Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IgnoreYield() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_IgnoreYield {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_IgnoreYield {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IgnoreYield() : YesNoType;
function set U_IgnoreYield(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_MorCode Property

MOR Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_MorCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MorCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MorCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MorCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_OperEndDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_OperEndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_OperEndDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_OperEndDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OperEndDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_OperEndTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_OperEndTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_OperEndTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_OperEndTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OperEndTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_OperStartDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_OperStartDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_OperStartDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_OperStartDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OperStartDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_OperStartTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_OperStartTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_OperStartTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_OperStartTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OperStartTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_OprCode Property

Operation Code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprCode() : String;
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_OprOverlayCode Property

Overlapping Operation Code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprOverlayCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprOverlayCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprOverlayCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprOverlayCode() : String;
function set U_OprOverlayCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_OprOverlayId Property

Id for Overlapping Operation

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprOverlayId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_OprOverlayId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_OprOverlayId {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprOverlayId() : int;
function set U_OprOverlayId(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_OprOverlayQty Property

Overlapping Quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprOverlayQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_OprOverlayQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_OprOverlayQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprOverlayQty() : double;
function set U_OprOverlayQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_OprSequence Property

Operation Sequence

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprSequence() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_OprSequence {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_OprSequence {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprSequence() : int;
function set U_OprSequence(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_Origin Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Origin() As ItemOriginType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ItemOriginType U_Origin {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ItemOriginType U_Origin {
 ItemOriginType get( );
 void set(
   ItemOriginType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Origin() : ItemOriginType;
function set U_Origin(value : ItemOriginType);
This language is not supported or no code example is available.

Property Value

Type: ItemOriginType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_QCActive Property

Returns Yes if Quality Control is Active

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QCActive() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_QCActive {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_QCActive {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QCActive() : YesNoType;
function set U_QCActive(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_QCTestDocEntry Property

QC Test DocEntry

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QCTestDocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_QCTestDocEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_QCTestDocEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QCTestDocEntry() : int;
function set U_QCTestDocEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_RelationType Property

Specifies Relation Type

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RelationType() As OperationRelationType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
OperationRelationType U_RelationType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property OperationRelationType U_RelationType {
 OperationRelationType get( );
 void set(
   OperationRelationType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RelationType() : OperationRelationType;
function set U_RelationType(value : OperationRelationType);
This language is not supported or no code example is available.

Property Value

Type: OperationRelationType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_Remarks Property

Operation Remarks

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_RevCode Property

Revision Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_RtgCode Property

Routing Code (key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RtgCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RtgCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_RtgOprCode Property

Routing Operation Key this is automaticly generated after fillinf U_RtgCode and U_OprCode it is Key for this operation int this routing

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RtgOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RtgOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgOprCode() : int;
function set U_RtgOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_Status Property

operation Status

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Status() As PFOperationStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
PFOperationStatus U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property PFOperationStatus U_Status {
 PFOperationStatus get( );
 void set(
   PFOperationStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Status() : PFOperationStatus;
function set U_Status(value : PFOperationStatus);
This language is not supported or no code example is available.

Property Value

Type: PFOperationStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_TestProtocolNo Property

Test Protocol No

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestProtocolNo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TestProtocolNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TestProtocolNo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestProtocolNo() : String;
function set U_TestProtocolNo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.U_TotalSeconds Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_TotalSeconds() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan U_TotalSeconds {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan U_TotalSeconds {
 TimeSpan get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TotalSeconds() : TimeSpan;
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations Methods

IManufacturingOrderRoutingOperations Interface See Also

The following tables list the members exposed by the IManufacturingOrderRoutingOperations type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | GetCalucationQuantity |
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderRoutingOperations Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderRoutingOperations.GetCalucationQuantity Method

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetCalucationQuantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double GetCalucationQuantity()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

double GetCalucationQuantity()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetCalucationQuantity() : double;
This language is not supported or no code example is available.

Return Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderRoutingOperations Interface
IManufacturingOrderRoutingOperations Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderSalesOrders Interface

Members See Also

Sales orders of manufacturing order document

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IManufacturingOrderSalesOrders
    Inherits IUDOChildBean, _
             IEnumerable(Of IManufacturingOrderSalesOrders)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IManufacturingOrderSalesOrders : IUDOChildBean,
   IEnumerable<IManufacturingOrderSalesOrders>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IManufacturingOrderSalesOrders : public IUDOChildBean^,
   public IEnumerable<IManufacturingOrderSalesOrders^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_MOR6
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderSalesOrders Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderSalesOrders Members

IManufacturingOrderSalesOrders Interface Methods Properties See Also

Sales orders of manufacturing order document

The following tables list the members exposed by the IManufacturingOrderSalesOrders type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_DocEntry | Sales Order DocEntry (key)
Public property | U_DocNo | Sales Order DocNum
Public property | U_ItemCode | Sales Order Line Item Code
Public property | U_ItemName | Sales Order Line Item Description
Public property | U_LineNo | Sales Order Line Number
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Quantity | Sales Order Line Quantity
Public property | U_WhsCode | Sales Order Line Warehouse Code
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | IsRowFilled | This method checks if row is filled or empty
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderSalesOrders Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderSalesOrders Properties

IManufacturingOrderSalesOrders Interface See Also

The following tables list the members exposed by the IManufacturingOrderSalesOrders type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_DocEntry | Sales Order DocEntry (key)
Public property | U_DocNo | Sales Order DocNum
Public property | U_ItemCode | Sales Order Line Item Code
Public property | U_ItemName | Sales Order Line Item Description
Public property | U_LineNo | Sales Order Line Number
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Quantity | Sales Order Line Quantity
Public property | U_WhsCode | Sales Order Line Warehouse Code
Public property | VisOrder |
Top
See Also

Reference

IManufacturingOrderSalesOrders Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderSalesOrders.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderSalesOrders Interface
IManufacturingOrderSalesOrders Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderSalesOrders.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderSalesOrders Interface
IManufacturingOrderSalesOrders Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderSalesOrders.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderSalesOrders Interface
IManufacturingOrderSalesOrders Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderSalesOrders.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderSalesOrders Interface
IManufacturingOrderSalesOrders Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderSalesOrders.U_DocEntry Property

Sales Order DocEntry (key)

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_DocEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_DocEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DocEntry() : int;
function set U_DocEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderSalesOrders Interface
IManufacturingOrderSalesOrders Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderSalesOrders.U_DocNo Property

Sales Order DocNum

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DocNo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DocNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DocNo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DocNo() : String;
function set U_DocNo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderSalesOrders Interface
IManufacturingOrderSalesOrders Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderSalesOrders.U_ItemCode Property

Sales Order Line Item Code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderSalesOrders Interface
IManufacturingOrderSalesOrders Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderSalesOrders.U_ItemName Property

Sales Order Line Item Description

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemName() : String;
function set U_ItemName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderSalesOrders Interface
IManufacturingOrderSalesOrders Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderSalesOrders.U_LineNo Property

Sales Order Line Number

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LineNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_LineNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_LineNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LineNo() : int;
function set U_LineNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderSalesOrders Interface
IManufacturingOrderSalesOrders Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderSalesOrders.U_Quantity Property

Sales Order Line Quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderSalesOrders Interface
IManufacturingOrderSalesOrders Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderSalesOrders.U_WhsCode Property

Sales Order Line Warehouse Code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderSalesOrders Interface
IManufacturingOrderSalesOrders Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderSalesOrders.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderSalesOrders Interface
IManufacturingOrderSalesOrders Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderSalesOrders Methods

IManufacturingOrderSalesOrders Interface See Also

The following tables list the members exposed by the IManufacturingOrderSalesOrders type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | IsRowFilled | This method checks if row is filled or empty
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderSalesOrders Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderSalesOrders.IsRowFilled Method

This method checks if row is filled or empty

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function IsRowFilled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool IsRowFilled()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool IsRowFilled()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function IsRowFilled() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderSalesOrders Interface
IManufacturingOrderSalesOrders Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps Interface

Members See Also

Scraps of manufacturing order document

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IManufacturingOrderScraps
    Inherits IUDOChildBean, _
             IEnumerable(Of IManufacturingOrderScraps)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IManufacturingOrderScraps : IUDOChildBean,
   IEnumerable<IManufacturingOrderScraps>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IManufacturingOrderScraps : public IUDOChildBean^,
   public IEnumerable<IManufacturingOrderScraps^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_MOR4
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps Members

IManufacturingOrderScraps Interface Methods Properties See Also

Scraps of manufacturing order document

The following tables list the members exposed by the IManufacturingOrderScraps type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | DsRowNum |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | RevisionName | User Data Source that holds Distribution Rules or Cost Centres codes
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ActCost |
Public property | U_ActualQty | Scraps Actual Quantity
Public property | U_BaseLine | Scraps Base Line number
Public property | U_BaseQty | Scraps Base Quantity
Public property | U_BatchResult | Batch Result based on specific formula used in Costing read-only
Public property | U_CostTotal |
Public property | U_Description | Scraps Description
Public property | U_Editable | Editable
Public property | U_EndDate | End date.
Public property | U_Factor | Scraps Factor
Public property | U_FactorDescription | Scraps Factor's Description
Public property | U_FixedCost |
Public property | U_Formula | Scraps Formula to calculate result
Public property | U_InventoryUoM | Scraps Unit of measure
Public property | U_IssueType | Scraps Issue Type
Public property | U_ItemCode | Scraps ItemCode
Public property | U_ItemCost |
Public property | U_ItemResources |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Locked |
Public property | U_OcrCode | Scraps Distribution Rule or Cost Centre code in Dimension 1
Public property | U_OcrCode2 | Scraps Distribution Rule or Cost Centre code in Dimension 2
Public property | U_OcrCode3 | Scraps Distribution Rule or Cost Centre code in Dimension 3
Public property | U_OcrCode4 | Scraps Distribution Rule or Cost Centre code in Dimension 4
Public property | U_OcrCode5 | Scraps Distribution Rule or Cost Centre code in Dimension 5
Public property | U_Origin |
Public property | U_PlannedQty | Scraps Planned Quantity
Public property | U_Price | Scraps Price
Public property | U_Project | Scraps Project code
Public property | U_Quantity | Scraps Quantity
Public property | U_Remarks | Scraps Remarks
Public property | U_Result | Scraps Result based on specific formula
Public property | U_Revision |
Public property | U_Sequence | Scraps Sequence number
Public property | U_StartDate | Start date.
Public property | U_Type | Type
Public property | U_VariableCost |
Public property | U_WhsCode | Scraps Warehouse Code
Public property | U_Yield |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderScraps Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps Properties

IManufacturingOrderScraps Interface See Also

The following tables list the members exposed by the IManufacturingOrderScraps type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | DsRowNum |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | RevisionName | User Data Source that holds Distribution Rules or Cost Centres codes
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ActCost |
Public property | U_ActualQty | Scraps Actual Quantity
Public property | U_BaseLine | Scraps Base Line number
Public property | U_BaseQty | Scraps Base Quantity
Public property | U_BatchResult | Batch Result based on specific formula used in Costing read-only
Public property | U_CostTotal |
Public property | U_Description | Scraps Description
Public property | U_Editable | Editable
Public property | U_EndDate | End date.
Public property | U_Factor | Scraps Factor
Public property | U_FactorDescription | Scraps Factor's Description
Public property | U_FixedCost |
Public property | U_Formula | Scraps Formula to calculate result
Public property | U_InventoryUoM | Scraps Unit of measure
Public property | U_IssueType | Scraps Issue Type
Public property | U_ItemCode | Scraps ItemCode
Public property | U_ItemCost |
Public property | U_ItemResources |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Locked |
Public property | U_OcrCode | Scraps Distribution Rule or Cost Centre code in Dimension 1
Public property | U_OcrCode2 | Scraps Distribution Rule or Cost Centre code in Dimension 2
Public property | U_OcrCode3 | Scraps Distribution Rule or Cost Centre code in Dimension 3
Public property | U_OcrCode4 | Scraps Distribution Rule or Cost Centre code in Dimension 4
Public property | U_OcrCode5 | Scraps Distribution Rule or Cost Centre code in Dimension 5
Public property | U_Origin |
Public property | U_PlannedQty | Scraps Planned Quantity
Public property | U_Price | Scraps Price
Public property | U_Project | Scraps Project code
Public property | U_Quantity | Scraps Quantity
Public property | U_Remarks | Scraps Remarks
Public property | U_Result | Scraps Result based on specific formula
Public property | U_Revision |
Public property | U_Sequence | Scraps Sequence number
Public property | U_StartDate | Start date.
Public property | U_Type | Type
Public property | U_VariableCost |
Public property | U_WhsCode | Scraps Warehouse Code
Public property | U_Yield |
Public property | VisOrder |
Top
See Also

Reference

IManufacturingOrderScraps Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.DsRowNum Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DsRowNum() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DsRowNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DsRowNum {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DsRowNum() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.RevisionName Property

User Data Source that holds Distribution Rules or Cost Centres codes

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property RevisionName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string RevisionName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ RevisionName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get RevisionName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_ActCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ActCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ActCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActCost() : double;
function set U_ActCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_ActualQty Property

Scraps Actual Quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActualQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ActualQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ActualQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActualQty() : double;
function set U_ActualQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_BaseLine Property

Scraps Base Line number

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLine() : int;
function set U_BaseLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_BaseQty Property

Scraps Base Quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_BaseQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_BaseQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseQty() : double;
function set U_BaseQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_BatchResult Property

Batch Result based on specific formula used in Costing read-only

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BatchResult() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_BatchResult {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_BatchResult {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchResult() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_CostTotal Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CostTotal() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_CostTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_CostTotal {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CostTotal() : double;
function set U_CostTotal(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_Description Property

Scraps Description

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Description() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Description {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Description {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Description() : String;
function set U_Description(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_Editable Property

Editable

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Editable() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Editable {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Editable {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Editable() : String;
function set U_Editable(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_EndDate Property

End date.

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_EndDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_EndDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EndDate() : DateTime;
function set U_EndDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_Factor Property

Scraps Factor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Factor() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Factor {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Factor {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Factor() : double;
function set U_Factor(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_FactorDescription Property

Scraps Factor's Description

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FactorDescription() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FactorDescription {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FactorDescription {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FactorDescription() : String;
function set U_FactorDescription(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_FixedCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FixedCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixedCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixedCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixedCost() : double;
function set U_FixedCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_Formula Property

Scraps Formula to calculate result

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Formula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Formula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Formula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Formula() : String;
function set U_Formula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_InventoryUoM Property

Scraps Unit of measure

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InventoryUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InventoryUoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InventoryUoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InventoryUoM() : String;
function set U_InventoryUoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_IssueType Property

Scraps Issue Type

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IssueType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_IssueType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_IssueType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IssueType() : String;
function set U_IssueType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_ItemCode Property

Scraps ItemCode

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_ItemCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ItemCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ItemCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCost() : double;
function set U_ItemCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_ItemResources Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemResources() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ItemResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ItemResources {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemResources() : double;
function set U_ItemResources(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_Locked Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Locked() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Locked {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Locked {
 YesNoType get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Locked() : YesNoType;
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_OcrCode Property

Scraps Distribution Rule or Cost Centre code in Dimension 1

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode() : String;
function set U_OcrCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_OcrCode2 Property

Scraps Distribution Rule or Cost Centre code in Dimension 2

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode2() : String;
function set U_OcrCode2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_OcrCode3 Property

Scraps Distribution Rule or Cost Centre code in Dimension 3

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode3() : String;
function set U_OcrCode3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_OcrCode4 Property

Scraps Distribution Rule or Cost Centre code in Dimension 4

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode4() : String;
function set U_OcrCode4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_OcrCode5 Property

Scraps Distribution Rule or Cost Centre code in Dimension 5

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode5() : String;
function set U_OcrCode5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_Origin Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Origin() As ItemOriginType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ItemOriginType U_Origin {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ItemOriginType U_Origin {
 ItemOriginType get( );
 void set(
   ItemOriginType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Origin() : ItemOriginType;
function set U_Origin(value : ItemOriginType);
This language is not supported or no code example is available.

Property Value

Type: ItemOriginType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_PlannedQty Property

Scraps Planned Quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PlannedQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PlannedQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PlannedQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PlannedQty() : double;
function set U_PlannedQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_Price Property

Scraps Price

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Price() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Price {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Price {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Price() : double;
function set U_Price(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_Project Property

Scraps Project code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Project() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Project {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Project {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Project() : String;
function set U_Project(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_Quantity Property

Scraps Quantity

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_Remarks Property

Scraps Remarks

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_Result Property

Scraps Result based on specific formula

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Result() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Result {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Result {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Result() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_Revision Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Revision() : String;
function set U_Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_Sequence Property

Scraps Sequence number

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Sequence() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_Sequence {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_Sequence {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Sequence() : int;
function set U_Sequence(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_StartDate Property

Start date.

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StartDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StartDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StartDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StartDate() : DateTime;
function set U_StartDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_Type Property

Type

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Type() As ScrapType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ScrapType U_Type {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ScrapType U_Type {
 ScrapType get( );
 void set(
   ScrapType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Type() : ScrapType;
function set U_Type(value : ScrapType);
This language is not supported or no code example is available.

Property Value

Type: ScrapType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_VariableCost Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VariableCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VariableCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VariableCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VariableCost() : double;
function set U_VariableCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_WhsCode Property

Scraps Warehouse Code

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.U_Yield Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Yield() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Yield {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Yield {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Yield() : double;
function set U_Yield(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrderScraps Interface
IManufacturingOrderScraps Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IManufacturingOrderScraps Methods

IManufacturingOrderScraps Interface See Also

The following tables list the members exposed by the IManufacturingOrderScraps type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IManufacturingOrderScraps Interface
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


PFOperationStatus Enumeration

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
NotStarted | NS
Started | ST
Holded | HO
Finished | FI
See Also

Reference

CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


PF_MORSchedulingMthd Enumeration

Descripes Types of Scheduling Methood

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Backward |
Forward |
See Also

Reference

CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


SplitMode Enumeration

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
ByNrOfMors |
BySplitQty |
See Also

Reference

CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | DocumentCreatingException | The exception that is thrown when Manufacturing Order document or Production Order document could not be created.
Public class | DocumentExistingException | The exception that is thrown when the existence checking of a Manufacturing Order document or a Production Order document has failed.
Public class | DocumentRetrievingException | The exception that is thrown when the data of a Manufacturing Order document or a Production Order document could not be retrieved.
Public class | DocumentUpdatingException | The exception that is thrown when the data of a Manufacturing Order document or a Production Order document could not be updated.
Public class | InvalidManufacturingOrderStatusException | The exception that is thrown when the status of a Manufacturing Order document could not be recognized as a known status.
Public class | SynchronizationException | The exception that is thrown when the synchronization of a Manufacturing Order document with a Production Order document has failed.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


DocumentCreatingException Class

Members See Also

The exception that is thrown when Manufacturing Order document or Production Order document could not be created.

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class DocumentCreatingException
    Inherits SynchronizationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DocumentCreatingException : SynchronizationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class DocumentCreatingException : public SynchronizationException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DocumentCreatingException
   extends SynchronizationException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization.SynchronizationException
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization.DocumentCreatingException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentCreatingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentCreatingException Members

DocumentCreatingException Class Constructors Methods Properties See Also

The exception that is thrown when Manufacturing Order document or Production Order document could not be created.

The following tables list the members exposed by the DocumentCreatingException type.

Constructors
 | Name | Description
Public constructor | DocumentCreatingException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | DocumentEntry | Gets the document entry of a document for which the exception occurred.
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

DocumentCreatingException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentCreatingException Constructor

DocumentCreatingException Class See Also

Overload List
Name | Description
DocumentCreatingException(string) |
DocumentCreatingException(string, Exception) |
DocumentCreatingException(string, int) |
See Also

Reference

DocumentCreatingException Class
DocumentCreatingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentCreatingException Properties

DocumentCreatingException Class See Also

The following tables list the members exposed by the DocumentCreatingException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | DocumentEntry | Gets the document entry of a document for which the exception occurred.
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

DocumentCreatingException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentCreatingException.DocumentEntry Property

Gets the document entry of a document for which the exception occurred.

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property DocumentEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int DocumentEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int DocumentEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocumentEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentCreatingException Class
DocumentCreatingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentCreatingException Methods

DocumentCreatingException Class See Also

The following tables list the members exposed by the DocumentCreatingException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

DocumentCreatingException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentExistingException Class

Members See Also

The exception that is thrown when the existence checking of a Manufacturing Order document or a Production Order document has failed.

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class DocumentExistingException
    Inherits ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DocumentExistingException : ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class DocumentExistingException : public ApplicationException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DocumentExistingException
   extends ApplicationException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization.DocumentExistingException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentExistingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentExistingException Members

DocumentExistingException Class Constructors Methods Properties See Also

The exception that is thrown when the existence checking of a Manufacturing Order document or a Production Order document has failed.

The following tables list the members exposed by the DocumentExistingException type.

Constructors
 | Name | Description
Public constructor | DocumentExistingException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

DocumentExistingException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentExistingException Constructor

DocumentExistingException Class See Also

Overload List
Name | Description
DocumentExistingException(string) |
DocumentExistingException(string, Exception) |
See Also

Reference

DocumentExistingException Class
DocumentExistingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentExistingException Properties

DocumentExistingException Class See Also

The following tables list the members exposed by the DocumentExistingException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

DocumentExistingException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentExistingException Methods

DocumentExistingException Class See Also

The following tables list the members exposed by the DocumentExistingException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

DocumentExistingException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentRetrievingException Class

Members See Also

The exception that is thrown when the data of a Manufacturing Order document or a Production Order document could not be retrieved.

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class DocumentRetrievingException
    Inherits SynchronizationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DocumentRetrievingException : SynchronizationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class DocumentRetrievingException : public SynchronizationException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DocumentRetrievingException
   extends SynchronizationException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization.SynchronizationException
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization.DocumentRetrievingException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentRetrievingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentRetrievingException Members

DocumentRetrievingException Class Constructors Methods Properties See Also

The exception that is thrown when the data of a Manufacturing Order document or a Production Order document could not be retrieved.

The following tables list the members exposed by the DocumentRetrievingException type.

Constructors
 | Name | Description
Public constructor | DocumentRetrievingException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | DocumentEntry | Gets the document entry of a document for which the exception occurred.
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

DocumentRetrievingException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentRetrievingException Constructor

DocumentRetrievingException Class See Also

Overload List
Name | Description
DocumentRetrievingException(string) |
DocumentRetrievingException(string, Exception) |
DocumentRetrievingException(string, int) |
See Also

Reference

DocumentRetrievingException Class
DocumentRetrievingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentRetrievingException Properties

DocumentRetrievingException Class See Also

The following tables list the members exposed by the DocumentRetrievingException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | DocumentEntry | Gets the document entry of a document for which the exception occurred.
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

DocumentRetrievingException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentRetrievingException.DocumentEntry Property

Gets the document entry of a document for which the exception occurred.

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property DocumentEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int DocumentEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int DocumentEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocumentEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentRetrievingException Class
DocumentRetrievingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentRetrievingException Methods

DocumentRetrievingException Class See Also

The following tables list the members exposed by the DocumentRetrievingException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

DocumentRetrievingException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentUpdatingException Class

Members See Also

The exception that is thrown when the data of a Manufacturing Order document or a Production Order document could not be updated.

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class DocumentUpdatingException
    Inherits SynchronizationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DocumentUpdatingException : SynchronizationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class DocumentUpdatingException : public SynchronizationException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DocumentUpdatingException
   extends SynchronizationException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization.SynchronizationException
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization.DocumentUpdatingException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentUpdatingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentUpdatingException Members

DocumentUpdatingException Class Constructors Methods Properties See Also

The exception that is thrown when the data of a Manufacturing Order document or a Production Order document could not be updated.

The following tables list the members exposed by the DocumentUpdatingException type.

Constructors
 | Name | Description
Public constructor | DocumentUpdatingException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | DocumentEntry | Gets the document entry of a document for which the exception occurred.
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

DocumentUpdatingException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentUpdatingException Constructor

DocumentUpdatingException Class See Also

Overload List
Name | Description
DocumentUpdatingException(string) |
DocumentUpdatingException(string, Exception) |
DocumentUpdatingException(string, int) |
See Also

Reference

DocumentUpdatingException Class
DocumentUpdatingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentUpdatingException Properties

DocumentUpdatingException Class See Also

The following tables list the members exposed by the DocumentUpdatingException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | DocumentEntry | Gets the document entry of a document for which the exception occurred.
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

DocumentUpdatingException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentUpdatingException.DocumentEntry Property

Gets the document entry of a document for which the exception occurred.

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property DocumentEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int DocumentEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int DocumentEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocumentEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentUpdatingException Class
DocumentUpdatingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentUpdatingException Methods

DocumentUpdatingException Class See Also

The following tables list the members exposed by the DocumentUpdatingException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

DocumentUpdatingException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


InvalidManufacturingOrderStatusException Class

Members See Also

The exception that is thrown when the status of a Manufacturing Order document could not be recognized as a known status.

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class InvalidManufacturingOrderStatusException
    Inherits SynchronizationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class InvalidManufacturingOrderStatusException : SynchronizationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class InvalidManufacturingOrderStatusException : public SynchronizationException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class InvalidManufacturingOrderStatusException
   extends SynchronizationException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization.SynchronizationException
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization.InvalidManufacturingOrderStatusException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InvalidManufacturingOrderStatusException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


InvalidManufacturingOrderStatusException Members

InvalidManufacturingOrderStatusException Class Constructors Methods Properties See Also

The exception that is thrown when the status of a Manufacturing Order document could not be recognized as a known status.

The following tables list the members exposed by the InvalidManufacturingOrderStatusException type.

Constructors
 | Name | Description
Public constructor | InvalidManufacturingOrderStatusException |
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

InvalidManufacturingOrderStatusException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


InvalidManufacturingOrderStatusException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public InvalidManufacturingOrderStatusException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
InvalidManufacturingOrderStatusException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function InvalidManufacturingOrderStatusException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InvalidManufacturingOrderStatusException Class
InvalidManufacturingOrderStatusException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


InvalidManufacturingOrderStatusException Properties

InvalidManufacturingOrderStatusException Class See Also

The following tables list the members exposed by the InvalidManufacturingOrderStatusException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

InvalidManufacturingOrderStatusException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


InvalidManufacturingOrderStatusException Methods

InvalidManufacturingOrderStatusException Class See Also

The following tables list the members exposed by the InvalidManufacturingOrderStatusException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

InvalidManufacturingOrderStatusException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


SynchronizationException Class

Members See Also

The exception that is thrown when the synchronization of a Manufacturing Order document with a Production Order document has failed.

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public MustInherit Class SynchronizationException
    Inherits ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public abstract class SynchronizationException : ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SynchronizationException abstract : public ApplicationException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public abstract class SynchronizationException
   extends ApplicationException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization.SynchronizationException
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization.DocumentCreatingException
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization.DocumentRetrievingException
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization.DocumentUpdatingException
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization.InvalidManufacturingOrderStatusException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SynchronizationException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


SynchronizationException Members

SynchronizationException Class Constructors Methods Properties See Also

The exception that is thrown when the synchronization of a Manufacturing Order document with a Production Order document has failed.

The following tables list the members exposed by the SynchronizationException type.

Constructors
 | Name | Description
Public constructor | SynchronizationException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

SynchronizationException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


SynchronizationException Constructor

SynchronizationException Class See Also

Overload List
Name | Description
SynchronizationException(string) |
SynchronizationException(string, Exception) |
See Also

Reference

SynchronizationException Class
SynchronizationException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


SynchronizationException Properties

SynchronizationException Class See Also

The following tables list the members exposed by the SynchronizationException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

SynchronizationException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


SynchronizationException Methods

SynchronizationException Class See Also

The following tables list the members exposed by the SynchronizationException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

SynchronizationException Class
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IManufacturingRelations | Manufacturing Order Relations
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IManufacturingRelations Interface

Members See Also

Manufacturing Order Relations

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IManufacturingRelations
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IManufacturingRelations : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IManufacturingRelations : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IManufacturingRelations
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OMAR
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations Members

IManufacturingRelations Interface Methods Properties See Also

Manufacturing Order Relations

The following tables list the members exposed by the IManufacturingRelations type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ChildDocEntry |
Public property | U_ChildLineNum |
Public property | U_ChildType |
Public property | U_ItemCode |
Public property | U_ParentDocEntry |
Public property | U_ParentLineNum |
Public property | U_Quantity |
Public property | U_Revision |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IManufacturingRelations Interface
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations Properties

IManufacturingRelations Interface See Also

The following tables list the members exposed by the IManufacturingRelations type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ChildDocEntry |
Public property | U_ChildLineNum |
Public property | U_ChildType |
Public property | U_ItemCode |
Public property | U_ParentDocEntry |
Public property | U_ParentLineNum |
Public property | U_Quantity |
Public property | U_Revision |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IManufacturingRelations Interface
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.U_ChildDocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ChildDocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ChildDocEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ChildDocEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ChildDocEntry() : int;
function set U_ChildDocEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.U_ChildLineNum Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ChildLineNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ChildLineNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ChildLineNum {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ChildLineNum() : int;
function set U_ChildLineNum(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.U_ChildType Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ChildType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ChildType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ChildType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ChildType() : String;
function set U_ChildType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.U_ParentDocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ParentDocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ParentDocEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ParentDocEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ParentDocEntry() : int;
function set U_ParentDocEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.U_ParentLineNum Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ParentLineNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ParentLineNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ParentLineNum {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ParentLineNum() : int;
function set U_ParentLineNum(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.U_Quantity Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.U_Revision Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Revision() : String;
function set U_Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingRelations Interface
IManufacturingRelations Members
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


IManufacturingRelations Methods

IManufacturingRelations Interface See Also

The following tables list the members exposed by the IManufacturingRelations type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IManufacturingRelations Interface
CompuTec.ProcessForce.API.Documents.ManufacturingRelations Namespace


CompuTec.ProcessForce.API.Documents.Operation Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IOperation | Operation object
Public interface | IOperationProperties | Properties for operation object
Public interface | IOperationResourceProperties | Resource properties for operation object
Public interface | IOperationResources | Resources for operation object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IOperation Interface

Members See Also

Operation object

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "Operation", TableName = "@CT_PF_OOPR", UDOVersion = "UDO_10")> _
Public Interface IOperation
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Operation", TableName = "@CT_PF_OOPR", UDOVersion = "UDO_10")]
public interface IOperation : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Operation", TableName = "@CT_PF_OOPR", UDOVersion = "UDO_10")]
public interface class IOperation : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "Operation", TableName = "@CT_PF_OOPR", UDOVersion = "UDO_10")
interface IOperation
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OOPR
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation Members

IOperation Interface Methods Properties See Also

Operation object

The following tables list the members exposed by the IOperation type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | OperationProperties |
Public property | OperationResourceProperties |
Public property | OperationResources |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ForceExecOrder |
Public property | U_IgnoreYield |
Public property | U_OprCode |
Public property | U_OprName |
Public property | U_QCActive |
Public property | U_Remarks |
Public property | U_TestProtocolNo |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetByOprCode |
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IOperation Interface
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation Properties

IOperation Interface See Also

The following tables list the members exposed by the IOperation type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | OperationProperties |
Public property | OperationResourceProperties |
Public property | OperationResources |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ForceExecOrder |
Public property | U_IgnoreYield |
Public property | U_OprCode |
Public property | U_OprName |
Public property | U_QCActive |
Public property | U_Remarks |
Public property | U_TestProtocolNo |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IOperation Interface
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.OperationProperties Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property OperationProperties() As IOperationProperties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IOperationProperties OperationProperties {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IOperationProperties^ OperationProperties {
 IOperationProperties^ get( );
 void set(
   IOperationProperties^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OperationProperties() : IOperationProperties;
function set OperationProperties(value : IOperationProperties);
This language is not supported or no code example is available.

Property Value

Type: IOperationProperties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.OperationResourceProperties Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property OperationResourceProperties() As IOperationResourceProperties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IOperationResourceProperties OperationResourceProperties {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IOperationResourceProperties^ OperationResourceProperties {
 IOperationResourceProperties^ get( );
 void set(
   IOperationResourceProperties^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OperationResourceProperties() : IOperationResourceProperties;
function set OperationResourceProperties(value : IOperationResourceProperties);
This language is not supported or no code example is available.

Property Value

Type: IOperationResourceProperties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.OperationResources Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property OperationResources() As IOperationResources
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IOperationResources OperationResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IOperationResources^ OperationResources {
 IOperationResources^ get( );
 void set(
   IOperationResources^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OperationResources() : IOperationResources;
function set OperationResources(value : IOperationResources);
This language is not supported or no code example is available.

Property Value

Type: IOperationResources
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.U_ForceExecOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ForceExecOrder() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_ForceExecOrder {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_ForceExecOrder {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ForceExecOrder() : YesNoType;
function set U_ForceExecOrder(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.U_IgnoreYield Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IgnoreYield() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_IgnoreYield {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_IgnoreYield {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IgnoreYield() : YesNoType;
function set U_IgnoreYield(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.U_OprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2, Required = true)> _
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, Required = true)]
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, Required = true)]

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2, Required = true)
function get U_OprCode() : String;

   AppEngineProperty(Priority = 2, Required = true)
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.U_OprName Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprName() : String;
function set U_OprName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.U_QCActive Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QCActive() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_QCActive {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_QCActive {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QCActive() : YesNoType;
function set U_QCActive(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.U_TestProtocolNo Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestProtocolNo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TestProtocolNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TestProtocolNo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestProtocolNo() : String;
function set U_TestProtocolNo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation Methods

IOperation Interface See Also

The following tables list the members exposed by the IOperation type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetByOprCode |
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IOperation Interface
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperation.GetByOprCode Method

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByOprCode( _
   ByVal oprCode As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByOprCode(
   string oprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByOprCode(
   String^ oprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByOprCode(
    oprCode : String
) : int;
This language is not supported or no code example is available.

Parameters

oprCode

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperation Interface
IOperation Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationProperties Interface

Members See Also

Properties for operation object

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IOperationProperties
    Inherits IUDOChildBean, _
             IEnumerable(Of IOperationProperties)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IOperationProperties : IUDOChildBean,
   IEnumerable<IOperationProperties>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IOperationProperties : public IUDOChildBean^,
   public IEnumerable<IOperationProperties^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_OPR1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationProperties Members

IOperationProperties Interface Methods Properties See Also

Properties for operation object

The following tables list the members exposed by the IOperationProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | PrpName |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OprCode | Operation COde (read only)
Public property | U_PrpCode | Property Code - Mandatory
Public property | U_PrpConType | Condition Type
Public property | U_PrpConValue | Property Value
Public property | U_PrpConValueTo | Property Value To
Public property | U_Remarks |
Public property | U_UnitOfMeasure | UOM
Public property | U_WordCode |
Public property | WordName |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationProperties Interface
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationProperties Properties

IOperationProperties Interface See Also

The following tables list the members exposed by the IOperationProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | PrpName |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OprCode | Operation COde (read only)
Public property | U_PrpCode | Property Code - Mandatory
Public property | U_PrpConType | Condition Type
Public property | U_PrpConValue | Property Value
Public property | U_PrpConValueTo | Property Value To
Public property | U_Remarks |
Public property | U_UnitOfMeasure | UOM
Public property | U_WordCode |
Public property | WordName |
Top
See Also

Reference

IOperationProperties Interface
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationProperties.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperties Interface
IOperationProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationProperties.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperties Interface
IOperationProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationProperties.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperties Interface
IOperationProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationProperties.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperties Interface
IOperationProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationProperties.PrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property PrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string PrpName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ PrpName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get PrpName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperties Interface
IOperationProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationProperties.U_OprCode Property

Operation COde (read only)

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperties Interface
IOperationProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationProperties.U_PrpCode Property

Property Code - Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpCode() : String;
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperties Interface
IOperationProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationProperties.U_PrpConType Property

Condition Type

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConType() As ConditionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ConditionType U_PrpConType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ConditionType U_PrpConType {
 ConditionType get( );
 void set(
   ConditionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConType() : ConditionType;
function set U_PrpConType(value : ConditionType);
This language is not supported or no code example is available.

Property Value

Type: ConditionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperties Interface
IOperationProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationProperties.U_PrpConValue Property

Property Value

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValue() : double;
function set U_PrpConValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperties Interface
IOperationProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationProperties.U_PrpConValueTo Property

Property Value To

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValueTo() : double;
function set U_PrpConValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperties Interface
IOperationProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationProperties.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperties Interface
IOperationProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationProperties.U_UnitOfMeasure Property

UOM

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UnitOfMeasure {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UnitOfMeasure {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UnitOfMeasure() : String;
function set U_UnitOfMeasure(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperties Interface
IOperationProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationProperties.U_WordCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperties Interface
IOperationProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationProperties.WordName Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property WordName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
string WordName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property String^ WordName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get WordName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperties Interface
IOperationProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationProperties Methods

IOperationProperties Interface See Also

The following tables list the members exposed by the IOperationProperties type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationProperties Interface
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResourceProperties Interface

Members See Also

Resource properties for operation object

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean(Parent = "IOperationResources")> _
Public Interface IOperationResourceProperties
    Inherits IUDOChildBean, _
             IEnumerable(Of IOperationResourceProperties)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IOperationResources")]
public interface IOperationResourceProperties : IUDOChildBean,
   IEnumerable<IOperationResourceProperties>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IOperationResources")]
public interface class IOperationResourceProperties : public IUDOChildBean^,
   public IEnumerable<IOperationResourceProperties^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_OPR3
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResourceProperties Members

IOperationResourceProperties Interface Methods Properties See Also

Resource properties for operation object

The following tables list the members exposed by the IOperationResourceProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OprCode | Operation Code - Mandatory
Public property | U_OprRscCode | OperationResource Key -Mandatory
Public property | U_PrpCode | Resource Property Code -Mandatory
Public property | U_PrpConType | Condition Type
Public property | U_PrpConValue | Value of property
Public property | U_PrpConValueTo | Value To For Property
Public property | U_Remarks |
Public property | U_UnitOfMeasure | UOM
Public property | U_WordCode |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationResourceProperties Interface
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResourceProperties Properties

IOperationResourceProperties Interface See Also

The following tables list the members exposed by the IOperationResourceProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OprCode | Operation Code - Mandatory
Public property | U_OprRscCode | OperationResource Key -Mandatory
Public property | U_PrpCode | Resource Property Code -Mandatory
Public property | U_PrpConType | Condition Type
Public property | U_PrpConValue | Value of property
Public property | U_PrpConValueTo | Value To For Property
Public property | U_Remarks |
Public property | U_UnitOfMeasure | UOM
Public property | U_WordCode |
Top
See Also

Reference

IOperationResourceProperties Interface
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResourceProperties.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResourceProperties Interface
IOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResourceProperties.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResourceProperties Interface
IOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResourceProperties.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResourceProperties Interface
IOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResourceProperties.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResourceProperties Interface
IOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResourceProperties.U_OprCode Property

Operation Code - Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(ParentKey = "U_OprCode")> _
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(ParentKey = "U_OprCode")]
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(ParentKey = "U_OprCode")]

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(ParentKey = "U_OprCode")
function get U_OprCode() : String;

   AppEngineProperty(ParentKey = "U_OprCode")
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResourceProperties Interface
IOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResourceProperties.U_OprRscCode Property

OperationResource Key -Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(ParentKey = "U_OprRscCode")> _
Property U_OprRscCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(ParentKey = "U_OprRscCode")]
int U_OprRscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(ParentKey = "U_OprRscCode")]

property int U_OprRscCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(ParentKey = "U_OprRscCode")
function get U_OprRscCode() : int;

   AppEngineProperty(ParentKey = "U_OprRscCode")
function set U_OprRscCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResourceProperties Interface
IOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResourceProperties.U_PrpCode Property

Resource Property Code -Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpCode() : String;
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResourceProperties Interface
IOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResourceProperties.U_PrpConType Property

Condition Type

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConType() As ConditionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ConditionType U_PrpConType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ConditionType U_PrpConType {
 ConditionType get( );
 void set(
   ConditionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConType() : ConditionType;
function set U_PrpConType(value : ConditionType);
This language is not supported or no code example is available.

Property Value

Type: ConditionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResourceProperties Interface
IOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResourceProperties.U_PrpConValue Property

Value of property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValue() : double;
function set U_PrpConValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResourceProperties Interface
IOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResourceProperties.U_PrpConValueTo Property

Value To For Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValueTo() : double;
function set U_PrpConValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResourceProperties Interface
IOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResourceProperties.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResourceProperties Interface
IOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResourceProperties.U_UnitOfMeasure Property

UOM

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UnitOfMeasure {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UnitOfMeasure {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UnitOfMeasure() : String;
function set U_UnitOfMeasure(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResourceProperties Interface
IOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResourceProperties.U_WordCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResourceProperties Interface
IOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResourceProperties Methods

IOperationResourceProperties Interface See Also

The following tables list the members exposed by the IOperationResourceProperties type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationResourceProperties Interface
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources Interface

Members See Also

Resources for operation object

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IOperationResources
    Inherits IUDOChildBean, _
             IEnumerable(Of IOperationResources)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IOperationResources : IUDOChildBean,
   IEnumerable<IOperationResources>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IOperationResources : public IUDOChildBean^,
   public IEnumerable<IOperationResources^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_OPR2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources Members

IOperationResources Interface Methods Properties See Also

Resources for operation object

The following tables list the members exposed by the IOperationResources type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | ResName |
Public property | RowNumDS |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_CycleCap | Cycle Capacity
Public property | U_HasCycles | Is this Resource works in cycles
Public property | U_IsDefault |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MachineCode | Machine Code if Resource type is Machine this Filed is mandatory
Public property | U_OcrCode |
Public property | U_OcrCode2 |
Public property | U_OcrCode3 |
Public property | U_OcrCode4 |
Public property | U_OcrCode5 |
Public property | U_OprCode |
Public property | U_OprRscCode |
Public property | U_Project |
Public property | U_QueueRate |
Public property | U_QueueTime |
Public property | U_Remarks |
Public property | U_RscCode |
Public property | U_RscType | Resource Type Read-Only
Public property | U_RunRate |
Public property | U_RunTime |
Public property | U_SetupRate |
Public property | U_SetupTime |
Public property | U_StockRate |
Public property | U_StockTime |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationResources Interface
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources Properties

IOperationResources Interface See Also

The following tables list the members exposed by the IOperationResources type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | ResName |
Public property | RowNumDS |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_CycleCap | Cycle Capacity
Public property | U_HasCycles | Is this Resource works in cycles
Public property | U_IsDefault |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MachineCode | Machine Code if Resource type is Machine this Filed is mandatory
Public property | U_OcrCode |
Public property | U_OcrCode2 |
Public property | U_OcrCode3 |
Public property | U_OcrCode4 |
Public property | U_OcrCode5 |
Public property | U_OprCode |
Public property | U_OprRscCode |
Public property | U_Project |
Public property | U_QueueRate |
Public property | U_QueueTime |
Public property | U_Remarks |
Public property | U_RscCode |
Public property | U_RscType | Resource Type Read-Only
Public property | U_RunRate |
Public property | U_RunTime |
Public property | U_SetupRate |
Public property | U_SetupTime |
Public property | U_StockRate |
Public property | U_StockTime |
Top
See Also

Reference

IOperationResources Interface
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.ResName Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property ResName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string ResName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ ResName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ResName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.RowNumDS Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RowNumDS() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string RowNumDS {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ RowNumDS {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RowNumDS() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_CycleCap Property

Cycle Capacity

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CycleCap() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_CycleCap {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_CycleCap {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CycleCap() : double;
function set U_CycleCap(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_HasCycles Property

Is this Resource works in cycles

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_HasCycles() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_HasCycles {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_HasCycles {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_HasCycles() : YesNoType;
function set U_HasCycles(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_IsDefault Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IsDefault() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_IsDefault {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_IsDefault {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IsDefault() : String;
function set U_IsDefault(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_MachineCode Property

Machine Code if Resource type is Machine this Filed is mandatory

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MachineCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MachineCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MachineCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MachineCode() : String;
function set U_MachineCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_OcrCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode() : String;
function set U_OcrCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_OcrCode2 Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode2() : String;
function set U_OcrCode2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_OcrCode3 Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode3() : String;
function set U_OcrCode3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_OcrCode4 Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode4() : String;
function set U_OcrCode4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_OcrCode5 Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode5() : String;
function set U_OcrCode5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_OprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprCode() : String;
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_OprRscCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property U_OprRscCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int U_OprRscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int U_OprRscCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_OprRscCode() : int;

   AppEnginePropertyIgnore()
function set U_OprRscCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_Project Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Project() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Project {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Project {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Project() : String;
function set U_Project(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_QueueRate Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QueueRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_QueueRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_QueueRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueRate() : RateType;
function set U_QueueRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_QueueTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QueueTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_QueueTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_QueueTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueTime() : double;
function set U_QueueTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_RscCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCode() : String;
function set U_RscCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_RscType Property

Resource Type Read-Only

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RscType() As ResourceType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ResourceType U_RscType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ResourceType U_RscType {
 ResourceType get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscType() : ResourceType;
This language is not supported or no code example is available.

Property Value

Type: ResourceType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_RunRate Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RunRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_RunRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_RunRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunRate() : RateType;
function set U_RunRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_RunTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RunTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RunTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RunTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunTime() : double;
function set U_RunTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_SetupRate Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SetupRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_SetupRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_SetupRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupRate() : RateType;
function set U_SetupRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_SetupTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SetupTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_SetupTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_SetupTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupTime() : double;
function set U_SetupTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_StockRate Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StockRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_StockRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_StockRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockRate() : RateType;
function set U_StockRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources.U_StockTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Operation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StockTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_StockTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_StockTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockTime() : double;
function set U_StockTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationResources Interface
IOperationResources Members
CompuTec.ProcessForce.API.Documents.Operation Namespace


IOperationResources Methods

IOperationResources Interface See Also

The following tables list the members exposed by the IOperationResources type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationResources Interface
CompuTec.ProcessForce.API.Documents.Operation Namespace


CompuTec.ProcessForce.API.Documents.OperationCheckList Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IOperationCheckList | Operation checklist object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IOperationCheckList Interface

Members See Also

Operation checklist object

Namespace: CompuTec.ProcessForce.API.Documents.OperationCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "OperationCheckList", TableName = "@CT_PF_OOCH")> _
Public Interface IOperationCheckList
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "OperationCheckList", TableName = "@CT_PF_OOCH")]
public interface IOperationCheckList : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "OperationCheckList", TableName = "@CT_PF_OOCH")]
public interface class IOperationCheckList : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "OperationCheckList", TableName = "@CT_PF_OOCH")
interface IOperationCheckList
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OOCH
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationCheckList Members
CompuTec.ProcessForce.API.Documents.OperationCheckList Namespace


IOperationCheckList Members

IOperationCheckList Interface Methods Properties See Also

Operation checklist object

The following tables list the members exposed by the IOperationCheckList type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Name |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Checked |
Public property | U_CurrentRemarks |
Public property | U_CurrentWordCode |
Public property | U_EmplID |
Public property | U_MorEntry |
Public property | U_OprCode |
Public property | U_PrpCode |
Public property | U_Remarks |
Public property | U_RtgCode |
Public property | U_RtgOprCode |
Public property | U_Value |
Public property | U_WordCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IOperationCheckList Interface
CompuTec.ProcessForce.API.Documents.OperationCheckList Namespace


IOperationCheckList Properties

IOperationCheckList Interface See Also

The following tables list the members exposed by the IOperationCheckList type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Name |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Checked |
Public property | U_CurrentRemarks |
Public property | U_CurrentWordCode |
Public property | U_EmplID |
Public property | U_MorEntry |
Public property | U_OprCode |
Public property | U_PrpCode |
Public property | U_Remarks |
Public property | U_RtgCode |
Public property | U_RtgOprCode |
Public property | U_Value |
Public property | U_WordCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
See Also

Reference

IOperationCheckList Interface
CompuTec.ProcessForce.API.Documents.OperationCheckList Namespace


IOperationCheckList.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationCheckList Interface
IOperationCheckList Members
CompuTec.ProcessForce.API.Documents.OperationCheckList Namespace


IOperationCheckList.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
function set Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationCheckList Interface
IOperationCheckList Members
CompuTec.ProcessForce.API.Documents.OperationCheckList Namespace


IOperationCheckList.U_Checked Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Checked() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Checked {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Checked {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Checked() : YesNoType;
function set U_Checked(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationCheckList Interface
IOperationCheckList Members
CompuTec.ProcessForce.API.Documents.OperationCheckList Namespace


IOperationCheckList.U_CurrentRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CurrentRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CurrentRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CurrentRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CurrentRemarks() : String;
function set U_CurrentRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationCheckList Interface
IOperationCheckList Members
CompuTec.ProcessForce.API.Documents.OperationCheckList Namespace


IOperationCheckList.U_CurrentWordCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CurrentWordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CurrentWordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CurrentWordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CurrentWordCode() : String;
function set U_CurrentWordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationCheckList Interface
IOperationCheckList Members
CompuTec.ProcessForce.API.Documents.OperationCheckList Namespace


IOperationCheckList.U_EmplID Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EmplID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_EmplID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_EmplID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EmplID() : int;
function set U_EmplID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationCheckList Interface
IOperationCheckList Members
CompuTec.ProcessForce.API.Documents.OperationCheckList Namespace


IOperationCheckList.U_MorEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MorEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_MorEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_MorEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MorEntry() : int;
function set U_MorEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationCheckList Interface
IOperationCheckList Members
CompuTec.ProcessForce.API.Documents.OperationCheckList Namespace


IOperationCheckList.U_OprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprCode() : String;
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationCheckList Interface
IOperationCheckList Members
CompuTec.ProcessForce.API.Documents.OperationCheckList Namespace


IOperationCheckList.U_PrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpCode() : String;
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationCheckList Interface
IOperationCheckList Members
CompuTec.ProcessForce.API.Documents.OperationCheckList Namespace


IOperationCheckList.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationCheckList Interface
IOperationCheckList Members
CompuTec.ProcessForce.API.Documents.OperationCheckList Namespace


IOperationCheckList.U_RtgCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RtgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RtgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgCode() : String;
function set U_RtgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationCheckList Interface
IOperationCheckList Members
CompuTec.ProcessForce.API.Documents.OperationCheckList Namespace


IOperationCheckList.U_RtgOprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RtgOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RtgOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgOprCode() : int;
function set U_RtgOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationCheckList Interface
IOperationCheckList Members
CompuTec.ProcessForce.API.Documents.OperationCheckList Namespace


IOperationCheckList.U_Value Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Value() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Value {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Value {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Value() : double;
function set U_Value(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationCheckList Interface
IOperationCheckList Members
CompuTec.ProcessForce.API.Documents.OperationCheckList Namespace


IOperationCheckList.U_WordCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationCheckList Interface
IOperationCheckList Members
CompuTec.ProcessForce.API.Documents.OperationCheckList Namespace


IOperationCheckList Methods

IOperationCheckList Interface See Also

The following tables list the members exposed by the IOperationCheckList type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IOperationCheckList Interface
CompuTec.ProcessForce.API.Documents.OperationCheckList Namespace


CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IOperationInOutProperty | Operation input output property object
Public interface | IOperationInOutPropertyWords | Words for operation input output property object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IOperationInOutProperty Interface

Members See Also

Operation input output property object

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "InOutProperty", TableName = "@CT_PF_OIOP", UDOVersion = "UDO_10")> _
Public Interface IOperationInOutProperty
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "InOutProperty", TableName = "@CT_PF_OIOP", UDOVersion = "UDO_10")]
public interface IOperationInOutProperty : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "InOutProperty", TableName = "@CT_PF_OIOP", UDOVersion = "UDO_10")]
public interface class IOperationInOutProperty : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "InOutProperty", TableName = "@CT_PF_OIOP", UDOVersion = "UDO_10")
interface IOperationInOutProperty
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OIOP
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutProperty Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty Members

IOperationInOutProperty Interface Methods Properties See Also

Operation input output property object

The following tables list the members exposed by the IOperationInOutProperty type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_PrpCode | Property Code - Mandatory
Public property | U_PrpName | Property Name
Public property | U_Remarks | Remarks
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Public property | Words |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetByOprPrpCode | methood Loads Operation Property object by Property Code -U_OprPrpCode
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IOperationInOutProperty Interface
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty Properties

IOperationInOutProperty Interface See Also

The following tables list the members exposed by the IOperationInOutProperty type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_PrpCode | Property Code - Mandatory
Public property | U_PrpName | Property Name
Public property | U_Remarks | Remarks
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Public property | Words |
Top
See Also

Reference

IOperationInOutProperty Interface
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutProperty Interface
IOperationInOutProperty Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutProperty Interface
IOperationInOutProperty Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutProperty Interface
IOperationInOutProperty Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutProperty Interface
IOperationInOutProperty Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutProperty Interface
IOperationInOutProperty Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutProperty Interface
IOperationInOutProperty Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutProperty Interface
IOperationInOutProperty Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutProperty Interface
IOperationInOutProperty Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutProperty Interface
IOperationInOutProperty Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutProperty Interface
IOperationInOutProperty Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty.U_PrpCode Property

Property Code - Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_PrpCode() : String;

   AppEngineProperty(Required = true)
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutProperty Interface
IOperationInOutProperty Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty.U_PrpName Property

Property Name

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpName() : String;
function set U_PrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutProperty Interface
IOperationInOutProperty Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty.U_Remarks Property

Remarks

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutProperty Interface
IOperationInOutProperty Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutProperty Interface
IOperationInOutProperty Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutProperty Interface
IOperationInOutProperty Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutProperty Interface
IOperationInOutProperty Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty.Words Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Words() As IOperationInOutPropertyWords
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IOperationInOutPropertyWords Words {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IOperationInOutPropertyWords^ Words {
 IOperationInOutPropertyWords^ get( );
 void set(
   IOperationInOutPropertyWords^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Words() : IOperationInOutPropertyWords;
function set Words(value : IOperationInOutPropertyWords);
This language is not supported or no code example is available.

Property Value

Type: IOperationInOutPropertyWords
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutProperty Interface
IOperationInOutProperty Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty Methods

IOperationInOutProperty Interface See Also

The following tables list the members exposed by the IOperationInOutProperty type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetByOprPrpCode | methood Loads Operation Property object by Property Code -U_OprPrpCode
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IOperationInOutProperty Interface
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutProperty.GetByOprPrpCode Method

methood Loads Operation Property object by Property Code -U_OprPrpCode

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByOprPrpCode( _
   ByVal code As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByOprPrpCode(
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByOprPrpCode(
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByOprPrpCode(
    code : String
) : int;
This language is not supported or no code example is available.

Parameters

code

Type: string

U_OprPrpCode

Return Value

Type: int

0 if success

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutProperty Interface
IOperationInOutProperty Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutPropertyWords Interface

Members See Also

Words for operation input output property object

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IOperationInOutPropertyWords
    Inherits IUDOChildBean, _
             IEnumerable(Of IOperationInOutPropertyWords)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IOperationInOutPropertyWords : IUDOChildBean,
   IEnumerable<IOperationInOutPropertyWords>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IOperationInOutPropertyWords : public IUDOChildBean^,
   public IEnumerable<IOperationInOutPropertyWords^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_IOP1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutPropertyWords Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutPropertyWords Members

IOperationInOutPropertyWords Interface Methods Properties See Also

Words for operation input output property object

The following tables list the members exposed by the IOperationInOutPropertyWords type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_WordName |
Public property | DS_WordRemarks |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_WordCode |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationInOutPropertyWords Interface
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutPropertyWords Properties

IOperationInOutPropertyWords Interface See Also

The following tables list the members exposed by the IOperationInOutPropertyWords type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_WordName |
Public property | DS_WordRemarks |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_WordCode |
Top
See Also

Reference

IOperationInOutPropertyWords Interface
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutPropertyWords.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutPropertyWords Interface
IOperationInOutPropertyWords Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutPropertyWords.DS_WordName Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_WordName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_WordName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_WordName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_WordName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutPropertyWords Interface
IOperationInOutPropertyWords Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutPropertyWords.DS_WordRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_WordRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_WordRemarks {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_WordRemarks {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_WordRemarks() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutPropertyWords Interface
IOperationInOutPropertyWords Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutPropertyWords.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutPropertyWords Interface
IOperationInOutPropertyWords Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutPropertyWords.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutPropertyWords Interface
IOperationInOutPropertyWords Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutPropertyWords.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutPropertyWords Interface
IOperationInOutPropertyWords Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutPropertyWords.U_WordCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationInOutProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationInOutPropertyWords Interface
IOperationInOutPropertyWords Members
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


IOperationInOutPropertyWords Methods

IOperationInOutPropertyWords Interface See Also

The following tables list the members exposed by the IOperationInOutPropertyWords type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationInOutPropertyWords Interface
CompuTec.ProcessForce.API.Documents.OperationInOutProperty Namespace


CompuTec.ProcessForce.API.Documents.OperationProperty Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IOperationProperty | Operation properties object
Public interface | IOperationPropertyWords | Words for operation properties object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IOperationProperty Interface

Members See Also

Operation properties object

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "OperationProperty", TableName = "@CT_PF_OPRO", UDOVersion = "UDO_10")> _
Public Interface IOperationProperty
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "OperationProperty", TableName = "@CT_PF_OPRO", UDOVersion = "UDO_10")]
public interface IOperationProperty : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "OperationProperty", TableName = "@CT_PF_OPRO", UDOVersion = "UDO_10")]
public interface class IOperationProperty : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "OperationProperty", TableName = "@CT_PF_OPRO", UDOVersion = "UDO_10")
interface IOperationProperty
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OPRO
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperty Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty Members

IOperationProperty Interface Methods Properties See Also

Operation properties object

The following tables list the members exposed by the IOperationProperty type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_OprPrpCode | Property Code - Mandatory
Public property | U_OprPrpName | Property Name
Public property | U_OprPrpRemarks | Remarks
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Public property | Words |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetByOprPrpCode | methood Loads Operation Property object by Property Code -U_OprPrpCode
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IOperationProperty Interface
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty Properties

IOperationProperty Interface See Also

The following tables list the members exposed by the IOperationProperty type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_OprPrpCode | Property Code - Mandatory
Public property | U_OprPrpName | Property Name
Public property | U_OprPrpRemarks | Remarks
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Public property | Words |
Top
See Also

Reference

IOperationProperty Interface
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperty Interface
IOperationProperty Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperty Interface
IOperationProperty Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperty Interface
IOperationProperty Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperty Interface
IOperationProperty Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperty Interface
IOperationProperty Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperty Interface
IOperationProperty Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperty Interface
IOperationProperty Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperty Interface
IOperationProperty Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperty Interface
IOperationProperty Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperty Interface
IOperationProperty Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty.U_OprPrpCode Property

Property Code - Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_OprPrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_OprPrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_OprPrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_OprPrpCode() : String;

   AppEngineProperty(Required = true)
function set U_OprPrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperty Interface
IOperationProperty Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty.U_OprPrpName Property

Property Name

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprPrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprPrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprPrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprPrpName() : String;
function set U_OprPrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperty Interface
IOperationProperty Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty.U_OprPrpRemarks Property

Remarks

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprPrpRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprPrpRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprPrpRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprPrpRemarks() : String;
function set U_OprPrpRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperty Interface
IOperationProperty Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperty Interface
IOperationProperty Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperty Interface
IOperationProperty Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperty Interface
IOperationProperty Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty.Words Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Words() As IOperationPropertyWords
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IOperationPropertyWords Words {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IOperationPropertyWords^ Words {
 IOperationPropertyWords^ get( );
 void set(
   IOperationPropertyWords^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Words() : IOperationPropertyWords;
function set Words(value : IOperationPropertyWords);
This language is not supported or no code example is available.

Property Value

Type: IOperationPropertyWords
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperty Interface
IOperationProperty Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty Methods

IOperationProperty Interface See Also

The following tables list the members exposed by the IOperationProperty type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetByOprPrpCode | methood Loads Operation Property object by Property Code -U_OprPrpCode
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IOperationProperty Interface
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationProperty.GetByOprPrpCode Method

methood Loads Operation Property object by Property Code -U_OprPrpCode

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByOprPrpCode( _
   ByVal code As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByOprPrpCode(
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByOprPrpCode(
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByOprPrpCode(
    code : String
) : int;
This language is not supported or no code example is available.

Parameters

code

Type: string

U_OprPrpCode

Return Value

Type: int

0 if success

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationProperty Interface
IOperationProperty Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationPropertyWords Interface

Members See Also

Words for operation properties object

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IOperationPropertyWords
    Inherits IUDOChildBean, _
             IEnumerable(Of IOperationPropertyWords)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IOperationPropertyWords : IUDOChildBean,
   IEnumerable<IOperationPropertyWords>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IOperationPropertyWords : public IUDOChildBean^,
   public IEnumerable<IOperationPropertyWords^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_PRO1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationPropertyWords Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationPropertyWords Members

IOperationPropertyWords Interface Methods Properties See Also

Words for operation properties object

The following tables list the members exposed by the IOperationPropertyWords type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_WordName |
Public property | DS_WordRemarks |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_WordCode |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationPropertyWords Interface
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationPropertyWords Properties

IOperationPropertyWords Interface See Also

The following tables list the members exposed by the IOperationPropertyWords type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_WordName |
Public property | DS_WordRemarks |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_WordCode |
Top
See Also

Reference

IOperationPropertyWords Interface
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationPropertyWords.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationPropertyWords Interface
IOperationPropertyWords Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationPropertyWords.DS_WordName Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_WordName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_WordName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_WordName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_WordName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationPropertyWords Interface
IOperationPropertyWords Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationPropertyWords.DS_WordRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_WordRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_WordRemarks {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_WordRemarks {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_WordRemarks() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationPropertyWords Interface
IOperationPropertyWords Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationPropertyWords.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationPropertyWords Interface
IOperationPropertyWords Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationPropertyWords.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationPropertyWords Interface
IOperationPropertyWords Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationPropertyWords.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationPropertyWords Interface
IOperationPropertyWords Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationPropertyWords.U_WordCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationPropertyWords Interface
IOperationPropertyWords Members
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


IOperationPropertyWords Methods

IOperationPropertyWords Interface See Also

The following tables list the members exposed by the IOperationPropertyWords type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationPropertyWords Interface
CompuTec.ProcessForce.API.Documents.OperationProperty Namespace


CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | AtLeastOneRowMustBeFilledException |
Public class | CantAddDocumentWithDuplicatedEntriesException |
Public class | CantAddJournalEntryException |
Public class | DocDateMissingException |
Public class | OperationTimeRecordingHelper |
Public class | ResourceNotFoundException |
Top
Interfaces
 | Name | Description
Public interface | IOperationTimeRecording | Operation time recording document
Public interface | IOperationTimeRecordingEmployeeTimeRecords | Employee time recordings operation time recordings document
Public interface | IOperationTimeRecordingLines | Lines of operation time recording document
Public interface | IOperationTimeRecordingReasons | Reasons of operation time recording document
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


AtLeastOneRowMustBeFilledException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class AtLeastOneRowMustBeFilledException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class AtLeastOneRowMustBeFilledException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class AtLeastOneRowMustBeFilledException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class AtLeastOneRowMustBeFilledException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.OperationTimeRecording.AtLeastOneRowMustBeFilledException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AtLeastOneRowMustBeFilledException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


AtLeastOneRowMustBeFilledException Members

AtLeastOneRowMustBeFilledException Class Constructors Methods Properties See Also

The following tables list the members exposed by the AtLeastOneRowMustBeFilledException type.

Constructors
 | Name | Description
Public constructor | AtLeastOneRowMustBeFilledException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

AtLeastOneRowMustBeFilledException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


AtLeastOneRowMustBeFilledException Constructor

AtLeastOneRowMustBeFilledException Class See Also

Overload List
Name | Description
AtLeastOneRowMustBeFilledException() |
AtLeastOneRowMustBeFilledException(string) |
AtLeastOneRowMustBeFilledException(string, Exception) |
See Also

Reference

AtLeastOneRowMustBeFilledException Class
AtLeastOneRowMustBeFilledException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


AtLeastOneRowMustBeFilledException Properties

AtLeastOneRowMustBeFilledException Class See Also

The following tables list the members exposed by the AtLeastOneRowMustBeFilledException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

AtLeastOneRowMustBeFilledException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


AtLeastOneRowMustBeFilledException Methods

AtLeastOneRowMustBeFilledException Class See Also

The following tables list the members exposed by the AtLeastOneRowMustBeFilledException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

AtLeastOneRowMustBeFilledException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


CantAddDocumentWithDuplicatedEntriesException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class CantAddDocumentWithDuplicatedEntriesException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class CantAddDocumentWithDuplicatedEntriesException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class CantAddDocumentWithDuplicatedEntriesException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class CantAddDocumentWithDuplicatedEntriesException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.OperationTimeRecording.CantAddDocumentWithDuplicatedEntriesException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantAddDocumentWithDuplicatedEntriesException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


CantAddDocumentWithDuplicatedEntriesException Members

CantAddDocumentWithDuplicatedEntriesException Class Constructors Methods Properties See Also

The following tables list the members exposed by the CantAddDocumentWithDuplicatedEntriesException type.

Constructors
 | Name | Description
Public constructor | CantAddDocumentWithDuplicatedEntriesException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

CantAddDocumentWithDuplicatedEntriesException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


CantAddDocumentWithDuplicatedEntriesException Constructor

CantAddDocumentWithDuplicatedEntriesException Class See Also

Overload List
Name | Description
CantAddDocumentWithDuplicatedEntriesException() |
CantAddDocumentWithDuplicatedEntriesException(string) |
CantAddDocumentWithDuplicatedEntriesException(string, Exception) |
See Also

Reference

CantAddDocumentWithDuplicatedEntriesException Class
CantAddDocumentWithDuplicatedEntriesException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


CantAddDocumentWithDuplicatedEntriesException Properties

CantAddDocumentWithDuplicatedEntriesException Class See Also

The following tables list the members exposed by the CantAddDocumentWithDuplicatedEntriesException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

CantAddDocumentWithDuplicatedEntriesException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


CantAddDocumentWithDuplicatedEntriesException Methods

CantAddDocumentWithDuplicatedEntriesException Class See Also

The following tables list the members exposed by the CantAddDocumentWithDuplicatedEntriesException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

CantAddDocumentWithDuplicatedEntriesException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


CantAddJournalEntryException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class CantAddJournalEntryException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class CantAddJournalEntryException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class CantAddJournalEntryException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class CantAddJournalEntryException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.OperationTimeRecording.CantAddJournalEntryException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantAddJournalEntryException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


CantAddJournalEntryException Members

CantAddJournalEntryException Class Constructors Methods Properties See Also

The following tables list the members exposed by the CantAddJournalEntryException type.

Constructors
 | Name | Description
Public constructor | CantAddJournalEntryException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

CantAddJournalEntryException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


CantAddJournalEntryException Constructor

CantAddJournalEntryException Class See Also

Overload List
Name | Description
CantAddJournalEntryException() |
CantAddJournalEntryException(string) |
CantAddJournalEntryException(string, Exception) |
See Also

Reference

CantAddJournalEntryException Class
CantAddJournalEntryException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


CantAddJournalEntryException Properties

CantAddJournalEntryException Class See Also

The following tables list the members exposed by the CantAddJournalEntryException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

CantAddJournalEntryException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


CantAddJournalEntryException Methods

CantAddJournalEntryException Class See Also

The following tables list the members exposed by the CantAddJournalEntryException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

CantAddJournalEntryException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


DocDateMissingException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class DocDateMissingException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class DocDateMissingException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class DocDateMissingException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class DocDateMissingException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.OperationTimeRecording.DocDateMissingException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocDateMissingException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


DocDateMissingException Members

DocDateMissingException Class Constructors Methods Properties See Also

The following tables list the members exposed by the DocDateMissingException type.

Constructors
 | Name | Description
Public constructor | DocDateMissingException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

DocDateMissingException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


DocDateMissingException Constructor

DocDateMissingException Class See Also

Overload List
Name | Description
DocDateMissingException() |
DocDateMissingException(string) |
DocDateMissingException(string, Exception) |
See Also

Reference

DocDateMissingException Class
DocDateMissingException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


DocDateMissingException Properties

DocDateMissingException Class See Also

The following tables list the members exposed by the DocDateMissingException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

DocDateMissingException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


DocDateMissingException Methods

DocDateMissingException Class See Also

The following tables list the members exposed by the DocDateMissingException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

DocDateMissingException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


OperationTimeRecordingHelper Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class OperationTimeRecordingHelper
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class OperationTimeRecordingHelper
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class OperationTimeRecordingHelper
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class OperationTimeRecordingHelper
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.OperationTimeRecording.OperationTimeRecordingHelper
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OperationTimeRecordingHelper Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


OperationTimeRecordingHelper Members

OperationTimeRecordingHelper Class Methods See Also

The following tables list the members exposed by the OperationTimeRecordingHelper type.

Methods
 | Name | Description
 | CalcTotalWorkTime |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

OperationTimeRecordingHelper Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


OperationTimeRecordingHelper Methods

OperationTimeRecordingHelper Class See Also

The following tables list the members exposed by the OperationTimeRecordingHelper type.

Methods
 | Name | Description
 | CalcTotalWorkTime |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

OperationTimeRecordingHelper Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


OperationTimeRecordingHelper.CalcTotalWorkTime Method

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function CalcTotalWorkTime( _
   ByVal udo As IOperationTimeRecording _
) As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static TimeSpan CalcTotalWorkTime(
   IOperationTimeRecording udo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static TimeSpan CalcTotalWorkTime(
   IOperationTimeRecording^ udo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function CalcTotalWorkTime(
    udo : IOperationTimeRecording
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

udo

Type: IOperationTimeRecording

Return Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OperationTimeRecordingHelper Class
OperationTimeRecordingHelper Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


ResourceNotFoundException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class ResourceNotFoundException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class ResourceNotFoundException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class ResourceNotFoundException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class ResourceNotFoundException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.OperationTimeRecording.ResourceNotFoundException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceNotFoundException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


ResourceNotFoundException Members

ResourceNotFoundException Class Constructors Methods Properties See Also

The following tables list the members exposed by the ResourceNotFoundException type.

Constructors
 | Name | Description
Public constructor | ResourceNotFoundException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ResourceNotFoundException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


ResourceNotFoundException Constructor

ResourceNotFoundException Class See Also

Overload List
Name | Description
ResourceNotFoundException() |
ResourceNotFoundException(string) |
ResourceNotFoundException(string, Exception) |
See Also

Reference

ResourceNotFoundException Class
ResourceNotFoundException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


ResourceNotFoundException Properties

ResourceNotFoundException Class See Also

The following tables list the members exposed by the ResourceNotFoundException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

ResourceNotFoundException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


ResourceNotFoundException Methods

ResourceNotFoundException Class See Also

The following tables list the members exposed by the ResourceNotFoundException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ResourceNotFoundException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording Interface

Members See Also

Operation time recording document

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "OperationTimeRecording", TableName = "@CT_PF_OOTR" ,UDOVersion = "UDO_10", ExludedHttpMethods = "DELETE")> _
Public Interface IOperationTimeRecording
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "OperationTimeRecording", TableName = "@CT_PF_OOTR" ,UDOVersion = "UDO_10", ExludedHttpMethods = "DELETE")]
public interface IOperationTimeRecording : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "OperationTimeRecording", TableName = "@CT_PF_OOTR" ,UDOVersion = "UDO_10", ExludedHttpMethods = "DELETE")]
public interface class IOperationTimeRecording : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "OperationTimeRecording", TableName = "@CT_PF_OOTR" ,UDOVersion = "UDO_10", ExludedHttpMethods = "DELETE")
interface IOperationTimeRecording
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OOTR
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording Members

IOperationTimeRecording Interface Methods Properties See Also

Operation time recording document

The following tables list the members exposed by the IOperationTimeRecording type.

Properties
 | Name | Description
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | EmployeeTimeRecords |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | Lines |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Reasons |
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Backflushed |
Public property | U_BaseCode |
Public property | U_Closed |
Public property | U_DocDate |
Public property | U_JrnlRemark |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_PostingDate |
Public property | U_Ref2 |
Public property | U_Remarks |
Public property | U_TransId |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastCorrectedDocEntry |
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IOperationTimeRecording Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording Properties

IOperationTimeRecording Interface See Also

The following tables list the members exposed by the IOperationTimeRecording type.

Properties
 | Name | Description
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | EmployeeTimeRecords |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | Lines |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Reasons |
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Backflushed |
Public property | U_BaseCode |
Public property | U_Closed |
Public property | U_DocDate |
Public property | U_JrnlRemark |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_PostingDate |
Public property | U_Ref2 |
Public property | U_Remarks |
Public property | U_TransId |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IOperationTimeRecording Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.DocNum Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.EmployeeTimeRecords Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property EmployeeTimeRecords() As IOperationTimeRecordingEmployeeTimeRecords
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IOperationTimeRecordingEmployeeTimeRecords EmployeeTimeRecords {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IOperationTimeRecordingEmployeeTimeRecords^ EmployeeTimeRecords {
 IOperationTimeRecordingEmployeeTimeRecords^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get EmployeeTimeRecords() : IOperationTimeRecordingEmployeeTimeRecords;
This language is not supported or no code example is available.

Property Value

Type: IOperationTimeRecordingEmployeeTimeRecords
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.Handwrtten Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Handwrtten() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Handwrtten {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Handwrtten {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Handwrtten() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.Instance Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Instance() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Instance {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Instance {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Instance() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.Lines Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Lines() As IOperationTimeRecordingLines
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IOperationTimeRecordingLines Lines {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IOperationTimeRecordingLines^ Lines {
 IOperationTimeRecordingLines^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Lines() : IOperationTimeRecordingLines;
This language is not supported or no code example is available.

Property Value

Type: IOperationTimeRecordingLines
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.Period Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Period() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Period {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Period {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Period() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.Reasons Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Reasons() As IOperationTimeRecordingReasons
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IOperationTimeRecordingReasons Reasons {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IOperationTimeRecordingReasons^ Reasons {
 IOperationTimeRecordingReasons^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Reasons() : IOperationTimeRecordingReasons;
This language is not supported or no code example is available.

Property Value

Type: IOperationTimeRecordingReasons
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.Series Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Series() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Series {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Series {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Series() : int;
function set Series(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.Status Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Status {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Status {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Status() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.U_Backflushed Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Backflushed() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Backflushed {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Backflushed {
 YesNoType get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Backflushed() : YesNoType;
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.U_BaseCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BaseCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BaseCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseCode() : String;
function set U_BaseCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.U_Closed Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Closed() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Closed {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Closed {
 YesNoType get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Closed() : YesNoType;
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.U_DocDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DocDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_DocDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_DocDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DocDate() : DateTime;
function set U_DocDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.U_JrnlRemark Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_JrnlRemark() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_JrnlRemark {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_JrnlRemark {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_JrnlRemark() : String;
function set U_JrnlRemark(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.U_PostingDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PostingDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_PostingDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_PostingDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PostingDate() : DateTime;
function set U_PostingDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.U_Ref2 Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Ref2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Ref2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Ref2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Ref2() : String;
function set U_Ref2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.U_TransId Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TransId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_TransId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_TransId {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TransId() : int;
function set U_TransId(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording Methods

IOperationTimeRecording Interface See Also

The following tables list the members exposed by the IOperationTimeRecording type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastCorrectedDocEntry |
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IOperationTimeRecording Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecording.GetLastCorrectedDocEntry Method

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetLastCorrectedDocEntry( _
   ByVal docentry As Integer, _
   ByVal Type As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetLastCorrectedDocEntry(
   int docentry,
   string Type
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetLastCorrectedDocEntry(
   int docentry,
   String^ Type
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetLastCorrectedDocEntry(
    docentry : int,
    Type : String
) : int;
This language is not supported or no code example is available.

Parameters

docentry

Type: int

Type

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecording Interface
IOperationTimeRecording Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingEmployeeTimeRecords Interface

Members See Also

Employee time recordings operation time recordings document

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IOperationTimeRecordingEmployeeTimeRecords
    Inherits IUDOChildBean, _
             IEnumerable(Of IOperationTimeRecordingEmployeeTimeRecords)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IOperationTimeRecordingEmployeeTimeRecords : IUDOChildBean,
   IEnumerable<IOperationTimeRecordingEmployeeTimeRecords>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IOperationTimeRecordingEmployeeTimeRecords : public IUDOChildBean^,
   public IEnumerable<IOperationTimeRecordingEmployeeTimeRecords^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_OTR2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingEmployeeTimeRecords Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingEmployeeTimeRecords Members

IOperationTimeRecordingEmployeeTimeRecords Interface Methods Properties See Also

Employee time recordings operation time recordings document

The following tables list the members exposed by the IOperationTimeRecordingEmployeeTimeRecords type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine |
Public property | U_DateFrom |
Public property | U_DateTo |
Public property | U_EmplID |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_TeamCode |
Public property | U_TimeFrom |
Public property | U_TimeTo |
Public property | VisOrder |
Public property | WorkDuration |
Public property | WorkEnd |
Public property | WorkStart |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationTimeRecordingEmployeeTimeRecords Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingEmployeeTimeRecords Properties

IOperationTimeRecordingEmployeeTimeRecords Interface See Also

The following tables list the members exposed by the IOperationTimeRecordingEmployeeTimeRecords type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine |
Public property | U_DateFrom |
Public property | U_DateTo |
Public property | U_EmplID |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_TeamCode |
Public property | U_TimeFrom |
Public property | U_TimeTo |
Public property | VisOrder |
Public property | WorkDuration |
Public property | WorkEnd |
Public property | WorkStart |
Top
See Also

Reference

IOperationTimeRecordingEmployeeTimeRecords Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingEmployeeTimeRecords.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingEmployeeTimeRecords Interface
IOperationTimeRecordingEmployeeTimeRecords Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingEmployeeTimeRecords.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingEmployeeTimeRecords Interface
IOperationTimeRecordingEmployeeTimeRecords Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingEmployeeTimeRecords.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingEmployeeTimeRecords Interface
IOperationTimeRecordingEmployeeTimeRecords Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingEmployeeTimeRecords.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingEmployeeTimeRecords Interface
IOperationTimeRecordingEmployeeTimeRecords Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingEmployeeTimeRecords.U_BaseLine Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLine() : int;
function set U_BaseLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingEmployeeTimeRecords Interface
IOperationTimeRecordingEmployeeTimeRecords Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingEmployeeTimeRecords.U_DateFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DateFrom() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_DateFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_DateFrom {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DateFrom() : DateTime;
function set U_DateFrom(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingEmployeeTimeRecords Interface
IOperationTimeRecordingEmployeeTimeRecords Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingEmployeeTimeRecords.U_DateTo Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DateTo() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_DateTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_DateTo {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DateTo() : DateTime;
function set U_DateTo(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingEmployeeTimeRecords Interface
IOperationTimeRecordingEmployeeTimeRecords Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingEmployeeTimeRecords.U_EmplID Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EmplID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_EmplID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_EmplID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EmplID() : int;
function set U_EmplID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingEmployeeTimeRecords Interface
IOperationTimeRecordingEmployeeTimeRecords Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingEmployeeTimeRecords.U_TeamCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TeamCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TeamCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TeamCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TeamCode() : String;
function set U_TeamCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingEmployeeTimeRecords Interface
IOperationTimeRecordingEmployeeTimeRecords Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingEmployeeTimeRecords.U_TimeFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TimeFrom() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_TimeFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_TimeFrom {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TimeFrom() : DateTime;
function set U_TimeFrom(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingEmployeeTimeRecords Interface
IOperationTimeRecordingEmployeeTimeRecords Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingEmployeeTimeRecords.U_TimeTo Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TimeTo() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_TimeTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_TimeTo {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TimeTo() : DateTime;
function set U_TimeTo(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingEmployeeTimeRecords Interface
IOperationTimeRecordingEmployeeTimeRecords Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingEmployeeTimeRecords.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingEmployeeTimeRecords Interface
IOperationTimeRecordingEmployeeTimeRecords Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingEmployeeTimeRecords.WorkDuration Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property WorkDuration() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan WorkDuration {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan WorkDuration {
 TimeSpan get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WorkDuration() : TimeSpan;
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingEmployeeTimeRecords Interface
IOperationTimeRecordingEmployeeTimeRecords Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingEmployeeTimeRecords.WorkEnd Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property WorkEnd() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime WorkEnd {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime WorkEnd {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WorkEnd() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingEmployeeTimeRecords Interface
IOperationTimeRecordingEmployeeTimeRecords Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingEmployeeTimeRecords.WorkStart Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property WorkStart() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime WorkStart {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime WorkStart {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WorkStart() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingEmployeeTimeRecords Interface
IOperationTimeRecordingEmployeeTimeRecords Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingEmployeeTimeRecords Methods

IOperationTimeRecordingEmployeeTimeRecords Interface See Also

The following tables list the members exposed by the IOperationTimeRecordingEmployeeTimeRecords type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationTimeRecordingEmployeeTimeRecords Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines Interface

Members See Also

Lines of operation time recording document

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IOperationTimeRecordingLines
    Inherits IUDOChildBean, _
             IEnumerable(Of IOperationTimeRecordingLines)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IOperationTimeRecordingLines : IUDOChildBean,
   IEnumerable<IOperationTimeRecordingLines>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IOperationTimeRecordingLines : public IUDOChildBean^,
   public IEnumerable<IOperationTimeRecordingLines^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_OTR1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines Members

IOperationTimeRecordingLines Interface Methods Properties See Also

Lines of operation time recording document

The following tables list the members exposed by the IOperationTimeRecordingLines type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | OperationStatus |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AcctCode |
Public property | U_BaseDocNum |
Public property | U_BaseEntry |
Public property | U_BaseLineNum |
Public property | U_CloseTask |
Public property | U_Effort |
Public property | U_EndDate |
Public property | U_EndTime |
Public property | U_FixedCost |
Public property | U_LineNum | Gets ProcessForce Line Num
Public property | U_NetQty |
Public property | U_NrOfResources |
Public property | U_OcrCode |
Public property | U_OcrCode2 |
Public property | U_OcrCode3 |
Public property | U_OcrCode4 |
Public property | U_OcrCode5 |
Public property | U_OprCode |
Public property | U_Project |
Public property | U_ReceiptedQty |
Public property | U_Remarks |
Public property | U_ReworkQty |
Public property | U_RscCode |
Public property | U_ScrapQty |
Public property | U_StartDate |
Public property | U_StartTime |
Public property | U_TargetEntry |
Public property | U_TargetLieNum |
Public property | U_TimeCost |
Public property | U_TimeType |
Public property | U_VariableCost |
Public property | U_WorkingHours |
Public property | U_Yield |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | CalculateDuration |
Public method | CalculateDurationBaseOnResourceCalendar |
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationTimeRecordingLines Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines Properties

IOperationTimeRecordingLines Interface See Also

The following tables list the members exposed by the IOperationTimeRecordingLines type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | OperationStatus |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AcctCode |
Public property | U_BaseDocNum |
Public property | U_BaseEntry |
Public property | U_BaseLineNum |
Public property | U_CloseTask |
Public property | U_Effort |
Public property | U_EndDate |
Public property | U_EndTime |
Public property | U_FixedCost |
Public property | U_LineNum | Gets ProcessForce Line Num
Public property | U_NetQty |
Public property | U_NrOfResources |
Public property | U_OcrCode |
Public property | U_OcrCode2 |
Public property | U_OcrCode3 |
Public property | U_OcrCode4 |
Public property | U_OcrCode5 |
Public property | U_OprCode |
Public property | U_Project |
Public property | U_ReceiptedQty |
Public property | U_Remarks |
Public property | U_ReworkQty |
Public property | U_RscCode |
Public property | U_ScrapQty |
Public property | U_StartDate |
Public property | U_StartTime |
Public property | U_TargetEntry |
Public property | U_TargetLieNum |
Public property | U_TimeCost |
Public property | U_TimeType |
Public property | U_VariableCost |
Public property | U_WorkingHours |
Public property | U_Yield |
Public property | VisOrder |
Top
See Also

Reference

IOperationTimeRecordingLines Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.OperationStatus Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property OperationStatus() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string OperationStatus {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ OperationStatus {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OperationStatus() : String;
function set OperationStatus(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_AcctCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AcctCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AcctCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AcctCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AcctCode() : String;
function set U_AcctCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_BaseDocNum Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseDocNum() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BaseDocNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BaseDocNum {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseDocNum() : String;
function set U_BaseDocNum(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_BaseEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseEntry() : int;
function set U_BaseEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_BaseLineNum Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLineNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLineNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLineNum {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLineNum() : int;
function set U_BaseLineNum(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_CloseTask Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CloseTask() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_CloseTask {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_CloseTask {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CloseTask() : YesNoType;
function set U_CloseTask(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_Effort Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Effort() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan U_Effort {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan U_Effort {
 TimeSpan get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Effort() : TimeSpan;
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_EndDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_EndDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_EndDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EndDate() : DateTime;
function set U_EndDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_EndTime Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EndTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_EndTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_EndTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EndTime() : DateTime;
function set U_EndTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_FixedCost Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_FixedCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixedCost {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixedCost {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixedCost() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_LineNum Property

Gets ProcessForce Line Num

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property U_LineNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
int U_LineNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property int U_LineNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get U_LineNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_NetQty Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_NetQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_NetQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_NetQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_NetQty() : double;
function set U_NetQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_NrOfResources Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_NrOfResources() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_NrOfResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_NrOfResources {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_NrOfResources() : int;
function set U_NrOfResources(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_OcrCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode() : String;
function set U_OcrCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_OcrCode2 Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode2() : String;
function set U_OcrCode2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_OcrCode3 Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode3() : String;
function set U_OcrCode3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_OcrCode4 Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode4() : String;
function set U_OcrCode4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_OcrCode5 Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode5() : String;
function set U_OcrCode5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_OprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprCode() : String;
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_Project Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Project() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Project {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Project {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Project() : String;
function set U_Project(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_ReceiptedQty Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReceiptedQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ReceiptedQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ReceiptedQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReceiptedQty() : double;
function set U_ReceiptedQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_ReworkQty Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReworkQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ReworkQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ReworkQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReworkQty() : double;
function set U_ReworkQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_RscCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCode() : String;
function set U_RscCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_ScrapQty Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ScrapQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ScrapQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ScrapQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ScrapQty() : double;
function set U_ScrapQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_StartDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StartDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StartDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StartDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StartDate() : DateTime;
function set U_StartDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_StartTime Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StartTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StartTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StartTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StartTime() : DateTime;
function set U_StartTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_TargetEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_TargetEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_TargetEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_TargetEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TargetEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_TargetLieNum Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_TargetLieNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_TargetLieNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_TargetLieNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TargetLieNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_TimeCost Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_TimeCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_TimeCost {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_TimeCost {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TimeCost() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_TimeType Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TimeType() As RecordingTimeType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RecordingTimeType U_TimeType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RecordingTimeType U_TimeType {
 RecordingTimeType get( );
 void set(
   RecordingTimeType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TimeType() : RecordingTimeType;
function set U_TimeType(value : RecordingTimeType);
This language is not supported or no code example is available.

Property Value

Type: RecordingTimeType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_VariableCost Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_VariableCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VariableCost {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VariableCost {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VariableCost() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_WorkingHours Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WorkingHours() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan U_WorkingHours {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan U_WorkingHours {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WorkingHours() : TimeSpan;
function set U_WorkingHours(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.U_Yield Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Yield() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Yield {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Yield {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Yield() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines Methods

IOperationTimeRecordingLines Interface See Also

The following tables list the members exposed by the IOperationTimeRecordingLines type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | CalculateDuration |
Public method | CalculateDurationBaseOnResourceCalendar |
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationTimeRecordingLines Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.CalculateDuration Method

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub CalculateDuration()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void CalculateDuration()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void CalculateDuration()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CalculateDuration();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingLines.CalculateDurationBaseOnResourceCalendar Method

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub CalculateDurationBaseOnResourceCalendar()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void CalculateDurationBaseOnResourceCalendar()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void CalculateDurationBaseOnResourceCalendar()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CalculateDurationBaseOnResourceCalendar();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingLines Interface
IOperationTimeRecordingLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingReasons Interface

Members See Also

Reasons of operation time recording document

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IOperationTimeRecordingReasons
    Inherits IUDOChildBean, _
             IEnumerable(Of IOperationTimeRecordingReasons)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IOperationTimeRecordingReasons : IUDOChildBean,
   IEnumerable<IOperationTimeRecordingReasons>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IOperationTimeRecordingReasons : public IUDOChildBean^,
   public IEnumerable<IOperationTimeRecordingReasons^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_OTR3
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingReasons Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingReasons Members

IOperationTimeRecordingReasons Interface Methods Properties See Also

Reasons of operation time recording document

The following tables list the members exposed by the IOperationTimeRecordingReasons type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Qty |
Public property | U_ReasonCode |
Public property | U_ReasonType |
Public property | U_Remarks |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationTimeRecordingReasons Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingReasons Properties

IOperationTimeRecordingReasons Interface See Also

The following tables list the members exposed by the IOperationTimeRecordingReasons type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Qty |
Public property | U_ReasonCode |
Public property | U_ReasonType |
Public property | U_Remarks |
Top
See Also

Reference

IOperationTimeRecordingReasons Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingReasons.U_BaseLine Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLine() : int;
function set U_BaseLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingReasons Interface
IOperationTimeRecordingReasons Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingReasons.U_Qty Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Qty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Qty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Qty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Qty() : double;
function set U_Qty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingReasons Interface
IOperationTimeRecordingReasons Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingReasons.U_ReasonCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReasonCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ReasonCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ReasonCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReasonCode() : String;
function set U_ReasonCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingReasons Interface
IOperationTimeRecordingReasons Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingReasons.U_ReasonType Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReasonType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ReasonType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ReasonType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReasonType() : String;
function set U_ReasonType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingReasons Interface
IOperationTimeRecordingReasons Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingReasons.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingReasons Interface
IOperationTimeRecordingReasons Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


IOperationTimeRecordingReasons Methods

IOperationTimeRecordingReasons Interface See Also

The following tables list the members exposed by the IOperationTimeRecordingReasons type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationTimeRecordingReasons Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | BaseDocumentIsClosedException |
Public class | CantChangeAdjustmentException |
Public class | OperationTimeRecordingAdjustmentHelper |
Top
Interfaces
 | Name | Description
Public interface | IOperationTimeRecordingAdjustment | Operation time recording adjusement document
Public interface | IOperationTimeRecordingAdjustmentEmployeesTimeRecordings | Employees time recordings of operation time recording adjusement document
Public interface | IOperationTimeRecordingAdjustmentLines | Lines of operation time recording adjusement document
Public interface | IOperationTimeRecordingAdjustmentReasons | Reasons of operation time recording adjusement document
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


BaseDocumentIsClosedException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class BaseDocumentIsClosedException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class BaseDocumentIsClosedException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class BaseDocumentIsClosedException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class BaseDocumentIsClosedException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment.BaseDocumentIsClosedException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentIsClosedException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


BaseDocumentIsClosedException Members

BaseDocumentIsClosedException Class Constructors Methods Properties See Also

The following tables list the members exposed by the BaseDocumentIsClosedException type.

Constructors
 | Name | Description
Public constructor | BaseDocumentIsClosedException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BaseDocumentIsClosedException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


BaseDocumentIsClosedException Constructor

BaseDocumentIsClosedException Class See Also

Overload List
Name | Description
BaseDocumentIsClosedException() |
BaseDocumentIsClosedException(string) |
BaseDocumentIsClosedException(string, Exception) |
See Also

Reference

BaseDocumentIsClosedException Class
BaseDocumentIsClosedException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


BaseDocumentIsClosedException Properties

BaseDocumentIsClosedException Class See Also

The following tables list the members exposed by the BaseDocumentIsClosedException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

BaseDocumentIsClosedException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


BaseDocumentIsClosedException Methods

BaseDocumentIsClosedException Class See Also

The following tables list the members exposed by the BaseDocumentIsClosedException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BaseDocumentIsClosedException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


CantChangeAdjustmentException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class CantChangeAdjustmentException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class CantChangeAdjustmentException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class CantChangeAdjustmentException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class CantChangeAdjustmentException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment.CantChangeAdjustmentException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantChangeAdjustmentException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


CantChangeAdjustmentException Members

CantChangeAdjustmentException Class Constructors Methods Properties See Also

The following tables list the members exposed by the CantChangeAdjustmentException type.

Constructors
 | Name | Description
Public constructor | CantChangeAdjustmentException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

CantChangeAdjustmentException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


CantChangeAdjustmentException Constructor

CantChangeAdjustmentException Class See Also

Overload List
Name | Description
CantChangeAdjustmentException() |
CantChangeAdjustmentException(string) |
CantChangeAdjustmentException(string, Exception) |
See Also

Reference

CantChangeAdjustmentException Class
CantChangeAdjustmentException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


CantChangeAdjustmentException Properties

CantChangeAdjustmentException Class See Also

The following tables list the members exposed by the CantChangeAdjustmentException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

CantChangeAdjustmentException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


CantChangeAdjustmentException Methods

CantChangeAdjustmentException Class See Also

The following tables list the members exposed by the CantChangeAdjustmentException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

CantChangeAdjustmentException Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


OperationTimeRecordingAdjustmentHelper Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class OperationTimeRecordingAdjustmentHelper
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class OperationTimeRecordingAdjustmentHelper
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class OperationTimeRecordingAdjustmentHelper
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class OperationTimeRecordingAdjustmentHelper
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment.OperationTimeRecordingAdjustmentHelper
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OperationTimeRecordingAdjustmentHelper Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


OperationTimeRecordingAdjustmentHelper Members

OperationTimeRecordingAdjustmentHelper Class Methods See Also

The following tables list the members exposed by the OperationTimeRecordingAdjustmentHelper type.

Methods
 | Name | Description
 | CalcTotalWorkTime |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

OperationTimeRecordingAdjustmentHelper Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


OperationTimeRecordingAdjustmentHelper Methods

OperationTimeRecordingAdjustmentHelper Class See Also

The following tables list the members exposed by the OperationTimeRecordingAdjustmentHelper type.

Methods
 | Name | Description
 | CalcTotalWorkTime |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

OperationTimeRecordingAdjustmentHelper Class
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


OperationTimeRecordingAdjustmentHelper.CalcTotalWorkTime Method

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function CalcTotalWorkTime( _
   ByVal udo As IOperationTimeRecordingAdjustment _
) As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static TimeSpan CalcTotalWorkTime(
   IOperationTimeRecordingAdjustment udo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static TimeSpan CalcTotalWorkTime(
   IOperationTimeRecordingAdjustment^ udo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function CalcTotalWorkTime(
    udo : IOperationTimeRecordingAdjustment
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

udo

Type: IOperationTimeRecordingAdjustment

Return Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OperationTimeRecordingAdjustmentHelper Class
OperationTimeRecordingAdjustmentHelper Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment Interface

Members See Also

Operation time recording adjusement document

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "OperationTimeRecordingAdjustment", TableName = "@CT_PF_OATR", UDOVersion = "UDO_10", ExludedHttpMethods = "DELETE")> _
Public Interface IOperationTimeRecordingAdjustment
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "OperationTimeRecordingAdjustment", TableName = "@CT_PF_OATR", UDOVersion = "UDO_10", ExludedHttpMethods = "DELETE")]
public interface IOperationTimeRecordingAdjustment : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "OperationTimeRecordingAdjustment", TableName = "@CT_PF_OATR", UDOVersion = "UDO_10", ExludedHttpMethods = "DELETE")]
public interface class IOperationTimeRecordingAdjustment : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "OperationTimeRecordingAdjustment", TableName = "@CT_PF_OATR", UDOVersion = "UDO_10", ExludedHttpMethods = "DELETE")
interface IOperationTimeRecordingAdjustment
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OATR
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment Members

IOperationTimeRecordingAdjustment Interface Methods Properties See Also

Operation time recording adjusement document

The following tables list the members exposed by the IOperationTimeRecordingAdjustment type.

Properties
 | Name | Description
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | EmployeeTimeRecords |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | Lines |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Reasons |
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Backflushed |
Public property | U_BaseEntry |
Public property | U_BaseType |
Public property | U_Closed |
Public property | U_DocDate |
Public property | U_JrnlRemark |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_PostingDate |
Public property | U_Ref2 |
Public property | U_Remarks |
Public property | U_TransId |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | CreateAdjustmentFromOperationTimeRecordings |
Public method | CreateAdjustmentFromOperationTimeRecordingsAdjustment |
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IOperationTimeRecordingAdjustment Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment Properties

IOperationTimeRecordingAdjustment Interface See Also

The following tables list the members exposed by the IOperationTimeRecordingAdjustment type.

Properties
 | Name | Description
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | EmployeeTimeRecords |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | Lines |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Reasons |
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Backflushed |
Public property | U_BaseEntry |
Public property | U_BaseType |
Public property | U_Closed |
Public property | U_DocDate |
Public property | U_JrnlRemark |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_PostingDate |
Public property | U_Ref2 |
Public property | U_Remarks |
Public property | U_TransId |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IOperationTimeRecordingAdjustment Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.DocNum Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.EmployeeTimeRecords Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property EmployeeTimeRecords() As IOperationTimeRecordingAdjustmentEmployeesTimeRecordings
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IOperationTimeRecordingAdjustmentEmployeesTimeRecordings EmployeeTimeRecords {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IOperationTimeRecordingAdjustmentEmployeesTimeRecordings^ EmployeeTimeRecords {
 IOperationTimeRecordingAdjustmentEmployeesTimeRecordings^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get EmployeeTimeRecords() : IOperationTimeRecordingAdjustmentEmployeesTimeRecordings;
This language is not supported or no code example is available.

Property Value

Type: IOperationTimeRecordingAdjustmentEmployeesTimeRecordings
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.Handwrtten Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Handwrtten() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Handwrtten {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Handwrtten {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Handwrtten() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.Instance Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Instance() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Instance {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Instance {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Instance() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.Lines Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Lines() As IOperationTimeRecordingAdjustmentLines
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IOperationTimeRecordingAdjustmentLines Lines {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IOperationTimeRecordingAdjustmentLines^ Lines {
 IOperationTimeRecordingAdjustmentLines^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Lines() : IOperationTimeRecordingAdjustmentLines;
This language is not supported or no code example is available.

Property Value

Type: IOperationTimeRecordingAdjustmentLines
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.Period Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Period() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Period {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Period {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Period() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.Reasons Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Reasons() As IOperationTimeRecordingAdjustmentReasons
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IOperationTimeRecordingAdjustmentReasons Reasons {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IOperationTimeRecordingAdjustmentReasons^ Reasons {
 IOperationTimeRecordingAdjustmentReasons^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Reasons() : IOperationTimeRecordingAdjustmentReasons;
This language is not supported or no code example is available.

Property Value

Type: IOperationTimeRecordingAdjustmentReasons
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.Series Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Series() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Series {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Series {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Series() : int;
function set Series(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.Status Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Status {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Status {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Status() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.U_Backflushed Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Backflushed() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Backflushed {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Backflushed {
 YesNoType get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Backflushed() : YesNoType;
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.U_BaseEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BaseEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.U_BaseType Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BaseType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BaseType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BaseType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseType() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.U_Closed Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Closed() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Closed {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Closed {
 YesNoType get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Closed() : YesNoType;
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.U_DocDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DocDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_DocDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_DocDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DocDate() : DateTime;
function set U_DocDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.U_JrnlRemark Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_JrnlRemark() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_JrnlRemark {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_JrnlRemark {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_JrnlRemark() : String;
function set U_JrnlRemark(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.U_PostingDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PostingDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_PostingDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_PostingDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PostingDate() : DateTime;
function set U_PostingDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.U_Ref2 Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Ref2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Ref2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Ref2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Ref2() : String;
function set U_Ref2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.U_TransId Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TransId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_TransId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_TransId {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TransId() : int;
function set U_TransId(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment Methods

IOperationTimeRecordingAdjustment Interface See Also

The following tables list the members exposed by the IOperationTimeRecordingAdjustment type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | CreateAdjustmentFromOperationTimeRecordings |
Public method | CreateAdjustmentFromOperationTimeRecordingsAdjustment |
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IOperationTimeRecordingAdjustment Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.CreateAdjustmentFromOperationTimeRecordings Method

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub CreateAdjustmentFromOperationTimeRecordings( _
   ByVal docentry As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void CreateAdjustmentFromOperationTimeRecordings(
   int docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void CreateAdjustmentFromOperationTimeRecordings(
   int docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CreateAdjustmentFromOperationTimeRecordings(
    docentry : int
);
This language is not supported or no code example is available.

Parameters

docentry

Type: int

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustment.CreateAdjustmentFromOperationTimeRecordingsAdjustment Method

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub CreateAdjustmentFromOperationTimeRecordingsAdjustment( _
   ByVal docentry As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void CreateAdjustmentFromOperationTimeRecordingsAdjustment(
   int docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void CreateAdjustmentFromOperationTimeRecordingsAdjustment(
   int docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CreateAdjustmentFromOperationTimeRecordingsAdjustment(
    docentry : int
);
This language is not supported or no code example is available.

Parameters

docentry

Type: int

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustment Interface
IOperationTimeRecordingAdjustment Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface

Members See Also

Employees time recordings of operation time recording adjusement document

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IOperationTimeRecordingAdjustmentEmployeesTimeRecordings
    Inherits IUDOChildBean, _
             IEnumerable(Of IOperationTimeRecordingAdjustmentEmployeesTimeRecordings)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IOperationTimeRecordingAdjustmentEmployeesTimeRecordings : IUDOChildBean,
   IEnumerable<IOperationTimeRecordingAdjustmentEmployeesTimeRecordings>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IOperationTimeRecordingAdjustmentEmployeesTimeRecordings : public IUDOChildBean^,
   public IEnumerable<IOperationTimeRecordingAdjustmentEmployeesTimeRecordings^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_ATR2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Members

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface Methods Properties See Also

Employees time recordings of operation time recording adjusement document

The following tables list the members exposed by the IOperationTimeRecordingAdjustmentEmployeesTimeRecordings type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine |
Public property | U_DateFrom |
Public property | U_DateTo |
Public property | U_EmplID |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_TeamCode |
Public property | U_TimeFrom |
Public property | U_TimeTo |
Public property | VisOrder |
Public property | WorkDuration |
Public property | WorkEnd |
Public property | WorkStart |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Properties

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface See Also

The following tables list the members exposed by the IOperationTimeRecordingAdjustmentEmployeesTimeRecordings type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine |
Public property | U_DateFrom |
Public property | U_DateTo |
Public property | U_EmplID |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_TeamCode |
Public property | U_TimeFrom |
Public property | U_TimeTo |
Public property | VisOrder |
Public property | WorkDuration |
Public property | WorkEnd |
Public property | WorkStart |
Top
See Also

Reference

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentEmployeesTimeRecordings.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface
IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentEmployeesTimeRecordings.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface
IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentEmployeesTimeRecordings.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface
IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentEmployeesTimeRecordings.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface
IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentEmployeesTimeRecordings.U_BaseLine Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLine() : int;
function set U_BaseLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface
IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentEmployeesTimeRecordings.U_DateFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property U_DateFrom() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime U_DateFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime U_DateFrom {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_DateFrom() : DateTime;

   AppEnginePropertyIgnore()
function set U_DateFrom(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface
IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentEmployeesTimeRecordings.U_DateTo Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property U_DateTo() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime U_DateTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime U_DateTo {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_DateTo() : DateTime;

   AppEnginePropertyIgnore()
function set U_DateTo(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface
IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentEmployeesTimeRecordings.U_EmplID Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EmplID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_EmplID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_EmplID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EmplID() : int;
function set U_EmplID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface
IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentEmployeesTimeRecordings.U_TeamCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TeamCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TeamCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TeamCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TeamCode() : String;
function set U_TeamCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface
IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentEmployeesTimeRecordings.U_TimeFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property U_TimeFrom() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime U_TimeFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime U_TimeFrom {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_TimeFrom() : DateTime;

   AppEnginePropertyIgnore()
function set U_TimeFrom(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface
IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentEmployeesTimeRecordings.U_TimeTo Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property U_TimeTo() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime U_TimeTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime U_TimeTo {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_TimeTo() : DateTime;

   AppEnginePropertyIgnore()
function set U_TimeTo(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface
IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentEmployeesTimeRecordings.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface
IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentEmployeesTimeRecordings.WorkDuration Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property WorkDuration() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan WorkDuration {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan WorkDuration {
 TimeSpan get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WorkDuration() : TimeSpan;
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface
IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentEmployeesTimeRecordings.WorkEnd Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property WorkEnd() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime WorkEnd {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime WorkEnd {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WorkEnd() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface
IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentEmployeesTimeRecordings.WorkStart Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property WorkStart() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime WorkStart {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime WorkStart {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WorkStart() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface
IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Methods

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface See Also

The following tables list the members exposed by the IOperationTimeRecordingAdjustmentEmployeesTimeRecordings type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationTimeRecordingAdjustmentEmployeesTimeRecordings Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines Interface

Members See Also

Lines of operation time recording adjusement document

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IOperationTimeRecordingAdjustmentLines
    Inherits IUDOChildBean, _
             IEnumerable(Of IOperationTimeRecordingAdjustmentLines)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IOperationTimeRecordingAdjustmentLines : IUDOChildBean,
   IEnumerable<IOperationTimeRecordingAdjustmentLines>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IOperationTimeRecordingAdjustmentLines : public IUDOChildBean^,
   public IEnumerable<IOperationTimeRecordingAdjustmentLines^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_ATR1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines Members

IOperationTimeRecordingAdjustmentLines Interface Methods Properties See Also

Lines of operation time recording adjusement document

The following tables list the members exposed by the IOperationTimeRecordingAdjustmentLines type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | OperationStatus |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AcctCode |
Public property | U_BaseDocNum |
Public property | U_BaseEntry |
Public property | U_BaseLineNum |
Public property | U_BaseType |
Public property | U_CloseTask |
Public property | U_Effort |
Public property | U_EndDate |
Public property | U_EndTime |
Public property | U_FixedCost |
Public property | U_LineNum | Gets ProcessForce Line Num
Public property | U_MORDocEntry |
Public property | U_MORDocNum |
Public property | U_MORLineNum |
Public property | U_NetQty |
Public property | U_NrOfResources |
Public property | U_OcrCode |
Public property | U_OcrCode2 |
Public property | U_OcrCode3 |
Public property | U_OcrCode4 |
Public property | U_OcrCode5 |
Public property | U_OprCode |
Public property | U_Project |
Public property | U_ReceiptedQty |
Public property | U_Remarks |
Public property | U_ReworkQty |
Public property | U_RscCode |
Public property | U_ScrapQty |
Public property | U_StartDate |
Public property | U_StartTime |
Public property | U_TargetEntry |
Public property | U_TargetLieNum |
Public property | U_TimeCost |
Public property | U_TimeType |
Public property | U_VariableCost |
Public property | U_WorkingHours |
Public property | U_Yield |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | CalculateDuration |
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines Properties

IOperationTimeRecordingAdjustmentLines Interface See Also

The following tables list the members exposed by the IOperationTimeRecordingAdjustmentLines type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | OperationStatus |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AcctCode |
Public property | U_BaseDocNum |
Public property | U_BaseEntry |
Public property | U_BaseLineNum |
Public property | U_BaseType |
Public property | U_CloseTask |
Public property | U_Effort |
Public property | U_EndDate |
Public property | U_EndTime |
Public property | U_FixedCost |
Public property | U_LineNum | Gets ProcessForce Line Num
Public property | U_MORDocEntry |
Public property | U_MORDocNum |
Public property | U_MORLineNum |
Public property | U_NetQty |
Public property | U_NrOfResources |
Public property | U_OcrCode |
Public property | U_OcrCode2 |
Public property | U_OcrCode3 |
Public property | U_OcrCode4 |
Public property | U_OcrCode5 |
Public property | U_OprCode |
Public property | U_Project |
Public property | U_ReceiptedQty |
Public property | U_Remarks |
Public property | U_ReworkQty |
Public property | U_RscCode |
Public property | U_ScrapQty |
Public property | U_StartDate |
Public property | U_StartTime |
Public property | U_TargetEntry |
Public property | U_TargetLieNum |
Public property | U_TimeCost |
Public property | U_TimeType |
Public property | U_VariableCost |
Public property | U_WorkingHours |
Public property | U_Yield |
Public property | VisOrder |
Top
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.OperationStatus Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property OperationStatus() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string OperationStatus {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ OperationStatus {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OperationStatus() : String;
function set OperationStatus(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_AcctCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AcctCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AcctCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AcctCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AcctCode() : String;
function set U_AcctCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_BaseDocNum Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BaseDocNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseDocNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseDocNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseDocNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_BaseEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BaseEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_BaseLineNum Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BaseLineNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLineNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLineNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLineNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_BaseType Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_BaseType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BaseType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BaseType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseType() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_CloseTask Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CloseTask() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_CloseTask {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_CloseTask {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CloseTask() : YesNoType;
function set U_CloseTask(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_Effort Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Effort() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan U_Effort {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan U_Effort {
 TimeSpan get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Effort() : TimeSpan;
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_EndDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_EndDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_EndDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EndDate() : DateTime;
function set U_EndDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_EndTime Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EndTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_EndTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_EndTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EndTime() : DateTime;
function set U_EndTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_FixedCost Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_FixedCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FixedCost {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FixedCost {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FixedCost() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_LineNum Property

Gets ProcessForce Line Num

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property U_LineNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
int U_LineNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property int U_LineNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get U_LineNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_MORDocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_MORDocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_MORDocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_MORDocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MORDocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_MORDocNum Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_MORDocNum() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MORDocNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MORDocNum {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MORDocNum() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_MORLineNum Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_MORLineNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_MORLineNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_MORLineNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MORLineNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_NetQty Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_NetQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_NetQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_NetQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_NetQty() : double;
function set U_NetQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_NrOfResources Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_NrOfResources() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_NrOfResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_NrOfResources {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_NrOfResources() : int;
function set U_NrOfResources(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_OcrCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode() : String;
function set U_OcrCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_OcrCode2 Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode2() : String;
function set U_OcrCode2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_OcrCode3 Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode3() : String;
function set U_OcrCode3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_OcrCode4 Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode4() : String;
function set U_OcrCode4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_OcrCode5 Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode5() : String;
function set U_OcrCode5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_OprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_Project Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Project() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Project {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Project {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Project() : String;
function set U_Project(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_ReceiptedQty Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReceiptedQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ReceiptedQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ReceiptedQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReceiptedQty() : double;
function set U_ReceiptedQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_ReworkQty Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReworkQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ReworkQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ReworkQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReworkQty() : double;
function set U_ReworkQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_RscCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCode() : String;
function set U_RscCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_ScrapQty Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ScrapQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ScrapQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ScrapQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ScrapQty() : double;
function set U_ScrapQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_StartDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StartDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StartDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StartDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StartDate() : DateTime;
function set U_StartDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_StartTime Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StartTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StartTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StartTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StartTime() : DateTime;
function set U_StartTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_TargetEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_TargetEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_TargetEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_TargetEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TargetEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_TargetLieNum Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_TargetLieNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_TargetLieNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_TargetLieNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TargetLieNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_TimeCost Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_TimeCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_TimeCost {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_TimeCost {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TimeCost() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_TimeType Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TimeType() As RecordingTimeType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RecordingTimeType U_TimeType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RecordingTimeType U_TimeType {
 RecordingTimeType get( );
 void set(
   RecordingTimeType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TimeType() : RecordingTimeType;
function set U_TimeType(value : RecordingTimeType);
This language is not supported or no code example is available.

Property Value

Type: RecordingTimeType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_VariableCost Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_VariableCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_VariableCost {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_VariableCost {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VariableCost() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_WorkingHours Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WorkingHours() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan U_WorkingHours {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan U_WorkingHours {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WorkingHours() : TimeSpan;
function set U_WorkingHours(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.U_Yield Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_Yield() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Yield {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Yield {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Yield() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines Methods

IOperationTimeRecordingAdjustmentLines Interface See Also

The following tables list the members exposed by the IOperationTimeRecordingAdjustmentLines type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | CalculateDuration |
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentLines.CalculateDuration Method

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub CalculateDuration()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void CalculateDuration()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void CalculateDuration()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CalculateDuration();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentLines Interface
IOperationTimeRecordingAdjustmentLines Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentReasons Interface

Members See Also

Reasons of operation time recording adjusement document

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IOperationTimeRecordingAdjustmentReasons
    Inherits IUDOChildBean, _
             IEnumerable(Of IOperationTimeRecordingAdjustmentReasons)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IOperationTimeRecordingAdjustmentReasons : IUDOChildBean,
   IEnumerable<IOperationTimeRecordingAdjustmentReasons>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IOperationTimeRecordingAdjustmentReasons : public IUDOChildBean^,
   public IEnumerable<IOperationTimeRecordingAdjustmentReasons^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_ATR3
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentReasons Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentReasons Members

IOperationTimeRecordingAdjustmentReasons Interface Methods Properties See Also

Reasons of operation time recording adjusement document

The following tables list the members exposed by the IOperationTimeRecordingAdjustmentReasons type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Qty |
Public property | U_ReasonCode |
Public property | U_ReasonType |
Public property | U_Remarks |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationTimeRecordingAdjustmentReasons Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentReasons Properties

IOperationTimeRecordingAdjustmentReasons Interface See Also

The following tables list the members exposed by the IOperationTimeRecordingAdjustmentReasons type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Qty |
Public property | U_ReasonCode |
Public property | U_ReasonType |
Public property | U_Remarks |
Top
See Also

Reference

IOperationTimeRecordingAdjustmentReasons Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentReasons.U_BaseLine Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLine() : int;
function set U_BaseLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentReasons Interface
IOperationTimeRecordingAdjustmentReasons Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentReasons.U_Qty Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Qty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Qty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Qty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Qty() : double;
function set U_Qty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentReasons Interface
IOperationTimeRecordingAdjustmentReasons Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentReasons.U_ReasonCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReasonCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ReasonCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ReasonCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReasonCode() : String;
function set U_ReasonCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentReasons Interface
IOperationTimeRecordingAdjustmentReasons Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentReasons.U_ReasonType Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReasonType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ReasonType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ReasonType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReasonType() : String;
function set U_ReasonType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentReasons Interface
IOperationTimeRecordingAdjustmentReasons Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentReasons.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOperationTimeRecordingAdjustmentReasons Interface
IOperationTimeRecordingAdjustmentReasons Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


IOperationTimeRecordingAdjustmentReasons Methods

IOperationTimeRecordingAdjustmentReasons Interface See Also

The following tables list the members exposed by the IOperationTimeRecordingAdjustmentReasons type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOperationTimeRecordingAdjustmentReasons Interface
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IOrderRecommendation | Order recommendation object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IOrderRecommendation Interface

Members See Also

Order recommendation object

Namespace: CompuTec.ProcessForce.API.Documents.OrderRecommendation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "OrderRecommendation", TableName = "@CT_PF_ORCM", UDOVersion = "UDO_10")> _
Public Interface IOrderRecommendation
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "OrderRecommendation", TableName = "@CT_PF_ORCM", UDOVersion = "UDO_10")]
public interface IOrderRecommendation : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "OrderRecommendation", TableName = "@CT_PF_ORCM", UDOVersion = "UDO_10")]
public interface class IOrderRecommendation : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "OrderRecommendation", TableName = "@CT_PF_ORCM", UDOVersion = "UDO_10")
interface IOrderRecommendation
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ORCM
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderRecommendation Members
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation Members

IOrderRecommendation Interface Methods Properties See Also

Order recommendation object

The following tables list the members exposed by the IOrderRecommendation type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_CardCode |
Public property | U_OrdRcmDocNo |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IOrderRecommendation Interface
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation Properties

IOrderRecommendation Interface See Also

The following tables list the members exposed by the IOrderRecommendation type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_CardCode |
Public property | U_OrdRcmDocNo |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IOrderRecommendation Interface
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderRecommendation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderRecommendation Interface
IOrderRecommendation Members
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderRecommendation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderRecommendation Interface
IOrderRecommendation Members
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderRecommendation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderRecommendation Interface
IOrderRecommendation Members
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderRecommendation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderRecommendation Interface
IOrderRecommendation Members
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderRecommendation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderRecommendation Interface
IOrderRecommendation Members
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderRecommendation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderRecommendation Interface
IOrderRecommendation Members
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderRecommendation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderRecommendation Interface
IOrderRecommendation Members
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderRecommendation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderRecommendation Interface
IOrderRecommendation Members
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderRecommendation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderRecommendation Interface
IOrderRecommendation Members
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderRecommendation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderRecommendation Interface
IOrderRecommendation Members
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation.U_CardCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderRecommendation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CardCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CardCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CardCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CardCode() : String;
function set U_CardCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderRecommendation Interface
IOrderRecommendation Members
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation.U_OrdRcmDocNo Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderRecommendation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OrdRcmDocNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_OrdRcmDocNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_OrdRcmDocNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OrdRcmDocNo() : int;
function set U_OrdRcmDocNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderRecommendation Interface
IOrderRecommendation Members
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderRecommendation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderRecommendation Interface
IOrderRecommendation Members
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderRecommendation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderRecommendation Interface
IOrderRecommendation Members
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderRecommendation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderRecommendation Interface
IOrderRecommendation Members
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderRecommendation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderRecommendation Interface
IOrderRecommendation Members
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderRecommendation
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderRecommendation Interface
IOrderRecommendation Members
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


IOrderRecommendation Methods

IOrderRecommendation Interface See Also

The following tables list the members exposed by the IOrderRecommendation type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IOrderRecommendation Interface
CompuTec.ProcessForce.API.Documents.OrderRecommendation Namespace


CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IOrderlessProductionDocument | Orderless production document
Public interface | IOrderlessProductionDocumentLines | Lines of orderless production document
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IOrderlessProductionDocument Interface

Members See Also

Orderless production document

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "OrderlessProduction", TableName = "@CT_PF_OPRD", ExludedHttpMethods = "DELETE")> _
Public Interface IOrderlessProductionDocument
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "OrderlessProduction", TableName = "@CT_PF_OPRD", ExludedHttpMethods = "DELETE")]
public interface IOrderlessProductionDocument : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "OrderlessProduction", TableName = "@CT_PF_OPRD", ExludedHttpMethods = "DELETE")]
public interface class IOrderlessProductionDocument : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "OrderlessProduction", TableName = "@CT_PF_OPRD", ExludedHttpMethods = "DELETE")
interface IOrderlessProductionDocument
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OPRD
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument Members

IOrderlessProductionDocument Interface Methods Properties See Also

Orderless production document

The following tables list the members exposed by the IOrderlessProductionDocument type.

Properties
 | Name | Description
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | Lines |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Date |
Public property | U_PostingDate |
Public property | U_Remarks |
Public property | U_Shift |
Public property | U_TemplateCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IOrderlessProductionDocument Interface
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument Properties

IOrderlessProductionDocument Interface See Also

The following tables list the members exposed by the IOrderlessProductionDocument type.

Properties
 | Name | Description
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | Lines |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Date |
Public property | U_PostingDate |
Public property | U_Remarks |
Public property | U_Shift |
Public property | U_TemplateCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IOrderlessProductionDocument Interface
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.DocNum Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.Handwrtten Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Handwrtten() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Handwrtten {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Handwrtten {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Handwrtten() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.Instance Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Instance() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Instance {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Instance {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Instance() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.Lines Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Lines() As IOrderlessProductionDocumentLines
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IOrderlessProductionDocumentLines Lines {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IOrderlessProductionDocumentLines^ Lines {
 IOrderlessProductionDocumentLines^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Lines() : IOrderlessProductionDocumentLines;
This language is not supported or no code example is available.

Property Value

Type: IOrderlessProductionDocumentLines
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.Period Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Period() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Period {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Period {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Period() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.Series Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Series() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Series {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Series {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Series() : int;
function set Series(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.Status Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Status {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Status {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Status() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.U_Date Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Date() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Date {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Date {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Date() : DateTime;
function set U_Date(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.U_PostingDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PostingDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_PostingDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_PostingDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PostingDate() : DateTime;
function set U_PostingDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.U_Shift Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Shift() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Shift {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Shift {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Shift() : String;
function set U_Shift(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.U_TemplateCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TemplateCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TemplateCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TemplateCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TemplateCode() : String;
function set U_TemplateCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocument Interface
IOrderlessProductionDocument Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocument Methods

IOrderlessProductionDocument Interface See Also

The following tables list the members exposed by the IOrderlessProductionDocument type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IOrderlessProductionDocument Interface
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines Interface

Members See Also

Lines of orderless production document

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IOrderlessProductionDocumentLines
    Inherits IUDOChildBean, _
             IEnumerable(Of IOrderlessProductionDocumentLines)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IOrderlessProductionDocumentLines : IUDOChildBean,
   IEnumerable<IOrderlessProductionDocumentLines>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IOrderlessProductionDocumentLines : public IUDOChildBean^,
   public IEnumerable<IOrderlessProductionDocumentLines^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_PRD1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines Members

IOrderlessProductionDocumentLines Interface Methods Properties See Also

Lines of orderless production document

The following tables list the members exposed by the IOrderlessProductionDocumentLines type.

Properties
 | Name | Description
Public property | Branch |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | DsRowNum |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine |
Public property | U_BomCode |
Public property | U_Classification |
Public property | U_DocEntry |
Public property | U_DocNum |
Public property | U_ItemCode |
Public property | U_ItemType |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MorLine |
Public property | U_Price |
Public property | U_Qty |
Public property | U_RevCode |
Public property | U_RtgCode |
Public property | U_WhsCode |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOrderlessProductionDocumentLines Interface
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines Properties

IOrderlessProductionDocumentLines Interface See Also

The following tables list the members exposed by the IOrderlessProductionDocumentLines type.

Properties
 | Name | Description
Public property | Branch |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | DsRowNum |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine |
Public property | U_BomCode |
Public property | U_Classification |
Public property | U_DocEntry |
Public property | U_DocNum |
Public property | U_ItemCode |
Public property | U_ItemType |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MorLine |
Public property | U_Price |
Public property | U_Qty |
Public property | U_RevCode |
Public property | U_RtgCode |
Public property | U_WhsCode |
Public property | VisOrder |
Top
See Also

Reference

IOrderlessProductionDocumentLines Interface
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.Branch Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Branch() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Branch {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Branch {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Branch() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.DsRowNum Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DsRowNum() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DsRowNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DsRowNum {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DsRowNum() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.U_BaseLine Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLine() : int;
function set U_BaseLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.U_BomCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BomCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BomCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BomCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BomCode() : String;
function set U_BomCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.U_Classification Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Classification() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Classification {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Classification {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Classification() : String;
function set U_Classification(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.U_DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.U_DocNum Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_DocNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_DocNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_DocNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DocNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.U_ItemType Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemType() : String;
function set U_ItemType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.U_MorLine Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_MorLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_MorLine {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_MorLine {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MorLine() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.U_Price Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Price() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Price {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Price {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Price() : double;
function set U_Price(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.U_Qty Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Qty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Qty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Qty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Qty() : double;
function set U_Qty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.U_RevCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevCode() : String;
function set U_RevCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.U_RtgCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RtgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RtgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgCode() : String;
function set U_RtgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.U_WhsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionDocumentLines Interface
IOrderlessProductionDocumentLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


IOrderlessProductionDocumentLines Methods

IOrderlessProductionDocumentLines Interface See Also

The following tables list the members exposed by the IOrderlessProductionDocumentLines type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOrderlessProductionDocumentLines Interface
CompuTec.ProcessForce.API.Documents.OrderlessProductionDocument Namespace


CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IOrderlessProductionTemplate | Orderless production template object
Public interface | IOrderlessProductionTemplateLines | Lines of orderless production template object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IOrderlessProductionTemplate Interface

Members See Also

Orderless production template object

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "OrderlessProductionTemplate", TableName = "@CT_PF_OPRT", UDOVersion = "UDO_10")> _
Public Interface IOrderlessProductionTemplate
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "OrderlessProductionTemplate", TableName = "@CT_PF_OPRT", UDOVersion = "UDO_10")]
public interface IOrderlessProductionTemplate : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "OrderlessProductionTemplate", TableName = "@CT_PF_OPRT", UDOVersion = "UDO_10")]
public interface class IOrderlessProductionTemplate : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "OrderlessProductionTemplate", TableName = "@CT_PF_OPRT", UDOVersion = "UDO_10")
interface IOrderlessProductionTemplate
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OPRT
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplate Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplate Members

IOrderlessProductionTemplate Interface Methods Properties See Also

Orderless production template object

The following tables list the members exposed by the IOrderlessProductionTemplate type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Lines |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Date |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IOrderlessProductionTemplate Interface
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplate Properties

IOrderlessProductionTemplate Interface See Also

The following tables list the members exposed by the IOrderlessProductionTemplate type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Lines |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Date |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IOrderlessProductionTemplate Interface
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplate.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplate Interface
IOrderlessProductionTemplate Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplate.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplate Interface
IOrderlessProductionTemplate Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplate.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplate Interface
IOrderlessProductionTemplate Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplate.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplate Interface
IOrderlessProductionTemplate Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplate.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplate Interface
IOrderlessProductionTemplate Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplate.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplate Interface
IOrderlessProductionTemplate Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplate.Lines Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Lines() As IOrderlessProductionTemplateLines
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IOrderlessProductionTemplateLines Lines {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IOrderlessProductionTemplateLines^ Lines {
 IOrderlessProductionTemplateLines^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Lines() : IOrderlessProductionTemplateLines;
This language is not supported or no code example is available.

Property Value

Type: IOrderlessProductionTemplateLines
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplate Interface
IOrderlessProductionTemplate Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplate.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplate Interface
IOrderlessProductionTemplate Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplate.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
function set Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplate Interface
IOrderlessProductionTemplate Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplate.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplate Interface
IOrderlessProductionTemplate Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplate.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplate Interface
IOrderlessProductionTemplate Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplate.U_Date Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Date() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Date {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Date {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Date() : DateTime;
function set U_Date(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplate Interface
IOrderlessProductionTemplate Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplate.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplate Interface
IOrderlessProductionTemplate Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplate.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplate Interface
IOrderlessProductionTemplate Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplate.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplate Interface
IOrderlessProductionTemplate Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplate.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplate Interface
IOrderlessProductionTemplate Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplate Methods

IOrderlessProductionTemplate Interface See Also

The following tables list the members exposed by the IOrderlessProductionTemplate type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IOrderlessProductionTemplate Interface
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplateLines Interface

Members See Also

Lines of orderless production template object

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IOrderlessProductionTemplateLines
    Inherits IUDOChildBean, _
             IEnumerable(Of IOrderlessProductionTemplateLines)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IOrderlessProductionTemplateLines : IUDOChildBean,
   IEnumerable<IOrderlessProductionTemplateLines>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IOrderlessProductionTemplateLines : public IUDOChildBean^,
   public IEnumerable<IOrderlessProductionTemplateLines^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_PRT1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplateLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplateLines Members

IOrderlessProductionTemplateLines Interface Methods Properties See Also

Lines of orderless production template object

The following tables list the members exposed by the IOrderlessProductionTemplateLines type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine |
Public property | U_BomCode |
Public property | U_ItemCode |
Public property | U_ItemType |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_RevCode |
Public property | U_RtgCode |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOrderlessProductionTemplateLines Interface
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplateLines Properties

IOrderlessProductionTemplateLines Interface See Also

The following tables list the members exposed by the IOrderlessProductionTemplateLines type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine |
Public property | U_BomCode |
Public property | U_ItemCode |
Public property | U_ItemType |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_RevCode |
Public property | U_RtgCode |
Top
See Also

Reference

IOrderlessProductionTemplateLines Interface
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplateLines.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplateLines Interface
IOrderlessProductionTemplateLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplateLines.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplateLines Interface
IOrderlessProductionTemplateLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplateLines.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplateLines Interface
IOrderlessProductionTemplateLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplateLines.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplateLines Interface
IOrderlessProductionTemplateLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplateLines.U_BaseLine Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLine() : int;
function set U_BaseLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplateLines Interface
IOrderlessProductionTemplateLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplateLines.U_BomCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BomCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BomCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BomCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BomCode() : String;
function set U_BomCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplateLines Interface
IOrderlessProductionTemplateLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplateLines.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplateLines Interface
IOrderlessProductionTemplateLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplateLines.U_ItemType Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemType() : String;
function set U_ItemType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplateLines Interface
IOrderlessProductionTemplateLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplateLines.U_RevCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevCode() : String;
function set U_RevCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplateLines Interface
IOrderlessProductionTemplateLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplateLines.U_RtgCode Property

Namespace: CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RtgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RtgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgCode() : String;
function set U_RtgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IOrderlessProductionTemplateLines Interface
IOrderlessProductionTemplateLines Members
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


IOrderlessProductionTemplateLines Methods

IOrderlessProductionTemplateLines Interface See Also

The following tables list the members exposed by the IOrderlessProductionTemplateLines type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IOrderlessProductionTemplateLines Interface
CompuTec.ProcessForce.API.Documents.OrderlessProductionTemplate Namespace


CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
Name | Description
SupplierScoreCardTools |
Top
Interfaces
 | Name | Description
Public interface | ISupplierScoreCard | Supplier score card object
Public interface | ISupplierScoreCardAttachments | Attachments for supplier score card object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


SupplierScoreCardTools Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SupplierScoreCardTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static class SupplierScoreCardTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SupplierScoreCardTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SupplierScoreCardTools
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard.SupplierScoreCardTools
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplierScoreCardTools Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


SupplierScoreCardTools Members

SupplierScoreCardTools Class Methods See Also

The following tables list the members exposed by the SupplierScoreCardTools type.

Methods
 | Name | Description
 | CheckIfSupplierScoreCardAlreadyExists |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetMasterDataCodeBasedOnBPCode |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SupplierScoreCardTools Class
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


SupplierScoreCardTools Methods

SupplierScoreCardTools Class See Also

The following tables list the members exposed by the SupplierScoreCardTools type.

Methods
 | Name | Description
 | CheckIfSupplierScoreCardAlreadyExists |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetMasterDataCodeBasedOnBPCode |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SupplierScoreCardTools Class
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


SupplierScoreCardTools.CheckIfSupplierScoreCardAlreadyExists Method

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function CheckIfSupplierScoreCardAlreadyExists( _
   ByVal token As String, _
   ByVal bpcode As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool CheckIfSupplierScoreCardAlreadyExists(
   string token,
   string bpcode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool CheckIfSupplierScoreCardAlreadyExists(
   String^ token,
   String^ bpcode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function CheckIfSupplierScoreCardAlreadyExists(
    token : String,
    bpcode : String
) : boolean;
This language is not supported or no code example is available.

Parameters

token

Type: string

bpcode

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplierScoreCardTools Class
SupplierScoreCardTools Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


SupplierScoreCardTools.GetMasterDataCodeBasedOnBPCode Method

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetMasterDataCodeBasedOnBPCode( _
   ByVal token As String, _
   ByVal bpcode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetMasterDataCodeBasedOnBPCode(
   string token,
   string bpcode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetMasterDataCodeBasedOnBPCode(
   String^ token,
   String^ bpcode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetMasterDataCodeBasedOnBPCode(
    token : String,
    bpcode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

bpcode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplierScoreCardTools Class
SupplierScoreCardTools Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCard Interface

Members See Also

Supplier score card object

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "SupplierScoreCard", TableName = "@CT_PF_BSSC")> _
Public Interface ISupplierScoreCard
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "SupplierScoreCard", TableName = "@CT_PF_BSSC")]
public interface ISupplierScoreCard : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "SupplierScoreCard", TableName = "@CT_PF_BSSC")]
public interface class ISupplierScoreCard : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "SupplierScoreCard", TableName = "@CT_PF_BSSC")
interface ISupplierScoreCard
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_BSSC
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCard Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCard Members

ISupplierScoreCard Interface Methods Properties See Also

Supplier score card object

The following tables list the members exposed by the ISupplierScoreCard type.

Properties
 | Name | Description
Public property | Attachments |
Public property | Code |
Public property | DS_BpName |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_BpCode |
Public property | U_NoOfDaysEarly |
Public property | U_NoOfDaysLate |
Public property | U_Notes |
Public property | U_QuantityOver |
Public property | U_QuantityUnder |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ISupplierScoreCard Interface
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCard Properties

ISupplierScoreCard Interface See Also

The following tables list the members exposed by the ISupplierScoreCard type.

Properties
 | Name | Description
Public property | Attachments |
Public property | Code |
Public property | DS_BpName |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_BpCode |
Public property | U_NoOfDaysEarly |
Public property | U_NoOfDaysLate |
Public property | U_Notes |
Public property | U_QuantityOver |
Public property | U_QuantityUnder |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
See Also

Reference

ISupplierScoreCard Interface
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCard.Attachments Property

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property Attachments() As ISupplierScoreCardAttachments
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
ISupplierScoreCardAttachments Attachments {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property ISupplierScoreCardAttachments^ Attachments {
 ISupplierScoreCardAttachments^ get( );
 void set(
   ISupplierScoreCardAttachments^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Attachments() : ISupplierScoreCardAttachments;

   AppEnginePropertyIgnore()
function set Attachments(value : ISupplierScoreCardAttachments);
This language is not supported or no code example is available.

Property Value

Type: ISupplierScoreCardAttachments
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCard Interface
ISupplierScoreCard Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCard.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCard Interface
ISupplierScoreCard Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCard.DS_BpName Property

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_BpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_BpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_BpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_BpName() : String;

   AppEnginePropertyIgnore()
function set DS_BpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCard Interface
ISupplierScoreCard Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCard.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCard Interface
ISupplierScoreCard Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCard.U_BpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_BpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_BpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_BpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_BpCode() : String;

   AppEngineProperty(Required = true)
function set U_BpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCard Interface
ISupplierScoreCard Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCard.U_NoOfDaysEarly Property

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_NoOfDaysEarly() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_NoOfDaysEarly {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_NoOfDaysEarly {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_NoOfDaysEarly() : int;
function set U_NoOfDaysEarly(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCard Interface
ISupplierScoreCard Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCard.U_NoOfDaysLate Property

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_NoOfDaysLate() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_NoOfDaysLate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_NoOfDaysLate {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_NoOfDaysLate() : int;
function set U_NoOfDaysLate(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCard Interface
ISupplierScoreCard Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCard.U_Notes Property

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Notes() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Notes {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Notes {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Notes() : String;
function set U_Notes(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCard Interface
ISupplierScoreCard Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCard.U_QuantityOver Property

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QuantityOver() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_QuantityOver {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_QuantityOver {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QuantityOver() : int;
function set U_QuantityOver(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCard Interface
ISupplierScoreCard Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCard.U_QuantityUnder Property

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QuantityUnder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_QuantityUnder {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_QuantityUnder {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QuantityUnder() : int;
function set U_QuantityUnder(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCard Interface
ISupplierScoreCard Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCard Methods

ISupplierScoreCard Interface See Also

The following tables list the members exposed by the ISupplierScoreCard type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ISupplierScoreCard Interface
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCardAttachments Interface

Members See Also

Attachments for supplier score card object

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ISupplierScoreCardAttachments
    Inherits IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ISupplierScoreCardAttachments : IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ISupplierScoreCardAttachments : public IUDOChildBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ISupplierScoreCardAttachments
   implements IUDOChildBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_SSC1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCardAttachments Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCardAttachments Members

ISupplierScoreCardAttachments Interface Methods Properties See Also

Attachments for supplier score card object

The following tables list the members exposed by the ISupplierScoreCardAttachments type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AttDate |
Public property | U_FileName |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Path |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

ISupplierScoreCardAttachments Interface
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCardAttachments Properties

ISupplierScoreCardAttachments Interface See Also

The following tables list the members exposed by the ISupplierScoreCardAttachments type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AttDate |
Public property | U_FileName |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Path |
Public property | VisOrder |
Top
See Also

Reference

ISupplierScoreCardAttachments Interface
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCardAttachments.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCardAttachments Interface
ISupplierScoreCardAttachments Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCardAttachments.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCardAttachments Interface
ISupplierScoreCardAttachments Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCardAttachments.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCardAttachments Interface
ISupplierScoreCardAttachments Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCardAttachments.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCardAttachments Interface
ISupplierScoreCardAttachments Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCardAttachments.U_AttDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_AttDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_AttDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttDate() : DateTime;
function set U_AttDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCardAttachments Interface
ISupplierScoreCardAttachments Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCardAttachments.U_FileName Property

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FileName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FileName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FileName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FileName() : String;
function set U_FileName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCardAttachments Interface
ISupplierScoreCardAttachments Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCardAttachments.U_Path Property

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Path() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Path {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Path {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Path() : String;
function set U_Path(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCardAttachments Interface
ISupplierScoreCardAttachments Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCardAttachments.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplierScoreCardAttachments Interface
ISupplierScoreCardAttachments Members
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


ISupplierScoreCardAttachments Methods

ISupplierScoreCardAttachments Interface See Also

The following tables list the members exposed by the ISupplierScoreCardAttachments type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

ISupplierScoreCardAttachments Interface
CompuTec.ProcessForce.API.Documents.Other.SupplierScoreCard Namespace


CompuTec.ProcessForce.API.Documents.PDCLog Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IPDCLog | Object For Adding PC Log Informations.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IPDCLog Interface

Members See Also

Object For Adding PC Log Informations.

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "PDCLog", TableName = "@CT_PF_OPDL")> _
Public Interface IPDCLog
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "PDCLog", TableName = "@CT_PF_OPDL")]
public interface IPDCLog : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "PDCLog", TableName = "@CT_PF_OPDL")]
public interface class IPDCLog : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "PDCLog", TableName = "@CT_PF_OPDL")
interface IPDCLog
   implements IUDOBean
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog Members

IPDCLog Interface Methods Properties See Also

Object For Adding PC Log Informations.

The following tables list the members exposed by the IPDCLog type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ActType | Action Type I :LogIn O :LogOut
Public property | U_Client | Client IP Address
Public property | U_Date | Date of action
Public property | U_DirAcces | Is Direct Acces Enabled
Public property | U_EmplID | Employee ID
Public property | U_PDCLogin | PDC Login
Public property | U_SAPUSerID | SAP user ID
Public property | U_Time | Time of action
Public property | U_User | Windows User Account
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IPDCLog Interface
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog Properties

IPDCLog Interface See Also

The following tables list the members exposed by the IPDCLog type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ActType | Action Type I :LogIn O :LogOut
Public property | U_Client | Client IP Address
Public property | U_Date | Date of action
Public property | U_DirAcces | Is Direct Acces Enabled
Public property | U_EmplID | Employee ID
Public property | U_PDCLogin | PDC Login
Public property | U_SAPUSerID | SAP user ID
Public property | U_Time | Time of action
Public property | U_User | Windows User Account
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IPDCLog Interface
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.U_ActType Property

Action Type I :LogIn O :LogOut

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ActType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ActType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActType() : String;
function set U_ActType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.U_Client Property

Client IP Address

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Client() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Client {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Client {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Client() : String;
function set U_Client(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.U_Date Property

Date of action

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Date() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Date {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Date {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Date() : DateTime;
function set U_Date(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.U_DirAcces Property

Is Direct Acces Enabled

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<EnumType(new int[] { 1, 2 }, new string[] { "Y", "N" }, 2)> _
Property U_DirAcces() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[EnumType(new int[] { 1, 2 }, new string[] { "Y", "N" }, 2)]
YesNoType U_DirAcces {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[EnumType(new int[] { 1, 2 }, new string[] { "Y", "N" }, 2)]

property YesNoType U_DirAcces {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   EnumType(new int[] { 1, 2 }, new string[] { "Y", "N" }, 2)
function get U_DirAcces() : YesNoType;

   EnumType(new int[] { 1, 2 }, new string[] { "Y", "N" }, 2)
function set U_DirAcces(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.U_EmplID Property

Employee ID

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EmplID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_EmplID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_EmplID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EmplID() : int;
function set U_EmplID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.U_PDCLogin Property

PDC Login

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PDCLogin() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PDCLogin {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PDCLogin {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PDCLogin() : String;
function set U_PDCLogin(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.U_SAPUSerID Property

SAP user ID

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SAPUSerID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SAPUSerID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SAPUSerID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SAPUSerID() : int;
function set U_SAPUSerID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.U_Time Property

Time of action

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<TimeType()> _
Property U_Time() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[TimeType()]
DateTime U_Time {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[TimeType()]

property DateTime U_Time {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   TimeType()
function get U_Time() : DateTime;

   TimeType()
function set U_Time(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.U_User Property

Windows User Account

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_User() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_User {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_User {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_User() : String;
function set U_User(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCLog
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCLog Interface
IPDCLog Members
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


IPDCLog Methods

IPDCLog Interface See Also

The following tables list the members exposed by the IPDCLog type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IPDCLog Interface
CompuTec.ProcessForce.API.Documents.PDCLog Namespace


CompuTec.ProcessForce.API.Documents.PDCSettings Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IPDCSettings | PDCSettings object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IPDCSettings Interface

Members See Also

PDCSettings object

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "PDCSettings", TableName = "@CT_PF_OPDC")> _
Public Interface IPDCSettings
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "PDCSettings", TableName = "@CT_PF_OPDC")]
public interface IPDCSettings : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "PDCSettings", TableName = "@CT_PF_OPDC")]
public interface class IPDCSettings : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "PDCSettings", TableName = "@CT_PF_OPDC")
interface IPDCSettings
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_PDCSettings
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings Members

IPDCSettings Interface Methods Properties See Also

PDCSettings object

The following tables list the members exposed by the IPDCSettings type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | QueryName |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ActType |
Public property | U_Activity |
Public property | U_AttFromBOM |
Public property | U_AttFromItD |
Public property | U_AttFromMOR |
Public property | U_AutLftQty |
Public property | U_Color |
Public property | U_DelayClDialog |
Public property | U_DflSearch |
Public property | U_Language |
Public property | U_Localizations |
Public property | U_MngBoard |
Public property | U_PDCForceTare |
Public property | U_PDCMemo |
Public property | U_PDCSynchLines |
Public property | U_PdcDefView |
Public property | U_PdcSetEn |
Public property | U_RscCode |
Public property | U_ScrKeyboard |
Public property | U_ShowDatePick |
Public property | U_TaskListID | This is Internal Key from OUQR table
Public property | U_Theme |
Public property | U_UserSettings |
Public property | U_WMSSwitchBtn |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IPDCSettings Interface
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings Properties

IPDCSettings Interface See Also

The following tables list the members exposed by the IPDCSettings type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | QueryName |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ActType |
Public property | U_Activity |
Public property | U_AttFromBOM |
Public property | U_AttFromItD |
Public property | U_AttFromMOR |
Public property | U_AutLftQty |
Public property | U_Color |
Public property | U_DelayClDialog |
Public property | U_DflSearch |
Public property | U_Language |
Public property | U_Localizations |
Public property | U_MngBoard |
Public property | U_PDCForceTare |
Public property | U_PDCMemo |
Public property | U_PDCSynchLines |
Public property | U_PdcDefView |
Public property | U_PdcSetEn |
Public property | U_RscCode |
Public property | U_ScrKeyboard |
Public property | U_ShowDatePick |
Public property | U_TaskListID | This is Internal Key from OUQR table
Public property | U_Theme |
Public property | U_UserSettings |
Public property | U_WMSSwitchBtn |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IPDCSettings Interface
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
function set Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.QueryName Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property QueryName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string QueryName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ QueryName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get QueryName() : String;

   AppEnginePropertyIgnore()
function set QueryName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_ActType Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ActType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ActType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActType() : String;
function set U_ActType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_Activity Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Activity() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Activity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Activity {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Activity() : String;
function set U_Activity(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_AttFromBOM Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttFromBOM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AttFromBOM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AttFromBOM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttFromBOM() : String;
function set U_AttFromBOM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_AttFromItD Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttFromItD() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AttFromItD {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AttFromItD {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttFromItD() : String;
function set U_AttFromItD(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_AttFromMOR Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttFromMOR() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AttFromMOR {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AttFromMOR {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttFromMOR() : String;
function set U_AttFromMOR(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_AutLftQty Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AutLftQty() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AutLftQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AutLftQty {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AutLftQty() : String;
function set U_AutLftQty(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_Color Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Color() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Color {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Color {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Color() : String;
function set U_Color(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_DelayClDialog Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DelayClDialog() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_DelayClDialog {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_DelayClDialog {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DelayClDialog() : int;
function set U_DelayClDialog(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_DflSearch Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DflSearch() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DflSearch {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DflSearch {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DflSearch() : String;
function set U_DflSearch(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_Language Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Language() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Language {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Language {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Language() : String;
function set U_Language(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_Localizations Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Localizations() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Localizations {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Localizations {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Localizations() : String;
function set U_Localizations(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_MngBoard Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MngBoard() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_MngBoard {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_MngBoard {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MngBoard() : YesNoType;
function set U_MngBoard(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_PDCForceTare Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PDCForceTare() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PDCForceTare {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PDCForceTare {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PDCForceTare() : String;
function set U_PDCForceTare(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_PDCMemo Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PDCMemo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PDCMemo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PDCMemo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PDCMemo() : String;
function set U_PDCMemo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_PDCSynchLines Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PDCSynchLines() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PDCSynchLines {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PDCSynchLines {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PDCSynchLines() : String;
function set U_PDCSynchLines(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_PdcDefView Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PdcDefView() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PdcDefView {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PdcDefView {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PdcDefView() : String;
function set U_PdcDefView(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_PdcSetEn Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PdcSetEn() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_PdcSetEn {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_PdcSetEn {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PdcSetEn() : YesNoType;
function set U_PdcSetEn(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_RscCode Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCode() : String;
function set U_RscCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_ScrKeyboard Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ScrKeyboard() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_ScrKeyboard {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_ScrKeyboard {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ScrKeyboard() : YesNoType;
function set U_ScrKeyboard(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_ShowDatePick Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ShowDatePick() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ShowDatePick {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ShowDatePick {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ShowDatePick() : String;
function set U_ShowDatePick(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_TaskListID Property

This is Internal Key from OUQR table

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TaskListID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_TaskListID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_TaskListID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TaskListID() : int;
function set U_TaskListID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_Theme Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Theme() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Theme {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Theme {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Theme() : String;
function set U_Theme(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_UserSettings Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UserSettings() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UserSettings {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UserSettings {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UserSettings() : String;
function set U_UserSettings(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.U_WMSSwitchBtn Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WMSSwitchBtn() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_WMSSwitchBtn {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_WMSSwitchBtn {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WMSSwitchBtn() : YesNoType;
function set U_WMSSwitchBtn(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.PDCSettings
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPDCSettings Interface
IPDCSettings Members
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


IPDCSettings Methods

IPDCSettings Interface See Also

The following tables list the members exposed by the IPDCSettings type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IPDCSettings Interface
CompuTec.ProcessForce.API.Documents.PDCSettings Namespace


CompuTec.ProcessForce.API.Documents.PickOrder Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | PickOrderBaseDocumentReferenceType | Represents available types for Pick Order document's U_BaseRef property.
Public class | PickOrderDocumentType | Represents available types for Pick Order document's U_DocType and U_BaseType properties.
Public class | SeriesNullException |
Top
Interfaces
 | Name | Description
Public interface | IPickOrder | Pick order document
Public interface | IPickOrderBinAllocations | Bin allocations of pick order document
Public interface | IPickOrderLicenceRelations | Informations about related licence plates to this pick order
Public interface | IPickOrderPickedItems | Picked items of pick order document
Public interface | IPickOrderRelations | Relations between required and picked items Please do not modify !!!
Public interface | IPickOrderRequiredItems | Required items of pick order document
Top
Enumerations
 | Name | Description
Public enumeration | PF_LplOutType |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


PickOrderBaseDocumentReferenceType Class

Members See Also

Represents available types for Pick Order document's U_BaseRef property.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public NotInheritable Class PickOrderBaseDocumentReferenceType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public sealed class PickOrderBaseDocumentReferenceType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class PickOrderBaseDocumentReferenceType sealed
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public final class PickOrderBaseDocumentReferenceType
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.PickOrder.PickOrderBaseDocumentReferenceType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderBaseDocumentReferenceType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


PickOrderBaseDocumentReferenceType Members

PickOrderBaseDocumentReferenceType Class Methods Fields See Also

Represents available types for Pick Order document's U_BaseRef property.

The following tables list the members exposed by the PickOrderBaseDocumentReferenceType type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | ManufacturingOrder |
Public field | ManufacturingOrderCoProduct |
Public field | ManufacturingOrderItem |
Public field | ManufacturingOrderScrap |
Public field | NotApplicable |
Top
See Also

Reference

PickOrderBaseDocumentReferenceType Class
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


PickOrderBaseDocumentReferenceType Methods

PickOrderBaseDocumentReferenceType Class See Also

The following tables list the members exposed by the PickOrderBaseDocumentReferenceType type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PickOrderBaseDocumentReferenceType Class
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


PickOrderBaseDocumentReferenceType Fields

PickOrderBaseDocumentReferenceType Class See Also

The following tables list the members exposed by the PickOrderBaseDocumentReferenceType type.

Fields
 | Name | Description
Public field | ManufacturingOrder |
Public field | ManufacturingOrderCoProduct |
Public field | ManufacturingOrderItem |
Public field | ManufacturingOrderScrap |
Public field | NotApplicable |
Top
See Also

Reference

PickOrderBaseDocumentReferenceType Class
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


ManufacturingOrder Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ManufacturingOrder As String = "HR"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ManufacturingOrder = @"HR"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ManufacturingOrder = "HR";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ManufacturingOrder : String = "HR"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderBaseDocumentReferenceType Class
PickOrderBaseDocumentReferenceType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


ManufacturingOrderCoProduct Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ManufacturingOrderCoProduct As String = "CP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ManufacturingOrderCoProduct = @"CP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ManufacturingOrderCoProduct = "CP";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ManufacturingOrderCoProduct : String = "CP"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderBaseDocumentReferenceType Class
PickOrderBaseDocumentReferenceType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


ManufacturingOrderItem Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ManufacturingOrderItem As String = "IT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ManufacturingOrderItem = @"IT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ManufacturingOrderItem = "IT";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ManufacturingOrderItem : String = "IT"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderBaseDocumentReferenceType Class
PickOrderBaseDocumentReferenceType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


ManufacturingOrderScrap Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ManufacturingOrderScrap As String = "SC"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ManufacturingOrderScrap = @"SC"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ManufacturingOrderScrap = "SC";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ManufacturingOrderScrap : String = "SC"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderBaseDocumentReferenceType Class
PickOrderBaseDocumentReferenceType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


NotApplicable Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const NotApplicable As String = "NA"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string NotApplicable = @"NA"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ NotApplicable = "NA";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const NotApplicable : String = "NA"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderBaseDocumentReferenceType Class
PickOrderBaseDocumentReferenceType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


PickOrderDocumentType Class

Members See Also

Represents available types for Pick Order document's U_DocType and U_BaseType properties.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public NotInheritable Class PickOrderDocumentType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public sealed class PickOrderDocumentType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class PickOrderDocumentType sealed
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public final class PickOrderDocumentType
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.PickOrder.PickOrderDocumentType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


PickOrderDocumentType Members

PickOrderDocumentType Class Methods Fields See Also

Represents available types for Pick Order document's U_DocType and U_BaseType properties.

The following tables list the members exposed by the PickOrderDocumentType type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | APCorrectionInvoice |
Public field | APCorrectionInvoiceReversal |
Public field | APCreditMemo |
Public field | APDownPayment |
Public field | APInvoice |
Public field | ARCorrectionInvoice |
Public field | ARCorrectionInvoiceReversal |
Public field | ARCreditMemo |
Public field | ARDownPayment |
Public field | ARInvoice |
Public field | ChecksForPayment |
Public field | Delivery |
Public field | Deposit |
Public field | GoodsIsseFromProduction |
Public field | GoodsIssue |
Public field | GoodsReceipt |
Public field | GoodsReceiptFromProduction |
Public field | GoodsReceiptPO |
Public field | GoodsReturn |
Public field | IncomingPayment |
Public field | InventoryList |
Public field | InventoryValuation |
Public field | JournalEntry |
Public field | LandedCosts |
Public field | ManufacturingOrder |
Public field | PickOrder |
Public field | PickReceipt |
Public field | PostdatedDeposit |
Public field | ProductionOrder |
Public field | Returns |
Public field | SalesOrders |
Public field | VendorPayment |
Public field | WorkInstructions |
Top
See Also

Reference

PickOrderDocumentType Class
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


PickOrderDocumentType Methods

PickOrderDocumentType Class See Also

The following tables list the members exposed by the PickOrderDocumentType type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PickOrderDocumentType Class
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


PickOrderDocumentType Fields

PickOrderDocumentType Class See Also

The following tables list the members exposed by the PickOrderDocumentType type.

Fields
 | Name | Description
Public field | APCorrectionInvoice |
Public field | APCorrectionInvoiceReversal |
Public field | APCreditMemo |
Public field | APDownPayment |
Public field | APInvoice |
Public field | ARCorrectionInvoice |
Public field | ARCorrectionInvoiceReversal |
Public field | ARCreditMemo |
Public field | ARDownPayment |
Public field | ARInvoice |
Public field | ChecksForPayment |
Public field | Delivery |
Public field | Deposit |
Public field | GoodsIsseFromProduction |
Public field | GoodsIssue |
Public field | GoodsReceipt |
Public field | GoodsReceiptFromProduction |
Public field | GoodsReceiptPO |
Public field | GoodsReturn |
Public field | IncomingPayment |
Public field | InventoryList |
Public field | InventoryValuation |
Public field | JournalEntry |
Public field | LandedCosts |
Public field | ManufacturingOrder |
Public field | PickOrder |
Public field | PickReceipt |
Public field | PostdatedDeposit |
Public field | ProductionOrder |
Public field | Returns |
Public field | SalesOrders |
Public field | VendorPayment |
Public field | WorkInstructions |
Top
See Also

Reference

PickOrderDocumentType Class
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


APCorrectionInvoice Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const APCorrectionInvoice As String = "163"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string APCorrectionInvoice = @"163"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ APCorrectionInvoice = "163";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const APCorrectionInvoice : String = "163"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


APCorrectionInvoiceReversal Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const APCorrectionInvoiceReversal As String = "164"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string APCorrectionInvoiceReversal = @"164"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ APCorrectionInvoiceReversal = "164";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const APCorrectionInvoiceReversal : String = "164"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


APCreditMemo Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const APCreditMemo As String = "19"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string APCreditMemo = @"19"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ APCreditMemo = "19";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const APCreditMemo : String = "19"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


APDownPayment Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const APDownPayment As String = "204"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string APDownPayment = @"204"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ APDownPayment = "204";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const APDownPayment : String = "204"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


APInvoice Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const APInvoice As String = "18"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string APInvoice = @"18"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ APInvoice = "18";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const APInvoice : String = "18"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


ARCorrectionInvoice Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ARCorrectionInvoice As String = "165"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ARCorrectionInvoice = @"165"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ARCorrectionInvoice = "165";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ARCorrectionInvoice : String = "165"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


ARCorrectionInvoiceReversal Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ARCorrectionInvoiceReversal As String = "166"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ARCorrectionInvoiceReversal = @"166"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ARCorrectionInvoiceReversal = "166";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ARCorrectionInvoiceReversal : String = "166"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


ARCreditMemo Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ARCreditMemo As String = "14"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ARCreditMemo = @"14"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ARCreditMemo = "14";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ARCreditMemo : String = "14"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


ARDownPayment Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ARDownPayment As String = "203"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ARDownPayment = @"203"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ARDownPayment = "203";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ARDownPayment : String = "203"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


ARInvoice Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ARInvoice As String = "13"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ARInvoice = @"13"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ARInvoice = "13";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ARInvoice : String = "13"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


ChecksForPayment Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ChecksForPayment As String = "57"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ChecksForPayment = @"57"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ChecksForPayment = "57";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ChecksForPayment : String = "57"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


Delivery Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Delivery As String = "15"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Delivery = @"15"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Delivery = "15";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Delivery : String = "15"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


Deposit Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Deposit As String = "25"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Deposit = @"25"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Deposit = "25";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Deposit : String = "25"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


GoodsIsseFromProduction Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const GoodsIsseFromProduction As String = "11111111111"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string GoodsIsseFromProduction = @"11111111111"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ GoodsIsseFromProduction = "11111111111";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const GoodsIsseFromProduction : String = "11111111111"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


GoodsIssue Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const GoodsIssue As String = "60"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string GoodsIssue = @"60"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ GoodsIssue = "60";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const GoodsIssue : String = "60"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


GoodsReceipt Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const GoodsReceipt As String = "59"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string GoodsReceipt = @"59"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ GoodsReceipt = "59";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const GoodsReceipt : String = "59"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


GoodsReceiptFromProduction Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const GoodsReceiptFromProduction As String = "11111112222"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string GoodsReceiptFromProduction = @"11111112222"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ GoodsReceiptFromProduction = "11111112222";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const GoodsReceiptFromProduction : String = "11111112222"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


GoodsReceiptPO Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const GoodsReceiptPO As String = "20"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string GoodsReceiptPO = @"20"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ GoodsReceiptPO = "20";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const GoodsReceiptPO : String = "20"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


GoodsReturn Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const GoodsReturn As String = "21"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string GoodsReturn = @"21"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ GoodsReturn = "21";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const GoodsReturn : String = "21"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IncomingPayment Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const IncomingPayment As String = "24"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string IncomingPayment = @"24"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ IncomingPayment = "24";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const IncomingPayment : String = "24"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


InventoryList Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const InventoryList As String = "58"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string InventoryList = @"58"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ InventoryList = "58";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const InventoryList : String = "58"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


InventoryValuation Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const InventoryValuation As String = "162"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string InventoryValuation = @"162"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ InventoryValuation = "162";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const InventoryValuation : String = "162"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


JournalEntry Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const JournalEntry As String = "30"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string JournalEntry = @"30"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ JournalEntry = "30";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const JournalEntry : String = "30"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


LandedCosts Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const LandedCosts As String = "69"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string LandedCosts = @"69"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ LandedCosts = "69";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const LandedCosts : String = "69"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


ManufacturingOrder Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ManufacturingOrder As String = "999000001"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ManufacturingOrder = @"999000001"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ManufacturingOrder = "999000001";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ManufacturingOrder : String = "999000001"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


PickOrder Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const PickOrder As String = "999000002"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string PickOrder = @"999000002"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ PickOrder = "999000002";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const PickOrder : String = "999000002"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


PickReceipt Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const PickReceipt As String = "999000003"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string PickReceipt = @"999000003"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ PickReceipt = "999000003";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const PickReceipt : String = "999000003"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


PostdatedDeposit Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const PostdatedDeposit As String = "76"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string PostdatedDeposit = @"76"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ PostdatedDeposit = "76";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const PostdatedDeposit : String = "76"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


ProductionOrder Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ProductionOrder As String = "202"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ProductionOrder = @"202"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ProductionOrder = "202";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ProductionOrder : String = "202"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


Returns Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Returns As String = "16"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Returns = @"16"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Returns = "16";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Returns : String = "16"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


SalesOrders Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const SalesOrders As String = "17"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string SalesOrders = @"17"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ SalesOrders = "17";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const SalesOrders : String = "17"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


VendorPayment Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const VendorPayment As String = "46"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string VendorPayment = @"46"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ VendorPayment = "46";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const VendorPayment : String = "46"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


WorkInstructions Field

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const WorkInstructions As String = "68"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string WorkInstructions = @"68"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ WorkInstructions = "68";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const WorkInstructions : String = "68"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickOrderDocumentType Class
PickOrderDocumentType Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


SeriesNullException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SeriesNullException
    Inherits ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SeriesNullException : ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SeriesNullException : public ApplicationException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SeriesNullException
   extends ApplicationException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
CompuTec.ProcessForce.API.Documents.PickOrder.SeriesNullException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SeriesNullException Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


SeriesNullException Members

SeriesNullException Class Constructors Methods Properties See Also

The following tables list the members exposed by the SeriesNullException type.

Constructors
 | Name | Description
Public constructor | SeriesNullException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

SeriesNullException Class
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


SeriesNullException Constructor

SeriesNullException Class See Also

Overload List
Name | Description
SeriesNullException() |
SeriesNullException(string) |
SeriesNullException(string, Exception) |
See Also

Reference

SeriesNullException Class
SeriesNullException Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


SeriesNullException Properties

SeriesNullException Class See Also

The following tables list the members exposed by the SeriesNullException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

SeriesNullException Class
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


SeriesNullException Methods

SeriesNullException Class See Also

The following tables list the members exposed by the SeriesNullException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

SeriesNullException Class
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder Interface

Members See Also

Pick order document

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "PickOrder", TableName = "@CT_PF_OPOR", ExludedHttpMethods = "DELETE")> _
Public Interface IPickOrder
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "PickOrder", TableName = "@CT_PF_OPOR", ExludedHttpMethods = "DELETE")]
public interface IPickOrder : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "PickOrder", TableName = "@CT_PF_OPOR", ExludedHttpMethods = "DELETE")]
public interface class IPickOrder : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "PickOrder", TableName = "@CT_PF_OPOR", ExludedHttpMethods = "DELETE")
interface IPickOrder
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OPOR
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder Members

IPickOrder Interface Methods Properties See Also

Pick order document

The following tables list the members exposed by the IPickOrder type.

Properties
 | Name | Description
Public property | BinAllocations | in allocations
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_SeriesName | Document Series Name ReadOnly
Public property | DS_UserCode |
Public property | DS_UserName |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | PickedItems | Picked Items Please do not Edit This Values anly via Assigner
Public property | Relations | Obsolete. Relations Between Required and Picked Items Please do not Edit This Values anly via Assigner!!!!!!
Public property | RequiredItems | Required Items Documents Itemcodes quantity and references
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Date | Document Date
Public property | U_Employee | Employee uid
Public property | U_Ref2 | Ref2
Public property | U_Remarks | Document Remarks
Public property | U_Status |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetCreatedDocumentReferences | This method returns references to all documents created during production issue on Document Update Note that Auto Issue must be enabled
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IPickOrder Interface
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder Properties

IPickOrder Interface See Also

The following tables list the members exposed by the IPickOrder type.

Properties
 | Name | Description
Public property | BinAllocations | in allocations
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_SeriesName | Document Series Name ReadOnly
Public property | DS_UserCode |
Public property | DS_UserName |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | PickedItems | Picked Items Please do not Edit This Values anly via Assigner
Public property | Relations | Obsolete. Relations Between Required and Picked Items Please do not Edit This Values anly via Assigner!!!!!!
Public property | RequiredItems | Required Items Documents Itemcodes quantity and references
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Date | Document Date
Public property | U_Employee | Employee uid
Public property | U_Ref2 | Ref2
Public property | U_Remarks | Document Remarks
Public property | U_Status |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IPickOrder Interface
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.BinAllocations Property

in allocations

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property BinAllocations() As IPickOrderBinAllocations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
IPickOrderBinAllocations BinAllocations {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property IPickOrderBinAllocations^ BinAllocations {
 IPickOrderBinAllocations^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get BinAllocations() : IPickOrderBinAllocations;
This language is not supported or no code example is available.

Property Value

Type: IPickOrderBinAllocations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.DS_SeriesName Property

Document Series Name ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_SeriesName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_SeriesName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_SeriesName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_SeriesName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.DS_UserCode Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_UserCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_UserCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_UserCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_UserCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.DS_UserName Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_UserName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_UserName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_UserName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_UserName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.DocNum Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.Handwrtten Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Handwrtten() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Handwrtten {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Handwrtten {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Handwrtten() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.Instance Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Instance() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Instance {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Instance {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Instance() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.Period Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Period() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Period {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Period {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Period() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.PickedItems Property

Picked Items Please do not Edit This Values anly via Assigner

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property PickedItems() As IPickOrderPickedItems
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IPickOrderPickedItems PickedItems {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IPickOrderPickedItems^ PickedItems {
 IPickOrderPickedItems^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get PickedItems() : IPickOrderPickedItems;
This language is not supported or no code example is available.

Property Value

Type: IPickOrderPickedItems
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.Relations Property

NOTE: This member is now obsolete.

Relations Between Required and Picked Items Please do not Edit This Values anly via Assigner!!!!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Obsolete()> _
ReadOnly Property Relations() As IPickOrderRelations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete()]
IPickOrderRelations Relations {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete()]

property IPickOrderRelations^ Relations {
 IPickOrderRelations^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   Obsolete()
function get Relations() : IPickOrderRelations;
This language is not supported or no code example is available.

Property Value

Type: IPickOrderRelations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.RequiredItems Property

Required Items Documents Itemcodes quantity and references

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RequiredItems() As IPickOrderRequiredItems
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IPickOrderRequiredItems RequiredItems {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IPickOrderRequiredItems^ RequiredItems {
 IPickOrderRequiredItems^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RequiredItems() : IPickOrderRequiredItems;
This language is not supported or no code example is available.

Property Value

Type: IPickOrderRequiredItems
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.Series Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Series() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Series {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Series {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Series() : int;
function set Series(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.Status Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Status {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Status {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Status() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.U_Date Property

Document Date

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Date() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Date {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Date {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Date() : DateTime;
function set U_Date(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.U_Employee Property

Employee uid

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Employee() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_Employee {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_Employee {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Employee() : int;
function set U_Employee(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.U_Ref2 Property

Ref2

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Ref2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Ref2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Ref2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Ref2() : String;
function set U_Ref2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.U_Remarks Property

Document Remarks

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.U_Status Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Status() As PickStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
PickStatus U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property PickStatus U_Status {
 PickStatus get( );
 void set(
   PickStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Status() : PickStatus;
function set U_Status(value : PickStatus);
This language is not supported or no code example is available.

Property Value

Type: PickStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder Methods

IPickOrder Interface See Also

The following tables list the members exposed by the IPickOrder type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetCreatedDocumentReferences | This method returns references to all documents created during production issue on Document Update Note that Auto Issue must be enabled
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IPickOrder Interface
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrder.GetCreatedDocumentReferences Method

This method returns references to all documents created during production issue on Document Update Note that Auto Issue must be enabled

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetCreatedDocumentReferences() As List(Of DocRef)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<DocRef> GetCreatedDocumentReferences()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

List<DocRef^>^ GetCreatedDocumentReferences()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Return Value

Type: List<DocRef>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrder Interface
IPickOrder Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderBinAllocations Interface

Members See Also

Bin allocations of pick order document

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IPickOrderBinAllocations
    Inherits IUDOChildBean, _
             IEnumerable(Of IPickOrderBinAllocations)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IPickOrderBinAllocations : IUDOChildBean,
   IEnumerable<IPickOrderBinAllocations>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IPickOrderBinAllocations : public IUDOChildBean^,
   public IEnumerable<IPickOrderBinAllocations^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_POR5
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderBinAllocations Members

IPickOrderBinAllocations Interface Methods Properties See Also

Bin allocations of pick order document

The following tables list the members exposed by the IPickOrderBinAllocations type.

Properties
 | Name | Description
Public property | BinCode |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BinAbsEntry | bin allocation abs entry
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Quantity | quantity which is in this bin
Public property | U_SnAndBnLine | line number of batch or serial number if present
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPickOrderBinAllocations Interface
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderBinAllocations Properties

IPickOrderBinAllocations Interface See Also

The following tables list the members exposed by the IPickOrderBinAllocations type.

Properties
 | Name | Description
Public property | BinCode |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BinAbsEntry | bin allocation abs entry
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Quantity | quantity which is in this bin
Public property | U_SnAndBnLine | line number of batch or serial number if present
Public property | VisOrder |
Top
See Also

Reference

IPickOrderBinAllocations Interface
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderBinAllocations.BinCode Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property BinCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string BinCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ BinCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BinCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderBinAllocations Interface
IPickOrderBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderBinAllocations.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderBinAllocations Interface
IPickOrderBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderBinAllocations.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderBinAllocations Interface
IPickOrderBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderBinAllocations.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderBinAllocations Interface
IPickOrderBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderBinAllocations.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderBinAllocations Interface
IPickOrderBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderBinAllocations.U_BinAbsEntry Property

bin allocation abs entry

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BinAbsEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BinAbsEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BinAbsEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BinAbsEntry() : int;
function set U_BinAbsEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderBinAllocations Interface
IPickOrderBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderBinAllocations.U_Quantity Property

quantity which is in this bin

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderBinAllocations Interface
IPickOrderBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderBinAllocations.U_SnAndBnLine Property

line number of batch or serial number if present

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SnAndBnLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SnAndBnLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SnAndBnLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SnAndBnLine() : int;
function set U_SnAndBnLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderBinAllocations Interface
IPickOrderBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderBinAllocations.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderBinAllocations Interface
IPickOrderBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderBinAllocations Methods

IPickOrderBinAllocations Interface See Also

The following tables list the members exposed by the IPickOrderBinAllocations type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPickOrderBinAllocations Interface
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderLicenceRelations Interface

Members See Also

Informations about related licence plates to this pick order

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IPickOrderLicenceRelations
    Inherits IUDOChildBean, _
             IEnumerable(Of IPickOrderLicenceRelations)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IPickOrderLicenceRelations : IUDOChildBean,
   IEnumerable<IPickOrderLicenceRelations>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IPickOrderLicenceRelations : public IUDOChildBean^,
   public IEnumerable<IPickOrderLicenceRelations^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_POR4
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderLicenceRelations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderLicenceRelations Members

IPickOrderLicenceRelations Interface Methods Properties See Also

Informations about related licence plates to this pick order

The following tables list the members exposed by the IPickOrderLicenceRelations type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Closed | Is this licence Plate already issued. Please do not modify!!!
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_LplCode | Licnece Plate Code Please do not modify!!!
Public property | U_Type | Output Type Leave or Unregister
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPickOrderLicenceRelations Interface
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderLicenceRelations Properties

IPickOrderLicenceRelations Interface See Also

The following tables list the members exposed by the IPickOrderLicenceRelations type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Closed | Is this licence Plate already issued. Please do not modify!!!
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_LplCode | Licnece Plate Code Please do not modify!!!
Public property | U_Type | Output Type Leave or Unregister
Public property | VisOrder |
Top
See Also

Reference

IPickOrderLicenceRelations Interface
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderLicenceRelations.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderLicenceRelations Interface
IPickOrderLicenceRelations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderLicenceRelations.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderLicenceRelations Interface
IPickOrderLicenceRelations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderLicenceRelations.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderLicenceRelations Interface
IPickOrderLicenceRelations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderLicenceRelations.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderLicenceRelations Interface
IPickOrderLicenceRelations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderLicenceRelations.U_Closed Property

Is this licence Plate already issued. Please do not modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Closed() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Closed {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Closed {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Closed() : YesNoType;
function set U_Closed(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderLicenceRelations Interface
IPickOrderLicenceRelations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderLicenceRelations.U_LplCode Property

Licnece Plate Code Please do not modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LplCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LplCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LplCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LplCode() : String;
function set U_LplCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderLicenceRelations Interface
IPickOrderLicenceRelations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderLicenceRelations.U_Type Property

Output Type Leave or Unregister

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Type() As PF_LplOutType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
PF_LplOutType U_Type {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property PF_LplOutType U_Type {
 PF_LplOutType get( );
 void set(
   PF_LplOutType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Type() : PF_LplOutType;
function set U_Type(value : PF_LplOutType);
This language is not supported or no code example is available.

Property Value

Type: PF_LplOutType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderLicenceRelations Interface
IPickOrderLicenceRelations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderLicenceRelations.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderLicenceRelations Interface
IPickOrderLicenceRelations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderLicenceRelations Methods

IPickOrderLicenceRelations Interface See Also

The following tables list the members exposed by the IPickOrderLicenceRelations type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPickOrderLicenceRelations Interface
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems Interface

Members See Also

Picked items of pick order document

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IPickOrderPickedItems
    Inherits IUDOChildBean, _
             IEnumerable(Of IPickOrderPickedItems)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IPickOrderPickedItems : IUDOChildBean,
   IEnumerable<IPickOrderPickedItems>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IPickOrderPickedItems : public IUDOChildBean^,
   public IEnumerable<IPickOrderPickedItems^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_POR2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems Members

IPickOrderPickedItems Interface Methods Properties See Also

Picked items of pick order document

The following tables list the members exposed by the IPickOrderPickedItems type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_IsLicensePlate | Informational Filed
Public property | DS_ItemName |
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BnDistNumber | Batch Number for Batch Numbers. Please do not modify!!!
Public property | U_Issued | "Y","N" If Item Is Issued Please do not modify!!!
Public property | U_ItemCode | ItemCode Please do not modify!!!
Public property | U_LicPlateItemCode | Key in LicencePlate Please do not modify!!!
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_LplCode | Licence Plate code "ZZZZZZZZ" if Virtual LicencePlate Please do not modify!!!
Public property | U_LplsPath | Not used Yey Please do not modify!!!
Public property | U_Quantity | Item Quantity Please do not modify!!!
Public property | U_ReqItmLn | Picked Item line
Public property | U_SnDistNumber | Internal Serial Number for Serial Numbers. Please do not modify!!!
Public property | U_SnLotNumber | Batch ID for Serial Numbers. Please do not modify!!!
Public property | U_SnMnfNumber | Manufacturer Serial Number for Serial Numbers. Please do not modify!!!
Public property | U_SnSysNumber | System Serial Number for Serial Numbers. Please do not modify!!!
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPickOrderPickedItems Interface
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems Properties

IPickOrderPickedItems Interface See Also

The following tables list the members exposed by the IPickOrderPickedItems type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_IsLicensePlate | Informational Filed
Public property | DS_ItemName |
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BnDistNumber | Batch Number for Batch Numbers. Please do not modify!!!
Public property | U_Issued | "Y","N" If Item Is Issued Please do not modify!!!
Public property | U_ItemCode | ItemCode Please do not modify!!!
Public property | U_LicPlateItemCode | Key in LicencePlate Please do not modify!!!
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_LplCode | Licence Plate code "ZZZZZZZZ" if Virtual LicencePlate Please do not modify!!!
Public property | U_LplsPath | Not used Yey Please do not modify!!!
Public property | U_Quantity | Item Quantity Please do not modify!!!
Public property | U_ReqItmLn | Picked Item line
Public property | U_SnDistNumber | Internal Serial Number for Serial Numbers. Please do not modify!!!
Public property | U_SnLotNumber | Batch ID for Serial Numbers. Please do not modify!!!
Public property | U_SnMnfNumber | Manufacturer Serial Number for Serial Numbers. Please do not modify!!!
Public property | U_SnSysNumber | System Serial Number for Serial Numbers. Please do not modify!!!
Public property | VisOrder |
Top
See Also

Reference

IPickOrderPickedItems Interface
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems.DS_IsLicensePlate Property

Informational Filed

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_IsLicensePlate() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool DS_IsLicensePlate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool DS_IsLicensePlate {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_IsLicensePlate() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Interface
IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems.DS_ItemName Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_ItemName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_ItemName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_ItemName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Interface
IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Interface
IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Interface
IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Interface
IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Interface
IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems.U_BnDistNumber Property

Batch Number for Batch Numbers. Please do not modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BnDistNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BnDistNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BnDistNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BnDistNumber() : String;
function set U_BnDistNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Interface
IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems.U_Issued Property

"Y","N" If Item Is Issued Please do not modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Issued() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Issued {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Issued {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Issued() : String;
function set U_Issued(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Interface
IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems.U_ItemCode Property

ItemCode Please do not modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Interface
IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems.U_LicPlateItemCode Property

Key in LicencePlate Please do not modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LicPlateItemCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_LicPlateItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_LicPlateItemCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LicPlateItemCode() : int;
function set U_LicPlateItemCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Interface
IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems.U_LplCode Property

Licence Plate code "ZZZZZZZZ" if Virtual LicencePlate Please do not modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LplCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LplCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LplCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LplCode() : String;
function set U_LplCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Interface
IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems.U_LplsPath Property

Not used Yey Please do not modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LplsPath() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LplsPath {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LplsPath {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LplsPath() : String;
function set U_LplsPath(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Interface
IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems.U_Quantity Property

Item Quantity Please do not modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Interface
IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems.U_ReqItmLn Property

Picked Item line

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReqItmLn() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ReqItmLn {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ReqItmLn {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReqItmLn() : int;
function set U_ReqItmLn(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Interface
IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems.U_SnDistNumber Property

Internal Serial Number for Serial Numbers. Please do not modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SnDistNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SnDistNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SnDistNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SnDistNumber() : String;
function set U_SnDistNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Interface
IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems.U_SnLotNumber Property

Batch ID for Serial Numbers. Please do not modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SnLotNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SnLotNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SnLotNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SnLotNumber() : String;
function set U_SnLotNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Interface
IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems.U_SnMnfNumber Property

Manufacturer Serial Number for Serial Numbers. Please do not modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SnMnfNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SnMnfNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SnMnfNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SnMnfNumber() : String;
function set U_SnMnfNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Interface
IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems.U_SnSysNumber Property

System Serial Number for Serial Numbers. Please do not modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SnSysNumber() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SnSysNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SnSysNumber {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SnSysNumber() : int;
function set U_SnSysNumber(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Interface
IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderPickedItems Interface
IPickOrderPickedItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderPickedItems Methods

IPickOrderPickedItems Interface See Also

The following tables list the members exposed by the IPickOrderPickedItems type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPickOrderPickedItems Interface
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRelations Interface

Members See Also

Relations between required and picked items Please do not modify !!!

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IPickOrderRelations
    Inherits IUDOChildBean, _
             IEnumerable(Of IPickOrderRelations)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IPickOrderRelations : IUDOChildBean,
   IEnumerable<IPickOrderRelations>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IPickOrderRelations : public IUDOChildBean^,
   public IEnumerable<IPickOrderRelations^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_POR3
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRelations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRelations Members

IPickOrderRelations Interface Methods Properties See Also

Relations between required and picked items Please do not modify !!!

The following tables list the members exposed by the IPickOrderRelations type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PickItemLineNo | Line Number of Picked Items Please do not modify!!!
Public property | U_ReqItemLineNo | LineNumber of Required Items Please do not modify!!!
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPickOrderRelations Interface
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRelations Properties

IPickOrderRelations Interface See Also

The following tables list the members exposed by the IPickOrderRelations type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PickItemLineNo | Line Number of Picked Items Please do not modify!!!
Public property | U_ReqItemLineNo | LineNumber of Required Items Please do not modify!!!
Public property | VisOrder |
Top
See Also

Reference

IPickOrderRelations Interface
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRelations.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRelations Interface
IPickOrderRelations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRelations.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRelations Interface
IPickOrderRelations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRelations.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRelations Interface
IPickOrderRelations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRelations.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRelations Interface
IPickOrderRelations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRelations.U_PickItemLineNo Property

Line Number of Picked Items Please do not modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PickItemLineNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_PickItemLineNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_PickItemLineNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PickItemLineNo() : int;
function set U_PickItemLineNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRelations Interface
IPickOrderRelations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRelations.U_ReqItemLineNo Property

LineNumber of Required Items Please do not modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReqItemLineNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ReqItemLineNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ReqItemLineNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReqItemLineNo() : int;
function set U_ReqItemLineNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRelations Interface
IPickOrderRelations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRelations.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRelations Interface
IPickOrderRelations Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRelations Methods

IPickOrderRelations Interface See Also

The following tables list the members exposed by the IPickOrderRelations type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPickOrderRelations Interface
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems Interface

Members See Also

Required items of pick order document

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IPickOrderRequiredItems
    Inherits IUDOChildBean, _
             IEnumerable(Of IPickOrderRequiredItems)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IPickOrderRequiredItems : IUDOChildBean,
   IEnumerable<IPickOrderRequiredItems>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IPickOrderRequiredItems : public IUDOChildBean^,
   public IEnumerable<IPickOrderRequiredItems^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_POR1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems Members

IPickOrderRequiredItems Interface Methods Properties See Also

Required items of pick order document

The following tables list the members exposed by the IPickOrderRequiredItems type.

Properties
 | Name | Description
Public property | BatchNumbers | Obsolete.
Public property | BinAllocations |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_AccName | Account Name Read only
Public property | DS_BPName | Card Name Read only
Public property | DS_ItemName | ItemName Read Only
Public property | DS_ItemUoM | Unit of mesure Read only
Public property | DS_OcrName | Distribusion Rule Name Read only
Public property | DS_OprName | Operation Name
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | SerialNumbers | Obsolete.
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AccCode | Account Code
Public property | U_BPCode | Card Code Of Customer
Public property | U_BaseEntry | Doc Entry of base Document
Public property | U_BaseLineNo | Line Num of Base Document
Public property | U_BaseRef | Base reference
Public property | U_BaseType | Base Type Type od Document From This Row was Coppied
Public property | U_DocType | Type Of Document
Public property | U_DstWhsCode | Destination WareHouse Code
Public property | U_IssuedQty | Quantity that is already issued
Public property | U_ItemCode | ItemCode
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OcrCode | Distribusion Rule Code
Public property | U_OcrCode2 | Distribusion Rule Code2
Public property | U_OcrCode3 | Distribusion Rule Code3
Public property | U_OcrCode4 | Distribusion Rule Code4
Public property | U_OcrCode5 | Distribusion Rule Code5
Public property | U_OprCode | OperationCode
Public property | U_PickedQty | Picked Quantity
Public property | U_PlannedQty | Planned Quantity Usualy Copy from Base Document
Public property | U_Project | Project
Public property | U_RefLine | Refenrecne
Public property | U_Revision | Item Revision
Public property | U_SrcWhsCode | Source Warehouse Code
Public property | U_SubRatio |
Public property | U_WhsQty | ????
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | CreateDefaultBinAllocation |
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | GetPickedItemsLineNumbers | Gets a generic collection of U_LineNum values of CT_PF_POR2 table for given Required Item from CT_PF_POR3 table.
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPickOrderRequiredItems Interface
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems Properties

IPickOrderRequiredItems Interface See Also

The following tables list the members exposed by the IPickOrderRequiredItems type.

Properties
 | Name | Description
Public property | BatchNumbers | Obsolete.
Public property | BinAllocations |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_AccName | Account Name Read only
Public property | DS_BPName | Card Name Read only
Public property | DS_ItemName | ItemName Read Only
Public property | DS_ItemUoM | Unit of mesure Read only
Public property | DS_OcrName | Distribusion Rule Name Read only
Public property | DS_OprName | Operation Name
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | SerialNumbers | Obsolete.
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AccCode | Account Code
Public property | U_BPCode | Card Code Of Customer
Public property | U_BaseEntry | Doc Entry of base Document
Public property | U_BaseLineNo | Line Num of Base Document
Public property | U_BaseRef | Base reference
Public property | U_BaseType | Base Type Type od Document From This Row was Coppied
Public property | U_DocType | Type Of Document
Public property | U_DstWhsCode | Destination WareHouse Code
Public property | U_IssuedQty | Quantity that is already issued
Public property | U_ItemCode | ItemCode
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OcrCode | Distribusion Rule Code
Public property | U_OcrCode2 | Distribusion Rule Code2
Public property | U_OcrCode3 | Distribusion Rule Code3
Public property | U_OcrCode4 | Distribusion Rule Code4
Public property | U_OcrCode5 | Distribusion Rule Code5
Public property | U_OprCode | OperationCode
Public property | U_PickedQty | Picked Quantity
Public property | U_PlannedQty | Planned Quantity Usualy Copy from Base Document
Public property | U_Project | Project
Public property | U_RefLine | Refenrecne
Public property | U_Revision | Item Revision
Public property | U_SrcWhsCode | Source Warehouse Code
Public property | U_SubRatio |
Public property | U_WhsQty | ????
Public property | VisOrder |
Top
See Also

Reference

IPickOrderRequiredItems Interface
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.BatchNumbers Property

NOTE: This member is now obsolete.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Obsolete()> _
ReadOnly Property BatchNumbers() As IBatchNumbers
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete()]
IBatchNumbers BatchNumbers {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete()]

property IBatchNumbers^ BatchNumbers {
 IBatchNumbers^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   Obsolete()
function get BatchNumbers() : IBatchNumbers;
This language is not supported or no code example is available.

Property Value

Type: IBatchNumbers
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.BinAllocations Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property BinAllocations() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string BinAllocations {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ BinAllocations {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get BinAllocations() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.DS_AccName Property

Account Name Read only

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_AccName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_AccName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_AccName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_AccName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.DS_BPName Property

Card Name Read only

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_BPName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_BPName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_BPName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_BPName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.DS_ItemName Property

ItemName Read Only

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.DS_ItemUoM Property

Unit of mesure Read only

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_ItemUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemUoM {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemUoM {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemUoM() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.DS_OcrName Property

Distribusion Rule Name Read only

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_OcrName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_OcrName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_OcrName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_OcrName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.DS_OprName Property

Operation Name

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_OprName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_OprName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_OprName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_OprName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.SerialNumbers Property

NOTE: This member is now obsolete.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Obsolete()> _
ReadOnly Property SerialNumbers() As ISerialNumbers
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete()]
ISerialNumbers SerialNumbers {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete()]

property ISerialNumbers^ SerialNumbers {
 ISerialNumbers^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   Obsolete()
function get SerialNumbers() : ISerialNumbers;
This language is not supported or no code example is available.

Property Value

Type: ISerialNumbers
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_AccCode Property

Account Code

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AccCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AccCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AccCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AccCode() : String;
function set U_AccCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_BPCode Property

Card Code Of Customer

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BPCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BPCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BPCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BPCode() : String;
function set U_BPCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_BaseEntry Property

Doc Entry of base Document

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseEntry() : int;
function set U_BaseEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_BaseLineNo Property

Line Num of Base Document

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLineNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLineNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLineNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLineNo() : int;
function set U_BaseLineNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_BaseRef Property

Base reference

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseRef() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BaseRef {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BaseRef {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseRef() : String;
function set U_BaseRef(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_BaseType Property

Base Type Type od Document From This Row was Coppied

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BaseType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BaseType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseType() : String;
function set U_BaseType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_DocType Property

Type Of Document

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DocType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DocType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DocType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DocType() : String;
function set U_DocType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_DstWhsCode Property

Destination WareHouse Code

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DstWhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DstWhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DstWhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DstWhsCode() : String;
function set U_DstWhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_IssuedQty Property

Quantity that is already issued

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IssuedQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_IssuedQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_IssuedQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IssuedQty() : double;
function set U_IssuedQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_ItemCode Property

ItemCode

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_OcrCode Property

Distribusion Rule Code

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode() : String;
function set U_OcrCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_OcrCode2 Property

Distribusion Rule Code2

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode2() : String;
function set U_OcrCode2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_OcrCode3 Property

Distribusion Rule Code3

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode3() : String;
function set U_OcrCode3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_OcrCode4 Property

Distribusion Rule Code4

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode4() : String;
function set U_OcrCode4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_OcrCode5 Property

Distribusion Rule Code5

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode5() : String;
function set U_OcrCode5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_OprCode Property

OperationCode

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_PickedQty Property

Picked Quantity

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PickedQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PickedQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PickedQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PickedQty() : double;
function set U_PickedQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_PlannedQty Property

Planned Quantity Usualy Copy from Base Document

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PlannedQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PlannedQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PlannedQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PlannedQty() : double;
function set U_PlannedQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_Project Property

Project

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Project() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Project {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Project {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Project() : String;
function set U_Project(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_RefLine Property

Refenrecne

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RefLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RefLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RefLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RefLine() : int;
function set U_RefLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_Revision Property

Item Revision

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Revision() : String;
function set U_Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_SrcWhsCode Property

Source Warehouse Code

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SrcWhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SrcWhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SrcWhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SrcWhsCode() : String;
function set U_SrcWhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_SubRatio Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_SubRatio() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_SubRatio {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_SubRatio {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SubRatio() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.U_WhsQty Property

????

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property U_WhsQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
double U_WhsQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property double U_WhsQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_WhsQty() : double;

   AppEnginePropertyIgnore()
function set U_WhsQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems Methods

IPickOrderRequiredItems Interface See Also

The following tables list the members exposed by the IPickOrderRequiredItems type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | CreateDefaultBinAllocation |
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | GetPickedItemsLineNumbers | Gets a generic collection of U_LineNum values of CT_PF_POR2 table for given Required Item from CT_PF_POR3 table.
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPickOrderRequiredItems Interface
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.CreateDefaultBinAllocation Method

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub CreateDefaultBinAllocation()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void CreateDefaultBinAllocation()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void CreateDefaultBinAllocation()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CreateDefaultBinAllocation();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


IPickOrderRequiredItems.GetPickedItemsLineNumbers Method

Gets a generic collection of U_LineNum values of CT_PF_POR2 table for given Required Item from CT_PF_POR3 table.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetPickedItemsLineNumbers( _
   ByVal requiredItemLineNumber As Integer, _
   ByVal docEntry As Integer _
) As List(Of Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<int> GetPickedItemsLineNumbers(
   int requiredItemLineNumber,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

List<int>^ GetPickedItemsLineNumbers(
   int requiredItemLineNumber,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

requiredItemLineNumber

Type: int

The U_LineNum value of a Required Item.

docEntry

Type: int

A Pick Order document's DocEntry value.

Return Value

Type: List<int>

A generic collection of U_LineNum values of CT_PF_POR2 table retrieved from CT_PF_POR3 table.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickOrderRequiredItems Interface
IPickOrderRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


PF_LplOutType Enumeration

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Leave |
Unregister |
See Also

Reference

CompuTec.ProcessForce.API.Documents.PickOrder Namespace


CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | PickedItem | Represents a data of the Picked Item within ProcessForce's Pick Order document.
Public class | PickedItemAssigner | Allows assigning collection with Picked Items to particular Required Item from Pick Order UDO object.
Public class | RequiredItemQuantityHolder | Represents and manages changes in quantity values of Required Items from Pick Order UDO object.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


PickedItem Class

Members See Also

Represents a data of the Picked Item within ProcessForce's Pick Order document.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class PickedItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PickedItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class PickedItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PickedItem
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner.PickedItem
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickedItem Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


PickedItem Members

PickedItem Class Constructors Methods Properties See Also

Represents a data of the Picked Item within ProcessForce's Pick Order document.

The following tables list the members exposed by the PickedItem type.

Constructors
 | Name | Description
Public constructor | PickedItem | (Overloaded) Initializes a new instance of CompuTec.ProcessForce.API.Documents.PickOrder.PickedItem object.
Top
Properties
 | Name | Description
Public property | BnDistNumber | Gets or sets the Batch Number value for a Batch.
Public property | IsLicensePlate | Gets or sets whether the Picked Item represents an Item Master Data or License Plate object.
Public property | ItemCode | Gets or sets the code of a Picked Item.
Public property | Quantity | Gets or sets the quantity of a Picked Item.
Public property | SnDistNumber | Gets or sets the Internal Serial Number value for a Serial Number.
Public property | SnLotNumber | Gets or sets the Batch ID value for a Serial Number.
Public property | SnMnfNumber | Gets or sets the Manufacturer Serial Number value for a Serial Number.
Public property | SnSysNumber | Gets or sets the System Serial Number value for a Serial Number.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PickedItem Class
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


PickedItem Constructor

PickedItem Class See Also

Initializes a new instance of CompuTec.ProcessForce.API.Documents.PickOrder.PickedItem object.

Overload List
Name | Description
PickedItem() | Initializes a new instance of CompuTec.ProcessForce.API.Documents.PickOrder.PickedItem object.
PickedItem(string, bool, double) | Initializes a new instance of CompuTec.ProcessForce.API.Documents.PickOrder.PickedItem object.
PickedItem(string, bool, int, string, string, string, string, double) | Initializes a new instance of CompuTec.ProcessForce.API.Documents.PickOrder.PickedItem object.
See Also

Reference

PickedItem Class
PickedItem Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


PickedItem Properties

PickedItem Class See Also

The following tables list the members exposed by the PickedItem type.

Properties
 | Name | Description
Public property | BnDistNumber | Gets or sets the Batch Number value for a Batch.
Public property | IsLicensePlate | Gets or sets whether the Picked Item represents an Item Master Data or License Plate object.
Public property | ItemCode | Gets or sets the code of a Picked Item.
Public property | Quantity | Gets or sets the quantity of a Picked Item.
Public property | SnDistNumber | Gets or sets the Internal Serial Number value for a Serial Number.
Public property | SnLotNumber | Gets or sets the Batch ID value for a Serial Number.
Public property | SnMnfNumber | Gets or sets the Manufacturer Serial Number value for a Serial Number.
Public property | SnSysNumber | Gets or sets the System Serial Number value for a Serial Number.
Top
See Also

Reference

PickedItem Class
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


PickedItem.BnDistNumber Property

Gets or sets the Batch Number value for a Batch.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property BnDistNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string BnDistNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ BnDistNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get BnDistNumber() : String;
public function set BnDistNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickedItem Class
PickedItem Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


PickedItem.IsLicensePlate Property

Gets or sets whether the Picked Item represents an Item Master Data or License Plate object.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property IsLicensePlate() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool IsLicensePlate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool IsLicensePlate {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get IsLicensePlate() : boolean;
public function set IsLicensePlate(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickedItem Class
PickedItem Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


PickedItem.ItemCode Property

Gets or sets the code of a Picked Item.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ItemCode() : String;
public function set ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickedItem Class
PickedItem Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


PickedItem.Quantity Property

Gets or sets the quantity of a Picked Item.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property double Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Quantity() : double;
public function set Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickedItem Class
PickedItem Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


PickedItem.SnDistNumber Property

Gets or sets the Internal Serial Number value for a Serial Number.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SnDistNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string SnDistNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ SnDistNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SnDistNumber() : String;
public function set SnDistNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickedItem Class
PickedItem Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


PickedItem.SnLotNumber Property

Gets or sets the Batch ID value for a Serial Number.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SnLotNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string SnLotNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ SnLotNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SnLotNumber() : String;
public function set SnLotNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickedItem Class
PickedItem Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


PickedItem.SnMnfNumber Property

Gets or sets the Manufacturer Serial Number value for a Serial Number.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SnMnfNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string SnMnfNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ SnMnfNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SnMnfNumber() : String;
public function set SnMnfNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickedItem Class
PickedItem Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


PickedItem.SnSysNumber Property

Gets or sets the System Serial Number value for a Serial Number.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SnSysNumber() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int SnSysNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int SnSysNumber {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SnSysNumber() : int;
public function set SnSysNumber(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickedItem Class
PickedItem Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


PickedItem Methods

PickedItem Class See Also

The following tables list the members exposed by the PickedItem type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PickedItem Class
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


PickedItemAssigner Class

Members See Also

Allows assigning collection with Picked Items to particular Required Item from Pick Order UDO object.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class PickedItemAssigner
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PickedItemAssigner
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class PickedItemAssigner
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PickedItemAssigner
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner.PickedItemAssigner
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickedItemAssigner Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


PickedItemAssigner Members

PickedItemAssigner Class Methods See Also

Allows assigning collection with Picked Items to particular Required Item from Pick Order UDO object.

The following tables list the members exposed by the PickedItemAssigner type.

Methods
 | Name | Description
 | AssignPickedItems | Assigns a set of Picked Items to the list of Required Items of Pick Order UDO object.
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
 | ValidatePickedItem | Validates if given Picked Item can be assigned to a particular Required Item of Pick Order UDO object.
Top
See Also

Reference

PickedItemAssigner Class
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


PickedItemAssigner Methods

PickedItemAssigner Class See Also

The following tables list the members exposed by the PickedItemAssigner type.

Methods
 | Name | Description
 | AssignPickedItems | Assigns a set of Picked Items to the list of Required Items of Pick Order UDO object.
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
 | ValidatePickedItem | Validates if given Picked Item can be assigned to a particular Required Item of Pick Order UDO object.
Top
See Also

Reference

PickedItemAssigner Class
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


PickedItemAssigner.AssignPickedItems Method

Assigns a set of Picked Items to the list of Required Items of Pick Order UDO object.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function AssignPickedItems( _
   ByVal pickOrder As IPickOrder, _
   ByVal requiredItemsLineNumbers As List(Of Integer), _
   ByVal pickedItems As List(Of PickedItem), _
   Optional ByVal forceUpdate As Boolean = true _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool AssignPickedItems(
   IPickOrder pickOrder,
   List<int> requiredItemsLineNumbers,
   List<PickedItem> pickedItems,
   bool forceUpdate = true
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool AssignPickedItems(
   IPickOrder^ pickOrder,
   List<int>^ requiredItemsLineNumbers,
   List<PickedItem^>^ pickedItems,
   bool forceUpdate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

pickOrder

Type: IPickOrder

A handler to Pick Order UDO object.

requiredItemsLineNumbers

Type: List<int>

A generic collection with U_LineNum values of Required Items.

pickedItems

Type: List<PickedItem>

A generic collection with Picked Items data.

forceUpdate

Type: bool

Return Value

Type: bool

A Boolean value that indicates whether the assigning process was completed successfully or not.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickedItemAssigner Class
PickedItemAssigner Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


PickedItemAssigner.ValidatePickedItem Method

Validates if given Picked Item can be assigned to a particular Required Item of Pick Order UDO object.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function ValidatePickedItem( _
   ByVal Token As String, _
   ByVal pickOrder As IPickOrder, _
   ByVal requiredItemLineNo As Integer, _
   ByVal pickedItemData As PickedItem _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool ValidatePickedItem(
   string Token,
   IPickOrder pickOrder,
   int requiredItemLineNo,
   PickedItem pickedItemData
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool ValidatePickedItem(
   String^ Token,
   IPickOrder^ pickOrder,
   int requiredItemLineNo,
   PickedItem^ pickedItemData
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function ValidatePickedItem(
    Token : String,
    pickOrder : IPickOrder,
    requiredItemLineNo : int,
    pickedItemData : PickedItem
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

pickOrder

Type: IPickOrder

A handler to Pick Order UDO object.

requiredItemLineNo

Type: int

The U_LineNum value of Required Item.

pickedItemData

Type: PickedItem

The data of Picked Item.

Return Value

Type: bool

A Boolean value that indicates whether the Picked Item can be assigned to a particular Required Item or not.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickedItemAssigner Class
PickedItemAssigner Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


RequiredItemQuantityHolder Class

Members See Also

Represents and manages changes in quantity values of Required Items from Pick Order UDO object.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class RequiredItemQuantityHolder
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RequiredItemQuantityHolder
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class RequiredItemQuantityHolder
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RequiredItemQuantityHolder
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner.RequiredItemQuantityHolder
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RequiredItemQuantityHolder Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


RequiredItemQuantityHolder Members

RequiredItemQuantityHolder Class Constructors Methods See Also

Represents and manages changes in quantity values of Required Items from Pick Order UDO object.

The following tables list the members exposed by the RequiredItemQuantityHolder type.

Constructors
 | Name | Description
Public constructor | RequiredItemQuantityHolder | (Overloaded) Initializes a new instance of CompuTec.ProcessForce.API.Documents.PickOrder.Assigner.RequiredItemQuantityHolder object.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetPickedQuantity | Gets the Picked Quantity value of particular Required Item.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | SetPickedQuantity | Changes the Picked Quantity value of particular Required Item.
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateRequiredItemsPickedQuantity | Updates the Picked Quantity values for Required Items from Pick Order UDO object.
Top
See Also

Reference

RequiredItemQuantityHolder Class
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


RequiredItemQuantityHolder Constructor

RequiredItemQuantityHolder Class See Also

Initializes a new instance of CompuTec.ProcessForce.API.Documents.PickOrder.Assigner.RequiredItemQuantityHolder object.

Overload List
Name | Description
RequiredItemQuantityHolder() | Initializes a new instance of CompuTec.ProcessForce.API.Documents.PickOrder.Assigner.RequiredItemQuantityHolder object.
RequiredItemQuantityHolder(List<Int32>) | Initializes a new instance of CompuTec.ProcessForce.API.Documents.PickOrder.Assigner.RequiredItemQuantityHolder object.
See Also

Reference

RequiredItemQuantityHolder Class
RequiredItemQuantityHolder Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


RequiredItemQuantityHolder Methods

RequiredItemQuantityHolder Class See Also

The following tables list the members exposed by the RequiredItemQuantityHolder type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetPickedQuantity | Gets the Picked Quantity value of particular Required Item.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | SetPickedQuantity | Changes the Picked Quantity value of particular Required Item.
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateRequiredItemsPickedQuantity | Updates the Picked Quantity values for Required Items from Pick Order UDO object.
Top
See Also

Reference

RequiredItemQuantityHolder Class
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


RequiredItemQuantityHolder.GetPickedQuantity Method

Gets the Picked Quantity value of particular Required Item.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetPickedQuantity( _
   ByVal requiredItemLineNo As Integer _
) As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double GetPickedQuantity(
   int requiredItemLineNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
double GetPickedQuantity(
   int requiredItemLineNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetPickedQuantity(
    requiredItemLineNo : int
) : double;
This language is not supported or no code example is available.

Parameters

requiredItemLineNo

Type: int

The U_LineNum value of the Required Item.

Return Value

Type: double

The current Picked Quantity value of a Required Item.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RequiredItemQuantityHolder Class
RequiredItemQuantityHolder Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


RequiredItemQuantityHolder.SetPickedQuantity Method

Changes the Picked Quantity value of particular Required Item.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function SetPickedQuantity( _
   ByVal requiredItemLineNo As Integer, _
   ByVal quantityValue As Double _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool SetPickedQuantity(
   int requiredItemLineNo,
   double quantityValue
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool SetPickedQuantity(
   int requiredItemLineNo,
   double quantityValue
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SetPickedQuantity(
    requiredItemLineNo : int,
    quantityValue : double
) : boolean;
This language is not supported or no code example is available.

Parameters

requiredItemLineNo

Type: int

The U_LineNum value of the Required Item.

quantityValue

Type: double

A quantity value by which the Picked Quantity of Required Item will be increased or decreased.

Return Value

Type: bool

A Boolean value that indicates whether the change was applied successfully or not.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RequiredItemQuantityHolder Class
RequiredItemQuantityHolder Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


RequiredItemQuantityHolder.UpdateRequiredItemsPickedQuantity Method

Updates the Picked Quantity values for Required Items from Pick Order UDO object.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function UpdateRequiredItemsPickedQuantity( _
   ByVal udo As IPickOrder _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool UpdateRequiredItemsPickedQuantity(
   IPickOrder udo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool UpdateRequiredItemsPickedQuantity(
   IPickOrder^ udo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UpdateRequiredItemsPickedQuantity(
    udo : IPickOrder
) : boolean;
This language is not supported or no code example is available.

Parameters

udo

Type: IPickOrder

A handler to Pick Order UDO object.

Return Value

Type: bool

A Boolean value that indicates whether the update process was completed successfully or not.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RequiredItemQuantityHolder Class
RequiredItemQuantityHolder Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


CompuTec.ProcessForce.API.Documents.PickReceipt Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | BatchNumberQuantityMissMatchException |
Public class | PickReceiptDocumentType |
Public class | SerialNumberQuantityMissMatchException |
Public class | SerialNumbersAreNotUniqueException |
Top
Interfaces
 | Name | Description
Public interface | IPickReceipt | Document for receipting items form production order or delivery
Public interface | IPickReceiptBinAllocations | Bin allocations of pick receipt
Public interface | IPickReceiptPickedItems | This class describes information about picked items for required items Please do not modify this object !!!
Public interface | IPickReceiptRelations | This object describses relations between required and picked items Please do not modify !!!
Public interface | IPickReceiptRequiredItems | Required items of pick receipt
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


BatchNumberQuantityMissMatchException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class BatchNumberQuantityMissMatchException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class BatchNumberQuantityMissMatchException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class BatchNumberQuantityMissMatchException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class BatchNumberQuantityMissMatchException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.PickReceipt.BatchNumberQuantityMissMatchException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberQuantityMissMatchException Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


BatchNumberQuantityMissMatchException Members

BatchNumberQuantityMissMatchException Class Constructors Methods Properties See Also

The following tables list the members exposed by the BatchNumberQuantityMissMatchException type.

Constructors
 | Name | Description
Public constructor | BatchNumberQuantityMissMatchException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BatchNumberQuantityMissMatchException Class
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


BatchNumberQuantityMissMatchException Constructor

BatchNumberQuantityMissMatchException Class See Also

Overload List
Name | Description
BatchNumberQuantityMissMatchException() |
BatchNumberQuantityMissMatchException(string) |
BatchNumberQuantityMissMatchException(string, Exception) |
See Also

Reference

BatchNumberQuantityMissMatchException Class
BatchNumberQuantityMissMatchException Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


BatchNumberQuantityMissMatchException Properties

BatchNumberQuantityMissMatchException Class See Also

The following tables list the members exposed by the BatchNumberQuantityMissMatchException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

BatchNumberQuantityMissMatchException Class
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


BatchNumberQuantityMissMatchException Methods

BatchNumberQuantityMissMatchException Class See Also

The following tables list the members exposed by the BatchNumberQuantityMissMatchException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BatchNumberQuantityMissMatchException Class
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


PickReceiptDocumentType Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public NotInheritable Class PickReceiptDocumentType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public sealed class PickReceiptDocumentType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class PickReceiptDocumentType sealed
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public final class PickReceiptDocumentType
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.PickReceipt.PickReceiptDocumentType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickReceiptDocumentType Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


PickReceiptDocumentType Members

PickReceiptDocumentType Class Methods Fields See Also

The following tables list the members exposed by the PickReceiptDocumentType type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | PurchaseOrder |
Top
See Also

Reference

PickReceiptDocumentType Class
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


PickReceiptDocumentType Methods

PickReceiptDocumentType Class See Also

The following tables list the members exposed by the PickReceiptDocumentType type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PickReceiptDocumentType Class
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


PickReceiptDocumentType Fields

PickReceiptDocumentType Class See Also

The following tables list the members exposed by the PickReceiptDocumentType type.

Fields
 | Name | Description
Public field | PurchaseOrder |
Top
See Also

Reference

PickReceiptDocumentType Class
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


PurchaseOrder Field

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const PurchaseOrder As String = "22"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string PurchaseOrder = @"22"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ PurchaseOrder = "22";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const PurchaseOrder : String = "22"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickReceiptDocumentType Class
PickReceiptDocumentType Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


SerialNumberQuantityMissMatchException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class SerialNumberQuantityMissMatchException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class SerialNumberQuantityMissMatchException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class SerialNumberQuantityMissMatchException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class SerialNumberQuantityMissMatchException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.PickReceipt.SerialNumberQuantityMissMatchException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SerialNumberQuantityMissMatchException Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


SerialNumberQuantityMissMatchException Members

SerialNumberQuantityMissMatchException Class Constructors Methods Properties See Also

The following tables list the members exposed by the SerialNumberQuantityMissMatchException type.

Constructors
 | Name | Description
Public constructor | SerialNumberQuantityMissMatchException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

SerialNumberQuantityMissMatchException Class
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


SerialNumberQuantityMissMatchException Constructor

SerialNumberQuantityMissMatchException Class See Also

Overload List
Name | Description
SerialNumberQuantityMissMatchException() |
SerialNumberQuantityMissMatchException(string) |
SerialNumberQuantityMissMatchException(string, Exception) |
See Also

Reference

SerialNumberQuantityMissMatchException Class
SerialNumberQuantityMissMatchException Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


SerialNumberQuantityMissMatchException Properties

SerialNumberQuantityMissMatchException Class See Also

The following tables list the members exposed by the SerialNumberQuantityMissMatchException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

SerialNumberQuantityMissMatchException Class
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


SerialNumberQuantityMissMatchException Methods

SerialNumberQuantityMissMatchException Class See Also

The following tables list the members exposed by the SerialNumberQuantityMissMatchException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

SerialNumberQuantityMissMatchException Class
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


SerialNumbersAreNotUniqueException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class SerialNumbersAreNotUniqueException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class SerialNumbersAreNotUniqueException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class SerialNumbersAreNotUniqueException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class SerialNumbersAreNotUniqueException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.PickReceipt.SerialNumbersAreNotUniqueException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SerialNumbersAreNotUniqueException Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


SerialNumbersAreNotUniqueException Members

SerialNumbersAreNotUniqueException Class Constructors Methods Properties See Also

The following tables list the members exposed by the SerialNumbersAreNotUniqueException type.

Constructors
 | Name | Description
Public constructor | SerialNumbersAreNotUniqueException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

SerialNumbersAreNotUniqueException Class
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


SerialNumbersAreNotUniqueException Constructor

SerialNumbersAreNotUniqueException Class See Also

Overload List
Name | Description
SerialNumbersAreNotUniqueException() |
SerialNumbersAreNotUniqueException(string) |
SerialNumbersAreNotUniqueException(string, Exception) |
See Also

Reference

SerialNumbersAreNotUniqueException Class
SerialNumbersAreNotUniqueException Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


SerialNumbersAreNotUniqueException Properties

SerialNumbersAreNotUniqueException Class See Also

The following tables list the members exposed by the SerialNumbersAreNotUniqueException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

SerialNumbersAreNotUniqueException Class
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


SerialNumbersAreNotUniqueException Methods

SerialNumbersAreNotUniqueException Class See Also

The following tables list the members exposed by the SerialNumbersAreNotUniqueException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

SerialNumbersAreNotUniqueException Class
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt Interface

Members See Also

Document for receipting items form production order or delivery

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "PickReceipt", TableName = "@CT_PF_OPRE", ExludedHttpMethods = "DELETE")> _
Public Interface IPickReceipt
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "PickReceipt", TableName = "@CT_PF_OPRE", ExludedHttpMethods = "DELETE")]
public interface IPickReceipt : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "PickReceipt", TableName = "@CT_PF_OPRE", ExludedHttpMethods = "DELETE")]
public interface class IPickReceipt : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "PickReceipt", TableName = "@CT_PF_OPRE", ExludedHttpMethods = "DELETE")
interface IPickReceipt
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OPRE
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt Members

IPickReceipt Interface Methods Properties See Also

Document for receipting items form production order or delivery

The following tables list the members exposed by the IPickReceipt type.

Properties
 | Name | Description
Public property | BinAllocations |
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_SeriesName | Document Series Name
Public property | DS_UserCode | User Code
Public property | DS_UserName |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | PickedItems | Items that are assigned to required Item Please do not modify!!!
Public property | Relations | Obsolete. Relations Between Picked and Required Items Please do not modify!!!
Public property | RequiredItems | Document Lince ( required Items ) this items are editable and visible
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Date | Docuemnt Date
Public property | U_Employee | Employee uid
Public property | U_Ref2 | Ref2
Public property | U_Remarks | Document Remarks
Public property | U_Status |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetCreatedDocumentReferences | This metthod returns references to all documents created during Receipt from production on Document Update Note that Auto receipt must be enabled
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IPickReceipt Interface
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt Properties

IPickReceipt Interface See Also

The following tables list the members exposed by the IPickReceipt type.

Properties
 | Name | Description
Public property | BinAllocations |
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_SeriesName | Document Series Name
Public property | DS_UserCode | User Code
Public property | DS_UserName |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | PickedItems | Items that are assigned to required Item Please do not modify!!!
Public property | Relations | Obsolete. Relations Between Picked and Required Items Please do not modify!!!
Public property | RequiredItems | Document Lince ( required Items ) this items are editable and visible
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Date | Docuemnt Date
Public property | U_Employee | Employee uid
Public property | U_Ref2 | Ref2
Public property | U_Remarks | Document Remarks
Public property | U_Status |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IPickReceipt Interface
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.BinAllocations Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property BinAllocations() As IPickReceiptBinAllocations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IPickReceiptBinAllocations BinAllocations {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IPickReceiptBinAllocations^ BinAllocations {
 IPickReceiptBinAllocations^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BinAllocations() : IPickReceiptBinAllocations;
This language is not supported or no code example is available.

Property Value

Type: IPickReceiptBinAllocations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.DS_SeriesName Property

Document Series Name

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_SeriesName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_SeriesName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_SeriesName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_SeriesName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.DS_UserCode Property

User Code

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_UserCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_UserCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_UserCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_UserCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.DS_UserName Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_UserName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_UserName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_UserName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_UserName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 1,IsMasterKey = true)> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 1,IsMasterKey = true)]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 1,IsMasterKey = true)]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 1,IsMasterKey = true)
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.DocNum Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.Handwrtten Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Handwrtten() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Handwrtten {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Handwrtten {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Handwrtten() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.Instance Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Instance() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Instance {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Instance {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Instance() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.Period Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Period() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Period {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Period {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Period() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.PickedItems Property

Items that are assigned to required Item Please do not modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property PickedItems() As IPickReceiptPickedItems
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IPickReceiptPickedItems PickedItems {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IPickReceiptPickedItems^ PickedItems {
 IPickReceiptPickedItems^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get PickedItems() : IPickReceiptPickedItems;
This language is not supported or no code example is available.

Property Value

Type: IPickReceiptPickedItems
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.Relations Property

NOTE: This member is now obsolete.

Relations Between Picked and Required Items Please do not modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Obsolete()> _
<AppEnginePropertyIgnore()> _
ReadOnly Property Relations() As IPickReceiptRelations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete()]
[AppEnginePropertyIgnore()]
IPickReceiptRelations Relations {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete()]
[AppEnginePropertyIgnore()]

property IPickReceiptRelations^ Relations {
 IPickReceiptRelations^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   Obsolete()
   AppEnginePropertyIgnore()
function get Relations() : IPickReceiptRelations;
This language is not supported or no code example is available.

Property Value

Type: IPickReceiptRelations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.RequiredItems Property

Document Lince ( required Items ) this items are editable and visible

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RequiredItems() As IPickReceiptRequiredItems
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IPickReceiptRequiredItems RequiredItems {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IPickReceiptRequiredItems^ RequiredItems {
 IPickReceiptRequiredItems^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RequiredItems() : IPickReceiptRequiredItems;
This language is not supported or no code example is available.

Property Value

Type: IPickReceiptRequiredItems
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.Series Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Series() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Series {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Series {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Series() : int;
function set Series(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.Status Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Status {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Status {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Status() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.U_Date Property

Docuemnt Date

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Date() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Date {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Date {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Date() : DateTime;
function set U_Date(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.U_Employee Property

Employee uid

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Employee() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_Employee {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_Employee {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Employee() : int;
function set U_Employee(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.U_Ref2 Property

Ref2

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Ref2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Ref2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Ref2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Ref2() : String;
function set U_Ref2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.U_Remarks Property

Document Remarks

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.U_Status Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Status() As PickStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
PickStatus U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property PickStatus U_Status {
 PickStatus get( );
 void set(
   PickStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Status() : PickStatus;
function set U_Status(value : PickStatus);
This language is not supported or no code example is available.

Property Value

Type: PickStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt Methods

IPickReceipt Interface See Also

The following tables list the members exposed by the IPickReceipt type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetCreatedDocumentReferences | This metthod returns references to all documents created during Receipt from production on Document Update Note that Auto receipt must be enabled
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IPickReceipt Interface
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceipt.GetCreatedDocumentReferences Method

This metthod returns references to all documents created during Receipt from production on Document Update Note that Auto receipt must be enabled

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetCreatedDocumentReferences() As List(Of DocRef)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<DocRef> GetCreatedDocumentReferences()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

List<DocRef^>^ GetCreatedDocumentReferences()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Return Value

Type: List<DocRef>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceipt Interface
IPickReceipt Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptBinAllocations Interface

Members See Also

Bin allocations of pick receipt

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IPickReceiptBinAllocations
    Inherits IUDOChildBean, _
             IEnumerable(Of IPickReceiptBinAllocations)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IPickReceiptBinAllocations : IUDOChildBean,
   IEnumerable<IPickReceiptBinAllocations>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IPickReceiptBinAllocations : public IUDOChildBean^,
   public IEnumerable<IPickReceiptBinAllocations^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_PRE4
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptBinAllocations Members

IPickReceiptBinAllocations Interface Methods Properties See Also

Bin allocations of pick receipt

The following tables list the members exposed by the IPickReceiptBinAllocations type.

Properties
 | Name | Description
Public property | BinCode |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BinAbsEntry | bin allocation abs entry
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Quantity | quantity which is in this bin
Public property | U_SnAndBnLine | line number of batch or serial number if present
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPickReceiptBinAllocations Interface
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptBinAllocations Properties

IPickReceiptBinAllocations Interface See Also

The following tables list the members exposed by the IPickReceiptBinAllocations type.

Properties
 | Name | Description
Public property | BinCode |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BinAbsEntry | bin allocation abs entry
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Quantity | quantity which is in this bin
Public property | U_SnAndBnLine | line number of batch or serial number if present
Public property | VisOrder |
Top
See Also

Reference

IPickReceiptBinAllocations Interface
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptBinAllocations.BinCode Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property BinCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string BinCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ BinCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BinCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptBinAllocations Interface
IPickReceiptBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptBinAllocations.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptBinAllocations Interface
IPickReceiptBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptBinAllocations.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptBinAllocations Interface
IPickReceiptBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptBinAllocations.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptBinAllocations Interface
IPickReceiptBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptBinAllocations.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptBinAllocations Interface
IPickReceiptBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptBinAllocations.U_BinAbsEntry Property

bin allocation abs entry

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BinAbsEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BinAbsEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BinAbsEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BinAbsEntry() : int;
function set U_BinAbsEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptBinAllocations Interface
IPickReceiptBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptBinAllocations.U_Quantity Property

quantity which is in this bin

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptBinAllocations Interface
IPickReceiptBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptBinAllocations.U_SnAndBnLine Property

line number of batch or serial number if present

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SnAndBnLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SnAndBnLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SnAndBnLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SnAndBnLine() : int;
function set U_SnAndBnLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptBinAllocations Interface
IPickReceiptBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptBinAllocations.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptBinAllocations Interface
IPickReceiptBinAllocations Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptBinAllocations Methods

IPickReceiptBinAllocations Interface See Also

The following tables list the members exposed by the IPickReceiptBinAllocations type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPickReceiptBinAllocations Interface
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems Interface

Members See Also

This class describes information about picked items for required items Please do not modify this object !!!

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IPickReceiptPickedItems
    Inherits IUDOChildBean, _
             IEnumerable(Of IPickReceiptPickedItems)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IPickReceiptPickedItems : IUDOChildBean,
   IEnumerable<IPickReceiptPickedItems>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IPickReceiptPickedItems : public IUDOChildBean^,
   public IEnumerable<IPickReceiptPickedItems^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_PRE2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems Members

IPickReceiptPickedItems Interface Methods Properties See Also

This class describes information about picked items for required items Please do not modify this object !!!

The following tables list the members exposed by the IPickReceiptPickedItems type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_IsLicensePlate | dynamic informational filed
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BestBefDate |
Public property | U_BnConsDate | ConsumeDate
Public property | U_BnDistNumber | Batch Number for Batch Numbers. Please Do Not Modify!!!
Public property | U_BnExpDate | Expiry dates
Public property | U_BnExpTime | Expiry Time
Public property | U_BnInDate | Receipt date
Public property | U_BnInspDate | Inspection Date
Public property | U_BnLInspDate | Last Inspection Date
Public property | U_BnLotNumber | Batch attribute 2
Public property | U_BnMnfDate | Manufacturing Date
Public property | U_BnMnfSerial | Batch attribute 1
Public property | U_BnNInspDate | Next Inspection Date
Public property | U_BnNotes | Batch notes
Public property | U_BnQCStatus | QC Status
Public property | U_BnStatus | Batch Status
Public property | U_BnWConsDate | Warning Consume Date
Public property | U_BnWExpDate | Warning Expiry date
Public property | U_ItemCode | Item Code Please Do Not Modify!!!
Public property | U_LicPlateItemCode | Key of LicencePlate Item
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Location |
Public property | U_LplCode | Licnence Plate Code Please Do Not Modify!!!
Public property | U_LplsPath | Path currently not used Please Do Not Modify!!!
Public property | U_Origin |
Public property | U_Quantity | Item Quantity Please Do Not Modify!!!
Public property | U_Receipted | Y,N is this Item is already receipted Please Do Not Modify!!!
Public property | U_Remarks |
Public property | U_ReqItmLn |
Public property | U_SnDistNumber | Internal Serial Number for Serial Numbers.Please Do Not Modify!!!
Public property | U_SnLotNumber | Batch ID for Serial Numbers.Please Do Not Modify!!!
Public property | U_SnMnfNumber | Manufacturer Serial Number for Serial Numbers.Please Do Not Modify!!!
Public property | U_SnSysNumber | System Serial Number for Serial Numbers.Please Do Not Modify!!!
Public property | U_SupNumber |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPickReceiptPickedItems Interface
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems Properties

IPickReceiptPickedItems Interface See Also

The following tables list the members exposed by the IPickReceiptPickedItems type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_IsLicensePlate | dynamic informational filed
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BestBefDate |
Public property | U_BnConsDate | ConsumeDate
Public property | U_BnDistNumber | Batch Number for Batch Numbers. Please Do Not Modify!!!
Public property | U_BnExpDate | Expiry dates
Public property | U_BnExpTime | Expiry Time
Public property | U_BnInDate | Receipt date
Public property | U_BnInspDate | Inspection Date
Public property | U_BnLInspDate | Last Inspection Date
Public property | U_BnLotNumber | Batch attribute 2
Public property | U_BnMnfDate | Manufacturing Date
Public property | U_BnMnfSerial | Batch attribute 1
Public property | U_BnNInspDate | Next Inspection Date
Public property | U_BnNotes | Batch notes
Public property | U_BnQCStatus | QC Status
Public property | U_BnStatus | Batch Status
Public property | U_BnWConsDate | Warning Consume Date
Public property | U_BnWExpDate | Warning Expiry date
Public property | U_ItemCode | Item Code Please Do Not Modify!!!
Public property | U_LicPlateItemCode | Key of LicencePlate Item
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Location |
Public property | U_LplCode | Licnence Plate Code Please Do Not Modify!!!
Public property | U_LplsPath | Path currently not used Please Do Not Modify!!!
Public property | U_Origin |
Public property | U_Quantity | Item Quantity Please Do Not Modify!!!
Public property | U_Receipted | Y,N is this Item is already receipted Please Do Not Modify!!!
Public property | U_Remarks |
Public property | U_ReqItmLn |
Public property | U_SnDistNumber | Internal Serial Number for Serial Numbers.Please Do Not Modify!!!
Public property | U_SnLotNumber | Batch ID for Serial Numbers.Please Do Not Modify!!!
Public property | U_SnMnfNumber | Manufacturer Serial Number for Serial Numbers.Please Do Not Modify!!!
Public property | U_SnSysNumber | System Serial Number for Serial Numbers.Please Do Not Modify!!!
Public property | U_SupNumber |
Public property | VisOrder |
Top
See Also

Reference

IPickReceiptPickedItems Interface
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.DS_IsLicensePlate Property

dynamic informational filed

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_IsLicensePlate() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
bool DS_IsLicensePlate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property bool DS_IsLicensePlate {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_IsLicensePlate() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_BestBefDate Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BestBefDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_BestBefDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_BestBefDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BestBefDate() : DateTime;
function set U_BestBefDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_BnConsDate Property

ConsumeDate

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BnConsDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_BnConsDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_BnConsDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BnConsDate() : DateTime;
function set U_BnConsDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_BnDistNumber Property

Batch Number for Batch Numbers. Please Do Not Modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BnDistNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BnDistNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BnDistNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BnDistNumber() : String;
function set U_BnDistNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_BnExpDate Property

Expiry dates

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BnExpDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_BnExpDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_BnExpDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BnExpDate() : DateTime;
function set U_BnExpDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_BnExpTime Property

Expiry Time

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BnExpTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_BnExpTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_BnExpTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BnExpTime() : DateTime;
function set U_BnExpTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_BnInDate Property

Receipt date

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BnInDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_BnInDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_BnInDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BnInDate() : DateTime;
function set U_BnInDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_BnInspDate Property

Inspection Date

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BnInspDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_BnInspDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_BnInspDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BnInspDate() : DateTime;
function set U_BnInspDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_BnLInspDate Property

Last Inspection Date

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BnLInspDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_BnLInspDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_BnLInspDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BnLInspDate() : DateTime;
function set U_BnLInspDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_BnLotNumber Property

Batch attribute 2

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BnLotNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BnLotNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BnLotNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BnLotNumber() : String;
function set U_BnLotNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_BnMnfDate Property

Manufacturing Date

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BnMnfDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_BnMnfDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_BnMnfDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BnMnfDate() : DateTime;
function set U_BnMnfDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_BnMnfSerial Property

Batch attribute 1

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BnMnfSerial() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BnMnfSerial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BnMnfSerial {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BnMnfSerial() : String;
function set U_BnMnfSerial(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_BnNInspDate Property

Next Inspection Date

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BnNInspDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_BnNInspDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_BnNInspDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BnNInspDate() : DateTime;
function set U_BnNInspDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_BnNotes Property

Batch notes

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BnNotes() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BnNotes {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BnNotes {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BnNotes() : String;
function set U_BnNotes(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_BnQCStatus Property

QC Status

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BnQCStatus() As QCStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
QCStatus U_BnQCStatus {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property QCStatus U_BnQCStatus {
 QCStatus get( );
 void set(
   QCStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BnQCStatus() : QCStatus;
function set U_BnQCStatus(value : QCStatus);
This language is not supported or no code example is available.

Property Value

Type: QCStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_BnStatus Property

Batch Status

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BnStatus() As BatchStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
BatchStatus U_BnStatus {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property BatchStatus U_BnStatus {
 BatchStatus get( );
 void set(
   BatchStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BnStatus() : BatchStatus;
function set U_BnStatus(value : BatchStatus);
This language is not supported or no code example is available.

Property Value

Type: BatchStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_BnWConsDate Property

Warning Consume Date

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BnWConsDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_BnWConsDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_BnWConsDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BnWConsDate() : DateTime;
function set U_BnWConsDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_BnWExpDate Property

Warning Expiry date

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BnWExpDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_BnWExpDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_BnWExpDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BnWExpDate() : DateTime;
function set U_BnWExpDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_ItemCode Property

Item Code Please Do Not Modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_LicPlateItemCode Property

Key of LicencePlate Item

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LicPlateItemCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_LicPlateItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_LicPlateItemCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LicPlateItemCode() : int;
function set U_LicPlateItemCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_Location Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Location() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Location {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Location {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Location() : String;
function set U_Location(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_LplCode Property

Licnence Plate Code Please Do Not Modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LplCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LplCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LplCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LplCode() : String;
function set U_LplCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_LplsPath Property

Path currently not used Please Do Not Modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LplsPath() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LplsPath {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LplsPath {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LplsPath() : String;
function set U_LplsPath(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_Origin Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Origin() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Origin {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Origin {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Origin() : String;
function set U_Origin(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_Quantity Property

Item Quantity Please Do Not Modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_Receipted Property

Y,N is this Item is already receipted Please Do Not Modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Receipted() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Receipted {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Receipted {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Receipted() : String;
function set U_Receipted(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_ReqItmLn Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReqItmLn() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ReqItmLn {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ReqItmLn {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReqItmLn() : int;
function set U_ReqItmLn(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_SnDistNumber Property

Internal Serial Number for Serial Numbers.Please Do Not Modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SnDistNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SnDistNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SnDistNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SnDistNumber() : String;
function set U_SnDistNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_SnLotNumber Property

Batch ID for Serial Numbers.Please Do Not Modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SnLotNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SnLotNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SnLotNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SnLotNumber() : String;
function set U_SnLotNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_SnMnfNumber Property

Manufacturer Serial Number for Serial Numbers.Please Do Not Modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SnMnfNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SnMnfNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SnMnfNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SnMnfNumber() : String;
function set U_SnMnfNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_SnSysNumber Property

System Serial Number for Serial Numbers.Please Do Not Modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SnSysNumber() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SnSysNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SnSysNumber {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SnSysNumber() : int;
function set U_SnSysNumber(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.U_SupNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SupNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SupNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SupNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SupNumber() : String;
function set U_SupNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptPickedItems Interface
IPickReceiptPickedItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptPickedItems Methods

IPickReceiptPickedItems Interface See Also

The following tables list the members exposed by the IPickReceiptPickedItems type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPickReceiptPickedItems Interface
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRelations Interface

Members See Also

This object describses relations between required and picked items Please do not modify !!!

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IPickReceiptRelations
    Inherits IUDOChildBean, _
             IEnumerable(Of IPickReceiptRelations)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IPickReceiptRelations : IUDOChildBean,
   IEnumerable<IPickReceiptRelations>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IPickReceiptRelations : public IUDOChildBean^,
   public IEnumerable<IPickReceiptRelations^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_PRE3
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRelations Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRelations Members

IPickReceiptRelations Interface Methods Properties See Also

This object describses relations between required and picked items Please do not modify !!!

The following tables list the members exposed by the IPickReceiptRelations type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PickItemLineNo | Picked Item Line Num (U_LineNum) Please Do Not Modify!!!
Public property | U_ReqItemLineNo | Required Item LineNum U_LineNum Please Do Not Modify!!!
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPickReceiptRelations Interface
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRelations Properties

IPickReceiptRelations Interface See Also

The following tables list the members exposed by the IPickReceiptRelations type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PickItemLineNo | Picked Item Line Num (U_LineNum) Please Do Not Modify!!!
Public property | U_ReqItemLineNo | Required Item LineNum U_LineNum Please Do Not Modify!!!
Public property | VisOrder |
Top
See Also

Reference

IPickReceiptRelations Interface
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRelations.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRelations Interface
IPickReceiptRelations Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRelations.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRelations Interface
IPickReceiptRelations Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRelations.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRelations Interface
IPickReceiptRelations Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRelations.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRelations Interface
IPickReceiptRelations Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRelations.U_PickItemLineNo Property

Picked Item Line Num (U_LineNum) Please Do Not Modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PickItemLineNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_PickItemLineNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_PickItemLineNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PickItemLineNo() : int;
function set U_PickItemLineNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRelations Interface
IPickReceiptRelations Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRelations.U_ReqItemLineNo Property

Required Item LineNum U_LineNum Please Do Not Modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReqItemLineNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ReqItemLineNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ReqItemLineNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReqItemLineNo() : int;
function set U_ReqItemLineNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRelations Interface
IPickReceiptRelations Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRelations.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRelations Interface
IPickReceiptRelations Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRelations Methods

IPickReceiptRelations Interface See Also

The following tables list the members exposed by the IPickReceiptRelations type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPickReceiptRelations Interface
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems Interface

Members See Also

Required items of pick receipt

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IPickReceiptRequiredItems
    Inherits IUDOChildBean, _
             IEnumerable(Of IPickReceiptRequiredItems)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IPickReceiptRequiredItems : IUDOChildBean,
   IEnumerable<IPickReceiptRequiredItems>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IPickReceiptRequiredItems : public IUDOChildBean^,
   public IEnumerable<IPickReceiptRequiredItems^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_PRE1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems Members

IPickReceiptRequiredItems Interface Methods Properties See Also

Required items of pick receipt

The following tables list the members exposed by the IPickReceiptRequiredItems type.

Properties
 | Name | Description
Public property | BatchNumbers | Obsolete.
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_OprName |
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | SerialNumbers | Obsolete.
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AccCode | Account Code
Public property | U_BPCode | CardCode
Public property | U_BaseEntry | Doc Entry of base document
Public property | U_BaseLineNo | base Document Line Number
Public property | U_BaseRef | Reference
Public property | U_BaseType | Type of base document
Public property | U_Classification | Classification used as a parameter by Batch and serial Generators
Public property | U_DocType | Type od Out document
Public property | U_DstWhsCode | Destination Whs Code (used)
Public property | U_HandAssigned | Informational if batches or serials where Generated automaticly Please Do not Modify!!!
Public property | U_ItemCode | Item Code
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OcrCode | Distribution Rule
Public property | U_OcrCode2 | Distribution Rule 2
Public property | U_OcrCode3 | Distribution Rule 3
Public property | U_OcrCode4 | Distribution Rule 4
Public property | U_OcrCode5 | Distribution Rule 5
Public property | U_OprCode | OperationCode
Public property | U_PickedQty | Picked Quanttiy This quantity can be Receipted using actions
Public property | U_PlannedQty | Planned Quantity copied form base Document
Public property | U_Price | Receipt Price
Public property | U_Project | Project
Public property | U_ReceiptedQty | Quantity that is already Receipted
Public property | U_RefLine | Reference lince
Public property | U_RevisionCode | Revision Code
Public property | U_SrcWhsCode | Source Warehouse Code (not used)
Public property | U_SuppRef |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | CreateDefaultBinAllocation |
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | GetPickedItemsLineNumbers | Gets a generic collection of U_LineNum values of CT_PF_PRE2 table for given Required Item from CT_PF_PRE3 table.
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPickReceiptRequiredItems Interface
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems Properties

IPickReceiptRequiredItems Interface See Also

The following tables list the members exposed by the IPickReceiptRequiredItems type.

Properties
 | Name | Description
Public property | BatchNumbers | Obsolete.
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_OprName |
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | SerialNumbers | Obsolete.
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AccCode | Account Code
Public property | U_BPCode | CardCode
Public property | U_BaseEntry | Doc Entry of base document
Public property | U_BaseLineNo | base Document Line Number
Public property | U_BaseRef | Reference
Public property | U_BaseType | Type of base document
Public property | U_Classification | Classification used as a parameter by Batch and serial Generators
Public property | U_DocType | Type od Out document
Public property | U_DstWhsCode | Destination Whs Code (used)
Public property | U_HandAssigned | Informational if batches or serials where Generated automaticly Please Do not Modify!!!
Public property | U_ItemCode | Item Code
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OcrCode | Distribution Rule
Public property | U_OcrCode2 | Distribution Rule 2
Public property | U_OcrCode3 | Distribution Rule 3
Public property | U_OcrCode4 | Distribution Rule 4
Public property | U_OcrCode5 | Distribution Rule 5
Public property | U_OprCode | OperationCode
Public property | U_PickedQty | Picked Quanttiy This quantity can be Receipted using actions
Public property | U_PlannedQty | Planned Quantity copied form base Document
Public property | U_Price | Receipt Price
Public property | U_Project | Project
Public property | U_ReceiptedQty | Quantity that is already Receipted
Public property | U_RefLine | Reference lince
Public property | U_RevisionCode | Revision Code
Public property | U_SrcWhsCode | Source Warehouse Code (not used)
Public property | U_SuppRef |
Public property | VisOrder |
Top
See Also

Reference

IPickReceiptRequiredItems Interface
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.BatchNumbers Property

NOTE: This member is now obsolete.

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Obsolete()> _
ReadOnly Property BatchNumbers() As IBatchNumbers
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete()]
IBatchNumbers BatchNumbers {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete()]

property IBatchNumbers^ BatchNumbers {
 IBatchNumbers^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   Obsolete()
function get BatchNumbers() : IBatchNumbers;
This language is not supported or no code example is available.

Property Value

Type: IBatchNumbers
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.DS_OprName Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_OprName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_OprName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_OprName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_OprName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.SerialNumbers Property

NOTE: This member is now obsolete.

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Obsolete()> _
ReadOnly Property SerialNumbers() As ISerialNumbers
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete()]
ISerialNumbers SerialNumbers {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete()]

property ISerialNumbers^ SerialNumbers {
 ISerialNumbers^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   Obsolete()
function get SerialNumbers() : ISerialNumbers;
This language is not supported or no code example is available.

Property Value

Type: ISerialNumbers
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_AccCode Property

Account Code

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AccCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AccCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AccCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AccCode() : String;
function set U_AccCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_BPCode Property

CardCode

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BPCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BPCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BPCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BPCode() : String;
function set U_BPCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_BaseEntry Property

Doc Entry of base document

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseEntry() : int;
function set U_BaseEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_BaseLineNo Property

base Document Line Number

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLineNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLineNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLineNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLineNo() : int;
function set U_BaseLineNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_BaseRef Property

Reference

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseRef() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BaseRef {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BaseRef {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseRef() : String;
function set U_BaseRef(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_BaseType Property

Type of base document

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BaseType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BaseType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseType() : String;
function set U_BaseType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_Classification Property

Classification used as a parameter by Batch and serial Generators

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Classification() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Classification {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Classification {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Classification() : String;
function set U_Classification(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_DocType Property

Type od Out document

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DocType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DocType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DocType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DocType() : String;
function set U_DocType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_DstWhsCode Property

Destination Whs Code (used)

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DstWhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DstWhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DstWhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DstWhsCode() : String;
function set U_DstWhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_HandAssigned Property

Informational if batches or serials where Generated automaticly Please Do not Modify!!!

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_HandAssigned() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_HandAssigned {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_HandAssigned {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_HandAssigned() : YesNoType;
function set U_HandAssigned(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_ItemCode Property

Item Code

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_OcrCode Property

Distribution Rule

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode() : String;
function set U_OcrCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_OcrCode2 Property

Distribution Rule 2

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode2() : String;
function set U_OcrCode2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_OcrCode3 Property

Distribution Rule 3

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode3() : String;
function set U_OcrCode3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_OcrCode4 Property

Distribution Rule 4

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode4() : String;
function set U_OcrCode4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_OcrCode5 Property

Distribution Rule 5

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode5() : String;
function set U_OcrCode5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_OprCode Property

OperationCode

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_PickedQty Property

Picked Quanttiy This quantity can be Receipted using actions

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PickedQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PickedQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PickedQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PickedQty() : double;
function set U_PickedQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_PlannedQty Property

Planned Quantity copied form base Document

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PlannedQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PlannedQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PlannedQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PlannedQty() : double;
function set U_PlannedQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_Price Property

Receipt Price

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Price() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Price {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Price {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Price() : double;
function set U_Price(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_Project Property

Project

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Project() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Project {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Project {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Project() : String;
function set U_Project(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_ReceiptedQty Property

Quantity that is already Receipted

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReceiptedQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ReceiptedQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ReceiptedQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReceiptedQty() : double;
function set U_ReceiptedQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_RefLine Property

Reference lince

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RefLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RefLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RefLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RefLine() : int;
function set U_RefLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_RevisionCode Property

Revision Code

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RevisionCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevisionCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevisionCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevisionCode() : String;
function set U_RevisionCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_SrcWhsCode Property

Source Warehouse Code (not used)

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SrcWhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SrcWhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SrcWhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SrcWhsCode() : String;
function set U_SrcWhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.U_SuppRef Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SuppRef() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SuppRef {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SuppRef {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SuppRef() : String;
function set U_SuppRef(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems Methods

IPickReceiptRequiredItems Interface See Also

The following tables list the members exposed by the IPickReceiptRequiredItems type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | CreateDefaultBinAllocation |
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | GetPickedItemsLineNumbers | Gets a generic collection of U_LineNum values of CT_PF_PRE2 table for given Required Item from CT_PF_PRE3 table.
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPickReceiptRequiredItems Interface
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.CreateDefaultBinAllocation Method

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub CreateDefaultBinAllocation()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void CreateDefaultBinAllocation()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void CreateDefaultBinAllocation()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CreateDefaultBinAllocation();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IPickReceiptRequiredItems.GetPickedItemsLineNumbers Method

Gets a generic collection of U_LineNum values of CT_PF_PRE2 table for given Required Item from CT_PF_PRE3 table.

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetPickedItemsLineNumbers( _
   ByVal requiredItemLineNumber As Integer, _
   ByVal docEntry As Integer _
) As List(Of Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<int> GetPickedItemsLineNumbers(
   int requiredItemLineNumber,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

List<int>^ GetPickedItemsLineNumbers(
   int requiredItemLineNumber,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

requiredItemLineNumber

Type: int

The U_LineNum value of a Required Item.

docEntry

Type: int

A Pick Receipt document's DocEntry value.

Return Value

Type: List<int>

A generic collection of U_LineNum values of CT_PF_PRE2 table retrieved from CT_PF_PRE3 table.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickReceiptRequiredItems Interface
IPickReceiptRequiredItems Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IPrintLabelDefinition | Print label definition object
Public interface | IPrintLabelDefinitionLabelFields | Label fields of print label definition object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IPrintLabelDefinition Interface

Members See Also

Print label definition object

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IPrintLabelDefinition
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IPrintLabelDefinition : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IPrintLabelDefinition : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IPrintLabelDefinition
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OPLD
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition Members

IPrintLabelDefinition Interface Methods Properties See Also

Print label definition object

The following tables list the members exposed by the IPrintLabelDefinition type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_DefCode | definition code
Public property | U_LblCode | assigned label code
Public property | U_PrtCode | assigned printer code
Public property | U_Quantity | number of labels to print each time
Public property | U_UserQueryName | Name of user query, which is used for getting data for label
Public property | U_UsrQueryCategory | User Query category
Public property | U_UsrQueryIntKey | user query internal key
Public property | U_UsrQueryObjType | user query object type, for which labels could be printed
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByDefCode | get print label deinition by its code(U_DefCode)
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IPrintLabelDefinition Interface
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition Properties

IPrintLabelDefinition Interface See Also

The following tables list the members exposed by the IPrintLabelDefinition type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_DefCode | definition code
Public property | U_LblCode | assigned label code
Public property | U_PrtCode | assigned printer code
Public property | U_Quantity | number of labels to print each time
Public property | U_UserQueryName | Name of user query, which is used for getting data for label
Public property | U_UsrQueryCategory | User Query category
Public property | U_UsrQueryIntKey | user query internal key
Public property | U_UsrQueryObjType | user query object type, for which labels could be printed
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IPrintLabelDefinition Interface
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.U_DefCode Property

definition code

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DefCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DefCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DefCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DefCode() : String;
function set U_DefCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.U_LblCode Property

assigned label code

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LblCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LblCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LblCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LblCode() : String;
function set U_LblCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.U_PrtCode Property

assigned printer code

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrtCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrtCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrtCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrtCode() : String;
function set U_PrtCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.U_Quantity Property

number of labels to print each time

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_Quantity {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : int;
function set U_Quantity(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.U_UserQueryName Property

Name of user query, which is used for getting data for label

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UserQueryName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UserQueryName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UserQueryName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UserQueryName() : String;
function set U_UserQueryName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.U_UsrQueryCategory Property

User Query category

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UsrQueryCategory() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_UsrQueryCategory {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_UsrQueryCategory {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UsrQueryCategory() : int;
function set U_UsrQueryCategory(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.U_UsrQueryIntKey Property

user query internal key

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UsrQueryIntKey() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_UsrQueryIntKey {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_UsrQueryIntKey {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UsrQueryIntKey() : int;
function set U_UsrQueryIntKey(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.U_UsrQueryObjType Property

user query object type, for which labels could be printed

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UsrQueryObjType() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_UsrQueryObjType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_UsrQueryObjType {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UsrQueryObjType() : int;
function set U_UsrQueryObjType(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition Methods

IPrintLabelDefinition Interface See Also

The following tables list the members exposed by the IPrintLabelDefinition type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByDefCode | get print label deinition by its code(U_DefCode)
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IPrintLabelDefinition Interface
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinition.GetByDefCode Method

get print label deinition by its code(U_DefCode)

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByDefCode( _
   ByVal defCode As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByDefCode(
   string defCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByDefCode(
   String^ defCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByDefCode(
    defCode : String
) : int;
This language is not supported or no code example is available.

Parameters

defCode

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinition Interface
IPrintLabelDefinition Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinitionLabelFields Interface

Members See Also

Label fields of print label definition object

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IPrintLabelDefinitionLabelFields
    Inherits IUDOChildBean, _
             IEnumerable(Of IPrintLabelDefinitionLabelFields)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IPrintLabelDefinitionLabelFields : IUDOChildBean,
   IEnumerable<IPrintLabelDefinitionLabelFields>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IPrintLabelDefinitionLabelFields : public IUDOChildBean^,
   public IEnumerable<IPrintLabelDefinitionLabelFields^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_PLD1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinitionLabelFields Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinitionLabelFields Members

IPrintLabelDefinitionLabelFields Interface Methods Properties See Also

Label fields of print label definition object

The following tables list the members exposed by the IPrintLabelDefinitionLabelFields type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LabelDFFieldType |
Public property | U_LabelDFName |
Public property | U_LabelDFObjectType |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPrintLabelDefinitionLabelFields Interface
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinitionLabelFields Properties

IPrintLabelDefinitionLabelFields Interface See Also

The following tables list the members exposed by the IPrintLabelDefinitionLabelFields type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LabelDFFieldType |
Public property | U_LabelDFName |
Public property | U_LabelDFObjectType |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Top
See Also

Reference

IPrintLabelDefinitionLabelFields Interface
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinitionLabelFields.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinitionLabelFields Interface
IPrintLabelDefinitionLabelFields Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinitionLabelFields.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinitionLabelFields Interface
IPrintLabelDefinitionLabelFields Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinitionLabelFields.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinitionLabelFields Interface
IPrintLabelDefinitionLabelFields Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinitionLabelFields.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinitionLabelFields Interface
IPrintLabelDefinitionLabelFields Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinitionLabelFields.U_LabelDFFieldType Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LabelDFFieldType() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_LabelDFFieldType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_LabelDFFieldType {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LabelDFFieldType() : int;
function set U_LabelDFFieldType(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinitionLabelFields Interface
IPrintLabelDefinitionLabelFields Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinitionLabelFields.U_LabelDFName Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LabelDFName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LabelDFName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LabelDFName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LabelDFName() : String;
function set U_LabelDFName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinitionLabelFields Interface
IPrintLabelDefinitionLabelFields Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinitionLabelFields.U_LabelDFObjectType Property

Namespace: CompuTec.ProcessForce.API.Documents.PrintLabelDefinition
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LabelDFObjectType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LabelDFObjectType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LabelDFObjectType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LabelDFObjectType() : String;
function set U_LabelDFObjectType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrintLabelDefinitionLabelFields Interface
IPrintLabelDefinitionLabelFields Members
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


IPrintLabelDefinitionLabelFields Methods

IPrintLabelDefinitionLabelFields Interface See Also

The following tables list the members exposed by the IPrintLabelDefinitionLabelFields type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPrintLabelDefinitionLabelFields Interface
CompuTec.ProcessForce.API.Documents.PrintLabelDefinition Namespace


CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IPrinterMasterData | Printer object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IPrinterMasterData Interface

Members See Also

Printer object

Namespace: CompuTec.ProcessForce.API.Documents.PrinterMasterData
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "PrinterMasterData", TableName = "@CT_PF_OPMD")> _
Public Interface IPrinterMasterData
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "PrinterMasterData", TableName = "@CT_PF_OPMD")]
public interface IPrinterMasterData : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "PrinterMasterData", TableName = "@CT_PF_OPMD")]
public interface class IPrinterMasterData : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "PrinterMasterData", TableName = "@CT_PF_OPMD")
interface IPrinterMasterData
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OPMD
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrinterMasterData Members
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


IPrinterMasterData Members

IPrinterMasterData Interface Methods Properties See Also

Printer object

The following tables list the members exposed by the IPrinterMasterData type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_PrinterAddress | printer address: e.g. \\127.0.0.1\printer
Public property | U_PrinterCode | printer code
Public property | U_PrinterName | printer name
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IPrinterMasterData Interface
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


IPrinterMasterData Properties

IPrinterMasterData Interface See Also

The following tables list the members exposed by the IPrinterMasterData type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_PrinterAddress | printer address: e.g. \\127.0.0.1\printer
Public property | U_PrinterCode | printer code
Public property | U_PrinterName | printer name
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IPrinterMasterData Interface
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


IPrinterMasterData.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.PrinterMasterData
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrinterMasterData Interface
IPrinterMasterData Members
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


IPrinterMasterData.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.PrinterMasterData
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrinterMasterData Interface
IPrinterMasterData Members
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


IPrinterMasterData.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.PrinterMasterData
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrinterMasterData Interface
IPrinterMasterData Members
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


IPrinterMasterData.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.PrinterMasterData
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrinterMasterData Interface
IPrinterMasterData Members
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


IPrinterMasterData.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.PrinterMasterData
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrinterMasterData Interface
IPrinterMasterData Members
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


IPrinterMasterData.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.PrinterMasterData
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrinterMasterData Interface
IPrinterMasterData Members
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


IPrinterMasterData.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.PrinterMasterData
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrinterMasterData Interface
IPrinterMasterData Members
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


IPrinterMasterData.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.PrinterMasterData
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrinterMasterData Interface
IPrinterMasterData Members
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


IPrinterMasterData.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.PrinterMasterData
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrinterMasterData Interface
IPrinterMasterData Members
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


IPrinterMasterData.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.PrinterMasterData
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrinterMasterData Interface
IPrinterMasterData Members
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


IPrinterMasterData.U_PrinterAddress Property

printer address: e.g. \\127.0.0.1\printer

Namespace: CompuTec.ProcessForce.API.Documents.PrinterMasterData
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrinterAddress() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrinterAddress {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrinterAddress {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrinterAddress() : String;
function set U_PrinterAddress(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrinterMasterData Interface
IPrinterMasterData Members
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


IPrinterMasterData.U_PrinterCode Property

printer code

Namespace: CompuTec.ProcessForce.API.Documents.PrinterMasterData
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrinterCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrinterCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrinterCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrinterCode() : String;
function set U_PrinterCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrinterMasterData Interface
IPrinterMasterData Members
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


IPrinterMasterData.U_PrinterName Property

printer name

Namespace: CompuTec.ProcessForce.API.Documents.PrinterMasterData
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrinterName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrinterName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrinterName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrinterName() : String;
function set U_PrinterName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrinterMasterData Interface
IPrinterMasterData Members
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


IPrinterMasterData.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.PrinterMasterData
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrinterMasterData Interface
IPrinterMasterData Members
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


IPrinterMasterData.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.PrinterMasterData
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrinterMasterData Interface
IPrinterMasterData Members
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


IPrinterMasterData.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.PrinterMasterData
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPrinterMasterData Interface
IPrinterMasterData Members
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


IPrinterMasterData Methods

IPrinterMasterData Interface See Also

The following tables list the members exposed by the IPrinterMasterData type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IPrinterMasterData Interface
CompuTec.ProcessForce.API.Documents.PrinterMasterData Namespace


CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ITimeQuantityRegistration |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ITimeQuantityRegistration Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "TimeQuantityRegistration", TableName = "@CT_PF_OTQY", ExludedHttpMethods = "DELETE,PUT")> _
Public Interface ITimeQuantityRegistration
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "TimeQuantityRegistration", TableName = "@CT_PF_OTQY", ExludedHttpMethods = "DELETE,PUT")]
public interface ITimeQuantityRegistration : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "TimeQuantityRegistration", TableName = "@CT_PF_OTQY", ExludedHttpMethods = "DELETE,PUT")]
public interface class ITimeQuantityRegistration : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "TimeQuantityRegistration", TableName = "@CT_PF_OTQY", ExludedHttpMethods = "DELETE,PUT")
interface ITimeQuantityRegistration
   implements IUDOBean
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeQuantityRegistration Members
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration Members

ITimeQuantityRegistration Interface Methods Properties See Also

The following tables list the members exposed by the ITimeQuantityRegistration type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Name |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_BaseEntry |
Public property | U_BaseLine |
Public property | U_BrowseBy |
Public property | U_EmpID |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Quantity |
Public property | U_ReasonCode |
Public property | U_ReasonType |
Public property | U_Remarks |
Public property | U_SourceEntry |
Public property | U_SourceLine |
Public property | U_SourceType |
Public property | U_TileCode |
Public property | U_Type |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ITimeQuantityRegistration Interface
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration Properties

ITimeQuantityRegistration Interface See Also

The following tables list the members exposed by the ITimeQuantityRegistration type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Name |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_BaseEntry |
Public property | U_BaseLine |
Public property | U_BrowseBy |
Public property | U_EmpID |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Quantity |
Public property | U_ReasonCode |
Public property | U_ReasonType |
Public property | U_Remarks |
Public property | U_SourceEntry |
Public property | U_SourceLine |
Public property | U_SourceType |
Public property | U_TileCode |
Public property | U_Type |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
See Also

Reference

ITimeQuantityRegistration Interface
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
int Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property int Code {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : int;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeQuantityRegistration Interface
ITimeQuantityRegistration Members
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
function set Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeQuantityRegistration Interface
ITimeQuantityRegistration Members
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration.U_BaseEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseEntry() : int;
function set U_BaseEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeQuantityRegistration Interface
ITimeQuantityRegistration Members
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration.U_BaseLine Property

Namespace: CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLine() : int;
function set U_BaseLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeQuantityRegistration Interface
ITimeQuantityRegistration Members
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration.U_BrowseBy Property

Namespace: CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BrowseBy() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BrowseBy {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BrowseBy {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BrowseBy() : String;
function set U_BrowseBy(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeQuantityRegistration Interface
ITimeQuantityRegistration Members
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration.U_EmpID Property

Namespace: CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EmpID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_EmpID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_EmpID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EmpID() : int;
function set U_EmpID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeQuantityRegistration Interface
ITimeQuantityRegistration Members
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeQuantityRegistration Interface
ITimeQuantityRegistration Members
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeQuantityRegistration Interface
ITimeQuantityRegistration Members
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration.U_Quantity Property

Namespace: CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeQuantityRegistration Interface
ITimeQuantityRegistration Members
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration.U_ReasonCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReasonCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ReasonCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ReasonCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReasonCode() : String;
function set U_ReasonCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeQuantityRegistration Interface
ITimeQuantityRegistration Members
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration.U_ReasonType Property

Namespace: CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReasonType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ReasonType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ReasonType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReasonType() : String;
function set U_ReasonType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeQuantityRegistration Interface
ITimeQuantityRegistration Members
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeQuantityRegistration Interface
ITimeQuantityRegistration Members
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration.U_SourceEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SourceEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SourceEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SourceEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SourceEntry() : int;
function set U_SourceEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeQuantityRegistration Interface
ITimeQuantityRegistration Members
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration.U_SourceLine Property

Namespace: CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SourceLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SourceLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SourceLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SourceLine() : int;
function set U_SourceLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeQuantityRegistration Interface
ITimeQuantityRegistration Members
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration.U_SourceType Property

Namespace: CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SourceType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SourceType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SourceType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SourceType() : String;
function set U_SourceType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeQuantityRegistration Interface
ITimeQuantityRegistration Members
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration.U_TileCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TileCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TileCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TileCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TileCode() : String;
function set U_TileCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeQuantityRegistration Interface
ITimeQuantityRegistration Members
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration.U_Type Property

Namespace: CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Type() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Type {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Type {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Type() : String;
function set U_Type(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeQuantityRegistration Interface
ITimeQuantityRegistration Members
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


ITimeQuantityRegistration Methods

ITimeQuantityRegistration Interface See Also

The following tables list the members exposed by the ITimeQuantityRegistration type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ITimeQuantityRegistration Interface
CompuTec.ProcessForce.API.Documents.Production_Planing.Manufacturing_Order.TimeQuantityRegistration Namespace


CompuTec.ProcessForce.API.Documents.QualityControl Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | SerialNumberData |
Top
Enumerations
 | Name | Description
Public enumeration | UserDataSourceType |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


SerialNumberData Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SerialNumberData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SerialNumberData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SerialNumberData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SerialNumberData
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.QualityControl.SerialNumberData
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SerialNumberData Members
CompuTec.ProcessForce.API.Documents.QualityControl Namespace


SerialNumberData Members

SerialNumberData Class Methods Properties See Also

The following tables list the members exposed by the SerialNumberData type.

Properties
 | Name | Description
Public property | BatchId |
Public property | InternalNumber |
Public property | SupplementalNumber |
Public property | SystemNumber |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SerialNumberData Class
CompuTec.ProcessForce.API.Documents.QualityControl Namespace


SerialNumberData Properties

SerialNumberData Class See Also

The following tables list the members exposed by the SerialNumberData type.

Properties
 | Name | Description
Public property | BatchId |
Public property | InternalNumber |
Public property | SupplementalNumber |
Public property | SystemNumber |
Top
See Also

Reference

SerialNumberData Class
CompuTec.ProcessForce.API.Documents.QualityControl Namespace


SerialNumberData.BatchId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property BatchId() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string BatchId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ BatchId {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get BatchId() : String;
public function set BatchId(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SerialNumberData Class
SerialNumberData Members
CompuTec.ProcessForce.API.Documents.QualityControl Namespace


SerialNumberData.InternalNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InternalNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string InternalNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ InternalNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InternalNumber() : String;
public function set InternalNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SerialNumberData Class
SerialNumberData Members
CompuTec.ProcessForce.API.Documents.QualityControl Namespace


SerialNumberData.SupplementalNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SupplementalNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string SupplementalNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ SupplementalNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SupplementalNumber() : String;
public function set SupplementalNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SerialNumberData Class
SerialNumberData Members
CompuTec.ProcessForce.API.Documents.QualityControl Namespace


SerialNumberData.SystemNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SystemNumber() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int SystemNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int SystemNumber {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SystemNumber() : int;
public function set SystemNumber(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SerialNumberData Class
SerialNumberData Members
CompuTec.ProcessForce.API.Documents.QualityControl Namespace


SerialNumberData Methods

SerialNumberData Class See Also

The following tables list the members exposed by the SerialNumberData type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SerialNumberData Class
CompuTec.ProcessForce.API.Documents.QualityControl Namespace


UserDataSourceType Enumeration

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Unknown |
TestProperty |
ItemProperty |
ItemOrResource |
Defect |
Word |
Reason |
See Also

Reference

CompuTec.ProcessForce.API.Documents.QualityControl Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IComplaint | Complaints document
Public interface | IComplaintAttachments | Attachment for complaints document
Public interface | IComplaintBatches | Batches for complaints document
Public interface | IComplaintReasons | Reasons for complaints document
Public interface | IComplaintSerialNumbers | Serial numbers for complaints document
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IComplaint Interface

Members See Also

Complaints document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "Complaint", TableName = "@CT_PF_OCPL")> _
Public Interface IComplaint
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Complaint", TableName = "@CT_PF_OCPL")]
public interface IComplaint : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Complaint", TableName = "@CT_PF_OCPL")]
public interface class IComplaint : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "Complaint", TableName = "@CT_PF_OCPL")
interface IComplaint
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OCPL
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint Members

IComplaint Interface Methods Properties See Also

Complaints document

The following tables list the members exposed by the IComplaint type.

Properties
 | Name | Description
Public property | Attachments |
Public property | Batches |
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_BpContactName |
Public property | DS_BpName |
Public property | DS_ItemName |
Public property | DS_OriginatorFirstName |
Public property | DS_OriginatorFullName |
Public property | DS_OriginatorId |
Public property | DS_OriginatorLastName |
Public property | DS_OwnerFirstName |
Public property | DS_OwnerFullName |
Public property | DS_OwnerId |
Public property | DS_OwnerLastName |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Reasons |
Public property | SerialNumbers |
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ActionRemarks |
Public property | U_ActionWhsCode |
Public property | U_BpCode |
Public property | U_BpContactCode |
Public property | U_Closed |
Public property | U_ComplaintNo |
Public property | U_ComplaintType |
Public property | U_ConPerNam |
Public property | U_Created |
Public property | U_Delivery |
Public property | U_DocNo |
Public property | U_Footer |
Public property | U_Header |
Public property | U_Inspection |
Public property | U_ItemCode |
Public property | U_Notes |
Public property | U_OnHold |
Public property | U_OriginNam |
Public property | U_Originator |
Public property | U_Owner |
Public property | U_OwnerNam |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_PrjCode |
Public property | U_ProdRecall |
Public property | U_QcTest |
Public property | U_QualityTest |
Public property | U_Quantity |
Public property | U_Received |
Public property | U_Request |
Public property | U_RevCode |
Public property | U_Started |
Public property | U_Status |
Public property | U_TransRemarks |
Public property | U_TransType |
Public property | U_WhsCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | GetNextComplaintNo | Gets the Complaint No. value assigned for a next Complaint document.
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | SetDefaultSeries | Sets the default series for Complaint document.
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IComplaint Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint Properties

IComplaint Interface See Also

The following tables list the members exposed by the IComplaint type.

Properties
 | Name | Description
Public property | Attachments |
Public property | Batches |
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_BpContactName |
Public property | DS_BpName |
Public property | DS_ItemName |
Public property | DS_OriginatorFirstName |
Public property | DS_OriginatorFullName |
Public property | DS_OriginatorId |
Public property | DS_OriginatorLastName |
Public property | DS_OwnerFirstName |
Public property | DS_OwnerFullName |
Public property | DS_OwnerId |
Public property | DS_OwnerLastName |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Reasons |
Public property | SerialNumbers |
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ActionRemarks |
Public property | U_ActionWhsCode |
Public property | U_BpCode |
Public property | U_BpContactCode |
Public property | U_Closed |
Public property | U_ComplaintNo |
Public property | U_ComplaintType |
Public property | U_ConPerNam |
Public property | U_Created |
Public property | U_Delivery |
Public property | U_DocNo |
Public property | U_Footer |
Public property | U_Header |
Public property | U_Inspection |
Public property | U_ItemCode |
Public property | U_Notes |
Public property | U_OnHold |
Public property | U_OriginNam |
Public property | U_Originator |
Public property | U_Owner |
Public property | U_OwnerNam |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_PrjCode |
Public property | U_ProdRecall |
Public property | U_QcTest |
Public property | U_QualityTest |
Public property | U_Quantity |
Public property | U_Received |
Public property | U_Request |
Public property | U_RevCode |
Public property | U_Started |
Public property | U_Status |
Public property | U_TransRemarks |
Public property | U_TransType |
Public property | U_WhsCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IComplaint Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.Attachments Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Attachments() As IComplaintAttachments
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IComplaintAttachments Attachments {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IComplaintAttachments^ Attachments {
 IComplaintAttachments^ get( );
 void set(
   IComplaintAttachments^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Attachments() : IComplaintAttachments;
function set Attachments(value : IComplaintAttachments);
This language is not supported or no code example is available.

Property Value

Type: IComplaintAttachments
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.Batches Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Batches() As IComplaintBatches
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IComplaintBatches Batches {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IComplaintBatches^ Batches {
 IComplaintBatches^ get( );
 void set(
   IComplaintBatches^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Batches() : IComplaintBatches;
function set Batches(value : IComplaintBatches);
This language is not supported or no code example is available.

Property Value

Type: IComplaintBatches
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.DS_BpContactName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_BpContactName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_BpContactName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_BpContactName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_BpContactName() : String;

   AppEnginePropertyIgnore()
function set DS_BpContactName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.DS_BpName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_BpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_BpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_BpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_BpName() : String;

   AppEnginePropertyIgnore()
function set DS_BpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.DS_ItemName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemName() : String;

   AppEnginePropertyIgnore()
function set DS_ItemName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.DS_OriginatorFirstName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_OriginatorFirstName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_OriginatorFirstName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_OriginatorFirstName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_OriginatorFirstName() : String;

   AppEnginePropertyIgnore()
function set DS_OriginatorFirstName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.DS_OriginatorFullName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_OriginatorFullName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_OriginatorFullName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_OriginatorFullName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_OriginatorFullName() : String;

   AppEnginePropertyIgnore()
function set DS_OriginatorFullName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.DS_OriginatorId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_OriginatorId() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_OriginatorId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_OriginatorId {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_OriginatorId() : String;

   AppEnginePropertyIgnore()
function set DS_OriginatorId(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.DS_OriginatorLastName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_OriginatorLastName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_OriginatorLastName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_OriginatorLastName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_OriginatorLastName() : String;

   AppEnginePropertyIgnore()
function set DS_OriginatorLastName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.DS_OwnerFirstName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_OwnerFirstName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_OwnerFirstName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_OwnerFirstName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_OwnerFirstName() : String;

   AppEnginePropertyIgnore()
function set DS_OwnerFirstName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.DS_OwnerFullName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_OwnerFullName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_OwnerFullName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_OwnerFullName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_OwnerFullName() : String;

   AppEnginePropertyIgnore()
function set DS_OwnerFullName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.DS_OwnerId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_OwnerId() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_OwnerId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_OwnerId {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_OwnerId() : String;

   AppEnginePropertyIgnore()
function set DS_OwnerId(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.DS_OwnerLastName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_OwnerLastName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_OwnerLastName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_OwnerLastName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_OwnerLastName() : String;

   AppEnginePropertyIgnore()
function set DS_OwnerLastName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.DocNum Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.Handwrtten Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Handwrtten() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Handwrtten {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Handwrtten {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Handwrtten() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.Instance Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Instance() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Instance {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Instance {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Instance() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.Period Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Period() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Period {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Period {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Period() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.Reasons Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Reasons() As IComplaintReasons
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IComplaintReasons Reasons {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IComplaintReasons^ Reasons {
 IComplaintReasons^ get( );
 void set(
   IComplaintReasons^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Reasons() : IComplaintReasons;
function set Reasons(value : IComplaintReasons);
This language is not supported or no code example is available.

Property Value

Type: IComplaintReasons
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.SerialNumbers Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property SerialNumbers() As IComplaintSerialNumbers
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IComplaintSerialNumbers SerialNumbers {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IComplaintSerialNumbers^ SerialNumbers {
 IComplaintSerialNumbers^ get( );
 void set(
   IComplaintSerialNumbers^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get SerialNumbers() : IComplaintSerialNumbers;
function set SerialNumbers(value : IComplaintSerialNumbers);
This language is not supported or no code example is available.

Property Value

Type: IComplaintSerialNumbers
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.Series Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Series() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Series {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Series {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Series() : int;
function set Series(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.Status Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Status {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Status {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Status() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_ActionRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActionRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ActionRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ActionRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActionRemarks() : String;
function set U_ActionRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_ActionWhsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActionWhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ActionWhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ActionWhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActionWhsCode() : String;
function set U_ActionWhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_BpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BpCode() : String;
function set U_BpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_BpContactCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BpContactCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BpContactCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BpContactCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BpContactCode() : int;
function set U_BpContactCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_Closed Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Closed() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Closed {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Closed {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Closed() : DateTime;
function set U_Closed(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_ComplaintNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ComplaintNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ComplaintNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ComplaintNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ComplaintNo() : int;
function set U_ComplaintNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_ComplaintType Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ComplaintType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ComplaintType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ComplaintType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ComplaintType() : String;
function set U_ComplaintType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_ConPerNam Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ConPerNam() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ConPerNam {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ConPerNam {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ConPerNam() : String;
function set U_ConPerNam(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_Created Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_Created() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
DateTime U_Created {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property DateTime U_Created {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_Created() : DateTime;

   AppEngineProperty(Required = true)
function set U_Created(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_Delivery Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Delivery() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Delivery {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Delivery {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Delivery() : DateTime;
function set U_Delivery(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_DocNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DocNo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DocNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DocNo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DocNo() : String;
function set U_DocNo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_Footer Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Footer() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Footer {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Footer {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Footer() : String;
function set U_Footer(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_Header Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Header() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Header {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Header {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Header() : String;
function set U_Header(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_Inspection Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Inspection() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Inspection {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Inspection {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Inspection() : DateTime;
function set U_Inspection(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_Notes Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Notes() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Notes {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Notes {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Notes() : String;
function set U_Notes(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_OnHold Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OnHold() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_OnHold {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_OnHold {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OnHold() : DateTime;
function set U_OnHold(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_OriginNam Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OriginNam() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OriginNam {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OriginNam {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OriginNam() : String;
function set U_OriginNam(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_Originator Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Originator() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_Originator {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_Originator {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Originator() : int;
function set U_Originator(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_Owner Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Owner() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_Owner {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_Owner {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Owner() : int;
function set U_Owner(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_OwnerNam Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OwnerNam() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OwnerNam {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OwnerNam {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OwnerNam() : String;
function set U_OwnerNam(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_PrjCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrjCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrjCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrjCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrjCode() : String;
function set U_PrjCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_ProdRecall Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ProdRecall() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ProdRecall {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ProdRecall {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ProdRecall() : String;
function set U_ProdRecall(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_QcTest Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QcTest() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_QcTest {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_QcTest {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QcTest() : String;
function set U_QcTest(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_QualityTest Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QualityTest() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_QualityTest {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_QualityTest {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QualityTest() : String;
function set U_QualityTest(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_Quantity Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_Received Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Received() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Received {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Received {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Received() : DateTime;
function set U_Received(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_Request Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Request() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Request {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Request {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Request() : DateTime;
function set U_Request(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_RevCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevCode() : String;
function set U_RevCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_Started Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Started() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Started {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Started {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Started() : DateTime;
function set U_Started(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_Status Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_Status {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_Status() : String;

   AppEngineProperty(Required = true)
function set U_Status(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_TransRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TransRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TransRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TransRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TransRemarks() : String;
function set U_TransRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_TransType Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TransType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TransType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TransType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TransType() : String;
function set U_TransType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.U_WhsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint Methods

IComplaint Interface See Also

The following tables list the members exposed by the IComplaint type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | GetNextComplaintNo | Gets the Complaint No. value assigned for a next Complaint document.
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | SetDefaultSeries | Sets the default series for Complaint document.
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IComplaint Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.GetNextComplaintNo Method

Gets the Complaint No. value assigned for a next Complaint document.

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetNextComplaintNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetNextComplaintNo()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetNextComplaintNo()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetNextComplaintNo() : int;
This language is not supported or no code example is available.

Return Value

Type: int

The next Complaint No. value for a Complaint document..

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaint.SetDefaultSeries Method

Sets the default series for Complaint document.

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub SetDefaultSeries()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void SetDefaultSeries()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void SetDefaultSeries()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function SetDefaultSeries();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaint Interface
IComplaint Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintAttachments Interface

Members See Also

Attachment for complaints document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IComplaintAttachments
    Inherits IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IComplaintAttachments : IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IComplaintAttachments : public IUDOChildBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IComplaintAttachments
   implements IUDOChildBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_CPL4
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintAttachments Members

IComplaintAttachments Interface Methods Properties See Also

Attachment for complaints document

The following tables list the members exposed by the IComplaintAttachments type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AttDate |
Public property | U_FileName |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Path |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

IComplaintAttachments Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintAttachments Properties

IComplaintAttachments Interface See Also

The following tables list the members exposed by the IComplaintAttachments type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AttDate |
Public property | U_FileName |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Path |
Public property | VisOrder |
Top
See Also

Reference

IComplaintAttachments Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintAttachments.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintAttachments Interface
IComplaintAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintAttachments.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintAttachments Interface
IComplaintAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintAttachments.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintAttachments Interface
IComplaintAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintAttachments.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintAttachments Interface
IComplaintAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintAttachments.U_AttDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_AttDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_AttDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttDate() : DateTime;
function set U_AttDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintAttachments Interface
IComplaintAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintAttachments.U_FileName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FileName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FileName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FileName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FileName() : String;
function set U_FileName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintAttachments Interface
IComplaintAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintAttachments.U_Path Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Path() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Path {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Path {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Path() : String;
function set U_Path(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintAttachments Interface
IComplaintAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintAttachments.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintAttachments Interface
IComplaintAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintAttachments Methods

IComplaintAttachments Interface See Also

The following tables list the members exposed by the IComplaintAttachments type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

IComplaintAttachments Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintBatches Interface

Members See Also

Batches for complaints document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IComplaintBatches
    Inherits IUDOChildBean, _
             IEnumerable(Of IComplaintBatches)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IComplaintBatches : IUDOChildBean,
   IEnumerable<IComplaintBatches>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IComplaintBatches : public IUDOChildBean^,
   public IEnumerable<IComplaintBatches^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_CPL2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintBatches Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintBatches Members

IComplaintBatches Interface Methods Properties See Also

Batches for complaints document

The following tables list the members exposed by the IComplaintBatches type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Batch |
Public property | U_ComplaintNo |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IComplaintBatches Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintBatches Properties

IComplaintBatches Interface See Also

The following tables list the members exposed by the IComplaintBatches type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Batch |
Public property | U_ComplaintNo |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | VisOrder |
Top
See Also

Reference

IComplaintBatches Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintBatches.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintBatches Interface
IComplaintBatches Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintBatches.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintBatches Interface
IComplaintBatches Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintBatches.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintBatches Interface
IComplaintBatches Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintBatches.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintBatches Interface
IComplaintBatches Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintBatches.U_Batch Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Batch() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Batch {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Batch {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Batch() : String;
function set U_Batch(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintBatches Interface
IComplaintBatches Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintBatches.U_ComplaintNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ComplaintNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ComplaintNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ComplaintNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ComplaintNo() : int;
function set U_ComplaintNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintBatches Interface
IComplaintBatches Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintBatches.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintBatches Interface
IComplaintBatches Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintBatches Methods

IComplaintBatches Interface See Also

The following tables list the members exposed by the IComplaintBatches type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IComplaintBatches Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintReasons Interface

Members See Also

Reasons for complaints document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IComplaintReasons
    Inherits IUDOChildBean, _
             IEnumerable(Of IComplaintReasons)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IComplaintReasons : IUDOChildBean,
   IEnumerable<IComplaintReasons>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IComplaintReasons : public IUDOChildBean^,
   public IEnumerable<IComplaintReasons^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_CPL1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintReasons Members

IComplaintReasons Interface Methods Properties See Also

Reasons for complaints document

The following tables list the members exposed by the IComplaintReasons type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_ReasonTableCode |
Public property | DS_RsnName |
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ComplaintNo |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_RsnCode |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IComplaintReasons Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintReasons Properties

IComplaintReasons Interface See Also

The following tables list the members exposed by the IComplaintReasons type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_ReasonTableCode |
Public property | DS_RsnName |
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ComplaintNo |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_RsnCode |
Public property | VisOrder |
Top
See Also

Reference

IComplaintReasons Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintReasons.DS_ReasonTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ReasonTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ReasonTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ReasonTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ReasonTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_ReasonTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReasons Interface
IComplaintReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintReasons.DS_RsnName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_RsnName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_RsnName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_RsnName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_RsnName() : String;

   AppEnginePropertyIgnore()
function set DS_RsnName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReasons Interface
IComplaintReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintReasons.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReasons Interface
IComplaintReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintReasons.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReasons Interface
IComplaintReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintReasons.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReasons Interface
IComplaintReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintReasons.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReasons Interface
IComplaintReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintReasons.U_ComplaintNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ComplaintNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ComplaintNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ComplaintNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ComplaintNo() : int;
function set U_ComplaintNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReasons Interface
IComplaintReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintReasons.U_RsnCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RsnCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RsnCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RsnCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RsnCode() : String;
function set U_RsnCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReasons Interface
IComplaintReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintReasons.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReasons Interface
IComplaintReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintReasons Methods

IComplaintReasons Interface See Also

The following tables list the members exposed by the IComplaintReasons type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IComplaintReasons Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintSerialNumbers Interface

Members See Also

Serial numbers for complaints document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IComplaintSerialNumbers
    Inherits IUDOChildBean, _
             IEnumerable(Of IComplaintSerialNumbers)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IComplaintSerialNumbers : IUDOChildBean,
   IEnumerable<IComplaintSerialNumbers>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IComplaintSerialNumbers : public IUDOChildBean^,
   public IEnumerable<IComplaintSerialNumbers^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_CPL3
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintSerialNumbers Members

IComplaintSerialNumbers Interface Methods Properties See Also

Serial numbers for complaints document

The following tables list the members exposed by the IComplaintSerialNumbers type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_BatchNumber |
Public property | DS_InternalSerialNumber |
Public property | DS_ManufacturerSerialNumber |
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ComplaintNo |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_SysNumber |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IComplaintSerialNumbers Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintSerialNumbers Properties

IComplaintSerialNumbers Interface See Also

The following tables list the members exposed by the IComplaintSerialNumbers type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_BatchNumber |
Public property | DS_InternalSerialNumber |
Public property | DS_ManufacturerSerialNumber |
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ComplaintNo |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_SysNumber |
Public property | VisOrder |
Top
See Also

Reference

IComplaintSerialNumbers Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintSerialNumbers.DS_BatchNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_BatchNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_BatchNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_BatchNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_BatchNumber() : String;

   AppEnginePropertyIgnore()
function set DS_BatchNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintSerialNumbers Interface
IComplaintSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintSerialNumbers.DS_InternalSerialNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_InternalSerialNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_InternalSerialNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_InternalSerialNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_InternalSerialNumber() : String;

   AppEnginePropertyIgnore()
function set DS_InternalSerialNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintSerialNumbers Interface
IComplaintSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintSerialNumbers.DS_ManufacturerSerialNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ManufacturerSerialNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ManufacturerSerialNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ManufacturerSerialNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ManufacturerSerialNumber() : String;

   AppEnginePropertyIgnore()
function set DS_ManufacturerSerialNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintSerialNumbers Interface
IComplaintSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintSerialNumbers.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintSerialNumbers Interface
IComplaintSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintSerialNumbers.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintSerialNumbers Interface
IComplaintSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintSerialNumbers.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintSerialNumbers Interface
IComplaintSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintSerialNumbers.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintSerialNumbers Interface
IComplaintSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintSerialNumbers.U_ComplaintNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ComplaintNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ComplaintNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ComplaintNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ComplaintNo() : int;
function set U_ComplaintNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintSerialNumbers Interface
IComplaintSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintSerialNumbers.U_SysNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SysNumber() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SysNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SysNumber {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SysNumber() : int;
function set U_SysNumber(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintSerialNumbers Interface
IComplaintSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintSerialNumbers.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Complaint
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintSerialNumbers Interface
IComplaintSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


IComplaintSerialNumbers Methods

IComplaintSerialNumbers Interface See Also

The following tables list the members exposed by the IComplaintSerialNumbers type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IComplaintSerialNumbers Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Complaint Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IComplaintGroup | Complaint group object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IComplaintGroup Interface

Members See Also

Complaint group object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ComplaintGroup", TableName = "@CT_PF_OCGR")> _
Public Interface IComplaintGroup
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ComplaintGroup", TableName = "@CT_PF_OCGR")]
public interface IComplaintGroup : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ComplaintGroup", TableName = "@CT_PF_OCGR")]
public interface class IComplaintGroup : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ComplaintGroup", TableName = "@CT_PF_OCGR")
interface IComplaintGroup
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OCGR
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup Members

IComplaintGroup Interface Methods Properties See Also

Complaint group object

The following tables list the members exposed by the IComplaintGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Customer |
Public property | U_GrpCode |
Public property | U_GrpName |
Public property | U_Internal |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | U_Supplier |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IComplaintGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup Properties

IComplaintGroup Interface See Also

The following tables list the members exposed by the IComplaintGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Customer |
Public property | U_GrpCode |
Public property | U_GrpName |
Public property | U_Internal |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | U_Supplier |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IComplaintGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.U_Customer Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Customer() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Customer {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Customer {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Customer() : String;
function set U_Customer(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.U_GrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_GrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_GrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_GrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_GrpCode() : String;

   AppEngineProperty(Required = true)
function set U_GrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.U_GrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpName() : String;
function set U_GrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.U_Internal Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Internal() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Internal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Internal {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Internal() : String;
function set U_Internal(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.U_Supplier Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Supplier() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Supplier {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Supplier {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Supplier() : String;
function set U_Supplier(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintGroup Interface
IComplaintGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


IComplaintGroup Methods

IComplaintGroup Interface See Also

The following tables list the members exposed by the IComplaintGroup type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IComplaintGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintGroup Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IComplaintReason | Complaint reason object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IComplaintReason Interface

Members See Also

Complaint reason object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ComplaintReason", TableName = "@CT_PF_OCRS")> _
Public Interface IComplaintReason
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ComplaintReason", TableName = "@CT_PF_OCRS")]
public interface IComplaintReason : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ComplaintReason", TableName = "@CT_PF_OCRS")]
public interface class IComplaintReason : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ComplaintReason", TableName = "@CT_PF_OCRS")
interface IComplaintReason
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OCRS
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason Members

IComplaintReason Interface Methods Properties See Also

Complaint reason object

The following tables list the members exposed by the IComplaintReason type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_GroupName |
Public property | DS_GroupTableCode |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Customer |
Public property | U_GrpCode |
Public property | U_Internal |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | U_RsnCode |
Public property | U_RsnName |
Public property | U_Supplier |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IComplaintReason Interface
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason Properties

IComplaintReason Interface See Also

The following tables list the members exposed by the IComplaintReason type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_GroupName |
Public property | DS_GroupTableCode |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Customer |
Public property | U_GrpCode |
Public property | U_Internal |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_Remarks |
Public property | U_RsnCode |
Public property | U_RsnName |
Public property | U_Supplier |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IComplaintReason Interface
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.DS_GroupName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_GroupName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_GroupName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_GroupName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_GroupName() : String;

   AppEnginePropertyIgnore()
function set DS_GroupName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.DS_GroupTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_GroupTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_GroupTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_GroupTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_GroupTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_GroupTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.U_Customer Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Customer() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Customer {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Customer {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Customer() : String;
function set U_Customer(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.U_GrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpCode() : String;
function set U_GrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.U_Internal Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Internal() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Internal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Internal {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Internal() : String;
function set U_Internal(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.U_RsnCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RsnCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RsnCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RsnCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RsnCode() : String;
function set U_RsnCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.U_RsnName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RsnName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RsnName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RsnName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RsnName() : String;
function set U_RsnName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.U_Supplier Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Supplier() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Supplier {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Supplier {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Supplier() : String;
function set U_Supplier(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IComplaintReason Interface
IComplaintReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


IComplaintReason Methods

IComplaintReason Interface See Also

The following tables list the members exposed by the IComplaintReason type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IComplaintReason Interface
CompuTec.ProcessForce.API.Documents.QualityControl.ComplaintReason Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IDefect | Defect object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IDefect Interface

Members See Also

Defect object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "Defect", TableName = "@CT_PF_ODEF")> _
Public Interface IDefect
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Defect", TableName = "@CT_PF_ODEF")]
public interface IDefect : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Defect", TableName = "@CT_PF_ODEF")]
public interface class IDefect : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "Defect", TableName = "@CT_PF_ODEF")
interface IDefect
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ODEF
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect Members

IDefect Interface Methods Properties See Also

Defect object

The following tables list the members exposed by the IDefect type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_DefectGroupName |
Public property | DS_DefectGroupRemarks |
Public property | DS_DefectGroupTableCode |
Public property | DS_UsedCount |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_DefCode |
Public property | U_DefGrpCode |
Public property | U_DefName |
Public property | U_DefRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IDefect Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect Properties

IDefect Interface See Also

The following tables list the members exposed by the IDefect type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_DefectGroupName |
Public property | DS_DefectGroupRemarks |
Public property | DS_DefectGroupTableCode |
Public property | DS_UsedCount |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_DefCode |
Public property | U_DefGrpCode |
Public property | U_DefName |
Public property | U_DefRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IDefect Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.DS_DefectGroupName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_DefectGroupName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_DefectGroupName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_DefectGroupName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_DefectGroupName() : String;

   AppEnginePropertyIgnore()
function set DS_DefectGroupName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.DS_DefectGroupRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_DefectGroupRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_DefectGroupRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_DefectGroupRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_DefectGroupRemarks() : String;

   AppEnginePropertyIgnore()
function set DS_DefectGroupRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.DS_DefectGroupTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_DefectGroupTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_DefectGroupTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_DefectGroupTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_DefectGroupTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_DefectGroupTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.DS_UsedCount Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_UsedCount() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_UsedCount {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_UsedCount {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_UsedCount() : String;

   AppEnginePropertyIgnore()
function set DS_UsedCount(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.U_DefCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_DefCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_DefCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_DefCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_DefCode() : String;

   AppEngineProperty(Required = true)
function set U_DefCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.U_DefGrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DefGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DefGrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DefGrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DefGrpCode() : String;
function set U_DefGrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.U_DefName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DefName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DefName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DefName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DefName() : String;
function set U_DefName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.U_DefRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DefRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DefRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DefRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DefRemarks() : String;
function set U_DefRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Defect
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefect Interface
IDefect Members
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


IDefect Methods

IDefect Interface See Also

The following tables list the members exposed by the IDefect type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IDefect Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Defect Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IDefectGroup | Defect group object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IDefectGroup Interface

Members See Also

Defect group object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "DefectGroup", TableName = "@CT_PF_ODEG")> _
Public Interface IDefectGroup
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "DefectGroup", TableName = "@CT_PF_ODEG")]
public interface IDefectGroup : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "DefectGroup", TableName = "@CT_PF_ODEG")]
public interface class IDefectGroup : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "DefectGroup", TableName = "@CT_PF_ODEG")
interface IDefectGroup
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ODEG
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefectGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


IDefectGroup Members

IDefectGroup Interface Methods Properties See Also

Defect group object

The following tables list the members exposed by the IDefectGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_DefGrpCode |
Public property | U_DefGrpName |
Public property | U_DefGrpRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IDefectGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


IDefectGroup Properties

IDefectGroup Interface See Also

The following tables list the members exposed by the IDefectGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_DefGrpCode |
Public property | U_DefGrpName |
Public property | U_DefGrpRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IDefectGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


IDefectGroup.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefectGroup Interface
IDefectGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


IDefectGroup.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefectGroup Interface
IDefectGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


IDefectGroup.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefectGroup Interface
IDefectGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


IDefectGroup.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefectGroup Interface
IDefectGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


IDefectGroup.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefectGroup Interface
IDefectGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


IDefectGroup.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefectGroup Interface
IDefectGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


IDefectGroup.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefectGroup Interface
IDefectGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


IDefectGroup.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefectGroup Interface
IDefectGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


IDefectGroup.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefectGroup Interface
IDefectGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


IDefectGroup.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefectGroup Interface
IDefectGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


IDefectGroup.U_DefGrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_DefGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_DefGrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_DefGrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_DefGrpCode() : String;

   AppEngineProperty(Required = true)
function set U_DefGrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefectGroup Interface
IDefectGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


IDefectGroup.U_DefGrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DefGrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DefGrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DefGrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DefGrpName() : String;
function set U_DefGrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefectGroup Interface
IDefectGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


IDefectGroup.U_DefGrpRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DefGrpRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DefGrpRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DefGrpRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DefGrpRemarks() : String;
function set U_DefGrpRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefectGroup Interface
IDefectGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


IDefectGroup.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefectGroup Interface
IDefectGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


IDefectGroup.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefectGroup Interface
IDefectGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


IDefectGroup.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDefectGroup Interface
IDefectGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


IDefectGroup Methods

IDefectGroup Interface See Also

The following tables list the members exposed by the IDefectGroup type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IDefectGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.DefectGroup Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IInspector | Inspector object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IInspector Interface

Members See Also

Inspector object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "Inspector", TableName = "@CT_PF_OINS")> _
Public Interface IInspector
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Inspector", TableName = "@CT_PF_OINS")]
public interface IInspector : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Inspector", TableName = "@CT_PF_OINS")]
public interface class IInspector : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "Inspector", TableName = "@CT_PF_OINS")
interface IInspector
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OINS
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector Members

IInspector Interface Methods Properties See Also

Inspector object

The following tables list the members exposed by the IInspector type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_EmployeeFirstName |
Public property | DS_EmployeeLastName |
Public property | DS_EmployeeSecondName |
Public property | DS_InspectorGroupName |
Public property | DS_InspectorGroupRemarks |
Public property | DS_InspectorGroupTableCode |
Public property | DS_WarehouseName |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_EmployeeId |
Public property | U_InsCode |
Public property | U_InsGrpCode |
Public property | U_InsRemarks |
Public property | U_WhsCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IInspector Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector Properties

IInspector Interface See Also

The following tables list the members exposed by the IInspector type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_EmployeeFirstName |
Public property | DS_EmployeeLastName |
Public property | DS_EmployeeSecondName |
Public property | DS_InspectorGroupName |
Public property | DS_InspectorGroupRemarks |
Public property | DS_InspectorGroupTableCode |
Public property | DS_WarehouseName |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_EmployeeId |
Public property | U_InsCode |
Public property | U_InsGrpCode |
Public property | U_InsRemarks |
Public property | U_WhsCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IInspector Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.DS_EmployeeFirstName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_EmployeeFirstName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_EmployeeFirstName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_EmployeeFirstName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_EmployeeFirstName() : String;

   AppEnginePropertyIgnore()
function set DS_EmployeeFirstName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.DS_EmployeeLastName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_EmployeeLastName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_EmployeeLastName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_EmployeeLastName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_EmployeeLastName() : String;

   AppEnginePropertyIgnore()
function set DS_EmployeeLastName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.DS_EmployeeSecondName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_EmployeeSecondName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_EmployeeSecondName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_EmployeeSecondName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_EmployeeSecondName() : String;

   AppEnginePropertyIgnore()
function set DS_EmployeeSecondName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.DS_InspectorGroupName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_InspectorGroupName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_InspectorGroupName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_InspectorGroupName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_InspectorGroupName() : String;

   AppEnginePropertyIgnore()
function set DS_InspectorGroupName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.DS_InspectorGroupRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_InspectorGroupRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_InspectorGroupRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_InspectorGroupRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_InspectorGroupRemarks() : String;

   AppEnginePropertyIgnore()
function set DS_InspectorGroupRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.DS_InspectorGroupTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_InspectorGroupTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_InspectorGroupTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_InspectorGroupTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_InspectorGroupTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_InspectorGroupTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.DS_WarehouseName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_WarehouseName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_WarehouseName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_WarehouseName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_WarehouseName() : String;

   AppEnginePropertyIgnore()
function set DS_WarehouseName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.U_EmployeeId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EmployeeId() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_EmployeeId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_EmployeeId {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EmployeeId() : String;
function set U_EmployeeId(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.U_InsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_InsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_InsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_InsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_InsCode() : String;

   AppEngineProperty(Required = true)
function set U_InsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.U_InsGrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InsGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InsGrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InsGrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InsGrpCode() : String;
function set U_InsGrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.U_InsRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InsRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InsRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InsRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InsRemarks() : String;
function set U_InsRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.U_WhsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Inspector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspector Interface
IInspector Members
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


IInspector Methods

IInspector Interface See Also

The following tables list the members exposed by the IInspector type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IInspector Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Inspector Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IInspectorGroup | Inspector group object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IInspectorGroup Interface

Members See Also

Inspector group object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "InspectorGroup", TableName = "@CT_PF_OING", UDOVersion = "UDO_20")> _
Public Interface IInspectorGroup
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "InspectorGroup", TableName = "@CT_PF_OING", UDOVersion = "UDO_20")]
public interface IInspectorGroup : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "InspectorGroup", TableName = "@CT_PF_OING", UDOVersion = "UDO_20")]
public interface class IInspectorGroup : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "InspectorGroup", TableName = "@CT_PF_OING", UDOVersion = "UDO_20")
interface IInspectorGroup
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OING
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


IInspectorGroup Members

IInspectorGroup Interface Methods Properties See Also

Inspector group object

The following tables list the members exposed by the IInspectorGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_InsGrpCode |
Public property | U_InsGrpName |
Public property | U_InsGrpRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IInspectorGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


IInspectorGroup Properties

IInspectorGroup Interface See Also

The following tables list the members exposed by the IInspectorGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_InsGrpCode |
Public property | U_InsGrpName |
Public property | U_InsGrpRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IInspectorGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


IInspectorGroup.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorGroup Interface
IInspectorGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


IInspectorGroup.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorGroup Interface
IInspectorGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


IInspectorGroup.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorGroup Interface
IInspectorGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


IInspectorGroup.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorGroup Interface
IInspectorGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


IInspectorGroup.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorGroup Interface
IInspectorGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


IInspectorGroup.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorGroup Interface
IInspectorGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


IInspectorGroup.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorGroup Interface
IInspectorGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


IInspectorGroup.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorGroup Interface
IInspectorGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


IInspectorGroup.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorGroup Interface
IInspectorGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


IInspectorGroup.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorGroup Interface
IInspectorGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


IInspectorGroup.U_InsGrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_InsGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_InsGrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_InsGrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_InsGrpCode() : String;

   AppEngineProperty(Required = true)
function set U_InsGrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorGroup Interface
IInspectorGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


IInspectorGroup.U_InsGrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InsGrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InsGrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InsGrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InsGrpName() : String;
function set U_InsGrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorGroup Interface
IInspectorGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


IInspectorGroup.U_InsGrpRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InsGrpRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InsGrpRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InsGrpRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InsGrpRemarks() : String;
function set U_InsGrpRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorGroup Interface
IInspectorGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


IInspectorGroup.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorGroup Interface
IInspectorGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


IInspectorGroup.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorGroup Interface
IInspectorGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


IInspectorGroup.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorGroup Interface
IInspectorGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


IInspectorGroup Methods

IInspectorGroup Interface See Also

The following tables list the members exposed by the IInspectorGroup type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IInspectorGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorGroup Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IInspectorNcmr | Inspector ncmr object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IInspectorNcmr Interface

Members See Also

Inspector ncmr object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "InspectorNcmr", TableName = "@CT_PF_OINN")> _
Public Interface IInspectorNcmr
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "InspectorNcmr", TableName = "@CT_PF_OINN")]
public interface IInspectorNcmr : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "InspectorNcmr", TableName = "@CT_PF_OINN")]
public interface class IInspectorNcmr : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "InspectorNcmr", TableName = "@CT_PF_OINN")
interface IInspectorNcmr
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OINN
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr Members

IInspectorNcmr Interface Methods Properties See Also

Inspector ncmr object

The following tables list the members exposed by the IInspectorNcmr type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_EmployeeFirstName |
Public property | DS_EmployeeLastName |
Public property | DS_EmployeeSecondName |
Public property | DS_InspectorGroupName |
Public property | DS_InspectorGroupRemarks |
Public property | DS_InspectorGroupTableCode |
Public property | DS_WarehouseName |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_EmployeeId |
Public property | U_InsCode |
Public property | U_InsGrpCode |
Public property | U_InsRemarks |
Public property | U_WhsCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IInspectorNcmr Interface
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr Properties

IInspectorNcmr Interface See Also

The following tables list the members exposed by the IInspectorNcmr type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_EmployeeFirstName |
Public property | DS_EmployeeLastName |
Public property | DS_EmployeeSecondName |
Public property | DS_InspectorGroupName |
Public property | DS_InspectorGroupRemarks |
Public property | DS_InspectorGroupTableCode |
Public property | DS_WarehouseName |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_EmployeeId |
Public property | U_InsCode |
Public property | U_InsGrpCode |
Public property | U_InsRemarks |
Public property | U_WhsCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IInspectorNcmr Interface
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.DS_EmployeeFirstName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_EmployeeFirstName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_EmployeeFirstName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_EmployeeFirstName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_EmployeeFirstName() : String;

   AppEnginePropertyIgnore()
function set DS_EmployeeFirstName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.DS_EmployeeLastName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_EmployeeLastName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_EmployeeLastName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_EmployeeLastName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_EmployeeLastName() : String;

   AppEnginePropertyIgnore()
function set DS_EmployeeLastName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.DS_EmployeeSecondName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_EmployeeSecondName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_EmployeeSecondName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_EmployeeSecondName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_EmployeeSecondName() : String;

   AppEnginePropertyIgnore()
function set DS_EmployeeSecondName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.DS_InspectorGroupName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_InspectorGroupName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_InspectorGroupName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_InspectorGroupName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_InspectorGroupName() : String;

   AppEnginePropertyIgnore()
function set DS_InspectorGroupName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.DS_InspectorGroupRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_InspectorGroupRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_InspectorGroupRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_InspectorGroupRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_InspectorGroupRemarks() : String;

   AppEnginePropertyIgnore()
function set DS_InspectorGroupRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.DS_InspectorGroupTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_InspectorGroupTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_InspectorGroupTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_InspectorGroupTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_InspectorGroupTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_InspectorGroupTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.DS_WarehouseName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_WarehouseName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_WarehouseName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_WarehouseName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_WarehouseName() : String;

   AppEnginePropertyIgnore()
function set DS_WarehouseName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.U_EmployeeId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EmployeeId() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_EmployeeId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_EmployeeId {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EmployeeId() : String;
function set U_EmployeeId(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.U_InsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_InsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_InsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_InsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_InsCode() : String;

   AppEngineProperty(Required = true)
function set U_InsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.U_InsGrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InsGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InsGrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InsGrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InsGrpCode() : String;
function set U_InsGrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.U_InsRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InsRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InsRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InsRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InsRemarks() : String;
function set U_InsRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.U_WhsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInspectorNcmr Interface
IInspectorNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


IInspectorNcmr Methods

IInspectorNcmr Interface See Also

The following tables list the members exposed by the IInspectorNcmr type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IInspectorNcmr Interface
CompuTec.ProcessForce.API.Documents.QualityControl.InspectorNcmr Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | INcmrTransaction | Ncmr transaction document
Public interface | INcmrTransactionAttachments | Attachment for ncmr transaction document
Public interface | INcmrTransactionDefects | Defects for ncmr transaction document
Public interface | INcmrTransactionReasons | Reasons for ncmr transaction document
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


INcmrTransaction Interface

Members See Also

Ncmr transaction document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "NcmrTransaction", TableName = "@CT_PF_ONTR")> _
Public Interface INcmrTransaction
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "NcmrTransaction", TableName = "@CT_PF_ONTR")]
public interface INcmrTransaction : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "NcmrTransaction", TableName = "@CT_PF_ONTR")]
public interface class INcmrTransaction : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "NcmrTransaction", TableName = "@CT_PF_ONTR")
interface INcmrTransaction
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ONTR
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction Members

INcmrTransaction Interface Methods Properties See Also

Ncmr transaction document

The following tables list the members exposed by the INcmrTransaction type.

Properties
 | Name | Description
Public property | Attachments |
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_NcmrCreatorTableCode |
Public property | DS_QcTestComplaintNo |
Public property | DS_QcTestComplaintNoDocEntry |
Public property | DS_QcTestDefectQuantity |
Public property | DS_QcTestDescription |
Public property | DS_QcTestElectronicSignature |
Public property | DS_QcTestInspectorCode |
Public property | DS_QcTestInspectorTableCode |
Public property | DS_QcTestProjectCode |
Public property | DS_QcTestSampleSize |
Public property | DataSource |
Public property | Defects |
Public property | DocEntry |
Public property | DocNum |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Reasons |
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Closed |
Public property | U_ContAction |
Public property | U_CorrAction |
Public property | U_Created |
Public property | U_ManItems |
Public property | U_NcmrCrtCode |
Public property | U_NcmrNo |
Public property | U_Notes |
Public property | U_OnHold |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_PurItems |
Public property | U_QcTestNo |
Public property | U_RecAction |
Public property | U_Remarks |
Public property | U_Started |
Public property | U_Status |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | SetDefaultSeries | Sets the default series for NCMR Transaction document.
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

INcmrTransaction Interface
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction Properties

INcmrTransaction Interface See Also

The following tables list the members exposed by the INcmrTransaction type.

Properties
 | Name | Description
Public property | Attachments |
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_NcmrCreatorTableCode |
Public property | DS_QcTestComplaintNo |
Public property | DS_QcTestComplaintNoDocEntry |
Public property | DS_QcTestDefectQuantity |
Public property | DS_QcTestDescription |
Public property | DS_QcTestElectronicSignature |
Public property | DS_QcTestInspectorCode |
Public property | DS_QcTestInspectorTableCode |
Public property | DS_QcTestProjectCode |
Public property | DS_QcTestSampleSize |
Public property | DataSource |
Public property | Defects |
Public property | DocEntry |
Public property | DocNum |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Reasons |
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Closed |
Public property | U_ContAction |
Public property | U_CorrAction |
Public property | U_Created |
Public property | U_ManItems |
Public property | U_NcmrCrtCode |
Public property | U_NcmrNo |
Public property | U_Notes |
Public property | U_OnHold |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_PurItems |
Public property | U_QcTestNo |
Public property | U_RecAction |
Public property | U_Remarks |
Public property | U_Started |
Public property | U_Status |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

INcmrTransaction Interface
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.Attachments Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Attachments() As INcmrTransactionAttachments
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
INcmrTransactionAttachments Attachments {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property INcmrTransactionAttachments^ Attachments {
 INcmrTransactionAttachments^ get( );
 void set(
   INcmrTransactionAttachments^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Attachments() : INcmrTransactionAttachments;
function set Attachments(value : INcmrTransactionAttachments);
This language is not supported or no code example is available.

Property Value

Type: INcmrTransactionAttachments
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.DS_NcmrCreatorTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_NcmrCreatorTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_NcmrCreatorTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_NcmrCreatorTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_NcmrCreatorTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_NcmrCreatorTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.DS_QcTestComplaintNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_QcTestComplaintNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DS_QcTestComplaintNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DS_QcTestComplaintNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_QcTestComplaintNo() : int;

   AppEnginePropertyIgnore()
function set DS_QcTestComplaintNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.DS_QcTestComplaintNoDocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_QcTestComplaintNoDocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DS_QcTestComplaintNoDocEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DS_QcTestComplaintNoDocEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_QcTestComplaintNoDocEntry() : int;

   AppEnginePropertyIgnore()
function set DS_QcTestComplaintNoDocEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.DS_QcTestDefectQuantity Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_QcTestDefectQuantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
double DS_QcTestDefectQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property double DS_QcTestDefectQuantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_QcTestDefectQuantity() : double;

   AppEnginePropertyIgnore()
function set DS_QcTestDefectQuantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.DS_QcTestDescription Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_QcTestDescription() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_QcTestDescription {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_QcTestDescription {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_QcTestDescription() : String;

   AppEnginePropertyIgnore()
function set DS_QcTestDescription(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.DS_QcTestElectronicSignature Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_QcTestElectronicSignature() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_QcTestElectronicSignature {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_QcTestElectronicSignature {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_QcTestElectronicSignature() : String;

   AppEnginePropertyIgnore()
function set DS_QcTestElectronicSignature(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.DS_QcTestInspectorCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_QcTestInspectorCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_QcTestInspectorCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_QcTestInspectorCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_QcTestInspectorCode() : String;

   AppEnginePropertyIgnore()
function set DS_QcTestInspectorCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.DS_QcTestInspectorTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_QcTestInspectorTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_QcTestInspectorTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_QcTestInspectorTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_QcTestInspectorTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_QcTestInspectorTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.DS_QcTestProjectCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_QcTestProjectCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_QcTestProjectCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_QcTestProjectCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_QcTestProjectCode() : String;

   AppEnginePropertyIgnore()
function set DS_QcTestProjectCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.DS_QcTestSampleSize Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_QcTestSampleSize() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
double DS_QcTestSampleSize {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property double DS_QcTestSampleSize {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_QcTestSampleSize() : double;

   AppEnginePropertyIgnore()
function set DS_QcTestSampleSize(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.Defects Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Defects() As INcmrTransactionDefects
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
INcmrTransactionDefects Defects {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property INcmrTransactionDefects^ Defects {
 INcmrTransactionDefects^ get( );
 void set(
   INcmrTransactionDefects^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Defects() : INcmrTransactionDefects;
function set Defects(value : INcmrTransactionDefects);
This language is not supported or no code example is available.

Property Value

Type: INcmrTransactionDefects
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.DocNum Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.Handwrtten Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Handwrtten() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Handwrtten {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Handwrtten {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Handwrtten() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.Instance Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Instance() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Instance {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Instance {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Instance() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.Period Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Period() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Period {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Period {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Period() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.Reasons Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Reasons() As INcmrTransactionReasons
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
INcmrTransactionReasons Reasons {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property INcmrTransactionReasons^ Reasons {
 INcmrTransactionReasons^ get( );
 void set(
   INcmrTransactionReasons^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Reasons() : INcmrTransactionReasons;
function set Reasons(value : INcmrTransactionReasons);
This language is not supported or no code example is available.

Property Value

Type: INcmrTransactionReasons
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.Series Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Series() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Series {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Series {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Series() : int;
function set Series(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.Status Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Status {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Status {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Status() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.U_Closed Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Closed() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Closed {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Closed {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Closed() : DateTime;
function set U_Closed(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.U_ContAction Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ContAction() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ContAction {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ContAction {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ContAction() : String;
function set U_ContAction(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.U_CorrAction Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CorrAction() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CorrAction {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CorrAction {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CorrAction() : String;
function set U_CorrAction(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.U_Created Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Created() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Created {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Created {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Created() : DateTime;
function set U_Created(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.U_ManItems Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ManItems() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ManItems {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ManItems {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ManItems() : String;
function set U_ManItems(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.U_NcmrCrtCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_NcmrCrtCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_NcmrCrtCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_NcmrCrtCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_NcmrCrtCode() : String;
function set U_NcmrCrtCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.U_NcmrNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_NcmrNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_NcmrNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_NcmrNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_NcmrNo() : int;
function set U_NcmrNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.U_Notes Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Notes() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Notes {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Notes {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Notes() : String;
function set U_Notes(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.U_OnHold Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OnHold() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_OnHold {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_OnHold {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OnHold() : DateTime;
function set U_OnHold(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.U_PurItems Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PurItems() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PurItems {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PurItems {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PurItems() : String;
function set U_PurItems(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.U_QcTestNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QcTestNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_QcTestNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_QcTestNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QcTestNo() : int;
function set U_QcTestNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.U_RecAction Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RecAction() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RecAction {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RecAction {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RecAction() : String;
function set U_RecAction(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.U_Started Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Started() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Started {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Started {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Started() : DateTime;
function set U_Started(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.U_Status Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Status {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Status() : String;
function set U_Status(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction Methods

INcmrTransaction Interface See Also

The following tables list the members exposed by the INcmrTransaction type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | SetDefaultSeries | Sets the default series for NCMR Transaction document.
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

INcmrTransaction Interface
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransaction.SetDefaultSeries Method

Sets the default series for NCMR Transaction document.

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub SetDefaultSeries()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void SetDefaultSeries()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void SetDefaultSeries()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function SetDefaultSeries();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransaction Interface
INcmrTransaction Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionAttachments Interface

Members See Also

Attachment for ncmr transaction document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface INcmrTransactionAttachments
    Inherits IUDOChildBean, _
             IEnumerable(Of INcmrTransactionAttachments)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface INcmrTransactionAttachments : IUDOChildBean,
   IEnumerable<INcmrTransactionAttachments>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class INcmrTransactionAttachments : public IUDOChildBean^,
   public IEnumerable<INcmrTransactionAttachments^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_NTR3
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionAttachments Members

INcmrTransactionAttachments Interface Methods Properties See Also

Attachment for ncmr transaction document

The following tables list the members exposed by the INcmrTransactionAttachments type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AttDate |
Public property | U_FileName |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Path |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

INcmrTransactionAttachments Interface
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionAttachments Properties

INcmrTransactionAttachments Interface See Also

The following tables list the members exposed by the INcmrTransactionAttachments type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AttDate |
Public property | U_FileName |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Path |
Public property | VisOrder |
Top
See Also

Reference

INcmrTransactionAttachments Interface
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionAttachments.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionAttachments Interface
INcmrTransactionAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionAttachments.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionAttachments Interface
INcmrTransactionAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionAttachments.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionAttachments Interface
INcmrTransactionAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionAttachments.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionAttachments Interface
INcmrTransactionAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionAttachments.U_AttDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_AttDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_AttDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttDate() : DateTime;
function set U_AttDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionAttachments Interface
INcmrTransactionAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionAttachments.U_FileName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FileName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FileName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FileName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FileName() : String;
function set U_FileName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionAttachments Interface
INcmrTransactionAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionAttachments.U_Path Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Path() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Path {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Path {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Path() : String;
function set U_Path(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionAttachments Interface
INcmrTransactionAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionAttachments.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionAttachments Interface
INcmrTransactionAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionAttachments Methods

INcmrTransactionAttachments Interface See Also

The following tables list the members exposed by the INcmrTransactionAttachments type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

INcmrTransactionAttachments Interface
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionDefects Interface

Members See Also

Defects for ncmr transaction document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface INcmrTransactionDefects
    Inherits IUDOChildBean, _
             IEnumerable(Of INcmrTransactionDefects)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface INcmrTransactionDefects : IUDOChildBean,
   IEnumerable<INcmrTransactionDefects>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class INcmrTransactionDefects : public IUDOChildBean^,
   public IEnumerable<INcmrTransactionDefects^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_NTR1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionDefects Members

INcmrTransactionDefects Interface Methods Properties See Also

Defects for ncmr transaction document

The following tables list the members exposed by the INcmrTransactionDefects type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_DefectName |
Public property | DS_DefectTableCode |
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_DefCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_NcmrNo |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

INcmrTransactionDefects Interface
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionDefects Properties

INcmrTransactionDefects Interface See Also

The following tables list the members exposed by the INcmrTransactionDefects type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_DefectName |
Public property | DS_DefectTableCode |
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_DefCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_NcmrNo |
Public property | VisOrder |
Top
See Also

Reference

INcmrTransactionDefects Interface
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionDefects.DS_DefectName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_DefectName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_DefectName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_DefectName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_DefectName() : String;

   AppEnginePropertyIgnore()
function set DS_DefectName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionDefects Interface
INcmrTransactionDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionDefects.DS_DefectTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_DefectTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_DefectTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_DefectTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_DefectTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_DefectTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionDefects Interface
INcmrTransactionDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionDefects.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionDefects Interface
INcmrTransactionDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionDefects.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionDefects Interface
INcmrTransactionDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionDefects.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionDefects Interface
INcmrTransactionDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionDefects.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionDefects Interface
INcmrTransactionDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionDefects.U_DefCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DefCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DefCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DefCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DefCode() : String;
function set U_DefCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionDefects Interface
INcmrTransactionDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionDefects.U_NcmrNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_NcmrNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_NcmrNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_NcmrNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_NcmrNo() : int;
function set U_NcmrNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionDefects Interface
INcmrTransactionDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionDefects.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionDefects Interface
INcmrTransactionDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionDefects Methods

INcmrTransactionDefects Interface See Also

The following tables list the members exposed by the INcmrTransactionDefects type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

INcmrTransactionDefects Interface
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionReasons Interface

Members See Also

Reasons for ncmr transaction document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface INcmrTransactionReasons
    Inherits IUDOChildBean, _
             IEnumerable(Of INcmrTransactionReasons)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface INcmrTransactionReasons : IUDOChildBean,
   IEnumerable<INcmrTransactionReasons>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class INcmrTransactionReasons : public IUDOChildBean^,
   public IEnumerable<INcmrTransactionReasons^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_NTR2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionReasons Members

INcmrTransactionReasons Interface Methods Properties See Also

Reasons for ncmr transaction document

The following tables list the members exposed by the INcmrTransactionReasons type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_NcmrReasonName |
Public property | DS_NcmrReasonTableCode |
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_NcmrNo |
Public property | U_NcmrRsnCode |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

INcmrTransactionReasons Interface
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionReasons Properties

INcmrTransactionReasons Interface See Also

The following tables list the members exposed by the INcmrTransactionReasons type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_NcmrReasonName |
Public property | DS_NcmrReasonTableCode |
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_NcmrNo |
Public property | U_NcmrRsnCode |
Public property | VisOrder |
Top
See Also

Reference

INcmrTransactionReasons Interface
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionReasons.DS_NcmrReasonName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_NcmrReasonName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_NcmrReasonName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_NcmrReasonName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_NcmrReasonName() : String;

   AppEnginePropertyIgnore()
function set DS_NcmrReasonName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionReasons Interface
INcmrTransactionReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionReasons.DS_NcmrReasonTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_NcmrReasonTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_NcmrReasonTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_NcmrReasonTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_NcmrReasonTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_NcmrReasonTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionReasons Interface
INcmrTransactionReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionReasons.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionReasons Interface
INcmrTransactionReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionReasons.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionReasons Interface
INcmrTransactionReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionReasons.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionReasons Interface
INcmrTransactionReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionReasons.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionReasons Interface
INcmrTransactionReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionReasons.U_NcmrNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_NcmrNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_NcmrNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_NcmrNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_NcmrNo() : int;
function set U_NcmrNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionReasons Interface
INcmrTransactionReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionReasons.U_NcmrRsnCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_NcmrRsnCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_NcmrRsnCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_NcmrRsnCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_NcmrRsnCode() : String;

   AppEngineProperty(Required = true)
function set U_NcmrRsnCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionReasons Interface
INcmrTransactionReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionReasons.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

INcmrTransactionReasons Interface
INcmrTransactionReasons Members
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


INcmrTransactionReasons Methods

INcmrTransactionReasons Interface See Also

The following tables list the members exposed by the INcmrTransactionReasons type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

INcmrTransactionReasons Interface
CompuTec.ProcessForce.API.Documents.QualityControl.NcmrTransaction Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IQualityControlTestPool | Quality control test document
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IQualityControlTestPool Interface

Members See Also

Quality control test document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "QualityControlTestPool", TableName = "@CT_PF_OQCP", ExludedHttpMethods = "DELETE")> _
Public Interface IQualityControlTestPool
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "QualityControlTestPool", TableName = "@CT_PF_OQCP", ExludedHttpMethods = "DELETE")]
public interface IQualityControlTestPool : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "QualityControlTestPool", TableName = "@CT_PF_OQCP", ExludedHttpMethods = "DELETE")]
public interface class IQualityControlTestPool : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "QualityControlTestPool", TableName = "@CT_PF_OQCP", ExludedHttpMethods = "DELETE")
interface IQualityControlTestPool
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OQCP
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool Members

IQualityControlTestPool Interface Methods Properties See Also

Quality control test document

The following tables list the members exposed by the IQualityControlTestPool type.

Properties
 | Name | Description
Public property | Canceled |
Public property | CreateDate |
Public property | DS_AcceptanceNumberResultand |
Public property | DS_ComplaintDocEntry |
Public property | DS_ComplaintDocNo |
Public property | DS_ComplaintNo |
Public property | DS_ComplaintSeries |
Public property | DS_InspectorTableCode |
Public property | DS_ItemName |
Public property | DS_ItemUoM |
Public property | DS_ManufacturingDocNum |
Public property | DS_ManufacturingOperationName |
Public property | DS_ManufacturingOperationStatus |
Public property | DS_ManufacturingOperationTableCode |
Public property | DS_ManufacturingSeries |
Public property | DS_RejectionNumberResultand |
Public property | DS_TestProtocolTableCode |
Public property | DS_UsedCount |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_AcceptanceNumberReq |
Public property | U_BatchNumber |
Public property | U_BinCode |
Public property | U_BpCode |
Public property | U_Closed |
Public property | U_ComplaintNo |
Public property | U_Created |
Public property | U_Description |
Public property | U_ElectronicSign |
Public property | U_Footer |
Public property | U_Header |
Public property | U_InsCode |
Public property | U_ItemCode |
Public property | U_LotNumber |
Public property | U_MnfOprCode |
Public property | U_MnfOrder |
Public property | U_NumberOfSamples |
Public property | U_OnHold |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_PassFailDate |
Public property | U_PrjCode |
Public property | U_QcTestPoolNo |
Public property | U_RefersTo |
Public property | U_RejectionNumberReq |
Public property | U_RevCode |
Public property | U_SampleSize |
Public property | U_Start |
Public property | U_Status |
Public property | U_TestProtocolNo |
Public property | U_TestStatus |
Public property | U_TransType |
Public property | U_WaitingNcmr |
Public property | U_WhsCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | CheckIfTestStatusOfQCTestPoolIsCorrect | Check if Status of Quality Control Test Pool document is correct.
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | SetDefaultSeries | Sets the default series for Quality Control Test Pool document.
Public method | SetQCPoolTestsStatus | Sets QC Status for Quality Control Test Pool document.
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IQualityControlTestPool Interface
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool Properties

IQualityControlTestPool Interface See Also

The following tables list the members exposed by the IQualityControlTestPool type.

Properties
 | Name | Description
Public property | Canceled |
Public property | CreateDate |
Public property | DS_AcceptanceNumberResultand |
Public property | DS_ComplaintDocEntry |
Public property | DS_ComplaintDocNo |
Public property | DS_ComplaintNo |
Public property | DS_ComplaintSeries |
Public property | DS_InspectorTableCode |
Public property | DS_ItemName |
Public property | DS_ItemUoM |
Public property | DS_ManufacturingDocNum |
Public property | DS_ManufacturingOperationName |
Public property | DS_ManufacturingOperationStatus |
Public property | DS_ManufacturingOperationTableCode |
Public property | DS_ManufacturingSeries |
Public property | DS_RejectionNumberResultand |
Public property | DS_TestProtocolTableCode |
Public property | DS_UsedCount |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_AcceptanceNumberReq |
Public property | U_BatchNumber |
Public property | U_BinCode |
Public property | U_BpCode |
Public property | U_Closed |
Public property | U_ComplaintNo |
Public property | U_Created |
Public property | U_Description |
Public property | U_ElectronicSign |
Public property | U_Footer |
Public property | U_Header |
Public property | U_InsCode |
Public property | U_ItemCode |
Public property | U_LotNumber |
Public property | U_MnfOprCode |
Public property | U_MnfOrder |
Public property | U_NumberOfSamples |
Public property | U_OnHold |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_PassFailDate |
Public property | U_PrjCode |
Public property | U_QcTestPoolNo |
Public property | U_RefersTo |
Public property | U_RejectionNumberReq |
Public property | U_RevCode |
Public property | U_SampleSize |
Public property | U_Start |
Public property | U_Status |
Public property | U_TestProtocolNo |
Public property | U_TestStatus |
Public property | U_TransType |
Public property | U_WaitingNcmr |
Public property | U_WhsCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IQualityControlTestPool Interface
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.DS_AcceptanceNumberResultand Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_AcceptanceNumberResultand() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_AcceptanceNumberResultand {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_AcceptanceNumberResultand {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_AcceptanceNumberResultand() : String;

   AppEnginePropertyIgnore()
function set DS_AcceptanceNumberResultand(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.DS_ComplaintDocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ComplaintDocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DS_ComplaintDocEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DS_ComplaintDocEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ComplaintDocEntry() : int;

   AppEnginePropertyIgnore()
function set DS_ComplaintDocEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.DS_ComplaintDocNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ComplaintDocNo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ComplaintDocNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ComplaintDocNo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ComplaintDocNo() : String;

   AppEnginePropertyIgnore()
function set DS_ComplaintDocNo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.DS_ComplaintNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ComplaintNo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ComplaintNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ComplaintNo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ComplaintNo() : String;

   AppEnginePropertyIgnore()
function set DS_ComplaintNo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.DS_ComplaintSeries Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ComplaintSeries() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ComplaintSeries {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ComplaintSeries {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ComplaintSeries() : String;

   AppEnginePropertyIgnore()
function set DS_ComplaintSeries(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.DS_InspectorTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_InspectorTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_InspectorTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_InspectorTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_InspectorTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_InspectorTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.DS_ItemName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemName() : String;

   AppEnginePropertyIgnore()
function set DS_ItemName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.DS_ItemUoM Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ItemUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemUoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemUoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemUoM() : String;

   AppEnginePropertyIgnore()
function set DS_ItemUoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.DS_ManufacturingDocNum Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ManufacturingDocNum() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ManufacturingDocNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ManufacturingDocNum {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ManufacturingDocNum() : String;

   AppEnginePropertyIgnore()
function set DS_ManufacturingDocNum(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.DS_ManufacturingOperationName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ManufacturingOperationName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ManufacturingOperationName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ManufacturingOperationName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ManufacturingOperationName() : String;

   AppEnginePropertyIgnore()
function set DS_ManufacturingOperationName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.DS_ManufacturingOperationStatus Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ManufacturingOperationStatus() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ManufacturingOperationStatus {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ManufacturingOperationStatus {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ManufacturingOperationStatus() : String;

   AppEnginePropertyIgnore()
function set DS_ManufacturingOperationStatus(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.DS_ManufacturingOperationTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ManufacturingOperationTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ManufacturingOperationTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ManufacturingOperationTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ManufacturingOperationTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_ManufacturingOperationTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.DS_ManufacturingSeries Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ManufacturingSeries() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ManufacturingSeries {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ManufacturingSeries {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ManufacturingSeries() : String;

   AppEnginePropertyIgnore()
function set DS_ManufacturingSeries(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.DS_RejectionNumberResultand Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_RejectionNumberResultand() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_RejectionNumberResultand {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_RejectionNumberResultand {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_RejectionNumberResultand() : String;

   AppEnginePropertyIgnore()
function set DS_RejectionNumberResultand(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.DS_TestProtocolTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_TestProtocolTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_TestProtocolTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_TestProtocolTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_TestProtocolTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_TestProtocolTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.DS_UsedCount Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_UsedCount() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_UsedCount {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_UsedCount {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_UsedCount() : String;

   AppEnginePropertyIgnore()
function set DS_UsedCount(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.DocNum Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.Handwrtten Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Handwrtten() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Handwrtten {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Handwrtten {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Handwrtten() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.Instance Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Instance() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Instance {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Instance {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Instance() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.Period Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Period() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Period {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Period {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Period() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.Series Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Series() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Series {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Series {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Series() : int;
function set Series(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.Status Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Status {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Status {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Status() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_AcceptanceNumberReq Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AcceptanceNumberReq() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_AcceptanceNumberReq {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_AcceptanceNumberReq {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AcceptanceNumberReq() : int;
function set U_AcceptanceNumberReq(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_BatchNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BatchNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BatchNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BatchNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchNumber() : String;
function set U_BatchNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_BinCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BinCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BinCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BinCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BinCode() : String;
function set U_BinCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_BpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BpCode() : String;
function set U_BpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_Closed Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Closed() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Closed {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Closed {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Closed() : DateTime;
function set U_Closed(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_ComplaintNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ComplaintNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ComplaintNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ComplaintNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ComplaintNo() : int;
function set U_ComplaintNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_Created Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property U_Created() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime U_Created {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime U_Created {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_Created() : DateTime;

   AppEnginePropertyIgnore()
function set U_Created(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_Description Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Description() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Description {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Description {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Description() : String;
function set U_Description(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_ElectronicSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ElectronicSign() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ElectronicSign {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ElectronicSign {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ElectronicSign() : String;
function set U_ElectronicSign(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_Footer Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Footer() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Footer {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Footer {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Footer() : String;
function set U_Footer(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_Header Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Header() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Header {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Header {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Header() : String;
function set U_Header(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_InsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InsCode() : String;
function set U_InsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_LotNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LotNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LotNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LotNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LotNumber() : String;
function set U_LotNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_MnfOprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MnfOprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MnfOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MnfOprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MnfOprCode() : String;
function set U_MnfOprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_MnfOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MnfOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_MnfOrder {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_MnfOrder {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MnfOrder() : int;
function set U_MnfOrder(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_NumberOfSamples Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_NumberOfSamples() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_NumberOfSamples {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_NumberOfSamples {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_NumberOfSamples() : int;
function set U_NumberOfSamples(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_OnHold Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OnHold() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_OnHold {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_OnHold {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OnHold() : DateTime;
function set U_OnHold(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_PassFailDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PassFailDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_PassFailDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_PassFailDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PassFailDate() : DateTime;
function set U_PassFailDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_PrjCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrjCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrjCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrjCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrjCode() : String;
function set U_PrjCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_QcTestPoolNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QcTestPoolNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_QcTestPoolNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_QcTestPoolNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QcTestPoolNo() : int;
function set U_QcTestPoolNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_RefersTo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RefersTo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RefersTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RefersTo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RefersTo() : String;
function set U_RefersTo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_RejectionNumberReq Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RejectionNumberReq() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RejectionNumberReq {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RejectionNumberReq {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RejectionNumberReq() : int;
function set U_RejectionNumberReq(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_RevCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevCode() : String;
function set U_RevCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_SampleSize Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SampleSize() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_SampleSize {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_SampleSize {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SampleSize() : double;
function set U_SampleSize(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_Start Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property U_Start() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime U_Start {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime U_Start {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_Start() : DateTime;

   AppEnginePropertyIgnore()
function set U_Start(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_Status Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Status {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Status() : String;
function set U_Status(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_TestProtocolNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestProtocolNo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TestProtocolNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TestProtocolNo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestProtocolNo() : String;
function set U_TestProtocolNo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_TestStatus Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestStatus() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TestStatus {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TestStatus {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestStatus() : String;
function set U_TestStatus(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_TransType Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TransType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TransType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TransType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TransType() : String;
function set U_TransType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_WaitingNcmr Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WaitingNcmr() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_WaitingNcmr {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_WaitingNcmr {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WaitingNcmr() : DateTime;
function set U_WaitingNcmr(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.U_WhsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool Methods

IQualityControlTestPool Interface See Also

The following tables list the members exposed by the IQualityControlTestPool type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | CheckIfTestStatusOfQCTestPoolIsCorrect | Check if Status of Quality Control Test Pool document is correct.
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | SetDefaultSeries | Sets the default series for Quality Control Test Pool document.
Public method | SetQCPoolTestsStatus | Sets QC Status for Quality Control Test Pool document.
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IQualityControlTestPool Interface
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.CheckIfTestStatusOfQCTestPoolIsCorrect Method

Check if Status of Quality Control Test Pool document is correct.

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CheckIfTestStatusOfQCTestPoolIsCorrect() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int CheckIfTestStatusOfQCTestPoolIsCorrect()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int CheckIfTestStatusOfQCTestPoolIsCorrect()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CheckIfTestStatusOfQCTestPoolIsCorrect() : int;
This language is not supported or no code example is available.

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.SetDefaultSeries Method

Sets the default series for Quality Control Test Pool document.

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub SetDefaultSeries()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void SetDefaultSeries()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void SetDefaultSeries()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function SetDefaultSeries();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


IQualityControlTestPool.SetQCPoolTestsStatus Method

Sets QC Status for Quality Control Test Pool document.

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function SetQCPoolTestsStatus() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool SetQCPoolTestsStatus()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool SetQCPoolTestsStatus()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function SetQCPoolTestsStatus() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestPool Interface
IQualityControlTestPool Members
CompuTec.ProcessForce.API.Documents.QualityControl.QualityControlTestPool Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IReason | Reason object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IReason Interface

Members See Also

Reason object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "Reason", TableName = "@CT_PF_ORSN")> _
Public Interface IReason
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Reason", TableName = "@CT_PF_ORSN")]
public interface IReason : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Reason", TableName = "@CT_PF_ORSN")]
public interface class IReason : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "Reason", TableName = "@CT_PF_ORSN")
interface IReason
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ORSN
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason Members

IReason Interface Methods Properties See Also

Reason object

The following tables list the members exposed by the IReason type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_ReasonGroupName |
Public property | DS_ReasonGroupRemarks |
Public property | DS_ReasonGroupTableCode |
Public property | DS_UsedCount |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_RsnCode |
Public property | U_RsnGrpCode |
Public property | U_RsnName |
Public property | U_RsnRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IReason Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason Properties

IReason Interface See Also

The following tables list the members exposed by the IReason type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_ReasonGroupName |
Public property | DS_ReasonGroupRemarks |
Public property | DS_ReasonGroupTableCode |
Public property | DS_UsedCount |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_RsnCode |
Public property | U_RsnGrpCode |
Public property | U_RsnName |
Public property | U_RsnRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IReason Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.DS_ReasonGroupName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ReasonGroupName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ReasonGroupName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ReasonGroupName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ReasonGroupName() : String;

   AppEnginePropertyIgnore()
function set DS_ReasonGroupName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.DS_ReasonGroupRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ReasonGroupRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ReasonGroupRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ReasonGroupRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ReasonGroupRemarks() : String;

   AppEnginePropertyIgnore()
function set DS_ReasonGroupRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.DS_ReasonGroupTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ReasonGroupTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ReasonGroupTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ReasonGroupTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ReasonGroupTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_ReasonGroupTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.DS_UsedCount Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_UsedCount() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_UsedCount {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_UsedCount {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_UsedCount() : String;

   AppEnginePropertyIgnore()
function set DS_UsedCount(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.U_RsnCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_RsnCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_RsnCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_RsnCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_RsnCode() : String;

   AppEngineProperty(Required = true)
function set U_RsnCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.U_RsnGrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RsnGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RsnGrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RsnGrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RsnGrpCode() : String;
function set U_RsnGrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.U_RsnName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RsnName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RsnName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RsnName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RsnName() : String;
function set U_RsnName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.U_RsnRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RsnRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RsnRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RsnRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RsnRemarks() : String;
function set U_RsnRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Reason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReason Interface
IReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


IReason Methods

IReason Interface See Also

The following tables list the members exposed by the IReason type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IReason Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Reason Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IReasonGroup | Reason group object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IReasonGroup Interface

Members See Also

Reason group object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ReasonGroup", TableName = "@CT_PF_ORSG")> _
<AppEngineType(TypeName = "ReasonGroupQualityControl")> _
Public Interface IReasonGroup
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ReasonGroup", TableName = "@CT_PF_ORSG")]
[AppEngineType(TypeName = "ReasonGroupQualityControl")]
public interface IReasonGroup : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ReasonGroup", TableName = "@CT_PF_ORSG")]
[AppEngineType(TypeName = "ReasonGroupQualityControl")]
public interface class IReasonGroup : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ReasonGroup", TableName = "@CT_PF_ORSG")
   AppEngineType(TypeName = "ReasonGroupQualityControl")
interface IReasonGroup
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ORSG
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


IReasonGroup Members

IReasonGroup Interface Methods Properties See Also

Reason group object

The following tables list the members exposed by the IReasonGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_RsnGrpCode |
Public property | U_RsnGrpName |
Public property | U_RsnGrpRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IReasonGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


IReasonGroup Properties

IReasonGroup Interface See Also

The following tables list the members exposed by the IReasonGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_RsnGrpCode |
Public property | U_RsnGrpName |
Public property | U_RsnGrpRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IReasonGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


IReasonGroup.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


IReasonGroup.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


IReasonGroup.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


IReasonGroup.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


IReasonGroup.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


IReasonGroup.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


IReasonGroup.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


IReasonGroup.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


IReasonGroup.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


IReasonGroup.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


IReasonGroup.U_RsnGrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_RsnGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_RsnGrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_RsnGrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_RsnGrpCode() : String;

   AppEngineProperty(Required = true)
function set U_RsnGrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


IReasonGroup.U_RsnGrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RsnGrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RsnGrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RsnGrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RsnGrpName() : String;
function set U_RsnGrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


IReasonGroup.U_RsnGrpRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RsnGrpRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RsnGrpRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RsnGrpRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RsnGrpRemarks() : String;
function set U_RsnGrpRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


IReasonGroup.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


IReasonGroup.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


IReasonGroup.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


IReasonGroup Methods

IReasonGroup Interface See Also

The following tables list the members exposed by the IReasonGroup type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IReasonGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonGroup Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IReasonNcmr | Reason ncmr object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IReasonNcmr Interface

Members See Also

Reason ncmr object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ReasonNcmr", TableName = "@CT_PF_ORNN")> _
Public Interface IReasonNcmr
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ReasonNcmr", TableName = "@CT_PF_ORNN")]
public interface IReasonNcmr : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ReasonNcmr", TableName = "@CT_PF_ORNN")]
public interface class IReasonNcmr : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ReasonNcmr", TableName = "@CT_PF_ORNN")
interface IReasonNcmr
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ORNN
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr Members

IReasonNcmr Interface Methods Properties See Also

Reason ncmr object

The following tables list the members exposed by the IReasonNcmr type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_ReasonGroupName |
Public property | DS_ReasonGroupRemarks |
Public property | DS_ReasonGroupTableCode |
Public property | DS_UsedCount |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_RsnCode |
Public property | U_RsnGrpCode |
Public property | U_RsnName |
Public property | U_RsnRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IReasonNcmr Interface
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr Properties

IReasonNcmr Interface See Also

The following tables list the members exposed by the IReasonNcmr type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_ReasonGroupName |
Public property | DS_ReasonGroupRemarks |
Public property | DS_ReasonGroupTableCode |
Public property | DS_UsedCount |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_RsnCode |
Public property | U_RsnGrpCode |
Public property | U_RsnName |
Public property | U_RsnRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IReasonNcmr Interface
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.DS_ReasonGroupName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ReasonGroupName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ReasonGroupName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ReasonGroupName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ReasonGroupName() : String;

   AppEnginePropertyIgnore()
function set DS_ReasonGroupName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.DS_ReasonGroupRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ReasonGroupRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ReasonGroupRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ReasonGroupRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ReasonGroupRemarks() : String;

   AppEnginePropertyIgnore()
function set DS_ReasonGroupRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.DS_ReasonGroupTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ReasonGroupTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ReasonGroupTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ReasonGroupTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ReasonGroupTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_ReasonGroupTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.DS_UsedCount Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_UsedCount() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_UsedCount {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_UsedCount {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_UsedCount() : String;

   AppEnginePropertyIgnore()
function set DS_UsedCount(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.U_RsnCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_RsnCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_RsnCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_RsnCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_RsnCode() : String;

   AppEngineProperty(Required = true)
function set U_RsnCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.U_RsnGrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RsnGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RsnGrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RsnGrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RsnGrpCode() : String;
function set U_RsnGrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.U_RsnName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RsnName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RsnName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RsnName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RsnName() : String;
function set U_RsnName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.U_RsnRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RsnRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RsnRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RsnRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RsnRemarks() : String;
function set U_RsnRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonNcmr Interface
IReasonNcmr Members
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


IReasonNcmr Methods

IReasonNcmr Interface See Also

The following tables list the members exposed by the IReasonNcmr type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IReasonNcmr Interface
CompuTec.ProcessForce.API.Documents.QualityControl.ReasonNcmr Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ITestProperty | Test property object
Public interface | ITestPropertyWords | Words for test property object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ITestProperty Interface

Members See Also

Test property object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "TestProperty", TableName = "@CT_PF_OTPR")> _
Public Interface ITestProperty
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "TestProperty", TableName = "@CT_PF_OTPR")]
public interface ITestProperty : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "TestProperty", TableName = "@CT_PF_OTPR")]
public interface class ITestProperty : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "TestProperty", TableName = "@CT_PF_OTPR")
interface ITestProperty
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OTPR
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty Members

ITestProperty Interface Methods Properties See Also

Test property object

The following tables list the members exposed by the ITestProperty type.

Properties
 | Name | Description
Public property | BusinessPartnerRelations |
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_TestPropertyGroupName |
Public property | DS_TestPropertyGroupRemarks |
Public property | DS_TestPropertyGroupTableCode |
Public property | DS_UsedCount |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_TestPrpCode |
Public property | U_TestPrpGrpCode |
Public property | U_TestPrpName |
Public property | U_TestPrpRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Public property | Words |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ITestProperty Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty Properties

ITestProperty Interface See Also

The following tables list the members exposed by the ITestProperty type.

Properties
 | Name | Description
Public property | BusinessPartnerRelations |
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_TestPropertyGroupName |
Public property | DS_TestPropertyGroupRemarks |
Public property | DS_TestPropertyGroupTableCode |
Public property | DS_UsedCount |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_TestPrpCode |
Public property | U_TestPrpGrpCode |
Public property | U_TestPrpName |
Public property | U_TestPrpRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Public property | Words |
Top
See Also

Reference

ITestProperty Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.BusinessPartnerRelations Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BusinessPartnerRelations() As IBusinessPartnerRelations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBusinessPartnerRelations BusinessPartnerRelations {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBusinessPartnerRelations^ BusinessPartnerRelations {
 IBusinessPartnerRelations^ get( );
 void set(
   IBusinessPartnerRelations^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BusinessPartnerRelations() : IBusinessPartnerRelations;
function set BusinessPartnerRelations(value : IBusinessPartnerRelations);
This language is not supported or no code example is available.

Property Value

Type: IBusinessPartnerRelations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.DS_TestPropertyGroupName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_TestPropertyGroupName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_TestPropertyGroupName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_TestPropertyGroupName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_TestPropertyGroupName() : String;

   AppEnginePropertyIgnore()
function set DS_TestPropertyGroupName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.DS_TestPropertyGroupRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_TestPropertyGroupRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_TestPropertyGroupRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_TestPropertyGroupRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_TestPropertyGroupRemarks() : String;

   AppEnginePropertyIgnore()
function set DS_TestPropertyGroupRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.DS_TestPropertyGroupTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_TestPropertyGroupTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_TestPropertyGroupTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_TestPropertyGroupTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_TestPropertyGroupTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_TestPropertyGroupTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.DS_UsedCount Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_UsedCount() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_UsedCount {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_UsedCount {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_UsedCount() : String;

   AppEnginePropertyIgnore()
function set DS_UsedCount(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.U_TestPrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_TestPrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_TestPrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_TestPrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_TestPrpCode() : String;

   AppEngineProperty(Required = true)
function set U_TestPrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.U_TestPrpGrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestPrpGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TestPrpGrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TestPrpGrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestPrpGrpCode() : String;
function set U_TestPrpGrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.U_TestPrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestPrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TestPrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TestPrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestPrpName() : String;
function set U_TestPrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.U_TestPrpRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestPrpRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TestPrpRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TestPrpRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestPrpRemarks() : String;
function set U_TestPrpRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty.Words Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Words() As ITestPropertyWords
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ITestPropertyWords Words {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ITestPropertyWords^ Words {
 ITestPropertyWords^ get( );
 void set(
   ITestPropertyWords^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Words() : ITestPropertyWords;
function set Words(value : ITestPropertyWords);
This language is not supported or no code example is available.

Property Value

Type: ITestPropertyWords
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProperty Interface
ITestProperty Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestProperty Methods

ITestProperty Interface See Also

The following tables list the members exposed by the ITestProperty type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ITestProperty Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestPropertyWords Interface

Members See Also

Words for test property object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface ITestPropertyWords
    Inherits IUDOChildBean, _
             IEnumerable(Of ITestPropertyWords)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface ITestPropertyWords : IUDOChildBean,
   IEnumerable<ITestPropertyWords>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class ITestPropertyWords : public IUDOChildBean^,
   public IEnumerable<ITestPropertyWords^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_TPR1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyWords Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestPropertyWords Members

ITestPropertyWords Interface Methods Properties See Also

Words for test property object

The following tables list the members exposed by the ITestPropertyWords type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_WordName |
Public property | DS_WordRemarks |
Public property | DS_WordTableCode |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_WordCode |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ITestPropertyWords Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestPropertyWords Properties

ITestPropertyWords Interface See Also

The following tables list the members exposed by the ITestPropertyWords type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_WordName |
Public property | DS_WordRemarks |
Public property | DS_WordTableCode |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_WordCode |
Top
See Also

Reference

ITestPropertyWords Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestPropertyWords.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyWords Interface
ITestPropertyWords Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestPropertyWords.DS_WordName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_WordName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_WordName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_WordName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_WordName() : String;

   AppEnginePropertyIgnore()
function set DS_WordName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyWords Interface
ITestPropertyWords Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestPropertyWords.DS_WordRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_WordRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_WordRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_WordRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_WordRemarks() : String;

   AppEnginePropertyIgnore()
function set DS_WordRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyWords Interface
ITestPropertyWords Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestPropertyWords.DS_WordTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_WordTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_WordTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_WordTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_WordTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_WordTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyWords Interface
ITestPropertyWords Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestPropertyWords.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyWords Interface
ITestPropertyWords Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestPropertyWords.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyWords Interface
ITestPropertyWords Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestPropertyWords.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyWords Interface
ITestPropertyWords Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestPropertyWords.U_WordCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyWords Interface
ITestPropertyWords Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


ITestPropertyWords Methods

ITestPropertyWords Interface See Also

The following tables list the members exposed by the ITestPropertyWords type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ITestPropertyWords Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProperty Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ITestPropertyGroup | Test property group object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ITestPropertyGroup Interface

Members See Also

Test property group object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "TestPropertyGroup", TableName = "@CT_PF_OTPG")> _
Public Interface ITestPropertyGroup
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "TestPropertyGroup", TableName = "@CT_PF_OTPG")]
public interface ITestPropertyGroup : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "TestPropertyGroup", TableName = "@CT_PF_OTPG")]
public interface class ITestPropertyGroup : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "TestPropertyGroup", TableName = "@CT_PF_OTPG")
interface ITestPropertyGroup
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OTPG
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


ITestPropertyGroup Members

ITestPropertyGroup Interface Methods Properties See Also

Test property group object

The following tables list the members exposed by the ITestPropertyGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_TestPrpGrpCode |
Public property | U_TestPrpGrpName |
Public property | U_TestPrpGrpRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ITestPropertyGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


ITestPropertyGroup Properties

ITestPropertyGroup Interface See Also

The following tables list the members exposed by the ITestPropertyGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_TestPrpGrpCode |
Public property | U_TestPrpGrpName |
Public property | U_TestPrpGrpRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

ITestPropertyGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


ITestPropertyGroup.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyGroup Interface
ITestPropertyGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


ITestPropertyGroup.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyGroup Interface
ITestPropertyGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


ITestPropertyGroup.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyGroup Interface
ITestPropertyGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


ITestPropertyGroup.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyGroup Interface
ITestPropertyGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


ITestPropertyGroup.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyGroup Interface
ITestPropertyGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


ITestPropertyGroup.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyGroup Interface
ITestPropertyGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


ITestPropertyGroup.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyGroup Interface
ITestPropertyGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


ITestPropertyGroup.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyGroup Interface
ITestPropertyGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


ITestPropertyGroup.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyGroup Interface
ITestPropertyGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


ITestPropertyGroup.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyGroup Interface
ITestPropertyGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


ITestPropertyGroup.U_TestPrpGrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_TestPrpGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_TestPrpGrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_TestPrpGrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_TestPrpGrpCode() : String;

   AppEngineProperty(Required = true)
function set U_TestPrpGrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyGroup Interface
ITestPropertyGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


ITestPropertyGroup.U_TestPrpGrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestPrpGrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TestPrpGrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TestPrpGrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestPrpGrpName() : String;
function set U_TestPrpGrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyGroup Interface
ITestPropertyGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


ITestPropertyGroup.U_TestPrpGrpRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestPrpGrpRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TestPrpGrpRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TestPrpGrpRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestPrpGrpRemarks() : String;
function set U_TestPrpGrpRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyGroup Interface
ITestPropertyGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


ITestPropertyGroup.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyGroup Interface
ITestPropertyGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


ITestPropertyGroup.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyGroup Interface
ITestPropertyGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


ITestPropertyGroup.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestPropertyGroup Interface
ITestPropertyGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


ITestPropertyGroup Methods

ITestPropertyGroup Interface See Also

The following tables list the members exposed by the ITestPropertyGroup type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ITestPropertyGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestPropertyGroup Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ITestProtocol | Test protocol object
Public interface | ITestProtocolAttachments | Attachment for test protocol object
Public interface | ITestProtocolItemProperties | Item properties for test protocol object
Public interface | ITestProtocolItems | Items for test protocol object
Public interface | ITestProtocolProperties | Properties for test protocol object
Public interface | ITestProtocolResources | Resources for test protocol object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ITestProtocol Interface

Members See Also

Test protocol object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "TestProtocol", TableName = "@CT_PF_OTCL")> _
Public Interface ITestProtocol
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "TestProtocol", TableName = "@CT_PF_OTCL")]
public interface ITestProtocol : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "TestProtocol", TableName = "@CT_PF_OTCL")]
public interface class ITestProtocol : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "TestProtocol", TableName = "@CT_PF_OTCL")
interface ITestProtocol
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OTCL
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol Members

ITestProtocol Interface Methods Properties See Also

Test protocol object

The following tables list the members exposed by the ITestProtocol type.

Properties
 | Name | Description
Public property | Attachments |
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_GroupName |
Public property | DS_GroupTableCode |
Public property | DS_ItemName |
Public property | DS_ItemUnitOfMeasure |
Public property | DS_RevisionName |
Public property | DS_TestProtocolTemplateName |
Public property | DS_TestProtocolTemplateTableCode |
Public property | DS_TransactionOperationTableCode |
Public property | DS_UsedCount |
Public property | DS_WarehouseName |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | ItemProperties |
Public property | ItemPropertiesBusinessPartnerRelations |
Public property | Items |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Properties |
Public property | PropertiesBusinessPartnerRelations |
Public property | Resources |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_BinCode |
Public property | U_FrqARObligatory |
Public property | U_FrqAcceptanceNumber |
Public property | U_FrqAfterNoBatch |
Public property | U_FrqAutoCreate |
Public property | U_FrqCreatePool |
Public property | U_FrqInputQuantityFrom |
Public property | U_FrqInputQuantityTo |
Public property | U_FrqLastTestDate |
Public property | U_FrqNextTestDate |
Public property | U_FrqNumberOfSamples |
Public property | U_FrqPercentage |
Public property | U_FrqQuantity |
Public property | U_FrqRecInspDate |
Public property | U_FrqRefersTo |
Public property | U_FrqRejectionNumber |
Public property | U_FrqRemarks |
Public property | U_FrqSpecDate |
Public property | U_FrqTimeBtwnTests |
Public property | U_FrqUoM |
Public property | U_GrpCode |
Public property | U_Instructions |
Public property | U_ItemCode |
Public property | U_Project |
Public property | U_RevCode |
Public property | U_StockTrans |
Public property | U_TemplateCode |
Public property | U_TestPrclCode |
Public property | U_TestPrclName |
Public property | U_TrsCpl |
Public property | U_TrsInvBtchReTest |
Public property | U_TrsInvSnReTest |
Public property | U_TrsMnfGdsRcpt |
Public property | U_TrsMnfOrder |
Public property | U_TrsMnfPickRcpt |
Public property | U_TrsMnfPickRcptBp |
Public property | U_TrsOprCode |
Public property | U_TrsPurApInv |
Public property | U_TrsPurGdsRcptPo |
Public property | U_TrsPurGdsRcptPoBp |
Public property | U_ValidFrom |
Public property | U_ValidTo |
Public property | U_WhsCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Public method | UpdateItemPropertiesFromItemDetails | Updates Item Properties from Item Details.
Top
See Also

Reference

ITestProtocol Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol Properties

ITestProtocol Interface See Also

The following tables list the members exposed by the ITestProtocol type.

Properties
 | Name | Description
Public property | Attachments |
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_GroupName |
Public property | DS_GroupTableCode |
Public property | DS_ItemName |
Public property | DS_ItemUnitOfMeasure |
Public property | DS_RevisionName |
Public property | DS_TestProtocolTemplateName |
Public property | DS_TestProtocolTemplateTableCode |
Public property | DS_TransactionOperationTableCode |
Public property | DS_UsedCount |
Public property | DS_WarehouseName |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | ItemProperties |
Public property | ItemPropertiesBusinessPartnerRelations |
Public property | Items |
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Properties |
Public property | PropertiesBusinessPartnerRelations |
Public property | Resources |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_BinCode |
Public property | U_FrqARObligatory |
Public property | U_FrqAcceptanceNumber |
Public property | U_FrqAfterNoBatch |
Public property | U_FrqAutoCreate |
Public property | U_FrqCreatePool |
Public property | U_FrqInputQuantityFrom |
Public property | U_FrqInputQuantityTo |
Public property | U_FrqLastTestDate |
Public property | U_FrqNextTestDate |
Public property | U_FrqNumberOfSamples |
Public property | U_FrqPercentage |
Public property | U_FrqQuantity |
Public property | U_FrqRecInspDate |
Public property | U_FrqRefersTo |
Public property | U_FrqRejectionNumber |
Public property | U_FrqRemarks |
Public property | U_FrqSpecDate |
Public property | U_FrqTimeBtwnTests |
Public property | U_FrqUoM |
Public property | U_GrpCode |
Public property | U_Instructions |
Public property | U_ItemCode |
Public property | U_Project |
Public property | U_RevCode |
Public property | U_StockTrans |
Public property | U_TemplateCode |
Public property | U_TestPrclCode |
Public property | U_TestPrclName |
Public property | U_TrsCpl |
Public property | U_TrsInvBtchReTest |
Public property | U_TrsInvSnReTest |
Public property | U_TrsMnfGdsRcpt |
Public property | U_TrsMnfOrder |
Public property | U_TrsMnfPickRcpt |
Public property | U_TrsMnfPickRcptBp |
Public property | U_TrsOprCode |
Public property | U_TrsPurApInv |
Public property | U_TrsPurGdsRcptPo |
Public property | U_TrsPurGdsRcptPoBp |
Public property | U_ValidFrom |
Public property | U_ValidTo |
Public property | U_WhsCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

ITestProtocol Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.Attachments Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property Attachments() As ITestProtocolAttachments
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
ITestProtocolAttachments Attachments {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property ITestProtocolAttachments^ Attachments {
 ITestProtocolAttachments^ get( );
 void set(
   ITestProtocolAttachments^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Attachments() : ITestProtocolAttachments;

   AppEnginePropertyIgnore()
function set Attachments(value : ITestProtocolAttachments);
This language is not supported or no code example is available.

Property Value

Type: ITestProtocolAttachments
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.DS_GroupName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_GroupName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_GroupName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_GroupName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_GroupName() : String;

   AppEnginePropertyIgnore()
function set DS_GroupName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.DS_GroupTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_GroupTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_GroupTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_GroupTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_GroupTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_GroupTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.DS_ItemName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemName() : String;

   AppEnginePropertyIgnore()
function set DS_ItemName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.DS_ItemUnitOfMeasure Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ItemUnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemUnitOfMeasure {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemUnitOfMeasure {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemUnitOfMeasure() : String;

   AppEnginePropertyIgnore()
function set DS_ItemUnitOfMeasure(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.DS_RevisionName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_RevisionName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_RevisionName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_RevisionName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_RevisionName() : String;

   AppEnginePropertyIgnore()
function set DS_RevisionName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.DS_TestProtocolTemplateName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_TestProtocolTemplateName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_TestProtocolTemplateName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_TestProtocolTemplateName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_TestProtocolTemplateName() : String;

   AppEnginePropertyIgnore()
function set DS_TestProtocolTemplateName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.DS_TestProtocolTemplateTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_TestProtocolTemplateTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_TestProtocolTemplateTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_TestProtocolTemplateTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_TestProtocolTemplateTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_TestProtocolTemplateTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.DS_TransactionOperationTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_TransactionOperationTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_TransactionOperationTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_TransactionOperationTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_TransactionOperationTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_TransactionOperationTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.DS_UsedCount Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_UsedCount() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_UsedCount {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_UsedCount {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_UsedCount() : String;

   AppEnginePropertyIgnore()
function set DS_UsedCount(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.DS_WarehouseName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_WarehouseName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_WarehouseName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_WarehouseName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_WarehouseName() : String;

   AppEnginePropertyIgnore()
function set DS_WarehouseName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.ItemProperties Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ItemProperties() As ITestProtocolItemProperties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ITestProtocolItemProperties ItemProperties {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ITestProtocolItemProperties^ ItemProperties {
 ITestProtocolItemProperties^ get( );
 void set(
   ITestProtocolItemProperties^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ItemProperties() : ITestProtocolItemProperties;
function set ItemProperties(value : ITestProtocolItemProperties);
This language is not supported or no code example is available.

Property Value

Type: ITestProtocolItemProperties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.ItemPropertiesBusinessPartnerRelations Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ItemPropertiesBusinessPartnerRelations() As IBusinessPartnerRelationsThridLevel
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBusinessPartnerRelationsThridLevel ItemPropertiesBusinessPartnerRelations {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBusinessPartnerRelationsThridLevel^ ItemPropertiesBusinessPartnerRelations {
 IBusinessPartnerRelationsThridLevel^ get( );
 void set(
   IBusinessPartnerRelationsThridLevel^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ItemPropertiesBusinessPartnerRelations() : IBusinessPartnerRelationsThridLevel;
function set ItemPropertiesBusinessPartnerRelations(value : IBusinessPartnerRelationsThridLevel);
This language is not supported or no code example is available.

Property Value

Type: IBusinessPartnerRelationsThridLevel
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.Items Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Items() As ITestProtocolItems
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ITestProtocolItems Items {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ITestProtocolItems^ Items {
 ITestProtocolItems^ get( );
 void set(
   ITestProtocolItems^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Items() : ITestProtocolItems;
function set Items(value : ITestProtocolItems);
This language is not supported or no code example is available.

Property Value

Type: ITestProtocolItems
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.Properties Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Properties() As ITestProtocolProperties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ITestProtocolProperties Properties {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ITestProtocolProperties^ Properties {
 ITestProtocolProperties^ get( );
 void set(
   ITestProtocolProperties^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Properties() : ITestProtocolProperties;
function set Properties(value : ITestProtocolProperties);
This language is not supported or no code example is available.

Property Value

Type: ITestProtocolProperties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.PropertiesBusinessPartnerRelations Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property PropertiesBusinessPartnerRelations() As IBusinessPartnerRelationsThridLevel
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBusinessPartnerRelationsThridLevel PropertiesBusinessPartnerRelations {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBusinessPartnerRelationsThridLevel^ PropertiesBusinessPartnerRelations {
 IBusinessPartnerRelationsThridLevel^ get( );
 void set(
   IBusinessPartnerRelationsThridLevel^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get PropertiesBusinessPartnerRelations() : IBusinessPartnerRelationsThridLevel;
function set PropertiesBusinessPartnerRelations(value : IBusinessPartnerRelationsThridLevel);
This language is not supported or no code example is available.

Property Value

Type: IBusinessPartnerRelationsThridLevel
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.Resources Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Resources() As ITestProtocolResources
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ITestProtocolResources Resources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ITestProtocolResources^ Resources {
 ITestProtocolResources^ get( );
 void set(
   ITestProtocolResources^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Resources() : ITestProtocolResources;
function set Resources(value : ITestProtocolResources);
This language is not supported or no code example is available.

Property Value

Type: ITestProtocolResources
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_BinCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BinCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BinCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BinCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BinCode() : String;
function set U_BinCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_FrqARObligatory Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FrqARObligatory() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FrqARObligatory {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FrqARObligatory {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FrqARObligatory() : String;
function set U_FrqARObligatory(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_FrqAcceptanceNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FrqAcceptanceNumber() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_FrqAcceptanceNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_FrqAcceptanceNumber {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FrqAcceptanceNumber() : int;
function set U_FrqAcceptanceNumber(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_FrqAfterNoBatch Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FrqAfterNoBatch() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_FrqAfterNoBatch {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_FrqAfterNoBatch {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FrqAfterNoBatch() : int;
function set U_FrqAfterNoBatch(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_FrqAutoCreate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FrqAutoCreate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FrqAutoCreate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FrqAutoCreate {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FrqAutoCreate() : String;
function set U_FrqAutoCreate(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_FrqCreatePool Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FrqCreatePool() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FrqCreatePool {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FrqCreatePool {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FrqCreatePool() : String;
function set U_FrqCreatePool(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_FrqInputQuantityFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FrqInputQuantityFrom() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FrqInputQuantityFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FrqInputQuantityFrom {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FrqInputQuantityFrom() : double;
function set U_FrqInputQuantityFrom(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_FrqInputQuantityTo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FrqInputQuantityTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FrqInputQuantityTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FrqInputQuantityTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FrqInputQuantityTo() : double;
function set U_FrqInputQuantityTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_FrqLastTestDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FrqLastTestDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_FrqLastTestDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_FrqLastTestDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FrqLastTestDate() : DateTime;
function set U_FrqLastTestDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_FrqNextTestDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FrqNextTestDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_FrqNextTestDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_FrqNextTestDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FrqNextTestDate() : DateTime;
function set U_FrqNextTestDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_FrqNumberOfSamples Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FrqNumberOfSamples() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_FrqNumberOfSamples {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_FrqNumberOfSamples {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FrqNumberOfSamples() : int;
function set U_FrqNumberOfSamples(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_FrqPercentage Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FrqPercentage() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FrqPercentage {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FrqPercentage {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FrqPercentage() : String;
function set U_FrqPercentage(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_FrqQuantity Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FrqQuantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_FrqQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_FrqQuantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FrqQuantity() : double;
function set U_FrqQuantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_FrqRecInspDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FrqRecInspDate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FrqRecInspDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FrqRecInspDate {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FrqRecInspDate() : String;
function set U_FrqRecInspDate(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_FrqRefersTo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FrqRefersTo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FrqRefersTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FrqRefersTo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FrqRefersTo() : String;
function set U_FrqRefersTo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_FrqRejectionNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FrqRejectionNumber() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_FrqRejectionNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_FrqRejectionNumber {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FrqRejectionNumber() : int;
function set U_FrqRejectionNumber(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_FrqRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FrqRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FrqRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FrqRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FrqRemarks() : String;
function set U_FrqRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_FrqSpecDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FrqSpecDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_FrqSpecDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_FrqSpecDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FrqSpecDate() : DateTime;
function set U_FrqSpecDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_FrqTimeBtwnTests Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FrqTimeBtwnTests() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FrqTimeBtwnTests {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FrqTimeBtwnTests {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FrqTimeBtwnTests() : String;
function set U_FrqTimeBtwnTests(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_FrqUoM Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FrqUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FrqUoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FrqUoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FrqUoM() : String;
function set U_FrqUoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_GrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpCode() : String;
function set U_GrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_Instructions Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Instructions() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Instructions {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Instructions {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Instructions() : String;
function set U_Instructions(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_Project Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Project() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Project {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Project {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Project() : String;
function set U_Project(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_RevCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevCode() : String;
function set U_RevCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_StockTrans Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StockTrans() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_StockTrans {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_StockTrans {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockTrans() : String;
function set U_StockTrans(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_TemplateCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TemplateCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TemplateCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TemplateCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TemplateCode() : String;
function set U_TemplateCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_TestPrclCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_TestPrclCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_TestPrclCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_TestPrclCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_TestPrclCode() : String;

   AppEngineProperty(Required = true)
function set U_TestPrclCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_TestPrclName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestPrclName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TestPrclName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TestPrclName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestPrclName() : String;
function set U_TestPrclName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_TrsCpl Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TrsCpl() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TrsCpl {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TrsCpl {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TrsCpl() : String;
function set U_TrsCpl(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_TrsInvBtchReTest Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TrsInvBtchReTest() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TrsInvBtchReTest {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TrsInvBtchReTest {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TrsInvBtchReTest() : String;
function set U_TrsInvBtchReTest(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_TrsInvSnReTest Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TrsInvSnReTest() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TrsInvSnReTest {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TrsInvSnReTest {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TrsInvSnReTest() : String;
function set U_TrsInvSnReTest(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_TrsMnfGdsRcpt Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TrsMnfGdsRcpt() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TrsMnfGdsRcpt {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TrsMnfGdsRcpt {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TrsMnfGdsRcpt() : String;
function set U_TrsMnfGdsRcpt(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_TrsMnfOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TrsMnfOrder() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TrsMnfOrder {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TrsMnfOrder {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TrsMnfOrder() : String;
function set U_TrsMnfOrder(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_TrsMnfPickRcpt Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TrsMnfPickRcpt() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TrsMnfPickRcpt {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TrsMnfPickRcpt {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TrsMnfPickRcpt() : String;
function set U_TrsMnfPickRcpt(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_TrsMnfPickRcptBp Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TrsMnfPickRcptBp() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TrsMnfPickRcptBp {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TrsMnfPickRcptBp {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TrsMnfPickRcptBp() : String;
function set U_TrsMnfPickRcptBp(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_TrsOprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TrsOprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TrsOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TrsOprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TrsOprCode() : String;
function set U_TrsOprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_TrsPurApInv Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TrsPurApInv() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TrsPurApInv {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TrsPurApInv {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TrsPurApInv() : String;
function set U_TrsPurApInv(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_TrsPurGdsRcptPo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TrsPurGdsRcptPo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TrsPurGdsRcptPo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TrsPurGdsRcptPo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TrsPurGdsRcptPo() : String;
function set U_TrsPurGdsRcptPo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_TrsPurGdsRcptPoBp Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TrsPurGdsRcptPoBp() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TrsPurGdsRcptPoBp {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TrsPurGdsRcptPoBp {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TrsPurGdsRcptPoBp() : String;
function set U_TrsPurGdsRcptPoBp(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_ValidFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidFrom() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidFrom {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidFrom() : DateTime;
function set U_ValidFrom(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_ValidTo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidTo() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidTo {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidTo() : DateTime;
function set U_ValidTo(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.U_WhsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol Methods

ITestProtocol Interface See Also

The following tables list the members exposed by the ITestProtocol type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Public method | UpdateItemPropertiesFromItemDetails | Updates Item Properties from Item Details.
Top
See Also

Reference

ITestProtocol Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocol.UpdateItemPropertiesFromItemDetails Method

Updates Item Properties from Item Details.

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub UpdateItemPropertiesFromItemDetails()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void UpdateItemPropertiesFromItemDetails()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void UpdateItemPropertiesFromItemDetails()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function UpdateItemPropertiesFromItemDetails();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocol Interface
ITestProtocol Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolAttachments Interface

Members See Also

Attachment for test protocol object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ITestProtocolAttachments
    Inherits IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ITestProtocolAttachments : IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ITestProtocolAttachments : public IUDOChildBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ITestProtocolAttachments
   implements IUDOChildBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_TCL5
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolAttachments Members

ITestProtocolAttachments Interface Methods Properties See Also

Attachment for test protocol object

The following tables list the members exposed by the ITestProtocolAttachments type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AttDate |
Public property | U_FileName |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Path |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

ITestProtocolAttachments Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolAttachments Properties

ITestProtocolAttachments Interface See Also

The following tables list the members exposed by the ITestProtocolAttachments type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AttDate |
Public property | U_FileName |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Path |
Top
See Also

Reference

ITestProtocolAttachments Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolAttachments.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolAttachments Interface
ITestProtocolAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolAttachments.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolAttachments Interface
ITestProtocolAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolAttachments.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolAttachments Interface
ITestProtocolAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolAttachments.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolAttachments Interface
ITestProtocolAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolAttachments.U_AttDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_AttDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_AttDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttDate() : DateTime;
function set U_AttDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolAttachments Interface
ITestProtocolAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolAttachments.U_FileName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FileName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FileName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FileName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FileName() : String;
function set U_FileName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolAttachments Interface
ITestProtocolAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolAttachments.U_Path Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Path() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Path {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Path {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Path() : String;
function set U_Path(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolAttachments Interface
ITestProtocolAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolAttachments Methods

ITestProtocolAttachments Interface See Also

The following tables list the members exposed by the ITestProtocolAttachments type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

ITestProtocolAttachments Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties Interface

Members See Also

Item properties for test protocol object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface ITestProtocolItemProperties
    Inherits IUDOChildBean, _
             IEnumerable(Of ITestProtocolItemProperties)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface ITestProtocolItemProperties : IUDOChildBean,
   IEnumerable<ITestProtocolItemProperties>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class ITestProtocolItemProperties : public IUDOChildBean^,
   public IEnumerable<ITestProtocolItemProperties^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_TCL6
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties Members

ITestProtocolItemProperties Interface Methods Properties See Also

Item properties for test protocol object

The following tables list the members exposed by the ITestProtocolItemProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_CreateDate |
Public property | DS_PropertyName |
Public property | DS_PropertyTableCode |
Public property | DS_ReferenceName |
Public property | DS_ReferenceTableCode |
Public property | DS_UnitOfMeasure |
Public property | DS_UpdateDate |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Expression |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PrpCode |
Public property | U_RangeValueFrom |
Public property | U_RangeValueTo |
Public property | U_RefCode |
Public property | U_Remarks |
Public property | U_ValidFromDate |
Public property | U_ValidToDate |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ITestProtocolItemProperties Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties Properties

ITestProtocolItemProperties Interface See Also

The following tables list the members exposed by the ITestProtocolItemProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_CreateDate |
Public property | DS_PropertyName |
Public property | DS_PropertyTableCode |
Public property | DS_ReferenceName |
Public property | DS_ReferenceTableCode |
Public property | DS_UnitOfMeasure |
Public property | DS_UpdateDate |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Expression |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PrpCode |
Public property | U_RangeValueFrom |
Public property | U_RangeValueTo |
Public property | U_RefCode |
Public property | U_Remarks |
Public property | U_ValidFromDate |
Public property | U_ValidToDate |
Top
See Also

Reference

ITestProtocolItemProperties Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Interface
ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties.DS_CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_CreateDate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_CreateDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_CreateDate {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_CreateDate() : String;

   AppEnginePropertyIgnore()
function set DS_CreateDate(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Interface
ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties.DS_PropertyName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_PropertyName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_PropertyName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_PropertyName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_PropertyName() : String;

   AppEnginePropertyIgnore()
function set DS_PropertyName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Interface
ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties.DS_PropertyTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_PropertyTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_PropertyTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_PropertyTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_PropertyTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_PropertyTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Interface
ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties.DS_ReferenceName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ReferenceName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ReferenceName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ReferenceName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ReferenceName() : String;

   AppEnginePropertyIgnore()
function set DS_ReferenceName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Interface
ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties.DS_ReferenceTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ReferenceTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ReferenceTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ReferenceTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ReferenceTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_ReferenceTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Interface
ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties.DS_UnitOfMeasure Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_UnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_UnitOfMeasure {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_UnitOfMeasure {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_UnitOfMeasure() : String;

   AppEnginePropertyIgnore()
function set DS_UnitOfMeasure(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Interface
ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties.DS_UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_UpdateDate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_UpdateDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_UpdateDate {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_UpdateDate() : String;

   AppEnginePropertyIgnore()
function set DS_UpdateDate(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Interface
ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Interface
ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Interface
ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Interface
ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties.U_Expression Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Expression() As ConditionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ConditionType U_Expression {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ConditionType U_Expression {
 ConditionType get( );
 void set(
   ConditionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Expression() : ConditionType;
function set U_Expression(value : ConditionType);
This language is not supported or no code example is available.

Property Value

Type: ConditionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Interface
ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties.U_PrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpCode() : String;
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Interface
ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties.U_RangeValueFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RangeValueFrom() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RangeValueFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RangeValueFrom {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RangeValueFrom() : double;
function set U_RangeValueFrom(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Interface
ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties.U_RangeValueTo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RangeValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RangeValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RangeValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RangeValueTo() : double;
function set U_RangeValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Interface
ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties.U_RefCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RefCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RefCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RefCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RefCode() : String;
function set U_RefCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Interface
ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Interface
ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties.U_ValidFromDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidFromDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidFromDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidFromDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidFromDate() : DateTime;
function set U_ValidFromDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Interface
ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties.U_ValidToDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidToDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidToDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidToDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidToDate() : DateTime;
function set U_ValidToDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItemProperties Interface
ITestProtocolItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItemProperties Methods

ITestProtocolItemProperties Interface See Also

The following tables list the members exposed by the ITestProtocolItemProperties type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ITestProtocolItemProperties Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItems Interface

Members See Also

Items for test protocol object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface ITestProtocolItems
    Inherits IUDOChildBean, _
             IEnumerable(Of ITestProtocolItems)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface ITestProtocolItems : IUDOChildBean,
   IEnumerable<ITestProtocolItems>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class ITestProtocolItems : public IUDOChildBean^,
   public IEnumerable<ITestProtocolItems^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_TCL4
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItems Members

ITestProtocolItems Interface Methods Properties See Also

Items for test protocol object

The following tables list the members exposed by the ITestProtocolItems type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_CreateDate |
Public property | DS_ItemName |
Public property | DS_ItemUnitOfMeasure |
Public property | DS_UpdateDate |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ItemCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Quantity |
Public property | U_Remarks |
Public property | U_ValidFrom |
Public property | U_ValidTo |
Public property | U_WhsCode |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ITestProtocolItems Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItems Properties

ITestProtocolItems Interface See Also

The following tables list the members exposed by the ITestProtocolItems type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_CreateDate |
Public property | DS_ItemName |
Public property | DS_ItemUnitOfMeasure |
Public property | DS_UpdateDate |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ItemCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Quantity |
Public property | U_Remarks |
Public property | U_ValidFrom |
Public property | U_ValidTo |
Public property | U_WhsCode |
Top
See Also

Reference

ITestProtocolItems Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItems.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItems Interface
ITestProtocolItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItems.DS_CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_CreateDate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_CreateDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_CreateDate {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_CreateDate() : String;

   AppEnginePropertyIgnore()
function set DS_CreateDate(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItems Interface
ITestProtocolItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItems.DS_ItemName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemName() : String;

   AppEnginePropertyIgnore()
function set DS_ItemName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItems Interface
ITestProtocolItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItems.DS_ItemUnitOfMeasure Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ItemUnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemUnitOfMeasure {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemUnitOfMeasure {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemUnitOfMeasure() : String;

   AppEnginePropertyIgnore()
function set DS_ItemUnitOfMeasure(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItems Interface
ITestProtocolItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItems.DS_UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_UpdateDate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_UpdateDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_UpdateDate {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_UpdateDate() : String;

   AppEnginePropertyIgnore()
function set DS_UpdateDate(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItems Interface
ITestProtocolItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItems.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItems Interface
ITestProtocolItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItems.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItems Interface
ITestProtocolItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItems.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItems Interface
ITestProtocolItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItems.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItems Interface
ITestProtocolItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItems.U_Quantity Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItems Interface
ITestProtocolItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItems.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItems Interface
ITestProtocolItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItems.U_ValidFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidFrom() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidFrom {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidFrom() : DateTime;
function set U_ValidFrom(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItems Interface
ITestProtocolItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItems.U_ValidTo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidTo() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidTo {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidTo() : DateTime;
function set U_ValidTo(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItems Interface
ITestProtocolItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItems.U_WhsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolItems Interface
ITestProtocolItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolItems Methods

ITestProtocolItems Interface See Also

The following tables list the members exposed by the ITestProtocolItems type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ITestProtocolItems Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties Interface

Members See Also

Properties for test protocol object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface ITestProtocolProperties
    Inherits IUDOChildBean, _
             IEnumerable(Of ITestProtocolProperties)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface ITestProtocolProperties : IUDOChildBean,
   IEnumerable<ITestProtocolProperties>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class ITestProtocolProperties : public IUDOChildBean^,
   public IEnumerable<ITestProtocolProperties^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_TCL2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties Members

ITestProtocolProperties Interface Methods Properties See Also

Properties for test protocol object

The following tables list the members exposed by the ITestProtocolProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_CreateDate |
Public property | DS_PropertyName |
Public property | DS_PropertyTableCode |
Public property | DS_ReferenceName |
Public property | DS_ReferenceTableCode |
Public property | DS_UpdateDate |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Expression |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PrpCode |
Public property | U_RangeValueFrom |
Public property | U_RangeValueTo |
Public property | U_RefCode |
Public property | U_Remarks |
Public property | U_UnitOfMeasure |
Public property | U_ValidFromDate |
Public property | U_ValidToDate |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ITestProtocolProperties Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties Properties

ITestProtocolProperties Interface See Also

The following tables list the members exposed by the ITestProtocolProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_CreateDate |
Public property | DS_PropertyName |
Public property | DS_PropertyTableCode |
Public property | DS_ReferenceName |
Public property | DS_ReferenceTableCode |
Public property | DS_UpdateDate |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Expression |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PrpCode |
Public property | U_RangeValueFrom |
Public property | U_RangeValueTo |
Public property | U_RefCode |
Public property | U_Remarks |
Public property | U_UnitOfMeasure |
Public property | U_ValidFromDate |
Public property | U_ValidToDate |
Top
See Also

Reference

ITestProtocolProperties Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Interface
ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties.DS_CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_CreateDate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_CreateDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_CreateDate {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_CreateDate() : String;

   AppEnginePropertyIgnore()
function set DS_CreateDate(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Interface
ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties.DS_PropertyName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_PropertyName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_PropertyName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_PropertyName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_PropertyName() : String;

   AppEnginePropertyIgnore()
function set DS_PropertyName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Interface
ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties.DS_PropertyTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_PropertyTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_PropertyTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_PropertyTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_PropertyTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_PropertyTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Interface
ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties.DS_ReferenceName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ReferenceName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ReferenceName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ReferenceName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ReferenceName() : String;

   AppEnginePropertyIgnore()
function set DS_ReferenceName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Interface
ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties.DS_ReferenceTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ReferenceTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ReferenceTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ReferenceTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ReferenceTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_ReferenceTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Interface
ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties.DS_UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_UpdateDate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_UpdateDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_UpdateDate {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_UpdateDate() : String;

   AppEnginePropertyIgnore()
function set DS_UpdateDate(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Interface
ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Interface
ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Interface
ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Interface
ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties.U_Expression Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Expression() As ConditionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ConditionType U_Expression {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ConditionType U_Expression {
 ConditionType get( );
 void set(
   ConditionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Expression() : ConditionType;
function set U_Expression(value : ConditionType);
This language is not supported or no code example is available.

Property Value

Type: ConditionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Interface
ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties.U_PrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpCode() : String;
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Interface
ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties.U_RangeValueFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RangeValueFrom() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RangeValueFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RangeValueFrom {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RangeValueFrom() : double;
function set U_RangeValueFrom(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Interface
ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties.U_RangeValueTo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RangeValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RangeValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RangeValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RangeValueTo() : double;
function set U_RangeValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Interface
ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties.U_RefCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RefCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RefCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RefCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RefCode() : String;
function set U_RefCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Interface
ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Interface
ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties.U_UnitOfMeasure Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UnitOfMeasure {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UnitOfMeasure {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UnitOfMeasure() : String;
function set U_UnitOfMeasure(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Interface
ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties.U_ValidFromDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidFromDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidFromDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidFromDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidFromDate() : DateTime;
function set U_ValidFromDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Interface
ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties.U_ValidToDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidToDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidToDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidToDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidToDate() : DateTime;
function set U_ValidToDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolProperties Interface
ITestProtocolProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolProperties Methods

ITestProtocolProperties Interface See Also

The following tables list the members exposed by the ITestProtocolProperties type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ITestProtocolProperties Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolResources Interface

Members See Also

Resources for test protocol object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface ITestProtocolResources
    Inherits IUDOChildBean, _
             IEnumerable(Of ITestProtocolResources)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface ITestProtocolResources : IUDOChildBean,
   IEnumerable<ITestProtocolResources>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class ITestProtocolResources : public IUDOChildBean^,
   public IEnumerable<ITestProtocolResources^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_TCL3
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolResources Members

ITestProtocolResources Interface Methods Properties See Also

Resources for test protocol object

The following tables list the members exposed by the ITestProtocolResources type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_CreateDate |
Public property | DS_ResourceName |
Public property | DS_ResourceUnitOfMeasure |
Public property | DS_UpdateDate |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Quantity |
Public property | U_Remarks |
Public property | U_RscCode |
Public property | U_ValidFrom |
Public property | U_ValidTo |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ITestProtocolResources Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolResources Properties

ITestProtocolResources Interface See Also

The following tables list the members exposed by the ITestProtocolResources type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_CreateDate |
Public property | DS_ResourceName |
Public property | DS_ResourceUnitOfMeasure |
Public property | DS_UpdateDate |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Quantity |
Public property | U_Remarks |
Public property | U_RscCode |
Public property | U_ValidFrom |
Public property | U_ValidTo |
Top
See Also

Reference

ITestProtocolResources Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolResources.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolResources Interface
ITestProtocolResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolResources.DS_CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_CreateDate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_CreateDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_CreateDate {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_CreateDate() : String;

   AppEnginePropertyIgnore()
function set DS_CreateDate(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolResources Interface
ITestProtocolResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolResources.DS_ResourceName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ResourceName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ResourceName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ResourceName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ResourceName() : String;

   AppEnginePropertyIgnore()
function set DS_ResourceName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolResources Interface
ITestProtocolResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolResources.DS_ResourceUnitOfMeasure Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ResourceUnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ResourceUnitOfMeasure {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ResourceUnitOfMeasure {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ResourceUnitOfMeasure() : String;

   AppEnginePropertyIgnore()
function set DS_ResourceUnitOfMeasure(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolResources Interface
ITestProtocolResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolResources.DS_UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_UpdateDate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_UpdateDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_UpdateDate {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_UpdateDate() : String;

   AppEnginePropertyIgnore()
function set DS_UpdateDate(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolResources Interface
ITestProtocolResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolResources.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolResources Interface
ITestProtocolResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolResources.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolResources Interface
ITestProtocolResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolResources.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolResources Interface
ITestProtocolResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolResources.U_Quantity Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolResources Interface
ITestProtocolResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolResources.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolResources Interface
ITestProtocolResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolResources.U_RscCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCode() : String;
function set U_RscCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolResources Interface
ITestProtocolResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolResources.U_ValidFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidFrom() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidFrom {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidFrom() : DateTime;
function set U_ValidFrom(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolResources Interface
ITestProtocolResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolResources.U_ValidTo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidTo() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidTo {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidTo() : DateTime;
function set U_ValidTo(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolResources Interface
ITestProtocolResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


ITestProtocolResources Methods

ITestProtocolResources Interface See Also

The following tables list the members exposed by the ITestProtocolResources type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ITestProtocolResources Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocol Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ITestProtocolGroup | Test protocol group object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ITestProtocolGroup Interface

Members See Also

Test protocol group object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "TestProtocolGroup", TableName = "@CT_PF_OTCG")> _
Public Interface ITestProtocolGroup
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "TestProtocolGroup", TableName = "@CT_PF_OTCG")]
public interface ITestProtocolGroup : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "TestProtocolGroup", TableName = "@CT_PF_OTCG")]
public interface class ITestProtocolGroup : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "TestProtocolGroup", TableName = "@CT_PF_OTCG")
interface ITestProtocolGroup
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OTCG
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


ITestProtocolGroup Members

ITestProtocolGroup Interface Methods Properties See Also

Test protocol group object

The following tables list the members exposed by the ITestProtocolGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode |
Public property | U_GrpName |
Public property | U_GrpRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ITestProtocolGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


ITestProtocolGroup Properties

ITestProtocolGroup Interface See Also

The following tables list the members exposed by the ITestProtocolGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode |
Public property | U_GrpName |
Public property | U_GrpRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

ITestProtocolGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


ITestProtocolGroup.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolGroup Interface
ITestProtocolGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


ITestProtocolGroup.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolGroup Interface
ITestProtocolGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


ITestProtocolGroup.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolGroup Interface
ITestProtocolGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


ITestProtocolGroup.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolGroup Interface
ITestProtocolGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


ITestProtocolGroup.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolGroup Interface
ITestProtocolGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


ITestProtocolGroup.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolGroup Interface
ITestProtocolGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


ITestProtocolGroup.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolGroup Interface
ITestProtocolGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


ITestProtocolGroup.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolGroup Interface
ITestProtocolGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


ITestProtocolGroup.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolGroup Interface
ITestProtocolGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


ITestProtocolGroup.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolGroup Interface
ITestProtocolGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


ITestProtocolGroup.U_GrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpCode() : String;
function set U_GrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolGroup Interface
ITestProtocolGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


ITestProtocolGroup.U_GrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpName() : String;
function set U_GrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolGroup Interface
ITestProtocolGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


ITestProtocolGroup.U_GrpRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpRemarks() : String;
function set U_GrpRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolGroup Interface
ITestProtocolGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


ITestProtocolGroup.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolGroup Interface
ITestProtocolGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


ITestProtocolGroup.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolGroup Interface
ITestProtocolGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


ITestProtocolGroup.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolGroup Interface
ITestProtocolGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


ITestProtocolGroup Methods

ITestProtocolGroup Interface See Also

The following tables list the members exposed by the ITestProtocolGroup type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ITestProtocolGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolGroup Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ITestProtocolTemplate | Test protocol template object
Public interface | ITestProtocolTemplateProperties | Properties for test protocol template object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ITestProtocolTemplate Interface

Members See Also

Test protocol template object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "TestProtocolTemplate", TableName = "@CT_PF_OTPT")> _
Public Interface ITestProtocolTemplate
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "TestProtocolTemplate", TableName = "@CT_PF_OTPT")]
public interface ITestProtocolTemplate : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "TestProtocolTemplate", TableName = "@CT_PF_OTPT")]
public interface class ITestProtocolTemplate : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "TestProtocolTemplate", TableName = "@CT_PF_OTPT")
interface ITestProtocolTemplate
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OTPT
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate Members

ITestProtocolTemplate Interface Methods Properties See Also

Test protocol template object

The following tables list the members exposed by the ITestProtocolTemplate type.

Properties
 | Name | Description
Public property | BusinessPartnerRelations |
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_TestProtocolGroupName |
Public property | DS_TestProtocolGroupTableCode |
Public property | DS_UsedCount |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Properties |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode |
Public property | U_Remarks |
Public property | U_TemplateCode |
Public property | U_TemplateName |
Public property | U_ValidFromDate |
Public property | U_ValidToDate |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ITestProtocolTemplate Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate Properties

ITestProtocolTemplate Interface See Also

The following tables list the members exposed by the ITestProtocolTemplate type.

Properties
 | Name | Description
Public property | BusinessPartnerRelations |
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_TestProtocolGroupName |
Public property | DS_TestProtocolGroupTableCode |
Public property | DS_UsedCount |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Properties |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_GrpCode |
Public property | U_Remarks |
Public property | U_TemplateCode |
Public property | U_TemplateName |
Public property | U_ValidFromDate |
Public property | U_ValidToDate |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

ITestProtocolTemplate Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.BusinessPartnerRelations Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BusinessPartnerRelations() As IBusinessPartnerRelationsThridLevel
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBusinessPartnerRelationsThridLevel BusinessPartnerRelations {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBusinessPartnerRelationsThridLevel^ BusinessPartnerRelations {
 IBusinessPartnerRelationsThridLevel^ get( );
 void set(
   IBusinessPartnerRelationsThridLevel^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BusinessPartnerRelations() : IBusinessPartnerRelationsThridLevel;
function set BusinessPartnerRelations(value : IBusinessPartnerRelationsThridLevel);
This language is not supported or no code example is available.

Property Value

Type: IBusinessPartnerRelationsThridLevel
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.DS_TestProtocolGroupName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_TestProtocolGroupName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_TestProtocolGroupName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_TestProtocolGroupName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_TestProtocolGroupName() : String;

   AppEnginePropertyIgnore()
function set DS_TestProtocolGroupName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.DS_TestProtocolGroupTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_TestProtocolGroupTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_TestProtocolGroupTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_TestProtocolGroupTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_TestProtocolGroupTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_TestProtocolGroupTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.DS_UsedCount Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_UsedCount() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_UsedCount {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_UsedCount {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_UsedCount() : String;

   AppEnginePropertyIgnore()
function set DS_UsedCount(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.Properties Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Properties() As ITestProtocolTemplateProperties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ITestProtocolTemplateProperties Properties {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ITestProtocolTemplateProperties^ Properties {
 ITestProtocolTemplateProperties^ get( );
 void set(
   ITestProtocolTemplateProperties^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Properties() : ITestProtocolTemplateProperties;
function set Properties(value : ITestProtocolTemplateProperties);
This language is not supported or no code example is available.

Property Value

Type: ITestProtocolTemplateProperties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.U_GrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GrpCode() : String;
function set U_GrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.U_TemplateCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TemplateCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TemplateCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TemplateCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TemplateCode() : String;
function set U_TemplateCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.U_TemplateName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TemplateName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TemplateName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TemplateName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TemplateName() : String;
function set U_TemplateName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.U_ValidFromDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidFromDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidFromDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidFromDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidFromDate() : DateTime;
function set U_ValidFromDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.U_ValidToDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidToDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidToDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidToDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidToDate() : DateTime;
function set U_ValidToDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplate Interface
ITestProtocolTemplate Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplate Methods

ITestProtocolTemplate Interface See Also

The following tables list the members exposed by the ITestProtocolTemplate type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ITestProtocolTemplate Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties Interface

Members See Also

Properties for test protocol template object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface ITestProtocolTemplateProperties
    Inherits IUDOChildBean, _
             IEnumerable(Of ITestProtocolTemplateProperties)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface ITestProtocolTemplateProperties : IUDOChildBean,
   IEnumerable<ITestProtocolTemplateProperties>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class ITestProtocolTemplateProperties : public IUDOChildBean^,
   public IEnumerable<ITestProtocolTemplateProperties^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_TPT1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplateProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties Members

ITestProtocolTemplateProperties Interface Methods Properties See Also

Properties for test protocol template object

The following tables list the members exposed by the ITestProtocolTemplateProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_CreateDate |
Public property | DS_PropertyName |
Public property | DS_PropertyTableCode |
Public property | DS_ReferenceName |
Public property | DS_ReferenceTableCode |
Public property | DS_UpdateDate |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Expression |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PrpCode |
Public property | U_RangeValueFrom |
Public property | U_RangeValueTo |
Public property | U_RefCode |
Public property | U_UnitOfMeasure |
Public property | U_ValidFromDate |
Public property | U_ValidToDate |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ITestProtocolTemplateProperties Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties Properties

ITestProtocolTemplateProperties Interface See Also

The following tables list the members exposed by the ITestProtocolTemplateProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_CreateDate |
Public property | DS_PropertyName |
Public property | DS_PropertyTableCode |
Public property | DS_ReferenceName |
Public property | DS_ReferenceTableCode |
Public property | DS_UpdateDate |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Expression |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PrpCode |
Public property | U_RangeValueFrom |
Public property | U_RangeValueTo |
Public property | U_RefCode |
Public property | U_UnitOfMeasure |
Public property | U_ValidFromDate |
Public property | U_ValidToDate |
Top
See Also

Reference

ITestProtocolTemplateProperties Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplateProperties Interface
ITestProtocolTemplateProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties.DS_CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_CreateDate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_CreateDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_CreateDate {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_CreateDate() : String;

   AppEnginePropertyIgnore()
function set DS_CreateDate(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplateProperties Interface
ITestProtocolTemplateProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties.DS_PropertyName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_PropertyName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_PropertyName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_PropertyName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_PropertyName() : String;

   AppEnginePropertyIgnore()
function set DS_PropertyName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplateProperties Interface
ITestProtocolTemplateProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties.DS_PropertyTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_PropertyTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_PropertyTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_PropertyTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_PropertyTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_PropertyTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplateProperties Interface
ITestProtocolTemplateProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties.DS_ReferenceName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ReferenceName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ReferenceName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ReferenceName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ReferenceName() : String;

   AppEnginePropertyIgnore()
function set DS_ReferenceName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplateProperties Interface
ITestProtocolTemplateProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties.DS_ReferenceTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ReferenceTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ReferenceTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ReferenceTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ReferenceTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_ReferenceTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplateProperties Interface
ITestProtocolTemplateProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties.DS_UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_UpdateDate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_UpdateDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_UpdateDate {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_UpdateDate() : String;

   AppEnginePropertyIgnore()
function set DS_UpdateDate(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplateProperties Interface
ITestProtocolTemplateProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplateProperties Interface
ITestProtocolTemplateProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplateProperties Interface
ITestProtocolTemplateProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplateProperties Interface
ITestProtocolTemplateProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties.U_Expression Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Expression() As ConditionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ConditionType U_Expression {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ConditionType U_Expression {
 ConditionType get( );
 void set(
   ConditionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Expression() : ConditionType;
function set U_Expression(value : ConditionType);
This language is not supported or no code example is available.

Property Value

Type: ConditionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplateProperties Interface
ITestProtocolTemplateProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties.U_PrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpCode() : String;
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplateProperties Interface
ITestProtocolTemplateProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties.U_RangeValueFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RangeValueFrom() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RangeValueFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RangeValueFrom {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RangeValueFrom() : double;
function set U_RangeValueFrom(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplateProperties Interface
ITestProtocolTemplateProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties.U_RangeValueTo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RangeValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RangeValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RangeValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RangeValueTo() : double;
function set U_RangeValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplateProperties Interface
ITestProtocolTemplateProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties.U_RefCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RefCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RefCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RefCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RefCode() : String;
function set U_RefCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplateProperties Interface
ITestProtocolTemplateProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties.U_UnitOfMeasure Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UnitOfMeasure {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UnitOfMeasure {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UnitOfMeasure() : String;
function set U_UnitOfMeasure(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplateProperties Interface
ITestProtocolTemplateProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties.U_ValidFromDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidFromDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidFromDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidFromDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidFromDate() : DateTime;
function set U_ValidFromDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplateProperties Interface
ITestProtocolTemplateProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties.U_ValidToDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidToDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidToDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidToDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidToDate() : DateTime;
function set U_ValidToDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITestProtocolTemplateProperties Interface
ITestProtocolTemplateProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


ITestProtocolTemplateProperties Methods

ITestProtocolTemplateProperties Interface See Also

The following tables list the members exposed by the ITestProtocolTemplateProperties type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ITestProtocolTemplateProperties Interface
CompuTec.ProcessForce.API.Documents.QualityControl.TestProtocolTemplate Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IVehicleInspection | Vehicle inspection document
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IVehicleInspection Interface

Members See Also

Vehicle inspection document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "VehicleInspection", TableName = "@CT_PF_OCVI")> _
Public Interface IVehicleInspection
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "VehicleInspection", TableName = "@CT_PF_OCVI")]
public interface IVehicleInspection : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "VehicleInspection", TableName = "@CT_PF_OCVI")]
public interface class IVehicleInspection : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "VehicleInspection", TableName = "@CT_PF_OCVI")
interface IVehicleInspection
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OCVI
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection Members

IVehicleInspection Interface Methods Properties See Also

Vehicle inspection document

The following tables list the members exposed by the IVehicleInspection type.

Properties
 | Name | Description
Public property | Canceled | Canceled
Public property | CreateDate | CreateDate
Public property | CreateTime | CreateTime
Public property | DataSource | DataSource
Public property | DocEntry | DocEntry
Public property | DocNum | DocNum
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten | Handwritten
Public property | Instance | Instance
Public property | LogInst | LogInst
Public property | Object | Object
Public property | Period | Period
Public property | Series | Series
Public property | Status | Status
Public property | Token | (inherited from IUDOBean).
Public property | Transfered | Transfered
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ChemSp | Chem Spills Pass
Public property | U_ChemSpills_Remarks | Chemical Spills Remarks
Public property | U_Clean | Clean Pass
Public property | U_Clean_Remarks | Clean Remarks
Public property | U_Closed | Closed Pass
Public property | U_Closed_Remarks | Closed Remarks
Public property | U_ContainerNumber | Container Number
Public property | U_Covered | Covered Pass
Public property | U_Covered_Remarks | Covered Remark
Public property | U_Created | Inspection Date
Public property | U_Dry | Dry Pass
Public property | U_Dry_Remarks | Dry Remarks
Public property | U_GRCode | Document Code
Public property | U_ObjType | Object Type
Public property | U_OdorInsp | Odor Insp Pass
Public property | U_OdorInsp_Remarks | Odor Inspection Remarks
Public property | U_PestInsp | Pest Insp Pass
Public property | U_PestInsp_Remarks | Pest Inspection Remarks
Public property | U_PgInsp | Package Insp Pass
Public property | U_PgInsp_Remarks | Package Inspection Remarks
Public property | U_RC_ChemSpills_1 | Reason Codes Chemical Spills 1
Public property | U_RC_ChemSpills_2 | Reason Codes Chemical Spills 2
Public property | U_RC_ChemSpills_3 | Reason Codes Chemical Spills 3
Public property | U_RC_OdorInsp_1 | Reason Codes Odor Insp 1
Public property | U_RC_OdorInsp_2 | Reason Codes Odor Insp 2
Public property | U_RC_OdorInsp_3 | Reason Codes Odor Insp 3
Public property | U_RC_PestInsp_1 | Reason Codes Pest Insp 1
Public property | U_RC_PestInsp_2 | Reason Codes Odor Insp 2
Public property | U_RC_PestInsp_3 | Reason Codes Odor Insp 3
Public property | U_RC_PgInsp_1 | Reason Codes Package Insp 1
Public property | U_RC_PgInsp_2 | Reason Codes Package Insp 2
Public property | U_RC_PgInsp_3 | Reason Codes Package Insp 3
Public property | U_RC_Rubbish_1 | Reason Codes Rubbish 1
Public property | U_RC_Rubbish_2 | Reason Codes Rubbish 2
Public property | U_RC_Rubbish_3 | Reason Codes Rubbish 3
Public property | U_RC_SpProd_1 | Reason Codes Spoiled Products 1
Public property | U_RC_SpProd_2 | Reason Codes Spoiled Products 2
Public property | U_RC_SpProd_3 | Reason Codes Spoiled Products 3
Public property | U_RC_Temp | Reason Codes Temperature
Public property | U_RC_Temp1 | Reason Codes Temperature 1
Public property | U_RC_Temp2 | Reason Codes Temperature 2
Public property | U_Remarks | Remarks
Public property | U_Rubbish | Rubbish Pass
Public property | U_Rubbish_Remarks | Rubbish Remarks
Public property | U_SpProd | Spoiled Pass
Public property | U_SpProducts_Remarks | Spoiled Products Remarks
Public property | U_Temp | Temperature Insp Pass
Public property | U_Temp_Remarks | Temperature Remarks
Public property | U_TrackLicPlate | Track License Plate
Public property | U_TrailerNumber | Trailer Number
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate | UpdateDate
Public property | UpdateTime | UpdateTime
Public property | UserSign | UserSign
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAllVehicleInspectionReasons | Gets all vehicle inspection reasons codes as a dictionary with code - name fashion
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | SetDefaultSeries | Sets the default series for Complaint document.
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IVehicleInspection Interface
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection Properties

IVehicleInspection Interface See Also

The following tables list the members exposed by the IVehicleInspection type.

Properties
 | Name | Description
Public property | Canceled | Canceled
Public property | CreateDate | CreateDate
Public property | CreateTime | CreateTime
Public property | DataSource | DataSource
Public property | DocEntry | DocEntry
Public property | DocNum | DocNum
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten | Handwritten
Public property | Instance | Instance
Public property | LogInst | LogInst
Public property | Object | Object
Public property | Period | Period
Public property | Series | Series
Public property | Status | Status
Public property | Token | (inherited from IUDOBean).
Public property | Transfered | Transfered
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ChemSp | Chem Spills Pass
Public property | U_ChemSpills_Remarks | Chemical Spills Remarks
Public property | U_Clean | Clean Pass
Public property | U_Clean_Remarks | Clean Remarks
Public property | U_Closed | Closed Pass
Public property | U_Closed_Remarks | Closed Remarks
Public property | U_ContainerNumber | Container Number
Public property | U_Covered | Covered Pass
Public property | U_Covered_Remarks | Covered Remark
Public property | U_Created | Inspection Date
Public property | U_Dry | Dry Pass
Public property | U_Dry_Remarks | Dry Remarks
Public property | U_GRCode | Document Code
Public property | U_ObjType | Object Type
Public property | U_OdorInsp | Odor Insp Pass
Public property | U_OdorInsp_Remarks | Odor Inspection Remarks
Public property | U_PestInsp | Pest Insp Pass
Public property | U_PestInsp_Remarks | Pest Inspection Remarks
Public property | U_PgInsp | Package Insp Pass
Public property | U_PgInsp_Remarks | Package Inspection Remarks
Public property | U_RC_ChemSpills_1 | Reason Codes Chemical Spills 1
Public property | U_RC_ChemSpills_2 | Reason Codes Chemical Spills 2
Public property | U_RC_ChemSpills_3 | Reason Codes Chemical Spills 3
Public property | U_RC_OdorInsp_1 | Reason Codes Odor Insp 1
Public property | U_RC_OdorInsp_2 | Reason Codes Odor Insp 2
Public property | U_RC_OdorInsp_3 | Reason Codes Odor Insp 3
Public property | U_RC_PestInsp_1 | Reason Codes Pest Insp 1
Public property | U_RC_PestInsp_2 | Reason Codes Odor Insp 2
Public property | U_RC_PestInsp_3 | Reason Codes Odor Insp 3
Public property | U_RC_PgInsp_1 | Reason Codes Package Insp 1
Public property | U_RC_PgInsp_2 | Reason Codes Package Insp 2
Public property | U_RC_PgInsp_3 | Reason Codes Package Insp 3
Public property | U_RC_Rubbish_1 | Reason Codes Rubbish 1
Public property | U_RC_Rubbish_2 | Reason Codes Rubbish 2
Public property | U_RC_Rubbish_3 | Reason Codes Rubbish 3
Public property | U_RC_SpProd_1 | Reason Codes Spoiled Products 1
Public property | U_RC_SpProd_2 | Reason Codes Spoiled Products 2
Public property | U_RC_SpProd_3 | Reason Codes Spoiled Products 3
Public property | U_RC_Temp | Reason Codes Temperature
Public property | U_RC_Temp1 | Reason Codes Temperature 1
Public property | U_RC_Temp2 | Reason Codes Temperature 2
Public property | U_Remarks | Remarks
Public property | U_Rubbish | Rubbish Pass
Public property | U_Rubbish_Remarks | Rubbish Remarks
Public property | U_SpProd | Spoiled Pass
Public property | U_SpProducts_Remarks | Spoiled Products Remarks
Public property | U_Temp | Temperature Insp Pass
Public property | U_Temp_Remarks | Temperature Remarks
Public property | U_TrackLicPlate | Track License Plate
Public property | U_TrailerNumber | Trailer Number
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate | UpdateDate
Public property | UpdateTime | UpdateTime
Public property | UserSign | UserSign
Top
See Also

Reference

IVehicleInspection Interface
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.Canceled Property

Canceled

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.CreateDate Property

CreateDate

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.CreateTime Property

CreateTime

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.DataSource Property

DataSource

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.DocEntry Property

DocEntry

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.DocNum Property

DocNum

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.Handwrtten Property

Handwritten

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Handwrtten() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Handwrtten {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Handwrtten {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Handwrtten() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.Instance Property

Instance

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Instance() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Instance {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Instance {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Instance() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.LogInst Property

LogInst

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.Object Property

Object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.Period Property

Period

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Period() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Period {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Period {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Period() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.Series Property

Series

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Series() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Series {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Series {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Series() : int;
function set Series(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.Status Property

Status

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Status {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Status {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Status() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.Transfered Property

Transfered

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_ChemSp Property

Chem Spills Pass

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ChemSp() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_ChemSp {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_ChemSp {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ChemSp() : YesNoType;
function set U_ChemSp(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_ChemSpills_Remarks Property

Chemical Spills Remarks

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ChemSpills_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ChemSpills_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ChemSpills_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ChemSpills_Remarks() : String;
function set U_ChemSpills_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_Clean Property

Clean Pass

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Clean() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Clean {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Clean {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Clean() : YesNoType;
function set U_Clean(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_Clean_Remarks Property

Clean Remarks

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property U_Clean_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string U_Clean_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ U_Clean_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_Clean_Remarks() : String;

   AppEnginePropertyIgnore()
function set U_Clean_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_Closed Property

Closed Pass

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Closed() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Closed {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Closed {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Closed() : YesNoType;
function set U_Closed(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_Closed_Remarks Property

Closed Remarks

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Closed_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Closed_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Closed_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Closed_Remarks() : String;
function set U_Closed_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_ContainerNumber Property

Container Number

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ContainerNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ContainerNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ContainerNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ContainerNumber() : String;
function set U_ContainerNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_Covered Property

Covered Pass

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Covered() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Covered {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Covered {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Covered() : YesNoType;
function set U_Covered(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_Covered_Remarks Property

Covered Remark

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Covered_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Covered_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Covered_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Covered_Remarks() : String;
function set U_Covered_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_Created Property

Inspection Date

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Created() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Created {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Created {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Created() : DateTime;
function set U_Created(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_Dry Property

Dry Pass

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Dry() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Dry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Dry {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Dry() : YesNoType;
function set U_Dry(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_Dry_Remarks Property

Dry Remarks

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Dry_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Dry_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Dry_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Dry_Remarks() : String;
function set U_Dry_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_GRCode Property

Document Code

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_GRCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GRCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GRCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GRCode() : String;
function set U_GRCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_ObjType Property

Object Type

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ObjType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ObjType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ObjType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ObjType() : String;
function set U_ObjType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_OdorInsp Property

Odor Insp Pass

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OdorInsp() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_OdorInsp {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_OdorInsp {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OdorInsp() : YesNoType;
function set U_OdorInsp(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_OdorInsp_Remarks Property

Odor Inspection Remarks

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OdorInsp_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OdorInsp_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OdorInsp_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OdorInsp_Remarks() : String;
function set U_OdorInsp_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_PestInsp Property

Pest Insp Pass

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PestInsp() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_PestInsp {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_PestInsp {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PestInsp() : YesNoType;
function set U_PestInsp(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_PestInsp_Remarks Property

Pest Inspection Remarks

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PestInsp_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PestInsp_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PestInsp_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PestInsp_Remarks() : String;
function set U_PestInsp_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_PgInsp Property

Package Insp Pass

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PgInsp() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_PgInsp {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_PgInsp {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PgInsp() : YesNoType;
function set U_PgInsp(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_PgInsp_Remarks Property

Package Inspection Remarks

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PgInsp_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PgInsp_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PgInsp_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PgInsp_Remarks() : String;
function set U_PgInsp_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_ChemSpills_1 Property

Reason Codes Chemical Spills 1

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_ChemSpills_1() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_ChemSpills_1 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_ChemSpills_1 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_ChemSpills_1() : String;
function set U_RC_ChemSpills_1(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_ChemSpills_2 Property

Reason Codes Chemical Spills 2

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_ChemSpills_2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_ChemSpills_2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_ChemSpills_2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_ChemSpills_2() : String;
function set U_RC_ChemSpills_2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_ChemSpills_3 Property

Reason Codes Chemical Spills 3

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_ChemSpills_3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_ChemSpills_3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_ChemSpills_3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_ChemSpills_3() : String;
function set U_RC_ChemSpills_3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_OdorInsp_1 Property

Reason Codes Odor Insp 1

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_OdorInsp_1() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_OdorInsp_1 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_OdorInsp_1 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_OdorInsp_1() : String;
function set U_RC_OdorInsp_1(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_OdorInsp_2 Property

Reason Codes Odor Insp 2

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_OdorInsp_2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_OdorInsp_2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_OdorInsp_2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_OdorInsp_2() : String;
function set U_RC_OdorInsp_2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_OdorInsp_3 Property

Reason Codes Odor Insp 3

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_OdorInsp_3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_OdorInsp_3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_OdorInsp_3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_OdorInsp_3() : String;
function set U_RC_OdorInsp_3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_PestInsp_1 Property

Reason Codes Pest Insp 1

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_PestInsp_1() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_PestInsp_1 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_PestInsp_1 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_PestInsp_1() : String;
function set U_RC_PestInsp_1(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_PestInsp_2 Property

Reason Codes Odor Insp 2

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_PestInsp_2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_PestInsp_2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_PestInsp_2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_PestInsp_2() : String;
function set U_RC_PestInsp_2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_PestInsp_3 Property

Reason Codes Odor Insp 3

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_PestInsp_3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_PestInsp_3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_PestInsp_3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_PestInsp_3() : String;
function set U_RC_PestInsp_3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_PgInsp_1 Property

Reason Codes Package Insp 1

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_PgInsp_1() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_PgInsp_1 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_PgInsp_1 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_PgInsp_1() : String;
function set U_RC_PgInsp_1(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_PgInsp_2 Property

Reason Codes Package Insp 2

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_PgInsp_2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_PgInsp_2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_PgInsp_2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_PgInsp_2() : String;
function set U_RC_PgInsp_2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_PgInsp_3 Property

Reason Codes Package Insp 3

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_PgInsp_3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_PgInsp_3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_PgInsp_3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_PgInsp_3() : String;
function set U_RC_PgInsp_3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_Rubbish_1 Property

Reason Codes Rubbish 1

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_Rubbish_1() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_Rubbish_1 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_Rubbish_1 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_Rubbish_1() : String;
function set U_RC_Rubbish_1(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_Rubbish_2 Property

Reason Codes Rubbish 2

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_Rubbish_2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_Rubbish_2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_Rubbish_2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_Rubbish_2() : String;
function set U_RC_Rubbish_2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_Rubbish_3 Property

Reason Codes Rubbish 3

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_Rubbish_3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_Rubbish_3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_Rubbish_3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_Rubbish_3() : String;
function set U_RC_Rubbish_3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_SpProd_1 Property

Reason Codes Spoiled Products 1

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_SpProd_1() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_SpProd_1 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_SpProd_1 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_SpProd_1() : String;
function set U_RC_SpProd_1(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_SpProd_2 Property

Reason Codes Spoiled Products 2

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_SpProd_2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_SpProd_2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_SpProd_2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_SpProd_2() : String;
function set U_RC_SpProd_2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_SpProd_3 Property

Reason Codes Spoiled Products 3

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_SpProd_3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_SpProd_3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_SpProd_3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_SpProd_3() : String;
function set U_RC_SpProd_3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_Temp Property

Reason Codes Temperature

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_Temp() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_Temp {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_Temp {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_Temp() : String;
function set U_RC_Temp(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_Temp1 Property

Reason Codes Temperature 1

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_Temp1() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_Temp1 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_Temp1 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_Temp1() : String;
function set U_RC_Temp1(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_RC_Temp2 Property

Reason Codes Temperature 2

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RC_Temp2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RC_Temp2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RC_Temp2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RC_Temp2() : String;
function set U_RC_Temp2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_Remarks Property

Remarks

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_Rubbish Property

Rubbish Pass

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Rubbish() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Rubbish {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Rubbish {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Rubbish() : YesNoType;
function set U_Rubbish(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_Rubbish_Remarks Property

Rubbish Remarks

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Rubbish_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Rubbish_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Rubbish_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Rubbish_Remarks() : String;
function set U_Rubbish_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_SpProd Property

Spoiled Pass

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SpProd() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_SpProd {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_SpProd {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SpProd() : YesNoType;
function set U_SpProd(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_SpProducts_Remarks Property

Spoiled Products Remarks

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SpProducts_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SpProducts_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SpProducts_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SpProducts_Remarks() : String;
function set U_SpProducts_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_Temp Property

Temperature Insp Pass

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Temp() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Temp {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Temp {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Temp() : YesNoType;
function set U_Temp(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_Temp_Remarks Property

Temperature Remarks

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Temp_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Temp_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Temp_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Temp_Remarks() : String;
function set U_Temp_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_TrackLicPlate Property

Track License Plate

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TrackLicPlate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TrackLicPlate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TrackLicPlate {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TrackLicPlate() : String;
function set U_TrackLicPlate(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.U_TrailerNumber Property

Trailer Number

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TrailerNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TrailerNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TrailerNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TrailerNumber() : String;
function set U_TrailerNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.UpdateDate Property

UpdateDate

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.UpdateTime Property

UpdateTime

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.UserSign Property

UserSign

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection Methods

IVehicleInspection Interface See Also

The following tables list the members exposed by the IVehicleInspection type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAllVehicleInspectionReasons | Gets all vehicle inspection reasons codes as a dictionary with code - name fashion
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | SetDefaultSeries | Sets the default series for Complaint document.
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IVehicleInspection Interface
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.GetAllVehicleInspectionReasons Method

Gets all vehicle inspection reasons codes as a dictionary with code - name fashion

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAllVehicleInspectionReasons() As List(Of VehicleInspectionReasonSimpleClass)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<VehicleInspectionReasonSimpleClass> GetAllVehicleInspectionReasons()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

List<VehicleInspectionReasonSimpleClass^>^ GetAllVehicleInspectionReasons()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Return Value

Type: List<VehicleInspectionReasonSimpleClass>

Dictionary with Vehicle Inspection Reasons as [Code][Name]

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


IVehicleInspection.SetDefaultSeries Method

Sets the default series for Complaint document.

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub SetDefaultSeries()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void SetDefaultSeries()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void SetDefaultSeries()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function SetDefaultSeries();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspection Interface
IVehicleInspection Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspection Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IVehicleInspectionGroup | Vehicle inspection group object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IVehicleInspectionGroup Interface

Members See Also

Vehicle inspection group object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "VehicleInspectionGroup", TableName = "@CT_PF_OCVR")> _
Public Interface IVehicleInspectionGroup
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "VehicleInspectionGroup", TableName = "@CT_PF_OCVR")]
public interface IVehicleInspectionGroup : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "VehicleInspectionGroup", TableName = "@CT_PF_OCVR")]
public interface class IVehicleInspectionGroup : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "VehicleInspectionGroup", TableName = "@CT_PF_OCVR")
interface IVehicleInspectionGroup
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OCVR
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace


IVehicleInspectionGroup Members

IVehicleInspectionGroup Interface Methods Properties See Also

Vehicle inspection group object

The following tables list the members exposed by the IVehicleInspectionGroup type.

Properties
 | Name | Description
Public property | Canceled | Canceled
Public property | Code | Code
Public property | CreateDate | CreateDate
Public property | CreateTime | CreateTime
Public property | DataSource | DataSource
Public property | DocEntry | DocEntry
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst | LogInst
Public property | Name | Name
Public property | Object | Object
Public property | Token | (inherited from IUDOBean).
Public property | Transfered | Transfered
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_VGrpCode | Resource Group Code - Mandatory
Public property | U_VGrpName | Resource Group Name
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate | UpdateDate
Public property | UpdateTime | UpdateTime
Public property | UserSign | UserSign
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IVehicleInspectionGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace


IVehicleInspectionGroup Properties

IVehicleInspectionGroup Interface See Also

The following tables list the members exposed by the IVehicleInspectionGroup type.

Properties
 | Name | Description
Public property | Canceled | Canceled
Public property | Code | Code
Public property | CreateDate | CreateDate
Public property | CreateTime | CreateTime
Public property | DataSource | DataSource
Public property | DocEntry | DocEntry
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst | LogInst
Public property | Name | Name
Public property | Object | Object
Public property | Token | (inherited from IUDOBean).
Public property | Transfered | Transfered
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_VGrpCode | Resource Group Code - Mandatory
Public property | U_VGrpName | Resource Group Name
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate | UpdateDate
Public property | UpdateTime | UpdateTime
Public property | UserSign | UserSign
Top
See Also

Reference

IVehicleInspectionGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace


IVehicleInspectionGroup.Canceled Property

Canceled

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionGroup Interface
IVehicleInspectionGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace


IVehicleInspectionGroup.Code Property

Code

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionGroup Interface
IVehicleInspectionGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace


IVehicleInspectionGroup.CreateDate Property

CreateDate

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionGroup Interface
IVehicleInspectionGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace


IVehicleInspectionGroup.CreateTime Property

CreateTime

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionGroup Interface
IVehicleInspectionGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace


IVehicleInspectionGroup.DataSource Property

DataSource

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionGroup Interface
IVehicleInspectionGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace


IVehicleInspectionGroup.DocEntry Property

DocEntry

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionGroup Interface
IVehicleInspectionGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace


IVehicleInspectionGroup.LogInst Property

LogInst

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionGroup Interface
IVehicleInspectionGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace


IVehicleInspectionGroup.Name Property

Name

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionGroup Interface
IVehicleInspectionGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace


IVehicleInspectionGroup.Object Property

Object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionGroup Interface
IVehicleInspectionGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace


IVehicleInspectionGroup.Transfered Property

Transfered

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionGroup Interface
IVehicleInspectionGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace


IVehicleInspectionGroup.U_VGrpCode Property

Resource Group Code - Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_VGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_VGrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_VGrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_VGrpCode() : String;

   AppEngineProperty(Required = true)
function set U_VGrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionGroup Interface
IVehicleInspectionGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace


IVehicleInspectionGroup.U_VGrpName Property

Resource Group Name

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VGrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_VGrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_VGrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VGrpName() : String;
function set U_VGrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionGroup Interface
IVehicleInspectionGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace


IVehicleInspectionGroup.UpdateDate Property

UpdateDate

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionGroup Interface
IVehicleInspectionGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace


IVehicleInspectionGroup.UpdateTime Property

UpdateTime

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionGroup Interface
IVehicleInspectionGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace


IVehicleInspectionGroup.UserSign Property

UserSign

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionGroup Interface
IVehicleInspectionGroup Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace


IVehicleInspectionGroup Methods

IVehicleInspectionGroup Interface See Also

The following tables list the members exposed by the IVehicleInspectionGroup type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IVehicleInspectionGroup Interface
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionGroup Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IVehicleInspectionReason | Vehicle inspection reason object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IVehicleInspectionReason Interface

Members See Also

Vehicle inspection reason object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "VehicleInspectionReasons", TableName = "@CT_PF_OCVC")> _
Public Interface IVehicleInspectionReason
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "VehicleInspectionReasons", TableName = "@CT_PF_OCVC")]
public interface IVehicleInspectionReason : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "VehicleInspectionReasons", TableName = "@CT_PF_OCVC")]
public interface class IVehicleInspectionReason : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "VehicleInspectionReasons", TableName = "@CT_PF_OCVC")
interface IVehicleInspectionReason
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OCVC
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason Members

IVehicleInspectionReason Interface Methods Properties See Also

Vehicle inspection reason object

The following tables list the members exposed by the IVehicleInspectionReason type.

Properties
 | Name | Description
Public property | Canceled | cancelId
Public property | Code | Code
Public property | CreateDate | CreateDate
Public property | CreateTime | CreateTime
Public property | DS_GroupName | DS_GroupName
Public property | DS_GroupTableCode | DS_GroupTableCode
Public property | DataSource | DataSource
Public property | DocEntry | DocEntry
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst | LogInst
Public property | Name | Name
Public property | Object | Object
Public property | Token | (inherited from IUDOBean).
Public property | Transfered | Transfered
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ChSpills | Chemical Spills
Public property | U_OdorInsp | Odor Inspection
Public property | U_PFDBVersion | PFDB Version
Public property | U_PFVersion | PF Version
Public property | U_PestInsp | Pest Inspection
Public property | U_PgInsp | Package Inspection
Public property | U_Remarks | Remarks
Public property | U_RsnCode | Reason Code
Public property | U_RsnName | Reason Name
Public property | U_Rubbish | Rubbish
Public property | U_SpProd | Spoiled Production?
Public property | U_Temp | Temperature
Public property | U_VGrpCode | GroupCode
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate | UpdateDate
Public property | UpdateTime | UpdateTime
Public property | UserSign | UserSign
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IVehicleInspectionReason Interface
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason Properties

IVehicleInspectionReason Interface See Also

The following tables list the members exposed by the IVehicleInspectionReason type.

Properties
 | Name | Description
Public property | Canceled | cancelId
Public property | Code | Code
Public property | CreateDate | CreateDate
Public property | CreateTime | CreateTime
Public property | DS_GroupName | DS_GroupName
Public property | DS_GroupTableCode | DS_GroupTableCode
Public property | DataSource | DataSource
Public property | DocEntry | DocEntry
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst | LogInst
Public property | Name | Name
Public property | Object | Object
Public property | Token | (inherited from IUDOBean).
Public property | Transfered | Transfered
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ChSpills | Chemical Spills
Public property | U_OdorInsp | Odor Inspection
Public property | U_PFDBVersion | PFDB Version
Public property | U_PFVersion | PF Version
Public property | U_PestInsp | Pest Inspection
Public property | U_PgInsp | Package Inspection
Public property | U_Remarks | Remarks
Public property | U_RsnCode | Reason Code
Public property | U_RsnName | Reason Name
Public property | U_Rubbish | Rubbish
Public property | U_SpProd | Spoiled Production?
Public property | U_Temp | Temperature
Public property | U_VGrpCode | GroupCode
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate | UpdateDate
Public property | UpdateTime | UpdateTime
Public property | UserSign | UserSign
Top
See Also

Reference

IVehicleInspectionReason Interface
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.Canceled Property

cancelId

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.Code Property

Code

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.CreateDate Property

CreateDate

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.CreateTime Property

CreateTime

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.DS_GroupName Property

DS_GroupName

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_GroupName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_GroupName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_GroupName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_GroupName() : String;

   AppEnginePropertyIgnore()
function set DS_GroupName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.DS_GroupTableCode Property

DS_GroupTableCode

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_GroupTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_GroupTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_GroupTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_GroupTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_GroupTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.DataSource Property

DataSource

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.DocEntry Property

DocEntry

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.LogInst Property

LogInst

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.Name Property

Name

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.Object Property

Object

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.Transfered Property

Transfered

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.U_ChSpills Property

Chemical Spills

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ChSpills() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ChSpills {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ChSpills {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ChSpills() : String;
function set U_ChSpills(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.U_OdorInsp Property

Odor Inspection

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OdorInsp() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OdorInsp {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OdorInsp {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OdorInsp() : String;
function set U_OdorInsp(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.U_PFDBVersion Property

PFDB Version

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.U_PFVersion Property

PF Version

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.U_PestInsp Property

Pest Inspection

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PestInsp() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PestInsp {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PestInsp {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PestInsp() : String;
function set U_PestInsp(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.U_PgInsp Property

Package Inspection

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PgInsp() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PgInsp {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PgInsp {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PgInsp() : String;
function set U_PgInsp(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.U_Remarks Property

Remarks

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.U_RsnCode Property

Reason Code

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_RsnCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_RsnCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_RsnCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_RsnCode() : String;

   AppEngineProperty(Required = true)
function set U_RsnCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.U_RsnName Property

Reason Name

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RsnName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RsnName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RsnName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RsnName() : String;
function set U_RsnName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.U_Rubbish Property

Rubbish

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Rubbish() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Rubbish {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Rubbish {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Rubbish() : String;
function set U_Rubbish(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.U_SpProd Property

Spoiled Production?

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SpProd() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SpProd {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SpProd {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SpProd() : String;
function set U_SpProd(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.U_Temp Property

Temperature

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Temp() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Temp {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Temp {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Temp() : String;
function set U_Temp(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.U_VGrpCode Property

GroupCode

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_VGrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_VGrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VGrpCode() : String;
function set U_VGrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.UpdateDate Property

UpdateDate

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.UpdateTime Property

UpdateTime

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason.UserSign Property

UserSign

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IVehicleInspectionReason Interface
IVehicleInspectionReason Members
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


IVehicleInspectionReason Methods

IVehicleInspectionReason Interface See Also

The following tables list the members exposed by the IVehicleInspectionReason type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IVehicleInspectionReason Interface
CompuTec.ProcessForce.API.Documents.QualityControl.VehicleInspections.VehicleInspectionReasons Namespace


CompuTec.ProcessForce.API.Documents.ReasonCode Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IReasonCode | Reason code object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IReasonCode Interface

Members See Also

Reason code object

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ReasonCodes", TableName = "@CT_PF_ORSCD", UDOVersion = "UDO_10")> _
Public Interface IReasonCode
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ReasonCodes", TableName = "@CT_PF_ORSCD", UDOVersion = "UDO_10")]
public interface IReasonCode : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ReasonCodes", TableName = "@CT_PF_ORSCD", UDOVersion = "UDO_10")]
public interface class IReasonCode : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ReasonCodes", TableName = "@CT_PF_ORSCD", UDOVersion = "UDO_10")
interface IReasonCode
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ORSCD
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode Members

IReasonCode Interface Methods Properties See Also

Reason code object

The following tables list the members exposed by the IReasonCode type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_ReasonCode |
Public property | U_ReasonDesc |
Public property | U_ReasonGroup |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IReasonCode Interface
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode Properties

IReasonCode Interface See Also

The following tables list the members exposed by the IReasonCode type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_ReasonCode |
Public property | U_ReasonDesc |
Public property | U_ReasonGroup |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IReasonCode Interface
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Interface
IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Interface
IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Interface
IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Interface
IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Interface
IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Interface
IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Interface
IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Interface
IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Interface
IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Interface
IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Interface
IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Interface
IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode.U_ReasonCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_ReasonCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_ReasonCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_ReasonCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_ReasonCode() : String;

   AppEngineProperty(Required = true)
function set U_ReasonCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Interface
IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode.U_ReasonDesc Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReasonDesc() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ReasonDesc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ReasonDesc {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReasonDesc() : String;
function set U_ReasonDesc(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Interface
IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode.U_ReasonGroup Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReasonGroup() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ReasonGroup {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ReasonGroup {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReasonGroup() : String;
function set U_ReasonGroup(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Interface
IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Interface
IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Interface
IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Interface
IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonCode
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonCode Interface
IReasonCode Members
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


IReasonCode Methods

IReasonCode Interface See Also

The following tables list the members exposed by the IReasonCode type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IReasonCode Interface
CompuTec.ProcessForce.API.Documents.ReasonCode Namespace


CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IReasonGroup | Reason group object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IReasonGroup Interface

Members See Also

Reason group object

Namespace: CompuTec.ProcessForce.API.Documents.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ReasonGroup", TableName = "@CT_PF_ORSGRP", UDOVersion = "UDO_10")> _
Public Interface IReasonGroup
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ReasonGroup", TableName = "@CT_PF_ORSGRP", UDOVersion = "UDO_10")]
public interface IReasonGroup : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ReasonGroup", TableName = "@CT_PF_ORSGRP", UDOVersion = "UDO_10")]
public interface class IReasonGroup : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ReasonGroup", TableName = "@CT_PF_ORSGRP", UDOVersion = "UDO_10")
interface IReasonGroup
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ORSGRP
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Members
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup Members

IReasonGroup Interface Methods Properties See Also

Reason group object

The following tables list the members exposed by the IReasonGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_ReasonGrpCode |
Public property | U_ReasonGrpDesc |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IReasonGroup Interface
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup Properties

IReasonGroup Interface See Also

The following tables list the members exposed by the IReasonGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_ReasonGrpCode |
Public property | U_ReasonGrpDesc |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IReasonGroup Interface
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup.U_ReasonGrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_ReasonGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_ReasonGrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_ReasonGrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_ReasonGrpCode() : String;

   AppEngineProperty(Required = true)
function set U_ReasonGrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup.U_ReasonGrpDesc Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReasonGrpDesc() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ReasonGrpDesc {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ReasonGrpDesc {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReasonGrpDesc() : String;
function set U_ReasonGrpDesc(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.ReasonGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReasonGroup Interface
IReasonGroup Members
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


IReasonGroup Methods

IReasonGroup Interface See Also

The following tables list the members exposed by the IReasonGroup type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IReasonGroup Interface
CompuTec.ProcessForce.API.Documents.ReasonGroup Namespace


CompuTec.ProcessForce.API.Documents.Resource Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IResource | Resource object
Public interface | IResourceAttachments | Attachments for resource object
Public interface | IResourceLinkedTools | Linked Tools for resource object
Public interface | IResourceProperties | Properties for resource object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IResource Interface

Members See Also

Resource object

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "Resource", TableName = "@CT_PF_ORSC")> _
Public Interface IResource
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Resource", TableName = "@CT_PF_ORSC")]
public interface IResource : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Resource", TableName = "@CT_PF_ORSC")]
public interface class IResource : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "Resource", TableName = "@CT_PF_ORSC")
interface IResource
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ORSC
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource Members

IResource Interface Methods Properties See Also

Resource object

The following tables list the members exposed by the IResource type.

Properties
 | Name | Description
Public property | Attachments | Resource Lines :Attachments
Public property | BinCode |
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_ItemName |
Public property | DS_RscCalTableCode |
Public property | DS_RscCode |
Public property | DS_RscGrpName | Resource Group Name Get
Public property | DS_RscGrpTableCode |
Public property | DS_VendorName |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LinkedTools | Resource Lines : Linked Tools
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Properties | Resource Lines : resource Properies
Public property | RBinCode | Production Recrip Bin Code
Public property | ResourceGroupName |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Activity |
Public property | U_BinAbs |
Public property | U_CycleCap | Cycle Capacity
Public property | U_GSort | Gant Sort Settings
Public property | U_HasCycles | Is this Resource works in cycles
Public property | U_Infinite |
Public property | U_Info1 | Info 1 Formula
Public property | U_Info2 | Info 2 Formula
Public property | U_Info3 | Info 3 Formula
Public property | U_Info4 | Info 4 Formula
Public property | U_Info5 | Info 5 Formula
Public property | U_Info6 | Info 6 Formula
Public property | U_Info7 | Info 7 Formula
Public property | U_Info8 | Info 8 Formula
Public property | U_ItemCode |
Public property | U_LInfo1 | Info 1 Label
Public property | U_LInfo2 | Info 2 Label
Public property | U_LInfo3 | Info 3 Label
Public property | U_LInfo4 | Info 4 Label
Public property | U_LInfo5 | Info 5 Label
Public property | U_LInfo6 | Info 6 Label
Public property | U_LInfo7 | Info 7 Label
Public property | U_LInfo8 | Info 8 Label
Public property | U_OcrCode |
Public property | U_OcrCode2 |
Public property | U_OcrCode3 |
Public property | U_OcrCode4 |
Public property | U_OcrCode5 |
Public property | U_Project |
Public property | U_QueueRate | Default Queue Rate for this Resource
Public property | U_QueueTime | Default Queue Time for this resource
Public property | U_RBinAbs | Production Recrip Bin ID
Public property | U_RWhsCode | Production Recrip Warehouse
Public property | U_Remarks |
Public property | U_ResActCode | Resource Accounting code
Public property | U_ResourceCount | Number of resources in Company
Public property | U_RscCode | Resource code - mandatory
Public property | U_RscGrpCode | Resource group code
Public property | U_RscName | Resource Name
Public property | U_RscType | Resource Type M- Machine T- Tool L- Labour
Public property | U_RunRate | Default Run Rate for this Resource
Public property | U_RunTime | Default Run Time for this resource
Public property | U_SetupRate | Default Setup Rate for this Resource
Public property | U_SetupTime | Default Setup Time for this resource
Public property | U_StockRate | Default Stock Rate for this Resource
Public property | U_StockTime | Default Stock Time for this resource
Public property | U_VendorCode |
Public property | U_WhsCode | Production Issue Warehouse
Public property | U_Wrnng | Warning formula
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetByRscCode | Load Resource Object
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | IsInUse | Check if this resource is in use
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IResource Interface
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource Properties

IResource Interface See Also

The following tables list the members exposed by the IResource type.

Properties
 | Name | Description
Public property | Attachments | Resource Lines :Attachments
Public property | BinCode |
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_ItemName |
Public property | DS_RscCalTableCode |
Public property | DS_RscCode |
Public property | DS_RscGrpName | Resource Group Name Get
Public property | DS_RscGrpTableCode |
Public property | DS_VendorName |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LinkedTools | Resource Lines : Linked Tools
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Properties | Resource Lines : resource Properies
Public property | RBinCode | Production Recrip Bin Code
Public property | ResourceGroupName |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Activity |
Public property | U_BinAbs |
Public property | U_CycleCap | Cycle Capacity
Public property | U_GSort | Gant Sort Settings
Public property | U_HasCycles | Is this Resource works in cycles
Public property | U_Infinite |
Public property | U_Info1 | Info 1 Formula
Public property | U_Info2 | Info 2 Formula
Public property | U_Info3 | Info 3 Formula
Public property | U_Info4 | Info 4 Formula
Public property | U_Info5 | Info 5 Formula
Public property | U_Info6 | Info 6 Formula
Public property | U_Info7 | Info 7 Formula
Public property | U_Info8 | Info 8 Formula
Public property | U_ItemCode |
Public property | U_LInfo1 | Info 1 Label
Public property | U_LInfo2 | Info 2 Label
Public property | U_LInfo3 | Info 3 Label
Public property | U_LInfo4 | Info 4 Label
Public property | U_LInfo5 | Info 5 Label
Public property | U_LInfo6 | Info 6 Label
Public property | U_LInfo7 | Info 7 Label
Public property | U_LInfo8 | Info 8 Label
Public property | U_OcrCode |
Public property | U_OcrCode2 |
Public property | U_OcrCode3 |
Public property | U_OcrCode4 |
Public property | U_OcrCode5 |
Public property | U_Project |
Public property | U_QueueRate | Default Queue Rate for this Resource
Public property | U_QueueTime | Default Queue Time for this resource
Public property | U_RBinAbs | Production Recrip Bin ID
Public property | U_RWhsCode | Production Recrip Warehouse
Public property | U_Remarks |
Public property | U_ResActCode | Resource Accounting code
Public property | U_ResourceCount | Number of resources in Company
Public property | U_RscCode | Resource code - mandatory
Public property | U_RscGrpCode | Resource group code
Public property | U_RscName | Resource Name
Public property | U_RscType | Resource Type M- Machine T- Tool L- Labour
Public property | U_RunRate | Default Run Rate for this Resource
Public property | U_RunTime | Default Run Time for this resource
Public property | U_SetupRate | Default Setup Rate for this Resource
Public property | U_SetupTime | Default Setup Time for this resource
Public property | U_StockRate | Default Stock Rate for this Resource
Public property | U_StockTime | Default Stock Time for this resource
Public property | U_VendorCode |
Public property | U_WhsCode | Production Issue Warehouse
Public property | U_Wrnng | Warning formula
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IResource Interface
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.Attachments Property

Resource Lines :Attachments

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Attachments() As IResourceAttachments
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IResourceAttachments Attachments {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IResourceAttachments^ Attachments {
 IResourceAttachments^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Attachments() : IResourceAttachments;
This language is not supported or no code example is available.

Property Value

Type: IResourceAttachments
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.BinCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property BinCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string BinCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ BinCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get BinCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.DS_ItemName Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemName() : String;

   AppEnginePropertyIgnore()
function set DS_ItemName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.DS_RscCalTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_RscCalTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_RscCalTableCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_RscCalTableCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_RscCalTableCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.DS_RscCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_RscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_RscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_RscCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_RscCode() : String;

   AppEnginePropertyIgnore()
function set DS_RscCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.DS_RscGrpName Property

Resource Group Name Get

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_RscGrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_RscGrpName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_RscGrpName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_RscGrpName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.DS_RscGrpTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_RscGrpTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_RscGrpTableCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_RscGrpTableCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_RscGrpTableCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.DS_VendorName Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_VendorName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_VendorName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_VendorName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_VendorName() : String;

   AppEnginePropertyIgnore()
function set DS_VendorName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.LinkedTools Property

Resource Lines : Linked Tools

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LinkedTools() As IResourceLinkedTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IResourceLinkedTools LinkedTools {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IResourceLinkedTools^ LinkedTools {
 IResourceLinkedTools^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LinkedTools() : IResourceLinkedTools;
This language is not supported or no code example is available.

Property Value

Type: IResourceLinkedTools
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.Properties Property

Resource Lines : resource Properies

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Properties() As IResourceProperties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IResourceProperties Properties {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IResourceProperties^ Properties {
 IResourceProperties^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Properties() : IResourceProperties;
This language is not supported or no code example is available.

Property Value

Type: IResourceProperties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.RBinCode Property

Production Recrip Bin Code

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property RBinCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string RBinCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ RBinCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get RBinCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.ResourceGroupName Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property ResourceGroupName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string ResourceGroupName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ ResourceGroupName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get ResourceGroupName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_Activity Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Activity() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Activity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Activity {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Activity() : String;
function set U_Activity(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_BinAbs Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BinAbs() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BinAbs {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BinAbs {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BinAbs() : int;
function set U_BinAbs(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_CycleCap Property

Cycle Capacity

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CycleCap() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_CycleCap {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_CycleCap {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CycleCap() : double;
function set U_CycleCap(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_GSort Property

Gant Sort Settings

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_GSort() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_GSort {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_GSort {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_GSort() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_HasCycles Property

Is this Resource works in cycles

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_HasCycles() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_HasCycles {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_HasCycles {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_HasCycles() : YesNoType;
function set U_HasCycles(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_Infinite Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Infinite() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Infinite {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Infinite {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Infinite() : YesNoType;
function set U_Infinite(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_Info1 Property

Info 1 Formula

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Info1() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Info1 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Info1 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Info1() : String;
function set U_Info1(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_Info2 Property

Info 2 Formula

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Info2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Info2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Info2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Info2() : String;
function set U_Info2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_Info3 Property

Info 3 Formula

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Info3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Info3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Info3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Info3() : String;
function set U_Info3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_Info4 Property

Info 4 Formula

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Info4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Info4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Info4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Info4() : String;
function set U_Info4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_Info5 Property

Info 5 Formula

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Info5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Info5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Info5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Info5() : String;
function set U_Info5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_Info6 Property

Info 6 Formula

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Info6() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Info6 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Info6 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Info6() : String;
function set U_Info6(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_Info7 Property

Info 7 Formula

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Info7() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Info7 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Info7 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Info7() : String;
function set U_Info7(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_Info8 Property

Info 8 Formula

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Info8() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Info8 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Info8 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Info8() : String;
function set U_Info8(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_LInfo1 Property

Info 1 Label

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LInfo1() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LInfo1 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LInfo1 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LInfo1() : String;
function set U_LInfo1(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_LInfo2 Property

Info 2 Label

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LInfo2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LInfo2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LInfo2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LInfo2() : String;
function set U_LInfo2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_LInfo3 Property

Info 3 Label

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LInfo3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LInfo3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LInfo3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LInfo3() : String;
function set U_LInfo3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_LInfo4 Property

Info 4 Label

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LInfo4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LInfo4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LInfo4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LInfo4() : String;
function set U_LInfo4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_LInfo5 Property

Info 5 Label

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LInfo5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LInfo5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LInfo5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LInfo5() : String;
function set U_LInfo5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_LInfo6 Property

Info 6 Label

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LInfo6() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LInfo6 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LInfo6 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LInfo6() : String;
function set U_LInfo6(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_LInfo7 Property

Info 7 Label

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LInfo7() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LInfo7 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LInfo7 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LInfo7() : String;
function set U_LInfo7(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_LInfo8 Property

Info 8 Label

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LInfo8() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LInfo8 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LInfo8 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LInfo8() : String;
function set U_LInfo8(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_OcrCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode() : String;
function set U_OcrCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_OcrCode2 Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode2() : String;
function set U_OcrCode2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_OcrCode3 Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode3() : String;
function set U_OcrCode3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_OcrCode4 Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode4() : String;
function set U_OcrCode4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_OcrCode5 Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode5() : String;
function set U_OcrCode5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_Project Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Project() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Project {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Project {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Project() : String;
function set U_Project(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_QueueRate Property

Default Queue Rate for this Resource

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QueueRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_QueueRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_QueueRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueRate() : RateType;
function set U_QueueRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_QueueTime Property

Default Queue Time for this resource

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QueueTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_QueueTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_QueueTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueTime() : double;
function set U_QueueTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_RBinAbs Property

Production Recrip Bin ID

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RBinAbs() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RBinAbs {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RBinAbs {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RBinAbs() : int;
function set U_RBinAbs(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_RWhsCode Property

Production Recrip Warehouse

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RWhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RWhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RWhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RWhsCode() : String;
function set U_RWhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_ResActCode Property

Resource Accounting code

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ResActCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ResActCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ResActCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ResActCode() : String;
function set U_ResActCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_ResourceCount Property

Number of resources in Company

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ResourceCount() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ResourceCount {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ResourceCount {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ResourceCount() : int;
function set U_ResourceCount(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_RscCode Property

Resource code - mandatory

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCode() : String;
function set U_RscCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_RscGrpCode Property

Resource group code

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscGrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscGrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscGrpCode() : String;
function set U_RscGrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_RscName Property

Resource Name

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscName() : String;
function set U_RscName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_RscType Property

Resource Type M- Machine T- Tool L- Labour

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscType() As ResourceType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ResourceType U_RscType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ResourceType U_RscType {
 ResourceType get( );
 void set(
   ResourceType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscType() : ResourceType;
function set U_RscType(value : ResourceType);
This language is not supported or no code example is available.

Property Value

Type: ResourceType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_RunRate Property

Default Run Rate for this Resource

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RunRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_RunRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_RunRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunRate() : RateType;
function set U_RunRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_RunTime Property

Default Run Time for this resource

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RunTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RunTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RunTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunTime() : double;
function set U_RunTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_SetupRate Property

Default Setup Rate for this Resource

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SetupRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_SetupRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_SetupRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupRate() : RateType;
function set U_SetupRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_SetupTime Property

Default Setup Time for this resource

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SetupTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_SetupTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_SetupTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupTime() : double;
function set U_SetupTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_StockRate Property

Default Stock Rate for this Resource

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StockRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_StockRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_StockRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockRate() : RateType;
function set U_StockRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_StockTime Property

Default Stock Time for this resource

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StockTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_StockTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_StockTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockTime() : double;
function set U_StockTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_VendorCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_VendorCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_VendorCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_VendorCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_VendorCode() : String;
function set U_VendorCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_WhsCode Property

Production Issue Warehouse

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.U_Wrnng Property

Warning formula

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Wrnng() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Wrnng {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Wrnng {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Wrnng() : String;
function set U_Wrnng(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource Methods

IResource Interface See Also

The following tables list the members exposed by the IResource type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetByRscCode | Load Resource Object
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | IsInUse | Check if this resource is in use
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IResource Interface
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.GetByRscCode Method

Load Resource Object

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByRscCode( _
   ByVal RscCode As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByRscCode(
   string RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByRscCode(
   String^ RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByRscCode(
    RscCode : String
) : int;
This language is not supported or no code example is available.

Parameters

RscCode

Type: string

U_RscCode

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResource.IsInUse Method

Check if this resource is in use

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function IsInUse() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool IsInUse()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool IsInUse()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function IsInUse() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResource Interface
IResource Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceAttachments Interface

Members See Also

Attachments for resource object

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IResourceAttachments
    Inherits IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IResourceAttachments : IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IResourceAttachments : public IUDOChildBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IResourceAttachments
   implements IUDOChildBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_RSC9
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceAttachments Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceAttachments Members

IResourceAttachments Interface Methods Properties See Also

Attachments for resource object

The following tables list the members exposed by the IResourceAttachments type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AttDate |
Public property | U_FileName |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Path |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

IResourceAttachments Interface
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceAttachments Properties

IResourceAttachments Interface See Also

The following tables list the members exposed by the IResourceAttachments type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AttDate |
Public property | U_FileName |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Path |
Top
See Also

Reference

IResourceAttachments Interface
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceAttachments.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceAttachments Interface
IResourceAttachments Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceAttachments.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceAttachments Interface
IResourceAttachments Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceAttachments.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceAttachments Interface
IResourceAttachments Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceAttachments.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceAttachments Interface
IResourceAttachments Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceAttachments.U_AttDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_AttDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_AttDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttDate() : DateTime;
function set U_AttDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceAttachments Interface
IResourceAttachments Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceAttachments.U_FileName Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FileName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FileName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FileName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FileName() : String;
function set U_FileName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceAttachments Interface
IResourceAttachments Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceAttachments.U_Path Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Path() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Path {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Path {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Path() : String;
function set U_Path(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceAttachments Interface
IResourceAttachments Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceAttachments Methods

IResourceAttachments Interface See Also

The following tables list the members exposed by the IResourceAttachments type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

IResourceAttachments Interface
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceLinkedTools Interface

Members See Also

Linked Tools for resource object

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IResourceLinkedTools
    Inherits IUDOChildBean, _
             IEnumerable(Of IResourceLinkedTools)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IResourceLinkedTools : IUDOChildBean,
   IEnumerable<IResourceLinkedTools>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IResourceLinkedTools : public IUDOChildBean^,
   public IEnumerable<IResourceLinkedTools^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_RSC2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceLinkedTools Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceLinkedTools Members

IResourceLinkedTools Interface Methods Properties See Also

Linked Tools for resource object

The following tables list the members exposed by the IResourceLinkedTools type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_LinkToolCode | Property Code -Mandatory
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IResourceLinkedTools Interface
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceLinkedTools Properties

IResourceLinkedTools Interface See Also

The following tables list the members exposed by the IResourceLinkedTools type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_LinkToolCode | Property Code -Mandatory
Top
See Also

Reference

IResourceLinkedTools Interface
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceLinkedTools.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceLinkedTools Interface
IResourceLinkedTools Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceLinkedTools.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceLinkedTools Interface
IResourceLinkedTools Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceLinkedTools.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceLinkedTools Interface
IResourceLinkedTools Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceLinkedTools.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceLinkedTools Interface
IResourceLinkedTools Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceLinkedTools.U_LinkToolCode Property

Property Code -Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LinkToolCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LinkToolCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LinkToolCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LinkToolCode() : String;
function set U_LinkToolCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceLinkedTools Interface
IResourceLinkedTools Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceLinkedTools Methods

IResourceLinkedTools Interface See Also

The following tables list the members exposed by the IResourceLinkedTools type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IResourceLinkedTools Interface
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceProperties Interface

Members See Also

Properties for resource object

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IResourceProperties
    Inherits IUDOChildBean, _
             IEnumerable(Of IResourceProperties)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IResourceProperties : IUDOChildBean,
   IEnumerable<IResourceProperties>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IResourceProperties : public IUDOChildBean^,
   public IEnumerable<IResourceProperties^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_RSC1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperties Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceProperties Members

IResourceProperties Interface Methods Properties See Also

Properties for resource object

The following tables list the members exposed by the IResourceProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_PrpName |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | PropertyName |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PrpCode | Property Code -Mandatory
Public property | U_PrpConType |
Public property | U_PrpConValue |
Public property | U_PrpConValueTo |
Public property | U_Remarks | This is remarks.
Public property | U_RscCode | Resource Code ReadOnly
Public property | U_UnitOfMeasure |
Public property | U_WordCode | This is dictionary value for property value.
Public property | WordName | This is remarks.
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IResourceProperties Interface
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceProperties Properties

IResourceProperties Interface See Also

The following tables list the members exposed by the IResourceProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_PrpName |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | PropertyName |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PrpCode | Property Code -Mandatory
Public property | U_PrpConType |
Public property | U_PrpConValue |
Public property | U_PrpConValueTo |
Public property | U_Remarks | This is remarks.
Public property | U_RscCode | Resource Code ReadOnly
Public property | U_UnitOfMeasure |
Public property | U_WordCode | This is dictionary value for property value.
Public property | WordName | This is remarks.
Top
See Also

Reference

IResourceProperties Interface
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceProperties.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperties Interface
IResourceProperties Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceProperties.DS_PrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_PrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_PrpName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_PrpName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_PrpName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperties Interface
IResourceProperties Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceProperties.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperties Interface
IResourceProperties Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceProperties.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperties Interface
IResourceProperties Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceProperties.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperties Interface
IResourceProperties Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceProperties.PropertyName Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property PropertyName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string PropertyName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ PropertyName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get PropertyName() : String;

   AppEnginePropertyIgnore()
function set PropertyName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperties Interface
IResourceProperties Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceProperties.U_PrpCode Property

Property Code -Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpCode() : String;
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperties Interface
IResourceProperties Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceProperties.U_PrpConType Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConType() As ConditionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ConditionType U_PrpConType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ConditionType U_PrpConType {
 ConditionType get( );
 void set(
   ConditionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConType() : ConditionType;
function set U_PrpConType(value : ConditionType);
This language is not supported or no code example is available.

Property Value

Type: ConditionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperties Interface
IResourceProperties Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceProperties.U_PrpConValue Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValue() : double;
function set U_PrpConValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperties Interface
IResourceProperties Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceProperties.U_PrpConValueTo Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValueTo() : double;
function set U_PrpConValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperties Interface
IResourceProperties Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceProperties.U_Remarks Property

This is remarks.

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperties Interface
IResourceProperties Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceProperties.U_RscCode Property

Resource Code ReadOnly

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperties Interface
IResourceProperties Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceProperties.U_UnitOfMeasure Property

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UnitOfMeasure {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UnitOfMeasure {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UnitOfMeasure() : String;
function set U_UnitOfMeasure(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperties Interface
IResourceProperties Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceProperties.U_WordCode Property

This is dictionary value for property value.

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperties Interface
IResourceProperties Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceProperties.WordName Property

This is remarks.

Namespace: CompuTec.ProcessForce.API.Documents.Resource
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property WordName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string WordName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ WordName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get WordName() : String;

   AppEnginePropertyIgnore()
function set WordName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperties Interface
IResourceProperties Members
CompuTec.ProcessForce.API.Documents.Resource Namespace


IResourceProperties Methods

IResourceProperties Interface See Also

The following tables list the members exposed by the IResourceProperties type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IResourceProperties Interface
CompuTec.ProcessForce.API.Documents.Resource Namespace


CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IResourceCheckList | Resource checklist object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IResourceCheckList Interface

Members See Also

Resource checklist object

Namespace: CompuTec.ProcessForce.API.Documents.ResourceCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ResourceCheckList", TableName = "@CT_PF_ORCH")> _
Public Interface IResourceCheckList
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ResourceCheckList", TableName = "@CT_PF_ORCH")]
public interface IResourceCheckList : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ResourceCheckList", TableName = "@CT_PF_ORCH")]
public interface class IResourceCheckList : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ResourceCheckList", TableName = "@CT_PF_ORCH")
interface IResourceCheckList
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ORCH
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCheckList Members
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


IResourceCheckList Members

IResourceCheckList Interface Methods Properties See Also

Resource checklist object

The following tables list the members exposed by the IResourceCheckList type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Name |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Checked |
Public property | U_CurrentRemarks |
Public property | U_CurrentWordCode |
Public property | U_EmplID |
Public property | U_MorEntry |
Public property | U_OprCode |
Public property | U_PrpCode |
Public property | U_Remarks |
Public property | U_RscCode |
Public property | U_RtgCode |
Public property | U_RtgOprCode |
Public property | U_RtopRscCode |
Public property | U_Value |
Public property | U_WordCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IResourceCheckList Interface
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


IResourceCheckList Properties

IResourceCheckList Interface See Also

The following tables list the members exposed by the IResourceCheckList type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Name |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Checked |
Public property | U_CurrentRemarks |
Public property | U_CurrentWordCode |
Public property | U_EmplID |
Public property | U_MorEntry |
Public property | U_OprCode |
Public property | U_PrpCode |
Public property | U_Remarks |
Public property | U_RscCode |
Public property | U_RtgCode |
Public property | U_RtgOprCode |
Public property | U_RtopRscCode |
Public property | U_Value |
Public property | U_WordCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
See Also

Reference

IResourceCheckList Interface
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


IResourceCheckList.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCheckList Interface
IResourceCheckList Members
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


IResourceCheckList.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
function set Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCheckList Interface
IResourceCheckList Members
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


IResourceCheckList.U_Checked Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Checked() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_Checked {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_Checked {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Checked() : YesNoType;
function set U_Checked(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCheckList Interface
IResourceCheckList Members
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


IResourceCheckList.U_CurrentRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CurrentRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CurrentRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CurrentRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CurrentRemarks() : String;
function set U_CurrentRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCheckList Interface
IResourceCheckList Members
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


IResourceCheckList.U_CurrentWordCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CurrentWordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CurrentWordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CurrentWordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CurrentWordCode() : String;
function set U_CurrentWordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCheckList Interface
IResourceCheckList Members
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


IResourceCheckList.U_EmplID Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EmplID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_EmplID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_EmplID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EmplID() : int;
function set U_EmplID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCheckList Interface
IResourceCheckList Members
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


IResourceCheckList.U_MorEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MorEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_MorEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_MorEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MorEntry() : int;
function set U_MorEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCheckList Interface
IResourceCheckList Members
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


IResourceCheckList.U_OprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprCode() : String;
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCheckList Interface
IResourceCheckList Members
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


IResourceCheckList.U_PrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpCode() : String;
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCheckList Interface
IResourceCheckList Members
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


IResourceCheckList.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCheckList Interface
IResourceCheckList Members
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


IResourceCheckList.U_RscCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCode() : String;
function set U_RscCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCheckList Interface
IResourceCheckList Members
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


IResourceCheckList.U_RtgCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RtgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RtgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgCode() : String;
function set U_RtgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCheckList Interface
IResourceCheckList Members
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


IResourceCheckList.U_RtgOprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RtgOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RtgOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgOprCode() : int;
function set U_RtgOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCheckList Interface
IResourceCheckList Members
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


IResourceCheckList.U_RtopRscCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtopRscCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RtopRscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RtopRscCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtopRscCode() : int;
function set U_RtopRscCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCheckList Interface
IResourceCheckList Members
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


IResourceCheckList.U_Value Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Value() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Value {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Value {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Value() : double;
function set U_Value(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCheckList Interface
IResourceCheckList Members
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


IResourceCheckList.U_WordCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceCheckList
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceCheckList Interface
IResourceCheckList Members
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


IResourceCheckList Methods

IResourceCheckList Interface See Also

The following tables list the members exposed by the IResourceCheckList type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IResourceCheckList Interface
CompuTec.ProcessForce.API.Documents.ResourceCheckList Namespace


CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IResourceGroup | Resource group object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IResourceGroup Interface

Members See Also

Resource group object

Namespace: CompuTec.ProcessForce.API.Documents.ResourceGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ResourceGroup", TableName = "@CT_PF_ORGR", UDOVersion = "UDO_10")> _
Public Interface IResourceGroup
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ResourceGroup", TableName = "@CT_PF_ORGR", UDOVersion = "UDO_10")]
public interface IResourceGroup : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ResourceGroup", TableName = "@CT_PF_ORGR", UDOVersion = "UDO_10")]
public interface class IResourceGroup : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ResourceGroup", TableName = "@CT_PF_ORGR", UDOVersion = "UDO_10")
interface IResourceGroup
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ORGR
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceGroup Members
CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace


IResourceGroup Members

IResourceGroup Interface Methods Properties See Also

Resource group object

The following tables list the members exposed by the IResourceGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_RscGrpCode | Resource Group Code - Mandatory
Public property | U_RscGrpName | Resource Group Name
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IResourceGroup Interface
CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace


IResourceGroup Properties

IResourceGroup Interface See Also

The following tables list the members exposed by the IResourceGroup type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_RscGrpCode | Resource Group Code - Mandatory
Public property | U_RscGrpName | Resource Group Name
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IResourceGroup Interface
CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace


IResourceGroup.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceGroup Interface
IResourceGroup Members
CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace


IResourceGroup.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceGroup Interface
IResourceGroup Members
CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace


IResourceGroup.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceGroup Interface
IResourceGroup Members
CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace


IResourceGroup.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceGroup Interface
IResourceGroup Members
CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace


IResourceGroup.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceGroup Interface
IResourceGroup Members
CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace


IResourceGroup.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceGroup Interface
IResourceGroup Members
CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace


IResourceGroup.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceGroup Interface
IResourceGroup Members
CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace


IResourceGroup.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceGroup Interface
IResourceGroup Members
CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace


IResourceGroup.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceGroup Interface
IResourceGroup Members
CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace


IResourceGroup.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceGroup Interface
IResourceGroup Members
CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace


IResourceGroup.U_RscGrpCode Property

Resource Group Code - Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.ResourceGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_RscGrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_RscGrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_RscGrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_RscGrpCode() : String;

   AppEngineProperty(Required = true)
function set U_RscGrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceGroup Interface
IResourceGroup Members
CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace


IResourceGroup.U_RscGrpName Property

Resource Group Name

Namespace: CompuTec.ProcessForce.API.Documents.ResourceGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscGrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscGrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscGrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscGrpName() : String;
function set U_RscGrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceGroup Interface
IResourceGroup Members
CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace


IResourceGroup.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceGroup Interface
IResourceGroup Members
CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace


IResourceGroup.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceGroup Interface
IResourceGroup Members
CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace


IResourceGroup.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceGroup
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceGroup Interface
IResourceGroup Members
CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace


IResourceGroup Methods

IResourceGroup Interface See Also

The following tables list the members exposed by the IResourceGroup type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IResourceGroup Interface
CompuTec.ProcessForce.API.Documents.ResourceGroup Namespace


CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IResourceProperty | Resource properties object
Public interface | IResourcePropertyWords | Words for resource properties object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IResourceProperty Interface

Members See Also

Resource properties object

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "ResourceProperty", TableName = "@CT_PF_OPRR", UDOVersion = "UDO_10")> _
Public Interface IResourceProperty
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ResourceProperty", TableName = "@CT_PF_OPRR", UDOVersion = "UDO_10")]
public interface IResourceProperty : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "ResourceProperty", TableName = "@CT_PF_OPRR", UDOVersion = "UDO_10")]
public interface class IResourceProperty : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "ResourceProperty", TableName = "@CT_PF_OPRR", UDOVersion = "UDO_10")
interface IResourceProperty
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OPRR
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperty Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty Members

IResourceProperty Interface Methods Properties See Also

Resource properties object

The following tables list the members exposed by the IResourceProperty type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_RscPrpCode | Resource Property -Mangatory
Public property | U_RscPrpName | Resource Property Name
Public property | U_RscPrpRemarks | Resource Property Remarks
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Public property | Words |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetByRscPrpCode | Loads data From Databse by U_RscPrpCode
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IResourceProperty Interface
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty Properties

IResourceProperty Interface See Also

The following tables list the members exposed by the IResourceProperty type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_RscPrpCode | Resource Property -Mangatory
Public property | U_RscPrpName | Resource Property Name
Public property | U_RscPrpRemarks | Resource Property Remarks
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Public property | Words |
Top
See Also

Reference

IResourceProperty Interface
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperty Interface
IResourceProperty Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperty Interface
IResourceProperty Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperty Interface
IResourceProperty Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperty Interface
IResourceProperty Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperty Interface
IResourceProperty Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperty Interface
IResourceProperty Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperty Interface
IResourceProperty Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperty Interface
IResourceProperty Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperty Interface
IResourceProperty Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperty Interface
IResourceProperty Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty.U_RscPrpCode Property

Resource Property -Mangatory

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscPrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscPrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscPrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscPrpCode() : String;
function set U_RscPrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperty Interface
IResourceProperty Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty.U_RscPrpName Property

Resource Property Name

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscPrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscPrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscPrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscPrpName() : String;
function set U_RscPrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperty Interface
IResourceProperty Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty.U_RscPrpRemarks Property

Resource Property Remarks

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscPrpRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscPrpRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscPrpRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscPrpRemarks() : String;
function set U_RscPrpRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperty Interface
IResourceProperty Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperty Interface
IResourceProperty Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperty Interface
IResourceProperty Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperty Interface
IResourceProperty Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty.Words Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Words() As IResourcePropertyWords
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IResourcePropertyWords Words {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IResourcePropertyWords^ Words {
 IResourcePropertyWords^ get( );
 void set(
   IResourcePropertyWords^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Words() : IResourcePropertyWords;
function set Words(value : IResourcePropertyWords);
This language is not supported or no code example is available.

Property Value

Type: IResourcePropertyWords
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperty Interface
IResourceProperty Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty Methods

IResourceProperty Interface See Also

The following tables list the members exposed by the IResourceProperty type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetByRscPrpCode | Loads data From Databse by U_RscPrpCode
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IResourceProperty Interface
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourceProperty.GetByRscPrpCode Method

Loads data From Databse by U_RscPrpCode

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByRscPrpCode( _
   ByVal code As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByRscPrpCode(
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByRscPrpCode(
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByRscPrpCode(
    code : String
) : int;
This language is not supported or no code example is available.

Parameters

code

Type: string

U_RscPrpCode

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourceProperty Interface
IResourceProperty Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourcePropertyWords Interface

Members See Also

Words for resource properties object

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IResourcePropertyWords
    Inherits IUDOChildBean, _
             IEnumerable(Of IResourcePropertyWords)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IResourcePropertyWords : IUDOChildBean,
   IEnumerable<IResourcePropertyWords>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IResourcePropertyWords : public IUDOChildBean^,
   public IEnumerable<IResourcePropertyWords^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_PRR1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcePropertyWords Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourcePropertyWords Members

IResourcePropertyWords Interface Methods Properties See Also

Words for resource properties object

The following tables list the members exposed by the IResourcePropertyWords type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_WordName |
Public property | DS_WordRemarks |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_WordCode |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IResourcePropertyWords Interface
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourcePropertyWords Properties

IResourcePropertyWords Interface See Also

The following tables list the members exposed by the IResourcePropertyWords type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_WordName |
Public property | DS_WordRemarks |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_WordCode |
Top
See Also

Reference

IResourcePropertyWords Interface
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourcePropertyWords.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcePropertyWords Interface
IResourcePropertyWords Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourcePropertyWords.DS_WordName Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_WordName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_WordName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_WordName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_WordName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcePropertyWords Interface
IResourcePropertyWords Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourcePropertyWords.DS_WordRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_WordRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_WordRemarks {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_WordRemarks {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_WordRemarks() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcePropertyWords Interface
IResourcePropertyWords Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourcePropertyWords.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcePropertyWords Interface
IResourcePropertyWords Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourcePropertyWords.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcePropertyWords Interface
IResourcePropertyWords Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourcePropertyWords.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcePropertyWords Interface
IResourcePropertyWords Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourcePropertyWords.U_WordCode Property

Namespace: CompuTec.ProcessForce.API.Documents.ResourceProperty
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_WordCode() : String;

   AppEngineProperty(Required = true)
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IResourcePropertyWords Interface
IResourcePropertyWords Members
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


IResourcePropertyWords Methods

IResourcePropertyWords Interface See Also

The following tables list the members exposed by the IResourcePropertyWords type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IResourcePropertyWords Interface
CompuTec.ProcessForce.API.Documents.ResourceProperty Namespace


CompuTec.ProcessForce.API.Documents.Routing Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IRouting | Routing object
Public interface | IRoutingOperationProperties | Properties for routing operations object
Public interface | IRoutingOperationRelations | Relations for routing operations object
Public interface | IRoutingOperationResourceProperties | Resource properties for routing operations object
Public interface | IRoutingOperationResources | Resources for routing operations object
Public interface | IRoutingOperations | Routing operations object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IRouting Interface

Members See Also

Routing object

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "Routing", TableName = "@CT_PF_ORTG", UDOVersion = "UDO_10")> _
Public Interface IRouting
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Routing", TableName = "@CT_PF_ORTG", UDOVersion = "UDO_10")]
public interface IRouting : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Routing", TableName = "@CT_PF_ORTG", UDOVersion = "UDO_10")]
public interface class IRouting : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "Routing", TableName = "@CT_PF_ORTG", UDOVersion = "UDO_10")
interface IRouting
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ORTG
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting Members

IRouting Interface Methods Properties See Also

Routing object

The following tables list the members exposed by the IRouting type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DimensionsParams |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | OperationProperties |
Public property | OperationResourceProperties |
Public property | OperationResources |
Public property | Operations |
Public property | Relations |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Remarks |
Public property | U_RtgCode |
Public property | U_RtgName |
Public property | U_TechInstructions |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetByRtgCode |
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IRouting Interface
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting Properties

IRouting Interface See Also

The following tables list the members exposed by the IRouting type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DimensionsParams |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | OperationProperties |
Public property | OperationResourceProperties |
Public property | OperationResources |
Public property | Operations |
Public property | Relations |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Remarks |
Public property | U_RtgCode |
Public property | U_RtgName |
Public property | U_TechInstructions |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IRouting Interface
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.DimensionsParams Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DimensionsParams() As Dictionary(Of String, IDimensions)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Dictionary<string, IDimensions> DimensionsParams {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Dictionary<String^, IDimensions^>^ DimensionsParams {
 Dictionary<String^, IDimensions^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: Dictionary<string, IDimensions>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.OperationProperties Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property OperationProperties() As IRoutingOperationProperties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IRoutingOperationProperties OperationProperties {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IRoutingOperationProperties^ OperationProperties {
 IRoutingOperationProperties^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OperationProperties() : IRoutingOperationProperties;
This language is not supported or no code example is available.

Property Value

Type: IRoutingOperationProperties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.OperationResourceProperties Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property OperationResourceProperties() As IRoutingOperationResourceProperties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IRoutingOperationResourceProperties OperationResourceProperties {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IRoutingOperationResourceProperties^ OperationResourceProperties {
 IRoutingOperationResourceProperties^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OperationResourceProperties() : IRoutingOperationResourceProperties;
This language is not supported or no code example is available.

Property Value

Type: IRoutingOperationResourceProperties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.OperationResources Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property OperationResources() As IRoutingOperationResources
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IRoutingOperationResources OperationResources {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IRoutingOperationResources^ OperationResources {
 IRoutingOperationResources^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OperationResources() : IRoutingOperationResources;
This language is not supported or no code example is available.

Property Value

Type: IRoutingOperationResources
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.Operations Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Operations() As IRoutingOperations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IRoutingOperations Operations {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IRoutingOperations^ Operations {
 IRoutingOperations^ get( );
 void set(
   IRoutingOperations^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Operations() : IRoutingOperations;
function set Operations(value : IRoutingOperations);
This language is not supported or no code example is available.

Property Value

Type: IRoutingOperations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.Relations Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Relations() As IRoutingOperationRelations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IRoutingOperationRelations Relations {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IRoutingOperationRelations^ Relations {
 IRoutingOperationRelations^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Relations() : IRoutingOperationRelations;
This language is not supported or no code example is available.

Property Value

Type: IRoutingOperationRelations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.U_RtgCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RtgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RtgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgCode() : String;
function set U_RtgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.U_RtgName Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RtgName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RtgName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgName() : String;
function set U_RtgName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.U_TechInstructions Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TechInstructions() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TechInstructions {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TechInstructions {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TechInstructions() : String;
function set U_TechInstructions(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting Methods

IRouting Interface See Also

The following tables list the members exposed by the IRouting type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetByRtgCode |
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IRouting Interface
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRouting.GetByRtgCode Method

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetByRtgCode( _
   ByVal rtgCode As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetByRtgCode(
   string rtgCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetByRtgCode(
   String^ rtgCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetByRtgCode(
    rtgCode : String
) : int;
This language is not supported or no code example is available.

Parameters

rtgCode

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRouting Interface
IRouting Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationProperties Interface

Members See Also

Properties for routing operations object

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean(Parent = "IRoutingOperations")> _
Public Interface IRoutingOperationProperties
    Inherits IUDOChildBean, _
             IEnumerable(Of IRoutingOperationProperties)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IRoutingOperations")]
public interface IRoutingOperationProperties : IUDOChildBean,
   IEnumerable<IRoutingOperationProperties>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IRoutingOperations")]
public interface class IRoutingOperationProperties : public IUDOChildBean^,
   public IEnumerable<IRoutingOperationProperties^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_RTG2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationProperties Members

IRoutingOperationProperties Interface Methods Properties See Also

Properties for routing operations object

The following tables list the members exposed by the IRoutingOperationProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PrpCode |
Public property | U_PrpConType |
Public property | U_PrpConValue |
Public property | U_PrpConValueTo |
Public property | U_Remarks |
Public property | U_RtgCode |
Public property | U_RtgOprCode |
Public property | U_UnitOfMeasure |
Public property | U_WordCode |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IRoutingOperationProperties Interface
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationProperties Properties

IRoutingOperationProperties Interface See Also

The following tables list the members exposed by the IRoutingOperationProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PrpCode |
Public property | U_PrpConType |
Public property | U_PrpConValue |
Public property | U_PrpConValueTo |
Public property | U_Remarks |
Public property | U_RtgCode |
Public property | U_RtgOprCode |
Public property | U_UnitOfMeasure |
Public property | U_WordCode |
Top
See Also

Reference

IRoutingOperationProperties Interface
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationProperties.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationProperties Interface
IRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationProperties.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationProperties Interface
IRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationProperties.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationProperties Interface
IRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationProperties.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationProperties Interface
IRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationProperties.U_PrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpCode() : String;
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationProperties Interface
IRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationProperties.U_PrpConType Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConType() As ConditionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ConditionType U_PrpConType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ConditionType U_PrpConType {
 ConditionType get( );
 void set(
   ConditionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConType() : ConditionType;
function set U_PrpConType(value : ConditionType);
This language is not supported or no code example is available.

Property Value

Type: ConditionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationProperties Interface
IRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationProperties.U_PrpConValue Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValue() : double;
function set U_PrpConValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationProperties Interface
IRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationProperties.U_PrpConValueTo Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValueTo() : double;
function set U_PrpConValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationProperties Interface
IRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationProperties.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationProperties Interface
IRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationProperties.U_RtgCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")> _
ReadOnly Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")]
string U_RtgCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")]

property String^ U_RtgCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")
function get U_RtgCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationProperties Interface
IRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationProperties.U_RtgOprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprCode")> _
Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprCode")]
int U_RtgOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprCode")]

property int U_RtgOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprCode")
function get U_RtgOprCode() : int;

   AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprCode")
function set U_RtgOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationProperties Interface
IRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationProperties.U_UnitOfMeasure Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UnitOfMeasure {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UnitOfMeasure {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UnitOfMeasure() : String;
function set U_UnitOfMeasure(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationProperties Interface
IRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationProperties.U_WordCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationProperties Interface
IRoutingOperationProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationProperties Methods

IRoutingOperationProperties Interface See Also

The following tables list the members exposed by the IRoutingOperationProperties type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IRoutingOperationProperties Interface
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationRelations Interface

Members See Also

Relations for routing operations object

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IRoutingOperationRelations
    Inherits IUDOChildBean, _
             IEnumerable(Of IRoutingOperationRelations)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IRoutingOperationRelations : IUDOChildBean,
   IEnumerable<IRoutingOperationRelations>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IRoutingOperationRelations : public IUDOChildBean^,
   public IEnumerable<IRoutingOperationRelations^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_RTG5
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationRelations Members

IRoutingOperationRelations Interface Methods Properties See Also

Relations for routing operations object

The following tables list the members exposed by the IRoutingOperationRelations type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine | Reference to U_LineNum Operation for witch we want to define predacessors
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_POprLine | Reference to Operation U_LineNUm witch is predacessor
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IRoutingOperationRelations Interface
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationRelations Properties

IRoutingOperationRelations Interface See Also

The following tables list the members exposed by the IRoutingOperationRelations type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLine | Reference to U_LineNum Operation for witch we want to define predacessors
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_POprLine | Reference to Operation U_LineNUm witch is predacessor
Top
See Also

Reference

IRoutingOperationRelations Interface
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationRelations.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationRelations Interface
IRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationRelations.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationRelations Interface
IRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationRelations.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationRelations Interface
IRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationRelations.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationRelations Interface
IRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationRelations.U_BaseLine Property

Reference to U_LineNum Operation for witch we want to define predacessors

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLine() : int;
function set U_BaseLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationRelations Interface
IRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationRelations.U_POprLine Property

Reference to Operation U_LineNUm witch is predacessor

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_POprLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_POprLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_POprLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_POprLine() : int;
function set U_POprLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationRelations Interface
IRoutingOperationRelations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationRelations Methods

IRoutingOperationRelations Interface See Also

The following tables list the members exposed by the IRoutingOperationRelations type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IRoutingOperationRelations Interface
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResourceProperties Interface

Members See Also

Resource properties for routing operations object

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean(Parent = "IRoutingOperationResources")> _
Public Interface IRoutingOperationResourceProperties
    Inherits IUDOChildBean, _
             IEnumerable(Of IRoutingOperationResourceProperties)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IRoutingOperationResources")]
public interface IRoutingOperationResourceProperties : IUDOChildBean,
   IEnumerable<IRoutingOperationResourceProperties>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IRoutingOperationResources")]
public interface class IRoutingOperationResourceProperties : public IUDOChildBean^,
   public IEnumerable<IRoutingOperationResourceProperties^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_RTG4
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResourceProperties Members

IRoutingOperationResourceProperties Interface Methods Properties See Also

Resource properties for routing operations object

The following tables list the members exposed by the IRoutingOperationResourceProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PrpCode | Property Code for ResourceProperty object -Mandatory
Public property | U_PrpConType | Condition Type
Public property | U_PrpConValue | Property Value
Public property | U_PrpConValueTo | Property Value To
Public property | U_Remarks | Remarks
Public property | U_RtgCode | Routing Code read only
Public property | U_RtgOprCode | RoutingOperation Key -Mandatory
Public property | U_RtgOprRscCode | Routing Operation Resource Key - Mandatory
Public property | U_UnitOfMeasure | UOM
Public property | U_WordCode | WordCode
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IRoutingOperationResourceProperties Interface
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResourceProperties Properties

IRoutingOperationResourceProperties Interface See Also

The following tables list the members exposed by the IRoutingOperationResourceProperties type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PrpCode | Property Code for ResourceProperty object -Mandatory
Public property | U_PrpConType | Condition Type
Public property | U_PrpConValue | Property Value
Public property | U_PrpConValueTo | Property Value To
Public property | U_Remarks | Remarks
Public property | U_RtgCode | Routing Code read only
Public property | U_RtgOprCode | RoutingOperation Key -Mandatory
Public property | U_RtgOprRscCode | Routing Operation Resource Key - Mandatory
Public property | U_UnitOfMeasure | UOM
Public property | U_WordCode | WordCode
Top
See Also

Reference

IRoutingOperationResourceProperties Interface
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResourceProperties.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResourceProperties Interface
IRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResourceProperties.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResourceProperties Interface
IRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResourceProperties.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResourceProperties Interface
IRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResourceProperties.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResourceProperties Interface
IRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResourceProperties.U_PrpCode Property

Property Code for ResourceProperty object -Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpCode() : String;
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResourceProperties Interface
IRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResourceProperties.U_PrpConType Property

Condition Type

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConType() As ConditionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ConditionType U_PrpConType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ConditionType U_PrpConType {
 ConditionType get( );
 void set(
   ConditionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConType() : ConditionType;
function set U_PrpConType(value : ConditionType);
This language is not supported or no code example is available.

Property Value

Type: ConditionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResourceProperties Interface
IRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResourceProperties.U_PrpConValue Property

Property Value

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValue() : double;
function set U_PrpConValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResourceProperties Interface
IRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResourceProperties.U_PrpConValueTo Property

Property Value To

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpConValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PrpConValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PrpConValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpConValueTo() : double;
function set U_PrpConValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResourceProperties Interface
IRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResourceProperties.U_Remarks Property

Remarks

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResourceProperties Interface
IRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResourceProperties.U_RtgCode Property

Routing Code read only

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")> _
ReadOnly Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")]
string U_RtgCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")]

property String^ U_RtgCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")
function get U_RtgCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResourceProperties Interface
IRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResourceProperties.U_RtgOprCode Property

RoutingOperation Key -Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")> _
Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")]
int U_RtgOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")]

property int U_RtgOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")
function get U_RtgOprCode() : int;

   AppEngineProperty(Priority = 3, ParentKey = "U_RtgOprCode")
function set U_RtgOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResourceProperties Interface
IRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResourceProperties.U_RtgOprRscCode Property

Routing Operation Resource Key - Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprRscCode")> _
Property U_RtgOprRscCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprRscCode")]
int U_RtgOprRscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprRscCode")]

property int U_RtgOprRscCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprRscCode")
function get U_RtgOprRscCode() : int;

   AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprRscCode")
function set U_RtgOprRscCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResourceProperties Interface
IRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResourceProperties.U_UnitOfMeasure Property

UOM

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UnitOfMeasure {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UnitOfMeasure {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UnitOfMeasure() : String;
function set U_UnitOfMeasure(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResourceProperties Interface
IRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResourceProperties.U_WordCode Property

WordCode

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordCode() : String;
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResourceProperties Interface
IRoutingOperationResourceProperties Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResourceProperties Methods

IRoutingOperationResourceProperties Interface See Also

The following tables list the members exposed by the IRoutingOperationResourceProperties type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IRoutingOperationResourceProperties Interface
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources Interface

Members See Also

Resources for routing operations object

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean(Parent = "IRoutingOperations")> _
Public Interface IRoutingOperationResources
    Inherits IUDOChildBean, _
             IEnumerable(Of IRoutingOperationResources)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IRoutingOperations")]
public interface IRoutingOperationResources : IUDOChildBean,
   IEnumerable<IRoutingOperationResources>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean(Parent = "IRoutingOperations")]
public interface class IRoutingOperationResources : public IUDOChildBean^,
   public IEnumerable<IRoutingOperationResources^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_RTG3
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources Members

IRoutingOperationResources Interface Methods Properties See Also

Resources for routing operations object

The following tables list the members exposed by the IRoutingOperationResources type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_CycleCap | Cycle Capacity
Public property | U_HasCycles | Is this Resource works in cycles
Public property | U_IsDefault | Is Default - Only one resource in each operation can be salected
Public property | U_IssueType | Issue Type
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MachineCode | Machine Code if Resource type is Machine this Filed is mandatory
Public property | U_OcrCode |
Public property | U_OcrCode2 |
Public property | U_OcrCode3 |
Public property | U_OcrCode4 |
Public property | U_OcrCode5 |
Public property | U_Project |
Public property | U_QueueRate | Rate For Queue --Values can be only fixed
Public property | U_QueueTime | Queue Time
Public property | U_Remarks | Resource Remarks
Public property | U_RscCode | Resource Code - Mandatory
Public property | U_RscType | Resource Type Read-Only
Public property | U_RtgCode | Get Touring Code
Public property | U_RtgOprCode | Key For Operation - Mandatory
Public property | U_RtgOprRscCode | Auto Generated Key For Current Resource
Public property | U_RunRate | Run Rate
Public property | U_RunTime | Run Time
Public property | U_SetupRate | Setup Rate -Values can be only fixed
Public property | U_SetupTime | Setup Time
Public property | U_StockRate | Stock Rate
Public property | U_StockTime | Stock Time
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IRoutingOperationResources Interface
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources Properties

IRoutingOperationResources Interface See Also

The following tables list the members exposed by the IRoutingOperationResources type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_CycleCap | Cycle Capacity
Public property | U_HasCycles | Is this Resource works in cycles
Public property | U_IsDefault | Is Default - Only one resource in each operation can be salected
Public property | U_IssueType | Issue Type
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MachineCode | Machine Code if Resource type is Machine this Filed is mandatory
Public property | U_OcrCode |
Public property | U_OcrCode2 |
Public property | U_OcrCode3 |
Public property | U_OcrCode4 |
Public property | U_OcrCode5 |
Public property | U_Project |
Public property | U_QueueRate | Rate For Queue --Values can be only fixed
Public property | U_QueueTime | Queue Time
Public property | U_Remarks | Resource Remarks
Public property | U_RscCode | Resource Code - Mandatory
Public property | U_RscType | Resource Type Read-Only
Public property | U_RtgCode | Get Touring Code
Public property | U_RtgOprCode | Key For Operation - Mandatory
Public property | U_RtgOprRscCode | Auto Generated Key For Current Resource
Public property | U_RunRate | Run Rate
Public property | U_RunTime | Run Time
Public property | U_SetupRate | Setup Rate -Values can be only fixed
Public property | U_SetupTime | Setup Time
Public property | U_StockRate | Stock Rate
Public property | U_StockTime | Stock Time
Top
See Also

Reference

IRoutingOperationResources Interface
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_CycleCap Property

Cycle Capacity

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CycleCap() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_CycleCap {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_CycleCap {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CycleCap() : double;
function set U_CycleCap(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_HasCycles Property

Is this Resource works in cycles

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_HasCycles() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_HasCycles {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_HasCycles {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_HasCycles() : YesNoType;
function set U_HasCycles(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_IsDefault Property

Is Default - Only one resource in each operation can be salected

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IsDefault() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_IsDefault {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_IsDefault {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IsDefault() : String;
function set U_IsDefault(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_IssueType Property

Issue Type

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IssueType() As IssueType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IssueType U_IssueType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IssueType U_IssueType {
 IssueType get( );
 void set(
   IssueType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IssueType() : IssueType;
function set U_IssueType(value : IssueType);
This language is not supported or no code example is available.

Property Value

Type: IssueType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_MachineCode Property

Machine Code if Resource type is Machine this Filed is mandatory

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MachineCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MachineCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MachineCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MachineCode() : String;
function set U_MachineCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_OcrCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode() : String;
function set U_OcrCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_OcrCode2 Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode2() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode2 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode2 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode2() : String;
function set U_OcrCode2(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_OcrCode3 Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode3() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode3 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode3 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode3() : String;
function set U_OcrCode3(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_OcrCode4 Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode4() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode4 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode4 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode4() : String;
function set U_OcrCode4(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_OcrCode5 Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OcrCode5() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OcrCode5 {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OcrCode5 {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OcrCode5() : String;
function set U_OcrCode5(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_Project Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Project() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Project {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Project {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Project() : String;
function set U_Project(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_QueueRate Property

Rate For Queue --Values can be only fixed

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QueueRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_QueueRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_QueueRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueRate() : RateType;
function set U_QueueRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_QueueTime Property

Queue Time

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QueueTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_QueueTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_QueueTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QueueTime() : double;
function set U_QueueTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_Remarks Property

Resource Remarks

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_RscCode Property

Resource Code - Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCode() : String;
function set U_RscCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_RscType Property

Resource Type Read-Only

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyReadOnly()> _
ReadOnly Property U_RscType() As ResourceType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]
ResourceType U_RscType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyReadOnly()]

property ResourceType U_RscType {
 ResourceType get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyReadOnly()
function get U_RscType() : ResourceType;
This language is not supported or no code example is available.

Property Value

Type: ResourceType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_RtgCode Property

Get Touring Code

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")> _
ReadOnly Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")]
string U_RtgCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")]

property String^ U_RtgCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 2, ParentKey = "U_RtgCode")
function get U_RtgCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_RtgOprCode Property

Key For Operation - Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprCode")> _
Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprCode")]
int U_RtgOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprCode")]

property int U_RtgOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprCode")
function get U_RtgOprCode() : int;

   AppEngineProperty(Priority = 4, ParentKey = "U_RtgOprCode")
function set U_RtgOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_RtgOprRscCode Property

Auto Generated Key For Current Resource

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgOprRscCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RtgOprRscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RtgOprRscCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgOprRscCode() : int;
function set U_RtgOprRscCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_RunRate Property

Run Rate

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RunRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_RunRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_RunRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunRate() : RateType;
function set U_RunRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_RunTime Property

Run Time

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RunTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RunTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RunTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RunTime() : double;
function set U_RunTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_SetupRate Property

Setup Rate -Values can be only fixed

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SetupRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_SetupRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_SetupRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupRate() : RateType;
function set U_SetupRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_SetupTime Property

Setup Time

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SetupTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_SetupTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_SetupTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SetupTime() : double;
function set U_SetupTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_StockRate Property

Stock Rate

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StockRate() As RateType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
RateType U_StockRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property RateType U_StockRate {
 RateType get( );
 void set(
   RateType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockRate() : RateType;
function set U_StockRate(value : RateType);
This language is not supported or no code example is available.

Property Value

Type: RateType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources.U_StockTime Property

Stock Time

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StockTime() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_StockTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_StockTime {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StockTime() : double;
function set U_StockTime(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperationResources Interface
IRoutingOperationResources Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperationResources Methods

IRoutingOperationResources Interface See Also

The following tables list the members exposed by the IRoutingOperationResources type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IRoutingOperationResources Interface
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations Interface

Members See Also

Routing operations object

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IRoutingOperations
    Inherits IUDOChildBean, _
             IEnumerable(Of IRoutingOperations), _
             IBaseOperationRelation
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IRoutingOperations : IUDOChildBean,
   IEnumerable<IRoutingOperations>,
   IBaseOperationRelation
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IRoutingOperations : public IUDOChildBean^,
   public IEnumerable<IRoutingOperations^>^,
   public IBaseOperationRelation^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_RTG1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations Members

IRoutingOperations Interface Methods Properties See Also

Routing operations object

The following tables list the members exposed by the IRoutingOperations type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_OprName | Operaion Name (read only)
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ForceExecOrder | Returns Yes if Force Execution Order is required
Public property | U_HasRelations | Returns Yes if Operation has declared Relations
Public property | U_IgnoreYield |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OprCode | Operation Code -Mandatory
Public property | U_OprOverlayCode | Operation Overlay Code
Public property | U_OprOverlayId | Operation Overlay ID
Public property | U_OprOverlayQty | Operation Overlay Quantity
Public property | U_OprSequence | Operation Sequence
Public property | U_QCActive | Quality Control is Active
Public property | U_RelationType | Specifies Relation Type
Public property | U_Remarks | Remarks
Public property | U_RtgCode |
Public property | U_RtgOprCode | RoutingOperation key - Madatory
Public property | U_TestProtocolNo | Test Protocol No
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IRoutingOperations Interface
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations Properties

IRoutingOperations Interface See Also

The following tables list the members exposed by the IRoutingOperations type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_OprName | Operaion Name (read only)
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ForceExecOrder | Returns Yes if Force Execution Order is required
Public property | U_HasRelations | Returns Yes if Operation has declared Relations
Public property | U_IgnoreYield |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_OprCode | Operation Code -Mandatory
Public property | U_OprOverlayCode | Operation Overlay Code
Public property | U_OprOverlayId | Operation Overlay ID
Public property | U_OprOverlayQty | Operation Overlay Quantity
Public property | U_OprSequence | Operation Sequence
Public property | U_QCActive | Quality Control is Active
Public property | U_RelationType | Specifies Relation Type
Public property | U_Remarks | Remarks
Public property | U_RtgCode |
Public property | U_RtgOprCode | RoutingOperation key - Madatory
Public property | U_TestProtocolNo | Test Protocol No
Top
See Also

Reference

IRoutingOperations Interface
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Interface
IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations.DS_OprName Property

Operaion Name (read only)

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_OprName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_OprName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_OprName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_OprName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Interface
IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Interface
IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Interface
IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Interface
IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations.U_ForceExecOrder Property

Returns Yes if Force Execution Order is required

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ForceExecOrder() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_ForceExecOrder {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_ForceExecOrder {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ForceExecOrder() : YesNoType;
function set U_ForceExecOrder(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Interface
IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations.U_HasRelations Property

Returns Yes if Operation has declared Relations

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_HasRelations() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_HasRelations {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_HasRelations {
 YesNoType get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_HasRelations() : YesNoType;
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Interface
IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations.U_IgnoreYield Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IgnoreYield() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_IgnoreYield {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_IgnoreYield {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IgnoreYield() : YesNoType;
function set U_IgnoreYield(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Interface
IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations.U_OprCode Property

Operation Code -Mandatory

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprCode() : String;
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Interface
IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations.U_OprOverlayCode Property

Operation Overlay Code

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprOverlayCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprOverlayCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprOverlayCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprOverlayCode() : String;
function set U_OprOverlayCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Interface
IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations.U_OprOverlayId Property

Operation Overlay ID

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprOverlayId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_OprOverlayId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_OprOverlayId {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprOverlayId() : int;
function set U_OprOverlayId(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Interface
IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations.U_OprOverlayQty Property

Operation Overlay Quantity

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprOverlayQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_OprOverlayQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_OprOverlayQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprOverlayQty() : double;
function set U_OprOverlayQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Interface
IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations.U_OprSequence Property

Operation Sequence

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprSequence() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_OprSequence {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_OprSequence {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprSequence() : int;
function set U_OprSequence(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Interface
IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations.U_QCActive Property

Quality Control is Active

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QCActive() As YesNoType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
YesNoType U_QCActive {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property YesNoType U_QCActive {
 YesNoType get( );
 void set(
   YesNoType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QCActive() : YesNoType;
function set U_QCActive(value : YesNoType);
This language is not supported or no code example is available.

Property Value

Type: YesNoType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Interface
IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations.U_RelationType Property

Specifies Relation Type

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RelationType() As OperationRelationType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
OperationRelationType U_RelationType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property OperationRelationType U_RelationType {
 OperationRelationType get( );
 void set(
   OperationRelationType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RelationType() : OperationRelationType;
function set U_RelationType(value : OperationRelationType);
This language is not supported or no code example is available.

Property Value

Type: OperationRelationType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Interface
IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations.U_Remarks Property

Remarks

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Interface
IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations.U_RtgCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RtgCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RtgCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Interface
IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations.U_RtgOprCode Property

RoutingOperation key - Madatory

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RtgOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RtgOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgOprCode() : int;
function set U_RtgOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Interface
IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations.U_TestProtocolNo Property

Test Protocol No

Namespace: CompuTec.ProcessForce.API.Documents.Routing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestProtocolNo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TestProtocolNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TestProtocolNo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestProtocolNo() : String;
function set U_TestProtocolNo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRoutingOperations Interface
IRoutingOperations Members
CompuTec.ProcessForce.API.Documents.Routing Namespace


IRoutingOperations Methods

IRoutingOperations Interface See Also

The following tables list the members exposed by the IRoutingOperations type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IRoutingOperations Interface
CompuTec.ProcessForce.API.Documents.Routing Namespace


CompuTec.ProcessForce.API.Documents.SelectDistributionRule Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Enumerations
 | Name | Description
Public enumeration | Objects |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


Objects Enumeration

Namespace: CompuTec.ProcessForce.API.Documents.SelectDistributionRule
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Empty |
RoutingResources |
BillOfMaterials |
BillOfMaterialsResources |
BillOfMaterialsCoproducts |
BillOfMaterialsItems |
BillOfMaterialsScraps |
ManufacturingOrder |
ManufacturingOrderCoproducts |
ManufacturingOrderItems |
ManufacturingOrderResources |
ManufacturingOrderScraps |
PickOrder |
PickReceipt |
OperationTimeRecording |
OperationTimeRecordingAdjustment |
Operations |
See Also

Reference

CompuTec.ProcessForce.API.Documents.SelectDistributionRule Namespace


CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ISerialTemplate | Serial template object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ISerialTemplate Interface

Members See Also

Serial template object

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "SerialTemplate", TableName = "@CT_PF_OSTM", UDOVersion = "UDO_10")> _
Public Interface ISerialTemplate
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "SerialTemplate", TableName = "@CT_PF_OSTM", UDOVersion = "UDO_10")]
public interface ISerialTemplate : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "SerialTemplate", TableName = "@CT_PF_OSTM", UDOVersion = "UDO_10")]
public interface class ISerialTemplate : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "SerialTemplate", TableName = "@CT_PF_OSTM", UDOVersion = "UDO_10")
interface ISerialTemplate
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OSTM
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate Members

ISerialTemplate Interface Methods Properties See Also

Serial template object

The following tables list the members exposed by the ISerialTemplate type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_DistCntr |
Public property | U_DistDtFr |
Public property | U_DistTempl |
Public property | U_LotCntr |
Public property | U_LotDtFrmt |
Public property | U_LotTempl |
Public property | U_MnfCntr |
Public property | U_MnfDtFr |
Public property | U_MnfTempl |
Public property | U_TemplateName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ISerialTemplate Interface
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate Properties

ISerialTemplate Interface See Also

The following tables list the members exposed by the ISerialTemplate type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_DistCntr |
Public property | U_DistDtFr |
Public property | U_DistTempl |
Public property | U_LotCntr |
Public property | U_LotDtFrmt |
Public property | U_LotTempl |
Public property | U_MnfCntr |
Public property | U_MnfDtFr |
Public property | U_MnfTempl |
Public property | U_TemplateName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

ISerialTemplate Interface
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.U_DistCntr Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DistCntr() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_DistCntr {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_DistCntr {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DistCntr() : int;
function set U_DistCntr(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.U_DistDtFr Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DistDtFr() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DistDtFr {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DistDtFr {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DistDtFr() : String;
function set U_DistDtFr(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.U_DistTempl Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DistTempl() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DistTempl {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DistTempl {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DistTempl() : String;
function set U_DistTempl(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.U_LotCntr Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LotCntr() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_LotCntr {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_LotCntr {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LotCntr() : int;
function set U_LotCntr(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.U_LotDtFrmt Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LotDtFrmt() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LotDtFrmt {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LotDtFrmt {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LotDtFrmt() : String;
function set U_LotDtFrmt(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.U_LotTempl Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LotTempl() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LotTempl {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LotTempl {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LotTempl() : String;
function set U_LotTempl(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.U_MnfCntr Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MnfCntr() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_MnfCntr {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_MnfCntr {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MnfCntr() : int;
function set U_MnfCntr(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.U_MnfDtFr Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MnfDtFr() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MnfDtFr {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MnfDtFr {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MnfDtFr() : String;
function set U_MnfDtFr(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.U_MnfTempl Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MnfTempl() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MnfTempl {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MnfTempl {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MnfTempl() : String;
function set U_MnfTempl(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.U_TemplateName Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TemplateName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TemplateName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TemplateName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TemplateName() : String;
function set U_TemplateName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.SerialTemplate
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialTemplate Interface
ISerialTemplate Members
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


ISerialTemplate Methods

ISerialTemplate Interface See Also

The following tables list the members exposed by the ISerialTemplate type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ISerialTemplate Interface
CompuTec.ProcessForce.API.Documents.SerialTemplate Namespace


CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ISeriesConfiguration | Series configuration object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ISeriesConfiguration Interface

Members See Also

Series configuration object

Namespace: CompuTec.ProcessForce.API.Documents.SeriesConfiguration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ISeriesConfiguration
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ISeriesConfiguration : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ISeriesConfiguration : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ISeriesConfiguration
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OMSC
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISeriesConfiguration Members
CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace


ISeriesConfiguration Members

ISeriesConfiguration Interface Methods Properties See Also

Series configuration object

The following tables list the members exposed by the ISeriesConfiguration type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ManOrderSeriesId |
Public property | U_ProdOrderSeriesId |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ISeriesConfiguration Interface
CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace


ISeriesConfiguration Properties

ISeriesConfiguration Interface See Also

The following tables list the members exposed by the ISeriesConfiguration type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ManOrderSeriesId |
Public property | U_ProdOrderSeriesId |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

ISeriesConfiguration Interface
CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace


ISeriesConfiguration.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.SeriesConfiguration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISeriesConfiguration Interface
ISeriesConfiguration Members
CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace


ISeriesConfiguration.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.SeriesConfiguration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISeriesConfiguration Interface
ISeriesConfiguration Members
CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace


ISeriesConfiguration.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.SeriesConfiguration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISeriesConfiguration Interface
ISeriesConfiguration Members
CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace


ISeriesConfiguration.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.SeriesConfiguration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISeriesConfiguration Interface
ISeriesConfiguration Members
CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace


ISeriesConfiguration.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.SeriesConfiguration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISeriesConfiguration Interface
ISeriesConfiguration Members
CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace


ISeriesConfiguration.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.SeriesConfiguration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISeriesConfiguration Interface
ISeriesConfiguration Members
CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace


ISeriesConfiguration.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.SeriesConfiguration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISeriesConfiguration Interface
ISeriesConfiguration Members
CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace


ISeriesConfiguration.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.SeriesConfiguration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISeriesConfiguration Interface
ISeriesConfiguration Members
CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace


ISeriesConfiguration.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.SeriesConfiguration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISeriesConfiguration Interface
ISeriesConfiguration Members
CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace


ISeriesConfiguration.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.SeriesConfiguration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISeriesConfiguration Interface
ISeriesConfiguration Members
CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace


ISeriesConfiguration.U_ManOrderSeriesId Property

Namespace: CompuTec.ProcessForce.API.Documents.SeriesConfiguration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ManOrderSeriesId() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ManOrderSeriesId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ManOrderSeriesId {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ManOrderSeriesId() : String;
function set U_ManOrderSeriesId(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISeriesConfiguration Interface
ISeriesConfiguration Members
CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace


ISeriesConfiguration.U_ProdOrderSeriesId Property

Namespace: CompuTec.ProcessForce.API.Documents.SeriesConfiguration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ProdOrderSeriesId() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ProdOrderSeriesId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ProdOrderSeriesId {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ProdOrderSeriesId() : String;
function set U_ProdOrderSeriesId(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISeriesConfiguration Interface
ISeriesConfiguration Members
CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace


ISeriesConfiguration.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.SeriesConfiguration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISeriesConfiguration Interface
ISeriesConfiguration Members
CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace


ISeriesConfiguration.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.SeriesConfiguration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISeriesConfiguration Interface
ISeriesConfiguration Members
CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace


ISeriesConfiguration.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.SeriesConfiguration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISeriesConfiguration Interface
ISeriesConfiguration Members
CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace


ISeriesConfiguration Methods

ISeriesConfiguration Interface See Also

The following tables list the members exposed by the ISeriesConfiguration type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ISeriesConfiguration Interface
CompuTec.ProcessForce.API.Documents.SeriesConfiguration Namespace


CompuTec.ProcessForce.API.Documents.Shift Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IShift | Shift object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IShift Interface

Members See Also

Shift object

Namespace: CompuTec.ProcessForce.API.Documents.Shift
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "Shift", TableName = "@CT_PF_OSHF")> _
Public Interface IShift
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Shift", TableName = "@CT_PF_OSHF")]
public interface IShift : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Shift", TableName = "@CT_PF_OSHF")]
public interface class IShift : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "Shift", TableName = "@CT_PF_OSHF")
interface IShift
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OSHF
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IShift Members
CompuTec.ProcessForce.API.Documents.Shift Namespace


IShift Members

IShift Interface Methods Properties See Also

Shift object

The following tables list the members exposed by the IShift type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ShfCode |
Public property | U_ShfName |
Public property | U_ShfRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IShift Interface
CompuTec.ProcessForce.API.Documents.Shift Namespace


IShift Properties

IShift Interface See Also

The following tables list the members exposed by the IShift type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ShfCode |
Public property | U_ShfName |
Public property | U_ShfRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IShift Interface
CompuTec.ProcessForce.API.Documents.Shift Namespace


IShift.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Shift
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IShift Interface
IShift Members
CompuTec.ProcessForce.API.Documents.Shift Namespace


IShift.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Shift
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IShift Interface
IShift Members
CompuTec.ProcessForce.API.Documents.Shift Namespace


IShift.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Shift
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IShift Interface
IShift Members
CompuTec.ProcessForce.API.Documents.Shift Namespace


IShift.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Shift
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IShift Interface
IShift Members
CompuTec.ProcessForce.API.Documents.Shift Namespace


IShift.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Shift
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IShift Interface
IShift Members
CompuTec.ProcessForce.API.Documents.Shift Namespace


IShift.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Shift
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IShift Interface
IShift Members
CompuTec.ProcessForce.API.Documents.Shift Namespace


IShift.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Shift
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IShift Interface
IShift Members
CompuTec.ProcessForce.API.Documents.Shift Namespace


IShift.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Shift
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IShift Interface
IShift Members
CompuTec.ProcessForce.API.Documents.Shift Namespace


IShift.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Shift
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IShift Interface
IShift Members
CompuTec.ProcessForce.API.Documents.Shift Namespace


IShift.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Shift
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IShift Interface
IShift Members
CompuTec.ProcessForce.API.Documents.Shift Namespace


IShift.U_ShfCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Shift
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_ShfCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_ShfCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_ShfCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_ShfCode() : String;

   AppEngineProperty(Required = true)
function set U_ShfCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IShift Interface
IShift Members
CompuTec.ProcessForce.API.Documents.Shift Namespace


IShift.U_ShfName Property

Namespace: CompuTec.ProcessForce.API.Documents.Shift
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ShfName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ShfName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ShfName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ShfName() : String;
function set U_ShfName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IShift Interface
IShift Members
CompuTec.ProcessForce.API.Documents.Shift Namespace


IShift.U_ShfRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Shift
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ShfRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ShfRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ShfRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ShfRemarks() : String;
function set U_ShfRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IShift Interface
IShift Members
CompuTec.ProcessForce.API.Documents.Shift Namespace


IShift.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Shift
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IShift Interface
IShift Members
CompuTec.ProcessForce.API.Documents.Shift Namespace


IShift.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Shift
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IShift Interface
IShift Members
CompuTec.ProcessForce.API.Documents.Shift Namespace


IShift.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Shift
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IShift Interface
IShift Members
CompuTec.ProcessForce.API.Documents.Shift Namespace


IShift Methods

IShift Interface See Also

The following tables list the members exposed by the IShift type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IShift Interface
CompuTec.ProcessForce.API.Documents.Shift Namespace


CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ISimpleProductionPlanning | Simple production planning object
Public interface | ISimpleProductionPlanningOperations | Operations of simple production planing object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ISimpleProductionPlanning Interface

Members See Also

Simple production planning object

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "SimpleProductionPlanning", TableName = "@CT_PF_OSPP", UDOVersion = "UDO_10")> _
Public Interface ISimpleProductionPlanning
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "SimpleProductionPlanning", TableName = "@CT_PF_OSPP", UDOVersion = "UDO_10")]
public interface ISimpleProductionPlanning : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "SimpleProductionPlanning", TableName = "@CT_PF_OSPP", UDOVersion = "UDO_10")]
public interface class ISimpleProductionPlanning : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "SimpleProductionPlanning", TableName = "@CT_PF_OSPP", UDOVersion = "UDO_10")
interface ISimpleProductionPlanning
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OSPP
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning Members

ISimpleProductionPlanning Interface Methods Properties See Also

Simple production planning object

The following tables list the members exposed by the ISimpleProductionPlanning type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_RscName |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Operations |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_SppCode |
Public property | U_SppDate |
Public property | U_SppName |
Public property | U_SppRscCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ISimpleProductionPlanning Interface
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning Properties

ISimpleProductionPlanning Interface See Also

The following tables list the members exposed by the ISimpleProductionPlanning type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_RscName |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Operations |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_SppCode |
Public property | U_SppDate |
Public property | U_SppName |
Public property | U_SppRscCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

ISimpleProductionPlanning Interface
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Interface
ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Interface
ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Interface
ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Interface
ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning.DS_RscName Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_RscName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_RscName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_RscName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_RscName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Interface
ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Interface
ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Interface
ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Interface
ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Interface
ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Interface
ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning.Operations Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Operations() As ISimpleProductionPlanningOperations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ISimpleProductionPlanningOperations Operations {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ISimpleProductionPlanningOperations^ Operations {
 ISimpleProductionPlanningOperations^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Operations() : ISimpleProductionPlanningOperations;
This language is not supported or no code example is available.

Property Value

Type: ISimpleProductionPlanningOperations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Interface
ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Interface
ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning.U_SppCode Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SppCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SppCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SppCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SppCode() : String;
function set U_SppCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Interface
ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning.U_SppDate Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SppDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_SppDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_SppDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SppDate() : DateTime;
function set U_SppDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Interface
ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning.U_SppName Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SppName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SppName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SppName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SppName() : String;
function set U_SppName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Interface
ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning.U_SppRscCode Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SppRscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SppRscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SppRscCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SppRscCode() : String;
function set U_SppRscCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Interface
ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Interface
ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Interface
ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanning Interface
ISimpleProductionPlanning Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanning Methods

ISimpleProductionPlanning Interface See Also

The following tables list the members exposed by the ISimpleProductionPlanning type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ISimpleProductionPlanning Interface
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanningOperations Interface

Members See Also

Operations of simple production planing object

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface ISimpleProductionPlanningOperations
    Inherits IUDOChildBean, _
             IEnumerable(Of ISimpleProductionPlanningOperations)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface ISimpleProductionPlanningOperations : IUDOChildBean,
   IEnumerable<ISimpleProductionPlanningOperations>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class ISimpleProductionPlanningOperations : public IUDOChildBean^,
   public IEnumerable<ISimpleProductionPlanningOperations^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_SPP1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanningOperations Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanningOperations Members

ISimpleProductionPlanningOperations Interface Methods Properties See Also

Operations of simple production planing object

The following tables list the members exposed by the ISimpleProductionPlanningOperations type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_MorItemCode |
Public property | DS_OprName |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MorDocEntry |
Public property | U_OprCode |
Public property | U_Remarks |
Public property | U_SppCode |
Public property | U_StartTime |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ISimpleProductionPlanningOperations Interface
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanningOperations Properties

ISimpleProductionPlanningOperations Interface See Also

The following tables list the members exposed by the ISimpleProductionPlanningOperations type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_MorItemCode |
Public property | DS_OprName |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_MorDocEntry |
Public property | U_OprCode |
Public property | U_Remarks |
Public property | U_SppCode |
Public property | U_StartTime |
Top
See Also

Reference

ISimpleProductionPlanningOperations Interface
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanningOperations.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanningOperations Interface
ISimpleProductionPlanningOperations Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanningOperations.DS_MorItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_MorItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_MorItemCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_MorItemCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_MorItemCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanningOperations Interface
ISimpleProductionPlanningOperations Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanningOperations.DS_OprName Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_OprName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_OprName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_OprName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_OprName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanningOperations Interface
ISimpleProductionPlanningOperations Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanningOperations.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanningOperations Interface
ISimpleProductionPlanningOperations Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanningOperations.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanningOperations Interface
ISimpleProductionPlanningOperations Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanningOperations.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanningOperations Interface
ISimpleProductionPlanningOperations Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanningOperations.U_MorDocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MorDocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_MorDocEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_MorDocEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MorDocEntry() : int;
function set U_MorDocEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanningOperations Interface
ISimpleProductionPlanningOperations Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanningOperations.U_OprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprCode() : String;
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanningOperations Interface
ISimpleProductionPlanningOperations Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanningOperations.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanningOperations Interface
ISimpleProductionPlanningOperations Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanningOperations.U_SppCode Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SppCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SppCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SppCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SppCode() : String;
function set U_SppCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanningOperations Interface
ISimpleProductionPlanningOperations Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanningOperations.U_StartTime Property

Namespace: CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StartTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StartTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StartTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StartTime() : DateTime;
function set U_StartTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISimpleProductionPlanningOperations Interface
ISimpleProductionPlanningOperations Members
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


ISimpleProductionPlanningOperations Methods

ISimpleProductionPlanningOperations Interface See Also

The following tables list the members exposed by the ISimpleProductionPlanningOperations type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ISimpleProductionPlanningOperations Interface
CompuTec.ProcessForce.API.Documents.SimpleProductionPlanning Namespace


CompuTec.ProcessForce.API.Documents.Substitutes Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ISubstitutes | Subtitution object
Public interface | ISubstitutesLines | Lines for substitution object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ISubstitutes Interface

Members See Also

Subtitution object

Namespace: CompuTec.ProcessForce.API.Documents.Substitutes
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "Substitutes", TableName = "@CT_PF_OSIT")> _
Public Interface ISubstitutes
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Substitutes", TableName = "@CT_PF_OSIT")]
public interface ISubstitutes : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Substitutes", TableName = "@CT_PF_OSIT")]
public interface class ISubstitutes : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "Substitutes", TableName = "@CT_PF_OSIT")
interface ISubstitutes
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OSIT
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISubstitutes Members
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutes Members

ISubstitutes Interface Methods Properties See Also

Subtitution object

The following tables list the members exposed by the ISubstitutes type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Lines |
Public property | Name |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ISubstitutes Interface
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutes Properties

ISubstitutes Interface See Also

The following tables list the members exposed by the ISubstitutes type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Lines |
Public property | Name |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
See Also

Reference

ISubstitutes Interface
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutes.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Substitutes
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISubstitutes Interface
ISubstitutes Members
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutes.Lines Property

Namespace: CompuTec.ProcessForce.API.Documents.Substitutes
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Lines() As ISubstitutesLines
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ISubstitutesLines Lines {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ISubstitutesLines^ Lines {
 ISubstitutesLines^ get( );
 void set(
   ISubstitutesLines^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Lines() : ISubstitutesLines;
function set Lines(value : ISubstitutesLines);
This language is not supported or no code example is available.

Property Value

Type: ISubstitutesLines
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISubstitutes Interface
ISubstitutes Members
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutes.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Substitutes
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
function set Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISubstitutes Interface
ISubstitutes Members
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutes.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Substitutes
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISubstitutes Interface
ISubstitutes Members
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutes Methods

ISubstitutes Interface See Also

The following tables list the members exposed by the ISubstitutes type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ISubstitutes Interface
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutesLines Interface

Members See Also

Lines for substitution object

Namespace: CompuTec.ProcessForce.API.Documents.Substitutes
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ISubstitutesLines
    Inherits IUDOChildBean, _
             IEnumerable(Of ISubstitutesLines)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ISubstitutesLines : IUDOChildBean,
   IEnumerable<ISubstitutesLines>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ISubstitutesLines : public IUDOChildBean^,
   public IEnumerable<ISubstitutesLines^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_SIT1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISubstitutesLines Members
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutesLines Members

ISubstitutesLines Interface Methods Properties See Also

Lines for substitution object

The following tables list the members exposed by the ISubstitutesLines type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Ratio |
Public property | U_Remarks |
Public property | U_Revision |
Public property | U_SItemCode |
Public property | U_SRevision |
Public property | U_ValidFrom |
Public property | U_ValidTo |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ISubstitutesLines Interface
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutesLines Properties

ISubstitutesLines Interface See Also

The following tables list the members exposed by the ISubstitutesLines type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Ratio |
Public property | U_Remarks |
Public property | U_Revision |
Public property | U_SItemCode |
Public property | U_SRevision |
Public property | U_ValidFrom |
Public property | U_ValidTo |
Top
See Also

Reference

ISubstitutesLines Interface
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutesLines.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Substitutes
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISubstitutesLines Interface
ISubstitutesLines Members
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutesLines.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Substitutes
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISubstitutesLines Interface
ISubstitutesLines Members
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutesLines.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Substitutes
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISubstitutesLines Interface
ISubstitutesLines Members
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutesLines.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Substitutes
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISubstitutesLines Interface
ISubstitutesLines Members
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutesLines.U_Ratio Property

Namespace: CompuTec.ProcessForce.API.Documents.Substitutes
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Ratio() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Ratio {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Ratio {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Ratio() : double;
function set U_Ratio(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISubstitutesLines Interface
ISubstitutesLines Members
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutesLines.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Substitutes
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISubstitutesLines Interface
ISubstitutesLines Members
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutesLines.U_Revision Property

Namespace: CompuTec.ProcessForce.API.Documents.Substitutes
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Revision() : String;
function set U_Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISubstitutesLines Interface
ISubstitutesLines Members
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutesLines.U_SItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Substitutes
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SItemCode() : String;
function set U_SItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISubstitutesLines Interface
ISubstitutesLines Members
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutesLines.U_SRevision Property

Namespace: CompuTec.ProcessForce.API.Documents.Substitutes
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SRevision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SRevision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SRevision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SRevision() : String;
function set U_SRevision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISubstitutesLines Interface
ISubstitutesLines Members
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutesLines.U_ValidFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.Substitutes
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidFrom() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidFrom {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidFrom() : DateTime;
function set U_ValidFrom(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISubstitutesLines Interface
ISubstitutesLines Members
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutesLines.U_ValidTo Property

Namespace: CompuTec.ProcessForce.API.Documents.Substitutes
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidTo() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidTo {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidTo() : DateTime;
function set U_ValidTo(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISubstitutesLines Interface
ISubstitutesLines Members
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


ISubstitutesLines Methods

ISubstitutesLines Interface See Also

The following tables list the members exposed by the ISubstitutesLines type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ISubstitutesLines Interface
CompuTec.ProcessForce.API.Documents.Substitutes Namespace


CompuTec.ProcessForce.API.Documents.Team Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ITeam | Team object
Public interface | ITeamMembers | Members of team object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ITeam Interface

Members See Also

Team object

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "Team", TableName = "@CT_PF_OTEM", UDOVersion = "UDO_10")> _
Public Interface ITeam
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Team", TableName = "@CT_PF_OTEM", UDOVersion = "UDO_10")]
public interface ITeam : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Team", TableName = "@CT_PF_OTEM", UDOVersion = "UDO_10")]
public interface class ITeam : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "Team", TableName = "@CT_PF_OTEM", UDOVersion = "UDO_10")
interface ITeam
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OTEM
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam Members

ITeam Interface Methods Properties See Also

Team object

The following tables list the members exposed by the ITeam type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_ChargehandFirstName |
Public property | DS_ChargehandFullName |
Public property | DS_ChargehandLastName |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Members |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Remarks |
Public property | U_ShfCode |
Public property | U_TeamChargehandId |
Public property | U_TeamCode |
Public property | U_TeamDate |
Public property | U_TeamName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ITeam Interface
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam Properties

ITeam Interface See Also

The following tables list the members exposed by the ITeam type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DS_ChargehandFirstName |
Public property | DS_ChargehandFullName |
Public property | DS_ChargehandLastName |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Members |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_Remarks |
Public property | U_ShfCode |
Public property | U_TeamChargehandId |
Public property | U_TeamCode |
Public property | U_TeamDate |
Public property | U_TeamName |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

ITeam Interface
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.DS_ChargehandFirstName Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_ChargehandFirstName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_ChargehandFirstName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_ChargehandFirstName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_ChargehandFirstName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.DS_ChargehandFullName Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_ChargehandFullName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_ChargehandFullName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_ChargehandFullName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_ChargehandFullName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.DS_ChargehandLastName Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_ChargehandLastName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_ChargehandLastName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_ChargehandLastName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_ChargehandLastName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.Members Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Members() As ITeamMembers
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ITeamMembers Members {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ITeamMembers^ Members {
 ITeamMembers^ get( );
 void set(
   ITeamMembers^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Members() : ITeamMembers;
function set Members(value : ITeamMembers);
This language is not supported or no code example is available.

Property Value

Type: ITeamMembers
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.U_ShfCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ShfCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ShfCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ShfCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ShfCode() : String;
function set U_ShfCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.U_TeamChargehandId Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TeamChargehandId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_TeamChargehandId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_TeamChargehandId {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TeamChargehandId() : int;
function set U_TeamChargehandId(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.U_TeamCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_TeamCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_TeamCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_TeamCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_TeamCode() : String;

   AppEngineProperty(Required = true)
function set U_TeamCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.U_TeamDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TeamDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_TeamDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_TeamDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TeamDate() : DateTime;
function set U_TeamDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.U_TeamName Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TeamName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TeamName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TeamName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TeamName() : String;
function set U_TeamName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeam Interface
ITeam Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeam Methods

ITeam Interface See Also

The following tables list the members exposed by the ITeam type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ITeam Interface
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeamMembers Interface

Members See Also

Members of team object

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface ITeamMembers
    Inherits IUDOChildBean, _
             IEnumerable(Of ITeamMembers)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface ITeamMembers : IUDOChildBean,
   IEnumerable<ITeamMembers>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class ITeamMembers : public IUDOChildBean^,
   public IEnumerable<ITeamMembers^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_TEM1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeamMembers Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeamMembers Members

ITeamMembers Interface Methods Properties See Also

Members of team object

The following tables list the members exposed by the ITeamMembers type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_MemberFirstName |
Public property | DS_MemberLastName |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_EmpId |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Remarks |
Public property | U_TeamCode |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ITeamMembers Interface
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeamMembers Properties

ITeamMembers Interface See Also

The following tables list the members exposed by the ITeamMembers type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_MemberFirstName |
Public property | DS_MemberLastName |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_EmpId |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Remarks |
Public property | U_TeamCode |
Top
See Also

Reference

ITeamMembers Interface
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeamMembers.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeamMembers Interface
ITeamMembers Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeamMembers.DS_MemberFirstName Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_MemberFirstName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_MemberFirstName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_MemberFirstName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_MemberFirstName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeamMembers Interface
ITeamMembers Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeamMembers.DS_MemberLastName Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DS_MemberLastName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DS_MemberLastName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DS_MemberLastName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DS_MemberLastName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeamMembers Interface
ITeamMembers Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeamMembers.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeamMembers Interface
ITeamMembers Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeamMembers.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeamMembers Interface
ITeamMembers Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeamMembers.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeamMembers Interface
ITeamMembers Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeamMembers.U_EmpId Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EmpId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_EmpId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_EmpId {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EmpId() : int;
function set U_EmpId(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeamMembers Interface
ITeamMembers Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeamMembers.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeamMembers Interface
ITeamMembers Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeamMembers.U_TeamCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Team
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_TeamCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_TeamCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_TeamCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_TeamCode() : String;

   AppEngineProperty(Required = true)
function set U_TeamCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITeamMembers Interface
ITeamMembers Members
CompuTec.ProcessForce.API.Documents.Team Namespace


ITeamMembers Methods

ITeamMembers Interface See Also

The following tables list the members exposed by the ITeamMembers type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ITeamMembers Interface
CompuTec.ProcessForce.API.Documents.Team Namespace


CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | ITimeTempMaterials |
Public interface | ITimeTempRegEntry |
Public interface | ITimeTempRegLines |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ITimeTempMaterials Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface ITimeTempMaterials
    Inherits IUDOChildBean, _
             IEnumerable(Of ITimeTempMaterials)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface ITimeTempMaterials : IUDOChildBean,
   IEnumerable<ITimeTempMaterials>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class ITimeTempMaterials : public IUDOChildBean^,
   public IEnumerable<ITimeTempMaterials^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempMaterials Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempMaterials Members

ITimeTempMaterials Interface Methods Properties See Also

The following tables list the members exposed by the ITimeTempMaterials type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_DocType |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_TargetEntry |
Public property | U_TargetNumber |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ITimeTempMaterials Interface
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempMaterials Properties

ITimeTempMaterials Interface See Also

The following tables list the members exposed by the ITimeTempMaterials type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_DocType |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_TargetEntry |
Public property | U_TargetNumber |
Top
See Also

Reference

ITimeTempMaterials Interface
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempMaterials.U_DocType Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DocType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DocType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DocType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DocType() : String;
function set U_DocType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempMaterials Interface
ITimeTempMaterials Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempMaterials.U_TargetEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TargetEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_TargetEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_TargetEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TargetEntry() : int;
function set U_TargetEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempMaterials Interface
ITimeTempMaterials Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempMaterials.U_TargetNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TargetNumber() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_TargetNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_TargetNumber {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TargetNumber() : int;
function set U_TargetNumber(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempMaterials Interface
ITimeTempMaterials Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempMaterials Methods

ITimeTempMaterials Interface See Also

The following tables list the members exposed by the ITimeTempMaterials type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ITimeTempMaterials Interface
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "TimeTempRegEntry", TableName = "@CT_PF_OTRT")> _
Public Interface ITimeTempRegEntry
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "TimeTempRegEntry", TableName = "@CT_PF_OTRT")]
public interface ITimeTempRegEntry : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "TimeTempRegEntry", TableName = "@CT_PF_OTRT")]
public interface class ITimeTempRegEntry : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "TimeTempRegEntry", TableName = "@CT_PF_OTRT")
interface ITimeTempRegEntry
   implements IUDOBean
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegEntry Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry Members

ITimeTempRegEntry Interface Methods Properties See Also

The following tables list the members exposed by the ITimeTempRegEntry type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Lines |
Public property | Materials |
Public property | Name |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_BaseEntry |
Public property | U_BaseNum |
Public property | U_DocDate |
Public property | U_EmplID |
Public property | U_LabourCode |
Public property | U_OprCode |
Public property | U_OprName |
Public property | U_OprSequence |
Public property | U_ParentCode |
Public property | U_Remark |
Public property | U_RscCode |
Public property | U_RscLine |
Public property | U_Status |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ITimeTempRegEntry Interface
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry Properties

ITimeTempRegEntry Interface See Also

The following tables list the members exposed by the ITimeTempRegEntry type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Lines |
Public property | Materials |
Public property | Name |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_BaseEntry |
Public property | U_BaseNum |
Public property | U_DocDate |
Public property | U_EmplID |
Public property | U_LabourCode |
Public property | U_OprCode |
Public property | U_OprName |
Public property | U_OprSequence |
Public property | U_ParentCode |
Public property | U_Remark |
Public property | U_RscCode |
Public property | U_RscLine |
Public property | U_Status |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
See Also

Reference

ITimeTempRegEntry Interface
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegEntry Interface
ITimeTempRegEntry Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry.Lines Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Lines() As ITimeTempRegLines
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ITimeTempRegLines Lines {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ITimeTempRegLines^ Lines {
 ITimeTempRegLines^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Lines() : ITimeTempRegLines;
This language is not supported or no code example is available.

Property Value

Type: ITimeTempRegLines
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegEntry Interface
ITimeTempRegEntry Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry.Materials Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Materials() As ITimeTempMaterials
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ITimeTempMaterials Materials {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ITimeTempMaterials^ Materials {
 ITimeTempMaterials^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Materials() : ITimeTempMaterials;
This language is not supported or no code example is available.

Property Value

Type: ITimeTempMaterials
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegEntry Interface
ITimeTempRegEntry Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
function set Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegEntry Interface
ITimeTempRegEntry Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry.U_BaseEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseEntry() : int;
function set U_BaseEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegEntry Interface
ITimeTempRegEntry Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry.U_BaseNum Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseNum {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseNum() : int;
function set U_BaseNum(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegEntry Interface
ITimeTempRegEntry Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry.U_DocDate Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DocDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_DocDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_DocDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DocDate() : DateTime;
function set U_DocDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegEntry Interface
ITimeTempRegEntry Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry.U_EmplID Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EmplID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_EmplID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_EmplID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EmplID() : int;
function set U_EmplID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegEntry Interface
ITimeTempRegEntry Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry.U_LabourCode Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LabourCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LabourCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LabourCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LabourCode() : String;
function set U_LabourCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegEntry Interface
ITimeTempRegEntry Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry.U_OprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprCode() : String;
function set U_OprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegEntry Interface
ITimeTempRegEntry Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry.U_OprName Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OprName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OprName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprName() : String;
function set U_OprName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegEntry Interface
ITimeTempRegEntry Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry.U_OprSequence Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OprSequence() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_OprSequence {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_OprSequence {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OprSequence() : int;
function set U_OprSequence(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegEntry Interface
ITimeTempRegEntry Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry.U_ParentCode Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ParentCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ParentCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ParentCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ParentCode() : String;
function set U_ParentCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegEntry Interface
ITimeTempRegEntry Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry.U_Remark Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remark() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remark {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remark {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remark() : String;
function set U_Remark(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegEntry Interface
ITimeTempRegEntry Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry.U_RscCode Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCode() : String;
function set U_RscCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegEntry Interface
ITimeTempRegEntry Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry.U_RscLine Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RscLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RscLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscLine() : int;
function set U_RscLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegEntry Interface
ITimeTempRegEntry Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry.U_Status Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Status {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Status() : String;
function set U_Status(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegEntry Interface
ITimeTempRegEntry Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegEntry Methods

ITimeTempRegEntry Interface See Also

The following tables list the members exposed by the ITimeTempRegEntry type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

ITimeTempRegEntry Interface
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegLines Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface ITimeTempRegLines
    Inherits IUDOChildBean, _
             IEnumerable(Of ITimeTempRegLines)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface ITimeTempRegLines : IUDOChildBean,
   IEnumerable<ITimeTempRegLines>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class ITimeTempRegLines : public IUDOChildBean^,
   public IEnumerable<ITimeTempRegLines^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegLines Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegLines Members

ITimeTempRegLines Interface Methods Properties See Also

The following tables list the members exposed by the ITimeTempRegLines type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_EndDate |
Public property | U_EndTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_StartDate |
Public property | U_StartTime |
Public property | U_Type |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ITimeTempRegLines Interface
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegLines Properties

ITimeTempRegLines Interface See Also

The following tables list the members exposed by the ITimeTempRegLines type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_EndDate |
Public property | U_EndTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_StartDate |
Public property | U_StartTime |
Public property | U_Type |
Top
See Also

Reference

ITimeTempRegLines Interface
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegLines.U_EndDate Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_EndDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_EndDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EndDate() : DateTime;
function set U_EndDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegLines Interface
ITimeTempRegLines Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegLines.U_EndTime Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EndTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_EndTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_EndTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EndTime() : DateTime;
function set U_EndTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegLines Interface
ITimeTempRegLines Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegLines.U_StartDate Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StartDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StartDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StartDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StartDate() : DateTime;
function set U_StartDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegLines Interface
ITimeTempRegLines Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegLines.U_StartTime Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_StartTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_StartTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_StartTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_StartTime() : DateTime;
function set U_StartTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegLines Interface
ITimeTempRegLines Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegLines.U_Type Property

Namespace: CompuTec.ProcessForce.API.Documents.TimeTempRegEntry
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Type() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Type {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Type {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Type() : String;
function set U_Type(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeTempRegLines Interface
ITimeTempRegLines Members
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


ITimeTempRegLines Methods

ITimeTempRegLines Interface See Also

The following tables list the members exposed by the ITimeTempRegLines type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

ITimeTempRegLines Interface
CompuTec.ProcessForce.API.Documents.TimeTempRegEntry Namespace


CompuTec.ProcessForce.API.Documents.Wordbook Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IWordbook | Wordbook object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IWordbook Interface

Members See Also

Wordbook object

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "Wordbook", TableName = "@CT_PF_OWRD", UDOVersion = "UDO_10")> _
Public Interface IWordbook
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Wordbook", TableName = "@CT_PF_OWRD", UDOVersion = "UDO_10")]
public interface IWordbook : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "Wordbook", TableName = "@CT_PF_OWRD", UDOVersion = "UDO_10")]
public interface class IWordbook : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "Wordbook", TableName = "@CT_PF_OWRD", UDOVersion = "UDO_10")
interface IWordbook
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OWRD
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook Members

IWordbook Interface Methods Properties See Also

Wordbook object

The following tables list the members exposed by the IWordbook type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ItemProp |
Public property | U_OperIoProp |
Public property | U_OperProp |
Public property | U_RscProp |
Public property | U_TestProp |
Public property | U_WordCode |
Public property | U_WordName |
Public property | U_WordRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IWordbook Interface
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook Properties

IWordbook Interface See Also

The following tables list the members exposed by the IWordbook type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ItemProp |
Public property | U_OperIoProp |
Public property | U_OperProp |
Public property | U_RscProp |
Public property | U_TestProp |
Public property | U_WordCode |
Public property | U_WordName |
Public property | U_WordRemarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IWordbook Interface
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.U_ItemProp Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemProp() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemProp {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemProp {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemProp() : String;
function set U_ItemProp(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.U_OperIoProp Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OperIoProp() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OperIoProp {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OperIoProp {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OperIoProp() : String;
function set U_OperIoProp(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.U_OperProp Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OperProp() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_OperProp {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_OperProp {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OperProp() : String;
function set U_OperProp(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.U_RscProp Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscProp() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscProp {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscProp {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscProp() : String;
function set U_RscProp(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.U_TestProp Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestProp() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TestProp {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TestProp {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestProp() : String;
function set U_TestProp(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.U_WordCode Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_WordCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_WordCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_WordCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_WordCode() : String;

   AppEngineProperty(Required = true)
function set U_WordCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.U_WordName Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordName() : String;
function set U_WordName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.U_WordRemarks Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WordRemarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WordRemarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WordRemarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WordRemarks() : String;
function set U_WordRemarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.Wordbook
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWordbook Interface
IWordbook Members
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


IWordbook Methods

IWordbook Interface See Also

The following tables list the members exposed by the IWordbook type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IWordbook Interface
CompuTec.ProcessForce.API.Documents.Wordbook Namespace


CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | SapDateTime | Represents date and time used by SAP Business One database.
Top
Interfaces
 | Name | Description
Public interface | IWorkRegistration | Work registration object
Public interface | IWorkRegistrationEmployees | Employee of work registration object
Public interface | IWorkRegistrationManufacturingOrders | Manufacturing orders of work registration object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


SapDateTime Class

Members See Also

Represents date and time used by SAP Business One database.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SapDateTime
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SapDateTime
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SapDateTime
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SapDateTime
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents.WorkRegistration.SapDateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SapDateTime Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


SapDateTime Members

SapDateTime Class Constructors Methods Properties See Also

Represents date and time used by SAP Business One database.

The following tables list the members exposed by the SapDateTime type.

Constructors
 | Name | Description
Public constructor | SapDateTime | (Overloaded) Initializes a new instance of CompuTec.ProcessForce.API.Documents.WorkRegistration.SapDateTime object.
Top
Properties
 | Name | Description
Public property | SapDate | Gets the date used by SAP Business One database.
Public property | SapTime | Gets the time used by SAP Business One database.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | ExtractSapTime | Extracts the time used by SAP Business One database based on System.DateTime object.
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SapDateTime Class
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


SapDateTime Constructor

SapDateTime Class See Also

Initializes a new instance of CompuTec.ProcessForce.API.Documents.WorkRegistration.SapDateTime object.

Overload List
Name | Description
SapDateTime() | Initializes a new instance of CompuTec.ProcessForce.API.Documents.WorkRegistration.SapDateTime object.
SapDateTime(DateTime) | Initializes a new instance of CompuTec.ProcessForce.API.Documents.WorkRegistration.SapDateTime object.
See Also

Reference

SapDateTime Class
SapDateTime Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


SapDateTime Properties

SapDateTime Class See Also

The following tables list the members exposed by the SapDateTime type.

Properties
 | Name | Description
Public property | SapDate | Gets the date used by SAP Business One database.
Public property | SapTime | Gets the time used by SAP Business One database.
Top
See Also

Reference

SapDateTime Class
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


SapDateTime.SapDate Property

Gets the date used by SAP Business One database.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property SapDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime SapDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime SapDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SapDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SapDateTime Class
SapDateTime Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


SapDateTime.SapTime Property

Gets the time used by SAP Business One database.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property SapTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime SapTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime SapTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SapTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SapDateTime Class
SapDateTime Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


SapDateTime Methods

SapDateTime Class See Also

The following tables list the members exposed by the SapDateTime type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | ExtractSapTime | Extracts the time used by SAP Business One database based on System.DateTime object.
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SapDateTime Class
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


SapDateTime.ExtractSapTime Method

Extracts the time used by SAP Business One database based on System.DateTime object.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function ExtractSapTime( _
   ByVal date As Date _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int ExtractSapTime(
   DateTime date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static int ExtractSapTime(
   DateTime date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function ExtractSapTime(
    date : DateTime
) : int;
This language is not supported or no code example is available.

Parameters

date

Type: DateTime

System.DateTime object that represents the date and time.

Return Value

Type: int

The time used by SAP Business One database.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SapDateTime Class
SapDateTime Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration Interface

Members See Also

Work registration object

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "WorkRegistration", TableName = "@CT_PF_OWRG", UDOVersion = "UDO_10")> _
Public Interface IWorkRegistration
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "WorkRegistration", TableName = "@CT_PF_OWRG", UDOVersion = "UDO_10")]
public interface IWorkRegistration : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "WorkRegistration", TableName = "@CT_PF_OWRG", UDOVersion = "UDO_10")]
public interface class IWorkRegistration : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "WorkRegistration", TableName = "@CT_PF_OWRG", UDOVersion = "UDO_10")
interface IWorkRegistration
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OWRG
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration Members

IWorkRegistration Interface Methods Properties See Also

Work registration object

The following tables list the members exposed by the IWorkRegistration type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | Employees | Gets or sets the collection of employees.
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | ManufacturingOrders | Gets or sets the collection of manufacturing order documents.
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_RefNo |
Public property | U_Remarks |
Public property | U_WorkResult |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | AssignEmployee | (Overloaded) Assigns an employee.
Public method | AssignManufacturingOrder | Assigns a manufacturing order document.
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IWorkRegistration Interface
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration Properties

IWorkRegistration Interface See Also

The following tables list the members exposed by the IWorkRegistration type.

Properties
 | Name | Description
Public property | Canceled |
Public property | Code |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | Employees | Gets or sets the collection of employees.
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | LogInst |
Public property | ManufacturingOrders | Gets or sets the collection of manufacturing order documents.
Public property | Name |
Public property | Object |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_RefNo |
Public property | U_Remarks |
Public property | U_WorkResult |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IWorkRegistration Interface
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.Employees Property

Gets or sets the collection of employees.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Employees() As IWorkRegistrationEmployees
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IWorkRegistrationEmployees Employees {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IWorkRegistrationEmployees^ Employees {
 IWorkRegistrationEmployees^ get( );
 void set(
   IWorkRegistrationEmployees^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Employees() : IWorkRegistrationEmployees;
function set Employees(value : IWorkRegistrationEmployees);
This language is not supported or no code example is available.

Property Value

Type: IWorkRegistrationEmployees
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.ManufacturingOrders Property

Gets or sets the collection of manufacturing order documents.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ManufacturingOrders() As IWorkRegistrationManufacturingOrders
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IWorkRegistrationManufacturingOrders ManufacturingOrders {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IWorkRegistrationManufacturingOrders^ ManufacturingOrders {
 IWorkRegistrationManufacturingOrders^ get( );
 void set(
   IWorkRegistrationManufacturingOrders^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ManufacturingOrders() : IWorkRegistrationManufacturingOrders;
function set ManufacturingOrders(value : IWorkRegistrationManufacturingOrders);
This language is not supported or no code example is available.

Property Value

Type: IWorkRegistrationManufacturingOrders
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.Name Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.U_RefNo Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RefNo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RefNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RefNo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RefNo() : String;
function set U_RefNo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.U_WorkResult Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WorkResult() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_WorkResult {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_WorkResult {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WorkResult() : double;
function set U_WorkResult(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration Methods

IWorkRegistration Interface See Also

The following tables list the members exposed by the IWorkRegistration type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | AssignEmployee | (Overloaded) Assigns an employee.
Public method | AssignManufacturingOrder | Assigns a manufacturing order document.
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IWorkRegistration Interface
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.AssignEmployee Method

IWorkRegistration Interface See Also

Assigns an employee.

Overload List
Name | Description
AssignEmployee(int, DateTime, DateTime) | Assigns an employee.
AssignEmployee(int, SapDateTime, SapDateTime) | Assigns an employee for current day.
AssignEmployee(int, int) | Assigns an employee for current day.
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.AssignManufacturingOrder Method

Assigns a manufacturing order document.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function AssignManufacturingOrder( _
   ByVal docEntry As Integer, _
   ByVal rtgCode As String, _
   ByVal rtgOprCode As Integer _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool AssignManufacturingOrder(
   int docEntry,
   string rtgCode,
   int rtgOprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool AssignManufacturingOrder(
   int docEntry,
   String^ rtgCode,
   int rtgOprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function AssignManufacturingOrder(
    docEntry : int,
    rtgCode : String,
    rtgOprCode : int
) : boolean;
This language is not supported or no code example is available.

Parameters

docEntry

Type: int

Document entry.

rtgCode

Type: string

Routing code.

rtgOprCode

Type: int

Routing-operation relation code.

Return Value

Type: bool

A Boolean value that indicates whether manufacturing order document was assigned successfully or not.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationEmployees Interface

Members See Also

Employee of work registration object

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IWorkRegistrationEmployees
    Inherits IUDOChildBean, _
             IEnumerable(Of IWorkRegistrationEmployees)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IWorkRegistrationEmployees : IUDOChildBean,
   IEnumerable<IWorkRegistrationEmployees>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IWorkRegistrationEmployees : public IUDOChildBean^,
   public IEnumerable<IWorkRegistrationEmployees^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_WRG2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationEmployees Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationEmployees Members

IWorkRegistrationEmployees Interface Methods Properties See Also

Employee of work registration object

The following tables list the members exposed by the IWorkRegistrationEmployees type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_EmpFirstName | Gets the first name of an employee.
Public property | DS_EmpLastName | Gets the last name of an employee.
Public property | DS_EmpSecondName | Gets the second name of an employee.
Public property | DS_EmployeeId | Gets or sets the ID of an employee.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_EmpId |
Public property | U_EndDate |
Public property | U_EndTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_QualityTime |
Public property | U_StartDate |
Public property | U_StartTime |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | CalculateMinutes | Calculates the minutes based on date range.
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IWorkRegistrationEmployees Interface
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationEmployees Properties

IWorkRegistrationEmployees Interface See Also

The following tables list the members exposed by the IWorkRegistrationEmployees type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_EmpFirstName | Gets the first name of an employee.
Public property | DS_EmpLastName | Gets the last name of an employee.
Public property | DS_EmpSecondName | Gets the second name of an employee.
Public property | DS_EmployeeId | Gets or sets the ID of an employee.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_EmpId |
Public property | U_EndDate |
Public property | U_EndTime |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_QualityTime |
Public property | U_StartDate |
Public property | U_StartTime |
Top
See Also

Reference

IWorkRegistrationEmployees Interface
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationEmployees.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationEmployees Interface
IWorkRegistrationEmployees Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationEmployees.DS_EmpFirstName Property

Gets the first name of an employee.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_EmpFirstName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_EmpFirstName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_EmpFirstName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_EmpFirstName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationEmployees Interface
IWorkRegistrationEmployees Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationEmployees.DS_EmpLastName Property

Gets the last name of an employee.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_EmpLastName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_EmpLastName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_EmpLastName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_EmpLastName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationEmployees Interface
IWorkRegistrationEmployees Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationEmployees.DS_EmpSecondName Property

Gets the second name of an employee.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_EmpSecondName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_EmpSecondName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_EmpSecondName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_EmpSecondName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationEmployees Interface
IWorkRegistrationEmployees Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationEmployees.DS_EmployeeId Property

Gets or sets the ID of an employee.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_EmployeeId() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_EmployeeId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_EmployeeId {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_EmployeeId() : String;

   AppEnginePropertyIgnore()
function set DS_EmployeeId(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationEmployees Interface
IWorkRegistrationEmployees Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationEmployees.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationEmployees Interface
IWorkRegistrationEmployees Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationEmployees.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationEmployees Interface
IWorkRegistrationEmployees Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationEmployees.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationEmployees Interface
IWorkRegistrationEmployees Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationEmployees.U_EmpId Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EmpId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_EmpId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_EmpId {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EmpId() : int;
function set U_EmpId(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationEmployees Interface
IWorkRegistrationEmployees Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationEmployees.U_EndDate Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property U_EndDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime U_EndDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime U_EndDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_EndDate() : DateTime;

   AppEnginePropertyIgnore()
function set U_EndDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationEmployees Interface
IWorkRegistrationEmployees Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationEmployees.U_EndTime Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property U_EndTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime U_EndTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime U_EndTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_EndTime() : DateTime;

   AppEnginePropertyIgnore()
function set U_EndTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationEmployees Interface
IWorkRegistrationEmployees Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationEmployees.U_QualityTime Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QualityTime() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_QualityTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_QualityTime {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QualityTime() : int;
function set U_QualityTime(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationEmployees Interface
IWorkRegistrationEmployees Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationEmployees.U_StartDate Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property U_StartDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime U_StartDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime U_StartDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_StartDate() : DateTime;

   AppEnginePropertyIgnore()
function set U_StartDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationEmployees Interface
IWorkRegistrationEmployees Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationEmployees.U_StartTime Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property U_StartTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime U_StartTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime U_StartTime {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_StartTime() : DateTime;

   AppEnginePropertyIgnore()
function set U_StartTime(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationEmployees Interface
IWorkRegistrationEmployees Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationEmployees Methods

IWorkRegistrationEmployees Interface See Also

The following tables list the members exposed by the IWorkRegistrationEmployees type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | CalculateMinutes | Calculates the minutes based on date range.
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IWorkRegistrationEmployees Interface
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationEmployees.CalculateMinutes Method

Calculates the minutes based on date range.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CalculateMinutes() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int CalculateMinutes()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int CalculateMinutes()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CalculateMinutes() : int;
This language is not supported or no code example is available.

Return Value

Type: int

Number of minutes within a date range.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationEmployees Interface
IWorkRegistrationEmployees Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationManufacturingOrders Interface

Members See Also

Manufacturing orders of work registration object

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IWorkRegistrationManufacturingOrders
    Inherits IUDOChildBean, _
             IEnumerable(Of IWorkRegistrationManufacturingOrders)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IWorkRegistrationManufacturingOrders : IUDOChildBean,
   IEnumerable<IWorkRegistrationManufacturingOrders>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IWorkRegistrationManufacturingOrders : public IUDOChildBean^,
   public IEnumerable<IWorkRegistrationManufacturingOrders^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_WRG1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationManufacturingOrders Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationManufacturingOrders Members

IWorkRegistrationManufacturingOrders Interface Methods Properties See Also

Manufacturing orders of work registration object

The following tables list the members exposed by the IWorkRegistrationManufacturingOrders type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_MorDocEntry | Gets or sets the string representation of manufacturing order's document entry.
Public property | DS_OprCode | Gets the code of an operation.
Public property | DS_OprName | Gets the remarks of an operation.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_DocEntry |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_RtgCode |
Public property | U_RtgOprCode |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IWorkRegistrationManufacturingOrders Interface
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationManufacturingOrders Properties

IWorkRegistrationManufacturingOrders Interface See Also

The following tables list the members exposed by the IWorkRegistrationManufacturingOrders type.

Properties
 | Name | Description
Public property | Code |
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_MorDocEntry | Gets or sets the string representation of manufacturing order's document entry.
Public property | DS_OprCode | Gets the code of an operation.
Public property | DS_OprName | Gets the remarks of an operation.
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_DocEntry |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_RtgCode |
Public property | U_RtgOprCode |
Top
See Also

Reference

IWorkRegistrationManufacturingOrders Interface
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationManufacturingOrders.Code Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationManufacturingOrders Interface
IWorkRegistrationManufacturingOrders Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationManufacturingOrders.DS_MorDocEntry Property

Gets or sets the string representation of manufacturing order's document entry.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_MorDocEntry() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_MorDocEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_MorDocEntry {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_MorDocEntry() : String;

   AppEnginePropertyIgnore()
function set DS_MorDocEntry(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationManufacturingOrders Interface
IWorkRegistrationManufacturingOrders Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationManufacturingOrders.DS_OprCode Property

Gets the code of an operation.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_OprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_OprCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_OprCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_OprCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationManufacturingOrders Interface
IWorkRegistrationManufacturingOrders Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationManufacturingOrders.DS_OprName Property

Gets the remarks of an operation.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DS_OprName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_OprName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_OprName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_OprName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationManufacturingOrders Interface
IWorkRegistrationManufacturingOrders Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationManufacturingOrders.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationManufacturingOrders Interface
IWorkRegistrationManufacturingOrders Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationManufacturingOrders.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationManufacturingOrders Interface
IWorkRegistrationManufacturingOrders Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationManufacturingOrders.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationManufacturingOrders Interface
IWorkRegistrationManufacturingOrders Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationManufacturingOrders.U_DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_DocEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_DocEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DocEntry() : int;
function set U_DocEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationManufacturingOrders Interface
IWorkRegistrationManufacturingOrders Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationManufacturingOrders.U_RtgCode Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RtgCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RtgCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgCode() : String;
function set U_RtgCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationManufacturingOrders Interface
IWorkRegistrationManufacturingOrders Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationManufacturingOrders.U_RtgOprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RtgOprCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RtgOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RtgOprCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RtgOprCode() : int;
function set U_RtgOprCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistrationManufacturingOrders Interface
IWorkRegistrationManufacturingOrders Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistrationManufacturingOrders Methods

IWorkRegistrationManufacturingOrders Interface See Also

The following tables list the members exposed by the IWorkRegistrationManufacturingOrders type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IWorkRegistrationManufacturingOrders Interface
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


CompuTec.ProcessForce.API.Documents._Bill_Of_Materials_.BillOfMaterials.Exceptions Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | RunRateNotValidValueException |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


RunRateNotValidValueException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents._Bill_Of_Materials_.BillOfMaterials.Exceptions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class RunRateNotValidValueException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class RunRateNotValidValueException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class RunRateNotValidValueException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class RunRateNotValidValueException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents._Bill_Of_Materials_.BillOfMaterials.Exceptions.RunRateNotValidValueException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RunRateNotValidValueException Members
CompuTec.ProcessForce.API.Documents._Bill_Of_Materials_.BillOfMaterials.Exceptions Namespace


RunRateNotValidValueException Members

RunRateNotValidValueException Class Constructors Methods Properties See Also

The following tables list the members exposed by the RunRateNotValidValueException type.

Constructors
 | Name | Description
Public constructor | RunRateNotValidValueException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

RunRateNotValidValueException Class
CompuTec.ProcessForce.API.Documents._Bill_Of_Materials_.BillOfMaterials.Exceptions Namespace


RunRateNotValidValueException Constructor

RunRateNotValidValueException Class See Also

Overload List
Name | Description
RunRateNotValidValueException() |
RunRateNotValidValueException(string) |
RunRateNotValidValueException(string, Exception) |
See Also

Reference

RunRateNotValidValueException Class
RunRateNotValidValueException Members
CompuTec.ProcessForce.API.Documents._Bill_Of_Materials_.BillOfMaterials.Exceptions Namespace


RunRateNotValidValueException Properties

RunRateNotValidValueException Class See Also

The following tables list the members exposed by the RunRateNotValidValueException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

RunRateNotValidValueException Class
CompuTec.ProcessForce.API.Documents._Bill_Of_Materials_.BillOfMaterials.Exceptions Namespace


RunRateNotValidValueException Methods

RunRateNotValidValueException Class See Also

The following tables list the members exposed by the RunRateNotValidValueException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

RunRateNotValidValueException Class
CompuTec.ProcessForce.API.Documents._Bill_Of_Materials_.BillOfMaterials.Exceptions Namespace


CompuTec.ProcessForce.API.Documents._Other_.ActionFacts Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IActionFact |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IActionFact Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents._Other_.ActionFacts
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IActionFact
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IActionFact : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IActionFact : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IActionFact
   implements IUDOBean
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IActionFact Members
CompuTec.ProcessForce.API.Documents._Other_.ActionFacts Namespace


IActionFact Members

IActionFact Interface Methods Properties See Also

The following tables list the members exposed by the IActionFact type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ActionID |
Public property | U_Date |
Public property | U_Time |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IActionFact Interface
CompuTec.ProcessForce.API.Documents._Other_.ActionFacts Namespace


IActionFact Properties

IActionFact Interface See Also

The following tables list the members exposed by the IActionFact type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ActionID |
Public property | U_Date |
Public property | U_Time |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
See Also

Reference

IActionFact Interface
CompuTec.ProcessForce.API.Documents._Other_.ActionFacts Namespace


IActionFact.Code Property

Namespace: CompuTec.ProcessForce.API.Documents._Other_.ActionFacts
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Code() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Code {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : int;
function set Code(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IActionFact Interface
IActionFact Members
CompuTec.ProcessForce.API.Documents._Other_.ActionFacts Namespace


IActionFact.U_ActionID Property

Namespace: CompuTec.ProcessForce.API.Documents._Other_.ActionFacts
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActionID() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ActionID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ActionID {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActionID() : String;
function set U_ActionID(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IActionFact Interface
IActionFact Members
CompuTec.ProcessForce.API.Documents._Other_.ActionFacts Namespace


IActionFact.U_Date Property

Namespace: CompuTec.ProcessForce.API.Documents._Other_.ActionFacts
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Date() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Date {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Date {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Date() : DateTime;
function set U_Date(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IActionFact Interface
IActionFact Members
CompuTec.ProcessForce.API.Documents._Other_.ActionFacts Namespace


IActionFact.U_Time Property

Namespace: CompuTec.ProcessForce.API.Documents._Other_.ActionFacts
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Time() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_Time {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_Time {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Time() : int;
function set U_Time(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IActionFact Interface
IActionFact Members
CompuTec.ProcessForce.API.Documents._Other_.ActionFacts Namespace


IActionFact Methods

IActionFact Interface See Also

The following tables list the members exposed by the IActionFact type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IActionFact Interface
CompuTec.ProcessForce.API.Documents._Other_.ActionFacts Namespace


CompuTec.ProcessForce.API.Documents._Other_.AdditionalBatchDetails Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Enumerations
 | Name | Description
Public enumeration | BatchStatus |
Public enumeration | QCAction |
Public enumeration | QCStatus |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


BatchStatus Enumeration

Namespace: CompuTec.ProcessForce.API.Documents._Other_.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Released |
NotAccesible |
Locked |
See Also

Reference

CompuTec.ProcessForce.API.Documents._Other_.AdditionalBatchDetails Namespace


QCAction Enumeration

Namespace: CompuTec.ProcessForce.API.Documents._Other_.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Rework |
Downgrade |
Scrap |
WriteOff |
BatchRecall |
None |
GoodsReturn |
See Also

Reference

CompuTec.ProcessForce.API.Documents._Other_.AdditionalBatchDetails Namespace


QCStatus Enumeration

Namespace: CompuTec.ProcessForce.API.Documents._Other_.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Failed |
OnHold |
Inspection |
Passed |
QCTesting |
ToBeDetermined |
See Also

Reference

CompuTec.ProcessForce.API.Documents._Other_.AdditionalBatchDetails Namespace


CompuTec.ProcessForce.API.Documents._Other_.BusinessPartnerRelations Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | BusinessPartnerRelationsHelper |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


BusinessPartnerRelationsHelper Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents._Other_.BusinessPartnerRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BusinessPartnerRelationsHelper
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BusinessPartnerRelationsHelper
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BusinessPartnerRelationsHelper
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BusinessPartnerRelationsHelper
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents._Other_.BusinessPartnerRelations.BusinessPartnerRelationsHelper
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BusinessPartnerRelationsHelper Members
CompuTec.ProcessForce.API.Documents._Other_.BusinessPartnerRelations Namespace


BusinessPartnerRelationsHelper Members

BusinessPartnerRelationsHelper Class Methods See Also

The following tables list the members exposed by the BusinessPartnerRelationsHelper type.

Methods
 | Name | Description
 | CopyRelations | (Overloaded)
 | DeleteRelations |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

BusinessPartnerRelationsHelper Class
CompuTec.ProcessForce.API.Documents._Other_.BusinessPartnerRelations Namespace


BusinessPartnerRelationsHelper Methods

BusinessPartnerRelationsHelper Class See Also

The following tables list the members exposed by the BusinessPartnerRelationsHelper type.

Methods
 | Name | Description
 | CopyRelations | (Overloaded)
 | DeleteRelations |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

BusinessPartnerRelationsHelper Class
CompuTec.ProcessForce.API.Documents._Other_.BusinessPartnerRelations Namespace


BusinessPartnerRelationsHelper.CopyRelations Method

BusinessPartnerRelationsHelper Class See Also

Overload List
Name | Description
CopyRelations(IEnumerable<IBusinessPartnerRelations>, IBusinessPartnerRelations) |
CopyRelations(IEnumerable<IBusinessPartnerRelations>, IBusinessPartnerRelationsThridLevel, int) |
See Also

Reference

BusinessPartnerRelationsHelper Class
BusinessPartnerRelationsHelper Members
CompuTec.ProcessForce.API.Documents._Other_.BusinessPartnerRelations Namespace


BusinessPartnerRelationsHelper.DeleteRelations Method

Namespace: CompuTec.ProcessForce.API.Documents._Other_.BusinessPartnerRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub DeleteRelations( _
   ByVal relations As IBusinessPartnerRelationsThridLevel, _
   ByVal baseLineNum As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void DeleteRelations(
   IBusinessPartnerRelationsThridLevel relations,
   int baseLineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void DeleteRelations(
   IBusinessPartnerRelationsThridLevel^ relations,
   int baseLineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function DeleteRelations(
    relations : IBusinessPartnerRelationsThridLevel,
    baseLineNum : int
);
This language is not supported or no code example is available.

Parameters

relations

Type: IBusinessPartnerRelationsThridLevel

baseLineNum

Type: int

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BusinessPartnerRelationsHelper Class
BusinessPartnerRelationsHelper Members
CompuTec.ProcessForce.API.Documents._Other_.BusinessPartnerRelations Namespace


CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.ManufacturingOrder.Exception Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | RoutingNotActiveException |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


RoutingNotActiveException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.ManufacturingOrder.Exception
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class RoutingNotActiveException
    Inherits UDOException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RoutingNotActiveException : UDOException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class RoutingNotActiveException : public UDOException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RoutingNotActiveException
   extends UDOException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Core.UDOException
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.ManufacturingOrder.Exception.RoutingNotActiveException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RoutingNotActiveException Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.ManufacturingOrder.Exception Namespace


RoutingNotActiveException Members

RoutingNotActiveException Class Constructors Methods Properties See Also

The following tables list the members exposed by the RoutingNotActiveException type.

Constructors
 | Name | Description
Public constructor | RoutingNotActiveException |
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | ObjectCode | (inherited from UDOException).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

RoutingNotActiveException Class
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.ManufacturingOrder.Exception Namespace


RoutingNotActiveException Constructor

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.ManufacturingOrder.Exception
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RoutingNotActiveException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RoutingNotActiveException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RoutingNotActiveException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RoutingNotActiveException Class
RoutingNotActiveException Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.ManufacturingOrder.Exception Namespace


RoutingNotActiveException Properties

RoutingNotActiveException Class See Also

The following tables list the members exposed by the RoutingNotActiveException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | ObjectCode | (inherited from UDOException).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

RoutingNotActiveException Class
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.ManufacturingOrder.Exception Namespace


RoutingNotActiveException Methods

RoutingNotActiveException Class See Also

The following tables list the members exposed by the RoutingNotActiveException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

RoutingNotActiveException Class
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.ManufacturingOrder.Exception Namespace


CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IWeightDocument | Downtime document
Public interface | IWeightDocumentLine | Picked items of pick order document
Public interface | IWeightLog |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IWeightDocument Interface

Members See Also

Downtime document

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "WeightDocument", TableName = "@CT_PF_OWDC")> _
Public Interface IWeightDocument
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "WeightDocument", TableName = "@CT_PF_OWDC")]
public interface IWeightDocument : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "WeightDocument", TableName = "@CT_PF_OWDC")]
public interface class IWeightDocument : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "WeightDocument", TableName = "@CT_PF_OWDC")
interface IWeightDocument
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OWDC
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument Members

IWeightDocument Interface Methods Properties See Also

Downtime document

The following tables list the members exposed by the IWeightDocument type.

Properties
 | Name | Description
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | Lines |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_BaseRscLineNum |
Public property | U_EmpID |
Public property | U_MorEntry |
Public property | U_Remarks |
Public property | U_Source |
Public property | U_Status |
Public property | U_TerminalID |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IWeightDocument Interface
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument Properties

IWeightDocument Interface See Also

The following tables list the members exposed by the IWeightDocument type.

Properties
 | Name | Description
Public property | Canceled |
Public property | CreateDate |
Public property | CreateTime |
Public property | DataSource |
Public property | DocEntry |
Public property | DocNum |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | Lines |
Public property | LogInst |
Public property | Object |
Public property | Period |
Public property | Series |
Public property | Status |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_BaseRscLineNum |
Public property | U_EmpID |
Public property | U_MorEntry |
Public property | U_Remarks |
Public property | U_Source |
Public property | U_Status |
Public property | U_TerminalID |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
See Also

Reference

IWeightDocument Interface
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.CreateTime Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.DocNum Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.Handwrtten Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Handwrtten() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Handwrtten {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Handwrtten {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Handwrtten() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.Instance Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Instance() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Instance {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Instance {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Instance() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.Lines Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Lines() As IWeightDocumentLine
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IWeightDocumentLine Lines {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IWeightDocumentLine^ Lines {
 IWeightDocumentLine^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Lines() : IWeightDocumentLine;
This language is not supported or no code example is available.

Property Value

Type: IWeightDocumentLine
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.Object Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.Period Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Period() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Period {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Period {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Period() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.Series Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Series() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Series {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Series {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Series() : int;
function set Series(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.Status Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Status {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Status {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Status() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.U_BaseRscLineNum Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseRscLineNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseRscLineNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseRscLineNum {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseRscLineNum() : int;
function set U_BaseRscLineNum(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.U_EmpID Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EmpID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_EmpID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_EmpID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EmpID() : int;
function set U_EmpID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.U_MorEntry Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MorEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_MorEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_MorEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MorEntry() : int;
function set U_MorEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.U_Source Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Source() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Source {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Source {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Source() : String;
function set U_Source(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.U_Status Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Status() As WeightDocumentStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
WeightDocumentStatus U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property WeightDocumentStatus U_Status {
 WeightDocumentStatus get( );
 void set(
   WeightDocumentStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Status() : WeightDocumentStatus;
function set U_Status(value : WeightDocumentStatus);
This language is not supported or no code example is available.

Property Value

Type: WeightDocumentStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.U_TerminalID Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TerminalID() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TerminalID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TerminalID {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TerminalID() : String;
function set U_TerminalID(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocument Interface
IWeightDocument Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocument Methods

IWeightDocument Interface See Also

The following tables list the members exposed by the IWeightDocument type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IWeightDocument Interface
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocumentLine Interface

Members See Also

Picked items of pick order document

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IWeightDocumentLine
    Inherits IUDOChildBean, _
             IEnumerable(Of IWeightDocumentLine)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IWeightDocumentLine : IUDOChildBean,
   IEnumerable<IWeightDocumentLine>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IWeightDocumentLine : public IUDOChildBean^,
   public IEnumerable<IWeightDocumentLine^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_WDC1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocumentLine Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocumentLine Members

IWeightDocumentLine Interface Methods Properties See Also

Picked items of pick order document

The following tables list the members exposed by the IWeightDocumentLine type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLineNum | Reference from U_LineNume in MOR3
Public property | U_BatchNumber | Batch number
Public property | U_BinCode | Bin code
Public property | U_EmpID | Employee identifier
Public property | U_ItemCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_LineStatus | Line status {A - Active, R - Removed}
Public property | U_PlannedQuantity | Planned Quantity
Public property | U_Qty | Quantity
Public property | U_Remarks | Remarks
Public property | U_WeightScaleName | Weight Scale Name
Public property | U_WeightScaleSerialNumber | Weight Scale Serial Number
Public property | U_WhsCode | Warehouse code
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IWeightDocumentLine Interface
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocumentLine Properties

IWeightDocumentLine Interface See Also

The following tables list the members exposed by the IWeightDocumentLine type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BaseLineNum | Reference from U_LineNume in MOR3
Public property | U_BatchNumber | Batch number
Public property | U_BinCode | Bin code
Public property | U_EmpID | Employee identifier
Public property | U_ItemCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_LineStatus | Line status {A - Active, R - Removed}
Public property | U_PlannedQuantity | Planned Quantity
Public property | U_Qty | Quantity
Public property | U_Remarks | Remarks
Public property | U_WeightScaleName | Weight Scale Name
Public property | U_WeightScaleSerialNumber | Weight Scale Serial Number
Public property | U_WhsCode | Warehouse code
Top
See Also

Reference

IWeightDocumentLine Interface
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocumentLine.U_BaseLineNum Property

Reference from U_LineNume in MOR3

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BaseLineNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_BaseLineNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_BaseLineNum {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BaseLineNum() : int;
function set U_BaseLineNum(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocumentLine Interface
IWeightDocumentLine Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocumentLine.U_BatchNumber Property

Batch number

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BatchNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BatchNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BatchNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchNumber() : String;
function set U_BatchNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocumentLine Interface
IWeightDocumentLine Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocumentLine.U_BinCode Property

Bin code

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BinCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BinCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BinCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BinCode() : String;
function set U_BinCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocumentLine Interface
IWeightDocumentLine Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocumentLine.U_EmpID Property

Employee identifier

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EmpID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_EmpID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_EmpID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EmpID() : int;
function set U_EmpID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocumentLine Interface
IWeightDocumentLine Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocumentLine.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocumentLine Interface
IWeightDocumentLine Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocumentLine.U_LineStatus Property

Line status {A - Active, R - Removed}

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LineStatus() As WeightDocumentLineStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
WeightDocumentLineStatus U_LineStatus {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property WeightDocumentLineStatus U_LineStatus {
 WeightDocumentLineStatus get( );
 void set(
   WeightDocumentLineStatus value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LineStatus() : WeightDocumentLineStatus;
function set U_LineStatus(value : WeightDocumentLineStatus);
This language is not supported or no code example is available.

Property Value

Type: WeightDocumentLineStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocumentLine Interface
IWeightDocumentLine Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocumentLine.U_PlannedQuantity Property

Planned Quantity

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PlannedQuantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PlannedQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PlannedQuantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PlannedQuantity() : double;
function set U_PlannedQuantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocumentLine Interface
IWeightDocumentLine Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocumentLine.U_Qty Property

Quantity

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Qty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Qty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Qty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Qty() : double;
function set U_Qty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocumentLine Interface
IWeightDocumentLine Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocumentLine.U_Remarks Property

Remarks

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocumentLine Interface
IWeightDocumentLine Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocumentLine.U_WeightScaleName Property

Weight Scale Name

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WeightScaleName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WeightScaleName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WeightScaleName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WeightScaleName() : String;
function set U_WeightScaleName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocumentLine Interface
IWeightDocumentLine Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocumentLine.U_WeightScaleSerialNumber Property

Weight Scale Serial Number

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WeightScaleSerialNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WeightScaleSerialNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WeightScaleSerialNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WeightScaleSerialNumber() : String;
function set U_WeightScaleSerialNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocumentLine Interface
IWeightDocumentLine Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocumentLine.U_WhsCode Property

Warehouse code

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightDocumentLine Interface
IWeightDocumentLine Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightDocumentLine Methods

IWeightDocumentLine Interface See Also

The following tables list the members exposed by the IWeightDocumentLine type.

Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IWeightDocumentLine Interface
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightLog Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "WeightLog", TableName = "@CT_PF_OWLG")> _
Public Interface IWeightLog
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "WeightLog", TableName = "@CT_PF_OWLG")]
public interface IWeightLog : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "WeightLog", TableName = "@CT_PF_OWLG")]
public interface class IWeightLog : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "WeightLog", TableName = "@CT_PF_OWLG")
interface IWeightLog
   implements IUDOBean
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightLog Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightLog Members

IWeightLog Interface Methods Properties See Also

The following tables list the members exposed by the IWeightLog type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ComputerName |
Public property | U_Date |
Public property | U_EmpID |
Public property | U_Gross |
Public property | U_Nett |
Public property | U_PDC_ID |
Public property | U_SourceEntry |
Public property | U_SourceLineNum |
Public property | U_Time |
Public property | U_WeightScaleName |
Public property | U_WeightScaleSerialNumber |
Public property | U_WholeMessage |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IWeightLog Interface
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightLog Properties

IWeightLog Interface See Also

The following tables list the members exposed by the IWeightLog type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ComputerName |
Public property | U_Date |
Public property | U_EmpID |
Public property | U_Gross |
Public property | U_Nett |
Public property | U_PDC_ID |
Public property | U_SourceEntry |
Public property | U_SourceLineNum |
Public property | U_Time |
Public property | U_WeightScaleName |
Public property | U_WeightScaleSerialNumber |
Public property | U_WholeMessage |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
See Also

Reference

IWeightLog Interface
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightLog.Code Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
int Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property int Code {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : int;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightLog Interface
IWeightLog Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightLog.U_ComputerName Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ComputerName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ComputerName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ComputerName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ComputerName() : String;
function set U_ComputerName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightLog Interface
IWeightLog Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightLog.U_Date Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Date() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Date {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Date {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Date() : DateTime;
function set U_Date(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightLog Interface
IWeightLog Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightLog.U_EmpID Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_EmpID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_EmpID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_EmpID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_EmpID() : int;
function set U_EmpID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightLog Interface
IWeightLog Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightLog.U_Gross Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Gross() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Gross {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Gross {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Gross() : double;
function set U_Gross(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightLog Interface
IWeightLog Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightLog.U_Nett Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Nett() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Nett {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Nett {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Nett() : double;
function set U_Nett(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightLog Interface
IWeightLog Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightLog.U_PDC_ID Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PDC_ID() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PDC_ID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PDC_ID {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PDC_ID() : String;
function set U_PDC_ID(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightLog Interface
IWeightLog Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightLog.U_SourceEntry Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SourceEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SourceEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SourceEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SourceEntry() : int;
function set U_SourceEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightLog Interface
IWeightLog Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightLog.U_SourceLineNum Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SourceLineNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SourceLineNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SourceLineNum {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SourceLineNum() : int;
function set U_SourceLineNum(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightLog Interface
IWeightLog Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightLog.U_Time Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Time() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_Time {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_Time {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Time() : int;
function set U_Time(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightLog Interface
IWeightLog Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightLog.U_WeightScaleName Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WeightScaleName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WeightScaleName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WeightScaleName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WeightScaleName() : String;
function set U_WeightScaleName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightLog Interface
IWeightLog Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightLog.U_WeightScaleSerialNumber Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WeightScaleSerialNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WeightScaleSerialNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WeightScaleSerialNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WeightScaleSerialNumber() : String;
function set U_WeightScaleSerialNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightLog Interface
IWeightLog Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightLog.U_WholeMessage Property

Namespace: CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WholeMessage() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WholeMessage {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WholeMessage {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WholeMessage() : String;
function set U_WholeMessage(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWeightLog Interface
IWeightLog Members
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


IWeightLog Methods

IWeightLog Interface See Also

The following tables list the members exposed by the IWeightLog type.

Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IWeightLog Interface
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.WeightProcess Namespace


CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | VehicleInspectionReasonSimpleClass |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


VehicleInspectionReasonSimpleClass Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class VehicleInspectionReasonSimpleClass
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class VehicleInspectionReasonSimpleClass
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class VehicleInspectionReasonSimpleClass
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class VehicleInspectionReasonSimpleClass
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason.VehicleInspectionReasonSimpleClass
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VehicleInspectionReasonSimpleClass Members
CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason Namespace


VehicleInspectionReasonSimpleClass Members

VehicleInspectionReasonSimpleClass Class Methods Properties See Also

The following tables list the members exposed by the VehicleInspectionReasonSimpleClass type.

Properties
 | Name | Description
Public property | ChemicalCheck |
Public property | Code |
Public property | OdorCheck |
Public property | PcgCheck |
Public property | PestCheck |
Public property | RsnCode |
Public property | RsnName |
Public property | RubbishCheck |
Public property | SpoledCheck |
Public property | TempCheck |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

VehicleInspectionReasonSimpleClass Class
CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason Namespace


VehicleInspectionReasonSimpleClass Properties

VehicleInspectionReasonSimpleClass Class See Also

The following tables list the members exposed by the VehicleInspectionReasonSimpleClass type.

Properties
 | Name | Description
Public property | ChemicalCheck |
Public property | Code |
Public property | OdorCheck |
Public property | PcgCheck |
Public property | PestCheck |
Public property | RsnCode |
Public property | RsnName |
Public property | RubbishCheck |
Public property | SpoledCheck |
Public property | TempCheck |
Top
See Also

Reference

VehicleInspectionReasonSimpleClass Class
CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason Namespace


VehicleInspectionReasonSimpleClass.ChemicalCheck Property

Namespace: CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ChemicalCheck() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool ChemicalCheck {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool ChemicalCheck {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ChemicalCheck() : boolean;
public function set ChemicalCheck(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VehicleInspectionReasonSimpleClass Class
VehicleInspectionReasonSimpleClass Members
CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason Namespace


VehicleInspectionReasonSimpleClass.Code Property

Namespace: CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Code() : String;
public function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VehicleInspectionReasonSimpleClass Class
VehicleInspectionReasonSimpleClass Members
CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason Namespace


VehicleInspectionReasonSimpleClass.OdorCheck Property

Namespace: CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property OdorCheck() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool OdorCheck {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool OdorCheck {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get OdorCheck() : boolean;
public function set OdorCheck(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VehicleInspectionReasonSimpleClass Class
VehicleInspectionReasonSimpleClass Members
CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason Namespace


VehicleInspectionReasonSimpleClass.PcgCheck Property

Namespace: CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property PcgCheck() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool PcgCheck {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool PcgCheck {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get PcgCheck() : boolean;
public function set PcgCheck(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VehicleInspectionReasonSimpleClass Class
VehicleInspectionReasonSimpleClass Members
CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason Namespace


VehicleInspectionReasonSimpleClass.PestCheck Property

Namespace: CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property PestCheck() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool PestCheck {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool PestCheck {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get PestCheck() : boolean;
public function set PestCheck(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VehicleInspectionReasonSimpleClass Class
VehicleInspectionReasonSimpleClass Members
CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason Namespace


VehicleInspectionReasonSimpleClass.RsnCode Property

Namespace: CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property RsnCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string RsnCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ RsnCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get RsnCode() : String;
public function set RsnCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VehicleInspectionReasonSimpleClass Class
VehicleInspectionReasonSimpleClass Members
CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason Namespace


VehicleInspectionReasonSimpleClass.RsnName Property

Namespace: CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property RsnName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string RsnName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ RsnName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get RsnName() : String;
public function set RsnName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VehicleInspectionReasonSimpleClass Class
VehicleInspectionReasonSimpleClass Members
CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason Namespace


VehicleInspectionReasonSimpleClass.RubbishCheck Property

Namespace: CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property RubbishCheck() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool RubbishCheck {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool RubbishCheck {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get RubbishCheck() : boolean;
public function set RubbishCheck(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VehicleInspectionReasonSimpleClass Class
VehicleInspectionReasonSimpleClass Members
CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason Namespace


VehicleInspectionReasonSimpleClass.SpoledCheck Property

Namespace: CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SpoledCheck() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool SpoledCheck {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool SpoledCheck {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SpoledCheck() : boolean;
public function set SpoledCheck(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VehicleInspectionReasonSimpleClass Class
VehicleInspectionReasonSimpleClass Members
CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason Namespace


VehicleInspectionReasonSimpleClass.TempCheck Property

Namespace: CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property TempCheck() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool TempCheck {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool TempCheck {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get TempCheck() : boolean;
public function set TempCheck(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VehicleInspectionReasonSimpleClass Class
VehicleInspectionReasonSimpleClass Members
CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason Namespace


VehicleInspectionReasonSimpleClass Methods

VehicleInspectionReasonSimpleClass Class See Also

The following tables list the members exposed by the VehicleInspectionReasonSimpleClass type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

VehicleInspectionReasonSimpleClass Class
CompuTec.ProcessForce.API.Documents._Quality_Control_._VehicleInspections_.VehicleInspectionReason Namespace


CompuTec.ProcessForce.API.DynamicCosting.Common Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Enumerations
 | Name | Description
Public enumeration | TransactionEngineType |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


TransactionEngineType Enumeration

Namespace: CompuTec.ProcessForce.API.DynamicCosting.Common
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
CostRollUp |
CostRollOver |
ItemCostingRestore |
ResourceCostingRestore |
See Also

Reference

CompuTec.ProcessForce.API.DynamicCosting.Common Namespace


CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | ItemCostingRestorationManager |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ItemCostingRestorationManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.DynamicCosting.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ItemCostingRestorationManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemCostingRestorationManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ItemCostingRestorationManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemCostingRestorationManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.DynamicCosting.Restoration.ItemCostingRestorationManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorationManager Members
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


ItemCostingRestorationManager Members

ItemCostingRestorationManager Class Constructors Methods Fields Properties See Also

The following tables list the members exposed by the ItemCostingRestorationManager type.

Constructors
 | Name | Description
Public constructor | ItemCostingRestorationManager | Initializes a new instance of the CostingRestorationManager class.
Top
Properties
Name | Description
DeleteAllData | Gets or sets an indication whether or not all Item Costing data must be deleted before restoration process.
NextLogInstValues | Gets or sets the next LogInst values for a specified codes.
Top
Methods
 | Name | Description
 | CheckItemCostManagedByWarehouses | Checks whether or not the item cost is managed by warehouses.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Initialize | Initializes the Item Costing related data for restoring.
Public method | InitializeDataFromCsvFile |
 | OpenRestoreFileNumberingForm | Opens "Restore File Numbering" messagebox window.
Public method | Restore | Restores the missing Item Costing data.
Public method | SaveCsvFiles | Saves the data in CSV files.
Public method | SaveFaultRowCsvFile | Saves the data of a fault row in CSV file.
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
Name | Description
IsItemCostManagedByWarehouses | Determines whether or not the item cost is managed by warehouses.
IsRestoreFileNumberingMessageBoxOpened | Gets or sets an indication whether or not the "Restore File Numbering" messagebox window was opened.
ShouldCustomMessageBeDisplayedBeforeRestoration | Gets or sets an indication whether or not a custom, ProcessForce related messagebox should be displayed before restoration.
ShouldMessageBoxAboutFileNumberingRestoringBeClosed | Gets or sets an indication whether or not the "File Numbering Restoring succeeded" messagebox window should be closed.
SuspendItemCostingRestoration | Gets or sets the indication whether or not the Item Costing data restoration should be restored.
Top
See Also

Reference

ItemCostingRestorationManager Class
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


ItemCostingRestorationManager Constructor

Initializes a new instance of the CostingRestorationManager class.

Namespace: CompuTec.ProcessForce.API.DynamicCosting.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String, _
   Optional ByVal deleteAll As Boolean = false _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemCostingRestorationManager(
   string token,
   bool deleteAll = false
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemCostingRestorationManager(
   String^ token,
   bool deleteAll
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemCostingRestorationManager(
    token : String,
    deleteAll : boolean
);
This language is not supported or no code example is available.

Parameters

token

Type: string

Connection token.

deleteAll

Type: bool

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorationManager Class
ItemCostingRestorationManager Members
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


ItemCostingRestorationManager Properties

ItemCostingRestorationManager Class See Also

The following tables list the members exposed by the ItemCostingRestorationManager type.

Properties
Name | Description
DeleteAllData | Gets or sets an indication whether or not all Item Costing data must be deleted before restoration process.
NextLogInstValues | Gets or sets the next LogInst values for a specified codes.
Top
See Also

Reference

ItemCostingRestorationManager Class
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


ItemCostingRestorationManager.DeleteAllData Property

Gets or sets an indication whether or not all Item Costing data must be deleted before restoration process.

Namespace: CompuTec.ProcessForce.API.DynamicCosting.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property DeleteAllData() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool DeleteAllData {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property bool DeleteAllData {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get DeleteAllData() : boolean;
public static function set DeleteAllData(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorationManager Class
ItemCostingRestorationManager Members
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


ItemCostingRestorationManager.NextLogInstValues Property

Gets or sets the next LogInst values for a specified codes.

Namespace: CompuTec.ProcessForce.API.DynamicCosting.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property NextLogInstValues() As Dictionary(Of String, Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Dictionary<string, int> NextLogInstValues {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property Dictionary<String^, int>^ NextLogInstValues {
 Dictionary<String^, int>^ get( );
 void set(
   Dictionary<String^, int>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: Dictionary<string, int>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorationManager Class
ItemCostingRestorationManager Members
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


ItemCostingRestorationManager Methods

ItemCostingRestorationManager Class See Also

The following tables list the members exposed by the ItemCostingRestorationManager type.

Methods
 | Name | Description
 | CheckItemCostManagedByWarehouses | Checks whether or not the item cost is managed by warehouses.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Initialize | Initializes the Item Costing related data for restoring.
Public method | InitializeDataFromCsvFile |
 | OpenRestoreFileNumberingForm | Opens "Restore File Numbering" messagebox window.
Public method | Restore | Restores the missing Item Costing data.
Public method | SaveCsvFiles | Saves the data in CSV files.
Public method | SaveFaultRowCsvFile | Saves the data of a fault row in CSV file.
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ItemCostingRestorationManager Class
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


ItemCostingRestorationManager.CheckItemCostManagedByWarehouses Method

Checks whether or not the item cost is managed by warehouses.

Namespace: CompuTec.ProcessForce.API.DynamicCosting.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function CheckItemCostManagedByWarehouses( _
   ByVal Token As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool CheckItemCostManagedByWarehouses(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool CheckItemCostManagedByWarehouses(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function CheckItemCostManagedByWarehouses(
    Token : String
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Token.

Return Value

Type: bool

true if item cost is managed by warehouses; otherwise, false.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorationManager Class
ItemCostingRestorationManager Members
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


ItemCostingRestorationManager.Dispose Method

Namespace: CompuTec.ProcessForce.API.DynamicCosting.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Dispose()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Dispose()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Dispose()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Dispose();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorationManager Class
ItemCostingRestorationManager Members
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


ItemCostingRestorationManager.Initialize Method

Initializes the Item Costing related data for restoring.

Namespace: CompuTec.ProcessForce.API.DynamicCosting.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Initialize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Initialize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Initialize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Initialize();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorationManager Class
ItemCostingRestorationManager Members
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


ItemCostingRestorationManager.InitializeDataFromCsvFile Method

Namespace: CompuTec.ProcessForce.API.DynamicCosting.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function InitializeDataFromCsvFile( _
   ByVal path As String, _
   ByVal costCategories As List(Of String) _
) As CsvDataReadResult
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CsvDataReadResult InitializeDataFromCsvFile(
   string path,
   List<string> costCategories
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CsvDataReadResult InitializeDataFromCsvFile(
   String^ path,
   List<String^>^ costCategories
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

path

Type: string

costCategories

Type: List<string>

Return Value

Type: CsvDataReadResult
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorationManager Class
ItemCostingRestorationManager Members
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


ItemCostingRestorationManager.OpenRestoreFileNumberingForm Method

Opens "Restore File Numbering" messagebox window.

Namespace: CompuTec.ProcessForce.API.DynamicCosting.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub OpenRestoreFileNumberingForm()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void OpenRestoreFileNumberingForm()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void OpenRestoreFileNumberingForm()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function OpenRestoreFileNumberingForm();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorationManager Class
ItemCostingRestorationManager Members
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


ItemCostingRestorationManager.Restore Method

Restores the missing Item Costing data.

Namespace: CompuTec.ProcessForce.API.DynamicCosting.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Restore( _
   Optional ByVal restoreNumbering As Boolean = false _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Restore(
   bool restoreNumbering = false
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Restore(
   bool restoreNumbering
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Restore(
    restoreNumbering : boolean
);
This language is not supported or no code example is available.

Parameters

restoreNumbering

Type: bool

Determines whether or not the Document Numbering data should be automatically fixed after Item Costing restoration.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorationManager Class
ItemCostingRestorationManager Members
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


ItemCostingRestorationManager.SaveCsvFiles Method

Saves the data in CSV files.

Namespace: CompuTec.ProcessForce.API.DynamicCosting.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub SaveCsvFiles()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void SaveCsvFiles()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void SaveCsvFiles()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SaveCsvFiles();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorationManager Class
ItemCostingRestorationManager Members
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


ItemCostingRestorationManager.SaveFaultRowCsvFile Method

Saves the data of a fault row in CSV file.

Namespace: CompuTec.ProcessForce.API.DynamicCosting.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub SaveFaultRowCsvFile( _
   ByVal dbTableName As String, _
   ByVal dataTable As DataTable, _
   ByVal row As DataRow _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void SaveFaultRowCsvFile(
   string dbTableName,
   DataTable dataTable,
   DataRow row
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void SaveFaultRowCsvFile(
   String^ dbTableName,
   DataTable^ dataTable,
   DataRow^ row
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SaveFaultRowCsvFile(
    dbTableName : String,
    dataTable : DataTable,
    row : DataRow
);
This language is not supported or no code example is available.

Parameters

dbTableName

Type: string

Database table name.

dataTable

Type: DataTable

Costing data for which the error occurred.

row

Type: DataRow

The data of a row for which the unique constraint violated exception occurred.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorationManager Class
ItemCostingRestorationManager Members
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


ItemCostingRestorationManager Fields

ItemCostingRestorationManager Class See Also

The following tables list the members exposed by the ItemCostingRestorationManager type.

Fields
Name | Description
IsItemCostManagedByWarehouses | Determines whether or not the item cost is managed by warehouses.
IsRestoreFileNumberingMessageBoxOpened | Gets or sets an indication whether or not the "Restore File Numbering" messagebox window was opened.
ShouldCustomMessageBeDisplayedBeforeRestoration | Gets or sets an indication whether or not a custom, ProcessForce related messagebox should be displayed before restoration.
ShouldMessageBoxAboutFileNumberingRestoringBeClosed | Gets or sets an indication whether or not the "File Numbering Restoring succeeded" messagebox window should be closed.
SuspendItemCostingRestoration | Gets or sets the indication whether or not the Item Costing data restoration should be restored.
Top
See Also

Reference

ItemCostingRestorationManager Class
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


IsItemCostManagedByWarehouses Field

Determines whether or not the item cost is managed by warehouses.

Namespace: CompuTec.ProcessForce.API.DynamicCosting.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared IsItemCostManagedByWarehouses As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool IsItemCostManagedByWarehouses
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool IsItemCostManagedByWarehouses;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static IsItemCostManagedByWarehouses : boolean
This language is not supported or no code example is available.

Field Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorationManager Class
ItemCostingRestorationManager Members
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


IsRestoreFileNumberingMessageBoxOpened Field

Gets or sets an indication whether or not the "Restore File Numbering" messagebox window was opened.

Namespace: CompuTec.ProcessForce.API.DynamicCosting.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared IsRestoreFileNumberingMessageBoxOpened As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool IsRestoreFileNumberingMessageBoxOpened
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool IsRestoreFileNumberingMessageBoxOpened;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static IsRestoreFileNumberingMessageBoxOpened : boolean
This language is not supported or no code example is available.

Field Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorationManager Class
ItemCostingRestorationManager Members
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


ShouldCustomMessageBeDisplayedBeforeRestoration Field

Gets or sets an indication whether or not a custom, ProcessForce related messagebox should be displayed before restoration.

Namespace: CompuTec.ProcessForce.API.DynamicCosting.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared ShouldCustomMessageBeDisplayedBeforeRestoration As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool ShouldCustomMessageBeDisplayedBeforeRestoration
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool ShouldCustomMessageBeDisplayedBeforeRestoration;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static ShouldCustomMessageBeDisplayedBeforeRestoration : boolean
This language is not supported or no code example is available.

Field Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorationManager Class
ItemCostingRestorationManager Members
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


ShouldMessageBoxAboutFileNumberingRestoringBeClosed Field

Gets or sets an indication whether or not the "File Numbering Restoring succeeded" messagebox window should be closed.

Namespace: CompuTec.ProcessForce.API.DynamicCosting.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared ShouldMessageBoxAboutFileNumberingRestoringBeClosed As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool ShouldMessageBoxAboutFileNumberingRestoringBeClosed
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool ShouldMessageBoxAboutFileNumberingRestoringBeClosed;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static ShouldMessageBoxAboutFileNumberingRestoringBeClosed : boolean
This language is not supported or no code example is available.

Field Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorationManager Class
ItemCostingRestorationManager Members
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


SuspendItemCostingRestoration Field

Gets or sets the indication whether or not the Item Costing data restoration should be restored.

Namespace: CompuTec.ProcessForce.API.DynamicCosting.Restoration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared SuspendItemCostingRestoration As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool SuspendItemCostingRestoration
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool SuspendItemCostingRestoration;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static SuspendItemCostingRestoration : boolean
This language is not supported or no code example is available.

Field Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingRestorationManager Class
ItemCostingRestorationManager Members
CompuTec.ProcessForce.API.DynamicCosting.Restoration Namespace


CompuTec.ProcessForce.API.DynamicCosting.Restoration.Data Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Enumerations
 | Name | Description
Public enumeration | CsvDataReadResult |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


CsvDataReadResult Enumeration

Namespace: CompuTec.ProcessForce.API.DynamicCosting.Restoration.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
FilePathIsInvalid | The path of the CSV file is invalid.
FileDoesNotExist | The CSV file does not exist.
CostCategoryIsNotDefined | At least one cost category must be defined.
NoDataInTheFile | No data was found in the CSV file.
Success | Success.
See Also

Reference

CompuTec.ProcessForce.API.DynamicCosting.Restoration.Data Namespace


CompuTec.ProcessForce.API.DynamicCosting.RollOver.Data Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Enumerations
 | Name | Description
Public enumeration | ValuationMethod | Contains a set of available valuation methods.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ValuationMethod Enumeration

Contains a set of available valuation methods.

Namespace: CompuTec.ProcessForce.API.DynamicCosting.RollOver.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Standard | Standard.
MovingAverage | Moving average.
Fifo | FIFO.
BatchOrSerialNo | Batch or Serial no.
Unknown | Unknown valuation method.
See Also

Reference

CompuTec.ProcessForce.API.DynamicCosting.RollOver.Data Namespace


CompuTec.ProcessForce.API.DynamicCosting.RollUp Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Enumerations
 | Name | Description
Public enumeration | ErrorType |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ErrorType Enumeration

Namespace: CompuTec.ProcessForce.API.DynamicCosting.RollUp
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
StandardItemRollUp |
SemiGoodRollUp |
FinishedGoodRollUp |
See Also

Reference

CompuTec.ProcessForce.API.DynamicCosting.RollUp Namespace


CompuTec.ProcessForce.API.DynamicCosting.RollUp.Data Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Enumerations
 | Name | Description
Public enumeration | CoproductCalculationType |
Public enumeration | RollUpMode |
Public enumeration | ScrapCalculationType |
Public enumeration | ValuationMethod | Contains a set of available valuation methods.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


CoproductCalculationType Enumeration

Namespace: CompuTec.ProcessForce.API.DynamicCosting.RollUp.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
GoodRelatedValues |
OwnCostingValues |
See Also

Reference

CompuTec.ProcessForce.API.DynamicCosting.RollUp.Data Namespace


RollUpMode Enumeration

Namespace: CompuTec.ProcessForce.API.DynamicCosting.RollUp.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Full | A full Cost Roll-up is performed.
Single | Cost Roll-up is performed only for a selected good.
See Also

Reference

CompuTec.ProcessForce.API.DynamicCosting.RollUp.Data Namespace


ScrapCalculationType Enumeration

Namespace: CompuTec.ProcessForce.API.DynamicCosting.RollUp.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
GoodRelatedValues |
OwnCostingValues |
See Also

Reference

CompuTec.ProcessForce.API.DynamicCosting.RollUp.Data Namespace


ValuationMethod Enumeration

Contains a set of available valuation methods.

Namespace: CompuTec.ProcessForce.API.DynamicCosting.RollUp.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Standard | Standard.
MovingAverage | Moving average.
Fifo | FIFO.
BatchOrSerialNo | Batch or Serial no.
Unknown | Unknown valuation method.
See Also

Reference

CompuTec.ProcessForce.API.DynamicCosting.RollUp.Data Namespace


CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | CostedBillOfMaterialsQueries |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


CostedBillOfMaterialsQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class CostedBillOfMaterialsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CostedBillOfMaterialsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class CostedBillOfMaterialsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CostedBillOfMaterialsQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials.CostedBillOfMaterialsQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries Members

CostedBillOfMaterialsQueries Class Methods See Also

The following tables list the members exposed by the CostedBillOfMaterialsQueries type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBOMTotalCosts |
Public method | GetBillOfMaterialsCosts |
Public method | GetBillOfMaterialsCostsForRouting |
Public method | GetBillOfMaterialsCostsForRoutingNonContinuous |
Public method | GetBillOfMaterialsCostsNonContinuous |
Public method | GetBillOfMaterialsStructure |
Public method | GetBomCodeForDefaultItemRevision |
Public method | GetCoproductCost |
Public method | GetCoproductCosts |
Public method | GetCoproductCostsNonContinuous |
Public method | GetFinalProductCost |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemCost |
 | GetItemCostWarehouseManagementState |
Public method | GetItemWarehouses |
Public method | GetRawMaterialCosts |
Public method | GetRawMaterialCostsNonContinuous |
Public method | GetRoutingResources |
Public method | GetRoutings |
Public method | GetScrapCost |
Public method | GetScrapCosts |
Public method | GetScrapCostsNonContinuous |
Public method | GetSemiGoodCost |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

CostedBillOfMaterialsQueries Class
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries Methods

CostedBillOfMaterialsQueries Class See Also

The following tables list the members exposed by the CostedBillOfMaterialsQueries type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBOMTotalCosts |
Public method | GetBillOfMaterialsCosts |
Public method | GetBillOfMaterialsCostsForRouting |
Public method | GetBillOfMaterialsCostsForRoutingNonContinuous |
Public method | GetBillOfMaterialsCostsNonContinuous |
Public method | GetBillOfMaterialsStructure |
Public method | GetBomCodeForDefaultItemRevision |
Public method | GetCoproductCost |
Public method | GetCoproductCosts |
Public method | GetCoproductCostsNonContinuous |
Public method | GetFinalProductCost |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemCost |
 | GetItemCostWarehouseManagementState |
Public method | GetItemWarehouses |
Public method | GetRawMaterialCosts |
Public method | GetRawMaterialCostsNonContinuous |
Public method | GetRoutingResources |
Public method | GetRoutings |
Public method | GetScrapCost |
Public method | GetScrapCosts |
Public method | GetScrapCostsNonContinuous |
Public method | GetSemiGoodCost |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

CostedBillOfMaterialsQueries Class
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetBOMTotalCosts Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBOMTotalCosts( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revisionCode As String, _
   ByVal whsCode As String, _
   ByVal costCategoryCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBOMTotalCosts(
   string token,
   string itemCode,
   string revisionCode,
   string whsCode,
   string costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBOMTotalCosts(
   String^ token,
   String^ itemCode,
   String^ revisionCode,
   String^ whsCode,
   String^ costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBOMTotalCosts(
    token : String,
    itemCode : String,
    revisionCode : String,
    whsCode : String,
    costCategoryCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revisionCode

Type: string

whsCode

Type: string

costCategoryCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetBillOfMaterialsCosts Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBillOfMaterialsCosts( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revisionCode As String, _
   ByVal costCategoryCode As String, _
   ByVal warehouseCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBillOfMaterialsCosts(
   string token,
   string itemCode,
   string revisionCode,
   string costCategoryCode,
   string warehouseCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBillOfMaterialsCosts(
   String^ token,
   String^ itemCode,
   String^ revisionCode,
   String^ costCategoryCode,
   String^ warehouseCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBillOfMaterialsCosts(
    token : String,
    itemCode : String,
    revisionCode : String,
    costCategoryCode : String,
    warehouseCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revisionCode

Type: string

costCategoryCode

Type: string

warehouseCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetBillOfMaterialsCostsForRouting Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBillOfMaterialsCostsForRouting( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revisionCode As String, _
   ByVal costCategoryCode As String, _
   ByVal warehouseCode As String, _
   ByVal routingCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBillOfMaterialsCostsForRouting(
   string token,
   string itemCode,
   string revisionCode,
   string costCategoryCode,
   string warehouseCode,
   string routingCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBillOfMaterialsCostsForRouting(
   String^ token,
   String^ itemCode,
   String^ revisionCode,
   String^ costCategoryCode,
   String^ warehouseCode,
   String^ routingCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBillOfMaterialsCostsForRouting(
    token : String,
    itemCode : String,
    revisionCode : String,
    costCategoryCode : String,
    warehouseCode : String,
    routingCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revisionCode

Type: string

costCategoryCode

Type: string

warehouseCode

Type: string

routingCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetBillOfMaterialsCostsForRoutingNonContinuous Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBillOfMaterialsCostsForRoutingNonContinuous( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revisionCode As String, _
   ByVal costCategoryCode As String, _
   ByVal routingCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBillOfMaterialsCostsForRoutingNonContinuous(
   string token,
   string itemCode,
   string revisionCode,
   string costCategoryCode,
   string routingCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBillOfMaterialsCostsForRoutingNonContinuous(
   String^ token,
   String^ itemCode,
   String^ revisionCode,
   String^ costCategoryCode,
   String^ routingCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBillOfMaterialsCostsForRoutingNonContinuous(
    token : String,
    itemCode : String,
    revisionCode : String,
    costCategoryCode : String,
    routingCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revisionCode

Type: string

costCategoryCode

Type: string

routingCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetBillOfMaterialsCostsNonContinuous Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBillOfMaterialsCostsNonContinuous( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revisionCode As String, _
   ByVal costCategoryCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBillOfMaterialsCostsNonContinuous(
   string token,
   string itemCode,
   string revisionCode,
   string costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBillOfMaterialsCostsNonContinuous(
   String^ token,
   String^ itemCode,
   String^ revisionCode,
   String^ costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBillOfMaterialsCostsNonContinuous(
    token : String,
    itemCode : String,
    revisionCode : String,
    costCategoryCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revisionCode

Type: string

costCategoryCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetBillOfMaterialsStructure Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBillOfMaterialsStructure( _
   ByVal token As String, _
   ByVal code As String, _
   ByVal costCategoryCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBillOfMaterialsStructure(
   string token,
   string code,
   string costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBillOfMaterialsStructure(
   String^ token,
   String^ code,
   String^ costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBillOfMaterialsStructure(
    token : String,
    code : String,
    costCategoryCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

code

Type: string

costCategoryCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetBomCodeForDefaultItemRevision Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBomCodeForDefaultItemRevision( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBomCodeForDefaultItemRevision(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBomCodeForDefaultItemRevision(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBomCodeForDefaultItemRevision(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetCoproductCost Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetCoproductCost( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revisionCode As String, _
   ByVal costCategoryCode As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetCoproductCost(
   string token,
   string itemCode,
   string revisionCode,
   string costCategoryCode,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetCoproductCost(
   String^ token,
   String^ itemCode,
   String^ revisionCode,
   String^ costCategoryCode,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetCoproductCost(
    token : String,
    itemCode : String,
    revisionCode : String,
    costCategoryCode : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revisionCode

Type: string

costCategoryCode

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetCoproductCosts Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetCoproductCosts( _
   ByVal token As String, _
   ByVal parentItemCode As String, _
   ByVal coproductCode As String, _
   ByVal parentRevisionCode As String, _
   ByVal costCategoryCode As String, _
   ByVal coproductWarehouseCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetCoproductCosts(
   string token,
   string parentItemCode,
   string coproductCode,
   string parentRevisionCode,
   string costCategoryCode,
   string coproductWarehouseCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetCoproductCosts(
   String^ token,
   String^ parentItemCode,
   String^ coproductCode,
   String^ parentRevisionCode,
   String^ costCategoryCode,
   String^ coproductWarehouseCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetCoproductCosts(
    token : String,
    parentItemCode : String,
    coproductCode : String,
    parentRevisionCode : String,
    costCategoryCode : String,
    coproductWarehouseCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

parentItemCode

Type: string

coproductCode

Type: string

parentRevisionCode

Type: string

costCategoryCode

Type: string

coproductWarehouseCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetCoproductCostsNonContinuous Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetCoproductCostsNonContinuous( _
   ByVal token As String, _
   ByVal parentItemCode As String, _
   ByVal coproductCode As String, _
   ByVal parentRevisionCode As String, _
   ByVal costCategoryCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetCoproductCostsNonContinuous(
   string token,
   string parentItemCode,
   string coproductCode,
   string parentRevisionCode,
   string costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetCoproductCostsNonContinuous(
   String^ token,
   String^ parentItemCode,
   String^ coproductCode,
   String^ parentRevisionCode,
   String^ costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetCoproductCostsNonContinuous(
    token : String,
    parentItemCode : String,
    coproductCode : String,
    parentRevisionCode : String,
    costCategoryCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

parentItemCode

Type: string

coproductCode

Type: string

parentRevisionCode

Type: string

costCategoryCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetFinalProductCost Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetFinalProductCost( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revisionCode As String, _
   ByVal costCategoryCode As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetFinalProductCost(
   string token,
   string itemCode,
   string revisionCode,
   string costCategoryCode,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetFinalProductCost(
   String^ token,
   String^ itemCode,
   String^ revisionCode,
   String^ costCategoryCode,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetFinalProductCost(
    token : String,
    itemCode : String,
    revisionCode : String,
    costCategoryCode : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revisionCode

Type: string

costCategoryCode

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetItemCost Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemCost( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal costCategoryCode As String, _
   ByVal whsCode As String, _
   ByVal revisionCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemCost(
   string token,
   string itemCode,
   string costCategoryCode,
   string whsCode,
   string revisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemCost(
   String^ token,
   String^ itemCode,
   String^ costCategoryCode,
   String^ whsCode,
   String^ revisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemCost(
    token : String,
    itemCode : String,
    costCategoryCode : String,
    whsCode : String,
    revisionCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

costCategoryCode

Type: string

whsCode

Type: string

revisionCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetItemCostWarehouseManagementState Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemCostWarehouseManagementState( _
   ByVal Token As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool GetItemCostWarehouseManagementState(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool GetItemCostWarehouseManagementState(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemCostWarehouseManagementState(
    Token : String
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetItemWarehouses Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemWarehouses( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemWarehouses(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemWarehouses(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemWarehouses(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetRawMaterialCosts Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRawMaterialCosts( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revisionCode As String, _
   ByVal costCategoryCode As String, _
   ByVal warehouseCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRawMaterialCosts(
   string token,
   string itemCode,
   string revisionCode,
   string costCategoryCode,
   string warehouseCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRawMaterialCosts(
   String^ token,
   String^ itemCode,
   String^ revisionCode,
   String^ costCategoryCode,
   String^ warehouseCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRawMaterialCosts(
    token : String,
    itemCode : String,
    revisionCode : String,
    costCategoryCode : String,
    warehouseCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revisionCode

Type: string

costCategoryCode

Type: string

warehouseCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetRawMaterialCostsNonContinuous Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRawMaterialCostsNonContinuous( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revisionCode As String, _
   ByVal costCategoryCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRawMaterialCostsNonContinuous(
   string token,
   string itemCode,
   string revisionCode,
   string costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRawMaterialCostsNonContinuous(
   String^ token,
   String^ itemCode,
   String^ revisionCode,
   String^ costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRawMaterialCostsNonContinuous(
    token : String,
    itemCode : String,
    revisionCode : String,
    costCategoryCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revisionCode

Type: string

costCategoryCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetRoutingResources Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRoutingResources( _
   ByVal token As String, _
   ByVal code As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRoutingResources(
   string token,
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRoutingResources(
   String^ token,
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRoutingResources(
    token : String,
    code : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

code

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetRoutings Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRoutings( _
   ByVal token As String, _
   ByVal bomCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRoutings(
   string token,
   string bomCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRoutings(
   String^ token,
   String^ bomCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRoutings(
    token : String,
    bomCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

bomCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetScrapCost Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetScrapCost( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revisionCode As String, _
   ByVal costCategoryCode As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetScrapCost(
   string token,
   string itemCode,
   string revisionCode,
   string costCategoryCode,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetScrapCost(
   String^ token,
   String^ itemCode,
   String^ revisionCode,
   String^ costCategoryCode,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetScrapCost(
    token : String,
    itemCode : String,
    revisionCode : String,
    costCategoryCode : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revisionCode

Type: string

costCategoryCode

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetScrapCosts Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetScrapCosts( _
   ByVal token As String, _
   ByVal parentItemCode As String, _
   ByVal scrapCode As String, _
   ByVal parentRevisionCode As String, _
   ByVal costCategoryCode As String, _
   ByVal scrapWarehouseCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetScrapCosts(
   string token,
   string parentItemCode,
   string scrapCode,
   string parentRevisionCode,
   string costCategoryCode,
   string scrapWarehouseCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetScrapCosts(
   String^ token,
   String^ parentItemCode,
   String^ scrapCode,
   String^ parentRevisionCode,
   String^ costCategoryCode,
   String^ scrapWarehouseCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetScrapCosts(
    token : String,
    parentItemCode : String,
    scrapCode : String,
    parentRevisionCode : String,
    costCategoryCode : String,
    scrapWarehouseCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

parentItemCode

Type: string

scrapCode

Type: string

parentRevisionCode

Type: string

costCategoryCode

Type: string

scrapWarehouseCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetScrapCostsNonContinuous Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetScrapCostsNonContinuous( _
   ByVal token As String, _
   ByVal parentItemCode As String, _
   ByVal scrapCode As String, _
   ByVal parentRevisionCode As String, _
   ByVal costCategoryCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetScrapCostsNonContinuous(
   string token,
   string parentItemCode,
   string scrapCode,
   string parentRevisionCode,
   string costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetScrapCostsNonContinuous(
   String^ token,
   String^ parentItemCode,
   String^ scrapCode,
   String^ parentRevisionCode,
   String^ costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetScrapCostsNonContinuous(
    token : String,
    parentItemCode : String,
    scrapCode : String,
    parentRevisionCode : String,
    costCategoryCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

parentItemCode

Type: string

scrapCode

Type: string

parentRevisionCode

Type: string

costCategoryCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CostedBillOfMaterialsQueries.GetSemiGoodCost Method

Namespace: CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSemiGoodCost( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal costCategoryCode As String, _
   ByVal whsCode As String, _
   ByVal revisionCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSemiGoodCost(
   string token,
   string itemCode,
   string costCategoryCode,
   string whsCode,
   string revisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSemiGoodCost(
   String^ token,
   String^ itemCode,
   String^ costCategoryCode,
   String^ whsCode,
   String^ revisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSemiGoodCost(
    token : String,
    itemCode : String,
    costCategoryCode : String,
    whsCode : String,
    revisionCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

costCategoryCode

Type: string

whsCode

Type: string

revisionCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsQueries Class
CostedBillOfMaterialsQueries Members
CompuTec.ProcessForce.API.Queries.CostedBillOfMaterials Namespace


CompuTec.ProcessForce.API.Queries.CostingQueries Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | CostingBaseQueries |
Public class | CostingSapHanaQueries |
Public class | CostingSqlServerQuerties |
Top
Interfaces
 | Name | Description
Public interface | ICostingQueries |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


CostingBaseQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class CostingBaseQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CostingBaseQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class CostingBaseQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CostingBaseQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.CostingQueries.CostingBaseQueries
CompuTec.ProcessForce.API.Queries.CostingQueries.CostingSapHanaQueries
CompuTec.ProcessForce.API.Queries.CostingQueries.CostingSqlServerQuerties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries Members

CostingBaseQueries Class Methods See Also

The following tables list the members exposed by the CostingBaseQueries type.

Methods
 | Name | Description
Public method | BillOfMaterialsExists |
Public method | CallCleanUpProcedure |
Public method | CreateTempItemsTable |
Public method | DetectChangesOnCostingProperties |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | ExtractBillOfMaterials |
Public method | GetActiveCostCategories |
Public method | GetAllSingleStructureItems |
Public method | GetArchiveITC5Table | Gets the name of the log table for CT_PF_ITC5 table.
Public method | GetBillOfMaterialRoutings |
Public method | GetBillOfMaterialsCoproducts |
Public method | GetBillOfMaterialsCosts |
Public method | GetBillOfMaterialsResourceDetails |
Public method | GetBillOfMaterialsResources |
Public method | GetBillOfMaterialsRoutings |
Public method | GetBillOfMaterialsScrap |
Public method | GetBomWithDefaultRevisionCode | Gets the code of Bill of Materials record for specified item code and its default revision.
Public method | GetCoproductSequenceNo |
Public method | GetCostedMorHeaderCosts |
Public method | GetCostedMorMaterialCosts |
Public method | GetCostedMorResourceCosts |
Public method | GetCostsComparisonRoutings |
Public method | GetDynamicCostingCoproducts |
Public method | GetDynamicCostingDetailCosts |
Public method | GetDynamicCostingFifoItems |
Public method | GetDynamicCostingFifoItemsManagedByWarehouse |
Public method | GetDynamicCostingItems |
Public method | GetDynamicCostingLastPurchasePriceInSystemCurrency |
Public method | GetDynamicCostingOperations |
Public method | GetDynamicCostingPriceListCosts |
Public method | GetDynamicCostingRawMaterials |
Public method | GetDynamicCostingResourceDetails |
Public method | GetDynamicCostingResourceDetailsCosts |
Public method | GetDynamicCostingResources |
Public method | GetDynamicCostingRolledCosts |
Public method | GetDynamicCostingRoutings |
Public method | GetDynamicCostingScraps |
Public method | GetDynamicCostingSerialBatchItems |
Public method | GetDynamicCostingSerialBatchItemsManagedByWarehouse |
Public method | GetDynamicCostingSerialBatchPrice |
Public method | GetDynamicCostingSerialBatchPriceManagedByWarehouse |
Public method | GetDynamicCostingStandardAndMovingAverageCosts |
Public method | GetDynamicCostingStandardAndMovingAverageCostsManagedByWarehouse |
Public method | GetFifoPriceWhenNoLayersAreAvailable |
Public method | GetFifoPriceWhenNoLayersAreAvailableNoWarehouses |
Public method | GetFixedVariableValueForItem |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemCostByRevisionEx |
Public method | GetItemCostForCostCategory000 |
Public method | GetItemCostingByItemCode |
Public method | GetItemCostingByItemGroupCode |
Public method | GetItemCostingDetails |
Public method | GetItemCostingPrecisionRestoreData |
Public method | GetItemCostingRestoreData |
Public method | GetItemCostingToSynchronize |
Public method | GetItemCostsEx |
Public method | GetItemNonDropShipWarehouses |
Public method | GetItemRolledCosts |
Public method | GetLastPurchasePriceInSystemCurrency |
Public method | GetLastRolledCostPrecision |
Public method | GetLastRolledCostPrecisionWarehouse |
Public method | GetLogTableNames |
Public method | GetNonDropWarehouses |
Public method | GetPriceListPriceInLocalCurrency |
Public method | GetReceiptPriceEx |
Public method | GetReceiptPriceExForHeader |
Public method | GetResourceCostingRestoreData |
Public method | GetResourceCostingToSynchronize |
Public method | GetResourceCosts |
Public method | GetRestoreCoproductsData |
Public method | GetRestoreCostingDetailsData |
Public method | GetRestoreHeaderData |
Public method | GetRestoreHeaderValues |
Public method | GetRestoreItemCostingEntriesToDelete |
Public method | GetRestoreMaxCostingDetailsLineNoIds |
Public method | GetRestoreMaxRolledCostsPrecisionLineNoIds |
Public method | GetRestoreRolledCostsData |
Public method | GetRestoreScrapData |
Public method | GetRollOverItems |
Public method | GetRollOverItemsMatchingGroup |
Public method | GetRollOverItemsMatchingGroupAndProperties |
Public method | GetRollOverItemsMatchingProperties |
Public method | GetRollUpAllowedItems |
Public method | GetRollUpAllowedItems2 |
Public method | GetRollUpAllowedSemiGoods |
Public method | GetRollUpItems |
Public method | GetRollUpItemsMatchingGroup |
Public method | GetRollUpItemsMatchingGroupAndProperties |
Public method | GetRollUpItemsMatchingProperties |
Public method | GetRollUpOrder |
Public method | GetRollUpOrderForSapHana |
Public method | GetScrapSequenceNo |
Public method | GetSerialBatchPrice |
Public method | GetSerialBatchPriceForWarehouse |
Public method | GetStandardRawMaterialsForRefreshingPrices |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetWarehousesToSynchronize |
Public method | ImportItemsDataToTemporaryTable |
Public method | IsRoutingDefaultForRollUp |
Public method | ItemCostingExists |
Public method | PrepareSingleStructureTempTable |
Public method | ResourceCostingExists |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateAccountCostingOnAllMORs |
Public method | UpdateAccountCostingOnSpecificMOR |
Public method | UpdateItemCostingTypeForCreatedOrDeletedBom |
Top
See Also

Reference

CostingBaseQueries Class
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries Methods

CostingBaseQueries Class See Also

The following tables list the members exposed by the CostingBaseQueries type.

Methods
 | Name | Description
Public method | BillOfMaterialsExists |
Public method | CallCleanUpProcedure |
Public method | CreateTempItemsTable |
Public method | DetectChangesOnCostingProperties |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | ExtractBillOfMaterials |
Public method | GetActiveCostCategories |
Public method | GetAllSingleStructureItems |
Public method | GetArchiveITC5Table | Gets the name of the log table for CT_PF_ITC5 table.
Public method | GetBillOfMaterialRoutings |
Public method | GetBillOfMaterialsCoproducts |
Public method | GetBillOfMaterialsCosts |
Public method | GetBillOfMaterialsResourceDetails |
Public method | GetBillOfMaterialsResources |
Public method | GetBillOfMaterialsRoutings |
Public method | GetBillOfMaterialsScrap |
Public method | GetBomWithDefaultRevisionCode | Gets the code of Bill of Materials record for specified item code and its default revision.
Public method | GetCoproductSequenceNo |
Public method | GetCostedMorHeaderCosts |
Public method | GetCostedMorMaterialCosts |
Public method | GetCostedMorResourceCosts |
Public method | GetCostsComparisonRoutings |
Public method | GetDynamicCostingCoproducts |
Public method | GetDynamicCostingDetailCosts |
Public method | GetDynamicCostingFifoItems |
Public method | GetDynamicCostingFifoItemsManagedByWarehouse |
Public method | GetDynamicCostingItems |
Public method | GetDynamicCostingLastPurchasePriceInSystemCurrency |
Public method | GetDynamicCostingOperations |
Public method | GetDynamicCostingPriceListCosts |
Public method | GetDynamicCostingRawMaterials |
Public method | GetDynamicCostingResourceDetails |
Public method | GetDynamicCostingResourceDetailsCosts |
Public method | GetDynamicCostingResources |
Public method | GetDynamicCostingRolledCosts |
Public method | GetDynamicCostingRoutings |
Public method | GetDynamicCostingScraps |
Public method | GetDynamicCostingSerialBatchItems |
Public method | GetDynamicCostingSerialBatchItemsManagedByWarehouse |
Public method | GetDynamicCostingSerialBatchPrice |
Public method | GetDynamicCostingSerialBatchPriceManagedByWarehouse |
Public method | GetDynamicCostingStandardAndMovingAverageCosts |
Public method | GetDynamicCostingStandardAndMovingAverageCostsManagedByWarehouse |
Public method | GetFifoPriceWhenNoLayersAreAvailable |
Public method | GetFifoPriceWhenNoLayersAreAvailableNoWarehouses |
Public method | GetFixedVariableValueForItem |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemCostByRevisionEx |
Public method | GetItemCostForCostCategory000 |
Public method | GetItemCostingByItemCode |
Public method | GetItemCostingByItemGroupCode |
Public method | GetItemCostingDetails |
Public method | GetItemCostingPrecisionRestoreData |
Public method | GetItemCostingRestoreData |
Public method | GetItemCostingToSynchronize |
Public method | GetItemCostsEx |
Public method | GetItemNonDropShipWarehouses |
Public method | GetItemRolledCosts |
Public method | GetLastPurchasePriceInSystemCurrency |
Public method | GetLastRolledCostPrecision |
Public method | GetLastRolledCostPrecisionWarehouse |
Public method | GetLogTableNames |
Public method | GetNonDropWarehouses |
Public method | GetPriceListPriceInLocalCurrency |
Public method | GetReceiptPriceEx |
Public method | GetReceiptPriceExForHeader |
Public method | GetResourceCostingRestoreData |
Public method | GetResourceCostingToSynchronize |
Public method | GetResourceCosts |
Public method | GetRestoreCoproductsData |
Public method | GetRestoreCostingDetailsData |
Public method | GetRestoreHeaderData |
Public method | GetRestoreHeaderValues |
Public method | GetRestoreItemCostingEntriesToDelete |
Public method | GetRestoreMaxCostingDetailsLineNoIds |
Public method | GetRestoreMaxRolledCostsPrecisionLineNoIds |
Public method | GetRestoreRolledCostsData |
Public method | GetRestoreScrapData |
Public method | GetRollOverItems |
Public method | GetRollOverItemsMatchingGroup |
Public method | GetRollOverItemsMatchingGroupAndProperties |
Public method | GetRollOverItemsMatchingProperties |
Public method | GetRollUpAllowedItems |
Public method | GetRollUpAllowedItems2 |
Public method | GetRollUpAllowedSemiGoods |
Public method | GetRollUpItems |
Public method | GetRollUpItemsMatchingGroup |
Public method | GetRollUpItemsMatchingGroupAndProperties |
Public method | GetRollUpItemsMatchingProperties |
Public method | GetRollUpOrder |
Public method | GetRollUpOrderForSapHana |
Public method | GetScrapSequenceNo |
Public method | GetSerialBatchPrice |
Public method | GetSerialBatchPriceForWarehouse |
Public method | GetStandardRawMaterialsForRefreshingPrices |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetWarehousesToSynchronize |
Public method | ImportItemsDataToTemporaryTable |
Public method | IsRoutingDefaultForRollUp |
Public method | ItemCostingExists |
Public method | PrepareSingleStructureTempTable |
Public method | ResourceCostingExists |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateAccountCostingOnAllMORs |
Public method | UpdateAccountCostingOnSpecificMOR |
Public method | UpdateItemCostingTypeForCreatedOrDeletedBom |
Top
See Also

Reference

CostingBaseQueries Class
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.BillOfMaterialsExists Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function BillOfMaterialsExists( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset BillOfMaterialsExists(
   string token,
   string itemCode,
   string revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ BillOfMaterialsExists(
   String^ token,
   String^ itemCode,
   String^ revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BillOfMaterialsExists(
    token : String,
    itemCode : String,
    revCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.CallCleanUpProcedure Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub CallCleanUpProcedure( _
   ByVal Token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void CallCleanUpProcedure(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void CallCleanUpProcedure(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CallCleanUpProcedure(
    Token : String
);
This language is not supported or no code example is available.

Parameters

Token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.CreateTempItemsTable Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub CreateTempItemsTable( _
   ByVal Token As String, _
   ByVal tableName As String, _
   ByVal connection As DbConnection _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void CreateTempItemsTable(
   string Token,
   string tableName,
   DbConnection connection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void CreateTempItemsTable(
   String^ Token,
   String^ tableName,
   DbConnection^ connection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CreateTempItemsTable(
    Token : String,
    tableName : String,
    connection : DbConnection
);
This language is not supported or no code example is available.

Parameters

Token

Type: string

tableName

Type: string

connection

Type: DbConnection

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.DetectChangesOnCostingProperties Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function DetectChangesOnCostingProperties( _
   ByVal token As String, _
   ByVal itemGroup As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset DetectChangesOnCostingProperties(
   string token,
   int itemGroup
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ DetectChangesOnCostingProperties(
   String^ token,
   int itemGroup
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DetectChangesOnCostingProperties(
    token : String,
    itemGroup : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemGroup

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.ExtractBillOfMaterials Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function ExtractBillOfMaterials( _
   ByVal Token As String, _
   ByVal tableName As String, _
   ByVal connection As DbConnection _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset ExtractBillOfMaterials(
   string Token,
   string tableName,
   DbConnection connection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ ExtractBillOfMaterials(
   String^ Token,
   String^ tableName,
   DbConnection^ connection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ExtractBillOfMaterials(
    Token : String,
    tableName : String,
    connection : DbConnection
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

tableName

Type: string

connection

Type: DbConnection

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetActiveCostCategories Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetActiveCostCategories( _
   ByVal token As String _
) As List(Of CodeDescriptionContainer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<CodeDescriptionContainer> GetActiveCostCategories(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<CodeDescriptionContainer^>^ GetActiveCostCategories(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: List<CodeDescriptionContainer>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetAllSingleStructureItems Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAllSingleStructureItems( _
   ByVal Tokem As String, _
   ByVal connection As DbConnection, _
   ByVal SingleStructureTempTable As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAllSingleStructureItems(
   string Tokem,
   DbConnection connection,
   string SingleStructureTempTable
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAllSingleStructureItems(
   String^ Tokem,
   DbConnection^ connection,
   String^ SingleStructureTempTable
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAllSingleStructureItems(
    Tokem : String,
    connection : DbConnection,
    SingleStructureTempTable : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Tokem

Type: string

connection

Type: DbConnection

SingleStructureTempTable

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetArchiveITC5Table Method

Gets the name of the log table for CT_PF_ITC5 table.

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetArchiveITC5Table( _
   ByVal token As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GetArchiveITC5Table(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ GetArchiveITC5Table(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetArchiveITC5Table(
    token : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

Token.

Return Value

Type: string

System.String object that represents the name of the log table for CT_PF_ITC5 table.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetBillOfMaterialRoutings Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBillOfMaterialRoutings( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBillOfMaterialRoutings(
   string token,
   string itemCode,
   string revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBillOfMaterialRoutings(
   String^ token,
   String^ itemCode,
   String^ revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBillOfMaterialRoutings(
    token : String,
    itemCode : String,
    revCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetBillOfMaterialsCoproducts Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBillOfMaterialsCoproducts( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBillOfMaterialsCoproducts(
   string token,
   string itemCode,
   string revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBillOfMaterialsCoproducts(
   String^ token,
   String^ itemCode,
   String^ revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBillOfMaterialsCoproducts(
    token : String,
    itemCode : String,
    revCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetBillOfMaterialsCosts Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBillOfMaterialsCosts( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBillOfMaterialsCosts(
   string token,
   string itemCode,
   string revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBillOfMaterialsCosts(
   String^ token,
   String^ itemCode,
   String^ revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBillOfMaterialsCosts(
    token : String,
    itemCode : String,
    revCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetBillOfMaterialsResourceDetails Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBillOfMaterialsResourceDetails( _
   ByVal token As String, _
   ByVal code As String, _
   ByVal rtgCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBillOfMaterialsResourceDetails(
   string token,
   string code,
   string rtgCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBillOfMaterialsResourceDetails(
   String^ token,
   String^ code,
   String^ rtgCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBillOfMaterialsResourceDetails(
    token : String,
    code : String,
    rtgCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

code

Type: string

rtgCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetBillOfMaterialsResources Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBillOfMaterialsResources( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBillOfMaterialsResources(
   string token,
   string itemCode,
   string revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBillOfMaterialsResources(
   String^ token,
   String^ itemCode,
   String^ revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBillOfMaterialsResources(
    token : String,
    itemCode : String,
    revCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetBillOfMaterialsRoutings Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBillOfMaterialsRoutings( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBillOfMaterialsRoutings(
   string token,
   string itemCode,
   string revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBillOfMaterialsRoutings(
   String^ token,
   String^ itemCode,
   String^ revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBillOfMaterialsRoutings(
    token : String,
    itemCode : String,
    revCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetBillOfMaterialsScrap Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBillOfMaterialsScrap( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBillOfMaterialsScrap(
   string token,
   string itemCode,
   string revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBillOfMaterialsScrap(
   String^ token,
   String^ itemCode,
   String^ revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBillOfMaterialsScrap(
    token : String,
    itemCode : String,
    revCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetBomWithDefaultRevisionCode Method

Gets the code of Bill of Materials record for specified item code and its default revision.

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBomWithDefaultRevisionCode( _
   ByVal token As String, _
   ByVal itemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GetBomWithDefaultRevisionCode(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ GetBomWithDefaultRevisionCode(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBomWithDefaultRevisionCode(
    token : String,
    itemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

Token.

itemCode

Type: string

Item code.

Return Value

Type: string

System.String object that represents the code of a Bill of Materials record. If no matching records were found, String.Empty value is returned.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetCoproductSequenceNo Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetCoproductSequenceNo( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String, _
   ByVal coproduct As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetCoproductSequenceNo(
   string token,
   string itemCode,
   string revCode,
   string coproduct
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetCoproductSequenceNo(
   String^ token,
   String^ itemCode,
   String^ revCode,
   String^ coproduct
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetCoproductSequenceNo(
    token : String,
    itemCode : String,
    revCode : String,
    coproduct : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

coproduct

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetCostedMorHeaderCosts Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetCostedMorHeaderCosts( _
   ByVal token As String, _
   ByVal morId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetCostedMorHeaderCosts(
   string token,
   int morId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetCostedMorHeaderCosts(
   String^ token,
   int morId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetCostedMorHeaderCosts(
    token : String,
    morId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

morId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetCostedMorMaterialCosts Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetCostedMorMaterialCosts( _
   ByVal token As String, _
   ByVal morId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetCostedMorMaterialCosts(
   string token,
   int morId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetCostedMorMaterialCosts(
   String^ token,
   int morId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetCostedMorMaterialCosts(
    token : String,
    morId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

morId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetCostedMorResourceCosts Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetCostedMorResourceCosts( _
   ByVal token As String, _
   ByVal documentId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetCostedMorResourceCosts(
   string token,
   int documentId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetCostedMorResourceCosts(
   String^ token,
   int documentId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetCostedMorResourceCosts(
    token : String,
    documentId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

documentId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetCostsComparisonRoutings Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetCostsComparisonRoutings( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revisionCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetCostsComparisonRoutings(
   string token,
   string itemCode,
   string revisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetCostsComparisonRoutings(
   String^ token,
   String^ itemCode,
   String^ revisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetCostsComparisonRoutings(
    token : String,
    itemCode : String,
    revisionCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revisionCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingCoproducts Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingCoproducts( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingCoproducts(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingCoproducts(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingCoproducts(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingDetailCosts Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingDetailCosts( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingDetailCosts(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingDetailCosts(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingDetailCosts(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingFifoItems Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingFifoItems( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingFifoItems(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingFifoItems(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingFifoItems(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingFifoItemsManagedByWarehouse Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingFifoItemsManagedByWarehouse( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingFifoItemsManagedByWarehouse(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingFifoItemsManagedByWarehouse(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingFifoItemsManagedByWarehouse(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingItems Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingItems( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingItems(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingItems(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingItems(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingLastPurchasePriceInSystemCurrency Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingLastPurchasePriceInSystemCurrency( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingLastPurchasePriceInSystemCurrency(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingLastPurchasePriceInSystemCurrency(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingLastPurchasePriceInSystemCurrency(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingOperations Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingOperations( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingOperations(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingOperations(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingOperations(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingPriceListCosts Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingPriceListCosts( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingPriceListCosts(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingPriceListCosts(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingPriceListCosts(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingRawMaterials Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingRawMaterials( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingRawMaterials(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingRawMaterials(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingRawMaterials(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingResourceDetails Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingResourceDetails( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingResourceDetails(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingResourceDetails(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingResourceDetails(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingResourceDetailsCosts Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingResourceDetailsCosts( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingResourceDetailsCosts(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingResourceDetailsCosts(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingResourceDetailsCosts(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingResources Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingResources( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingResources(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingResources(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingResources(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingRolledCosts Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingRolledCosts( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingRolledCosts(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingRolledCosts(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingRolledCosts(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingRoutings Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingRoutings( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingRoutings(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingRoutings(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingRoutings(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingScraps Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingScraps( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingScraps(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingScraps(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingScraps(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingSerialBatchItems Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingSerialBatchItems( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingSerialBatchItems(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingSerialBatchItems(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingSerialBatchItems(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingSerialBatchItemsManagedByWarehouse Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingSerialBatchItemsManagedByWarehouse( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingSerialBatchItemsManagedByWarehouse(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingSerialBatchItemsManagedByWarehouse(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingSerialBatchItemsManagedByWarehouse(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingSerialBatchPrice Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingSerialBatchPrice( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingSerialBatchPrice(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingSerialBatchPrice(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingSerialBatchPrice(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingSerialBatchPriceManagedByWarehouse Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingSerialBatchPriceManagedByWarehouse( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal warehouseCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingSerialBatchPriceManagedByWarehouse(
   string token,
   string itemCode,
   string warehouseCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingSerialBatchPriceManagedByWarehouse(
   String^ token,
   String^ itemCode,
   String^ warehouseCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingSerialBatchPriceManagedByWarehouse(
    token : String,
    itemCode : String,
    warehouseCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

warehouseCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingStandardAndMovingAverageCosts Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingStandardAndMovingAverageCosts( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingStandardAndMovingAverageCosts(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingStandardAndMovingAverageCosts(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingStandardAndMovingAverageCosts(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetDynamicCostingStandardAndMovingAverageCostsManagedByWarehouse Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostingStandardAndMovingAverageCostsManagedByWarehouse( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostingStandardAndMovingAverageCostsManagedByWarehouse(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostingStandardAndMovingAverageCostsManagedByWarehouse(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostingStandardAndMovingAverageCostsManagedByWarehouse(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetFifoPriceWhenNoLayersAreAvailable Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetFifoPriceWhenNoLayersAreAvailable( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetFifoPriceWhenNoLayersAreAvailable(
   string token,
   string itemCode,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetFifoPriceWhenNoLayersAreAvailable(
   String^ token,
   String^ itemCode,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetFifoPriceWhenNoLayersAreAvailable(
    token : String,
    itemCode : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetFifoPriceWhenNoLayersAreAvailableNoWarehouses Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetFifoPriceWhenNoLayersAreAvailableNoWarehouses( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetFifoPriceWhenNoLayersAreAvailableNoWarehouses(
   string token,
   string itemCode,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetFifoPriceWhenNoLayersAreAvailableNoWarehouses(
   String^ token,
   String^ itemCode,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetFifoPriceWhenNoLayersAreAvailableNoWarehouses(
    token : String,
    itemCode : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetFixedVariableValueForItem Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetFixedVariableValueForItem( _
   ByVal token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String, _
   ByVal RevCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetFixedVariableValueForItem(
   string token,
   string ItemCode,
   string WhsCode,
   string RevCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetFixedVariableValueForItem(
   String^ token,
   String^ ItemCode,
   String^ WhsCode,
   String^ RevCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetFixedVariableValueForItem(
    token : String,
    ItemCode : String,
    WhsCode : String,
    RevCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

ItemCode

Type: string

WhsCode

Type: string

RevCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetItemCostByRevisionEx Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemCostByRevisionEx( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String, _
   ByVal RevisionCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemCostByRevisionEx(
   string Token,
   string ItemCode,
   string WhsCode,
   string RevisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemCostByRevisionEx(
   String^ Token,
   String^ ItemCode,
   String^ WhsCode,
   String^ RevisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemCostByRevisionEx(
    Token : String,
    ItemCode : String,
    WhsCode : String,
    RevisionCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

WhsCode

Type: string

RevisionCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetItemCostForCostCategory000 Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemCostForCostCategory000( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemCostForCostCategory000(
   string token,
   string itemCode,
   string revCode,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemCostForCostCategory000(
   String^ token,
   String^ itemCode,
   String^ revCode,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemCostForCostCategory000(
    token : String,
    itemCode : String,
    revCode : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetItemCostingByItemCode Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemCostingByItemCode( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemCostingByItemCode(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemCostingByItemCode(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemCostingByItemCode(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetItemCostingByItemGroupCode Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemCostingByItemGroupCode( _
   ByVal token As String, _
   ByVal group As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemCostingByItemGroupCode(
   string token,
   int group
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemCostingByItemGroupCode(
   String^ token,
   int group
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemCostingByItemGroupCode(
    token : String,
    group : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

group

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetItemCostingDetails Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemCostingDetails( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revisionCode As String, _
   ByVal costCategoryCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemCostingDetails(
   string token,
   string itemCode,
   string revisionCode,
   string costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemCostingDetails(
   String^ token,
   String^ itemCode,
   String^ revisionCode,
   String^ costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemCostingDetails(
    token : String,
    itemCode : String,
    revisionCode : String,
    costCategoryCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revisionCode

Type: string

costCategoryCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetItemCostingPrecisionRestoreData Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemCostingPrecisionRestoreData( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemCostingPrecisionRestoreData(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemCostingPrecisionRestoreData(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemCostingPrecisionRestoreData(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetItemCostingRestoreData Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemCostingRestoreData( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemCostingRestoreData(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemCostingRestoreData(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemCostingRestoreData(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetItemCostingToSynchronize Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemCostingToSynchronize( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemCostingToSynchronize(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemCostingToSynchronize(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemCostingToSynchronize(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetItemCostsEx Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemCostsEx( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemCostsEx(
   string Token,
   string ItemCode,
   string WhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemCostsEx(
   String^ Token,
   String^ ItemCode,
   String^ WhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemCostsEx(
    Token : String,
    ItemCode : String,
    WhsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

WhsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetItemNonDropShipWarehouses Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemNonDropShipWarehouses( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemNonDropShipWarehouses(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemNonDropShipWarehouses(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemNonDropShipWarehouses(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetItemRolledCosts Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemRolledCosts( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revisionCode As String, _
   ByVal costCategoryCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemRolledCosts(
   string token,
   string itemCode,
   string revisionCode,
   string costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemRolledCosts(
   String^ token,
   String^ itemCode,
   String^ revisionCode,
   String^ costCategoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemRolledCosts(
    token : String,
    itemCode : String,
    revisionCode : String,
    costCategoryCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revisionCode

Type: string

costCategoryCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetLastPurchasePriceInSystemCurrency Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetLastPurchasePriceInSystemCurrency( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetLastPurchasePriceInSystemCurrency(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetLastPurchasePriceInSystemCurrency(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetLastPurchasePriceInSystemCurrency(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetLastRolledCostPrecision Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetLastRolledCostPrecision( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String, _
   ByVal costCategory As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetLastRolledCostPrecision(
   string token,
   string itemCode,
   string revCode,
   string costCategory
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetLastRolledCostPrecision(
   String^ token,
   String^ itemCode,
   String^ revCode,
   String^ costCategory
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetLastRolledCostPrecision(
    token : String,
    itemCode : String,
    revCode : String,
    costCategory : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

costCategory

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetLastRolledCostPrecisionWarehouse Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetLastRolledCostPrecisionWarehouse( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String, _
   ByVal costCategory As String, _
   ByVal warehouse As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetLastRolledCostPrecisionWarehouse(
   string token,
   string itemCode,
   string revCode,
   string costCategory,
   string warehouse
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetLastRolledCostPrecisionWarehouse(
   String^ token,
   String^ itemCode,
   String^ revCode,
   String^ costCategory,
   String^ warehouse
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetLastRolledCostPrecisionWarehouse(
    token : String,
    itemCode : String,
    revCode : String,
    costCategory : String,
    warehouse : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

costCategory

Type: string

warehouse

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetLogTableNames Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetLogTableNames( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetLogTableNames(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetLogTableNames(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetLogTableNames(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetNonDropWarehouses Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetNonDropWarehouses( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetNonDropWarehouses(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetNonDropWarehouses(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetNonDropWarehouses(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetPriceListPriceInLocalCurrency Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetPriceListPriceInLocalCurrency( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal priceList As String _
) As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double GetPriceListPriceInLocalCurrency(
   string token,
   string itemCode,
   string priceList
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
double GetPriceListPriceInLocalCurrency(
   String^ token,
   String^ itemCode,
   String^ priceList
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetPriceListPriceInLocalCurrency(
    token : String,
    itemCode : String,
    priceList : String
) : double;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

priceList

Type: string

Return Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetReceiptPriceEx Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetReceiptPriceEx( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String, _
   ByVal RevCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetReceiptPriceEx(
   string Token,
   string ItemCode,
   string WhsCode,
   string RevCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetReceiptPriceEx(
   String^ Token,
   String^ ItemCode,
   String^ WhsCode,
   String^ RevCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetReceiptPriceEx(
    Token : String,
    ItemCode : String,
    WhsCode : String,
    RevCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

WhsCode

Type: string

RevCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetReceiptPriceExForHeader Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetReceiptPriceExForHeader( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String, _
   ByVal RevCode As String, _
   ByVal Routing As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetReceiptPriceExForHeader(
   string Token,
   string ItemCode,
   string WhsCode,
   string RevCode,
   string Routing
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetReceiptPriceExForHeader(
   String^ Token,
   String^ ItemCode,
   String^ WhsCode,
   String^ RevCode,
   String^ Routing
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetReceiptPriceExForHeader(
    Token : String,
    ItemCode : String,
    WhsCode : String,
    RevCode : String,
    Routing : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

WhsCode

Type: string

RevCode

Type: string

Routing

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetResourceCostingRestoreData Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetResourceCostingRestoreData( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetResourceCostingRestoreData(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetResourceCostingRestoreData(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetResourceCostingRestoreData(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetResourceCostingToSynchronize Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetResourceCostingToSynchronize( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetResourceCostingToSynchronize(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetResourceCostingToSynchronize(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetResourceCostingToSynchronize(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetResourceCosts Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetResourceCosts( _
   ByVal Token As String, _
   ByVal RscCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetResourceCosts(
   string Token,
   string RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetResourceCosts(
   String^ Token,
   String^ RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetResourceCosts(
    Token : String,
    RscCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

RscCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRestoreCoproductsData Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRestoreCoproductsData( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRestoreCoproductsData(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRestoreCoproductsData(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRestoreCoproductsData(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRestoreCostingDetailsData Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRestoreCostingDetailsData( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRestoreCostingDetailsData(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRestoreCostingDetailsData(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRestoreCostingDetailsData(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRestoreHeaderData Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRestoreHeaderData( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRestoreHeaderData(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRestoreHeaderData(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRestoreHeaderData(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRestoreHeaderValues Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRestoreHeaderValues( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRestoreHeaderValues(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRestoreHeaderValues(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRestoreHeaderValues(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRestoreItemCostingEntriesToDelete Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRestoreItemCostingEntriesToDelete( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRestoreItemCostingEntriesToDelete(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRestoreItemCostingEntriesToDelete(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRestoreItemCostingEntriesToDelete(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRestoreMaxCostingDetailsLineNoIds Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRestoreMaxCostingDetailsLineNoIds( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRestoreMaxCostingDetailsLineNoIds(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRestoreMaxCostingDetailsLineNoIds(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRestoreMaxCostingDetailsLineNoIds(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRestoreMaxRolledCostsPrecisionLineNoIds Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRestoreMaxRolledCostsPrecisionLineNoIds( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRestoreMaxRolledCostsPrecisionLineNoIds(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRestoreMaxRolledCostsPrecisionLineNoIds(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRestoreMaxRolledCostsPrecisionLineNoIds(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRestoreRolledCostsData Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRestoreRolledCostsData( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRestoreRolledCostsData(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRestoreRolledCostsData(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRestoreRolledCostsData(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRestoreScrapData Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRestoreScrapData( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRestoreScrapData(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRestoreScrapData(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRestoreScrapData(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRollOverItems Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRollOverItems( _
   ByVal token As String, _
   ByVal fromItem As String, _
   ByVal toItem As String, _
   ByVal dumbItem As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRollOverItems(
   string token,
   string fromItem,
   string toItem,
   string dumbItem
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRollOverItems(
   String^ token,
   String^ fromItem,
   String^ toItem,
   String^ dumbItem
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRollOverItems(
    token : String,
    fromItem : String,
    toItem : String,
    dumbItem : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

fromItem

Type: string

toItem

Type: string

dumbItem

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRollOverItemsMatchingGroup Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRollOverItemsMatchingGroup( _
   ByVal token As String, _
   ByVal fromItem As String, _
   ByVal toItem As String, _
   ByVal group As Integer, _
   ByVal dumbItem As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRollOverItemsMatchingGroup(
   string token,
   string fromItem,
   string toItem,
   int group,
   string dumbItem
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRollOverItemsMatchingGroup(
   String^ token,
   String^ fromItem,
   String^ toItem,
   int group,
   String^ dumbItem
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRollOverItemsMatchingGroup(
    token : String,
    fromItem : String,
    toItem : String,
    group : int,
    dumbItem : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

fromItem

Type: string

toItem

Type: string

group

Type: int

dumbItem

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRollOverItemsMatchingGroupAndProperties Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRollOverItemsMatchingGroupAndProperties( _
   ByVal token As String, _
   ByVal fromItem As String, _
   ByVal toItem As String, _
   ByVal group As Integer, _
   ByVal properties As String, _
   ByVal dumbItem As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRollOverItemsMatchingGroupAndProperties(
   string token,
   string fromItem,
   string toItem,
   int group,
   string properties,
   string dumbItem
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRollOverItemsMatchingGroupAndProperties(
   String^ token,
   String^ fromItem,
   String^ toItem,
   int group,
   String^ properties,
   String^ dumbItem
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRollOverItemsMatchingGroupAndProperties(
    token : String,
    fromItem : String,
    toItem : String,
    group : int,
    properties : String,
    dumbItem : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

fromItem

Type: string

toItem

Type: string

group

Type: int

properties

Type: string

dumbItem

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRollOverItemsMatchingProperties Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRollOverItemsMatchingProperties( _
   ByVal token As String, _
   ByVal fromItem As String, _
   ByVal toItem As String, _
   ByVal properties As String, _
   ByVal dumbItem As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRollOverItemsMatchingProperties(
   string token,
   string fromItem,
   string toItem,
   string properties,
   string dumbItem
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRollOverItemsMatchingProperties(
   String^ token,
   String^ fromItem,
   String^ toItem,
   String^ properties,
   String^ dumbItem
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRollOverItemsMatchingProperties(
    token : String,
    fromItem : String,
    toItem : String,
    properties : String,
    dumbItem : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

fromItem

Type: string

toItem

Type: string

properties

Type: string

dumbItem

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRollUpAllowedItems Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRollUpAllowedItems( _
   ByVal token As String, _
   ByVal sqlItems As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRollUpAllowedItems(
   string token,
   string sqlItems
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRollUpAllowedItems(
   String^ token,
   String^ sqlItems
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRollUpAllowedItems(
    token : String,
    sqlItems : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

sqlItems

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRollUpAllowedItems2 Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRollUpAllowedItems2( _
   ByVal token As String, _
   ByVal tablename As String, _
   ByVal connection As DbConnection _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRollUpAllowedItems2(
   string token,
   string tablename,
   DbConnection connection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRollUpAllowedItems2(
   String^ token,
   String^ tablename,
   DbConnection^ connection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRollUpAllowedItems2(
    token : String,
    tablename : String,
    connection : DbConnection
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

tablename

Type: string

connection

Type: DbConnection

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRollUpAllowedSemiGoods Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRollUpAllowedSemiGoods( _
   ByVal token As String, _
   ByVal sqlItems As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRollUpAllowedSemiGoods(
   string token,
   string sqlItems
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRollUpAllowedSemiGoods(
   String^ token,
   String^ sqlItems
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRollUpAllowedSemiGoods(
    token : String,
    sqlItems : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

sqlItems

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRollUpItems Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub GetRollUpItems( _
   ByVal token As String, _
   ByVal fromItem As String, _
   ByVal toItem As String, _
   ByVal tablename As String, _
   ByVal conn As DbConnection _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void GetRollUpItems(
   string token,
   string fromItem,
   string toItem,
   string tablename,
   DbConnection conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void GetRollUpItems(
   String^ token,
   String^ fromItem,
   String^ toItem,
   String^ tablename,
   DbConnection^ conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRollUpItems(
    token : String,
    fromItem : String,
    toItem : String,
    tablename : String,
    conn : DbConnection
);
This language is not supported or no code example is available.

Parameters

token

Type: string

fromItem

Type: string

toItem

Type: string

tablename

Type: string

conn

Type: DbConnection

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRollUpItemsMatchingGroup Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub GetRollUpItemsMatchingGroup( _
   ByVal token As String, _
   ByVal fromItem As String, _
   ByVal toItem As String, _
   ByVal group As Integer, _
   ByVal tablename As String, _
   ByVal conn As DbConnection _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void GetRollUpItemsMatchingGroup(
   string token,
   string fromItem,
   string toItem,
   int group,
   string tablename,
   DbConnection conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void GetRollUpItemsMatchingGroup(
   String^ token,
   String^ fromItem,
   String^ toItem,
   int group,
   String^ tablename,
   DbConnection^ conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRollUpItemsMatchingGroup(
    token : String,
    fromItem : String,
    toItem : String,
    group : int,
    tablename : String,
    conn : DbConnection
);
This language is not supported or no code example is available.

Parameters

token

Type: string

fromItem

Type: string

toItem

Type: string

group

Type: int

tablename

Type: string

conn

Type: DbConnection

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRollUpItemsMatchingGroupAndProperties Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub GetRollUpItemsMatchingGroupAndProperties( _
   ByVal token As String, _
   ByVal fromItem As String, _
   ByVal toItem As String, _
   ByVal group As Integer, _
   ByVal properties As String, _
   ByVal tablename As String, _
   ByVal conn As DbConnection _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void GetRollUpItemsMatchingGroupAndProperties(
   string token,
   string fromItem,
   string toItem,
   int group,
   string properties,
   string tablename,
   DbConnection conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void GetRollUpItemsMatchingGroupAndProperties(
   String^ token,
   String^ fromItem,
   String^ toItem,
   int group,
   String^ properties,
   String^ tablename,
   DbConnection^ conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRollUpItemsMatchingGroupAndProperties(
    token : String,
    fromItem : String,
    toItem : String,
    group : int,
    properties : String,
    tablename : String,
    conn : DbConnection
);
This language is not supported or no code example is available.

Parameters

token

Type: string

fromItem

Type: string

toItem

Type: string

group

Type: int

properties

Type: string

tablename

Type: string

conn

Type: DbConnection

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRollUpItemsMatchingProperties Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub GetRollUpItemsMatchingProperties( _
   ByVal token As String, _
   ByVal fromItem As String, _
   ByVal toItem As String, _
   ByVal properties As String, _
   ByVal tablename As String, _
   ByVal conn As DbConnection _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void GetRollUpItemsMatchingProperties(
   string token,
   string fromItem,
   string toItem,
   string properties,
   string tablename,
   DbConnection conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void GetRollUpItemsMatchingProperties(
   String^ token,
   String^ fromItem,
   String^ toItem,
   String^ properties,
   String^ tablename,
   DbConnection^ conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRollUpItemsMatchingProperties(
    token : String,
    fromItem : String,
    toItem : String,
    properties : String,
    tablename : String,
    conn : DbConnection
);
This language is not supported or no code example is available.

Parameters

token

Type: string

fromItem

Type: string

toItem

Type: string

properties

Type: string

tablename

Type: string

conn

Type: DbConnection

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRollUpOrder Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRollUpOrder( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRollUpOrder(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRollUpOrder(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRollUpOrder(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetRollUpOrderForSapHana Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRollUpOrderForSapHana( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRollUpOrderForSapHana(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRollUpOrderForSapHana(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRollUpOrderForSapHana(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetScrapSequenceNo Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetScrapSequenceNo( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String, _
   ByVal scrap As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetScrapSequenceNo(
   string token,
   string itemCode,
   string revCode,
   string scrap
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetScrapSequenceNo(
   String^ token,
   String^ itemCode,
   String^ revCode,
   String^ scrap
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetScrapSequenceNo(
    token : String,
    itemCode : String,
    revCode : String,
    scrap : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

scrap

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetSerialBatchPrice Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSerialBatchPrice( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSerialBatchPrice(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSerialBatchPrice(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSerialBatchPrice(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetSerialBatchPriceForWarehouse Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSerialBatchPriceForWarehouse( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSerialBatchPriceForWarehouse(
   string token,
   string itemCode,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSerialBatchPriceForWarehouse(
   String^ token,
   String^ itemCode,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSerialBatchPriceForWarehouse(
    token : String,
    itemCode : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetStandardRawMaterialsForRefreshingPrices Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetStandardRawMaterialsForRefreshingPrices( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetStandardRawMaterialsForRefreshingPrices(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetStandardRawMaterialsForRefreshingPrices(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetStandardRawMaterialsForRefreshingPrices(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.GetWarehousesToSynchronize Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetWarehousesToSynchronize( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetWarehousesToSynchronize(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetWarehousesToSynchronize(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetWarehousesToSynchronize(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.ImportItemsDataToTemporaryTable Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function ImportItemsDataToTemporaryTable( _
   ByVal Token As String, _
   ByVal list As List(Of String), _
   ByVal conn As DbConnection _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ImportItemsDataToTemporaryTable(
   string Token,
   List<string> list,
   DbConnection conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ ImportItemsDataToTemporaryTable(
   String^ Token,
   List<String^>^ list,
   DbConnection^ conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

list

Type: List<string>

conn

Type: DbConnection

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.IsRoutingDefaultForRollUp Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function IsRoutingDefaultForRollUp( _
   ByVal token As String, _
   ByVal bomCode As String, _
   ByVal rtgCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset IsRoutingDefaultForRollUp(
   string token,
   string bomCode,
   string rtgCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ IsRoutingDefaultForRollUp(
   String^ token,
   String^ bomCode,
   String^ rtgCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function IsRoutingDefaultForRollUp(
    token : String,
    bomCode : String,
    rtgCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

bomCode

Type: string

rtgCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.ItemCostingExists Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function ItemCostingExists( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String, _
   ByVal costCategory As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset ItemCostingExists(
   string token,
   string itemCode,
   string revCode,
   string costCategory
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ ItemCostingExists(
   String^ token,
   String^ itemCode,
   String^ revCode,
   String^ costCategory
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemCostingExists(
    token : String,
    itemCode : String,
    revCode : String,
    costCategory : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

costCategory

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.PrepareSingleStructureTempTable Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function PrepareSingleStructureTempTable( _
   ByVal Token As String, _
   ByVal connection As DbConnection, _
   ByVal baseItemCode As String, _
   ByVal baseRevisionCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string PrepareSingleStructureTempTable(
   string Token,
   DbConnection connection,
   string baseItemCode,
   string baseRevisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ PrepareSingleStructureTempTable(
   String^ Token,
   DbConnection^ connection,
   String^ baseItemCode,
   String^ baseRevisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function PrepareSingleStructureTempTable(
    Token : String,
    connection : DbConnection,
    baseItemCode : String,
    baseRevisionCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

connection

Type: DbConnection

baseItemCode

Type: string

baseRevisionCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.ResourceCostingExists Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function ResourceCostingExists( _
   ByVal token As String, _
   ByVal rscCode As String, _
   ByVal costCategory As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset ResourceCostingExists(
   string token,
   string rscCode,
   string costCategory
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ ResourceCostingExists(
   String^ token,
   String^ rscCode,
   String^ costCategory
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceCostingExists(
    token : String,
    rscCode : String,
    costCategory : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

rscCode

Type: string

costCategory

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.UpdateAccountCostingOnAllMORs Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function UpdateAccountCostingOnAllMORs( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset UpdateAccountCostingOnAllMORs(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ UpdateAccountCostingOnAllMORs(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UpdateAccountCostingOnAllMORs(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.UpdateAccountCostingOnSpecificMOR Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function UpdateAccountCostingOnSpecificMOR( _
   ByVal token As String, _
   ByVal MORDocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset UpdateAccountCostingOnSpecificMOR(
   string token,
   int MORDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ UpdateAccountCostingOnSpecificMOR(
   String^ token,
   int MORDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UpdateAccountCostingOnSpecificMOR(
    token : String,
    MORDocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

MORDocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingBaseQueries.UpdateItemCostingTypeForCreatedOrDeletedBom Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function UpdateItemCostingTypeForCreatedOrDeletedBom( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revisionCode As String, _
   ByVal isCreating As Boolean _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset UpdateItemCostingTypeForCreatedOrDeletedBom(
   string token,
   string itemCode,
   string revisionCode,
   bool isCreating
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ UpdateItemCostingTypeForCreatedOrDeletedBom(
   String^ token,
   String^ itemCode,
   String^ revisionCode,
   bool isCreating
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UpdateItemCostingTypeForCreatedOrDeletedBom(
    token : String,
    itemCode : String,
    revisionCode : String,
    isCreating : boolean
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revisionCode

Type: string

isCreating

Type: bool

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingBaseQueries Class
CostingBaseQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingSapHanaQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class CostingSapHanaQueries
    Inherits CostingBaseQueries
    Implements ICostingQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CostingSapHanaQueries : CostingBaseQueries,
   ICostingQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class CostingSapHanaQueries : public CostingBaseQueries^,
   public ICostingQueries^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CostingSapHanaQueries
   extends CostingBaseQueries
   implements ICostingQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.CostingQueries.CostingBaseQueries
CompuTec.ProcessForce.API.Queries.CostingQueries.CostingSapHanaQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingSapHanaQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingSapHanaQueries Members

CostingSapHanaQueries Class Methods See Also

The following tables list the members exposed by the CostingSapHanaQueries type.

Methods
 | Name | Description
Public method | BillOfMaterialsExists | (inherited from CostingBaseQueries).
Public method | CallCleanUpProcedure | (inherited from CostingBaseQueries).
Public method | CreateTempItemsTable | (inherited from CostingBaseQueries).
Public method | DetectChangesOnCostingProperties | (inherited from CostingBaseQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | ExtractBillOfMaterials | (inherited from CostingBaseQueries).
Public method | GetActiveCostCategories | (inherited from CostingBaseQueries).
Public method | GetAllSingleStructureItems | (inherited from CostingBaseQueries).
Public method | GetArchiveITC5Table | Gets the name of the log table for CT_PF_ITC5 table. (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialRoutings | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsCoproducts | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsCosts | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsResourceDetails | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsResources | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsRoutings | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsScrap | (inherited from CostingBaseQueries).
Public method | GetBomWithDefaultRevisionCode | Gets the code of Bill of Materials record for specified item code and its default revision. (inherited from CostingBaseQueries).
Public method | GetCoproductSequenceNo | (inherited from CostingBaseQueries).
Public method | GetCostedMorHeaderCosts | (inherited from CostingBaseQueries).
Public method | GetCostedMorMaterialCosts | (inherited from CostingBaseQueries).
Public method | GetCostedMorResourceCosts | (inherited from CostingBaseQueries).
Public method | GetCostsComparisonRoutings | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingCoproducts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingDetailCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingFifoItems | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingFifoItemsManagedByWarehouse | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingItems | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingLastPurchasePriceInSystemCurrency | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingOperations | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingPriceListCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingRawMaterials | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingResourceDetails | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingResourceDetailsCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingResources | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingRolledCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingRoutings | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingScraps | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingSerialBatchItems | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingSerialBatchItemsManagedByWarehouse | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingSerialBatchPrice | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingSerialBatchPriceManagedByWarehouse | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingStandardAndMovingAverageCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingStandardAndMovingAverageCostsManagedByWarehouse | (inherited from CostingBaseQueries).
Public method | GetFifoPriceWhenNoLayersAreAvailable | (inherited from CostingBaseQueries).
Public method | GetFifoPriceWhenNoLayersAreAvailableNoWarehouses | (inherited from CostingBaseQueries).
Public method | GetFixedVariableValueForItem | (inherited from CostingBaseQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemCostByRevisionEx | (inherited from CostingBaseQueries).
Public method | GetItemCostForCostCategory000 | (inherited from CostingBaseQueries).
Public method | GetItemCostingByItemCode | (inherited from CostingBaseQueries).
Public method | GetItemCostingByItemGroupCode | (inherited from CostingBaseQueries).
Public method | GetItemCostingDetails | (inherited from CostingBaseQueries).
Public method | GetItemCostingPrecisionRestoreData | (inherited from CostingBaseQueries).
Public method | GetItemCostingRestoreData | (inherited from CostingBaseQueries).
Public method | GetItemCostingToSynchronize | (inherited from CostingBaseQueries).
Public method | GetItemCostsEx | (inherited from CostingBaseQueries).
Public method | GetItemNonDropShipWarehouses | (inherited from CostingBaseQueries).
Public method | GetItemRolledCosts | (inherited from CostingBaseQueries).
Public method | GetLastPurchasePriceInSystemCurrency | (inherited from CostingBaseQueries).
Public method | GetLastRolledCostPrecision | (inherited from CostingBaseQueries).
Public method | GetLastRolledCostPrecisionWarehouse | (inherited from CostingBaseQueries).
Public method | GetLogTableNames | (inherited from CostingBaseQueries).
Public method | GetNonDropWarehouses | (inherited from CostingBaseQueries).
Public method | GetPriceListPriceInLocalCurrency | (inherited from CostingBaseQueries).
Public method | GetReceiptPriceEx | (inherited from CostingBaseQueries).
Public method | GetReceiptPriceExForHeader | (inherited from CostingBaseQueries).
Public method | GetResourceCostingRestoreData | (inherited from CostingBaseQueries).
Public method | GetResourceCostingToSynchronize | (inherited from CostingBaseQueries).
Public method | GetResourceCosts | (inherited from CostingBaseQueries).
Public method | GetRestoreCoproductsData | (inherited from CostingBaseQueries).
Public method | GetRestoreCostingDetailsData | (inherited from CostingBaseQueries).
Public method | GetRestoreHeaderData | (inherited from CostingBaseQueries).
Public method | GetRestoreHeaderValues | (inherited from CostingBaseQueries).
Public method | GetRestoreItemCostingEntriesToDelete | (inherited from CostingBaseQueries).
Public method | GetRestoreMaxCostingDetailsLineNoIds | (inherited from CostingBaseQueries).
Public method | GetRestoreMaxRolledCostsPrecisionLineNoIds | (inherited from CostingBaseQueries).
Public method | GetRestoreRolledCostsData | (inherited from CostingBaseQueries).
Public method | GetRestoreScrapData | (inherited from CostingBaseQueries).
Public method | GetRollOverItems | (inherited from CostingBaseQueries).
Public method | GetRollOverItemsMatchingGroup | (inherited from CostingBaseQueries).
Public method | GetRollOverItemsMatchingGroupAndProperties | (inherited from CostingBaseQueries).
Public method | GetRollOverItemsMatchingProperties | (inherited from CostingBaseQueries).
Public method | GetRollUpAllowedItems | (inherited from CostingBaseQueries).
Public method | GetRollUpAllowedItems2 | (inherited from CostingBaseQueries).
Public method | GetRollUpAllowedSemiGoods | (inherited from CostingBaseQueries).
Public method | GetRollUpItems | (inherited from CostingBaseQueries).
Public method | GetRollUpItemsMatchingGroup | (inherited from CostingBaseQueries).
Public method | GetRollUpItemsMatchingGroupAndProperties | (inherited from CostingBaseQueries).
Public method | GetRollUpItemsMatchingProperties | (inherited from CostingBaseQueries).
Public method | GetRollUpOrder | (inherited from CostingBaseQueries).
Public method | GetRollUpOrderForSapHana | (inherited from CostingBaseQueries).
Public method | GetScrapSequenceNo | (inherited from CostingBaseQueries).
Public method | GetSerialBatchPrice | (inherited from CostingBaseQueries).
Public method | GetSerialBatchPriceForWarehouse | (inherited from CostingBaseQueries).
Public method | GetStandardRawMaterialsForRefreshingPrices | (inherited from CostingBaseQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetWarehousesToSynchronize | (inherited from CostingBaseQueries).
Public method | ImportItemsDataToTemporaryTable | (inherited from CostingBaseQueries).
Public method | IsRoutingDefaultForRollUp | (inherited from CostingBaseQueries).
Public method | ItemCostingExists | (inherited from CostingBaseQueries).
Public method | PrepareSingleStructureTempTable | (inherited from CostingBaseQueries).
Public method | ResourceCostingExists | (inherited from CostingBaseQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateAccountCostingOnAllMORs | (inherited from CostingBaseQueries).
Public method | UpdateAccountCostingOnSpecificMOR | (inherited from CostingBaseQueries).
Public method | UpdateItemCostingTypeForCreatedOrDeletedBom | (inherited from CostingBaseQueries).
Top
See Also

Reference

CostingSapHanaQueries Class
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingSapHanaQueries Methods

CostingSapHanaQueries Class See Also

The following tables list the members exposed by the CostingSapHanaQueries type.

Methods
 | Name | Description
Public method | BillOfMaterialsExists | (inherited from CostingBaseQueries).
Public method | CallCleanUpProcedure | (inherited from CostingBaseQueries).
Public method | CreateTempItemsTable | (inherited from CostingBaseQueries).
Public method | DetectChangesOnCostingProperties | (inherited from CostingBaseQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | ExtractBillOfMaterials | (inherited from CostingBaseQueries).
Public method | GetActiveCostCategories | (inherited from CostingBaseQueries).
Public method | GetAllSingleStructureItems | (inherited from CostingBaseQueries).
Public method | GetArchiveITC5Table | Gets the name of the log table for CT_PF_ITC5 table. (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialRoutings | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsCoproducts | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsCosts | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsResourceDetails | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsResources | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsRoutings | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsScrap | (inherited from CostingBaseQueries).
Public method | GetBomWithDefaultRevisionCode | Gets the code of Bill of Materials record for specified item code and its default revision. (inherited from CostingBaseQueries).
Public method | GetCoproductSequenceNo | (inherited from CostingBaseQueries).
Public method | GetCostedMorHeaderCosts | (inherited from CostingBaseQueries).
Public method | GetCostedMorMaterialCosts | (inherited from CostingBaseQueries).
Public method | GetCostedMorResourceCosts | (inherited from CostingBaseQueries).
Public method | GetCostsComparisonRoutings | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingCoproducts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingDetailCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingFifoItems | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingFifoItemsManagedByWarehouse | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingItems | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingLastPurchasePriceInSystemCurrency | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingOperations | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingPriceListCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingRawMaterials | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingResourceDetails | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingResourceDetailsCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingResources | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingRolledCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingRoutings | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingScraps | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingSerialBatchItems | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingSerialBatchItemsManagedByWarehouse | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingSerialBatchPrice | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingSerialBatchPriceManagedByWarehouse | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingStandardAndMovingAverageCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingStandardAndMovingAverageCostsManagedByWarehouse | (inherited from CostingBaseQueries).
Public method | GetFifoPriceWhenNoLayersAreAvailable | (inherited from CostingBaseQueries).
Public method | GetFifoPriceWhenNoLayersAreAvailableNoWarehouses | (inherited from CostingBaseQueries).
Public method | GetFixedVariableValueForItem | (inherited from CostingBaseQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemCostByRevisionEx | (inherited from CostingBaseQueries).
Public method | GetItemCostForCostCategory000 | (inherited from CostingBaseQueries).
Public method | GetItemCostingByItemCode | (inherited from CostingBaseQueries).
Public method | GetItemCostingByItemGroupCode | (inherited from CostingBaseQueries).
Public method | GetItemCostingDetails | (inherited from CostingBaseQueries).
Public method | GetItemCostingPrecisionRestoreData | (inherited from CostingBaseQueries).
Public method | GetItemCostingRestoreData | (inherited from CostingBaseQueries).
Public method | GetItemCostingToSynchronize | (inherited from CostingBaseQueries).
Public method | GetItemCostsEx | (inherited from CostingBaseQueries).
Public method | GetItemNonDropShipWarehouses | (inherited from CostingBaseQueries).
Public method | GetItemRolledCosts | (inherited from CostingBaseQueries).
Public method | GetLastPurchasePriceInSystemCurrency | (inherited from CostingBaseQueries).
Public method | GetLastRolledCostPrecision | (inherited from CostingBaseQueries).
Public method | GetLastRolledCostPrecisionWarehouse | (inherited from CostingBaseQueries).
Public method | GetLogTableNames | (inherited from CostingBaseQueries).
Public method | GetNonDropWarehouses | (inherited from CostingBaseQueries).
Public method | GetPriceListPriceInLocalCurrency | (inherited from CostingBaseQueries).
Public method | GetReceiptPriceEx | (inherited from CostingBaseQueries).
Public method | GetReceiptPriceExForHeader | (inherited from CostingBaseQueries).
Public method | GetResourceCostingRestoreData | (inherited from CostingBaseQueries).
Public method | GetResourceCostingToSynchronize | (inherited from CostingBaseQueries).
Public method | GetResourceCosts | (inherited from CostingBaseQueries).
Public method | GetRestoreCoproductsData | (inherited from CostingBaseQueries).
Public method | GetRestoreCostingDetailsData | (inherited from CostingBaseQueries).
Public method | GetRestoreHeaderData | (inherited from CostingBaseQueries).
Public method | GetRestoreHeaderValues | (inherited from CostingBaseQueries).
Public method | GetRestoreItemCostingEntriesToDelete | (inherited from CostingBaseQueries).
Public method | GetRestoreMaxCostingDetailsLineNoIds | (inherited from CostingBaseQueries).
Public method | GetRestoreMaxRolledCostsPrecisionLineNoIds | (inherited from CostingBaseQueries).
Public method | GetRestoreRolledCostsData | (inherited from CostingBaseQueries).
Public method | GetRestoreScrapData | (inherited from CostingBaseQueries).
Public method | GetRollOverItems | (inherited from CostingBaseQueries).
Public method | GetRollOverItemsMatchingGroup | (inherited from CostingBaseQueries).
Public method | GetRollOverItemsMatchingGroupAndProperties | (inherited from CostingBaseQueries).
Public method | GetRollOverItemsMatchingProperties | (inherited from CostingBaseQueries).
Public method | GetRollUpAllowedItems | (inherited from CostingBaseQueries).
Public method | GetRollUpAllowedItems2 | (inherited from CostingBaseQueries).
Public method | GetRollUpAllowedSemiGoods | (inherited from CostingBaseQueries).
Public method | GetRollUpItems | (inherited from CostingBaseQueries).
Public method | GetRollUpItemsMatchingGroup | (inherited from CostingBaseQueries).
Public method | GetRollUpItemsMatchingGroupAndProperties | (inherited from CostingBaseQueries).
Public method | GetRollUpItemsMatchingProperties | (inherited from CostingBaseQueries).
Public method | GetRollUpOrder | (inherited from CostingBaseQueries).
Public method | GetRollUpOrderForSapHana | (inherited from CostingBaseQueries).
Public method | GetScrapSequenceNo | (inherited from CostingBaseQueries).
Public method | GetSerialBatchPrice | (inherited from CostingBaseQueries).
Public method | GetSerialBatchPriceForWarehouse | (inherited from CostingBaseQueries).
Public method | GetStandardRawMaterialsForRefreshingPrices | (inherited from CostingBaseQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetWarehousesToSynchronize | (inherited from CostingBaseQueries).
Public method | ImportItemsDataToTemporaryTable | (inherited from CostingBaseQueries).
Public method | IsRoutingDefaultForRollUp | (inherited from CostingBaseQueries).
Public method | ItemCostingExists | (inherited from CostingBaseQueries).
Public method | PrepareSingleStructureTempTable | (inherited from CostingBaseQueries).
Public method | ResourceCostingExists | (inherited from CostingBaseQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateAccountCostingOnAllMORs | (inherited from CostingBaseQueries).
Public method | UpdateAccountCostingOnSpecificMOR | (inherited from CostingBaseQueries).
Public method | UpdateItemCostingTypeForCreatedOrDeletedBom | (inherited from CostingBaseQueries).
Top
See Also

Reference

CostingSapHanaQueries Class
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingSqlServerQuerties Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class CostingSqlServerQuerties
    Inherits CostingBaseQueries
    Implements ICostingQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CostingSqlServerQuerties : CostingBaseQueries,
   ICostingQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class CostingSqlServerQuerties : public CostingBaseQueries^,
   public ICostingQueries^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CostingSqlServerQuerties
   extends CostingBaseQueries
   implements ICostingQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.CostingQueries.CostingBaseQueries
CompuTec.ProcessForce.API.Queries.CostingQueries.CostingSqlServerQuerties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostingSqlServerQuerties Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingSqlServerQuerties Members

CostingSqlServerQuerties Class Methods See Also

The following tables list the members exposed by the CostingSqlServerQuerties type.

Methods
 | Name | Description
Public method | BillOfMaterialsExists | (inherited from CostingBaseQueries).
Public method | CallCleanUpProcedure | (inherited from CostingBaseQueries).
Public method | CreateTempItemsTable | (inherited from CostingBaseQueries).
Public method | DetectChangesOnCostingProperties | (inherited from CostingBaseQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | ExtractBillOfMaterials | (inherited from CostingBaseQueries).
Public method | GetActiveCostCategories | (inherited from CostingBaseQueries).
Public method | GetAllSingleStructureItems | (inherited from CostingBaseQueries).
Public method | GetArchiveITC5Table | Gets the name of the log table for CT_PF_ITC5 table. (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialRoutings | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsCoproducts | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsCosts | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsResourceDetails | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsResources | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsRoutings | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsScrap | (inherited from CostingBaseQueries).
Public method | GetBomWithDefaultRevisionCode | Gets the code of Bill of Materials record for specified item code and its default revision. (inherited from CostingBaseQueries).
Public method | GetCoproductSequenceNo | (inherited from CostingBaseQueries).
Public method | GetCostedMorHeaderCosts | (inherited from CostingBaseQueries).
Public method | GetCostedMorMaterialCosts | (inherited from CostingBaseQueries).
Public method | GetCostedMorResourceCosts | (inherited from CostingBaseQueries).
Public method | GetCostsComparisonRoutings | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingCoproducts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingDetailCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingFifoItems | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingFifoItemsManagedByWarehouse | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingItems | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingLastPurchasePriceInSystemCurrency | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingOperations | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingPriceListCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingRawMaterials | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingResourceDetails | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingResourceDetailsCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingResources | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingRolledCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingRoutings | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingScraps | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingSerialBatchItems | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingSerialBatchItemsManagedByWarehouse | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingSerialBatchPrice | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingSerialBatchPriceManagedByWarehouse | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingStandardAndMovingAverageCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingStandardAndMovingAverageCostsManagedByWarehouse | (inherited from CostingBaseQueries).
Public method | GetFifoPriceWhenNoLayersAreAvailable | (inherited from CostingBaseQueries).
Public method | GetFifoPriceWhenNoLayersAreAvailableNoWarehouses | (inherited from CostingBaseQueries).
Public method | GetFixedVariableValueForItem | (inherited from CostingBaseQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemCostByRevisionEx | (inherited from CostingBaseQueries).
Public method | GetItemCostForCostCategory000 | (inherited from CostingBaseQueries).
Public method | GetItemCostingByItemCode | (inherited from CostingBaseQueries).
Public method | GetItemCostingByItemGroupCode | (inherited from CostingBaseQueries).
Public method | GetItemCostingDetails | (inherited from CostingBaseQueries).
Public method | GetItemCostingPrecisionRestoreData | (inherited from CostingBaseQueries).
Public method | GetItemCostingRestoreData | (inherited from CostingBaseQueries).
Public method | GetItemCostingToSynchronize | (inherited from CostingBaseQueries).
Public method | GetItemCostsEx | (inherited from CostingBaseQueries).
Public method | GetItemNonDropShipWarehouses | (inherited from CostingBaseQueries).
Public method | GetItemRolledCosts | (inherited from CostingBaseQueries).
Public method | GetLastPurchasePriceInSystemCurrency | (inherited from CostingBaseQueries).
Public method | GetLastRolledCostPrecision | (inherited from CostingBaseQueries).
Public method | GetLastRolledCostPrecisionWarehouse | (inherited from CostingBaseQueries).
Public method | GetLogTableNames | (inherited from CostingBaseQueries).
Public method | GetNonDropWarehouses | (inherited from CostingBaseQueries).
Public method | GetPriceListPriceInLocalCurrency | (inherited from CostingBaseQueries).
Public method | GetReceiptPriceEx | (inherited from CostingBaseQueries).
Public method | GetReceiptPriceExForHeader | (inherited from CostingBaseQueries).
Public method | GetResourceCostingRestoreData | (inherited from CostingBaseQueries).
Public method | GetResourceCostingToSynchronize | (inherited from CostingBaseQueries).
Public method | GetResourceCosts | (inherited from CostingBaseQueries).
Public method | GetRestoreCoproductsData | (inherited from CostingBaseQueries).
Public method | GetRestoreCostingDetailsData | (inherited from CostingBaseQueries).
Public method | GetRestoreHeaderData | (inherited from CostingBaseQueries).
Public method | GetRestoreHeaderValues | (inherited from CostingBaseQueries).
Public method | GetRestoreItemCostingEntriesToDelete | (inherited from CostingBaseQueries).
Public method | GetRestoreMaxCostingDetailsLineNoIds | (inherited from CostingBaseQueries).
Public method | GetRestoreMaxRolledCostsPrecisionLineNoIds | (inherited from CostingBaseQueries).
Public method | GetRestoreRolledCostsData | (inherited from CostingBaseQueries).
Public method | GetRestoreScrapData | (inherited from CostingBaseQueries).
Public method | GetRollOverItems | (inherited from CostingBaseQueries).
Public method | GetRollOverItemsMatchingGroup | (inherited from CostingBaseQueries).
Public method | GetRollOverItemsMatchingGroupAndProperties | (inherited from CostingBaseQueries).
Public method | GetRollOverItemsMatchingProperties | (inherited from CostingBaseQueries).
Public method | GetRollUpAllowedItems | (inherited from CostingBaseQueries).
Public method | GetRollUpAllowedItems2 | (inherited from CostingBaseQueries).
Public method | GetRollUpAllowedSemiGoods | (inherited from CostingBaseQueries).
Public method | GetRollUpItems | (inherited from CostingBaseQueries).
Public method | GetRollUpItemsMatchingGroup | (inherited from CostingBaseQueries).
Public method | GetRollUpItemsMatchingGroupAndProperties | (inherited from CostingBaseQueries).
Public method | GetRollUpItemsMatchingProperties | (inherited from CostingBaseQueries).
Public method | GetRollUpOrder | (inherited from CostingBaseQueries).
Public method | GetRollUpOrderForSapHana | (inherited from CostingBaseQueries).
Public method | GetScrapSequenceNo | (inherited from CostingBaseQueries).
Public method | GetSerialBatchPrice | (inherited from CostingBaseQueries).
Public method | GetSerialBatchPriceForWarehouse | (inherited from CostingBaseQueries).
Public method | GetStandardRawMaterialsForRefreshingPrices | (inherited from CostingBaseQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetWarehousesToSynchronize | (inherited from CostingBaseQueries).
Public method | ImportItemsDataToTemporaryTable | (inherited from CostingBaseQueries).
Public method | IsRoutingDefaultForRollUp | (inherited from CostingBaseQueries).
Public method | ItemCostingExists | (inherited from CostingBaseQueries).
Public method | PrepareSingleStructureTempTable | (inherited from CostingBaseQueries).
Public method | ResourceCostingExists | (inherited from CostingBaseQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateAccountCostingOnAllMORs | (inherited from CostingBaseQueries).
Public method | UpdateAccountCostingOnSpecificMOR | (inherited from CostingBaseQueries).
Public method | UpdateItemCostingTypeForCreatedOrDeletedBom | (inherited from CostingBaseQueries).
Top
See Also

Reference

CostingSqlServerQuerties Class
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CostingSqlServerQuerties Methods

CostingSqlServerQuerties Class See Also

The following tables list the members exposed by the CostingSqlServerQuerties type.

Methods
 | Name | Description
Public method | BillOfMaterialsExists | (inherited from CostingBaseQueries).
Public method | CallCleanUpProcedure | (inherited from CostingBaseQueries).
Public method | CreateTempItemsTable | (inherited from CostingBaseQueries).
Public method | DetectChangesOnCostingProperties | (inherited from CostingBaseQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | ExtractBillOfMaterials | (inherited from CostingBaseQueries).
Public method | GetActiveCostCategories | (inherited from CostingBaseQueries).
Public method | GetAllSingleStructureItems | (inherited from CostingBaseQueries).
Public method | GetArchiveITC5Table | Gets the name of the log table for CT_PF_ITC5 table. (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialRoutings | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsCoproducts | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsCosts | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsResourceDetails | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsResources | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsRoutings | (inherited from CostingBaseQueries).
Public method | GetBillOfMaterialsScrap | (inherited from CostingBaseQueries).
Public method | GetBomWithDefaultRevisionCode | Gets the code of Bill of Materials record for specified item code and its default revision. (inherited from CostingBaseQueries).
Public method | GetCoproductSequenceNo | (inherited from CostingBaseQueries).
Public method | GetCostedMorHeaderCosts | (inherited from CostingBaseQueries).
Public method | GetCostedMorMaterialCosts | (inherited from CostingBaseQueries).
Public method | GetCostedMorResourceCosts | (inherited from CostingBaseQueries).
Public method | GetCostsComparisonRoutings | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingCoproducts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingDetailCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingFifoItems | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingFifoItemsManagedByWarehouse | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingItems | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingLastPurchasePriceInSystemCurrency | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingOperations | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingPriceListCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingRawMaterials | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingResourceDetails | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingResourceDetailsCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingResources | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingRolledCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingRoutings | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingScraps | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingSerialBatchItems | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingSerialBatchItemsManagedByWarehouse | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingSerialBatchPrice | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingSerialBatchPriceManagedByWarehouse | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingStandardAndMovingAverageCosts | (inherited from CostingBaseQueries).
Public method | GetDynamicCostingStandardAndMovingAverageCostsManagedByWarehouse | (inherited from CostingBaseQueries).
Public method | GetFifoPriceWhenNoLayersAreAvailable | (inherited from CostingBaseQueries).
Public method | GetFifoPriceWhenNoLayersAreAvailableNoWarehouses | (inherited from CostingBaseQueries).
Public method | GetFixedVariableValueForItem | (inherited from CostingBaseQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemCostByRevisionEx | (inherited from CostingBaseQueries).
Public method | GetItemCostForCostCategory000 | (inherited from CostingBaseQueries).
Public method | GetItemCostingByItemCode | (inherited from CostingBaseQueries).
Public method | GetItemCostingByItemGroupCode | (inherited from CostingBaseQueries).
Public method | GetItemCostingDetails | (inherited from CostingBaseQueries).
Public method | GetItemCostingPrecisionRestoreData | (inherited from CostingBaseQueries).
Public method | GetItemCostingRestoreData | (inherited from CostingBaseQueries).
Public method | GetItemCostingToSynchronize | (inherited from CostingBaseQueries).
Public method | GetItemCostsEx | (inherited from CostingBaseQueries).
Public method | GetItemNonDropShipWarehouses | (inherited from CostingBaseQueries).
Public method | GetItemRolledCosts | (inherited from CostingBaseQueries).
Public method | GetLastPurchasePriceInSystemCurrency | (inherited from CostingBaseQueries).
Public method | GetLastRolledCostPrecision | (inherited from CostingBaseQueries).
Public method | GetLastRolledCostPrecisionWarehouse | (inherited from CostingBaseQueries).
Public method | GetLogTableNames | (inherited from CostingBaseQueries).
Public method | GetNonDropWarehouses | (inherited from CostingBaseQueries).
Public method | GetPriceListPriceInLocalCurrency | (inherited from CostingBaseQueries).
Public method | GetReceiptPriceEx | (inherited from CostingBaseQueries).
Public method | GetReceiptPriceExForHeader | (inherited from CostingBaseQueries).
Public method | GetResourceCostingRestoreData | (inherited from CostingBaseQueries).
Public method | GetResourceCostingToSynchronize | (inherited from CostingBaseQueries).
Public method | GetResourceCosts | (inherited from CostingBaseQueries).
Public method | GetRestoreCoproductsData | (inherited from CostingBaseQueries).
Public method | GetRestoreCostingDetailsData | (inherited from CostingBaseQueries).
Public method | GetRestoreHeaderData | (inherited from CostingBaseQueries).
Public method | GetRestoreHeaderValues | (inherited from CostingBaseQueries).
Public method | GetRestoreItemCostingEntriesToDelete | (inherited from CostingBaseQueries).
Public method | GetRestoreMaxCostingDetailsLineNoIds | (inherited from CostingBaseQueries).
Public method | GetRestoreMaxRolledCostsPrecisionLineNoIds | (inherited from CostingBaseQueries).
Public method | GetRestoreRolledCostsData | (inherited from CostingBaseQueries).
Public method | GetRestoreScrapData | (inherited from CostingBaseQueries).
Public method | GetRollOverItems | (inherited from CostingBaseQueries).
Public method | GetRollOverItemsMatchingGroup | (inherited from CostingBaseQueries).
Public method | GetRollOverItemsMatchingGroupAndProperties | (inherited from CostingBaseQueries).
Public method | GetRollOverItemsMatchingProperties | (inherited from CostingBaseQueries).
Public method | GetRollUpAllowedItems | (inherited from CostingBaseQueries).
Public method | GetRollUpAllowedItems2 | (inherited from CostingBaseQueries).
Public method | GetRollUpAllowedSemiGoods | (inherited from CostingBaseQueries).
Public method | GetRollUpItems | (inherited from CostingBaseQueries).
Public method | GetRollUpItemsMatchingGroup | (inherited from CostingBaseQueries).
Public method | GetRollUpItemsMatchingGroupAndProperties | (inherited from CostingBaseQueries).
Public method | GetRollUpItemsMatchingProperties | (inherited from CostingBaseQueries).
Public method | GetRollUpOrder | (inherited from CostingBaseQueries).
Public method | GetRollUpOrderForSapHana | (inherited from CostingBaseQueries).
Public method | GetScrapSequenceNo | (inherited from CostingBaseQueries).
Public method | GetSerialBatchPrice | (inherited from CostingBaseQueries).
Public method | GetSerialBatchPriceForWarehouse | (inherited from CostingBaseQueries).
Public method | GetStandardRawMaterialsForRefreshingPrices | (inherited from CostingBaseQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetWarehousesToSynchronize | (inherited from CostingBaseQueries).
Public method | ImportItemsDataToTemporaryTable | (inherited from CostingBaseQueries).
Public method | IsRoutingDefaultForRollUp | (inherited from CostingBaseQueries).
Public method | ItemCostingExists | (inherited from CostingBaseQueries).
Public method | PrepareSingleStructureTempTable | (inherited from CostingBaseQueries).
Public method | ResourceCostingExists | (inherited from CostingBaseQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateAccountCostingOnAllMORs | (inherited from CostingBaseQueries).
Public method | UpdateAccountCostingOnSpecificMOR | (inherited from CostingBaseQueries).
Public method | UpdateItemCostingTypeForCreatedOrDeletedBom | (inherited from CostingBaseQueries).
Top
See Also

Reference

CostingSqlServerQuerties Class
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ICostingQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICostingQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ICostingQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICostingQueries
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries Members

ICostingQueries Interface Methods See Also

The following tables list the members exposed by the ICostingQueries type.

Methods
 | Name | Description
Public method | CallCleanUpProcedure |
Public method | CreateTempItemsTable |
Public method | ExtractBillOfMaterials |
Public method | GetAllSingleStructureItems |
Public method | GetFixedVariableValueForItem |
Public method | GetItemCostByRevisionEx |
Public method | GetItemCostsEx | Obsolete. T0.U_ATLFixOH, T0.U_ATLVarOH, T0.U_ATLMaterial, T0.U_TCResources
Public method | GetReceiptPriceEx |
Public method | GetReceiptPriceExForHeader | U_TCToTal
Public method | GetResourceCosts |
Public method | GetRollUpAllowedItems2 |
Public method | GetRollUpItems |
Public method | GetRollUpItemsMatchingGroup |
Public method | GetRollUpItemsMatchingGroupAndProperties |
Public method | GetRollUpItemsMatchingProperties |
Public method | ImportItemsDataToTemporaryTable |
Public method | PrepareSingleStructureTempTable |
Public method | UpdateAccountCostingOnAllMORs |
Public method | UpdateAccountCostingOnSpecificMOR |
Top
See Also

Reference

ICostingQueries Interface
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries Methods

ICostingQueries Interface See Also

The following tables list the members exposed by the ICostingQueries type.

Methods
 | Name | Description
Public method | CallCleanUpProcedure |
Public method | CreateTempItemsTable |
Public method | ExtractBillOfMaterials |
Public method | GetAllSingleStructureItems |
Public method | GetFixedVariableValueForItem |
Public method | GetItemCostByRevisionEx |
Public method | GetItemCostsEx | Obsolete. T0.U_ATLFixOH, T0.U_ATLVarOH, T0.U_ATLMaterial, T0.U_TCResources
Public method | GetReceiptPriceEx |
Public method | GetReceiptPriceExForHeader | U_TCToTal
Public method | GetResourceCosts |
Public method | GetRollUpAllowedItems2 |
Public method | GetRollUpItems |
Public method | GetRollUpItemsMatchingGroup |
Public method | GetRollUpItemsMatchingGroupAndProperties |
Public method | GetRollUpItemsMatchingProperties |
Public method | ImportItemsDataToTemporaryTable |
Public method | PrepareSingleStructureTempTable |
Public method | UpdateAccountCostingOnAllMORs |
Public method | UpdateAccountCostingOnSpecificMOR |
Top
See Also

Reference

ICostingQueries Interface
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries.CallCleanUpProcedure Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub CallCleanUpProcedure( _
   ByVal Token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void CallCleanUpProcedure(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void CallCleanUpProcedure(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CallCleanUpProcedure(
    Token : String
);
This language is not supported or no code example is available.

Parameters

Token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Interface
ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries.CreateTempItemsTable Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub CreateTempItemsTable( _
   ByVal Token As String, _
   ByVal tableName As String, _
   ByVal connection As DbConnection _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void CreateTempItemsTable(
   string Token,
   string tableName,
   DbConnection connection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void CreateTempItemsTable(
   String^ Token,
   String^ tableName,
   DbConnection^ connection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CreateTempItemsTable(
    Token : String,
    tableName : String,
    connection : DbConnection
);
This language is not supported or no code example is available.

Parameters

Token

Type: string

tableName

Type: string

connection

Type: DbConnection

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Interface
ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries.ExtractBillOfMaterials Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function ExtractBillOfMaterials( _
   ByVal Token As String, _
   ByVal tableName As String, _
   ByVal connection As DbConnection _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset ExtractBillOfMaterials(
   string Token,
   string tableName,
   DbConnection connection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ ExtractBillOfMaterials(
   String^ Token,
   String^ tableName,
   DbConnection^ connection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function ExtractBillOfMaterials(
    Token : String,
    tableName : String,
    connection : DbConnection
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

tableName

Type: string

connection

Type: DbConnection

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Interface
ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries.GetAllSingleStructureItems Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAllSingleStructureItems( _
   ByVal Tokem As String, _
   ByVal connection As DbConnection, _
   ByVal SingleStructureTempTable As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetAllSingleStructureItems(
   string Tokem,
   DbConnection connection,
   string SingleStructureTempTable
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetAllSingleStructureItems(
   String^ Tokem,
   DbConnection^ connection,
   String^ SingleStructureTempTable
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetAllSingleStructureItems(
    Tokem : String,
    connection : DbConnection,
    SingleStructureTempTable : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Tokem

Type: string

connection

Type: DbConnection

SingleStructureTempTable

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Interface
ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries.GetFixedVariableValueForItem Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetFixedVariableValueForItem( _
   ByVal token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String, _
   ByVal RevCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetFixedVariableValueForItem(
   string token,
   string ItemCode,
   string WhsCode,
   string RevCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetFixedVariableValueForItem(
   String^ token,
   String^ ItemCode,
   String^ WhsCode,
   String^ RevCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetFixedVariableValueForItem(
    token : String,
    ItemCode : String,
    WhsCode : String,
    RevCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

ItemCode

Type: string

WhsCode

Type: string

RevCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Interface
ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries.GetItemCostByRevisionEx Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetItemCostByRevisionEx( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String, _
   ByVal RevisionCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetItemCostByRevisionEx(
   string Token,
   string ItemCode,
   string WhsCode,
   string RevisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetItemCostByRevisionEx(
   String^ Token,
   String^ ItemCode,
   String^ WhsCode,
   String^ RevisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetItemCostByRevisionEx(
    Token : String,
    ItemCode : String,
    WhsCode : String,
    RevisionCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

WhsCode

Type: string

RevisionCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Interface
ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries.GetItemCostsEx Method

NOTE: This member is now obsolete. Please use get costing with Revision - GetItemCostByRevisionEx(...)

T0.U_ATLFixOH, T0.U_ATLVarOH, T0.U_ATLMaterial, T0.U_TCResources

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Obsolete("Please use get costing with Revision - GetItemCostByRevisionEx(...)")> _
Function GetItemCostsEx( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete("Please use get costing with Revision - GetItemCostByRevisionEx(...)")]
CTRecordset GetItemCostsEx(
   string Token,
   string ItemCode,
   string WhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete("Please use get costing with Revision - GetItemCostByRevisionEx(...)")]

CTRecordset^ GetItemCostsEx(
   String^ Token,
   String^ ItemCode,
   String^ WhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   Obsolete("Please use get costing with Revision - GetItemCostByRevisionEx(...)")
function GetItemCostsEx(
    Token : String,
    ItemCode : String,
    WhsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

WhsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Interface
ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries.GetReceiptPriceEx Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetReceiptPriceEx( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String, _
   ByVal revCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetReceiptPriceEx(
   string Token,
   string ItemCode,
   string WhsCode,
   string revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetReceiptPriceEx(
   String^ Token,
   String^ ItemCode,
   String^ WhsCode,
   String^ revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetReceiptPriceEx(
    Token : String,
    ItemCode : String,
    WhsCode : String,
    revCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

WhsCode

Type: string

revCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Interface
ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries.GetReceiptPriceExForHeader Method

U_TCToTal

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetReceiptPriceExForHeader( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String, _
   ByVal RevCode As String, _
   ByVal Routing As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetReceiptPriceExForHeader(
   string Token,
   string ItemCode,
   string WhsCode,
   string RevCode,
   string Routing
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetReceiptPriceExForHeader(
   String^ Token,
   String^ ItemCode,
   String^ WhsCode,
   String^ RevCode,
   String^ Routing
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetReceiptPriceExForHeader(
    Token : String,
    ItemCode : String,
    WhsCode : String,
    RevCode : String,
    Routing : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

WhsCode

Type: string

RevCode

Type: string

Routing

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Interface
ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries.GetResourceCosts Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetResourceCosts( _
   ByVal Token As String, _
   ByVal RscCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetResourceCosts(
   string Token,
   string RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetResourceCosts(
   String^ Token,
   String^ RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetResourceCosts(
    Token : String,
    RscCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

RscCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Interface
ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries.GetRollUpAllowedItems2 Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetRollUpAllowedItems2( _
   ByVal token As String, _
   ByVal tablename As String, _
   ByVal connection As DbConnection _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetRollUpAllowedItems2(
   string token,
   string tablename,
   DbConnection connection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetRollUpAllowedItems2(
   String^ token,
   String^ tablename,
   DbConnection^ connection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetRollUpAllowedItems2(
    token : String,
    tablename : String,
    connection : DbConnection
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

tablename

Type: string

connection

Type: DbConnection

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Interface
ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries.GetRollUpItems Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub GetRollUpItems( _
   ByVal token As String, _
   ByVal fromItem As String, _
   ByVal toItem As String, _
   ByVal tablename As String, _
   ByVal conn As DbConnection _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void GetRollUpItems(
   string token,
   string fromItem,
   string toItem,
   string tablename,
   DbConnection conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void GetRollUpItems(
   String^ token,
   String^ fromItem,
   String^ toItem,
   String^ tablename,
   DbConnection^ conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetRollUpItems(
    token : String,
    fromItem : String,
    toItem : String,
    tablename : String,
    conn : DbConnection
);
This language is not supported or no code example is available.

Parameters

token

Type: string

fromItem

Type: string

toItem

Type: string

tablename

Type: string

conn

Type: DbConnection

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Interface
ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries.GetRollUpItemsMatchingGroup Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub GetRollUpItemsMatchingGroup( _
   ByVal token As String, _
   ByVal fromItem As String, _
   ByVal toItem As String, _
   ByVal group As Integer, _
   ByVal tablename As String, _
   ByVal conn As DbConnection _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void GetRollUpItemsMatchingGroup(
   string token,
   string fromItem,
   string toItem,
   int group,
   string tablename,
   DbConnection conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void GetRollUpItemsMatchingGroup(
   String^ token,
   String^ fromItem,
   String^ toItem,
   int group,
   String^ tablename,
   DbConnection^ conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetRollUpItemsMatchingGroup(
    token : String,
    fromItem : String,
    toItem : String,
    group : int,
    tablename : String,
    conn : DbConnection
);
This language is not supported or no code example is available.

Parameters

token

Type: string

fromItem

Type: string

toItem

Type: string

group

Type: int

tablename

Type: string

conn

Type: DbConnection

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Interface
ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries.GetRollUpItemsMatchingGroupAndProperties Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub GetRollUpItemsMatchingGroupAndProperties( _
   ByVal token As String, _
   ByVal fromItem As String, _
   ByVal toItem As String, _
   ByVal group As Integer, _
   ByVal properties As String, _
   ByVal tablename As String, _
   ByVal conn As DbConnection _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void GetRollUpItemsMatchingGroupAndProperties(
   string token,
   string fromItem,
   string toItem,
   int group,
   string properties,
   string tablename,
   DbConnection conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void GetRollUpItemsMatchingGroupAndProperties(
   String^ token,
   String^ fromItem,
   String^ toItem,
   int group,
   String^ properties,
   String^ tablename,
   DbConnection^ conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetRollUpItemsMatchingGroupAndProperties(
    token : String,
    fromItem : String,
    toItem : String,
    group : int,
    properties : String,
    tablename : String,
    conn : DbConnection
);
This language is not supported or no code example is available.

Parameters

token

Type: string

fromItem

Type: string

toItem

Type: string

group

Type: int

properties

Type: string

tablename

Type: string

conn

Type: DbConnection

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Interface
ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries.GetRollUpItemsMatchingProperties Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub GetRollUpItemsMatchingProperties( _
   ByVal token As String, _
   ByVal fromItem As String, _
   ByVal toItem As String, _
   ByVal properties As String, _
   ByVal tablename As String, _
   ByVal conn As DbConnection _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void GetRollUpItemsMatchingProperties(
   string token,
   string fromItem,
   string toItem,
   string properties,
   string tablename,
   DbConnection conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void GetRollUpItemsMatchingProperties(
   String^ token,
   String^ fromItem,
   String^ toItem,
   String^ properties,
   String^ tablename,
   DbConnection^ conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetRollUpItemsMatchingProperties(
    token : String,
    fromItem : String,
    toItem : String,
    properties : String,
    tablename : String,
    conn : DbConnection
);
This language is not supported or no code example is available.

Parameters

token

Type: string

fromItem

Type: string

toItem

Type: string

properties

Type: string

tablename

Type: string

conn

Type: DbConnection

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Interface
ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries.ImportItemsDataToTemporaryTable Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function ImportItemsDataToTemporaryTable( _
   ByVal Token As String, _
   ByVal list As List(Of String), _
   ByVal conn As DbConnection _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string ImportItemsDataToTemporaryTable(
   string Token,
   List<string> list,
   DbConnection conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

String^ ImportItemsDataToTemporaryTable(
   String^ Token,
   List<String^>^ list,
   DbConnection^ conn
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

list

Type: List<string>

conn

Type: DbConnection

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Interface
ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries.PrepareSingleStructureTempTable Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function PrepareSingleStructureTempTable( _
   ByVal Token As String, _
   ByVal connection As DbConnection, _
   ByVal baseItemCode As String, _
   ByVal baseRevisionCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string PrepareSingleStructureTempTable(
   string Token,
   DbConnection connection,
   string baseItemCode,
   string baseRevisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

String^ PrepareSingleStructureTempTable(
   String^ Token,
   DbConnection^ connection,
   String^ baseItemCode,
   String^ baseRevisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function PrepareSingleStructureTempTable(
    Token : String,
    connection : DbConnection,
    baseItemCode : String,
    baseRevisionCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

connection

Type: DbConnection

baseItemCode

Type: string

baseRevisionCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Interface
ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries.UpdateAccountCostingOnAllMORs Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function UpdateAccountCostingOnAllMORs( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset UpdateAccountCostingOnAllMORs(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ UpdateAccountCostingOnAllMORs(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function UpdateAccountCostingOnAllMORs(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Interface
ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


ICostingQueries.UpdateAccountCostingOnSpecificMOR Method

Namespace: CompuTec.ProcessForce.API.Queries.CostingQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function UpdateAccountCostingOnSpecificMOR( _
   ByVal token As String, _
   ByVal MORDocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset UpdateAccountCostingOnSpecificMOR(
   string token,
   int MORDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ UpdateAccountCostingOnSpecificMOR(
   String^ token,
   int MORDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function UpdateAccountCostingOnSpecificMOR(
    token : String,
    MORDocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

MORDocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICostingQueries Interface
ICostingQueries Members
CompuTec.ProcessForce.API.Queries.CostingQueries Namespace


CompuTec.ProcessForce.API.Queries.Ingredients Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | HAHAIngredientsQueries |
Public class | IngredientsBaseQuerties |
Public class | SQLIngredientsQueries |
Top
Interfaces
 | Name | Description
Public interface | IIngredientsQueries |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


HAHAIngredientsQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class HAHAIngredientsQueries
    Inherits IngredientsBaseQuerties
    Implements IIngredientsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class HAHAIngredientsQueries : IngredientsBaseQuerties,
   IIngredientsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class HAHAIngredientsQueries : public IngredientsBaseQuerties^,
   public IIngredientsQueries^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class HAHAIngredientsQueries
   extends IngredientsBaseQuerties
   implements IIngredientsQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.Ingredients.IngredientsBaseQuerties
CompuTec.ProcessForce.API.Queries.Ingredients.HAHAIngredientsQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HAHAIngredientsQueries Members
CompuTec.ProcessForce.API.Queries.Ingredients Namespace


HAHAIngredientsQueries Members

HAHAIngredientsQueries Class Methods See Also

The following tables list the members exposed by the HAHAIngredientsQueries type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetIngredientDailyValues | (inherited from IngredientsBaseQuerties).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

HAHAIngredientsQueries Class
CompuTec.ProcessForce.API.Queries.Ingredients Namespace


HAHAIngredientsQueries Methods

HAHAIngredientsQueries Class See Also

The following tables list the members exposed by the HAHAIngredientsQueries type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetIngredientDailyValues | (inherited from IngredientsBaseQuerties).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

HAHAIngredientsQueries Class
CompuTec.ProcessForce.API.Queries.Ingredients Namespace


IngredientsBaseQuerties.GetIngredientDailyValues Method

Namespace: CompuTec.ProcessForce.API.Queries.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetIngredientDailyValues( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetIngredientDailyValues(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetIngredientDailyValues(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetIngredientDailyValues(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IngredientsBaseQuerties Class
IngredientsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.Ingredients Namespace


IngredientsBaseQuerties Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class IngredientsBaseQuerties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class IngredientsBaseQuerties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class IngredientsBaseQuerties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class IngredientsBaseQuerties
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.Ingredients.IngredientsBaseQuerties
CompuTec.ProcessForce.API.Queries.Ingredients.HAHAIngredientsQueries
CompuTec.ProcessForce.API.Queries.Ingredients.SQLIngredientsQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IngredientsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.Ingredients Namespace


IngredientsBaseQuerties Members

IngredientsBaseQuerties Class Methods See Also

The following tables list the members exposed by the IngredientsBaseQuerties type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetIngredientDailyValues |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

IngredientsBaseQuerties Class
CompuTec.ProcessForce.API.Queries.Ingredients Namespace


IngredientsBaseQuerties Methods

IngredientsBaseQuerties Class See Also

The following tables list the members exposed by the IngredientsBaseQuerties type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetIngredientDailyValues |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

IngredientsBaseQuerties Class
CompuTec.ProcessForce.API.Queries.Ingredients Namespace


SQLIngredientsQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SQLIngredientsQueries
    Inherits IngredientsBaseQuerties
    Implements IIngredientsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SQLIngredientsQueries : IngredientsBaseQuerties,
   IIngredientsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SQLIngredientsQueries : public IngredientsBaseQuerties^,
   public IIngredientsQueries^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SQLIngredientsQueries
   extends IngredientsBaseQuerties
   implements IIngredientsQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.Ingredients.IngredientsBaseQuerties
CompuTec.ProcessForce.API.Queries.Ingredients.SQLIngredientsQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SQLIngredientsQueries Members
CompuTec.ProcessForce.API.Queries.Ingredients Namespace


SQLIngredientsQueries Members

SQLIngredientsQueries Class Methods See Also

The following tables list the members exposed by the SQLIngredientsQueries type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetIngredientDailyValues | (inherited from IngredientsBaseQuerties).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SQLIngredientsQueries Class
CompuTec.ProcessForce.API.Queries.Ingredients Namespace


SQLIngredientsQueries Methods

SQLIngredientsQueries Class See Also

The following tables list the members exposed by the SQLIngredientsQueries type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetIngredientDailyValues | (inherited from IngredientsBaseQuerties).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SQLIngredientsQueries Class
CompuTec.ProcessForce.API.Queries.Ingredients Namespace


IIngredientsQueries Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IIngredientsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IIngredientsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IIngredientsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IIngredientsQueries
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientsQueries Members
CompuTec.ProcessForce.API.Queries.Ingredients Namespace


IIngredientsQueries Members

IIngredientsQueries Interface Methods See Also

The following tables list the members exposed by the IIngredientsQueries type.

Methods
 | Name | Description
Public method | GetIngredientDailyValues |
Top
See Also

Reference

IIngredientsQueries Interface
CompuTec.ProcessForce.API.Queries.Ingredients Namespace


IIngredientsQueries Methods

IIngredientsQueries Interface See Also

The following tables list the members exposed by the IIngredientsQueries type.

Methods
 | Name | Description
Public method | GetIngredientDailyValues |
Top
See Also

Reference

IIngredientsQueries Interface
CompuTec.ProcessForce.API.Queries.Ingredients Namespace


IIngredientsQueries.GetIngredientDailyValues Method

Namespace: CompuTec.ProcessForce.API.Queries.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetIngredientDailyValues( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetIngredientDailyValues(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetIngredientDailyValues(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetIngredientDailyValues(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IIngredientsQueries Interface
IIngredientsQueries Members
CompuTec.ProcessForce.API.Queries.Ingredients Namespace


CompuTec.ProcessForce.API.Queries.ItemDetails Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | HAHAItemDetailsQueries |
Public class | ItemDetailsBaseQuerties |
Public class | SQLItemDetailsQueries |
Top
Interfaces
 | Name | Description
Public interface | IItemDetailsQueries |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


HAHAItemDetailsQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class HAHAItemDetailsQueries
    Inherits ItemDetailsBaseQuerties
    Implements IItemDetailsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class HAHAItemDetailsQueries : ItemDetailsBaseQuerties,
   IItemDetailsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class HAHAItemDetailsQueries : public ItemDetailsBaseQuerties^,
   public IItemDetailsQueries^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class HAHAItemDetailsQueries
   extends ItemDetailsBaseQuerties
   implements IItemDetailsQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.ItemDetails.ItemDetailsBaseQuerties
CompuTec.ProcessForce.API.Queries.ItemDetails.HAHAItemDetailsQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HAHAItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


HAHAItemDetailsQueries Members

HAHAItemDetailsQueries Class Methods See Also

The following tables list the members exposed by the HAHAItemDetailsQueries type.

Methods
 | Name | Description
Public method | DetectItemGroupChange | (inherited from ItemDetailsBaseQuerties).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAlternativeOrigins | Returns alternatives origins for specified item. Columns in result: Name, Code (inherited from ItemDetailsBaseQuerties).
Public method | GetAlternativeOriginsQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchData | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchDataByDocumentType | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchDataGoodsReceipt | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchDataPickReceipt | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTrace | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTraceEdges |
Public method | GetBatchTraceNodes |
Public method | GetBatchTraceabilityComplaintSqlQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTraceabilityDocumentSqlQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTraceabilityManufacturingOrderSqlQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTraceabilityQualityControlTestSqlQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetDefaultOrigin | Returns default Origin for specified item (inherited from ItemDetailsBaseQuerties).
Public method | GetDefaultRevision | (inherited from ItemDetailsBaseQuerties).
Public method | GetGroupGroupName | Returns default Origin for specified item (inherited from ItemDetailsBaseQuerties).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemDetailsBatchQueue | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsBatchTemplate | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsConsume | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsConsumeWarning | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsExpire | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsExpireWarning | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsExpiryTemplate | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsExpiryType | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsInspectionInterval | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsPFBatchQCStatus | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsPFBatchStatus | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsSAPBatchQCStatus | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsSAPBatchStatus | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsSerialTemplate | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsShelfLifeTime | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsSubGroupDescription | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemNameAndRevisonName | (inherited from ItemDetailsBaseQuerties).
Public method | GetListOfBillOfMaterialsWhereItemIsUsed | (inherited from ItemDetailsBaseQuerties).
Public method | GetListOfManufacturingOrderWhereItemIsUsed | (inherited from ItemDetailsBaseQuerties).
Public method | GetListOfWordCodesForProperty | (inherited from ItemDetailsBaseQuerties).
Public method | GetMrpDefaultState | (inherited from ItemDetailsBaseQuerties).
Public method | GetOrigins | Returns list of origins for specified item. (inherited from ItemDetailsBaseQuerties).
Public method | GetRevisionDetailsByBomCode | (inherited from ItemDetailsBaseQuerties).
Public method | GetSerialData | (inherited from ItemDetailsBaseQuerties).
Public method | GetSerialDataByDocumentType | (inherited from ItemDetailsBaseQuerties).
Public method | GetSerialDataGoodsReceipt | (inherited from ItemDetailsBaseQuerties).
Public method | GetSerialDataPickReceipt | (inherited from ItemDetailsBaseQuerties).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateBillOfMaterials | (inherited from ItemDetailsBaseQuerties).
Public method | UpdateInventoryLines | Update all inventory lines. For all items itemCode == null (inherited from ItemDetailsBaseQuerties).
Public method | UpdateManufacturingOrders | (inherited from ItemDetailsBaseQuerties).
Top
See Also

Reference

HAHAItemDetailsQueries Class
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


HAHAItemDetailsQueries Methods

HAHAItemDetailsQueries Class See Also

The following tables list the members exposed by the HAHAItemDetailsQueries type.

Methods
 | Name | Description
Public method | DetectItemGroupChange | (inherited from ItemDetailsBaseQuerties).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAlternativeOrigins | Returns alternatives origins for specified item. Columns in result: Name, Code (inherited from ItemDetailsBaseQuerties).
Public method | GetAlternativeOriginsQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchData | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchDataByDocumentType | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchDataGoodsReceipt | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchDataPickReceipt | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTrace | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTraceEdges |
Public method | GetBatchTraceNodes |
Public method | GetBatchTraceabilityComplaintSqlQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTraceabilityDocumentSqlQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTraceabilityManufacturingOrderSqlQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTraceabilityQualityControlTestSqlQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetDefaultOrigin | Returns default Origin for specified item (inherited from ItemDetailsBaseQuerties).
Public method | GetDefaultRevision | (inherited from ItemDetailsBaseQuerties).
Public method | GetGroupGroupName | Returns default Origin for specified item (inherited from ItemDetailsBaseQuerties).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemDetailsBatchQueue | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsBatchTemplate | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsConsume | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsConsumeWarning | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsExpire | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsExpireWarning | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsExpiryTemplate | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsExpiryType | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsInspectionInterval | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsPFBatchQCStatus | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsPFBatchStatus | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsSAPBatchQCStatus | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsSAPBatchStatus | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsSerialTemplate | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsShelfLifeTime | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsSubGroupDescription | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemNameAndRevisonName | (inherited from ItemDetailsBaseQuerties).
Public method | GetListOfBillOfMaterialsWhereItemIsUsed | (inherited from ItemDetailsBaseQuerties).
Public method | GetListOfManufacturingOrderWhereItemIsUsed | (inherited from ItemDetailsBaseQuerties).
Public method | GetListOfWordCodesForProperty | (inherited from ItemDetailsBaseQuerties).
Public method | GetMrpDefaultState | (inherited from ItemDetailsBaseQuerties).
Public method | GetOrigins | Returns list of origins for specified item. (inherited from ItemDetailsBaseQuerties).
Public method | GetRevisionDetailsByBomCode | (inherited from ItemDetailsBaseQuerties).
Public method | GetSerialData | (inherited from ItemDetailsBaseQuerties).
Public method | GetSerialDataByDocumentType | (inherited from ItemDetailsBaseQuerties).
Public method | GetSerialDataGoodsReceipt | (inherited from ItemDetailsBaseQuerties).
Public method | GetSerialDataPickReceipt | (inherited from ItemDetailsBaseQuerties).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateBillOfMaterials | (inherited from ItemDetailsBaseQuerties).
Public method | UpdateInventoryLines | Update all inventory lines. For all items itemCode == null (inherited from ItemDetailsBaseQuerties).
Public method | UpdateManufacturingOrders | (inherited from ItemDetailsBaseQuerties).
Top
See Also

Reference

HAHAItemDetailsQueries Class
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.DetectItemGroupChange Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function DetectItemGroupChange( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset DetectItemGroupChange(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ DetectItemGroupChange(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DetectItemGroupChange(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetAlternativeOrigins Method

Returns alternatives origins for specified item. Columns in result: Name, Code

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAlternativeOrigins( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAlternativeOrigins(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAlternativeOrigins(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAlternativeOrigins(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetAlternativeOriginsQuery Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAlternativeOriginsQuery( _
   ByVal ItemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GetAlternativeOriginsQuery(
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ GetAlternativeOriginsQuery(
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAlternativeOriginsQuery(
    ItemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

ItemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetBatchData Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBatchData( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal docEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBatchData(
   string token,
   string itemCode,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBatchData(
   String^ token,
   String^ itemCode,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBatchData(
    token : String,
    itemCode : String,
    docEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

docEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetBatchDataByDocumentType Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBatchDataByDocumentType( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal docEntry As Integer, _
   ByVal docType As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBatchDataByDocumentType(
   string token,
   string itemCode,
   int docEntry,
   string docType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBatchDataByDocumentType(
   String^ token,
   String^ itemCode,
   int docEntry,
   String^ docType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBatchDataByDocumentType(
    token : String,
    itemCode : String,
    docEntry : int,
    docType : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

docEntry

Type: int

docType

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetBatchDataGoodsReceipt Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBatchDataGoodsReceipt( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal docEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBatchDataGoodsReceipt(
   string token,
   string itemCode,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBatchDataGoodsReceipt(
   String^ token,
   String^ itemCode,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBatchDataGoodsReceipt(
    token : String,
    itemCode : String,
    docEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

docEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetBatchDataPickReceipt Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBatchDataPickReceipt( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal docEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBatchDataPickReceipt(
   string token,
   string itemCode,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBatchDataPickReceipt(
   String^ token,
   String^ itemCode,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBatchDataPickReceipt(
    token : String,
    itemCode : String,
    docEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

docEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetBatchTrace Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBatchTrace( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal batch As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBatchTrace(
   string token,
   string itemCode,
   string batch
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBatchTrace(
   String^ token,
   String^ itemCode,
   String^ batch
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBatchTrace(
    token : String,
    itemCode : String,
    batch : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

batch

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


HAHAItemDetailsQueries.GetBatchTraceEdges Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBatchTraceEdges( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBatchTraceEdges(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBatchTraceEdges(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBatchTraceEdges(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HAHAItemDetailsQueries Class
HAHAItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


HAHAItemDetailsQueries.GetBatchTraceNodes Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBatchTraceNodes( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBatchTraceNodes(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBatchTraceNodes(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBatchTraceNodes(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HAHAItemDetailsQueries Class
HAHAItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetBatchTraceabilityComplaintSqlQuery Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBatchTraceabilityComplaintSqlQuery( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal batch As String, _
   ByVal docNo As Integer, _
   ByVal transType As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBatchTraceabilityComplaintSqlQuery(
   string token,
   string itemCode,
   string batch,
   int docNo,
   string transType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBatchTraceabilityComplaintSqlQuery(
   String^ token,
   String^ itemCode,
   String^ batch,
   int docNo,
   String^ transType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBatchTraceabilityComplaintSqlQuery(
    token : String,
    itemCode : String,
    batch : String,
    docNo : int,
    transType : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

batch

Type: string

docNo

Type: int

transType

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetBatchTraceabilityDocumentSqlQuery Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBatchTraceabilityDocumentSqlQuery( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal systemNo As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBatchTraceabilityDocumentSqlQuery(
   string token,
   string itemCode,
   string systemNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBatchTraceabilityDocumentSqlQuery(
   String^ token,
   String^ itemCode,
   String^ systemNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBatchTraceabilityDocumentSqlQuery(
    token : String,
    itemCode : String,
    systemNo : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

systemNo

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetBatchTraceabilityManufacturingOrderSqlQuery Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBatchTraceabilityManufacturingOrderSqlQuery( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal batch As String, _
   ByVal docType As Integer, _
   ByVal docNo As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBatchTraceabilityManufacturingOrderSqlQuery(
   string token,
   string itemCode,
   string batch,
   int docType,
   int docNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBatchTraceabilityManufacturingOrderSqlQuery(
   String^ token,
   String^ itemCode,
   String^ batch,
   int docType,
   int docNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBatchTraceabilityManufacturingOrderSqlQuery(
    token : String,
    itemCode : String,
    batch : String,
    docType : int,
    docNo : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

batch

Type: string

docType

Type: int

docNo

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetBatchTraceabilityQualityControlTestSqlQuery Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBatchTraceabilityQualityControlTestSqlQuery( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal batch As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBatchTraceabilityQualityControlTestSqlQuery(
   string token,
   string itemCode,
   string batch
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBatchTraceabilityQualityControlTestSqlQuery(
   String^ token,
   String^ itemCode,
   String^ batch
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBatchTraceabilityQualityControlTestSqlQuery(
    token : String,
    itemCode : String,
    batch : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

batch

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetDefaultOrigin Method

Returns default Origin for specified item

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDefaultOrigin( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GetDefaultOrigin(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ GetDefaultOrigin(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDefaultOrigin(
    Token : String,
    ItemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetDefaultRevision Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDefaultRevision( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDefaultRevision(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDefaultRevision(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDefaultRevision(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetGroupGroupName Method

Returns default Origin for specified item

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetGroupGroupName( _
   ByVal Token As String, _
   ByVal grpCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GetGroupGroupName(
   string Token,
   string grpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ GetGroupGroupName(
   String^ Token,
   String^ grpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetGroupGroupName(
    Token : String,
    grpCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

grpCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetItemDetailsBatchQueue Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemDetailsBatchQueue( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemDetailsBatchQueue(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemDetailsBatchQueue(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemDetailsBatchQueue(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetItemDetailsBatchTemplate Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemDetailsBatchTemplate( _
   ByVal token As String, _
   ByVal itemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GetItemDetailsBatchTemplate(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ GetItemDetailsBatchTemplate(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemDetailsBatchTemplate(
    token : String,
    itemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetItemDetailsConsume Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemDetailsConsume( _
   ByVal token As String, _
   ByVal itemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GetItemDetailsConsume(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ GetItemDetailsConsume(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemDetailsConsume(
    token : String,
    itemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetItemDetailsConsumeWarning Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemDetailsConsumeWarning( _
   ByVal token As String, _
   ByVal itemCode As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int GetItemDetailsConsumeWarning(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int GetItemDetailsConsumeWarning(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemDetailsConsumeWarning(
    token : String,
    itemCode : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetItemDetailsExpire Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemDetailsExpire( _
   ByVal token As String, _
   ByVal itemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GetItemDetailsExpire(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ GetItemDetailsExpire(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemDetailsExpire(
    token : String,
    itemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetItemDetailsExpireWarning Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemDetailsExpireWarning( _
   ByVal token As String, _
   ByVal itemCode As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int GetItemDetailsExpireWarning(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int GetItemDetailsExpireWarning(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemDetailsExpireWarning(
    token : String,
    itemCode : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetItemDetailsExpiryTemplate Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemDetailsExpiryTemplate( _
   ByVal token As String, _
   ByVal itemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GetItemDetailsExpiryTemplate(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ GetItemDetailsExpiryTemplate(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemDetailsExpiryTemplate(
    token : String,
    itemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetItemDetailsExpiryType Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemDetailsExpiryType( _
   ByVal token As String, _
   ByVal itemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GetItemDetailsExpiryType(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ GetItemDetailsExpiryType(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemDetailsExpiryType(
    token : String,
    itemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetItemDetailsInspectionInterval Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemDetailsInspectionInterval( _
   ByVal token As String, _
   ByVal itemCode As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int GetItemDetailsInspectionInterval(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int GetItemDetailsInspectionInterval(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemDetailsInspectionInterval(
    token : String,
    itemCode : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetItemDetailsPFBatchQCStatus Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemDetailsPFBatchQCStatus( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemDetailsPFBatchQCStatus(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemDetailsPFBatchQCStatus(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemDetailsPFBatchQCStatus(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetItemDetailsPFBatchStatus Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemDetailsPFBatchStatus( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemDetailsPFBatchStatus(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemDetailsPFBatchStatus(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemDetailsPFBatchStatus(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetItemDetailsSAPBatchQCStatus Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemDetailsSAPBatchQCStatus( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemDetailsSAPBatchQCStatus(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemDetailsSAPBatchQCStatus(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemDetailsSAPBatchQCStatus(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetItemDetailsSAPBatchStatus Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemDetailsSAPBatchStatus( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemDetailsSAPBatchStatus(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemDetailsSAPBatchStatus(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemDetailsSAPBatchStatus(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetItemDetailsSerialTemplate Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemDetailsSerialTemplate( _
   ByVal token As String, _
   ByVal itemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GetItemDetailsSerialTemplate(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ GetItemDetailsSerialTemplate(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemDetailsSerialTemplate(
    token : String,
    itemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetItemDetailsShelfLifeTime Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemDetailsShelfLifeTime( _
   ByVal token As String, _
   ByVal itemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GetItemDetailsShelfLifeTime(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ GetItemDetailsShelfLifeTime(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemDetailsShelfLifeTime(
    token : String,
    itemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetItemDetailsSubGroupDescription Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemDetailsSubGroupDescription( _
   ByVal Token As String, _
   ByVal GrpCode As String, _
   ByVal LineNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemDetailsSubGroupDescription(
   string Token,
   string GrpCode,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemDetailsSubGroupDescription(
   String^ Token,
   String^ GrpCode,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemDetailsSubGroupDescription(
    Token : String,
    GrpCode : String,
    LineNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

GrpCode

Type: string

LineNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetItemNameAndRevisonName Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemNameAndRevisonName( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal RevisionCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemNameAndRevisonName(
   string Token,
   string ItemCode,
   string RevisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemNameAndRevisonName(
   String^ Token,
   String^ ItemCode,
   String^ RevisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemNameAndRevisonName(
    Token : String,
    ItemCode : String,
    RevisionCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

RevisionCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetListOfBillOfMaterialsWhereItemIsUsed Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetListOfBillOfMaterialsWhereItemIsUsed( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetListOfBillOfMaterialsWhereItemIsUsed(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetListOfBillOfMaterialsWhereItemIsUsed(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetListOfBillOfMaterialsWhereItemIsUsed(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetListOfManufacturingOrderWhereItemIsUsed Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetListOfManufacturingOrderWhereItemIsUsed( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetListOfManufacturingOrderWhereItemIsUsed(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetListOfManufacturingOrderWhereItemIsUsed(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetListOfManufacturingOrderWhereItemIsUsed(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetListOfWordCodesForProperty Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetListOfWordCodesForProperty( _
   ByVal Token As String, _
   ByVal PropertyCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetListOfWordCodesForProperty(
   string Token,
   string PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetListOfWordCodesForProperty(
   String^ Token,
   String^ PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetListOfWordCodesForProperty(
    Token : String,
    PropertyCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

PropertyCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetMrpDefaultState Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetMrpDefaultState( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revisionCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetMrpDefaultState(
   string token,
   string itemCode,
   string revisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetMrpDefaultState(
   String^ token,
   String^ itemCode,
   String^ revisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetMrpDefaultState(
    token : String,
    itemCode : String,
    revisionCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revisionCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetOrigins Method

Returns list of origins for specified item.

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetOrigins( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As List(Of String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<string> GetOrigins(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<String^>^ GetOrigins(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: List<string>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetRevisionDetailsByBomCode Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRevisionDetailsByBomCode( _
   ByVal Token As String, _
   ByVal BomCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRevisionDetailsByBomCode(
   string Token,
   string BomCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRevisionDetailsByBomCode(
   String^ Token,
   String^ BomCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRevisionDetailsByBomCode(
    Token : String,
    BomCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

BomCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetSerialData Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSerialData( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal docEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSerialData(
   string token,
   string itemCode,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSerialData(
   String^ token,
   String^ itemCode,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSerialData(
    token : String,
    itemCode : String,
    docEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

docEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetSerialDataByDocumentType Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSerialDataByDocumentType( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal docEntry As Integer, _
   ByVal docType As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSerialDataByDocumentType(
   string token,
   string itemCode,
   int docEntry,
   string docType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSerialDataByDocumentType(
   String^ token,
   String^ itemCode,
   int docEntry,
   String^ docType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSerialDataByDocumentType(
    token : String,
    itemCode : String,
    docEntry : int,
    docType : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

docEntry

Type: int

docType

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetSerialDataGoodsReceipt Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSerialDataGoodsReceipt( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal docEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSerialDataGoodsReceipt(
   string token,
   string itemCode,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSerialDataGoodsReceipt(
   String^ token,
   String^ itemCode,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSerialDataGoodsReceipt(
    token : String,
    itemCode : String,
    docEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

docEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.GetSerialDataPickReceipt Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSerialDataPickReceipt( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal docEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSerialDataPickReceipt(
   string token,
   string itemCode,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSerialDataPickReceipt(
   String^ token,
   String^ itemCode,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSerialDataPickReceipt(
    token : String,
    itemCode : String,
    docEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

docEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.UpdateBillOfMaterials Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function UpdateBillOfMaterials( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset UpdateBillOfMaterials(
   string token,
   string itemCode,
   string revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ UpdateBillOfMaterials(
   String^ token,
   String^ itemCode,
   String^ revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UpdateBillOfMaterials(
    token : String,
    itemCode : String,
    revCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.UpdateInventoryLines Method

Update all inventory lines. For all items itemCode == null

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub UpdateInventoryLines( _
   ByVal Token As String, _
   Optional ByVal itemCode As String = null _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void UpdateInventoryLines(
   string Token,
   string itemCode = null
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void UpdateInventoryLines(
   String^ Token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UpdateInventoryLines(
    Token : String,
    itemCode : String
);
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemCode

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties.UpdateManufacturingOrders Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function UpdateManufacturingOrders( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset UpdateManufacturingOrders(
   string token,
   string itemCode,
   string revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ UpdateManufacturingOrders(
   String^ token,
   String^ itemCode,
   String^ revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UpdateManufacturingOrders(
    token : String,
    itemCode : String,
    revCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Class
ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ItemDetailsBaseQuerties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemDetailsBaseQuerties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ItemDetailsBaseQuerties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemDetailsBaseQuerties
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.ItemDetails.ItemDetailsBaseQuerties
CompuTec.ProcessForce.API.Queries.ItemDetails.HAHAItemDetailsQueries
CompuTec.ProcessForce.API.Queries.ItemDetails.SQLItemDetailsQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsBaseQuerties Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties Members

ItemDetailsBaseQuerties Class Methods See Also

The following tables list the members exposed by the ItemDetailsBaseQuerties type.

Methods
 | Name | Description
Public method | DetectItemGroupChange |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAlternativeOrigins | Returns alternatives origins for specified item. Columns in result: Name, Code
Public method | GetAlternativeOriginsQuery |
Public method | GetBatchData |
Public method | GetBatchDataByDocumentType |
Public method | GetBatchDataGoodsReceipt |
Public method | GetBatchDataPickReceipt |
Public method | GetBatchTrace |
Public method | GetBatchTraceabilityComplaintSqlQuery |
Public method | GetBatchTraceabilityDocumentSqlQuery |
Public method | GetBatchTraceabilityManufacturingOrderSqlQuery |
Public method | GetBatchTraceabilityQualityControlTestSqlQuery |
Public method | GetDefaultOrigin | Returns default Origin for specified item
Public method | GetDefaultRevision |
Public method | GetGroupGroupName | Returns default Origin for specified item
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemDetailsBatchQueue |
Public method | GetItemDetailsBatchTemplate |
Public method | GetItemDetailsConsume |
Public method | GetItemDetailsConsumeWarning |
Public method | GetItemDetailsExpire |
Public method | GetItemDetailsExpireWarning |
Public method | GetItemDetailsExpiryTemplate |
Public method | GetItemDetailsExpiryType |
Public method | GetItemDetailsInspectionInterval |
Public method | GetItemDetailsPFBatchQCStatus |
Public method | GetItemDetailsPFBatchStatus |
Public method | GetItemDetailsSAPBatchQCStatus |
Public method | GetItemDetailsSAPBatchStatus |
Public method | GetItemDetailsSerialTemplate |
Public method | GetItemDetailsShelfLifeTime |
Public method | GetItemDetailsSubGroupDescription |
Public method | GetItemNameAndRevisonName |
Public method | GetListOfBillOfMaterialsWhereItemIsUsed |
Public method | GetListOfManufacturingOrderWhereItemIsUsed |
Public method | GetListOfWordCodesForProperty |
Public method | GetMrpDefaultState |
Public method | GetOrigins | Returns list of origins for specified item.
Public method | GetRevisionDetailsByBomCode |
Public method | GetSerialData |
Public method | GetSerialDataByDocumentType |
Public method | GetSerialDataGoodsReceipt |
Public method | GetSerialDataPickReceipt |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateBillOfMaterials |
Public method | UpdateInventoryLines | Update all inventory lines. For all items itemCode == null
Public method | UpdateManufacturingOrders |
Top
See Also

Reference

ItemDetailsBaseQuerties Class
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


ItemDetailsBaseQuerties Methods

ItemDetailsBaseQuerties Class See Also

The following tables list the members exposed by the ItemDetailsBaseQuerties type.

Methods
 | Name | Description
Public method | DetectItemGroupChange |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAlternativeOrigins | Returns alternatives origins for specified item. Columns in result: Name, Code
Public method | GetAlternativeOriginsQuery |
Public method | GetBatchData |
Public method | GetBatchDataByDocumentType |
Public method | GetBatchDataGoodsReceipt |
Public method | GetBatchDataPickReceipt |
Public method | GetBatchTrace |
Public method | GetBatchTraceabilityComplaintSqlQuery |
Public method | GetBatchTraceabilityDocumentSqlQuery |
Public method | GetBatchTraceabilityManufacturingOrderSqlQuery |
Public method | GetBatchTraceabilityQualityControlTestSqlQuery |
Public method | GetDefaultOrigin | Returns default Origin for specified item
Public method | GetDefaultRevision |
Public method | GetGroupGroupName | Returns default Origin for specified item
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemDetailsBatchQueue |
Public method | GetItemDetailsBatchTemplate |
Public method | GetItemDetailsConsume |
Public method | GetItemDetailsConsumeWarning |
Public method | GetItemDetailsExpire |
Public method | GetItemDetailsExpireWarning |
Public method | GetItemDetailsExpiryTemplate |
Public method | GetItemDetailsExpiryType |
Public method | GetItemDetailsInspectionInterval |
Public method | GetItemDetailsPFBatchQCStatus |
Public method | GetItemDetailsPFBatchStatus |
Public method | GetItemDetailsSAPBatchQCStatus |
Public method | GetItemDetailsSAPBatchStatus |
Public method | GetItemDetailsSerialTemplate |
Public method | GetItemDetailsShelfLifeTime |
Public method | GetItemDetailsSubGroupDescription |
Public method | GetItemNameAndRevisonName |
Public method | GetListOfBillOfMaterialsWhereItemIsUsed |
Public method | GetListOfManufacturingOrderWhereItemIsUsed |
Public method | GetListOfWordCodesForProperty |
Public method | GetMrpDefaultState |
Public method | GetOrigins | Returns list of origins for specified item.
Public method | GetRevisionDetailsByBomCode |
Public method | GetSerialData |
Public method | GetSerialDataByDocumentType |
Public method | GetSerialDataGoodsReceipt |
Public method | GetSerialDataPickReceipt |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateBillOfMaterials |
Public method | UpdateInventoryLines | Update all inventory lines. For all items itemCode == null
Public method | UpdateManufacturingOrders |
Top
See Also

Reference

ItemDetailsBaseQuerties Class
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


SQLItemDetailsQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SQLItemDetailsQueries
    Inherits ItemDetailsBaseQuerties
    Implements IItemDetailsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SQLItemDetailsQueries : ItemDetailsBaseQuerties,
   IItemDetailsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SQLItemDetailsQueries : public ItemDetailsBaseQuerties^,
   public IItemDetailsQueries^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SQLItemDetailsQueries
   extends ItemDetailsBaseQuerties
   implements IItemDetailsQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.ItemDetails.ItemDetailsBaseQuerties
CompuTec.ProcessForce.API.Queries.ItemDetails.SQLItemDetailsQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SQLItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


SQLItemDetailsQueries Members

SQLItemDetailsQueries Class Methods See Also

The following tables list the members exposed by the SQLItemDetailsQueries type.

Methods
 | Name | Description
Public method | DetectItemGroupChange | (inherited from ItemDetailsBaseQuerties).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAlternativeOrigins | Returns alternatives origins for specified item. Columns in result: Name, Code (inherited from ItemDetailsBaseQuerties).
Public method | GetAlternativeOriginsQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchData | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchDataByDocumentType | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchDataGoodsReceipt | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchDataPickReceipt | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTrace | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTraceabilityComplaintSqlQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTraceabilityDocumentSqlQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTraceabilityManufacturingOrderSqlQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTraceabilityQualityControlTestSqlQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetDefaultOrigin | Returns default Origin for specified item (inherited from ItemDetailsBaseQuerties).
Public method | GetDefaultRevision | (inherited from ItemDetailsBaseQuerties).
Public method | GetGroupGroupName | Returns default Origin for specified item (inherited from ItemDetailsBaseQuerties).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemDetailsBatchQueue | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsBatchTemplate | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsConsume | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsConsumeWarning | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsExpire | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsExpireWarning | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsExpiryTemplate | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsExpiryType | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsInspectionInterval | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsPFBatchQCStatus | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsPFBatchStatus | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsSAPBatchQCStatus | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsSAPBatchStatus | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsSerialTemplate | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsShelfLifeTime | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsSubGroupDescription | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemNameAndRevisonName | (inherited from ItemDetailsBaseQuerties).
Public method | GetListOfBillOfMaterialsWhereItemIsUsed | (inherited from ItemDetailsBaseQuerties).
Public method | GetListOfManufacturingOrderWhereItemIsUsed | (inherited from ItemDetailsBaseQuerties).
Public method | GetListOfWordCodesForProperty | (inherited from ItemDetailsBaseQuerties).
Public method | GetMrpDefaultState | (inherited from ItemDetailsBaseQuerties).
Public method | GetOrigins | Returns list of origins for specified item. (inherited from ItemDetailsBaseQuerties).
Public method | GetRevisionDetailsByBomCode | (inherited from ItemDetailsBaseQuerties).
Public method | GetSerialData | (inherited from ItemDetailsBaseQuerties).
Public method | GetSerialDataByDocumentType | (inherited from ItemDetailsBaseQuerties).
Public method | GetSerialDataGoodsReceipt | (inherited from ItemDetailsBaseQuerties).
Public method | GetSerialDataPickReceipt | (inherited from ItemDetailsBaseQuerties).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateBillOfMaterials | (inherited from ItemDetailsBaseQuerties).
Public method | UpdateInventoryLines | Update all inventory lines. For all items itemCode == null (inherited from ItemDetailsBaseQuerties).
Public method | UpdateManufacturingOrders | (inherited from ItemDetailsBaseQuerties).
Top
See Also

Reference

SQLItemDetailsQueries Class
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


SQLItemDetailsQueries Methods

SQLItemDetailsQueries Class See Also

The following tables list the members exposed by the SQLItemDetailsQueries type.

Methods
 | Name | Description
Public method | DetectItemGroupChange | (inherited from ItemDetailsBaseQuerties).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAlternativeOrigins | Returns alternatives origins for specified item. Columns in result: Name, Code (inherited from ItemDetailsBaseQuerties).
Public method | GetAlternativeOriginsQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchData | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchDataByDocumentType | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchDataGoodsReceipt | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchDataPickReceipt | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTrace | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTraceabilityComplaintSqlQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTraceabilityDocumentSqlQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTraceabilityManufacturingOrderSqlQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetBatchTraceabilityQualityControlTestSqlQuery | (inherited from ItemDetailsBaseQuerties).
Public method | GetDefaultOrigin | Returns default Origin for specified item (inherited from ItemDetailsBaseQuerties).
Public method | GetDefaultRevision | (inherited from ItemDetailsBaseQuerties).
Public method | GetGroupGroupName | Returns default Origin for specified item (inherited from ItemDetailsBaseQuerties).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemDetailsBatchQueue | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsBatchTemplate | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsConsume | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsConsumeWarning | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsExpire | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsExpireWarning | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsExpiryTemplate | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsExpiryType | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsInspectionInterval | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsPFBatchQCStatus | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsPFBatchStatus | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsSAPBatchQCStatus | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsSAPBatchStatus | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsSerialTemplate | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsShelfLifeTime | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemDetailsSubGroupDescription | (inherited from ItemDetailsBaseQuerties).
Public method | GetItemNameAndRevisonName | (inherited from ItemDetailsBaseQuerties).
Public method | GetListOfBillOfMaterialsWhereItemIsUsed | (inherited from ItemDetailsBaseQuerties).
Public method | GetListOfManufacturingOrderWhereItemIsUsed | (inherited from ItemDetailsBaseQuerties).
Public method | GetListOfWordCodesForProperty | (inherited from ItemDetailsBaseQuerties).
Public method | GetMrpDefaultState | (inherited from ItemDetailsBaseQuerties).
Public method | GetOrigins | Returns list of origins for specified item. (inherited from ItemDetailsBaseQuerties).
Public method | GetRevisionDetailsByBomCode | (inherited from ItemDetailsBaseQuerties).
Public method | GetSerialData | (inherited from ItemDetailsBaseQuerties).
Public method | GetSerialDataByDocumentType | (inherited from ItemDetailsBaseQuerties).
Public method | GetSerialDataGoodsReceipt | (inherited from ItemDetailsBaseQuerties).
Public method | GetSerialDataPickReceipt | (inherited from ItemDetailsBaseQuerties).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateBillOfMaterials | (inherited from ItemDetailsBaseQuerties).
Public method | UpdateInventoryLines | Update all inventory lines. For all items itemCode == null (inherited from ItemDetailsBaseQuerties).
Public method | UpdateManufacturingOrders | (inherited from ItemDetailsBaseQuerties).
Top
See Also

Reference

SQLItemDetailsQueries Class
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IItemDetailsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IItemDetailsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IItemDetailsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IItemDetailsQueries
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries Members

IItemDetailsQueries Interface Methods See Also

The following tables list the members exposed by the IItemDetailsQueries type.

Methods
 | Name | Description
Public method | GetAlternativeOrigins | Returns alternatives origins for specified item. Columns in result: Name, Code
Public method | GetAlternativeOriginsQuery | Returns SQL query, alternatives origins for specified item. Columns in result: Name, Code
Public method | GetBatchData |
Public method | GetBatchTrace |
Public method | GetBatchTraceabilityComplaintSqlQuery |
Public method | GetBatchTraceabilityDocumentSqlQuery |
Public method | GetBatchTraceabilityManufacturingOrderSqlQuery |
Public method | GetBatchTraceabilityQualityControlTestSqlQuery |
Public method | GetDefaultOrigin |
Public method | GetDefaultRevision |
Public method | GetGroupGroupName | Returns Group Group Name based on Code
Public method | GetItemDetailsBatchQueue |
Public method | GetItemDetailsBatchTemplate |
Public method | GetItemDetailsConsume |
Public method | GetItemDetailsConsumeWarning |
Public method | GetItemDetailsExpire |
Public method | GetItemDetailsExpireWarning |
Public method | GetItemDetailsInspectionInterval |
Public method | GetItemDetailsPFBatchQCStatus |
Public method | GetItemDetailsPFBatchStatus |
Public method | GetItemDetailsSAPBatchQCStatus |
Public method | GetItemDetailsSAPBatchStatus |
Public method | GetItemDetailsSerialTemplate |
Public method | GetItemDetailsShelfLifeTime |
Public method | GetItemDetailsSubGroupDescription |
Public method | GetItemNameAndRevisonName | "ItemName", "U_Description"
Public method | GetListOfBillOfMaterialsWhereItemIsUsed |
Public method | GetListOfWordCodesForProperty |
Public method | GetOrigins | Returns list of origins for specified item.
Public method | GetRevisionDetailsByBomCode | T1.U_Default, T1.U_Status, T1.U_ValidFrom, T1.U_ValidTo
Public method | UpdateBillOfMaterials |
Public method | UpdateInventoryLines | Update lines in @CT_PF_IDT13
Public method | UpdateManufacturingOrders |
Top
See Also

Reference

IItemDetailsQueries Interface
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries Methods

IItemDetailsQueries Interface See Also

The following tables list the members exposed by the IItemDetailsQueries type.

Methods
 | Name | Description
Public method | GetAlternativeOrigins | Returns alternatives origins for specified item. Columns in result: Name, Code
Public method | GetAlternativeOriginsQuery | Returns SQL query, alternatives origins for specified item. Columns in result: Name, Code
Public method | GetBatchData |
Public method | GetBatchTrace |
Public method | GetBatchTraceabilityComplaintSqlQuery |
Public method | GetBatchTraceabilityDocumentSqlQuery |
Public method | GetBatchTraceabilityManufacturingOrderSqlQuery |
Public method | GetBatchTraceabilityQualityControlTestSqlQuery |
Public method | GetDefaultOrigin |
Public method | GetDefaultRevision |
Public method | GetGroupGroupName | Returns Group Group Name based on Code
Public method | GetItemDetailsBatchQueue |
Public method | GetItemDetailsBatchTemplate |
Public method | GetItemDetailsConsume |
Public method | GetItemDetailsConsumeWarning |
Public method | GetItemDetailsExpire |
Public method | GetItemDetailsExpireWarning |
Public method | GetItemDetailsInspectionInterval |
Public method | GetItemDetailsPFBatchQCStatus |
Public method | GetItemDetailsPFBatchStatus |
Public method | GetItemDetailsSAPBatchQCStatus |
Public method | GetItemDetailsSAPBatchStatus |
Public method | GetItemDetailsSerialTemplate |
Public method | GetItemDetailsShelfLifeTime |
Public method | GetItemDetailsSubGroupDescription |
Public method | GetItemNameAndRevisonName | "ItemName", "U_Description"
Public method | GetListOfBillOfMaterialsWhereItemIsUsed |
Public method | GetListOfWordCodesForProperty |
Public method | GetOrigins | Returns list of origins for specified item.
Public method | GetRevisionDetailsByBomCode | T1.U_Default, T1.U_Status, T1.U_ValidFrom, T1.U_ValidTo
Public method | UpdateBillOfMaterials |
Public method | UpdateInventoryLines | Update lines in @CT_PF_IDT13
Public method | UpdateManufacturingOrders |
Top
See Also

Reference

IItemDetailsQueries Interface
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetAlternativeOrigins Method

Returns alternatives origins for specified item. Columns in result: Name, Code

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetAlternativeOrigins( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetAlternativeOrigins(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetAlternativeOrigins(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetAlternativeOrigins(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetAlternativeOriginsQuery Method

Returns SQL query, alternatives origins for specified item. Columns in result: Name, Code

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAlternativeOriginsQuery( _
   ByVal ItemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string GetAlternativeOriginsQuery(
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

String^ GetAlternativeOriginsQuery(
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetAlternativeOriginsQuery(
    ItemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

ItemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetBatchData Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetBatchData( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal docEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetBatchData(
   string token,
   string itemCode,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetBatchData(
   String^ token,
   String^ itemCode,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetBatchData(
    token : String,
    itemCode : String,
    docEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

docEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetBatchTrace Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetBatchTrace( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal batch As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetBatchTrace(
   string token,
   string itemCode,
   string batch
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetBatchTrace(
   String^ token,
   String^ itemCode,
   String^ batch
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetBatchTrace(
    token : String,
    itemCode : String,
    batch : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

batch

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetBatchTraceabilityComplaintSqlQuery Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetBatchTraceabilityComplaintSqlQuery( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal batch As String, _
   ByVal docNo As Integer, _
   ByVal transType As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetBatchTraceabilityComplaintSqlQuery(
   string token,
   string itemCode,
   string batch,
   int docNo,
   string transType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetBatchTraceabilityComplaintSqlQuery(
   String^ token,
   String^ itemCode,
   String^ batch,
   int docNo,
   String^ transType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetBatchTraceabilityComplaintSqlQuery(
    token : String,
    itemCode : String,
    batch : String,
    docNo : int,
    transType : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

batch

Type: string

docNo

Type: int

transType

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetBatchTraceabilityDocumentSqlQuery Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetBatchTraceabilityDocumentSqlQuery( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal systemNo As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetBatchTraceabilityDocumentSqlQuery(
   string token,
   string itemCode,
   string systemNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetBatchTraceabilityDocumentSqlQuery(
   String^ token,
   String^ itemCode,
   String^ systemNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetBatchTraceabilityDocumentSqlQuery(
    token : String,
    itemCode : String,
    systemNo : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

systemNo

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetBatchTraceabilityManufacturingOrderSqlQuery Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetBatchTraceabilityManufacturingOrderSqlQuery( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal batch As String, _
   ByVal docType As Integer, _
   ByVal docNo As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetBatchTraceabilityManufacturingOrderSqlQuery(
   string token,
   string itemCode,
   string batch,
   int docType,
   int docNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetBatchTraceabilityManufacturingOrderSqlQuery(
   String^ token,
   String^ itemCode,
   String^ batch,
   int docType,
   int docNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetBatchTraceabilityManufacturingOrderSqlQuery(
    token : String,
    itemCode : String,
    batch : String,
    docType : int,
    docNo : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

batch

Type: string

docType

Type: int

docNo

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetBatchTraceabilityQualityControlTestSqlQuery Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetBatchTraceabilityQualityControlTestSqlQuery( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal batch As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetBatchTraceabilityQualityControlTestSqlQuery(
   string token,
   string itemCode,
   string batch
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetBatchTraceabilityQualityControlTestSqlQuery(
   String^ token,
   String^ itemCode,
   String^ batch
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetBatchTraceabilityQualityControlTestSqlQuery(
    token : String,
    itemCode : String,
    batch : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

batch

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetDefaultOrigin Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetDefaultOrigin( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
string GetDefaultOrigin(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

String^ GetDefaultOrigin(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetDefaultOrigin(
    Token : String,
    ItemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetDefaultRevision Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetDefaultRevision( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetDefaultRevision(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetDefaultRevision(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetDefaultRevision(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetGroupGroupName Method

Returns Group Group Name based on Code

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetGroupGroupName( _
   ByVal Token As String, _
   ByVal grpCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string GetGroupGroupName(
   string Token,
   string grpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

String^ GetGroupGroupName(
   String^ Token,
   String^ grpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetGroupGroupName(
    Token : String,
    grpCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Token

grpCode

Type: string

group group code

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetItemDetailsBatchQueue Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetItemDetailsBatchQueue( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetItemDetailsBatchQueue(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetItemDetailsBatchQueue(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetItemDetailsBatchQueue(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetItemDetailsBatchTemplate Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetItemDetailsBatchTemplate( _
   ByVal token As String, _
   ByVal itemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
string GetItemDetailsBatchTemplate(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

String^ GetItemDetailsBatchTemplate(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetItemDetailsBatchTemplate(
    token : String,
    itemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetItemDetailsConsume Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetItemDetailsConsume( _
   ByVal token As String, _
   ByVal itemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
string GetItemDetailsConsume(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

String^ GetItemDetailsConsume(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetItemDetailsConsume(
    token : String,
    itemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetItemDetailsConsumeWarning Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetItemDetailsConsumeWarning( _
   ByVal token As String, _
   ByVal itemCode As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
int GetItemDetailsConsumeWarning(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

int GetItemDetailsConsumeWarning(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetItemDetailsConsumeWarning(
    token : String,
    itemCode : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetItemDetailsExpire Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetItemDetailsExpire( _
   ByVal token As String, _
   ByVal itemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
string GetItemDetailsExpire(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

String^ GetItemDetailsExpire(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetItemDetailsExpire(
    token : String,
    itemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetItemDetailsExpireWarning Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetItemDetailsExpireWarning( _
   ByVal token As String, _
   ByVal itemCode As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
int GetItemDetailsExpireWarning(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

int GetItemDetailsExpireWarning(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetItemDetailsExpireWarning(
    token : String,
    itemCode : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetItemDetailsInspectionInterval Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetItemDetailsInspectionInterval( _
   ByVal token As String, _
   ByVal itemCode As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
int GetItemDetailsInspectionInterval(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

int GetItemDetailsInspectionInterval(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetItemDetailsInspectionInterval(
    token : String,
    itemCode : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetItemDetailsPFBatchQCStatus Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetItemDetailsPFBatchQCStatus( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetItemDetailsPFBatchQCStatus(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetItemDetailsPFBatchQCStatus(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetItemDetailsPFBatchQCStatus(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetItemDetailsPFBatchStatus Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetItemDetailsPFBatchStatus( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetItemDetailsPFBatchStatus(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetItemDetailsPFBatchStatus(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetItemDetailsPFBatchStatus(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetItemDetailsSAPBatchQCStatus Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetItemDetailsSAPBatchQCStatus( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetItemDetailsSAPBatchQCStatus(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetItemDetailsSAPBatchQCStatus(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetItemDetailsSAPBatchQCStatus(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetItemDetailsSAPBatchStatus Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetItemDetailsSAPBatchStatus( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetItemDetailsSAPBatchStatus(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetItemDetailsSAPBatchStatus(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetItemDetailsSAPBatchStatus(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetItemDetailsSerialTemplate Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetItemDetailsSerialTemplate( _
   ByVal token As String, _
   ByVal itemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
string GetItemDetailsSerialTemplate(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

String^ GetItemDetailsSerialTemplate(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetItemDetailsSerialTemplate(
    token : String,
    itemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetItemDetailsShelfLifeTime Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetItemDetailsShelfLifeTime( _
   ByVal token As String, _
   ByVal itemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
string GetItemDetailsShelfLifeTime(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

String^ GetItemDetailsShelfLifeTime(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetItemDetailsShelfLifeTime(
    token : String,
    itemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetItemDetailsSubGroupDescription Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetItemDetailsSubGroupDescription( _
   ByVal Token As String, _
   ByVal GrpCode As String, _
   ByVal LineNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetItemDetailsSubGroupDescription(
   string Token,
   string GrpCode,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetItemDetailsSubGroupDescription(
   String^ Token,
   String^ GrpCode,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetItemDetailsSubGroupDescription(
    Token : String,
    GrpCode : String,
    LineNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

GrpCode

Type: string

LineNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetItemNameAndRevisonName Method

"ItemName", "U_Description"

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetItemNameAndRevisonName( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal RevisionCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetItemNameAndRevisonName(
   string Token,
   string ItemCode,
   string RevisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetItemNameAndRevisonName(
   String^ Token,
   String^ ItemCode,
   String^ RevisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetItemNameAndRevisonName(
    Token : String,
    ItemCode : String,
    RevisionCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

RevisionCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetListOfBillOfMaterialsWhereItemIsUsed Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetListOfBillOfMaterialsWhereItemIsUsed( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetListOfBillOfMaterialsWhereItemIsUsed(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetListOfBillOfMaterialsWhereItemIsUsed(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetListOfBillOfMaterialsWhereItemIsUsed(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetListOfWordCodesForProperty Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetListOfWordCodesForProperty( _
   ByVal Token As String, _
   ByVal PropertyCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetListOfWordCodesForProperty(
   string Token,
   string PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetListOfWordCodesForProperty(
   String^ Token,
   String^ PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetListOfWordCodesForProperty(
    Token : String,
    PropertyCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

PropertyCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetOrigins Method

Returns list of origins for specified item.

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetOrigins( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As List(Of String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
List<string> GetOrigins(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

List<String^>^ GetOrigins(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: List<string>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.GetRevisionDetailsByBomCode Method

T1.U_Default, T1.U_Status, T1.U_ValidFrom, T1.U_ValidTo

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetRevisionDetailsByBomCode( _
   ByVal Token As String, _
   ByVal BomCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetRevisionDetailsByBomCode(
   string Token,
   string BomCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetRevisionDetailsByBomCode(
   String^ Token,
   String^ BomCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetRevisionDetailsByBomCode(
    Token : String,
    BomCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

BomCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.UpdateBillOfMaterials Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function UpdateBillOfMaterials( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset UpdateBillOfMaterials(
   string token,
   string itemCode,
   string revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ UpdateBillOfMaterials(
   String^ token,
   String^ itemCode,
   String^ revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function UpdateBillOfMaterials(
    token : String,
    itemCode : String,
    revCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.UpdateInventoryLines Method

Update lines in @CT_PF_IDT13

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub UpdateInventoryLines( _
   ByVal Token As String, _
   Optional ByVal itemCode As String = null _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void UpdateInventoryLines(
   string Token,
   string itemCode = null
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void UpdateInventoryLines(
   String^ Token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function UpdateInventoryLines(
    Token : String,
    itemCode : String
);
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemCode

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


IItemDetailsQueries.UpdateManufacturingOrders Method

Namespace: CompuTec.ProcessForce.API.Queries.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function UpdateManufacturingOrders( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset UpdateManufacturingOrders(
   string token,
   string itemCode,
   string revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ UpdateManufacturingOrders(
   String^ token,
   String^ itemCode,
   String^ revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function UpdateManufacturingOrders(
    token : String,
    itemCode : String,
    revCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemDetailsQueries Interface
IItemDetailsQueries Members
CompuTec.ProcessForce.API.Queries.ItemDetails Namespace


CompuTec.ProcessForce.API.Queries.MORSelector Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | MORSelectorQueries |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


MORSelectorQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.MORSelector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MORSelectorQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MORSelectorQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MORSelectorQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MORSelectorQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.MORSelector.MORSelectorQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MORSelectorQueries Members
CompuTec.ProcessForce.API.Queries.MORSelector Namespace


MORSelectorQueries Members

MORSelectorQueries Class Methods See Also

The following tables list the members exposed by the MORSelectorQueries type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetMORSelector |
Public method | GetMORSelectorDynSQL |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MORSelectorQueries Class
CompuTec.ProcessForce.API.Queries.MORSelector Namespace


MORSelectorQueries Methods

MORSelectorQueries Class See Also

The following tables list the members exposed by the MORSelectorQueries type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetMORSelector |
Public method | GetMORSelectorDynSQL |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MORSelectorQueries Class
CompuTec.ProcessForce.API.Queries.MORSelector Namespace


MORSelectorQueries.GetMORSelector Method

Namespace: CompuTec.ProcessForce.API.Queries.MORSelector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetMORSelector() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GetMORSelector()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ GetMORSelector()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetMORSelector() : String;
This language is not supported or no code example is available.

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MORSelectorQueries Class
MORSelectorQueries Members
CompuTec.ProcessForce.API.Queries.MORSelector Namespace


MORSelectorQueries.GetMORSelectorDynSQL Method

Namespace: CompuTec.ProcessForce.API.Queries.MORSelector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetMORSelectorDynSQL() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GetMORSelectorDynSQL()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ GetMORSelectorDynSQL()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetMORSelectorDynSQL() : String;
This language is not supported or no code example is available.

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MORSelectorQueries Class
MORSelectorQueries Members
CompuTec.ProcessForce.API.Queries.MORSelector Namespace


CompuTec.ProcessForce.API.Queries.MRP Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | MRPBaseQueries |
Public class | MRPSapHanaQueries |
Public class | MRPSqlServerQuerties |
Top
Interfaces
 | Name | Description
Public interface | IMRPQueries |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


MRPBaseQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MRPBaseQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPBaseQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MRPBaseQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPBaseQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.MRP.MRPBaseQueries
CompuTec.ProcessForce.API.Queries.MRP.MRPSapHanaQueries
CompuTec.ProcessForce.API.Queries.MRP.MRPSqlServerQuerties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries Members

MRPBaseQueries Class Methods See Also

The following tables list the members exposed by the MRPBaseQueries type.

Methods
 | Name | Description
Public method | BaseManufacturingOrderLoader |
Public method | BaseSalesOrderLoader | (Overloaded)
Public method | CheckProductTree |
Public method | CoproductsBOMList |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBlanketAgreements |
Public method | GetBusinessPlaceForWarehouse |
Public method | GetDefaultForMrpBillOfMaterialsCode |
Public method | GetDefaultVendorCode |
Public method | GetDuplicateOrderRecommendationDocumentIds |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemBaseUnitCode |
Public method | GetItemLastPurchasePrice |
Public method | GetItemPriceListPrice |
Public method | GetItemUnits |
Public method | GetItemVendors |
Public method | GetItemVendorsWithNames |
Public method | GetItemsRevisions |
Public method | GetItemsUnitOfMeasureData |
Public method | GetListOfAssignedManufacturingOrdersForSalesOrder |
Public method | GetManufacturingOrderDocEntry |
Public method | GetManufacturingOrderSeriesWhenAllSeriesAreEnabledForAllDocuments |
Public method | GetOpenRecommendationData |
Public method | GetOpenedOrderRecomendationsBasedOnScenario |
Public method | GetOrderRecommendationDocumentIds |
Public method | GetPrefferedVendors |
Public method | GetPriceBasedOnBusinessPartnerPriceList |
Public method | GetProductionOrderDocumentId |
Public method | GetProductionOrderUnitPrice |
Public method | GetSpecialPriceForMrpVendor |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetUoMPrice | Gets the price defined for an item's unit of measure.
Public method | GetUserSeries | Gets the series available for user for particular objects and groups.
Public method | GetVendorDefaultPriceListName |
Public method | GetVendorPriceListPrice |
Public method | GetVendors |
Public method | GetVendorsData |
Public method | GetVendorsNames |
Public method | GetWarehouseLocationName |
Public method | InitializeItems |
Public method | InitializeItemsByCompany |
Public method | InitializeItemsByWhs |
Public method | IsVendorTheDefaultPreferredVendor |
Public method | PurchaseOrderBaseLoader |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateRecommendationQuantity | Updates the Quantity value in a corresponding ORCM database table record.
Public method | UpdateRecommendationStatus | Updates the Status value in a corresponding ORCM database table record.
Top
See Also

Reference

MRPBaseQueries Class
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries Methods

MRPBaseQueries Class See Also

The following tables list the members exposed by the MRPBaseQueries type.

Methods
 | Name | Description
Public method | BaseManufacturingOrderLoader |
Public method | BaseSalesOrderLoader | (Overloaded)
Public method | CheckProductTree |
Public method | CoproductsBOMList |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBlanketAgreements |
Public method | GetBusinessPlaceForWarehouse |
Public method | GetDefaultForMrpBillOfMaterialsCode |
Public method | GetDefaultVendorCode |
Public method | GetDuplicateOrderRecommendationDocumentIds |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemBaseUnitCode |
Public method | GetItemLastPurchasePrice |
Public method | GetItemPriceListPrice |
Public method | GetItemUnits |
Public method | GetItemVendors |
Public method | GetItemVendorsWithNames |
Public method | GetItemsRevisions |
Public method | GetItemsUnitOfMeasureData |
Public method | GetListOfAssignedManufacturingOrdersForSalesOrder |
Public method | GetManufacturingOrderDocEntry |
Public method | GetManufacturingOrderSeriesWhenAllSeriesAreEnabledForAllDocuments |
Public method | GetOpenRecommendationData |
Public method | GetOpenedOrderRecomendationsBasedOnScenario |
Public method | GetOrderRecommendationDocumentIds |
Public method | GetPrefferedVendors |
Public method | GetPriceBasedOnBusinessPartnerPriceList |
Public method | GetProductionOrderDocumentId |
Public method | GetProductionOrderUnitPrice |
Public method | GetSpecialPriceForMrpVendor |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetUoMPrice | Gets the price defined for an item's unit of measure.
Public method | GetUserSeries | Gets the series available for user for particular objects and groups.
Public method | GetVendorDefaultPriceListName |
Public method | GetVendorPriceListPrice |
Public method | GetVendors |
Public method | GetVendorsData |
Public method | GetVendorsNames |
Public method | GetWarehouseLocationName |
Public method | InitializeItems |
Public method | InitializeItemsByCompany |
Public method | InitializeItemsByWhs |
Public method | IsVendorTheDefaultPreferredVendor |
Public method | PurchaseOrderBaseLoader |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateRecommendationQuantity | Updates the Quantity value in a corresponding ORCM database table record.
Public method | UpdateRecommendationStatus | Updates the Status value in a corresponding ORCM database table record.
Top
See Also

Reference

MRPBaseQueries Class
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.BaseManufacturingOrderLoader Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function BaseManufacturingOrderLoader( _
   ByVal Token As String, _
   ByVal includerevisions As Boolean _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset BaseManufacturingOrderLoader(
   string Token,
   bool includerevisions
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ BaseManufacturingOrderLoader(
   String^ Token,
   bool includerevisions
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BaseManufacturingOrderLoader(
    Token : String,
    includerevisions : boolean
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

includerevisions

Type: bool

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.BaseSalesOrderLoader Method

MRPBaseQueries Class See Also

Overload List
Name | Description
BaseSalesOrderLoader(string, bool, bool, bool, IEnumerable<String>, IEnumerable<String>, IEnumerable<Int32>) |
BaseSalesOrderLoader(string, bool, string) |
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.CheckProductTree Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CheckProductTree( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset CheckProductTree(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ CheckProductTree(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CheckProductTree(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.CoproductsBOMList Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CoproductsBOMList( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset CoproductsBOMList(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ CoproductsBOMList(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CoproductsBOMList(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetBlanketAgreements Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBlanketAgreements( _
   ByVal token As String, _
   ByVal bpCode As String, _
   ByVal date As Date, _
   ByVal itemCode As String, _
   ByVal quantity As Double _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBlanketAgreements(
   string token,
   string bpCode,
   DateTime date,
   string itemCode,
   double quantity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBlanketAgreements(
   String^ token,
   String^ bpCode,
   DateTime date,
   String^ itemCode,
   double quantity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBlanketAgreements(
    token : String,
    bpCode : String,
    date : DateTime,
    itemCode : String,
    quantity : double
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

bpCode

Type: string

date

Type: DateTime

itemCode

Type: string

quantity

Type: double

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetBusinessPlaceForWarehouse Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBusinessPlaceForWarehouse( _
   ByVal token As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBusinessPlaceForWarehouse(
   string token,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBusinessPlaceForWarehouse(
   String^ token,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBusinessPlaceForWarehouse(
    token : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetDefaultForMrpBillOfMaterialsCode Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDefaultForMrpBillOfMaterialsCode( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDefaultForMrpBillOfMaterialsCode(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDefaultForMrpBillOfMaterialsCode(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDefaultForMrpBillOfMaterialsCode(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetDefaultVendorCode Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDefaultVendorCode( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDefaultVendorCode(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDefaultVendorCode(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDefaultVendorCode(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetDuplicateOrderRecommendationDocumentIds Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDuplicateOrderRecommendationDocumentIds( _
   ByVal token As String, _
   ByVal fromItemCode As String, _
   ByVal toItemCode As String, _
   ByVal objAbs As Integer, _
   ByVal date As Date _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDuplicateOrderRecommendationDocumentIds(
   string token,
   string fromItemCode,
   string toItemCode,
   int objAbs,
   DateTime date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDuplicateOrderRecommendationDocumentIds(
   String^ token,
   String^ fromItemCode,
   String^ toItemCode,
   int objAbs,
   DateTime date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDuplicateOrderRecommendationDocumentIds(
    token : String,
    fromItemCode : String,
    toItemCode : String,
    objAbs : int,
    date : DateTime
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

fromItemCode

Type: string

toItemCode

Type: string

objAbs

Type: int

date

Type: DateTime

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetItemBaseUnitCode Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemBaseUnitCode( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemBaseUnitCode(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemBaseUnitCode(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemBaseUnitCode(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetItemLastPurchasePrice Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemLastPurchasePrice( _
   ByVal token As String, _
   ByVal vendorCode As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemLastPurchasePrice(
   string token,
   string vendorCode,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemLastPurchasePrice(
   String^ token,
   String^ vendorCode,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemLastPurchasePrice(
    token : String,
    vendorCode : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

vendorCode

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetItemPriceListPrice Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemPriceListPrice( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemPriceListPrice(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemPriceListPrice(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemPriceListPrice(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetItemUnits Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemUnits( _
   ByVal token As String, _
   ByVal unitGroupId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemUnits(
   string token,
   int unitGroupId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemUnits(
   String^ token,
   int unitGroupId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemUnits(
    token : String,
    unitGroupId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

unitGroupId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetItemVendors Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemVendors( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal date As Date _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemVendors(
   string token,
   string itemCode,
   DateTime date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemVendors(
   String^ token,
   String^ itemCode,
   DateTime date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemVendors(
    token : String,
    itemCode : String,
    date : DateTime
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

date

Type: DateTime

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetItemVendorsWithNames Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemVendorsWithNames( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemVendorsWithNames(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemVendorsWithNames(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemVendorsWithNames(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetItemsRevisions Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemsRevisions( _
   ByVal token As String, _
   ByVal itemCodes As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemsRevisions(
   string token,
   List<string> itemCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemsRevisions(
   String^ token,
   List<String^>^ itemCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCodes

Type: List<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetItemsUnitOfMeasureData Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemsUnitOfMeasureData( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemsUnitOfMeasureData(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemsUnitOfMeasureData(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemsUnitOfMeasureData(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetListOfAssignedManufacturingOrdersForSalesOrder Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetListOfAssignedManufacturingOrdersForSalesOrder( _
   ByVal token As String, _
   ByVal salesOrderId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetListOfAssignedManufacturingOrdersForSalesOrder(
   string token,
   int salesOrderId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetListOfAssignedManufacturingOrdersForSalesOrder(
   String^ token,
   int salesOrderId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetListOfAssignedManufacturingOrdersForSalesOrder(
    token : String,
    salesOrderId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

salesOrderId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetManufacturingOrderDocEntry Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetManufacturingOrderDocEntry( _
   ByVal token As String, _
   ByVal docNo As Integer, _
   ByVal itemCode As String, _
   ByVal dueDate As Date, _
   ByVal quantity As Double _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetManufacturingOrderDocEntry(
   string token,
   int docNo,
   string itemCode,
   DateTime dueDate,
   double quantity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetManufacturingOrderDocEntry(
   String^ token,
   int docNo,
   String^ itemCode,
   DateTime dueDate,
   double quantity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetManufacturingOrderDocEntry(
    token : String,
    docNo : int,
    itemCode : String,
    dueDate : DateTime,
    quantity : double
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docNo

Type: int

itemCode

Type: string

dueDate

Type: DateTime

quantity

Type: double

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetManufacturingOrderSeriesWhenAllSeriesAreEnabledForAllDocuments Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetManufacturingOrderSeriesWhenAllSeriesAreEnabledForAllDocuments( _
   ByVal token As String, _
   ByVal objType As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetManufacturingOrderSeriesWhenAllSeriesAreEnabledForAllDocuments(
   string token,
   string objType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetManufacturingOrderSeriesWhenAllSeriesAreEnabledForAllDocuments(
   String^ token,
   String^ objType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetManufacturingOrderSeriesWhenAllSeriesAreEnabledForAllDocuments(
    token : String,
    objType : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

objType

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetOpenRecommendationData Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetOpenRecommendationData( _
   ByVal token As String, _
   ByVal status As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetOpenRecommendationData(
   string token,
   string status
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetOpenRecommendationData(
   String^ token,
   String^ status
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetOpenRecommendationData(
    token : String,
    status : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

status

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetOpenedOrderRecomendationsBasedOnScenario Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetOpenedOrderRecomendationsBasedOnScenario( _
   ByVal token As String, _
   ByVal scenarioCode As String _
) As List(Of String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<string> GetOpenedOrderRecomendationsBasedOnScenario(
   string token,
   string scenarioCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<String^>^ GetOpenedOrderRecomendationsBasedOnScenario(
   String^ token,
   String^ scenarioCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

scenarioCode

Type: string

Return Value

Type: List<string>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetOrderRecommendationDocumentIds Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetOrderRecommendationDocumentIds( _
   ByVal token As String, _
   ByVal fromItemCode As String, _
   ByVal toItemCode As String, _
   ByVal objAbs As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetOrderRecommendationDocumentIds(
   string token,
   string fromItemCode,
   string toItemCode,
   int objAbs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetOrderRecommendationDocumentIds(
   String^ token,
   String^ fromItemCode,
   String^ toItemCode,
   int objAbs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetOrderRecommendationDocumentIds(
    token : String,
    fromItemCode : String,
    toItemCode : String,
    objAbs : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

fromItemCode

Type: string

toItemCode

Type: string

objAbs

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetPrefferedVendors Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetPrefferedVendors( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetPrefferedVendors(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetPrefferedVendors(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetPrefferedVendors(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetPriceBasedOnBusinessPartnerPriceList Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetPriceBasedOnBusinessPartnerPriceList( _
   ByVal token As String, _
   ByVal businessPartnerCode As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetPriceBasedOnBusinessPartnerPriceList(
   string token,
   string businessPartnerCode,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetPriceBasedOnBusinessPartnerPriceList(
   String^ token,
   String^ businessPartnerCode,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetPriceBasedOnBusinessPartnerPriceList(
    token : String,
    businessPartnerCode : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

businessPartnerCode

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset

CTRecordset object with the results.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetProductionOrderDocumentId Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetProductionOrderDocumentId( _
   ByVal token As String, _
   ByVal manOrderId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetProductionOrderDocumentId(
   string token,
   int manOrderId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetProductionOrderDocumentId(
   String^ token,
   int manOrderId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetProductionOrderDocumentId(
    token : String,
    manOrderId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

manOrderId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetProductionOrderUnitPrice Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetProductionOrderUnitPrice( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetProductionOrderUnitPrice(
   string token,
   string itemCode,
   string revCode,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetProductionOrderUnitPrice(
   String^ token,
   String^ itemCode,
   String^ revCode,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetProductionOrderUnitPrice(
    token : String,
    itemCode : String,
    revCode : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetSpecialPriceForMrpVendor Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSpecialPriceForMrpVendor( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal vendorCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSpecialPriceForMrpVendor(
   string token,
   string itemCode,
   string vendorCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSpecialPriceForMrpVendor(
   String^ token,
   String^ itemCode,
   String^ vendorCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSpecialPriceForMrpVendor(
    token : String,
    itemCode : String,
    vendorCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

vendorCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetUoMPrice Method

Gets the price defined for an item's unit of measure.

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetUoMPrice( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal uomCode As String _
) As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double GetUoMPrice(
   string token,
   string itemCode,
   string uomCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
double GetUoMPrice(
   String^ token,
   String^ itemCode,
   String^ uomCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetUoMPrice(
    token : String,
    itemCode : String,
    uomCode : String
) : double;
This language is not supported or no code example is available.

Parameters

token

Type: string

Token.

itemCode

Type: string

Item code.

uomCode

Type: string

Unit of measure code.

Return Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetUserSeries Method

Gets the series available for user for particular objects and groups.

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetUserSeries( _
   ByVal token As String, _
   ByVal objectCodes As List(Of String), _
   ByVal groupCodes As List(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetUserSeries(
   string token,
   List<string> objectCodes,
   List<int> groupCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetUserSeries(
   String^ token,
   List<String^>^ objectCodes,
   List<int>^ groupCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

Token.

objectCodes

Type: List<string>

A collection with object codes.

groupCodes

Type: List<int>

A collection with series group codes.

Return Value

Type: CTRecordset

CTRecordset object.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetVendorDefaultPriceListName Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetVendorDefaultPriceListName( _
   ByVal token As String, _
   ByVal vendorCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetVendorDefaultPriceListName(
   string token,
   string vendorCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetVendorDefaultPriceListName(
   String^ token,
   String^ vendorCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetVendorDefaultPriceListName(
    token : String,
    vendorCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

vendorCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetVendorPriceListPrice Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetVendorPriceListPrice( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal vendorCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetVendorPriceListPrice(
   string token,
   string itemCode,
   string vendorCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetVendorPriceListPrice(
   String^ token,
   String^ itemCode,
   String^ vendorCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetVendorPriceListPrice(
    token : String,
    itemCode : String,
    vendorCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

vendorCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetVendors Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetVendors( _
   ByVal Token As String, _
   ByVal cardCodes As IEnumerable(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetVendors(
   string Token,
   IEnumerable<string> cardCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetVendors(
   String^ Token,
   IEnumerable<String^>^ cardCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

cardCodes

Type: IEnumerable<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetVendorsData Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetVendorsData( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetVendorsData(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetVendorsData(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetVendorsData(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetVendorsNames Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetVendorsNames( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetVendorsNames(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetVendorsNames(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetVendorsNames(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.GetWarehouseLocationName Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetWarehouseLocationName( _
   ByVal token As String, _
   ByVal WhsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetWarehouseLocationName(
   string token,
   string WhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetWarehouseLocationName(
   String^ token,
   String^ WhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetWarehouseLocationName(
    token : String,
    WhsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

WhsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.InitializeItems Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function InitializeItems( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset InitializeItems(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ InitializeItems(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function InitializeItems(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.InitializeItemsByCompany Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function InitializeItemsByCompany( _
   ByVal Token As String, _
   ByVal includerevisions As Boolean, _
   ByVal scenarioCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset InitializeItemsByCompany(
   string Token,
   bool includerevisions,
   string scenarioCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ InitializeItemsByCompany(
   String^ Token,
   bool includerevisions,
   String^ scenarioCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function InitializeItemsByCompany(
    Token : String,
    includerevisions : boolean,
    scenarioCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

includerevisions

Type: bool

scenarioCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.InitializeItemsByWhs Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function InitializeItemsByWhs( _
   ByVal Token As String, _
   ByVal includerevisions As Boolean, _
   ByVal scenarioCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset InitializeItemsByWhs(
   string Token,
   bool includerevisions,
   string scenarioCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ InitializeItemsByWhs(
   String^ Token,
   bool includerevisions,
   String^ scenarioCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function InitializeItemsByWhs(
    Token : String,
    includerevisions : boolean,
    scenarioCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

includerevisions

Type: bool

scenarioCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.IsVendorTheDefaultPreferredVendor Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function IsVendorTheDefaultPreferredVendor( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal vendorCode As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool IsVendorTheDefaultPreferredVendor(
   string token,
   string itemCode,
   string vendorCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool IsVendorTheDefaultPreferredVendor(
   String^ token,
   String^ itemCode,
   String^ vendorCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function IsVendorTheDefaultPreferredVendor(
    token : String,
    itemCode : String,
    vendorCode : String
) : boolean;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

vendorCode

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.PurchaseOrderBaseLoader Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function PurchaseOrderBaseLoader( _
   ByVal Token As String, _
   ByVal configurationCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset PurchaseOrderBaseLoader(
   string Token,
   string configurationCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ PurchaseOrderBaseLoader(
   String^ Token,
   String^ configurationCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function PurchaseOrderBaseLoader(
    Token : String,
    configurationCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

configurationCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.UpdateRecommendationQuantity Method

Updates the Quantity value in a corresponding ORCM database table record.

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub UpdateRecommendationQuantity( _
   ByVal token As String, _
   ByVal recommendationId As Integer, _
   ByVal quantityCreated As Double _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void UpdateRecommendationQuantity(
   string token,
   int recommendationId,
   double quantityCreated
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void UpdateRecommendationQuantity(
   String^ token,
   int recommendationId,
   double quantityCreated
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UpdateRecommendationQuantity(
    token : String,
    recommendationId : int,
    quantityCreated : double
);
This language is not supported or no code example is available.

Parameters

token

Type: string

recommendationId

Type: int

Recommendation ID.

quantityCreated

Type: double

Quantity that has been created for an order.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.UpdateRecommendationStatus Method

Updates the Status value in a corresponding ORCM database table record.

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub UpdateRecommendationStatus( _
   ByVal token As String, _
   ByVal recommendationId As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void UpdateRecommendationStatus(
   string token,
   int recommendationId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void UpdateRecommendationStatus(
   String^ token,
   int recommendationId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UpdateRecommendationStatus(
    token : String,
    recommendationId : int
);
This language is not supported or no code example is available.

Parameters

token

Type: string

recommendationId

Type: int

Recommendation ID.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPSapHanaQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MRPSapHanaQueries
    Inherits MRPBaseQueries
    Implements IMRPQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPSapHanaQueries : MRPBaseQueries,
   IMRPQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MRPSapHanaQueries : public MRPBaseQueries^,
   public IMRPQueries^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPSapHanaQueries
   extends MRPBaseQueries
   implements IMRPQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.MRP.MRPBaseQueries
CompuTec.ProcessForce.API.Queries.MRP.MRPSapHanaQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPSapHanaQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPSapHanaQueries Members

MRPSapHanaQueries Class Methods See Also

The following tables list the members exposed by the MRPSapHanaQueries type.

Methods
 | Name | Description
Public method | BaseManufacturingOrderLoader | (inherited from MRPBaseQueries).
Public method | BaseSalesOrderLoader | (Overloaded) (inherited from MRPBaseQueries).
Public method | CheckProductTree | (inherited from MRPBaseQueries).
Public method | CoproductsBOMList | (inherited from MRPBaseQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBlanketAgreements | (inherited from MRPBaseQueries).
Public method | GetBusinessPlaceForWarehouse | (inherited from MRPBaseQueries).
Public method | GetDefaultForMrpBillOfMaterialsCode | (inherited from MRPBaseQueries).
Public method | GetDefaultVendorCode | (inherited from MRPBaseQueries).
Public method | GetDuplicateOrderRecommendationDocumentIds | (inherited from MRPBaseQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemBaseUnitCode | (inherited from MRPBaseQueries).
Public method | GetItemLastPurchasePrice | (inherited from MRPBaseQueries).
Public method | GetItemPriceListPrice | (inherited from MRPBaseQueries).
Public method | GetItemUnits | (inherited from MRPBaseQueries).
Public method | GetItemVendors | (inherited from MRPBaseQueries).
Public method | GetItemVendorsWithNames | (inherited from MRPBaseQueries).
Public method | GetItemsRevisions | (inherited from MRPBaseQueries).
Public method | GetItemsUnitOfMeasureData | (inherited from MRPBaseQueries).
Public method | GetListOfAssignedManufacturingOrdersForSalesOrder | (inherited from MRPBaseQueries).
Public method | GetManufacturingOrderDocEntry | (inherited from MRPBaseQueries).
Public method | GetManufacturingOrderSeriesWhenAllSeriesAreEnabledForAllDocuments | (inherited from MRPBaseQueries).
Public method | GetOpenRecommendationData | (inherited from MRPBaseQueries).
Public method | GetOpenedOrderRecomendationsBasedOnScenario | (inherited from MRPBaseQueries).
Public method | GetOrderRecommendationDocumentIds | (inherited from MRPBaseQueries).
Public method | GetPrefferedVendors | (inherited from MRPBaseQueries).
Public method | GetPriceBasedOnBusinessPartnerPriceList | (inherited from MRPBaseQueries).
Public method | GetProductionOrderDocumentId | (inherited from MRPBaseQueries).
Public method | GetProductionOrderUnitPrice | (inherited from MRPBaseQueries).
Public method | GetSpecialPriceForMrpVendor | (inherited from MRPBaseQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetUoMPrice | Gets the price defined for an item's unit of measure. (inherited from MRPBaseQueries).
Public method | GetUserSeries | Gets the series available for user for particular objects and groups. (inherited from MRPBaseQueries).
Public method | GetVendorDefaultPriceListName | (inherited from MRPBaseQueries).
Public method | GetVendorPriceListPrice | (inherited from MRPBaseQueries).
Public method | GetVendors | (inherited from MRPBaseQueries).
Public method | GetVendorsData | (inherited from MRPBaseQueries).
Public method | GetVendorsNames | (inherited from MRPBaseQueries).
Public method | GetWarehouseLocationName | (inherited from MRPBaseQueries).
Public method | InitializeItems | (inherited from MRPBaseQueries).
Public method | InitializeItemsByCompany | (inherited from MRPBaseQueries).
Public method | InitializeItemsByWhs | (inherited from MRPBaseQueries).
Public method | IsVendorTheDefaultPreferredVendor | (inherited from MRPBaseQueries).
Public method | PurchaseOrderBaseLoader | (inherited from MRPBaseQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateRecommendationQuantity | Updates the Quantity value in a corresponding ORCM database table record. (inherited from MRPBaseQueries).
Public method | UpdateRecommendationStatus | Updates the Status value in a corresponding ORCM database table record. (inherited from MRPBaseQueries).
Top
See Also

Reference

MRPSapHanaQueries Class
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPSapHanaQueries Methods

MRPSapHanaQueries Class See Also

The following tables list the members exposed by the MRPSapHanaQueries type.

Methods
 | Name | Description
Public method | BaseManufacturingOrderLoader | (inherited from MRPBaseQueries).
Public method | BaseSalesOrderLoader | (Overloaded) (inherited from MRPBaseQueries).
Public method | CheckProductTree | (inherited from MRPBaseQueries).
Public method | CoproductsBOMList | (inherited from MRPBaseQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBlanketAgreements | (inherited from MRPBaseQueries).
Public method | GetBusinessPlaceForWarehouse | (inherited from MRPBaseQueries).
Public method | GetDefaultForMrpBillOfMaterialsCode | (inherited from MRPBaseQueries).
Public method | GetDefaultVendorCode | (inherited from MRPBaseQueries).
Public method | GetDuplicateOrderRecommendationDocumentIds | (inherited from MRPBaseQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemBaseUnitCode | (inherited from MRPBaseQueries).
Public method | GetItemLastPurchasePrice | (inherited from MRPBaseQueries).
Public method | GetItemPriceListPrice | (inherited from MRPBaseQueries).
Public method | GetItemUnits | (inherited from MRPBaseQueries).
Public method | GetItemVendors | (inherited from MRPBaseQueries).
Public method | GetItemVendorsWithNames | (inherited from MRPBaseQueries).
Public method | GetItemsRevisions | (inherited from MRPBaseQueries).
Public method | GetItemsUnitOfMeasureData | (inherited from MRPBaseQueries).
Public method | GetListOfAssignedManufacturingOrdersForSalesOrder | (inherited from MRPBaseQueries).
Public method | GetManufacturingOrderDocEntry | (inherited from MRPBaseQueries).
Public method | GetManufacturingOrderSeriesWhenAllSeriesAreEnabledForAllDocuments | (inherited from MRPBaseQueries).
Public method | GetOpenRecommendationData | (inherited from MRPBaseQueries).
Public method | GetOpenedOrderRecomendationsBasedOnScenario | (inherited from MRPBaseQueries).
Public method | GetOrderRecommendationDocumentIds | (inherited from MRPBaseQueries).
Public method | GetPrefferedVendors | (inherited from MRPBaseQueries).
Public method | GetPriceBasedOnBusinessPartnerPriceList | (inherited from MRPBaseQueries).
Public method | GetProductionOrderDocumentId | (inherited from MRPBaseQueries).
Public method | GetProductionOrderUnitPrice | (inherited from MRPBaseQueries).
Public method | GetSpecialPriceForMrpVendor | (inherited from MRPBaseQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetUoMPrice | Gets the price defined for an item's unit of measure. (inherited from MRPBaseQueries).
Public method | GetUserSeries | Gets the series available for user for particular objects and groups. (inherited from MRPBaseQueries).
Public method | GetVendorDefaultPriceListName | (inherited from MRPBaseQueries).
Public method | GetVendorPriceListPrice | (inherited from MRPBaseQueries).
Public method | GetVendors | (inherited from MRPBaseQueries).
Public method | GetVendorsData | (inherited from MRPBaseQueries).
Public method | GetVendorsNames | (inherited from MRPBaseQueries).
Public method | GetWarehouseLocationName | (inherited from MRPBaseQueries).
Public method | InitializeItems | (inherited from MRPBaseQueries).
Public method | InitializeItemsByCompany | (inherited from MRPBaseQueries).
Public method | InitializeItemsByWhs | (inherited from MRPBaseQueries).
Public method | IsVendorTheDefaultPreferredVendor | (inherited from MRPBaseQueries).
Public method | PurchaseOrderBaseLoader | (inherited from MRPBaseQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateRecommendationQuantity | Updates the Quantity value in a corresponding ORCM database table record. (inherited from MRPBaseQueries).
Public method | UpdateRecommendationStatus | Updates the Status value in a corresponding ORCM database table record. (inherited from MRPBaseQueries).
Top
See Also

Reference

MRPSapHanaQueries Class
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPSqlServerQuerties Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MRPSqlServerQuerties
    Inherits MRPBaseQueries
    Implements IMRPQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPSqlServerQuerties : MRPBaseQueries,
   IMRPQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MRPSqlServerQuerties : public MRPBaseQueries^,
   public IMRPQueries^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPSqlServerQuerties
   extends MRPBaseQueries
   implements IMRPQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.MRP.MRPBaseQueries
CompuTec.ProcessForce.API.Queries.MRP.MRPSqlServerQuerties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPSqlServerQuerties Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPSqlServerQuerties Members

MRPSqlServerQuerties Class Methods See Also

The following tables list the members exposed by the MRPSqlServerQuerties type.

Methods
 | Name | Description
Public method | BaseManufacturingOrderLoader | (inherited from MRPBaseQueries).
Public method | BaseSalesOrderLoader | (Overloaded) (inherited from MRPBaseQueries).
Public method | CheckProductTree | (inherited from MRPBaseQueries).
Public method | CoproductsBOMList | (inherited from MRPBaseQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBlanketAgreements | (inherited from MRPBaseQueries).
Public method | GetBusinessPlaceForWarehouse | (inherited from MRPBaseQueries).
Public method | GetDefaultForMrpBillOfMaterialsCode | (inherited from MRPBaseQueries).
Public method | GetDefaultVendorCode | (inherited from MRPBaseQueries).
Public method | GetDuplicateOrderRecommendationDocumentIds | (inherited from MRPBaseQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemBaseUnitCode | (inherited from MRPBaseQueries).
Public method | GetItemLastPurchasePrice | (inherited from MRPBaseQueries).
Public method | GetItemPriceListPrice | (inherited from MRPBaseQueries).
Public method | GetItemUnits | (inherited from MRPBaseQueries).
Public method | GetItemVendors | (inherited from MRPBaseQueries).
Public method | GetItemVendorsWithNames | (inherited from MRPBaseQueries).
Public method | GetItemsRevisions | (inherited from MRPBaseQueries).
Public method | GetItemsUnitOfMeasureData | (inherited from MRPBaseQueries).
Public method | GetListOfAssignedManufacturingOrdersForSalesOrder | (inherited from MRPBaseQueries).
Public method | GetManufacturingOrderDocEntry | (inherited from MRPBaseQueries).
Public method | GetManufacturingOrderSeriesWhenAllSeriesAreEnabledForAllDocuments | (inherited from MRPBaseQueries).
Public method | GetOpenRecommendationData | (inherited from MRPBaseQueries).
Public method | GetOpenedOrderRecomendationsBasedOnScenario | (inherited from MRPBaseQueries).
Public method | GetOrderRecommendationDocumentIds | (inherited from MRPBaseQueries).
Public method | GetPrefferedVendors | (inherited from MRPBaseQueries).
Public method | GetPriceBasedOnBusinessPartnerPriceList | (inherited from MRPBaseQueries).
Public method | GetProductionOrderDocumentId | (inherited from MRPBaseQueries).
Public method | GetProductionOrderUnitPrice | (inherited from MRPBaseQueries).
Public method | GetSpecialPriceForMrpVendor | (inherited from MRPBaseQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetUoMPrice | Gets the price defined for an item's unit of measure. (inherited from MRPBaseQueries).
Public method | GetUserSeries | Gets the series available for user for particular objects and groups. (inherited from MRPBaseQueries).
Public method | GetVendorDefaultPriceListName | (inherited from MRPBaseQueries).
Public method | GetVendorPriceListPrice | (inherited from MRPBaseQueries).
Public method | GetVendors | (inherited from MRPBaseQueries).
Public method | GetVendorsData | (inherited from MRPBaseQueries).
Public method | GetVendorsNames | (inherited from MRPBaseQueries).
Public method | GetWarehouseLocationName | (inherited from MRPBaseQueries).
Public method | InitializeItems | (inherited from MRPBaseQueries).
Public method | InitializeItemsByCompany | (inherited from MRPBaseQueries).
Public method | InitializeItemsByWhs | (inherited from MRPBaseQueries).
Public method | IsVendorTheDefaultPreferredVendor | (inherited from MRPBaseQueries).
Public method | PurchaseOrderBaseLoader | (inherited from MRPBaseQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateRecommendationQuantity | Updates the Quantity value in a corresponding ORCM database table record. (inherited from MRPBaseQueries).
Public method | UpdateRecommendationStatus | Updates the Status value in a corresponding ORCM database table record. (inherited from MRPBaseQueries).
Top
See Also

Reference

MRPSqlServerQuerties Class
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPSqlServerQuerties Methods

MRPSqlServerQuerties Class See Also

The following tables list the members exposed by the MRPSqlServerQuerties type.

Methods
 | Name | Description
Public method | BaseManufacturingOrderLoader | (inherited from MRPBaseQueries).
Public method | BaseSalesOrderLoader | (Overloaded) (inherited from MRPBaseQueries).
Public method | CheckProductTree | (inherited from MRPBaseQueries).
Public method | CoproductsBOMList | (inherited from MRPBaseQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBlanketAgreements | (inherited from MRPBaseQueries).
Public method | GetBusinessPlaceForWarehouse | (inherited from MRPBaseQueries).
Public method | GetDefaultForMrpBillOfMaterialsCode | (inherited from MRPBaseQueries).
Public method | GetDefaultVendorCode | (inherited from MRPBaseQueries).
Public method | GetDuplicateOrderRecommendationDocumentIds | (inherited from MRPBaseQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemBaseUnitCode | (inherited from MRPBaseQueries).
Public method | GetItemLastPurchasePrice | (inherited from MRPBaseQueries).
Public method | GetItemPriceListPrice | (inherited from MRPBaseQueries).
Public method | GetItemUnits | (inherited from MRPBaseQueries).
Public method | GetItemVendors | (inherited from MRPBaseQueries).
Public method | GetItemVendorsWithNames | (inherited from MRPBaseQueries).
Public method | GetItemsRevisions | (inherited from MRPBaseQueries).
Public method | GetItemsUnitOfMeasureData | (inherited from MRPBaseQueries).
Public method | GetListOfAssignedManufacturingOrdersForSalesOrder | (inherited from MRPBaseQueries).
Public method | GetManufacturingOrderDocEntry | (inherited from MRPBaseQueries).
Public method | GetManufacturingOrderSeriesWhenAllSeriesAreEnabledForAllDocuments | (inherited from MRPBaseQueries).
Public method | GetOpenRecommendationData | (inherited from MRPBaseQueries).
Public method | GetOpenedOrderRecomendationsBasedOnScenario | (inherited from MRPBaseQueries).
Public method | GetOrderRecommendationDocumentIds | (inherited from MRPBaseQueries).
Public method | GetPrefferedVendors | (inherited from MRPBaseQueries).
Public method | GetPriceBasedOnBusinessPartnerPriceList | (inherited from MRPBaseQueries).
Public method | GetProductionOrderDocumentId | (inherited from MRPBaseQueries).
Public method | GetProductionOrderUnitPrice | (inherited from MRPBaseQueries).
Public method | GetSpecialPriceForMrpVendor | (inherited from MRPBaseQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetUoMPrice | Gets the price defined for an item's unit of measure. (inherited from MRPBaseQueries).
Public method | GetUserSeries | Gets the series available for user for particular objects and groups. (inherited from MRPBaseQueries).
Public method | GetVendorDefaultPriceListName | (inherited from MRPBaseQueries).
Public method | GetVendorPriceListPrice | (inherited from MRPBaseQueries).
Public method | GetVendors | (inherited from MRPBaseQueries).
Public method | GetVendorsData | (inherited from MRPBaseQueries).
Public method | GetVendorsNames | (inherited from MRPBaseQueries).
Public method | GetWarehouseLocationName | (inherited from MRPBaseQueries).
Public method | InitializeItems | (inherited from MRPBaseQueries).
Public method | InitializeItemsByCompany | (inherited from MRPBaseQueries).
Public method | InitializeItemsByWhs | (inherited from MRPBaseQueries).
Public method | IsVendorTheDefaultPreferredVendor | (inherited from MRPBaseQueries).
Public method | PurchaseOrderBaseLoader | (inherited from MRPBaseQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateRecommendationQuantity | Updates the Quantity value in a corresponding ORCM database table record. (inherited from MRPBaseQueries).
Public method | UpdateRecommendationStatus | Updates the Status value in a corresponding ORCM database table record. (inherited from MRPBaseQueries).
Top
See Also

Reference

MRPSqlServerQuerties Class
CompuTec.ProcessForce.API.Queries.MRP Namespace


IMRPQueries Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IMRPQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IMRPQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IMRPQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IMRPQueries
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


IMRPQueries Members

IMRPQueries Interface Methods See Also

The following tables list the members exposed by the IMRPQueries type.

Methods
 | Name | Description
Public method | BaseManufacturingOrderLoader |
Public method | BaseSalesOrderLoader |
Public method | CoproductsBOMList |
Public method | GetOpenedOrderRecomendationsBasedOnScenario |
Public method | GetPrefferedVendors |
Public method | GetVendors |
Public method | GetVendorsData |
Public method | InitializeItems |
Public method | InitializeItemsByCompany |
Public method | InitializeItemsByWhs |
Public method | PurchaseOrderBaseLoader |
Top
See Also

Reference

IMRPQueries Interface
CompuTec.ProcessForce.API.Queries.MRP Namespace


IMRPQueries Methods

IMRPQueries Interface See Also

The following tables list the members exposed by the IMRPQueries type.

Methods
 | Name | Description
Public method | BaseManufacturingOrderLoader |
Public method | BaseSalesOrderLoader |
Public method | CoproductsBOMList |
Public method | GetOpenedOrderRecomendationsBasedOnScenario |
Public method | GetPrefferedVendors |
Public method | GetVendors |
Public method | GetVendorsData |
Public method | InitializeItems |
Public method | InitializeItemsByCompany |
Public method | InitializeItemsByWhs |
Public method | PurchaseOrderBaseLoader |
Top
See Also

Reference

IMRPQueries Interface
CompuTec.ProcessForce.API.Queries.MRP Namespace


IMRPQueries.BaseManufacturingOrderLoader Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function BaseManufacturingOrderLoader( _
   ByVal Token As String, _
   ByVal includerevisions As Boolean _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset BaseManufacturingOrderLoader(
   string Token,
   bool includerevisions
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ BaseManufacturingOrderLoader(
   String^ Token,
   bool includerevisions
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function BaseManufacturingOrderLoader(
    Token : String,
    includerevisions : boolean
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

includerevisions

Type: bool

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPQueries Interface
IMRPQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


IMRPQueries.BaseSalesOrderLoader Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function BaseSalesOrderLoader( _
   ByVal Token As String, _
   ByVal includerevisions As Boolean, _
   ByVal scenarioCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset BaseSalesOrderLoader(
   string Token,
   bool includerevisions,
   string scenarioCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ BaseSalesOrderLoader(
   String^ Token,
   bool includerevisions,
   String^ scenarioCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function BaseSalesOrderLoader(
    Token : String,
    includerevisions : boolean,
    scenarioCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

includerevisions

Type: bool

scenarioCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPQueries Interface
IMRPQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


IMRPQueries.CoproductsBOMList Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CoproductsBOMList( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset CoproductsBOMList(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ CoproductsBOMList(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CoproductsBOMList(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPQueries Interface
IMRPQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


IMRPQueries.GetOpenedOrderRecomendationsBasedOnScenario Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetOpenedOrderRecomendationsBasedOnScenario( _
   ByVal token As String, _
   ByVal scenarioCode As String _
) As List(Of String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<string> GetOpenedOrderRecomendationsBasedOnScenario(
   string token,
   string scenarioCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

List<String^>^ GetOpenedOrderRecomendationsBasedOnScenario(
   String^ token,
   String^ scenarioCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

scenarioCode

Type: string

Return Value

Type: List<string>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPQueries Interface
IMRPQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


IMRPQueries.GetPrefferedVendors Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetPrefferedVendors( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetPrefferedVendors(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetPrefferedVendors(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetPrefferedVendors(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPQueries Interface
IMRPQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


IMRPQueries.GetVendors Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetVendors( _
   ByVal Token As String, _
   ByVal cardCodes As IEnumerable(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetVendors(
   string Token,
   IEnumerable<string> cardCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetVendors(
   String^ Token,
   IEnumerable<String^>^ cardCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

cardCodes

Type: IEnumerable<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPQueries Interface
IMRPQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


IMRPQueries.GetVendorsData Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetVendorsData( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetVendorsData(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetVendorsData(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetVendorsData(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPQueries Interface
IMRPQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


IMRPQueries.InitializeItems Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function InitializeItems( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset InitializeItems(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ InitializeItems(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function InitializeItems(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPQueries Interface
IMRPQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


IMRPQueries.InitializeItemsByCompany Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function InitializeItemsByCompany( _
   ByVal Token As String, _
   ByVal includerevisions As Boolean, _
   ByVal scenarioCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset InitializeItemsByCompany(
   string Token,
   bool includerevisions,
   string scenarioCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ InitializeItemsByCompany(
   String^ Token,
   bool includerevisions,
   String^ scenarioCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function InitializeItemsByCompany(
    Token : String,
    includerevisions : boolean,
    scenarioCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

includerevisions

Type: bool

scenarioCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPQueries Interface
IMRPQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


IMRPQueries.InitializeItemsByWhs Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function InitializeItemsByWhs( _
   ByVal Token As String, _
   ByVal includerevisions As Boolean, _
   ByVal scenarioCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset InitializeItemsByWhs(
   string Token,
   bool includerevisions,
   string scenarioCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ InitializeItemsByWhs(
   String^ Token,
   bool includerevisions,
   String^ scenarioCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function InitializeItemsByWhs(
    Token : String,
    includerevisions : boolean,
    scenarioCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

includerevisions

Type: bool

scenarioCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPQueries Interface
IMRPQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


IMRPQueries.PurchaseOrderBaseLoader Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function PurchaseOrderBaseLoader( _
   ByVal Token As String, _
   ByVal configurationCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset PurchaseOrderBaseLoader(
   string Token,
   string configurationCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ PurchaseOrderBaseLoader(
   String^ Token,
   String^ configurationCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function PurchaseOrderBaseLoader(
    Token : String,
    configurationCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

configurationCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPQueries Interface
IMRPQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


CompuTec.ProcessForce.API.Queries.Maintanance Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | MaintananceBaseQuery |
Top
Interfaces
 | Name | Description
Public interface | IMaintananceBaseQuery |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


MaintananceBaseQuery Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.Maintanance
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MaintananceBaseQuery
    Implements IMaintananceBaseQuery
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MaintananceBaseQuery : IMaintananceBaseQuery
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MaintananceBaseQuery  : public IMaintananceBaseQuery^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MaintananceBaseQuery
   implements IMaintananceBaseQuery
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.Maintanance.MaintananceBaseQuery
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MaintananceBaseQuery Members
CompuTec.ProcessForce.API.Queries.Maintanance Namespace


MaintananceBaseQuery Members

MaintananceBaseQuery Class Methods See Also

The following tables list the members exposed by the MaintananceBaseQuery type.

Methods
 | Name | Description
Public method | CloseDownTimeInformationForPDC |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetTasksToPause |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MaintananceBaseQuery Class
CompuTec.ProcessForce.API.Queries.Maintanance Namespace


MaintananceBaseQuery Methods

MaintananceBaseQuery Class See Also

The following tables list the members exposed by the MaintananceBaseQuery type.

Methods
 | Name | Description
Public method | CloseDownTimeInformationForPDC |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetTasksToPause |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MaintananceBaseQuery Class
CompuTec.ProcessForce.API.Queries.Maintanance Namespace


MaintananceBaseQuery.CloseDownTimeInformationForPDC Method

Namespace: CompuTec.ProcessForce.API.Queries.Maintanance
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CloseDownTimeInformationForPDC( _
   ByVal Token As String, _
   ByVal resourceCode As String, _
   ByVal closeDateTime As Date _
) As CTRecordset Implements  _
   IMaintananceBaseQuery.CloseDownTimeInformationForPDC
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset CloseDownTimeInformationForPDC(
   string Token,
   string resourceCode,
   DateTime closeDateTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ CloseDownTimeInformationForPDC(
   String^ Token,
   String^ resourceCode,
   DateTime closeDateTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CloseDownTimeInformationForPDC(
    Token : String,
    resourceCode : String,
    closeDateTime : DateTime
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

resourceCode

Type: string

closeDateTime

Type: DateTime

Return Value

Type: CTRecordset

Implements

IMaintananceBaseQuery.CloseDownTimeInformationForPDC
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MaintananceBaseQuery Class
MaintananceBaseQuery Members
CompuTec.ProcessForce.API.Queries.Maintanance Namespace


MaintananceBaseQuery.GetTasksToPause Method

Namespace: CompuTec.ProcessForce.API.Queries.Maintanance
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTasksToPause( _
   ByVal Token As String, _
   ByVal resourceCode As String, _
   ByVal BaseCode As String _
) As CTRecordset Implements  _
   IMaintananceBaseQuery.GetTasksToPause
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTasksToPause(
   string Token,
   string resourceCode,
   string BaseCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTasksToPause(
   String^ Token,
   String^ resourceCode,
   String^ BaseCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetTasksToPause(
    Token : String,
    resourceCode : String,
    BaseCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

resourceCode

Type: string

BaseCode

Type: string

Return Value

Type: CTRecordset

Implements

IMaintananceBaseQuery.GetTasksToPause
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MaintananceBaseQuery Class
MaintananceBaseQuery Members
CompuTec.ProcessForce.API.Queries.Maintanance Namespace


IMaintananceBaseQuery Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.Maintanance
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IMaintananceBaseQuery
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IMaintananceBaseQuery
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IMaintananceBaseQuery
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IMaintananceBaseQuery
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMaintananceBaseQuery Members
CompuTec.ProcessForce.API.Queries.Maintanance Namespace


IMaintananceBaseQuery Members

IMaintananceBaseQuery Interface Methods See Also

The following tables list the members exposed by the IMaintananceBaseQuery type.

Methods
 | Name | Description
Public method | CloseDownTimeInformationForPDC |
Public method | GetTasksToPause |
Top
See Also

Reference

IMaintananceBaseQuery Interface
CompuTec.ProcessForce.API.Queries.Maintanance Namespace


IMaintananceBaseQuery Methods

IMaintananceBaseQuery Interface See Also

The following tables list the members exposed by the IMaintananceBaseQuery type.

Methods
 | Name | Description
Public method | CloseDownTimeInformationForPDC |
Public method | GetTasksToPause |
Top
See Also

Reference

IMaintananceBaseQuery Interface
CompuTec.ProcessForce.API.Queries.Maintanance Namespace


IMaintananceBaseQuery.CloseDownTimeInformationForPDC Method

Namespace: CompuTec.ProcessForce.API.Queries.Maintanance
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function CloseDownTimeInformationForPDC( _
   ByVal Tokenm As String, _
   ByVal ResourceCode As String, _
   ByVal closeDateTime As Date _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset CloseDownTimeInformationForPDC(
   string Tokenm,
   string ResourceCode,
   DateTime closeDateTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ CloseDownTimeInformationForPDC(
   String^ Tokenm,
   String^ ResourceCode,
   DateTime closeDateTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function CloseDownTimeInformationForPDC(
    Tokenm : String,
    ResourceCode : String,
    closeDateTime : DateTime
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Tokenm

Type: string

ResourceCode

Type: string

closeDateTime

Type: DateTime

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMaintananceBaseQuery Interface
IMaintananceBaseQuery Members
CompuTec.ProcessForce.API.Queries.Maintanance Namespace


IMaintananceBaseQuery.GetTasksToPause Method

Namespace: CompuTec.ProcessForce.API.Queries.Maintanance
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetTasksToPause( _
   ByVal Token As String, _
   ByVal resourceCode As String, _
   ByVal BaseCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetTasksToPause(
   string Token,
   string resourceCode,
   string BaseCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetTasksToPause(
   String^ Token,
   String^ resourceCode,
   String^ BaseCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetTasksToPause(
    Token : String,
    resourceCode : String,
    BaseCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

resourceCode

Type: string

BaseCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMaintananceBaseQuery Interface
IMaintananceBaseQuery Members
CompuTec.ProcessForce.API.Queries.Maintanance Namespace


CompuTec.ProcessForce.API.Queries.PickAndPack Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | HAHAPickAndPackQueries |
Public class | PickAndPackBaseQuerties |
Public class | SQLPickAndPackQueries |
Top
Interfaces
 | Name | Description
Public interface | IPickAndPackQueries |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


HAHAPickAndPackQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class HAHAPickAndPackQueries
    Inherits PickAndPackBaseQuerties
    Implements IPickAndPackQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class HAHAPickAndPackQueries : PickAndPackBaseQuerties,
   IPickAndPackQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class HAHAPickAndPackQueries : public PickAndPackBaseQuerties^,
   public IPickAndPackQueries^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class HAHAPickAndPackQueries
   extends PickAndPackBaseQuerties
   implements IPickAndPackQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.PickAndPack.PickAndPackBaseQuerties
CompuTec.ProcessForce.API.Queries.PickAndPack.HAHAPickAndPackQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HAHAPickAndPackQueries Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


HAHAPickAndPackQueries Members

HAHAPickAndPackQueries Class Methods See Also

The following tables list the members exposed by the HAHAPickAndPackQueries type.

Methods
 | Name | Description
Public method | AdjustServiceItem | (inherited from PickAndPackBaseQuerties).
Public method | BinQtyForItemManagedByBatches | (inherited from PickAndPackBaseQuerties).
Public method | BinQtyForitemNotManagedItem | (inherited from PickAndPackBaseQuerties).
Public method | CheckIfThereIsDistNumberInMorQuery | (inherited from PickAndPackBaseQuerties).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBinLoactionForDocument | (inherited from PickAndPackBaseQuerties).
Public method | GetClassificationCountForPre1 | (inherited from PickAndPackBaseQuerties).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetIssueItemsFromOperations | (inherited from PickAndPackBaseQuerties).
Public method | GetLastPickOrderDocEntry | (inherited from PickAndPackBaseQuerties).
Public method | GetLastPickReceiptDocEntry | (inherited from PickAndPackBaseQuerties).
Public method | GetMORDocToUpdateByCopyFromOnPickOrder | (inherited from PickAndPackBaseQuerties).
Public method | GetMORDocToUpdateByCopyFromOnPickReceipt | (inherited from PickAndPackBaseQuerties).
Public method | GetPickOrderNextDocEntry | (inherited from PickAndPackBaseQuerties).
Public method | GetPriceForItemForDocument | (inherited from PickAndPackBaseQuerties).
 | GetQueryBatchForItemCode | GetQuery to obtain Correct Order (inherited from PickAndPackBaseQuerties).
 | GetQueryBatchForItemCodeByBin | GetQuery to obtain Correct Order (inherited from PickAndPackBaseQuerties).
Public method | GetReceiptItemsFromOperations | (inherited from PickAndPackBaseQuerties).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | RestorePickDocumentReferences | (inherited from PickAndPackBaseQuerties).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

HAHAPickAndPackQueries Class
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


HAHAPickAndPackQueries Methods

HAHAPickAndPackQueries Class See Also

The following tables list the members exposed by the HAHAPickAndPackQueries type.

Methods
 | Name | Description
Public method | AdjustServiceItem | (inherited from PickAndPackBaseQuerties).
Public method | BinQtyForItemManagedByBatches | (inherited from PickAndPackBaseQuerties).
Public method | BinQtyForitemNotManagedItem | (inherited from PickAndPackBaseQuerties).
Public method | CheckIfThereIsDistNumberInMorQuery | (inherited from PickAndPackBaseQuerties).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBinLoactionForDocument | (inherited from PickAndPackBaseQuerties).
Public method | GetClassificationCountForPre1 | (inherited from PickAndPackBaseQuerties).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetIssueItemsFromOperations | (inherited from PickAndPackBaseQuerties).
Public method | GetLastPickOrderDocEntry | (inherited from PickAndPackBaseQuerties).
Public method | GetLastPickReceiptDocEntry | (inherited from PickAndPackBaseQuerties).
Public method | GetMORDocToUpdateByCopyFromOnPickOrder | (inherited from PickAndPackBaseQuerties).
Public method | GetMORDocToUpdateByCopyFromOnPickReceipt | (inherited from PickAndPackBaseQuerties).
Public method | GetPickOrderNextDocEntry | (inherited from PickAndPackBaseQuerties).
Public method | GetPriceForItemForDocument | (inherited from PickAndPackBaseQuerties).
 | GetQueryBatchForItemCode | GetQuery to obtain Correct Order (inherited from PickAndPackBaseQuerties).
 | GetQueryBatchForItemCodeByBin | GetQuery to obtain Correct Order (inherited from PickAndPackBaseQuerties).
Public method | GetReceiptItemsFromOperations | (inherited from PickAndPackBaseQuerties).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | RestorePickDocumentReferences | (inherited from PickAndPackBaseQuerties).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

HAHAPickAndPackQueries Class
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties.AdjustServiceItem Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function AdjustServiceItem( _
   ByVal Token As String, _
   ByVal MorEntry As Integer, _
   ByVal BaseEnty As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset AdjustServiceItem(
   string Token,
   int MorEntry,
   int BaseEnty
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ AdjustServiceItem(
   String^ Token,
   int MorEntry,
   int BaseEnty
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function AdjustServiceItem(
    Token : String,
    MorEntry : int,
    BaseEnty : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

MorEntry

Type: int

BaseEnty

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackBaseQuerties Class
PickAndPackBaseQuerties Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties.BinQtyForItemManagedByBatches Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function BinQtyForItemManagedByBatches( _
   ByVal tokem As String, _
   ByVal DistNumber As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset BinQtyForItemManagedByBatches(
   string tokem,
   string DistNumber,
   string ItemCode,
   string WhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ BinQtyForItemManagedByBatches(
   String^ tokem,
   String^ DistNumber,
   String^ ItemCode,
   String^ WhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BinQtyForItemManagedByBatches(
    tokem : String,
    DistNumber : String,
    ItemCode : String,
    WhsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

tokem

Type: string

DistNumber

Type: string

ItemCode

Type: string

WhsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackBaseQuerties Class
PickAndPackBaseQuerties Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties.BinQtyForitemNotManagedItem Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function BinQtyForitemNotManagedItem( _
   ByVal token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset BinQtyForitemNotManagedItem(
   string token,
   string ItemCode,
   string WhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ BinQtyForitemNotManagedItem(
   String^ token,
   String^ ItemCode,
   String^ WhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BinQtyForitemNotManagedItem(
    token : String,
    ItemCode : String,
    WhsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

ItemCode

Type: string

WhsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackBaseQuerties Class
PickAndPackBaseQuerties Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties.CheckIfThereIsDistNumberInMorQuery Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CheckIfThereIsDistNumberInMorQuery( _
   ByVal token As String, _
   ByVal morDocNum As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset CheckIfThereIsDistNumberInMorQuery(
   string token,
   string morDocNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ CheckIfThereIsDistNumberInMorQuery(
   String^ token,
   String^ morDocNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CheckIfThereIsDistNumberInMorQuery(
    token : String,
    morDocNum : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

morDocNum

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackBaseQuerties Class
PickAndPackBaseQuerties Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties.GetBinLoactionForDocument Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBinLoactionForDocument( _
   ByVal Token As String, _
   ByVal DocTyp As Integer, _
   ByVal DocEntry As Integer, _
   ByVal DocLine As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBinLoactionForDocument(
   string Token,
   int DocTyp,
   int DocEntry,
   int DocLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBinLoactionForDocument(
   String^ Token,
   int DocTyp,
   int DocEntry,
   int DocLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBinLoactionForDocument(
    Token : String,
    DocTyp : int,
    DocEntry : int,
    DocLine : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocTyp

Type: int

DocEntry

Type: int

DocLine

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackBaseQuerties Class
PickAndPackBaseQuerties Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties.GetClassificationCountForPre1 Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetClassificationCountForPre1( _
   ByVal token As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int GetClassificationCountForPre1(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int GetClassificationCountForPre1(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetClassificationCountForPre1(
    token : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackBaseQuerties Class
PickAndPackBaseQuerties Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties.GetIssueItemsFromOperations Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetIssueItemsFromOperations( _
   ByVal token As String, _
   ByVal docentry As Integer, _
   ByVal OprlineNUms As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetIssueItemsFromOperations(
   string token,
   int docentry,
   IEnumerable<int> OprlineNUms
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetIssueItemsFromOperations(
   String^ token,
   int docentry,
   IEnumerable<int>^ OprlineNUms
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

docentry

Type: int

OprlineNUms

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackBaseQuerties Class
PickAndPackBaseQuerties Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties.GetLastPickOrderDocEntry Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetLastPickOrderDocEntry( _
   ByVal token As String, _
   ByVal DocDate As Date _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int GetLastPickOrderDocEntry(
   string token,
   DateTime DocDate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int GetLastPickOrderDocEntry(
   String^ token,
   DateTime DocDate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetLastPickOrderDocEntry(
    token : String,
    DocDate : DateTime
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

DocDate

Type: DateTime

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackBaseQuerties Class
PickAndPackBaseQuerties Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties.GetLastPickReceiptDocEntry Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetLastPickReceiptDocEntry( _
   ByVal token As String, _
   ByVal DocDate As Date _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int GetLastPickReceiptDocEntry(
   string token,
   DateTime DocDate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int GetLastPickReceiptDocEntry(
   String^ token,
   DateTime DocDate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetLastPickReceiptDocEntry(
    token : String,
    DocDate : DateTime
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

DocDate

Type: DateTime

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackBaseQuerties Class
PickAndPackBaseQuerties Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties.GetMORDocToUpdateByCopyFromOnPickOrder Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetMORDocToUpdateByCopyFromOnPickOrder( _
   ByVal Token As String, _
   ByVal pickDocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetMORDocToUpdateByCopyFromOnPickOrder(
   string Token,
   int pickDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetMORDocToUpdateByCopyFromOnPickOrder(
   String^ Token,
   int pickDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetMORDocToUpdateByCopyFromOnPickOrder(
    Token : String,
    pickDocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

pickDocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackBaseQuerties Class
PickAndPackBaseQuerties Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties.GetMORDocToUpdateByCopyFromOnPickReceipt Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetMORDocToUpdateByCopyFromOnPickReceipt( _
   ByVal Token As String, _
   ByVal pickDocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetMORDocToUpdateByCopyFromOnPickReceipt(
   string Token,
   int pickDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetMORDocToUpdateByCopyFromOnPickReceipt(
   String^ Token,
   int pickDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetMORDocToUpdateByCopyFromOnPickReceipt(
    Token : String,
    pickDocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

pickDocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackBaseQuerties Class
PickAndPackBaseQuerties Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties.GetPickOrderNextDocEntry Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetPickOrderNextDocEntry( _
   ByVal token As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int GetPickOrderNextDocEntry(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int GetPickOrderNextDocEntry(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetPickOrderNextDocEntry(
    token : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackBaseQuerties Class
PickAndPackBaseQuerties Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties.GetPriceForItemForDocument Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetPriceForItemForDocument( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revision As String, _
   ByVal whsCode As String, _
   ByVal MorDocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetPriceForItemForDocument(
   string token,
   string itemCode,
   string revision,
   string whsCode,
   int MorDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetPriceForItemForDocument(
   String^ token,
   String^ itemCode,
   String^ revision,
   String^ whsCode,
   int MorDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetPriceForItemForDocument(
    token : String,
    itemCode : String,
    revision : String,
    whsCode : String,
    MorDocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revision

Type: string

whsCode

Type: string

MorDocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackBaseQuerties Class
PickAndPackBaseQuerties Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties.GetQueryBatchForItemCode Method

GetQuery to obtain Correct Order

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetQueryBatchForItemCode( _
   ByVal Token As String, _
   ByVal itemCode As String, _
   ByVal whscode As String, _
   ByVal issueBy As IssuePrimarilyByEnum, _
   ByVal PorEntry As Integer, _
   ByVal RevisionCode As String, _
   ByVal enableBinLocation As Boolean _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetQueryBatchForItemCode(
   string Token,
   string itemCode,
   string whscode,
   IssuePrimarilyByEnum issueBy,
   int PorEntry,
   string RevisionCode,
   bool enableBinLocation
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetQueryBatchForItemCode(
   String^ Token,
   String^ itemCode,
   String^ whscode,
   IssuePrimarilyByEnum issueBy,
   int PorEntry,
   String^ RevisionCode,
   bool enableBinLocation
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetQueryBatchForItemCode(
    Token : String,
    itemCode : String,
    whscode : String,
    issueBy : IssuePrimarilyByEnum,
    PorEntry : int,
    RevisionCode : String,
    enableBinLocation : boolean
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemCode

Type: string

whscode

Type: string

issueBy

Type: IssuePrimarilyByEnum

PorEntry

Type: int

RevisionCode

Type: string

enableBinLocation

Type: bool

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackBaseQuerties Class
PickAndPackBaseQuerties Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties.GetQueryBatchForItemCodeByBin Method

GetQuery to obtain Correct Order

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetQueryBatchForItemCodeByBin( _
   ByVal Token As String, _
   ByVal itemCode As String, _
   ByVal whscode As String, _
   ByVal issueBy As IssuePrimarilyByEnum, _
   ByVal RevisionCode As String, _
   ByVal BinAbs As Integer _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetQueryBatchForItemCodeByBin(
   string Token,
   string itemCode,
   string whscode,
   IssuePrimarilyByEnum issueBy,
   string RevisionCode,
   int BinAbs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetQueryBatchForItemCodeByBin(
   String^ Token,
   String^ itemCode,
   String^ whscode,
   IssuePrimarilyByEnum issueBy,
   String^ RevisionCode,
   int BinAbs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetQueryBatchForItemCodeByBin(
    Token : String,
    itemCode : String,
    whscode : String,
    issueBy : IssuePrimarilyByEnum,
    RevisionCode : String,
    BinAbs : int
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemCode

Type: string

whscode

Type: string

issueBy

Type: IssuePrimarilyByEnum

RevisionCode

Type: string

BinAbs

Type: int

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackBaseQuerties Class
PickAndPackBaseQuerties Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties.GetReceiptItemsFromOperations Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetReceiptItemsFromOperations( _
   ByVal token As String, _
   ByVal docentry As Integer, _
   ByVal OprlineNUms As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetReceiptItemsFromOperations(
   string token,
   int docentry,
   IEnumerable<int> OprlineNUms
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetReceiptItemsFromOperations(
   String^ token,
   int docentry,
   IEnumerable<int>^ OprlineNUms
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

docentry

Type: int

OprlineNUms

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackBaseQuerties Class
PickAndPackBaseQuerties Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties.RestorePickDocumentReferences Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function RestorePickDocumentReferences( _
   ByVal Token As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool RestorePickDocumentReferences(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool RestorePickDocumentReferences(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RestorePickDocumentReferences(
    Token : String
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackBaseQuerties Class
PickAndPackBaseQuerties Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class PickAndPackBaseQuerties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PickAndPackBaseQuerties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class PickAndPackBaseQuerties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PickAndPackBaseQuerties
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.PickAndPack.PickAndPackBaseQuerties
CompuTec.ProcessForce.API.Queries.PickAndPack.HAHAPickAndPackQueries
CompuTec.ProcessForce.API.Queries.PickAndPack.SQLPickAndPackQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackBaseQuerties Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties Members

PickAndPackBaseQuerties Class Methods See Also

The following tables list the members exposed by the PickAndPackBaseQuerties type.

Methods
 | Name | Description
Public method | AdjustServiceItem |
Public method | BinQtyForItemManagedByBatches |
Public method | BinQtyForitemNotManagedItem |
Public method | CheckIfThereIsDistNumberInMorQuery |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBinLoactionForDocument |
Public method | GetClassificationCountForPre1 |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetIssueItemsFromOperations |
Public method | GetLastPickOrderDocEntry |
Public method | GetLastPickReceiptDocEntry |
Public method | GetMORDocToUpdateByCopyFromOnPickOrder |
Public method | GetMORDocToUpdateByCopyFromOnPickReceipt |
Public method | GetPickOrderNextDocEntry |
Public method | GetPriceForItemForDocument |
 | GetQueryBatchForItemCode | GetQuery to obtain Correct Order
 | GetQueryBatchForItemCodeByBin | GetQuery to obtain Correct Order
Public method | GetReceiptItemsFromOperations |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | RestorePickDocumentReferences |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PickAndPackBaseQuerties Class
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


PickAndPackBaseQuerties Methods

PickAndPackBaseQuerties Class See Also

The following tables list the members exposed by the PickAndPackBaseQuerties type.

Methods
 | Name | Description
Public method | AdjustServiceItem |
Public method | BinQtyForItemManagedByBatches |
Public method | BinQtyForitemNotManagedItem |
Public method | CheckIfThereIsDistNumberInMorQuery |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBinLoactionForDocument |
Public method | GetClassificationCountForPre1 |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetIssueItemsFromOperations |
Public method | GetLastPickOrderDocEntry |
Public method | GetLastPickReceiptDocEntry |
Public method | GetMORDocToUpdateByCopyFromOnPickOrder |
Public method | GetMORDocToUpdateByCopyFromOnPickReceipt |
Public method | GetPickOrderNextDocEntry |
Public method | GetPriceForItemForDocument |
 | GetQueryBatchForItemCode | GetQuery to obtain Correct Order
 | GetQueryBatchForItemCodeByBin | GetQuery to obtain Correct Order
Public method | GetReceiptItemsFromOperations |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | RestorePickDocumentReferences |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PickAndPackBaseQuerties Class
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


SQLPickAndPackQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SQLPickAndPackQueries
    Inherits PickAndPackBaseQuerties
    Implements IPickAndPackQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SQLPickAndPackQueries : PickAndPackBaseQuerties,
   IPickAndPackQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SQLPickAndPackQueries : public PickAndPackBaseQuerties^,
   public IPickAndPackQueries^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SQLPickAndPackQueries
   extends PickAndPackBaseQuerties
   implements IPickAndPackQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.PickAndPack.PickAndPackBaseQuerties
CompuTec.ProcessForce.API.Queries.PickAndPack.SQLPickAndPackQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SQLPickAndPackQueries Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


SQLPickAndPackQueries Members

SQLPickAndPackQueries Class Methods See Also

The following tables list the members exposed by the SQLPickAndPackQueries type.

Methods
 | Name | Description
Public method | AdjustServiceItem | (inherited from PickAndPackBaseQuerties).
Public method | BinQtyForItemManagedByBatches | (inherited from PickAndPackBaseQuerties).
Public method | BinQtyForitemNotManagedItem | (inherited from PickAndPackBaseQuerties).
Public method | CheckIfThereIsDistNumberInMorQuery | (inherited from PickAndPackBaseQuerties).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBinLoactionForDocument | (inherited from PickAndPackBaseQuerties).
Public method | GetClassificationCountForPre1 | (inherited from PickAndPackBaseQuerties).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetIssueItemsFromOperations | (inherited from PickAndPackBaseQuerties).
Public method | GetLastPickOrderDocEntry | (inherited from PickAndPackBaseQuerties).
Public method | GetLastPickReceiptDocEntry | (inherited from PickAndPackBaseQuerties).
Public method | GetMORDocToUpdateByCopyFromOnPickOrder | (inherited from PickAndPackBaseQuerties).
Public method | GetMORDocToUpdateByCopyFromOnPickReceipt | (inherited from PickAndPackBaseQuerties).
Public method | GetPickOrderNextDocEntry | (inherited from PickAndPackBaseQuerties).
Public method | GetPriceForItemForDocument | (inherited from PickAndPackBaseQuerties).
 | GetQueryBatchForItemCode | GetQuery to obtain Correct Order (inherited from PickAndPackBaseQuerties).
 | GetQueryBatchForItemCodeByBin | GetQuery to obtain Correct Order (inherited from PickAndPackBaseQuerties).
Public method | GetReceiptItemsFromOperations | (inherited from PickAndPackBaseQuerties).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | RestorePickDocumentReferences | (inherited from PickAndPackBaseQuerties).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SQLPickAndPackQueries Class
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


SQLPickAndPackQueries Methods

SQLPickAndPackQueries Class See Also

The following tables list the members exposed by the SQLPickAndPackQueries type.

Methods
 | Name | Description
Public method | AdjustServiceItem | (inherited from PickAndPackBaseQuerties).
Public method | BinQtyForItemManagedByBatches | (inherited from PickAndPackBaseQuerties).
Public method | BinQtyForitemNotManagedItem | (inherited from PickAndPackBaseQuerties).
Public method | CheckIfThereIsDistNumberInMorQuery | (inherited from PickAndPackBaseQuerties).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBinLoactionForDocument | (inherited from PickAndPackBaseQuerties).
Public method | GetClassificationCountForPre1 | (inherited from PickAndPackBaseQuerties).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetIssueItemsFromOperations | (inherited from PickAndPackBaseQuerties).
Public method | GetLastPickOrderDocEntry | (inherited from PickAndPackBaseQuerties).
Public method | GetLastPickReceiptDocEntry | (inherited from PickAndPackBaseQuerties).
Public method | GetMORDocToUpdateByCopyFromOnPickOrder | (inherited from PickAndPackBaseQuerties).
Public method | GetMORDocToUpdateByCopyFromOnPickReceipt | (inherited from PickAndPackBaseQuerties).
Public method | GetPickOrderNextDocEntry | (inherited from PickAndPackBaseQuerties).
Public method | GetPriceForItemForDocument | (inherited from PickAndPackBaseQuerties).
 | GetQueryBatchForItemCode | GetQuery to obtain Correct Order (inherited from PickAndPackBaseQuerties).
 | GetQueryBatchForItemCodeByBin | GetQuery to obtain Correct Order (inherited from PickAndPackBaseQuerties).
Public method | GetReceiptItemsFromOperations | (inherited from PickAndPackBaseQuerties).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | RestorePickDocumentReferences | (inherited from PickAndPackBaseQuerties).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SQLPickAndPackQueries Class
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


IPickAndPackQueries Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IPickAndPackQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IPickAndPackQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IPickAndPackQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IPickAndPackQueries
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickAndPackQueries Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


IPickAndPackQueries Members

IPickAndPackQueries Interface Methods See Also

The following tables list the members exposed by the IPickAndPackQueries type.

Methods
 | Name | Description
Public method | AdjustServiceItem |
Public method | BinQtyForItemManagedByBatches |
Public method | BinQtyForitemNotManagedItem |
Public method | CheckIfThereIsDistNumberInMorQuery |
Public method | GetBinLoactionForDocument |
Public method | GetClassificationCountForPre1 |
Public method | GetIssueItemsFromOperations |
Public method | GetLastPickOrderDocEntry |
Public method | GetLastPickReceiptDocEntry |
Public method | GetMORDocToUpdateByCopyFromOnPickOrder | Get Reference On MOR documents When Copy From is found
Public method | GetMORDocToUpdateByCopyFromOnPickReceipt | Get Reference On MOR documents When Copy From is found
Public method | GetPickOrderNextDocEntry |
Public method | GetPriceForItemForDocument |
Public method | GetReceiptItemsFromOperations |
Public method | RestorePickDocumentReferences |
Top
See Also

Reference

IPickAndPackQueries Interface
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


IPickAndPackQueries Methods

IPickAndPackQueries Interface See Also

The following tables list the members exposed by the IPickAndPackQueries type.

Methods
 | Name | Description
Public method | AdjustServiceItem |
Public method | BinQtyForItemManagedByBatches |
Public method | BinQtyForitemNotManagedItem |
Public method | CheckIfThereIsDistNumberInMorQuery |
Public method | GetBinLoactionForDocument |
Public method | GetClassificationCountForPre1 |
Public method | GetIssueItemsFromOperations |
Public method | GetLastPickOrderDocEntry |
Public method | GetLastPickReceiptDocEntry |
Public method | GetMORDocToUpdateByCopyFromOnPickOrder | Get Reference On MOR documents When Copy From is found
Public method | GetMORDocToUpdateByCopyFromOnPickReceipt | Get Reference On MOR documents When Copy From is found
Public method | GetPickOrderNextDocEntry |
Public method | GetPriceForItemForDocument |
Public method | GetReceiptItemsFromOperations |
Public method | RestorePickDocumentReferences |
Top
See Also

Reference

IPickAndPackQueries Interface
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


IPickAndPackQueries.AdjustServiceItem Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function AdjustServiceItem( _
   ByVal Token As String, _
   ByVal MorEntry As Integer, _
   ByVal BaseEnty As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset AdjustServiceItem(
   string Token,
   int MorEntry,
   int BaseEnty
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ AdjustServiceItem(
   String^ Token,
   int MorEntry,
   int BaseEnty
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function AdjustServiceItem(
    Token : String,
    MorEntry : int,
    BaseEnty : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

MorEntry

Type: int

BaseEnty

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickAndPackQueries Interface
IPickAndPackQueries Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


IPickAndPackQueries.BinQtyForItemManagedByBatches Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function BinQtyForItemManagedByBatches( _
   ByVal tokem As String, _
   ByVal DistNumber As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset BinQtyForItemManagedByBatches(
   string tokem,
   string DistNumber,
   string ItemCode,
   string WhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ BinQtyForItemManagedByBatches(
   String^ tokem,
   String^ DistNumber,
   String^ ItemCode,
   String^ WhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function BinQtyForItemManagedByBatches(
    tokem : String,
    DistNumber : String,
    ItemCode : String,
    WhsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

tokem

Type: string

DistNumber

Type: string

ItemCode

Type: string

WhsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickAndPackQueries Interface
IPickAndPackQueries Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


IPickAndPackQueries.BinQtyForitemNotManagedItem Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function BinQtyForitemNotManagedItem( _
   ByVal token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset BinQtyForitemNotManagedItem(
   string token,
   string ItemCode,
   string WhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ BinQtyForitemNotManagedItem(
   String^ token,
   String^ ItemCode,
   String^ WhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function BinQtyForitemNotManagedItem(
    token : String,
    ItemCode : String,
    WhsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

ItemCode

Type: string

WhsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickAndPackQueries Interface
IPickAndPackQueries Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


IPickAndPackQueries.CheckIfThereIsDistNumberInMorQuery Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CheckIfThereIsDistNumberInMorQuery( _
   ByVal token As String, _
   ByVal morDocNum As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset CheckIfThereIsDistNumberInMorQuery(
   string token,
   string morDocNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ CheckIfThereIsDistNumberInMorQuery(
   String^ token,
   String^ morDocNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CheckIfThereIsDistNumberInMorQuery(
    token : String,
    morDocNum : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

morDocNum

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickAndPackQueries Interface
IPickAndPackQueries Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


IPickAndPackQueries.GetBinLoactionForDocument Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetBinLoactionForDocument( _
   ByVal Token As String, _
   ByVal DocTyp As Integer, _
   ByVal DocEntry As Integer, _
   ByVal DocLine As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetBinLoactionForDocument(
   string Token,
   int DocTyp,
   int DocEntry,
   int DocLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetBinLoactionForDocument(
   String^ Token,
   int DocTyp,
   int DocEntry,
   int DocLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetBinLoactionForDocument(
    Token : String,
    DocTyp : int,
    DocEntry : int,
    DocLine : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocTyp

Type: int

DocEntry

Type: int

DocLine

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickAndPackQueries Interface
IPickAndPackQueries Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


IPickAndPackQueries.GetClassificationCountForPre1 Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetClassificationCountForPre1( _
   ByVal token As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetClassificationCountForPre1(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetClassificationCountForPre1(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetClassificationCountForPre1(
    token : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickAndPackQueries Interface
IPickAndPackQueries Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


IPickAndPackQueries.GetIssueItemsFromOperations Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetIssueItemsFromOperations( _
   ByVal token As String, _
   ByVal docentry As Integer, _
   ByVal OprlineNUms As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetIssueItemsFromOperations(
   string token,
   int docentry,
   IEnumerable<int> OprlineNUms
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetIssueItemsFromOperations(
   String^ token,
   int docentry,
   IEnumerable<int>^ OprlineNUms
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

docentry

Type: int

OprlineNUms

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickAndPackQueries Interface
IPickAndPackQueries Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


IPickAndPackQueries.GetLastPickOrderDocEntry Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetLastPickOrderDocEntry( _
   ByVal token As String, _
   ByVal DocDate As Date _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetLastPickOrderDocEntry(
   string token,
   DateTime DocDate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetLastPickOrderDocEntry(
   String^ token,
   DateTime DocDate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetLastPickOrderDocEntry(
    token : String,
    DocDate : DateTime
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

DocDate

Type: DateTime

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickAndPackQueries Interface
IPickAndPackQueries Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


IPickAndPackQueries.GetLastPickReceiptDocEntry Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetLastPickReceiptDocEntry( _
   ByVal token As String, _
   ByVal DocDate As Date _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetLastPickReceiptDocEntry(
   string token,
   DateTime DocDate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetLastPickReceiptDocEntry(
   String^ token,
   DateTime DocDate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetLastPickReceiptDocEntry(
    token : String,
    DocDate : DateTime
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

DocDate

Type: DateTime

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickAndPackQueries Interface
IPickAndPackQueries Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


IPickAndPackQueries.GetMORDocToUpdateByCopyFromOnPickOrder Method

Get Reference On MOR documents When Copy From is found

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetMORDocToUpdateByCopyFromOnPickOrder( _
   ByVal Token As String, _
   ByVal pickDocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetMORDocToUpdateByCopyFromOnPickOrder(
   string Token,
   int pickDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetMORDocToUpdateByCopyFromOnPickOrder(
   String^ Token,
   int pickDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetMORDocToUpdateByCopyFromOnPickOrder(
    Token : String,
    pickDocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

pickDocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickAndPackQueries Interface
IPickAndPackQueries Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


IPickAndPackQueries.GetMORDocToUpdateByCopyFromOnPickReceipt Method

Get Reference On MOR documents When Copy From is found

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetMORDocToUpdateByCopyFromOnPickReceipt( _
   ByVal Token As String, _
   ByVal pickDocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetMORDocToUpdateByCopyFromOnPickReceipt(
   string Token,
   int pickDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetMORDocToUpdateByCopyFromOnPickReceipt(
   String^ Token,
   int pickDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetMORDocToUpdateByCopyFromOnPickReceipt(
    Token : String,
    pickDocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

pickDocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickAndPackQueries Interface
IPickAndPackQueries Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


IPickAndPackQueries.GetPickOrderNextDocEntry Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetPickOrderNextDocEntry( _
   ByVal token As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int GetPickOrderNextDocEntry(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int GetPickOrderNextDocEntry(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetPickOrderNextDocEntry(
    token : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickAndPackQueries Interface
IPickAndPackQueries Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


IPickAndPackQueries.GetPriceForItemForDocument Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetPriceForItemForDocument( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revision As String, _
   ByVal whsCode As String, _
   ByVal MorDocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetPriceForItemForDocument(
   string token,
   string itemCode,
   string revision,
   string whsCode,
   int MorDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetPriceForItemForDocument(
   String^ token,
   String^ itemCode,
   String^ revision,
   String^ whsCode,
   int MorDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetPriceForItemForDocument(
    token : String,
    itemCode : String,
    revision : String,
    whsCode : String,
    MorDocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revision

Type: string

whsCode

Type: string

MorDocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickAndPackQueries Interface
IPickAndPackQueries Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


IPickAndPackQueries.GetReceiptItemsFromOperations Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetReceiptItemsFromOperations( _
   ByVal token As String, _
   ByVal docentry As Integer, _
   ByVal OprlineNUms As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetReceiptItemsFromOperations(
   string token,
   int docentry,
   IEnumerable<int> OprlineNUms
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetReceiptItemsFromOperations(
   String^ token,
   int docentry,
   IEnumerable<int>^ OprlineNUms
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

docentry

Type: int

OprlineNUms

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickAndPackQueries Interface
IPickAndPackQueries Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


IPickAndPackQueries.RestorePickDocumentReferences Method

Namespace: CompuTec.ProcessForce.API.Queries.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function RestorePickDocumentReferences( _
   ByVal Token As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool RestorePickDocumentReferences(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool RestorePickDocumentReferences(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function RestorePickDocumentReferences(
    Token : String
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickAndPackQueries Interface
IPickAndPackQueries Members
CompuTec.ProcessForce.API.Queries.PickAndPack Namespace


CompuTec.ProcessForce.API.Queries.PlanningCostingDetails Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | PlanningCostingDetailsQueries |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


PlanningCostingDetailsQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.PlanningCostingDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class PlanningCostingDetailsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PlanningCostingDetailsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class PlanningCostingDetailsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PlanningCostingDetailsQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.PlanningCostingDetails.PlanningCostingDetailsQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PlanningCostingDetailsQueries Members
CompuTec.ProcessForce.API.Queries.PlanningCostingDetails Namespace


PlanningCostingDetailsQueries Members

PlanningCostingDetailsQueries Class Methods See Also

The following tables list the members exposed by the PlanningCostingDetailsQueries type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetActualMaterialCost |
Public method | GetCaTotalCosts |
Public method | GetFinalProductCost |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemCost |
Public method | GetSeriesName |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsSemiGood |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PlanningCostingDetailsQueries Class
CompuTec.ProcessForce.API.Queries.PlanningCostingDetails Namespace


PlanningCostingDetailsQueries Methods

PlanningCostingDetailsQueries Class See Also

The following tables list the members exposed by the PlanningCostingDetailsQueries type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetActualMaterialCost |
Public method | GetCaTotalCosts |
Public method | GetFinalProductCost |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemCost |
Public method | GetSeriesName |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IsSemiGood |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PlanningCostingDetailsQueries Class
CompuTec.ProcessForce.API.Queries.PlanningCostingDetails Namespace


PlanningCostingDetailsQueries.GetActualMaterialCost Method

Namespace: CompuTec.ProcessForce.API.Queries.PlanningCostingDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetActualMaterialCost( _
   ByVal token As String, _
   ByVal docEntry As Integer, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetActualMaterialCost(
   string token,
   int docEntry,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetActualMaterialCost(
   String^ token,
   int docEntry,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetActualMaterialCost(
    token : String,
    docEntry : int,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntry

Type: int

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PlanningCostingDetailsQueries Class
PlanningCostingDetailsQueries Members
CompuTec.ProcessForce.API.Queries.PlanningCostingDetails Namespace


PlanningCostingDetailsQueries.GetCaTotalCosts Method

Namespace: CompuTec.ProcessForce.API.Queries.PlanningCostingDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetCaTotalCosts( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetCaTotalCosts(
   string token,
   string itemCode,
   string revCode,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetCaTotalCosts(
   String^ token,
   String^ itemCode,
   String^ revCode,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetCaTotalCosts(
    token : String,
    itemCode : String,
    revCode : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PlanningCostingDetailsQueries Class
PlanningCostingDetailsQueries Members
CompuTec.ProcessForce.API.Queries.PlanningCostingDetails Namespace


PlanningCostingDetailsQueries.GetFinalProductCost Method

Namespace: CompuTec.ProcessForce.API.Queries.PlanningCostingDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetFinalProductCost( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String, _
   ByVal costCategoryCode As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetFinalProductCost(
   string token,
   string itemCode,
   string revCode,
   string costCategoryCode,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetFinalProductCost(
   String^ token,
   String^ itemCode,
   String^ revCode,
   String^ costCategoryCode,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetFinalProductCost(
    token : String,
    itemCode : String,
    revCode : String,
    costCategoryCode : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

costCategoryCode

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PlanningCostingDetailsQueries Class
PlanningCostingDetailsQueries Members
CompuTec.ProcessForce.API.Queries.PlanningCostingDetails Namespace


PlanningCostingDetailsQueries.GetItemCost Method

Namespace: CompuTec.ProcessForce.API.Queries.PlanningCostingDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemCost( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal whsCode As String, _
   ByVal revCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemCost(
   string token,
   string itemCode,
   string whsCode,
   string revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemCost(
   String^ token,
   String^ itemCode,
   String^ whsCode,
   String^ revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemCost(
    token : String,
    itemCode : String,
    whsCode : String,
    revCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

whsCode

Type: string

revCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PlanningCostingDetailsQueries Class
PlanningCostingDetailsQueries Members
CompuTec.ProcessForce.API.Queries.PlanningCostingDetails Namespace


PlanningCostingDetailsQueries.GetSeriesName Method

Namespace: CompuTec.ProcessForce.API.Queries.PlanningCostingDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSeriesName( _
   ByVal token As String, _
   ByVal series As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSeriesName(
   string token,
   int series
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSeriesName(
   String^ token,
   int series
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSeriesName(
    token : String,
    series : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

series

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PlanningCostingDetailsQueries Class
PlanningCostingDetailsQueries Members
CompuTec.ProcessForce.API.Queries.PlanningCostingDetails Namespace


PlanningCostingDetailsQueries.IsSemiGood Method

Namespace: CompuTec.ProcessForce.API.Queries.PlanningCostingDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function IsSemiGood( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revision As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset IsSemiGood(
   string token,
   string itemCode,
   string revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ IsSemiGood(
   String^ token,
   String^ itemCode,
   String^ revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function IsSemiGood(
    token : String,
    itemCode : String,
    revision : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revision

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PlanningCostingDetailsQueries Class
PlanningCostingDetailsQueries Members
CompuTec.ProcessForce.API.Queries.PlanningCostingDetails Namespace


CompuTec.ProcessForce.API.Queries.QualityControl Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | QualityControlBaseQueries |
Public class | QualityControlSapHanaQueries |
Public class | QualityControlSqlServerQuerties |
Top
Interfaces
 | Name | Description
Public interface | IQualityControlQueries |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


QualityControlBaseQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class QualityControlBaseQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QualityControlBaseQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class QualityControlBaseQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QualityControlBaseQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.QualityControl.QualityControlBaseQueries
CompuTec.ProcessForce.API.Queries.QualityControl.QualityControlSapHanaQueries
CompuTec.ProcessForce.API.Queries.QualityControl.QualityControlSqlServerQuerties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries Members

QualityControlBaseQueries Class Methods See Also

The following tables list the members exposed by the QualityControlBaseQueries type.

Methods
 | Name | Description
Public method | BatchDetailsQualityControlReportQuery |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBatchRelatedComplaints |
Public method | GetComplaintHeaderUserDataSources |
Public method | GetComplaintMatchingBatchNo |
Public method | GetComplaintMatchingBatchNoForManufacturingOrder |
Public method | GetComplaintMatchingSerialNo |
Public method | GetComplaintMatchingSerialNoForManufacturingOrder |
Public method | GetComplaintReasonsUserDataSources |
Public method | GetComplaintSerialNoUserDataSources |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemProperties |
Public method | GetLastNcmrTransactionDocEntry |
Public method | GetManufacturingOrderOperationStatus |
Public method | GetNcmrTransactionDefectUserDataSources |
Public method | GetNcmrTransactionHeaderUserDataSources |
Public method | GetNcmrTransactionInspectorTableCode |
Public method | GetNcmrTransactionReasonUserDataSources |
Public method | GetNextComplaintNo |
Public method | GetNextNcmrTransactionNo |
Public method | GetNextQualityControlTestNo |
Public method | GetNextQualityControlTestPoolNo |
Public method | GetQualityControlAdditionalBatchDetails |
Public method | GetQualityControlComplaintDocEntry |
Public method | GetQualityControlTestChildUserDataSources |
Public method | GetQualityControlTestDocumentSeriesAndNumber |
Public method | GetQualityControlTestHeaderUserDataSources |
Public method | GetQualityControlTestPoolHeaderUserDataSources |
Public method | GetQualityControlTestPoolUsedCount |
Public method | GetQualityControlTestSerialUserDataSources |
Public method | GetQualityControlTestUsedCount |
Public method | GetReferenceCodes |
Public method | GetTestPropertyReferenceCodes |
Public method | GetTestProtocolAttachments |
Public method | GetTestProtocolHeaderUserDataSources |
Public method | GetTestProtocolItemProperties |
Public method | GetTestProtocolItems |
Public method | GetTestProtocolItemsResourcesUserDataSources |
Public method | GetTestProtocolPropertiesUserDataSources |
Public method | GetTestProtocolResources |
Public method | GetTestProtocolTemplatesCodes |
Public method | GetTestProtocolTemplatesCodesForPool |
Public method | GetTestProtocolTemplatesCodesItemCodeForRetest |
Public method | GetTestProtocolTemplatesCodesItemCodeForRetestForMOR |
Public method | GetTestProtocolTestResults |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | QCTExistsGoodReceipt |
Public method | QCTExistsGoodReceiptPO |
Public method | RepairComplaintsU_DocNoField |
Public method | TestProtocolExists |
Public method | TestProtocolExistsComplaint |
Public method | TestProtocolExistsGoodReceipt |
Public method | TestProtocolExistsPickReceipt |
Public method | TestProtocolExistsStockTransfer |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QualityControlBaseQueries Class
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries Methods

QualityControlBaseQueries Class See Also

The following tables list the members exposed by the QualityControlBaseQueries type.

Methods
 | Name | Description
Public method | BatchDetailsQualityControlReportQuery |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBatchRelatedComplaints |
Public method | GetComplaintHeaderUserDataSources |
Public method | GetComplaintMatchingBatchNo |
Public method | GetComplaintMatchingBatchNoForManufacturingOrder |
Public method | GetComplaintMatchingSerialNo |
Public method | GetComplaintMatchingSerialNoForManufacturingOrder |
Public method | GetComplaintReasonsUserDataSources |
Public method | GetComplaintSerialNoUserDataSources |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemProperties |
Public method | GetLastNcmrTransactionDocEntry |
Public method | GetManufacturingOrderOperationStatus |
Public method | GetNcmrTransactionDefectUserDataSources |
Public method | GetNcmrTransactionHeaderUserDataSources |
Public method | GetNcmrTransactionInspectorTableCode |
Public method | GetNcmrTransactionReasonUserDataSources |
Public method | GetNextComplaintNo |
Public method | GetNextNcmrTransactionNo |
Public method | GetNextQualityControlTestNo |
Public method | GetNextQualityControlTestPoolNo |
Public method | GetQualityControlAdditionalBatchDetails |
Public method | GetQualityControlComplaintDocEntry |
Public method | GetQualityControlTestChildUserDataSources |
Public method | GetQualityControlTestDocumentSeriesAndNumber |
Public method | GetQualityControlTestHeaderUserDataSources |
Public method | GetQualityControlTestPoolHeaderUserDataSources |
Public method | GetQualityControlTestPoolUsedCount |
Public method | GetQualityControlTestSerialUserDataSources |
Public method | GetQualityControlTestUsedCount |
Public method | GetReferenceCodes |
Public method | GetTestPropertyReferenceCodes |
Public method | GetTestProtocolAttachments |
Public method | GetTestProtocolHeaderUserDataSources |
Public method | GetTestProtocolItemProperties |
Public method | GetTestProtocolItems |
Public method | GetTestProtocolItemsResourcesUserDataSources |
Public method | GetTestProtocolPropertiesUserDataSources |
Public method | GetTestProtocolResources |
Public method | GetTestProtocolTemplatesCodes |
Public method | GetTestProtocolTemplatesCodesForPool |
Public method | GetTestProtocolTemplatesCodesItemCodeForRetest |
Public method | GetTestProtocolTemplatesCodesItemCodeForRetestForMOR |
Public method | GetTestProtocolTestResults |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | QCTExistsGoodReceipt |
Public method | QCTExistsGoodReceiptPO |
Public method | RepairComplaintsU_DocNoField |
Public method | TestProtocolExists |
Public method | TestProtocolExistsComplaint |
Public method | TestProtocolExistsGoodReceipt |
Public method | TestProtocolExistsPickReceipt |
Public method | TestProtocolExistsStockTransfer |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QualityControlBaseQueries Class
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.BatchDetailsQualityControlReportQuery Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function BatchDetailsQualityControlReportQuery( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal DistNumber As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string BatchDetailsQualityControlReportQuery(
   string token,
   string itemCode,
   string DistNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ BatchDetailsQualityControlReportQuery(
   String^ token,
   String^ itemCode,
   String^ DistNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchDetailsQualityControlReportQuery(
    token : String,
    itemCode : String,
    DistNumber : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

DistNumber

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetBatchRelatedComplaints Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBatchRelatedComplaints( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal batchNo As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBatchRelatedComplaints(
   string token,
   string itemCode,
   string batchNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBatchRelatedComplaints(
   String^ token,
   String^ itemCode,
   String^ batchNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBatchRelatedComplaints(
    token : String,
    itemCode : String,
    batchNo : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

batchNo

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetComplaintHeaderUserDataSources Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetComplaintHeaderUserDataSources( _
   ByVal token As String, _
   ByVal docEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetComplaintHeaderUserDataSources(
   string token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetComplaintHeaderUserDataSources(
   String^ token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetComplaintHeaderUserDataSources(
    token : String,
    docEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetComplaintMatchingBatchNo Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetComplaintMatchingBatchNo( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal documentId As Integer, _
   ByVal documentType As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetComplaintMatchingBatchNo(
   string token,
   string itemCode,
   int documentId,
   int documentType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetComplaintMatchingBatchNo(
   String^ token,
   String^ itemCode,
   int documentId,
   int documentType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetComplaintMatchingBatchNo(
    token : String,
    itemCode : String,
    documentId : int,
    documentType : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

documentId

Type: int

documentType

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetComplaintMatchingBatchNoForManufacturingOrder Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetComplaintMatchingBatchNoForManufacturingOrder( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal documentNo As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetComplaintMatchingBatchNoForManufacturingOrder(
   string token,
   string itemCode,
   int documentNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetComplaintMatchingBatchNoForManufacturingOrder(
   String^ token,
   String^ itemCode,
   int documentNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetComplaintMatchingBatchNoForManufacturingOrder(
    token : String,
    itemCode : String,
    documentNo : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

documentNo

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetComplaintMatchingSerialNo Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetComplaintMatchingSerialNo( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal documentId As Integer, _
   ByVal documentType As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetComplaintMatchingSerialNo(
   string token,
   string itemCode,
   int documentId,
   int documentType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetComplaintMatchingSerialNo(
   String^ token,
   String^ itemCode,
   int documentId,
   int documentType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetComplaintMatchingSerialNo(
    token : String,
    itemCode : String,
    documentId : int,
    documentType : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

documentId

Type: int

documentType

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetComplaintMatchingSerialNoForManufacturingOrder Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetComplaintMatchingSerialNoForManufacturingOrder( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal documentId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetComplaintMatchingSerialNoForManufacturingOrder(
   string token,
   string itemCode,
   int documentId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetComplaintMatchingSerialNoForManufacturingOrder(
   String^ token,
   String^ itemCode,
   int documentId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetComplaintMatchingSerialNoForManufacturingOrder(
    token : String,
    itemCode : String,
    documentId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

documentId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetComplaintReasonsUserDataSources Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetComplaintReasonsUserDataSources( _
   ByVal token As String, _
   ByVal docEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetComplaintReasonsUserDataSources(
   string token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetComplaintReasonsUserDataSources(
   String^ token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetComplaintReasonsUserDataSources(
    token : String,
    docEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetComplaintSerialNoUserDataSources Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetComplaintSerialNoUserDataSources( _
   ByVal token As String, _
   ByVal docEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetComplaintSerialNoUserDataSources(
   string token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetComplaintSerialNoUserDataSources(
   String^ token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetComplaintSerialNoUserDataSources(
    token : String,
    docEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetItemProperties Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemProperties( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemProperties(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemProperties(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemProperties(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetLastNcmrTransactionDocEntry Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetLastNcmrTransactionDocEntry( _
   ByVal token As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int GetLastNcmrTransactionDocEntry(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int GetLastNcmrTransactionDocEntry(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetLastNcmrTransactionDocEntry(
    token : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetManufacturingOrderOperationStatus Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetManufacturingOrderOperationStatus( _
   ByVal token As String, _
   ByVal mnfCode As Integer, _
   ByVal mnfOprCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetManufacturingOrderOperationStatus(
   string token,
   int mnfCode,
   string mnfOprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetManufacturingOrderOperationStatus(
   String^ token,
   int mnfCode,
   String^ mnfOprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetManufacturingOrderOperationStatus(
    token : String,
    mnfCode : int,
    mnfOprCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

mnfCode

Type: int

mnfOprCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetNcmrTransactionDefectUserDataSources Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetNcmrTransactionDefectUserDataSources( _
   ByVal token As String, _
   ByVal docId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetNcmrTransactionDefectUserDataSources(
   string token,
   int docId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetNcmrTransactionDefectUserDataSources(
   String^ token,
   int docId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetNcmrTransactionDefectUserDataSources(
    token : String,
    docId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetNcmrTransactionHeaderUserDataSources Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetNcmrTransactionHeaderUserDataSources( _
   ByVal token As String, _
   ByVal qcDocId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetNcmrTransactionHeaderUserDataSources(
   string token,
   int qcDocId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetNcmrTransactionHeaderUserDataSources(
   String^ token,
   int qcDocId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetNcmrTransactionHeaderUserDataSources(
    token : String,
    qcDocId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

qcDocId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetNcmrTransactionInspectorTableCode Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetNcmrTransactionInspectorTableCode( _
   ByVal token As String, _
   ByVal docId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetNcmrTransactionInspectorTableCode(
   string token,
   int docId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetNcmrTransactionInspectorTableCode(
   String^ token,
   int docId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetNcmrTransactionInspectorTableCode(
    token : String,
    docId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetNcmrTransactionReasonUserDataSources Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetNcmrTransactionReasonUserDataSources( _
   ByVal token As String, _
   ByVal docId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetNcmrTransactionReasonUserDataSources(
   string token,
   int docId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetNcmrTransactionReasonUserDataSources(
   String^ token,
   int docId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetNcmrTransactionReasonUserDataSources(
    token : String,
    docId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetNextComplaintNo Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetNextComplaintNo( _
   ByVal token As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int GetNextComplaintNo(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int GetNextComplaintNo(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetNextComplaintNo(
    token : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetNextNcmrTransactionNo Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetNextNcmrTransactionNo( _
   ByVal token As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int GetNextNcmrTransactionNo(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int GetNextNcmrTransactionNo(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetNextNcmrTransactionNo(
    token : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetNextQualityControlTestNo Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetNextQualityControlTestNo( _
   ByVal token As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int GetNextQualityControlTestNo(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int GetNextQualityControlTestNo(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetNextQualityControlTestNo(
    token : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetNextQualityControlTestPoolNo Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetNextQualityControlTestPoolNo( _
   ByVal token As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int GetNextQualityControlTestPoolNo(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int GetNextQualityControlTestPoolNo(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetNextQualityControlTestPoolNo(
    token : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetQualityControlAdditionalBatchDetails Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetQualityControlAdditionalBatchDetails( _
   ByVal token As String, _
   ByVal qualityControlId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetQualityControlAdditionalBatchDetails(
   string token,
   int qualityControlId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetQualityControlAdditionalBatchDetails(
   String^ token,
   int qualityControlId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetQualityControlAdditionalBatchDetails(
    token : String,
    qualityControlId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

qualityControlId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetQualityControlComplaintDocEntry Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetQualityControlComplaintDocEntry( _
   ByVal token As String, _
   ByVal docId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetQualityControlComplaintDocEntry(
   string token,
   int docId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetQualityControlComplaintDocEntry(
   String^ token,
   int docId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetQualityControlComplaintDocEntry(
    token : String,
    docId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetQualityControlTestChildUserDataSources Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetQualityControlTestChildUserDataSources( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetQualityControlTestChildUserDataSources(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetQualityControlTestChildUserDataSources(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetQualityControlTestChildUserDataSources(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetQualityControlTestDocumentSeriesAndNumber Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetQualityControlTestDocumentSeriesAndNumber( _
   ByVal token As String, _
   ByVal docId As Integer, _
   ByVal objectCode As String, _
   ByVal tableName As String, _
   ByVal isQueryForManufacturingOrder As Boolean _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetQualityControlTestDocumentSeriesAndNumber(
   string token,
   int docId,
   string objectCode,
   string tableName,
   bool isQueryForManufacturingOrder
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetQualityControlTestDocumentSeriesAndNumber(
   String^ token,
   int docId,
   String^ objectCode,
   String^ tableName,
   bool isQueryForManufacturingOrder
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetQualityControlTestDocumentSeriesAndNumber(
    token : String,
    docId : int,
    objectCode : String,
    tableName : String,
    isQueryForManufacturingOrder : boolean
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docId

Type: int

objectCode

Type: string

tableName

Type: string

isQueryForManufacturingOrder

Type: bool

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetQualityControlTestHeaderUserDataSources Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetQualityControlTestHeaderUserDataSources( _
   ByVal token As String, _
   ByVal docId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetQualityControlTestHeaderUserDataSources(
   string token,
   int docId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetQualityControlTestHeaderUserDataSources(
   String^ token,
   int docId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetQualityControlTestHeaderUserDataSources(
    token : String,
    docId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetQualityControlTestPoolHeaderUserDataSources Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetQualityControlTestPoolHeaderUserDataSources( _
   ByVal token As String, _
   ByVal docId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetQualityControlTestPoolHeaderUserDataSources(
   string token,
   int docId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetQualityControlTestPoolHeaderUserDataSources(
   String^ token,
   int docId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetQualityControlTestPoolHeaderUserDataSources(
    token : String,
    docId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetQualityControlTestPoolUsedCount Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetQualityControlTestPoolUsedCount( _
   ByVal token As String, _
   ByVal qcPoolNo As Integer _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int GetQualityControlTestPoolUsedCount(
   string token,
   int qcPoolNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int GetQualityControlTestPoolUsedCount(
   String^ token,
   int qcPoolNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetQualityControlTestPoolUsedCount(
    token : String,
    qcPoolNo : int
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

qcPoolNo

Type: int

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetQualityControlTestSerialUserDataSources Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetQualityControlTestSerialUserDataSources( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetQualityControlTestSerialUserDataSources(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetQualityControlTestSerialUserDataSources(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetQualityControlTestSerialUserDataSources(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetQualityControlTestUsedCount Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetQualityControlTestUsedCount( _
   ByVal token As String, _
   ByVal docEntry As Integer _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int GetQualityControlTestUsedCount(
   string token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int GetQualityControlTestUsedCount(
   String^ token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetQualityControlTestUsedCount(
    token : String,
    docEntry : int
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntry

Type: int

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetReferenceCodes Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetReferenceCodes( _
   ByVal token As String, _
   ByVal prpCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetReferenceCodes(
   string token,
   string prpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetReferenceCodes(
   String^ token,
   String^ prpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetReferenceCodes(
    token : String,
    prpCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

prpCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetTestPropertyReferenceCodes Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTestPropertyReferenceCodes( _
   ByVal token As String, _
   ByVal prpCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTestPropertyReferenceCodes(
   string token,
   string prpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTestPropertyReferenceCodes(
   String^ token,
   String^ prpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetTestPropertyReferenceCodes(
    token : String,
    prpCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

prpCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetTestProtocolAttachments Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTestProtocolAttachments( _
   ByVal token As String, _
   ByVal testProtocolNo As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTestProtocolAttachments(
   string token,
   string testProtocolNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTestProtocolAttachments(
   String^ token,
   String^ testProtocolNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetTestProtocolAttachments(
    token : String,
    testProtocolNo : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

testProtocolNo

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetTestProtocolHeaderUserDataSources Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTestProtocolHeaderUserDataSources( _
   ByVal token As String, _
   ByVal testProtocolCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTestProtocolHeaderUserDataSources(
   string token,
   string testProtocolCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTestProtocolHeaderUserDataSources(
   String^ token,
   String^ testProtocolCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetTestProtocolHeaderUserDataSources(
    token : String,
    testProtocolCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

testProtocolCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetTestProtocolItemProperties Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTestProtocolItemProperties( _
   ByVal token As String, _
   ByVal testProtocolNo As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTestProtocolItemProperties(
   string token,
   string testProtocolNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTestProtocolItemProperties(
   String^ token,
   String^ testProtocolNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetTestProtocolItemProperties(
    token : String,
    testProtocolNo : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

testProtocolNo

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetTestProtocolItems Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTestProtocolItems( _
   ByVal token As String, _
   ByVal testProtocolNo As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTestProtocolItems(
   string token,
   string testProtocolNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTestProtocolItems(
   String^ token,
   String^ testProtocolNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetTestProtocolItems(
    token : String,
    testProtocolNo : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

testProtocolNo

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetTestProtocolItemsResourcesUserDataSources Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTestProtocolItemsResourcesUserDataSources( _
   ByVal token As String, _
   ByVal testProtocolCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTestProtocolItemsResourcesUserDataSources(
   string token,
   string testProtocolCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTestProtocolItemsResourcesUserDataSources(
   String^ token,
   String^ testProtocolCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetTestProtocolItemsResourcesUserDataSources(
    token : String,
    testProtocolCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

testProtocolCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetTestProtocolPropertiesUserDataSources Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTestProtocolPropertiesUserDataSources( _
   ByVal token As String, _
   ByVal testProtocolCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTestProtocolPropertiesUserDataSources(
   string token,
   string testProtocolCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTestProtocolPropertiesUserDataSources(
   String^ token,
   String^ testProtocolCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetTestProtocolPropertiesUserDataSources(
    token : String,
    testProtocolCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

testProtocolCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetTestProtocolResources Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTestProtocolResources( _
   ByVal token As String, _
   ByVal testProtocolNo As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTestProtocolResources(
   string token,
   string testProtocolNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTestProtocolResources(
   String^ token,
   String^ testProtocolNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetTestProtocolResources(
    token : String,
    testProtocolNo : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

testProtocolNo

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetTestProtocolTemplatesCodes Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTestProtocolTemplatesCodes( _
   ByVal Token As String, _
   ByVal date As Date _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTestProtocolTemplatesCodes(
   string Token,
   DateTime date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTestProtocolTemplatesCodes(
   String^ Token,
   DateTime date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetTestProtocolTemplatesCodes(
    Token : String,
    date : DateTime
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

date

Type: DateTime

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetTestProtocolTemplatesCodesForPool Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTestProtocolTemplatesCodesForPool( _
   ByVal Token As String, _
   ByVal date As Date _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTestProtocolTemplatesCodesForPool(
   string Token,
   DateTime date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTestProtocolTemplatesCodesForPool(
   String^ Token,
   DateTime date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetTestProtocolTemplatesCodesForPool(
    Token : String,
    date : DateTime
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

date

Type: DateTime

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetTestProtocolTemplatesCodesItemCodeForRetest Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTestProtocolTemplatesCodesItemCodeForRetest( _
   ByVal Token As String, _
   ByVal date As Date, _
   ByVal itemcode As String, _
   ByVal revision As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTestProtocolTemplatesCodesItemCodeForRetest(
   string Token,
   DateTime date,
   string itemcode,
   string revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTestProtocolTemplatesCodesItemCodeForRetest(
   String^ Token,
   DateTime date,
   String^ itemcode,
   String^ revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetTestProtocolTemplatesCodesItemCodeForRetest(
    Token : String,
    date : DateTime,
    itemcode : String,
    revision : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

date

Type: DateTime

itemcode

Type: string

revision

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetTestProtocolTemplatesCodesItemCodeForRetestForMOR Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTestProtocolTemplatesCodesItemCodeForRetestForMOR( _
   ByVal Token As String, _
   ByVal date As Date, _
   ByVal itemcode As String, _
   ByVal revision As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTestProtocolTemplatesCodesItemCodeForRetestForMOR(
   string Token,
   DateTime date,
   string itemcode,
   string revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTestProtocolTemplatesCodesItemCodeForRetestForMOR(
   String^ Token,
   DateTime date,
   String^ itemcode,
   String^ revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetTestProtocolTemplatesCodesItemCodeForRetestForMOR(
    Token : String,
    date : DateTime,
    itemcode : String,
    revision : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

date

Type: DateTime

itemcode

Type: string

revision

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.GetTestProtocolTestResults Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTestProtocolTestResults( _
   ByVal token As String, _
   ByVal testProtocolNo As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTestProtocolTestResults(
   string token,
   string testProtocolNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTestProtocolTestResults(
   String^ token,
   String^ testProtocolNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetTestProtocolTestResults(
    token : String,
    testProtocolNo : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

testProtocolNo

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.QCTExistsGoodReceipt Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function QCTExistsGoodReceipt( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal docEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset QCTExistsGoodReceipt(
   string token,
   string itemCode,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ QCTExistsGoodReceipt(
   String^ token,
   String^ itemCode,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QCTExistsGoodReceipt(
    token : String,
    itemCode : String,
    docEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

docEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.QCTExistsGoodReceiptPO Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function QCTExistsGoodReceiptPO( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal docEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset QCTExistsGoodReceiptPO(
   string token,
   string itemCode,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ QCTExistsGoodReceiptPO(
   String^ token,
   String^ itemCode,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QCTExistsGoodReceiptPO(
    token : String,
    itemCode : String,
    docEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

docEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.RepairComplaintsU_DocNoField Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function RepairComplaintsU_DocNoField( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset RepairComplaintsU_DocNoField(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ RepairComplaintsU_DocNoField(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RepairComplaintsU_DocNoField(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.TestProtocolExists Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function TestProtocolExists( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal cardCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset TestProtocolExists(
   string token,
   string itemCode,
   string cardCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ TestProtocolExists(
   String^ token,
   String^ itemCode,
   String^ cardCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function TestProtocolExists(
    token : String,
    itemCode : String,
    cardCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

cardCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.TestProtocolExistsComplaint Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function TestProtocolExistsComplaint( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset TestProtocolExistsComplaint(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ TestProtocolExistsComplaint(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function TestProtocolExistsComplaint(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.TestProtocolExistsGoodReceipt Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function TestProtocolExistsGoodReceipt( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal cardCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset TestProtocolExistsGoodReceipt(
   string token,
   string itemCode,
   string cardCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ TestProtocolExistsGoodReceipt(
   String^ token,
   String^ itemCode,
   String^ cardCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function TestProtocolExistsGoodReceipt(
    token : String,
    itemCode : String,
    cardCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

cardCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.TestProtocolExistsPickReceipt Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function TestProtocolExistsPickReceipt( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal cardCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset TestProtocolExistsPickReceipt(
   string token,
   string itemCode,
   string cardCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ TestProtocolExistsPickReceipt(
   String^ token,
   String^ itemCode,
   String^ cardCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function TestProtocolExistsPickReceipt(
    token : String,
    itemCode : String,
    cardCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

cardCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlBaseQueries.TestProtocolExistsStockTransfer Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function TestProtocolExistsStockTransfer( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal cardCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset TestProtocolExistsStockTransfer(
   string token,
   string itemCode,
   string cardCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ TestProtocolExistsStockTransfer(
   String^ token,
   String^ itemCode,
   String^ cardCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function TestProtocolExistsStockTransfer(
    token : String,
    itemCode : String,
    cardCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

cardCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlBaseQueries Class
QualityControlBaseQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlSapHanaQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class QualityControlSapHanaQueries
    Inherits QualityControlBaseQueries
    Implements IQualityControlQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QualityControlSapHanaQueries : QualityControlBaseQueries,
   IQualityControlQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class QualityControlSapHanaQueries : public QualityControlBaseQueries^,
   public IQualityControlQueries^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QualityControlSapHanaQueries
   extends QualityControlBaseQueries
   implements IQualityControlQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.QualityControl.QualityControlBaseQueries
CompuTec.ProcessForce.API.Queries.QualityControl.QualityControlSapHanaQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlSapHanaQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlSapHanaQueries Members

QualityControlSapHanaQueries Class Methods See Also

The following tables list the members exposed by the QualityControlSapHanaQueries type.

Methods
 | Name | Description
Public method | BatchDetailsQualityControlReportQuery | (inherited from QualityControlBaseQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBatchRelatedComplaints | (inherited from QualityControlBaseQueries).
Public method | GetComplaintHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetComplaintMatchingBatchNo | (inherited from QualityControlBaseQueries).
Public method | GetComplaintMatchingBatchNoForManufacturingOrder | (inherited from QualityControlBaseQueries).
Public method | GetComplaintMatchingSerialNo | (inherited from QualityControlBaseQueries).
Public method | GetComplaintMatchingSerialNoForManufacturingOrder | (inherited from QualityControlBaseQueries).
Public method | GetComplaintReasonsUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetComplaintSerialNoUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemProperties | (inherited from QualityControlBaseQueries).
Public method | GetLastNcmrTransactionDocEntry | (inherited from QualityControlBaseQueries).
Public method | GetManufacturingOrderOperationStatus | (inherited from QualityControlBaseQueries).
Public method | GetNcmrTransactionDefectUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetNcmrTransactionHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetNcmrTransactionInspectorTableCode | (inherited from QualityControlBaseQueries).
Public method | GetNcmrTransactionReasonUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetNextComplaintNo | (inherited from QualityControlBaseQueries).
Public method | GetNextNcmrTransactionNo | (inherited from QualityControlBaseQueries).
Public method | GetNextQualityControlTestNo | (inherited from QualityControlBaseQueries).
Public method | GetNextQualityControlTestPoolNo | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlAdditionalBatchDetails | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlComplaintDocEntry | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestChildUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestDocumentSeriesAndNumber | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestPoolHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestPoolUsedCount | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestSerialUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestUsedCount | (inherited from QualityControlBaseQueries).
Public method | GetReferenceCodes | (inherited from QualityControlBaseQueries).
Public method | GetTestPropertyReferenceCodes | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolAttachments | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolItemProperties | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolItems | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolItemsResourcesUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolPropertiesUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolResources | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTemplatesCodes | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTemplatesCodesForPool | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTemplatesCodesItemCodeForRetest | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTemplatesCodesItemCodeForRetestForMOR | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTestResults | (inherited from QualityControlBaseQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | QCTExistsGoodReceipt | (inherited from QualityControlBaseQueries).
Public method | QCTExistsGoodReceiptPO | (inherited from QualityControlBaseQueries).
Public method | RepairComplaintsU_DocNoField | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExists | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExistsComplaint | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExistsGoodReceipt | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExistsPickReceipt | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExistsStockTransfer | (inherited from QualityControlBaseQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QualityControlSapHanaQueries Class
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlSapHanaQueries Methods

QualityControlSapHanaQueries Class See Also

The following tables list the members exposed by the QualityControlSapHanaQueries type.

Methods
 | Name | Description
Public method | BatchDetailsQualityControlReportQuery | (inherited from QualityControlBaseQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBatchRelatedComplaints | (inherited from QualityControlBaseQueries).
Public method | GetComplaintHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetComplaintMatchingBatchNo | (inherited from QualityControlBaseQueries).
Public method | GetComplaintMatchingBatchNoForManufacturingOrder | (inherited from QualityControlBaseQueries).
Public method | GetComplaintMatchingSerialNo | (inherited from QualityControlBaseQueries).
Public method | GetComplaintMatchingSerialNoForManufacturingOrder | (inherited from QualityControlBaseQueries).
Public method | GetComplaintReasonsUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetComplaintSerialNoUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemProperties | (inherited from QualityControlBaseQueries).
Public method | GetLastNcmrTransactionDocEntry | (inherited from QualityControlBaseQueries).
Public method | GetManufacturingOrderOperationStatus | (inherited from QualityControlBaseQueries).
Public method | GetNcmrTransactionDefectUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetNcmrTransactionHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetNcmrTransactionInspectorTableCode | (inherited from QualityControlBaseQueries).
Public method | GetNcmrTransactionReasonUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetNextComplaintNo | (inherited from QualityControlBaseQueries).
Public method | GetNextNcmrTransactionNo | (inherited from QualityControlBaseQueries).
Public method | GetNextQualityControlTestNo | (inherited from QualityControlBaseQueries).
Public method | GetNextQualityControlTestPoolNo | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlAdditionalBatchDetails | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlComplaintDocEntry | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestChildUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestDocumentSeriesAndNumber | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestPoolHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestPoolUsedCount | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestSerialUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestUsedCount | (inherited from QualityControlBaseQueries).
Public method | GetReferenceCodes | (inherited from QualityControlBaseQueries).
Public method | GetTestPropertyReferenceCodes | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolAttachments | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolItemProperties | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolItems | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolItemsResourcesUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolPropertiesUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolResources | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTemplatesCodes | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTemplatesCodesForPool | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTemplatesCodesItemCodeForRetest | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTemplatesCodesItemCodeForRetestForMOR | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTestResults | (inherited from QualityControlBaseQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | QCTExistsGoodReceipt | (inherited from QualityControlBaseQueries).
Public method | QCTExistsGoodReceiptPO | (inherited from QualityControlBaseQueries).
Public method | RepairComplaintsU_DocNoField | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExists | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExistsComplaint | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExistsGoodReceipt | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExistsPickReceipt | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExistsStockTransfer | (inherited from QualityControlBaseQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QualityControlSapHanaQueries Class
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlSqlServerQuerties Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class QualityControlSqlServerQuerties
    Inherits QualityControlBaseQueries
    Implements IQualityControlQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QualityControlSqlServerQuerties : QualityControlBaseQueries,
   IQualityControlQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class QualityControlSqlServerQuerties : public QualityControlBaseQueries^,
   public IQualityControlQueries^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QualityControlSqlServerQuerties
   extends QualityControlBaseQueries
   implements IQualityControlQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.QualityControl.QualityControlBaseQueries
CompuTec.ProcessForce.API.Queries.QualityControl.QualityControlSqlServerQuerties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QualityControlSqlServerQuerties Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlSqlServerQuerties Members

QualityControlSqlServerQuerties Class Methods See Also

The following tables list the members exposed by the QualityControlSqlServerQuerties type.

Methods
 | Name | Description
Public method | BatchDetailsQualityControlReportQuery | (inherited from QualityControlBaseQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBatchRelatedComplaints | (inherited from QualityControlBaseQueries).
Public method | GetComplaintHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetComplaintMatchingBatchNo | (inherited from QualityControlBaseQueries).
Public method | GetComplaintMatchingBatchNoForManufacturingOrder | (inherited from QualityControlBaseQueries).
Public method | GetComplaintMatchingSerialNo | (inherited from QualityControlBaseQueries).
Public method | GetComplaintMatchingSerialNoForManufacturingOrder | (inherited from QualityControlBaseQueries).
Public method | GetComplaintReasonsUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetComplaintSerialNoUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemProperties | (inherited from QualityControlBaseQueries).
Public method | GetLastNcmrTransactionDocEntry | (inherited from QualityControlBaseQueries).
Public method | GetManufacturingOrderOperationStatus | (inherited from QualityControlBaseQueries).
Public method | GetNcmrTransactionDefectUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetNcmrTransactionHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetNcmrTransactionInspectorTableCode | (inherited from QualityControlBaseQueries).
Public method | GetNcmrTransactionReasonUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetNextComplaintNo | (inherited from QualityControlBaseQueries).
Public method | GetNextNcmrTransactionNo | (inherited from QualityControlBaseQueries).
Public method | GetNextQualityControlTestNo | (inherited from QualityControlBaseQueries).
Public method | GetNextQualityControlTestPoolNo | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlAdditionalBatchDetails | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlComplaintDocEntry | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestChildUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestDocumentSeriesAndNumber | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestPoolHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestPoolUsedCount | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestSerialUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestUsedCount | (inherited from QualityControlBaseQueries).
Public method | GetReferenceCodes | (inherited from QualityControlBaseQueries).
Public method | GetTestPropertyReferenceCodes | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolAttachments | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolItemProperties | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolItems | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolItemsResourcesUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolPropertiesUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolResources | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTemplatesCodes | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTemplatesCodesForPool | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTemplatesCodesItemCodeForRetest | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTemplatesCodesItemCodeForRetestForMOR | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTestResults | (inherited from QualityControlBaseQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | QCTExistsGoodReceipt | (inherited from QualityControlBaseQueries).
Public method | QCTExistsGoodReceiptPO | (inherited from QualityControlBaseQueries).
Public method | RepairComplaintsU_DocNoField | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExists | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExistsComplaint | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExistsGoodReceipt | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExistsPickReceipt | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExistsStockTransfer | (inherited from QualityControlBaseQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QualityControlSqlServerQuerties Class
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


QualityControlSqlServerQuerties Methods

QualityControlSqlServerQuerties Class See Also

The following tables list the members exposed by the QualityControlSqlServerQuerties type.

Methods
 | Name | Description
Public method | BatchDetailsQualityControlReportQuery | (inherited from QualityControlBaseQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBatchRelatedComplaints | (inherited from QualityControlBaseQueries).
Public method | GetComplaintHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetComplaintMatchingBatchNo | (inherited from QualityControlBaseQueries).
Public method | GetComplaintMatchingBatchNoForManufacturingOrder | (inherited from QualityControlBaseQueries).
Public method | GetComplaintMatchingSerialNo | (inherited from QualityControlBaseQueries).
Public method | GetComplaintMatchingSerialNoForManufacturingOrder | (inherited from QualityControlBaseQueries).
Public method | GetComplaintReasonsUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetComplaintSerialNoUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemProperties | (inherited from QualityControlBaseQueries).
Public method | GetLastNcmrTransactionDocEntry | (inherited from QualityControlBaseQueries).
Public method | GetManufacturingOrderOperationStatus | (inherited from QualityControlBaseQueries).
Public method | GetNcmrTransactionDefectUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetNcmrTransactionHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetNcmrTransactionInspectorTableCode | (inherited from QualityControlBaseQueries).
Public method | GetNcmrTransactionReasonUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetNextComplaintNo | (inherited from QualityControlBaseQueries).
Public method | GetNextNcmrTransactionNo | (inherited from QualityControlBaseQueries).
Public method | GetNextQualityControlTestNo | (inherited from QualityControlBaseQueries).
Public method | GetNextQualityControlTestPoolNo | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlAdditionalBatchDetails | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlComplaintDocEntry | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestChildUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestDocumentSeriesAndNumber | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestPoolHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestPoolUsedCount | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestSerialUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetQualityControlTestUsedCount | (inherited from QualityControlBaseQueries).
Public method | GetReferenceCodes | (inherited from QualityControlBaseQueries).
Public method | GetTestPropertyReferenceCodes | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolAttachments | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolHeaderUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolItemProperties | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolItems | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolItemsResourcesUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolPropertiesUserDataSources | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolResources | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTemplatesCodes | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTemplatesCodesForPool | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTemplatesCodesItemCodeForRetest | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTemplatesCodesItemCodeForRetestForMOR | (inherited from QualityControlBaseQueries).
Public method | GetTestProtocolTestResults | (inherited from QualityControlBaseQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | QCTExistsGoodReceipt | (inherited from QualityControlBaseQueries).
Public method | QCTExistsGoodReceiptPO | (inherited from QualityControlBaseQueries).
Public method | RepairComplaintsU_DocNoField | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExists | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExistsComplaint | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExistsGoodReceipt | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExistsPickReceipt | (inherited from QualityControlBaseQueries).
Public method | TestProtocolExistsStockTransfer | (inherited from QualityControlBaseQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QualityControlSqlServerQuerties Class
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


IQualityControlQueries Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IQualityControlQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IQualityControlQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IQualityControlQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IQualityControlQueries
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


IQualityControlQueries Members

IQualityControlQueries Interface Methods See Also

The following tables list the members exposed by the IQualityControlQueries type.

Methods
 | Name | Description
Public method | BatchDetailsQualityControlReportQuery |
Public method | GetTestProtocolTemplatesCodes |
Public method | GetTestProtocolTemplatesCodesForPool |
Public method | GetTestProtocolTemplatesCodesItemCodeForRetest |
Public method | GetTestProtocolTemplatesCodesItemCodeForRetestForMOR |
Public method | RepairComplaintsU_DocNoField |
Top
See Also

Reference

IQualityControlQueries Interface
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


IQualityControlQueries Methods

IQualityControlQueries Interface See Also

The following tables list the members exposed by the IQualityControlQueries type.

Methods
 | Name | Description
Public method | BatchDetailsQualityControlReportQuery |
Public method | GetTestProtocolTemplatesCodes |
Public method | GetTestProtocolTemplatesCodesForPool |
Public method | GetTestProtocolTemplatesCodesItemCodeForRetest |
Public method | GetTestProtocolTemplatesCodesItemCodeForRetestForMOR |
Public method | RepairComplaintsU_DocNoField |
Top
See Also

Reference

IQualityControlQueries Interface
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


IQualityControlQueries.BatchDetailsQualityControlReportQuery Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function BatchDetailsQualityControlReportQuery( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal DistNumber As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string BatchDetailsQualityControlReportQuery(
   string token,
   string itemCode,
   string DistNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

String^ BatchDetailsQualityControlReportQuery(
   String^ token,
   String^ itemCode,
   String^ DistNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function BatchDetailsQualityControlReportQuery(
    token : String,
    itemCode : String,
    DistNumber : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

DistNumber

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlQueries Interface
IQualityControlQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


IQualityControlQueries.GetTestProtocolTemplatesCodes Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetTestProtocolTemplatesCodes( _
   ByVal Token As String, _
   ByVal date As Date _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetTestProtocolTemplatesCodes(
   string Token,
   DateTime date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetTestProtocolTemplatesCodes(
   String^ Token,
   DateTime date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetTestProtocolTemplatesCodes(
    Token : String,
    date : DateTime
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

date

Type: DateTime

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlQueries Interface
IQualityControlQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


IQualityControlQueries.GetTestProtocolTemplatesCodesForPool Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetTestProtocolTemplatesCodesForPool( _
   ByVal Token As String, _
   ByVal date As Date _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetTestProtocolTemplatesCodesForPool(
   string Token,
   DateTime date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetTestProtocolTemplatesCodesForPool(
   String^ Token,
   DateTime date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetTestProtocolTemplatesCodesForPool(
    Token : String,
    date : DateTime
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

date

Type: DateTime

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlQueries Interface
IQualityControlQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


IQualityControlQueries.GetTestProtocolTemplatesCodesItemCodeForRetest Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetTestProtocolTemplatesCodesItemCodeForRetest( _
   ByVal Token As String, _
   ByVal date As Date, _
   ByVal itemcode As String, _
   ByVal revision As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetTestProtocolTemplatesCodesItemCodeForRetest(
   string Token,
   DateTime date,
   string itemcode,
   string revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetTestProtocolTemplatesCodesItemCodeForRetest(
   String^ Token,
   DateTime date,
   String^ itemcode,
   String^ revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetTestProtocolTemplatesCodesItemCodeForRetest(
    Token : String,
    date : DateTime,
    itemcode : String,
    revision : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

date

Type: DateTime

itemcode

Type: string

revision

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlQueries Interface
IQualityControlQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


IQualityControlQueries.GetTestProtocolTemplatesCodesItemCodeForRetestForMOR Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetTestProtocolTemplatesCodesItemCodeForRetestForMOR( _
   ByVal Token As String, _
   ByVal date As Date, _
   ByVal itemcode As String, _
   ByVal revision As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetTestProtocolTemplatesCodesItemCodeForRetestForMOR(
   string Token,
   DateTime date,
   string itemcode,
   string revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetTestProtocolTemplatesCodesItemCodeForRetestForMOR(
   String^ Token,
   DateTime date,
   String^ itemcode,
   String^ revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetTestProtocolTemplatesCodesItemCodeForRetestForMOR(
    Token : String,
    date : DateTime,
    itemcode : String,
    revision : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

date

Type: DateTime

itemcode

Type: string

revision

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlQueries Interface
IQualityControlQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


IQualityControlQueries.RepairComplaintsU_DocNoField Method

Namespace: CompuTec.ProcessForce.API.Queries.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function RepairComplaintsU_DocNoField( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset RepairComplaintsU_DocNoField(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ RepairComplaintsU_DocNoField(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function RepairComplaintsU_DocNoField(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlQueries Interface
IQualityControlQueries Members
CompuTec.ProcessForce.API.Queries.QualityControl Namespace


CompuTec.ProcessForce.API.Queries.Scheduling Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | HANASchedulingQueries |
Public class | SQLSchedulingQueries |
Public class | SchedulingBaseQueries |
Top
Interfaces
 | Name | Description
Public interface | ISchedulingQueries |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


HANASchedulingQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class HANASchedulingQueries
    Inherits SchedulingBaseQueries
    Implements ISchedulingQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class HANASchedulingQueries : SchedulingBaseQueries,
   ISchedulingQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class HANASchedulingQueries : public SchedulingBaseQueries^,
   public ISchedulingQueries^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class HANASchedulingQueries
   extends SchedulingBaseQueries
   implements ISchedulingQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.Scheduling.SchedulingBaseQueries
CompuTec.ProcessForce.API.Queries.Scheduling.HANASchedulingQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HANASchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


HANASchedulingQueries Members

HANASchedulingQueries Class Methods See Also

The following tables list the members exposed by the HANASchedulingQueries type.

Methods
 | Name | Description
Public method | CheckStatusOfTask | (inherited from SchedulingBaseQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GEtAllWorkResources | (inherited from SchedulingBaseQueries).
Public method | GEtReceiptedQuantityForMOR | (inherited from SchedulingBaseQueries).
Public method | GEtReceiptedQuantityForMORLine | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativeResources | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativeResourcesDirectAccess | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativeResourcesForCreatedMorsWithoutChangedRoutings | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativesForCreatedMorWithChangedRoutingsAndNotCreatedMors | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativesFromOperations | (inherited from SchedulingBaseQueries).
Public method | GetAllExtendedRelationsBetweenListOfMors | (inherited from SchedulingBaseQueries).
Public method | GetAllExtendedRelationsForSpecificMor | (inherited from SchedulingBaseQueries).
Public method | GetAllLinkedTools | (inherited from SchedulingBaseQueries).
Public method | GetAllRelations | (inherited from SchedulingBaseQueries).
Public method | GetExtendedRelations | (inherited from SchedulingBaseQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetHolidayData | (inherited from SchedulingBaseQueries).
Public method | GetHolidayParam | (inherited from SchedulingBaseQueries).
Public method | GetInactiveItemsSqlQuery | (inherited from SchedulingBaseQueries).
Public method | GetInfiniteFieldOfResources | (inherited from SchedulingBaseQueries).
Public method | GetLastTeamCode | (inherited from SchedulingBaseQueries).
Public method | GetLoadAvalibliForResource | (inherited from SchedulingBaseQueries).
Public method | GetMinAndMaxActualDateTimesForOperationsRelations | (inherited from SchedulingBaseQueries).
Public method | GetPDCTasks | (inherited from SchedulingBaseQueries).
Public method | GetPDCTasksToClose | (inherited from SchedulingBaseQueries).
Public method | GetQuantities | (inherited from SchedulingBaseQueries).
Public method | GetResourceGroupOverload | (inherited from SchedulingBaseQueries).
Public method | GetResourceOverload | (inherited from SchedulingBaseQueries).
Public method | GetResourcesForSchedulingBackground | Retun List of Schedulele Resources for Gant (inherited from SchedulingBaseQueries).
Public method | GetSalesOrderReferences | (inherited from SchedulingBaseQueries).
Public method | GetStdHolidayCode | (inherited from SchedulingBaseQueries).
Public method | GetSumOfAllExtendedMorRelationsQuantitiesChild | (inherited from SchedulingBaseQueries).
Public method | GetSumOfAllExtendedMorRelationsQuantitiesChildExcept | (inherited from SchedulingBaseQueries).
Public method | GetSumOfAllExtendedMorRelationsQuantitiesParent | (inherited from SchedulingBaseQueries).
Public method | GetSumOfAllExtendedMorRelationsQuantitiesParentExcept | (inherited from SchedulingBaseQueries).
Public method | GetTaskStatusByMOR | (inherited from SchedulingBaseQueries).
Public method | GetTaskStatusForMors | (inherited from SchedulingBaseQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetValueOfDeliveryTime | (Overloaded) Method is receiving delivery time as in hierarchy. First is going go check in business partner address and if there is no, then is trying to get this information from header of business partner. If there is no value in business partner address, neither in business partner then method is going to receive empty string. (inherited from SchedulingBaseQueries).
Public method | GetValueOfInternalLeadTime | (Overloaded) The method is going to receive value of internal lead time as is mentioned in hierarchy. First is going to check in business partner address, then business partner general. The next tries would be in item details revision and the other one in item master data in case row contains item, not the bom. Then warehouse is going to be check, but only in case if the operation was triggered from line, not the header. Last place which is going to be be check is document settings. If there is no value then empty string is going to be received. (inherited from SchedulingBaseQueries).
Public method | GetValueOfReceiveLeadTime | The method is going to receive value of receive lead time as is mentioned in hierarchy. First is going to check in business partner address, then business partner general. The next try would be in warehouse, but only in case if the operation was triggered from line, not the header. Last place which is going to be be check is document settings. If there is no value then empty string is going to be received. (inherited from SchedulingBaseQueries).
Public method | MORRelationsAssignChild | (inherited from SchedulingBaseQueries).
Public method | MORRelationsAssignParent | (inherited from SchedulingBaseQueries).
Public method | MORRelationsCreateChild | (inherited from SchedulingBaseQueries).
Public method | MORRelationsCreateParent | (inherited from SchedulingBaseQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | ValidateCloseTaskFieldForCLoseSteToNo | (inherited from SchedulingBaseQueries).
Public method | ValidateCloseTaskFieldForCLoseSteToYes | (inherited from SchedulingBaseQueries).
Top
See Also

Reference

HANASchedulingQueries Class
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


HANASchedulingQueries Methods

HANASchedulingQueries Class See Also

The following tables list the members exposed by the HANASchedulingQueries type.

Methods
 | Name | Description
Public method | CheckStatusOfTask | (inherited from SchedulingBaseQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GEtAllWorkResources | (inherited from SchedulingBaseQueries).
Public method | GEtReceiptedQuantityForMOR | (inherited from SchedulingBaseQueries).
Public method | GEtReceiptedQuantityForMORLine | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativeResources | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativeResourcesDirectAccess | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativeResourcesForCreatedMorsWithoutChangedRoutings | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativesForCreatedMorWithChangedRoutingsAndNotCreatedMors | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativesFromOperations | (inherited from SchedulingBaseQueries).
Public method | GetAllExtendedRelationsBetweenListOfMors | (inherited from SchedulingBaseQueries).
Public method | GetAllExtendedRelationsForSpecificMor | (inherited from SchedulingBaseQueries).
Public method | GetAllLinkedTools | (inherited from SchedulingBaseQueries).
Public method | GetAllRelations | (inherited from SchedulingBaseQueries).
Public method | GetExtendedRelations | (inherited from SchedulingBaseQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetHolidayData | (inherited from SchedulingBaseQueries).
Public method | GetHolidayParam | (inherited from SchedulingBaseQueries).
Public method | GetInactiveItemsSqlQuery | (inherited from SchedulingBaseQueries).
Public method | GetInfiniteFieldOfResources | (inherited from SchedulingBaseQueries).
Public method | GetLastTeamCode | (inherited from SchedulingBaseQueries).
Public method | GetLoadAvalibliForResource | (inherited from SchedulingBaseQueries).
Public method | GetMinAndMaxActualDateTimesForOperationsRelations | (inherited from SchedulingBaseQueries).
Public method | GetPDCTasks | (inherited from SchedulingBaseQueries).
Public method | GetPDCTasksToClose | (inherited from SchedulingBaseQueries).
Public method | GetQuantities | (inherited from SchedulingBaseQueries).
Public method | GetResourceGroupOverload | (inherited from SchedulingBaseQueries).
Public method | GetResourceOverload | (inherited from SchedulingBaseQueries).
Public method | GetResourcesForSchedulingBackground | Retun List of Schedulele Resources for Gant (inherited from SchedulingBaseQueries).
Public method | GetSalesOrderReferences | (inherited from SchedulingBaseQueries).
Public method | GetStdHolidayCode | (inherited from SchedulingBaseQueries).
Public method | GetSumOfAllExtendedMorRelationsQuantitiesChild | (inherited from SchedulingBaseQueries).
Public method | GetSumOfAllExtendedMorRelationsQuantitiesChildExcept | (inherited from SchedulingBaseQueries).
Public method | GetSumOfAllExtendedMorRelationsQuantitiesParent | (inherited from SchedulingBaseQueries).
Public method | GetSumOfAllExtendedMorRelationsQuantitiesParentExcept | (inherited from SchedulingBaseQueries).
Public method | GetTaskStatusByMOR | (inherited from SchedulingBaseQueries).
Public method | GetTaskStatusForMors | (inherited from SchedulingBaseQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetValueOfDeliveryTime | (Overloaded) Method is receiving delivery time as in hierarchy. First is going go check in business partner address and if there is no, then is trying to get this information from header of business partner. If there is no value in business partner address, neither in business partner then method is going to receive empty string. (inherited from SchedulingBaseQueries).
Public method | GetValueOfInternalLeadTime | (Overloaded) The method is going to receive value of internal lead time as is mentioned in hierarchy. First is going to check in business partner address, then business partner general. The next tries would be in item details revision and the other one in item master data in case row contains item, not the bom. Then warehouse is going to be check, but only in case if the operation was triggered from line, not the header. Last place which is going to be be check is document settings. If there is no value then empty string is going to be received. (inherited from SchedulingBaseQueries).
Public method | GetValueOfReceiveLeadTime | The method is going to receive value of receive lead time as is mentioned in hierarchy. First is going to check in business partner address, then business partner general. The next try would be in warehouse, but only in case if the operation was triggered from line, not the header. Last place which is going to be be check is document settings. If there is no value then empty string is going to be received. (inherited from SchedulingBaseQueries).
Public method | MORRelationsAssignChild | (inherited from SchedulingBaseQueries).
Public method | MORRelationsAssignParent | (inherited from SchedulingBaseQueries).
Public method | MORRelationsCreateChild | (inherited from SchedulingBaseQueries).
Public method | MORRelationsCreateParent | (inherited from SchedulingBaseQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | ValidateCloseTaskFieldForCLoseSteToNo | (inherited from SchedulingBaseQueries).
Public method | ValidateCloseTaskFieldForCLoseSteToYes | (inherited from SchedulingBaseQueries).
Top
See Also

Reference

HANASchedulingQueries Class
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.CheckStatusOfTask Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CheckStatusOfTask( _
   ByVal Token As String, _
   ByVal DocEntrys As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset CheckStatusOfTask(
   string Token,
   IEnumerable<int> DocEntrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ CheckStatusOfTask(
   String^ Token,
   IEnumerable<int>^ DocEntrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntrys

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GEtAllWorkResources Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GEtAllWorkResources( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GEtAllWorkResources(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GEtAllWorkResources(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GEtAllWorkResources(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GEtReceiptedQuantityForMOR Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GEtReceiptedQuantityForMOR( _
   ByVal Token As String, _
   ByVal DocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GEtReceiptedQuantityForMOR(
   string Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GEtReceiptedQuantityForMOR(
   String^ Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GEtReceiptedQuantityForMOR(
    Token : String,
    DocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GEtReceiptedQuantityForMORLine Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GEtReceiptedQuantityForMORLine( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal LineNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GEtReceiptedQuantityForMORLine(
   string Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GEtReceiptedQuantityForMORLine(
   String^ Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GEtReceiptedQuantityForMORLine(
    Token : String,
    DocEntry : int,
    LineNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

LineNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetAllAlternativeResources Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAllAlternativeResources( _
   ByVal Token As String, _
   ByVal queryWhere As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAllAlternativeResources(
   string Token,
   string queryWhere
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAllAlternativeResources(
   String^ Token,
   String^ queryWhere
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAllAlternativeResources(
    Token : String,
    queryWhere : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

queryWhere

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetAllAlternativeResourcesDirectAccess Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAllAlternativeResourcesDirectAccess( _
   ByVal Token As String, _
   ByVal connection As DbConnection, _
   ByVal tempTableName As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAllAlternativeResourcesDirectAccess(
   string Token,
   DbConnection connection,
   string tempTableName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAllAlternativeResourcesDirectAccess(
   String^ Token,
   DbConnection^ connection,
   String^ tempTableName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAllAlternativeResourcesDirectAccess(
    Token : String,
    connection : DbConnection,
    tempTableName : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

connection

Type: DbConnection

tempTableName

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetAllAlternativeResourcesForCreatedMorsWithoutChangedRoutings Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAllAlternativeResourcesForCreatedMorsWithoutChangedRoutings( _
   ByVal Token As String, _
   ByVal mors As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAllAlternativeResourcesForCreatedMorsWithoutChangedRoutings(
   string Token,
   List<string> mors
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAllAlternativeResourcesForCreatedMorsWithoutChangedRoutings(
   String^ Token,
   List<String^>^ mors
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

mors

Type: List<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetAllAlternativesForCreatedMorWithChangedRoutingsAndNotCreatedMors Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAllAlternativesForCreatedMorWithChangedRoutingsAndNotCreatedMors( _
   ByVal Token As String, _
   ByVal bom As String, _
   ByVal revision As String, _
   ByVal routing As String, _
   ByVal rtgOprCode As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAllAlternativesForCreatedMorWithChangedRoutingsAndNotCreatedMors(
   string Token,
   string bom,
   string revision,
   string routing,
   int rtgOprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAllAlternativesForCreatedMorWithChangedRoutingsAndNotCreatedMors(
   String^ Token,
   String^ bom,
   String^ revision,
   String^ routing,
   int rtgOprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAllAlternativesForCreatedMorWithChangedRoutingsAndNotCreatedMors(
    Token : String,
    bom : String,
    revision : String,
    routing : String,
    rtgOprCode : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

bom

Type: string

revision

Type: string

routing

Type: string

rtgOprCode

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetAllAlternativesFromOperations Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAllAlternativesFromOperations( _
   ByVal Token As String, _
   ByVal oprCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAllAlternativesFromOperations(
   string Token,
   string oprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAllAlternativesFromOperations(
   String^ Token,
   String^ oprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAllAlternativesFromOperations(
    Token : String,
    oprCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

oprCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetAllExtendedRelationsBetweenListOfMors Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAllExtendedRelationsBetweenListOfMors( _
   ByVal Token As String, _
   ByVal docEntries As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAllExtendedRelationsBetweenListOfMors(
   string Token,
   List<string> docEntries
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAllExtendedRelationsBetweenListOfMors(
   String^ Token,
   List<String^>^ docEntries
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

docEntries

Type: List<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetAllExtendedRelationsForSpecificMor Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAllExtendedRelationsForSpecificMor( _
   ByVal Token As String, _
   ByVal docEntry As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAllExtendedRelationsForSpecificMor(
   string Token,
   string docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAllExtendedRelationsForSpecificMor(
   String^ Token,
   String^ docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAllExtendedRelationsForSpecificMor(
    Token : String,
    docEntry : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

docEntry

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetAllLinkedTools Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAllLinkedTools( _
   ByVal Token As String, _
   ByVal usedResources As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAllLinkedTools(
   string Token,
   List<string> usedResources
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAllLinkedTools(
   String^ Token,
   List<String^>^ usedResources
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

usedResources

Type: List<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetAllRelations Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAllRelations( _
   ByVal Token As String, _
   ByVal docEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAllRelations(
   string Token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAllRelations(
   String^ Token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAllRelations(
    Token : String,
    docEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

docEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetExtendedRelations Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetExtendedRelations( _
   ByVal Token As String, _
   ByVal docEntry As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetExtendedRelations(
   string Token,
   string docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetExtendedRelations(
   String^ Token,
   String^ docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetExtendedRelations(
    Token : String,
    docEntry : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

docEntry

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetHolidayData Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetHolidayData( _
   ByVal Token As String, _
   ByVal hldCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetHolidayData(
   string Token,
   string hldCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetHolidayData(
   String^ Token,
   String^ hldCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetHolidayData(
    Token : String,
    hldCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

hldCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetHolidayParam Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetHolidayParam( _
   ByVal Token As String, _
   ByVal hldCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetHolidayParam(
   string Token,
   string hldCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetHolidayParam(
   String^ Token,
   String^ hldCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetHolidayParam(
    Token : String,
    hldCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

hldCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetInactiveItemsSqlQuery Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetInactiveItemsSqlQuery( _
   ByVal token As String, _
   ByVal itemCodes As IEnumerable(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetInactiveItemsSqlQuery(
   string token,
   IEnumerable<string> itemCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetInactiveItemsSqlQuery(
   String^ token,
   IEnumerable<String^>^ itemCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCodes

Type: IEnumerable<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetInfiniteFieldOfResources Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetInfiniteFieldOfResources( _
   ByVal Token As String, _
   ByVal resources As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetInfiniteFieldOfResources(
   string Token,
   List<string> resources
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetInfiniteFieldOfResources(
   String^ Token,
   List<String^>^ resources
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

resources

Type: List<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetLastTeamCode Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetLastTeamCode( _
   ByVal token As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GetLastTeamCode(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ GetLastTeamCode(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetLastTeamCode(
    token : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetLoadAvalibliForResource Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetLoadAvalibliForResource( _
   ByVal Token As String, _
   ByVal Resource As String, _
   ByVal FromDate As Date, _
   ByVal ExludedDocEntrys As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetLoadAvalibliForResource(
   string Token,
   string Resource,
   DateTime FromDate,
   IEnumerable<int> ExludedDocEntrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetLoadAvalibliForResource(
   String^ Token,
   String^ Resource,
   DateTime FromDate,
   IEnumerable<int>^ ExludedDocEntrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

Resource

Type: string

FromDate

Type: DateTime

ExludedDocEntrys

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetMinAndMaxActualDateTimesForOperationsRelations Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetMinAndMaxActualDateTimesForOperationsRelations( _
   ByVal Token As String, _
   ByVal docEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetMinAndMaxActualDateTimesForOperationsRelations(
   string Token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetMinAndMaxActualDateTimesForOperationsRelations(
   String^ Token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetMinAndMaxActualDateTimesForOperationsRelations(
    Token : String,
    docEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

docEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetPDCTasks Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetPDCTasks( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetPDCTasks(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetPDCTasks(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetPDCTasks(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetPDCTasksToClose Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetPDCTasksToClose( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal baseLine As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetPDCTasksToClose(
   string Token,
   int DocEntry,
   int baseLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetPDCTasksToClose(
   String^ Token,
   int DocEntry,
   int baseLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetPDCTasksToClose(
    Token : String,
    DocEntry : int,
    baseLine : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

baseLine

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetQuantities Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetQuantities( _
   ByVal Token As String, _
   ByVal docEntry As Integer, _
   ByVal oprId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetQuantities(
   string Token,
   int docEntry,
   int oprId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetQuantities(
   String^ Token,
   int docEntry,
   int oprId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetQuantities(
    Token : String,
    docEntry : int,
    oprId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

docEntry

Type: int

oprId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetResourceGroupOverload Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetResourceGroupOverload( _
   ByVal Token As String, _
   ByVal StartDate As Date, _
   ByVal EndDate As Date, _
   ByVal RscGroup As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetResourceGroupOverload(
   string Token,
   DateTime StartDate,
   DateTime EndDate,
   string RscGroup
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetResourceGroupOverload(
   String^ Token,
   DateTime StartDate,
   DateTime EndDate,
   String^ RscGroup
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetResourceGroupOverload(
    Token : String,
    StartDate : DateTime,
    EndDate : DateTime,
    RscGroup : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

StartDate

Type: DateTime

EndDate

Type: DateTime

RscGroup

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetResourceOverload Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetResourceOverload( _
   ByVal Token As String, _
   ByVal StartDate As Date, _
   ByVal EndDate As Date, _
   ByVal RscCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetResourceOverload(
   string Token,
   DateTime StartDate,
   DateTime EndDate,
   string RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetResourceOverload(
   String^ Token,
   DateTime StartDate,
   DateTime EndDate,
   String^ RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetResourceOverload(
    Token : String,
    StartDate : DateTime,
    EndDate : DateTime,
    RscCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

StartDate

Type: DateTime

EndDate

Type: DateTime

RscCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetResourcesForSchedulingBackground Method

Retun List of Schedulele Resources for Gant

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetResourcesForSchedulingBackground( _
   ByVal Token As String, _
   ByVal DocEntrys As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetResourcesForSchedulingBackground(
   string Token,
   IEnumerable<int> DocEntrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetResourcesForSchedulingBackground(
   String^ Token,
   IEnumerable<int>^ DocEntrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntrys

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetSalesOrderReferences Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSalesOrderReferences( _
   ByVal Token As String, _
   ByVal docentry As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSalesOrderReferences(
   string Token,
   IEnumerable<int> docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSalesOrderReferences(
   String^ Token,
   IEnumerable<int>^ docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

docentry

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetStdHolidayCode Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetStdHolidayCode( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetStdHolidayCode(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetStdHolidayCode(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetStdHolidayCode(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetSumOfAllExtendedMorRelationsQuantitiesChild Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSumOfAllExtendedMorRelationsQuantitiesChild( _
   ByVal token As String, _
   ByVal docEntry As Integer, _
   ByVal type As String, _
   ByVal lineNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSumOfAllExtendedMorRelationsQuantitiesChild(
   string token,
   int docEntry,
   string type,
   int lineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSumOfAllExtendedMorRelationsQuantitiesChild(
   String^ token,
   int docEntry,
   String^ type,
   int lineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSumOfAllExtendedMorRelationsQuantitiesChild(
    token : String,
    docEntry : int,
    type : String,
    lineNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntry

Type: int

type

Type: string

lineNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetSumOfAllExtendedMorRelationsQuantitiesChildExcept Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSumOfAllExtendedMorRelationsQuantitiesChildExcept( _
   ByVal token As String, _
   ByVal docEntry As Integer, _
   ByVal type As String, _
   ByVal lineNum As Integer, _
   ByVal docEntryExcept As Integer, _
   ByVal lineNumExcept As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSumOfAllExtendedMorRelationsQuantitiesChildExcept(
   string token,
   int docEntry,
   string type,
   int lineNum,
   int docEntryExcept,
   int lineNumExcept
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSumOfAllExtendedMorRelationsQuantitiesChildExcept(
   String^ token,
   int docEntry,
   String^ type,
   int lineNum,
   int docEntryExcept,
   int lineNumExcept
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSumOfAllExtendedMorRelationsQuantitiesChildExcept(
    token : String,
    docEntry : int,
    type : String,
    lineNum : int,
    docEntryExcept : int,
    lineNumExcept : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntry

Type: int

type

Type: string

lineNum

Type: int

docEntryExcept

Type: int

lineNumExcept

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetSumOfAllExtendedMorRelationsQuantitiesParent Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSumOfAllExtendedMorRelationsQuantitiesParent( _
   ByVal token As String, _
   ByVal docEntry As Integer, _
   ByVal lineNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSumOfAllExtendedMorRelationsQuantitiesParent(
   string token,
   int docEntry,
   int lineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSumOfAllExtendedMorRelationsQuantitiesParent(
   String^ token,
   int docEntry,
   int lineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSumOfAllExtendedMorRelationsQuantitiesParent(
    token : String,
    docEntry : int,
    lineNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntry

Type: int

lineNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetSumOfAllExtendedMorRelationsQuantitiesParentExcept Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSumOfAllExtendedMorRelationsQuantitiesParentExcept( _
   ByVal token As String, _
   ByVal docEntry As Integer, _
   ByVal lineNum As Integer, _
   ByVal docEntryExcept As Integer, _
   ByVal typeExcept As String, _
   ByVal lineNumExcept As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSumOfAllExtendedMorRelationsQuantitiesParentExcept(
   string token,
   int docEntry,
   int lineNum,
   int docEntryExcept,
   string typeExcept,
   int lineNumExcept
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSumOfAllExtendedMorRelationsQuantitiesParentExcept(
   String^ token,
   int docEntry,
   int lineNum,
   int docEntryExcept,
   String^ typeExcept,
   int lineNumExcept
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSumOfAllExtendedMorRelationsQuantitiesParentExcept(
    token : String,
    docEntry : int,
    lineNum : int,
    docEntryExcept : int,
    typeExcept : String,
    lineNumExcept : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntry

Type: int

lineNum

Type: int

docEntryExcept

Type: int

typeExcept

Type: string

lineNumExcept

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetTaskStatusByMOR Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTaskStatusByMOR( _
   ByVal Token As String, _
   ByVal DocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTaskStatusByMOR(
   string Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTaskStatusByMOR(
   String^ Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetTaskStatusByMOR(
    Token : String,
    DocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetTaskStatusForMors Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTaskStatusForMors( _
   ByVal Token As String, _
   ByVal DocEntry As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTaskStatusForMors(
   string Token,
   IEnumerable<int> DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTaskStatusForMors(
   String^ Token,
   IEnumerable<int>^ DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetValueOfDeliveryTime Method

SchedulingBaseQueries Class See Also

Method is receiving delivery time as in hierarchy. First is going go check in business partner address and if there is no, then is trying to get this information from header of business partner. If there is no value in business partner address, neither in business partner then method is going to receive empty string.

Overload List
Name | Description
GetValueOfDeliveryTime(string, string) | This version of method is going to check requested business partner's default ship to address and then business partner header. Original description: Method is receiving delivery time as in hierarchy. First is going go check in business partner address and if there is no, then is trying to get this information from header of business partner. If there is no value in business partner address, neither in business partner then method is going to receive empty string.
GetValueOfDeliveryTime(string, string, string) | Method is receiving delivery time as in hierarchy. First is going go check in business partner address and if there is no, then is trying to get this information from header of business partner. If there is no value in business partner address, neither in business partner then method is going to receive empty string.
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetValueOfInternalLeadTime Method

SchedulingBaseQueries Class See Also

The method is going to receive value of internal lead time as is mentioned in hierarchy. First is going to check in business partner address, then business partner general. The next tries would be in item details revision and the other one in item master data in case row contains item, not the bom. Then warehouse is going to be check, but only in case if the operation was triggered from line, not the header. Last place which is going to be be check is document settings. If there is no value then empty string is going to be received.

Overload List
Name | Description
GetValueOfInternalLeadTime(string, string, string, string, string, DateTime, bool) | The method is going to receive value of internal lead time as is mentioned in hierarchy. First is going to check in business partner address, then business partner general. The next try would be in item mater data in case row contains item, not the bom. Then warehouse is going to be check, but only in case if the operation was triggered from line, not the header. Last place which is going to be be check is document settings. If there is no value then empty string is going to be received.
GetValueOfInternalLeadTime(string, string, string, string, string, string, DateTime, bool) | The method is going to receive value of internal lead time as is mentioned in hierarchy. First is going to check in business partner address, then business partner general. The next tries would be in item details revision and the other one in item master data in case row contains item, not the bom. Then warehouse is going to be check, but only in case if the operation was triggered from line, not the header. Last place which is going to be be check is document settings. If there is no value then empty string is going to be received.
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetValueOfReceiveLeadTime Method

The method is going to receive value of receive lead time as is mentioned in hierarchy. First is going to check in business partner address, then business partner general. The next try would be in warehouse, but only in case if the operation was triggered from line, not the header. Last place which is going to be be check is document settings. If there is no value then empty string is going to be received.

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetValueOfReceiveLeadTime( _
   ByVal Token As String, _
   ByVal shipToAddressValue As String, _
   ByVal customerCodeValue As String, _
   ByVal warehouseValue As String, _
   ByVal triggeredFromMatrix As Boolean, _
   ByVal dateTime As Date, _
   Optional ByVal trueForFutureFalseForPast As Boolean = true _
) As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan GetValueOfReceiveLeadTime(
   string Token,
   string shipToAddressValue,
   string customerCodeValue,
   string warehouseValue,
   bool triggeredFromMatrix,
   DateTime dateTime,
   bool trueForFutureFalseForPast = true
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeSpan GetValueOfReceiveLeadTime(
   String^ Token,
   String^ shipToAddressValue,
   String^ customerCodeValue,
   String^ warehouseValue,
   bool triggeredFromMatrix,
   DateTime dateTime,
   bool trueForFutureFalseForPast
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetValueOfReceiveLeadTime(
    Token : String,
    shipToAddressValue : String,
    customerCodeValue : String,
    warehouseValue : String,
    triggeredFromMatrix : boolean,
    dateTime : DateTime,
    trueForFutureFalseForPast : boolean
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

Token

Type: string

shipToAddressValue

Type: string

customerCodeValue

Type: string

warehouseValue

Type: string

triggeredFromMatrix

Type: bool

dateTime

Type: DateTime

trueForFutureFalseForPast

Type: bool

Return Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.MORRelationsAssignChild Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function MORRelationsAssignChild( _
   ByVal Token As String, _
   ByVal itemCodes As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset MORRelationsAssignChild(
   string Token,
   List<string> itemCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ MORRelationsAssignChild(
   String^ Token,
   List<String^>^ itemCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemCodes

Type: List<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.MORRelationsAssignParent Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function MORRelationsAssignParent( _
   ByVal Token As String, _
   ByVal itemCodes As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset MORRelationsAssignParent(
   string Token,
   List<string> itemCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ MORRelationsAssignParent(
   String^ Token,
   List<String^>^ itemCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemCodes

Type: List<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.MORRelationsCreateChild Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function MORRelationsCreateChild( _
   ByVal Token As String, _
   ByVal itemCodes As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset MORRelationsCreateChild(
   string Token,
   List<string> itemCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ MORRelationsCreateChild(
   String^ Token,
   List<String^>^ itemCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemCodes

Type: List<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.MORRelationsCreateParent Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function MORRelationsCreateParent( _
   ByVal Token As String, _
   ByVal itemCodes As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset MORRelationsCreateParent(
   string Token,
   List<string> itemCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ MORRelationsCreateParent(
   String^ Token,
   List<String^>^ itemCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemCodes

Type: List<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.ValidateCloseTaskFieldForCLoseSteToNo Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function ValidateCloseTaskFieldForCLoseSteToNo( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal baseLine As Integer, _
   ByVal PDCCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset ValidateCloseTaskFieldForCLoseSteToNo(
   string Token,
   int DocEntry,
   int baseLine,
   string PDCCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ ValidateCloseTaskFieldForCLoseSteToNo(
   String^ Token,
   int DocEntry,
   int baseLine,
   String^ PDCCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ValidateCloseTaskFieldForCLoseSteToNo(
    Token : String,
    DocEntry : int,
    baseLine : int,
    PDCCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

baseLine

Type: int

PDCCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.ValidateCloseTaskFieldForCLoseSteToYes Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function ValidateCloseTaskFieldForCLoseSteToYes( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal baseLine As Integer, _
   ByVal PDCCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset ValidateCloseTaskFieldForCLoseSteToYes(
   string Token,
   int DocEntry,
   int baseLine,
   string PDCCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ ValidateCloseTaskFieldForCLoseSteToYes(
   String^ Token,
   int DocEntry,
   int baseLine,
   String^ PDCCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ValidateCloseTaskFieldForCLoseSteToYes(
    Token : String,
    DocEntry : int,
    baseLine : int,
    PDCCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

baseLine

Type: int

PDCCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SQLSchedulingQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SQLSchedulingQueries
    Inherits SchedulingBaseQueries
    Implements ISchedulingQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SQLSchedulingQueries : SchedulingBaseQueries,
   ISchedulingQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SQLSchedulingQueries : public SchedulingBaseQueries^,
   public ISchedulingQueries^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SQLSchedulingQueries
   extends SchedulingBaseQueries
   implements ISchedulingQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.Scheduling.SchedulingBaseQueries
CompuTec.ProcessForce.API.Queries.Scheduling.SQLSchedulingQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SQLSchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SQLSchedulingQueries Members

SQLSchedulingQueries Class Methods See Also

The following tables list the members exposed by the SQLSchedulingQueries type.

Methods
 | Name | Description
Public method | CheckStatusOfTask | (inherited from SchedulingBaseQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GEtAllWorkResources | (inherited from SchedulingBaseQueries).
Public method | GEtReceiptedQuantityForMOR | (inherited from SchedulingBaseQueries).
Public method | GEtReceiptedQuantityForMORLine | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativeResources | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativeResourcesDirectAccess | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativeResourcesForCreatedMorsWithoutChangedRoutings | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativesForCreatedMorWithChangedRoutingsAndNotCreatedMors | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativesFromOperations | (inherited from SchedulingBaseQueries).
Public method | GetAllExtendedRelationsBetweenListOfMors | (inherited from SchedulingBaseQueries).
Public method | GetAllExtendedRelationsForSpecificMor | (inherited from SchedulingBaseQueries).
Public method | GetAllLinkedTools | (inherited from SchedulingBaseQueries).
Public method | GetAllRelations | (inherited from SchedulingBaseQueries).
Public method | GetExtendedRelations | (inherited from SchedulingBaseQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetHolidayData | (inherited from SchedulingBaseQueries).
Public method | GetHolidayParam | (inherited from SchedulingBaseQueries).
Public method | GetInactiveItemsSqlQuery | (inherited from SchedulingBaseQueries).
Public method | GetInfiniteFieldOfResources | (inherited from SchedulingBaseQueries).
Public method | GetLastTeamCode | (inherited from SchedulingBaseQueries).
Public method | GetLoadAvalibliForResource | (inherited from SchedulingBaseQueries).
Public method | GetMinAndMaxActualDateTimesForOperationsRelations | (inherited from SchedulingBaseQueries).
Public method | GetPDCTasks | (inherited from SchedulingBaseQueries).
Public method | GetPDCTasksToClose | (inherited from SchedulingBaseQueries).
Public method | GetQuantities | (inherited from SchedulingBaseQueries).
Public method | GetResourceGroupOverload | (inherited from SchedulingBaseQueries).
Public method | GetResourceOverload | (inherited from SchedulingBaseQueries).
Public method | GetResourcesForSchedulingBackground | Retun List of Schedulele Resources for Gant (inherited from SchedulingBaseQueries).
Public method | GetSalesOrderReferences | (inherited from SchedulingBaseQueries).
Public method | GetStdHolidayCode | (inherited from SchedulingBaseQueries).
Public method | GetSumOfAllExtendedMorRelationsQuantitiesChild | (inherited from SchedulingBaseQueries).
Public method | GetSumOfAllExtendedMorRelationsQuantitiesChildExcept | (inherited from SchedulingBaseQueries).
Public method | GetSumOfAllExtendedMorRelationsQuantitiesParent | (inherited from SchedulingBaseQueries).
Public method | GetSumOfAllExtendedMorRelationsQuantitiesParentExcept | (inherited from SchedulingBaseQueries).
Public method | GetTaskStatusByMOR | (inherited from SchedulingBaseQueries).
Public method | GetTaskStatusForMors | (inherited from SchedulingBaseQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetValueOfDeliveryTime | (Overloaded) Method is receiving delivery time as in hierarchy. First is going go check in business partner address and if there is no, then is trying to get this information from header of business partner. If there is no value in business partner address, neither in business partner then method is going to receive empty string. (inherited from SchedulingBaseQueries).
Public method | GetValueOfInternalLeadTime | (Overloaded) The method is going to receive value of internal lead time as is mentioned in hierarchy. First is going to check in business partner address, then business partner general. The next tries would be in item details revision and the other one in item master data in case row contains item, not the bom. Then warehouse is going to be check, but only in case if the operation was triggered from line, not the header. Last place which is going to be be check is document settings. If there is no value then empty string is going to be received. (inherited from SchedulingBaseQueries).
Public method | GetValueOfReceiveLeadTime | The method is going to receive value of receive lead time as is mentioned in hierarchy. First is going to check in business partner address, then business partner general. The next try would be in warehouse, but only in case if the operation was triggered from line, not the header. Last place which is going to be be check is document settings. If there is no value then empty string is going to be received. (inherited from SchedulingBaseQueries).
Public method | MORRelationsAssignChild | (inherited from SchedulingBaseQueries).
Public method | MORRelationsAssignParent | (inherited from SchedulingBaseQueries).
Public method | MORRelationsCreateChild | (inherited from SchedulingBaseQueries).
Public method | MORRelationsCreateParent | (inherited from SchedulingBaseQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | ValidateCloseTaskFieldForCLoseSteToNo | (inherited from SchedulingBaseQueries).
Public method | ValidateCloseTaskFieldForCLoseSteToYes | (inherited from SchedulingBaseQueries).
Top
See Also

Reference

SQLSchedulingQueries Class
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SQLSchedulingQueries Methods

SQLSchedulingQueries Class See Also

The following tables list the members exposed by the SQLSchedulingQueries type.

Methods
 | Name | Description
Public method | CheckStatusOfTask | (inherited from SchedulingBaseQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GEtAllWorkResources | (inherited from SchedulingBaseQueries).
Public method | GEtReceiptedQuantityForMOR | (inherited from SchedulingBaseQueries).
Public method | GEtReceiptedQuantityForMORLine | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativeResources | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativeResourcesDirectAccess | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativeResourcesForCreatedMorsWithoutChangedRoutings | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativesForCreatedMorWithChangedRoutingsAndNotCreatedMors | (inherited from SchedulingBaseQueries).
Public method | GetAllAlternativesFromOperations | (inherited from SchedulingBaseQueries).
Public method | GetAllExtendedRelationsBetweenListOfMors | (inherited from SchedulingBaseQueries).
Public method | GetAllExtendedRelationsForSpecificMor | (inherited from SchedulingBaseQueries).
Public method | GetAllLinkedTools | (inherited from SchedulingBaseQueries).
Public method | GetAllRelations | (inherited from SchedulingBaseQueries).
Public method | GetExtendedRelations | (inherited from SchedulingBaseQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetHolidayData | (inherited from SchedulingBaseQueries).
Public method | GetHolidayParam | (inherited from SchedulingBaseQueries).
Public method | GetInactiveItemsSqlQuery | (inherited from SchedulingBaseQueries).
Public method | GetInfiniteFieldOfResources | (inherited from SchedulingBaseQueries).
Public method | GetLastTeamCode | (inherited from SchedulingBaseQueries).
Public method | GetLoadAvalibliForResource | (inherited from SchedulingBaseQueries).
Public method | GetMinAndMaxActualDateTimesForOperationsRelations | (inherited from SchedulingBaseQueries).
Public method | GetPDCTasks | (inherited from SchedulingBaseQueries).
Public method | GetPDCTasksToClose | (inherited from SchedulingBaseQueries).
Public method | GetQuantities | (inherited from SchedulingBaseQueries).
Public method | GetResourceGroupOverload | (inherited from SchedulingBaseQueries).
Public method | GetResourceOverload | (inherited from SchedulingBaseQueries).
Public method | GetResourcesForSchedulingBackground | Retun List of Schedulele Resources for Gant (inherited from SchedulingBaseQueries).
Public method | GetSalesOrderReferences | (inherited from SchedulingBaseQueries).
Public method | GetStdHolidayCode | (inherited from SchedulingBaseQueries).
Public method | GetSumOfAllExtendedMorRelationsQuantitiesChild | (inherited from SchedulingBaseQueries).
Public method | GetSumOfAllExtendedMorRelationsQuantitiesChildExcept | (inherited from SchedulingBaseQueries).
Public method | GetSumOfAllExtendedMorRelationsQuantitiesParent | (inherited from SchedulingBaseQueries).
Public method | GetSumOfAllExtendedMorRelationsQuantitiesParentExcept | (inherited from SchedulingBaseQueries).
Public method | GetTaskStatusByMOR | (inherited from SchedulingBaseQueries).
Public method | GetTaskStatusForMors | (inherited from SchedulingBaseQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetValueOfDeliveryTime | (Overloaded) Method is receiving delivery time as in hierarchy. First is going go check in business partner address and if there is no, then is trying to get this information from header of business partner. If there is no value in business partner address, neither in business partner then method is going to receive empty string. (inherited from SchedulingBaseQueries).
Public method | GetValueOfInternalLeadTime | (Overloaded) The method is going to receive value of internal lead time as is mentioned in hierarchy. First is going to check in business partner address, then business partner general. The next tries would be in item details revision and the other one in item master data in case row contains item, not the bom. Then warehouse is going to be check, but only in case if the operation was triggered from line, not the header. Last place which is going to be be check is document settings. If there is no value then empty string is going to be received. (inherited from SchedulingBaseQueries).
Public method | GetValueOfReceiveLeadTime | The method is going to receive value of receive lead time as is mentioned in hierarchy. First is going to check in business partner address, then business partner general. The next try would be in warehouse, but only in case if the operation was triggered from line, not the header. Last place which is going to be be check is document settings. If there is no value then empty string is going to be received. (inherited from SchedulingBaseQueries).
Public method | MORRelationsAssignChild | (inherited from SchedulingBaseQueries).
Public method | MORRelationsAssignParent | (inherited from SchedulingBaseQueries).
Public method | MORRelationsCreateChild | (inherited from SchedulingBaseQueries).
Public method | MORRelationsCreateParent | (inherited from SchedulingBaseQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | ValidateCloseTaskFieldForCLoseSteToNo | (inherited from SchedulingBaseQueries).
Public method | ValidateCloseTaskFieldForCLoseSteToYes | (inherited from SchedulingBaseQueries).
Top
See Also

Reference

SQLSchedulingQueries Class
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SchedulingBaseQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SchedulingBaseQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SchedulingBaseQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SchedulingBaseQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.Scheduling.SchedulingBaseQueries
CompuTec.ProcessForce.API.Queries.Scheduling.HANASchedulingQueries
CompuTec.ProcessForce.API.Queries.Scheduling.SQLSchedulingQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries Members

SchedulingBaseQueries Class Methods See Also

The following tables list the members exposed by the SchedulingBaseQueries type.

Methods
 | Name | Description
Public method | CheckStatusOfTask |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GEtAllWorkResources |
Public method | GEtReceiptedQuantityForMOR |
Public method | GEtReceiptedQuantityForMORLine |
Public method | GetAllAlternativeResources |
Public method | GetAllAlternativeResourcesDirectAccess |
Public method | GetAllAlternativeResourcesForCreatedMorsWithoutChangedRoutings |
Public method | GetAllAlternativesForCreatedMorWithChangedRoutingsAndNotCreatedMors |
Public method | GetAllAlternativesFromOperations |
Public method | GetAllExtendedRelationsBetweenListOfMors |
Public method | GetAllExtendedRelationsForSpecificMor |
Public method | GetAllLinkedTools |
Public method | GetAllRelations |
Public method | GetExtendedRelations |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetHolidayData |
Public method | GetHolidayParam |
Public method | GetInactiveItemsSqlQuery |
Public method | GetInfiniteFieldOfResources |
Public method | GetLastTeamCode |
Public method | GetLoadAvalibliForResource |
Public method | GetMinAndMaxActualDateTimesForOperationsRelations |
Public method | GetPDCTasks |
Public method | GetPDCTasksToClose |
Public method | GetQuantities |
Public method | GetResourceGroupOverload |
Public method | GetResourceOverload |
Public method | GetResourcesForSchedulingBackground | Retun List of Schedulele Resources for Gant
Public method | GetSalesOrderReferences |
Public method | GetStdHolidayCode |
Public method | GetSumOfAllExtendedMorRelationsQuantitiesChild |
Public method | GetSumOfAllExtendedMorRelationsQuantitiesChildExcept |
Public method | GetSumOfAllExtendedMorRelationsQuantitiesParent |
Public method | GetSumOfAllExtendedMorRelationsQuantitiesParentExcept |
Public method | GetTaskStatusByMOR |
Public method | GetTaskStatusForMors |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetValueOfDeliveryTime | (Overloaded) Method is receiving delivery time as in hierarchy. First is going go check in business partner address and if there is no, then is trying to get this information from header of business partner. If there is no value in business partner address, neither in business partner then method is going to receive empty string.
Public method | GetValueOfInternalLeadTime | (Overloaded) The method is going to receive value of internal lead time as is mentioned in hierarchy. First is going to check in business partner address, then business partner general. The next tries would be in item details revision and the other one in item master data in case row contains item, not the bom. Then warehouse is going to be check, but only in case if the operation was triggered from line, not the header. Last place which is going to be be check is document settings. If there is no value then empty string is going to be received.
Public method | GetValueOfReceiveLeadTime | The method is going to receive value of receive lead time as is mentioned in hierarchy. First is going to check in business partner address, then business partner general. The next try would be in warehouse, but only in case if the operation was triggered from line, not the header. Last place which is going to be be check is document settings. If there is no value then empty string is going to be received.
Public method | MORRelationsAssignChild |
Public method | MORRelationsAssignParent |
Public method | MORRelationsCreateChild |
Public method | MORRelationsCreateParent |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | ValidateCloseTaskFieldForCLoseSteToNo |
Public method | ValidateCloseTaskFieldForCLoseSteToYes |
Top
See Also

Reference

SchedulingBaseQueries Class
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries Methods

SchedulingBaseQueries Class See Also

The following tables list the members exposed by the SchedulingBaseQueries type.

Methods
 | Name | Description
Public method | CheckStatusOfTask |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GEtAllWorkResources |
Public method | GEtReceiptedQuantityForMOR |
Public method | GEtReceiptedQuantityForMORLine |
Public method | GetAllAlternativeResources |
Public method | GetAllAlternativeResourcesDirectAccess |
Public method | GetAllAlternativeResourcesForCreatedMorsWithoutChangedRoutings |
Public method | GetAllAlternativesForCreatedMorWithChangedRoutingsAndNotCreatedMors |
Public method | GetAllAlternativesFromOperations |
Public method | GetAllExtendedRelationsBetweenListOfMors |
Public method | GetAllExtendedRelationsForSpecificMor |
Public method | GetAllLinkedTools |
Public method | GetAllRelations |
Public method | GetExtendedRelations |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetHolidayData |
Public method | GetHolidayParam |
Public method | GetInactiveItemsSqlQuery |
Public method | GetInfiniteFieldOfResources |
Public method | GetLastTeamCode |
Public method | GetLoadAvalibliForResource |
Public method | GetMinAndMaxActualDateTimesForOperationsRelations |
Public method | GetPDCTasks |
Public method | GetPDCTasksToClose |
Public method | GetQuantities |
Public method | GetResourceGroupOverload |
Public method | GetResourceOverload |
Public method | GetResourcesForSchedulingBackground | Retun List of Schedulele Resources for Gant
Public method | GetSalesOrderReferences |
Public method | GetStdHolidayCode |
Public method | GetSumOfAllExtendedMorRelationsQuantitiesChild |
Public method | GetSumOfAllExtendedMorRelationsQuantitiesChildExcept |
Public method | GetSumOfAllExtendedMorRelationsQuantitiesParent |
Public method | GetSumOfAllExtendedMorRelationsQuantitiesParentExcept |
Public method | GetTaskStatusByMOR |
Public method | GetTaskStatusForMors |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetValueOfDeliveryTime | (Overloaded) Method is receiving delivery time as in hierarchy. First is going go check in business partner address and if there is no, then is trying to get this information from header of business partner. If there is no value in business partner address, neither in business partner then method is going to receive empty string.
Public method | GetValueOfInternalLeadTime | (Overloaded) The method is going to receive value of internal lead time as is mentioned in hierarchy. First is going to check in business partner address, then business partner general. The next tries would be in item details revision and the other one in item master data in case row contains item, not the bom. Then warehouse is going to be check, but only in case if the operation was triggered from line, not the header. Last place which is going to be be check is document settings. If there is no value then empty string is going to be received.
Public method | GetValueOfReceiveLeadTime | The method is going to receive value of receive lead time as is mentioned in hierarchy. First is going to check in business partner address, then business partner general. The next try would be in warehouse, but only in case if the operation was triggered from line, not the header. Last place which is going to be be check is document settings. If there is no value then empty string is going to be received.
Public method | MORRelationsAssignChild |
Public method | MORRelationsAssignParent |
Public method | MORRelationsCreateChild |
Public method | MORRelationsCreateParent |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | ValidateCloseTaskFieldForCLoseSteToNo |
Public method | ValidateCloseTaskFieldForCLoseSteToYes |
Top
See Also

Reference

SchedulingBaseQueries Class
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ISchedulingQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ISchedulingQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ISchedulingQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ISchedulingQueries
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries Members

ISchedulingQueries Interface Methods See Also

The following tables list the members exposed by the ISchedulingQueries type.

Methods
 | Name | Description
Public method | CheckStatusOfTask |
Public method | GEtAllWorkResources |
Public method | GEtReceiptedQuantityForMOR | U_BaseLineNum,isnull(U_ReceiptedQty,0) [Qty]
Public method | GEtReceiptedQuantityForMORLine |
Public method | GetAllAlternativeResources |
Public method | GetAllAlternativeResourcesDirectAccess |
Public method | GetAllAlternativeResourcesForCreatedMorsWithoutChangedRoutings |
Public method | GetAllAlternativesForCreatedMorWithChangedRoutingsAndNotCreatedMors |
Public method | GetAllAlternativesFromOperations |
Public method | GetAllExtendedRelationsBetweenListOfMors |
Public method | GetAllExtendedRelationsForSpecificMor |
Public method | GetAllLinkedTools |
Public method | GetAllRelations |
Public method | GetExtendedRelations |
Public method | GetHolidayData |
Public method | GetHolidayParam |
Public method | GetInfiniteFieldOfResources |
Public method | GetLoadAvalibliForResource |
Public method | GetMinAndMaxActualDateTimesForOperationsRelations |
Public method | GetPDCTasks |
Public method | GetPDCTasksToClose |
Public method | GetQuantities |
Public method | GetResourceGroupOverload |
Public method | GetResourceOverload |
Public method | GetResourcesForSchedulingBackground |
Public method | GetSalesOrderReferences |
Public method | GetStdHolidayCode |
Public method | GetSumOfAllExtendedMorRelationsQuantitiesChild |
Public method | GetSumOfAllExtendedMorRelationsQuantitiesChildExcept |
Public method | GetSumOfAllExtendedMorRelationsQuantitiesParent |
Public method | GetSumOfAllExtendedMorRelationsQuantitiesParentExcept |
Public method | GetTaskStatusByMOR |
Public method | GetTaskStatusForMors |
Public method | GetValueOfDeliveryTime | (Overloaded)
Public method | GetValueOfInternalLeadTime | (Overloaded)
Public method | GetValueOfReceiveLeadTime |
Public method | MORRelationsAssignChild |
Public method | MORRelationsAssignParent |
Public method | MORRelationsCreateChild |
Public method | MORRelationsCreateParent |
Public method | ValidateCloseTaskFieldForCLoseSteToNo |
Public method | ValidateCloseTaskFieldForCLoseSteToYes |
Top
See Also

Reference

ISchedulingQueries Interface
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries Methods

ISchedulingQueries Interface See Also

The following tables list the members exposed by the ISchedulingQueries type.

Methods
 | Name | Description
Public method | CheckStatusOfTask |
Public method | GEtAllWorkResources |
Public method | GEtReceiptedQuantityForMOR | U_BaseLineNum,isnull(U_ReceiptedQty,0) [Qty]
Public method | GEtReceiptedQuantityForMORLine |
Public method | GetAllAlternativeResources |
Public method | GetAllAlternativeResourcesDirectAccess |
Public method | GetAllAlternativeResourcesForCreatedMorsWithoutChangedRoutings |
Public method | GetAllAlternativesForCreatedMorWithChangedRoutingsAndNotCreatedMors |
Public method | GetAllAlternativesFromOperations |
Public method | GetAllExtendedRelationsBetweenListOfMors |
Public method | GetAllExtendedRelationsForSpecificMor |
Public method | GetAllLinkedTools |
Public method | GetAllRelations |
Public method | GetExtendedRelations |
Public method | GetHolidayData |
Public method | GetHolidayParam |
Public method | GetInfiniteFieldOfResources |
Public method | GetLoadAvalibliForResource |
Public method | GetMinAndMaxActualDateTimesForOperationsRelations |
Public method | GetPDCTasks |
Public method | GetPDCTasksToClose |
Public method | GetQuantities |
Public method | GetResourceGroupOverload |
Public method | GetResourceOverload |
Public method | GetResourcesForSchedulingBackground |
Public method | GetSalesOrderReferences |
Public method | GetStdHolidayCode |
Public method | GetSumOfAllExtendedMorRelationsQuantitiesChild |
Public method | GetSumOfAllExtendedMorRelationsQuantitiesChildExcept |
Public method | GetSumOfAllExtendedMorRelationsQuantitiesParent |
Public method | GetSumOfAllExtendedMorRelationsQuantitiesParentExcept |
Public method | GetTaskStatusByMOR |
Public method | GetTaskStatusForMors |
Public method | GetValueOfDeliveryTime | (Overloaded)
Public method | GetValueOfInternalLeadTime | (Overloaded)
Public method | GetValueOfReceiveLeadTime |
Public method | MORRelationsAssignChild |
Public method | MORRelationsAssignParent |
Public method | MORRelationsCreateChild |
Public method | MORRelationsCreateParent |
Public method | ValidateCloseTaskFieldForCLoseSteToNo |
Public method | ValidateCloseTaskFieldForCLoseSteToYes |
Top
See Also

Reference

ISchedulingQueries Interface
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.CheckStatusOfTask Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CheckStatusOfTask( _
   ByVal Token As String, _
   ByVal DocEntrys As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset CheckStatusOfTask(
   string Token,
   IEnumerable<int> DocEntrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ CheckStatusOfTask(
   String^ Token,
   IEnumerable<int>^ DocEntrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntrys

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GEtAllWorkResources Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GEtAllWorkResources( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GEtAllWorkResources(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GEtAllWorkResources(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GEtAllWorkResources(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GEtReceiptedQuantityForMOR Method

U_BaseLineNum,isnull(U_ReceiptedQty,0) [Qty]

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GEtReceiptedQuantityForMOR( _
   ByVal Token As String, _
   ByVal DocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GEtReceiptedQuantityForMOR(
   string Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GEtReceiptedQuantityForMOR(
   String^ Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GEtReceiptedQuantityForMOR(
    Token : String,
    DocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GEtReceiptedQuantityForMORLine Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GEtReceiptedQuantityForMORLine( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal LineNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GEtReceiptedQuantityForMORLine(
   string Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GEtReceiptedQuantityForMORLine(
   String^ Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GEtReceiptedQuantityForMORLine(
    Token : String,
    DocEntry : int,
    LineNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

LineNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetAllAlternativeResources Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAllAlternativeResources( _
   ByVal token As String, _
   ByVal queryWhere As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetAllAlternativeResources(
   string token,
   string queryWhere
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetAllAlternativeResources(
   String^ token,
   String^ queryWhere
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetAllAlternativeResources(
    token : String,
    queryWhere : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

queryWhere

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetAllAlternativeResourcesDirectAccess Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAllAlternativeResourcesDirectAccess( _
   ByVal Token As String, _
   ByVal connection As DbConnection, _
   ByVal tempTableName As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetAllAlternativeResourcesDirectAccess(
   string Token,
   DbConnection connection,
   string tempTableName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetAllAlternativeResourcesDirectAccess(
   String^ Token,
   DbConnection^ connection,
   String^ tempTableName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetAllAlternativeResourcesDirectAccess(
    Token : String,
    connection : DbConnection,
    tempTableName : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

connection

Type: DbConnection

tempTableName

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetAllAlternativeResourcesForCreatedMorsWithoutChangedRoutings Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAllAlternativeResourcesForCreatedMorsWithoutChangedRoutings( _
   ByVal token As String, _
   ByVal mors As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetAllAlternativeResourcesForCreatedMorsWithoutChangedRoutings(
   string token,
   List<string> mors
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetAllAlternativeResourcesForCreatedMorsWithoutChangedRoutings(
   String^ token,
   List<String^>^ mors
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

mors

Type: List<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetAllAlternativesForCreatedMorWithChangedRoutingsAndNotCreatedMors Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAllAlternativesForCreatedMorWithChangedRoutingsAndNotCreatedMors( _
   ByVal Token As String, _
   ByVal bom As String, _
   ByVal revision As String, _
   ByVal routing As String, _
   ByVal rtgOprCode As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetAllAlternativesForCreatedMorWithChangedRoutingsAndNotCreatedMors(
   string Token,
   string bom,
   string revision,
   string routing,
   int rtgOprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetAllAlternativesForCreatedMorWithChangedRoutingsAndNotCreatedMors(
   String^ Token,
   String^ bom,
   String^ revision,
   String^ routing,
   int rtgOprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetAllAlternativesForCreatedMorWithChangedRoutingsAndNotCreatedMors(
    Token : String,
    bom : String,
    revision : String,
    routing : String,
    rtgOprCode : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

bom

Type: string

revision

Type: string

routing

Type: string

rtgOprCode

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetAllAlternativesFromOperations Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAllAlternativesFromOperations( _
   ByVal Token As String, _
   ByVal oprCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetAllAlternativesFromOperations(
   string Token,
   string oprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetAllAlternativesFromOperations(
   String^ Token,
   String^ oprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetAllAlternativesFromOperations(
    Token : String,
    oprCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

oprCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetAllExtendedRelationsBetweenListOfMors Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAllExtendedRelationsBetweenListOfMors( _
   ByVal token As String, _
   ByVal docEntries As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetAllExtendedRelationsBetweenListOfMors(
   string token,
   List<string> docEntries
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetAllExtendedRelationsBetweenListOfMors(
   String^ token,
   List<String^>^ docEntries
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntries

Type: List<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetAllExtendedRelationsForSpecificMor Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAllExtendedRelationsForSpecificMor( _
   ByVal Token As String, _
   ByVal docEntry As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetAllExtendedRelationsForSpecificMor(
   string Token,
   string docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetAllExtendedRelationsForSpecificMor(
   String^ Token,
   String^ docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetAllExtendedRelationsForSpecificMor(
    Token : String,
    docEntry : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

docEntry

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetAllLinkedTools Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAllLinkedTools( _
   ByVal token As String, _
   ByVal usedResources As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetAllLinkedTools(
   string token,
   List<string> usedResources
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetAllLinkedTools(
   String^ token,
   List<String^>^ usedResources
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

usedResources

Type: List<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetAllRelations Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAllRelations( _
   ByVal token As String, _
   ByVal docEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetAllRelations(
   string token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetAllRelations(
   String^ token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetAllRelations(
    token : String,
    docEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetExtendedRelations Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetExtendedRelations( _
   ByVal token As String, _
   ByVal docEntry As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetExtendedRelations(
   string token,
   string docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetExtendedRelations(
   String^ token,
   String^ docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetExtendedRelations(
    token : String,
    docEntry : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntry

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetHolidayData Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetHolidayData( _
   ByVal Token As String, _
   ByVal hldCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetHolidayData(
   string Token,
   string hldCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetHolidayData(
   String^ Token,
   String^ hldCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetHolidayData(
    Token : String,
    hldCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

hldCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetHolidayParam Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetHolidayParam( _
   ByVal Token As String, _
   ByVal hldCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetHolidayParam(
   string Token,
   string hldCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetHolidayParam(
   String^ Token,
   String^ hldCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetHolidayParam(
    Token : String,
    hldCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

hldCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetInfiniteFieldOfResources Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetInfiniteFieldOfResources( _
   ByVal Token As String, _
   ByVal resources As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetInfiniteFieldOfResources(
   string Token,
   List<string> resources
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetInfiniteFieldOfResources(
   String^ Token,
   List<String^>^ resources
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

resources

Type: List<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetLoadAvalibliForResource Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetLoadAvalibliForResource( _
   ByVal Token As String, _
   ByVal Resource As String, _
   ByVal FromDate As Date, _
   ByVal ExludedDocEntrys As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetLoadAvalibliForResource(
   string Token,
   string Resource,
   DateTime FromDate,
   IEnumerable<int> ExludedDocEntrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetLoadAvalibliForResource(
   String^ Token,
   String^ Resource,
   DateTime FromDate,
   IEnumerable<int>^ ExludedDocEntrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

Resource

Type: string

FromDate

Type: DateTime

ExludedDocEntrys

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetMinAndMaxActualDateTimesForOperationsRelations Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetMinAndMaxActualDateTimesForOperationsRelations( _
   ByVal Token As String, _
   ByVal docEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetMinAndMaxActualDateTimesForOperationsRelations(
   string Token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetMinAndMaxActualDateTimesForOperationsRelations(
   String^ Token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetMinAndMaxActualDateTimesForOperationsRelations(
    Token : String,
    docEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

docEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetPDCTasks Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetPDCTasks( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetPDCTasks(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetPDCTasks(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetPDCTasks(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetPDCTasksToClose Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetPDCTasksToClose( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal baseLine As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetPDCTasksToClose(
   string Token,
   int DocEntry,
   int baseLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetPDCTasksToClose(
   String^ Token,
   int DocEntry,
   int baseLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetPDCTasksToClose(
    Token : String,
    DocEntry : int,
    baseLine : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

baseLine

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetQuantities Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetQuantities( _
   ByVal Token As String, _
   ByVal docEntry As Integer, _
   ByVal oprId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetQuantities(
   string Token,
   int docEntry,
   int oprId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetQuantities(
   String^ Token,
   int docEntry,
   int oprId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetQuantities(
    Token : String,
    docEntry : int,
    oprId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

docEntry

Type: int

oprId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetResourceGroupOverload Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetResourceGroupOverload( _
   ByVal Token As String, _
   ByVal StartDate As Date, _
   ByVal EndDate As Date, _
   ByVal RscGroup As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetResourceGroupOverload(
   string Token,
   DateTime StartDate,
   DateTime EndDate,
   string RscGroup
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetResourceGroupOverload(
   String^ Token,
   DateTime StartDate,
   DateTime EndDate,
   String^ RscGroup
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetResourceGroupOverload(
    Token : String,
    StartDate : DateTime,
    EndDate : DateTime,
    RscGroup : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

StartDate

Type: DateTime

EndDate

Type: DateTime

RscGroup

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetResourceOverload Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetResourceOverload( _
   ByVal Token As String, _
   ByVal StartDate As Date, _
   ByVal EndDate As Date, _
   ByVal RscCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetResourceOverload(
   string Token,
   DateTime StartDate,
   DateTime EndDate,
   string RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetResourceOverload(
   String^ Token,
   DateTime StartDate,
   DateTime EndDate,
   String^ RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetResourceOverload(
    Token : String,
    StartDate : DateTime,
    EndDate : DateTime,
    RscCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

StartDate

Type: DateTime

EndDate

Type: DateTime

RscCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetResourcesForSchedulingBackground Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetResourcesForSchedulingBackground( _
   ByVal Token As String, _
   ByVal DocEntrys As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetResourcesForSchedulingBackground(
   string Token,
   IEnumerable<int> DocEntrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetResourcesForSchedulingBackground(
   String^ Token,
   IEnumerable<int>^ DocEntrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntrys

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetSalesOrderReferences Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetSalesOrderReferences( _
   ByVal Token As String, _
   ByVal docentry As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetSalesOrderReferences(
   string Token,
   IEnumerable<int> docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetSalesOrderReferences(
   String^ Token,
   IEnumerable<int>^ docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

docentry

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetStdHolidayCode Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetStdHolidayCode( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetStdHolidayCode(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetStdHolidayCode(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetStdHolidayCode(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetSumOfAllExtendedMorRelationsQuantitiesChild Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetSumOfAllExtendedMorRelationsQuantitiesChild( _
   ByVal token As String, _
   ByVal docEntry As Integer, _
   ByVal type As String, _
   ByVal lineNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetSumOfAllExtendedMorRelationsQuantitiesChild(
   string token,
   int docEntry,
   string type,
   int lineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetSumOfAllExtendedMorRelationsQuantitiesChild(
   String^ token,
   int docEntry,
   String^ type,
   int lineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetSumOfAllExtendedMorRelationsQuantitiesChild(
    token : String,
    docEntry : int,
    type : String,
    lineNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntry

Type: int

type

Type: string

lineNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetSumOfAllExtendedMorRelationsQuantitiesChildExcept Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetSumOfAllExtendedMorRelationsQuantitiesChildExcept( _
   ByVal token As String, _
   ByVal docEntry As Integer, _
   ByVal type As String, _
   ByVal lineNum As Integer, _
   ByVal docEntryExcept As Integer, _
   ByVal lineNumExcept As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetSumOfAllExtendedMorRelationsQuantitiesChildExcept(
   string token,
   int docEntry,
   string type,
   int lineNum,
   int docEntryExcept,
   int lineNumExcept
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetSumOfAllExtendedMorRelationsQuantitiesChildExcept(
   String^ token,
   int docEntry,
   String^ type,
   int lineNum,
   int docEntryExcept,
   int lineNumExcept
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetSumOfAllExtendedMorRelationsQuantitiesChildExcept(
    token : String,
    docEntry : int,
    type : String,
    lineNum : int,
    docEntryExcept : int,
    lineNumExcept : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntry

Type: int

type

Type: string

lineNum

Type: int

docEntryExcept

Type: int

lineNumExcept

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetSumOfAllExtendedMorRelationsQuantitiesParent Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetSumOfAllExtendedMorRelationsQuantitiesParent( _
   ByVal token As String, _
   ByVal docEntry As Integer, _
   ByVal lineNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetSumOfAllExtendedMorRelationsQuantitiesParent(
   string token,
   int docEntry,
   int lineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetSumOfAllExtendedMorRelationsQuantitiesParent(
   String^ token,
   int docEntry,
   int lineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetSumOfAllExtendedMorRelationsQuantitiesParent(
    token : String,
    docEntry : int,
    lineNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntry

Type: int

lineNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetSumOfAllExtendedMorRelationsQuantitiesParentExcept Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetSumOfAllExtendedMorRelationsQuantitiesParentExcept( _
   ByVal token As String, _
   ByVal docEntry As Integer, _
   ByVal lineNum As Integer, _
   ByVal docEntryExcept As Integer, _
   ByVal typeExcept As String, _
   ByVal lineNumExcept As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetSumOfAllExtendedMorRelationsQuantitiesParentExcept(
   string token,
   int docEntry,
   int lineNum,
   int docEntryExcept,
   string typeExcept,
   int lineNumExcept
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetSumOfAllExtendedMorRelationsQuantitiesParentExcept(
   String^ token,
   int docEntry,
   int lineNum,
   int docEntryExcept,
   String^ typeExcept,
   int lineNumExcept
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetSumOfAllExtendedMorRelationsQuantitiesParentExcept(
    token : String,
    docEntry : int,
    lineNum : int,
    docEntryExcept : int,
    typeExcept : String,
    lineNumExcept : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntry

Type: int

lineNum

Type: int

docEntryExcept

Type: int

typeExcept

Type: string

lineNumExcept

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetTaskStatusByMOR Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetTaskStatusByMOR( _
   ByVal Token As String, _
   ByVal DocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetTaskStatusByMOR(
   string Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetTaskStatusByMOR(
   String^ Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetTaskStatusByMOR(
    Token : String,
    DocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetTaskStatusForMors Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetTaskStatusForMors( _
   ByVal Token As String, _
   ByVal DocEntry As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetTaskStatusForMors(
   string Token,
   IEnumerable<int> DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetTaskStatusForMors(
   String^ Token,
   IEnumerable<int>^ DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetValueOfDeliveryTime Method

ISchedulingQueries Interface See Also

Overload List
Name | Description
GetValueOfDeliveryTime(string, string) |
GetValueOfDeliveryTime(string, string, string) |
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetValueOfInternalLeadTime Method

ISchedulingQueries Interface See Also

Overload List
Name | Description
GetValueOfInternalLeadTime(string, string, string, string, string, DateTime, bool) |
GetValueOfInternalLeadTime(string, string, string, string, string, string, DateTime, bool) |
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetValueOfReceiveLeadTime Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetValueOfReceiveLeadTime( _
   ByVal Token As String, _
   ByVal shipToAddressValue As String, _
   ByVal customerCodeValue As String, _
   ByVal warehouseValue As String, _
   ByVal triggeredFromMatrix As Boolean, _
   ByVal dateTime As Date, _
   Optional ByVal trueForFutureFalseForPast As Boolean = true _
) As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan GetValueOfReceiveLeadTime(
   string Token,
   string shipToAddressValue,
   string customerCodeValue,
   string warehouseValue,
   bool triggeredFromMatrix,
   DateTime dateTime,
   bool trueForFutureFalseForPast = true
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

TimeSpan GetValueOfReceiveLeadTime(
   String^ Token,
   String^ shipToAddressValue,
   String^ customerCodeValue,
   String^ warehouseValue,
   bool triggeredFromMatrix,
   DateTime dateTime,
   bool trueForFutureFalseForPast
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetValueOfReceiveLeadTime(
    Token : String,
    shipToAddressValue : String,
    customerCodeValue : String,
    warehouseValue : String,
    triggeredFromMatrix : boolean,
    dateTime : DateTime,
    trueForFutureFalseForPast : boolean
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

Token

Type: string

shipToAddressValue

Type: string

customerCodeValue

Type: string

warehouseValue

Type: string

triggeredFromMatrix

Type: bool

dateTime

Type: DateTime

trueForFutureFalseForPast

Type: bool

Return Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.MORRelationsAssignChild Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function MORRelationsAssignChild( _
   ByVal token As String, _
   ByVal docEntries As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset MORRelationsAssignChild(
   string token,
   List<string> docEntries
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ MORRelationsAssignChild(
   String^ token,
   List<String^>^ docEntries
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntries

Type: List<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.MORRelationsAssignParent Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function MORRelationsAssignParent( _
   ByVal token As String, _
   ByVal docEntries As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset MORRelationsAssignParent(
   string token,
   List<string> docEntries
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ MORRelationsAssignParent(
   String^ token,
   List<String^>^ docEntries
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntries

Type: List<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.MORRelationsCreateChild Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function MORRelationsCreateChild( _
   ByVal token As String, _
   ByVal docEntries As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset MORRelationsCreateChild(
   string token,
   List<string> docEntries
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ MORRelationsCreateChild(
   String^ token,
   List<String^>^ docEntries
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntries

Type: List<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.MORRelationsCreateParent Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function MORRelationsCreateParent( _
   ByVal token As String, _
   ByVal docEntries As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset MORRelationsCreateParent(
   string token,
   List<string> docEntries
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ MORRelationsCreateParent(
   String^ token,
   List<String^>^ docEntries
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntries

Type: List<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.ValidateCloseTaskFieldForCLoseSteToNo Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function ValidateCloseTaskFieldForCLoseSteToNo( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal baseLine As Integer, _
   ByVal PDCCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset ValidateCloseTaskFieldForCLoseSteToNo(
   string Token,
   int DocEntry,
   int baseLine,
   string PDCCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ ValidateCloseTaskFieldForCLoseSteToNo(
   String^ Token,
   int DocEntry,
   int baseLine,
   String^ PDCCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function ValidateCloseTaskFieldForCLoseSteToNo(
    Token : String,
    DocEntry : int,
    baseLine : int,
    PDCCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

baseLine

Type: int

PDCCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.ValidateCloseTaskFieldForCLoseSteToYes Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function ValidateCloseTaskFieldForCLoseSteToYes( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal baseLine As Integer, _
   ByVal PDCCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset ValidateCloseTaskFieldForCLoseSteToYes(
   string Token,
   int DocEntry,
   int baseLine,
   string PDCCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ ValidateCloseTaskFieldForCLoseSteToYes(
   String^ Token,
   int DocEntry,
   int baseLine,
   String^ PDCCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function ValidateCloseTaskFieldForCLoseSteToYes(
    Token : String,
    DocEntry : int,
    baseLine : int,
    PDCCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

baseLine

Type: int

PDCCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


CompuTec.ProcessForce.API.Queries.SupplierScoreCard Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | SupplierScoreCardQueries |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


SupplierScoreCardQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SupplierScoreCardQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SupplierScoreCardQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SupplierScoreCardQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SupplierScoreCardQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.SupplierScoreCard.SupplierScoreCardQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplierScoreCardQueries Members
CompuTec.ProcessForce.API.Queries.SupplierScoreCard Namespace


SupplierScoreCardQueries Members

SupplierScoreCardQueries Class Methods See Also

The following tables list the members exposed by the SupplierScoreCardQueries type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetSSCDetailsQueryString |
Public method | GetSSCSummaryQueryString |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SupplierScoreCardQueries Class
CompuTec.ProcessForce.API.Queries.SupplierScoreCard Namespace


SupplierScoreCardQueries Methods

SupplierScoreCardQueries Class See Also

The following tables list the members exposed by the SupplierScoreCardQueries type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetSSCDetailsQueryString |
Public method | GetSSCSummaryQueryString |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SupplierScoreCardQueries Class
CompuTec.ProcessForce.API.Queries.SupplierScoreCard Namespace


SupplierScoreCardQueries.GetSSCDetailsQueryString Method

Namespace: CompuTec.ProcessForce.API.Queries.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSSCDetailsQueryString( _
   ByVal cardCode As String, _
   ByVal noOfCmpl As Double, _
   ByVal noOfFailedQCT As Double, _
   ByVal noOfRet As Double, _
   ByVal noOnTime As Double, _
   ByVal noEarly As Double, _
   ByVal noLate As Double, _
   ByVal noEqualQt As Double, _
   ByVal noUnderQt As Double, _
   ByVal noOverQt As Double, _
   ByVal daysEarly As Integer, _
   ByVal daysLate As Integer, _
   ByVal quantityUnder As Double, _
   ByVal quantityOver As Double _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GetSSCDetailsQueryString(
   string cardCode,
   double noOfCmpl,
   double noOfFailedQCT,
   double noOfRet,
   double noOnTime,
   double noEarly,
   double noLate,
   double noEqualQt,
   double noUnderQt,
   double noOverQt,
   int daysEarly,
   int daysLate,
   double quantityUnder,
   double quantityOver
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ GetSSCDetailsQueryString(
   String^ cardCode,
   double noOfCmpl,
   double noOfFailedQCT,
   double noOfRet,
   double noOnTime,
   double noEarly,
   double noLate,
   double noEqualQt,
   double noUnderQt,
   double noOverQt,
   int daysEarly,
   int daysLate,
   double quantityUnder,
   double quantityOver
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSSCDetailsQueryString(
    cardCode : String,
    noOfCmpl : double,
    noOfFailedQCT : double,
    noOfRet : double,
    noOnTime : double,
    noEarly : double,
    noLate : double,
    noEqualQt : double,
    noUnderQt : double,
    noOverQt : double,
    daysEarly : int,
    daysLate : int,
    quantityUnder : double,
    quantityOver : double
) : String;
This language is not supported or no code example is available.

Parameters

cardCode

Type: string

noOfCmpl

Type: double

noOfFailedQCT

Type: double

noOfRet

Type: double

noOnTime

Type: double

noEarly

Type: double

noLate

Type: double

noEqualQt

Type: double

noUnderQt

Type: double

noOverQt

Type: double

daysEarly

Type: int

daysLate

Type: int

quantityUnder

Type: double

quantityOver

Type: double

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplierScoreCardQueries Class
SupplierScoreCardQueries Members
CompuTec.ProcessForce.API.Queries.SupplierScoreCard Namespace


SupplierScoreCardQueries.GetSSCSummaryQueryString Method

Namespace: CompuTec.ProcessForce.API.Queries.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSSCSummaryQueryString( _
   ByVal TotalWV As Double, _
   ByVal TotalWVmtd As Double, _
   ByVal TotalWVpm As Double, _
   ByVal TotalWVmytd As Double, _
   ByVal TotalWVpy As Double, _
   ByVal QualityWV As Double, _
   ByVal QualityWVmtd As Double, _
   ByVal QualityWVpm As Double, _
   ByVal QualityWVmytd As Double, _
   ByVal QualityWVpy As Double, _
   ByVal DeliveryWV As Double, _
   ByVal DeliveryWVmtd As Double, _
   ByVal DeliveryWVpm As Double, _
   ByVal DeliveryWVmytd As Double, _
   ByVal DeliveryWVpy As Double, _
   ByVal QuantityWV As Double, _
   ByVal QuantityWVmtd As Double, _
   ByVal QuantityWVpm As Double, _
   ByVal QuantityWVmytd As Double, _
   ByVal QuantityWVpy As Double _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GetSSCSummaryQueryString(
   double TotalWV,
   double TotalWVmtd,
   double TotalWVpm,
   double TotalWVmytd,
   double TotalWVpy,
   double QualityWV,
   double QualityWVmtd,
   double QualityWVpm,
   double QualityWVmytd,
   double QualityWVpy,
   double DeliveryWV,
   double DeliveryWVmtd,
   double DeliveryWVpm,
   double DeliveryWVmytd,
   double DeliveryWVpy,
   double QuantityWV,
   double QuantityWVmtd,
   double QuantityWVpm,
   double QuantityWVmytd,
   double QuantityWVpy
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ GetSSCSummaryQueryString(
   double TotalWV,
   double TotalWVmtd,
   double TotalWVpm,
   double TotalWVmytd,
   double TotalWVpy,
   double QualityWV,
   double QualityWVmtd,
   double QualityWVpm,
   double QualityWVmytd,
   double QualityWVpy,
   double DeliveryWV,
   double DeliveryWVmtd,
   double DeliveryWVpm,
   double DeliveryWVmytd,
   double DeliveryWVpy,
   double QuantityWV,
   double QuantityWVmtd,
   double QuantityWVpm,
   double QuantityWVmytd,
   double QuantityWVpy
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSSCSummaryQueryString(
    TotalWV : double,
    TotalWVmtd : double,
    TotalWVpm : double,
    TotalWVmytd : double,
    TotalWVpy : double,
    QualityWV : double,
    QualityWVmtd : double,
    QualityWVpm : double,
    QualityWVmytd : double,
    QualityWVpy : double,
    DeliveryWV : double,
    DeliveryWVmtd : double,
    DeliveryWVpm : double,
    DeliveryWVmytd : double,
    DeliveryWVpy : double,
    QuantityWV : double,
    QuantityWVmtd : double,
    QuantityWVpm : double,
    QuantityWVmytd : double,
    QuantityWVpy : double
) : String;
This language is not supported or no code example is available.

Parameters

TotalWV

Type: double

TotalWVmtd

Type: double

TotalWVpm

Type: double

TotalWVmytd

Type: double

TotalWVpy

Type: double

QualityWV

Type: double

QualityWVmtd

Type: double

QualityWVpm

Type: double

QualityWVmytd

Type: double

QualityWVpy

Type: double

DeliveryWV

Type: double

DeliveryWVmtd

Type: double

DeliveryWVpm

Type: double

DeliveryWVmytd

Type: double

DeliveryWVpy

Type: double

QuantityWV

Type: double

QuantityWVmtd

Type: double

QuantityWVpm

Type: double

QuantityWVmytd

Type: double

QuantityWVpy

Type: double

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplierScoreCardQueries Class
SupplierScoreCardQueries Members
CompuTec.ProcessForce.API.Queries.SupplierScoreCard Namespace


CompuTec.ProcessForce.API.Queries.SystemQueries Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | BaseSystemQueries |
Public class | HANASystemQueries |
Public class | SQLSystemQueries |
Top
Interfaces
 | Name | Description
Public interface | ISystemQueries |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


BaseSystemQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BaseSystemQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BaseSystemQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BaseSystemQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BaseSystemQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.SystemQueries.BaseSystemQueries
CompuTec.ProcessForce.API.Queries.SystemQueries.HANASystemQueries
CompuTec.ProcessForce.API.Queries.SystemQueries.SQLSystemQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries Members

BaseSystemQueries Class Methods See Also

The following tables list the members exposed by the BaseSystemQueries type.

Methods
 | Name | Description
Public method | EnablePostResourceConfirmation |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | FindBatchTampate |
Public method | FindSerialTemplate |
Public method | GetAdtJeForCompicatedTypes |
Public method | GetAllResourcesFromMOR16ThatAreInactive |
Public method | GetAlreadyDefinedAdditionaBatchDetails |
Public method | GetBaseTypeForbatch |
Public method | GetBatchAllDetails | All Details for Batch generally select * from "OBTN"
Public method | GetBatchQuantity |
Public method | GetBatchSerialDocumentInfo |
Public method | GetBatchTemplateDetails |
Public method | GetBatchesInFEFOOrder |
Public method | GetBatchesInFMFOOrder |
Public method | GetBatchesToCreateAddtitemCodes |
Public method | GetBranchesForBOMS |
Public method | GetBranchesForBOMSBacflush |
Public method | GetColumnConfiguration | Gets the configuration of given columns for a specified parent.
Public method | GetCostCentres |
Public method | GetCostForResourceLine |
Public method | GetCountiresList |
Public method | GetCountryCode |
Public method | GetCountryName |
Public method | GetDataForRestoreAdditionaBatchDetails |
Public method | GetDefaultValueForField |
Public method | GetDefaultValueForFields |
Public method | GetDynamicCostForReceipt |
Public method | GetExpiryDateTemplate |
Public method | GetExpiryDateType |
Public method | GetFifoLayersForCorrection |
Public method | GetFirstBOMToOpen |
Public method | GetFreeBatchItems |
Public method | GetFreeItems |
Public method | GetFreeSerialItems |
Public method | GetGlobalBatchSettings |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemBatchQueue |
Public method | GetItemDetailsExistsForBatch |
Public method | GetItemsProperties |
Public method | GetItemsToRestoreItemDetails |
Public method | GetItemsToRestoreItemDetailsInventory |
Public method | GetMatchingCurrencyCode |
Public method | GetMinClosingDateForMor |
Public method | GetMissingBatchesForProdReceipt |
Public method | GetMorBranch |
Public method | GetMorInfo |
Public method | GetMorLinesToUnlock |
Public method | GetOpenSalesOrderForItems |
Public method | GetOprNamesForCodes |
Public method | GetPeriodIndicator |
Public method | GetProductionAccounts |
Public method | GetProperties |
Public method | GetProposedDocumentSeries |
Public method | GetResourceBookedTime |
Public method | GetResourceBookedTimeByType |
Public method | GetResourceWIPAcct |
Public method | GetRevisionFromGoodsReceiptDoc |
Public method | GetRevisionFromGoodsReceiptPODoc |
Public method | GetSerialNumberQuantity |
Public method | GetSeriesNameForJE |
Public method | GetSubstituteItems |
Public method | GetSubstituteRatio |
Public method | GetSubstituteRevision |
Public method | GetSumFreeBatchItems |
Public method | GetSumFreeItems |
Public method | GetSumFreeSerialItems |
Public method | GetTableColumns |
Public method | GetTestProperties |
Public method | GetTransValueFormOITM |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetTypesOfListOfFields |
Public method | GetUpdatePaymentDocumentAdditionalJournalEntries |
Public method | GetUserDataFieldsToCompare | Gets the list of User Data Fields of two database tables to compare.
Public method | GetWhsInfo |
Public method | GetWhsJournal |
Public method | GetYieldForResource |
Public method | IsPahtomMaterial |
Public method | IsThereAnyResourceWithRunTimeZeroAtBom |
Public method | IsThereAnyResourceWithRunTimeZeroAtMor |
Public method | MORItemsValuationMethodValidation |
Public method | MORUpdateValuesAddition |
Public method | MORUpdateValuesSubstraction |
Public method | MorReferencesToRemove |
Public method | OperationAdjustmentTimeRecordingBookings |
Public method | OperationTimeRecordingBookings |
Public method | PickOrdersNotToClose |
Public method | PickReceiptNotToClose |
Public method | ReplicateBatchDetails |
Public method | RestoreAutoCloseTask |
Public method | RestoreBatchDetails |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateItemDescOnBOM |
Public method | UpdateItemDescOnBOMAll |
Top
See Also

Reference

BaseSystemQueries Class
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries Methods

BaseSystemQueries Class See Also

The following tables list the members exposed by the BaseSystemQueries type.

Methods
 | Name | Description
Public method | EnablePostResourceConfirmation |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | FindBatchTampate |
Public method | FindSerialTemplate |
Public method | GetAdtJeForCompicatedTypes |
Public method | GetAllResourcesFromMOR16ThatAreInactive |
Public method | GetAlreadyDefinedAdditionaBatchDetails |
Public method | GetBaseTypeForbatch |
Public method | GetBatchAllDetails | All Details for Batch generally select * from "OBTN"
Public method | GetBatchQuantity |
Public method | GetBatchSerialDocumentInfo |
Public method | GetBatchTemplateDetails |
Public method | GetBatchesInFEFOOrder |
Public method | GetBatchesInFMFOOrder |
Public method | GetBatchesToCreateAddtitemCodes |
Public method | GetBranchesForBOMS |
Public method | GetBranchesForBOMSBacflush |
Public method | GetColumnConfiguration | Gets the configuration of given columns for a specified parent.
Public method | GetCostCentres |
Public method | GetCostForResourceLine |
Public method | GetCountiresList |
Public method | GetCountryCode |
Public method | GetCountryName |
Public method | GetDataForRestoreAdditionaBatchDetails |
Public method | GetDefaultValueForField |
Public method | GetDefaultValueForFields |
Public method | GetDynamicCostForReceipt |
Public method | GetExpiryDateTemplate |
Public method | GetExpiryDateType |
Public method | GetFifoLayersForCorrection |
Public method | GetFirstBOMToOpen |
Public method | GetFreeBatchItems |
Public method | GetFreeItems |
Public method | GetFreeSerialItems |
Public method | GetGlobalBatchSettings |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemBatchQueue |
Public method | GetItemDetailsExistsForBatch |
Public method | GetItemsProperties |
Public method | GetItemsToRestoreItemDetails |
Public method | GetItemsToRestoreItemDetailsInventory |
Public method | GetMatchingCurrencyCode |
Public method | GetMinClosingDateForMor |
Public method | GetMissingBatchesForProdReceipt |
Public method | GetMorBranch |
Public method | GetMorInfo |
Public method | GetMorLinesToUnlock |
Public method | GetOpenSalesOrderForItems |
Public method | GetOprNamesForCodes |
Public method | GetPeriodIndicator |
Public method | GetProductionAccounts |
Public method | GetProperties |
Public method | GetProposedDocumentSeries |
Public method | GetResourceBookedTime |
Public method | GetResourceBookedTimeByType |
Public method | GetResourceWIPAcct |
Public method | GetRevisionFromGoodsReceiptDoc |
Public method | GetRevisionFromGoodsReceiptPODoc |
Public method | GetSerialNumberQuantity |
Public method | GetSeriesNameForJE |
Public method | GetSubstituteItems |
Public method | GetSubstituteRatio |
Public method | GetSubstituteRevision |
Public method | GetSumFreeBatchItems |
Public method | GetSumFreeItems |
Public method | GetSumFreeSerialItems |
Public method | GetTableColumns |
Public method | GetTestProperties |
Public method | GetTransValueFormOITM |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetTypesOfListOfFields |
Public method | GetUpdatePaymentDocumentAdditionalJournalEntries |
Public method | GetUserDataFieldsToCompare | Gets the list of User Data Fields of two database tables to compare.
Public method | GetWhsInfo |
Public method | GetWhsJournal |
Public method | GetYieldForResource |
Public method | IsPahtomMaterial |
Public method | IsThereAnyResourceWithRunTimeZeroAtBom |
Public method | IsThereAnyResourceWithRunTimeZeroAtMor |
Public method | MORItemsValuationMethodValidation |
Public method | MORUpdateValuesAddition |
Public method | MORUpdateValuesSubstraction |
Public method | MorReferencesToRemove |
Public method | OperationAdjustmentTimeRecordingBookings |
Public method | OperationTimeRecordingBookings |
Public method | PickOrdersNotToClose |
Public method | PickReceiptNotToClose |
Public method | ReplicateBatchDetails |
Public method | RestoreAutoCloseTask |
Public method | RestoreBatchDetails |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateItemDescOnBOM |
Public method | UpdateItemDescOnBOMAll |
Top
See Also

Reference

BaseSystemQueries Class
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.EnablePostResourceConfirmation Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function EnablePostResourceConfirmation( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset EnablePostResourceConfirmation(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ EnablePostResourceConfirmation(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function EnablePostResourceConfirmation(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.FindBatchTampate Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function FindBatchTampate( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset FindBatchTampate(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ FindBatchTampate(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function FindBatchTampate(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.FindSerialTemplate Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function FindSerialTemplate( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset FindSerialTemplate(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ FindSerialTemplate(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function FindSerialTemplate(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetAdtJeForCompicatedTypes Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAdtJeForCompicatedTypes( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAdtJeForCompicatedTypes(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAdtJeForCompicatedTypes(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAdtJeForCompicatedTypes(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetAllResourcesFromMOR16ThatAreInactive Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAllResourcesFromMOR16ThatAreInactive( _
   ByVal Token As String, _
   ByVal morDocEntries As List(Of Integer) _
) As List(Of Tuple(Of Integer, Integer))
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<Tuple<int, int>> GetAllResourcesFromMOR16ThatAreInactive(
   string Token,
   List<int> morDocEntries
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<Tuple<int, int>^>^ GetAllResourcesFromMOR16ThatAreInactive(
   String^ Token,
   List<int>^ morDocEntries
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

morDocEntries

Type: List<int>

Return Value

Type: List<Tuple<int, int>>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetAlreadyDefinedAdditionaBatchDetails Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAlreadyDefinedAdditionaBatchDetails( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal SysNumber As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAlreadyDefinedAdditionaBatchDetails(
   string Token,
   string ItemCode,
   int SysNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAlreadyDefinedAdditionaBatchDetails(
   String^ Token,
   String^ ItemCode,
   int SysNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAlreadyDefinedAdditionaBatchDetails(
    Token : String,
    ItemCode : String,
    SysNumber : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

SysNumber

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetBaseTypeForbatch Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBaseTypeForbatch( _
   ByVal Token As String, _
   ByVal ItemCoe As String, _
   ByVal SysNumber As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBaseTypeForbatch(
   string Token,
   string ItemCoe,
   int SysNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBaseTypeForbatch(
   String^ Token,
   String^ ItemCoe,
   int SysNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBaseTypeForbatch(
    Token : String,
    ItemCoe : String,
    SysNumber : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCoe

Type: string

SysNumber

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetBatchAllDetails Method

All Details for Batch generally select * from "OBTN"

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBatchAllDetails( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal DistNumber As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBatchAllDetails(
   string Token,
   string ItemCode,
   string DistNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBatchAllDetails(
   String^ Token,
   String^ ItemCode,
   String^ DistNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBatchAllDetails(
    Token : String,
    ItemCode : String,
    DistNumber : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

DistNumber

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetBatchQuantity Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBatchQuantity( _
   ByVal token As String, _
   ByVal ItemCode As String, _
   ByVal DistNumber As String _
) As Dictionary(Of String, Double)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Dictionary<string, double> GetBatchQuantity(
   string token,
   string ItemCode,
   string DistNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Dictionary<String^, double>^ GetBatchQuantity(
   String^ token,
   String^ ItemCode,
   String^ DistNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

ItemCode

Type: string

DistNumber

Type: string

Return Value

Type: Dictionary<string, double>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetBatchSerialDocumentInfo Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBatchSerialDocumentInfo( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal DocType As Integer, _
   ByVal DocLine As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBatchSerialDocumentInfo(
   string Token,
   int DocEntry,
   int DocType,
   int DocLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBatchSerialDocumentInfo(
   String^ Token,
   int DocEntry,
   int DocType,
   int DocLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBatchSerialDocumentInfo(
    Token : String,
    DocEntry : int,
    DocType : int,
    DocLine : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

DocType

Type: int

DocLine

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetBatchTemplateDetails Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBatchTemplateDetails( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBatchTemplateDetails(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBatchTemplateDetails(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBatchTemplateDetails(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetBatchesInFEFOOrder Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBatchesInFEFOOrder( _
   ByVal token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String, _
   ByVal Revision As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBatchesInFEFOOrder(
   string token,
   string ItemCode,
   string WhsCode,
   string Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBatchesInFEFOOrder(
   String^ token,
   String^ ItemCode,
   String^ WhsCode,
   String^ Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBatchesInFEFOOrder(
    token : String,
    ItemCode : String,
    WhsCode : String,
    Revision : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

ItemCode

Type: string

WhsCode

Type: string

Revision

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetBatchesInFMFOOrder Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBatchesInFMFOOrder( _
   ByVal token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String, _
   ByVal Revision As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBatchesInFMFOOrder(
   string token,
   string ItemCode,
   string WhsCode,
   string Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBatchesInFMFOOrder(
   String^ token,
   String^ ItemCode,
   String^ WhsCode,
   String^ Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBatchesInFMFOOrder(
    token : String,
    ItemCode : String,
    WhsCode : String,
    Revision : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

ItemCode

Type: string

WhsCode

Type: string

Revision

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetBatchesToCreateAddtitemCodes Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBatchesToCreateAddtitemCodes( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal docType As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBatchesToCreateAddtitemCodes(
   string Token,
   int DocEntry,
   int docType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBatchesToCreateAddtitemCodes(
   String^ Token,
   int DocEntry,
   int docType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBatchesToCreateAddtitemCodes(
    Token : String,
    DocEntry : int,
    docType : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

docType

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetBranchesForBOMS Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBranchesForBOMS( _
   ByVal Token As String, _
   ByVal bomcodes As IList(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBranchesForBOMS(
   string Token,
   IList<string> bomcodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBranchesForBOMS(
   String^ Token,
   IList<String^>^ bomcodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

bomcodes

Type: IList<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetBranchesForBOMSBacflush Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBranchesForBOMSBacflush( _
   ByVal Token As String, _
   ByVal bomcodes As IList(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBranchesForBOMSBacflush(
   string Token,
   IList<string> bomcodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBranchesForBOMSBacflush(
   String^ Token,
   IList<String^>^ bomcodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

bomcodes

Type: IList<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetColumnConfiguration Method

Gets the configuration of given columns for a specified parent.

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetColumnConfiguration( _
   ByVal token As String, _
   ByVal parentId As String, _
   ByVal columnIds As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetColumnConfiguration(
   string token,
   string parentId,
   List<string> columnIds
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetColumnConfiguration(
   String^ token,
   String^ parentId,
   List<String^>^ columnIds
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

Token.

parentId

Type: string

The ID of the parent.

columnIds

Type: List<string>

A collection of the IDs of columns.

Return Value

Type: CTRecordset

CTRecordset object.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetCostCentres Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetCostCentres( _
   ByVal Token As String, _
   ByVal ocrCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetCostCentres(
   string Token,
   string ocrCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetCostCentres(
   String^ Token,
   String^ ocrCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetCostCentres(
    Token : String,
    ocrCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ocrCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetCostForResourceLine Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetCostForResourceLine( _
   ByVal Token As String, _
   ByVal BaseLineNum As Integer, _
   ByVal BaseEntry As Integer, _
   ByVal WorkingHours As Double, _
   ByVal TimeType As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetCostForResourceLine(
   string Token,
   int BaseLineNum,
   int BaseEntry,
   double WorkingHours,
   string TimeType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetCostForResourceLine(
   String^ Token,
   int BaseLineNum,
   int BaseEntry,
   double WorkingHours,
   String^ TimeType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetCostForResourceLine(
    Token : String,
    BaseLineNum : int,
    BaseEntry : int,
    WorkingHours : double,
    TimeType : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

BaseLineNum

Type: int

BaseEntry

Type: int

WorkingHours

Type: double

TimeType

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetCountiresList Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetCountiresList( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetCountiresList(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetCountiresList(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetCountiresList(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetCountryCode Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetCountryCode( _
   ByVal Token As String, _
   ByVal CountryName As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GetCountryCode(
   string Token,
   string CountryName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ GetCountryCode(
   String^ Token,
   String^ CountryName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetCountryCode(
    Token : String,
    CountryName : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

CountryName

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetCountryName Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetCountryName( _
   ByVal Token As String, _
   ByVal CountryCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GetCountryName(
   string Token,
   string CountryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ GetCountryName(
   String^ Token,
   String^ CountryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetCountryName(
    Token : String,
    CountryCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

CountryCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetDataForRestoreAdditionaBatchDetails Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDataForRestoreAdditionaBatchDetails( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDataForRestoreAdditionaBatchDetails(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDataForRestoreAdditionaBatchDetails(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDataForRestoreAdditionaBatchDetails(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetDefaultValueForField Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDefaultValueForField( _
   ByVal token As String, _
   ByVal TableID As String, _
   ByVal AliasID As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDefaultValueForField(
   string token,
   string TableID,
   string AliasID
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDefaultValueForField(
   String^ token,
   String^ TableID,
   String^ AliasID
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDefaultValueForField(
    token : String,
    TableID : String,
    AliasID : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

TableID

Type: string

AliasID

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetDefaultValueForFields Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDefaultValueForFields( _
   ByVal token As String, _
   ByVal TableID As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDefaultValueForFields(
   string token,
   string TableID
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDefaultValueForFields(
   String^ token,
   String^ TableID
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDefaultValueForFields(
    token : String,
    TableID : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

TableID

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetDynamicCostForReceipt Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDynamicCostForReceipt( _
   ByVal Token As String, _
   ByVal MorEntry As Integer, _
   ByVal ItemBackFlushEntry As Integer, _
   ByVal CPSCRDocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDynamicCostForReceipt(
   string Token,
   int MorEntry,
   int ItemBackFlushEntry,
   int CPSCRDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDynamicCostForReceipt(
   String^ Token,
   int MorEntry,
   int ItemBackFlushEntry,
   int CPSCRDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDynamicCostForReceipt(
    Token : String,
    MorEntry : int,
    ItemBackFlushEntry : int,
    CPSCRDocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

MorEntry

Type: int

ItemBackFlushEntry

Type: int

CPSCRDocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetExpiryDateTemplate Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetExpiryDateTemplate( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetExpiryDateTemplate(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetExpiryDateTemplate(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetExpiryDateTemplate(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetExpiryDateType Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetExpiryDateType( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetExpiryDateType(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetExpiryDateType(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetExpiryDateType(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetFifoLayersForCorrection Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetFifoLayersForCorrection( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal OperType As String, _
   ByVal OperEntry As Integer, _
   ByVal OperLine As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetFifoLayersForCorrection(
   string Token,
   int DocEntry,
   string OperType,
   int OperEntry,
   int OperLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetFifoLayersForCorrection(
   String^ Token,
   int DocEntry,
   String^ OperType,
   int OperEntry,
   int OperLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetFifoLayersForCorrection(
    Token : String,
    DocEntry : int,
    OperType : String,
    OperEntry : int,
    OperLine : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

OperType

Type: string

OperEntry

Type: int

OperLine

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetFirstBOMToOpen Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetFirstBOMToOpen( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetFirstBOMToOpen(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetFirstBOMToOpen(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetFirstBOMToOpen(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetFreeBatchItems Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetFreeBatchItems( _
   ByVal Token As String, _
   ByVal itemcode As String, _
   ByVal whsCode As String, _
   ByVal Revision As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetFreeBatchItems(
   string Token,
   string itemcode,
   string whsCode,
   string Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetFreeBatchItems(
   String^ Token,
   String^ itemcode,
   String^ whsCode,
   String^ Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetFreeBatchItems(
    Token : String,
    itemcode : String,
    whsCode : String,
    Revision : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemcode

Type: string

whsCode

Type: string

Revision

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetFreeItems Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetFreeItems( _
   ByVal Token As String, _
   ByVal itemcode As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetFreeItems(
   string Token,
   string itemcode,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetFreeItems(
   String^ Token,
   String^ itemcode,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetFreeItems(
    Token : String,
    itemcode : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemcode

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetFreeSerialItems Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetFreeSerialItems( _
   ByVal Token As String, _
   ByVal itemcode As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetFreeSerialItems(
   string Token,
   string itemcode,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetFreeSerialItems(
   String^ Token,
   String^ itemcode,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetFreeSerialItems(
    Token : String,
    itemcode : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemcode

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetGlobalBatchSettings Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetGlobalBatchSettings( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetGlobalBatchSettings(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetGlobalBatchSettings(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetGlobalBatchSettings(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetItemBatchQueue Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemBatchQueue( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemBatchQueue(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemBatchQueue(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemBatchQueue(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetItemDetailsExistsForBatch Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemDetailsExistsForBatch( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal SysNumber As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemDetailsExistsForBatch(
   string Token,
   string ItemCode,
   int SysNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemDetailsExistsForBatch(
   String^ Token,
   String^ ItemCode,
   int SysNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemDetailsExistsForBatch(
    Token : String,
    ItemCode : String,
    SysNumber : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

SysNumber

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetItemsProperties Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemsProperties( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemsProperties(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemsProperties(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemsProperties(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetItemsToRestoreItemDetails Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemsToRestoreItemDetails( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemsToRestoreItemDetails(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemsToRestoreItemDetails(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemsToRestoreItemDetails(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetItemsToRestoreItemDetailsInventory Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemsToRestoreItemDetailsInventory( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetItemsToRestoreItemDetailsInventory(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetItemsToRestoreItemDetailsInventory(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemsToRestoreItemDetailsInventory(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetMatchingCurrencyCode Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetMatchingCurrencyCode( _
   ByVal token As String, _
   ByVal searchValue As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetMatchingCurrencyCode(
   string token,
   string searchValue
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetMatchingCurrencyCode(
   String^ token,
   String^ searchValue
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetMatchingCurrencyCode(
    token : String,
    searchValue : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

searchValue

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetMinClosingDateForMor Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetMinClosingDateForMor( _
   ByVal Token As String, _
   ByVal Docentry As Integer _
) As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime GetMinClosingDateForMor(
   string Token,
   int Docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DateTime GetMinClosingDateForMor(
   String^ Token,
   int Docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetMinClosingDateForMor(
    Token : String,
    Docentry : int
) : DateTime;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Docentry

Type: int

Return Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetMissingBatchesForProdReceipt Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetMissingBatchesForProdReceipt( _
   ByVal Token As String, _
   ByVal PickOrderDocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetMissingBatchesForProdReceipt(
   string Token,
   int PickOrderDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetMissingBatchesForProdReceipt(
   String^ Token,
   int PickOrderDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetMissingBatchesForProdReceipt(
    Token : String,
    PickOrderDocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

PickOrderDocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetMorBranch Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetMorBranch( _
   ByVal Token As String, _
   ByVal DocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetMorBranch(
   string Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetMorBranch(
   String^ Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetMorBranch(
    Token : String,
    DocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetMorInfo Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetMorInfo( _
   ByVal Token As String, _
   ByVal DocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetMorInfo(
   string Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetMorInfo(
   String^ Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetMorInfo(
    Token : String,
    DocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetMorLinesToUnlock Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetMorLinesToUnlock( _
   ByVal Token As String, _
   ByVal docentrys As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetMorLinesToUnlock(
   string Token,
   IEnumerable<int> docentrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetMorLinesToUnlock(
   String^ Token,
   IEnumerable<int>^ docentrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

docentrys

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetOpenSalesOrderForItems Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetOpenSalesOrderForItems( _
   ByVal Token As String, _
   ByVal Items As IEnumerable(Of String) _
) As List(Of Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<int> GetOpenSalesOrderForItems(
   string Token,
   IEnumerable<string> Items
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<int>^ GetOpenSalesOrderForItems(
   String^ Token,
   IEnumerable<String^>^ Items
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

Items

Type: IEnumerable<string>

Return Value

Type: List<int>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetOprNamesForCodes Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetOprNamesForCodes( _
   ByVal token As String, _
   ByVal ocrCodes As IEnumerable(Of String) _
) As Dictionary(Of String, String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Dictionary<string, string> GetOprNamesForCodes(
   string token,
   IEnumerable<string> ocrCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Dictionary<String^, String^>^ GetOprNamesForCodes(
   String^ token,
   IEnumerable<String^>^ ocrCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

ocrCodes

Type: IEnumerable<string>

Return Value

Type: Dictionary<string, string>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetPeriodIndicator Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetPeriodIndicator( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetPeriodIndicator(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetPeriodIndicator(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetPeriodIndicator(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetProductionAccounts Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetProductionAccounts( _
   ByVal Token As String, _
   ByVal ParentItemCode As String, _
   ByVal ParentWhsCode As String, _
   ByVal ComponentItemCode As String, _
   ByVal ComponentWhsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetProductionAccounts(
   string Token,
   string ParentItemCode,
   string ParentWhsCode,
   string ComponentItemCode,
   string ComponentWhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetProductionAccounts(
   String^ Token,
   String^ ParentItemCode,
   String^ ParentWhsCode,
   String^ ComponentItemCode,
   String^ ComponentWhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetProductionAccounts(
    Token : String,
    ParentItemCode : String,
    ParentWhsCode : String,
    ComponentItemCode : String,
    ComponentWhsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ParentItemCode

Type: string

ParentWhsCode

Type: string

ComponentItemCode

Type: string

ComponentWhsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetProperties Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetProperties( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetProperties(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetProperties(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetProperties(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetProposedDocumentSeries Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetProposedDocumentSeries( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetProposedDocumentSeries(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetProposedDocumentSeries(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetProposedDocumentSeries(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetResourceBookedTime Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetResourceBookedTime( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal LineNums As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetResourceBookedTime(
   string Token,
   int DocEntry,
   IEnumerable<int> LineNums
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetResourceBookedTime(
   String^ Token,
   int DocEntry,
   IEnumerable<int>^ LineNums
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

LineNums

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetResourceBookedTimeByType Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetResourceBookedTimeByType( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal LineNums As IEnumerable(Of Integer), _
   ByVal Type As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetResourceBookedTimeByType(
   string Token,
   int DocEntry,
   IEnumerable<int> LineNums,
   string Type
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetResourceBookedTimeByType(
   String^ Token,
   int DocEntry,
   IEnumerable<int>^ LineNums,
   String^ Type
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

LineNums

Type: IEnumerable<int>

Type

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetResourceWIPAcct Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetResourceWIPAcct( _
   ByVal Token As String, _
   ByVal BaseEntry As Integer, _
   ByVal BaseLine As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetResourceWIPAcct(
   string Token,
   int BaseEntry,
   int BaseLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetResourceWIPAcct(
   String^ Token,
   int BaseEntry,
   int BaseLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetResourceWIPAcct(
    Token : String,
    BaseEntry : int,
    BaseLine : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

BaseEntry

Type: int

BaseLine

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetRevisionFromGoodsReceiptDoc Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRevisionFromGoodsReceiptDoc( _
   ByVal Token As String, _
   ByVal DocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRevisionFromGoodsReceiptDoc(
   string Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRevisionFromGoodsReceiptDoc(
   String^ Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRevisionFromGoodsReceiptDoc(
    Token : String,
    DocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetRevisionFromGoodsReceiptPODoc Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRevisionFromGoodsReceiptPODoc( _
   ByVal Token As String, _
   ByVal DocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRevisionFromGoodsReceiptPODoc(
   string Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRevisionFromGoodsReceiptPODoc(
   String^ Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRevisionFromGoodsReceiptPODoc(
    Token : String,
    DocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetSerialNumberQuantity Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSerialNumberQuantity( _
   ByVal token As String, _
   ByVal ItemCode As String, _
   ByVal SysNumber As Integer _
) As Dictionary(Of String, Double)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Dictionary<string, double> GetSerialNumberQuantity(
   string token,
   string ItemCode,
   int SysNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Dictionary<String^, double>^ GetSerialNumberQuantity(
   String^ token,
   String^ ItemCode,
   int SysNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

ItemCode

Type: string

SysNumber

Type: int

Return Value

Type: Dictionary<string, double>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetSeriesNameForJE Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSeriesNameForJE( _
   ByVal Token As String, _
   ByVal TransId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSeriesNameForJE(
   string Token,
   int TransId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSeriesNameForJE(
   String^ Token,
   int TransId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSeriesNameForJE(
    Token : String,
    TransId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

TransId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetSubstituteItems Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSubstituteItems( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal Revision As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSubstituteItems(
   string Token,
   string ItemCode,
   string Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSubstituteItems(
   String^ Token,
   String^ ItemCode,
   String^ Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSubstituteItems(
    Token : String,
    ItemCode : String,
    Revision : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Revision

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetSubstituteRatio Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSubstituteRatio( _
   ByVal Token As String, _
   ByVal originalItemCode As String, _
   ByVal originalRevision As String, _
   ByVal ReplacementItemCode As String, _
   ByVal ReplacementRevision As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSubstituteRatio(
   string Token,
   string originalItemCode,
   string originalRevision,
   string ReplacementItemCode,
   string ReplacementRevision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSubstituteRatio(
   String^ Token,
   String^ originalItemCode,
   String^ originalRevision,
   String^ ReplacementItemCode,
   String^ ReplacementRevision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSubstituteRatio(
    Token : String,
    originalItemCode : String,
    originalRevision : String,
    ReplacementItemCode : String,
    ReplacementRevision : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

originalItemCode

Type: string

originalRevision

Type: string

ReplacementItemCode

Type: string

ReplacementRevision

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetSubstituteRevision Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSubstituteRevision( _
   ByVal Token As String, _
   ByVal originalItemCode As String, _
   ByVal originalRevision As String, _
   ByVal ReplacementItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSubstituteRevision(
   string Token,
   string originalItemCode,
   string originalRevision,
   string ReplacementItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSubstituteRevision(
   String^ Token,
   String^ originalItemCode,
   String^ originalRevision,
   String^ ReplacementItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSubstituteRevision(
    Token : String,
    originalItemCode : String,
    originalRevision : String,
    ReplacementItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

originalItemCode

Type: string

originalRevision

Type: string

ReplacementItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetSumFreeBatchItems Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSumFreeBatchItems( _
   ByVal Token As String, _
   ByVal itemcode As String, _
   ByVal revision As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSumFreeBatchItems(
   string Token,
   string itemcode,
   string revision,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSumFreeBatchItems(
   String^ Token,
   String^ itemcode,
   String^ revision,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSumFreeBatchItems(
    Token : String,
    itemcode : String,
    revision : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemcode

Type: string

revision

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetSumFreeItems Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSumFreeItems( _
   ByVal Token As String, _
   ByVal itemcode As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSumFreeItems(
   string Token,
   string itemcode,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSumFreeItems(
   String^ Token,
   String^ itemcode,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSumFreeItems(
    Token : String,
    itemcode : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemcode

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetSumFreeSerialItems Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSumFreeSerialItems( _
   ByVal Token As String, _
   ByVal itemcode As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSumFreeSerialItems(
   string Token,
   string itemcode,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSumFreeSerialItems(
   String^ Token,
   String^ itemcode,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSumFreeSerialItems(
    Token : String,
    itemcode : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemcode

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetTableColumns Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTableColumns( _
   ByVal Token As String, _
   ByVal TableID As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTableColumns(
   string Token,
   string TableID
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTableColumns(
   String^ Token,
   String^ TableID
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetTableColumns(
    Token : String,
    TableID : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

TableID

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetTestProperties Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTestProperties( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTestProperties(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTestProperties(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetTestProperties(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetTransValueFormOITM Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTransValueFormOITM( _
   ByVal Token As String, _
   ByVal CreatedBy As Integer, _
   ByVal TransType As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTransValueFormOITM(
   string Token,
   int CreatedBy,
   string TransType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTransValueFormOITM(
   String^ Token,
   int CreatedBy,
   String^ TransType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetTransValueFormOITM(
    Token : String,
    CreatedBy : int,
    TransType : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

CreatedBy

Type: int

TransType

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetTypesOfListOfFields Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetTypesOfListOfFields( _
   ByVal token As String, _
   ByVal TableID As String, _
   ByVal aliases As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetTypesOfListOfFields(
   string token,
   string TableID,
   List<string> aliases
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetTypesOfListOfFields(
   String^ token,
   String^ TableID,
   List<String^>^ aliases
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

TableID

Type: string

aliases

Type: List<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetUpdatePaymentDocumentAdditionalJournalEntries Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetUpdatePaymentDocumentAdditionalJournalEntries( _
   ByVal Token As String, _
   ByVal TableName As String, _
   ByVal DocNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetUpdatePaymentDocumentAdditionalJournalEntries(
   string Token,
   string TableName,
   int DocNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetUpdatePaymentDocumentAdditionalJournalEntries(
   String^ Token,
   String^ TableName,
   int DocNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetUpdatePaymentDocumentAdditionalJournalEntries(
    Token : String,
    TableName : String,
    DocNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

TableName

Type: string

DocNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetUserDataFieldsToCompare Method

Gets the list of User Data Fields of two database tables to compare.

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetUserDataFieldsToCompare( _
   ByVal token As String, _
   ByVal table1 As String, _
   ByVal table2 As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetUserDataFieldsToCompare(
   string token,
   string table1,
   string table2
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetUserDataFieldsToCompare(
   String^ token,
   String^ table1,
   String^ table2
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetUserDataFieldsToCompare(
    token : String,
    table1 : String,
    table2 : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Token.

table1

Type: string

The first database table.

table2

Type: string

The second database table.

Return Value

Type: CTRecordset

CTRecordset object.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetWhsInfo Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetWhsInfo( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetWhsInfo(
   string Token,
   string ItemCode,
   string WhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetWhsInfo(
   String^ Token,
   String^ ItemCode,
   String^ WhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetWhsInfo(
    Token : String,
    ItemCode : String,
    WhsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

WhsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetWhsJournal Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetWhsJournal( _
   ByVal Tokne As String, _
   ByVal TransType As String, _
   ByVal DocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetWhsJournal(
   string Tokne,
   string TransType,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetWhsJournal(
   String^ Tokne,
   String^ TransType,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetWhsJournal(
    Tokne : String,
    TransType : String,
    DocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Tokne

Type: string

TransType

Type: string

DocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.GetYieldForResource Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetYieldForResource( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal LineNum As Integer _
) As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double GetYieldForResource(
   string Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
double GetYieldForResource(
   String^ Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetYieldForResource(
    Token : String,
    DocEntry : int,
    LineNum : int
) : double;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

LineNum

Type: int

Return Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.IsPahtomMaterial Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function IsPahtomMaterial( _
   ByVal Token As String, _
   ByVal itemCode As String, _
   ByVal revison As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool IsPahtomMaterial(
   string Token,
   string itemCode,
   string revison
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool IsPahtomMaterial(
   String^ Token,
   String^ itemCode,
   String^ revison
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function IsPahtomMaterial(
    Token : String,
    itemCode : String,
    revison : String
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemCode

Type: string

revison

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.IsThereAnyResourceWithRunTimeZeroAtBom Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function IsThereAnyResourceWithRunTimeZeroAtBom( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset IsThereAnyResourceWithRunTimeZeroAtBom(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ IsThereAnyResourceWithRunTimeZeroAtBom(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function IsThereAnyResourceWithRunTimeZeroAtBom(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.IsThereAnyResourceWithRunTimeZeroAtMor Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function IsThereAnyResourceWithRunTimeZeroAtMor( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset IsThereAnyResourceWithRunTimeZeroAtMor(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ IsThereAnyResourceWithRunTimeZeroAtMor(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function IsThereAnyResourceWithRunTimeZeroAtMor(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.MORItemsValuationMethodValidation Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function MORItemsValuationMethodValidation( _
   ByVal token As String, _
   ByVal itemCodesList As IEnumerable(Of String) _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string MORItemsValuationMethodValidation(
   string token,
   IEnumerable<string> itemCodesList
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ MORItemsValuationMethodValidation(
   String^ token,
   IEnumerable<String^>^ itemCodesList
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCodesList

Type: IEnumerable<string>

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.MORUpdateValuesAddition Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function MORUpdateValuesAddition( _
   ByVal token As String, _
   ByVal DocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset MORUpdateValuesAddition(
   string token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ MORUpdateValuesAddition(
   String^ token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function MORUpdateValuesAddition(
    token : String,
    DocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

DocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.MORUpdateValuesSubstraction Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function MORUpdateValuesSubstraction( _
   ByVal token As String, _
   ByVal DocEntry As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset MORUpdateValuesSubstraction(
   string token,
   string DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ MORUpdateValuesSubstraction(
   String^ token,
   String^ DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function MORUpdateValuesSubstraction(
    token : String,
    DocEntry : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

DocEntry

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.MorReferencesToRemove Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function MorReferencesToRemove( _
   ByVal Token As String, _
   ByVal DocEntry As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset MorReferencesToRemove(
   string Token,
   string DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ MorReferencesToRemove(
   String^ Token,
   String^ DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function MorReferencesToRemove(
    Token : String,
    DocEntry : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.OperationAdjustmentTimeRecordingBookings Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function OperationAdjustmentTimeRecordingBookings( _
   ByVal Token As String, _
   ByVal WorkingHours As Double, _
   ByVal TimeType As String, _
   ByVal RscCode As String, _
   ByVal BaseLine As Integer, _
   ByVal BaseEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset OperationAdjustmentTimeRecordingBookings(
   string Token,
   double WorkingHours,
   string TimeType,
   string RscCode,
   int BaseLine,
   int BaseEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ OperationAdjustmentTimeRecordingBookings(
   String^ Token,
   double WorkingHours,
   String^ TimeType,
   String^ RscCode,
   int BaseLine,
   int BaseEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function OperationAdjustmentTimeRecordingBookings(
    Token : String,
    WorkingHours : double,
    TimeType : String,
    RscCode : String,
    BaseLine : int,
    BaseEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

WorkingHours

Type: double

TimeType

Type: string

RscCode

Type: string

BaseLine

Type: int

BaseEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.OperationTimeRecordingBookings Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function OperationTimeRecordingBookings( _
   ByVal Token As String, _
   ByVal WorkingHours As Double, _
   ByVal TimeType As String, _
   ByVal RscCode As String, _
   ByVal BaseLineNum As Integer, _
   ByVal BaseEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset OperationTimeRecordingBookings(
   string Token,
   double WorkingHours,
   string TimeType,
   string RscCode,
   int BaseLineNum,
   int BaseEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ OperationTimeRecordingBookings(
   String^ Token,
   double WorkingHours,
   String^ TimeType,
   String^ RscCode,
   int BaseLineNum,
   int BaseEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function OperationTimeRecordingBookings(
    Token : String,
    WorkingHours : double,
    TimeType : String,
    RscCode : String,
    BaseLineNum : int,
    BaseEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

WorkingHours

Type: double

TimeType

Type: string

RscCode

Type: string

BaseLineNum

Type: int

BaseEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.PickOrdersNotToClose Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function PickOrdersNotToClose( _
   ByVal Token As String, _
   ByVal MorEntry As Integer, _
   ByVal PorDocEntry As IEnumerable(Of Integer) _
) As List(Of Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<int> PickOrdersNotToClose(
   string Token,
   int MorEntry,
   IEnumerable<int> PorDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<int>^ PickOrdersNotToClose(
   String^ Token,
   int MorEntry,
   IEnumerable<int>^ PorDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

MorEntry

Type: int

PorDocEntry

Type: IEnumerable<int>

Return Value

Type: List<int>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.PickReceiptNotToClose Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function PickReceiptNotToClose( _
   ByVal Token As String, _
   ByVal MorEntry As Integer, _
   ByVal PorDocEntry As IEnumerable(Of Integer) _
) As List(Of Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<int> PickReceiptNotToClose(
   string Token,
   int MorEntry,
   IEnumerable<int> PorDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<int>^ PickReceiptNotToClose(
   String^ Token,
   int MorEntry,
   IEnumerable<int>^ PorDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

MorEntry

Type: int

PorDocEntry

Type: IEnumerable<int>

Return Value

Type: List<int>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.ReplicateBatchDetails Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function ReplicateBatchDetails( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset ReplicateBatchDetails(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ ReplicateBatchDetails(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ReplicateBatchDetails(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.RestoreAutoCloseTask Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub RestoreAutoCloseTask( _
   ByVal Token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void RestoreAutoCloseTask(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void RestoreAutoCloseTask(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RestoreAutoCloseTask(
    Token : String
);
This language is not supported or no code example is available.

Parameters

Token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.RestoreBatchDetails Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function RestoreBatchDetails( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset RestoreBatchDetails(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ RestoreBatchDetails(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RestoreBatchDetails(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.UpdateItemDescOnBOM Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function UpdateItemDescOnBOM( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset UpdateItemDescOnBOM(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ UpdateItemDescOnBOM(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UpdateItemDescOnBOM(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


BaseSystemQueries.UpdateItemDescOnBOMAll Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function UpdateItemDescOnBOMAll( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset UpdateItemDescOnBOMAll(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ UpdateItemDescOnBOMAll(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UpdateItemDescOnBOMAll(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSystemQueries Class
BaseSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


HANASystemQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class HANASystemQueries
    Inherits BaseSystemQueries
    Implements ISystemQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class HANASystemQueries : BaseSystemQueries,
   ISystemQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class HANASystemQueries : public BaseSystemQueries^,
   public ISystemQueries^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class HANASystemQueries
   extends BaseSystemQueries
   implements ISystemQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.SystemQueries.BaseSystemQueries
CompuTec.ProcessForce.API.Queries.SystemQueries.HANASystemQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HANASystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


HANASystemQueries Members

HANASystemQueries Class Methods See Also

The following tables list the members exposed by the HANASystemQueries type.

Methods
 | Name | Description
Public method | EnablePostResourceConfirmation | (inherited from BaseSystemQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | FindBatchTampate | (inherited from BaseSystemQueries).
Public method | FindSerialTemplate | (inherited from BaseSystemQueries).
Public method | GetAdtJeForCompicatedTypes | (inherited from BaseSystemQueries).
Public method | GetAllResourcesFromMOR16ThatAreInactive | (inherited from BaseSystemQueries).
Public method | GetAlreadyDefinedAdditionaBatchDetails | (inherited from BaseSystemQueries).
Public method | GetBaseTypeForbatch | (inherited from BaseSystemQueries).
Public method | GetBatchAllDetails | All Details for Batch generally select * from "OBTN" (inherited from BaseSystemQueries).
Public method | GetBatchQuantity | (inherited from BaseSystemQueries).
Public method | GetBatchSerialDocumentInfo | (inherited from BaseSystemQueries).
Public method | GetBatchTemplateDetails | (inherited from BaseSystemQueries).
Public method | GetBatchesInFEFOOrder | (inherited from BaseSystemQueries).
Public method | GetBatchesInFMFOOrder | (inherited from BaseSystemQueries).
Public method | GetBatchesToCreateAddtitemCodes | (inherited from BaseSystemQueries).
Public method | GetBranchesForBOMS | (inherited from BaseSystemQueries).
Public method | GetBranchesForBOMSBacflush | (inherited from BaseSystemQueries).
Public method | GetColumnConfiguration | Gets the configuration of given columns for a specified parent. (inherited from BaseSystemQueries).
Public method | GetCostCentres | (inherited from BaseSystemQueries).
Public method | GetCostForResourceLine | (inherited from BaseSystemQueries).
Public method | GetCountiresList | (inherited from BaseSystemQueries).
Public method | GetCountryCode | (inherited from BaseSystemQueries).
Public method | GetCountryName | (inherited from BaseSystemQueries).
Public method | GetDataForRestoreAdditionaBatchDetails | (inherited from BaseSystemQueries).
Public method | GetDefaultValueForField | (inherited from BaseSystemQueries).
Public method | GetDefaultValueForFields | (inherited from BaseSystemQueries).
Public method | GetDynamicCostForReceipt | (inherited from BaseSystemQueries).
Public method | GetExpiryDateTemplate | (inherited from BaseSystemQueries).
Public method | GetExpiryDateType | (inherited from BaseSystemQueries).
Public method | GetFifoLayersForCorrection | (inherited from BaseSystemQueries).
Public method | GetFirstBOMToOpen | (inherited from BaseSystemQueries).
Public method | GetFreeBatchItems | (inherited from BaseSystemQueries).
Public method | GetFreeItems | (inherited from BaseSystemQueries).
Public method | GetFreeSerialItems | (inherited from BaseSystemQueries).
Public method | GetGlobalBatchSettings | (inherited from BaseSystemQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemBatchQueue | (inherited from BaseSystemQueries).
Public method | GetItemDetailsExistsForBatch | (inherited from BaseSystemQueries).
Public method | GetItemsProperties | (inherited from BaseSystemQueries).
Public method | GetItemsToRestoreItemDetails | (inherited from BaseSystemQueries).
Public method | GetItemsToRestoreItemDetailsInventory | (inherited from BaseSystemQueries).
Public method | GetMatchingCurrencyCode | (inherited from BaseSystemQueries).
Public method | GetMinClosingDateForMor | (inherited from BaseSystemQueries).
Public method | GetMissingBatchesForProdReceipt | (inherited from BaseSystemQueries).
Public method | GetMorBranch | (inherited from BaseSystemQueries).
Public method | GetMorInfo | (inherited from BaseSystemQueries).
Public method | GetMorLinesToUnlock | (inherited from BaseSystemQueries).
Public method | GetOpenSalesOrderForItems | (inherited from BaseSystemQueries).
Public method | GetOprNamesForCodes | (inherited from BaseSystemQueries).
Public method | GetPeriodIndicator | (inherited from BaseSystemQueries).
Public method | GetProductionAccounts | (inherited from BaseSystemQueries).
Public method | GetProperties | (inherited from BaseSystemQueries).
Public method | GetProposedDocumentSeries | (inherited from BaseSystemQueries).
Public method | GetResourceBookedTime | (inherited from BaseSystemQueries).
Public method | GetResourceBookedTimeByType | (inherited from BaseSystemQueries).
Public method | GetResourceWIPAcct | (inherited from BaseSystemQueries).
Public method | GetRevisionFromGoodsReceiptDoc | (inherited from BaseSystemQueries).
Public method | GetRevisionFromGoodsReceiptPODoc | (inherited from BaseSystemQueries).
Public method | GetSerialNumberQuantity | (inherited from BaseSystemQueries).
Public method | GetSeriesNameForJE | (inherited from BaseSystemQueries).
Public method | GetSubstituteItems | (inherited from BaseSystemQueries).
Public method | GetSubstituteRatio | (inherited from BaseSystemQueries).
Public method | GetSubstituteRevision | (inherited from BaseSystemQueries).
Public method | GetSumFreeBatchItems | (inherited from BaseSystemQueries).
Public method | GetSumFreeItems | (inherited from BaseSystemQueries).
Public method | GetSumFreeSerialItems | (inherited from BaseSystemQueries).
Public method | GetTableColumns | (inherited from BaseSystemQueries).
Public method | GetTestProperties | (inherited from BaseSystemQueries).
Public method | GetTransValueFormOITM | (inherited from BaseSystemQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetTypesOfListOfFields | (inherited from BaseSystemQueries).
Public method | GetUpdatePaymentDocumentAdditionalJournalEntries | (inherited from BaseSystemQueries).
Public method | GetUserDataFieldsToCompare | Gets the list of User Data Fields of two database tables to compare. (inherited from BaseSystemQueries).
Public method | GetWhsInfo | (inherited from BaseSystemQueries).
Public method | GetWhsJournal | (inherited from BaseSystemQueries).
Public method | GetYieldForResource | (inherited from BaseSystemQueries).
Public method | IsPahtomMaterial | (inherited from BaseSystemQueries).
Public method | IsThereAnyResourceWithRunTimeZeroAtBom | (inherited from BaseSystemQueries).
Public method | IsThereAnyResourceWithRunTimeZeroAtMor | (inherited from BaseSystemQueries).
Public method | MORItemsValuationMethodValidation | (inherited from BaseSystemQueries).
Public method | MORUpdateValuesAddition | (inherited from BaseSystemQueries).
Public method | MORUpdateValuesSubstraction | (inherited from BaseSystemQueries).
Public method | MorReferencesToRemove | (inherited from BaseSystemQueries).
Public method | OperationAdjustmentTimeRecordingBookings | (inherited from BaseSystemQueries).
Public method | OperationTimeRecordingBookings | (inherited from BaseSystemQueries).
Public method | PickOrdersNotToClose | (inherited from BaseSystemQueries).
Public method | PickReceiptNotToClose | (inherited from BaseSystemQueries).
Public method | ReplicateBatchDetails | (inherited from BaseSystemQueries).
Public method | RestoreAutoCloseTask | (inherited from BaseSystemQueries).
Public method | RestoreBatchDetails | (inherited from BaseSystemQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateItemDescOnBOM | (inherited from BaseSystemQueries).
Public method | UpdateItemDescOnBOMAll | (inherited from BaseSystemQueries).
Top
See Also

Reference

HANASystemQueries Class
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


HANASystemQueries Methods

HANASystemQueries Class See Also

The following tables list the members exposed by the HANASystemQueries type.

Methods
 | Name | Description
Public method | EnablePostResourceConfirmation | (inherited from BaseSystemQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | FindBatchTampate | (inherited from BaseSystemQueries).
Public method | FindSerialTemplate | (inherited from BaseSystemQueries).
Public method | GetAdtJeForCompicatedTypes | (inherited from BaseSystemQueries).
Public method | GetAllResourcesFromMOR16ThatAreInactive | (inherited from BaseSystemQueries).
Public method | GetAlreadyDefinedAdditionaBatchDetails | (inherited from BaseSystemQueries).
Public method | GetBaseTypeForbatch | (inherited from BaseSystemQueries).
Public method | GetBatchAllDetails | All Details for Batch generally select * from "OBTN" (inherited from BaseSystemQueries).
Public method | GetBatchQuantity | (inherited from BaseSystemQueries).
Public method | GetBatchSerialDocumentInfo | (inherited from BaseSystemQueries).
Public method | GetBatchTemplateDetails | (inherited from BaseSystemQueries).
Public method | GetBatchesInFEFOOrder | (inherited from BaseSystemQueries).
Public method | GetBatchesInFMFOOrder | (inherited from BaseSystemQueries).
Public method | GetBatchesToCreateAddtitemCodes | (inherited from BaseSystemQueries).
Public method | GetBranchesForBOMS | (inherited from BaseSystemQueries).
Public method | GetBranchesForBOMSBacflush | (inherited from BaseSystemQueries).
Public method | GetColumnConfiguration | Gets the configuration of given columns for a specified parent. (inherited from BaseSystemQueries).
Public method | GetCostCentres | (inherited from BaseSystemQueries).
Public method | GetCostForResourceLine | (inherited from BaseSystemQueries).
Public method | GetCountiresList | (inherited from BaseSystemQueries).
Public method | GetCountryCode | (inherited from BaseSystemQueries).
Public method | GetCountryName | (inherited from BaseSystemQueries).
Public method | GetDataForRestoreAdditionaBatchDetails | (inherited from BaseSystemQueries).
Public method | GetDefaultValueForField | (inherited from BaseSystemQueries).
Public method | GetDefaultValueForFields | (inherited from BaseSystemQueries).
Public method | GetDynamicCostForReceipt | (inherited from BaseSystemQueries).
Public method | GetExpiryDateTemplate | (inherited from BaseSystemQueries).
Public method | GetExpiryDateType | (inherited from BaseSystemQueries).
Public method | GetFifoLayersForCorrection | (inherited from BaseSystemQueries).
Public method | GetFirstBOMToOpen | (inherited from BaseSystemQueries).
Public method | GetFreeBatchItems | (inherited from BaseSystemQueries).
Public method | GetFreeItems | (inherited from BaseSystemQueries).
Public method | GetFreeSerialItems | (inherited from BaseSystemQueries).
Public method | GetGlobalBatchSettings | (inherited from BaseSystemQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemBatchQueue | (inherited from BaseSystemQueries).
Public method | GetItemDetailsExistsForBatch | (inherited from BaseSystemQueries).
Public method | GetItemsProperties | (inherited from BaseSystemQueries).
Public method | GetItemsToRestoreItemDetails | (inherited from BaseSystemQueries).
Public method | GetItemsToRestoreItemDetailsInventory | (inherited from BaseSystemQueries).
Public method | GetMatchingCurrencyCode | (inherited from BaseSystemQueries).
Public method | GetMinClosingDateForMor | (inherited from BaseSystemQueries).
Public method | GetMissingBatchesForProdReceipt | (inherited from BaseSystemQueries).
Public method | GetMorBranch | (inherited from BaseSystemQueries).
Public method | GetMorInfo | (inherited from BaseSystemQueries).
Public method | GetMorLinesToUnlock | (inherited from BaseSystemQueries).
Public method | GetOpenSalesOrderForItems | (inherited from BaseSystemQueries).
Public method | GetOprNamesForCodes | (inherited from BaseSystemQueries).
Public method | GetPeriodIndicator | (inherited from BaseSystemQueries).
Public method | GetProductionAccounts | (inherited from BaseSystemQueries).
Public method | GetProperties | (inherited from BaseSystemQueries).
Public method | GetProposedDocumentSeries | (inherited from BaseSystemQueries).
Public method | GetResourceBookedTime | (inherited from BaseSystemQueries).
Public method | GetResourceBookedTimeByType | (inherited from BaseSystemQueries).
Public method | GetResourceWIPAcct | (inherited from BaseSystemQueries).
Public method | GetRevisionFromGoodsReceiptDoc | (inherited from BaseSystemQueries).
Public method | GetRevisionFromGoodsReceiptPODoc | (inherited from BaseSystemQueries).
Public method | GetSerialNumberQuantity | (inherited from BaseSystemQueries).
Public method | GetSeriesNameForJE | (inherited from BaseSystemQueries).
Public method | GetSubstituteItems | (inherited from BaseSystemQueries).
Public method | GetSubstituteRatio | (inherited from BaseSystemQueries).
Public method | GetSubstituteRevision | (inherited from BaseSystemQueries).
Public method | GetSumFreeBatchItems | (inherited from BaseSystemQueries).
Public method | GetSumFreeItems | (inherited from BaseSystemQueries).
Public method | GetSumFreeSerialItems | (inherited from BaseSystemQueries).
Public method | GetTableColumns | (inherited from BaseSystemQueries).
Public method | GetTestProperties | (inherited from BaseSystemQueries).
Public method | GetTransValueFormOITM | (inherited from BaseSystemQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetTypesOfListOfFields | (inherited from BaseSystemQueries).
Public method | GetUpdatePaymentDocumentAdditionalJournalEntries | (inherited from BaseSystemQueries).
Public method | GetUserDataFieldsToCompare | Gets the list of User Data Fields of two database tables to compare. (inherited from BaseSystemQueries).
Public method | GetWhsInfo | (inherited from BaseSystemQueries).
Public method | GetWhsJournal | (inherited from BaseSystemQueries).
Public method | GetYieldForResource | (inherited from BaseSystemQueries).
Public method | IsPahtomMaterial | (inherited from BaseSystemQueries).
Public method | IsThereAnyResourceWithRunTimeZeroAtBom | (inherited from BaseSystemQueries).
Public method | IsThereAnyResourceWithRunTimeZeroAtMor | (inherited from BaseSystemQueries).
Public method | MORItemsValuationMethodValidation | (inherited from BaseSystemQueries).
Public method | MORUpdateValuesAddition | (inherited from BaseSystemQueries).
Public method | MORUpdateValuesSubstraction | (inherited from BaseSystemQueries).
Public method | MorReferencesToRemove | (inherited from BaseSystemQueries).
Public method | OperationAdjustmentTimeRecordingBookings | (inherited from BaseSystemQueries).
Public method | OperationTimeRecordingBookings | (inherited from BaseSystemQueries).
Public method | PickOrdersNotToClose | (inherited from BaseSystemQueries).
Public method | PickReceiptNotToClose | (inherited from BaseSystemQueries).
Public method | ReplicateBatchDetails | (inherited from BaseSystemQueries).
Public method | RestoreAutoCloseTask | (inherited from BaseSystemQueries).
Public method | RestoreBatchDetails | (inherited from BaseSystemQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateItemDescOnBOM | (inherited from BaseSystemQueries).
Public method | UpdateItemDescOnBOMAll | (inherited from BaseSystemQueries).
Top
See Also

Reference

HANASystemQueries Class
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


SQLSystemQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SQLSystemQueries
    Inherits BaseSystemQueries
    Implements ISystemQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SQLSystemQueries : BaseSystemQueries,
   ISystemQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SQLSystemQueries : public BaseSystemQueries^,
   public ISystemQueries^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SQLSystemQueries
   extends BaseSystemQueries
   implements ISystemQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.SystemQueries.BaseSystemQueries
CompuTec.ProcessForce.API.Queries.SystemQueries.SQLSystemQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SQLSystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


SQLSystemQueries Members

SQLSystemQueries Class Methods See Also

The following tables list the members exposed by the SQLSystemQueries type.

Methods
 | Name | Description
Public method | EnablePostResourceConfirmation | (inherited from BaseSystemQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | FindBatchTampate | (inherited from BaseSystemQueries).
Public method | FindSerialTemplate | (inherited from BaseSystemQueries).
Public method | GetAdtJeForCompicatedTypes | (inherited from BaseSystemQueries).
Public method | GetAllResourcesFromMOR16ThatAreInactive | (inherited from BaseSystemQueries).
Public method | GetAlreadyDefinedAdditionaBatchDetails | (inherited from BaseSystemQueries).
Public method | GetBaseTypeForbatch | (inherited from BaseSystemQueries).
Public method | GetBatchAllDetails | All Details for Batch generally select * from "OBTN" (inherited from BaseSystemQueries).
Public method | GetBatchQuantity | (inherited from BaseSystemQueries).
Public method | GetBatchSerialDocumentInfo | (inherited from BaseSystemQueries).
Public method | GetBatchTemplateDetails | (inherited from BaseSystemQueries).
Public method | GetBatchesInFEFOOrder | (inherited from BaseSystemQueries).
Public method | GetBatchesInFMFOOrder | (inherited from BaseSystemQueries).
Public method | GetBatchesToCreateAddtitemCodes | (inherited from BaseSystemQueries).
Public method | GetBranchesForBOMS | (inherited from BaseSystemQueries).
Public method | GetBranchesForBOMSBacflush | (inherited from BaseSystemQueries).
Public method | GetColumnConfiguration | Gets the configuration of given columns for a specified parent. (inherited from BaseSystemQueries).
Public method | GetCostCentres | (inherited from BaseSystemQueries).
Public method | GetCostForResourceLine | (inherited from BaseSystemQueries).
Public method | GetCountiresList | (inherited from BaseSystemQueries).
Public method | GetCountryCode | (inherited from BaseSystemQueries).
Public method | GetCountryName | (inherited from BaseSystemQueries).
Public method | GetDataForRestoreAdditionaBatchDetails | (inherited from BaseSystemQueries).
Public method | GetDefaultValueForField | (inherited from BaseSystemQueries).
Public method | GetDefaultValueForFields | (inherited from BaseSystemQueries).
Public method | GetDynamicCostForReceipt | (inherited from BaseSystemQueries).
Public method | GetExpiryDateTemplate | (inherited from BaseSystemQueries).
Public method | GetExpiryDateType | (inherited from BaseSystemQueries).
Public method | GetFifoLayersForCorrection | (inherited from BaseSystemQueries).
Public method | GetFirstBOMToOpen | (inherited from BaseSystemQueries).
Public method | GetFreeBatchItems | (inherited from BaseSystemQueries).
Public method | GetFreeItems | (inherited from BaseSystemQueries).
Public method | GetFreeSerialItems | (inherited from BaseSystemQueries).
Public method | GetGlobalBatchSettings | (inherited from BaseSystemQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemBatchQueue | (inherited from BaseSystemQueries).
Public method | GetItemDetailsExistsForBatch | (inherited from BaseSystemQueries).
Public method | GetItemsProperties | (inherited from BaseSystemQueries).
Public method | GetItemsToRestoreItemDetails | (inherited from BaseSystemQueries).
Public method | GetItemsToRestoreItemDetailsInventory | (inherited from BaseSystemQueries).
Public method | GetMatchingCurrencyCode | (inherited from BaseSystemQueries).
Public method | GetMinClosingDateForMor | (inherited from BaseSystemQueries).
Public method | GetMissingBatchesForProdReceipt | (inherited from BaseSystemQueries).
Public method | GetMorBranch | (inherited from BaseSystemQueries).
Public method | GetMorInfo | (inherited from BaseSystemQueries).
Public method | GetMorLinesToUnlock | (inherited from BaseSystemQueries).
Public method | GetOpenSalesOrderForItems | (inherited from BaseSystemQueries).
Public method | GetOprNamesForCodes | (inherited from BaseSystemQueries).
Public method | GetPeriodIndicator | (inherited from BaseSystemQueries).
Public method | GetProductionAccounts | (inherited from BaseSystemQueries).
Public method | GetProperties | (inherited from BaseSystemQueries).
Public method | GetProposedDocumentSeries | (inherited from BaseSystemQueries).
Public method | GetResourceBookedTime | (inherited from BaseSystemQueries).
Public method | GetResourceBookedTimeByType | (inherited from BaseSystemQueries).
Public method | GetResourceWIPAcct | (inherited from BaseSystemQueries).
Public method | GetRevisionFromGoodsReceiptDoc | (inherited from BaseSystemQueries).
Public method | GetRevisionFromGoodsReceiptPODoc | (inherited from BaseSystemQueries).
Public method | GetSerialNumberQuantity | (inherited from BaseSystemQueries).
Public method | GetSeriesNameForJE | (inherited from BaseSystemQueries).
Public method | GetSubstituteItems | (inherited from BaseSystemQueries).
Public method | GetSubstituteRatio | (inherited from BaseSystemQueries).
Public method | GetSubstituteRevision | (inherited from BaseSystemQueries).
Public method | GetSumFreeBatchItems | (inherited from BaseSystemQueries).
Public method | GetSumFreeItems | (inherited from BaseSystemQueries).
Public method | GetSumFreeSerialItems | (inherited from BaseSystemQueries).
Public method | GetTableColumns | (inherited from BaseSystemQueries).
Public method | GetTestProperties | (inherited from BaseSystemQueries).
Public method | GetTransValueFormOITM | (inherited from BaseSystemQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetTypesOfListOfFields | (inherited from BaseSystemQueries).
Public method | GetUpdatePaymentDocumentAdditionalJournalEntries | (inherited from BaseSystemQueries).
Public method | GetUserDataFieldsToCompare | Gets the list of User Data Fields of two database tables to compare. (inherited from BaseSystemQueries).
Public method | GetWhsInfo | (inherited from BaseSystemQueries).
Public method | GetWhsJournal | (inherited from BaseSystemQueries).
Public method | GetYieldForResource | (inherited from BaseSystemQueries).
Public method | IsPahtomMaterial | (inherited from BaseSystemQueries).
Public method | IsThereAnyResourceWithRunTimeZeroAtBom | (inherited from BaseSystemQueries).
Public method | IsThereAnyResourceWithRunTimeZeroAtMor | (inherited from BaseSystemQueries).
Public method | MORItemsValuationMethodValidation | (inherited from BaseSystemQueries).
Public method | MORUpdateValuesAddition | (inherited from BaseSystemQueries).
Public method | MORUpdateValuesSubstraction | (inherited from BaseSystemQueries).
Public method | MorReferencesToRemove | (inherited from BaseSystemQueries).
Public method | OperationAdjustmentTimeRecordingBookings | (inherited from BaseSystemQueries).
Public method | OperationTimeRecordingBookings | (inherited from BaseSystemQueries).
Public method | PickOrdersNotToClose | (inherited from BaseSystemQueries).
Public method | PickReceiptNotToClose | (inherited from BaseSystemQueries).
Public method | ReplicateBatchDetails | (inherited from BaseSystemQueries).
Public method | RestoreAutoCloseTask | (inherited from BaseSystemQueries).
Public method | RestoreBatchDetails | (inherited from BaseSystemQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateItemDescOnBOM | (inherited from BaseSystemQueries).
Public method | UpdateItemDescOnBOMAll | (inherited from BaseSystemQueries).
Top
See Also

Reference

SQLSystemQueries Class
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


SQLSystemQueries Methods

SQLSystemQueries Class See Also

The following tables list the members exposed by the SQLSystemQueries type.

Methods
 | Name | Description
Public method | EnablePostResourceConfirmation | (inherited from BaseSystemQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | FindBatchTampate | (inherited from BaseSystemQueries).
Public method | FindSerialTemplate | (inherited from BaseSystemQueries).
Public method | GetAdtJeForCompicatedTypes | (inherited from BaseSystemQueries).
Public method | GetAllResourcesFromMOR16ThatAreInactive | (inherited from BaseSystemQueries).
Public method | GetAlreadyDefinedAdditionaBatchDetails | (inherited from BaseSystemQueries).
Public method | GetBaseTypeForbatch | (inherited from BaseSystemQueries).
Public method | GetBatchAllDetails | All Details for Batch generally select * from "OBTN" (inherited from BaseSystemQueries).
Public method | GetBatchQuantity | (inherited from BaseSystemQueries).
Public method | GetBatchSerialDocumentInfo | (inherited from BaseSystemQueries).
Public method | GetBatchTemplateDetails | (inherited from BaseSystemQueries).
Public method | GetBatchesInFEFOOrder | (inherited from BaseSystemQueries).
Public method | GetBatchesInFMFOOrder | (inherited from BaseSystemQueries).
Public method | GetBatchesToCreateAddtitemCodes | (inherited from BaseSystemQueries).
Public method | GetBranchesForBOMS | (inherited from BaseSystemQueries).
Public method | GetBranchesForBOMSBacflush | (inherited from BaseSystemQueries).
Public method | GetColumnConfiguration | Gets the configuration of given columns for a specified parent. (inherited from BaseSystemQueries).
Public method | GetCostCentres | (inherited from BaseSystemQueries).
Public method | GetCostForResourceLine | (inherited from BaseSystemQueries).
Public method | GetCountiresList | (inherited from BaseSystemQueries).
Public method | GetCountryCode | (inherited from BaseSystemQueries).
Public method | GetCountryName | (inherited from BaseSystemQueries).
Public method | GetDataForRestoreAdditionaBatchDetails | (inherited from BaseSystemQueries).
Public method | GetDefaultValueForField | (inherited from BaseSystemQueries).
Public method | GetDefaultValueForFields | (inherited from BaseSystemQueries).
Public method | GetDynamicCostForReceipt | (inherited from BaseSystemQueries).
Public method | GetExpiryDateTemplate | (inherited from BaseSystemQueries).
Public method | GetExpiryDateType | (inherited from BaseSystemQueries).
Public method | GetFifoLayersForCorrection | (inherited from BaseSystemQueries).
Public method | GetFirstBOMToOpen | (inherited from BaseSystemQueries).
Public method | GetFreeBatchItems | (inherited from BaseSystemQueries).
Public method | GetFreeItems | (inherited from BaseSystemQueries).
Public method | GetFreeSerialItems | (inherited from BaseSystemQueries).
Public method | GetGlobalBatchSettings | (inherited from BaseSystemQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemBatchQueue | (inherited from BaseSystemQueries).
Public method | GetItemDetailsExistsForBatch | (inherited from BaseSystemQueries).
Public method | GetItemsProperties | (inherited from BaseSystemQueries).
Public method | GetItemsToRestoreItemDetails | (inherited from BaseSystemQueries).
Public method | GetItemsToRestoreItemDetailsInventory | (inherited from BaseSystemQueries).
Public method | GetMatchingCurrencyCode | (inherited from BaseSystemQueries).
Public method | GetMinClosingDateForMor | (inherited from BaseSystemQueries).
Public method | GetMissingBatchesForProdReceipt | (inherited from BaseSystemQueries).
Public method | GetMorBranch | (inherited from BaseSystemQueries).
Public method | GetMorInfo | (inherited from BaseSystemQueries).
Public method | GetMorLinesToUnlock | (inherited from BaseSystemQueries).
Public method | GetOpenSalesOrderForItems | (inherited from BaseSystemQueries).
Public method | GetOprNamesForCodes | (inherited from BaseSystemQueries).
Public method | GetPeriodIndicator | (inherited from BaseSystemQueries).
Public method | GetProductionAccounts | (inherited from BaseSystemQueries).
Public method | GetProperties | (inherited from BaseSystemQueries).
Public method | GetProposedDocumentSeries | (inherited from BaseSystemQueries).
Public method | GetResourceBookedTime | (inherited from BaseSystemQueries).
Public method | GetResourceBookedTimeByType | (inherited from BaseSystemQueries).
Public method | GetResourceWIPAcct | (inherited from BaseSystemQueries).
Public method | GetRevisionFromGoodsReceiptDoc | (inherited from BaseSystemQueries).
Public method | GetRevisionFromGoodsReceiptPODoc | (inherited from BaseSystemQueries).
Public method | GetSerialNumberQuantity | (inherited from BaseSystemQueries).
Public method | GetSeriesNameForJE | (inherited from BaseSystemQueries).
Public method | GetSubstituteItems | (inherited from BaseSystemQueries).
Public method | GetSubstituteRatio | (inherited from BaseSystemQueries).
Public method | GetSubstituteRevision | (inherited from BaseSystemQueries).
Public method | GetSumFreeBatchItems | (inherited from BaseSystemQueries).
Public method | GetSumFreeItems | (inherited from BaseSystemQueries).
Public method | GetSumFreeSerialItems | (inherited from BaseSystemQueries).
Public method | GetTableColumns | (inherited from BaseSystemQueries).
Public method | GetTestProperties | (inherited from BaseSystemQueries).
Public method | GetTransValueFormOITM | (inherited from BaseSystemQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetTypesOfListOfFields | (inherited from BaseSystemQueries).
Public method | GetUpdatePaymentDocumentAdditionalJournalEntries | (inherited from BaseSystemQueries).
Public method | GetUserDataFieldsToCompare | Gets the list of User Data Fields of two database tables to compare. (inherited from BaseSystemQueries).
Public method | GetWhsInfo | (inherited from BaseSystemQueries).
Public method | GetWhsJournal | (inherited from BaseSystemQueries).
Public method | GetYieldForResource | (inherited from BaseSystemQueries).
Public method | IsPahtomMaterial | (inherited from BaseSystemQueries).
Public method | IsThereAnyResourceWithRunTimeZeroAtBom | (inherited from BaseSystemQueries).
Public method | IsThereAnyResourceWithRunTimeZeroAtMor | (inherited from BaseSystemQueries).
Public method | MORItemsValuationMethodValidation | (inherited from BaseSystemQueries).
Public method | MORUpdateValuesAddition | (inherited from BaseSystemQueries).
Public method | MORUpdateValuesSubstraction | (inherited from BaseSystemQueries).
Public method | MorReferencesToRemove | (inherited from BaseSystemQueries).
Public method | OperationAdjustmentTimeRecordingBookings | (inherited from BaseSystemQueries).
Public method | OperationTimeRecordingBookings | (inherited from BaseSystemQueries).
Public method | PickOrdersNotToClose | (inherited from BaseSystemQueries).
Public method | PickReceiptNotToClose | (inherited from BaseSystemQueries).
Public method | ReplicateBatchDetails | (inherited from BaseSystemQueries).
Public method | RestoreAutoCloseTask | (inherited from BaseSystemQueries).
Public method | RestoreBatchDetails | (inherited from BaseSystemQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateItemDescOnBOM | (inherited from BaseSystemQueries).
Public method | UpdateItemDescOnBOMAll | (inherited from BaseSystemQueries).
Top
See Also

Reference

SQLSystemQueries Class
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ISystemQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ISystemQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ISystemQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ISystemQueries
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries Members

ISystemQueries Interface Methods See Also

The following tables list the members exposed by the ISystemQueries type.

Methods
 | Name | Description
Public method | EnablePostResourceConfirmation | Determines whether or not the Post Resources Confirmation checkbox must be enabled on the General Settings form.
Public method | FindBatchTampate |
Public method | FindSerialTemplate |
Public method | GetAdtJeForCompicatedTypes | "PmntID", "ObjCrtType"
Public method | GetAllResourcesFromMOR16ThatAreInactive |
Public method | GetAlreadyDefinedAdditionaBatchDetails | t0."ItemCode",t0."SysNumber"
Public method | GetBaseTypeForbatch | top 1 t0."DocEntry", t0."DocType" ,isnull(t2."DocEntry",0) "MnfDocEntry",ISNULL(t3."U_Revision",'') "Revision",ISNULL(t4."U_Description",'')
Public method | GetBatchAllDetails |
Public method | GetBatchQuantity |
Public method | GetBatchSerialDocumentInfo |
Public method | GetBatchTemplateDetails | isnull("U_Expiry",'N')"U_Expiry", ISNULL("U_ShelfTime",'0d')"U_ShelfTime",isnull("U_Consume",'N')"U_Consume" ,ISNULL("U_ConsWarn",0) "U_ConsWarn",ISNULL("U_ExpWarn",0)"U_ExpWarn", isnull("U_InspDays",0)"U_InspDays"
Public method | GetBatchesInFEFOOrder |
Public method | GetBatchesInFMFOOrder |
Public method | GetBatchesToCreateAddtitemCodes | t0."ItemCode" , t1."SysNumber" ,ifnull(t3."U_Revision",'') "Revision",ifnull(t3."U_RevisionName",'') "RevisionName"
Public method | GetBranchesForBOMS |
Public method | GetBranchesForBOMSBacflush |
Public method | GetCostCentres | T1.OcrCode, T0.U_CT_Acct5, T0.U_CT_ContrAcct, T1.PrcAmount, T1.OcrTotal
Public method | GetCostForResourceLine |
Public method | GetCountiresList |
Public method | GetCountryCode |
Public method | GetCountryName |
Public method | GetDataForRestoreAdditionaBatchDetails | returns data erquired for batch details restoration
Public method | GetDefaultValueForField | t0."Dflt", t0."Descr", COUNT(t1."TableID") as "Count", t0."TableID", t0."FieldID", t0."EditType"
Public method | GetDefaultValueForFields | t0."Dflt", t0."Descr", t0."TableID", t0."FieldID", t0."EditType", 'U_' || t0."AliasID" AS "AliasID", t0."EditSize"
Public method | GetDynamicCostForReceipt |
Public method | GetExpiryDateTemplate |
Public method | GetExpiryDateType |
Public method | GetFifoLayersForCorrection |
Public method | GetFirstBOMToOpen |
Public method | GetFreeBatchItems |
Public method | GetFreeItems |
Public method | GetFreeSerialItems |
Public method | GetGlobalBatchSettings | "U_SapDfQCS", "U_PFDfQCS", "U_PFDfBS", "U_SapDfBS"
Public method | GetItemBatchQueue |
Public method | GetItemDetailsExistsForBatch | t0.ItemCode,t0.SysNumber ,t0.DistNumber
Public method | GetItemsToRestoreItemDetails | ItemCode
Public method | GetItemsToRestoreItemDetailsInventory |
Public method | GetMinClosingDateForMor |
Public method | GetMissingBatchesForProdReceipt | t0.U_BnStatus ,t3.U_Description,t5.DocEntry [BaseEntry] ,t5.DocType [BaseType], t1.*
Public method | GetMorBranch |
Public method | GetMorLinesToUnlock |
Public method | GetOpenSalesOrderForItems |
Public method | GetOprNamesForCodes | gets ocr codes an names
Public method | GetProductionAccounts |
Public method | GetResourceBookedTime |
Public method | GetResourceBookedTimeByType |
Public method | GetResourceWIPAcct | "WipAcct"
Public method | GetRevisionFromGoodsReceiptDoc |
Public method | GetRevisionFromGoodsReceiptPODoc |
Public method | GetSerialNumberQuantity |
Public method | GetSeriesNameForJE | T0.SeriesName
Public method | GetSubstituteItems |
Public method | GetSubstituteRatio |
Public method | GetSubstituteRevision |
Public method | GetSumFreeBatchItems |
Public method | GetSumFreeItems |
Public method | GetSumFreeSerialItems |
Public method | GetTableColumns |
Public method | GetTransValueFormOITM | "TransType", "CreatedBy", BASE_REF, "DocLineNum", SUM("TransValue") AS "TransValue", SUM("InQty"), SUM("OutQty"), "Price", "CardCode", "ItemCode", "Warehouse"
Public method | GetTypesOfListOfFields |
Public method | GetUpdatePaymentDocumentAdditionalJournalEntries | t0."DocNum" AS "Numer dokumentu", t0."Canceled", IFNULL(t1."TransId", 0) AS "Transakcja bazowa", IFNULL(t2."TransId", 0) AS "Anulowanie", IFNULL(t3."TransId", 0) AS "Roliczenie transakcji bazowej", IFNULL(t4."TransId", 0) AS "Rozliczenie anulowania"
Public method | GetWhsInfo |
Public method | GetWhsJournal | T0.TransType, T0.CreatedBy, T0.BASE_REF, T0.DocLineNum, T0.DocDate, T0.Allocation, T0.CardCode, T0.CardName, T0.JrnlMemo, T0.DocTime, T0.ItemCode, T0.Dscription, SUM(T0.InQty) AS 'InQty', SUM(T0.OutQty) AS 'OutQty', T0.Price, T0.Currency, T0.Warehouse, T0.TaxDate, T0.UserSign, SUM(T0.TransValue) AS 'TransValue', T0.InvntAct, OcrCode, OcrCode2, OcrCode3, OcrCode4, OcrCode5, PrjCode
Public method | GetYieldForResource |
Public method | IsPahtomMaterial |
Public method | IsThereAnyResourceWithRunTimeZeroAtBom |
Public method | IsThereAnyResourceWithRunTimeZeroAtMor |
Public method | MORItemsValuationMethodValidation |
Public method | MORUpdateValuesAddition |
Public method | MORUpdateValuesSubstraction |
Public method | MorReferencesToRemove |
Public method | OperationAdjustmentTimeRecordingBookings |
Public method | OperationTimeRecordingBookings |
Public method | PickOrdersNotToClose |
Public method | PickReceiptNotToClose |
Public method | ReplicateBatchDetails |
Public method | RestoreAutoCloseTask |
Public method | RestoreBatchDetails |
Public method | UpdateItemDescOnBOM |
Public method | UpdateItemDescOnBOMAll |
Top
See Also

Reference

ISystemQueries Interface
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries Methods

ISystemQueries Interface See Also

The following tables list the members exposed by the ISystemQueries type.

Methods
 | Name | Description
Public method | EnablePostResourceConfirmation | Determines whether or not the Post Resources Confirmation checkbox must be enabled on the General Settings form.
Public method | FindBatchTampate |
Public method | FindSerialTemplate |
Public method | GetAdtJeForCompicatedTypes | "PmntID", "ObjCrtType"
Public method | GetAllResourcesFromMOR16ThatAreInactive |
Public method | GetAlreadyDefinedAdditionaBatchDetails | t0."ItemCode",t0."SysNumber"
Public method | GetBaseTypeForbatch | top 1 t0."DocEntry", t0."DocType" ,isnull(t2."DocEntry",0) "MnfDocEntry",ISNULL(t3."U_Revision",'') "Revision",ISNULL(t4."U_Description",'')
Public method | GetBatchAllDetails |
Public method | GetBatchQuantity |
Public method | GetBatchSerialDocumentInfo |
Public method | GetBatchTemplateDetails | isnull("U_Expiry",'N')"U_Expiry", ISNULL("U_ShelfTime",'0d')"U_ShelfTime",isnull("U_Consume",'N')"U_Consume" ,ISNULL("U_ConsWarn",0) "U_ConsWarn",ISNULL("U_ExpWarn",0)"U_ExpWarn", isnull("U_InspDays",0)"U_InspDays"
Public method | GetBatchesInFEFOOrder |
Public method | GetBatchesInFMFOOrder |
Public method | GetBatchesToCreateAddtitemCodes | t0."ItemCode" , t1."SysNumber" ,ifnull(t3."U_Revision",'') "Revision",ifnull(t3."U_RevisionName",'') "RevisionName"
Public method | GetBranchesForBOMS |
Public method | GetBranchesForBOMSBacflush |
Public method | GetCostCentres | T1.OcrCode, T0.U_CT_Acct5, T0.U_CT_ContrAcct, T1.PrcAmount, T1.OcrTotal
Public method | GetCostForResourceLine |
Public method | GetCountiresList |
Public method | GetCountryCode |
Public method | GetCountryName |
Public method | GetDataForRestoreAdditionaBatchDetails | returns data erquired for batch details restoration
Public method | GetDefaultValueForField | t0."Dflt", t0."Descr", COUNT(t1."TableID") as "Count", t0."TableID", t0."FieldID", t0."EditType"
Public method | GetDefaultValueForFields | t0."Dflt", t0."Descr", t0."TableID", t0."FieldID", t0."EditType", 'U_' || t0."AliasID" AS "AliasID", t0."EditSize"
Public method | GetDynamicCostForReceipt |
Public method | GetExpiryDateTemplate |
Public method | GetExpiryDateType |
Public method | GetFifoLayersForCorrection |
Public method | GetFirstBOMToOpen |
Public method | GetFreeBatchItems |
Public method | GetFreeItems |
Public method | GetFreeSerialItems |
Public method | GetGlobalBatchSettings | "U_SapDfQCS", "U_PFDfQCS", "U_PFDfBS", "U_SapDfBS"
Public method | GetItemBatchQueue |
Public method | GetItemDetailsExistsForBatch | t0.ItemCode,t0.SysNumber ,t0.DistNumber
Public method | GetItemsToRestoreItemDetails | ItemCode
Public method | GetItemsToRestoreItemDetailsInventory |
Public method | GetMinClosingDateForMor |
Public method | GetMissingBatchesForProdReceipt | t0.U_BnStatus ,t3.U_Description,t5.DocEntry [BaseEntry] ,t5.DocType [BaseType], t1.*
Public method | GetMorBranch |
Public method | GetMorLinesToUnlock |
Public method | GetOpenSalesOrderForItems |
Public method | GetOprNamesForCodes | gets ocr codes an names
Public method | GetProductionAccounts |
Public method | GetResourceBookedTime |
Public method | GetResourceBookedTimeByType |
Public method | GetResourceWIPAcct | "WipAcct"
Public method | GetRevisionFromGoodsReceiptDoc |
Public method | GetRevisionFromGoodsReceiptPODoc |
Public method | GetSerialNumberQuantity |
Public method | GetSeriesNameForJE | T0.SeriesName
Public method | GetSubstituteItems |
Public method | GetSubstituteRatio |
Public method | GetSubstituteRevision |
Public method | GetSumFreeBatchItems |
Public method | GetSumFreeItems |
Public method | GetSumFreeSerialItems |
Public method | GetTableColumns |
Public method | GetTransValueFormOITM | "TransType", "CreatedBy", BASE_REF, "DocLineNum", SUM("TransValue") AS "TransValue", SUM("InQty"), SUM("OutQty"), "Price", "CardCode", "ItemCode", "Warehouse"
Public method | GetTypesOfListOfFields |
Public method | GetUpdatePaymentDocumentAdditionalJournalEntries | t0."DocNum" AS "Numer dokumentu", t0."Canceled", IFNULL(t1."TransId", 0) AS "Transakcja bazowa", IFNULL(t2."TransId", 0) AS "Anulowanie", IFNULL(t3."TransId", 0) AS "Roliczenie transakcji bazowej", IFNULL(t4."TransId", 0) AS "Rozliczenie anulowania"
Public method | GetWhsInfo |
Public method | GetWhsJournal | T0.TransType, T0.CreatedBy, T0.BASE_REF, T0.DocLineNum, T0.DocDate, T0.Allocation, T0.CardCode, T0.CardName, T0.JrnlMemo, T0.DocTime, T0.ItemCode, T0.Dscription, SUM(T0.InQty) AS 'InQty', SUM(T0.OutQty) AS 'OutQty', T0.Price, T0.Currency, T0.Warehouse, T0.TaxDate, T0.UserSign, SUM(T0.TransValue) AS 'TransValue', T0.InvntAct, OcrCode, OcrCode2, OcrCode3, OcrCode4, OcrCode5, PrjCode
Public method | GetYieldForResource |
Public method | IsPahtomMaterial |
Public method | IsThereAnyResourceWithRunTimeZeroAtBom |
Public method | IsThereAnyResourceWithRunTimeZeroAtMor |
Public method | MORItemsValuationMethodValidation |
Public method | MORUpdateValuesAddition |
Public method | MORUpdateValuesSubstraction |
Public method | MorReferencesToRemove |
Public method | OperationAdjustmentTimeRecordingBookings |
Public method | OperationTimeRecordingBookings |
Public method | PickOrdersNotToClose |
Public method | PickReceiptNotToClose |
Public method | ReplicateBatchDetails |
Public method | RestoreAutoCloseTask |
Public method | RestoreBatchDetails |
Public method | UpdateItemDescOnBOM |
Public method | UpdateItemDescOnBOMAll |
Top
See Also

Reference

ISystemQueries Interface
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.EnablePostResourceConfirmation Method

Determines whether or not the Post Resources Confirmation checkbox must be enabled on the General Settings form.

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function EnablePostResourceConfirmation( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset EnablePostResourceConfirmation(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ EnablePostResourceConfirmation(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function EnablePostResourceConfirmation(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Token.

Return Value

Type: CTRecordset

Int32 object.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.FindBatchTampate Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function FindBatchTampate( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset FindBatchTampate(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ FindBatchTampate(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function FindBatchTampate(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.FindSerialTemplate Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function FindSerialTemplate( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset FindSerialTemplate(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ FindSerialTemplate(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function FindSerialTemplate(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetAdtJeForCompicatedTypes Method

"PmntID", "ObjCrtType"

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAdtJeForCompicatedTypes( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetAdtJeForCompicatedTypes(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetAdtJeForCompicatedTypes(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetAdtJeForCompicatedTypes(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetAllResourcesFromMOR16ThatAreInactive Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAllResourcesFromMOR16ThatAreInactive( _
   ByVal Token As String, _
   ByVal docEntries As List(Of Integer) _
) As List(Of Tuple(Of Integer, Integer))
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<Tuple<int, int>> GetAllResourcesFromMOR16ThatAreInactive(
   string Token,
   List<int> docEntries
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

List<Tuple<int, int>^>^ GetAllResourcesFromMOR16ThatAreInactive(
   String^ Token,
   List<int>^ docEntries
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

docEntries

Type: List<int>

Return Value

Type: List<Tuple<int, int>>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetAlreadyDefinedAdditionaBatchDetails Method

t0."ItemCode",t0."SysNumber"

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAlreadyDefinedAdditionaBatchDetails( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal SysNumber As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetAlreadyDefinedAdditionaBatchDetails(
   string Token,
   string ItemCode,
   int SysNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetAlreadyDefinedAdditionaBatchDetails(
   String^ Token,
   String^ ItemCode,
   int SysNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetAlreadyDefinedAdditionaBatchDetails(
    Token : String,
    ItemCode : String,
    SysNumber : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

SysNumber

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetBaseTypeForbatch Method

top 1 t0."DocEntry", t0."DocType" ,isnull(t2."DocEntry",0) "MnfDocEntry",ISNULL(t3."U_Revision",'') "Revision",ISNULL(t4."U_Description",'')

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetBaseTypeForbatch( _
   ByVal Token As String, _
   ByVal ItemCoe As String, _
   ByVal SysNumber As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetBaseTypeForbatch(
   string Token,
   string ItemCoe,
   int SysNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetBaseTypeForbatch(
   String^ Token,
   String^ ItemCoe,
   int SysNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetBaseTypeForbatch(
    Token : String,
    ItemCoe : String,
    SysNumber : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCoe

Type: string

SysNumber

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetBatchAllDetails Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetBatchAllDetails( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal DistNumber As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetBatchAllDetails(
   string Token,
   string ItemCode,
   string DistNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetBatchAllDetails(
   String^ Token,
   String^ ItemCode,
   String^ DistNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetBatchAllDetails(
    Token : String,
    ItemCode : String,
    DistNumber : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

DistNumber

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetBatchQuantity Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetBatchQuantity( _
   ByVal token As String, _
   ByVal ItemCode As String, _
   ByVal DistNumber As String _
) As Dictionary(Of String, Double)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Dictionary<string, double> GetBatchQuantity(
   string token,
   string ItemCode,
   string DistNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Dictionary<String^, double>^ GetBatchQuantity(
   String^ token,
   String^ ItemCode,
   String^ DistNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

ItemCode

Type: string

DistNumber

Type: string

Return Value

Type: Dictionary<string, double>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetBatchSerialDocumentInfo Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetBatchSerialDocumentInfo( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal DocType As Integer, _
   ByVal DocLine As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetBatchSerialDocumentInfo(
   string Token,
   int DocEntry,
   int DocType,
   int DocLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetBatchSerialDocumentInfo(
   String^ Token,
   int DocEntry,
   int DocType,
   int DocLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetBatchSerialDocumentInfo(
    Token : String,
    DocEntry : int,
    DocType : int,
    DocLine : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

DocType

Type: int

DocLine

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetBatchTemplateDetails Method

isnull("U_Expiry",'N')"U_Expiry", ISNULL("U_ShelfTime",'0d')"U_ShelfTime",isnull("U_Consume",'N')"U_Consume" ,ISNULL("U_ConsWarn",0) "U_ConsWarn",ISNULL("U_ExpWarn",0)"U_ExpWarn", isnull("U_InspDays",0)"U_InspDays"

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetBatchTemplateDetails( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetBatchTemplateDetails(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetBatchTemplateDetails(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetBatchTemplateDetails(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetBatchesInFEFOOrder Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetBatchesInFEFOOrder( _
   ByVal token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String, _
   ByVal revision As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetBatchesInFEFOOrder(
   string token,
   string ItemCode,
   string WhsCode,
   string revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetBatchesInFEFOOrder(
   String^ token,
   String^ ItemCode,
   String^ WhsCode,
   String^ revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetBatchesInFEFOOrder(
    token : String,
    ItemCode : String,
    WhsCode : String,
    revision : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

ItemCode

Type: string

WhsCode

Type: string

revision

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetBatchesInFMFOOrder Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetBatchesInFMFOOrder( _
   ByVal token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String, _
   ByVal revision As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetBatchesInFMFOOrder(
   string token,
   string ItemCode,
   string WhsCode,
   string revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetBatchesInFMFOOrder(
   String^ token,
   String^ ItemCode,
   String^ WhsCode,
   String^ revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetBatchesInFMFOOrder(
    token : String,
    ItemCode : String,
    WhsCode : String,
    revision : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

ItemCode

Type: string

WhsCode

Type: string

revision

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetBatchesToCreateAddtitemCodes Method

t0."ItemCode" , t1."SysNumber" ,ifnull(t3."U_Revision",'') "Revision",ifnull(t3."U_RevisionName",'') "RevisionName"

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetBatchesToCreateAddtitemCodes( _
   ByVal Toke As String, _
   ByVal DocEntry As Integer, _
   ByVal docType As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetBatchesToCreateAddtitemCodes(
   string Toke,
   int DocEntry,
   int docType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetBatchesToCreateAddtitemCodes(
   String^ Toke,
   int DocEntry,
   int docType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetBatchesToCreateAddtitemCodes(
    Toke : String,
    DocEntry : int,
    docType : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Toke

Type: string

DocEntry

Type: int

docType

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetBranchesForBOMS Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetBranchesForBOMS( _
   ByVal Token As String, _
   ByVal bomcodes As IList(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetBranchesForBOMS(
   string Token,
   IList<string> bomcodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetBranchesForBOMS(
   String^ Token,
   IList<String^>^ bomcodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

bomcodes

Type: IList<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetBranchesForBOMSBacflush Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetBranchesForBOMSBacflush( _
   ByVal Token As String, _
   ByVal bomcodes As IList(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetBranchesForBOMSBacflush(
   string Token,
   IList<string> bomcodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetBranchesForBOMSBacflush(
   String^ Token,
   IList<String^>^ bomcodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

bomcodes

Type: IList<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetCostCentres Method

T1.OcrCode, T0.U_CT_Acct5, T0.U_CT_ContrAcct, T1.PrcAmount, T1.OcrTotal

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetCostCentres( _
   ByVal Token As String, _
   ByVal ocrCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetCostCentres(
   string Token,
   string ocrCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetCostCentres(
   String^ Token,
   String^ ocrCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetCostCentres(
    Token : String,
    ocrCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ocrCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetCostForResourceLine Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetCostForResourceLine( _
   ByVal Token As String, _
   ByVal BaseLineNum As Integer, _
   ByVal BaseEntry As Integer, _
   ByVal WorkingHours As Double, _
   ByVal TimeType As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetCostForResourceLine(
   string Token,
   int BaseLineNum,
   int BaseEntry,
   double WorkingHours,
   string TimeType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetCostForResourceLine(
   String^ Token,
   int BaseLineNum,
   int BaseEntry,
   double WorkingHours,
   String^ TimeType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetCostForResourceLine(
    Token : String,
    BaseLineNum : int,
    BaseEntry : int,
    WorkingHours : double,
    TimeType : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

BaseLineNum

Type: int

BaseEntry

Type: int

WorkingHours

Type: double

TimeType

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetCountiresList Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetCountiresList( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetCountiresList(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetCountiresList(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetCountiresList(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetCountryCode Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetCountryCode( _
   ByVal Token As String, _
   ByVal CountryName As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string GetCountryCode(
   string Token,
   string CountryName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

String^ GetCountryCode(
   String^ Token,
   String^ CountryName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetCountryCode(
    Token : String,
    CountryName : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

CountryName

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetCountryName Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetCountryName( _
   ByVal Token As String, _
   ByVal CountryCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string GetCountryName(
   string Token,
   string CountryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

String^ GetCountryName(
   String^ Token,
   String^ CountryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetCountryName(
    Token : String,
    CountryCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

CountryCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetDataForRestoreAdditionaBatchDetails Method

returns data erquired for batch details restoration

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetDataForRestoreAdditionaBatchDetails( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetDataForRestoreAdditionaBatchDetails(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetDataForRestoreAdditionaBatchDetails(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetDataForRestoreAdditionaBatchDetails(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetDefaultValueForField Method

t0."Dflt", t0."Descr", COUNT(t1."TableID") as "Count", t0."TableID", t0."FieldID", t0."EditType"

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetDefaultValueForField( _
   ByVal token As String, _
   ByVal TableID As String, _
   ByVal AliasID As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetDefaultValueForField(
   string token,
   string TableID,
   string AliasID
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetDefaultValueForField(
   String^ token,
   String^ TableID,
   String^ AliasID
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetDefaultValueForField(
    token : String,
    TableID : String,
    AliasID : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

TableID

Type: string

AliasID

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetDefaultValueForFields Method

t0."Dflt", t0."Descr", t0."TableID", t0."FieldID", t0."EditType", 'U_' || t0."AliasID" AS "AliasID", t0."EditSize"

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetDefaultValueForFields( _
   ByVal token As String, _
   ByVal TableID As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetDefaultValueForFields(
   string token,
   string TableID
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetDefaultValueForFields(
   String^ token,
   String^ TableID
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetDefaultValueForFields(
    token : String,
    TableID : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

TableID

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetDynamicCostForReceipt Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetDynamicCostForReceipt( _
   ByVal Token As String, _
   ByVal MorEntry As Integer, _
   ByVal ItemBackFlushEntry As Integer, _
   ByVal CPSCRDocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetDynamicCostForReceipt(
   string Token,
   int MorEntry,
   int ItemBackFlushEntry,
   int CPSCRDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetDynamicCostForReceipt(
   String^ Token,
   int MorEntry,
   int ItemBackFlushEntry,
   int CPSCRDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetDynamicCostForReceipt(
    Token : String,
    MorEntry : int,
    ItemBackFlushEntry : int,
    CPSCRDocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

MorEntry

Type: int

ItemBackFlushEntry

Type: int

CPSCRDocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetExpiryDateTemplate Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetExpiryDateTemplate( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetExpiryDateTemplate(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetExpiryDateTemplate(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetExpiryDateTemplate(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetExpiryDateType Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetExpiryDateType( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetExpiryDateType(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetExpiryDateType(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetExpiryDateType(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetFifoLayersForCorrection Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetFifoLayersForCorrection( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal OperType As String, _
   ByVal OperEntry As Integer, _
   ByVal OperLine As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetFifoLayersForCorrection(
   string Token,
   int DocEntry,
   string OperType,
   int OperEntry,
   int OperLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetFifoLayersForCorrection(
   String^ Token,
   int DocEntry,
   String^ OperType,
   int OperEntry,
   int OperLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetFifoLayersForCorrection(
    Token : String,
    DocEntry : int,
    OperType : String,
    OperEntry : int,
    OperLine : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

OperType

Type: string

OperEntry

Type: int

OperLine

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetFirstBOMToOpen Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetFirstBOMToOpen( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetFirstBOMToOpen(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetFirstBOMToOpen(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetFirstBOMToOpen(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetFreeBatchItems Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetFreeBatchItems( _
   ByVal Token As String, _
   ByVal itemcode As String, _
   ByVal whsCode As String, _
   ByVal revision As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetFreeBatchItems(
   string Token,
   string itemcode,
   string whsCode,
   string revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetFreeBatchItems(
   String^ Token,
   String^ itemcode,
   String^ whsCode,
   String^ revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetFreeBatchItems(
    Token : String,
    itemcode : String,
    whsCode : String,
    revision : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemcode

Type: string

whsCode

Type: string

revision

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetFreeItems Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetFreeItems( _
   ByVal Token As String, _
   ByVal itemcode As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetFreeItems(
   string Token,
   string itemcode,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetFreeItems(
   String^ Token,
   String^ itemcode,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetFreeItems(
    Token : String,
    itemcode : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemcode

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetFreeSerialItems Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetFreeSerialItems( _
   ByVal Token As String, _
   ByVal itemcode As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetFreeSerialItems(
   string Token,
   string itemcode,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetFreeSerialItems(
   String^ Token,
   String^ itemcode,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetFreeSerialItems(
    Token : String,
    itemcode : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemcode

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetGlobalBatchSettings Method

"U_SapDfQCS", "U_PFDfQCS", "U_PFDfBS", "U_SapDfBS"

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetGlobalBatchSettings( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetGlobalBatchSettings(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetGlobalBatchSettings(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetGlobalBatchSettings(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetItemBatchQueue Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetItemBatchQueue( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetItemBatchQueue(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetItemBatchQueue(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetItemBatchQueue(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetItemDetailsExistsForBatch Method

t0.ItemCode,t0.SysNumber ,t0.DistNumber

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetItemDetailsExistsForBatch( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal SysNumber As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetItemDetailsExistsForBatch(
   string Token,
   string ItemCode,
   int SysNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetItemDetailsExistsForBatch(
   String^ Token,
   String^ ItemCode,
   int SysNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetItemDetailsExistsForBatch(
    Token : String,
    ItemCode : String,
    SysNumber : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

SysNumber

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetItemsToRestoreItemDetails Method

ItemCode

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetItemsToRestoreItemDetails( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetItemsToRestoreItemDetails(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetItemsToRestoreItemDetails(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetItemsToRestoreItemDetails(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetItemsToRestoreItemDetailsInventory Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetItemsToRestoreItemDetailsInventory( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetItemsToRestoreItemDetailsInventory(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetItemsToRestoreItemDetailsInventory(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetItemsToRestoreItemDetailsInventory(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetMinClosingDateForMor Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetMinClosingDateForMor( _
   ByVal Token As String, _
   ByVal Docentry As Integer _
) As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime GetMinClosingDateForMor(
   string Token,
   int Docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

DateTime GetMinClosingDateForMor(
   String^ Token,
   int Docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetMinClosingDateForMor(
    Token : String,
    Docentry : int
) : DateTime;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Docentry

Type: int

Return Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetMissingBatchesForProdReceipt Method

t0.U_BnStatus ,t3.U_Description,t5.DocEntry [BaseEntry] ,t5.DocType [BaseType], t1.*

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetMissingBatchesForProdReceipt( _
   ByVal Token As String, _
   ByVal PickOrderDocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetMissingBatchesForProdReceipt(
   string Token,
   int PickOrderDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetMissingBatchesForProdReceipt(
   String^ Token,
   int PickOrderDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetMissingBatchesForProdReceipt(
    Token : String,
    PickOrderDocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

PickOrderDocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetMorBranch Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetMorBranch( _
   ByVal Token As String, _
   ByVal DocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetMorBranch(
   string Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetMorBranch(
   String^ Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetMorBranch(
    Token : String,
    DocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetMorLinesToUnlock Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetMorLinesToUnlock( _
   ByVal Token As String, _
   ByVal docentrys As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetMorLinesToUnlock(
   string Token,
   IEnumerable<int> docentrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetMorLinesToUnlock(
   String^ Token,
   IEnumerable<int>^ docentrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

docentrys

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetOpenSalesOrderForItems Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetOpenSalesOrderForItems( _
   ByVal Token As String, _
   ByVal Items As IEnumerable(Of String) _
) As List(Of Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<int> GetOpenSalesOrderForItems(
   string Token,
   IEnumerable<string> Items
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

List<int>^ GetOpenSalesOrderForItems(
   String^ Token,
   IEnumerable<String^>^ Items
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

Items

Type: IEnumerable<string>

Return Value

Type: List<int>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetOprNamesForCodes Method

gets ocr codes an names

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetOprNamesForCodes( _
   ByVal token As String, _
   ByVal ocrCodes As IEnumerable(Of String) _
) As Dictionary(Of String, String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Dictionary<string, string> GetOprNamesForCodes(
   string token,
   IEnumerable<string> ocrCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Dictionary<String^, String^>^ GetOprNamesForCodes(
   String^ token,
   IEnumerable<String^>^ ocrCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

ocrCodes

Type: IEnumerable<string>

Return Value

Type: Dictionary<string, string>

dictionary key - ocr code, value - ocr name

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetProductionAccounts Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetProductionAccounts( _
   ByVal Token As String, _
   ByVal ParentItemCode As String, _
   ByVal ParentWhsCode As String, _
   ByVal ComponentItemCode As String, _
   ByVal ComponentWhsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetProductionAccounts(
   string Token,
   string ParentItemCode,
   string ParentWhsCode,
   string ComponentItemCode,
   string ComponentWhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetProductionAccounts(
   String^ Token,
   String^ ParentItemCode,
   String^ ParentWhsCode,
   String^ ComponentItemCode,
   String^ ComponentWhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetProductionAccounts(
    Token : String,
    ParentItemCode : String,
    ParentWhsCode : String,
    ComponentItemCode : String,
    ComponentWhsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ParentItemCode

Type: string

ParentWhsCode

Type: string

ComponentItemCode

Type: string

ComponentWhsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetResourceBookedTime Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetResourceBookedTime( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal LineNums As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetResourceBookedTime(
   string Token,
   int DocEntry,
   IEnumerable<int> LineNums
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetResourceBookedTime(
   String^ Token,
   int DocEntry,
   IEnumerable<int>^ LineNums
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

LineNums

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetResourceBookedTimeByType Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetResourceBookedTimeByType( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal LineNums As IEnumerable(Of Integer), _
   ByVal Type As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetResourceBookedTimeByType(
   string Token,
   int DocEntry,
   IEnumerable<int> LineNums,
   string Type
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetResourceBookedTimeByType(
   String^ Token,
   int DocEntry,
   IEnumerable<int>^ LineNums,
   String^ Type
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

LineNums

Type: IEnumerable<int>

Type

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetResourceWIPAcct Method

"WipAcct"

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetResourceWIPAcct( _
   ByVal Token As String, _
   ByVal BaseEntry As Integer, _
   ByVal BaseLine As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetResourceWIPAcct(
   string Token,
   int BaseEntry,
   int BaseLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetResourceWIPAcct(
   String^ Token,
   int BaseEntry,
   int BaseLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetResourceWIPAcct(
    Token : String,
    BaseEntry : int,
    BaseLine : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

BaseEntry

Type: int

BaseLine

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetRevisionFromGoodsReceiptDoc Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetRevisionFromGoodsReceiptDoc( _
   ByVal Token As String, _
   ByVal DocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetRevisionFromGoodsReceiptDoc(
   string Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetRevisionFromGoodsReceiptDoc(
   String^ Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetRevisionFromGoodsReceiptDoc(
    Token : String,
    DocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetRevisionFromGoodsReceiptPODoc Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetRevisionFromGoodsReceiptPODoc( _
   ByVal Token As String, _
   ByVal DocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetRevisionFromGoodsReceiptPODoc(
   string Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetRevisionFromGoodsReceiptPODoc(
   String^ Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetRevisionFromGoodsReceiptPODoc(
    Token : String,
    DocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetSerialNumberQuantity Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetSerialNumberQuantity( _
   ByVal token As String, _
   ByVal ItemCode As String, _
   ByVal SysNumber As Integer _
) As Dictionary(Of String, Double)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Dictionary<string, double> GetSerialNumberQuantity(
   string token,
   string ItemCode,
   int SysNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Dictionary<String^, double>^ GetSerialNumberQuantity(
   String^ token,
   String^ ItemCode,
   int SysNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

ItemCode

Type: string

SysNumber

Type: int

Return Value

Type: Dictionary<string, double>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetSeriesNameForJE Method

T0.SeriesName

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetSeriesNameForJE( _
   ByVal Token As String, _
   ByVal TransId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetSeriesNameForJE(
   string Token,
   int TransId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetSeriesNameForJE(
   String^ Token,
   int TransId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetSeriesNameForJE(
    Token : String,
    TransId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

TransId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetSubstituteItems Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetSubstituteItems( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal Revision As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetSubstituteItems(
   string Token,
   string ItemCode,
   string Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetSubstituteItems(
   String^ Token,
   String^ ItemCode,
   String^ Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetSubstituteItems(
    Token : String,
    ItemCode : String,
    Revision : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Revision

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetSubstituteRatio Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetSubstituteRatio( _
   ByVal Token As String, _
   ByVal originalItemCode As String, _
   ByVal originalRevision As String, _
   ByVal ReplacementItemCode As String, _
   ByVal ReplacementRevision As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetSubstituteRatio(
   string Token,
   string originalItemCode,
   string originalRevision,
   string ReplacementItemCode,
   string ReplacementRevision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetSubstituteRatio(
   String^ Token,
   String^ originalItemCode,
   String^ originalRevision,
   String^ ReplacementItemCode,
   String^ ReplacementRevision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetSubstituteRatio(
    Token : String,
    originalItemCode : String,
    originalRevision : String,
    ReplacementItemCode : String,
    ReplacementRevision : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

originalItemCode

Type: string

originalRevision

Type: string

ReplacementItemCode

Type: string

ReplacementRevision

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetSubstituteRevision Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetSubstituteRevision( _
   ByVal Token As String, _
   ByVal originalItemCode As String, _
   ByVal originalRevision As String, _
   ByVal ReplacementItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetSubstituteRevision(
   string Token,
   string originalItemCode,
   string originalRevision,
   string ReplacementItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetSubstituteRevision(
   String^ Token,
   String^ originalItemCode,
   String^ originalRevision,
   String^ ReplacementItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetSubstituteRevision(
    Token : String,
    originalItemCode : String,
    originalRevision : String,
    ReplacementItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

originalItemCode

Type: string

originalRevision

Type: string

ReplacementItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetSumFreeBatchItems Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetSumFreeBatchItems( _
   ByVal Token As String, _
   ByVal itemcode As String, _
   ByVal revision As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetSumFreeBatchItems(
   string Token,
   string itemcode,
   string revision,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetSumFreeBatchItems(
   String^ Token,
   String^ itemcode,
   String^ revision,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetSumFreeBatchItems(
    Token : String,
    itemcode : String,
    revision : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemcode

Type: string

revision

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetSumFreeItems Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetSumFreeItems( _
   ByVal Token As String, _
   ByVal itemcode As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetSumFreeItems(
   string Token,
   string itemcode,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetSumFreeItems(
   String^ Token,
   String^ itemcode,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetSumFreeItems(
    Token : String,
    itemcode : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemcode

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetSumFreeSerialItems Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetSumFreeSerialItems( _
   ByVal Token As String, _
   ByVal itemcode As String, _
   ByVal whsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetSumFreeSerialItems(
   string Token,
   string itemcode,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetSumFreeSerialItems(
   String^ Token,
   String^ itemcode,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetSumFreeSerialItems(
    Token : String,
    itemcode : String,
    whsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemcode

Type: string

whsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetTableColumns Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetTableColumns( _
   ByVal Token As String, _
   ByVal TableID As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetTableColumns(
   string Token,
   string TableID
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetTableColumns(
   String^ Token,
   String^ TableID
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetTableColumns(
    Token : String,
    TableID : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

TableID

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetTransValueFormOITM Method

"TransType", "CreatedBy", BASE_REF, "DocLineNum", SUM("TransValue") AS "TransValue", SUM("InQty"), SUM("OutQty"), "Price", "CardCode", "ItemCode", "Warehouse"

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetTransValueFormOITM( _
   ByVal Token As String, _
   ByVal CreatedBy As Integer, _
   ByVal TransType As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetTransValueFormOITM(
   string Token,
   int CreatedBy,
   string TransType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetTransValueFormOITM(
   String^ Token,
   int CreatedBy,
   String^ TransType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetTransValueFormOITM(
    Token : String,
    CreatedBy : int,
    TransType : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

CreatedBy

Type: int

TransType

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetTypesOfListOfFields Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetTypesOfListOfFields( _
   ByVal token As String, _
   ByVal TableID As String, _
   ByVal aliases As List(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetTypesOfListOfFields(
   string token,
   string TableID,
   List<string> aliases
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetTypesOfListOfFields(
   String^ token,
   String^ TableID,
   List<String^>^ aliases
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

TableID

Type: string

aliases

Type: List<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetUpdatePaymentDocumentAdditionalJournalEntries Method

t0."DocNum" AS "Numer dokumentu", t0."Canceled", IFNULL(t1."TransId", 0) AS "Transakcja bazowa", IFNULL(t2."TransId", 0) AS "Anulowanie", IFNULL(t3."TransId", 0) AS "Roliczenie transakcji bazowej", IFNULL(t4."TransId", 0) AS "Rozliczenie anulowania"

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetUpdatePaymentDocumentAdditionalJournalEntries( _
   ByVal Token As String, _
   ByVal TableName As String, _
   ByVal DocNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetUpdatePaymentDocumentAdditionalJournalEntries(
   string Token,
   string TableName,
   int DocNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetUpdatePaymentDocumentAdditionalJournalEntries(
   String^ Token,
   String^ TableName,
   int DocNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetUpdatePaymentDocumentAdditionalJournalEntries(
    Token : String,
    TableName : String,
    DocNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

TableName

Type: string

DocNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetWhsInfo Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetWhsInfo( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetWhsInfo(
   string Token,
   string ItemCode,
   string WhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetWhsInfo(
   String^ Token,
   String^ ItemCode,
   String^ WhsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetWhsInfo(
    Token : String,
    ItemCode : String,
    WhsCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

WhsCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetWhsJournal Method

T0.TransType, T0.CreatedBy, T0.BASE_REF, T0.DocLineNum, T0.DocDate, T0.Allocation, T0.CardCode, T0.CardName, T0.JrnlMemo, T0.DocTime, T0.ItemCode, T0.Dscription, SUM(T0.InQty) AS 'InQty', SUM(T0.OutQty) AS 'OutQty', T0.Price, T0.Currency, T0.Warehouse, T0.TaxDate, T0.UserSign, SUM(T0.TransValue) AS 'TransValue', T0.InvntAct, OcrCode, OcrCode2, OcrCode3, OcrCode4, OcrCode5, PrjCode

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetWhsJournal( _
   ByVal Tokne As String, _
   ByVal TransType As String, _
   ByVal DocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetWhsJournal(
   string Tokne,
   string TransType,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetWhsJournal(
   String^ Tokne,
   String^ TransType,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetWhsJournal(
    Tokne : String,
    TransType : String,
    DocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Tokne

Type: string

TransType

Type: string

DocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.GetYieldForResource Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetYieldForResource( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal LineNum As Integer _
) As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double GetYieldForResource(
   string Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

double GetYieldForResource(
   String^ Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetYieldForResource(
    Token : String,
    DocEntry : int,
    LineNum : int
) : double;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

LineNum

Type: int

Return Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.IsPahtomMaterial Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function IsPahtomMaterial( _
   ByVal Token As String, _
   ByVal itemCode As String, _
   ByVal revison As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool IsPahtomMaterial(
   string Token,
   string itemCode,
   string revison
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool IsPahtomMaterial(
   String^ Token,
   String^ itemCode,
   String^ revison
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function IsPahtomMaterial(
    Token : String,
    itemCode : String,
    revison : String
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemCode

Type: string

revison

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.IsThereAnyResourceWithRunTimeZeroAtBom Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function IsThereAnyResourceWithRunTimeZeroAtBom( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset IsThereAnyResourceWithRunTimeZeroAtBom(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ IsThereAnyResourceWithRunTimeZeroAtBom(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function IsThereAnyResourceWithRunTimeZeroAtBom(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.IsThereAnyResourceWithRunTimeZeroAtMor Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function IsThereAnyResourceWithRunTimeZeroAtMor( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset IsThereAnyResourceWithRunTimeZeroAtMor(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ IsThereAnyResourceWithRunTimeZeroAtMor(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function IsThereAnyResourceWithRunTimeZeroAtMor(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.MORItemsValuationMethodValidation Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function MORItemsValuationMethodValidation( _
   ByVal Token As String, _
   ByVal itemcodes As IEnumerable(Of String) _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string MORItemsValuationMethodValidation(
   string Token,
   IEnumerable<string> itemcodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

String^ MORItemsValuationMethodValidation(
   String^ Token,
   IEnumerable<String^>^ itemcodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemcodes

Type: IEnumerable<string>

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.MORUpdateValuesAddition Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function MORUpdateValuesAddition( _
   ByVal Token As String, _
   ByVal DocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset MORUpdateValuesAddition(
   string Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ MORUpdateValuesAddition(
   String^ Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function MORUpdateValuesAddition(
    Token : String,
    DocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.MORUpdateValuesSubstraction Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function MORUpdateValuesSubstraction( _
   ByVal Token As String, _
   ByVal DocEntry As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset MORUpdateValuesSubstraction(
   string Token,
   string DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ MORUpdateValuesSubstraction(
   String^ Token,
   String^ DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function MORUpdateValuesSubstraction(
    Token : String,
    DocEntry : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.MorReferencesToRemove Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function MorReferencesToRemove( _
   ByVal Token As String, _
   ByVal DocEntry As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset MorReferencesToRemove(
   string Token,
   string DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ MorReferencesToRemove(
   String^ Token,
   String^ DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function MorReferencesToRemove(
    Token : String,
    DocEntry : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.OperationAdjustmentTimeRecordingBookings Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function OperationAdjustmentTimeRecordingBookings( _
   ByVal Token As String, _
   ByVal WorkingHours As Double, _
   ByVal TimeType As String, _
   ByVal RscCode As String, _
   ByVal BaseLine As Integer, _
   ByVal BaseEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset OperationAdjustmentTimeRecordingBookings(
   string Token,
   double WorkingHours,
   string TimeType,
   string RscCode,
   int BaseLine,
   int BaseEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ OperationAdjustmentTimeRecordingBookings(
   String^ Token,
   double WorkingHours,
   String^ TimeType,
   String^ RscCode,
   int BaseLine,
   int BaseEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function OperationAdjustmentTimeRecordingBookings(
    Token : String,
    WorkingHours : double,
    TimeType : String,
    RscCode : String,
    BaseLine : int,
    BaseEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

WorkingHours

Type: double

TimeType

Type: string

RscCode

Type: string

BaseLine

Type: int

BaseEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.OperationTimeRecordingBookings Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function OperationTimeRecordingBookings( _
   ByVal Token As String, _
   ByVal WorkingHours As Double, _
   ByVal TimeType As String, _
   ByVal RscCode As String, _
   ByVal BaseLineNum As Integer, _
   ByVal BaseEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset OperationTimeRecordingBookings(
   string Token,
   double WorkingHours,
   string TimeType,
   string RscCode,
   int BaseLineNum,
   int BaseEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ OperationTimeRecordingBookings(
   String^ Token,
   double WorkingHours,
   String^ TimeType,
   String^ RscCode,
   int BaseLineNum,
   int BaseEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function OperationTimeRecordingBookings(
    Token : String,
    WorkingHours : double,
    TimeType : String,
    RscCode : String,
    BaseLineNum : int,
    BaseEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

WorkingHours

Type: double

TimeType

Type: string

RscCode

Type: string

BaseLineNum

Type: int

BaseEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.PickOrdersNotToClose Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function PickOrdersNotToClose( _
   ByVal Token As String, _
   ByVal MorEntry As Integer, _
   ByVal PorDocEntry As IEnumerable(Of Integer) _
) As List(Of Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<int> PickOrdersNotToClose(
   string Token,
   int MorEntry,
   IEnumerable<int> PorDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

List<int>^ PickOrdersNotToClose(
   String^ Token,
   int MorEntry,
   IEnumerable<int>^ PorDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

MorEntry

Type: int

PorDocEntry

Type: IEnumerable<int>

Return Value

Type: List<int>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.PickReceiptNotToClose Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function PickReceiptNotToClose( _
   ByVal Token As String, _
   ByVal MorEntry As Integer, _
   ByVal PorDocEntry As IEnumerable(Of Integer) _
) As List(Of Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<int> PickReceiptNotToClose(
   string Token,
   int MorEntry,
   IEnumerable<int> PorDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

List<int>^ PickReceiptNotToClose(
   String^ Token,
   int MorEntry,
   IEnumerable<int>^ PorDocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

MorEntry

Type: int

PorDocEntry

Type: IEnumerable<int>

Return Value

Type: List<int>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.ReplicateBatchDetails Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function ReplicateBatchDetails( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset ReplicateBatchDetails(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ ReplicateBatchDetails(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function ReplicateBatchDetails(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.RestoreAutoCloseTask Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub RestoreAutoCloseTask( _
   ByVal Token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void RestoreAutoCloseTask(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void RestoreAutoCloseTask(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function RestoreAutoCloseTask(
    Token : String
);
This language is not supported or no code example is available.

Parameters

Token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.RestoreBatchDetails Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function RestoreBatchDetails( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset RestoreBatchDetails(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ RestoreBatchDetails(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function RestoreBatchDetails(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.UpdateItemDescOnBOM Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function UpdateItemDescOnBOM( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset UpdateItemDescOnBOM(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ UpdateItemDescOnBOM(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function UpdateItemDescOnBOM(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


ISystemQueries.UpdateItemDescOnBOMAll Method

Namespace: CompuTec.ProcessForce.API.Queries.SystemQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function UpdateItemDescOnBOMAll( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset UpdateItemDescOnBOMAll(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ UpdateItemDescOnBOMAll(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function UpdateItemDescOnBOMAll(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISystemQueries Interface
ISystemQueries Members
CompuTec.ProcessForce.API.Queries.SystemQueries Namespace


CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | BaseTechnologyQueries | Manages the base SQL queries for Technology functionality.
Public class | HANATechnologyQueries |
Public class | SQLTechnologyQueries |
Top
Interfaces
 | Name | Description
Public interface | ITechnologyQueries |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


BaseTechnologyQueries Class

Members See Also

Manages the base SQL queries for Technology functionality.

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BaseTechnologyQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BaseTechnologyQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BaseTechnologyQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BaseTechnologyQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.TechnologyQueries.BaseTechnologyQueries
CompuTec.ProcessForce.API.Queries.TechnologyQueries.HANATechnologyQueries
CompuTec.ProcessForce.API.Queries.TechnologyQueries.SQLTechnologyQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries Members

BaseTechnologyQueries Class Methods See Also

Manages the base SQL queries for Technology functionality.

The following tables list the members exposed by the BaseTechnologyQueries type.

Methods
 | Name | Description
Public method | BillOfMaterialExistsWithEmptyRevision |
Public method | CallCT_PF_CalculateWiPVariancesOnMORClose |
Public method | CheckIfLinkedToolsAreToolsTypes |
Public method | CheckIfThereIsResourceInNotClosedMor |
Public method | CreateManufacturingOrdersForSemiProducts |
Public method | CreateManufacturingOrdersForSemiProductsRows |
Public method | DeleteResourceCalendarHistory |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAllFormulaBasedOnItemCode |
Public method | GetAllFormulaYieldsBasedOnItemCode |
Public method | GetAltResourcesBasedOnMOR |
Public method | GetAlternativeResourcesFromOperationsGant |
Public method | GetAlternativeResourcesGant | (Overloaded)
Public method | GetAssignedOperations |
Public method | GetAsynchronousManufacturingOrders |
Public method | GetAvalibleRouting |
Public method | GetBillOfMaterialsOperations |
Public method | GetCodesForBomPhantoms |
Public method | GetCompleatedTime |
Public method | GetDocumentsWithAsynchronousHeaders |
Public method | GetDocumentsWithAsynchronousStatuses |
Public method | GetDoubledUnsynchronizedMOR_WOR |
Public method | GetDoubledUnsynchronizedMOR_WORTuple |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetLastCodeForBOM |
Public method | GetLineNumsForOperation |
Public method | GetManufacturingOrderDocEntries |
Public method | GetManufacturingOrderOperationDocEntries |
Public method | GetManufacturingOrderOperations |
Public method | GetManufacturingOrderRelatedSeries | Gets a collection of Manufacturing Order related numbering series.
Public method | GetManufacturingOrderRowsData |
Public method | GetManufacturingOrderSeries |
Public method | GetMatchingQualityControlTestIds |
Public method | GetMorRowDetails |
Public method | GetOpenedDownTimeForResources |
Public method | GetOperationAndResourceCodes |
Public method | GetOperationIOPropertyWordsCodes |
Public method | GetOperationPropertyWordsCodes |
Public method | GetOperationSequence |
Public method | GetOperationStatus |
Public method | GetProductionOrderRelatedSeries | Gets a collection of Production Order related numbering series.
Public method | GetProductionOrderRowsData |
Public method | GetProductionOrdersThatHaveIssuedItems | (Overloaded)
Public method | GetRelatedMorToSalesOrder |
Public method | GetResourcePropertyNames |
Public method | GetResourcePropertyWordsCodes |
Public method | GetResourceWordNames |
Public method | GetRevisonsForManufacturingOrder |
Public method | GetRoutingCodesAndNames |
Public method | GetSimpleManufacturingOrderDocEntries |
Public method | GetSimpleProductionPlanningCodes |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetUnsynchronizedMOR_WOR |
Public method | GetWholeCompleatedTime |
Public method | InsertResourceCalendarHistoryEntry |
Public method | IsInOutOperationPropertyUsed |
Public method | IsItemUsedInBillOfMaterialsHeader |
Public method | IsOperationPropertyUsed |
Public method | IsOperationUsed |
Public method | IsResourceUsed |
Public method | IsRoutingUsed |
Public method | IsSalesOrderAssignedToManufacturingOrder |
Public method | ManufacturingActualTasksQuery |
Public method | ManufacturingTimeBookingReportQuery |
Public method | RenameResourceHistoryCalendar |
Public method | RepairActiveAtMorResources |
Public method | RepairActiveAtMorResources2 |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | ValidateComponentsAgainstLoop |
Public method | ValidateCoproductsScraps |
Public method | ValidateItemNotUsedCoproductsScrap |
Top
See Also

Reference

BaseTechnologyQueries Class
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries Methods

BaseTechnologyQueries Class See Also

The following tables list the members exposed by the BaseTechnologyQueries type.

Methods
 | Name | Description
Public method | BillOfMaterialExistsWithEmptyRevision |
Public method | CallCT_PF_CalculateWiPVariancesOnMORClose |
Public method | CheckIfLinkedToolsAreToolsTypes |
Public method | CheckIfThereIsResourceInNotClosedMor |
Public method | CreateManufacturingOrdersForSemiProducts |
Public method | CreateManufacturingOrdersForSemiProductsRows |
Public method | DeleteResourceCalendarHistory |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAllFormulaBasedOnItemCode |
Public method | GetAllFormulaYieldsBasedOnItemCode |
Public method | GetAltResourcesBasedOnMOR |
Public method | GetAlternativeResourcesFromOperationsGant |
Public method | GetAlternativeResourcesGant | (Overloaded)
Public method | GetAssignedOperations |
Public method | GetAsynchronousManufacturingOrders |
Public method | GetAvalibleRouting |
Public method | GetBillOfMaterialsOperations |
Public method | GetCodesForBomPhantoms |
Public method | GetCompleatedTime |
Public method | GetDocumentsWithAsynchronousHeaders |
Public method | GetDocumentsWithAsynchronousStatuses |
Public method | GetDoubledUnsynchronizedMOR_WOR |
Public method | GetDoubledUnsynchronizedMOR_WORTuple |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetLastCodeForBOM |
Public method | GetLineNumsForOperation |
Public method | GetManufacturingOrderDocEntries |
Public method | GetManufacturingOrderOperationDocEntries |
Public method | GetManufacturingOrderOperations |
Public method | GetManufacturingOrderRelatedSeries | Gets a collection of Manufacturing Order related numbering series.
Public method | GetManufacturingOrderRowsData |
Public method | GetManufacturingOrderSeries |
Public method | GetMatchingQualityControlTestIds |
Public method | GetMorRowDetails |
Public method | GetOpenedDownTimeForResources |
Public method | GetOperationAndResourceCodes |
Public method | GetOperationIOPropertyWordsCodes |
Public method | GetOperationPropertyWordsCodes |
Public method | GetOperationSequence |
Public method | GetOperationStatus |
Public method | GetProductionOrderRelatedSeries | Gets a collection of Production Order related numbering series.
Public method | GetProductionOrderRowsData |
Public method | GetProductionOrdersThatHaveIssuedItems | (Overloaded)
Public method | GetRelatedMorToSalesOrder |
Public method | GetResourcePropertyNames |
Public method | GetResourcePropertyWordsCodes |
Public method | GetResourceWordNames |
Public method | GetRevisonsForManufacturingOrder |
Public method | GetRoutingCodesAndNames |
Public method | GetSimpleManufacturingOrderDocEntries |
Public method | GetSimpleProductionPlanningCodes |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetUnsynchronizedMOR_WOR |
Public method | GetWholeCompleatedTime |
Public method | InsertResourceCalendarHistoryEntry |
Public method | IsInOutOperationPropertyUsed |
Public method | IsItemUsedInBillOfMaterialsHeader |
Public method | IsOperationPropertyUsed |
Public method | IsOperationUsed |
Public method | IsResourceUsed |
Public method | IsRoutingUsed |
Public method | IsSalesOrderAssignedToManufacturingOrder |
Public method | ManufacturingActualTasksQuery |
Public method | ManufacturingTimeBookingReportQuery |
Public method | RenameResourceHistoryCalendar |
Public method | RepairActiveAtMorResources |
Public method | RepairActiveAtMorResources2 |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | ValidateComponentsAgainstLoop |
Public method | ValidateCoproductsScraps |
Public method | ValidateItemNotUsedCoproductsScrap |
Top
See Also

Reference

BaseTechnologyQueries Class
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.BillOfMaterialExistsWithEmptyRevision Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function BillOfMaterialExistsWithEmptyRevision( _
   ByVal token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset BillOfMaterialExistsWithEmptyRevision(
   string token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ BillOfMaterialExistsWithEmptyRevision(
   String^ token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BillOfMaterialExistsWithEmptyRevision(
    token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.CallCT_PF_CalculateWiPVariancesOnMORClose Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CallCT_PF_CalculateWiPVariancesOnMORClose( _
   ByVal Token As String, _
   ByVal DocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset CallCT_PF_CalculateWiPVariancesOnMORClose(
   string Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ CallCT_PF_CalculateWiPVariancesOnMORClose(
   String^ Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CallCT_PF_CalculateWiPVariancesOnMORClose(
    Token : String,
    DocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.CheckIfLinkedToolsAreToolsTypes Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CheckIfLinkedToolsAreToolsTypes( _
   ByVal token As String, _
   ByVal lst As IEnumerable(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset CheckIfLinkedToolsAreToolsTypes(
   string token,
   IEnumerable<string> lst
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ CheckIfLinkedToolsAreToolsTypes(
   String^ token,
   IEnumerable<String^>^ lst
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

lst

Type: IEnumerable<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.CheckIfThereIsResourceInNotClosedMor Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CheckIfThereIsResourceInNotClosedMor( _
   ByVal Token As String, _
   ByVal RscCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset CheckIfThereIsResourceInNotClosedMor(
   string Token,
   string RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ CheckIfThereIsResourceInNotClosedMor(
   String^ Token,
   String^ RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CheckIfThereIsResourceInNotClosedMor(
    Token : String,
    RscCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

RscCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.CreateManufacturingOrdersForSemiProducts Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CreateManufacturingOrdersForSemiProducts( _
   ByVal Token As String, _
   ByVal DocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset CreateManufacturingOrdersForSemiProducts(
   string Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ CreateManufacturingOrdersForSemiProducts(
   String^ Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CreateManufacturingOrdersForSemiProducts(
    Token : String,
    DocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.CreateManufacturingOrdersForSemiProductsRows Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CreateManufacturingOrdersForSemiProductsRows( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal rows As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset CreateManufacturingOrdersForSemiProductsRows(
   string Token,
   int DocEntry,
   IEnumerable<int> rows
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ CreateManufacturingOrdersForSemiProductsRows(
   String^ Token,
   int DocEntry,
   IEnumerable<int>^ rows
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

rows

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.DeleteResourceCalendarHistory Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function DeleteResourceCalendarHistory( _
   ByVal token As String, _
   ByVal resourceCode As String, _
   ByVal fromDate As Date _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset DeleteResourceCalendarHistory(
   string token,
   string resourceCode,
   DateTime fromDate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ DeleteResourceCalendarHistory(
   String^ token,
   String^ resourceCode,
   DateTime fromDate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DeleteResourceCalendarHistory(
    token : String,
    resourceCode : String,
    fromDate : DateTime
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

resourceCode

Type: string

fromDate

Type: DateTime

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetAllFormulaBasedOnItemCode Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAllFormulaBasedOnItemCode( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAllFormulaBasedOnItemCode(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAllFormulaBasedOnItemCode(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAllFormulaBasedOnItemCode(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetAllFormulaYieldsBasedOnItemCode Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAllFormulaYieldsBasedOnItemCode( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAllFormulaYieldsBasedOnItemCode(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAllFormulaYieldsBasedOnItemCode(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAllFormulaYieldsBasedOnItemCode(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetAltResourcesBasedOnMOR Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAltResourcesBasedOnMOR( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal LineID As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAltResourcesBasedOnMOR(
   string Token,
   int DocEntry,
   int LineID
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAltResourcesBasedOnMOR(
   String^ Token,
   int DocEntry,
   int LineID
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAltResourcesBasedOnMOR(
    Token : String,
    DocEntry : int,
    LineID : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

LineID

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetAlternativeResourcesFromOperationsGant Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAlternativeResourcesFromOperationsGant( _
   ByVal Token As String, _
   ByVal OprCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAlternativeResourcesFromOperationsGant(
   string Token,
   string OprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAlternativeResourcesFromOperationsGant(
   String^ Token,
   String^ OprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAlternativeResourcesFromOperationsGant(
    Token : String,
    OprCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

OprCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetAlternativeResourcesGant Method

BaseTechnologyQueries Class See Also

Overload List
Name | Description
GetAlternativeResourcesGant(string, string, string, int, string, string) |
GetAlternativeResourcesGant(string, string, string, int, string, string, string) |
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetAssignedOperations Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAssignedOperations( _
   ByVal token As String, _
   ByVal sppCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAssignedOperations(
   string token,
   string sppCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAssignedOperations(
   String^ token,
   String^ sppCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAssignedOperations(
    token : String,
    sppCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

sppCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetAsynchronousManufacturingOrders Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAsynchronousManufacturingOrders( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAsynchronousManufacturingOrders(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAsynchronousManufacturingOrders(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAsynchronousManufacturingOrders(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetAvalibleRouting Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAvalibleRouting( _
   ByVal Token As String, _
   ByVal itemcode As String, _
   ByVal revision As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAvalibleRouting(
   string Token,
   string itemcode,
   string revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAvalibleRouting(
   String^ Token,
   String^ itemcode,
   String^ revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAvalibleRouting(
    Token : String,
    itemcode : String,
    revision : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemcode

Type: string

revision

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetBillOfMaterialsOperations Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetBillOfMaterialsOperations( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetBillOfMaterialsOperations(
   string token,
   string itemCode,
   string revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetBillOfMaterialsOperations(
   String^ token,
   String^ itemCode,
   String^ revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetBillOfMaterialsOperations(
    token : String,
    itemCode : String,
    revCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetCodesForBomPhantoms Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetCodesForBomPhantoms( _
   ByVal Token As String _
) As List(Of String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<string> GetCodesForBomPhantoms(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<String^>^ GetCodesForBomPhantoms(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: List<string>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetCompleatedTime Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetCompleatedTime( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal LineNum As Integer, _
   ByVal TimeType As String, _
   ByVal RscCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetCompleatedTime(
   string Token,
   int DocEntry,
   int LineNum,
   string TimeType,
   string RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetCompleatedTime(
   String^ Token,
   int DocEntry,
   int LineNum,
   String^ TimeType,
   String^ RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetCompleatedTime(
    Token : String,
    DocEntry : int,
    LineNum : int,
    TimeType : String,
    RscCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

LineNum

Type: int

TimeType

Type: string

RscCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetDocumentsWithAsynchronousHeaders Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDocumentsWithAsynchronousHeaders( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDocumentsWithAsynchronousHeaders(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDocumentsWithAsynchronousHeaders(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDocumentsWithAsynchronousHeaders(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetDocumentsWithAsynchronousStatuses Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDocumentsWithAsynchronousStatuses( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetDocumentsWithAsynchronousStatuses(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetDocumentsWithAsynchronousStatuses(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDocumentsWithAsynchronousStatuses(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetDoubledUnsynchronizedMOR_WOR Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDoubledUnsynchronizedMOR_WOR( _
   ByVal Token As String _
) As List(Of Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<int> GetDoubledUnsynchronizedMOR_WOR(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<int>^ GetDoubledUnsynchronizedMOR_WOR(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: List<int>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetDoubledUnsynchronizedMOR_WORTuple Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDoubledUnsynchronizedMOR_WORTuple( _
   ByVal Token As String _
) As Dictionary(Of Integer, Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Dictionary<int, int> GetDoubledUnsynchronizedMOR_WORTuple(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Dictionary<int, int>^ GetDoubledUnsynchronizedMOR_WORTuple(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: Dictionary<int, int>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetLastCodeForBOM Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetLastCodeForBOM( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetLastCodeForBOM(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetLastCodeForBOM(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetLastCodeForBOM(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetLineNumsForOperation Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetLineNumsForOperation( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal LineNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetLineNumsForOperation(
   string Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetLineNumsForOperation(
   String^ Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetLineNumsForOperation(
    Token : String,
    DocEntry : int,
    LineNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

LineNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetManufacturingOrderDocEntries Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetManufacturingOrderDocEntries( _
   ByVal token As String, _
   ByVal series As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetManufacturingOrderDocEntries(
   string token,
   string series,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetManufacturingOrderDocEntries(
   String^ token,
   String^ series,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetManufacturingOrderDocEntries(
    token : String,
    series : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

series

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetManufacturingOrderOperationDocEntries Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetManufacturingOrderOperationDocEntries( _
   ByVal token As String, _
   ByVal series As Integer, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetManufacturingOrderOperationDocEntries(
   string token,
   int series,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetManufacturingOrderOperationDocEntries(
   String^ token,
   int series,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetManufacturingOrderOperationDocEntries(
    token : String,
    series : int,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

series

Type: int

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetManufacturingOrderOperations Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetManufacturingOrderOperations( _
   ByVal token As String, _
   ByVal docId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetManufacturingOrderOperations(
   string token,
   int docId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetManufacturingOrderOperations(
   String^ token,
   int docId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetManufacturingOrderOperations(
    token : String,
    docId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetManufacturingOrderRelatedSeries Method

Gets a collection of Manufacturing Order related numbering series.

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetManufacturingOrderRelatedSeries( _
   ByVal token As String _
) As Dictionary(Of String, String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Dictionary<string, string> GetManufacturingOrderRelatedSeries(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Dictionary<String^, String^>^ GetManufacturingOrderRelatedSeries(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

Token.

Return Value

Type: Dictionary<string, string>

A generic dictionary with numbering series as keys and description as values.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetManufacturingOrderRowsData Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetManufacturingOrderRowsData( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetManufacturingOrderRowsData(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetManufacturingOrderRowsData(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetManufacturingOrderRowsData(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetManufacturingOrderSeries Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetManufacturingOrderSeries( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetManufacturingOrderSeries(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetManufacturingOrderSeries(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetManufacturingOrderSeries(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetMatchingQualityControlTestIds Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetMatchingQualityControlTestIds( _
   ByVal token As String, _
   ByVal docId As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetMatchingQualityControlTestIds(
   string token,
   int docId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetMatchingQualityControlTestIds(
   String^ token,
   int docId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetMatchingQualityControlTestIds(
    token : String,
    docId : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docId

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetMorRowDetails Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetMorRowDetails( _
   ByVal Token As String, _
   ByVal ItemCodes As IEnumerable(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetMorRowDetails(
   string Token,
   IEnumerable<string> ItemCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetMorRowDetails(
   String^ Token,
   IEnumerable<String^>^ ItemCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCodes

Type: IEnumerable<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetOpenedDownTimeForResources Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetOpenedDownTimeForResources( _
   ByVal Token As String, _
   ByVal RscCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetOpenedDownTimeForResources(
   string Token,
   string RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetOpenedDownTimeForResources(
   String^ Token,
   String^ RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetOpenedDownTimeForResources(
    Token : String,
    RscCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

RscCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetOperationAndResourceCodes Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetOperationAndResourceCodes( _
   ByVal Token As String, _
   ByVal docEntry As Integer, _
   ByVal lineNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetOperationAndResourceCodes(
   string Token,
   int docEntry,
   int lineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetOperationAndResourceCodes(
   String^ Token,
   int docEntry,
   int lineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetOperationAndResourceCodes(
    Token : String,
    docEntry : int,
    lineNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

docEntry

Type: int

lineNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetOperationIOPropertyWordsCodes Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetOperationIOPropertyWordsCodes( _
   ByVal Token As String, _
   ByVal OprIOPrpCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetOperationIOPropertyWordsCodes(
   string Token,
   string OprIOPrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetOperationIOPropertyWordsCodes(
   String^ Token,
   String^ OprIOPrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetOperationIOPropertyWordsCodes(
    Token : String,
    OprIOPrpCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

OprIOPrpCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetOperationPropertyWordsCodes Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetOperationPropertyWordsCodes( _
   ByVal Token As String, _
   ByVal OprPrpCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetOperationPropertyWordsCodes(
   string Token,
   string OprPrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetOperationPropertyWordsCodes(
   String^ Token,
   String^ OprPrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetOperationPropertyWordsCodes(
    Token : String,
    OprPrpCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

OprPrpCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetOperationSequence Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetOperationSequence( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal LineNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetOperationSequence(
   string Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetOperationSequence(
   String^ Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetOperationSequence(
    Token : String,
    DocEntry : int,
    LineNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

LineNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetOperationStatus Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetOperationStatus( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal LineNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetOperationStatus(
   string Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetOperationStatus(
   String^ Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetOperationStatus(
    Token : String,
    DocEntry : int,
    LineNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

LineNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetProductionOrderRelatedSeries Method

Gets a collection of Production Order related numbering series.

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetProductionOrderRelatedSeries( _
   ByVal token As String _
) As Dictionary(Of String, String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Dictionary<string, string> GetProductionOrderRelatedSeries(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Dictionary<String^, String^>^ GetProductionOrderRelatedSeries(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

Token.

Return Value

Type: Dictionary<string, string>

A generic dictionary with numbering series as keys and description as values.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetProductionOrderRowsData Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetProductionOrderRowsData( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetProductionOrderRowsData(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetProductionOrderRowsData(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetProductionOrderRowsData(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetProductionOrdersThatHaveIssuedItems Method

BaseTechnologyQueries Class See Also

Overload List
Name | Description
GetProductionOrdersThatHaveIssuedItems(string) |
GetProductionOrdersThatHaveIssuedItems(string, int) |
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetRelatedMorToSalesOrder Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRelatedMorToSalesOrder( _
   ByVal Token As String, _
   ByVal SalesEntry As Integer, _
   ByVal ItemCode As String, _
   ByVal Revision As String, _
   ByVal LineNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRelatedMorToSalesOrder(
   string Token,
   int SalesEntry,
   string ItemCode,
   string Revision,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRelatedMorToSalesOrder(
   String^ Token,
   int SalesEntry,
   String^ ItemCode,
   String^ Revision,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRelatedMorToSalesOrder(
    Token : String,
    SalesEntry : int,
    ItemCode : String,
    Revision : String,
    LineNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

SalesEntry

Type: int

ItemCode

Type: string

Revision

Type: string

LineNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetResourcePropertyNames Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetResourcePropertyNames( _
   ByVal token As String, _
   ByVal lst As IEnumerable(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetResourcePropertyNames(
   string token,
   IEnumerable<string> lst
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetResourcePropertyNames(
   String^ token,
   IEnumerable<String^>^ lst
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

lst

Type: IEnumerable<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetResourcePropertyWordsCodes Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetResourcePropertyWordsCodes( _
   ByVal Token As String, _
   ByVal RscPrpCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetResourcePropertyWordsCodes(
   string Token,
   string RscPrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetResourcePropertyWordsCodes(
   String^ Token,
   String^ RscPrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetResourcePropertyWordsCodes(
    Token : String,
    RscPrpCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

RscPrpCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetResourceWordNames Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetResourceWordNames( _
   ByVal token As String, _
   ByVal lst As IEnumerable(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetResourceWordNames(
   string token,
   IEnumerable<string> lst
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetResourceWordNames(
   String^ token,
   IEnumerable<String^>^ lst
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

lst

Type: IEnumerable<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetRevisonsForManufacturingOrder Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRevisonsForManufacturingOrder( _
   ByVal Token As String, _
   ByVal itemcode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRevisonsForManufacturingOrder(
   string Token,
   string itemcode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRevisonsForManufacturingOrder(
   String^ Token,
   String^ itemcode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRevisonsForManufacturingOrder(
    Token : String,
    itemcode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemcode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetRoutingCodesAndNames Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRoutingCodesAndNames( _
   ByVal token As String, _
   ByVal RoutingCodes As IEnumerable(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetRoutingCodesAndNames(
   string token,
   IEnumerable<string> RoutingCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetRoutingCodesAndNames(
   String^ token,
   IEnumerable<String^>^ RoutingCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

RoutingCodes

Type: IEnumerable<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetSimpleManufacturingOrderDocEntries Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSimpleManufacturingOrderDocEntries( _
   ByVal token As String, _
   ByVal date As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSimpleManufacturingOrderDocEntries(
   string token,
   string date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSimpleManufacturingOrderDocEntries(
   String^ token,
   String^ date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSimpleManufacturingOrderDocEntries(
    token : String,
    date : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

date

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetSimpleProductionPlanningCodes Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetSimpleProductionPlanningCodes( _
   ByVal token As String, _
   ByVal date As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetSimpleProductionPlanningCodes(
   string token,
   string date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetSimpleProductionPlanningCodes(
   String^ token,
   String^ date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetSimpleProductionPlanningCodes(
    token : String,
    date : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

date

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetUnsynchronizedMOR_WOR Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetUnsynchronizedMOR_WOR( _
   ByVal Token As String _
) As List(Of Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<int> GetUnsynchronizedMOR_WOR(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<int>^ GetUnsynchronizedMOR_WOR(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: List<int>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetWholeCompleatedTime Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetWholeCompleatedTime( _
   ByVal Token As String, _
   ByVal DocEntrys As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetWholeCompleatedTime(
   string Token,
   IEnumerable<int> DocEntrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetWholeCompleatedTime(
   String^ Token,
   IEnumerable<int>^ DocEntrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntrys

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.InsertResourceCalendarHistoryEntry Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function InsertResourceCalendarHistoryEntry( _
   ByVal token As String, _
   ByVal code As String, _
   ByVal resourceCode As String, _
   ByVal date As Date, _
   ByVal fromTime As Integer, _
   ByVal toTime As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset InsertResourceCalendarHistoryEntry(
   string token,
   string code,
   string resourceCode,
   DateTime date,
   int fromTime,
   int toTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ InsertResourceCalendarHistoryEntry(
   String^ token,
   String^ code,
   String^ resourceCode,
   DateTime date,
   int fromTime,
   int toTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function InsertResourceCalendarHistoryEntry(
    token : String,
    code : String,
    resourceCode : String,
    date : DateTime,
    fromTime : int,
    toTime : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

code

Type: string

resourceCode

Type: string

date

Type: DateTime

fromTime

Type: int

toTime

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.IsInOutOperationPropertyUsed Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function IsInOutOperationPropertyUsed( _
   ByVal token As String, _
   ByVal prpCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset IsInOutOperationPropertyUsed(
   string token,
   string prpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ IsInOutOperationPropertyUsed(
   String^ token,
   String^ prpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function IsInOutOperationPropertyUsed(
    token : String,
    prpCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

prpCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.IsItemUsedInBillOfMaterialsHeader Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function IsItemUsedInBillOfMaterialsHeader( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset IsItemUsedInBillOfMaterialsHeader(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ IsItemUsedInBillOfMaterialsHeader(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function IsItemUsedInBillOfMaterialsHeader(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.IsOperationPropertyUsed Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function IsOperationPropertyUsed( _
   ByVal token As String, _
   ByVal prpCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset IsOperationPropertyUsed(
   string token,
   string prpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ IsOperationPropertyUsed(
   String^ token,
   String^ prpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function IsOperationPropertyUsed(
    token : String,
    prpCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

prpCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.IsOperationUsed Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function IsOperationUsed( _
   ByVal token As String, _
   ByVal oprCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset IsOperationUsed(
   string token,
   string oprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ IsOperationUsed(
   String^ token,
   String^ oprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function IsOperationUsed(
    token : String,
    oprCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

oprCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.IsResourceUsed Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function IsResourceUsed( _
   ByVal token As String, _
   ByVal rscCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset IsResourceUsed(
   string token,
   string rscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ IsResourceUsed(
   String^ token,
   String^ rscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function IsResourceUsed(
    token : String,
    rscCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

rscCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.IsRoutingUsed Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function IsRoutingUsed( _
   ByVal token As String, _
   ByVal RtgCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset IsRoutingUsed(
   string token,
   string RtgCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ IsRoutingUsed(
   String^ token,
   String^ RtgCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function IsRoutingUsed(
    token : String,
    RtgCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

RtgCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.IsSalesOrderAssignedToManufacturingOrder Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function IsSalesOrderAssignedToManufacturingOrder( _
   ByVal token As String, _
   ByVal docId As Integer, _
   ByVal docNo As Integer, _
   ByVal lineNo As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset IsSalesOrderAssignedToManufacturingOrder(
   string token,
   int docId,
   int docNo,
   int lineNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ IsSalesOrderAssignedToManufacturingOrder(
   String^ token,
   int docId,
   int docNo,
   int lineNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function IsSalesOrderAssignedToManufacturingOrder(
    token : String,
    docId : int,
    docNo : int,
    lineNo : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docId

Type: int

docNo

Type: int

lineNo

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.ManufacturingActualTasksQuery Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function ManufacturingActualTasksQuery( _
   ByVal token As String, _
   ByVal docEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset ManufacturingActualTasksQuery(
   string token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ ManufacturingActualTasksQuery(
   String^ token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ManufacturingActualTasksQuery(
    token : String,
    docEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.ManufacturingTimeBookingReportQuery Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function ManufacturingTimeBookingReportQuery( _
   ByVal token As String, _
   ByVal docEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset ManufacturingTimeBookingReportQuery(
   string token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ ManufacturingTimeBookingReportQuery(
   String^ token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ManufacturingTimeBookingReportQuery(
    token : String,
    docEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.RenameResourceHistoryCalendar Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function RenameResourceHistoryCalendar( _
   ByVal token As String, _
   ByVal oldRscCode As String, _
   ByVal newRscCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset RenameResourceHistoryCalendar(
   string token,
   string oldRscCode,
   string newRscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ RenameResourceHistoryCalendar(
   String^ token,
   String^ oldRscCode,
   String^ newRscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RenameResourceHistoryCalendar(
    token : String,
    oldRscCode : String,
    newRscCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

oldRscCode

Type: string

newRscCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.RepairActiveAtMorResources Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function RepairActiveAtMorResources( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset RepairActiveAtMorResources(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ RepairActiveAtMorResources(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RepairActiveAtMorResources(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.RepairActiveAtMorResources2 Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function RepairActiveAtMorResources2( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset RepairActiveAtMorResources2(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ RepairActiveAtMorResources2(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RepairActiveAtMorResources2(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.ValidateComponentsAgainstLoop Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function ValidateComponentsAgainstLoop( _
   ByVal token As String, _
   ByVal ParentItemCode As String, _
   ByVal components As IEnumerable(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset ValidateComponentsAgainstLoop(
   string token,
   string ParentItemCode,
   IEnumerable<string> components
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ ValidateComponentsAgainstLoop(
   String^ token,
   String^ ParentItemCode,
   IEnumerable<String^>^ components
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

ParentItemCode

Type: string

components

Type: IEnumerable<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.ValidateCoproductsScraps Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function ValidateCoproductsScraps( _
   ByVal Token As String, _
   ByVal itmcodes As List(Of Tuple(Of String, String)) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset ValidateCoproductsScraps(
   string Token,
   List<Tuple<string, string>> itmcodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ ValidateCoproductsScraps(
   String^ Token,
   List<Tuple<String^, String^>^>^ itmcodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

itmcodes

Type: List<Tuple<string, string>>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.ValidateItemNotUsedCoproductsScrap Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function ValidateItemNotUsedCoproductsScrap( _
   ByVal token As String, _
   ByVal ItemCode As String, _
   ByVal Revision As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset ValidateItemNotUsedCoproductsScrap(
   string token,
   string ItemCode,
   string Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ ValidateItemNotUsedCoproductsScrap(
   String^ token,
   String^ ItemCode,
   String^ Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ValidateItemNotUsedCoproductsScrap(
    token : String,
    ItemCode : String,
    Revision : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

ItemCode

Type: string

Revision

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


HANATechnologyQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class HANATechnologyQueries
    Inherits BaseTechnologyQueries
    Implements ITechnologyQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class HANATechnologyQueries : BaseTechnologyQueries,
   ITechnologyQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class HANATechnologyQueries : public BaseTechnologyQueries^,
   public ITechnologyQueries^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class HANATechnologyQueries
   extends BaseTechnologyQueries
   implements ITechnologyQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.TechnologyQueries.BaseTechnologyQueries
CompuTec.ProcessForce.API.Queries.TechnologyQueries.HANATechnologyQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

HANATechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


HANATechnologyQueries Members

HANATechnologyQueries Class Methods See Also

The following tables list the members exposed by the HANATechnologyQueries type.

Methods
 | Name | Description
Public method | BillOfMaterialExistsWithEmptyRevision | (inherited from BaseTechnologyQueries).
Public method | CallCT_PF_CalculateWiPVariancesOnMORClose | (inherited from BaseTechnologyQueries).
Public method | CheckIfLinkedToolsAreToolsTypes | (inherited from BaseTechnologyQueries).
Public method | CheckIfThereIsResourceInNotClosedMor | (inherited from BaseTechnologyQueries).
Public method | CreateManufacturingOrdersForSemiProducts | (inherited from BaseTechnologyQueries).
Public method | CreateManufacturingOrdersForSemiProductsRows | (inherited from BaseTechnologyQueries).
Public method | DeleteResourceCalendarHistory | (inherited from BaseTechnologyQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAllFormulaBasedOnItemCode | (inherited from BaseTechnologyQueries).
Public method | GetAllFormulaYieldsBasedOnItemCode | (inherited from BaseTechnologyQueries).
Public method | GetAltResourcesBasedOnMOR | (inherited from BaseTechnologyQueries).
Public method | GetAlternativeResourcesFromOperationsGant | (inherited from BaseTechnologyQueries).
Public method | GetAlternativeResourcesGant | (Overloaded) (inherited from BaseTechnologyQueries).
Public method | GetAssignedOperations | (inherited from BaseTechnologyQueries).
Public method | GetAsynchronousManufacturingOrders | (inherited from BaseTechnologyQueries).
Public method | GetAvalibleRouting | (inherited from BaseTechnologyQueries).
Public method | GetBillOfMaterialsOperations | (inherited from BaseTechnologyQueries).
Public method | GetCodesForBomPhantoms | (inherited from BaseTechnologyQueries).
Public method | GetCompleatedTime | (inherited from BaseTechnologyQueries).
Public method | GetDocumentsWithAsynchronousHeaders | (inherited from BaseTechnologyQueries).
Public method | GetDocumentsWithAsynchronousStatuses | (inherited from BaseTechnologyQueries).
Public method | GetDoubledUnsynchronizedMOR_WOR | (inherited from BaseTechnologyQueries).
Public method | GetDoubledUnsynchronizedMOR_WORTuple | (inherited from BaseTechnologyQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetLastCodeForBOM | (inherited from BaseTechnologyQueries).
Public method | GetLineNumsForOperation | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderDocEntries | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderOperationDocEntries | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderOperations | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderRelatedSeries | Gets a collection of Manufacturing Order related numbering series. (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderRowsData | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderSeries | (inherited from BaseTechnologyQueries).
Public method | GetMatchingQualityControlTestIds | (inherited from BaseTechnologyQueries).
Public method | GetMorRowDetails | (inherited from BaseTechnologyQueries).
Public method | GetOpenedDownTimeForResources | (inherited from BaseTechnologyQueries).
Public method | GetOperationAndResourceCodes | (inherited from BaseTechnologyQueries).
Public method | GetOperationIOPropertyWordsCodes | (inherited from BaseTechnologyQueries).
Public method | GetOperationPropertyWordsCodes | (inherited from BaseTechnologyQueries).
Public method | GetOperationSequence | (inherited from BaseTechnologyQueries).
Public method | GetOperationStatus | (inherited from BaseTechnologyQueries).
Public method | GetProductionOrderRelatedSeries | Gets a collection of Production Order related numbering series. (inherited from BaseTechnologyQueries).
Public method | GetProductionOrderRowsData | (inherited from BaseTechnologyQueries).
Public method | GetProductionOrdersThatHaveIssuedItems | (Overloaded) (inherited from BaseTechnologyQueries).
Public method | GetRelatedMorToSalesOrder | (inherited from BaseTechnologyQueries).
Public method | GetResourcePropertyNames | (inherited from BaseTechnologyQueries).
Public method | GetResourcePropertyWordsCodes | (inherited from BaseTechnologyQueries).
Public method | GetResourceWordNames | (inherited from BaseTechnologyQueries).
Public method | GetRevisonsForManufacturingOrder | (inherited from BaseTechnologyQueries).
Public method | GetRoutingCodesAndNames | (inherited from BaseTechnologyQueries).
Public method | GetSimpleManufacturingOrderDocEntries | (inherited from BaseTechnologyQueries).
Public method | GetSimpleProductionPlanningCodes | (inherited from BaseTechnologyQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetUnsynchronizedMOR_WOR | (inherited from BaseTechnologyQueries).
Public method | GetWholeCompleatedTime | (inherited from BaseTechnologyQueries).
Public method | InsertResourceCalendarHistoryEntry | (inherited from BaseTechnologyQueries).
Public method | IsInOutOperationPropertyUsed | (inherited from BaseTechnologyQueries).
Public method | IsItemUsedInBillOfMaterialsHeader | (inherited from BaseTechnologyQueries).
Public method | IsOperationPropertyUsed | (inherited from BaseTechnologyQueries).
Public method | IsOperationUsed | (inherited from BaseTechnologyQueries).
Public method | IsResourceUsed | (inherited from BaseTechnologyQueries).
Public method | IsRoutingUsed | (inherited from BaseTechnologyQueries).
Public method | IsSalesOrderAssignedToManufacturingOrder | (inherited from BaseTechnologyQueries).
Public method | ManufacturingActualTasksQuery | (inherited from BaseTechnologyQueries).
Public method | ManufacturingTimeBookingReportQuery | (inherited from BaseTechnologyQueries).
Public method | RenameResourceHistoryCalendar | (inherited from BaseTechnologyQueries).
Public method | RepairActiveAtMorResources | (inherited from BaseTechnologyQueries).
Public method | RepairActiveAtMorResources2 | (inherited from BaseTechnologyQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | ValidateComponentsAgainstLoop | (inherited from BaseTechnologyQueries).
Public method | ValidateCoproductsScraps | (inherited from BaseTechnologyQueries).
Public method | ValidateItemNotUsedCoproductsScrap | (inherited from BaseTechnologyQueries).
Top
See Also

Reference

HANATechnologyQueries Class
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


HANATechnologyQueries Methods

HANATechnologyQueries Class See Also

The following tables list the members exposed by the HANATechnologyQueries type.

Methods
 | Name | Description
Public method | BillOfMaterialExistsWithEmptyRevision | (inherited from BaseTechnologyQueries).
Public method | CallCT_PF_CalculateWiPVariancesOnMORClose | (inherited from BaseTechnologyQueries).
Public method | CheckIfLinkedToolsAreToolsTypes | (inherited from BaseTechnologyQueries).
Public method | CheckIfThereIsResourceInNotClosedMor | (inherited from BaseTechnologyQueries).
Public method | CreateManufacturingOrdersForSemiProducts | (inherited from BaseTechnologyQueries).
Public method | CreateManufacturingOrdersForSemiProductsRows | (inherited from BaseTechnologyQueries).
Public method | DeleteResourceCalendarHistory | (inherited from BaseTechnologyQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAllFormulaBasedOnItemCode | (inherited from BaseTechnologyQueries).
Public method | GetAllFormulaYieldsBasedOnItemCode | (inherited from BaseTechnologyQueries).
Public method | GetAltResourcesBasedOnMOR | (inherited from BaseTechnologyQueries).
Public method | GetAlternativeResourcesFromOperationsGant | (inherited from BaseTechnologyQueries).
Public method | GetAlternativeResourcesGant | (Overloaded) (inherited from BaseTechnologyQueries).
Public method | GetAssignedOperations | (inherited from BaseTechnologyQueries).
Public method | GetAsynchronousManufacturingOrders | (inherited from BaseTechnologyQueries).
Public method | GetAvalibleRouting | (inherited from BaseTechnologyQueries).
Public method | GetBillOfMaterialsOperations | (inherited from BaseTechnologyQueries).
Public method | GetCodesForBomPhantoms | (inherited from BaseTechnologyQueries).
Public method | GetCompleatedTime | (inherited from BaseTechnologyQueries).
Public method | GetDocumentsWithAsynchronousHeaders | (inherited from BaseTechnologyQueries).
Public method | GetDocumentsWithAsynchronousStatuses | (inherited from BaseTechnologyQueries).
Public method | GetDoubledUnsynchronizedMOR_WOR | (inherited from BaseTechnologyQueries).
Public method | GetDoubledUnsynchronizedMOR_WORTuple | (inherited from BaseTechnologyQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetLastCodeForBOM | (inherited from BaseTechnologyQueries).
Public method | GetLineNumsForOperation | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderDocEntries | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderOperationDocEntries | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderOperations | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderRelatedSeries | Gets a collection of Manufacturing Order related numbering series. (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderRowsData | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderSeries | (inherited from BaseTechnologyQueries).
Public method | GetMatchingQualityControlTestIds | (inherited from BaseTechnologyQueries).
Public method | GetMorRowDetails | (inherited from BaseTechnologyQueries).
Public method | GetOpenedDownTimeForResources | (inherited from BaseTechnologyQueries).
Public method | GetOperationAndResourceCodes | (inherited from BaseTechnologyQueries).
Public method | GetOperationIOPropertyWordsCodes | (inherited from BaseTechnologyQueries).
Public method | GetOperationPropertyWordsCodes | (inherited from BaseTechnologyQueries).
Public method | GetOperationSequence | (inherited from BaseTechnologyQueries).
Public method | GetOperationStatus | (inherited from BaseTechnologyQueries).
Public method | GetProductionOrderRelatedSeries | Gets a collection of Production Order related numbering series. (inherited from BaseTechnologyQueries).
Public method | GetProductionOrderRowsData | (inherited from BaseTechnologyQueries).
Public method | GetProductionOrdersThatHaveIssuedItems | (Overloaded) (inherited from BaseTechnologyQueries).
Public method | GetRelatedMorToSalesOrder | (inherited from BaseTechnologyQueries).
Public method | GetResourcePropertyNames | (inherited from BaseTechnologyQueries).
Public method | GetResourcePropertyWordsCodes | (inherited from BaseTechnologyQueries).
Public method | GetResourceWordNames | (inherited from BaseTechnologyQueries).
Public method | GetRevisonsForManufacturingOrder | (inherited from BaseTechnologyQueries).
Public method | GetRoutingCodesAndNames | (inherited from BaseTechnologyQueries).
Public method | GetSimpleManufacturingOrderDocEntries | (inherited from BaseTechnologyQueries).
Public method | GetSimpleProductionPlanningCodes | (inherited from BaseTechnologyQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetUnsynchronizedMOR_WOR | (inherited from BaseTechnologyQueries).
Public method | GetWholeCompleatedTime | (inherited from BaseTechnologyQueries).
Public method | InsertResourceCalendarHistoryEntry | (inherited from BaseTechnologyQueries).
Public method | IsInOutOperationPropertyUsed | (inherited from BaseTechnologyQueries).
Public method | IsItemUsedInBillOfMaterialsHeader | (inherited from BaseTechnologyQueries).
Public method | IsOperationPropertyUsed | (inherited from BaseTechnologyQueries).
Public method | IsOperationUsed | (inherited from BaseTechnologyQueries).
Public method | IsResourceUsed | (inherited from BaseTechnologyQueries).
Public method | IsRoutingUsed | (inherited from BaseTechnologyQueries).
Public method | IsSalesOrderAssignedToManufacturingOrder | (inherited from BaseTechnologyQueries).
Public method | ManufacturingActualTasksQuery | (inherited from BaseTechnologyQueries).
Public method | ManufacturingTimeBookingReportQuery | (inherited from BaseTechnologyQueries).
Public method | RenameResourceHistoryCalendar | (inherited from BaseTechnologyQueries).
Public method | RepairActiveAtMorResources | (inherited from BaseTechnologyQueries).
Public method | RepairActiveAtMorResources2 | (inherited from BaseTechnologyQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | ValidateComponentsAgainstLoop | (inherited from BaseTechnologyQueries).
Public method | ValidateCoproductsScraps | (inherited from BaseTechnologyQueries).
Public method | ValidateItemNotUsedCoproductsScrap | (inherited from BaseTechnologyQueries).
Top
See Also

Reference

HANATechnologyQueries Class
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


SQLTechnologyQueries Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SQLTechnologyQueries
    Inherits BaseTechnologyQueries
    Implements ITechnologyQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SQLTechnologyQueries : BaseTechnologyQueries,
   ITechnologyQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SQLTechnologyQueries : public BaseTechnologyQueries^,
   public ITechnologyQueries^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SQLTechnologyQueries
   extends BaseTechnologyQueries
   implements ITechnologyQueries
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.TechnologyQueries.BaseTechnologyQueries
CompuTec.ProcessForce.API.Queries.TechnologyQueries.SQLTechnologyQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SQLTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


SQLTechnologyQueries Members

SQLTechnologyQueries Class Methods See Also

The following tables list the members exposed by the SQLTechnologyQueries type.

Methods
 | Name | Description
Public method | BillOfMaterialExistsWithEmptyRevision | (inherited from BaseTechnologyQueries).
Public method | CallCT_PF_CalculateWiPVariancesOnMORClose | (inherited from BaseTechnologyQueries).
Public method | CheckIfLinkedToolsAreToolsTypes | (inherited from BaseTechnologyQueries).
Public method | CheckIfThereIsResourceInNotClosedMor | (inherited from BaseTechnologyQueries).
Public method | CreateManufacturingOrdersForSemiProducts | (inherited from BaseTechnologyQueries).
Public method | CreateManufacturingOrdersForSemiProductsRows | (inherited from BaseTechnologyQueries).
Public method | DeleteResourceCalendarHistory | (inherited from BaseTechnologyQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAllFormulaBasedOnItemCode | (inherited from BaseTechnologyQueries).
Public method | GetAllFormulaYieldsBasedOnItemCode | (inherited from BaseTechnologyQueries).
Public method | GetAltResourcesBasedOnMOR | (inherited from BaseTechnologyQueries).
Public method | GetAlternativeResourcesFromOperationsGant | (inherited from BaseTechnologyQueries).
Public method | GetAlternativeResourcesGant | (Overloaded) (inherited from BaseTechnologyQueries).
Public method | GetAssignedOperations | (inherited from BaseTechnologyQueries).
Public method | GetAsynchronousManufacturingOrders | (inherited from BaseTechnologyQueries).
Public method | GetAvalibleRouting | (inherited from BaseTechnologyQueries).
Public method | GetBillOfMaterialsOperations | (inherited from BaseTechnologyQueries).
Public method | GetCodesForBomPhantoms | (inherited from BaseTechnologyQueries).
Public method | GetCompleatedTime | (inherited from BaseTechnologyQueries).
Public method | GetDocumentsWithAsynchronousHeaders | (inherited from BaseTechnologyQueries).
Public method | GetDocumentsWithAsynchronousStatuses | (inherited from BaseTechnologyQueries).
Public method | GetDoubledUnsynchronizedMOR_WOR | (inherited from BaseTechnologyQueries).
Public method | GetDoubledUnsynchronizedMOR_WORTuple | (inherited from BaseTechnologyQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetLastCodeForBOM | (inherited from BaseTechnologyQueries).
Public method | GetLineNumsForOperation | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderDocEntries | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderOperationDocEntries | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderOperations | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderRelatedSeries | Gets a collection of Manufacturing Order related numbering series. (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderRowsData | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderSeries | (inherited from BaseTechnologyQueries).
Public method | GetMatchingQualityControlTestIds | (inherited from BaseTechnologyQueries).
Public method | GetMorRowDetails | (inherited from BaseTechnologyQueries).
Public method | GetOpenedDownTimeForResources | (inherited from BaseTechnologyQueries).
Public method | GetOperationAndResourceCodes | (inherited from BaseTechnologyQueries).
Public method | GetOperationIOPropertyWordsCodes | (inherited from BaseTechnologyQueries).
Public method | GetOperationPropertyWordsCodes | (inherited from BaseTechnologyQueries).
Public method | GetOperationSequence | (inherited from BaseTechnologyQueries).
Public method | GetOperationStatus | (inherited from BaseTechnologyQueries).
Public method | GetProductionOrderRelatedSeries | Gets a collection of Production Order related numbering series. (inherited from BaseTechnologyQueries).
Public method | GetProductionOrderRowsData | (inherited from BaseTechnologyQueries).
Public method | GetProductionOrdersThatHaveIssuedItems | (Overloaded) (inherited from BaseTechnologyQueries).
Public method | GetRelatedMorToSalesOrder | (inherited from BaseTechnologyQueries).
Public method | GetResourcePropertyNames | (inherited from BaseTechnologyQueries).
Public method | GetResourcePropertyWordsCodes | (inherited from BaseTechnologyQueries).
Public method | GetResourceWordNames | (inherited from BaseTechnologyQueries).
Public method | GetRevisonsForManufacturingOrder | (inherited from BaseTechnologyQueries).
Public method | GetRoutingCodesAndNames | (inherited from BaseTechnologyQueries).
Public method | GetSimpleManufacturingOrderDocEntries | (inherited from BaseTechnologyQueries).
Public method | GetSimpleProductionPlanningCodes | (inherited from BaseTechnologyQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetUnsynchronizedMOR_WOR | (inherited from BaseTechnologyQueries).
Public method | GetWholeCompleatedTime | (inherited from BaseTechnologyQueries).
Public method | InsertResourceCalendarHistoryEntry | (inherited from BaseTechnologyQueries).
Public method | IsInOutOperationPropertyUsed | (inherited from BaseTechnologyQueries).
Public method | IsItemUsedInBillOfMaterialsHeader | (inherited from BaseTechnologyQueries).
Public method | IsOperationPropertyUsed | (inherited from BaseTechnologyQueries).
Public method | IsOperationUsed | (inherited from BaseTechnologyQueries).
Public method | IsResourceUsed | (inherited from BaseTechnologyQueries).
Public method | IsRoutingUsed | (inherited from BaseTechnologyQueries).
Public method | IsSalesOrderAssignedToManufacturingOrder | (inherited from BaseTechnologyQueries).
Public method | ManufacturingActualTasksQuery | (inherited from BaseTechnologyQueries).
Public method | ManufacturingTimeBookingReportQuery | (inherited from BaseTechnologyQueries).
Public method | RenameResourceHistoryCalendar | (inherited from BaseTechnologyQueries).
Public method | RepairActiveAtMorResources | (inherited from BaseTechnologyQueries).
Public method | RepairActiveAtMorResources2 | (inherited from BaseTechnologyQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | ValidateComponentsAgainstLoop | (inherited from BaseTechnologyQueries).
Public method | ValidateCoproductsScraps | (inherited from BaseTechnologyQueries).
Public method | ValidateItemNotUsedCoproductsScrap | (inherited from BaseTechnologyQueries).
Top
See Also

Reference

SQLTechnologyQueries Class
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


SQLTechnologyQueries Methods

SQLTechnologyQueries Class See Also

The following tables list the members exposed by the SQLTechnologyQueries type.

Methods
 | Name | Description
Public method | BillOfMaterialExistsWithEmptyRevision | (inherited from BaseTechnologyQueries).
Public method | CallCT_PF_CalculateWiPVariancesOnMORClose | (inherited from BaseTechnologyQueries).
Public method | CheckIfLinkedToolsAreToolsTypes | (inherited from BaseTechnologyQueries).
Public method | CheckIfThereIsResourceInNotClosedMor | (inherited from BaseTechnologyQueries).
Public method | CreateManufacturingOrdersForSemiProducts | (inherited from BaseTechnologyQueries).
Public method | CreateManufacturingOrdersForSemiProductsRows | (inherited from BaseTechnologyQueries).
Public method | DeleteResourceCalendarHistory | (inherited from BaseTechnologyQueries).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAllFormulaBasedOnItemCode | (inherited from BaseTechnologyQueries).
Public method | GetAllFormulaYieldsBasedOnItemCode | (inherited from BaseTechnologyQueries).
Public method | GetAltResourcesBasedOnMOR | (inherited from BaseTechnologyQueries).
Public method | GetAlternativeResourcesFromOperationsGant | (inherited from BaseTechnologyQueries).
Public method | GetAlternativeResourcesGant | (Overloaded) (inherited from BaseTechnologyQueries).
Public method | GetAssignedOperations | (inherited from BaseTechnologyQueries).
Public method | GetAsynchronousManufacturingOrders | (inherited from BaseTechnologyQueries).
Public method | GetAvalibleRouting | (inherited from BaseTechnologyQueries).
Public method | GetBillOfMaterialsOperations | (inherited from BaseTechnologyQueries).
Public method | GetCodesForBomPhantoms | (inherited from BaseTechnologyQueries).
Public method | GetCompleatedTime | (inherited from BaseTechnologyQueries).
Public method | GetDocumentsWithAsynchronousHeaders | (inherited from BaseTechnologyQueries).
Public method | GetDocumentsWithAsynchronousStatuses | (inherited from BaseTechnologyQueries).
Public method | GetDoubledUnsynchronizedMOR_WOR | (inherited from BaseTechnologyQueries).
Public method | GetDoubledUnsynchronizedMOR_WORTuple | (inherited from BaseTechnologyQueries).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetLastCodeForBOM | (inherited from BaseTechnologyQueries).
Public method | GetLineNumsForOperation | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderDocEntries | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderOperationDocEntries | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderOperations | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderRelatedSeries | Gets a collection of Manufacturing Order related numbering series. (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderRowsData | (inherited from BaseTechnologyQueries).
Public method | GetManufacturingOrderSeries | (inherited from BaseTechnologyQueries).
Public method | GetMatchingQualityControlTestIds | (inherited from BaseTechnologyQueries).
Public method | GetMorRowDetails | (inherited from BaseTechnologyQueries).
Public method | GetOpenedDownTimeForResources | (inherited from BaseTechnologyQueries).
Public method | GetOperationAndResourceCodes | (inherited from BaseTechnologyQueries).
Public method | GetOperationIOPropertyWordsCodes | (inherited from BaseTechnologyQueries).
Public method | GetOperationPropertyWordsCodes | (inherited from BaseTechnologyQueries).
Public method | GetOperationSequence | (inherited from BaseTechnologyQueries).
Public method | GetOperationStatus | (inherited from BaseTechnologyQueries).
Public method | GetProductionOrderRelatedSeries | Gets a collection of Production Order related numbering series. (inherited from BaseTechnologyQueries).
Public method | GetProductionOrderRowsData | (inherited from BaseTechnologyQueries).
Public method | GetProductionOrdersThatHaveIssuedItems | (Overloaded) (inherited from BaseTechnologyQueries).
Public method | GetRelatedMorToSalesOrder | (inherited from BaseTechnologyQueries).
Public method | GetResourcePropertyNames | (inherited from BaseTechnologyQueries).
Public method | GetResourcePropertyWordsCodes | (inherited from BaseTechnologyQueries).
Public method | GetResourceWordNames | (inherited from BaseTechnologyQueries).
Public method | GetRevisonsForManufacturingOrder | (inherited from BaseTechnologyQueries).
Public method | GetRoutingCodesAndNames | (inherited from BaseTechnologyQueries).
Public method | GetSimpleManufacturingOrderDocEntries | (inherited from BaseTechnologyQueries).
Public method | GetSimpleProductionPlanningCodes | (inherited from BaseTechnologyQueries).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetUnsynchronizedMOR_WOR | (inherited from BaseTechnologyQueries).
Public method | GetWholeCompleatedTime | (inherited from BaseTechnologyQueries).
Public method | InsertResourceCalendarHistoryEntry | (inherited from BaseTechnologyQueries).
Public method | IsInOutOperationPropertyUsed | (inherited from BaseTechnologyQueries).
Public method | IsItemUsedInBillOfMaterialsHeader | (inherited from BaseTechnologyQueries).
Public method | IsOperationPropertyUsed | (inherited from BaseTechnologyQueries).
Public method | IsOperationUsed | (inherited from BaseTechnologyQueries).
Public method | IsResourceUsed | (inherited from BaseTechnologyQueries).
Public method | IsRoutingUsed | (inherited from BaseTechnologyQueries).
Public method | IsSalesOrderAssignedToManufacturingOrder | (inherited from BaseTechnologyQueries).
Public method | ManufacturingActualTasksQuery | (inherited from BaseTechnologyQueries).
Public method | ManufacturingTimeBookingReportQuery | (inherited from BaseTechnologyQueries).
Public method | RenameResourceHistoryCalendar | (inherited from BaseTechnologyQueries).
Public method | RepairActiveAtMorResources | (inherited from BaseTechnologyQueries).
Public method | RepairActiveAtMorResources2 | (inherited from BaseTechnologyQueries).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | ValidateComponentsAgainstLoop | (inherited from BaseTechnologyQueries).
Public method | ValidateCoproductsScraps | (inherited from BaseTechnologyQueries).
Public method | ValidateItemNotUsedCoproductsScrap | (inherited from BaseTechnologyQueries).
Top
See Also

Reference

SQLTechnologyQueries Class
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ITechnologyQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ITechnologyQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ITechnologyQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ITechnologyQueries
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries Members

ITechnologyQueries Interface Methods See Also

The following tables list the members exposed by the ITechnologyQueries type.

Methods
 | Name | Description
Public method | BillOfMaterialExistsWithEmptyRevision |
Public method | CallCT_PF_CalculateWiPVariancesOnMORClose |
Public method | CheckIfLinkedToolsAreToolsTypes |
Public method | CheckIfThereIsResourceInNotClosedMor |
Public method | CreateManufacturingOrdersForSemiProducts | T1.Code, T0.U_Result
Public method | CreateManufacturingOrdersForSemiProductsRows | T1.Code, T0.U_Result
Public method | GetAllFormulaBasedOnItemCode | For retriving the formula from item group based on itemcode
Public method | GetAllFormulaYieldsBasedOnItemCode | For retrieving formula yields from item group based on itemcode
Public method | GetAltResourcesBasedOnMOR |
Public method | GetAlternativeResourcesFromOperationsGant |
Public method | GetAlternativeResourcesGant | (Overloaded) snull(t1.U_RscCode,'') [AltTOOL], T0.*
Public method | GetAvalibleRouting | "U_RtgCode"
Public method | GetCodesForBomPhantoms |
Public method | GetCompleatedTime |
Public method | GetDoubledUnsynchronizedMOR_WOR | Get list of Production Orders to be canceled
Public method | GetDoubledUnsynchronizedMOR_WORTuple |
Public method | GetLastCodeForBOM |
Public method | GetLineNumsForOperation | t2."U_LineNum"
Public method | GetMorRowDetails | t0.ItemCode,t0.ItemName,t0.InvntryUom,t0.DfltWH,t0.InvntItem ,t1.U_Code,t1.U_Description,t0.PrcrmntMtd ,t2.U_AcptLowerQty
Public method | GetOpenedDownTimeForResources |
Public method | GetOperationAndResourceCodes |
Public method | GetOperationIOPropertyWordsCodes |
Public method | GetOperationPropertyWordsCodes |
Public method | GetOperationSequence | 1."U_OprSequence"
Public method | GetOperationStatus | 1."U_Status"
Public method | GetRelatedMorToSalesOrder | Mor DocEntry
Public method | GetResourcePropertyNames |
Public method | GetResourcePropertyWordsCodes |
Public method | GetResourceWordNames |
Public method | GetRevisonsForManufacturingOrder | t1."U_Code", t1."U_Description"
Public method | GetRoutingCodesAndNames | "U_RtgName", "U_RtgCode"
Public method | GetUnsynchronizedMOR_WOR | Returns a List Of unsynchronized MOR-WOR documents
Public method | GetWholeCompleatedTime |
Public method | IsResourceUsed |
Public method | IsRoutingUsed |
Public method | RepairActiveAtMorResources |
Public method | RepairActiveAtMorResources2 |
Public method | ValidateComponentsAgainstLoop |
Public method | ValidateCoproductsScraps |
Public method | ValidateItemNotUsedCoproductsScrap |
Top
See Also

Reference

ITechnologyQueries Interface
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries Methods

ITechnologyQueries Interface See Also

The following tables list the members exposed by the ITechnologyQueries type.

Methods
 | Name | Description
Public method | BillOfMaterialExistsWithEmptyRevision |
Public method | CallCT_PF_CalculateWiPVariancesOnMORClose |
Public method | CheckIfLinkedToolsAreToolsTypes |
Public method | CheckIfThereIsResourceInNotClosedMor |
Public method | CreateManufacturingOrdersForSemiProducts | T1.Code, T0.U_Result
Public method | CreateManufacturingOrdersForSemiProductsRows | T1.Code, T0.U_Result
Public method | GetAllFormulaBasedOnItemCode | For retriving the formula from item group based on itemcode
Public method | GetAllFormulaYieldsBasedOnItemCode | For retrieving formula yields from item group based on itemcode
Public method | GetAltResourcesBasedOnMOR |
Public method | GetAlternativeResourcesFromOperationsGant |
Public method | GetAlternativeResourcesGant | (Overloaded) snull(t1.U_RscCode,'') [AltTOOL], T0.*
Public method | GetAvalibleRouting | "U_RtgCode"
Public method | GetCodesForBomPhantoms |
Public method | GetCompleatedTime |
Public method | GetDoubledUnsynchronizedMOR_WOR | Get list of Production Orders to be canceled
Public method | GetDoubledUnsynchronizedMOR_WORTuple |
Public method | GetLastCodeForBOM |
Public method | GetLineNumsForOperation | t2."U_LineNum"
Public method | GetMorRowDetails | t0.ItemCode,t0.ItemName,t0.InvntryUom,t0.DfltWH,t0.InvntItem ,t1.U_Code,t1.U_Description,t0.PrcrmntMtd ,t2.U_AcptLowerQty
Public method | GetOpenedDownTimeForResources |
Public method | GetOperationAndResourceCodes |
Public method | GetOperationIOPropertyWordsCodes |
Public method | GetOperationPropertyWordsCodes |
Public method | GetOperationSequence | 1."U_OprSequence"
Public method | GetOperationStatus | 1."U_Status"
Public method | GetRelatedMorToSalesOrder | Mor DocEntry
Public method | GetResourcePropertyNames |
Public method | GetResourcePropertyWordsCodes |
Public method | GetResourceWordNames |
Public method | GetRevisonsForManufacturingOrder | t1."U_Code", t1."U_Description"
Public method | GetRoutingCodesAndNames | "U_RtgName", "U_RtgCode"
Public method | GetUnsynchronizedMOR_WOR | Returns a List Of unsynchronized MOR-WOR documents
Public method | GetWholeCompleatedTime |
Public method | IsResourceUsed |
Public method | IsRoutingUsed |
Public method | RepairActiveAtMorResources |
Public method | RepairActiveAtMorResources2 |
Public method | ValidateComponentsAgainstLoop |
Public method | ValidateCoproductsScraps |
Public method | ValidateItemNotUsedCoproductsScrap |
Top
See Also

Reference

ITechnologyQueries Interface
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.BillOfMaterialExistsWithEmptyRevision Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function BillOfMaterialExistsWithEmptyRevision( _
   ByVal token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset BillOfMaterialExistsWithEmptyRevision(
   string token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ BillOfMaterialExistsWithEmptyRevision(
   String^ token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function BillOfMaterialExistsWithEmptyRevision(
    token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.CallCT_PF_CalculateWiPVariancesOnMORClose Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CallCT_PF_CalculateWiPVariancesOnMORClose( _
   ByVal Token As String, _
   ByVal DocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset CallCT_PF_CalculateWiPVariancesOnMORClose(
   string Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ CallCT_PF_CalculateWiPVariancesOnMORClose(
   String^ Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CallCT_PF_CalculateWiPVariancesOnMORClose(
    Token : String,
    DocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.CheckIfLinkedToolsAreToolsTypes Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CheckIfLinkedToolsAreToolsTypes( _
   ByVal token As String, _
   ByVal lst As IEnumerable(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset CheckIfLinkedToolsAreToolsTypes(
   string token,
   IEnumerable<string> lst
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ CheckIfLinkedToolsAreToolsTypes(
   String^ token,
   IEnumerable<String^>^ lst
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

lst

Type: IEnumerable<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.CheckIfThereIsResourceInNotClosedMor Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CheckIfThereIsResourceInNotClosedMor( _
   ByVal Token As String, _
   ByVal RscCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset CheckIfThereIsResourceInNotClosedMor(
   string Token,
   string RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ CheckIfThereIsResourceInNotClosedMor(
   String^ Token,
   String^ RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CheckIfThereIsResourceInNotClosedMor(
    Token : String,
    RscCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

RscCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.CreateManufacturingOrdersForSemiProducts Method

T1.Code, T0.U_Result

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CreateManufacturingOrdersForSemiProducts( _
   ByVal Token As String, _
   ByVal DocEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset CreateManufacturingOrdersForSemiProducts(
   string Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ CreateManufacturingOrdersForSemiProducts(
   String^ Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CreateManufacturingOrdersForSemiProducts(
    Token : String,
    DocEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.CreateManufacturingOrdersForSemiProductsRows Method

T1.Code, T0.U_Result

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CreateManufacturingOrdersForSemiProductsRows( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal rows As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset CreateManufacturingOrdersForSemiProductsRows(
   string Token,
   int DocEntry,
   IEnumerable<int> rows
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ CreateManufacturingOrdersForSemiProductsRows(
   String^ Token,
   int DocEntry,
   IEnumerable<int>^ rows
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

rows

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetAllFormulaBasedOnItemCode Method

For retriving the formula from item group based on itemcode

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAllFormulaBasedOnItemCode( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetAllFormulaBasedOnItemCode(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetAllFormulaBasedOnItemCode(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetAllFormulaBasedOnItemCode(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset

All formulas: scrap, coproduction, item, phantom

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetAllFormulaYieldsBasedOnItemCode Method

For retrieving formula yields from item group based on itemcode

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAllFormulaYieldsBasedOnItemCode( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetAllFormulaYieldsBasedOnItemCode(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetAllFormulaYieldsBasedOnItemCode(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetAllFormulaYieldsBasedOnItemCode(
    Token : String,
    ItemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: CTRecordset

All yield formulas

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetAltResourcesBasedOnMOR Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetAltResourcesBasedOnMOR( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal LineID As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetAltResourcesBasedOnMOR(
   string Token,
   int DocEntry,
   int LineID
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetAltResourcesBasedOnMOR(
   String^ Token,
   int DocEntry,
   int LineID
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetAltResourcesBasedOnMOR(
    Token : String,
    DocEntry : int,
    LineID : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

LineID

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetAlternativeResourcesFromOperationsGant Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAlternativeResourcesFromOperationsGant( _
   ByVal Token As String, _
   ByVal OprCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetAlternativeResourcesFromOperationsGant(
   string Token,
   string OprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetAlternativeResourcesFromOperationsGant(
   String^ Token,
   String^ OprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetAlternativeResourcesFromOperationsGant(
    Token : String,
    OprCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

OprCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetAlternativeResourcesGant Method

ITechnologyQueries Interface See Also

snull(t1.U_RscCode,'') [AltTOOL], T0.*

Overload List
Name | Description
GetAlternativeResourcesGant(string, string, string, int, string, string) | U_RscCode
GetAlternativeResourcesGant(string, string, string, int, string, string, string) | snull(t1.U_RscCode,'') [AltTOOL], T0.*
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetAvalibleRouting Method

"U_RtgCode"

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAvalibleRouting( _
   ByVal Token As String, _
   ByVal itemcode As String, _
   ByVal revision As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetAvalibleRouting(
   string Token,
   string itemcode,
   string revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetAvalibleRouting(
   String^ Token,
   String^ itemcode,
   String^ revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetAvalibleRouting(
    Token : String,
    itemcode : String,
    revision : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemcode

Type: string

revision

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetCodesForBomPhantoms Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetCodesForBomPhantoms( _
   ByVal Token As String _
) As List(Of String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<string> GetCodesForBomPhantoms(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

List<String^>^ GetCodesForBomPhantoms(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: List<string>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetCompleatedTime Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetCompleatedTime( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal LineNum As Integer, _
   ByVal TimeType As String, _
   ByVal RscCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetCompleatedTime(
   string Token,
   int DocEntry,
   int LineNum,
   string TimeType,
   string RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetCompleatedTime(
   String^ Token,
   int DocEntry,
   int LineNum,
   String^ TimeType,
   String^ RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetCompleatedTime(
    Token : String,
    DocEntry : int,
    LineNum : int,
    TimeType : String,
    RscCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

LineNum

Type: int

TimeType

Type: string

RscCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetDoubledUnsynchronizedMOR_WOR Method

Get list of Production Orders to be canceled

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetDoubledUnsynchronizedMOR_WOR( _
   ByVal Token As String _
) As List(Of Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<int> GetDoubledUnsynchronizedMOR_WOR(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

List<int>^ GetDoubledUnsynchronizedMOR_WOR(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: List<int>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetDoubledUnsynchronizedMOR_WORTuple Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetDoubledUnsynchronizedMOR_WORTuple( _
   ByVal Token As String _
) As Dictionary(Of Integer, Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Dictionary<int, int> GetDoubledUnsynchronizedMOR_WORTuple(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Dictionary<int, int>^ GetDoubledUnsynchronizedMOR_WORTuple(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: Dictionary<int, int>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetLastCodeForBOM Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetLastCodeForBOM( _
   ByVal Token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetLastCodeForBOM(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetLastCodeForBOM(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetLastCodeForBOM(
    Token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetLineNumsForOperation Method

t2."U_LineNum"

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetLineNumsForOperation( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal LineNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetLineNumsForOperation(
   string Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetLineNumsForOperation(
   String^ Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetLineNumsForOperation(
    Token : String,
    DocEntry : int,
    LineNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

LineNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetMorRowDetails Method

t0.ItemCode,t0.ItemName,t0.InvntryUom,t0.DfltWH,t0.InvntItem ,t1.U_Code,t1.U_Description,t0.PrcrmntMtd ,t2.U_AcptLowerQty

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetMorRowDetails( _
   ByVal Token As String, _
   ByVal ItemCodes As IEnumerable(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetMorRowDetails(
   string Token,
   IEnumerable<string> ItemCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetMorRowDetails(
   String^ Token,
   IEnumerable<String^>^ ItemCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCodes

Type: IEnumerable<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetOpenedDownTimeForResources Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetOpenedDownTimeForResources( _
   ByVal Token As String, _
   ByVal RscCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetOpenedDownTimeForResources(
   string Token,
   string RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetOpenedDownTimeForResources(
   String^ Token,
   String^ RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function GetOpenedDownTimeForResources(
    Token : String,
    RscCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

RscCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetOperationAndResourceCodes Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetOperationAndResourceCodes( _
   ByVal Token As String, _
   ByVal docEntry As Integer, _
   ByVal lineNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetOperationAndResourceCodes(
   string Token,
   int docEntry,
   int lineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetOperationAndResourceCodes(
   String^ Token,
   int docEntry,
   int lineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetOperationAndResourceCodes(
    Token : String,
    docEntry : int,
    lineNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

docEntry

Type: int

lineNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetOperationIOPropertyWordsCodes Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetOperationIOPropertyWordsCodes( _
   ByVal Token As String, _
   ByVal OprIOPrpCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetOperationIOPropertyWordsCodes(
   string Token,
   string OprIOPrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetOperationIOPropertyWordsCodes(
   String^ Token,
   String^ OprIOPrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetOperationIOPropertyWordsCodes(
    Token : String,
    OprIOPrpCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

OprIOPrpCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetOperationPropertyWordsCodes Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetOperationPropertyWordsCodes( _
   ByVal Token As String, _
   ByVal OprPrpCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetOperationPropertyWordsCodes(
   string Token,
   string OprPrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetOperationPropertyWordsCodes(
   String^ Token,
   String^ OprPrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetOperationPropertyWordsCodes(
    Token : String,
    OprPrpCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

OprPrpCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetOperationSequence Method

1."U_OprSequence"

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetOperationSequence( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal LineNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetOperationSequence(
   string Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetOperationSequence(
   String^ Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetOperationSequence(
    Token : String,
    DocEntry : int,
    LineNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

LineNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetOperationStatus Method

1."U_Status"

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetOperationStatus( _
   ByVal Token As String, _
   ByVal DocEntry As Integer, _
   ByVal LineNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetOperationStatus(
   string Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetOperationStatus(
   String^ Token,
   int DocEntry,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetOperationStatus(
    Token : String,
    DocEntry : int,
    LineNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

LineNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetRelatedMorToSalesOrder Method

Mor DocEntry

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetRelatedMorToSalesOrder( _
   ByVal Token As String, _
   ByVal SalesEntry As Integer, _
   ByVal ItemCode As String, _
   ByVal Revision As String, _
   ByVal LineNum As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetRelatedMorToSalesOrder(
   string Token,
   int SalesEntry,
   string ItemCode,
   string Revision,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetRelatedMorToSalesOrder(
   String^ Token,
   int SalesEntry,
   String^ ItemCode,
   String^ Revision,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetRelatedMorToSalesOrder(
    Token : String,
    SalesEntry : int,
    ItemCode : String,
    Revision : String,
    LineNum : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

SalesEntry

Type: int

ItemCode

Type: string

Revision

Type: string

LineNum

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetResourcePropertyNames Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function GetResourcePropertyNames( _
   ByVal token As String, _
   ByVal lst As IEnumerable(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset GetResourcePropertyNames(
   string token,
   IEnumerable<string> lst
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ GetResourcePropertyNames(
   String^ token,
   IEnumerable<String^>^ lst
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

lst

Type: IEnumerable<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetResourcePropertyWordsCodes Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetResourcePropertyWordsCodes( _
   ByVal Token As String, _
   ByVal RscPrpCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetResourcePropertyWordsCodes(
   string Token,
   string RscPrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetResourcePropertyWordsCodes(
   String^ Token,
   String^ RscPrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetResourcePropertyWordsCodes(
    Token : String,
    RscPrpCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

RscPrpCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetResourceWordNames Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetResourceWordNames( _
   ByVal token As String, _
   ByVal lst As IEnumerable(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetResourceWordNames(
   string token,
   IEnumerable<string> lst
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetResourceWordNames(
   String^ token,
   IEnumerable<String^>^ lst
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

lst

Type: IEnumerable<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetRevisonsForManufacturingOrder Method

t1."U_Code", t1."U_Description"

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetRevisonsForManufacturingOrder( _
   ByVal Token As String, _
   ByVal itemcode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetRevisonsForManufacturingOrder(
   string Token,
   string itemcode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetRevisonsForManufacturingOrder(
   String^ Token,
   String^ itemcode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetRevisonsForManufacturingOrder(
    Token : String,
    itemcode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemcode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetRoutingCodesAndNames Method

"U_RtgName", "U_RtgCode"

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetRoutingCodesAndNames( _
   ByVal token As String, _
   ByVal RoutingCodes As IEnumerable(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetRoutingCodesAndNames(
   string token,
   IEnumerable<string> RoutingCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetRoutingCodesAndNames(
   String^ token,
   IEnumerable<String^>^ RoutingCodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

RoutingCodes

Type: IEnumerable<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetUnsynchronizedMOR_WOR Method

Returns a List Of unsynchronized MOR-WOR documents

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetUnsynchronizedMOR_WOR( _
   ByVal Token As String _
) As List(Of Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<int> GetUnsynchronizedMOR_WOR(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

List<int>^ GetUnsynchronizedMOR_WOR(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: List<int>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetWholeCompleatedTime Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetWholeCompleatedTime( _
   ByVal Token As String, _
   ByVal DocEntrys As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetWholeCompleatedTime(
   string Token,
   IEnumerable<int> DocEntrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetWholeCompleatedTime(
   String^ Token,
   IEnumerable<int>^ DocEntrys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntrys

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.IsResourceUsed Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function IsResourceUsed( _
   ByVal token As String, _
   ByVal rscCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset IsResourceUsed(
   string token,
   string rscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ IsResourceUsed(
   String^ token,
   String^ rscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function IsResourceUsed(
    token : String,
    rscCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

rscCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.IsRoutingUsed Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQuery()> _
Function IsRoutingUsed( _
   ByVal token As String, _
   ByVal RtgCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]
CTRecordset IsRoutingUsed(
   string token,
   string RtgCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQuery()]

CTRecordset^ IsRoutingUsed(
   String^ token,
   String^ RtgCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineQuery()
function IsRoutingUsed(
    token : String,
    RtgCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

RtgCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.RepairActiveAtMorResources Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function RepairActiveAtMorResources( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset RepairActiveAtMorResources(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ RepairActiveAtMorResources(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function RepairActiveAtMorResources(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.RepairActiveAtMorResources2 Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function RepairActiveAtMorResources2( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset RepairActiveAtMorResources2(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ RepairActiveAtMorResources2(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function RepairActiveAtMorResources2(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.ValidateComponentsAgainstLoop Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function ValidateComponentsAgainstLoop( _
   ByVal token As String, _
   ByVal ParentItemCode As String, _
   ByVal components As IEnumerable(Of String) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset ValidateComponentsAgainstLoop(
   string token,
   string ParentItemCode,
   IEnumerable<string> components
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ ValidateComponentsAgainstLoop(
   String^ token,
   String^ ParentItemCode,
   IEnumerable<String^>^ components
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

ParentItemCode

Type: string

components

Type: IEnumerable<string>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.ValidateCoproductsScraps Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function ValidateCoproductsScraps( _
   ByVal Token As String, _
   ByVal itmcodes As List(Of Tuple(Of String, String)) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset ValidateCoproductsScraps(
   string Token,
   List<Tuple<string, string>> itmcodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ ValidateCoproductsScraps(
   String^ Token,
   List<Tuple<String^, String^>^>^ itmcodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

itmcodes

Type: List<Tuple<string, string>>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.ValidateItemNotUsedCoproductsScrap Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function ValidateItemNotUsedCoproductsScrap( _
   ByVal token As String, _
   ByVal ItemCode As String, _
   ByVal Revision As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset ValidateItemNotUsedCoproductsScrap(
   string token,
   string ItemCode,
   string Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ ValidateItemNotUsedCoproductsScrap(
   String^ token,
   String^ ItemCode,
   String^ Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function ValidateItemNotUsedCoproductsScrap(
    token : String,
    ItemCode : String,
    Revision : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

ItemCode

Type: string

Revision

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


CompuTec.ProcessForce.API.Resources.CostedBillOfMaterials Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | CostedBillOfMaterialsResourceManager |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


CostedBillOfMaterialsResourceManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Resources.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class CostedBillOfMaterialsResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CostedBillOfMaterialsResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class CostedBillOfMaterialsResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CostedBillOfMaterialsResourceManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Resources.CostedBillOfMaterials.CostedBillOfMaterialsResourceManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsResourceManager Members
CompuTec.ProcessForce.API.Resources.CostedBillOfMaterials Namespace


CostedBillOfMaterialsResourceManager Members

CostedBillOfMaterialsResourceManager Class Methods See Also

The following tables list the members exposed by the CostedBillOfMaterialsResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

CostedBillOfMaterialsResourceManager Class
CompuTec.ProcessForce.API.Resources.CostedBillOfMaterials Namespace


CostedBillOfMaterialsResourceManager Methods

CostedBillOfMaterialsResourceManager Class See Also

The following tables list the members exposed by the CostedBillOfMaterialsResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

CostedBillOfMaterialsResourceManager Class
CompuTec.ProcessForce.API.Resources.CostedBillOfMaterials Namespace


CostedBillOfMaterialsResourceManager.GetResurce Method

Namespace: CompuTec.ProcessForce.API.Resources.CostedBillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResurce( _
   ByVal ResourceName As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResurce(
   string ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResurce(
   String^ ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResurce(
    ResourceName : String
) : String;
This language is not supported or no code example is available.

Parameters

ResourceName

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostedBillOfMaterialsResourceManager Class
CostedBillOfMaterialsResourceManager Members
CompuTec.ProcessForce.API.Resources.CostedBillOfMaterials Namespace


CompuTec.ProcessForce.API.Resources.Costing Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | QueryResourceManager | Manages the SQL queries stored in the resource files.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


QueryResourceManager Class

Members See Also

Manages the SQL queries stored in the resource files.

Namespace: CompuTec.ProcessForce.API.Resources.Costing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QueryResourceManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Resources.Costing.QueryResourceManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QueryResourceManager Members
CompuTec.ProcessForce.API.Resources.Costing Namespace


QueryResourceManager Members

QueryResourceManager Class Methods See Also

Manages the SQL queries stored in the resource files.

The following tables list the members exposed by the QueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce | Gets the content of a resource.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QueryResourceManager Class
CompuTec.ProcessForce.API.Resources.Costing Namespace


QueryResourceManager Methods

QueryResourceManager Class See Also

The following tables list the members exposed by the QueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce | Gets the content of a resource.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QueryResourceManager Class
CompuTec.ProcessForce.API.Resources.Costing Namespace


QueryResourceManager.GetResurce Method

Gets the content of a resource.

Namespace: CompuTec.ProcessForce.API.Resources.Costing
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResurce( _
   ByVal ResourceName As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResurce(
   string ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResurce(
   String^ ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResurce(
    ResourceName : String
) : String;
This language is not supported or no code example is available.

Parameters

ResourceName

Type: string

Resource name.

Return Value

Type: string

String object that represents the value of a specified resource.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QueryResourceManager Class
QueryResourceManager Members
CompuTec.ProcessForce.API.Resources.Costing Namespace


CompuTec.ProcessForce.API.Resources.Ingredients Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | IngredientsQueryResourceManager |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IngredientsQueryResourceManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Resources.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class IngredientsQueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class IngredientsQueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class IngredientsQueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class IngredientsQueryResourceManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Resources.Ingredients.IngredientsQueryResourceManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IngredientsQueryResourceManager Members
CompuTec.ProcessForce.API.Resources.Ingredients Namespace


IngredientsQueryResourceManager Members

IngredientsQueryResourceManager Class Methods See Also

The following tables list the members exposed by the IngredientsQueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

IngredientsQueryResourceManager Class
CompuTec.ProcessForce.API.Resources.Ingredients Namespace


IngredientsQueryResourceManager Methods

IngredientsQueryResourceManager Class See Also

The following tables list the members exposed by the IngredientsQueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

IngredientsQueryResourceManager Class
CompuTec.ProcessForce.API.Resources.Ingredients Namespace


IngredientsQueryResourceManager.GetResurce Method

Namespace: CompuTec.ProcessForce.API.Resources.Ingredients
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResurce( _
   ByVal ResourceName As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResurce(
   string ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResurce(
   String^ ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResurce(
    ResourceName : String
) : String;
This language is not supported or no code example is available.

Parameters

ResourceName

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IngredientsQueryResourceManager Class
IngredientsQueryResourceManager Members
CompuTec.ProcessForce.API.Resources.Ingredients Namespace


CompuTec.ProcessForce.API.Resources.ItemDetails Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | QueryResourceManager |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


QueryResourceManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Resources.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QueryResourceManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Resources.ItemDetails.QueryResourceManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QueryResourceManager Members
CompuTec.ProcessForce.API.Resources.ItemDetails Namespace


QueryResourceManager Members

QueryResourceManager Class Methods See Also

The following tables list the members exposed by the QueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QueryResourceManager Class
CompuTec.ProcessForce.API.Resources.ItemDetails Namespace


QueryResourceManager Methods

QueryResourceManager Class See Also

The following tables list the members exposed by the QueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QueryResourceManager Class
CompuTec.ProcessForce.API.Resources.ItemDetails Namespace


QueryResourceManager.GetResurce Method

Namespace: CompuTec.ProcessForce.API.Resources.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResurce( _
   ByVal ResourceName As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResurce(
   string ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResurce(
   String^ ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResurce(
    ResourceName : String
) : String;
This language is not supported or no code example is available.

Parameters

ResourceName

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QueryResourceManager Class
QueryResourceManager Members
CompuTec.ProcessForce.API.Resources.ItemDetails Namespace


CompuTec.ProcessForce.API.Resources.MORSelector Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | MORSelectorResourceManager |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


MORSelectorResourceManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Resources.MORSelector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MORSelectorResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MORSelectorResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MORSelectorResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MORSelectorResourceManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Resources.MORSelector.MORSelectorResourceManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MORSelectorResourceManager Members
CompuTec.ProcessForce.API.Resources.MORSelector Namespace


MORSelectorResourceManager Members

MORSelectorResourceManager Class Methods See Also

The following tables list the members exposed by the MORSelectorResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MORSelectorResourceManager Class
CompuTec.ProcessForce.API.Resources.MORSelector Namespace


MORSelectorResourceManager Methods

MORSelectorResourceManager Class See Also

The following tables list the members exposed by the MORSelectorResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MORSelectorResourceManager Class
CompuTec.ProcessForce.API.Resources.MORSelector Namespace


MORSelectorResourceManager.GetResurce Method

Namespace: CompuTec.ProcessForce.API.Resources.MORSelector
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResurce( _
   ByVal ResourceName As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResurce(
   string ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResurce(
   String^ ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResurce(
    ResourceName : String
) : String;
This language is not supported or no code example is available.

Parameters

ResourceName

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MORSelectorResourceManager Class
MORSelectorResourceManager Members
CompuTec.ProcessForce.API.Resources.MORSelector Namespace


CompuTec.ProcessForce.API.Resources.MRP Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | QueryResourceManager | Manages the SQL queries stored in the resource files.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


QueryResourceManager Class

Members See Also

Manages the SQL queries stored in the resource files.

Namespace: CompuTec.ProcessForce.API.Resources.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QueryResourceManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Resources.MRP.QueryResourceManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QueryResourceManager Members
CompuTec.ProcessForce.API.Resources.MRP Namespace


QueryResourceManager Members

QueryResourceManager Class Methods See Also

Manages the SQL queries stored in the resource files.

The following tables list the members exposed by the QueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce | Gets the content of a resource.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QueryResourceManager Class
CompuTec.ProcessForce.API.Resources.MRP Namespace


QueryResourceManager Methods

QueryResourceManager Class See Also

The following tables list the members exposed by the QueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce | Gets the content of a resource.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QueryResourceManager Class
CompuTec.ProcessForce.API.Resources.MRP Namespace


QueryResourceManager.GetResurce Method

Gets the content of a resource.

Namespace: CompuTec.ProcessForce.API.Resources.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResurce( _
   ByVal ResourceName As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResurce(
   string ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResurce(
   String^ ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResurce(
    ResourceName : String
) : String;
This language is not supported or no code example is available.

Parameters

ResourceName

Type: string

Resource name.

Return Value

Type: string

String object that represents the value of a specified resource.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QueryResourceManager Class
QueryResourceManager Members
CompuTec.ProcessForce.API.Resources.MRP Namespace


CompuTec.ProcessForce.API.Resources.Maintanance Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | QueryResourceManager |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


QueryResourceManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Resources.Maintanance
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QueryResourceManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Resources.Maintanance.QueryResourceManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QueryResourceManager Members
CompuTec.ProcessForce.API.Resources.Maintanance Namespace


QueryResourceManager Members

QueryResourceManager Class Methods See Also

The following tables list the members exposed by the QueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce | Gets the content of a resource.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QueryResourceManager Class
CompuTec.ProcessForce.API.Resources.Maintanance Namespace


QueryResourceManager Methods

QueryResourceManager Class See Also

The following tables list the members exposed by the QueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce | Gets the content of a resource.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QueryResourceManager Class
CompuTec.ProcessForce.API.Resources.Maintanance Namespace


QueryResourceManager.GetResurce Method

Gets the content of a resource.

Namespace: CompuTec.ProcessForce.API.Resources.Maintanance
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResurce( _
   ByVal ResourceName As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResurce(
   string ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResurce(
   String^ ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResurce(
    ResourceName : String
) : String;
This language is not supported or no code example is available.

Parameters

ResourceName

Type: string

Resource name.

Return Value

Type: string

String object that represents the value of a specified resource.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QueryResourceManager Class
QueryResourceManager Members
CompuTec.ProcessForce.API.Resources.Maintanance Namespace


CompuTec.ProcessForce.API.Resources.PickAndPack Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | PickAndPackResourceManager |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


PickAndPackResourceManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Resources.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class PickAndPackResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PickAndPackResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class PickAndPackResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PickAndPackResourceManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Resources.PickAndPack.PickAndPackResourceManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackResourceManager Members
CompuTec.ProcessForce.API.Resources.PickAndPack Namespace


PickAndPackResourceManager Members

PickAndPackResourceManager Class Methods See Also

The following tables list the members exposed by the PickAndPackResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PickAndPackResourceManager Class
CompuTec.ProcessForce.API.Resources.PickAndPack Namespace


PickAndPackResourceManager Methods

PickAndPackResourceManager Class See Also

The following tables list the members exposed by the PickAndPackResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PickAndPackResourceManager Class
CompuTec.ProcessForce.API.Resources.PickAndPack Namespace


PickAndPackResourceManager.GetResurce Method

Namespace: CompuTec.ProcessForce.API.Resources.PickAndPack
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResurce( _
   ByVal ResourceName As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResurce(
   string ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResurce(
   String^ ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResurce(
    ResourceName : String
) : String;
This language is not supported or no code example is available.

Parameters

ResourceName

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAndPackResourceManager Class
PickAndPackResourceManager Members
CompuTec.ProcessForce.API.Resources.PickAndPack Namespace


CompuTec.ProcessForce.API.Resources.PlanningCostingDetails Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | PlanningDetailsQueryResourceManager |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


PlanningDetailsQueryResourceManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Resources.PlanningCostingDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class PlanningDetailsQueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PlanningDetailsQueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class PlanningDetailsQueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PlanningDetailsQueryResourceManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Resources.PlanningCostingDetails.PlanningDetailsQueryResourceManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PlanningDetailsQueryResourceManager Members
CompuTec.ProcessForce.API.Resources.PlanningCostingDetails Namespace


PlanningDetailsQueryResourceManager Members

PlanningDetailsQueryResourceManager Class Methods See Also

The following tables list the members exposed by the PlanningDetailsQueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PlanningDetailsQueryResourceManager Class
CompuTec.ProcessForce.API.Resources.PlanningCostingDetails Namespace


PlanningDetailsQueryResourceManager Methods

PlanningDetailsQueryResourceManager Class See Also

The following tables list the members exposed by the PlanningDetailsQueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PlanningDetailsQueryResourceManager Class
CompuTec.ProcessForce.API.Resources.PlanningCostingDetails Namespace


PlanningDetailsQueryResourceManager.GetResurce Method

Namespace: CompuTec.ProcessForce.API.Resources.PlanningCostingDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResurce( _
   ByVal ResourceName As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResurce(
   string ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResurce(
   String^ ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResurce(
    ResourceName : String
) : String;
This language is not supported or no code example is available.

Parameters

ResourceName

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PlanningDetailsQueryResourceManager Class
PlanningDetailsQueryResourceManager Members
CompuTec.ProcessForce.API.Resources.PlanningCostingDetails Namespace


CompuTec.ProcessForce.API.Resources.QualityControl Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | QueryResourceManager | Manages the SQL queries stored in the resource files.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


QueryResourceManager Class

Members See Also

Manages the SQL queries stored in the resource files.

Namespace: CompuTec.ProcessForce.API.Resources.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QueryResourceManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Resources.QualityControl.QueryResourceManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QueryResourceManager Members
CompuTec.ProcessForce.API.Resources.QualityControl Namespace


QueryResourceManager Members

QueryResourceManager Class Methods See Also

Manages the SQL queries stored in the resource files.

The following tables list the members exposed by the QueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce | Gets the content of a resource.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QueryResourceManager Class
CompuTec.ProcessForce.API.Resources.QualityControl Namespace


QueryResourceManager Methods

QueryResourceManager Class See Also

The following tables list the members exposed by the QueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce | Gets the content of a resource.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QueryResourceManager Class
CompuTec.ProcessForce.API.Resources.QualityControl Namespace


QueryResourceManager.GetResurce Method

Gets the content of a resource.

Namespace: CompuTec.ProcessForce.API.Resources.QualityControl
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResurce( _
   ByVal ResourceName As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResurce(
   string ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResurce(
   String^ ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResurce(
    ResourceName : String
) : String;
This language is not supported or no code example is available.

Parameters

ResourceName

Type: string

Resource name.

Return Value

Type: string

String object that represents the value of a specified resource.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QueryResourceManager Class
QueryResourceManager Members
CompuTec.ProcessForce.API.Resources.QualityControl Namespace


CompuTec.ProcessForce.API.Resources.Scheduling Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | QueryResourceManager |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


QueryResourceManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Resources.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QueryResourceManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Resources.Scheduling.QueryResourceManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QueryResourceManager Members
CompuTec.ProcessForce.API.Resources.Scheduling Namespace


QueryResourceManager Members

QueryResourceManager Class Methods See Also

The following tables list the members exposed by the QueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QueryResourceManager Class
CompuTec.ProcessForce.API.Resources.Scheduling Namespace


QueryResourceManager Methods

QueryResourceManager Class See Also

The following tables list the members exposed by the QueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QueryResourceManager Class
CompuTec.ProcessForce.API.Resources.Scheduling Namespace


QueryResourceManager.GetResurce Method

Namespace: CompuTec.ProcessForce.API.Resources.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResurce( _
   ByVal ResourceName As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResurce(
   string ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResurce(
   String^ ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResurce(
    ResourceName : String
) : String;
This language is not supported or no code example is available.

Parameters

ResourceName

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QueryResourceManager Class
QueryResourceManager Members
CompuTec.ProcessForce.API.Resources.Scheduling Namespace


CompuTec.ProcessForce.API.Resources.SupplierScoreCard Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | SupplierScoreCardResourceManager |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


SupplierScoreCardResourceManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Resources.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SupplierScoreCardResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SupplierScoreCardResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SupplierScoreCardResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SupplierScoreCardResourceManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Resources.SupplierScoreCard.SupplierScoreCardResourceManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplierScoreCardResourceManager Members
CompuTec.ProcessForce.API.Resources.SupplierScoreCard Namespace


SupplierScoreCardResourceManager Members

SupplierScoreCardResourceManager Class Methods See Also

The following tables list the members exposed by the SupplierScoreCardResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SupplierScoreCardResourceManager Class
CompuTec.ProcessForce.API.Resources.SupplierScoreCard Namespace


SupplierScoreCardResourceManager Methods

SupplierScoreCardResourceManager Class See Also

The following tables list the members exposed by the SupplierScoreCardResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SupplierScoreCardResourceManager Class
CompuTec.ProcessForce.API.Resources.SupplierScoreCard Namespace


SupplierScoreCardResourceManager.GetResurce Method

Namespace: CompuTec.ProcessForce.API.Resources.SupplierScoreCard
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResurce( _
   ByVal ResourceName As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResurce(
   string ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResurce(
   String^ ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResurce(
    ResourceName : String
) : String;
This language is not supported or no code example is available.

Parameters

ResourceName

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplierScoreCardResourceManager Class
SupplierScoreCardResourceManager Members
CompuTec.ProcessForce.API.Resources.SupplierScoreCard Namespace


CompuTec.ProcessForce.API.Resources.System Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | QueryResourceManager |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


QueryResourceManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Resources.System
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QueryResourceManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Resources.System.QueryResourceManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QueryResourceManager Members
CompuTec.ProcessForce.API.Resources.System Namespace


QueryResourceManager Members

QueryResourceManager Class Methods See Also

The following tables list the members exposed by the QueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QueryResourceManager Class
CompuTec.ProcessForce.API.Resources.System Namespace


QueryResourceManager Methods

QueryResourceManager Class See Also

The following tables list the members exposed by the QueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QueryResourceManager Class
CompuTec.ProcessForce.API.Resources.System Namespace


QueryResourceManager.GetResurce Method

Namespace: CompuTec.ProcessForce.API.Resources.System
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResurce( _
   ByVal ResourceName As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResurce(
   string ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResurce(
   String^ ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResurce(
    ResourceName : String
) : String;
This language is not supported or no code example is available.

Parameters

ResourceName

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QueryResourceManager Class
QueryResourceManager Members
CompuTec.ProcessForce.API.Resources.System Namespace


CompuTec.ProcessForce.API.Resources.Technology Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | QueryResourceManager |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


QueryResourceManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Resources.Technology
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class QueryResourceManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QueryResourceManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Resources.Technology.QueryResourceManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QueryResourceManager Members
CompuTec.ProcessForce.API.Resources.Technology Namespace


QueryResourceManager Members

QueryResourceManager Class Methods See Also

The following tables list the members exposed by the QueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QueryResourceManager Class
CompuTec.ProcessForce.API.Resources.Technology Namespace


QueryResourceManager Methods

QueryResourceManager Class See Also

The following tables list the members exposed by the QueryResourceManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetResurce |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QueryResourceManager Class
CompuTec.ProcessForce.API.Resources.Technology Namespace


QueryResourceManager.GetResurce Method

Namespace: CompuTec.ProcessForce.API.Resources.Technology
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResurce( _
   ByVal ResourceName As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResurce(
   string ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResurce(
   String^ ResourceName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResurce(
    ResourceName : String
) : String;
This language is not supported or no code example is available.

Parameters

ResourceName

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QueryResourceManager Class
QueryResourceManager Members
CompuTec.ProcessForce.API.Resources.Technology Namespace


CompuTec.ProcessForce.API.Scheduling.Core Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | CoreSchedule |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


CoreSchedule Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Scheduling.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class CoreSchedule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class CoreSchedule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class CoreSchedule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class CoreSchedule
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Scheduling.Core.CoreSchedule
CompuTec.ProcessForce.API.Scheduling.BaseSchedule
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CoreSchedule Members
CompuTec.ProcessForce.API.Scheduling.Core Namespace


CoreSchedule Members

CoreSchedule Class Constructors Methods Fields Properties See Also

The following tables list the members exposed by the CoreSchedule type.

Constructors
 | Name | Description
Public constructor | CoreSchedule |
Top
Properties
 | Name | Description
Public property | ResourceCode |
Public property | ResourceName |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAvailbleEffort | This Function Checks Resource calendar and calculates What effort is availble between these two dates
Public method | GetFinish |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetIntervalsForSpecificDays |
Public method | GetIntervalsForSpecificRange |
Public method | GetNextWorkingTime |
Public method | GetPreviousWorkingTime |
Public method | GetStart |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
 | Name | Description
 | DayOfWeekTable |
Public field | holidays |
Public field | standardweek |
Public field | workexceptions |
Top
See Also

Reference

CoreSchedule Class
CompuTec.ProcessForce.API.Scheduling.Core Namespace


CoreSchedule Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CoreSchedule(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CoreSchedule(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CoreSchedule(
    token : String
);
This language is not supported or no code example is available.

Parameters

token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CoreSchedule Class
CoreSchedule Members
CompuTec.ProcessForce.API.Scheduling.Core Namespace


CoreSchedule Properties

CoreSchedule Class See Also

The following tables list the members exposed by the CoreSchedule type.

Properties
 | Name | Description
Public property | ResourceCode |
Public property | ResourceName |
Top
See Also

Reference

CoreSchedule Class
CompuTec.ProcessForce.API.Scheduling.Core Namespace


CoreSchedule.ResourceCode Property

Namespace: CompuTec.ProcessForce.API.Scheduling.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ResourceCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ResourceCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ResourceCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ResourceCode() : String;
public function set ResourceCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CoreSchedule Class
CoreSchedule Members
CompuTec.ProcessForce.API.Scheduling.Core Namespace


CoreSchedule.ResourceName Property

Namespace: CompuTec.ProcessForce.API.Scheduling.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ResourceName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ResourceName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ResourceName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ResourceName() : String;
public function set ResourceName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CoreSchedule Class
CoreSchedule Members
CompuTec.ProcessForce.API.Scheduling.Core Namespace


CoreSchedule Methods

CoreSchedule Class See Also

The following tables list the members exposed by the CoreSchedule type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAvailbleEffort | This Function Checks Resource calendar and calculates What effort is availble between these two dates
Public method | GetFinish |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetIntervalsForSpecificDays |
Public method | GetIntervalsForSpecificRange |
Public method | GetNextWorkingTime |
Public method | GetPreviousWorkingTime |
Public method | GetStart |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

CoreSchedule Class
CompuTec.ProcessForce.API.Scheduling.Core Namespace


CoreSchedule.GetAvailbleEffort Method

This Function Checks Resource calendar and calculates What effort is availble between these two dates

Namespace: CompuTec.ProcessForce.API.Scheduling.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAvailbleEffort( _
   ByVal from As Date, _
   ByVal to As Date _
) As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan GetAvailbleEffort(
   DateTime from,
   DateTime to
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeSpan GetAvailbleEffort(
   DateTime from,
   DateTime to
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAvailbleEffort(
    from : DateTime,
    to : DateTime
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

from

Type: DateTime

to

Type: DateTime

Return Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CoreSchedule Class
CoreSchedule Members
CompuTec.ProcessForce.API.Scheduling.Core Namespace


CoreSchedule.GetFinish Method

Namespace: CompuTec.ProcessForce.API.Scheduling.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetFinish( _
   ByVal start As Date, _
   ByVal Effort As TimeSpan _
) As Nullable(Of Date)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Nullable<DateTime> GetFinish(
   DateTime start,
   TimeSpan Effort
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Nullable<DateTime> GetFinish(
   DateTime start,
   TimeSpan Effort
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

start

Type: DateTime

Effort

Type: TimeSpan

Return Value

Type: Nullable<DateTime>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CoreSchedule Class
CoreSchedule Members
CompuTec.ProcessForce.API.Scheduling.Core Namespace


CoreSchedule.GetIntervalsForSpecificDays Method

Namespace: CompuTec.ProcessForce.API.Scheduling.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overridable Function GetIntervalsForSpecificDays( _
   ByVal day As Date _
) As TimeIntervals
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public virtual TimeIntervals GetIntervalsForSpecificDays(
   DateTime day
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
virtual TimeIntervals^ GetIntervalsForSpecificDays(
   DateTime day
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetIntervalsForSpecificDays(
    day : DateTime
) : TimeIntervals;
This language is not supported or no code example is available.

Parameters

day

Type: DateTime

Return Value

Type: TimeIntervals
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CoreSchedule Class
CoreSchedule Members
CompuTec.ProcessForce.API.Scheduling.Core Namespace


CoreSchedule.GetIntervalsForSpecificRange Method

Namespace: CompuTec.ProcessForce.API.Scheduling.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overridable Shadows Function GetIntervalsForSpecificRange( _
   ByVal start As Date, _
   ByVal end As Date _
) As List(Of ITimeInterval)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
new public virtual List<ITimeInterval> GetIntervalsForSpecificRange(
   DateTime start,
   DateTime end
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
virtual List<ITimeInterval^>^ GetIntervalsForSpecificRange(
   DateTime start,
   DateTime end
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

start

Type: DateTime

end

Type: DateTime

Return Value

Type: List<ITimeInterval>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CoreSchedule Class
CoreSchedule Members
CompuTec.ProcessForce.API.Scheduling.Core Namespace


CoreSchedule.GetNextWorkingTime Method

Namespace: CompuTec.ProcessForce.API.Scheduling.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetNextWorkingTime( _
   ByVal start As Date _
) As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime GetNextWorkingTime(
   DateTime start
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DateTime GetNextWorkingTime(
   DateTime start
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetNextWorkingTime(
    start : DateTime
) : DateTime;
This language is not supported or no code example is available.

Parameters

start

Type: DateTime

Return Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CoreSchedule Class
CoreSchedule Members
CompuTec.ProcessForce.API.Scheduling.Core Namespace


CoreSchedule.GetPreviousWorkingTime Method

Namespace: CompuTec.ProcessForce.API.Scheduling.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetPreviousWorkingTime( _
   ByVal start As Date _
) As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime GetPreviousWorkingTime(
   DateTime start
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DateTime GetPreviousWorkingTime(
   DateTime start
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetPreviousWorkingTime(
    start : DateTime
) : DateTime;
This language is not supported or no code example is available.

Parameters

start

Type: DateTime

Return Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CoreSchedule Class
CoreSchedule Members
CompuTec.ProcessForce.API.Scheduling.Core Namespace


CoreSchedule.GetStart Method

Namespace: CompuTec.ProcessForce.API.Scheduling.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetStart( _
   ByVal finish As Date, _
   ByVal Effort As TimeSpan _
) As Nullable(Of Date)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Nullable<DateTime> GetStart(
   DateTime finish,
   TimeSpan Effort
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Nullable<DateTime> GetStart(
   DateTime finish,
   TimeSpan Effort
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

finish

Type: DateTime

Effort

Type: TimeSpan

Return Value

Type: Nullable<DateTime>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CoreSchedule Class
CoreSchedule Members
CompuTec.ProcessForce.API.Scheduling.Core Namespace


CoreSchedule Fields

CoreSchedule Class See Also

The following tables list the members exposed by the CoreSchedule type.

Fields
 | Name | Description
 | DayOfWeekTable |
Public field | holidays |
Public field | standardweek |
Public field | workexceptions |
Top
See Also

Reference

CoreSchedule Class
CompuTec.ProcessForce.API.Scheduling.Core Namespace


DayOfWeekTable Field

Namespace: CompuTec.ProcessForce.API.Scheduling.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<XmlIgnore()> _
Public Shared Shadows DayOfWeekTable As String()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlIgnore()]
new public static string[] DayOfWeekTable
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlIgnore()]
public:
static array< String^ >^ DayOfWeekTable;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   XmlIgnore()
static DayOfWeekTable : String[]
This language is not supported or no code example is available.

Field Value

Type: string[]
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CoreSchedule Class
CoreSchedule Members
CompuTec.ProcessForce.API.Scheduling.Core Namespace


holidays Field

Namespace: CompuTec.ProcessForce.API.Scheduling.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public holidays As List(Of Date)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<DateTime> holidays
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<DateTime>^ holidays;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Field Value

Type: List<DateTime>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CoreSchedule Class
CoreSchedule Members
CompuTec.ProcessForce.API.Scheduling.Core Namespace


standardweek Field

Namespace: CompuTec.ProcessForce.API.Scheduling.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public standardweek As Dictionary(Of DayOfWeek, TimeIntervals)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Dictionary<DayOfWeek, TimeIntervals> standardweek
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Dictionary<DayOfWeek, TimeIntervals^>^ standardweek;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Field Value

Type: Dictionary<DayOfWeek, TimeIntervals>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CoreSchedule Class
CoreSchedule Members
CompuTec.ProcessForce.API.Scheduling.Core Namespace


workexceptions Field

Namespace: CompuTec.ProcessForce.API.Scheduling.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public workexceptions As Dictionary(Of Date, TimeIntervals)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Dictionary<DateTime, TimeIntervals> workexceptions
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Dictionary<DateTime, TimeIntervals^>^ workexceptions;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Field Value

Type: Dictionary<DateTime, TimeIntervals>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CoreSchedule Class
CoreSchedule Members
CompuTec.ProcessForce.API.Scheduling.Core Namespace


CompuTec.ProcessForce.API.Scheduling.Helpers Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | TaskStatusHelper |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


TaskStatusHelper Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Scheduling.Helpers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class TaskStatusHelper
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class TaskStatusHelper
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class TaskStatusHelper
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class TaskStatusHelper
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Scheduling.Helpers.TaskStatusHelper
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TaskStatusHelper Members
CompuTec.ProcessForce.API.Scheduling.Helpers Namespace


TaskStatusHelper Members

TaskStatusHelper Class Methods Properties See Also

The following tables list the members exposed by the TaskStatusHelper type.

Properties
 | Name | Description
Public property | DocEntry |
Public property | LineNum |
Public property | MinStart |
Public property | Quantity |
Public property | TaskStatus |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetTaskStatusForMors |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | MakeTaskStatusObjectFromSingleMOR |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

TaskStatusHelper Class
CompuTec.ProcessForce.API.Scheduling.Helpers Namespace


TaskStatusHelper Properties

TaskStatusHelper Class See Also

The following tables list the members exposed by the TaskStatusHelper type.

Properties
 | Name | Description
Public property | DocEntry |
Public property | LineNum |
Public property | MinStart |
Public property | Quantity |
Public property | TaskStatus |
Top
See Also

Reference

TaskStatusHelper Class
CompuTec.ProcessForce.API.Scheduling.Helpers Namespace


TaskStatusHelper.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Scheduling.Helpers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DocEntry() As Integer
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TaskStatusHelper Class
TaskStatusHelper Members
CompuTec.ProcessForce.API.Scheduling.Helpers Namespace


TaskStatusHelper.LineNum Property

Namespace: CompuTec.ProcessForce.API.Scheduling.Helpers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property LineNum() As Integer
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int LineNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int LineNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get LineNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TaskStatusHelper Class
TaskStatusHelper Members
CompuTec.ProcessForce.API.Scheduling.Helpers Namespace


TaskStatusHelper.MinStart Property

Namespace: CompuTec.ProcessForce.API.Scheduling.Helpers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property MinStart() As Date
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime MinStart {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime MinStart {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get MinStart() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TaskStatusHelper Class
TaskStatusHelper Members
CompuTec.ProcessForce.API.Scheduling.Helpers Namespace


TaskStatusHelper.Quantity Property

Namespace: CompuTec.ProcessForce.API.Scheduling.Helpers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Quantity() As Double
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double Quantity {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property double Quantity {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Quantity() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TaskStatusHelper Class
TaskStatusHelper Members
CompuTec.ProcessForce.API.Scheduling.Helpers Namespace


TaskStatusHelper.TaskStatus Property

Namespace: CompuTec.ProcessForce.API.Scheduling.Helpers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property TaskStatus() As Integer
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int TaskStatus {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int TaskStatus {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get TaskStatus() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TaskStatusHelper Class
TaskStatusHelper Members
CompuTec.ProcessForce.API.Scheduling.Helpers Namespace


TaskStatusHelper Methods

TaskStatusHelper Class See Also

The following tables list the members exposed by the TaskStatusHelper type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetTaskStatusForMors |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | MakeTaskStatusObjectFromSingleMOR |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

TaskStatusHelper Class
CompuTec.ProcessForce.API.Scheduling.Helpers Namespace


TaskStatusHelper.GetTaskStatusForMors Method

Namespace: CompuTec.ProcessForce.API.Scheduling.Helpers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetTaskStatusForMors( _
   ByVal Token As String, _
   ByVal keys As IEnumerable(Of Integer) _
) As List(Of TaskStatusHelper)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static List<TaskStatusHelper> GetTaskStatusForMors(
   string Token,
   IEnumerable<int> keys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static List<TaskStatusHelper^>^ GetTaskStatusForMors(
   String^ Token,
   IEnumerable<int>^ keys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

keys

Type: IEnumerable<int>

Return Value

Type: List<TaskStatusHelper>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TaskStatusHelper Class
TaskStatusHelper Members
CompuTec.ProcessForce.API.Scheduling.Helpers Namespace


TaskStatusHelper.MakeTaskStatusObjectFromSingleMOR Method

Namespace: CompuTec.ProcessForce.API.Scheduling.Helpers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function MakeTaskStatusObjectFromSingleMOR( _
   ByVal Token As String, _
   ByVal mor As IManufacturingOrder _
) As TaskStatusHelper
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static TaskStatusHelper MakeTaskStatusObjectFromSingleMOR(
   string Token,
   IManufacturingOrder mor
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static TaskStatusHelper^ MakeTaskStatusObjectFromSingleMOR(
   String^ Token,
   IManufacturingOrder^ mor
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function MakeTaskStatusObjectFromSingleMOR(
    Token : String,
    mor : IManufacturingOrder
) : TaskStatusHelper;
This language is not supported or no code example is available.

Parameters

Token

Type: string

mor

Type: IManufacturingOrder

Return Value

Type: TaskStatusHelper
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TaskStatusHelper Class
TaskStatusHelper Members
CompuTec.ProcessForce.API.Scheduling.Helpers Namespace


CompuTec.ProcessForce.API.Tools.Converters Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | PriceCurrencyConverter | Converts System.String object that represents the price and currency to a corresponding value according to SAP Business One's format configuration.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


PriceCurrencyConverter Class

Members See Also

Converts System.String object that represents the price and currency to a corresponding value according to SAP Business One's format configuration.

Namespace: CompuTec.ProcessForce.API.Tools.Converters
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class PriceCurrencyConverter
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PriceCurrencyConverter
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class PriceCurrencyConverter
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PriceCurrencyConverter
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.Converters.PriceCurrencyConverter
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PriceCurrencyConverter Members
CompuTec.ProcessForce.API.Tools.Converters Namespace


PriceCurrencyConverter Members

PriceCurrencyConverter Class Constructors Methods Properties See Also

Converts System.String object that represents the price and currency to a corresponding value according to SAP Business One's format configuration.

The following tables list the members exposed by the PriceCurrencyConverter type.

Constructors
 | Name | Description
Public constructor | PriceCurrencyConverter | Initializes a new instance of the PriceCurrencyConverter class.
Top
Properties
 | Name | Description
Public property | ConvertedValue | Gets or sets the converted price and currency code value.
Public property | CurrencyCode | Gets or sets the extracted currency code.
Public property | Price | Gets or sets the extracted price.
Public property | Token | Gets or sets the token for SQL queries.
Public property | ValueToConvert | Gets or sets the value to convert.
Top
Methods
 | Name | Description
Public method | Convert | Converts the provided value to a corresponding value according to SAP Business One's format configuration.
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PriceCurrencyConverter Class
CompuTec.ProcessForce.API.Tools.Converters Namespace


PriceCurrencyConverter Constructor

Initializes a new instance of the PriceCurrencyConverter class.

Namespace: CompuTec.ProcessForce.API.Tools.Converters
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String, _
   ByVal valueToConvert As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public PriceCurrencyConverter(
   string token,
   string valueToConvert
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
PriceCurrencyConverter(
   String^ token,
   String^ valueToConvert
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function PriceCurrencyConverter(
    token : String,
    valueToConvert : String
);
This language is not supported or no code example is available.

Parameters

token

Type: string

Token.

valueToConvert

Type: string

System.String object to convert.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PriceCurrencyConverter Class
PriceCurrencyConverter Members
CompuTec.ProcessForce.API.Tools.Converters Namespace


PriceCurrencyConverter Properties

PriceCurrencyConverter Class See Also

The following tables list the members exposed by the PriceCurrencyConverter type.

Properties
 | Name | Description
Public property | ConvertedValue | Gets or sets the converted price and currency code value.
Public property | CurrencyCode | Gets or sets the extracted currency code.
Public property | Price | Gets or sets the extracted price.
Public property | Token | Gets or sets the token for SQL queries.
Public property | ValueToConvert | Gets or sets the value to convert.
Top
See Also

Reference

PriceCurrencyConverter Class
CompuTec.ProcessForce.API.Tools.Converters Namespace


PriceCurrencyConverter.ConvertedValue Property

Gets or sets the converted price and currency code value.

Namespace: CompuTec.ProcessForce.API.Tools.Converters
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ConvertedValue() As String
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ConvertedValue {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ConvertedValue {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ConvertedValue() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PriceCurrencyConverter Class
PriceCurrencyConverter Members
CompuTec.ProcessForce.API.Tools.Converters Namespace


PriceCurrencyConverter.CurrencyCode Property

Gets or sets the extracted currency code.

Namespace: CompuTec.ProcessForce.API.Tools.Converters
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property CurrencyCode() As String
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string CurrencyCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ CurrencyCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get CurrencyCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PriceCurrencyConverter Class
PriceCurrencyConverter Members
CompuTec.ProcessForce.API.Tools.Converters Namespace


PriceCurrencyConverter.Price Property

Gets or sets the extracted price.

Namespace: CompuTec.ProcessForce.API.Tools.Converters
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Price() As Double
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double Price {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property double Price {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Price() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PriceCurrencyConverter Class
PriceCurrencyConverter Members
CompuTec.ProcessForce.API.Tools.Converters Namespace


PriceCurrencyConverter.Token Property

Gets or sets the token for SQL queries.

Namespace: CompuTec.ProcessForce.API.Tools.Converters
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Token() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Token {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Token {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Token() : String;
public function set Token(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PriceCurrencyConverter Class
PriceCurrencyConverter Members
CompuTec.ProcessForce.API.Tools.Converters Namespace


PriceCurrencyConverter.ValueToConvert Property

Gets or sets the value to convert.

Namespace: CompuTec.ProcessForce.API.Tools.Converters
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ValueToConvert() As String
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ValueToConvert {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ValueToConvert {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ValueToConvert() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PriceCurrencyConverter Class
PriceCurrencyConverter Members
CompuTec.ProcessForce.API.Tools.Converters Namespace


PriceCurrencyConverter Methods

PriceCurrencyConverter Class See Also

The following tables list the members exposed by the PriceCurrencyConverter type.

Methods
 | Name | Description
Public method | Convert | Converts the provided value to a corresponding value according to SAP Business One's format configuration.
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PriceCurrencyConverter Class
CompuTec.ProcessForce.API.Tools.Converters Namespace


PriceCurrencyConverter.Convert Method

Converts the provided value to a corresponding value according to SAP Business One's format configuration.

Namespace: CompuTec.ProcessForce.API.Tools.Converters
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function Convert( _
   Optional ByVal convertFromUi As Boolean = false _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool Convert(
   bool convertFromUi = false
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool Convert(
   bool convertFromUi
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Convert(
    convertFromUi : boolean
) : boolean;
This language is not supported or no code example is available.

Parameters

convertFromUi

Type: bool

Return Value

Type: bool

true if conversion was completed successfully; otherwise, false.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PriceCurrencyConverter Class
PriceCurrencyConverter Members
CompuTec.ProcessForce.API.Tools.Converters Namespace


CompuTec.ProcessForce.API.Tools.Correction Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | CorrectionModel |
Public class | Row |
Top
Interfaces
 | Name | Description
Public interface | Generator<T, K> |
Public interface | LineGererator<T> |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


CorrectionModel Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.Correction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class CorrectionModel
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CorrectionModel
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class CorrectionModel
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CorrectionModel
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.Correction.CorrectionModel
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CorrectionModel Members
CompuTec.ProcessForce.API.Tools.Correction Namespace


CorrectionModel Members

CorrectionModel Class Methods Properties See Also

The following tables list the members exposed by the CorrectionModel type.

Properties
 | Name | Description
Public property | Lines |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

CorrectionModel Class
CompuTec.ProcessForce.API.Tools.Correction Namespace


CorrectionModel Properties

CorrectionModel Class See Also

The following tables list the members exposed by the CorrectionModel type.

Properties
 | Name | Description
Public property | Lines |
Top
See Also

Reference

CorrectionModel Class
CompuTec.ProcessForce.API.Tools.Correction Namespace


CorrectionModel.Lines Property

Namespace: CompuTec.ProcessForce.API.Tools.Correction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Lines() As List(Of Row)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<Row> Lines {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<Row^>^ Lines {
 List<Row^>^ get( );
 void set(
   List<Row^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<Row>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CorrectionModel Class
CorrectionModel Members
CompuTec.ProcessForce.API.Tools.Correction Namespace


CorrectionModel Methods

CorrectionModel Class See Also

The following tables list the members exposed by the CorrectionModel type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

CorrectionModel Class
CompuTec.ProcessForce.API.Tools.Correction Namespace


Row Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.Correction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class Row
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Row
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class Row
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Row
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.Correction.Row
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Row Members
CompuTec.ProcessForce.API.Tools.Correction Namespace


Row Members

Row Class Methods Properties See Also

The following tables list the members exposed by the Row type.

Properties
 | Name | Description
Public property | Batches |
Public property | Bins |
Public property | LineTotal |
Public property | Serials |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Classes
 | Name | Description
Public class | Batch |
Public class | Bin |
Public class | Serial |
Top
See Also

Reference

Row Class
CompuTec.ProcessForce.API.Tools.Correction Namespace


Batch Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.Correction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class Batch
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Batch
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class Batch
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Batch
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.Correction.Row.Batch
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Batch Members
CompuTec.ProcessForce.API.Tools.Correction Namespace


Batch Members

Batch Class Methods See Also

The following tables list the members exposed by the Batch type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Batch Class
CompuTec.ProcessForce.API.Tools.Correction Namespace


Batch Methods

Batch Class See Also

The following tables list the members exposed by the Batch type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Batch Class
CompuTec.ProcessForce.API.Tools.Correction Namespace


Bin Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.Correction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class Bin
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Bin
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class Bin
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Bin
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.Correction.Row.Bin
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Bin Members
CompuTec.ProcessForce.API.Tools.Correction Namespace


Bin Members

Bin Class Methods Properties See Also

The following tables list the members exposed by the Bin type.

Properties
 | Name | Description
Public property | BinAbs |
Public property | Qty |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Bin Class
CompuTec.ProcessForce.API.Tools.Correction Namespace


Bin Properties

Bin Class See Also

The following tables list the members exposed by the Bin type.

Properties
 | Name | Description
Public property | BinAbs |
Public property | Qty |
Top
See Also

Reference

Bin Class
CompuTec.ProcessForce.API.Tools.Correction Namespace


Bin.BinAbs Property

Namespace: CompuTec.ProcessForce.API.Tools.Correction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property BinAbs() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int BinAbs {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int BinAbs {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get BinAbs() : int;
public function set BinAbs(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Bin Class
Bin Members
CompuTec.ProcessForce.API.Tools.Correction Namespace


Bin.Qty Property

Namespace: CompuTec.ProcessForce.API.Tools.Correction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Qty() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal Qty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal Qty {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Qty() : decimal;
public function set Qty(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Bin Class
Bin Members
CompuTec.ProcessForce.API.Tools.Correction Namespace


Bin Methods

Bin Class See Also

The following tables list the members exposed by the Bin type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Bin Class
CompuTec.ProcessForce.API.Tools.Correction Namespace


Serial Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.Correction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class Serial
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Serial
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class Serial
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Serial
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.Correction.Row.Serial
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Serial Members
CompuTec.ProcessForce.API.Tools.Correction Namespace


Serial Members

Serial Class Methods See Also

The following tables list the members exposed by the Serial type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Serial Class
CompuTec.ProcessForce.API.Tools.Correction Namespace


Serial Methods

Serial Class See Also

The following tables list the members exposed by the Serial type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Serial Class
CompuTec.ProcessForce.API.Tools.Correction Namespace


Row Properties

Row Class See Also

The following tables list the members exposed by the Row type.

Properties
 | Name | Description
Public property | Batches |
Public property | Bins |
Public property | LineTotal |
Public property | Serials |
Top
See Also

Reference

Row Class
CompuTec.ProcessForce.API.Tools.Correction Namespace


Row.Batches Property

Namespace: CompuTec.ProcessForce.API.Tools.Correction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Batches() As List(Of Batch)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<Batch> Batches {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<Batch^>^ Batches {
 List<Batch^>^ get( );
 void set(
   List<Batch^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<Batch>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Row Class
Row Members
CompuTec.ProcessForce.API.Tools.Correction Namespace


Row.Bins Property

Namespace: CompuTec.ProcessForce.API.Tools.Correction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Bins() As List(Of Bin)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<Bin> Bins {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<Bin^>^ Bins {
 List<Bin^>^ get( );
 void set(
   List<Bin^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<Bin>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Row Class
Row Members
CompuTec.ProcessForce.API.Tools.Correction Namespace


Row.LineTotal Property

Namespace: CompuTec.ProcessForce.API.Tools.Correction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property LineTotal() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal LineTotal {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal LineTotal {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get LineTotal() : decimal;
public function set LineTotal(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Row Class
Row Members
CompuTec.ProcessForce.API.Tools.Correction Namespace


Row.Serials Property

Namespace: CompuTec.ProcessForce.API.Tools.Correction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Serials() As List(Of Serial)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<Serial> Serials {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<Serial^>^ Serials {
 List<Serial^>^ get( );
 void set(
   List<Serial^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<Serial>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Row Class
Row Members
CompuTec.ProcessForce.API.Tools.Correction Namespace


Row Methods

Row Class See Also

The following tables list the members exposed by the Row type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Row Class
CompuTec.ProcessForce.API.Tools.Correction Namespace


Generator<T, K> Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.Correction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface Generator(Of  _
   T, _
   K)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface Generator<T, K>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
generic<typename T, typename K>
public interface class Generator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Type Parameters

T

K

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Generator<T, K> Members
CompuTec.ProcessForce.API.Tools.Correction Namespace


Generator<T, K> Members

Generator<T, K> Interface Methods Properties See Also

The following tables list the members exposed by the Generator<T, K> type.

Properties
 | Name | Description
Public property | MOR |
Public property | Pick |
Top
Methods
 | Name | Description
Public method | FIllReferencesonInputDocuments |
Public method | Generate |
Top
See Also

Reference

Generator<T, K> Interface
CompuTec.ProcessForce.API.Tools.Correction Namespace


Generator<T, K> Properties

Generator<T, K> Interface See Also

The following tables list the members exposed by the Generator<T, K> type.

Properties
 | Name | Description
Public property | MOR |
Public property | Pick |
Top
See Also

Reference

Generator<T, K> Interface
CompuTec.ProcessForce.API.Tools.Correction Namespace


Generator<T, K>.MOR Property

Namespace: CompuTec.ProcessForce.API.Tools.Correction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property MOR() As IManufacturingOrder
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IManufacturingOrder MOR {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IManufacturingOrder^ MOR {
 IManufacturingOrder^ get( );
 void set(
   IManufacturingOrder^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get MOR() : IManufacturingOrder;
function set MOR(value : IManufacturingOrder);
This language is not supported or no code example is available.

Property Value

Type: IManufacturingOrder
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Generator<T, K> Interface
Generator<T, K> Members
CompuTec.ProcessForce.API.Tools.Correction Namespace


Generator<T, K>.Pick Property

Namespace: CompuTec.ProcessForce.API.Tools.Correction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Pick() As K
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
K Pick {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property K^ Pick {
 K^ get( );
 void set(
   K^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Pick() : K;
function set Pick(value : K);
This language is not supported or no code example is available.

Property Value

Type: K
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Generator<T, K> Interface
Generator<T, K> Members
CompuTec.ProcessForce.API.Tools.Correction Namespace


Generator<T, K> Methods

Generator<T, K> Interface See Also

The following tables list the members exposed by the Generator<T, K> type.

Methods
 | Name | Description
Public method | FIllReferencesonInputDocuments |
Public method | Generate |
Top
See Also

Reference

Generator<T, K> Interface
CompuTec.ProcessForce.API.Tools.Correction Namespace


Generator<T, K>.FIllReferencesonInputDocuments Method

Namespace: CompuTec.ProcessForce.API.Tools.Correction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub FIllReferencesonInputDocuments()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void FIllReferencesonInputDocuments()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void FIllReferencesonInputDocuments()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function FIllReferencesonInputDocuments();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Generator<T, K> Interface
Generator<T, K> Members
CompuTec.ProcessForce.API.Tools.Correction Namespace


Generator<T, K>.Generate Method

Namespace: CompuTec.ProcessForce.API.Tools.Correction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Generate( _
   ByRef model As CorrectionModel, _
   ByVal BaseDocument As T _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Generate(
   out CorrectionModel model,
   T BaseDocument
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Generate(
   CorrectionModel^& model,
   T^ BaseDocument
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Generate(
    model : CorrectionModel,
    BaseDocument : T
);
This language is not supported or no code example is available.

Parameters

model

Type: CorrectionModel

BaseDocument

Type: T

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Generator<T, K> Interface
Generator<T, K> Members
CompuTec.ProcessForce.API.Tools.Correction Namespace


LineGererator<T> Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.Correction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface LineGererator(Of  _
   T)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface LineGererator<T>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
generic<typename T>
public interface class LineGererator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Type Parameters

T

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LineGererator<T> Members
CompuTec.ProcessForce.API.Tools.Correction Namespace


LineGererator<T> Members

LineGererator<T> Interface Methods See Also

The following tables list the members exposed by the LineGererator<T> type.

Methods
 | Name | Description
Public method | Generate |
Top
See Also

Reference

LineGererator<T> Interface
CompuTec.ProcessForce.API.Tools.Correction Namespace


LineGererator<T> Methods

LineGererator<T> Interface See Also

The following tables list the members exposed by the LineGererator<T> type.

Methods
 | Name | Description
Public method | Generate |
Top
See Also

Reference

LineGererator<T> Interface
CompuTec.ProcessForce.API.Tools.Correction Namespace


LineGererator<T>.Generate Method

Namespace: CompuTec.ProcessForce.API.Tools.Correction
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Generate( _
   ByRef model As CorrectionModel, _
   ByVal LineInCorrection As T _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Generate(
   ref CorrectionModel model,
   T LineInCorrection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Generate(
   CorrectionModel^& model,
   T^ LineInCorrection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Generate(
    model : CorrectionModel,
    LineInCorrection : T
);
This language is not supported or no code example is available.

Parameters

model

Type: CorrectionModel

LineInCorrection

Type: T

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LineGererator<T> Interface
LineGererator<T> Members
CompuTec.ProcessForce.API.Tools.Correction Namespace


CompuTec.ProcessForce.API.Tools.MRP Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Enumerations
 | Name | Description
Public enumeration | Direction |
Public enumeration | Source |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


Direction Enumeration

Namespace: CompuTec.ProcessForce.API.Tools.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
In |
Out |
See Also

Reference

CompuTec.ProcessForce.API.Tools.MRP Namespace


Source Enumeration

Namespace: CompuTec.ProcessForce.API.Tools.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Document |
MRP |
See Also

Reference

CompuTec.ProcessForce.API.Tools.MRP Namespace


CompuTec.ProcessForce.API.Tools.MRP.Data Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | InternalLeadManager |
Public class | MRPLink |
Public class | MRPPeriod |
Public class | MRPReport |
Public class | MRPResult |
Public class | MRPResultReference |
Public class | MRPResultRow |
Public class | MRPResults |
Public class | Recomendations |
Public class | RecomendationsLink |
Top
Interfaces
 | Name | Description
Public interface | IInputRestrictions |
Public interface | ILink |
Public interface | ILoader |
Public interface | IPathInitializator |
Public interface | IRecomendations |
Public interface | IRecomendationsLink |
Public interface | IWhsConfiguration |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


InternalLeadManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class InternalLeadManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class InternalLeadManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class InternalLeadManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class InternalLeadManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.InternalLeadManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InternalLeadManager Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


InternalLeadManager Members

InternalLeadManager Class Constructors Methods Properties See Also

The following tables list the members exposed by the InternalLeadManager type.

Constructors
 | Name | Description
Public constructor | InternalLeadManager |
Top
Properties
 | Name | Description
Public property | Enabled |
Public property | MRPManager |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetInternaTimeForRecomendationLine |
Public method | GetRule |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Initialize |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

InternalLeadManager Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


InternalLeadManager Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal manager As MRPManager _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public InternalLeadManager(
   MRPManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
InternalLeadManager(
   MRPManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function InternalLeadManager(
    manager : MRPManager
);
This language is not supported or no code example is available.

Parameters

manager

Type: MRPManager

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InternalLeadManager Class
InternalLeadManager Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


InternalLeadManager Properties

InternalLeadManager Class See Also

The following tables list the members exposed by the InternalLeadManager type.

Properties
 | Name | Description
Public property | Enabled |
Public property | MRPManager |
Top
See Also

Reference

InternalLeadManager Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


InternalLeadManager.Enabled Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Enabled() As Boolean
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool Enabled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool Enabled {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Enabled() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InternalLeadManager Class
InternalLeadManager Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


InternalLeadManager.MRPManager Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property MRPManager() As MRPManager
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MRPManager MRPManager {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property MRPManager^ MRPManager {
 MRPManager^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get MRPManager() : MRPManager;
This language is not supported or no code example is available.

Property Value

Type: MRPManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InternalLeadManager Class
InternalLeadManager Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


InternalLeadManager Methods

InternalLeadManager Class See Also

The following tables list the members exposed by the InternalLeadManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetInternaTimeForRecomendationLine |
Public method | GetRule |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Initialize |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

InternalLeadManager Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


InternalLeadManager.GetInternaTimeForRecomendationLine Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetInternaTimeForRecomendationLine( _
   ByVal path As IPathItem, _
   ByVal line As IDocLine _
) As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan GetInternaTimeForRecomendationLine(
   IPathItem path,
   IDocLine line
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeSpan GetInternaTimeForRecomendationLine(
   IPathItem^ path,
   IDocLine^ line
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetInternaTimeForRecomendationLine(
    path : IPathItem,
    line : IDocLine
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

path

Type: IPathItem

line

Type: IDocLine

Return Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InternalLeadManager Class
InternalLeadManager Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


InternalLeadManager.GetRule Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetRule( _
   ByVal head As IDoc _
) As IInternalLeadTimeRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IInternalLeadTimeRule GetRule(
   IDoc head
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IInternalLeadTimeRule^ GetRule(
   IDoc^ head
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetRule(
    head : IDoc
) : IInternalLeadTimeRule;
This language is not supported or no code example is available.

Parameters

head

Type: IDoc

Return Value

Type: IInternalLeadTimeRule
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InternalLeadManager Class
InternalLeadManager Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


InternalLeadManager.Initialize Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Initialize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Initialize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Initialize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Initialize();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InternalLeadManager Class
InternalLeadManager Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MRPLink
    Implements ILink
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPLink : ILink
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MRPLink  : public ILink^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPLink
   implements ILink
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.MRPLink
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink Members

MRPLink Class Methods Properties See Also

The following tables list the members exposed by the MRPLink type.

Properties
 | Name | Description
Public property | BomCode |
Public property | CalculatedDueDate |
Public property | DemandEntity |
Public property | DemandOwner |
Public property | DueDate |
Public property | GeneratedDocumentType |
Public property | InternalLeadTime |
Public property | IsBroken |
Public property | LeadTime |
Public property | Quantity |
Public property | ReleaseDate |
Public property | Source |
Public property | SourceDate |
Public property | SupplyEntity |
Public property | SupplyOwner |
Top
Methods
 | Name | Description
Public method | CalculateDatesForGeneratedEntity |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MRPLink Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink Properties

MRPLink Class See Also

The following tables list the members exposed by the MRPLink type.

Properties
 | Name | Description
Public property | BomCode |
Public property | CalculatedDueDate |
Public property | DemandEntity |
Public property | DemandOwner |
Public property | DueDate |
Public property | GeneratedDocumentType |
Public property | InternalLeadTime |
Public property | IsBroken |
Public property | LeadTime |
Public property | Quantity |
Public property | ReleaseDate |
Public property | Source |
Public property | SourceDate |
Public property | SupplyEntity |
Public property | SupplyOwner |
Top
See Also

Reference

MRPLink Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink.BomCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property BomCode() As String Implements  _
   ILink.BomCode
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string BomCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ BomCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get BomCode() : String;
public function set BomCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

ILink.BomCode
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPLink Class
MRPLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink.CalculatedDueDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property CalculatedDueDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime CalculatedDueDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime CalculatedDueDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get CalculatedDueDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPLink Class
MRPLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink.DemandEntity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DemandEntity() As IMRPEntity Implements  _
   ILink.DemandEntity
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IMRPEntity DemandEntity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IMRPEntity^ DemandEntity {
 IMRPEntity^ get( );
 void set(
   IMRPEntity^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DemandEntity() : IMRPEntity;
public function set DemandEntity(value : IMRPEntity);
This language is not supported or no code example is available.

Property Value

Type: IMRPEntity

Implements

ILink.DemandEntity
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPLink Class
MRPLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink.DemandOwner Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DemandOwner() As IPathItem Implements  _
   ILink.DemandOwner
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IPathItem DemandOwner {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IPathItem^ DemandOwner {
 IPathItem^ get( );
 void set(
   IPathItem^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DemandOwner() : IPathItem;
public function set DemandOwner(value : IPathItem);
This language is not supported or no code example is available.

Property Value

Type: IPathItem

Implements

ILink.DemandOwner
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPLink Class
MRPLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink.DueDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DueDate() As Date Implements  _
   ILink.DueDate
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime DueDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime DueDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DueDate() : DateTime;
public function set DueDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime

Implements

ILink.DueDate
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPLink Class
MRPLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink.GeneratedDocumentType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property GeneratedDocumentType() As String Implements  _
   ILink.GeneratedDocumentType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string GeneratedDocumentType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ GeneratedDocumentType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get GeneratedDocumentType() : String;
This language is not supported or no code example is available.

Property Value

Type: string

Implements

ILink.GeneratedDocumentType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPLink Class
MRPLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink.InternalLeadTime Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InternalLeadTime() As TimeSpan Implements  _
   ILink.InternalLeadTime
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan InternalLeadTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property TimeSpan InternalLeadTime {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InternalLeadTime() : TimeSpan;
public function set InternalLeadTime(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan

Implements

ILink.InternalLeadTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPLink Class
MRPLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink.IsBroken Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property IsBroken() As Boolean Implements  _
   ILink.IsBroken
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool IsBroken {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool IsBroken {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get IsBroken() : boolean;
public function set IsBroken(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool

Implements

ILink.IsBroken
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPLink Class
MRPLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink.LeadTime Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property LeadTime() As TimeSpan Implements  _
   ILink.LeadTime
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan LeadTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property TimeSpan LeadTime {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get LeadTime() : TimeSpan;
public function set LeadTime(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan

Implements

ILink.LeadTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPLink Class
MRPLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink.Quantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Quantity() As Decimal Implements  _
   ILink.Quantity
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal Quantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Quantity() : decimal;
public function set Quantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal

Implements

ILink.Quantity
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPLink Class
MRPLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink.ReleaseDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ReleaseDate() As Date Implements  _
   ILink.ReleaseDate
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime ReleaseDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime ReleaseDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ReleaseDate() : DateTime;
public function set ReleaseDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime

Implements

ILink.ReleaseDate
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPLink Class
MRPLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink.Source Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Source() As IDocLine Implements  _
   ILink.Source
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IDocLine Source {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IDocLine^ Source {
 IDocLine^ get( );
 void set(
   IDocLine^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Source() : IDocLine;
public function set Source(value : IDocLine);
This language is not supported or no code example is available.

Property Value

Type: IDocLine

Implements

ILink.Source
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPLink Class
MRPLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink.SourceDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property SourceDate() As Date Implements  _
   ILink.SourceDate
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime SourceDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime SourceDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SourceDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime

Implements

ILink.SourceDate
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPLink Class
MRPLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink.SupplyEntity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SupplyEntity() As IMRPEntity Implements  _
   ILink.SupplyEntity
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IMRPEntity SupplyEntity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IMRPEntity^ SupplyEntity {
 IMRPEntity^ get( );
 void set(
   IMRPEntity^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SupplyEntity() : IMRPEntity;
public function set SupplyEntity(value : IMRPEntity);
This language is not supported or no code example is available.

Property Value

Type: IMRPEntity

Implements

ILink.SupplyEntity
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPLink Class
MRPLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink.SupplyOwner Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SupplyOwner() As IPathItem Implements  _
   ILink.SupplyOwner
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IPathItem SupplyOwner {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IPathItem^ SupplyOwner {
 IPathItem^ get( );
 void set(
   IPathItem^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SupplyOwner() : IPathItem;
public function set SupplyOwner(value : IPathItem);
This language is not supported or no code example is available.

Property Value

Type: IPathItem

Implements

ILink.SupplyOwner
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPLink Class
MRPLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink Methods

MRPLink Class See Also

The following tables list the members exposed by the MRPLink type.

Methods
 | Name | Description
Public method | CalculateDatesForGeneratedEntity |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MRPLink Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPLink.CalculateDatesForGeneratedEntity Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub CalculateDatesForGeneratedEntity( _
   ByVal calculator As IDateCalculator _
) Implements  _
   ILink.CalculateDatesForGeneratedEntity
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void CalculateDatesForGeneratedEntity(
   IDateCalculator calculator
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void CalculateDatesForGeneratedEntity(
   IDateCalculator^ calculator
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CalculateDatesForGeneratedEntity(
    calculator : IDateCalculator
);
This language is not supported or no code example is available.

Parameters

calculator

Type: IDateCalculator

Implements

ILink.CalculateDatesForGeneratedEntity
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPLink Class
MRPLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPPeriod Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MRPPeriod
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPPeriod
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MRPPeriod
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPPeriod
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.MRPPeriod
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPPeriod Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPPeriod Members

MRPPeriod Class Methods Properties See Also

The following tables list the members exposed by the MRPPeriod type.

Properties
 | Name | Description
Public property | From |
Public property | Name |
Public property | To |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MRPPeriod Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPPeriod Properties

MRPPeriod Class See Also

The following tables list the members exposed by the MRPPeriod type.

Properties
 | Name | Description
Public property | From |
Public property | Name |
Public property | To |
Top
See Also

Reference

MRPPeriod Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPPeriod.From Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property From() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime From {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime From {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get From() : DateTime;
public function set From(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPPeriod Class
MRPPeriod Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPPeriod.Name Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Name() : String;
public function set Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPPeriod Class
MRPPeriod Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPPeriod.To Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property To() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime To {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime To {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get To() : DateTime;
public function set To(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPPeriod Class
MRPPeriod Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPPeriod Methods

MRPPeriod Class See Also

The following tables list the members exposed by the MRPPeriod type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MRPPeriod Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPReport Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MRPReport
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPReport
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MRPReport
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPReport
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.MRPReport
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPReport Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPReport Members

MRPReport Class Constructors Methods Properties See Also

The following tables list the members exposed by the MRPReport type.

Constructors
 | Name | Description
Public constructor | MRPReport |
Top
Properties
 | Name | Description
Public property | Periods |
Public property | Rows |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MRPReport Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPReport Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MRPReport()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
MRPReport()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function MRPReport();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPReport Class
MRPReport Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPReport Properties

MRPReport Class See Also

The following tables list the members exposed by the MRPReport type.

Properties
 | Name | Description
Public property | Periods |
Public property | Rows |
Top
See Also

Reference

MRPReport Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPReport.Periods Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Periods() As List(Of MRPPeriod)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<MRPPeriod> Periods {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<MRPPeriod^>^ Periods {
 List<MRPPeriod^>^ get( );
 void set(
   List<MRPPeriod^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<MRPPeriod>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPReport Class
MRPReport Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPReport.Rows Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Rows() As List(Of MRPResultRow)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<MRPResultRow> Rows {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<MRPResultRow^>^ Rows {
 List<MRPResultRow^>^ get( );
 void set(
   List<MRPResultRow^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<MRPResultRow>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPReport Class
MRPReport Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPReport Methods

MRPReport Class See Also

The following tables list the members exposed by the MRPReport type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MRPReport Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResult Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MRPResult
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPResult
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MRPResult
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPResult
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.MRPResult
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResult Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResult Members

MRPResult Class Constructors Methods Properties See Also

The following tables list the members exposed by the MRPResult type.

Constructors
 | Name | Description
Public constructor | MRPResult |
Top
Properties
 | Name | Description
Public property | Demand |
Public property | InAvailbleQuantity |
Public property | InStockQuantity |
Public property | OutAvailbleQuantity |
Public property | OutStockQuantity |
Public property | Period |
Public property | Recomendataions |
Public property | References |
Public property | Supply |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MRPResult Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResult Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MRPResult()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
MRPResult()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function MRPResult();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResult Class
MRPResult Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResult Properties

MRPResult Class See Also

The following tables list the members exposed by the MRPResult type.

Properties
 | Name | Description
Public property | Demand |
Public property | InAvailbleQuantity |
Public property | InStockQuantity |
Public property | OutAvailbleQuantity |
Public property | OutStockQuantity |
Public property | Period |
Public property | Recomendataions |
Public property | References |
Public property | Supply |
Top
See Also

Reference

MRPResult Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResult.Demand Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Demand() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal Demand {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal Demand {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Demand() : decimal;
public function set Demand(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResult Class
MRPResult Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResult.InAvailbleQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InAvailbleQuantity() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal InAvailbleQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal InAvailbleQuantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InAvailbleQuantity() : decimal;
public function set InAvailbleQuantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResult Class
MRPResult Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResult.InStockQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InStockQuantity() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal InStockQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal InStockQuantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InStockQuantity() : decimal;
public function set InStockQuantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResult Class
MRPResult Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResult.OutAvailbleQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property OutAvailbleQuantity() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal OutAvailbleQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal OutAvailbleQuantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get OutAvailbleQuantity() : decimal;
public function set OutAvailbleQuantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResult Class
MRPResult Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResult.OutStockQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property OutStockQuantity() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal OutStockQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal OutStockQuantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get OutStockQuantity() : decimal;
public function set OutStockQuantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResult Class
MRPResult Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResult.Period Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Period() As MRPPeriod
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MRPPeriod Period {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property MRPPeriod^ Period {
 MRPPeriod^ get( );
 void set(
   MRPPeriod^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Period() : MRPPeriod;
public function set Period(value : MRPPeriod);
This language is not supported or no code example is available.

Property Value

Type: MRPPeriod
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResult Class
MRPResult Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResult.Recomendataions Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Recomendataions() As List(Of MRPResultReference)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<MRPResultReference> Recomendataions {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<MRPResultReference^>^ Recomendataions {
 List<MRPResultReference^>^ get( );
 void set(
   List<MRPResultReference^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<MRPResultReference>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResult Class
MRPResult Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResult.References Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property References() As List(Of MRPResultReference)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<MRPResultReference> References {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<MRPResultReference^>^ References {
 List<MRPResultReference^>^ get( );
 void set(
   List<MRPResultReference^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<MRPResultReference>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResult Class
MRPResult Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResult.Supply Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Supply() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal Supply {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal Supply {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Supply() : decimal;
public function set Supply(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResult Class
MRPResult Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResult Methods

MRPResult Class See Also

The following tables list the members exposed by the MRPResult type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MRPResult Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultReference Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MRPResultReference
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPResultReference
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MRPResultReference
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPResultReference
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.MRPResultReference
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResultReference Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultReference Members

MRPResultReference Class Methods Properties See Also

The following tables list the members exposed by the MRPResultReference type.

Properties
 | Name | Description
Public property | Direction |
Public property | DocNum |
Public property | DocType |
Public property | DueDate |
Public property | Key |
Public property | Quantity |
Public property | RecomendationDate |
Public property | Remarks |
Public property | WhsCode |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MRPResultReference Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultReference Properties

MRPResultReference Class See Also

The following tables list the members exposed by the MRPResultReference type.

Properties
 | Name | Description
Public property | Direction |
Public property | DocNum |
Public property | DocType |
Public property | DueDate |
Public property | Key |
Public property | Quantity |
Public property | RecomendationDate |
Public property | Remarks |
Public property | WhsCode |
Top
See Also

Reference

MRPResultReference Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultReference.Direction Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Direction() As Direction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Direction Direction {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Direction Direction {
 Direction get( );
 void set(
   Direction value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Direction() : Direction;
public function set Direction(value : Direction);
This language is not supported or no code example is available.

Property Value

Type: Direction
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResultReference Class
MRPResultReference Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultReference.DocNum Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DocNum() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DocNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DocNum {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocNum() : String;
public function set DocNum(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResultReference Class
MRPResultReference Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultReference.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DocType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DocType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DocType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocType() : String;
public function set DocType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResultReference Class
MRPResultReference Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultReference.DueDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DueDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime DueDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime DueDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DueDate() : DateTime;
public function set DueDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResultReference Class
MRPResultReference Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultReference.Key Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Key() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Key {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Key {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Key() : String;
public function set Key(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResultReference Class
MRPResultReference Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultReference.Quantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Quantity() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal Quantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Quantity() : decimal;
public function set Quantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResultReference Class
MRPResultReference Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultReference.RecomendationDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property RecomendationDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime RecomendationDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime RecomendationDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get RecomendationDate() : DateTime;
public function set RecomendationDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResultReference Class
MRPResultReference Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultReference.Remarks Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Remarks() : String;
public function set Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResultReference Class
MRPResultReference Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultReference.WhsCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get WhsCode() : String;
public function set WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResultReference Class
MRPResultReference Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultReference Methods

MRPResultReference Class See Also

The following tables list the members exposed by the MRPResultReference type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MRPResultReference Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultRow Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MRPResultRow
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPResultRow
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MRPResultRow
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPResultRow
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.MRPResultRow
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResultRow Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultRow Members

MRPResultRow Class Constructors Methods Properties See Also

The following tables list the members exposed by the MRPResultRow type.

Constructors
 | Name | Description
Public constructor | MRPResultRow |
Top
Properties
 | Name | Description
Public property | Cells |
Public property | ItemCode |
Public property | Revision |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MRPResultRow Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultRow Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal itemCode As String, _
   ByVal revision As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MRPResultRow(
   string itemCode,
   string revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
MRPResultRow(
   String^ itemCode,
   String^ revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function MRPResultRow(
    itemCode : String,
    revision : String
);
This language is not supported or no code example is available.

Parameters

itemCode

Type: string

revision

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResultRow Class
MRPResultRow Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultRow Properties

MRPResultRow Class See Also

The following tables list the members exposed by the MRPResultRow type.

Properties
 | Name | Description
Public property | Cells |
Public property | ItemCode |
Public property | Revision |
Top
See Also

Reference

MRPResultRow Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultRow.Cells Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Cells() As List(Of MRPResult)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<MRPResult> Cells {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<MRPResult^>^ Cells {
 List<MRPResult^>^ get( );
 void set(
   List<MRPResult^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<MRPResult>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResultRow Class
MRPResultRow Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultRow.ItemCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ItemCode() : String;
public function set ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResultRow Class
MRPResultRow Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultRow.Revision Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Revision() : String;
public function set Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResultRow Class
MRPResultRow Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResultRow Methods

MRPResultRow Class See Also

The following tables list the members exposed by the MRPResultRow type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MRPResultRow Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResults Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MRPResults
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPResults
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MRPResults
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPResults
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.MRPResults
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResults Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResults Members

MRPResults Class Constructors Methods Properties See Also

The following tables list the members exposed by the MRPResults type.

Constructors
 | Name | Description
Public constructor | MRPResults |
Top
Properties
 | Name | Description
Public property | Recomendations |
Public property | Report |
Public property | Scenario |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MRPResults Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResults Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MRPResults()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
MRPResults()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function MRPResults();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResults Class
MRPResults Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResults Properties

MRPResults Class See Also

The following tables list the members exposed by the MRPResults type.

Properties
 | Name | Description
Public property | Recomendations |
Public property | Report |
Public property | Scenario |
Top
See Also

Reference

MRPResults Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResults.Recomendations Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Recomendations() As List(Of Recomendations)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<Recomendations> Recomendations {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<Recomendations^>^ Recomendations {
 List<Recomendations^>^ get( );
 void set(
   List<Recomendations^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<Recomendations>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResults Class
MRPResults Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResults.Report Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Report() As MRPReport
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MRPReport Report {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property MRPReport^ Report {
 MRPReport^ get( );
 void set(
   MRPReport^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Report() : MRPReport;
public function set Report(value : MRPReport);
This language is not supported or no code example is available.

Property Value

Type: MRPReport
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResults Class
MRPResults Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResults.Scenario Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Scenario() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Scenario {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Scenario {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Scenario() : String;
public function set Scenario(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPResults Class
MRPResults Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


MRPResults Methods

MRPResults Class See Also

The following tables list the members exposed by the MRPResults type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MRPResults Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class Recomendations
    Implements IRecomendations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Recomendations : IRecomendations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class Recomendations  : public IRecomendations^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Recomendations
   implements IRecomendations
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.Recomendations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations Members

Recomendations Class Methods Properties See Also

The following tables list the members exposed by the Recomendations type.

Properties
 | Name | Description
Public property | CardCode |
Public property | CardName |
Public property | Currency |
Public property | DocType |
Public property | DueDate |
Public property | InternalLeadDate |
Public property | InvUOM |
Public property | InventoryQty |
Public property | ItemCode |
Public property | Key |
Public property | Links |
Public property | Price |
Public property | PurchaseOUM |
Public property | PurchaseQty |
Public property | ReleaseDate |
Public property | Remarks |
Public property | Revision |
Public property | ToWhsCode |
Public property | WhsCode |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Recomendations Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations Properties

Recomendations Class See Also

The following tables list the members exposed by the Recomendations type.

Properties
 | Name | Description
Public property | CardCode |
Public property | CardName |
Public property | Currency |
Public property | DocType |
Public property | DueDate |
Public property | InternalLeadDate |
Public property | InvUOM |
Public property | InventoryQty |
Public property | ItemCode |
Public property | Key |
Public property | Links |
Public property | Price |
Public property | PurchaseOUM |
Public property | PurchaseQty |
Public property | ReleaseDate |
Public property | Remarks |
Public property | Revision |
Public property | ToWhsCode |
Public property | WhsCode |
Top
See Also

Reference

Recomendations Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations.CardCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property CardCode() As String Implements  _
   IRecomendations.CardCode
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string CardCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ CardCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get CardCode() : String;
public function set CardCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IRecomendations.CardCode
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Class
Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations.CardName Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property CardName() As String Implements  _
   IRecomendations.CardName
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string CardName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ CardName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get CardName() : String;
public function set CardName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IRecomendations.CardName
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Class
Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations.Currency Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Currency() As String Implements  _
   IRecomendations.Currency
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Currency {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Currency {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Currency() : String;
public function set Currency(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IRecomendations.Currency
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Class
Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DocType() As String Implements  _
   IRecomendations.DocType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DocType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DocType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocType() : String;
public function set DocType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IRecomendations.DocType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Class
Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations.DueDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DueDate() As Date Implements  _
   IRecomendations.DueDate
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime DueDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime DueDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DueDate() : DateTime;
public function set DueDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime

Implements

IRecomendations.DueDate
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Class
Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations.InternalLeadDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InternalLeadDate() As Date Implements  _
   IRecomendations.InternalLeadDate
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime InternalLeadDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime InternalLeadDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InternalLeadDate() : DateTime;
public function set InternalLeadDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime

Implements

IRecomendations.InternalLeadDate
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Class
Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations.InvUOM Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InvUOM() As String Implements  _
   IRecomendations.InvUOM
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string InvUOM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ InvUOM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InvUOM() : String;
public function set InvUOM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IRecomendations.InvUOM
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Class
Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations.InventoryQty Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InventoryQty() As Decimal Implements  _
   IRecomendations.InventoryQty
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal InventoryQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal InventoryQty {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InventoryQty() : decimal;
public function set InventoryQty(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal

Implements

IRecomendations.InventoryQty
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Class
Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations.ItemCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ItemCode() As String Implements  _
   IRecomendations.ItemCode
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ItemCode() : String;
public function set ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IRecomendations.ItemCode
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Class
Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations.Key Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Key() As String Implements  _
   IRecomendations.Key
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Key {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Key {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Key() : String;
public function set Key(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IRecomendations.Key
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Class
Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations.Links Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Links() As List(Of RecomendationsLink) Implements  _
   IRecomendations.Links
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<RecomendationsLink> Links {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<RecomendationsLink^>^ Links {
 List<RecomendationsLink^>^ get( );
 void set(
   List<RecomendationsLink^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<RecomendationsLink>

Implements

IRecomendations.Links
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Class
Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations.Price Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Price() As Decimal Implements  _
   IRecomendations.Price
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal Price {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal Price {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Price() : decimal;
public function set Price(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal

Implements

IRecomendations.Price
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Class
Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations.PurchaseOUM Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property PurchaseOUM() As String Implements  _
   IRecomendations.PurchaseOUM
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string PurchaseOUM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ PurchaseOUM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get PurchaseOUM() : String;
public function set PurchaseOUM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IRecomendations.PurchaseOUM
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Class
Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations.PurchaseQty Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property PurchaseQty() As Decimal Implements  _
   IRecomendations.PurchaseQty
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal PurchaseQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal PurchaseQty {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get PurchaseQty() : decimal;
public function set PurchaseQty(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal

Implements

IRecomendations.PurchaseQty
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Class
Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations.ReleaseDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ReleaseDate() As Date Implements  _
   IRecomendations.ReleaseDate
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime ReleaseDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime ReleaseDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ReleaseDate() : DateTime;
public function set ReleaseDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime

Implements

IRecomendations.ReleaseDate
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Class
Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations.Remarks Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Remarks() As String Implements  _
   IRecomendations.Remarks
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Remarks() : String;
public function set Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IRecomendations.Remarks
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Class
Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations.Revision Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Revision() As String Implements  _
   IRecomendations.Revision
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Revision() : String;
public function set Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IRecomendations.Revision
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Class
Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations.ToWhsCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ToWhsCode() As String Implements  _
   IRecomendations.ToWhsCode
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ToWhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ToWhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ToWhsCode() : String;
public function set ToWhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IRecomendations.ToWhsCode
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Class
Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations.WhsCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property WhsCode() As String Implements  _
   IRecomendations.WhsCode
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get WhsCode() : String;
public function set WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IRecomendations.WhsCode
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Recomendations Class
Recomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


Recomendations Methods

Recomendations Class See Also

The following tables list the members exposed by the Recomendations type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Recomendations Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


RecomendationsLink Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class RecomendationsLink
    Implements IRecomendationsLink
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RecomendationsLink : IRecomendationsLink
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class RecomendationsLink  : public IRecomendationsLink^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RecomendationsLink
   implements IRecomendationsLink
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.RecomendationsLink
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RecomendationsLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


RecomendationsLink Members

RecomendationsLink Class Methods Properties See Also

The following tables list the members exposed by the RecomendationsLink type.

Properties
 | Name | Description
Public property | DocEntry |
Public property | DocType |
Public property | InverntoryQty |
Public property | Key |
Public property | LineNum |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

RecomendationsLink Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


RecomendationsLink Properties

RecomendationsLink Class See Also

The following tables list the members exposed by the RecomendationsLink type.

Properties
 | Name | Description
Public property | DocEntry |
Public property | DocType |
Public property | InverntoryQty |
Public property | Key |
Public property | LineNum |
Top
See Also

Reference

RecomendationsLink Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


RecomendationsLink.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DocEntry() As Integer Implements  _
   IRecomendationsLink.DocEntry
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int DocEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int DocEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocEntry() : int;
public function set DocEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int

Implements

IRecomendationsLink.DocEntry
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RecomendationsLink Class
RecomendationsLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


RecomendationsLink.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DocType() As String Implements  _
   IRecomendationsLink.DocType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DocType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DocType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocType() : String;
public function set DocType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IRecomendationsLink.DocType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RecomendationsLink Class
RecomendationsLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


RecomendationsLink.InverntoryQty Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InverntoryQty() As Decimal Implements  _
   IRecomendationsLink.InverntoryQty
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal InverntoryQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal InverntoryQty {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InverntoryQty() : decimal;
public function set InverntoryQty(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal

Implements

IRecomendationsLink.InverntoryQty
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RecomendationsLink Class
RecomendationsLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


RecomendationsLink.Key Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Key() As String Implements  _
   IRecomendationsLink.Key
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Key {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Key {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Key() : String;
public function set Key(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IRecomendationsLink.Key
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RecomendationsLink Class
RecomendationsLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


RecomendationsLink.LineNum Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property LineNum() As Integer Implements  _
   IRecomendationsLink.LineNum
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int LineNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int LineNum {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get LineNum() : int;
public function set LineNum(value : int);
This language is not supported or no code example is available.

Property Value

Type: int

Implements

IRecomendationsLink.LineNum
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RecomendationsLink Class
RecomendationsLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


RecomendationsLink Methods

RecomendationsLink Class See Also

The following tables list the members exposed by the RecomendationsLink type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

RecomendationsLink Class
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IInputRestrictions Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IInputRestrictions
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IInputRestrictions
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IInputRestrictions
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IInputRestrictions
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputRestrictions Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IInputRestrictions Members

IInputRestrictions Interface Properties See Also

The following tables list the members exposed by the IInputRestrictions type.

Properties
 | Name | Description
Public property | Code |
Public property | DocEntry |
Public property | ObjType |
Top
See Also

Reference

IInputRestrictions Interface
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IInputRestrictions Properties

IInputRestrictions Interface See Also

The following tables list the members exposed by the IInputRestrictions type.

Properties
 | Name | Description
Public property | Code |
Public property | DocEntry |
Public property | ObjType |
Top
See Also

Reference

IInputRestrictions Interface
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IInputRestrictions.Code Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Code {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Code {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Code() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputRestrictions Interface
IInputRestrictions Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IInputRestrictions.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputRestrictions Interface
IInputRestrictions Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IInputRestrictions.ObjType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ObjType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string ObjType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ ObjType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ObjType() : String;
function set ObjType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInputRestrictions Interface
IInputRestrictions Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILink Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ILink
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ILink
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ILink
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ILink
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILink Members

ILink Interface Methods Properties See Also

The following tables list the members exposed by the ILink type.

Properties
 | Name | Description
Public property | BomCode |
Public property | DemandEntity |
Public property | DemandOwner |
Public property | DueDate |
Public property | GeneratedDocumentType |
Public property | InternalLeadTime |
Public property | IsBroken |
Public property | LeadTime |
Public property | Quantity |
Public property | ReleaseDate |
Public property | Source |
Public property | SourceDate |
Public property | SupplyEntity |
Public property | SupplyOwner |
Top
Methods
 | Name | Description
Public method | CalculateDatesForGeneratedEntity |
Top
See Also

Reference

ILink Interface
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILink Properties

ILink Interface See Also

The following tables list the members exposed by the ILink type.

Properties
 | Name | Description
Public property | BomCode |
Public property | DemandEntity |
Public property | DemandOwner |
Public property | DueDate |
Public property | GeneratedDocumentType |
Public property | InternalLeadTime |
Public property | IsBroken |
Public property | LeadTime |
Public property | Quantity |
Public property | ReleaseDate |
Public property | Source |
Public property | SourceDate |
Public property | SupplyEntity |
Public property | SupplyOwner |
Top
See Also

Reference

ILink Interface
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILink.BomCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BomCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string BomCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ BomCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BomCode() : String;
function set BomCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILink Interface
ILink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILink.DemandEntity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DemandEntity() As IMRPEntity
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IMRPEntity DemandEntity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IMRPEntity^ DemandEntity {
 IMRPEntity^ get( );
 void set(
   IMRPEntity^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DemandEntity() : IMRPEntity;
function set DemandEntity(value : IMRPEntity);
This language is not supported or no code example is available.

Property Value

Type: IMRPEntity
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILink Interface
ILink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILink.DemandOwner Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DemandOwner() As IPathItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IPathItem DemandOwner {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IPathItem^ DemandOwner {
 IPathItem^ get( );
 void set(
   IPathItem^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DemandOwner() : IPathItem;
function set DemandOwner(value : IPathItem);
This language is not supported or no code example is available.

Property Value

Type: IPathItem
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILink Interface
ILink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILink.DueDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DueDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime DueDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime DueDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DueDate() : DateTime;
function set DueDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILink Interface
ILink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILink.GeneratedDocumentType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property GeneratedDocumentType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string GeneratedDocumentType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ GeneratedDocumentType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get GeneratedDocumentType() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILink Interface
ILink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILink.InternalLeadTime Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property InternalLeadTime() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan InternalLeadTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan InternalLeadTime {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get InternalLeadTime() : TimeSpan;
function set InternalLeadTime(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILink Interface
ILink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILink.IsBroken Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property IsBroken() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool IsBroken {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool IsBroken {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get IsBroken() : boolean;
function set IsBroken(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILink Interface
ILink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILink.LeadTime Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property LeadTime() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan LeadTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan LeadTime {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LeadTime() : TimeSpan;
function set LeadTime(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILink Interface
ILink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILink.Quantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Quantity() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal Quantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Quantity() : decimal;
function set Quantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILink Interface
ILink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILink.ReleaseDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ReleaseDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime ReleaseDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime ReleaseDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ReleaseDate() : DateTime;
function set ReleaseDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILink Interface
ILink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILink.Source Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Source() As IDocLine
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IDocLine Source {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IDocLine^ Source {
 IDocLine^ get( );
 void set(
   IDocLine^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Source() : IDocLine;
function set Source(value : IDocLine);
This language is not supported or no code example is available.

Property Value

Type: IDocLine
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILink Interface
ILink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILink.SourceDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property SourceDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime SourceDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime SourceDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get SourceDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILink Interface
ILink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILink.SupplyEntity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property SupplyEntity() As IMRPEntity
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IMRPEntity SupplyEntity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IMRPEntity^ SupplyEntity {
 IMRPEntity^ get( );
 void set(
   IMRPEntity^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get SupplyEntity() : IMRPEntity;
function set SupplyEntity(value : IMRPEntity);
This language is not supported or no code example is available.

Property Value

Type: IMRPEntity
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILink Interface
ILink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILink.SupplyOwner Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property SupplyOwner() As IPathItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IPathItem SupplyOwner {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IPathItem^ SupplyOwner {
 IPathItem^ get( );
 void set(
   IPathItem^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get SupplyOwner() : IPathItem;
function set SupplyOwner(value : IPathItem);
This language is not supported or no code example is available.

Property Value

Type: IPathItem
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILink Interface
ILink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILink Methods

ILink Interface See Also

The following tables list the members exposed by the ILink type.

Methods
 | Name | Description
Public method | CalculateDatesForGeneratedEntity |
Top
See Also

Reference

ILink Interface
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILink.CalculateDatesForGeneratedEntity Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub CalculateDatesForGeneratedEntity( _
   ByVal calculator As IDateCalculator _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void CalculateDatesForGeneratedEntity(
   IDateCalculator calculator
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void CalculateDatesForGeneratedEntity(
   IDateCalculator^ calculator
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CalculateDatesForGeneratedEntity(
    calculator : IDateCalculator
);
This language is not supported or no code example is available.

Parameters

calculator

Type: IDateCalculator

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILink Interface
ILink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILoader Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ILoader
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILoader Members

ILoader Interface Methods Properties See Also

The following tables list the members exposed by the ILoader type.

Properties
 | Name | Description
Public property | DocType |
Top
Methods
 | Name | Description
Public method | LoadData |
Top
See Also

Reference

ILoader Interface
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILoader Properties

ILoader Interface See Also

The following tables list the members exposed by the ILoader type.

Properties
 | Name | Description
Public property | DocType |
Top
See Also

Reference

ILoader Interface
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILoader.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DocType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DocType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocType() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILoader Interface
ILoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILoader Methods

ILoader Interface See Also

The following tables list the members exposed by the ILoader type.

Methods
 | Name | Description
Public method | LoadData |
Top
See Also

Reference

ILoader Interface
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


ILoader.LoadData Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function LoadData( _
   ByVal configuration As IScenario, _
   ByVal manager As DocumentManager _
) As List(Of IDoc)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<IDoc> LoadData(
   IScenario configuration,
   DocumentManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

List<IDoc^>^ LoadData(
   IScenario^ configuration,
   DocumentManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

configuration

Type: IScenario

manager

Type: DocumentManager

Return Value

Type: List<IDoc>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ILoader Interface
ILoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IPathInitializator Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IPathInitializator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IPathInitializator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IPathInitializator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IPathInitializator
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathInitializator Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IPathInitializator Members

IPathInitializator Interface Methods See Also

The following tables list the members exposed by the IPathInitializator type.

Methods
 | Name | Description
Public method | Initialize |
Top
See Also

Reference

IPathInitializator Interface
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IPathInitializator Methods

IPathInitializator Interface See Also

The following tables list the members exposed by the IPathInitializator type.

Methods
 | Name | Description
Public method | Initialize |
Top
See Also

Reference

IPathInitializator Interface
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IPathInitializator.Initialize Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function Initialize( _
   ByVal scenario As IScenario _
) As List(Of IPathItem)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<IPathItem> Initialize(
   IScenario scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

List<IPathItem^>^ Initialize(
   IScenario^ scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

scenario

Type: IScenario

Return Value

Type: List<IPathItem>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathInitializator Interface
IPathInitializator Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IRecomendations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IRecomendations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IRecomendations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IRecomendations
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations Members

IRecomendations Interface Properties See Also

The following tables list the members exposed by the IRecomendations type.

Properties
 | Name | Description
Public property | CardCode |
Public property | CardName |
Public property | Currency |
Public property | DocType |
Public property | DueDate |
Public property | InternalLeadDate |
Public property | InvUOM |
Public property | InventoryQty |
Public property | ItemCode |
Public property | Key |
Public property | Links |
Public property | Price |
Public property | PurchaseOUM |
Public property | PurchaseQty |
Public property | ReleaseDate |
Public property | Remarks |
Public property | Revision |
Public property | ToWhsCode |
Public property | WhsCode |
Top
See Also

Reference

IRecomendations Interface
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations Properties

IRecomendations Interface See Also

The following tables list the members exposed by the IRecomendations type.

Properties
 | Name | Description
Public property | CardCode |
Public property | CardName |
Public property | Currency |
Public property | DocType |
Public property | DueDate |
Public property | InternalLeadDate |
Public property | InvUOM |
Public property | InventoryQty |
Public property | ItemCode |
Public property | Key |
Public property | Links |
Public property | Price |
Public property | PurchaseOUM |
Public property | PurchaseQty |
Public property | ReleaseDate |
Public property | Remarks |
Public property | Revision |
Public property | ToWhsCode |
Public property | WhsCode |
Top
See Also

Reference

IRecomendations Interface
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations.CardCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property CardCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string CardCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ CardCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CardCode() : String;
function set CardCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Interface
IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations.CardName Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property CardName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string CardName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ CardName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CardName() : String;
function set CardName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Interface
IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations.Currency Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Currency() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Currency {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Currency {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Currency() : String;
function set Currency(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Interface
IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DocType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DocType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DocType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocType() : String;
function set DocType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Interface
IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations.DueDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DueDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime DueDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime DueDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DueDate() : DateTime;
function set DueDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Interface
IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations.InternalLeadDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property InternalLeadDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime InternalLeadDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime InternalLeadDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get InternalLeadDate() : DateTime;
function set InternalLeadDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Interface
IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations.InvUOM Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property InvUOM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string InvUOM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ InvUOM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get InvUOM() : String;
function set InvUOM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Interface
IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations.InventoryQty Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property InventoryQty() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal InventoryQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal InventoryQty {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get InventoryQty() : decimal;
function set InventoryQty(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Interface
IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations.ItemCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ItemCode() : String;
function set ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Interface
IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations.Key Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Key() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Key {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Key {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Key() : String;
function set Key(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Interface
IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations.Links Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Links() As List(Of RecomendationsLink)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<RecomendationsLink> Links {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property List<RecomendationsLink^>^ Links {
 List<RecomendationsLink^>^ get( );
 void set(
   List<RecomendationsLink^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<RecomendationsLink>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Interface
IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations.Price Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Price() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal Price {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal Price {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Price() : decimal;
function set Price(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Interface
IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations.PurchaseOUM Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property PurchaseOUM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string PurchaseOUM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ PurchaseOUM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get PurchaseOUM() : String;
function set PurchaseOUM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Interface
IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations.PurchaseQty Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property PurchaseQty() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal PurchaseQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal PurchaseQty {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get PurchaseQty() : decimal;
function set PurchaseQty(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Interface
IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations.ReleaseDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ReleaseDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime ReleaseDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime ReleaseDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ReleaseDate() : DateTime;
function set ReleaseDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Interface
IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations.Remarks Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Remarks {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Remarks {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Remarks() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Interface
IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations.Revision Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Revision() : String;
function set Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Interface
IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations.ToWhsCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ToWhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string ToWhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ ToWhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ToWhsCode() : String;
function set ToWhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Interface
IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendations.WhsCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WhsCode() : String;
function set WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendations Interface
IRecomendations Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendationsLink Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IRecomendationsLink
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IRecomendationsLink
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IRecomendationsLink
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IRecomendationsLink
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendationsLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendationsLink Members

IRecomendationsLink Interface Properties See Also

The following tables list the members exposed by the IRecomendationsLink type.

Properties
 | Name | Description
Public property | DocEntry |
Public property | DocType |
Public property | InverntoryQty |
Public property | Key |
Public property | LineNum |
Top
See Also

Reference

IRecomendationsLink Interface
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendationsLink Properties

IRecomendationsLink Interface See Also

The following tables list the members exposed by the IRecomendationsLink type.

Properties
 | Name | Description
Public property | DocEntry |
Public property | DocType |
Public property | InverntoryQty |
Public property | Key |
Public property | LineNum |
Top
See Also

Reference

IRecomendationsLink Interface
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendationsLink.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
function set DocEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendationsLink Interface
IRecomendationsLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendationsLink.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DocType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DocType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DocType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocType() : String;
function set DocType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendationsLink Interface
IRecomendationsLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendationsLink.InverntoryQty Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property InverntoryQty() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal InverntoryQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal InverntoryQty {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get InverntoryQty() : decimal;
function set InverntoryQty(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendationsLink Interface
IRecomendationsLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendationsLink.Key Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Key() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Key {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Key {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Key() : String;
function set Key(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendationsLink Interface
IRecomendationsLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IRecomendationsLink.LineNum Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property LineNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineNum {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineNum() : int;
function set LineNum(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRecomendationsLink Interface
IRecomendationsLink Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IWhsConfiguration Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IWhsConfiguration
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IWhsConfiguration
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IWhsConfiguration
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IWhsConfiguration
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWhsConfiguration Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IWhsConfiguration Members

IWhsConfiguration Interface Properties See Also

The following tables list the members exposed by the IWhsConfiguration type.

Properties
 | Name | Description
Public property | BatchByExpiryDate |
Public property | BatchExpiryFrom |
Public property | BatchExpiryTo |
Public property | BatchLocked |
Public property | BatchNotAccessible |
Public property | BatchReleased |
Public property | IncludeDemand |
Public property | IncludeSupply |
Public property | WhsCode |
Top
See Also

Reference

IWhsConfiguration Interface
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IWhsConfiguration Properties

IWhsConfiguration Interface See Also

The following tables list the members exposed by the IWhsConfiguration type.

Properties
 | Name | Description
Public property | BatchByExpiryDate |
Public property | BatchExpiryFrom |
Public property | BatchExpiryTo |
Public property | BatchLocked |
Public property | BatchNotAccessible |
Public property | BatchReleased |
Public property | IncludeDemand |
Public property | IncludeSupply |
Public property | WhsCode |
Top
See Also

Reference

IWhsConfiguration Interface
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IWhsConfiguration.BatchByExpiryDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BatchByExpiryDate() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool BatchByExpiryDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool BatchByExpiryDate {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BatchByExpiryDate() : boolean;
function set BatchByExpiryDate(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWhsConfiguration Interface
IWhsConfiguration Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IWhsConfiguration.BatchExpiryFrom Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BatchExpiryFrom() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime BatchExpiryFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime BatchExpiryFrom {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BatchExpiryFrom() : DateTime;
function set BatchExpiryFrom(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWhsConfiguration Interface
IWhsConfiguration Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IWhsConfiguration.BatchExpiryTo Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BatchExpiryTo() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime BatchExpiryTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime BatchExpiryTo {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BatchExpiryTo() : DateTime;
function set BatchExpiryTo(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWhsConfiguration Interface
IWhsConfiguration Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IWhsConfiguration.BatchLocked Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BatchLocked() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool BatchLocked {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool BatchLocked {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BatchLocked() : boolean;
function set BatchLocked(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWhsConfiguration Interface
IWhsConfiguration Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IWhsConfiguration.BatchNotAccessible Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BatchNotAccessible() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool BatchNotAccessible {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool BatchNotAccessible {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BatchNotAccessible() : boolean;
function set BatchNotAccessible(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWhsConfiguration Interface
IWhsConfiguration Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IWhsConfiguration.BatchReleased Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BatchReleased() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool BatchReleased {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool BatchReleased {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BatchReleased() : boolean;
function set BatchReleased(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWhsConfiguration Interface
IWhsConfiguration Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IWhsConfiguration.IncludeDemand Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property IncludeDemand() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool IncludeDemand {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool IncludeDemand {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get IncludeDemand() : boolean;
function set IncludeDemand(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWhsConfiguration Interface
IWhsConfiguration Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IWhsConfiguration.IncludeSupply Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property IncludeSupply() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool IncludeSupply {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool IncludeSupply {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get IncludeSupply() : boolean;
function set IncludeSupply(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWhsConfiguration Interface
IWhsConfiguration Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


IWhsConfiguration.WhsCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WhsCode() : String;
function set WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWhsConfiguration Interface
IWhsConfiguration Members
CompuTec.ProcessForce.API.Tools.MRP.Data Namespace


CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | ARReserveInvoicesLoader |
Public class | BlanketPurchaseAgreementsLoder |
Public class | BlanketSalesAgreementsLoader |
Public class | ForecastLoader |
Public class | InventoryTransferRequestLoader |
Public class | ItemInitializator |
Public class | ManufacturingOrdersLoader |
Public class | PurchaseOrdersLoader |
Public class | PurchaseQuotationLoader |
Public class | PurchaseRequestLoader |
Public class | RecurringPurchaseTransactionsLoader |
Public class | RecurringSalesTransactionsLoader |
Public class | SalesOrdersLoader |
Public class | SalesQuotationLoader |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ARReserveInvoicesLoader Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ARReserveInvoicesLoader
    Implements ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ARReserveInvoicesLoader : ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ARReserveInvoicesLoader  : public ILoader^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ARReserveInvoicesLoader
   implements ILoader
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators.ARReserveInvoicesLoader
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ARReserveInvoicesLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ARReserveInvoicesLoader Members

ARReserveInvoicesLoader Class Methods Properties See Also

The following tables list the members exposed by the ARReserveInvoicesLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ARReserveInvoicesLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ARReserveInvoicesLoader Properties

ARReserveInvoicesLoader Class See Also

The following tables list the members exposed by the ARReserveInvoicesLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
See Also

Reference

ARReserveInvoicesLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ARReserveInvoicesLoader.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Shadows Property DocType() As String Implements  _
   ILoader.DocType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
new public string DocType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DocType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public hide function get DocType() : String;
This language is not supported or no code example is available.

Property Value

Type: string

Implements

ILoader.DocType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ARReserveInvoicesLoader Class
ARReserveInvoicesLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ARReserveInvoicesLoader Methods

ARReserveInvoicesLoader Class See Also

The following tables list the members exposed by the ARReserveInvoicesLoader type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ARReserveInvoicesLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ARReserveInvoicesLoader.LoadData Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function LoadData( _
   ByVal configuration As IScenario, _
   ByVal manager As DocumentManager _
) As List(Of IDoc) Implements  _
   ILoader.LoadData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDoc> LoadData(
   IScenario configuration,
   DocumentManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<IDoc^>^ LoadData(
   IScenario^ configuration,
   DocumentManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

configuration

Type: IScenario

manager

Type: DocumentManager

Return Value

Type: List<IDoc>

Implements

ILoader.LoadData
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ARReserveInvoicesLoader Class
ARReserveInvoicesLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


BlanketPurchaseAgreementsLoder Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BlanketPurchaseAgreementsLoder
    Implements ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BlanketPurchaseAgreementsLoder : ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BlanketPurchaseAgreementsLoder  : public ILoader^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BlanketPurchaseAgreementsLoder
   implements ILoader
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators.BlanketPurchaseAgreementsLoder
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BlanketPurchaseAgreementsLoder Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


BlanketPurchaseAgreementsLoder Members

BlanketPurchaseAgreementsLoder Class Methods Properties See Also

The following tables list the members exposed by the BlanketPurchaseAgreementsLoder type.

Properties
 | Name | Description
Public property | DocType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

BlanketPurchaseAgreementsLoder Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


BlanketPurchaseAgreementsLoder Properties

BlanketPurchaseAgreementsLoder Class See Also

The following tables list the members exposed by the BlanketPurchaseAgreementsLoder type.

Properties
 | Name | Description
Public property | DocType |
Top
See Also

Reference

BlanketPurchaseAgreementsLoder Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


BlanketPurchaseAgreementsLoder.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property DocType() As String Implements  _
   ILoader.DocType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DocType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DocType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocType() : String;
This language is not supported or no code example is available.

Property Value

Type: string

Implements

ILoader.DocType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BlanketPurchaseAgreementsLoder Class
BlanketPurchaseAgreementsLoder Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


BlanketPurchaseAgreementsLoder Methods

BlanketPurchaseAgreementsLoder Class See Also

The following tables list the members exposed by the BlanketPurchaseAgreementsLoder type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

BlanketPurchaseAgreementsLoder Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


BlanketPurchaseAgreementsLoder.LoadData Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function LoadData( _
   ByVal configuration As IScenario, _
   ByVal manager As DocumentManager _
) As List(Of IDoc) Implements  _
   ILoader.LoadData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDoc> LoadData(
   IScenario configuration,
   DocumentManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<IDoc^>^ LoadData(
   IScenario^ configuration,
   DocumentManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

configuration

Type: IScenario

manager

Type: DocumentManager

Return Value

Type: List<IDoc>

Implements

ILoader.LoadData
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BlanketPurchaseAgreementsLoder Class
BlanketPurchaseAgreementsLoder Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


BlanketSalesAgreementsLoader Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BlanketSalesAgreementsLoader
    Implements ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BlanketSalesAgreementsLoader : ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BlanketSalesAgreementsLoader  : public ILoader^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BlanketSalesAgreementsLoader
   implements ILoader
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators.BlanketSalesAgreementsLoader
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BlanketSalesAgreementsLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


BlanketSalesAgreementsLoader Members

BlanketSalesAgreementsLoader Class Methods Properties See Also

The following tables list the members exposed by the BlanketSalesAgreementsLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

BlanketSalesAgreementsLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


BlanketSalesAgreementsLoader Properties

BlanketSalesAgreementsLoader Class See Also

The following tables list the members exposed by the BlanketSalesAgreementsLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
See Also

Reference

BlanketSalesAgreementsLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


BlanketSalesAgreementsLoader.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property DocType() As String Implements  _
   ILoader.DocType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DocType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DocType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocType() : String;
This language is not supported or no code example is available.

Property Value

Type: string

Implements

ILoader.DocType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BlanketSalesAgreementsLoader Class
BlanketSalesAgreementsLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


BlanketSalesAgreementsLoader Methods

BlanketSalesAgreementsLoader Class See Also

The following tables list the members exposed by the BlanketSalesAgreementsLoader type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

BlanketSalesAgreementsLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


BlanketSalesAgreementsLoader.LoadData Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function LoadData( _
   ByVal configuration As IScenario, _
   ByVal manager As DocumentManager _
) As List(Of IDoc) Implements  _
   ILoader.LoadData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDoc> LoadData(
   IScenario configuration,
   DocumentManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<IDoc^>^ LoadData(
   IScenario^ configuration,
   DocumentManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

configuration

Type: IScenario

manager

Type: DocumentManager

Return Value

Type: List<IDoc>

Implements

ILoader.LoadData
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BlanketSalesAgreementsLoader Class
BlanketSalesAgreementsLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ForecastLoader Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ForecastLoader
    Implements ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ForecastLoader : ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ForecastLoader  : public ILoader^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ForecastLoader
   implements ILoader
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators.ForecastLoader
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ForecastLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ForecastLoader Members

ForecastLoader Class Methods Properties See Also

The following tables list the members exposed by the ForecastLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ForecastLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ForecastLoader Properties

ForecastLoader Class See Also

The following tables list the members exposed by the ForecastLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
See Also

Reference

ForecastLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ForecastLoader.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property DocType() As String Implements  _
   ILoader.DocType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DocType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DocType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocType() : String;
This language is not supported or no code example is available.

Property Value

Type: string

Implements

ILoader.DocType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ForecastLoader Class
ForecastLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ForecastLoader Methods

ForecastLoader Class See Also

The following tables list the members exposed by the ForecastLoader type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ForecastLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ForecastLoader.LoadData Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function LoadData( _
   ByVal configuration As IScenario, _
   ByVal manager As DocumentManager _
) As List(Of IDoc) Implements  _
   ILoader.LoadData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDoc> LoadData(
   IScenario configuration,
   DocumentManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<IDoc^>^ LoadData(
   IScenario^ configuration,
   DocumentManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

configuration

Type: IScenario

manager

Type: DocumentManager

Return Value

Type: List<IDoc>

Implements

ILoader.LoadData
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ForecastLoader Class
ForecastLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


InventoryTransferRequestLoader Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class InventoryTransferRequestLoader
    Implements ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class InventoryTransferRequestLoader : ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class InventoryTransferRequestLoader  : public ILoader^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class InventoryTransferRequestLoader
   implements ILoader
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators.InventoryTransferRequestLoader
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InventoryTransferRequestLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


InventoryTransferRequestLoader Members

InventoryTransferRequestLoader Class Methods Properties See Also

The following tables list the members exposed by the InventoryTransferRequestLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

InventoryTransferRequestLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


InventoryTransferRequestLoader Properties

InventoryTransferRequestLoader Class See Also

The following tables list the members exposed by the InventoryTransferRequestLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
See Also

Reference

InventoryTransferRequestLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


InventoryTransferRequestLoader.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property DocType() As String Implements  _
   ILoader.DocType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DocType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DocType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocType() : String;
This language is not supported or no code example is available.

Property Value

Type: string

Implements

ILoader.DocType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InventoryTransferRequestLoader Class
InventoryTransferRequestLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


InventoryTransferRequestLoader Methods

InventoryTransferRequestLoader Class See Also

The following tables list the members exposed by the InventoryTransferRequestLoader type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

InventoryTransferRequestLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


InventoryTransferRequestLoader.LoadData Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function LoadData( _
   ByVal configuration As IScenario, _
   ByVal manager As DocumentManager _
) As List(Of IDoc) Implements  _
   ILoader.LoadData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDoc> LoadData(
   IScenario configuration,
   DocumentManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<IDoc^>^ LoadData(
   IScenario^ configuration,
   DocumentManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

configuration

Type: IScenario

manager

Type: DocumentManager

Return Value

Type: List<IDoc>

Implements

ILoader.LoadData
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InventoryTransferRequestLoader Class
InventoryTransferRequestLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ItemInitializator Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ItemInitializator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemInitializator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ItemInitializator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemInitializator
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators.ItemInitializator
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemInitializator Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ItemInitializator Members

ItemInitializator Class Constructors Methods Properties See Also

The following tables list the members exposed by the ItemInitializator type.

Constructors
 | Name | Description
Public constructor | ItemInitializator |
Top
Properties
 | Name | Description
Public property | AllPaths |
Public property | ItemManagers |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | InitializeItems |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ItemInitializator Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ItemInitializator Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal mRPManager As MRPManager _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemInitializator(
   MRPManager mRPManager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemInitializator(
   MRPManager^ mRPManager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemInitializator(
    mRPManager : MRPManager
);
This language is not supported or no code example is available.

Parameters

mRPManager

Type: MRPManager

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemInitializator Class
ItemInitializator Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ItemInitializator Properties

ItemInitializator Class See Also

The following tables list the members exposed by the ItemInitializator type.

Properties
 | Name | Description
Public property | AllPaths |
Public property | ItemManagers |
Top
See Also

Reference

ItemInitializator Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ItemInitializator.AllPaths Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property AllPaths() As List(Of IPathItem)
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IPathItem> AllPaths {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<IPathItem^>^ AllPaths {
 List<IPathItem^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IPathItem>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemInitializator Class
ItemInitializator Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ItemInitializator.ItemManagers Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ItemManagers() As Dictionary(Of String, ItemManager)
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Dictionary<string, ItemManager> ItemManagers {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Dictionary<String^, ItemManager^>^ ItemManagers {
 Dictionary<String^, ItemManager^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: Dictionary<string, ItemManager>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemInitializator Class
ItemInitializator Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ItemInitializator Methods

ItemInitializator Class See Also

The following tables list the members exposed by the ItemInitializator type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | InitializeItems |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ItemInitializator Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ItemInitializator.InitializeItems Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function InitializeItems() As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Result InitializeItems()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Result^ InitializeItems()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function InitializeItems() : Result;
This language is not supported or no code example is available.

Return Value

Type: Result
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemInitializator Class
ItemInitializator Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ManufacturingOrdersLoader Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ManufacturingOrdersLoader
    Implements ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ManufacturingOrdersLoader : ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ManufacturingOrdersLoader  : public ILoader^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ManufacturingOrdersLoader
   implements ILoader
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators.ManufacturingOrdersLoader
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ManufacturingOrdersLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ManufacturingOrdersLoader Members

ManufacturingOrdersLoader Class Methods Properties See Also

The following tables list the members exposed by the ManufacturingOrdersLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ManufacturingOrdersLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ManufacturingOrdersLoader Properties

ManufacturingOrdersLoader Class See Also

The following tables list the members exposed by the ManufacturingOrdersLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
See Also

Reference

ManufacturingOrdersLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ManufacturingOrdersLoader.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property DocType() As String Implements  _
   ILoader.DocType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DocType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DocType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocType() : String;
This language is not supported or no code example is available.

Property Value

Type: string

Implements

ILoader.DocType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ManufacturingOrdersLoader Class
ManufacturingOrdersLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ManufacturingOrdersLoader Methods

ManufacturingOrdersLoader Class See Also

The following tables list the members exposed by the ManufacturingOrdersLoader type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ManufacturingOrdersLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


ManufacturingOrdersLoader.LoadData Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function LoadData( _
   ByVal configuration As IScenario, _
   ByVal manager As DocumentManager _
) As List(Of IDoc) Implements  _
   ILoader.LoadData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDoc> LoadData(
   IScenario configuration,
   DocumentManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<IDoc^>^ LoadData(
   IScenario^ configuration,
   DocumentManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

configuration

Type: IScenario

manager

Type: DocumentManager

Return Value

Type: List<IDoc>

Implements

ILoader.LoadData
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ManufacturingOrdersLoader Class
ManufacturingOrdersLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


PurchaseOrdersLoader Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class PurchaseOrdersLoader
    Implements ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PurchaseOrdersLoader : ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class PurchaseOrdersLoader  : public ILoader^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PurchaseOrdersLoader
   implements ILoader
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators.PurchaseOrdersLoader
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseOrdersLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


PurchaseOrdersLoader Members

PurchaseOrdersLoader Class Methods Properties See Also

The following tables list the members exposed by the PurchaseOrdersLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PurchaseOrdersLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


PurchaseOrdersLoader Properties

PurchaseOrdersLoader Class See Also

The following tables list the members exposed by the PurchaseOrdersLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
See Also

Reference

PurchaseOrdersLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


PurchaseOrdersLoader.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property DocType() As String Implements  _
   ILoader.DocType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DocType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DocType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocType() : String;
This language is not supported or no code example is available.

Property Value

Type: string

Implements

ILoader.DocType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseOrdersLoader Class
PurchaseOrdersLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


PurchaseOrdersLoader Methods

PurchaseOrdersLoader Class See Also

The following tables list the members exposed by the PurchaseOrdersLoader type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PurchaseOrdersLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


PurchaseOrdersLoader.LoadData Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function LoadData( _
   ByVal configuration As IScenario, _
   ByVal manager As DocumentManager _
) As List(Of IDoc) Implements  _
   ILoader.LoadData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDoc> LoadData(
   IScenario configuration,
   DocumentManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<IDoc^>^ LoadData(
   IScenario^ configuration,
   DocumentManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

configuration

Type: IScenario

manager

Type: DocumentManager

Return Value

Type: List<IDoc>

Implements

ILoader.LoadData
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseOrdersLoader Class
PurchaseOrdersLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


PurchaseQuotationLoader Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class PurchaseQuotationLoader
    Implements ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PurchaseQuotationLoader : ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class PurchaseQuotationLoader  : public ILoader^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PurchaseQuotationLoader
   implements ILoader
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators.PurchaseQuotationLoader
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseQuotationLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


PurchaseQuotationLoader Members

PurchaseQuotationLoader Class Methods Properties See Also

The following tables list the members exposed by the PurchaseQuotationLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PurchaseQuotationLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


PurchaseQuotationLoader Properties

PurchaseQuotationLoader Class See Also

The following tables list the members exposed by the PurchaseQuotationLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
See Also

Reference

PurchaseQuotationLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


PurchaseQuotationLoader.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property DocType() As String Implements  _
   ILoader.DocType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DocType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DocType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocType() : String;
This language is not supported or no code example is available.

Property Value

Type: string

Implements

ILoader.DocType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseQuotationLoader Class
PurchaseQuotationLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


PurchaseQuotationLoader Methods

PurchaseQuotationLoader Class See Also

The following tables list the members exposed by the PurchaseQuotationLoader type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PurchaseQuotationLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


PurchaseQuotationLoader.LoadData Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function LoadData( _
   ByVal configuration As IScenario, _
   ByVal manager As DocumentManager _
) As List(Of IDoc) Implements  _
   ILoader.LoadData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDoc> LoadData(
   IScenario configuration,
   DocumentManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<IDoc^>^ LoadData(
   IScenario^ configuration,
   DocumentManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

configuration

Type: IScenario

manager

Type: DocumentManager

Return Value

Type: List<IDoc>

Implements

ILoader.LoadData
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseQuotationLoader Class
PurchaseQuotationLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


PurchaseRequestLoader Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class PurchaseRequestLoader
    Implements ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PurchaseRequestLoader : ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class PurchaseRequestLoader  : public ILoader^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PurchaseRequestLoader
   implements ILoader
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators.PurchaseRequestLoader
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseRequestLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


PurchaseRequestLoader Members

PurchaseRequestLoader Class Methods Properties See Also

The following tables list the members exposed by the PurchaseRequestLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PurchaseRequestLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


PurchaseRequestLoader Properties

PurchaseRequestLoader Class See Also

The following tables list the members exposed by the PurchaseRequestLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
See Also

Reference

PurchaseRequestLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


PurchaseRequestLoader.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property DocType() As String Implements  _
   ILoader.DocType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DocType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DocType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocType() : String;
This language is not supported or no code example is available.

Property Value

Type: string

Implements

ILoader.DocType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseRequestLoader Class
PurchaseRequestLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


PurchaseRequestLoader Methods

PurchaseRequestLoader Class See Also

The following tables list the members exposed by the PurchaseRequestLoader type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PurchaseRequestLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


PurchaseRequestLoader.LoadData Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function LoadData( _
   ByVal configuration As IScenario, _
   ByVal manager As DocumentManager _
) As List(Of IDoc) Implements  _
   ILoader.LoadData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDoc> LoadData(
   IScenario configuration,
   DocumentManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<IDoc^>^ LoadData(
   IScenario^ configuration,
   DocumentManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

configuration

Type: IScenario

manager

Type: DocumentManager

Return Value

Type: List<IDoc>

Implements

ILoader.LoadData
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseRequestLoader Class
PurchaseRequestLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


RecurringPurchaseTransactionsLoader Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class RecurringPurchaseTransactionsLoader
    Implements ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RecurringPurchaseTransactionsLoader : ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class RecurringPurchaseTransactionsLoader  : public ILoader^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RecurringPurchaseTransactionsLoader
   implements ILoader
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators.RecurringPurchaseTransactionsLoader
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RecurringPurchaseTransactionsLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


RecurringPurchaseTransactionsLoader Members

RecurringPurchaseTransactionsLoader Class Methods Properties See Also

The following tables list the members exposed by the RecurringPurchaseTransactionsLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

RecurringPurchaseTransactionsLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


RecurringPurchaseTransactionsLoader Properties

RecurringPurchaseTransactionsLoader Class See Also

The following tables list the members exposed by the RecurringPurchaseTransactionsLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
See Also

Reference

RecurringPurchaseTransactionsLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


RecurringPurchaseTransactionsLoader.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Shadows Property DocType() As String Implements  _
   ILoader.DocType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
new public string DocType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DocType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public hide function get DocType() : String;
This language is not supported or no code example is available.

Property Value

Type: string

Implements

ILoader.DocType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RecurringPurchaseTransactionsLoader Class
RecurringPurchaseTransactionsLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


RecurringPurchaseTransactionsLoader Methods

RecurringPurchaseTransactionsLoader Class See Also

The following tables list the members exposed by the RecurringPurchaseTransactionsLoader type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

RecurringPurchaseTransactionsLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


RecurringPurchaseTransactionsLoader.LoadData Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function LoadData( _
   ByVal configuration As IScenario, _
   ByVal manager As DocumentManager _
) As List(Of IDoc) Implements  _
   ILoader.LoadData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDoc> LoadData(
   IScenario configuration,
   DocumentManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<IDoc^>^ LoadData(
   IScenario^ configuration,
   DocumentManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

configuration

Type: IScenario

manager

Type: DocumentManager

Return Value

Type: List<IDoc>

Implements

ILoader.LoadData
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RecurringPurchaseTransactionsLoader Class
RecurringPurchaseTransactionsLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


RecurringSalesTransactionsLoader Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class RecurringSalesTransactionsLoader
    Implements ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RecurringSalesTransactionsLoader : ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class RecurringSalesTransactionsLoader  : public ILoader^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RecurringSalesTransactionsLoader
   implements ILoader
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators.RecurringSalesTransactionsLoader
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RecurringSalesTransactionsLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


RecurringSalesTransactionsLoader Members

RecurringSalesTransactionsLoader Class Methods Properties See Also

The following tables list the members exposed by the RecurringSalesTransactionsLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

RecurringSalesTransactionsLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


RecurringSalesTransactionsLoader Properties

RecurringSalesTransactionsLoader Class See Also

The following tables list the members exposed by the RecurringSalesTransactionsLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
See Also

Reference

RecurringSalesTransactionsLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


RecurringSalesTransactionsLoader.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Shadows Property DocType() As String Implements  _
   ILoader.DocType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
new public string DocType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DocType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public hide function get DocType() : String;
This language is not supported or no code example is available.

Property Value

Type: string

Implements

ILoader.DocType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RecurringSalesTransactionsLoader Class
RecurringSalesTransactionsLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


RecurringSalesTransactionsLoader Methods

RecurringSalesTransactionsLoader Class See Also

The following tables list the members exposed by the RecurringSalesTransactionsLoader type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

RecurringSalesTransactionsLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


RecurringSalesTransactionsLoader.LoadData Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function LoadData( _
   ByVal configuration As IScenario, _
   ByVal manager As DocumentManager _
) As List(Of IDoc) Implements  _
   ILoader.LoadData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDoc> LoadData(
   IScenario configuration,
   DocumentManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<IDoc^>^ LoadData(
   IScenario^ configuration,
   DocumentManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

configuration

Type: IScenario

manager

Type: DocumentManager

Return Value

Type: List<IDoc>

Implements

ILoader.LoadData
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RecurringSalesTransactionsLoader Class
RecurringSalesTransactionsLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


SalesOrdersLoader Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SalesOrdersLoader
    Implements ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SalesOrdersLoader : ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SalesOrdersLoader  : public ILoader^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SalesOrdersLoader
   implements ILoader
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators.SalesOrdersLoader
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SalesOrdersLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


SalesOrdersLoader Members

SalesOrdersLoader Class Methods Properties See Also

The following tables list the members exposed by the SalesOrdersLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SalesOrdersLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


SalesOrdersLoader Properties

SalesOrdersLoader Class See Also

The following tables list the members exposed by the SalesOrdersLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
See Also

Reference

SalesOrdersLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


SalesOrdersLoader.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property DocType() As String Implements  _
   ILoader.DocType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DocType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DocType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocType() : String;
This language is not supported or no code example is available.

Property Value

Type: string

Implements

ILoader.DocType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SalesOrdersLoader Class
SalesOrdersLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


SalesOrdersLoader Methods

SalesOrdersLoader Class See Also

The following tables list the members exposed by the SalesOrdersLoader type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SalesOrdersLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


SalesOrdersLoader.LoadData Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function LoadData( _
   ByVal configuration As IScenario, _
   ByVal manager As DocumentManager _
) As List(Of IDoc) Implements  _
   ILoader.LoadData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDoc> LoadData(
   IScenario configuration,
   DocumentManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<IDoc^>^ LoadData(
   IScenario^ configuration,
   DocumentManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

configuration

Type: IScenario

manager

Type: DocumentManager

Return Value

Type: List<IDoc>

Implements

ILoader.LoadData
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SalesOrdersLoader Class
SalesOrdersLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


SalesQuotationLoader Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SalesQuotationLoader
    Implements ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SalesQuotationLoader : ILoader
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SalesQuotationLoader  : public ILoader^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SalesQuotationLoader
   implements ILoader
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators.SalesQuotationLoader
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SalesQuotationLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


SalesQuotationLoader Members

SalesQuotationLoader Class Methods Properties See Also

The following tables list the members exposed by the SalesQuotationLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SalesQuotationLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


SalesQuotationLoader Properties

SalesQuotationLoader Class See Also

The following tables list the members exposed by the SalesQuotationLoader type.

Properties
 | Name | Description
Public property | DocType |
Top
See Also

Reference

SalesQuotationLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


SalesQuotationLoader.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property DocType() As String Implements  _
   ILoader.DocType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DocType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DocType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocType() : String;
This language is not supported or no code example is available.

Property Value

Type: string

Implements

ILoader.DocType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SalesQuotationLoader Class
SalesQuotationLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


SalesQuotationLoader Methods

SalesQuotationLoader Class See Also

The following tables list the members exposed by the SalesQuotationLoader type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SalesQuotationLoader Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


SalesQuotationLoader.LoadData Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function LoadData( _
   ByVal configuration As IScenario, _
   ByVal manager As DocumentManager _
) As List(Of IDoc) Implements  _
   ILoader.LoadData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDoc> LoadData(
   IScenario configuration,
   DocumentManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<IDoc^>^ LoadData(
   IScenario^ configuration,
   DocumentManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

configuration

Type: IScenario

manager

Type: DocumentManager

Return Value

Type: List<IDoc>

Implements

ILoader.LoadData
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SalesQuotationLoader Class
SalesQuotationLoader Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Initializators Namespace


CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | Vendor |
Public class | VendorAddress |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


Vendor Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class Vendor
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Vendor
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class Vendor
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Vendor
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors.Vendor
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Vendor Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


Vendor Members

Vendor Class Constructors Methods Properties See Also

The following tables list the members exposed by the Vendor type.

Constructors
 | Name | Description
Public constructor | Vendor |
Top
Properties
 | Name | Description
Public property | Addres |
Public property | Addreses |
Public property | CardCode |
Public property | DfltAddress |
Public property | DfltDelTimeSlot |
Public property | DfltPriority |
Public property | InternalLeadTime |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Init |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Vendor Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


Vendor Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal cc As String, _
   ByVal addr As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Vendor(
   string cc,
   string addr
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Vendor(
   String^ cc,
   String^ addr
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Vendor(
    cc : String,
    addr : String
);
This language is not supported or no code example is available.

Parameters

cc

Type: string

addr

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Vendor Class
Vendor Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


Vendor Properties

Vendor Class See Also

The following tables list the members exposed by the Vendor type.

Properties
 | Name | Description
Public property | Addres |
Public property | Addreses |
Public property | CardCode |
Public property | DfltAddress |
Public property | DfltDelTimeSlot |
Public property | DfltPriority |
Public property | InternalLeadTime |
Top
See Also

Reference

Vendor Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


Vendor.Addres Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Addres() As VendorAddress
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public VendorAddress Addres {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property VendorAddress^ Addres {
 VendorAddress^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Addres() : VendorAddress;
This language is not supported or no code example is available.

Property Value

Type: VendorAddress
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Vendor Class
Vendor Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


Vendor.Addreses Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Addreses() As List(Of VendorAddress)
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<VendorAddress> Addreses {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<VendorAddress^>^ Addreses {
 List<VendorAddress^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<VendorAddress>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Vendor Class
Vendor Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


Vendor.CardCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property CardCode() As String
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string CardCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ CardCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get CardCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Vendor Class
Vendor Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


Vendor.DfltAddress Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DfltAddress() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DfltAddress {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DfltAddress {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DfltAddress() : String;
public function set DfltAddress(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Vendor Class
Vendor Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


Vendor.DfltDelTimeSlot Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DfltDelTimeSlot() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int DfltDelTimeSlot {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int DfltDelTimeSlot {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DfltDelTimeSlot() : int;
public function set DfltDelTimeSlot(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Vendor Class
Vendor Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


Vendor.DfltPriority Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DfltPriority() As Integer
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int DfltPriority {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int DfltPriority {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DfltPriority() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Vendor Class
Vendor Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


Vendor.InternalLeadTime Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InternalLeadTime() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan InternalLeadTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property TimeSpan InternalLeadTime {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InternalLeadTime() : TimeSpan;
public function set InternalLeadTime(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Vendor Class
Vendor Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


Vendor Methods

Vendor Class See Also

The following tables list the members exposed by the Vendor type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Init |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Vendor Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


Vendor.Init Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Init()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Init()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Init()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Init();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Vendor Class
Vendor Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


VendorAddress Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class VendorAddress
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class VendorAddress
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class VendorAddress
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class VendorAddress
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors.VendorAddress
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VendorAddress Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


VendorAddress Members

VendorAddress Class Methods Properties See Also

The following tables list the members exposed by the VendorAddress type.

Properties
 | Name | Description
Public property | Address |
Public property | DfltDelTimeSlot |
Public property | InternalLeadTime |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

VendorAddress Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


VendorAddress Properties

VendorAddress Class See Also

The following tables list the members exposed by the VendorAddress type.

Properties
 | Name | Description
Public property | Address |
Public property | DfltDelTimeSlot |
Public property | InternalLeadTime |
Top
See Also

Reference

VendorAddress Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


VendorAddress.Address Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Address() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Address {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Address {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Address() : String;
public function set Address(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VendorAddress Class
VendorAddress Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


VendorAddress.DfltDelTimeSlot Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DfltDelTimeSlot() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int DfltDelTimeSlot {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int DfltDelTimeSlot {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DfltDelTimeSlot() : int;
public function set DfltDelTimeSlot(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VendorAddress Class
VendorAddress Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


VendorAddress.InternalLeadTime Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InternalLeadTime() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan InternalLeadTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property TimeSpan InternalLeadTime {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InternalLeadTime() : TimeSpan;
public function set InternalLeadTime(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VendorAddress Class
VendorAddress Members
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


VendorAddress Methods

VendorAddress Class See Also

The following tables list the members exposed by the VendorAddress type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

VendorAddress Class
CompuTec.ProcessForce.API.Tools.MRP.Data.Vendors Namespace


CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | AggregationManager |
Public class | DataLoadManager |
Public class | DatesCalculator |
Public class | DocumentManager |
Public class | ItemManager |
Public class | MRPManager |
Public class | ResultBuilder |
Public class | RuleManager |
Public class | WarehouseManager |
Top
Interfaces
 | Name | Description
Public interface | ICallendar |
Public interface | IDateCalculator |
Public interface | IInternalLeadTimeRule |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


AggregationManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class AggregationManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class AggregationManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class AggregationManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class AggregationManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.AggregationManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AggregationManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


AggregationManager Members

AggregationManager Class Constructors Methods Properties See Also

The following tables list the members exposed by the AggregationManager type.

Constructors
 | Name | Description
Public constructor | AggregationManager |
Top
Properties
 | Name | Description
Public property | Result |
Top
Methods
 | Name | Description
Public method | Aggregate |
Public method | BuildRecomendations |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | RecalculateQuantities |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Classes
 | Name | Description
Public class | MRPAggregation |
Top
See Also

Reference

AggregationManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPAggregation Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<DebuggerDisplay("{Period.From} {Period.To} {Entities.Count} {InStockQty} {OutStockQty} {Supply} {Demand}")> _
Public Class MRPAggregation
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DebuggerDisplay("{Period.From} {Period.To} {Entities.Count} {InStockQty} {OutStockQty} {Supply} {Demand}")]
public class MRPAggregation
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[DebuggerDisplay("{Period.From} {Period.To} {Entities.Count} {InStockQty} {OutStockQty} {Supply} {Demand}")]
public ref class MRPAggregation
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   DebuggerDisplay("{Period.From} {Period.To} {Entities.Count} {InStockQty} {OutStockQty} {Supply} {Demand}")
class MRPAggregation
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.AggregationManager.MRPAggregation
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPAggregation Members

MRPAggregation Class Constructors Methods Properties See Also

The following tables list the members exposed by the MRPAggregation type.

Constructors
 | Name | Description
Public constructor | MRPAggregation |
Top
Properties
 | Name | Description
Public property | Demand |
Public property | Documents |
Public property | Drafts |
Public property | Entities |
Public property | InAvailbleQuantity |
Public property | InStockQty |
Public property | Item |
Public property | OutAvailbleQuantity |
Public property | OutStockQty |
Public property | Period |
Public property | Recomendations |
Public property | Supply |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MRPAggregation Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPAggregation Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MRPAggregation()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
MRPAggregation()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function MRPAggregation();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPAggregation Class
MRPAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPAggregation Properties

MRPAggregation Class See Also

The following tables list the members exposed by the MRPAggregation type.

Properties
 | Name | Description
Public property | Demand |
Public property | Documents |
Public property | Drafts |
Public property | Entities |
Public property | InAvailbleQuantity |
Public property | InStockQty |
Public property | Item |
Public property | OutAvailbleQuantity |
Public property | OutStockQty |
Public property | Period |
Public property | Recomendations |
Public property | Supply |
Top
See Also

Reference

MRPAggregation Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPAggregation.Demand Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Demand() As Decimal
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal Demand {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal Demand {
 Decimal get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Demand() : decimal;
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPAggregation Class
MRPAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPAggregation.Documents Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Documents() As List(Of IDocLine)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDocLine> Documents {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<IDocLine^>^ Documents {
 List<IDocLine^>^ get( );
 void set(
   List<IDocLine^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IDocLine>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPAggregation Class
MRPAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPAggregation.Drafts Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Drafts() As List(Of IDoc)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDoc> Drafts {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<IDoc^>^ Drafts {
 List<IDoc^>^ get( );
 void set(
   List<IDoc^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IDoc>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPAggregation Class
MRPAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPAggregation.Entities Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Entities() As List(Of IMRPEntity)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IMRPEntity> Entities {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<IMRPEntity^>^ Entities {
 List<IMRPEntity^>^ get( );
 void set(
   List<IMRPEntity^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IMRPEntity>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPAggregation Class
MRPAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPAggregation.InAvailbleQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InAvailbleQuantity() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal InAvailbleQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal InAvailbleQuantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InAvailbleQuantity() : decimal;
public function set InAvailbleQuantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPAggregation Class
MRPAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPAggregation.InStockQty Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InStockQty() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal InStockQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal InStockQty {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InStockQty() : decimal;
public function set InStockQty(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPAggregation Class
MRPAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPAggregation.Item Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Item() As IItemSettings
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IItemSettings Item {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IItemSettings^ Item {
 IItemSettings^ get( );
 void set(
   IItemSettings^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Item() : IItemSettings;
public function set Item(value : IItemSettings);
This language is not supported or no code example is available.

Property Value

Type: IItemSettings
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPAggregation Class
MRPAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPAggregation.OutAvailbleQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property OutAvailbleQuantity() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal OutAvailbleQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal OutAvailbleQuantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get OutAvailbleQuantity() : decimal;
public function set OutAvailbleQuantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPAggregation Class
MRPAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPAggregation.OutStockQty Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property OutStockQty() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal OutStockQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal OutStockQty {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get OutStockQty() : decimal;
public function set OutStockQty(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPAggregation Class
MRPAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPAggregation.Period Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Period() As MRPPeriod
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MRPPeriod Period {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property MRPPeriod^ Period {
 MRPPeriod^ get( );
 void set(
   MRPPeriod^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Period() : MRPPeriod;
public function set Period(value : MRPPeriod);
This language is not supported or no code example is available.

Property Value

Type: MRPPeriod
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPAggregation Class
MRPAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPAggregation.Recomendations Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Recomendations() As List(Of IMRPOrderRecomendations)
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IMRPOrderRecomendations> Recomendations {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<IMRPOrderRecomendations^>^ Recomendations {
 List<IMRPOrderRecomendations^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IMRPOrderRecomendations>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPAggregation Class
MRPAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPAggregation.Supply Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Supply() As Decimal
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal Supply {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal Supply {
 Decimal get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Supply() : decimal;
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPAggregation Class
MRPAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPAggregation Methods

MRPAggregation Class See Also

The following tables list the members exposed by the MRPAggregation type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MRPAggregation Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


AggregationManager Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public AggregationManager()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
AggregationManager()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function AggregationManager();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AggregationManager Class
AggregationManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


AggregationManager Properties

AggregationManager Class See Also

The following tables list the members exposed by the AggregationManager type.

Properties
 | Name | Description
Public property | Result |
Top
See Also

Reference

AggregationManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


AggregationManager.Result Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Result() As Dictionary(Of ItemRev, LinkedList(Of MRPAggregation))
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Dictionary<ItemRev, LinkedList<MRPAggregation>> Result {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Dictionary<ItemRev^, LinkedList<MRPAggregation^>^>^ Result {
 Dictionary<ItemRev^, LinkedList<MRPAggregation^>^>^ get( );
 void set(
   Dictionary<ItemRev^, LinkedList<MRPAggregation^>^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: Dictionary<ItemRev, LinkedList<MRPAggregation>>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AggregationManager Class
AggregationManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


AggregationManager Methods

AggregationManager Class See Also

The following tables list the members exposed by the AggregationManager type.

Methods
 | Name | Description
Public method | Aggregate |
Public method | BuildRecomendations |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | RecalculateQuantities |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

AggregationManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


AggregationManager.Aggregate Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Aggregate( _
   ByVal mRPManager As MRPManager, _
   ByVal periods As List(Of MRPPeriod) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Aggregate(
   MRPManager mRPManager,
   List<MRPPeriod> periods
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Aggregate(
   MRPManager^ mRPManager,
   List<MRPPeriod^>^ periods
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

mRPManager

Type: MRPManager

periods

Type: List<MRPPeriod>

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AggregationManager Class
AggregationManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


AggregationManager.BuildRecomendations Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub BuildRecomendations( _
   ByVal scenario As IScenario, _
   ByVal aggregation As MRPAggregation _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void BuildRecomendations(
   IScenario scenario,
   MRPAggregation aggregation
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void BuildRecomendations(
   IScenario^ scenario,
   MRPAggregation^ aggregation
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BuildRecomendations(
    scenario : IScenario,
    aggregation : MRPAggregation
);
This language is not supported or no code example is available.

Parameters

scenario

Type: IScenario

aggregation

Type: MRPAggregation

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AggregationManager Class
AggregationManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


AggregationManager.RecalculateQuantities Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub RecalculateQuantities( _
   ByVal startedQty As Decimal, _
   ByVal lst As LinkedList(Of MRPAggregation) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void RecalculateQuantities(
   decimal startedQty,
   LinkedList<MRPAggregation> lst
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void RecalculateQuantities(
   Decimal startedQty,
   LinkedList<MRPAggregation^>^ lst
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

startedQty

Type: decimal

lst

Type: LinkedList<MRPAggregation>

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AggregationManager Class
AggregationManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DataLoadManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class DataLoadManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DataLoadManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class DataLoadManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DataLoadManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.DataLoadManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataLoadManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DataLoadManager Members

DataLoadManager Class Constructors Methods Properties See Also

The following tables list the members exposed by the DataLoadManager type.

Constructors
 | Name | Description
Public constructor | DataLoadManager |
Top
Properties
 | Name | Description
Public property | DocManager |
Public property | MrpManager |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

DataLoadManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DataLoadManager Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal manager As DocumentManager, _
   ByVal mrpManager As MRPManager _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DataLoadManager(
   DocumentManager manager,
   MRPManager mrpManager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DataLoadManager(
   DocumentManager^ manager,
   MRPManager^ mrpManager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DataLoadManager(
    manager : DocumentManager,
    mrpManager : MRPManager
);
This language is not supported or no code example is available.

Parameters

manager

Type: DocumentManager

mrpManager

Type: MRPManager

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataLoadManager Class
DataLoadManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DataLoadManager Properties

DataLoadManager Class See Also

The following tables list the members exposed by the DataLoadManager type.

Properties
 | Name | Description
Public property | DocManager |
Public property | MrpManager |
Top
See Also

Reference

DataLoadManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DataLoadManager.DocManager Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DocManager() As DocumentManager
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DocumentManager DocManager {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DocumentManager^ DocManager {
 DocumentManager^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocManager() : DocumentManager;
This language is not supported or no code example is available.

Property Value

Type: DocumentManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataLoadManager Class
DataLoadManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DataLoadManager.MrpManager Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property MrpManager() As MRPManager
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MRPManager MrpManager {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property MRPManager^ MrpManager {
 MRPManager^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get MrpManager() : MRPManager;
This language is not supported or no code example is available.

Property Value

Type: MRPManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataLoadManager Class
DataLoadManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DataLoadManager Methods

DataLoadManager Class See Also

The following tables list the members exposed by the DataLoadManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadData |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

DataLoadManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DataLoadManager.LoadData Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function LoadData( _
   ByVal config As IScenario _
) As List(Of IDoc)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDoc> LoadData(
   IScenario config
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<IDoc^>^ LoadData(
   IScenario^ config
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

config

Type: IScenario

Return Value

Type: List<IDoc>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataLoadManager Class
DataLoadManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DatesCalculator Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class DatesCalculator
    Implements IDateCalculator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DatesCalculator : IDateCalculator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class DatesCalculator  : public IDateCalculator^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DatesCalculator
   implements IDateCalculator
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.DatesCalculator
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DatesCalculator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DatesCalculator Members

DatesCalculator Class Constructors Methods See Also

The following tables list the members exposed by the DatesCalculator type.

Constructors
 | Name | Description
Public constructor | DatesCalculator |
Top
Methods
 | Name | Description
Public method | AddDays |
Public method | CalculateDatesForLink |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadCallendars |
Public method | SubstractDays |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

DatesCalculator Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DatesCalculator Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal rPManager As MRPManager _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DatesCalculator(
   MRPManager rPManager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DatesCalculator(
   MRPManager^ rPManager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DatesCalculator(
    rPManager : MRPManager
);
This language is not supported or no code example is available.

Parameters

rPManager

Type: MRPManager

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DatesCalculator Class
DatesCalculator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DatesCalculator Methods

DatesCalculator Class See Also

The following tables list the members exposed by the DatesCalculator type.

Methods
 | Name | Description
Public method | AddDays |
Public method | CalculateDatesForLink |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadCallendars |
Public method | SubstractDays |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

DatesCalculator Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DatesCalculator.AddDays Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function AddDays( _
   ByVal ObjType As String, _
   ByVal date As Date, _
   ByVal span As TimeSpan _
) As Date Implements  _
   IDateCalculator.AddDays
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime AddDays(
   string ObjType,
   DateTime date,
   TimeSpan span
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DateTime AddDays(
   String^ ObjType,
   DateTime date,
   TimeSpan span
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function AddDays(
    ObjType : String,
    date : DateTime,
    span : TimeSpan
) : DateTime;
This language is not supported or no code example is available.

Parameters

ObjType

Type: string

date

Type: DateTime

span

Type: TimeSpan

Return Value

Type: DateTime

Implements

IDateCalculator.AddDays
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DatesCalculator Class
DatesCalculator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DatesCalculator.CalculateDatesForLink Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub CalculateDatesForLink( _
   ByVal link As ILink _
) Implements  _
   IDateCalculator.CalculateDatesForLink
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void CalculateDatesForLink(
   ILink link
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void CalculateDatesForLink(
   ILink^ link
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CalculateDatesForLink(
    link : ILink
);
This language is not supported or no code example is available.

Parameters

link

Type: ILink

Implements

IDateCalculator.CalculateDatesForLink
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DatesCalculator Class
DatesCalculator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DatesCalculator.LoadCallendars Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub LoadCallendars( _
   ByVal scenario As IScenario _
) Implements  _
   IDateCalculator.LoadCallendars
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void LoadCallendars(
   IScenario scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void LoadCallendars(
   IScenario^ scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function LoadCallendars(
    scenario : IScenario
);
This language is not supported or no code example is available.

Parameters

scenario

Type: IScenario

Implements

IDateCalculator.LoadCallendars
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DatesCalculator Class
DatesCalculator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DatesCalculator.SubstractDays Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function SubstractDays( _
   ByVal ObjType As String, _
   ByVal date As Date, _
   ByVal span As TimeSpan _
) As Date Implements  _
   IDateCalculator.SubstractDays
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime SubstractDays(
   string ObjType,
   DateTime date,
   TimeSpan span
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DateTime SubstractDays(
   String^ ObjType,
   DateTime date,
   TimeSpan span
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SubstractDays(
    ObjType : String,
    date : DateTime,
    span : TimeSpan
) : DateTime;
This language is not supported or no code example is available.

Parameters

ObjType

Type: string

date

Type: DateTime

span

Type: TimeSpan

Return Value

Type: DateTime

Implements

IDateCalculator.SubstractDays
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DatesCalculator Class
DatesCalculator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DocumentManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class DocumentManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DocumentManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class DocumentManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DocumentManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.DocumentManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DocumentManager Members

DocumentManager Class Constructors Methods Properties See Also

The following tables list the members exposed by the DocumentManager type.

Constructors
 | Name | Description
Public constructor | DocumentManager |
Top
Properties
 | Name | Description
Public property | Documents |
Public property | MRPManager |
Top
Methods
 | Name | Description
Public method | ContainsDocument |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetDocument | (Overloaded)
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | PlaceRecomendation |
Public method | SetDocument |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

DocumentManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DocumentManager Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal owner As MRPManager _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DocumentManager(
   MRPManager owner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DocumentManager(
   MRPManager^ owner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DocumentManager(
    owner : MRPManager
);
This language is not supported or no code example is available.

Parameters

owner

Type: MRPManager

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentManager Class
DocumentManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DocumentManager Properties

DocumentManager Class See Also

The following tables list the members exposed by the DocumentManager type.

Properties
 | Name | Description
Public property | Documents |
Public property | MRPManager |
Top
See Also

Reference

DocumentManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DocumentManager.Documents Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property Documents() As IEnumerable(Of IDoc)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IEnumerable<IDoc> Documents {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IEnumerable<IDoc^>^ Documents {
 IEnumerable<IDoc^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: IEnumerable<IDoc>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentManager Class
DocumentManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DocumentManager.MRPManager Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property MRPManager() As MRPManager
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MRPManager MRPManager {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property MRPManager^ MRPManager {
 MRPManager^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get MRPManager() : MRPManager;
This language is not supported or no code example is available.

Property Value

Type: MRPManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentManager Class
DocumentManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DocumentManager Methods

DocumentManager Class See Also

The following tables list the members exposed by the DocumentManager type.

Methods
 | Name | Description
Public method | ContainsDocument |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetDocument | (Overloaded)
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | PlaceRecomendation |
Public method | SetDocument |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

DocumentManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DocumentManager.ContainsDocument Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function ContainsDocument( _
   ByVal type As String, _
   ByVal docentry As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool ContainsDocument(
   string type,
   string docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool ContainsDocument(
   String^ type,
   String^ docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ContainsDocument(
    type : String,
    docentry : String
) : boolean;
This language is not supported or no code example is available.

Parameters

type

Type: string

docentry

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentManager Class
DocumentManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DocumentManager.GetDocument Method

DocumentManager Class See Also

Overload List
Name | Description
GetDocument(string, int) |
GetDocument(string, string) |
See Also

Reference

DocumentManager Class
DocumentManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DocumentManager.PlaceRecomendation Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function PlaceRecomendation( _
   ByVal recomendation As IDoc _
) As List(Of IMRPEntity)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IMRPEntity> PlaceRecomendation(
   IDoc recomendation
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<IMRPEntity^>^ PlaceRecomendation(
   IDoc^ recomendation
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

recomendation

Type: IDoc

Return Value

Type: List<IMRPEntity>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentManager Class
DocumentManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DocumentManager.SetDocument Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function SetDocument( _
   ByVal doc As IDoc _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool SetDocument(
   IDoc doc
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool SetDocument(
   IDoc^ doc
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SetDocument(
    doc : IDoc
) : boolean;
This language is not supported or no code example is available.

Parameters

doc

Type: IDoc

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentManager Class
DocumentManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ItemManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ItemManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ItemManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.ItemManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ItemManager Members

ItemManager Class Constructors Methods Properties See Also

The following tables list the members exposed by the ItemManager type.

Constructors
 | Name | Description
Public constructor | ItemManager |
Top
Properties
 | Name | Description
Public property | DefaultItem |
Public property | DefaultRevision |
Public property | DfltWhs |
Public property | ItemCode |
Public property | Manager |
Public property | Paths |
Public property | PrefferedVendor |
Public property | Priority |
Public property | ResultRow |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetPath |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | MarkAllAsVisited |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ItemManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ItemManager Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal mRPManager As MRPManager, _
   ByVal p As IEnumerable(Of IItemSettings) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemManager(
   MRPManager mRPManager,
   IEnumerable<IItemSettings> p
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemManager(
   MRPManager^ mRPManager,
   IEnumerable<IItemSettings^>^ p
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

mRPManager

Type: MRPManager

p

Type: IEnumerable<IItemSettings>

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemManager Class
ItemManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ItemManager Properties

ItemManager Class See Also

The following tables list the members exposed by the ItemManager type.

Properties
 | Name | Description
Public property | DefaultItem |
Public property | DefaultRevision |
Public property | DfltWhs |
Public property | ItemCode |
Public property | Manager |
Public property | Paths |
Public property | PrefferedVendor |
Public property | Priority |
Public property | ResultRow |
Top
See Also

Reference

ItemManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ItemManager.DefaultItem Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property DefaultItem() As IItemSettings
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IItemSettings DefaultItem {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IItemSettings^ DefaultItem {
 IItemSettings^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DefaultItem() : IItemSettings;
This language is not supported or no code example is available.

Property Value

Type: IItemSettings
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemManager Class
ItemManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ItemManager.DefaultRevision Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DefaultRevision() As String
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DefaultRevision {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DefaultRevision {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DefaultRevision() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemManager Class
ItemManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ItemManager.DfltWhs Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DfltWhs() As String
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DfltWhs {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DfltWhs {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DfltWhs() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemManager Class
ItemManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ItemManager.ItemCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ItemCode() As String
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ItemCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ItemCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ItemCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemManager Class
ItemManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ItemManager.Manager Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Manager() As MRPManager
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MRPManager Manager {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property MRPManager^ Manager {
 MRPManager^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Manager() : MRPManager;
This language is not supported or no code example is available.

Property Value

Type: MRPManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemManager Class
ItemManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ItemManager.Paths Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Paths() As List(Of IPathItem)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IPathItem> Paths {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<IPathItem^>^ Paths {
 List<IPathItem^>^ get( );
 void set(
   List<IPathItem^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IPathItem>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemManager Class
ItemManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ItemManager.PrefferedVendor Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property PrefferedVendor() As IPreferredVendors
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IPreferredVendors PrefferedVendor {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IPreferredVendors^ PrefferedVendor {
 IPreferredVendors^ get( );
 void set(
   IPreferredVendors^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get PrefferedVendor() : IPreferredVendors;
public function set PrefferedVendor(value : IPreferredVendors);
This language is not supported or no code example is available.

Property Value

Type: IPreferredVendors
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemManager Class
ItemManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ItemManager.Priority Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Priority() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int Priority {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int Priority {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Priority() : int;
public function set Priority(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemManager Class
ItemManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ItemManager.ResultRow Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ResultRow() As List(Of MRPResultRow)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<MRPResultRow> ResultRow {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<MRPResultRow^>^ ResultRow {
 List<MRPResultRow^>^ get( );
 void set(
   List<MRPResultRow^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<MRPResultRow>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemManager Class
ItemManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ItemManager Methods

ItemManager Class See Also

The following tables list the members exposed by the ItemManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetPath |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | MarkAllAsVisited |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ItemManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ItemManager.GetPath Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetPath( _
   ByVal revision As String, _
   ByVal whsCode As String _
) As IPathItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IPathItem GetPath(
   string revision,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IPathItem^ GetPath(
   String^ revision,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetPath(
    revision : String,
    whsCode : String
) : IPathItem;
This language is not supported or no code example is available.

Parameters

revision

Type: string

whsCode

Type: string

Return Value

Type: IPathItem
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemManager Class
ItemManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ItemManager.MarkAllAsVisited Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub MarkAllAsVisited( _
   Optional ByVal _visited As Boolean = true, _
   Optional ByVal _calculated As Boolean = true _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void MarkAllAsVisited(
   bool _visited = true,
   bool _calculated = true
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void MarkAllAsVisited(
   bool _visited,
   bool _calculated
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function MarkAllAsVisited(
    _visited : boolean,
    _calculated : boolean
);
This language is not supported or no code example is available.

Parameters

_visited

Type: bool

_calculated

Type: bool

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemManager Class
ItemManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MRPManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MRPManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MRPManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.MRPManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager Members

MRPManager Class Methods Properties See Also

The following tables list the members exposed by the MRPManager type.

Properties
 | Name | Description
Public property | AggManager |
Public property | AllPaths |
Public property | Configuration |
Public property | DateCalculator |
Public property | DocManager |
Public property | DocumentLoadManager |
Public property | Documents |
Public property | GroupPurchaseByDay |
Public property | InternalLeadManager |
Public property | ItemManagers |
Public property | Recomendations |
Public property | RulesManager |
Public property | SupplyManager |
Public property | Token |
Public property | WhsManager |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemManager | (Overloaded)
Public method | GetPathSelectorRule |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | PrintPath |
Public method | RunMRP |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MRPManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager Properties

MRPManager Class See Also

The following tables list the members exposed by the MRPManager type.

Properties
 | Name | Description
Public property | AggManager |
Public property | AllPaths |
Public property | Configuration |
Public property | DateCalculator |
Public property | DocManager |
Public property | DocumentLoadManager |
Public property | Documents |
Public property | GroupPurchaseByDay |
Public property | InternalLeadManager |
Public property | ItemManagers |
Public property | Recomendations |
Public property | RulesManager |
Public property | SupplyManager |
Public property | Token |
Public property | WhsManager |
Top
See Also

Reference

MRPManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.AggManager Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property AggManager() As AggregationManager
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public AggregationManager AggManager {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property AggregationManager^ AggManager {
 AggregationManager^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get AggManager() : AggregationManager;
This language is not supported or no code example is available.

Property Value

Type: AggregationManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.AllPaths Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property AllPaths() As List(Of IPathItem)
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IPathItem> AllPaths {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<IPathItem^>^ AllPaths {
 List<IPathItem^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IPathItem>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.Configuration Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Configuration() As IScenario
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IScenario Configuration {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IScenario^ Configuration {
 IScenario^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Configuration() : IScenario;
This language is not supported or no code example is available.

Property Value

Type: IScenario
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.DateCalculator Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DateCalculator() As IDateCalculator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IDateCalculator DateCalculator {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IDateCalculator^ DateCalculator {
 IDateCalculator^ get( );
 void set(
   IDateCalculator^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DateCalculator() : IDateCalculator;
public function set DateCalculator(value : IDateCalculator);
This language is not supported or no code example is available.

Property Value

Type: IDateCalculator
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.DocManager Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DocManager() As DocumentManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DocumentManager DocManager {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DocumentManager^ DocManager {
 DocumentManager^ get( );
 void set(
   DocumentManager^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocManager() : DocumentManager;
public function set DocManager(value : DocumentManager);
This language is not supported or no code example is available.

Property Value

Type: DocumentManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.DocumentLoadManager Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DocumentLoadManager() As DataLoadManager
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DataLoadManager DocumentLoadManager {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DataLoadManager^ DocumentLoadManager {
 DataLoadManager^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocumentLoadManager() : DataLoadManager;
This language is not supported or no code example is available.

Property Value

Type: DataLoadManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.Documents Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property Documents() As IEnumerable(Of IDoc)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IEnumerable<IDoc> Documents {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IEnumerable<IDoc^>^ Documents {
 IEnumerable<IDoc^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: IEnumerable<IDoc>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.GroupPurchaseByDay Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property GroupPurchaseByDay() As Boolean
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool GroupPurchaseByDay {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool GroupPurchaseByDay {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get GroupPurchaseByDay() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.InternalLeadManager Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InternalLeadManager() As InternalLeadManager
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public InternalLeadManager InternalLeadManager {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property InternalLeadManager^ InternalLeadManager {
 InternalLeadManager^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InternalLeadManager() : InternalLeadManager;
This language is not supported or no code example is available.

Property Value

Type: InternalLeadManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.ItemManagers Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ItemManagers() As Dictionary(Of String, ItemManager)
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Dictionary<string, ItemManager> ItemManagers {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Dictionary<String^, ItemManager^>^ ItemManagers {
 Dictionary<String^, ItemManager^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: Dictionary<string, ItemManager>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.Recomendations Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Recomendations() As List(Of IDoc)
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDoc> Recomendations {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<IDoc^>^ Recomendations {
 List<IDoc^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IDoc>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.RulesManager Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property RulesManager() As RuleManager
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RuleManager RulesManager {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property RuleManager^ RulesManager {
 RuleManager^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get RulesManager() : RuleManager;
This language is not supported or no code example is available.

Property Value

Type: RuleManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.SupplyManager Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SupplyManager() As SupplyGenerator
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SupplyGenerator SupplyManager {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property SupplyGenerator^ SupplyManager {
 SupplyGenerator^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SupplyManager() : SupplyGenerator;
This language is not supported or no code example is available.

Property Value

Type: SupplyGenerator
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.Token Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property Token() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Token {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Token {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Token() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.WhsManager Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property WhsManager() As WarehouseManager
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public WarehouseManager WhsManager {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property WarehouseManager^ WhsManager {
 WarehouseManager^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get WhsManager() : WarehouseManager;
This language is not supported or no code example is available.

Property Value

Type: WarehouseManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager Methods

MRPManager Class See Also

The following tables list the members exposed by the MRPManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetItemManager | (Overloaded)
Public method | GetPathSelectorRule |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | PrintPath |
Public method | RunMRP |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MRPManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.GetItemManager Method

MRPManager Class See Also

Overload List
Name | Description
GetItemManager(string) |
GetItemManager(string, out ItemManager) |
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.GetPathSelectorRule Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetPathSelectorRule() As IPathSelectorRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IPathSelectorRule GetPathSelectorRule()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IPathSelectorRule^ GetPathSelectorRule()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetPathSelectorRule() : IPathSelectorRule;
This language is not supported or no code example is available.

Return Value

Type: IPathSelectorRule
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.PrintPath Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function PrintPath( _
   ByVal OnlyWithData As Boolean _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string PrintPath(
   bool OnlyWithData
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ PrintPath(
   bool OnlyWithData
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function PrintPath(
    OnlyWithData : boolean
) : String;
This language is not supported or no code example is available.

Parameters

OnlyWithData

Type: bool

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.RunMRP Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function RunMRP( _
   ByVal scenario As IScenario _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Result RunMRP(
   IScenario scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Result^ RunMRP(
   IScenario^ scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RunMRP(
    scenario : IScenario
) : Result;
This language is not supported or no code example is available.

Parameters

scenario

Type: IScenario

Return Value

Type: Result
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ResultBuilder Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ResultBuilder
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ResultBuilder
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ResultBuilder
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ResultBuilder
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.ResultBuilder
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResultBuilder Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ResultBuilder Members

ResultBuilder Class Constructors Methods Properties See Also

The following tables list the members exposed by the ResultBuilder type.

Constructors
 | Name | Description
Public constructor | ResultBuilder |
Top
Properties
 | Name | Description
Public property | StartDate |
Top
Methods
 | Name | Description
 | Between |
Public method | BuildPeriods |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetResult |
Public method | GetResults |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | SaveRecomendations |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ResultBuilder Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ResultBuilder Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal _manager As MRPManager _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResultBuilder(
   MRPManager _manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResultBuilder(
   MRPManager^ _manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResultBuilder(
    _manager : MRPManager
);
This language is not supported or no code example is available.

Parameters

_manager

Type: MRPManager

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResultBuilder Class
ResultBuilder Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ResultBuilder Properties

ResultBuilder Class See Also

The following tables list the members exposed by the ResultBuilder type.

Properties
 | Name | Description
Public property | StartDate |
Top
See Also

Reference

ResultBuilder Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ResultBuilder.StartDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property StartDate() As Date
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime StartDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime StartDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get StartDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResultBuilder Class
ResultBuilder Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ResultBuilder Methods

ResultBuilder Class See Also

The following tables list the members exposed by the ResultBuilder type.

Methods
 | Name | Description
 | Between |
Public method | BuildPeriods |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetResult |
Public method | GetResults |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | SaveRecomendations |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ResultBuilder Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ResultBuilder.Between Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function Between( _
   ByVal input As Date, _
   ByVal date1 As Date, _
   ByVal date2 As Date _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool Between(
   DateTime input,
   DateTime date1,
   DateTime date2
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool Between(
   DateTime input,
   DateTime date1,
   DateTime date2
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function Between(
    input : DateTime,
    date1 : DateTime,
    date2 : DateTime
) : boolean;
This language is not supported or no code example is available.

Parameters

input

Type: DateTime

date1

Type: DateTime

date2

Type: DateTime

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResultBuilder Class
ResultBuilder Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ResultBuilder.BuildPeriods Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function BuildPeriods( _
   ByVal scenario As IScenario _
) As List(Of MRPPeriod)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<MRPPeriod> BuildPeriods(
   IScenario scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<MRPPeriod^>^ BuildPeriods(
   IScenario^ scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

scenario

Type: IScenario

Return Value

Type: List<MRPPeriod>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResultBuilder Class
ResultBuilder Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ResultBuilder.GetResult Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetResult() As MRPResults
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MRPResults GetResult()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
MRPResults^ GetResult()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetResult() : MRPResults;
This language is not supported or no code example is available.

Return Value

Type: MRPResults
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResultBuilder Class
ResultBuilder Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ResultBuilder.GetResults Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetResults( _
   ByVal scenario As IScenario, _
   ByVal item As ItemManager, _
   ByVal periods As List(Of MRPPeriod) _
) As List(Of MRPResultRow)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<MRPResultRow> GetResults(
   IScenario scenario,
   ItemManager item,
   List<MRPPeriod> periods
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<MRPResultRow^>^ GetResults(
   IScenario^ scenario,
   ItemManager^ item,
   List<MRPPeriod^>^ periods
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

scenario

Type: IScenario

item

Type: ItemManager

periods

Type: List<MRPPeriod>

Return Value

Type: List<MRPResultRow>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResultBuilder Class
ResultBuilder Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ResultBuilder.SaveRecomendations Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function SaveRecomendations( _
   ByVal token As String, _
   ByVal results As MRPResults _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Result SaveRecomendations(
   string token,
   MRPResults results
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static Result^ SaveRecomendations(
   String^ token,
   MRPResults^ results
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function SaveRecomendations(
    token : String,
    results : MRPResults
) : Result;
This language is not supported or no code example is available.

Parameters

token

Type: string

results

Type: MRPResults

Return Value

Type: Result
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResultBuilder Class
ResultBuilder Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


RuleManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class RuleManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RuleManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class RuleManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RuleManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.RuleManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RuleManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


RuleManager Members

RuleManager Class Methods See Also

The following tables list the members exposed by the RuleManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetMinMaxRule |
Public method | GetPathSelectorRule |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

RuleManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


RuleManager Methods

RuleManager Class See Also

The following tables list the members exposed by the RuleManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetMinMaxRule |
Public method | GetPathSelectorRule |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

RuleManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


RuleManager.GetMinMaxRule Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetMinMaxRule( _
   ByVal scenario As IScenario _
) As IMinMaxRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IMinMaxRule GetMinMaxRule(
   IScenario scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IMinMaxRule^ GetMinMaxRule(
   IScenario^ scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetMinMaxRule(
    scenario : IScenario
) : IMinMaxRule;
This language is not supported or no code example is available.

Parameters

scenario

Type: IScenario

Return Value

Type: IMinMaxRule
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RuleManager Class
RuleManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


RuleManager.GetPathSelectorRule Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetPathSelectorRule( _
   ByVal scenario As IScenario _
) As IPathSelectorRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IPathSelectorRule GetPathSelectorRule(
   IScenario scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IPathSelectorRule^ GetPathSelectorRule(
   IScenario^ scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetPathSelectorRule(
    scenario : IScenario
) : IPathSelectorRule;
This language is not supported or no code example is available.

Parameters

scenario

Type: IScenario

Return Value

Type: IPathSelectorRule
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RuleManager Class
RuleManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


WarehouseManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class WarehouseManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class WarehouseManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class WarehouseManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class WarehouseManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.WarehouseManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WarehouseManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


WarehouseManager Members

WarehouseManager Class Methods Properties See Also

The following tables list the members exposed by the WarehouseManager type.

Properties
 | Name | Description
Public property | BranchEnabled |
Public property | Branches |
Public property | DfltWhs |
Public property | Warehouses |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Load |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

WarehouseManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


WarehouseManager Properties

WarehouseManager Class See Also

The following tables list the members exposed by the WarehouseManager type.

Properties
 | Name | Description
Public property | BranchEnabled |
Public property | Branches |
Public property | DfltWhs |
Public property | Warehouses |
Top
See Also

Reference

WarehouseManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


WarehouseManager.BranchEnabled Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property BranchEnabled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool BranchEnabled {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool BranchEnabled {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get BranchEnabled() : boolean;
public function set BranchEnabled(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WarehouseManager Class
WarehouseManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


WarehouseManager.Branches Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Branches() As List(Of IBranch)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IBranch> Branches {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<IBranch^>^ Branches {
 List<IBranch^>^ get( );
 void set(
   List<IBranch^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IBranch>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WarehouseManager Class
WarehouseManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


WarehouseManager.DfltWhs Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DfltWhs() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DfltWhs {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DfltWhs {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DfltWhs() : String;
public function set DfltWhs(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WarehouseManager Class
WarehouseManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


WarehouseManager.Warehouses Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Warehouses() As List(Of IWhs)
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IWhs> Warehouses {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<IWhs^>^ Warehouses {
 List<IWhs^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IWhs>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WarehouseManager Class
WarehouseManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


WarehouseManager Methods

WarehouseManager Class See Also

The following tables list the members exposed by the WarehouseManager type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Load |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

WarehouseManager Class
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


WarehouseManager.Load Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Load( _
   ByVal scenario As IScenario _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Load(
   IScenario scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Load(
   IScenario^ scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Load(
    scenario : IScenario
);
This language is not supported or no code example is available.

Parameters

scenario

Type: IScenario

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WarehouseManager Class
WarehouseManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ICallendar Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ICallendar
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICallendar
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ICallendar
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ICallendar
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICallendar Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ICallendar Members

ICallendar Interface Methods See Also

The following tables list the members exposed by the ICallendar type.

Methods
 | Name | Description
Public method | AddDays |
Public method | SubstractDays |
Top
See Also

Reference

ICallendar Interface
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ICallendar Methods

ICallendar Interface See Also

The following tables list the members exposed by the ICallendar type.

Methods
 | Name | Description
Public method | AddDays |
Public method | SubstractDays |
Top
See Also

Reference

ICallendar Interface
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ICallendar.AddDays Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function AddDays( _
   ByVal date As Date, _
   ByVal span As TimeSpan _
) As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime AddDays(
   DateTime date,
   TimeSpan span
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

DateTime AddDays(
   DateTime date,
   TimeSpan span
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function AddDays(
    date : DateTime,
    span : TimeSpan
) : DateTime;
This language is not supported or no code example is available.

Parameters

date

Type: DateTime

span

Type: TimeSpan

Return Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICallendar Interface
ICallendar Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ICallendar.SubstractDays Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function SubstractDays( _
   ByVal date As Date, _
   ByVal span As TimeSpan _
) As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime SubstractDays(
   DateTime date,
   TimeSpan span
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

DateTime SubstractDays(
   DateTime date,
   TimeSpan span
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function SubstractDays(
    date : DateTime,
    span : TimeSpan
) : DateTime;
This language is not supported or no code example is available.

Parameters

date

Type: DateTime

span

Type: TimeSpan

Return Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICallendar Interface
ICallendar Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


IDateCalculator Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IDateCalculator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IDateCalculator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IDateCalculator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IDateCalculator
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDateCalculator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


IDateCalculator Members

IDateCalculator Interface Methods See Also

The following tables list the members exposed by the IDateCalculator type.

Methods
 | Name | Description
Public method | AddDays |
Public method | CalculateDatesForLink |
Public method | LoadCallendars |
Public method | SubstractDays |
Top
See Also

Reference

IDateCalculator Interface
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


IDateCalculator Methods

IDateCalculator Interface See Also

The following tables list the members exposed by the IDateCalculator type.

Methods
 | Name | Description
Public method | AddDays |
Public method | CalculateDatesForLink |
Public method | LoadCallendars |
Public method | SubstractDays |
Top
See Also

Reference

IDateCalculator Interface
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


IDateCalculator.AddDays Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function AddDays( _
   ByVal ObjType As String, _
   ByVal date As Date, _
   ByVal span As TimeSpan _
) As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime AddDays(
   string ObjType,
   DateTime date,
   TimeSpan span
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

DateTime AddDays(
   String^ ObjType,
   DateTime date,
   TimeSpan span
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function AddDays(
    ObjType : String,
    date : DateTime,
    span : TimeSpan
) : DateTime;
This language is not supported or no code example is available.

Parameters

ObjType

Type: string

date

Type: DateTime

span

Type: TimeSpan

Return Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDateCalculator Interface
IDateCalculator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


IDateCalculator.CalculateDatesForLink Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub CalculateDatesForLink( _
   ByVal link As ILink _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void CalculateDatesForLink(
   ILink link
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void CalculateDatesForLink(
   ILink^ link
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CalculateDatesForLink(
    link : ILink
);
This language is not supported or no code example is available.

Parameters

link

Type: ILink

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDateCalculator Interface
IDateCalculator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


IDateCalculator.LoadCallendars Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub LoadCallendars( _
   ByVal scenario As IScenario _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void LoadCallendars(
   IScenario scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void LoadCallendars(
   IScenario^ scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function LoadCallendars(
    scenario : IScenario
);
This language is not supported or no code example is available.

Parameters

scenario

Type: IScenario

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDateCalculator Interface
IDateCalculator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


IDateCalculator.SubstractDays Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function SubstractDays( _
   ByVal ObjType As String, _
   ByVal date As Date, _
   ByVal span As TimeSpan _
) As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime SubstractDays(
   string ObjType,
   DateTime date,
   TimeSpan span
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

DateTime SubstractDays(
   String^ ObjType,
   DateTime date,
   TimeSpan span
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function SubstractDays(
    ObjType : String,
    date : DateTime,
    span : TimeSpan
) : DateTime;
This language is not supported or no code example is available.

Parameters

ObjType

Type: string

date

Type: DateTime

span

Type: TimeSpan

Return Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDateCalculator Interface
IDateCalculator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


IInternalLeadTimeRule Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IInternalLeadTimeRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IInternalLeadTimeRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IInternalLeadTimeRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IInternalLeadTimeRule
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInternalLeadTimeRule Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


IInternalLeadTimeRule Members

IInternalLeadTimeRule Interface Methods See Also

The following tables list the members exposed by the IInternalLeadTimeRule type.

Methods
 | Name | Description
Public method | CalculateLeadTime | (Overloaded)
Top
See Also

Reference

IInternalLeadTimeRule Interface
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


IInternalLeadTimeRule Methods

IInternalLeadTimeRule Interface See Also

The following tables list the members exposed by the IInternalLeadTimeRule type.

Methods
 | Name | Description
Public method | CalculateLeadTime | (Overloaded)
Top
See Also

Reference

IInternalLeadTimeRule Interface
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


IInternalLeadTimeRule.CalculateLeadTime Method

IInternalLeadTimeRule Interface See Also

Overload List
Name | Description
CalculateLeadTime(IPathItem, IDocLine) |
CalculateLeadTime(ItemManager, IDocLine) |
See Also

Reference

IInternalLeadTimeRule Interface
IInternalLeadTimeRule Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


CompuTec.ProcessForce.API.Tools.MRP.Engine.Collections Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | SDQueue<T> | Semi sorted Linked List with fast
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


SDQueue<T> Class

Members See Also

Semi sorted Linked List with fast

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.Collections
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SDQueue(Of  _
   T As IComparable)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SDQueue<T>
   where T : IComparable
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
generic<typename T>
where T : IComparable^
public ref class SDQueue
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Type Parameters

T

Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.Collections.SDQueue<T>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SDQueue<T> Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.Collections Namespace


SDQueue<T> Members

SDQueue<T> Class Constructors Methods Properties See Also

Semi sorted Linked List with fast

The following tables list the members exposed by the SDQueue<T> type.

Constructors
 | Name | Description
Public constructor | SDQueue<T> |
Top
Properties
 | Name | Description
Public property | Items |
Public property | List |
Top
Methods
 | Name | Description
Public method | Add |
Public method | BuildSubList |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | SortEntities |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SDQueue<T> Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.Collections Namespace


SDQueue<T> Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.Collections
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SDQueue()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SDQueue()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SDQueue();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SDQueue<T> Class
SDQueue<T> Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.Collections Namespace


SDQueue<T> Properties

SDQueue<T> Class See Also

The following tables list the members exposed by the SDQueue<T> type.

Properties
 | Name | Description
Public property | Items |
Public property | List |
Top
See Also

Reference

SDQueue<T> Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.Collections Namespace


SDQueue<T>.Items Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.Collections
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Items() As List(Of T)
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<T> Items {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<T^>^ Items {
 List<T^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<T>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SDQueue<T> Class
SDQueue<T> Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.Collections Namespace


SDQueue<T>.List Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.Collections
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property List() As LinkedList(Of T)
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public LinkedList<T> List {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property LinkedList<T^>^ List {
 LinkedList<T^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: LinkedList<T>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SDQueue<T> Class
SDQueue<T> Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.Collections Namespace


SDQueue<T> Methods

SDQueue<T> Class See Also

The following tables list the members exposed by the SDQueue<T> type.

Methods
 | Name | Description
Public method | Add |
Public method | BuildSubList |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | SortEntities |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SDQueue<T> Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.Collections Namespace


SDQueue<T>.Add Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.Collections
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Add( _
   ByVal entry As T _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Add(
   T entry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Add(
   T^ entry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Add(
    entry : T
);
This language is not supported or no code example is available.

Parameters

entry

Type: T

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SDQueue<T> Class
SDQueue<T> Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.Collections Namespace


SDQueue<T>.BuildSubList Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.Collections
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function BuildSubList( _
   ByVal predicate As Predicate(Of T) _
) As LinkedList(Of T)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public LinkedList<T> BuildSubList(
   Predicate<T> predicate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
LinkedList<T^>^ BuildSubList(
   Predicate<T^>^ predicate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

predicate

Type: Predicate<T>

Return Value

Type: LinkedList<T>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SDQueue<T> Class
SDQueue<T> Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.Collections Namespace


SDQueue<T>.SortEntities Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.Collections
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub SortEntities()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void SortEntities()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void SortEntities()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SortEntities();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SDQueue<T> Class
SDQueue<T> Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.Collections Namespace


CompuTec.ProcessForce.API.Tools.MRP.Engine.PathBuilders Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | PathBuilder |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


PathBuilder Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.PathBuilders
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class PathBuilder
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PathBuilder
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class PathBuilder
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PathBuilder
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.PathBuilders.PathBuilder
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PathBuilder Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.PathBuilders Namespace


PathBuilder Members

PathBuilder Class Methods See Also

The following tables list the members exposed by the PathBuilder type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | PlaceDocuments |
Public method | PlaceRecomendations |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PathBuilder Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.PathBuilders Namespace


PathBuilder Methods

PathBuilder Class See Also

The following tables list the members exposed by the PathBuilder type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | PlaceDocuments |
Public method | PlaceRecomendations |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PathBuilder Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.PathBuilders Namespace


PathBuilder.PlaceDocuments Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.PathBuilders
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub PlaceDocuments( _
   ByVal manager As MRPManager _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void PlaceDocuments(
   MRPManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void PlaceDocuments(
   MRPManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function PlaceDocuments(
    manager : MRPManager
);
This language is not supported or no code example is available.

Parameters

manager

Type: MRPManager

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PathBuilder Class
PathBuilder Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.PathBuilders Namespace


PathBuilder.PlaceRecomendations Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.PathBuilders
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub PlaceRecomendations( _
   ByVal source As IMRPEntity, _
   ByVal docs As IEnumerable(Of IDoc) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void PlaceRecomendations(
   IMRPEntity source,
   IEnumerable<IDoc> docs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void PlaceRecomendations(
   IMRPEntity^ source,
   IEnumerable<IDoc^>^ docs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

source

Type: IMRPEntity

docs

Type: IEnumerable<IDoc>

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PathBuilder Class
PathBuilder Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.PathBuilders Namespace


CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | ItemRev |
Public class | ProductionGenerator |
Public class | PurchaseGenerator |
Public class | StockTransferGenerator |
Public class | SupplyAggregation |
Public class | SupplyGenerator |
Top
Interfaces
 | Name | Description
Public interface | ISupplyGenerator |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ItemRev Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ItemRev
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemRev
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ItemRev
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemRev
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.ItemRev
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemRev Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ItemRev Members

ItemRev Class Constructors Methods Fields See Also

The following tables list the members exposed by the ItemRev type.

Constructors
 | Name | Description
Public constructor | ItemRev |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object.
Public method | GetHashCode | Serves as the default hash function.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | ItemCode |
Public field | Revision |
Top
See Also

Reference

ItemRev Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ItemRev Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal itemcode As String, _
   ByVal revision As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemRev(
   string itemcode,
   string revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemRev(
   String^ itemcode,
   String^ revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemRev(
    itemcode : String,
    revision : String
);
This language is not supported or no code example is available.

Parameters

itemcode

Type: string

revision

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemRev Class
ItemRev Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ItemRev Methods

ItemRev Class See Also

The following tables list the members exposed by the ItemRev type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object.
Public method | GetHashCode | Serves as the default hash function.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ItemRev Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ItemRev.Equals Method

Determines whether the specified object is equal to the current object.

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public override bool Equals(
   object obj
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool Equals(
   object^ obj
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Equals(
    obj : object
) : boolean;
This language is not supported or no code example is available.

Parameters

obj

Type: object

The object to compare with the current object.

Return Value

Type: bool

true if the specified object is equal to the current object; otherwise, false.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemRev Class
ItemRev Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ItemRev.GetHashCode Method

Serves as the default hash function.

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overrides Function GetHashCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public override int GetHashCode()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int GetHashCode()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetHashCode() : int;
This language is not supported or no code example is available.

Return Value

Type: int

A hash code for the current object.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemRev Class
ItemRev Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ItemRev Fields

ItemRev Class See Also

The following tables list the members exposed by the ItemRev type.

Fields
 | Name | Description
Public field | ItemCode |
Public field | Revision |
Top
See Also

Reference

ItemRev Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ItemCode Field

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly ItemCode As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public readonly string ItemCode
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ ItemCode;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public readonly ItemCode : String
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemRev Class
ItemRev Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


Revision Field

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Revision As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public readonly string Revision
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ Revision;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public readonly Revision : String
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemRev Class
ItemRev Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ProductionGenerator Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ProductionGenerator
    Implements ISupplyGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ProductionGenerator : ISupplyGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ProductionGenerator  : public ISupplyGenerator^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ProductionGenerator
   implements ISupplyGenerator
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.ProductionGenerator
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProductionGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ProductionGenerator Members

ProductionGenerator Class Constructors Methods See Also

The following tables list the members exposed by the ProductionGenerator type.

Constructors
 | Name | Description
Public constructor | ProductionGenerator |
Top
Methods
 | Name | Description
Public method | CanGenerateRecomendations |
Public method | CanGenerateSupply | (Overloaded)
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GenerateLink |
Public method | GenerateRecomendations |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadDefinitions |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ProductionGenerator Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ProductionGenerator Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal scenario As IScenario _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ProductionGenerator(
   IScenario scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ProductionGenerator(
   IScenario^ scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ProductionGenerator(
    scenario : IScenario
);
This language is not supported or no code example is available.

Parameters

scenario

Type: IScenario

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProductionGenerator Class
ProductionGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ProductionGenerator Methods

ProductionGenerator Class See Also

The following tables list the members exposed by the ProductionGenerator type.

Methods
 | Name | Description
Public method | CanGenerateRecomendations |
Public method | CanGenerateSupply | (Overloaded)
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GenerateLink |
Public method | GenerateRecomendations |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadDefinitions |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ProductionGenerator Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ProductionGenerator.CanGenerateRecomendations Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CanGenerateRecomendations( _
   ByVal data As List(Of SupplyAggregation) _
) As Boolean Implements  _
   ISupplyGenerator.CanGenerateRecomendations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool CanGenerateRecomendations(
   List<SupplyAggregation> data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool CanGenerateRecomendations(
   List<SupplyAggregation^>^ data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

data

Type: List<SupplyAggregation>

Return Value

Type: bool

Implements

ISupplyGenerator.CanGenerateRecomendations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProductionGenerator Class
ProductionGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ProductionGenerator.CanGenerateSupply Method

ProductionGenerator Class See Also

Overload List
Name | Description
CanGenerateSupply(ItemManager, IScenario) |
CanGenerateSupply(LinkedListNode<IMRPEntity>, IScenario) |
See Also

Reference

ProductionGenerator Class
ProductionGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ProductionGenerator.GenerateLink Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GenerateLink( _
   ByVal entity As LinkedListNode(Of IMRPEntity), _
   ByVal itemManager As ItemManager, _
   ByVal configuration As IScenario _
) As ILink Implements  _
   ISupplyGenerator.GenerateLink
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ILink GenerateLink(
   LinkedListNode<IMRPEntity> entity,
   ItemManager itemManager,
   IScenario configuration
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ILink^ GenerateLink(
   LinkedListNode<IMRPEntity^>^ entity,
   ItemManager^ itemManager,
   IScenario^ configuration
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

entity

Type: LinkedListNode<IMRPEntity>

itemManager

Type: ItemManager

configuration

Type: IScenario

Return Value

Type: ILink

Implements

ISupplyGenerator.GenerateLink
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProductionGenerator Class
ProductionGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ProductionGenerator.GenerateRecomendations Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GenerateRecomendations( _
   ByVal data As List(Of SupplyAggregation) _
) As IEnumerable(Of IDoc) Implements  _
   ISupplyGenerator.GenerateRecomendations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IEnumerable<IDoc> GenerateRecomendations(
   List<SupplyAggregation> data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IEnumerable<IDoc^>^ GenerateRecomendations(
   List<SupplyAggregation^>^ data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

data

Type: List<SupplyAggregation>

Return Value

Type: IEnumerable<IDoc>

Implements

ISupplyGenerator.GenerateRecomendations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProductionGenerator Class
ProductionGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ProductionGenerator.LoadDefinitions Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub LoadDefinitions( _
   ByVal manager As MRPManager _
) Implements  _
   ISupplyGenerator.LoadDefinitions
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void LoadDefinitions(
   MRPManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void LoadDefinitions(
   MRPManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function LoadDefinitions(
    manager : MRPManager
);
This language is not supported or no code example is available.

Parameters

manager

Type: MRPManager

Implements

ISupplyGenerator.LoadDefinitions
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProductionGenerator Class
ProductionGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


PurchaseGenerator Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class PurchaseGenerator
    Implements ISupplyGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PurchaseGenerator : ISupplyGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class PurchaseGenerator  : public ISupplyGenerator^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PurchaseGenerator
   implements ISupplyGenerator
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.PurchaseGenerator
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


PurchaseGenerator Members

PurchaseGenerator Class Constructors Methods See Also

The following tables list the members exposed by the PurchaseGenerator type.

Constructors
 | Name | Description
Public constructor | PurchaseGenerator |
Top
Methods
 | Name | Description
Public method | CanGenerateRecomendations |
Public method | CanGenerateSupply | (Overloaded)
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GenerateLink |
Public method | GenerateRecomendations | Working
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadDefinitions |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PurchaseGenerator Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


PurchaseGenerator Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal generator As SupplyGenerator _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public PurchaseGenerator(
   SupplyGenerator generator
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
PurchaseGenerator(
   SupplyGenerator^ generator
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function PurchaseGenerator(
    generator : SupplyGenerator
);
This language is not supported or no code example is available.

Parameters

generator

Type: SupplyGenerator

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseGenerator Class
PurchaseGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


PurchaseGenerator Methods

PurchaseGenerator Class See Also

The following tables list the members exposed by the PurchaseGenerator type.

Methods
 | Name | Description
Public method | CanGenerateRecomendations |
Public method | CanGenerateSupply | (Overloaded)
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GenerateLink |
Public method | GenerateRecomendations | Working
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadDefinitions |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PurchaseGenerator Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


PurchaseGenerator.CanGenerateRecomendations Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CanGenerateRecomendations( _
   ByVal data As List(Of SupplyAggregation) _
) As Boolean Implements  _
   ISupplyGenerator.CanGenerateRecomendations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool CanGenerateRecomendations(
   List<SupplyAggregation> data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool CanGenerateRecomendations(
   List<SupplyAggregation^>^ data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

data

Type: List<SupplyAggregation>

Return Value

Type: bool

Implements

ISupplyGenerator.CanGenerateRecomendations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseGenerator Class
PurchaseGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


PurchaseGenerator.CanGenerateSupply Method

PurchaseGenerator Class See Also

Overload List
Name | Description
CanGenerateSupply(ItemManager, IScenario) |
CanGenerateSupply(LinkedListNode<IMRPEntity>, IScenario) | Working
See Also

Reference

PurchaseGenerator Class
PurchaseGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


PurchaseGenerator.GenerateLink Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GenerateLink( _
   ByVal entity As LinkedListNode(Of IMRPEntity), _
   ByVal itemManager As ItemManager, _
   ByVal configuration As IScenario _
) As ILink Implements  _
   ISupplyGenerator.GenerateLink
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ILink GenerateLink(
   LinkedListNode<IMRPEntity> entity,
   ItemManager itemManager,
   IScenario configuration
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ILink^ GenerateLink(
   LinkedListNode<IMRPEntity^>^ entity,
   ItemManager^ itemManager,
   IScenario^ configuration
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

entity

Type: LinkedListNode<IMRPEntity>

itemManager

Type: ItemManager

configuration

Type: IScenario

Return Value

Type: ILink

Implements

ISupplyGenerator.GenerateLink
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseGenerator Class
PurchaseGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


PurchaseGenerator.GenerateRecomendations Method

Working

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GenerateRecomendations( _
   ByVal data As List(Of SupplyAggregation) _
) As IEnumerable(Of IDoc) Implements  _
   ISupplyGenerator.GenerateRecomendations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IEnumerable<IDoc> GenerateRecomendations(
   List<SupplyAggregation> data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IEnumerable<IDoc^>^ GenerateRecomendations(
   List<SupplyAggregation^>^ data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

data

Type: List<SupplyAggregation>

Return Value

Type: IEnumerable<IDoc>

Implements

ISupplyGenerator.GenerateRecomendations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseGenerator Class
PurchaseGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


PurchaseGenerator.LoadDefinitions Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub LoadDefinitions( _
   ByVal manager As MRPManager _
) Implements  _
   ISupplyGenerator.LoadDefinitions
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void LoadDefinitions(
   MRPManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void LoadDefinitions(
   MRPManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function LoadDefinitions(
    manager : MRPManager
);
This language is not supported or no code example is available.

Parameters

manager

Type: MRPManager

Implements

ISupplyGenerator.LoadDefinitions
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseGenerator Class
PurchaseGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


StockTransferGenerator Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class StockTransferGenerator
    Implements ISupplyGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class StockTransferGenerator : ISupplyGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class StockTransferGenerator  : public ISupplyGenerator^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class StockTransferGenerator
   implements ISupplyGenerator
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.StockTransferGenerator
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


StockTransferGenerator Members

StockTransferGenerator Class Methods See Also

The following tables list the members exposed by the StockTransferGenerator type.

Methods
 | Name | Description
Public method | CanGenerateRecomendations |
Public method | CanGenerateSupply | (Overloaded)
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GenerateLink |
Public method | GenerateRecomendations |
Public method | GenerateSupply |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadDefinitions |
Public method | SetGeneratedDates |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

StockTransferGenerator Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


StockTransferGenerator Methods

StockTransferGenerator Class See Also

The following tables list the members exposed by the StockTransferGenerator type.

Methods
 | Name | Description
Public method | CanGenerateRecomendations |
Public method | CanGenerateSupply | (Overloaded)
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GenerateLink |
Public method | GenerateRecomendations |
Public method | GenerateSupply |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadDefinitions |
Public method | SetGeneratedDates |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

StockTransferGenerator Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


StockTransferGenerator.CanGenerateRecomendations Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CanGenerateRecomendations( _
   ByVal data As List(Of SupplyAggregation) _
) As Boolean Implements  _
   ISupplyGenerator.CanGenerateRecomendations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool CanGenerateRecomendations(
   List<SupplyAggregation> data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool CanGenerateRecomendations(
   List<SupplyAggregation^>^ data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

data

Type: List<SupplyAggregation>

Return Value

Type: bool

Implements

ISupplyGenerator.CanGenerateRecomendations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferGenerator Class
StockTransferGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


StockTransferGenerator.CanGenerateSupply Method

StockTransferGenerator Class See Also

Overload List
Name | Description
CanGenerateSupply(ItemManager, IScenario) |
CanGenerateSupply(LinkedListNode<IMRPEntity>, IScenario) |
See Also

Reference

StockTransferGenerator Class
StockTransferGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


StockTransferGenerator.GenerateLink Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GenerateLink( _
   ByVal entity As LinkedListNode(Of IMRPEntity), _
   ByVal itemManager As ItemManager, _
   ByVal configuration As IScenario _
) As ILink Implements  _
   ISupplyGenerator.GenerateLink
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ILink GenerateLink(
   LinkedListNode<IMRPEntity> entity,
   ItemManager itemManager,
   IScenario configuration
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ILink^ GenerateLink(
   LinkedListNode<IMRPEntity^>^ entity,
   ItemManager^ itemManager,
   IScenario^ configuration
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

entity

Type: LinkedListNode<IMRPEntity>

itemManager

Type: ItemManager

configuration

Type: IScenario

Return Value

Type: ILink

Implements

ISupplyGenerator.GenerateLink
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferGenerator Class
StockTransferGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


StockTransferGenerator.GenerateRecomendations Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GenerateRecomendations( _
   ByVal data As List(Of SupplyAggregation) _
) As IEnumerable(Of IDoc) Implements  _
   ISupplyGenerator.GenerateRecomendations
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IEnumerable<IDoc> GenerateRecomendations(
   List<SupplyAggregation> data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IEnumerable<IDoc^>^ GenerateRecomendations(
   List<SupplyAggregation^>^ data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

data

Type: List<SupplyAggregation>

Return Value

Type: IEnumerable<IDoc>

Implements

ISupplyGenerator.GenerateRecomendations
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferGenerator Class
StockTransferGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


StockTransferGenerator.GenerateSupply Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GenerateSupply( _
   ByVal entity As LinkedListNode(Of IMRPEntity), _
   ByVal itemManager As ItemManager, _
   ByVal configuration As IScenario _
) As IDoc
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IDoc GenerateSupply(
   LinkedListNode<IMRPEntity> entity,
   ItemManager itemManager,
   IScenario configuration
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IDoc^ GenerateSupply(
   LinkedListNode<IMRPEntity^>^ entity,
   ItemManager^ itemManager,
   IScenario^ configuration
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

entity

Type: LinkedListNode<IMRPEntity>

itemManager

Type: ItemManager

configuration

Type: IScenario

Return Value

Type: IDoc
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferGenerator Class
StockTransferGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


StockTransferGenerator.LoadDefinitions Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub LoadDefinitions( _
   ByVal manager As MRPManager _
) Implements  _
   ISupplyGenerator.LoadDefinitions
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void LoadDefinitions(
   MRPManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void LoadDefinitions(
   MRPManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function LoadDefinitions(
    manager : MRPManager
);
This language is not supported or no code example is available.

Parameters

manager

Type: MRPManager

Implements

ISupplyGenerator.LoadDefinitions
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferGenerator Class
StockTransferGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


StockTransferGenerator.SetGeneratedDates Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub SetGeneratedDates( _
   ByVal link As ILink, _
   ByVal internalLead As Date, _
   ByVal releaseDate As Date _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void SetGeneratedDates(
   ILink link,
   DateTime internalLead,
   DateTime releaseDate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void SetGeneratedDates(
   ILink^ link,
   DateTime internalLead,
   DateTime releaseDate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SetGeneratedDates(
    link : ILink,
    internalLead : DateTime,
    releaseDate : DateTime
);
This language is not supported or no code example is available.

Parameters

link

Type: ILink

internalLead

Type: DateTime

releaseDate

Type: DateTime

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferGenerator Class
StockTransferGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyAggregation Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SupplyAggregation
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SupplyAggregation
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SupplyAggregation
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SupplyAggregation
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.SupplyAggregation
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplyAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyAggregation Members

SupplyAggregation Class Constructors Methods Properties See Also

The following tables list the members exposed by the SupplyAggregation type.

Constructors
 | Name | Description
Public constructor | SupplyAggregation |
Top
Properties
 | Name | Description
Public property | AggrSupply |
Public property | InStock |
Public property | Links |
Public property | OutStock |
Public property | Path |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SupplyAggregation Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyAggregation Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SupplyAggregation()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SupplyAggregation()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SupplyAggregation();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplyAggregation Class
SupplyAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyAggregation Properties

SupplyAggregation Class See Also

The following tables list the members exposed by the SupplyAggregation type.

Properties
 | Name | Description
Public property | AggrSupply |
Public property | InStock |
Public property | Links |
Public property | OutStock |
Public property | Path |
Top
See Also

Reference

SupplyAggregation Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyAggregation.AggrSupply Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property AggrSupply() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal AggrSupply {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal AggrSupply {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get AggrSupply() : decimal;
public function set AggrSupply(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplyAggregation Class
SupplyAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyAggregation.InStock Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InStock() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal InStock {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal InStock {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InStock() : decimal;
public function set InStock(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplyAggregation Class
SupplyAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyAggregation.Links Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Links() As IEnumerable(Of ILink)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IEnumerable<ILink> Links {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IEnumerable<ILink^>^ Links {
 IEnumerable<ILink^>^ get( );
 void set(
   IEnumerable<ILink^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: IEnumerable<ILink>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplyAggregation Class
SupplyAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyAggregation.OutStock Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property OutStock() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal OutStock {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal OutStock {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get OutStock() : decimal;
public function set OutStock(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplyAggregation Class
SupplyAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyAggregation.Path Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Path() As IPathItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IPathItem Path {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IPathItem^ Path {
 IPathItem^ get( );
 void set(
   IPathItem^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Path() : IPathItem;
public function set Path(value : IPathItem);
This language is not supported or no code example is available.

Property Value

Type: IPathItem
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplyAggregation Class
SupplyAggregation Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyAggregation Methods

SupplyAggregation Class See Also

The following tables list the members exposed by the SupplyAggregation type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SupplyAggregation Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyGenerator Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SupplyGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SupplyGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SupplyGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SupplyGenerator
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.SupplyGenerator
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyGenerator Members

SupplyGenerator Class Constructors Methods Properties See Also

The following tables list the members exposed by the SupplyGenerator type.

Constructors
 | Name | Description
Public constructor | SupplyGenerator |
Top
Properties
 | Name | Description
Public property | MorGenerator |
Public property | MrpManager |
Public property | PrefferedVendors |
Public property | PurGenerator |
Public property | Supplyers |
Public property | WtrGenerator |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GenerateSupplyLinks |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | InitVendors |
Public method | Initialize | This must be executed after All Item Managers are builded
Public method | Start |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SupplyGenerator Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyGenerator Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal manager As MRPManager _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SupplyGenerator(
   MRPManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SupplyGenerator(
   MRPManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SupplyGenerator(
    manager : MRPManager
);
This language is not supported or no code example is available.

Parameters

manager

Type: MRPManager

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplyGenerator Class
SupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyGenerator Properties

SupplyGenerator Class See Also

The following tables list the members exposed by the SupplyGenerator type.

Properties
 | Name | Description
Public property | MorGenerator |
Public property | MrpManager |
Public property | PrefferedVendors |
Public property | PurGenerator |
Public property | Supplyers |
Public property | WtrGenerator |
Top
See Also

Reference

SupplyGenerator Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyGenerator.MorGenerator Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property MorGenerator() As ISupplyGenerator
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ISupplyGenerator MorGenerator {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property ISupplyGenerator^ MorGenerator {
 ISupplyGenerator^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get MorGenerator() : ISupplyGenerator;
This language is not supported or no code example is available.

Property Value

Type: ISupplyGenerator
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplyGenerator Class
SupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyGenerator.MrpManager Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property MrpManager() As MRPManager
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MRPManager MrpManager {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property MRPManager^ MrpManager {
 MRPManager^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get MrpManager() : MRPManager;
This language is not supported or no code example is available.

Property Value

Type: MRPManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplyGenerator Class
SupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyGenerator.PrefferedVendors Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property PrefferedVendors() As List(Of IPreferredVendors)
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IPreferredVendors> PrefferedVendors {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<IPreferredVendors^>^ PrefferedVendors {
 List<IPreferredVendors^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IPreferredVendors>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplyGenerator Class
SupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyGenerator.PurGenerator Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property PurGenerator() As ISupplyGenerator
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ISupplyGenerator PurGenerator {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property ISupplyGenerator^ PurGenerator {
 ISupplyGenerator^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get PurGenerator() : ISupplyGenerator;
This language is not supported or no code example is available.

Property Value

Type: ISupplyGenerator
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplyGenerator Class
SupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyGenerator.Supplyers Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Supplyers() As Dictionary(Of String, Vendor)
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Dictionary<string, Vendor> Supplyers {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Dictionary<String^, Vendor^>^ Supplyers {
 Dictionary<String^, Vendor^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: Dictionary<string, Vendor>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplyGenerator Class
SupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyGenerator.WtrGenerator Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property WtrGenerator() As ISupplyGenerator
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ISupplyGenerator WtrGenerator {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property ISupplyGenerator^ WtrGenerator {
 ISupplyGenerator^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get WtrGenerator() : ISupplyGenerator;
This language is not supported or no code example is available.

Property Value

Type: ISupplyGenerator
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplyGenerator Class
SupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyGenerator Methods

SupplyGenerator Class See Also

The following tables list the members exposed by the SupplyGenerator type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GenerateSupplyLinks |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | InitVendors |
Public method | Initialize | This must be executed after All Item Managers are builded
Public method | Start |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SupplyGenerator Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyGenerator.GenerateSupplyLinks Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub GenerateSupplyLinks( _
   ByVal paths As IEnumerable(Of IPathItem), _
   ByVal generators As IEnumerable(Of ISupplyGenerator) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void GenerateSupplyLinks(
   IEnumerable<IPathItem> paths,
   IEnumerable<ISupplyGenerator> generators
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void GenerateSupplyLinks(
   IEnumerable<IPathItem^>^ paths,
   IEnumerable<ISupplyGenerator^>^ generators
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

paths

Type: IEnumerable<IPathItem>

generators

Type: IEnumerable<ISupplyGenerator>

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplyGenerator Class
SupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyGenerator.InitVendors Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub InitVendors( _
   ByVal ParamArray cardCode As String() _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void InitVendors(
   params string[] cardCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void InitVendors(
   ...array< array< String^ >^ >^ cardCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function InitVendors(
   ...  cardCode : String[]
);
This language is not supported or no code example is available.

Parameters

cardCode

Type: string[]

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplyGenerator Class
SupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyGenerator.Initialize Method

This must be executed after All Item Managers are builded

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Initialize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Initialize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Initialize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Initialize();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplyGenerator Class
SupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


SupplyGenerator.Start Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Start()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Start()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Start()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Start();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SupplyGenerator Class
SupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ISupplyGenerator Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ISupplyGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ISupplyGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ISupplyGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ISupplyGenerator
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ISupplyGenerator Members

ISupplyGenerator Interface Methods See Also

The following tables list the members exposed by the ISupplyGenerator type.

Methods
 | Name | Description
Public method | CanGenerateRecomendations |
Public method | CanGenerateSupply | (Overloaded)
Public method | GenerateLink |
Public method | GenerateRecomendations |
Public method | LoadDefinitions |
Top
See Also

Reference

ISupplyGenerator Interface
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ISupplyGenerator Methods

ISupplyGenerator Interface See Also

The following tables list the members exposed by the ISupplyGenerator type.

Methods
 | Name | Description
Public method | CanGenerateRecomendations |
Public method | CanGenerateSupply | (Overloaded)
Public method | GenerateLink |
Public method | GenerateRecomendations |
Public method | LoadDefinitions |
Top
See Also

Reference

ISupplyGenerator Interface
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ISupplyGenerator.CanGenerateRecomendations Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CanGenerateRecomendations( _
   ByVal data As List(Of SupplyAggregation) _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool CanGenerateRecomendations(
   List<SupplyAggregation> data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool CanGenerateRecomendations(
   List<SupplyAggregation^>^ data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

data

Type: List<SupplyAggregation>

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplyGenerator Interface
ISupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ISupplyGenerator.CanGenerateSupply Method

ISupplyGenerator Interface See Also

Overload List
Name | Description
CanGenerateSupply(ItemManager, IScenario) |
CanGenerateSupply(LinkedListNode<IMRPEntity>, IScenario) |
See Also

Reference

ISupplyGenerator Interface
ISupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ISupplyGenerator.GenerateLink Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GenerateLink( _
   ByVal entity As LinkedListNode(Of IMRPEntity), _
   ByVal itemManager As ItemManager, _
   ByVal configuration As IScenario _
) As ILink
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ILink GenerateLink(
   LinkedListNode<IMRPEntity> entity,
   ItemManager itemManager,
   IScenario configuration
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

ILink^ GenerateLink(
   LinkedListNode<IMRPEntity^>^ entity,
   ItemManager^ itemManager,
   IScenario^ configuration
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

entity

Type: LinkedListNode<IMRPEntity>

itemManager

Type: ItemManager

configuration

Type: IScenario

Return Value

Type: ILink
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplyGenerator Interface
ISupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ISupplyGenerator.GenerateRecomendations Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GenerateRecomendations( _
   ByVal data As List(Of SupplyAggregation) _
) As IEnumerable(Of IDoc)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IEnumerable<IDoc> GenerateRecomendations(
   List<SupplyAggregation> data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

IEnumerable<IDoc^>^ GenerateRecomendations(
   List<SupplyAggregation^>^ data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

data

Type: List<SupplyAggregation>

Return Value

Type: IEnumerable<IDoc>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplyGenerator Interface
ISupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ISupplyGenerator.LoadDefinitions Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub LoadDefinitions( _
   ByVal manager As MRPManager _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void LoadDefinitions(
   MRPManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void LoadDefinitions(
   MRPManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function LoadDefinitions(
    manager : MRPManager
);
This language is not supported or no code example is available.

Parameters

manager

Type: MRPManager

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplyGenerator Interface
ISupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | MorFirstByLevelStrategy |
Public class | MorFirstStrategy |
Top
Interfaces
 | Name | Description
Public interface | IStrategy |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


MorFirstByLevelStrategy Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MorFirstByLevelStrategy
    Implements IStrategy
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MorFirstByLevelStrategy : IStrategy
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MorFirstByLevelStrategy  : public IStrategy^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MorFirstByLevelStrategy
   implements IStrategy
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy.MorFirstByLevelStrategy
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MorFirstByLevelStrategy Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy Namespace


MorFirstByLevelStrategy Members

MorFirstByLevelStrategy Class Methods See Also

The following tables list the members exposed by the MorFirstByLevelStrategy type.

Methods
 | Name | Description
Public method | Check |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetQueue |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MorFirstByLevelStrategy Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy Namespace


MorFirstByLevelStrategy Methods

MorFirstByLevelStrategy Class See Also

The following tables list the members exposed by the MorFirstByLevelStrategy type.

Methods
 | Name | Description
Public method | Check |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetQueue |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MorFirstByLevelStrategy Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy Namespace


MorFirstByLevelStrategy.Check Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function Check( _
   ByVal rsults As Dictionary(Of ItemRev, Integer), _
   ByVal bom As IBillOfMaterial, _
   ByVal data As Dictionary(Of ItemRev, IBillOfMaterial) _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int Check(
   Dictionary<ItemRev, int> rsults,
   IBillOfMaterial bom,
   Dictionary<ItemRev, IBillOfMaterial> data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int Check(
   Dictionary<ItemRev^, int>^ rsults,
   IBillOfMaterial^ bom,
   Dictionary<ItemRev^, IBillOfMaterial^>^ data
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

rsults

Type: Dictionary<ItemRev, int>

bom

Type: IBillOfMaterial

data

Type: Dictionary<ItemRev, IBillOfMaterial>

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MorFirstByLevelStrategy Class
MorFirstByLevelStrategy Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy Namespace


MorFirstByLevelStrategy.GetQueue Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetQueue( _
   ByVal manager As MRPManager _
) As IEnumerable(Of ItemManager) Implements  _
   IStrategy.GetQueue
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IEnumerable<ItemManager> GetQueue(
   MRPManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IEnumerable<ItemManager^>^ GetQueue(
   MRPManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

manager

Type: MRPManager

Return Value

Type: IEnumerable<ItemManager>

Implements

IStrategy.GetQueue
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MorFirstByLevelStrategy Class
MorFirstByLevelStrategy Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy Namespace


MorFirstStrategy Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MorFirstStrategy
    Implements IStrategy
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MorFirstStrategy : IStrategy
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MorFirstStrategy  : public IStrategy^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MorFirstStrategy
   implements IStrategy
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy.MorFirstStrategy
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MorFirstStrategy Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy Namespace


MorFirstStrategy Members

MorFirstStrategy Class Methods See Also

The following tables list the members exposed by the MorFirstStrategy type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetQueue |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MorFirstStrategy Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy Namespace


MorFirstStrategy Methods

MorFirstStrategy Class See Also

The following tables list the members exposed by the MorFirstStrategy type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetQueue |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MorFirstStrategy Class
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy Namespace


MorFirstStrategy.GetQueue Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetQueue( _
   ByVal manager As MRPManager _
) As IEnumerable(Of ItemManager) Implements  _
   IStrategy.GetQueue
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IEnumerable<ItemManager> GetQueue(
   MRPManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IEnumerable<ItemManager^>^ GetQueue(
   MRPManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

manager

Type: MRPManager

Return Value

Type: IEnumerable<ItemManager>

Implements

IStrategy.GetQueue
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MorFirstStrategy Class
MorFirstStrategy Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy Namespace


IStrategy Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IStrategy
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IStrategy
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IStrategy
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IStrategy
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IStrategy Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy Namespace


IStrategy Members

IStrategy Interface Methods See Also

The following tables list the members exposed by the IStrategy type.

Methods
 | Name | Description
Public method | GetQueue |
Top
See Also

Reference

IStrategy Interface
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy Namespace


IStrategy Methods

IStrategy Interface See Also

The following tables list the members exposed by the IStrategy type.

Methods
 | Name | Description
Public method | GetQueue |
Top
See Also

Reference

IStrategy Interface
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy Namespace


IStrategy.GetQueue Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetQueue( _
   ByVal manager As MRPManager _
) As IEnumerable(Of ItemManager)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IEnumerable<ItemManager> GetQueue(
   MRPManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

IEnumerable<ItemManager^>^ GetQueue(
   MRPManager^ manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

manager

Type: MRPManager

Return Value

Type: IEnumerable<ItemManager>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IStrategy Interface
IStrategy Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators.Strategy Namespace


CompuTec.ProcessForce.API.Tools.MRP.Exceptions Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | PathNotFoundForInputDataException |
Public class | WrongItemManagerException |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


PathNotFoundForInputDataException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Exceptions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class PathNotFoundForInputDataException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class PathNotFoundForInputDataException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class PathNotFoundForInputDataException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class PathNotFoundForInputDataException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Tools.MRP.Exceptions.PathNotFoundForInputDataException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PathNotFoundForInputDataException Members
CompuTec.ProcessForce.API.Tools.MRP.Exceptions Namespace


PathNotFoundForInputDataException Members

PathNotFoundForInputDataException Class Constructors Methods Properties See Also

The following tables list the members exposed by the PathNotFoundForInputDataException type.

Constructors
 | Name | Description
Public constructor | PathNotFoundForInputDataException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

PathNotFoundForInputDataException Class
CompuTec.ProcessForce.API.Tools.MRP.Exceptions Namespace


PathNotFoundForInputDataException Constructor

PathNotFoundForInputDataException Class See Also

Overload List
Name | Description
PathNotFoundForInputDataException() |
PathNotFoundForInputDataException(string) |
PathNotFoundForInputDataException(string, Exception) |
See Also

Reference

PathNotFoundForInputDataException Class
PathNotFoundForInputDataException Members
CompuTec.ProcessForce.API.Tools.MRP.Exceptions Namespace


PathNotFoundForInputDataException Properties

PathNotFoundForInputDataException Class See Also

The following tables list the members exposed by the PathNotFoundForInputDataException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

PathNotFoundForInputDataException Class
CompuTec.ProcessForce.API.Tools.MRP.Exceptions Namespace


PathNotFoundForInputDataException Methods

PathNotFoundForInputDataException Class See Also

The following tables list the members exposed by the PathNotFoundForInputDataException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

PathNotFoundForInputDataException Class
CompuTec.ProcessForce.API.Tools.MRP.Exceptions Namespace


WrongItemManagerException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Exceptions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class WrongItemManagerException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class WrongItemManagerException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class WrongItemManagerException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class WrongItemManagerException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Tools.MRP.Exceptions.WrongItemManagerException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WrongItemManagerException Members
CompuTec.ProcessForce.API.Tools.MRP.Exceptions Namespace


WrongItemManagerException Members

WrongItemManagerException Class Constructors Methods Properties See Also

The following tables list the members exposed by the WrongItemManagerException type.

Constructors
 | Name | Description
Public constructor | WrongItemManagerException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

WrongItemManagerException Class
CompuTec.ProcessForce.API.Tools.MRP.Exceptions Namespace


WrongItemManagerException Constructor

WrongItemManagerException Class See Also

Overload List
Name | Description
WrongItemManagerException() |
WrongItemManagerException(string) |
WrongItemManagerException(string, Exception) |
See Also

Reference

WrongItemManagerException Class
WrongItemManagerException Members
CompuTec.ProcessForce.API.Tools.MRP.Exceptions Namespace


WrongItemManagerException Properties

WrongItemManagerException Class See Also

The following tables list the members exposed by the WrongItemManagerException type.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
See Also

Reference

WrongItemManagerException Class
CompuTec.ProcessForce.API.Tools.MRP.Exceptions Namespace


WrongItemManagerException Methods

WrongItemManagerException Class See Also

The following tables list the members exposed by the WrongItemManagerException type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

WrongItemManagerException Class
CompuTec.ProcessForce.API.Tools.MRP.Exceptions Namespace


CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | BaseDocument |
Public class | BaseDocumentLine |
Public class | Branch |
Public class | ItemPath | Represents a Queue For one Route of an item revision whs / dependent of MRP Scenario
Public class | MrpEntity |
Public class | WhsInfo |
Top
Interfaces
 | Name | Description
Public interface | IBranch |
Public interface | IDoc |
Public interface | IDocLine |
Public interface | IItem |
Public interface | IItemSettings |
Public interface | IMRPEntity |
Public interface | IPathItem |
Public interface | IWhs |
Top
Enumerations
 | Name | Description
Public enumeration | SupplyType |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


BaseDocument Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BaseDocument
    Implements IDoc, _
               INotifyPropertyChanged
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BaseDocument : IDoc,
   INotifyPropertyChanged
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BaseDocument  : public IDoc^,
   public INotifyPropertyChanged^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BaseDocument
   implements IDoc,
              INotifyPropertyChanged
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Obj.BaseDocument
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocument Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocument Members

BaseDocument Class Constructors Events Methods Properties See Also

The following tables list the members exposed by the BaseDocument type.

Constructors
 | Name | Description
Public constructor | BaseDocument |
Top
Properties
 | Name | Description
Public property | Address |
Public property | CardCode |
Public property | ChildDocuments |
Public property | DocEntry |
Public property | DocNum |
Public property | DocType |
Public property | Draft |
Public property | Key |
Public property | Lines |
Public property | ParentDocuments |
Public property | ReleaseDate |
Public property | Source |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OnPropertyChanged |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

BaseDocument Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocument Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BaseDocument()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BaseDocument()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BaseDocument();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocument Class
BaseDocument Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocument Properties

BaseDocument Class See Also

The following tables list the members exposed by the BaseDocument type.

Properties
 | Name | Description
Public property | Address |
Public property | CardCode |
Public property | ChildDocuments |
Public property | DocEntry |
Public property | DocNum |
Public property | DocType |
Public property | Draft |
Public property | Key |
Public property | Lines |
Public property | ParentDocuments |
Public property | ReleaseDate |
Public property | Source |
Top
See Also

Reference

BaseDocument Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocument.Address Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Address() As String Implements  _
   IDoc.Address
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Address {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Address {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Address() : String;
public function set Address(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IDoc.Address
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocument Class
BaseDocument Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocument.CardCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property CardCode() As String Implements  _
   IDoc.CardCode
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string CardCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ CardCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get CardCode() : String;
public function set CardCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IDoc.CardCode
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocument Class
BaseDocument Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocument.ChildDocuments Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ChildDocuments() As List(Of IDoc) Implements  _
   IDoc.ChildDocuments
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDoc> ChildDocuments {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<IDoc^>^ ChildDocuments {
 List<IDoc^>^ get( );
 void set(
   List<IDoc^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IDoc>

Implements

IDoc.ChildDocuments
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocument Class
BaseDocument Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocument.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DocEntry() As Integer Implements  _
   IDoc.DocEntry
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int DocEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int DocEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocEntry() : int;
public function set DocEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int

Implements

IDoc.DocEntry
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocument Class
BaseDocument Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocument.DocNum Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DocNum() As Integer Implements  _
   IDoc.DocNum
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int DocNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int DocNum {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocNum() : int;
public function set DocNum(value : int);
This language is not supported or no code example is available.

Property Value

Type: int

Implements

IDoc.DocNum
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocument Class
BaseDocument Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocument.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DocType() As String Implements  _
   IDoc.DocType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DocType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DocType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocType() : String;
public function set DocType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IDoc.DocType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocument Class
BaseDocument Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocument.Draft Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Draft() As Boolean Implements  _
   IDoc.Draft
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool Draft {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool Draft {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Draft() : boolean;
public function set Draft(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool

Implements

IDoc.Draft
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocument Class
BaseDocument Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocument.Key Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Key() As String Implements  _
   IDoc.Key
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Key {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Key {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Key() : String;
public function set Key(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IDoc.Key
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocument Class
BaseDocument Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocument.Lines Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Lines() As List(Of IDocLine) Implements  _
   IDoc.Lines
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDocLine> Lines {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<IDocLine^>^ Lines {
 List<IDocLine^>^ get( );
 void set(
   List<IDocLine^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IDocLine>

Implements

IDoc.Lines
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocument Class
BaseDocument Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocument.ParentDocuments Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ParentDocuments() As List(Of IDoc) Implements  _
   IDoc.ParentDocuments
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IDoc> ParentDocuments {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<IDoc^>^ ParentDocuments {
 List<IDoc^>^ get( );
 void set(
   List<IDoc^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IDoc>

Implements

IDoc.ParentDocuments
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocument Class
BaseDocument Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocument.ReleaseDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ReleaseDate() As Date Implements  _
   IDoc.ReleaseDate
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime ReleaseDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime ReleaseDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ReleaseDate() : DateTime;
public function set ReleaseDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime

Implements

IDoc.ReleaseDate
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocument Class
BaseDocument Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocument.Source Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Source() As Source Implements  _
   IDoc.Source
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Source Source {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Source Source {
 Source get( );
 void set(
   Source value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Source() : Source;
public function set Source(value : Source);
This language is not supported or no code example is available.

Property Value

Type: Source

Implements

IDoc.Source
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocument Class
BaseDocument Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocument Methods

BaseDocument Class See Also

The following tables list the members exposed by the BaseDocument type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OnPropertyChanged |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

BaseDocument Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocument.OnPropertyChanged Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub OnPropertyChanged( _
   ByVal name As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void OnPropertyChanged(
   string name
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void OnPropertyChanged(
   String^ name
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function OnPropertyChanged(
    name : String
);
This language is not supported or no code example is available.

Parameters

name

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocument Class
BaseDocument Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocument Events

BaseDocument Class See Also

The following tables list the members exposed by the BaseDocument type.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

BaseDocument Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


PropertyChanged Event

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Event PropertyChanged As PropertyChangedEventHandler
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public event PropertyChangedEventHandler PropertyChanged
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
event PropertyChangedEventHandler^ PropertyChanged {
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript supports the use of events, but not the declaration of new ones.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocument Class
BaseDocument Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocumentLine Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BaseDocumentLine
    Implements IDocLine, _
               INotifyPropertyChanged
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BaseDocumentLine : IDocLine,
   INotifyPropertyChanged
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BaseDocumentLine  : public IDocLine^,
   public INotifyPropertyChanged^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BaseDocumentLine
   implements IDocLine,
              INotifyPropertyChanged
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Obj.BaseDocumentLine
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocumentLine Members

BaseDocumentLine Class Constructors Events Methods Properties See Also

The following tables list the members exposed by the BaseDocumentLine type.

Constructors
 | Name | Description
Public constructor | BaseDocumentLine |
Top
Properties
 | Name | Description
Public property | BPLId |
Public property | DemandDate |
Public property | Direction |
Public property | DueDate |
Public property | Header |
Public property | InventoryQuantity |
Public property | ItemCode |
Public property | LineNum |
Public property | Links |
Public property | ParentLineNum |
Public property | Revision |
Public property | WhsCode |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OnPropertyChanged |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

BaseDocumentLine Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocumentLine Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BaseDocumentLine()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BaseDocumentLine()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BaseDocumentLine();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentLine Class
BaseDocumentLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocumentLine Properties

BaseDocumentLine Class See Also

The following tables list the members exposed by the BaseDocumentLine type.

Properties
 | Name | Description
Public property | BPLId |
Public property | DemandDate |
Public property | Direction |
Public property | DueDate |
Public property | Header |
Public property | InventoryQuantity |
Public property | ItemCode |
Public property | LineNum |
Public property | Links |
Public property | ParentLineNum |
Public property | Revision |
Public property | WhsCode |
Top
See Also

Reference

BaseDocumentLine Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocumentLine.BPLId Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property BPLId() As Nullable(Of Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Nullable<int> BPLId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Nullable<int> BPLId {
 Nullable<int> get( );
 void set(
   Nullable<int> value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: Nullable<int>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentLine Class
BaseDocumentLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocumentLine.DemandDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DemandDate() As Date Implements  _
   IDocLine.DemandDate
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime DemandDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime DemandDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DemandDate() : DateTime;
public function set DemandDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime

Implements

IDocLine.DemandDate
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentLine Class
BaseDocumentLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocumentLine.Direction Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Direction() As Direction Implements  _
   IDocLine.Direction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Direction Direction {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Direction Direction {
 Direction get( );
 void set(
   Direction value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Direction() : Direction;
public function set Direction(value : Direction);
This language is not supported or no code example is available.

Property Value

Type: Direction

Implements

IDocLine.Direction
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentLine Class
BaseDocumentLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocumentLine.DueDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DueDate() As Date Implements  _
   IDocLine.DueDate
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime DueDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime DueDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DueDate() : DateTime;
public function set DueDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime

Implements

IDocLine.DueDate
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentLine Class
BaseDocumentLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocumentLine.Header Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Header() As IDoc Implements  _
   IDocLine.Header
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IDoc Header {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IDoc^ Header {
 IDoc^ get( );
 void set(
   IDoc^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Header() : IDoc;
public function set Header(value : IDoc);
This language is not supported or no code example is available.

Property Value

Type: IDoc

Implements

IDocLine.Header
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentLine Class
BaseDocumentLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocumentLine.InventoryQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InventoryQuantity() As Decimal Implements  _
   IDocLine.InventoryQuantity
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal InventoryQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal InventoryQuantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InventoryQuantity() : decimal;
public function set InventoryQuantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal

Implements

IDocLine.InventoryQuantity
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentLine Class
BaseDocumentLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocumentLine.ItemCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ItemCode() As String Implements  _
   IDocLine.ItemCode
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ItemCode() : String;
public function set ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IDocLine.ItemCode
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentLine Class
BaseDocumentLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocumentLine.LineNum Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property LineNum() As Integer Implements  _
   IDocLine.LineNum
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int LineNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int LineNum {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get LineNum() : int;
public function set LineNum(value : int);
This language is not supported or no code example is available.

Property Value

Type: int

Implements

IDocLine.LineNum
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentLine Class
BaseDocumentLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocumentLine.Links Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Links() As IList(Of ILink) Implements  _
   IDocLine.Links
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IList<ILink> Links {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IList<ILink^>^ Links {
 IList<ILink^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: IList<ILink>

Implements

IDocLine.Links
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentLine Class
BaseDocumentLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocumentLine.ParentLineNum Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ParentLineNum() As Integer Implements  _
   IDocLine.ParentLineNum
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int ParentLineNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int ParentLineNum {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ParentLineNum() : int;
public function set ParentLineNum(value : int);
This language is not supported or no code example is available.

Property Value

Type: int

Implements

IDocLine.ParentLineNum
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentLine Class
BaseDocumentLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocumentLine.Revision Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Revision() As String Implements  _
   IDocLine.Revision
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Revision() : String;
public function set Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IDocLine.Revision
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentLine Class
BaseDocumentLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocumentLine.WhsCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property WhsCode() As String Implements  _
   IDocLine.WhsCode
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get WhsCode() : String;
public function set WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IDocLine.WhsCode
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentLine Class
BaseDocumentLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocumentLine Methods

BaseDocumentLine Class See Also

The following tables list the members exposed by the BaseDocumentLine type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OnPropertyChanged |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

BaseDocumentLine Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocumentLine.OnPropertyChanged Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub OnPropertyChanged( _
   ByVal name As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void OnPropertyChanged(
   string name
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void OnPropertyChanged(
   String^ name
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function OnPropertyChanged(
    name : String
);
This language is not supported or no code example is available.

Parameters

name

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentLine Class
BaseDocumentLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


BaseDocumentLine Events

BaseDocumentLine Class See Also

The following tables list the members exposed by the BaseDocumentLine type.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

BaseDocumentLine Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


PropertyChanged Event

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Event PropertyChanged As PropertyChangedEventHandler
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public event PropertyChangedEventHandler PropertyChanged
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
event PropertyChangedEventHandler^ PropertyChanged {
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript supports the use of events, but not the declaration of new ones.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentLine Class
BaseDocumentLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


Branch Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class Branch
    Implements IBranch
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Branch : IBranch
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class Branch  : public IBranch^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Branch
   implements IBranch
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Obj.Branch
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Branch Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


Branch Members

Branch Class Methods Properties See Also

The following tables list the members exposed by the Branch type.

Properties
 | Name | Description
Public property | BPLID |
Public property | BranchCode |
Public property | DfltWhs |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Branch Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


Branch Properties

Branch Class See Also

The following tables list the members exposed by the Branch type.

Properties
 | Name | Description
Public property | BPLID |
Public property | BranchCode |
Public property | DfltWhs |
Top
See Also

Reference

Branch Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


Branch.BPLID Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property BPLID() As Integer Implements  _
   IBranch.BPLID
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int BPLID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int BPLID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get BPLID() : int;
public function set BPLID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int

Implements

IBranch.BPLID
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Branch Class
Branch Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


Branch.BranchCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property BranchCode() As String Implements  _
   IBranch.BranchCode
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string BranchCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ BranchCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get BranchCode() : String;
public function set BranchCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IBranch.BranchCode
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Branch Class
Branch Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


Branch.DfltWhs Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DfltWhs() As String Implements  _
   IBranch.DfltWhs
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DfltWhs {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DfltWhs {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DfltWhs() : String;
public function set DfltWhs(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IBranch.DfltWhs
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Branch Class
Branch Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


Branch Methods

Branch Class See Also

The following tables list the members exposed by the Branch type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Branch Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath Class

Members See Also

Represents a Queue For one Route of an item revision whs / dependent of MRP Scenario

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ItemPath
    Implements IPathItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemPath : IPathItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ItemPath  : public IPathItem^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemPath
   implements IPathItem
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Obj.ItemPath
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath Members

ItemPath Class Constructors Methods Properties See Also

Represents a Queue For one Route of an item revision whs / dependent of MRP Scenario

The following tables list the members exposed by the ItemPath type.

Constructors
 | Name | Description
Public constructor | ItemPath |
Top
Properties
 | Name | Description
Public property | Calculated |
Public property | Item |
Public property | ItemCode |
Public property | ItemManager |
Public property | Links |
Public property | Manager |
Public property | OnHandQuantity |
Public property | OnHandQuantityExt |
Public property | Queue |
Public property | Revision |
Public property | Warehouse |
Public property | WhsCode |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAvailbleQuantityForDate | (Overloaded)
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetNotVisitedEntietiesForDates |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Print |
Public method | RecalculateCumulaiveQuantity | (Overloaded)
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ItemPath Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal mRP As MRPManager, _
   ByVal itemManager As ItemManager, _
   ByVal item As IItemSettings _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemPath(
   MRPManager mRP,
   ItemManager itemManager,
   IItemSettings item
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemPath(
   MRPManager^ mRP,
   ItemManager^ itemManager,
   IItemSettings^ item
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemPath(
    mRP : MRPManager,
    itemManager : ItemManager,
    item : IItemSettings
);
This language is not supported or no code example is available.

Parameters

mRP

Type: MRPManager

itemManager

Type: ItemManager

item

Type: IItemSettings

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath Properties

ItemPath Class See Also

The following tables list the members exposed by the ItemPath type.

Properties
 | Name | Description
Public property | Calculated |
Public property | Item |
Public property | ItemCode |
Public property | ItemManager |
Public property | Links |
Public property | Manager |
Public property | OnHandQuantity |
Public property | OnHandQuantityExt |
Public property | Queue |
Public property | Revision |
Public property | Warehouse |
Public property | WhsCode |
Top
See Also

Reference

ItemPath Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath.Calculated Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Calculated() As Boolean Implements  _
   IPathItem.Calculated
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool Calculated {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool Calculated {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Calculated() : boolean;
public function set Calculated(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool

Implements

IPathItem.Calculated
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath.Item Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Item() As IItemSettings Implements  _
   IPathItem.Item
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IItemSettings Item {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IItemSettings^ Item {
 IItemSettings^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Item() : IItemSettings;
This language is not supported or no code example is available.

Property Value

Type: IItemSettings

Implements

IPathItem.Item
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath.ItemCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property ItemCode() As String Implements  _
   IPathItem.ItemCode
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ItemCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ItemCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ItemCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IPathItem.ItemCode
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath.ItemManager Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ItemManager() As ItemManager Implements  _
   IPathItem.ItemManager
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemManager ItemManager {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property ItemManager^ ItemManager {
 ItemManager^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ItemManager() : ItemManager;
This language is not supported or no code example is available.

Property Value

Type: ItemManager

Implements

IPathItem.ItemManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath.Links Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Links() As List(Of ILink) Implements  _
   IPathItem.Links
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<ILink> Links {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<ILink^>^ Links {
 List<ILink^>^ get( );
 void set(
   List<ILink^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<ILink>

Implements

IPathItem.Links
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath.Manager Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Manager() As MRPManager Implements  _
   IPathItem.Manager
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MRPManager Manager {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property MRPManager^ Manager {
 MRPManager^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Manager() : MRPManager;
This language is not supported or no code example is available.

Property Value

Type: MRPManager

Implements

IPathItem.Manager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath.OnHandQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property OnHandQuantity() As Decimal Implements  _
   IPathItem.OnHandQuantity
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal OnHandQuantity {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal OnHandQuantity {
 Decimal get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get OnHandQuantity() : decimal;
This language is not supported or no code example is available.

Property Value

Type: decimal

Implements

IPathItem.OnHandQuantity
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath.OnHandQuantityExt Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property OnHandQuantityExt() As List(Of Tuple(Of Decimal, Date)) Implements  _
   IPathItem.OnHandQuantityExt
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<Tuple<decimal, DateTime>> OnHandQuantityExt {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<Tuple<Decimal, DateTime>^>^ OnHandQuantityExt {
 List<Tuple<Decimal, DateTime>^>^ get( );
 void set(
   List<Tuple<Decimal, DateTime>^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<Tuple<decimal, DateTime>>

Implements

IPathItem.OnHandQuantityExt
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath.Queue Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Queue() As SDQueue(Of IMRPEntity) Implements  _
   IPathItem.Queue
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SDQueue<IMRPEntity> Queue {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property SDQueue<IMRPEntity^>^ Queue {
 SDQueue<IMRPEntity^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: SDQueue<IMRPEntity>

Implements

IPathItem.Queue
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath.Revision Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property Revision() As String Implements  _
   IPathItem.Revision
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Revision {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Revision {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Revision() : String;
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IPathItem.Revision
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath.Warehouse Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Warehouse() As IWhs Implements  _
   IPathItem.Warehouse
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IWhs Warehouse {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IWhs^ Warehouse {
 IWhs^ get( );
 void set(
   IWhs^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Warehouse() : IWhs;
public function set Warehouse(value : IWhs);
This language is not supported or no code example is available.

Property Value

Type: IWhs

Implements

IPathItem.Warehouse
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath.WhsCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property WhsCode() As String Implements  _
   IPathItem.WhsCode
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string WhsCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ WhsCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get WhsCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IPathItem.WhsCode
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath Methods

ItemPath Class See Also

The following tables list the members exposed by the ItemPath type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAvailbleQuantityForDate | (Overloaded)
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetNotVisitedEntietiesForDates |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Print |
Public method | RecalculateCumulaiveQuantity | (Overloaded)
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ItemPath Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath.GetAvailbleQuantityForDate Method

ItemPath Class See Also

Overload List
Name | Description
GetAvailbleQuantityForDate(DateTime, IMRPEntity) |
GetAvailbleQuantityForDate(DateTime) |
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath.GetNotVisitedEntietiesForDates Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetNotVisitedEntietiesForDates( _
   ByVal date As Date, _
   ByVal endPeriod As Date _
) As IEnumerable(Of LinkedListNode(Of IMRPEntity)) Implements  _
   IPathItem.GetNotVisitedEntietiesForDates
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IEnumerable<LinkedListNode<IMRPEntity>> GetNotVisitedEntietiesForDates(
   DateTime date,
   DateTime endPeriod
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IEnumerable<LinkedListNode<IMRPEntity^>^>^ GetNotVisitedEntietiesForDates(
   DateTime date,
   DateTime endPeriod
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

date

Type: DateTime

endPeriod

Type: DateTime

Return Value

Type: IEnumerable<LinkedListNode<IMRPEntity>>

Implements

IPathItem.GetNotVisitedEntietiesForDates
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath.Print Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function Print() As String Implements  _
   IPathItem.Print
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Print()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ Print()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Print() : String;
This language is not supported or no code example is available.

Return Value

Type: string

Implements

IPathItem.Print
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath.RecalculateCumulaiveQuantity Method

ItemPath Class See Also

Overload List
Name | Description
RecalculateCumulaiveQuantity() |
RecalculateCumulaiveQuantity(LinkedListNode<IMRPEntity>) |
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MrpEntity
    Implements IMRPEntity, _
               INotifyPropertyChanged
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MrpEntity : IMRPEntity,
   INotifyPropertyChanged
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MrpEntity  : public IMRPEntity^,
   public INotifyPropertyChanged^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MrpEntity
   implements IMRPEntity,
              INotifyPropertyChanged
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Obj.MrpEntity
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity Members

MrpEntity Class Constructors Events Methods Properties See Also

The following tables list the members exposed by the MrpEntity type.

Constructors
 | Name | Description
Public constructor | MrpEntity | (Overloaded)
Top
Properties
 | Name | Description
Public property | CumulativeDemand | Cumulative demand without current document
Public property | CumulativeSupply | Cumulative supply without current document
Public property | Date |
Public property | Direction |
Public property | InAvailbleQuantity |
Public property | InStockQuantity |
Public property | InternaLeadTime |
Public property | InternalEntits |
Public property | ItemCode |
Public property | OutAvailbleQuantity |
Public property | OutStockQuantity |
Public property | Owner |
Public property | References |
Public property | Remarks |
Public property | Revision |
Public property | SourceEntity |
Public property | StockQuantity |
Public property | SupplyType |
Public property | Visited |
Public property | WhsInfo |
Top
Methods
 | Name | Description
Public method | CompareTo | First compare by date then by Direction ( first input then output) then by Quantity
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OnPropertyChanged |
Public method | Print |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

MrpEntity Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity Constructor

MrpEntity Class See Also

Overload List
Name | Description
MrpEntity(IMRPEntity, IDocLine, TimeSpan, DateTime) | ForCreationOfAvailbility
MrpEntity(IPathItem, IDocLine) |
MrpEntity(IPathItem, IDocLine, SupplyType) |
MrpEntity(decimal, Direction, DateTime, SupplyType) |
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity Properties

MrpEntity Class See Also

The following tables list the members exposed by the MrpEntity type.

Properties
 | Name | Description
Public property | CumulativeDemand | Cumulative demand without current document
Public property | CumulativeSupply | Cumulative supply without current document
Public property | Date |
Public property | Direction |
Public property | InAvailbleQuantity |
Public property | InStockQuantity |
Public property | InternaLeadTime |
Public property | InternalEntits |
Public property | ItemCode |
Public property | OutAvailbleQuantity |
Public property | OutStockQuantity |
Public property | Owner |
Public property | References |
Public property | Remarks |
Public property | Revision |
Public property | SourceEntity |
Public property | StockQuantity |
Public property | SupplyType |
Public property | Visited |
Public property | WhsInfo |
Top
See Also

Reference

MrpEntity Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.CumulativeDemand Property

Cumulative demand without current document

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property CumulativeDemand() As Decimal Implements  _
   IMRPEntity.CumulativeDemand
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal CumulativeDemand {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal CumulativeDemand {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get CumulativeDemand() : decimal;
public function set CumulativeDemand(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal

Implements

IMRPEntity.CumulativeDemand
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.CumulativeSupply Property

Cumulative supply without current document

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property CumulativeSupply() As Decimal Implements  _
   IMRPEntity.CumulativeSupply
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal CumulativeSupply {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal CumulativeSupply {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get CumulativeSupply() : decimal;
public function set CumulativeSupply(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal

Implements

IMRPEntity.CumulativeSupply
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.Date Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Date() As Date Implements  _
   IMRPEntity.Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime Date {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime Date {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Date() : DateTime;
public function set Date(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime

Implements

IMRPEntity.Date
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.Direction Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Direction() As Direction Implements  _
   IMRPEntity.Direction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Direction Direction {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Direction Direction {
 Direction get( );
 void set(
   Direction value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Direction() : Direction;
public function set Direction(value : Direction);
This language is not supported or no code example is available.

Property Value

Type: Direction

Implements

IMRPEntity.Direction
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.InAvailbleQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InAvailbleQuantity() As Decimal Implements  _
   IMRPEntity.InAvailbleQuantity
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal InAvailbleQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal InAvailbleQuantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InAvailbleQuantity() : decimal;
public function set InAvailbleQuantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal

Implements

IMRPEntity.InAvailbleQuantity
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.InStockQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InStockQuantity() As Decimal Implements  _
   IMRPEntity.InStockQuantity
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal InStockQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal InStockQuantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InStockQuantity() : decimal;
public function set InStockQuantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal

Implements

IMRPEntity.InStockQuantity
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.InternaLeadTime Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InternaLeadTime() As TimeSpan Implements  _
   IMRPEntity.InternaLeadTime
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan InternaLeadTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property TimeSpan InternaLeadTime {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InternaLeadTime() : TimeSpan;
public function set InternaLeadTime(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan

Implements

IMRPEntity.InternaLeadTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.InternalEntits Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InternalEntits() As List(Of IMRPEntity) Implements  _
   IMRPEntity.InternalEntits
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IMRPEntity> InternalEntits {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<IMRPEntity^>^ InternalEntits {
 List<IMRPEntity^>^ get( );
 void set(
   List<IMRPEntity^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IMRPEntity>

Implements

IMRPEntity.InternalEntits
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.ItemCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ItemCode() As String Implements  _
   IMRPEntity.ItemCode
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ItemCode() : String;
public function set ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IMRPEntity.ItemCode
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.OutAvailbleQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property OutAvailbleQuantity() As Decimal Implements  _
   IMRPEntity.OutAvailbleQuantity
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal OutAvailbleQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal OutAvailbleQuantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get OutAvailbleQuantity() : decimal;
public function set OutAvailbleQuantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal

Implements

IMRPEntity.OutAvailbleQuantity
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.OutStockQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property OutStockQuantity() As Decimal Implements  _
   IMRPEntity.OutStockQuantity
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal OutStockQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal OutStockQuantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get OutStockQuantity() : decimal;
public function set OutStockQuantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal

Implements

IMRPEntity.OutStockQuantity
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.Owner Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Owner() As IPathItem Implements  _
   IMRPEntity.Owner
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IPathItem Owner {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IPathItem^ Owner {
 IPathItem^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Owner() : IPathItem;
This language is not supported or no code example is available.

Property Value

Type: IPathItem

Implements

IMRPEntity.Owner
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.References Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property References() As IList(Of IDocLine) Implements  _
   IMRPEntity.References
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IList<IDocLine> References {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IList<IDocLine^>^ References {
 IList<IDocLine^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: IList<IDocLine>

Implements

IMRPEntity.References
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.Remarks Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Remarks() As String Implements  _
   IMRPEntity.Remarks
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Remarks() : String;
public function set Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IMRPEntity.Remarks
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.Revision Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Revision() As String Implements  _
   IMRPEntity.Revision
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Revision() : String;
public function set Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IMRPEntity.Revision
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.SourceEntity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SourceEntity() As Boolean Implements  _
   IMRPEntity.SourceEntity
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool SourceEntity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool SourceEntity {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SourceEntity() : boolean;
public function set SourceEntity(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool

Implements

IMRPEntity.SourceEntity
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.StockQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property StockQuantity() As Decimal Implements  _
   IMRPEntity.StockQuantity
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal StockQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Decimal StockQuantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get StockQuantity() : decimal;
public function set StockQuantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal

Implements

IMRPEntity.StockQuantity
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.SupplyType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SupplyType() As SupplyType Implements  _
   IMRPEntity.SupplyType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SupplyType SupplyType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property SupplyType SupplyType {
 SupplyType get( );
 void set(
   SupplyType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SupplyType() : SupplyType;
public function set SupplyType(value : SupplyType);
This language is not supported or no code example is available.

Property Value

Type: SupplyType

Implements

IMRPEntity.SupplyType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.Visited Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Visited() As Boolean Implements  _
   IMRPEntity.Visited
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool Visited {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool Visited {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Visited() : boolean;
public function set Visited(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool

Implements

IMRPEntity.Visited
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.WhsInfo Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property WhsInfo() As IWhs Implements  _
   IMRPEntity.WhsInfo
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IWhs WhsInfo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IWhs^ WhsInfo {
 IWhs^ get( );
 void set(
   IWhs^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get WhsInfo() : IWhs;
public function set WhsInfo(value : IWhs);
This language is not supported or no code example is available.

Property Value

Type: IWhs

Implements

IMRPEntity.WhsInfo
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity Methods

MrpEntity Class See Also

The following tables list the members exposed by the MrpEntity type.

Methods
 | Name | Description
Public method | CompareTo | First compare by date then by Direction ( first input then output) then by Quantity
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | OnPropertyChanged |
Public method | Print |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

MrpEntity Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.CompareTo Method

First compare by date then by Direction ( first input then output) then by Quantity

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CompareTo( _
   ByVal obj As Object _
) As Integer Implements  _
   IMRPEntity.CompareTo
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int CompareTo(
   object obj
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int CompareTo(
   object^ obj
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CompareTo(
    obj : object
) : int;
This language is not supported or no code example is available.

Parameters

obj

Type: object

Return Value

Type: int

Implements

IMRPEntity.CompareTo
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.OnPropertyChanged Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub OnPropertyChanged( _
   ByVal name As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void OnPropertyChanged(
   string name
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void OnPropertyChanged(
   String^ name
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function OnPropertyChanged(
    name : String
);
This language is not supported or no code example is available.

Parameters

name

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity.Print Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function Print() As String Implements  _
   IMRPEntity.Print
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Print()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ Print()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Print() : String;
This language is not supported or no code example is available.

Return Value

Type: string

Implements

IMRPEntity.Print
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity Events

MrpEntity Class See Also

The following tables list the members exposed by the MrpEntity type.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

MrpEntity Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


PropertyChanged Event

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Event PropertyChanged As PropertyChangedEventHandler
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public event PropertyChangedEventHandler PropertyChanged
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
event PropertyChangedEventHandler^ PropertyChanged {
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript supports the use of events, but not the declaration of new ones.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


WhsInfo Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class WhsInfo
    Implements IWhs
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class WhsInfo : IWhs
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class WhsInfo  : public IWhs^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class WhsInfo
   implements IWhs
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Obj.WhsInfo
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WhsInfo Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


WhsInfo Members

WhsInfo Class Methods Properties See Also

The following tables list the members exposed by the WhsInfo type.

Properties
 | Name | Description
Public property | BPLId |
Public property | InternalLeadTime |
Public property | WhsCode |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

WhsInfo Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


WhsInfo Properties

WhsInfo Class See Also

The following tables list the members exposed by the WhsInfo type.

Properties
 | Name | Description
Public property | BPLId |
Public property | InternalLeadTime |
Public property | WhsCode |
Top
See Also

Reference

WhsInfo Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


WhsInfo.BPLId Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property BPLId() As Nullable(Of Integer) Implements  _
   IWhs.BPLId
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Nullable<int> BPLId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Nullable<int> BPLId {
 Nullable<int> get( );
 void set(
   Nullable<int> value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: Nullable<int>

Implements

IWhs.BPLId
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WhsInfo Class
WhsInfo Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


WhsInfo.InternalLeadTime Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InternalLeadTime() As TimeSpan Implements  _
   IWhs.InternalLeadTime
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan InternalLeadTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property TimeSpan InternalLeadTime {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InternalLeadTime() : TimeSpan;
public function set InternalLeadTime(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan

Implements

IWhs.InternalLeadTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WhsInfo Class
WhsInfo Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


WhsInfo.WhsCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property WhsCode() As String Implements  _
   IWhs.WhsCode
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get WhsCode() : String;
public function set WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

IWhs.WhsCode
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WhsInfo Class
WhsInfo Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


WhsInfo Methods

WhsInfo Class See Also

The following tables list the members exposed by the WhsInfo type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

WhsInfo Class
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IBranch Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IBranch
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IBranch
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IBranch
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IBranch
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBranch Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IBranch Members

IBranch Interface Properties See Also

The following tables list the members exposed by the IBranch type.

Properties
 | Name | Description
Public property | BPLID |
Public property | BranchCode |
Public property | DfltWhs |
Top
See Also

Reference

IBranch Interface
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IBranch Properties

IBranch Interface See Also

The following tables list the members exposed by the IBranch type.

Properties
 | Name | Description
Public property | BPLID |
Public property | BranchCode |
Public property | DfltWhs |
Top
See Also

Reference

IBranch Interface
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IBranch.BPLID Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BPLID() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int BPLID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int BPLID {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BPLID() : int;
function set BPLID(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBranch Interface
IBranch Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IBranch.BranchCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BranchCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string BranchCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ BranchCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BranchCode() : String;
function set BranchCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBranch Interface
IBranch Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IBranch.DfltWhs Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DfltWhs() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DfltWhs {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DfltWhs {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DfltWhs() : String;
function set DfltWhs(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBranch Interface
IBranch Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDoc Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IDoc
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IDoc
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IDoc
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IDoc
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDoc Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDoc Members

IDoc Interface Properties See Also

The following tables list the members exposed by the IDoc type.

Properties
 | Name | Description
Public property | Address |
Public property | CardCode |
Public property | ChildDocuments |
Public property | DocEntry |
Public property | DocNum |
Public property | DocType |
Public property | Draft |
Public property | Key |
Public property | Lines |
Public property | ParentDocuments |
Public property | ReleaseDate |
Public property | Source |
Top
See Also

Reference

IDoc Interface
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDoc Properties

IDoc Interface See Also

The following tables list the members exposed by the IDoc type.

Properties
 | Name | Description
Public property | Address |
Public property | CardCode |
Public property | ChildDocuments |
Public property | DocEntry |
Public property | DocNum |
Public property | DocType |
Public property | Draft |
Public property | Key |
Public property | Lines |
Public property | ParentDocuments |
Public property | ReleaseDate |
Public property | Source |
Top
See Also

Reference

IDoc Interface
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDoc.Address Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Address() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Address {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Address {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Address() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDoc Interface
IDoc Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDoc.CardCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property CardCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string CardCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ CardCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CardCode() : String;
function set CardCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDoc Interface
IDoc Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDoc.ChildDocuments Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property ChildDocuments() As List(Of IDoc)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<IDoc> ChildDocuments {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property List<IDoc^>^ ChildDocuments {
 List<IDoc^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IDoc>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDoc Interface
IDoc Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDoc.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
function set DocEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDoc Interface
IDoc Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDoc.DocNum Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DocNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocNum {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocNum() : int;
function set DocNum(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDoc Interface
IDoc Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDoc.DocType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DocType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DocType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DocType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocType() : String;
function set DocType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDoc Interface
IDoc Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDoc.Draft Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Draft() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool Draft {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool Draft {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Draft() : boolean;
function set Draft(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDoc Interface
IDoc Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDoc.Key Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Key() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Key {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Key {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Key() : String;
function set Key(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDoc Interface
IDoc Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDoc.Lines Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Lines() As List(Of IDocLine)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<IDocLine> Lines {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property List<IDocLine^>^ Lines {
 List<IDocLine^>^ get( );
 void set(
   List<IDocLine^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IDocLine>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDoc Interface
IDoc Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDoc.ParentDocuments Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property ParentDocuments() As List(Of IDoc)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<IDoc> ParentDocuments {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property List<IDoc^>^ ParentDocuments {
 List<IDoc^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IDoc>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDoc Interface
IDoc Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDoc.ReleaseDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ReleaseDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime ReleaseDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime ReleaseDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ReleaseDate() : DateTime;
function set ReleaseDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDoc Interface
IDoc Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDoc.Source Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Source() As Source
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Source Source {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Source Source {
 Source get( );
 void set(
   Source value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Source() : Source;
function set Source(value : Source);
This language is not supported or no code example is available.

Property Value

Type: Source
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDoc Interface
IDoc Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDocLine Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IDocLine
    Inherits IItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IDocLine : IItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IDocLine : public IItem^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IDocLine
   implements IItem
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDocLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDocLine Members

IDocLine Interface Properties See Also

The following tables list the members exposed by the IDocLine type.

Properties
 | Name | Description
Public property | DemandDate |
Public property | Direction |
Public property | DueDate |
Public property | Header |
Public property | InventoryQuantity |
Public property | ItemCode | (inherited from IItem).
Public property | LineNum |
Public property | Links |
Public property | ParentLineNum |
Public property | Revision | (inherited from IItem).
Public property | WhsCode |
Top
See Also

Reference

IDocLine Interface
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDocLine Properties

IDocLine Interface See Also

The following tables list the members exposed by the IDocLine type.

Properties
 | Name | Description
Public property | DemandDate |
Public property | Direction |
Public property | DueDate |
Public property | Header |
Public property | InventoryQuantity |
Public property | ItemCode | (inherited from IItem).
Public property | LineNum |
Public property | Links |
Public property | ParentLineNum |
Public property | Revision | (inherited from IItem).
Public property | WhsCode |
Top
See Also

Reference

IDocLine Interface
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDocLine.DemandDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DemandDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime DemandDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime DemandDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DemandDate() : DateTime;
function set DemandDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDocLine Interface
IDocLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDocLine.Direction Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Direction() As Direction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Direction Direction {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Direction Direction {
 Direction get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Direction() : Direction;
This language is not supported or no code example is available.

Property Value

Type: Direction
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDocLine Interface
IDocLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDocLine.DueDate Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DueDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime DueDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime DueDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DueDate() : DateTime;
function set DueDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDocLine Interface
IDocLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDocLine.Header Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Header() As IDoc
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IDoc Header {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IDoc^ Header {
 IDoc^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Header() : IDoc;
This language is not supported or no code example is available.

Property Value

Type: IDoc
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDocLine Interface
IDocLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDocLine.InventoryQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property InventoryQuantity() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal InventoryQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal InventoryQuantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get InventoryQuantity() : decimal;
function set InventoryQuantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDocLine Interface
IDocLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItem.ItemCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ItemCode() : String;
function set ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItem Interface
IItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDocLine.LineNum Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDocLine Interface
IDocLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDocLine.Links Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Links() As IList(Of ILink)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IList<ILink> Links {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IList<ILink^>^ Links {
 IList<ILink^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: IList<ILink>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDocLine Interface
IDocLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDocLine.ParentLineNum Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property ParentLineNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int ParentLineNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int ParentLineNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ParentLineNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDocLine Interface
IDocLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItem.Revision Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Revision {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Revision {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Revision() : String;
function set Revision(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItem Interface
IItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IDocLine.WhsCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WhsCode() : String;
function set WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDocLine Interface
IDocLine Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItem Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IItem
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItem Members

IItem Interface Properties See Also

The following tables list the members exposed by the IItem type.

Properties
 | Name | Description
Public property | ItemCode |
Public property | Revision |
Top
See Also

Reference

IItem Interface
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItem Properties

IItem Interface See Also

The following tables list the members exposed by the IItem type.

Properties
 | Name | Description
Public property | ItemCode |
Public property | Revision |
Top
See Also

Reference

IItem Interface
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IItemSettings
    Inherits IItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IItemSettings : IItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IItemSettings : public IItem^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IItemSettings
   implements IItem
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemSettings Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings Members

IItemSettings Interface Properties See Also

The following tables list the members exposed by the IItemSettings type.

Properties
 | Name | Description
Public property | BomCode |
Public property | CardCode |
Public property | DefaultRevisionCode |
Public property | DfltWhsCode |
Public property | ItemCode | (inherited from IItem).
Public property | ItemInternalLeadTime |
Public property | LeadTime |
Public property | MaterialPhantom |
Public property | Maximum |
Public property | Minimum |
Public property | OnHand |
Public property | OrderInterval |
Public property | OrderMultiple |
Public property | PrefferedVendors |
Public property | Revision | (inherited from IItem).
Public property | RevisionInternalLeadTime |
Public property | Tolerance |
Public property | Type |
Public property | WhsCode |
Public property | itemManager |
Top
See Also

Reference

IItemSettings Interface
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings Properties

IItemSettings Interface See Also

The following tables list the members exposed by the IItemSettings type.

Properties
 | Name | Description
Public property | BomCode |
Public property | CardCode |
Public property | DefaultRevisionCode |
Public property | DfltWhsCode |
Public property | ItemCode | (inherited from IItem).
Public property | ItemInternalLeadTime |
Public property | LeadTime |
Public property | MaterialPhantom |
Public property | Maximum |
Public property | Minimum |
Public property | OnHand |
Public property | OrderInterval |
Public property | OrderMultiple |
Public property | PrefferedVendors |
Public property | Revision | (inherited from IItem).
Public property | RevisionInternalLeadTime |
Public property | Tolerance |
Public property | Type |
Public property | WhsCode |
Public property | itemManager |
Top
See Also

Reference

IItemSettings Interface
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings.BomCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BomCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string BomCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ BomCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BomCode() : String;
function set BomCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemSettings Interface
IItemSettings Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings.CardCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property CardCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string CardCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ CardCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CardCode() : String;
function set CardCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemSettings Interface
IItemSettings Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings.DefaultRevisionCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DefaultRevisionCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DefaultRevisionCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DefaultRevisionCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DefaultRevisionCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemSettings Interface
IItemSettings Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings.DfltWhsCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DfltWhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DfltWhsCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DfltWhsCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DfltWhsCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemSettings Interface
IItemSettings Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings.ItemInternalLeadTime Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ItemInternalLeadTime() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan ItemInternalLeadTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan ItemInternalLeadTime {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ItemInternalLeadTime() : TimeSpan;
function set ItemInternalLeadTime(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemSettings Interface
IItemSettings Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings.LeadTime Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property LeadTime() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan LeadTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan LeadTime {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LeadTime() : TimeSpan;
function set LeadTime(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemSettings Interface
IItemSettings Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings.MaterialPhantom Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property MaterialPhantom() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool MaterialPhantom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool MaterialPhantom {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get MaterialPhantom() : boolean;
function set MaterialPhantom(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemSettings Interface
IItemSettings Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings.Maximum Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Maximum() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double Maximum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double Maximum {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Maximum() : double;
function set Maximum(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemSettings Interface
IItemSettings Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings.Minimum Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Minimum() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double Minimum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double Minimum {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Minimum() : double;
function set Minimum(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemSettings Interface
IItemSettings Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings.OnHand Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property OnHand() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal OnHand {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal OnHand {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OnHand() : decimal;
function set OnHand(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemSettings Interface
IItemSettings Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings.OrderInterval Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property OrderInterval() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double OrderInterval {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double OrderInterval {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OrderInterval() : double;
function set OrderInterval(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemSettings Interface
IItemSettings Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings.OrderMultiple Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property OrderMultiple() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double OrderMultiple {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double OrderMultiple {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OrderMultiple() : double;
function set OrderMultiple(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemSettings Interface
IItemSettings Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings.PrefferedVendors Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property PrefferedVendors() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool PrefferedVendors {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool PrefferedVendors {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get PrefferedVendors() : boolean;
function set PrefferedVendors(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemSettings Interface
IItemSettings Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings.RevisionInternalLeadTime Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property RevisionInternalLeadTime() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan RevisionInternalLeadTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan RevisionInternalLeadTime {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RevisionInternalLeadTime() : TimeSpan;
function set RevisionInternalLeadTime(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemSettings Interface
IItemSettings Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings.Tolerance Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Tolerance() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan Tolerance {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan Tolerance {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Tolerance() : TimeSpan;
function set Tolerance(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemSettings Interface
IItemSettings Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings.Type Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Type() As MRPType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
MRPType Type {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property MRPType Type {
 MRPType get( );
 void set(
   MRPType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Type() : MRPType;
function set Type(value : MRPType);
This language is not supported or no code example is available.

Property Value

Type: MRPType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemSettings Interface
IItemSettings Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings.WhsCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WhsCode() : String;
function set WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemSettings Interface
IItemSettings Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IItemSettings.itemManager Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property itemManager() As ItemManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ItemManager itemManager {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ItemManager^ itemManager {
 ItemManager^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get itemManager() : ItemManager;
This language is not supported or no code example is available.

Property Value

Type: ItemManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemSettings Interface
IItemSettings Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IMRPEntity
    Inherits IItem, _
             IComparable
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IMRPEntity : IItem,
   IComparable
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IMRPEntity : public IItem^,
   public IComparable^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IMRPEntity
   implements IItem,
              IComparable
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity Members

IMRPEntity Interface Methods Properties See Also

The following tables list the members exposed by the IMRPEntity type.

Properties
 | Name | Description
Public property | CumulativeDemand | Cumulative demand without current document
Public property | CumulativeSupply | Cumulative supply without current document
Public property | Date |
Public property | Direction |
Public property | InAvailbleQuantity |
Public property | InStockQuantity |
Public property | InternaLeadTime |
Public property | InternalEntits |
Public property | ItemCode | (inherited from IItem).
Public property | OutAvailbleQuantity |
Public property | OutStockQuantity |
Public property | Owner |
Public property | References |
Public property | Remarks |
Public property | Revision | (inherited from IItem).
Public property | SourceEntity |
Public property | StockQuantity |
Public property | SupplyType |
Public property | Visited |
Public property | WhsInfo |
Top
Methods
 | Name | Description
Public method | Print |
Top
See Also

Reference

IMRPEntity Interface
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity Properties

IMRPEntity Interface See Also

The following tables list the members exposed by the IMRPEntity type.

Properties
 | Name | Description
Public property | CumulativeDemand | Cumulative demand without current document
Public property | CumulativeSupply | Cumulative supply without current document
Public property | Date |
Public property | Direction |
Public property | InAvailbleQuantity |
Public property | InStockQuantity |
Public property | InternaLeadTime |
Public property | InternalEntits |
Public property | ItemCode | (inherited from IItem).
Public property | OutAvailbleQuantity |
Public property | OutStockQuantity |
Public property | Owner |
Public property | References |
Public property | Remarks |
Public property | Revision | (inherited from IItem).
Public property | SourceEntity |
Public property | StockQuantity |
Public property | SupplyType |
Public property | Visited |
Public property | WhsInfo |
Top
See Also

Reference

IMRPEntity Interface
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity.CumulativeDemand Property

Cumulative demand without current document

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property CumulativeDemand() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal CumulativeDemand {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal CumulativeDemand {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CumulativeDemand() : decimal;
function set CumulativeDemand(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Interface
IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity.CumulativeSupply Property

Cumulative supply without current document

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property CumulativeSupply() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal CumulativeSupply {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal CumulativeSupply {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CumulativeSupply() : decimal;
function set CumulativeSupply(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Interface
IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity.Date Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Date() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime Date {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime Date {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Date() : DateTime;
function set Date(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Interface
IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity.Direction Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Direction() As Direction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Direction Direction {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Direction Direction {
 Direction get( );
 void set(
   Direction value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Direction() : Direction;
function set Direction(value : Direction);
This language is not supported or no code example is available.

Property Value

Type: Direction
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Interface
IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity.InAvailbleQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property InAvailbleQuantity() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal InAvailbleQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal InAvailbleQuantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get InAvailbleQuantity() : decimal;
function set InAvailbleQuantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Interface
IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity.InStockQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property InStockQuantity() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal InStockQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal InStockQuantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get InStockQuantity() : decimal;
function set InStockQuantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Interface
IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity.InternaLeadTime Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property InternaLeadTime() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan InternaLeadTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan InternaLeadTime {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get InternaLeadTime() : TimeSpan;
function set InternaLeadTime(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Interface
IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity.InternalEntits Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property InternalEntits() As List(Of IMRPEntity)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<IMRPEntity> InternalEntits {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property List<IMRPEntity^>^ InternalEntits {
 List<IMRPEntity^>^ get( );
 void set(
   List<IMRPEntity^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IMRPEntity>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Interface
IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity.OutAvailbleQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property OutAvailbleQuantity() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal OutAvailbleQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal OutAvailbleQuantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OutAvailbleQuantity() : decimal;
function set OutAvailbleQuantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Interface
IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity.OutStockQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property OutStockQuantity() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal OutStockQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal OutStockQuantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OutStockQuantity() : decimal;
function set OutStockQuantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Interface
IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity.Owner Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Owner() As IPathItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IPathItem Owner {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IPathItem^ Owner {
 IPathItem^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Owner() : IPathItem;
This language is not supported or no code example is available.

Property Value

Type: IPathItem
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Interface
IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity.References Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property References() As IList(Of IDocLine)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IList<IDocLine> References {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IList<IDocLine^>^ References {
 IList<IDocLine^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: IList<IDocLine>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Interface
IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity.Remarks Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Remarks() : String;
function set Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Interface
IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity.SourceEntity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property SourceEntity() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool SourceEntity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool SourceEntity {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get SourceEntity() : boolean;
function set SourceEntity(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Interface
IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity.StockQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property StockQuantity() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal StockQuantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal StockQuantity {
 Decimal get( );
 void set(
   Decimal value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get StockQuantity() : decimal;
function set StockQuantity(value : decimal);
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Interface
IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity.SupplyType Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property SupplyType() As SupplyType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
SupplyType SupplyType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property SupplyType SupplyType {
 SupplyType get( );
 void set(
   SupplyType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get SupplyType() : SupplyType;
function set SupplyType(value : SupplyType);
This language is not supported or no code example is available.

Property Value

Type: SupplyType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Interface
IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity.Visited Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Visited() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool Visited {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool Visited {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Visited() : boolean;
function set Visited(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Interface
IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity.WhsInfo Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property WhsInfo() As IWhs
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IWhs WhsInfo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IWhs^ WhsInfo {
 IWhs^ get( );
 void set(
   IWhs^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WhsInfo() : IWhs;
function set WhsInfo(value : IWhs);
This language is not supported or no code example is available.

Property Value

Type: IWhs
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Interface
IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity Methods

IMRPEntity Interface See Also

The following tables list the members exposed by the IMRPEntity type.

Methods
 | Name | Description
Public method | Print |
Top
See Also

Reference

IMRPEntity Interface
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IMRPEntity.Print Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function Print() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Print()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

String^ Print()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Print() : String;
This language is not supported or no code example is available.

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMRPEntity Interface
IMRPEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IPathItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IPathItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IPathItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IPathItem
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem Members

IPathItem Interface Methods Properties See Also

The following tables list the members exposed by the IPathItem type.

Properties
 | Name | Description
Public property | Calculated |
Public property | Item |
Public property | ItemCode |
Public property | ItemManager |
Public property | Links |
Public property | Manager |
Public property | OnHandQuantity |
Public property | OnHandQuantityExt |
Public property | Queue |
Public property | Revision |
Public property | Warehouse |
Public property | WhsCode |
Top
Methods
 | Name | Description
Public method | GetAvailbleQuantityForDate | (Overloaded)
Public method | GetNotVisitedEntietiesForDates |
Public method | Print |
Public method | RecalculateCumulaiveQuantity | (Overloaded)
Top
See Also

Reference

IPathItem Interface
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem Properties

IPathItem Interface See Also

The following tables list the members exposed by the IPathItem type.

Properties
 | Name | Description
Public property | Calculated |
Public property | Item |
Public property | ItemCode |
Public property | ItemManager |
Public property | Links |
Public property | Manager |
Public property | OnHandQuantity |
Public property | OnHandQuantityExt |
Public property | Queue |
Public property | Revision |
Public property | Warehouse |
Public property | WhsCode |
Top
See Also

Reference

IPathItem Interface
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem.Calculated Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Calculated() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool Calculated {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool Calculated {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Calculated() : boolean;
function set Calculated(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem.Item Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Item() As IItemSettings
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IItemSettings Item {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IItemSettings^ Item {
 IItemSettings^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Item() : IItemSettings;
This language is not supported or no code example is available.

Property Value

Type: IItemSettings
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem.ItemCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string ItemCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ ItemCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ItemCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem.ItemManager Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property ItemManager() As ItemManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ItemManager ItemManager {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ItemManager^ ItemManager {
 ItemManager^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ItemManager() : ItemManager;
This language is not supported or no code example is available.

Property Value

Type: ItemManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem.Links Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Links() As List(Of ILink)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<ILink> Links {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property List<ILink^>^ Links {
 List<ILink^>^ get( );
 void set(
   List<ILink^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<ILink>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem.Manager Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Manager() As MRPManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
MRPManager Manager {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property MRPManager^ Manager {
 MRPManager^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Manager() : MRPManager;
This language is not supported or no code example is available.

Property Value

Type: MRPManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem.OnHandQuantity Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property OnHandQuantity() As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal OnHandQuantity {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Decimal OnHandQuantity {
 Decimal get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get OnHandQuantity() : decimal;
This language is not supported or no code example is available.

Property Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem.OnHandQuantityExt Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property OnHandQuantityExt() As List(Of Tuple(Of Decimal, Date))
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<Tuple<decimal, DateTime>> OnHandQuantityExt {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property List<Tuple<Decimal, DateTime>^>^ OnHandQuantityExt {
 List<Tuple<Decimal, DateTime>^>^ get( );
 void set(
   List<Tuple<Decimal, DateTime>^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<Tuple<decimal, DateTime>>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem.Queue Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Queue() As SDQueue(Of IMRPEntity)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
SDQueue<IMRPEntity> Queue {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property SDQueue<IMRPEntity^>^ Queue {
 SDQueue<IMRPEntity^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: SDQueue<IMRPEntity>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem.Revision Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Revision() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Revision {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Revision {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Revision() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem.Warehouse Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Warehouse() As IWhs
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IWhs Warehouse {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IWhs^ Warehouse {
 IWhs^ get( );
 void set(
   IWhs^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Warehouse() : IWhs;
function set Warehouse(value : IWhs);
This language is not supported or no code example is available.

Property Value

Type: IWhs
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem.WhsCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string WhsCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ WhsCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WhsCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem Methods

IPathItem Interface See Also

The following tables list the members exposed by the IPathItem type.

Methods
 | Name | Description
Public method | GetAvailbleQuantityForDate | (Overloaded)
Public method | GetNotVisitedEntietiesForDates |
Public method | Print |
Public method | RecalculateCumulaiveQuantity | (Overloaded)
Top
See Also

Reference

IPathItem Interface
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem.GetAvailbleQuantityForDate Method

IPathItem Interface See Also

Overload List
Name | Description
GetAvailbleQuantityForDate(DateTime, IMRPEntity) |
GetAvailbleQuantityForDate(DateTime) |
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem.GetNotVisitedEntietiesForDates Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetNotVisitedEntietiesForDates( _
   ByVal date As Date, _
   ByVal endPeriod As Date _
) As IEnumerable(Of LinkedListNode(Of IMRPEntity))
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IEnumerable<LinkedListNode<IMRPEntity>> GetNotVisitedEntietiesForDates(
   DateTime date,
   DateTime endPeriod
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

IEnumerable<LinkedListNode<IMRPEntity^>^>^ GetNotVisitedEntietiesForDates(
   DateTime date,
   DateTime endPeriod
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

date

Type: DateTime

endPeriod

Type: DateTime

Return Value

Type: IEnumerable<LinkedListNode<IMRPEntity>>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem.Print Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function Print() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Print()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

String^ Print()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Print() : String;
This language is not supported or no code example is available.

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem.RecalculateCumulaiveQuantity Method

IPathItem Interface See Also

Overload List
Name | Description
RecalculateCumulaiveQuantity() |
RecalculateCumulaiveQuantity(LinkedListNode<IMRPEntity>) |
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IWhs Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IWhs
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IWhs
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IWhs
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IWhs
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWhs Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IWhs Members

IWhs Interface Properties See Also

The following tables list the members exposed by the IWhs type.

Properties
 | Name | Description
Public property | BPLId |
Public property | InternalLeadTime |
Public property | WhsCode |
Top
See Also

Reference

IWhs Interface
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IWhs Properties

IWhs Interface See Also

The following tables list the members exposed by the IWhs type.

Properties
 | Name | Description
Public property | BPLId |
Public property | InternalLeadTime |
Public property | WhsCode |
Top
See Also

Reference

IWhs Interface
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IWhs.BPLId Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property BPLId() As Nullable(Of Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Nullable<int> BPLId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Nullable<int> BPLId {
 Nullable<int> get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: Nullable<int>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWhs Interface
IWhs Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IWhs.InternalLeadTime Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property InternalLeadTime() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan InternalLeadTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan InternalLeadTime {
 TimeSpan get( );
 void set(
   TimeSpan value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get InternalLeadTime() : TimeSpan;
function set InternalLeadTime(value : TimeSpan);
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWhs Interface
IWhs Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IWhs.WhsCode Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string WhsCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ WhsCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WhsCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWhs Interface
IWhs Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


SupplyType Enumeration

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
InternalLead |
Availble |
See Also

Reference

CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | ByCompanyPathSelectorRule |
Public class | ByWhsPathSelectorRule |
Public class | PurchaseInternalLeadTimeRule |
Public class | SalesInternalLeadTimeRule |
Public class | WhsIntenalLeadTimeCalculator |
Top
Interfaces
 | Name | Description
Public interface | IMinMaxRule |
Public interface | IPathSelectorRule |
Public interface | IStrategy |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ByCompanyPathSelectorRule Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ByCompanyPathSelectorRule
    Implements IPathSelectorRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ByCompanyPathSelectorRule : IPathSelectorRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ByCompanyPathSelectorRule  : public IPathSelectorRule^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ByCompanyPathSelectorRule
   implements IPathSelectorRule
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Rules.ByCompanyPathSelectorRule
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ByCompanyPathSelectorRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


ByCompanyPathSelectorRule Members

ByCompanyPathSelectorRule Class Methods Properties See Also

The following tables list the members exposed by the ByCompanyPathSelectorRule type.

Properties
 | Name | Description
Public property | Scenario |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetPath | (Overloaded)
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | SetScenario |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ByCompanyPathSelectorRule Class
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


ByCompanyPathSelectorRule Properties

ByCompanyPathSelectorRule Class See Also

The following tables list the members exposed by the ByCompanyPathSelectorRule type.

Properties
 | Name | Description
Public property | Scenario |
Top
See Also

Reference

ByCompanyPathSelectorRule Class
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


ByCompanyPathSelectorRule.Scenario Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Scenario() As IScenario Implements  _
   IPathSelectorRule.Scenario
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IScenario Scenario {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IScenario^ Scenario {
 IScenario^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Scenario() : IScenario;
This language is not supported or no code example is available.

Property Value

Type: IScenario

Implements

IPathSelectorRule.Scenario
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ByCompanyPathSelectorRule Class
ByCompanyPathSelectorRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


ByCompanyPathSelectorRule Methods

ByCompanyPathSelectorRule Class See Also

The following tables list the members exposed by the ByCompanyPathSelectorRule type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetPath | (Overloaded)
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | SetScenario |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ByCompanyPathSelectorRule Class
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


ByCompanyPathSelectorRule.GetPath Method

ByCompanyPathSelectorRule Class See Also

Overload List
Name | Description
GetPath(ItemManager, string, string, string) |
GetPath(MRPManager, string, string, string) |
See Also

Reference

ByCompanyPathSelectorRule Class
ByCompanyPathSelectorRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


ByCompanyPathSelectorRule.SetScenario Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub SetScenario( _
   ByVal scenario As IScenario _
) Implements  _
   IPathSelectorRule.SetScenario
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void SetScenario(
   IScenario scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void SetScenario(
   IScenario^ scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SetScenario(
    scenario : IScenario
);
This language is not supported or no code example is available.

Parameters

scenario

Type: IScenario

Implements

IPathSelectorRule.SetScenario
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ByCompanyPathSelectorRule Class
ByCompanyPathSelectorRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


ByWhsPathSelectorRule Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ByWhsPathSelectorRule
    Implements IPathSelectorRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ByWhsPathSelectorRule : IPathSelectorRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ByWhsPathSelectorRule  : public IPathSelectorRule^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ByWhsPathSelectorRule
   implements IPathSelectorRule
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Rules.ByWhsPathSelectorRule
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ByWhsPathSelectorRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


ByWhsPathSelectorRule Members

ByWhsPathSelectorRule Class Methods Properties See Also

The following tables list the members exposed by the ByWhsPathSelectorRule type.

Properties
 | Name | Description
Public property | Scenario |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetPath | (Overloaded)
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | SetScenario |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ByWhsPathSelectorRule Class
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


ByWhsPathSelectorRule Properties

ByWhsPathSelectorRule Class See Also

The following tables list the members exposed by the ByWhsPathSelectorRule type.

Properties
 | Name | Description
Public property | Scenario |
Top
See Also

Reference

ByWhsPathSelectorRule Class
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


ByWhsPathSelectorRule.Scenario Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Scenario() As IScenario Implements  _
   IPathSelectorRule.Scenario
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IScenario Scenario {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IScenario^ Scenario {
 IScenario^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Scenario() : IScenario;
This language is not supported or no code example is available.

Property Value

Type: IScenario

Implements

IPathSelectorRule.Scenario
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ByWhsPathSelectorRule Class
ByWhsPathSelectorRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


ByWhsPathSelectorRule Methods

ByWhsPathSelectorRule Class See Also

The following tables list the members exposed by the ByWhsPathSelectorRule type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetPath | (Overloaded)
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | SetScenario |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ByWhsPathSelectorRule Class
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


ByWhsPathSelectorRule.GetPath Method

ByWhsPathSelectorRule Class See Also

Overload List
Name | Description
GetPath(ItemManager, string, string, string) |
GetPath(MRPManager, string, string, string) |
See Also

Reference

ByWhsPathSelectorRule Class
ByWhsPathSelectorRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


ByWhsPathSelectorRule.SetScenario Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub SetScenario( _
   ByVal scenario As IScenario _
) Implements  _
   IPathSelectorRule.SetScenario
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void SetScenario(
   IScenario scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void SetScenario(
   IScenario^ scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SetScenario(
    scenario : IScenario
);
This language is not supported or no code example is available.

Parameters

scenario

Type: IScenario

Implements

IPathSelectorRule.SetScenario
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ByWhsPathSelectorRule Class
ByWhsPathSelectorRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


PurchaseInternalLeadTimeRule Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class PurchaseInternalLeadTimeRule
    Implements IInternalLeadTimeRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PurchaseInternalLeadTimeRule : IInternalLeadTimeRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class PurchaseInternalLeadTimeRule  : public IInternalLeadTimeRule^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PurchaseInternalLeadTimeRule
   implements IInternalLeadTimeRule
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Rules.PurchaseInternalLeadTimeRule
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseInternalLeadTimeRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


PurchaseInternalLeadTimeRule Members

PurchaseInternalLeadTimeRule Class Methods See Also

The following tables list the members exposed by the PurchaseInternalLeadTimeRule type.

Methods
 | Name | Description
Public method | CalculateLeadTime | (Overloaded)
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PurchaseInternalLeadTimeRule Class
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


PurchaseInternalLeadTimeRule Methods

PurchaseInternalLeadTimeRule Class See Also

The following tables list the members exposed by the PurchaseInternalLeadTimeRule type.

Methods
 | Name | Description
Public method | CalculateLeadTime | (Overloaded)
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PurchaseInternalLeadTimeRule Class
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


PurchaseInternalLeadTimeRule.CalculateLeadTime Method

PurchaseInternalLeadTimeRule Class See Also

Overload List
Name | Description
CalculateLeadTime(IPathItem, IDocLine) |
CalculateLeadTime(ItemManager, IDocLine) |
See Also

Reference

PurchaseInternalLeadTimeRule Class
PurchaseInternalLeadTimeRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


SalesInternalLeadTimeRule Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SalesInternalLeadTimeRule
    Implements IInternalLeadTimeRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SalesInternalLeadTimeRule : IInternalLeadTimeRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SalesInternalLeadTimeRule  : public IInternalLeadTimeRule^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SalesInternalLeadTimeRule
   implements IInternalLeadTimeRule
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Rules.SalesInternalLeadTimeRule
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SalesInternalLeadTimeRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


SalesInternalLeadTimeRule Members

SalesInternalLeadTimeRule Class Constructors Methods See Also

The following tables list the members exposed by the SalesInternalLeadTimeRule type.

Constructors
 | Name | Description
Public constructor | SalesInternalLeadTimeRule |
Top
Methods
 | Name | Description
Public method | CalculateLeadTime | (Overloaded)
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetInternalLeadfromCardCode |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SalesInternalLeadTimeRule Class
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


SalesInternalLeadTimeRule Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SalesInternalLeadTimeRule()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SalesInternalLeadTimeRule()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SalesInternalLeadTimeRule();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SalesInternalLeadTimeRule Class
SalesInternalLeadTimeRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


SalesInternalLeadTimeRule Methods

SalesInternalLeadTimeRule Class See Also

The following tables list the members exposed by the SalesInternalLeadTimeRule type.

Methods
 | Name | Description
Public method | CalculateLeadTime | (Overloaded)
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetInternalLeadfromCardCode |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SalesInternalLeadTimeRule Class
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


SalesInternalLeadTimeRule.CalculateLeadTime Method

SalesInternalLeadTimeRule Class See Also

Overload List
Name | Description
CalculateLeadTime(IPathItem, IDocLine) |
CalculateLeadTime(ItemManager, IDocLine) |
See Also

Reference

SalesInternalLeadTimeRule Class
SalesInternalLeadTimeRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


SalesInternalLeadTimeRule.GetInternalLeadfromCardCode Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetInternalLeadfromCardCode( _
   ByVal supply As SupplyGenerator, _
   ByVal cardCode As String, _
   ByVal address As String _
) As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan GetInternalLeadfromCardCode(
   SupplyGenerator supply,
   string cardCode,
   string address
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeSpan GetInternalLeadfromCardCode(
   SupplyGenerator^ supply,
   String^ cardCode,
   String^ address
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetInternalLeadfromCardCode(
    supply : SupplyGenerator,
    cardCode : String,
    address : String
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

supply

Type: SupplyGenerator

cardCode

Type: string

address

Type: string

Return Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SalesInternalLeadTimeRule Class
SalesInternalLeadTimeRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


WhsIntenalLeadTimeCalculator Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class WhsIntenalLeadTimeCalculator
    Implements IInternalLeadTimeRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class WhsIntenalLeadTimeCalculator : IInternalLeadTimeRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class WhsIntenalLeadTimeCalculator  : public IInternalLeadTimeRule^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class WhsIntenalLeadTimeCalculator
   implements IInternalLeadTimeRule
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.MRP.Rules.WhsIntenalLeadTimeCalculator
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WhsIntenalLeadTimeCalculator Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


WhsIntenalLeadTimeCalculator Members

WhsIntenalLeadTimeCalculator Class Methods See Also

The following tables list the members exposed by the WhsIntenalLeadTimeCalculator type.

Methods
 | Name | Description
Public method | CalculateLeadTime | (Overloaded)
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

WhsIntenalLeadTimeCalculator Class
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


WhsIntenalLeadTimeCalculator Methods

WhsIntenalLeadTimeCalculator Class See Also

The following tables list the members exposed by the WhsIntenalLeadTimeCalculator type.

Methods
 | Name | Description
Public method | CalculateLeadTime | (Overloaded)
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

WhsIntenalLeadTimeCalculator Class
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


WhsIntenalLeadTimeCalculator.CalculateLeadTime Method

WhsIntenalLeadTimeCalculator Class See Also

Overload List
Name | Description
CalculateLeadTime(IPathItem, IDocLine) |
CalculateLeadTime(ItemManager, IDocLine) |
See Also

Reference

WhsIntenalLeadTimeCalculator Class
WhsIntenalLeadTimeCalculator Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


IMinMaxRule Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IMinMaxRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IMinMaxRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IMinMaxRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IMinMaxRule
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMinMaxRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


IMinMaxRule Members

IMinMaxRule Interface Methods See Also

The following tables list the members exposed by the IMinMaxRule type.

Methods
 | Name | Description
Public method | GetMaximumInverntoryLevel |
Public method | GetMinumimInverntoryLevel |
Top
See Also

Reference

IMinMaxRule Interface
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


IMinMaxRule Methods

IMinMaxRule Interface See Also

The following tables list the members exposed by the IMinMaxRule type.

Methods
 | Name | Description
Public method | GetMaximumInverntoryLevel |
Public method | GetMinumimInverntoryLevel |
Top
See Also

Reference

IMinMaxRule Interface
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


IMinMaxRule.GetMaximumInverntoryLevel Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetMaximumInverntoryLevel( _
   ByVal pathItem As IPathItem _
) As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal GetMaximumInverntoryLevel(
   IPathItem pathItem
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Decimal GetMaximumInverntoryLevel(
   IPathItem^ pathItem
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetMaximumInverntoryLevel(
    pathItem : IPathItem
) : decimal;
This language is not supported or no code example is available.

Parameters

pathItem

Type: IPathItem

Return Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMinMaxRule Interface
IMinMaxRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


IMinMaxRule.GetMinumimInverntoryLevel Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetMinumimInverntoryLevel( _
   ByVal pathItem As IPathItem _
) As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal GetMinumimInverntoryLevel(
   IPathItem pathItem
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Decimal GetMinumimInverntoryLevel(
   IPathItem^ pathItem
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetMinumimInverntoryLevel(
    pathItem : IPathItem
) : decimal;
This language is not supported or no code example is available.

Parameters

pathItem

Type: IPathItem

Return Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IMinMaxRule Interface
IMinMaxRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


IPathSelectorRule Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IPathSelectorRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IPathSelectorRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IPathSelectorRule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IPathSelectorRule
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathSelectorRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


IPathSelectorRule Members

IPathSelectorRule Interface Methods Properties See Also

The following tables list the members exposed by the IPathSelectorRule type.

Properties
 | Name | Description
Public property | Scenario |
Top
Methods
 | Name | Description
Public method | GetPath | (Overloaded)
Public method | SetScenario |
Top
See Also

Reference

IPathSelectorRule Interface
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


IPathSelectorRule Properties

IPathSelectorRule Interface See Also

The following tables list the members exposed by the IPathSelectorRule type.

Properties
 | Name | Description
Public property | Scenario |
Top
See Also

Reference

IPathSelectorRule Interface
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


IPathSelectorRule.Scenario Property

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Scenario() As IScenario
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IScenario Scenario {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IScenario^ Scenario {
 IScenario^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Scenario() : IScenario;
This language is not supported or no code example is available.

Property Value

Type: IScenario
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathSelectorRule Interface
IPathSelectorRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


IPathSelectorRule Methods

IPathSelectorRule Interface See Also

The following tables list the members exposed by the IPathSelectorRule type.

Methods
 | Name | Description
Public method | GetPath | (Overloaded)
Public method | SetScenario |
Top
See Also

Reference

IPathSelectorRule Interface
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


IPathSelectorRule.GetPath Method

IPathSelectorRule Interface See Also

Overload List
Name | Description
GetPath(ItemManager, string, string, string) |
GetPath(MRPManager, string, string, string) |
See Also

Reference

IPathSelectorRule Interface
IPathSelectorRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


IPathSelectorRule.SetScenario Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub SetScenario( _
   ByVal scenario As IScenario _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void SetScenario(
   IScenario scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void SetScenario(
   IScenario^ scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function SetScenario(
    scenario : IScenario
);
This language is not supported or no code example is available.

Parameters

scenario

Type: IScenario

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathSelectorRule Interface
IPathSelectorRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


IStrategy Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IStrategy
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IStrategy
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IStrategy
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IStrategy
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IStrategy Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


IStrategy Members

IStrategy Interface Methods See Also

The following tables list the members exposed by the IStrategy type.

Methods
 | Name | Description
Public method | GetStrategy |
Top
See Also

Reference

IStrategy Interface
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


IStrategy Methods

IStrategy Interface See Also

The following tables list the members exposed by the IStrategy type.

Methods
 | Name | Description
Public method | GetStrategy |
Top
See Also

Reference

IStrategy Interface
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


IStrategy.GetStrategy Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetStrategy( _
   ByVal scenario As IScenario, _
   ByVal pathItem As IPathItem, _
   ByVal node As LinkedListNode(Of IMRPEntity) _
) As IDoc
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IDoc GetStrategy(
   IScenario scenario,
   IPathItem pathItem,
   LinkedListNode<IMRPEntity> node
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

IDoc^ GetStrategy(
   IScenario^ scenario,
   IPathItem^ pathItem,
   LinkedListNode<IMRPEntity^>^ node
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

scenario

Type: IScenario

pathItem

Type: IPathItem

node

Type: LinkedListNode<IMRPEntity>

Return Value

Type: IDoc
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IStrategy Interface
IStrategy Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | DataTable |
Public class | DataTableColumn |
Public class | DataTableRow |
Public class | DataTableRowCell |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


DataTable Class

Members See Also

Namespace: CompuTec.ProcessForce.API.UI.Tools.DataTables
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<System.Serializable()> _
<System.ComponentModel.DesignerCategory("code")> _
<System.Xml.Serialization.XmlType(AnonymousType = true)> _
<System.Xml.Serialization.XmlRoot(Namespace = "", IsNullable = false)> _
Public Class DataTable
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.Serializable()]
[System.ComponentModel.DesignerCategory("code")]
[System.Xml.Serialization.XmlType(AnonymousType = true)]
[System.Xml.Serialization.XmlRoot(Namespace = "", IsNullable = false)]
public class DataTable
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.Serializable()]
[System.ComponentModel.DesignerCategory("code")]
[System.Xml.Serialization.XmlType(AnonymousType = true)]
[System.Xml.Serialization.XmlRoot(Namespace = "", IsNullable = false)]
public ref class DataTable
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   System.Serializable()
   System.ComponentModel.DesignerCategory("code")
   System.Xml.Serialization.XmlType(AnonymousType = true)
   System.Xml.Serialization.XmlRoot(Namespace = "", IsNullable = false)
class DataTable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.UI.Tools.DataTables.DataTable
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataTable Members
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTable Members

DataTable Class Constructors Methods Properties See Also

The following tables list the members exposed by the DataTable type.

Constructors
 | Name | Description
Public constructor | DataTable |
Top
Properties
 | Name | Description
Public property | Columns |
Public property | Rows |
Public property | Uid |
Top
Methods
 | Name | Description
 | Deserialise |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | Toxml |
Top
See Also

Reference

DataTable Class
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTable Constructor

Namespace: CompuTec.ProcessForce.API.UI.Tools.DataTables
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DataTable()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DataTable()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DataTable();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataTable Class
DataTable Members
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTable Properties

DataTable Class See Also

The following tables list the members exposed by the DataTable type.

Properties
 | Name | Description
Public property | Columns |
Public property | Rows |
Public property | Uid |
Top
See Also

Reference

DataTable Class
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTable.Columns Property

Namespace: CompuTec.ProcessForce.API.UI.Tools.DataTables
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<System.Xml.Serialization.XmlArrayItem("Column", IsNullable = false)> _
Public Property Columns() As DataTableColumn()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.Xml.Serialization.XmlArrayItem("Column", IsNullable = false)]
public DataTableColumn[] Columns {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.Xml.Serialization.XmlArrayItem("Column", IsNullable = false)]
public:
property array< DataTableColumn^ >^ Columns {
 array< DataTableColumn^ >^ get( );
 void set(
   array< DataTableColumn^ >^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   System.Xml.Serialization.XmlArrayItem("Column", IsNullable = false)
function get Columns() : DataTableColumn[];
public
   System.Xml.Serialization.XmlArrayItem("Column", IsNullable = false)
function set Columns(value : DataTableColumn[]);
This language is not supported or no code example is available.

Property Value

Type: DataTableColumn[]
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataTable Class
DataTable Members
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTable.Rows Property

Namespace: CompuTec.ProcessForce.API.UI.Tools.DataTables
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<System.Xml.Serialization.XmlArrayItem("Row", IsNullable = false)> _
Public Property Rows() As DataTableRow()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.Xml.Serialization.XmlArrayItem("Row", IsNullable = false)]
public DataTableRow[] Rows {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.Xml.Serialization.XmlArrayItem("Row", IsNullable = false)]
public:
property array< DataTableRow^ >^ Rows {
 array< DataTableRow^ >^ get( );
 void set(
   array< DataTableRow^ >^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   System.Xml.Serialization.XmlArrayItem("Row", IsNullable = false)
function get Rows() : DataTableRow[];
public
   System.Xml.Serialization.XmlArrayItem("Row", IsNullable = false)
function set Rows(value : DataTableRow[]);
This language is not supported or no code example is available.

Property Value

Type: DataTableRow[]
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataTable Class
DataTable Members
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTable.Uid Property

Namespace: CompuTec.ProcessForce.API.UI.Tools.DataTables
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<System.Xml.Serialization.XmlAttribute()> _
Public Property Uid() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.Xml.Serialization.XmlAttribute()]
public string Uid {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.Xml.Serialization.XmlAttribute()]
public:
property String^ Uid {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   System.Xml.Serialization.XmlAttribute()
function get Uid() : String;
public
   System.Xml.Serialization.XmlAttribute()
function set Uid(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataTable Class
DataTable Members
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTable Methods

DataTable Class See Also

The following tables list the members exposed by the DataTable type.

Methods
 | Name | Description
 | Deserialise |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | Toxml |
Top
See Also

Reference

DataTable Class
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTable.Deserialise Method

Namespace: CompuTec.ProcessForce.API.UI.Tools.DataTables
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function Deserialise( _
   ByVal xml As String _
) As DataTable
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static DataTable Deserialise(
   string xml
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static DataTable^ Deserialise(
   String^ xml
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function Deserialise(
    xml : String
) : DataTable;
This language is not supported or no code example is available.

Parameters

xml

Type: string

Return Value

Type: DataTable
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataTable Class
DataTable Members
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTable.Toxml Method

Namespace: CompuTec.ProcessForce.API.UI.Tools.DataTables
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function Toxml() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Toxml()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ Toxml()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Toxml() : String;
This language is not supported or no code example is available.

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataTable Class
DataTable Members
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableColumn Class

Members See Also

Namespace: CompuTec.ProcessForce.API.UI.Tools.DataTables
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<System.CodeDom.Compiler.GeneratedCode("xsd", "4.0.30319.1")> _
<System.Serializable()> _
<System.ComponentModel.DesignerCategory("code")> _
<System.Xml.Serialization.XmlType(AnonymousType = true)> _
Public Class DataTableColumn
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.CodeDom.Compiler.GeneratedCode("xsd", "4.0.30319.1")]
[System.Serializable()]
[System.ComponentModel.DesignerCategory("code")]
[System.Xml.Serialization.XmlType(AnonymousType = true)]
public class DataTableColumn
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.CodeDom.Compiler.GeneratedCode("xsd", "4.0.30319.1")]
[System.Serializable()]
[System.ComponentModel.DesignerCategory("code")]
[System.Xml.Serialization.XmlType(AnonymousType = true)]
public ref class DataTableColumn
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   System.CodeDom.Compiler.GeneratedCode("xsd", "4.0.30319.1")
   System.Serializable()
   System.ComponentModel.DesignerCategory("code")
   System.Xml.Serialization.XmlType(AnonymousType = true)
class DataTableColumn
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.UI.Tools.DataTables.DataTableColumn
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataTableColumn Members
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableColumn Members

DataTableColumn Class Methods Properties See Also

The following tables list the members exposed by the DataTableColumn type.

Properties
 | Name | Description
Public property | MaxLength |
Public property | Type |
Public property | Uid |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

DataTableColumn Class
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableColumn Properties

DataTableColumn Class See Also

The following tables list the members exposed by the DataTableColumn type.

Properties
 | Name | Description
Public property | MaxLength |
Public property | Type |
Public property | Uid |
Top
See Also

Reference

DataTableColumn Class
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableColumn.MaxLength Property

Namespace: CompuTec.ProcessForce.API.UI.Tools.DataTables
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<System.Xml.Serialization.XmlAttribute()> _
Public Property MaxLength() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.Xml.Serialization.XmlAttribute()]
public int MaxLength {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.Xml.Serialization.XmlAttribute()]
public:
property int MaxLength {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   System.Xml.Serialization.XmlAttribute()
function get MaxLength() : int;
public
   System.Xml.Serialization.XmlAttribute()
function set MaxLength(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataTableColumn Class
DataTableColumn Members
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableColumn.Type Property

Namespace: CompuTec.ProcessForce.API.UI.Tools.DataTables
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<System.Xml.Serialization.XmlAttribute()> _
Public Property Type() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.Xml.Serialization.XmlAttribute()]
public int Type {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.Xml.Serialization.XmlAttribute()]
public:
property int Type {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   System.Xml.Serialization.XmlAttribute()
function get Type() : int;
public
   System.Xml.Serialization.XmlAttribute()
function set Type(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataTableColumn Class
DataTableColumn Members
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableColumn.Uid Property

Namespace: CompuTec.ProcessForce.API.UI.Tools.DataTables
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<System.Xml.Serialization.XmlAttribute()> _
Public Property Uid() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.Xml.Serialization.XmlAttribute()]
public string Uid {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.Xml.Serialization.XmlAttribute()]
public:
property String^ Uid {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   System.Xml.Serialization.XmlAttribute()
function get Uid() : String;
public
   System.Xml.Serialization.XmlAttribute()
function set Uid(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataTableColumn Class
DataTableColumn Members
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableColumn Methods

DataTableColumn Class See Also

The following tables list the members exposed by the DataTableColumn type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

DataTableColumn Class
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableRow Class

Members See Also

Namespace: CompuTec.ProcessForce.API.UI.Tools.DataTables
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<System.CodeDom.Compiler.GeneratedCode("xsd", "4.0.30319.1")> _
<System.Serializable()> _
<System.ComponentModel.DesignerCategory("code")> _
<System.Xml.Serialization.XmlType(AnonymousType = true)> _
Public Class DataTableRow
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.CodeDom.Compiler.GeneratedCode("xsd", "4.0.30319.1")]
[System.Serializable()]
[System.ComponentModel.DesignerCategory("code")]
[System.Xml.Serialization.XmlType(AnonymousType = true)]
public class DataTableRow
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.CodeDom.Compiler.GeneratedCode("xsd", "4.0.30319.1")]
[System.Serializable()]
[System.ComponentModel.DesignerCategory("code")]
[System.Xml.Serialization.XmlType(AnonymousType = true)]
public ref class DataTableRow
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   System.CodeDom.Compiler.GeneratedCode("xsd", "4.0.30319.1")
   System.Serializable()
   System.ComponentModel.DesignerCategory("code")
   System.Xml.Serialization.XmlType(AnonymousType = true)
class DataTableRow
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.UI.Tools.DataTables.DataTableRow
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataTableRow Members
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableRow Members

DataTableRow Class Constructors Methods Properties See Also

The following tables list the members exposed by the DataTableRow type.

Constructors
 | Name | Description
Public constructor | DataTableRow | (Overloaded)
Top
Properties
 | Name | Description
Public property | Cells |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

DataTableRow Class
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableRow Constructor

DataTableRow Class See Also

Overload List
Name | Description
DataTableRow() |
DataTableRow(string, string, string, int, int) |
See Also

Reference

DataTableRow Class
DataTableRow Members
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableRow Properties

DataTableRow Class See Also

The following tables list the members exposed by the DataTableRow type.

Properties
 | Name | Description
Public property | Cells |
Top
See Also

Reference

DataTableRow Class
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableRow.Cells Property

Namespace: CompuTec.ProcessForce.API.UI.Tools.DataTables
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<System.Xml.Serialization.XmlArrayItem("Cell", IsNullable = false)> _
Public Property Cells() As DataTableRowCell()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.Xml.Serialization.XmlArrayItem("Cell", IsNullable = false)]
public DataTableRowCell[] Cells {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.Xml.Serialization.XmlArrayItem("Cell", IsNullable = false)]
public:
property array< DataTableRowCell^ >^ Cells {
 array< DataTableRowCell^ >^ get( );
 void set(
   array< DataTableRowCell^ >^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   System.Xml.Serialization.XmlArrayItem("Cell", IsNullable = false)
function get Cells() : DataTableRowCell[];
public
   System.Xml.Serialization.XmlArrayItem("Cell", IsNullable = false)
function set Cells(value : DataTableRowCell[]);
This language is not supported or no code example is available.

Property Value

Type: DataTableRowCell[]
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataTableRow Class
DataTableRow Members
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableRow Methods

DataTableRow Class See Also

The following tables list the members exposed by the DataTableRow type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

DataTableRow Class
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableRowCell Class

Members See Also

Namespace: CompuTec.ProcessForce.API.UI.Tools.DataTables
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<System.CodeDom.Compiler.GeneratedCode("xsd", "4.0.30319.1")> _
<System.Serializable()> _
<System.ComponentModel.DesignerCategory("code")> _
<System.Xml.Serialization.XmlType(AnonymousType = true)> _
Public Class DataTableRowCell
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.CodeDom.Compiler.GeneratedCode("xsd", "4.0.30319.1")]
[System.Serializable()]
[System.ComponentModel.DesignerCategory("code")]
[System.Xml.Serialization.XmlType(AnonymousType = true)]
public class DataTableRowCell
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[System.CodeDom.Compiler.GeneratedCode("xsd", "4.0.30319.1")]
[System.Serializable()]
[System.ComponentModel.DesignerCategory("code")]
[System.Xml.Serialization.XmlType(AnonymousType = true)]
public ref class DataTableRowCell
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   System.CodeDom.Compiler.GeneratedCode("xsd", "4.0.30319.1")
   System.Serializable()
   System.ComponentModel.DesignerCategory("code")
   System.Xml.Serialization.XmlType(AnonymousType = true)
class DataTableRowCell
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.UI.Tools.DataTables.DataTableRowCell
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataTableRowCell Members
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableRowCell Members

DataTableRowCell Class Methods Properties See Also

The following tables list the members exposed by the DataTableRowCell type.

Properties
 | Name | Description
Public property | ColumnUid |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

DataTableRowCell Class
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableRowCell Properties

DataTableRowCell Class See Also

The following tables list the members exposed by the DataTableRowCell type.

Properties
 | Name | Description
Public property | ColumnUid |
Public property | Value |
Top
See Also

Reference

DataTableRowCell Class
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableRowCell.ColumnUid Property

Namespace: CompuTec.ProcessForce.API.UI.Tools.DataTables
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ColumnUid() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ColumnUid {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ColumnUid {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ColumnUid() : String;
public function set ColumnUid(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataTableRowCell Class
DataTableRowCell Members
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableRowCell.Value Property

Namespace: CompuTec.ProcessForce.API.UI.Tools.DataTables
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Value() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Value {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Value {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Value() : String;
public function set Value(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataTableRowCell Class
DataTableRowCell Members
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableRowCell Methods

DataTableRowCell Class See Also

The following tables list the members exposed by the DataTableRowCell type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

DataTableRowCell Class
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


CompuTec.ProcessForce.API.UI.Translations Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
Name | Description
GetTranslationResources |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


GetTranslationResources Class

Members See Also

Namespace: CompuTec.ProcessForce.API.UI.Translations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class GetTranslationResources
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static class GetTranslationResources
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class GetTranslationResources
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class GetTranslationResources
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.UI.Translations.GetTranslationResources
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GetTranslationResources Members
CompuTec.ProcessForce.API.UI.Translations Namespace


GetTranslationResources Members

GetTranslationResources Class Methods See Also

The following tables list the members exposed by the GetTranslationResources type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
 | TranslationStreamDelegate |
Top
See Also

Reference

GetTranslationResources Class
CompuTec.ProcessForce.API.UI.Translations Namespace


GetTranslationResources Methods

GetTranslationResources Class See Also

The following tables list the members exposed by the GetTranslationResources type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
 | TranslationStreamDelegate |
Top
See Also

Reference

GetTranslationResources Class
CompuTec.ProcessForce.API.UI.Translations Namespace


GetTranslationResources.TranslationStreamDelegate Method

Namespace: CompuTec.ProcessForce.API.UI.Translations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function TranslationStreamDelegate( _
   ByVal translationsType As TranslationsTypes _
) As Stream
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Stream TranslationStreamDelegate(
   TranslationsTypes translationsType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static Stream^ TranslationStreamDelegate(
   TranslationsTypes translationsType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function TranslationStreamDelegate(
    translationsType : TranslationsTypes
) : Stream;
This language is not supported or no code example is available.

Parameters

translationsType

Type: TranslationsTypes

Return Value

Type: Stream
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GetTranslationResources Class
GetTranslationResources Members
CompuTec.ProcessForce.API.UI.Translations Namespace


ICopyFromDocument.DoAction Method

Namespace: CompuTec.ProcessForce.API.Actions.CopyFromDocument
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub DoAction()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void DoAction()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void DoAction()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function DoAction();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICopyFromDocument Interface
ICopyFromDocument Members
CompuTec.ProcessForce.API.Actions.CopyFromDocument Namespace


IRequiredItems.U_DstWhsCode Property

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DstWhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DstWhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DstWhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DstWhsCode() : String;
function set U_DstWhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRequiredItems Interface
IRequiredItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IRequiredItems.U_RefLine Property

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RefLine() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RefLine {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RefLine {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RefLine() : int;
function set U_RefLine(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRequiredItems Interface
IRequiredItems Members
CompuTec.ProcessForce.API.Assigners Namespace


PickAssignerException Constructor

Namespace: CompuTec.ProcessForce.API.Assigners.PickAssigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public PickAssignerException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
PickAssignerException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function PickAssignerException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAssignerException Class
PickAssignerException Members
CompuTec.ProcessForce.API.Assigners.PickAssigner Namespace


PickAssignerException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Assigners.PickAssigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public PickAssignerException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
PickAssignerException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function PickAssignerException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAssignerException Class
PickAssignerException Members
CompuTec.ProcessForce.API.Assigners.PickAssigner Namespace


PickAssignerException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Assigners.PickAssigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public PickAssignerException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
PickAssignerException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function PickAssignerException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickAssignerException Class
PickAssignerException Members
CompuTec.ProcessForce.API.Assigners.PickAssigner Namespace


BatchOrSerialTemplateMissingException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchOrSerialTemplateMissingException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchOrSerialTemplateMissingException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchOrSerialTemplateMissingException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchOrSerialTemplateMissingException Class
BatchOrSerialTemplateMissingException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsUsedInBOMAsParentException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemDetailsUsedInBOMAsParentException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemDetailsUsedInBOMAsParentException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemDetailsUsedInBOMAsParentException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsUsedInBOMAsParentException Class
ItemDetailsUsedInBOMAsParentException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsUsedInBOMAsParentException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemDetailsUsedInBOMAsParentException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemDetailsUsedInBOMAsParentException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemDetailsUsedInBOMAsParentException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsUsedInBOMAsParentException Class
ItemDetailsUsedInBOMAsParentException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsUsedInBOMAsParentException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemDetailsUsedInBOMAsParentException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemDetailsUsedInBOMAsParentException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemDetailsUsedInBOMAsParentException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsUsedInBOMAsParentException Class
ItemDetailsUsedInBOMAsParentException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ShelfTimeFormatException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ShelfTimeFormatException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ShelfTimeFormatException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ShelfTimeFormatException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ShelfTimeFormatException Class
ShelfTimeFormatException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


CompuTec.ProcessForce.API.Configuration Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | ConfigurationHolder | Holds the configuration of ProcessForce.
Public class | ConfigurationReadException | The exception that is thrown when the configuration of ProcessForce could not be read.
Public class | ConfigurationUpdateException | The exception that is thrown when the configuration of ProcessForce could not be updated.
Public class | GeneralSettings | Represents ProcessForce's available configuration settings.
Public class | InvalidConfigurationValueException | The exception that is thrown when the value of ProcessForce's configuration setting is invalid.
Top
Interfaces
 | Name | Description
Public interface | IConfiguration | Represents the configuration of ProcessForce.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ConfigurationHolder Class

Members See Also

Holds the configuration of ProcessForce.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ConfigurationHolder
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ConfigurationHolder
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ConfigurationHolder
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ConfigurationHolder
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Configuration.ConfigurationHolder
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ConfigurationHolder Members
CompuTec.ProcessForce.API.Configuration Namespace


ConfigurationHolder Members

ConfigurationHolder Class Methods Properties See Also

Holds the configuration of ProcessForce.

The following tables list the members exposed by the ConfigurationHolder type.

Properties
 | Name | Description
 | Configuration |
Public property | Item | Gets the configuration of ProcessForce.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ConfigurationHolder Class
CompuTec.ProcessForce.API.Configuration Namespace


BatchOrSerialTemplateMissingException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchOrSerialTemplateMissingException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchOrSerialTemplateMissingException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchOrSerialTemplateMissingException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchOrSerialTemplateMissingException Class
BatchOrSerialTemplateMissingException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


BatchOrSerialTemplateMissingException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchOrSerialTemplateMissingException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchOrSerialTemplateMissingException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchOrSerialTemplateMissingException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchOrSerialTemplateMissingException Class
BatchOrSerialTemplateMissingException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsMustHaveOneDefaultRevisionException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemDetailsMustHaveOneDefaultRevisionException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemDetailsMustHaveOneDefaultRevisionException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemDetailsMustHaveOneDefaultRevisionException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsMustHaveOneDefaultRevisionException Class
ItemDetailsMustHaveOneDefaultRevisionException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsMustHaveOneDefaultRevisionException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemDetailsMustHaveOneDefaultRevisionException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemDetailsMustHaveOneDefaultRevisionException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemDetailsMustHaveOneDefaultRevisionException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsMustHaveOneDefaultRevisionException Class
ItemDetailsMustHaveOneDefaultRevisionException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsMustHaveOneDefaultRevisionException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemDetailsMustHaveOneDefaultRevisionException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemDetailsMustHaveOneDefaultRevisionException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemDetailsMustHaveOneDefaultRevisionException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsMustHaveOneDefaultRevisionException Class
ItemDetailsMustHaveOneDefaultRevisionException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsMustHaveOneDefaultRevisionForMrpException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemDetailsMustHaveOneDefaultRevisionForMrpException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemDetailsMustHaveOneDefaultRevisionForMrpException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemDetailsMustHaveOneDefaultRevisionForMrpException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsMustHaveOneDefaultRevisionForMrpException Class
ItemDetailsMustHaveOneDefaultRevisionForMrpException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsMustHaveOneDefaultRevisionForMrpException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemDetailsMustHaveOneDefaultRevisionForMrpException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemDetailsMustHaveOneDefaultRevisionForMrpException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemDetailsMustHaveOneDefaultRevisionForMrpException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsMustHaveOneDefaultRevisionForMrpException Class
ItemDetailsMustHaveOneDefaultRevisionForMrpException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ItemDetailsMustHaveOneDefaultRevisionForMrpException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemDetailsMustHaveOneDefaultRevisionForMrpException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemDetailsMustHaveOneDefaultRevisionForMrpException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemDetailsMustHaveOneDefaultRevisionForMrpException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsMustHaveOneDefaultRevisionForMrpException Class
ItemDetailsMustHaveOneDefaultRevisionForMrpException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ShelfTimeFormatException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ShelfTimeFormatException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ShelfTimeFormatException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ShelfTimeFormatException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ShelfTimeFormatException Class
ShelfTimeFormatException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ShelfTimeFormatException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ShelfTimeFormatException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ShelfTimeFormatException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ShelfTimeFormatException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ShelfTimeFormatException Class
ShelfTimeFormatException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


WarningDatesMismatchException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public WarningDatesMismatchException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
WarningDatesMismatchException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function WarningDatesMismatchException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WarningDatesMismatchException Class
WarningDatesMismatchException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


WarningDatesMismatchException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public WarningDatesMismatchException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
WarningDatesMismatchException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function WarningDatesMismatchException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WarningDatesMismatchException Class
WarningDatesMismatchException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


WarningDatesMismatchException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public WarningDatesMismatchException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
WarningDatesMismatchException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function WarningDatesMismatchException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WarningDatesMismatchException Class
WarningDatesMismatchException Members
CompuTec.ProcessForce.API.Documents.ItemDetails Namespace


ConfigurationHolder.Configuration Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Shared Property Configuration() As ConfigurationHolder
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static ConfigurationHolder Configuration {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property ConfigurationHolder^ Configuration {
 ConfigurationHolder^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get Configuration() : ConfigurationHolder;
This language is not supported or no code example is available.

Property Value

Type: ConfigurationHolder
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ConfigurationHolder Class
ConfigurationHolder Members
CompuTec.ProcessForce.API.Configuration Namespace


ConfigurationHolder.Item Property

Gets the configuration of ProcessForce.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property Item( _
   ByVal token As String _
) As IConfiguration
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IConfiguration this[
   string token
] {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IConfiguration^ Item[String] {
 IConfiguration^ get(
   String^ token
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript suports the use of indexed properties, but not the declaration of new ones.
This language is not supported or no code example is available.

Parameters

token

Type: string

Property Value

Type: IConfiguration
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ConfigurationHolder Class
ConfigurationHolder Members
CompuTec.ProcessForce.API.Configuration Namespace


ConfigurationReadException Class

Members See Also

The exception that is thrown when the configuration of ProcessForce could not be read.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ConfigurationReadException
    Inherits ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ConfigurationReadException : ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ConfigurationReadException : public ApplicationException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ConfigurationReadException
   extends ApplicationException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
CompuTec.ProcessForce.API.Configuration.ConfigurationReadException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ConfigurationReadException Members
CompuTec.ProcessForce.API.Configuration Namespace


ConfigurationReadException Members

ConfigurationReadException Class Constructors Methods Properties See Also

The exception that is thrown when the configuration of ProcessForce could not be read.

The following tables list the members exposed by the ConfigurationReadException type.

Constructors
 | Name | Description
Public constructor | ConfigurationReadException | (Overloaded) Initializes a new instance of ConfigurationReadException class with a specified error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ConfigurationReadException Class
CompuTec.ProcessForce.API.Configuration Namespace


ConfigurationReadException(String) Constructor

Initializes a new instance of ConfigurationReadException class with a specified error message.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ConfigurationReadException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ConfigurationReadException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ConfigurationReadException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

A message that describes the error.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ConfigurationReadException Class
ConfigurationReadException Members
CompuTec.ProcessForce.API.Configuration Namespace


ConfigurationReadException Constructor

ConfigurationReadException Class See Also

Initializes a new instance of ConfigurationReadException class with a specified error message.

Overload List
Name | Description
ConfigurationReadException(string) | Initializes a new instance of ConfigurationReadException class with a specified error message.
ConfigurationReadException(string, Exception) | Initializes a new instance of ConfigurationReadException class with a specified error message and a reference to the inner exception that is the cause of this exception.
See Also

Reference

ConfigurationReadException Class
ConfigurationReadException Members
CompuTec.ProcessForce.API.Configuration Namespace


ConfigurationReadException(String, Exception) Constructor

Initializes a new instance of ConfigurationReadException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ConfigurationReadException(
   string message,
   Exception innerException
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ConfigurationReadException(
   String^ message,
   Exception^ innerException
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ConfigurationReadException(
    message : String,
    innerException : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

A message that describes the error.

innerException

Type: Exception

The exception that is the cause of the current exception.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ConfigurationReadException Class
ConfigurationReadException Members
CompuTec.ProcessForce.API.Configuration Namespace


ConfigurationUpdateException Class

Members See Also

The exception that is thrown when the configuration of ProcessForce could not be updated.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ConfigurationUpdateException
    Inherits ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ConfigurationUpdateException : ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ConfigurationUpdateException : public ApplicationException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ConfigurationUpdateException
   extends ApplicationException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
CompuTec.ProcessForce.API.Configuration.ConfigurationUpdateException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ConfigurationUpdateException Members
CompuTec.ProcessForce.API.Configuration Namespace


ConfigurationUpdateException Members

ConfigurationUpdateException Class Constructors Methods Properties See Also

The exception that is thrown when the configuration of ProcessForce could not be updated.

The following tables list the members exposed by the ConfigurationUpdateException type.

Constructors
 | Name | Description
Public constructor | ConfigurationUpdateException | (Overloaded) Initializes a new instance of ConfigurationUpdateException class with a specified error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ConfigurationUpdateException Class
CompuTec.ProcessForce.API.Configuration Namespace


ConfigurationUpdateException(String) Constructor

Initializes a new instance of ConfigurationUpdateException class with a specified error message.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ConfigurationUpdateException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ConfigurationUpdateException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ConfigurationUpdateException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

A message that describes the error.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ConfigurationUpdateException Class
ConfigurationUpdateException Members
CompuTec.ProcessForce.API.Configuration Namespace


ConfigurationUpdateException Constructor

ConfigurationUpdateException Class See Also

Initializes a new instance of ConfigurationUpdateException class with a specified error message.

Overload List
Name | Description
ConfigurationUpdateException(string) | Initializes a new instance of ConfigurationUpdateException class with a specified error message.
ConfigurationUpdateException(string, Exception) | Initializes a new instance of ConfigurationUpdateException class with a specified error message and a reference to the inner exception that is the cause of this exception.
See Also

Reference

ConfigurationUpdateException Class
ConfigurationUpdateException Members
CompuTec.ProcessForce.API.Configuration Namespace


ConfigurationUpdateException(String, Exception) Constructor

Initializes a new instance of ConfigurationUpdateException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ConfigurationUpdateException(
   string message,
   Exception innerException
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ConfigurationUpdateException(
   String^ message,
   Exception^ innerException
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ConfigurationUpdateException(
    message : String,
    innerException : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

A message that describes the error.

innerException

Type: Exception

The exception that is the cause of the current exception.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ConfigurationUpdateException Class
ConfigurationUpdateException Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings Class

Members See Also

Represents ProcessForce's available configuration settings.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class GeneralSettings
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class GeneralSettings
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class GeneralSettings
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class GeneralSettings
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Configuration.GeneralSettings
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings Members

GeneralSettings Class Methods Properties See Also

Represents ProcessForce's available configuration settings.

The following tables list the members exposed by the GeneralSettings type.

Properties
 | Name | Description
 | AutoIssueEnabled |
 | AutoReceiptEnabled |
 | BatchTemplateCode | Gets or sets the default code of batch template.
 | ConsumeWarning | Gets or sets the consume days warning.
 | CoproductsFormula | Gets or sets the default bill of materials formula for coproducts.
 | CostAccountingDimensionId | Gets or sets a dimension used for Cost Accounting.
 | ExpiryWarning | Gets or sets the expiry days warning.
 | InspectionDays | Gets or sets the days between inspections.
 | IsBatchAndSerialNoSupportForLocationsEnabled | Gets or sets the indication whether the batch and serial number support for locations is enabled or disabled.
 | IsConsume | Gets or sets the indication whether the shelf time is consume date.
 | IsExpiry | Gets or sets the indication whether the shelf time is expiry date.
 | IsLocationsSupportForDocumentsEnabled | Gets or sets the indication whether the locations support for SAP Business One's documents is enabled or disabled.
 | IsProductTreeSynchronizationEnabled | Gets or sets the indication whether the synchronization between bill of materials and product trees is enabled or disabled.
 | IsProductionMenuEnabled | Gets or sets the indication whether the standard functionalities of SAP Business One's Production menu is enabled or disabled.
 | IsProductionOrdersSynchronizationEnabled | Gets or sets the indication whether the synchronization between manufacturing orders and production orders is enabled or disabled.
 | ItemGroupCode | Gets or sets the default item group code for license plates.
 | ItemsFormula | Gets or sets the default bill of materials formula for items.
 | MrpManufacturingOrderSeries | Gets or sets the default series code for MRP based manufacturing orders.
 | MrpProductionOrderComponent | Gets or sets the default component for coproducts based MRP production orders.
 | MrpProductionOrderCoproductSeries | Gets or sets the default series code for coproducts based MRP production orders.
 | MrpProductionOrderSeries | Gets or sets the default series code for MRP based production orders.
 | PhantomsFormula | Gets or sets the default bill of materials formula for phantoms.
 | PostResourceConfirmation | Gets or sets resource posting confirmation.
 | PostWiPVariance | Gets or sets if WiP variance should be calculated.
 | Prefix | Gets or sets the default prefix for license plates.
 | QcItemGroup | Gets or sets default item group code for QC items
 | QcResourceGroup | Gets or sets default item group code for QC resources.
 | ScrapFormula | Gets or sets the default bill of materials formula for scrap.
 | SerialNoTemplateCode | Gets or sets the default code of serial number template.
 | ShelfTime | Gets or sets the shelf time.
Public property | UseTcTotalPrice | Gets or sets the indication whether the TC Total price must be used during receiving the item on stock.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | Refresh | Refreshes the configuration of ProcessForce by retrieving it from the database.
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

GeneralSettings Class
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.IsProductionMenuEnabled Property

Gets or sets the indication whether the standard functionalities of SAP Business One's Production menu is enabled or disabled.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property IsProductionMenuEnabled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool IsProductionMenuEnabled {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property bool IsProductionMenuEnabled {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get IsProductionMenuEnabled() : boolean;
public static function set IsProductionMenuEnabled(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.BatchTemplateCode Property

Gets or sets the default code of batch template.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property BatchTemplateCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string BatchTemplateCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property String^ BatchTemplateCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get BatchTemplateCode() : String;
public static function set BatchTemplateCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.SerialNoTemplateCode Property

Gets or sets the default code of serial number template.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property SerialNoTemplateCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string SerialNoTemplateCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property String^ SerialNoTemplateCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get SerialNoTemplateCode() : String;
public static function set SerialNoTemplateCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.Prefix Property

Gets or sets the default prefix for license plates.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property Prefix() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string Prefix {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property String^ Prefix {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get Prefix() : String;
public static function set Prefix(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


IPreferredVendors.SetDefaultVendor (Int32) Method

Sets the default vendor by its row number.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub SetDefaultVendor( _
   ByVal rowNo As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void SetDefaultVendor(
   int rowNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void SetDefaultVendor(
   int rowNo
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function SetDefaultVendor(
    rowNo : int
);
This language is not supported or no code example is available.

Parameters

rowNo

Type: int

Row number.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


IPreferredVendors.SetDefaultVendor (String) Method

Sets the default vendor by its code.

Namespace: CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub SetDefaultVendor( _
   ByVal vendorCode As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void SetDefaultVendor(
   string vendorCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void SetDefaultVendor(
   String^ vendorCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function SetDefaultVendor(
    vendorCode : String
);
This language is not supported or no code example is available.

Parameters

vendorCode

Type: string

Vendor code.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPreferredVendors Interface
IPreferredVendors Members
CompuTec.ProcessForce.API.Documents.ItemDetails.PreferredVendors Namespace


GeneralSettings.ItemGroupCode Property

Gets or sets the default item group code for license plates.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property ItemGroupCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int ItemGroupCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property int ItemGroupCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get ItemGroupCode() : int;
public static function set ItemGroupCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.ItemsFormula Property

Gets or sets the default bill of materials formula for items.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property ItemsFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string ItemsFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property String^ ItemsFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get ItemsFormula() : String;
public static function set ItemsFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.CoproductsFormula Property

Gets or sets the default bill of materials formula for coproducts.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property CoproductsFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string CoproductsFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property String^ CoproductsFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get CoproductsFormula() : String;
public static function set CoproductsFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.ScrapFormula Property

Gets or sets the default bill of materials formula for scrap.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property ScrapFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string ScrapFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property String^ ScrapFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get ScrapFormula() : String;
public static function set ScrapFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.PhantomsFormula Property

Gets or sets the default bill of materials formula for phantoms.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property PhantomsFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string PhantomsFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property String^ PhantomsFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get PhantomsFormula() : String;
public static function set PhantomsFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.IsProductTreeSynchronizationEnabled Property

Gets or sets the indication whether the synchronization between bill of materials and product trees is enabled or disabled.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property IsProductTreeSynchronizationEnabled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool IsProductTreeSynchronizationEnabled {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property bool IsProductTreeSynchronizationEnabled {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get IsProductTreeSynchronizationEnabled() : boolean;
public static function set IsProductTreeSynchronizationEnabled(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.IsProductionOrdersSynchronizationEnabled Property

Gets or sets the indication whether the synchronization between manufacturing orders and production orders is enabled or disabled.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property IsProductionOrdersSynchronizationEnabled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool IsProductionOrdersSynchronizationEnabled {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property bool IsProductionOrdersSynchronizationEnabled {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get IsProductionOrdersSynchronizationEnabled() : boolean;
public static function set IsProductionOrdersSynchronizationEnabled(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.IsLocationsSupportForDocumentsEnabled Property

Gets or sets the indication whether the locations support for SAP Business One's documents is enabled or disabled.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property IsLocationsSupportForDocumentsEnabled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool IsLocationsSupportForDocumentsEnabled {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property bool IsLocationsSupportForDocumentsEnabled {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get IsLocationsSupportForDocumentsEnabled() : boolean;
public static function set IsLocationsSupportForDocumentsEnabled(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.IsBatchAndSerialNoSupportForLocationsEnabled Property

Gets or sets the indication whether the batch and serial number support for locations is enabled or disabled.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property IsBatchAndSerialNoSupportForLocationsEnabled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool IsBatchAndSerialNoSupportForLocationsEnabled {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property bool IsBatchAndSerialNoSupportForLocationsEnabled {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get IsBatchAndSerialNoSupportForLocationsEnabled() : boolean;
public static function set IsBatchAndSerialNoSupportForLocationsEnabled(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.MrpProductionOrderCoproductSeries Property

Gets or sets the default series code for coproducts based MRP production orders.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property MrpProductionOrderCoproductSeries() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int MrpProductionOrderCoproductSeries {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property int MrpProductionOrderCoproductSeries {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get MrpProductionOrderCoproductSeries() : int;
public static function set MrpProductionOrderCoproductSeries(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


ItemCodeOrSystemNumberMissMuchException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemCodeOrSystemNumberMissMuchException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemCodeOrSystemNumberMissMuchException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemCodeOrSystemNumberMissMuchException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCodeOrSystemNumberMissMuchException Class
ItemCodeOrSystemNumberMissMuchException Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


ItemCodeOrSystemNumberMissMuchException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemCodeOrSystemNumberMissMuchException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemCodeOrSystemNumberMissMuchException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemCodeOrSystemNumberMissMuchException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCodeOrSystemNumberMissMuchException Class
ItemCodeOrSystemNumberMissMuchException Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


ItemCodeOrSystemNumberMissMuchException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemCodeOrSystemNumberMissMuchException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemCodeOrSystemNumberMissMuchException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemCodeOrSystemNumberMissMuchException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCodeOrSystemNumberMissMuchException Class
ItemCodeOrSystemNumberMissMuchException Members
CompuTec.ProcessForce.API.Documents.AdditionalBatchDetails Namespace


GeneralSettings.MrpProductionOrderComponent Property

Gets or sets the default component for coproducts based MRP production orders.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property MrpProductionOrderComponent() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string MrpProductionOrderComponent {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property String^ MrpProductionOrderComponent {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get MrpProductionOrderComponent() : String;
public static function set MrpProductionOrderComponent(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.MrpManufacturingOrderSeries Property

Gets or sets the default series code for MRP based manufacturing orders.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property MrpManufacturingOrderSeries() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int MrpManufacturingOrderSeries {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property int MrpManufacturingOrderSeries {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get MrpManufacturingOrderSeries() : int;
public static function set MrpManufacturingOrderSeries(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.MrpProductionOrderSeries Property

Gets or sets the default series code for MRP based production orders.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property MrpProductionOrderSeries() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int MrpProductionOrderSeries {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property int MrpProductionOrderSeries {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get MrpProductionOrderSeries() : int;
public static function set MrpProductionOrderSeries(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.QcResourceGroup Property

Gets or sets default item group code for QC resources.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property QcResourceGroup() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int QcResourceGroup {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property int QcResourceGroup {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get QcResourceGroup() : int;
public static function set QcResourceGroup(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.QcItemGroup Property

Gets or sets default item group code for QC items

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property QcItemGroup() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int QcItemGroup {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property int QcItemGroup {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get QcItemGroup() : int;
public static function set QcItemGroup(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


BusinessPartnerRelationsHelper.CopyRelations (IEnumerable<IBusinessPartnerRelations>, IBusinessPartnerRelations) Method

Namespace: CompuTec.ProcessForce.API.Documents._Other_.BusinessPartnerRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub CopyRelations( _
   ByVal from As IEnumerable(Of IBusinessPartnerRelations), _
   ByVal to As IBusinessPartnerRelations _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void CopyRelations(
   IEnumerable<IBusinessPartnerRelations> from,
   IBusinessPartnerRelations to
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void CopyRelations(
   IEnumerable<IBusinessPartnerRelations^>^ from,
   IBusinessPartnerRelations^ to
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

from

Type: IEnumerable<IBusinessPartnerRelations>

to

Type: IBusinessPartnerRelations

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BusinessPartnerRelationsHelper Class
BusinessPartnerRelationsHelper Members
CompuTec.ProcessForce.API.Documents._Other_.BusinessPartnerRelations Namespace


BusinessPartnerRelationsHelper.CopyRelations (IEnumerable<IBusinessPartnerRelations>, IBusinessPartnerRelationsThridLevel, Int32) Method

Namespace: CompuTec.ProcessForce.API.Documents._Other_.BusinessPartnerRelations
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub CopyRelations( _
   ByVal from As IEnumerable(Of IBusinessPartnerRelations), _
   ByVal to As IBusinessPartnerRelationsThridLevel, _
   ByVal baseLineNum As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void CopyRelations(
   IEnumerable<IBusinessPartnerRelations> from,
   IBusinessPartnerRelationsThridLevel to,
   int baseLineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void CopyRelations(
   IEnumerable<IBusinessPartnerRelations^>^ from,
   IBusinessPartnerRelationsThridLevel^ to,
   int baseLineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

from

Type: IEnumerable<IBusinessPartnerRelations>

to

Type: IBusinessPartnerRelationsThridLevel

baseLineNum

Type: int

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BusinessPartnerRelationsHelper Class
BusinessPartnerRelationsHelper Members
CompuTec.ProcessForce.API.Documents._Other_.BusinessPartnerRelations Namespace


GeneralSettings.CostAccountingDimensionId Property

Gets or sets a dimension used for Cost Accounting.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property CostAccountingDimensionId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int CostAccountingDimensionId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property int CostAccountingDimensionId {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get CostAccountingDimensionId() : int;
public static function set CostAccountingDimensionId(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.InspectionDays Property

Gets or sets the days between inspections.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property InspectionDays() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int InspectionDays {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property int InspectionDays {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get InspectionDays() : int;
public static function set InspectionDays(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.ExpiryWarning Property

Gets or sets the expiry days warning.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property ExpiryWarning() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int ExpiryWarning {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property int ExpiryWarning {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get ExpiryWarning() : int;
public static function set ExpiryWarning(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.ConsumeWarning Property

Gets or sets the consume days warning.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property ConsumeWarning() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int ConsumeWarning {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property int ConsumeWarning {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get ConsumeWarning() : int;
public static function set ConsumeWarning(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.IsExpiry Property

Gets or sets the indication whether the shelf time is expiry date.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property IsExpiry() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool IsExpiry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property bool IsExpiry {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get IsExpiry() : boolean;
public static function set IsExpiry(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.IsConsume Property

Gets or sets the indication whether the shelf time is consume date.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property IsConsume() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool IsConsume {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property bool IsConsume {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get IsConsume() : boolean;
public static function set IsConsume(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


StockTransferData(String, String, Boolean, Double) Constructor

Initializes a new instance of CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.StockTransferData object.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal destWhsCode As String, _
   ByVal itemCode As String, _
   ByVal isLicensePlate As Boolean, _
   ByVal quantity As Double _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public StockTransferData(
   string destWhsCode,
   string itemCode,
   bool isLicensePlate,
   double quantity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
StockTransferData(
   String^ destWhsCode,
   String^ itemCode,
   bool isLicensePlate,
   double quantity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function StockTransferData(
    destWhsCode : String,
    itemCode : String,
    isLicensePlate : boolean,
    quantity : double
);
This language is not supported or no code example is available.

Parameters

destWhsCode

Type: string

A code of destination warehouse for transferring item master data.

itemCode

Type: string

A code of transferring item master data.

isLicensePlate

Type: bool

Defines if given item code represents a license plate or a standard item master data.

quantity

Type: double

Quantity of transferring item master data.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferData Class
StockTransferData Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferData(String, String, Boolean, Double, StockTransferDataManagementType) Constructor

Initializes a new instance of CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.StockTransferData object.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal destWhsCode As String, _
   ByVal itemCode As String, _
   ByVal isLicensePlate As Boolean, _
   ByVal quantity As Double, _
   ByVal managementType As StockTransferDataManagementType _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public StockTransferData(
   string destWhsCode,
   string itemCode,
   bool isLicensePlate,
   double quantity,
   StockTransferDataManagementType managementType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
StockTransferData(
   String^ destWhsCode,
   String^ itemCode,
   bool isLicensePlate,
   double quantity,
   StockTransferDataManagementType managementType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function StockTransferData(
    destWhsCode : String,
    itemCode : String,
    isLicensePlate : boolean,
    quantity : double,
    managementType : StockTransferDataManagementType
);
This language is not supported or no code example is available.

Parameters

destWhsCode

Type: string

A code of destination warehouse for transferring item master data.

itemCode

Type: string

A code of transferring item master data.

isLicensePlate

Type: bool

Defines if given item code represents a license plate or a standard item master data.

quantity

Type: double

Quantity of transferring item master data.

managementType

Type: StockTransferDataManagementType

Defines the type by which the Item Master Data is managed.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferData Class
StockTransferData Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


StockTransferData(String, String, Boolean, Double, StockTransferDataManagementType, List<BatchNumber>) Constructor

Initializes a new instance of CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.StockTransferData object.

Namespace: CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal destWhsCode As String, _
   ByVal itemCode As String, _
   ByVal isLicensePlate As Boolean, _
   ByVal quantity As Double, _
   ByVal managementType As StockTransferDataManagementType, _
   ByVal batchNumbers As List(Of BatchNumber) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public StockTransferData(
   string destWhsCode,
   string itemCode,
   bool isLicensePlate,
   double quantity,
   StockTransferDataManagementType managementType,
   List<BatchNumber> batchNumbers
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
StockTransferData(
   String^ destWhsCode,
   String^ itemCode,
   bool isLicensePlate,
   double quantity,
   StockTransferDataManagementType managementType,
   List<BatchNumber^>^ batchNumbers
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

destWhsCode

Type: string

A code of destination warehouse for transferring item master data.

itemCode

Type: string

A code of transferring item master data.

isLicensePlate

Type: bool

Defines if given item code represents a license plate or a standard item master data.

quantity

Type: double

Quantity of transferring item master data.

managementType

Type: StockTransferDataManagementType

Defines the type by which the Item Master Data is managed. This parameter identifies the type of numbers given by batchNumbers parameter.

batchNumbers

Type: List<BatchNumber>

A generic list with batch number data for an Item Master Data.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferData Class
StockTransferData Members
CompuTec.ProcessForce.API.Documents.DraftDocumentAuthorization.Manager Namespace


GeneralSettings.ShelfTime Property

Gets or sets the shelf time.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property ShelfTime() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string ShelfTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property String^ ShelfTime {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get ShelfTime() : String;
public static function set ShelfTime(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.UseTcTotalPrice Property

Gets or sets the indication whether the TC Total price must be used during receiving the item on stock.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property UseTcTotalPrice() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool UseTcTotalPrice {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool UseTcTotalPrice {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get UseTcTotalPrice() : boolean;
public function set UseTcTotalPrice(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.PostResourceConfirmation Property

Gets or sets resource posting confirmation.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property PostResourceConfirmation() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool PostResourceConfirmation {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property bool PostResourceConfirmation {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get PostResourceConfirmation() : boolean;
public static function set PostResourceConfirmation(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.PostWiPVariance Property

Gets or sets if WiP variance should be calculated.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property PostWiPVariance() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool PostWiPVariance {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property bool PostWiPVariance {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get PostWiPVariance() : boolean;
public static function set PostWiPVariance(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.AutoReceiptEnabled Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property AutoReceiptEnabled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool AutoReceiptEnabled {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property bool AutoReceiptEnabled {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get AutoReceiptEnabled() : boolean;
public static function set AutoReceiptEnabled(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.AutoIssueEnabled Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Property AutoIssueEnabled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool AutoIssueEnabled {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property bool AutoIssueEnabled {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get AutoIssueEnabled() : boolean;
public static function set AutoIssueEnabled(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


GeneralSettings.Refresh Method

Refreshes the configuration of ProcessForce by retrieving it from the database.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub Refresh( _
   ByVal Token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void Refresh(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void Refresh(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function Refresh(
    Token : String
);
This language is not supported or no code example is available.

Parameters

Token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GeneralSettings Class
GeneralSettings Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration Interface

Members See Also

Represents the configuration of ProcessForce.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IConfiguration
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IConfiguration
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IConfiguration
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IConfiguration
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration Members

IConfiguration Interface Methods Properties See Also

Represents the configuration of ProcessForce.

The following tables list the members exposed by the IConfiguration type.

Properties
 | Name | Description
Public property | AutoIssueEnabled |
Public property | AutoReceiptEnabled |
Public property | BatchQueue |
Public property | BatchTemplateCode | Gets or sets the default code of batch template.
Public property | ConsumeWarning | Gets or sets the consume days warning.
Public property | CoproductsFormula | Gets or sets the default bill of materials formula for coproducts.
Public property | CostAccountingDimensionId | Gets or sets a dimension used for Cost Accounting.
Public property | DateFormat |
Public property | DateTimeFomrat |
Public property | Dflt_CoproductYieldFormula |
Public property | Dflt_ItemYieldFormula |
Public property | Dflt_ScrapYieldFormula |
Public property | Dflt_YieldFormula |
Public property | EpiryEvaluationTemplate |
Public property | EpiryEvaluationType |
Public property | ExpiryWarning | Gets or sets the expiry days warning.
Public property | InspectionDays | Gets or sets the days between inspections.
Public property | IsBatchSerialNoSupportForLocationsEnabled | Gets or sets the indication whether the batch and serial number support for locations is enabled (true) or disabled (false).
Public property | IsConsume | Gets or sets the indication whether the shelf time is consume date.
Public property | IsExpiry | Gets or sets the indication whether the shelf time is expiry date.
Public property | IsLocationsSupportForDocumentsEnabled | Gets or sets the indication whether the locations support for SAP Business One's documents is enabled (true) or disabled (false).
Public property | IsProductTreesSynchronizationEnabled | Gets or sets the indication whether the synchronization between bill of materials and product trees is enabled (true) or disabled (false).
Public property | IsProductionOrdersSynchronizationEnabled | Gets or sets the indication whether the synchronization between manufacturing orders and production orders is enabled (true) or disabled (false).
Public property | IsSapProductionMenuEnabled | Gets or sets the indication whether the standard functionalities of SAP Business One's Production menu are enabled (true) or disabled (false).
Public property | ItemsFormula | Gets or sets the default bill of materials formula for items.
Public property | LicenseServerAddress |
Public property | LicenseServerPort |
Public property | MrpCoproductProductionOrderComponent | Gets or sets the default component for coproducts based MRP production orders.
Public property | MrpCoproductProductionOrderSeries | Gets or sets the default series code for coproducts based MRP production orders.
Public property | MrpManufacturingOrderSeries | Gets or sets the default series code for MRP based manufacturing orders.
Public property | MrpProductionOrderSeries | Gets or sets the default series code for MRP based production orders.
Public property | PFDfltBatchStatus |
Public property | PFDfltQCBatchStatus |
Public property | PhantomsFormula | Gets or sets the default bill of materials formula for phantoms.
Public property | PostResourcesConfirmation | Gets or setrs If resources confirmation are posted
Public property | QcItemGroupCode | Gets or sets default item group code for QC items
Public property | QcResourceGroupCode | Gets or sets default item group code for QC resources.
Public property | ReceiptEvaluationType |
Public property | RevisionCode |
Public property | RevisionName |
Public property | SAPDfltBatchStatus |
Public property | SAPDfltQCBatchStatus |
Public property | ScrapFormula | Gets or sets the default bill of materials formula for scrap.
Public property | SerialNoTemplateCode | Gets or sets the default code of serial number template.
Public property | ShelfTime | Gets or sets the shelf time.
Public property | TimeFormat |
Public property | UseTcTotalPrice | Gets or sets the indication whether the TC Total price must be used during receiving the item on stock.
Top
Methods
 | Name | Description
Public method | Refresh |
Public method | UpdateConfiguration | Updates the configuration data of ProcessForce.
Top
See Also

Reference

IConfiguration Interface
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.DateFormat Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DateFormat() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DateFormat {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DateFormat {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DateFormat() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.TimeFormat Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property TimeFormat() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string TimeFormat {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ TimeFormat {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get TimeFormat() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IDownTimeReasonGroups.Code Property

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTimeReasonGroups Interface
IDownTimeReasonGroups Members
CompuTec.ProcessForce.API.Documents Namespace


IDownTimeReason Interface

Members See Also

Downtime reason object

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "DownTimeReason", TableName = "@CT_PF_ODTRS")> _
Public Interface IDownTimeReason
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "DownTimeReason", TableName = "@CT_PF_ODTRS")]
public interface IDownTimeReason : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "DownTimeReason", TableName = "@CT_PF_ODTRS")]
public interface class IDownTimeReason : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "DownTimeReason", TableName = "@CT_PF_ODTRS")
interface IDownTimeReason
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ODTRS
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTimeReason Members
CompuTec.ProcessForce.API.Documents Namespace


IDownTimeReason Members

IDownTimeReason Interface Methods Properties See Also

Downtime reason object

The following tables list the members exposed by the IDownTimeReason type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | GroupName |
Public property | Name |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ReasonGroup |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IDownTimeReason Interface
CompuTec.ProcessForce.API.Documents Namespace


IDownTimeReason.U_ReasonGroup Property

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(Required = true)> _
Property U_ReasonGroup() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]
string U_ReasonGroup {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(Required = true)]

property String^ U_ReasonGroup {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(Required = true)
function get U_ReasonGroup() : String;

   AppEngineProperty(Required = true)
function set U_ReasonGroup(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTimeReason Interface
IDownTimeReason Members
CompuTec.ProcessForce.API.Documents Namespace


IDownTimeReason.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTimeReason Interface
IDownTimeReason Members
CompuTec.ProcessForce.API.Documents Namespace


IDownTimeReason.GroupName Property

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property GroupName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string GroupName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ GroupName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get GroupName() : String;

   AppEnginePropertyIgnore()
function set GroupName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTimeReason Interface
IDownTimeReason Members
CompuTec.ProcessForce.API.Documents Namespace


IDownTimeReason.Name Property

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Name() : String;

   AppEnginePropertyIgnore()
function set Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTimeReason Interface
IDownTimeReason Members
CompuTec.ProcessForce.API.Documents Namespace


IConfiguration.DateTimeFomrat Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DateTimeFomrat() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string DateTimeFomrat {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ DateTimeFomrat {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DateTimeFomrat() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.SAPDfltBatchStatus Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property SAPDfltBatchStatus() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string SAPDfltBatchStatus {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ SAPDfltBatchStatus {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get SAPDfltBatchStatus() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.SAPDfltQCBatchStatus Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property SAPDfltQCBatchStatus() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string SAPDfltQCBatchStatus {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ SAPDfltQCBatchStatus {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get SAPDfltQCBatchStatus() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IReworkReason Interface

Members See Also

Rework reason object

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IReworkReason
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IReworkReason : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IReworkReason : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IReworkReason
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ORWRS
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReworkReason Members
CompuTec.ProcessForce.API.Documents Namespace


IReworkReason Members

IReworkReason Interface Methods Properties See Also

Rework reason object

The following tables list the members exposed by the IReworkReason type.

Properties
 | Name | Description
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | GroupName |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ReasonGroup |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IReworkReason Interface
CompuTec.ProcessForce.API.Documents Namespace


IReworkReason.U_ReasonGroup Property

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReasonGroup() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ReasonGroup {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ReasonGroup {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReasonGroup() : String;
function set U_ReasonGroup(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReworkReason Interface
IReworkReason Members
CompuTec.ProcessForce.API.Documents Namespace


IReworkReason.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReworkReason Interface
IReworkReason Members
CompuTec.ProcessForce.API.Documents Namespace


IReworkReason.GroupName Property

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property GroupName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string GroupName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ GroupName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get GroupName() : String;
function set GroupName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReworkReason Interface
IReworkReason Members
CompuTec.ProcessForce.API.Documents Namespace


IScrapReasonGroups Interface

Members See Also

Scaps for reason groups object

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IScrapReasonGroups
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IScrapReasonGroups : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IScrapReasonGroups : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IScrapReasonGroups
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OSCRG
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScrapReasonGroups Members
CompuTec.ProcessForce.API.Documents Namespace


IScrapReasonGroups Members

IScrapReasonGroups Interface Methods Properties See Also

Scaps for reason groups object

The following tables list the members exposed by the IScrapReasonGroups type.

Properties
 | Name | Description
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IScrapReasonGroups Interface
CompuTec.ProcessForce.API.Documents Namespace


IScrapReasons Interface

Members See Also

Scrap reasons object

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IScrapReasons
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IScrapReasons : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IScrapReasons : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IScrapReasons
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OSCRS
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScrapReasons Members
CompuTec.ProcessForce.API.Documents Namespace


IScrapReasons Members

IScrapReasons Interface Methods Properties See Also

Scrap reasons object

The following tables list the members exposed by the IScrapReasons type.

Properties
 | Name | Description
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | GroupName |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_ReasonGroup |
Public property | U_Remarks |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IScrapReasons Interface
CompuTec.ProcessForce.API.Documents Namespace


IConfiguration.PFDfltBatchStatus Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property PFDfltBatchStatus() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string PFDfltBatchStatus {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ PFDfltBatchStatus {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get PFDfltBatchStatus() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


BillOfMaterialsNotValidException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BillOfMaterialsNotValidException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BillOfMaterialsNotValidException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BillOfMaterialsNotValidException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialsNotValidException Class
BillOfMaterialsNotValidException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsNotValidException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BillOfMaterialsNotValidException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BillOfMaterialsNotValidException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BillOfMaterialsNotValidException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialsNotValidException Class
BillOfMaterialsNotValidException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsNotValidException(SerializationInfo, StreamingContext) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal serializationInfo As SerializationInfo, _
   ByVal streamingContext As StreamingContext _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BillOfMaterialsNotValidException(
   SerializationInfo serializationInfo,
   StreamingContext streamingContext
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BillOfMaterialsNotValidException(
   SerializationInfo^ serializationInfo,
   StreamingContext streamingContext
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BillOfMaterialsNotValidException(
    serializationInfo : SerializationInfo,
    streamingContext : StreamingContext
);
This language is not supported or no code example is available.

Parameters

serializationInfo

Type: SerializationInfo

streamingContext

Type: StreamingContext

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialsNotValidException Class
BillOfMaterialsNotValidException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsRevisionsMismmatchException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BillOfMaterialsRevisionsMismmatchException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BillOfMaterialsRevisionsMismmatchException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BillOfMaterialsRevisionsMismmatchException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialsRevisionsMismmatchException Class
BillOfMaterialsRevisionsMismmatchException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsRevisionsMismmatchException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BillOfMaterialsRevisionsMismmatchException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BillOfMaterialsRevisionsMismmatchException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BillOfMaterialsRevisionsMismmatchException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialsRevisionsMismmatchException Class
BillOfMaterialsRevisionsMismmatchException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IDownTimeReasonGroups Interface

Members See Also

Downtime reason groups object

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "DownTimeReasonGroup", TableName = "@CT_PF_ODTRG")> _
Public Interface IDownTimeReasonGroups
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "DownTimeReasonGroup", TableName = "@CT_PF_ODTRG")]
public interface IDownTimeReasonGroups : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "DownTimeReasonGroup", TableName = "@CT_PF_ODTRG")]
public interface class IDownTimeReasonGroups : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "DownTimeReasonGroup", TableName = "@CT_PF_ODTRG")
interface IDownTimeReasonGroups
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ODTRG
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTimeReasonGroups Members
CompuTec.ProcessForce.API.Documents Namespace


IDownTimeReasonGroups Members

IDownTimeReasonGroups Interface Methods Properties See Also

Downtime reason groups object

The following tables list the members exposed by the IDownTimeReasonGroups type.

Properties
 | Name | Description
Public property | Code |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Name |
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IDownTimeReasonGroups Interface
CompuTec.ProcessForce.API.Documents Namespace


IDownTimeReasonGroups.Name Property

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
function set Name(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTimeReasonGroups Interface
IDownTimeReasonGroups Members
CompuTec.ProcessForce.API.Documents Namespace


IDownTimeReason.Code Property

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get Code() : String;

   AppEngineProperty(IsMasterKey = true)
function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IDownTimeReason Interface
IDownTimeReason Members
CompuTec.ProcessForce.API.Documents Namespace


IReworkReasonGroups Interface

Members See Also

Groups for rework reason object

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IReworkReasonGroups
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IReworkReasonGroups : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IReworkReasonGroups : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IReworkReasonGroups
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_ORWRG
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IReworkReasonGroups Members
CompuTec.ProcessForce.API.Documents Namespace


IReworkReasonGroups Members

IReworkReasonGroups Interface Methods Properties See Also

Groups for rework reason object

The following tables list the members exposed by the IReworkReasonGroups type.

Properties
 | Name | Description
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IReworkReasonGroups Interface
CompuTec.ProcessForce.API.Documents Namespace


IScrapReasons.U_ReasonGroup Property

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReasonGroup() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ReasonGroup {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ReasonGroup {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReasonGroup() : String;
function set U_ReasonGroup(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScrapReasons Interface
IScrapReasons Members
CompuTec.ProcessForce.API.Documents Namespace


IScrapReasons.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScrapReasons Interface
IScrapReasons Members
CompuTec.ProcessForce.API.Documents Namespace


IScrapReasons.GroupName Property

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property GroupName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string GroupName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ GroupName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get GroupName() : String;
function set GroupName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IScrapReasons Interface
IScrapReasons Members
CompuTec.ProcessForce.API.Documents Namespace


BillOfMaterialsNotExistsException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BillOfMaterialsNotExistsException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BillOfMaterialsNotExistsException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BillOfMaterialsNotExistsException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialsNotExistsException Class
BillOfMaterialsNotExistsException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsNotExistsException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BillOfMaterialsNotExistsException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BillOfMaterialsNotExistsException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BillOfMaterialsNotExistsException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialsNotExistsException Class
BillOfMaterialsNotExistsException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsNotExistsException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BillOfMaterialsNotExistsException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BillOfMaterialsNotExistsException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BillOfMaterialsNotExistsException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialsNotExistsException Class
BillOfMaterialsNotExistsException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BillOfMaterialsNotValidException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BillOfMaterialsNotValidException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BillOfMaterialsNotValidException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BillOfMaterialsNotValidException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialsNotValidException Class
BillOfMaterialsNotValidException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IConfiguration.PFDfltQCBatchStatus Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property PFDfltQCBatchStatus() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string PFDfltQCBatchStatus {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ PFDfltQCBatchStatus {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get PFDfltQCBatchStatus() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


BillOfMaterialsRevisionsMismmatchException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BillOfMaterialsRevisionsMismmatchException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BillOfMaterialsRevisionsMismmatchException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BillOfMaterialsRevisionsMismmatchException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialsRevisionsMismmatchException Class
BillOfMaterialsRevisionsMismmatchException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


CantChangeBillOfMateriaCodeInThisStatusException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CantChangeBillOfMateriaCodeInThisStatusException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CantChangeBillOfMateriaCodeInThisStatusException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CantChangeBillOfMateriaCodeInThisStatusException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantChangeBillOfMateriaCodeInThisStatusException Class
CantChangeBillOfMateriaCodeInThisStatusException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


CantChangeBillOfMateriaCodeInThisStatusException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CantChangeBillOfMateriaCodeInThisStatusException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CantChangeBillOfMateriaCodeInThisStatusException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CantChangeBillOfMateriaCodeInThisStatusException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantChangeBillOfMateriaCodeInThisStatusException Class
CantChangeBillOfMateriaCodeInThisStatusException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


CantChangeBillOfMateriaCodeInThisStatusException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CantChangeBillOfMateriaCodeInThisStatusException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CantChangeBillOfMateriaCodeInThisStatusException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CantChangeBillOfMateriaCodeInThisStatusException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantChangeBillOfMateriaCodeInThisStatusException Class
CantChangeBillOfMateriaCodeInThisStatusException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


CantChangeRevisionRelatedTransactionDetectedException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CantChangeRevisionRelatedTransactionDetectedException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CantChangeRevisionRelatedTransactionDetectedException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CantChangeRevisionRelatedTransactionDetectedException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantChangeRevisionRelatedTransactionDetectedException Class
CantChangeRevisionRelatedTransactionDetectedException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


CantChangeRevisionRelatedTransactionDetectedException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CantChangeRevisionRelatedTransactionDetectedException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CantChangeRevisionRelatedTransactionDetectedException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CantChangeRevisionRelatedTransactionDetectedException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantChangeRevisionRelatedTransactionDetectedException Class
CantChangeRevisionRelatedTransactionDetectedException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


CantChangeRevisionRelatedTransactionDetectedException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CantChangeRevisionRelatedTransactionDetectedException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CantChangeRevisionRelatedTransactionDetectedException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CantChangeRevisionRelatedTransactionDetectedException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantChangeRevisionRelatedTransactionDetectedException Class
CantChangeRevisionRelatedTransactionDetectedException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


InvalidRevisionException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public InvalidRevisionException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
InvalidRevisionException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function InvalidRevisionException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InvalidRevisionException Class
InvalidRevisionException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


InvalidRevisionException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public InvalidRevisionException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
InvalidRevisionException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function InvalidRevisionException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InvalidRevisionException Class
InvalidRevisionException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceExistsForOperationException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceExistsForOperationException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceExistsForOperationException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceExistsForOperationException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceExistsForOperationException Class
ResourceExistsForOperationException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IConfiguration.EpiryEvaluationType Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property EpiryEvaluationType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string EpiryEvaluationType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ EpiryEvaluationType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get EpiryEvaluationType() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


ResourceExistsForOperationException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceExistsForOperationException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceExistsForOperationException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceExistsForOperationException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceExistsForOperationException Class
ResourceExistsForOperationException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceExistsForOperationException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceExistsForOperationException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceExistsForOperationException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceExistsForOperationException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceExistsForOperationException Class
ResourceExistsForOperationException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IConfiguration.EpiryEvaluationTemplate Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property EpiryEvaluationTemplate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string EpiryEvaluationTemplate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ EpiryEvaluationTemplate {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get EpiryEvaluationTemplate() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.RevisionCode Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RevisionCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string RevisionCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ RevisionCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RevisionCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.RevisionName Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property RevisionName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string RevisionName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ RevisionName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get RevisionName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.IsSapProductionMenuEnabled Property

Gets or sets the indication whether the standard functionalities of SAP Business One's Production menu are enabled (true) or disabled (false).

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property IsSapProductionMenuEnabled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool IsSapProductionMenuEnabled {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool IsSapProductionMenuEnabled {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get IsSapProductionMenuEnabled() : boolean;
function set IsSapProductionMenuEnabled(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.BatchTemplateCode Property

Gets or sets the default code of batch template.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BatchTemplateCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string BatchTemplateCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ BatchTemplateCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BatchTemplateCode() : String;
function set BatchTemplateCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.SerialNoTemplateCode Property

Gets or sets the default code of serial number template.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property SerialNoTemplateCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string SerialNoTemplateCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ SerialNoTemplateCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get SerialNoTemplateCode() : String;
function set SerialNoTemplateCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.BatchQueue Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BatchQueue() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string BatchQueue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ BatchQueue {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BatchQueue() : String;
function set BatchQueue(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.ItemsFormula Property

Gets or sets the default bill of materials formula for items.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ItemsFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string ItemsFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ ItemsFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ItemsFormula() : String;
function set ItemsFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.CoproductsFormula Property

Gets or sets the default bill of materials formula for coproducts.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property CoproductsFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string CoproductsFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ CoproductsFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CoproductsFormula() : String;
function set CoproductsFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.ScrapFormula Property

Gets or sets the default bill of materials formula for scrap.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ScrapFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string ScrapFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ ScrapFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ScrapFormula() : String;
function set ScrapFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IManufacturingOrder.CreateManufacturingOrdersForSemiProducts Method

This method Creates Manufacturing Orders For Semi Products

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CreateManufacturingOrdersForSemiProducts() As List(Of Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<int> CreateManufacturingOrdersForSemiProducts()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

List<int>^ CreateManufacturingOrdersForSemiProducts()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Return Value

Type: List<int>

List Of newly Created DocEntry`s

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IConfiguration.PhantomsFormula Property

Gets or sets the default bill of materials formula for phantoms.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property PhantomsFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string PhantomsFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ PhantomsFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get PhantomsFormula() : String;
function set PhantomsFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.Dflt_YieldFormula Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Dflt_YieldFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Dflt_YieldFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Dflt_YieldFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Dflt_YieldFormula() : String;
function set Dflt_YieldFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.IsProductTreesSynchronizationEnabled Property

Gets or sets the indication whether the synchronization between bill of materials and product trees is enabled (true) or disabled (false).

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property IsProductTreesSynchronizationEnabled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool IsProductTreesSynchronizationEnabled {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool IsProductTreesSynchronizationEnabled {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get IsProductTreesSynchronizationEnabled() : boolean;
function set IsProductTreesSynchronizationEnabled(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.AutoReceiptEnabled Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property AutoReceiptEnabled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool AutoReceiptEnabled {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool AutoReceiptEnabled {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get AutoReceiptEnabled() : boolean;
function set AutoReceiptEnabled(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IManufacturingOrder.CreateManufacturingOrdersForSemiProducts (Int32()) Method

Create ManufacturingOrders for semi product

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CreateManufacturingOrdersForSemiProducts( _
   ByVal rowLineNums As Integer() _
) As List(Of Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<int> CreateManufacturingOrdersForSemiProducts(
   int[] rowLineNums
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

List<int>^ CreateManufacturingOrdersForSemiProducts(
   array< int >^ rowLineNums
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

rowLineNums

Type: int[]

U_Linenum Items Collection You want to use for this creation

Return Value

Type: List<int>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IManufacturingOrder Interface
IManufacturingOrder Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IConfiguration.AutoIssueEnabled Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property AutoIssueEnabled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool AutoIssueEnabled {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool AutoIssueEnabled {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get AutoIssueEnabled() : boolean;
function set AutoIssueEnabled(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.IsProductionOrdersSynchronizationEnabled Property

Gets or sets the indication whether the synchronization between manufacturing orders and production orders is enabled (true) or disabled (false).

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property IsProductionOrdersSynchronizationEnabled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool IsProductionOrdersSynchronizationEnabled {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool IsProductionOrdersSynchronizationEnabled {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get IsProductionOrdersSynchronizationEnabled() : boolean;
function set IsProductionOrdersSynchronizationEnabled(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.Dflt_CoproductYieldFormula Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Dflt_CoproductYieldFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Dflt_CoproductYieldFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Dflt_CoproductYieldFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Dflt_CoproductYieldFormula() : String;
function set Dflt_CoproductYieldFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.Dflt_ScrapYieldFormula Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Dflt_ScrapYieldFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Dflt_ScrapYieldFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Dflt_ScrapYieldFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Dflt_ScrapYieldFormula() : String;
function set Dflt_ScrapYieldFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.Dflt_ItemYieldFormula Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Dflt_ItemYieldFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Dflt_ItemYieldFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Dflt_ItemYieldFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Dflt_ItemYieldFormula() : String;
function set Dflt_ItemYieldFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.IsLocationsSupportForDocumentsEnabled Property

Gets or sets the indication whether the locations support for SAP Business One's documents is enabled (true) or disabled (false).

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property IsLocationsSupportForDocumentsEnabled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool IsLocationsSupportForDocumentsEnabled {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool IsLocationsSupportForDocumentsEnabled {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get IsLocationsSupportForDocumentsEnabled() : boolean;
function set IsLocationsSupportForDocumentsEnabled(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IAdvancedUDOChildBean Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IAdvancedUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IAdvancedUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IAdvancedUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IAdvancedUDOChildBean
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdvancedUDOChildBean Members
CompuTec.ProcessForce.API.Core Namespace


IAdvancedUDOChildBean Members

IAdvancedUDOChildBean Interface Methods Properties See Also

The following tables list the members exposed by the IAdvancedUDOChildBean type.

Properties
 | Name | Description
Public property | Childs |
Public property | CurrentPosition |
Public property | IMasterBean |
Public property | Parent |
Top
Methods
 | Name | Description
Public method | IsRowFilled |
Top
See Also

Reference

IAdvancedUDOChildBean Interface
CompuTec.ProcessForce.API.Core Namespace


IAdvancedUDOChildBean.IMasterBean Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property IMasterBean() As IAdvancedUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IAdvancedUDOChildBean IMasterBean {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IAdvancedUDOChildBean^ IMasterBean {
 IAdvancedUDOChildBean^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get IMasterBean() : IAdvancedUDOChildBean;
This language is not supported or no code example is available.

Property Value

Type: IAdvancedUDOChildBean
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdvancedUDOChildBean Interface
IAdvancedUDOChildBean Members
CompuTec.ProcessForce.API.Core Namespace


IAdvancedUDOChildBean.CurrentPosition Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property CurrentPosition() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int CurrentPosition {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int CurrentPosition {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CurrentPosition() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdvancedUDOChildBean Interface
IAdvancedUDOChildBean Members
CompuTec.ProcessForce.API.Core Namespace


IAdvancedUDOChildBean.Childs Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Childs() As List(Of IUDOChildBean)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
List<IUDOChildBean> Childs {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property List<IUDOChildBean^>^ Childs {
 List<IUDOChildBean^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<IUDOChildBean>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdvancedUDOChildBean Interface
IAdvancedUDOChildBean Members
CompuTec.ProcessForce.API.Core Namespace


IAdvancedUDOChildBean.Parent Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Parent() As IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IUDOBean Parent {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IUDOBean^ Parent {
 IUDOBean^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Parent() : IUDOBean;
This language is not supported or no code example is available.

Property Value

Type: IUDOBean
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdvancedUDOChildBean Interface
IAdvancedUDOChildBean Members
CompuTec.ProcessForce.API.Core Namespace


IAdvancedUDOChildBean.IsRowFilled Method

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function IsRowFilled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool IsRowFilled()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool IsRowFilled()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function IsRowFilled() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdvancedUDOChildBean Interface
IAdvancedUDOChildBean Members
CompuTec.ProcessForce.API.Core Namespace


ObjectTypes Enumeration

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
CrystalManager |
ResourceGroup |
ResourceProperty |
Resource |
Routing |
Operation |
OperationProperty |
ManufacturingOrder |
BillOfMaterial |
ItemDetails |
LicensePlate |
InOutProperty |
Team |
LicensePlateGroup |
Shift |
CapacityCalendar |
SimpleProductionPlanning |
DraftDocumentAuthorization |
PickOrder |
PickReceipt |
LocationInventoryData |
ItemMasterDataAvailableLocation |
ItemPropertyGroup |
ItemClassificationGroup |
ItemClassification |
ItemProperty |
Wordbook |
ItemPhrases |
ItemPhrasesGroup |
ItemGroup |
ItemGroupGroup |
ItemText |
ItemTextGroup |
Defect |
DefectGroup |
Reason |
ReasonGroup |
Inspector |
InspectorGroup |
TestProperty |
TestPropertyGroup |
TestProtocol |
TestProtocolGroup |
TestProtocolTemplate |
PlateReferences |
LocationAvailability |
Label |
LocationMasterData |
PrinterMasterData |
PrintLabelDefinition |
HelpConfig |
WorkRegistration |
BatchTemplate |
SerialTemplate |
AdditionalJournalEntries |
CostCategory |
CostingConfiguration |
LabourGroup |
LocationAttribute |
ReasonCodes |
ReasonGroups |
LocationQueue |
OrderRecommendation |
AdditionalBatchDetails |
IngredientCategory |
Allergen |
IngredientMasterData |
IngredientDailyValue |
IngredientTemplate |
InspectorNcmr |
ReasonNcmr |
ComplaintGroup |
ComplaintReason |
Complaint |
QualityControlTest |
NcmrTransaction |
OperationTimeRecording |
OperationTimeRecordingAdjustment |
CostingCostCategory |
ItemCosting |
ResourceCosting |
CalendarTemplate |
ResourceCalendar |
InventoryRegistry |
ResourcesAccounting |
EmployeeCalendar |
IngredientClassificationType |
IngredientClassification |
Nutrient |
ItemIngredientData |
ResourceAccounting |
DownTimeReasonGroup |
ScrapReasonGroup |
ReworkReasonGroup |
DownTimeReason |
ScrapReason |
ReworkReason |
DownTime |
TimeTempRegEntry |
OperationCheckList |
ResourceCheckList |
PreferredVendors |
VehicleInspection |
VehicleInspectionGroup |
VehicleInspectionReasons |
ManufacturingOrderSeriesConfiguration |
ExpiryDateEvalTemplate |
Substitutes |
OrderlessProductionTemplate |
OrderlessProduction |
QualityControlTest2 |
ItemPropertyCheckList |
SupplierScoreCard |
ItemOrigins |
TimeQuantityRegistration |
PlanningNormalization |
CostsComparison |
PDCSettings |
Class |
Category |
PDCLog |
WeightDocument |
WeightDocumentLine |
WeightLog |
ResourceCalendarStandardHours |
InputOutputCheckList |
QualityControlTestPool |
ManufacturingRelations |
ActionFact |
Forecast |
Scenario |
MRPOrderRecomendation |
See Also

Reference

CompuTec.ProcessForce.API.Core Namespace


CompuTec.ProcessForce.API.Enumerators Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Enumerations
 | Name | Description
Public enumeration | BatchQueueType |
Public enumeration | CardType |
Public enumeration | ConditionType | Conditions for properies
Public enumeration | DownTimeStatus |
Public enumeration | ExpiryDateEvaluation |
Public enumeration | FormulaType |
Public enumeration | IssueType |
Public enumeration | ItemDirection | Typ Of Item direction Used on Bom and Mor on RoutingOperataionInOut
Public enumeration | ItemOriginType |
Public enumeration | MRPConsumtionMethod |
Public enumeration | MRPMode |
Public enumeration | MRPPeriod |
Public enumeration | MRPRecomendationInventoryLevel |
Public enumeration | MRPSortBy |
Public enumeration | MRPStatus |
Public enumeration | MRPType |
Public enumeration | ManufacturingComponentType | Manufaturing Components Types Enumerator
Public enumeration | ManufacturingOrderStatus |
Public enumeration | OperationRelationType |
Public enumeration | PickStatus |
Public enumeration | ProcurmentDocumentType |
Public enumeration | ProductionType |
Public enumeration | RateType | Rate Types For Resource And Operaion Times
Public enumeration | ReceiptEvaluationType |
Public enumeration | RecordingTimeType |
Public enumeration | ResourceType |
Public enumeration | ScrapType |
Public enumeration | WeightDocumentLineStatus |
Public enumeration | WeightDocumentStatus |
Public enumeration | YesNoType |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


BatchQueueType Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
FIFO |
FEFO |
FMFO |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


CardType Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
cCustomer |
cSupplier |
cLid |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


ConditionType Enumeration

Conditions for properies

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Equal | EQ
NotEqual | NE
GratherThan | GT
GratherThanOrEqual | GE
LessThan | LT
LessThanOrEqual | LE
Between | BT
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


DownTimeStatus Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Reported |
InProgress |
Working |
Fixed |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


ExpiryDateEvaluation Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
StartDate |
RequiredDate |
EndDate |
CreateDate |
CurrentDate |
Query |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


ItemDirection Enumeration

Typ Of Item direction Used on Bom and Mor on RoutingOperataionInOut

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
In | Input Item in I
Out | Output Item O
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


ItemOriginType Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
BOM |
Phantom |
PhantomBom |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


MRPConsumtionMethod Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
backwardForward |
forwardBackward |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


FormulaType Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
ItemsFormula |
CoProductFormula |
ScrapFormula |
PhantomFormula |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


MRPRecomendationInventoryLevel Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Required |
Minimum |
Maximum |
MinMax |
None |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


OperationRelationType Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
None |
LastFinish |
FirstFinish |
StartingOperation |
Overloading |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


RateType Enumeration

Rate Types For Resource And Operaion Times

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
FixedSeconds |
FixedMinutes |
FixedHours |
SecondsPerPiece |
MinutesPerPiece |
HoursPerPiece |
PiecesPerSecond |
PiecesPerMinute |
PiecesPerHour |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


RecordingTimeType Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
QueueTime |
StockTime |
RunTime |
SetupTime |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


ResourceType Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Machine |
Labour |
Tool |
Subcontractor |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


WeightDocumentStatus Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Started |
Finished |
Closed |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


YesNoType Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Yes |
No |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


IssueType Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Manual |
BackFlush |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


AdditionalBatchDetailsGenerator.RestoreBatchDetails (String, Int32, Int32) Method

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function RestoreBatchDetails( _
   ByVal Token As String, _
   ByVal docEntry As Integer, _
   ByVal objectType As Integer _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Result RestoreBatchDetails(
   string Token,
   int docEntry,
   int objectType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static Result^ RestoreBatchDetails(
   String^ Token,
   int docEntry,
   int objectType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function RestoreBatchDetails(
    Token : String,
    docEntry : int,
    objectType : int
) : Result;
This language is not supported or no code example is available.

Parameters

Token

Type: string

docEntry

Type: int

objectType

Type: int

Return Value

Type: Result
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AdditionalBatchDetailsGenerator Class
AdditionalBatchDetailsGenerator Members
CompuTec.ProcessForce.API.Generators Namespace


AdditionalBatchDetailsGenerator.ReplicateBatchDetails Method

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function ReplicateBatchDetails( _
   ByVal Token As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool ReplicateBatchDetails(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool ReplicateBatchDetails(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function ReplicateBatchDetails(
    Token : String
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AdditionalBatchDetailsGenerator Class
AdditionalBatchDetailsGenerator Members
CompuTec.ProcessForce.API.Generators Namespace


BatchDetailsService Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BatchDetailsService
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BatchDetailsService
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BatchDetailsService
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BatchDetailsService
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Generators.BatchDetailsService
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchDetailsService Members
CompuTec.ProcessForce.API.Generators Namespace


BatchDetailsService Members

BatchDetailsService Class Methods See Also

The following tables list the members exposed by the BatchDetailsService type.

Methods
 | Name | Description
Public method | CreateAditionalBatchDetailsForDocument |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | RestoreBatchDetails | Restores BatchDetailsObject
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

BatchDetailsService Class
CompuTec.ProcessForce.API.Generators Namespace


BatchDetailsService.RestoreBatchDetails Method

Restores BatchDetailsObject

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub RestoreBatchDetails()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void RestoreBatchDetails()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void RestoreBatchDetails()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RestoreBatchDetails();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchDetailsService Class
BatchDetailsService Members
CompuTec.ProcessForce.API.Generators Namespace


BatchDetailsService.CreateAditionalBatchDetailsForDocument Method

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CreateAditionalBatchDetailsForDocument( _
   ByVal DocEntry As Integer, _
   ByVal ObjectType As Integer _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Result CreateAditionalBatchDetailsForDocument(
   int DocEntry,
   int ObjectType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Result^ CreateAditionalBatchDetailsForDocument(
   int DocEntry,
   int ObjectType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CreateAditionalBatchDetailsForDocument(
    DocEntry : int,
    ObjectType : int
) : Result;
This language is not supported or no code example is available.

Parameters

DocEntry

Type: int

ObjectType

Type: int

Return Value

Type: Result
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchDetailsService Class
BatchDetailsService Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BatchNumberGeneratedResults
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BatchNumberGeneratedResults
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BatchNumberGeneratedResults
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BatchNumberGeneratedResults
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Generators.BatchNumberGeneratedResults
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults Members

BatchNumberGeneratedResults Class Methods Properties See Also

The following tables list the members exposed by the BatchNumberGeneratedResults type.

Properties
 | Name | Description
Public property | BestBeforeDate |
Public property | ConsumeDate |
Public property | DistNumber |
Public property | ExpiryDate |
Public property | ExpiryTime |
Public property | InspectionDate |
Public property | LastInspectionDate |
Public property | NextInspectionDate |
Public property | Origin |
Public property | QCStatus |
Public property | QCStatusStr |
Public property | Revision |
Public property | RevisionDscription |
Public property | SAPStatus |
Public property | Status |
Public property | StatusStr |
Public property | SuppNumber |
Public property | WarningConsumeDate |
Public property | WarningExpiryDate |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

BatchNumberGeneratedResults Class
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults.WarningExpiryDate Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property WarningExpiryDate() As Date
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime WarningExpiryDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime WarningExpiryDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get WarningExpiryDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Class
BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults.QCStatus Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property QCStatus() As QCStatus
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QCStatus QCStatus {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property QCStatus QCStatus {
 QCStatus get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get QCStatus() : QCStatus;
This language is not supported or no code example is available.

Property Value

Type: QCStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Class
BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults.SuppNumber Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SuppNumber() As String
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string SuppNumber {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ SuppNumber {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SuppNumber() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Class
BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults.Origin Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Origin() As String
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Origin {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Origin {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Origin() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Class
BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults.BestBeforeDate Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property BestBeforeDate() As Date
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime BestBeforeDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime BestBeforeDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get BestBeforeDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Class
BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults.QCStatusStr Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property QCStatusStr() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string QCStatusStr {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ QCStatusStr {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get QCStatusStr() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Class
BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


AlreadyDefinedAdditionalBatchDetailException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public AlreadyDefinedAdditionalBatchDetailException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
AlreadyDefinedAdditionalBatchDetailException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function AlreadyDefinedAdditionalBatchDetailException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AlreadyDefinedAdditionalBatchDetailException Class
AlreadyDefinedAdditionalBatchDetailException Members
CompuTec.ProcessForce.API.Generators Namespace


AlreadyDefinedAdditionalBatchDetailException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public AlreadyDefinedAdditionalBatchDetailException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
AlreadyDefinedAdditionalBatchDetailException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function AlreadyDefinedAdditionalBatchDetailException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AlreadyDefinedAdditionalBatchDetailException Class
AlreadyDefinedAdditionalBatchDetailException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchGenaratorClassificationNotFoundException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class BatchGenaratorClassificationNotFoundException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class BatchGenaratorClassificationNotFoundException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class BatchGenaratorClassificationNotFoundException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class BatchGenaratorClassificationNotFoundException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Generators.BatchGenaratorClassificationNotFoundException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchGenaratorClassificationNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchGenaratorClassificationNotFoundException Members

BatchGenaratorClassificationNotFoundException Class Constructors Methods Properties See Also

The following tables list the members exposed by the BatchGenaratorClassificationNotFoundException type.

Constructors
 | Name | Description
Public constructor | BatchGenaratorClassificationNotFoundException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BatchGenaratorClassificationNotFoundException Class
CompuTec.ProcessForce.API.Generators Namespace


BatchGenaratorClassificationNotFoundException Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchGenaratorClassificationNotFoundException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchGenaratorClassificationNotFoundException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchGenaratorClassificationNotFoundException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchGenaratorClassificationNotFoundException Class
BatchGenaratorClassificationNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchGenaratorClassificationNotFoundException Constructor

BatchGenaratorClassificationNotFoundException Class See Also

Overload List
Name | Description
BatchGenaratorClassificationNotFoundException() |
BatchGenaratorClassificationNotFoundException(string) |
BatchGenaratorClassificationNotFoundException(string, Exception) |
See Also

Reference

BatchGenaratorClassificationNotFoundException Class
BatchGenaratorClassificationNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchGenaratorClassificationNotFoundException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchGenaratorClassificationNotFoundException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchGenaratorClassificationNotFoundException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchGenaratorClassificationNotFoundException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchGenaratorClassificationNotFoundException Class
BatchGenaratorClassificationNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchGenaratorClassificationNotFoundException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchGenaratorClassificationNotFoundException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchGenaratorClassificationNotFoundException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchGenaratorClassificationNotFoundException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchGenaratorClassificationNotFoundException Class
BatchGenaratorClassificationNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


ManufacturingComponentType Enumeration

Manufaturing Components Types Enumerator

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Item | IT
Cooproduct | CP
Scrap | SC
Phantom | PH
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


ManufacturingOrderStatus Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
NotScheduled |
Scheduled |
Released |
Started |
Finished |
Closed |
Created |
NotSet |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


MRPMode Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
ByCompany |
RunByWarehouse |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


MRPPeriod Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Month |
Week |
Day |
Hour |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


MRPSortBy Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
AssemblySequence |
ItemNumber |
ItemDescription |
ItemGroup |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


MRPStatus Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
NotRunned |
Running |
Completed |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


MRPType Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Make |
Buy |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


PickStatus Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Open |
Started |
Closed |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


ProcurmentDocumentType Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Order |
Request |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


ProductionType Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Internal |
External |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


ReceiptEvaluationType Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Costing |
ItemCosting |
Dynamic |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


ScrapType Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Technological |
Usefull |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


WeightDocumentLineStatus Enumeration

Namespace: CompuTec.ProcessForce.API.Enumerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Active |
Removed |
See Also

Reference

CompuTec.ProcessForce.API.Enumerators Namespace


CompuTec.ProcessForce.API.Exceptons Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | DatabaseVersionNotSupportedException |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


DatabaseVersionNotSupportedException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Exceptons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class DatabaseVersionNotSupportedException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class DatabaseVersionNotSupportedException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class DatabaseVersionNotSupportedException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class DatabaseVersionNotSupportedException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Exceptons.DatabaseVersionNotSupportedException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DatabaseVersionNotSupportedException Members
CompuTec.ProcessForce.API.Exceptons Namespace


DatabaseVersionNotSupportedException Members

DatabaseVersionNotSupportedException Class Constructors Methods Properties See Also

The following tables list the members exposed by the DatabaseVersionNotSupportedException type.

Constructors
 | Name | Description
Public constructor | DatabaseVersionNotSupportedException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

DatabaseVersionNotSupportedException Class
CompuTec.ProcessForce.API.Exceptons Namespace


DatabaseVersionNotSupportedException Constructor

Namespace: CompuTec.ProcessForce.API.Exceptons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DatabaseVersionNotSupportedException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DatabaseVersionNotSupportedException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DatabaseVersionNotSupportedException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DatabaseVersionNotSupportedException Class
DatabaseVersionNotSupportedException Members
CompuTec.ProcessForce.API.Exceptons Namespace


DatabaseVersionNotSupportedException Constructor

DatabaseVersionNotSupportedException Class See Also

Overload List
Name | Description
DatabaseVersionNotSupportedException() |
DatabaseVersionNotSupportedException(string) |
DatabaseVersionNotSupportedException(string, Exception) |
See Also

Reference

DatabaseVersionNotSupportedException Class
DatabaseVersionNotSupportedException Members
CompuTec.ProcessForce.API.Exceptons Namespace


DatabaseVersionNotSupportedException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Exceptons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DatabaseVersionNotSupportedException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DatabaseVersionNotSupportedException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DatabaseVersionNotSupportedException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DatabaseVersionNotSupportedException Class
DatabaseVersionNotSupportedException Members
CompuTec.ProcessForce.API.Exceptons Namespace


DatabaseVersionNotSupportedException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Exceptons
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DatabaseVersionNotSupportedException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DatabaseVersionNotSupportedException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DatabaseVersionNotSupportedException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DatabaseVersionNotSupportedException Class
DatabaseVersionNotSupportedException Members
CompuTec.ProcessForce.API.Exceptons Namespace


CompuTec.ProcessForce.API.Generators Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | AdditionalBatchDetailsGenerator |
Public class | AlreadyDefinedAdditionalBatchDetailException |
Public class | BatchDetailsService |
Public class | BatchGenaratorClassificationNotFoundException |
Public class | BatchGenaratorExpressionToLongException |
Public class | BatchGeneratorEmptyItemCodeException |
Public class | BatchNumberGeneratedResults |
Public class | BatchNumberGenerator |
Public class | BatchTemplateGenerationFailedException |
Public class | BatchTemplateIncorrectDateFormatException |
Public class | BatchTemplateNotFoundException |
Public class | ExpiryDateGenerationException |
Public class | ExpiryDateGenerator |
Public class | ItemDetailsNotFoundException |
Public class | QCTestDocumentsGenerator |
Public class | QCTestDocumentsGeneratorDocEntryIsZeroException |
Public class | QCTestDocumentsGeneratorDocumentTypeNotSupportedException |
Public class | QCTestDocumentsGeneratorEmptyDocumentTypeException |
Public class | QCTestDocumentsGeneratorItemsNotFoundException |
Public class | QCTestDocumentsGeneratorSystemException |
Public class | ZeroQuantityForSpecificBatchException |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


AdditionalBatchDetailsGenerator Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class AdditionalBatchDetailsGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class AdditionalBatchDetailsGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class AdditionalBatchDetailsGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class AdditionalBatchDetailsGenerator
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Generators.AdditionalBatchDetailsGenerator
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AdditionalBatchDetailsGenerator Members
CompuTec.ProcessForce.API.Generators Namespace


AdditionalBatchDetailsGenerator Members

AdditionalBatchDetailsGenerator Class Methods See Also

The following tables list the members exposed by the AdditionalBatchDetailsGenerator type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetStatus |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | ReplicateBatchDetails |
 | RestoreBatchDetails | (Overloaded)
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

AdditionalBatchDetailsGenerator Class
CompuTec.ProcessForce.API.Generators Namespace


AdditionalBatchDetailsGenerator.GetStatus Method

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetStatus( _
   ByVal status As QCAction _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetStatus(
   QCAction status
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetStatus(
   QCAction status
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetStatus(
    status : QCAction
) : String;
This language is not supported or no code example is available.

Parameters

status

Type: QCAction

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AdditionalBatchDetailsGenerator Class
AdditionalBatchDetailsGenerator Members
CompuTec.ProcessForce.API.Generators Namespace


AdditionalBatchDetailsGenerator.RestoreBatchDetails (String) Method

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function RestoreBatchDetails( _
   ByVal Token As String _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Result RestoreBatchDetails(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static Result^ RestoreBatchDetails(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function RestoreBatchDetails(
    Token : String
) : Result;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: Result
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AdditionalBatchDetailsGenerator Class
AdditionalBatchDetailsGenerator Members
CompuTec.ProcessForce.API.Generators Namespace


AdditionalBatchDetailsGenerator.RestoreBatchDetails Method

AdditionalBatchDetailsGenerator Class See Also

Overload List
Name | Description
RestoreBatchDetails(string) |
RestoreBatchDetails(string, int, int) |
See Also

Reference

AdditionalBatchDetailsGenerator Class
AdditionalBatchDetailsGenerator Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults.Revision Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Revision() As String
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Revision {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Revision {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Revision() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Class
BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults.RevisionDscription Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property RevisionDscription() As String
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string RevisionDscription {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ RevisionDscription {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get RevisionDscription() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Class
BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults.DistNumber Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DistNumber() As String
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DistNumber {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DistNumber {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DistNumber() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Class
BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults.ExpiryDate Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ExpiryDate() As Date
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime ExpiryDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime ExpiryDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ExpiryDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Class
BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults.ExpiryTime Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property ExpiryTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime ExpiryTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime ExpiryTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ExpiryTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Class
BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults.InspectionDate Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property InspectionDate() As Date
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime InspectionDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime InspectionDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get InspectionDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Class
BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults.NextInspectionDate Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property NextInspectionDate() As Date
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime NextInspectionDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime NextInspectionDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get NextInspectionDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Class
BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults.LastInspectionDate Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property LastInspectionDate() As Date
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime LastInspectionDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime LastInspectionDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get LastInspectionDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Class
BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults.ConsumeDate Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ConsumeDate() As Date
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime ConsumeDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime ConsumeDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ConsumeDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Class
BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults.WarningConsumeDate Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property WarningConsumeDate() As Date
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime WarningConsumeDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime WarningConsumeDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get WarningConsumeDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Class
BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults.Status Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Status() As BatchStatus
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchStatus Status {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property BatchStatus Status {
 BatchStatus get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Status() : BatchStatus;
This language is not supported or no code example is available.

Property Value

Type: BatchStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Class
BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults.StatusStr Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property StatusStr() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string StatusStr {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ StatusStr {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get StatusStr() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Class
BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGeneratedResults.SAPStatus Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property SAPStatus() As BoDefaultBatchStatus
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BoDefaultBatchStatus SAPStatus {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property BoDefaultBatchStatus SAPStatus {
 BoDefaultBatchStatus get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SAPStatus() : BoDefaultBatchStatus;
This language is not supported or no code example is available.

Property Value

Type: BoDefaultBatchStatus
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGeneratedResults Class
BatchNumberGeneratedResults Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGenerator Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BatchNumberGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BatchNumberGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BatchNumberGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BatchNumberGenerator
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Generators.BatchNumberGenerator
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGenerator Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGenerator Members

BatchNumberGenerator Class Methods See Also

The following tables list the members exposed by the BatchNumberGenerator type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | GenerateBatch | (Overloaded)
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

BatchNumberGenerator Class
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGenerator.GenerateBatch (String, String, String, String, String) Method

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GenerateBatch( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal Classification As String, _
   Optional ByVal MORNumber As String = "", _
   Optional ByVal PickNumber As String = "" _
) As Tuple(Of String, String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Tuple<string, string> GenerateBatch(
   string Token,
   string ItemCode,
   string Classification,
   string MORNumber = "",
   string PickNumber = ""
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static Tuple<String^, String^>^ GenerateBatch(
   String^ Token,
   String^ ItemCode,
   String^ Classification,
   String^ MORNumber,
   String^ PickNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Classification

Type: string

MORNumber

Type: string

PickNumber

Type: string

Return Value

Type: Tuple<string, string>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGenerator Class
BatchNumberGenerator Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGenerator.GenerateBatch Method

BatchNumberGenerator Class See Also

Overload List
Name | Description
GenerateBatch(string, string, string, string, string, bool, string, string) |
GenerateBatch(string, string, string, string, string, int, bool, string, string) |
GenerateBatch(string, string, string, int, string, string) |
GenerateBatch(string, string, string, string, string) |
See Also

Reference

BatchNumberGenerator Class
BatchNumberGenerator Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGenerator.GenerateBatch (String, String, String, Int32, String, String) Method

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GenerateBatch( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal Classification As String, _
   ByVal numberofbatches As Integer, _
   Optional ByVal MORNumber As String = "", _
   Optional ByVal PickNumber As String = "" _
) As List(Of Tuple(Of String, String))
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static List<Tuple<string, string>> GenerateBatch(
   string Token,
   string ItemCode,
   string Classification,
   int numberofbatches,
   string MORNumber = "",
   string PickNumber = ""
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static List<Tuple<String^, String^>^>^ GenerateBatch(
   String^ Token,
   String^ ItemCode,
   String^ Classification,
   int numberofbatches,
   String^ MORNumber,
   String^ PickNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Classification

Type: string

numberofbatches

Type: int

MORNumber

Type: string

PickNumber

Type: string

Return Value

Type: List<Tuple<string, string>>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGenerator Class
BatchNumberGenerator Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGenerator.GenerateBatch (String, String, String, String, String, Boolean, String, String) Method

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GenerateBatch( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal Classification As String, _
   ByVal revisionCode As String, _
   ByVal revisionDscription As String, _
   Optional ByVal SAPDocument As Boolean = true, _
   Optional ByVal MORNumber As String = "", _
   Optional ByVal PickNumber As String = "" _
) As BatchNumberGeneratedResults
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static BatchNumberGeneratedResults GenerateBatch(
   string Token,
   string ItemCode,
   string Classification,
   string revisionCode,
   string revisionDscription,
   bool SAPDocument = true,
   string MORNumber = "",
   string PickNumber = ""
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static BatchNumberGeneratedResults^ GenerateBatch(
   String^ Token,
   String^ ItemCode,
   String^ Classification,
   String^ revisionCode,
   String^ revisionDscription,
   bool SAPDocument,
   String^ MORNumber,
   String^ PickNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GenerateBatch(
    Token : String,
    ItemCode : String,
    Classification : String,
    revisionCode : String,
    revisionDscription : String,
    SAPDocument : boolean,
    MORNumber : String,
    PickNumber : String
) : BatchNumberGeneratedResults;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Classification

Type: string

revisionCode

Type: string

revisionDscription

Type: string

SAPDocument

Type: bool

MORNumber

Type: string

PickNumber

Type: string

Return Value

Type: BatchNumberGeneratedResults
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGenerator Class
BatchNumberGenerator Members
CompuTec.ProcessForce.API.Generators Namespace


BatchNumberGenerator.GenerateBatch (String, String, String, String, String, Int32, Boolean, String, String) Method

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GenerateBatch( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal Classification As String, _
   ByVal revisionCode As String, _
   ByVal revisionDscription As String, _
   ByVal numberOfBatches As Integer, _
   Optional ByVal SAPDocument As Boolean = true, _
   Optional ByVal MORNumber As String = "", _
   Optional ByVal PickNumber As String = "" _
) As List(Of BatchNumberGeneratedResults)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static List<BatchNumberGeneratedResults> GenerateBatch(
   string Token,
   string ItemCode,
   string Classification,
   string revisionCode,
   string revisionDscription,
   int numberOfBatches,
   bool SAPDocument = true,
   string MORNumber = "",
   string PickNumber = ""
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static List<BatchNumberGeneratedResults^>^ GenerateBatch(
   String^ Token,
   String^ ItemCode,
   String^ Classification,
   String^ revisionCode,
   String^ revisionDscription,
   int numberOfBatches,
   bool SAPDocument,
   String^ MORNumber,
   String^ PickNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Classification

Type: string

revisionCode

Type: string

revisionDscription

Type: string

numberOfBatches

Type: int

SAPDocument

Type: bool

MORNumber

Type: string

PickNumber

Type: string

Return Value

Type: List<BatchNumberGeneratedResults>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberGenerator Class
BatchNumberGenerator Members
CompuTec.ProcessForce.API.Generators Namespace


AlreadyDefinedAdditionalBatchDetailException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class AlreadyDefinedAdditionalBatchDetailException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class AlreadyDefinedAdditionalBatchDetailException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class AlreadyDefinedAdditionalBatchDetailException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class AlreadyDefinedAdditionalBatchDetailException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Generators.AlreadyDefinedAdditionalBatchDetailException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AlreadyDefinedAdditionalBatchDetailException Members
CompuTec.ProcessForce.API.Generators Namespace


AlreadyDefinedAdditionalBatchDetailException Members

AlreadyDefinedAdditionalBatchDetailException Class Constructors Methods Properties See Also

The following tables list the members exposed by the AlreadyDefinedAdditionalBatchDetailException type.

Constructors
 | Name | Description
Public constructor | AlreadyDefinedAdditionalBatchDetailException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

AlreadyDefinedAdditionalBatchDetailException Class
CompuTec.ProcessForce.API.Generators Namespace


AlreadyDefinedAdditionalBatchDetailException Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public AlreadyDefinedAdditionalBatchDetailException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
AlreadyDefinedAdditionalBatchDetailException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function AlreadyDefinedAdditionalBatchDetailException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AlreadyDefinedAdditionalBatchDetailException Class
AlreadyDefinedAdditionalBatchDetailException Members
CompuTec.ProcessForce.API.Generators Namespace


AlreadyDefinedAdditionalBatchDetailException Constructor

AlreadyDefinedAdditionalBatchDetailException Class See Also

Overload List
Name | Description
AlreadyDefinedAdditionalBatchDetailException() |
AlreadyDefinedAdditionalBatchDetailException(string) |
AlreadyDefinedAdditionalBatchDetailException(string, Exception) |
See Also

Reference

AlreadyDefinedAdditionalBatchDetailException Class
AlreadyDefinedAdditionalBatchDetailException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchGenaratorExpressionToLongException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class BatchGenaratorExpressionToLongException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class BatchGenaratorExpressionToLongException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class BatchGenaratorExpressionToLongException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class BatchGenaratorExpressionToLongException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Generators.BatchGenaratorExpressionToLongException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchGenaratorExpressionToLongException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchGenaratorExpressionToLongException Members

BatchGenaratorExpressionToLongException Class Constructors Methods Properties See Also

The following tables list the members exposed by the BatchGenaratorExpressionToLongException type.

Constructors
 | Name | Description
Public constructor | BatchGenaratorExpressionToLongException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BatchGenaratorExpressionToLongException Class
CompuTec.ProcessForce.API.Generators Namespace


BatchGenaratorExpressionToLongException Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchGenaratorExpressionToLongException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchGenaratorExpressionToLongException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchGenaratorExpressionToLongException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchGenaratorExpressionToLongException Class
BatchGenaratorExpressionToLongException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchGenaratorExpressionToLongException Constructor

BatchGenaratorExpressionToLongException Class See Also

Overload List
Name | Description
BatchGenaratorExpressionToLongException() |
BatchGenaratorExpressionToLongException(string) |
BatchGenaratorExpressionToLongException(string, Exception) |
See Also

Reference

BatchGenaratorExpressionToLongException Class
BatchGenaratorExpressionToLongException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchGenaratorExpressionToLongException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchGenaratorExpressionToLongException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchGenaratorExpressionToLongException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchGenaratorExpressionToLongException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchGenaratorExpressionToLongException Class
BatchGenaratorExpressionToLongException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchGenaratorExpressionToLongException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchGenaratorExpressionToLongException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchGenaratorExpressionToLongException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchGenaratorExpressionToLongException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchGenaratorExpressionToLongException Class
BatchGenaratorExpressionToLongException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchGeneratorEmptyItemCodeException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class BatchGeneratorEmptyItemCodeException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class BatchGeneratorEmptyItemCodeException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class BatchGeneratorEmptyItemCodeException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class BatchGeneratorEmptyItemCodeException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Generators.BatchGeneratorEmptyItemCodeException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchGeneratorEmptyItemCodeException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchGeneratorEmptyItemCodeException Members

BatchGeneratorEmptyItemCodeException Class Constructors Methods Properties See Also

The following tables list the members exposed by the BatchGeneratorEmptyItemCodeException type.

Constructors
 | Name | Description
Public constructor | BatchGeneratorEmptyItemCodeException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BatchGeneratorEmptyItemCodeException Class
CompuTec.ProcessForce.API.Generators Namespace


BatchGeneratorEmptyItemCodeException Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchGeneratorEmptyItemCodeException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchGeneratorEmptyItemCodeException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchGeneratorEmptyItemCodeException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchGeneratorEmptyItemCodeException Class
BatchGeneratorEmptyItemCodeException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchGeneratorEmptyItemCodeException Constructor

BatchGeneratorEmptyItemCodeException Class See Also

Overload List
Name | Description
BatchGeneratorEmptyItemCodeException() |
BatchGeneratorEmptyItemCodeException(string) |
BatchGeneratorEmptyItemCodeException(string, Exception) |
See Also

Reference

BatchGeneratorEmptyItemCodeException Class
BatchGeneratorEmptyItemCodeException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchGeneratorEmptyItemCodeException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchGeneratorEmptyItemCodeException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchGeneratorEmptyItemCodeException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchGeneratorEmptyItemCodeException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchGeneratorEmptyItemCodeException Class
BatchGeneratorEmptyItemCodeException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchGeneratorEmptyItemCodeException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchGeneratorEmptyItemCodeException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchGeneratorEmptyItemCodeException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchGeneratorEmptyItemCodeException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchGeneratorEmptyItemCodeException Class
BatchGeneratorEmptyItemCodeException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchTemplateGenerationFailedException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class BatchTemplateGenerationFailedException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class BatchTemplateGenerationFailedException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class BatchTemplateGenerationFailedException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class BatchTemplateGenerationFailedException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Generators.BatchTemplateGenerationFailedException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchTemplateGenerationFailedException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchTemplateGenerationFailedException Members

BatchTemplateGenerationFailedException Class Constructors Methods Properties See Also

The following tables list the members exposed by the BatchTemplateGenerationFailedException type.

Constructors
 | Name | Description
Public constructor | BatchTemplateGenerationFailedException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BatchTemplateGenerationFailedException Class
CompuTec.ProcessForce.API.Generators Namespace


BatchTemplateGenerationFailedException Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchTemplateGenerationFailedException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchTemplateGenerationFailedException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchTemplateGenerationFailedException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchTemplateGenerationFailedException Class
BatchTemplateGenerationFailedException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchTemplateGenerationFailedException Constructor

BatchTemplateGenerationFailedException Class See Also

Overload List
Name | Description
BatchTemplateGenerationFailedException() |
BatchTemplateGenerationFailedException(string) |
BatchTemplateGenerationFailedException(string, Exception) |
See Also

Reference

BatchTemplateGenerationFailedException Class
BatchTemplateGenerationFailedException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchTemplateGenerationFailedException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchTemplateGenerationFailedException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchTemplateGenerationFailedException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchTemplateGenerationFailedException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchTemplateGenerationFailedException Class
BatchTemplateGenerationFailedException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchTemplateGenerationFailedException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchTemplateGenerationFailedException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchTemplateGenerationFailedException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchTemplateGenerationFailedException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchTemplateGenerationFailedException Class
BatchTemplateGenerationFailedException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchTemplateIncorrectDateFormatException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class BatchTemplateIncorrectDateFormatException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class BatchTemplateIncorrectDateFormatException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class BatchTemplateIncorrectDateFormatException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class BatchTemplateIncorrectDateFormatException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Generators.BatchTemplateIncorrectDateFormatException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchTemplateIncorrectDateFormatException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchTemplateIncorrectDateFormatException Members

BatchTemplateIncorrectDateFormatException Class Constructors Methods Properties See Also

The following tables list the members exposed by the BatchTemplateIncorrectDateFormatException type.

Constructors
 | Name | Description
Public constructor | BatchTemplateIncorrectDateFormatException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BatchTemplateIncorrectDateFormatException Class
CompuTec.ProcessForce.API.Generators Namespace


BatchTemplateIncorrectDateFormatException Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchTemplateIncorrectDateFormatException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchTemplateIncorrectDateFormatException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchTemplateIncorrectDateFormatException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchTemplateIncorrectDateFormatException Class
BatchTemplateIncorrectDateFormatException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchTemplateIncorrectDateFormatException Constructor

BatchTemplateIncorrectDateFormatException Class See Also

Overload List
Name | Description
BatchTemplateIncorrectDateFormatException() |
BatchTemplateIncorrectDateFormatException(string) |
BatchTemplateIncorrectDateFormatException(string, Exception) |
See Also

Reference

BatchTemplateIncorrectDateFormatException Class
BatchTemplateIncorrectDateFormatException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchTemplateIncorrectDateFormatException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchTemplateIncorrectDateFormatException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchTemplateIncorrectDateFormatException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchTemplateIncorrectDateFormatException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchTemplateIncorrectDateFormatException Class
BatchTemplateIncorrectDateFormatException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchTemplateIncorrectDateFormatException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchTemplateIncorrectDateFormatException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchTemplateIncorrectDateFormatException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchTemplateIncorrectDateFormatException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchTemplateIncorrectDateFormatException Class
BatchTemplateIncorrectDateFormatException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchTemplateNotFoundException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class BatchTemplateNotFoundException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class BatchTemplateNotFoundException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class BatchTemplateNotFoundException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class BatchTemplateNotFoundException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Generators.BatchTemplateNotFoundException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchTemplateNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchTemplateNotFoundException Members

BatchTemplateNotFoundException Class Constructors Methods Properties See Also

The following tables list the members exposed by the BatchTemplateNotFoundException type.

Constructors
 | Name | Description
Public constructor | BatchTemplateNotFoundException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BatchTemplateNotFoundException Class
CompuTec.ProcessForce.API.Generators Namespace


BatchTemplateNotFoundException Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchTemplateNotFoundException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchTemplateNotFoundException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchTemplateNotFoundException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchTemplateNotFoundException Class
BatchTemplateNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchTemplateNotFoundException Constructor

BatchTemplateNotFoundException Class See Also

Overload List
Name | Description
BatchTemplateNotFoundException() |
BatchTemplateNotFoundException(string) |
BatchTemplateNotFoundException(string, Exception) |
See Also

Reference

BatchTemplateNotFoundException Class
BatchTemplateNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchTemplateNotFoundException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchTemplateNotFoundException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchTemplateNotFoundException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchTemplateNotFoundException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchTemplateNotFoundException Class
BatchTemplateNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


BatchTemplateNotFoundException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchTemplateNotFoundException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchTemplateNotFoundException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchTemplateNotFoundException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchTemplateNotFoundException Class
BatchTemplateNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


ExpiryDateGenerationException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class ExpiryDateGenerationException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class ExpiryDateGenerationException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class ExpiryDateGenerationException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class ExpiryDateGenerationException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Generators.ExpiryDateGenerationException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExpiryDateGenerationException Members
CompuTec.ProcessForce.API.Generators Namespace


ExpiryDateGenerationException Members

ExpiryDateGenerationException Class Constructors Methods Properties See Also

The following tables list the members exposed by the ExpiryDateGenerationException type.

Constructors
 | Name | Description
Public constructor | ExpiryDateGenerationException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ExpiryDateGenerationException Class
CompuTec.ProcessForce.API.Generators Namespace


ExpiryDateGenerationException Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ExpiryDateGenerationException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ExpiryDateGenerationException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ExpiryDateGenerationException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExpiryDateGenerationException Class
ExpiryDateGenerationException Members
CompuTec.ProcessForce.API.Generators Namespace


ExpiryDateGenerationException Constructor

ExpiryDateGenerationException Class See Also

Overload List
Name | Description
ExpiryDateGenerationException() |
ExpiryDateGenerationException(string) |
ExpiryDateGenerationException(string, Exception) |
See Also

Reference

ExpiryDateGenerationException Class
ExpiryDateGenerationException Members
CompuTec.ProcessForce.API.Generators Namespace


ExpiryDateGenerationException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ExpiryDateGenerationException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ExpiryDateGenerationException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ExpiryDateGenerationException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExpiryDateGenerationException Class
ExpiryDateGenerationException Members
CompuTec.ProcessForce.API.Generators Namespace


ExpiryDateGenerationException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ExpiryDateGenerationException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ExpiryDateGenerationException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ExpiryDateGenerationException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExpiryDateGenerationException Class
ExpiryDateGenerationException Members
CompuTec.ProcessForce.API.Generators Namespace


ItemDetailsNotFoundException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class ItemDetailsNotFoundException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class ItemDetailsNotFoundException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class ItemDetailsNotFoundException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class ItemDetailsNotFoundException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Generators.ItemDetailsNotFoundException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


ItemDetailsNotFoundException Members

ItemDetailsNotFoundException Class Constructors Methods Properties See Also

The following tables list the members exposed by the ItemDetailsNotFoundException type.

Constructors
 | Name | Description
Public constructor | ItemDetailsNotFoundException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ItemDetailsNotFoundException Class
CompuTec.ProcessForce.API.Generators Namespace


ItemDetailsNotFoundException Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemDetailsNotFoundException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemDetailsNotFoundException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemDetailsNotFoundException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsNotFoundException Class
ItemDetailsNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


ItemDetailsNotFoundException Constructor

ItemDetailsNotFoundException Class See Also

Overload List
Name | Description
ItemDetailsNotFoundException() |
ItemDetailsNotFoundException(string) |
ItemDetailsNotFoundException(string, Exception) |
See Also

Reference

ItemDetailsNotFoundException Class
ItemDetailsNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


ItemDetailsNotFoundException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemDetailsNotFoundException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemDetailsNotFoundException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemDetailsNotFoundException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsNotFoundException Class
ItemDetailsNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


ItemDetailsNotFoundException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemDetailsNotFoundException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemDetailsNotFoundException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemDetailsNotFoundException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetailsNotFoundException Class
ItemDetailsNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorDocEntryIsZeroException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class QCTestDocumentsGeneratorDocEntryIsZeroException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class QCTestDocumentsGeneratorDocEntryIsZeroException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class QCTestDocumentsGeneratorDocEntryIsZeroException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class QCTestDocumentsGeneratorDocEntryIsZeroException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Generators.QCTestDocumentsGeneratorDocEntryIsZeroException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorDocEntryIsZeroException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorDocEntryIsZeroException Members

QCTestDocumentsGeneratorDocEntryIsZeroException Class Constructors Methods Properties See Also

The following tables list the members exposed by the QCTestDocumentsGeneratorDocEntryIsZeroException type.

Constructors
 | Name | Description
Public constructor | QCTestDocumentsGeneratorDocEntryIsZeroException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

QCTestDocumentsGeneratorDocEntryIsZeroException Class
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorDocEntryIsZeroException Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QCTestDocumentsGeneratorDocEntryIsZeroException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QCTestDocumentsGeneratorDocEntryIsZeroException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QCTestDocumentsGeneratorDocEntryIsZeroException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorDocEntryIsZeroException Class
QCTestDocumentsGeneratorDocEntryIsZeroException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorDocEntryIsZeroException Constructor

QCTestDocumentsGeneratorDocEntryIsZeroException Class See Also

Overload List
Name | Description
QCTestDocumentsGeneratorDocEntryIsZeroException() |
QCTestDocumentsGeneratorDocEntryIsZeroException(string) |
QCTestDocumentsGeneratorDocEntryIsZeroException(string, Exception) |
See Also

Reference

QCTestDocumentsGeneratorDocEntryIsZeroException Class
QCTestDocumentsGeneratorDocEntryIsZeroException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorDocEntryIsZeroException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QCTestDocumentsGeneratorDocEntryIsZeroException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QCTestDocumentsGeneratorDocEntryIsZeroException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QCTestDocumentsGeneratorDocEntryIsZeroException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorDocEntryIsZeroException Class
QCTestDocumentsGeneratorDocEntryIsZeroException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorDocEntryIsZeroException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QCTestDocumentsGeneratorDocEntryIsZeroException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QCTestDocumentsGeneratorDocEntryIsZeroException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QCTestDocumentsGeneratorDocEntryIsZeroException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorDocEntryIsZeroException Class
QCTestDocumentsGeneratorDocEntryIsZeroException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorDocumentTypeNotSupportedException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class QCTestDocumentsGeneratorDocumentTypeNotSupportedException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class QCTestDocumentsGeneratorDocumentTypeNotSupportedException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class QCTestDocumentsGeneratorDocumentTypeNotSupportedException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class QCTestDocumentsGeneratorDocumentTypeNotSupportedException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Generators.QCTestDocumentsGeneratorDocumentTypeNotSupportedException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorDocumentTypeNotSupportedException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorDocumentTypeNotSupportedException Members

QCTestDocumentsGeneratorDocumentTypeNotSupportedException Class Constructors Methods Properties See Also

The following tables list the members exposed by the QCTestDocumentsGeneratorDocumentTypeNotSupportedException type.

Constructors
 | Name | Description
Public constructor | QCTestDocumentsGeneratorDocumentTypeNotSupportedException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

QCTestDocumentsGeneratorDocumentTypeNotSupportedException Class
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorDocumentTypeNotSupportedException Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QCTestDocumentsGeneratorDocumentTypeNotSupportedException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QCTestDocumentsGeneratorDocumentTypeNotSupportedException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QCTestDocumentsGeneratorDocumentTypeNotSupportedException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorDocumentTypeNotSupportedException Class
QCTestDocumentsGeneratorDocumentTypeNotSupportedException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorDocumentTypeNotSupportedException Constructor

QCTestDocumentsGeneratorDocumentTypeNotSupportedException Class See Also

Overload List
Name | Description
QCTestDocumentsGeneratorDocumentTypeNotSupportedException() |
QCTestDocumentsGeneratorDocumentTypeNotSupportedException(string) |
QCTestDocumentsGeneratorDocumentTypeNotSupportedException(string, Exception) |
See Also

Reference

QCTestDocumentsGeneratorDocumentTypeNotSupportedException Class
QCTestDocumentsGeneratorDocumentTypeNotSupportedException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorDocumentTypeNotSupportedException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QCTestDocumentsGeneratorDocumentTypeNotSupportedException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QCTestDocumentsGeneratorDocumentTypeNotSupportedException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QCTestDocumentsGeneratorDocumentTypeNotSupportedException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorDocumentTypeNotSupportedException Class
QCTestDocumentsGeneratorDocumentTypeNotSupportedException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorDocumentTypeNotSupportedException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QCTestDocumentsGeneratorDocumentTypeNotSupportedException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QCTestDocumentsGeneratorDocumentTypeNotSupportedException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QCTestDocumentsGeneratorDocumentTypeNotSupportedException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorDocumentTypeNotSupportedException Class
QCTestDocumentsGeneratorDocumentTypeNotSupportedException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorEmptyDocumentTypeException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class QCTestDocumentsGeneratorEmptyDocumentTypeException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class QCTestDocumentsGeneratorEmptyDocumentTypeException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class QCTestDocumentsGeneratorEmptyDocumentTypeException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class QCTestDocumentsGeneratorEmptyDocumentTypeException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Generators.QCTestDocumentsGeneratorEmptyDocumentTypeException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorEmptyDocumentTypeException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorEmptyDocumentTypeException Members

QCTestDocumentsGeneratorEmptyDocumentTypeException Class Constructors Methods Properties See Also

The following tables list the members exposed by the QCTestDocumentsGeneratorEmptyDocumentTypeException type.

Constructors
 | Name | Description
Public constructor | QCTestDocumentsGeneratorEmptyDocumentTypeException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

QCTestDocumentsGeneratorEmptyDocumentTypeException Class
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorEmptyDocumentTypeException Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QCTestDocumentsGeneratorEmptyDocumentTypeException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QCTestDocumentsGeneratorEmptyDocumentTypeException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QCTestDocumentsGeneratorEmptyDocumentTypeException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorEmptyDocumentTypeException Class
QCTestDocumentsGeneratorEmptyDocumentTypeException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorEmptyDocumentTypeException Constructor

QCTestDocumentsGeneratorEmptyDocumentTypeException Class See Also

Overload List
Name | Description
QCTestDocumentsGeneratorEmptyDocumentTypeException() |
QCTestDocumentsGeneratorEmptyDocumentTypeException(string) |
QCTestDocumentsGeneratorEmptyDocumentTypeException(string, Exception) |
See Also

Reference

QCTestDocumentsGeneratorEmptyDocumentTypeException Class
QCTestDocumentsGeneratorEmptyDocumentTypeException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorEmptyDocumentTypeException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QCTestDocumentsGeneratorEmptyDocumentTypeException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QCTestDocumentsGeneratorEmptyDocumentTypeException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QCTestDocumentsGeneratorEmptyDocumentTypeException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorEmptyDocumentTypeException Class
QCTestDocumentsGeneratorEmptyDocumentTypeException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorEmptyDocumentTypeException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QCTestDocumentsGeneratorEmptyDocumentTypeException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QCTestDocumentsGeneratorEmptyDocumentTypeException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QCTestDocumentsGeneratorEmptyDocumentTypeException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorEmptyDocumentTypeException Class
QCTestDocumentsGeneratorEmptyDocumentTypeException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorItemsNotFoundException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class QCTestDocumentsGeneratorItemsNotFoundException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class QCTestDocumentsGeneratorItemsNotFoundException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class QCTestDocumentsGeneratorItemsNotFoundException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class QCTestDocumentsGeneratorItemsNotFoundException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Generators.QCTestDocumentsGeneratorItemsNotFoundException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorItemsNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorItemsNotFoundException Members

QCTestDocumentsGeneratorItemsNotFoundException Class Constructors Methods Properties See Also

The following tables list the members exposed by the QCTestDocumentsGeneratorItemsNotFoundException type.

Constructors
 | Name | Description
Public constructor | QCTestDocumentsGeneratorItemsNotFoundException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

QCTestDocumentsGeneratorItemsNotFoundException Class
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorItemsNotFoundException Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QCTestDocumentsGeneratorItemsNotFoundException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QCTestDocumentsGeneratorItemsNotFoundException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QCTestDocumentsGeneratorItemsNotFoundException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorItemsNotFoundException Class
QCTestDocumentsGeneratorItemsNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorItemsNotFoundException Constructor

QCTestDocumentsGeneratorItemsNotFoundException Class See Also

Overload List
Name | Description
QCTestDocumentsGeneratorItemsNotFoundException() |
QCTestDocumentsGeneratorItemsNotFoundException(string) |
QCTestDocumentsGeneratorItemsNotFoundException(string, Exception) |
See Also

Reference

QCTestDocumentsGeneratorItemsNotFoundException Class
QCTestDocumentsGeneratorItemsNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorItemsNotFoundException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QCTestDocumentsGeneratorItemsNotFoundException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QCTestDocumentsGeneratorItemsNotFoundException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QCTestDocumentsGeneratorItemsNotFoundException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorItemsNotFoundException Class
QCTestDocumentsGeneratorItemsNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorItemsNotFoundException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QCTestDocumentsGeneratorItemsNotFoundException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QCTestDocumentsGeneratorItemsNotFoundException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QCTestDocumentsGeneratorItemsNotFoundException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorItemsNotFoundException Class
QCTestDocumentsGeneratorItemsNotFoundException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorSystemException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class QCTestDocumentsGeneratorSystemException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class QCTestDocumentsGeneratorSystemException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class QCTestDocumentsGeneratorSystemException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class QCTestDocumentsGeneratorSystemException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Generators.QCTestDocumentsGeneratorSystemException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorSystemException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorSystemException Members

QCTestDocumentsGeneratorSystemException Class Constructors Methods Properties See Also

The following tables list the members exposed by the QCTestDocumentsGeneratorSystemException type.

Constructors
 | Name | Description
Public constructor | QCTestDocumentsGeneratorSystemException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

QCTestDocumentsGeneratorSystemException Class
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorSystemException Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QCTestDocumentsGeneratorSystemException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QCTestDocumentsGeneratorSystemException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QCTestDocumentsGeneratorSystemException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorSystemException Class
QCTestDocumentsGeneratorSystemException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorSystemException Constructor

QCTestDocumentsGeneratorSystemException Class See Also

Overload List
Name | Description
QCTestDocumentsGeneratorSystemException() |
QCTestDocumentsGeneratorSystemException(string) |
QCTestDocumentsGeneratorSystemException(string, Exception) |
See Also

Reference

QCTestDocumentsGeneratorSystemException Class
QCTestDocumentsGeneratorSystemException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorSystemException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QCTestDocumentsGeneratorSystemException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QCTestDocumentsGeneratorSystemException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QCTestDocumentsGeneratorSystemException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorSystemException Class
QCTestDocumentsGeneratorSystemException Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGeneratorSystemException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QCTestDocumentsGeneratorSystemException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QCTestDocumentsGeneratorSystemException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QCTestDocumentsGeneratorSystemException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGeneratorSystemException Class
QCTestDocumentsGeneratorSystemException Members
CompuTec.ProcessForce.API.Generators Namespace


ZeroQuantityForSpecificBatchException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class ZeroQuantityForSpecificBatchException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class ZeroQuantityForSpecificBatchException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class ZeroQuantityForSpecificBatchException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class ZeroQuantityForSpecificBatchException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Generators.ZeroQuantityForSpecificBatchException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ZeroQuantityForSpecificBatchException Members
CompuTec.ProcessForce.API.Generators Namespace


ZeroQuantityForSpecificBatchException Members

ZeroQuantityForSpecificBatchException Class Constructors Methods Properties See Also

The following tables list the members exposed by the ZeroQuantityForSpecificBatchException type.

Constructors
 | Name | Description
Public constructor | ZeroQuantityForSpecificBatchException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ZeroQuantityForSpecificBatchException Class
CompuTec.ProcessForce.API.Generators Namespace


ZeroQuantityForSpecificBatchException Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ZeroQuantityForSpecificBatchException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ZeroQuantityForSpecificBatchException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ZeroQuantityForSpecificBatchException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ZeroQuantityForSpecificBatchException Class
ZeroQuantityForSpecificBatchException Members
CompuTec.ProcessForce.API.Generators Namespace


ZeroQuantityForSpecificBatchException Constructor

ZeroQuantityForSpecificBatchException Class See Also

Overload List
Name | Description
ZeroQuantityForSpecificBatchException() |
ZeroQuantityForSpecificBatchException(string) |
ZeroQuantityForSpecificBatchException(string, Exception) |
See Also

Reference

ZeroQuantityForSpecificBatchException Class
ZeroQuantityForSpecificBatchException Members
CompuTec.ProcessForce.API.Generators Namespace


ZeroQuantityForSpecificBatchException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ZeroQuantityForSpecificBatchException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ZeroQuantityForSpecificBatchException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ZeroQuantityForSpecificBatchException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ZeroQuantityForSpecificBatchException Class
ZeroQuantityForSpecificBatchException Members
CompuTec.ProcessForce.API.Generators Namespace


ZeroQuantityForSpecificBatchException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ZeroQuantityForSpecificBatchException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ZeroQuantityForSpecificBatchException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ZeroQuantityForSpecificBatchException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ZeroQuantityForSpecificBatchException Class
ZeroQuantityForSpecificBatchException Members
CompuTec.ProcessForce.API.Generators Namespace


ExpiryDateGenerator Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ExpiryDateGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ExpiryDateGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ExpiryDateGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ExpiryDateGenerator
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Generators.ExpiryDateGenerator
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExpiryDateGenerator Members
CompuTec.ProcessForce.API.Generators Namespace


ExpiryDateGenerator Members

ExpiryDateGenerator Class Methods See Also

The following tables list the members exposed by the ExpiryDateGenerator type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | Generate |
 | GenerateFromTemplate |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ExpiryDateGenerator Class
CompuTec.ProcessForce.API.Generators Namespace


ExpiryDateGenerator.Generate Method

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function Generate( _
   ByVal Token As String, _
   ByVal itemCode As String, _
   Optional ByVal Classification As String = "", _
   Optional ByVal MORDE As String = "", _
   Optional ByVal PORDN As String = "" _
) As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static DateTime Generate(
   string Token,
   string itemCode,
   string Classification = "",
   string MORDE = "",
   string PORDN = ""
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static DateTime Generate(
   String^ Token,
   String^ itemCode,
   String^ Classification,
   String^ MORDE,
   String^ PORDN
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function Generate(
    Token : String,
    itemCode : String,
    Classification : String,
    MORDE : String,
    PORDN : String
) : DateTime;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemCode

Type: string

Classification

Type: string

MORDE

Type: string

PORDN

Type: string

Return Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExpiryDateGenerator Class
ExpiryDateGenerator Members
CompuTec.ProcessForce.API.Generators Namespace


ExpiryDateGenerator.GenerateFromTemplate Method

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GenerateFromTemplate( _
   ByVal Token As String, _
   ByVal Format As String, _
   ByVal ItemCode As String, _
   Optional ByVal Classification As String = "", _
   Optional ByVal MORDE As String = "", _
   Optional ByVal PORDN As String = "" _
) As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static DateTime GenerateFromTemplate(
   string Token,
   string Format,
   string ItemCode,
   string Classification = "",
   string MORDE = "",
   string PORDN = ""
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static DateTime GenerateFromTemplate(
   String^ Token,
   String^ Format,
   String^ ItemCode,
   String^ Classification,
   String^ MORDE,
   String^ PORDN
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GenerateFromTemplate(
    Token : String,
    Format : String,
    ItemCode : String,
    Classification : String,
    MORDE : String,
    PORDN : String
) : DateTime;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Format

Type: string

ItemCode

Type: string

Classification

Type: string

MORDE

Type: string

PORDN

Type: string

Return Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExpiryDateGenerator Class
ExpiryDateGenerator Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGenerator Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class QCTestDocumentsGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QCTestDocumentsGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class QCTestDocumentsGenerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QCTestDocumentsGenerator
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Generators.QCTestDocumentsGenerator
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGenerator Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGenerator Members

QCTestDocumentsGenerator Class Methods Fields See Also

The following tables list the members exposed by the QCTestDocumentsGenerator type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | GenerateQCTestDocuments | This Methood generate Quality Control Tests Documents for Document
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Classes
 | Name | Description
Public class | QCTestItemData |
Top
Fields
Name | Description
SupportedAutoCreateTestDocumentsTypes |
Top
See Also

Reference

QCTestDocumentsGenerator Class
CompuTec.ProcessForce.API.Generators Namespace


QCTestDocumentsGenerator.GenerateQCTestDocuments Method

This Methood generate Quality Control Tests Documents for Document

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GenerateQCTestDocuments( _
   ByVal Token As String, _
   ByVal DocumentType As String, _
   ByVal DocEntry As Integer _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Result GenerateQCTestDocuments(
   string Token,
   string DocumentType,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static Result^ GenerateQCTestDocuments(
   String^ Token,
   String^ DocumentType,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GenerateQCTestDocuments(
    Token : String,
    DocumentType : String,
    DocEntry : int
) : Result;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Token

DocumentType

Type: string

Type of document

DocEntry

Type: int

DocEntry of document

Return Value

Type: Result

??

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGenerator Class
QCTestDocumentsGenerator Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestItemData Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class QCTestItemData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QCTestItemData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class QCTestItemData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QCTestItemData
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Generators.QCTestDocumentsGenerator.QCTestItemData
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestItemData Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestItemData Members

QCTestItemData Class Constructors Methods Properties See Also

The following tables list the members exposed by the QCTestItemData type.

Constructors
 | Name | Description
Public constructor | QCTestItemData | (Overloaded)
Top
Properties
 | Name | Description
Public property | BatchNumber |
Public property | BatchesList |
Public property | LotNumber |
Public property | LotNumbersList |
Public property | RefersTo |
Public property | SerialNumber |
Public property | SerialNumbersList |
Public property | SystemNumber |
Public property | TransactionType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

QCTestItemData Class
CompuTec.ProcessForce.API.Generators Namespace


QCTestItemData.RefersTo Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property RefersTo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string RefersTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ RefersTo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get RefersTo() : String;
public function set RefersTo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestItemData Class
QCTestItemData Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestItemData.LotNumber Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property LotNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string LotNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ LotNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get LotNumber() : String;
public function set LotNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestItemData Class
QCTestItemData Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestItemData.BatchNumber Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property BatchNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string BatchNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ BatchNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get BatchNumber() : String;
public function set BatchNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestItemData Class
QCTestItemData Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestItemData.SerialNumber Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SerialNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string SerialNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ SerialNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SerialNumber() : String;
public function set SerialNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestItemData Class
QCTestItemData Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestItemData.SystemNumber Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SystemNumber() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int SystemNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int SystemNumber {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SystemNumber() : int;
public function set SystemNumber(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestItemData Class
QCTestItemData Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestItemData.TransactionType Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property TransactionType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string TransactionType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ TransactionType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get TransactionType() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestItemData Class
QCTestItemData Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestItemData.BatchesList Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property BatchesList() As List(Of String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<string> BatchesList {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<String^>^ BatchesList {
 List<String^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<string>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestItemData Class
QCTestItemData Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestItemData.LotNumbersList Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property LotNumbersList() As List(Of Tuple(Of String, String))
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<Tuple<string, string>> LotNumbersList {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<Tuple<String^, String^>^>^ LotNumbersList {
 List<Tuple<String^, String^>^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<Tuple<string, string>>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestItemData Class
QCTestItemData Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestItemData.SerialNumbersList Property

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property SerialNumbersList() As List(Of SerialNumberData)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<SerialNumberData> SerialNumbersList {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<SerialNumberData^>^ SerialNumbersList {
 List<SerialNumberData^>^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<SerialNumberData>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestItemData Class
QCTestItemData Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestItemData(String, String, Int32, String, String, String, Boolean, Int32) Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal documentNumber As Integer, _
   ByVal documentType As String, _
   ByVal testProtocolNumber As String, _
   ByVal businessPartnerCode As String, _
   Optional ByVal createPool As Boolean = false, _
   Optional ByVal numberOfSamples As Integer = 0 _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QCTestItemData(
   string token,
   string itemCode,
   int documentNumber,
   string documentType,
   string testProtocolNumber,
   string businessPartnerCode,
   bool createPool = false,
   int numberOfSamples = 0
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QCTestItemData(
   String^ token,
   String^ itemCode,
   int documentNumber,
   String^ documentType,
   String^ testProtocolNumber,
   String^ businessPartnerCode,
   bool createPool,
   int numberOfSamples
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QCTestItemData(
    token : String,
    itemCode : String,
    documentNumber : int,
    documentType : String,
    testProtocolNumber : String,
    businessPartnerCode : String,
    createPool : boolean,
    numberOfSamples : int
);
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

documentNumber

Type: int

documentType

Type: string

testProtocolNumber

Type: string

businessPartnerCode

Type: string

createPool

Type: bool

numberOfSamples

Type: int

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestItemData Class
QCTestItemData Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestItemData Constructor

QCTestItemData Class See Also

Overload List
Name | Description
QCTestItemData() |
QCTestItemData(string, string, int, string, string, string, bool, int) |
See Also

Reference

QCTestItemData Class
QCTestItemData Members
CompuTec.ProcessForce.API.Generators Namespace


QCTestItemData Constructor

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QCTestItemData()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QCTestItemData()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QCTestItemData();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestItemData Class
QCTestItemData Members
CompuTec.ProcessForce.API.Generators Namespace


SupportedAutoCreateTestDocumentsTypes Field

Namespace: CompuTec.ProcessForce.API.Generators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Shadows SupportedAutoCreateTestDocumentsTypes As List(Of String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
new public static List<string> SupportedAutoCreateTestDocumentsTypes
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static List<String^>^ SupportedAutoCreateTestDocumentsTypes;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Field Value

Type: List<string>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QCTestDocumentsGenerator Class
QCTestDocumentsGenerator Members
CompuTec.ProcessForce.API.Generators Namespace


CompuTec.ProcessForce.API Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | ProcessForceCompanyInitializator | Class With Factory metohood to create ProcessForceCompany Class;
Public class | VersionInfo | Allows retrieving an assembly and database version values of ProcessForce's current installation.
Top
Interfaces
 | Name | Description
Public interface | IProcessForceCompany |
Top
Enumerations
 | Name | Description
Public enumeration | StopTransactionType |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


StopTransactionType Enumeration

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Commit |
Rollback |
See Also

Reference

CompuTec.ProcessForce.API Namespace


IProcessForceCompany Interface

Members See Also

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IProcessForceCompany
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IProcessForceCompany
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IProcessForceCompany
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IProcessForceCompany
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany Members

IProcessForceCompany Interface Methods Properties See Also

The following tables list the members exposed by the IProcessForceCompany type.

Properties
 | Name | Description
Public property | Databasename | SQL database to connect to
Public property | DbServerType | Type of SQL Server
Public property | InTransaction | Determines whether transaction Was Initialized in this company connection scope
Public property | IsConnected | return true if Yu are connected to company
Public property | Language | SAP Language
Public property | LicenseServer | SAP LicenceServer
Public property | Password | Sap password
Public property | SQLPassword | Sql Password
Public property | SQLServer | Sql Server network Addres
Public property | SQLUserName | Sql user name
Public property | SapCompany | Returns SAP Company objet
Public property | Token | Connection token
Public property | UseTrusted | Integrated security
Public property | UserName | SAP User Name
Top
Methods
 | Name | Description
Public method | Connect | (Overloaded) Connects to SAP Company
Public method | CreatePFAction | Factory methood to create ProcessForce obect to perform an action
Public method | CreatePFObject | Factory methood to create ProcessForce Document
Public method | CreateSapObject | Creates SAP Object
Public method | Disconnect | Disconnects from Company
Public method | EndTransaction | Call This method on end transaction
Public method | GenerateAdditionalBatchDetails |
Public method | GenerateBatchNumber | This Methood is used to generate next Batch Number for an Item
Public method | GenerateQCTestDocuments | This Methood is used to generate Quality Control Test Documents
Public method | GenerateSerial | This Methood is used to generate next Serial nmbers for an Item
Public method | IsDaltaLayerEnabled | Returms true if datalayer Connection is established
Public method | PerformRollOver | (Overloaded) Performs the Roll-Over procedure.
Public method | PerformRollUp | (Overloaded) Methods that perform Cost Roll Up
Public method | Reconnect | Reconnects To SAP Company
Public method | RestoreBillOfMaterials | Restores Bill of materials synchronization Data NON MRP synchronization
Public method | StartTransaction | Call this method instead of SAP start Transaction
Public method | SynchronizemanufacturingOrders | This Method finds all manufacturing orders that are unsynchronized and synchronize them back.
Public method | getLastErrorDescription | returns Last Error Message
Top
See Also

Reference

IProcessForceCompany Interface
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.SapCompany Property

Returns SAP Company objet

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property SapCompany() As Company
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Company SapCompany {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property Company^ SapCompany {
 Company^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get SapCompany() : Company;
This language is not supported or no code example is available.

Property Value

Type: Company
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.UserName Property

SAP User Name

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property UserName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string UserName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ UserName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserName() : String;
function set UserName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.Password Property

Sap password

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Password() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Password {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Password {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Password() : String;
function set Password(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.LicenseServer Property

SAP LicenceServer

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property LicenseServer() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string LicenseServer {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ LicenseServer {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LicenseServer() : String;
function set LicenseServer(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.SQLServer Property

Sql Server network Addres

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property SQLServer() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string SQLServer {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ SQLServer {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get SQLServer() : String;
function set SQLServer(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.SQLUserName Property

Sql user name

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property SQLUserName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string SQLUserName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ SQLUserName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get SQLUserName() : String;
function set SQLUserName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.SQLPassword Property

Sql Password

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property SQLPassword() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string SQLPassword {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ SQLPassword {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get SQLPassword() : String;
function set SQLPassword(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.Databasename Property

SQL database to connect to

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Databasename() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Databasename {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Databasename {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Databasename() : String;
function set Databasename(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.UseTrusted Property

Integrated security

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property UseTrusted() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool UseTrusted {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool UseTrusted {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UseTrusted() : boolean;
function set UseTrusted(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.DbServerType Property

Type of SQL Server

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property DbServerType() As BoDataServerTypes
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
BoDataServerTypes DbServerType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property BoDataServerTypes DbServerType {
 BoDataServerTypes get( );
 void set(
   BoDataServerTypes value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DbServerType() : BoDataServerTypes;
function set DbServerType(value : BoDataServerTypes);
This language is not supported or no code example is available.

Property Value

Type: BoDataServerTypes
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.Token Property

Connection token

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Token() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Token {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Token {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Token() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.Language Property

SAP Language

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Language() As BoSuppLangs
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
BoSuppLangs Language {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property BoSuppLangs Language {
 BoSuppLangs get( );
 void set(
   BoSuppLangs value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Language() : BoSuppLangs;
function set Language(value : BoSuppLangs);
This language is not supported or no code example is available.

Property Value

Type: BoSuppLangs
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.InTransaction Property

Determines whether transaction Was Initialized in this company connection scope

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property InTransaction() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool InTransaction {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool InTransaction {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get InTransaction() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.StartTransaction Method

Call this method instead of SAP start Transaction

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub StartTransaction()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void StartTransaction()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void StartTransaction()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function StartTransaction();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.EndTransaction Method

Call This method on end transaction

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub EndTransaction( _
   ByVal type As StopTransactionType _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void EndTransaction(
   StopTransactionType type
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void EndTransaction(
   StopTransactionType type
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function EndTransaction(
    type : StopTransactionType
);
This language is not supported or no code example is available.

Parameters

type

Type: StopTransactionType

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.IsDaltaLayerEnabled Method

Returms true if datalayer Connection is established

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function IsDaltaLayerEnabled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool IsDaltaLayerEnabled()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool IsDaltaLayerEnabled()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function IsDaltaLayerEnabled() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.Reconnect Method

Reconnects To SAP Company

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function Reconnect() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Reconnect()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int Reconnect()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Reconnect() : int;
This language is not supported or no code example is available.

Return Value

Type: int

1-success ;0-Errror

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.Connect Method

Connects to SAP Company

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function Connect() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Connect()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int Connect()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Connect() : int;
This language is not supported or no code example is available.

Return Value

Type: int

1-success ;0-Errror

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.Connect Method

IProcessForceCompany Interface See Also

Connects to SAP Company

Overload List
Name | Description
Connect() | Connects to SAP Company
Connect(string) | Connects to PF company where Base Connection is already initialized by Computec.Core
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.Connect (String) Method

Connects to PF company where Base Connection is already initialized by Computec.Core

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Connect( _
   ByVal Token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Connect(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Connect(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Connect(
    Token : String
);
This language is not supported or no code example is available.

Parameters

Token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.Disconnect Method

Disconnects from Company

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Disconnect()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Disconnect()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Disconnect()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Disconnect();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.IsConnected Property

return true if Yu are connected to company

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property IsConnected() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool IsConnected {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool IsConnected {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get IsConnected() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.CreateSapObject Method

Creates SAP Object

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CreateSapObject( _
   ByVal objectType As BoObjectTypes _
) As Object
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
object CreateSapObject(
   BoObjectTypes objectType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

object^ CreateSapObject(
   BoObjectTypes objectType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CreateSapObject(
    objectType : BoObjectTypes
) : object;
This language is not supported or no code example is available.

Parameters

objectType

Type: BoObjectTypes

Type of Object To Reurn

Return Value

Type: object

Sap Object

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.PerformRollUp (List<RollingUpBillOfMaterials>, List<String>, String, List<String>, Boolean) Method

Methods that perform Cost Roll Up

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function PerformRollUp( _
   ByVal billOfMaterials As List(Of RollingUpBillOfMaterials), _
   ByVal rawMaterials As List(Of String), _
   ByVal costCategory As String, _
   ByVal warehouses As List(Of String), _
   ByVal rollUpOverStructure As Boolean _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Result PerformRollUp(
   List<RollingUpBillOfMaterials> billOfMaterials,
   List<string> rawMaterials,
   string costCategory,
   List<string> warehouses,
   bool rollUpOverStructure
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Result^ PerformRollUp(
   List<RollingUpBillOfMaterials^>^ billOfMaterials,
   List<String^>^ rawMaterials,
   String^ costCategory,
   List<String^>^ warehouses,
   bool rollUpOverStructure
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

billOfMaterials

Type: List<RollingUpBillOfMaterials>

List of Bill Of Materials on with roll up will affect

rawMaterials

Type: List<string>

List of Materials (not BOM) on with roll up will affect

costCategory

Type: string

warehouses

Type: List<string>

rollUpOverStructure

Type: bool

Determines whether or not the roll-up must be performed over the structure.

Return Value

Type: Result
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.PerformRollOver (List<RollOverItem>, List<String>, String, String) Method

Performs the Roll-Over procedure.

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function PerformRollOver( _
   ByVal items As List(Of RollOverItem), _
   ByVal warehouses As List(Of String), _
   ByVal fromCostCategory As String, _
   ByVal toCostCategory As String _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Result PerformRollOver(
   List<RollOverItem> items,
   List<string> warehouses,
   string fromCostCategory,
   string toCostCategory
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Result^ PerformRollOver(
   List<RollOverItem^>^ items,
   List<String^>^ warehouses,
   String^ fromCostCategory,
   String^ toCostCategory
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

items

Type: List<RollOverItem>

A collection of items for which the Roll-Over will affect.

warehouses

Type: List<string>

A collection of warehouses for which the Roll-Over will affect.

fromCostCategory

Type: string

The source cost category, from which the costs will be copied.

toCostCategory

Type: string

The destination cost category, to which the costs will be copied.

Return Value

Type: Result

The Result object with the performed Roll-Over procedure results.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.PerformRollOver Method

IProcessForceCompany Interface See Also

Performs the Roll-Over procedure.

Overload List
Name | Description
PerformRollOver(List<RollOverItem>, List<String>, string, string) | Performs the Roll-Over procedure.
PerformRollOver(List<RollOverItem>, List<String>, string, string, bool) | Performs the Roll-Over procedure.
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.PerformRollOver (List<RollOverItem>, List<String>, String, String, Boolean) Method

Performs the Roll-Over procedure.

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function PerformRollOver( _
   ByVal items As List(Of RollOverItem), _
   ByVal warehouses As List(Of String), _
   ByVal fromCostCategory As String, _
   ByVal toCostCategory As String, _
   ByVal rollOverResourceCosting As Boolean _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Result PerformRollOver(
   List<RollOverItem> items,
   List<string> warehouses,
   string fromCostCategory,
   string toCostCategory,
   bool rollOverResourceCosting
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Result^ PerformRollOver(
   List<RollOverItem^>^ items,
   List<String^>^ warehouses,
   String^ fromCostCategory,
   String^ toCostCategory,
   bool rollOverResourceCosting
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

items

Type: List<RollOverItem>

A collection of items for which the Roll-Over will affect.

warehouses

Type: List<string>

A collection of warehouses for which the Roll-Over will affect.

fromCostCategory

Type: string

The source cost category, from which the costs will be copied.

toCostCategory

Type: string

The destination cost category, to which the costs will be copied.

rollOverResourceCosting

Type: bool

Determines whether or not to execute the Roll-Over for the resource costing data.

Return Value

Type: Result

The Result object with the performed Roll-Over procedure results.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.SynchronizemanufacturingOrders Method

This Method finds all manufacturing orders that are unsynchronized and synchronize them back.

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function SynchronizemanufacturingOrders() As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Result SynchronizemanufacturingOrders()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Result^ SynchronizemanufacturingOrders()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function SynchronizemanufacturingOrders() : Result;
This language is not supported or no code example is available.

Return Value

Type: Result
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.CreatePFObject Method

Factory methood to create ProcessForce Document

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CreatePFObject( _
   ByVal documentType As ObjectTypes _
) As Object
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
object CreatePFObject(
   ObjectTypes documentType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

object^ CreatePFObject(
   ObjectTypes documentType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CreatePFObject(
    documentType : ObjectTypes
) : object;
This language is not supported or no code example is available.

Parameters

documentType

Type: ObjectTypes

Type of Document

Return Value

Type: object

PF document

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


RequestData Class

Members See Also

Namespace: CompuTec.ProcessForce.API.PrintLabels.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class RequestData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RequestData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class RequestData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RequestData
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.PrintLabels.Data.RequestData
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RequestData Members
CompuTec.ProcessForce.API.PrintLabels.Data Namespace


RequestData Members

RequestData Class Methods Fields Properties See Also

The following tables list the members exposed by the RequestData type.

Properties
 | Name | Description
Public property | Item |
Public property | Properties |
Top
Methods
 | Name | Description
 | CreateRequests |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | GetDefinitions |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Send |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
Name | Description
IntFields |
StandardFields |
decimalFields |
Top
See Also

Reference

RequestData Class
CompuTec.ProcessForce.API.PrintLabels.Data Namespace


StandardFields Field

Namespace: CompuTec.ProcessForce.API.PrintLabels.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Shadows ReadOnly StandardFields As String()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
new public static readonly string[] StandardFields
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static array< String^ >^ StandardFields;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static readonly StandardFields : String[]
This language is not supported or no code example is available.

Field Value

Type: string[]
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RequestData Class
RequestData Members
CompuTec.ProcessForce.API.PrintLabels.Data Namespace


IntFields Field

Namespace: CompuTec.ProcessForce.API.PrintLabels.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Shadows ReadOnly IntFields As String()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
new public static readonly string[] IntFields
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static array< String^ >^ IntFields;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static readonly IntFields : String[]
This language is not supported or no code example is available.

Field Value

Type: string[]
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RequestData Class
RequestData Members
CompuTec.ProcessForce.API.PrintLabels.Data Namespace


decimalFields Field

Namespace: CompuTec.ProcessForce.API.PrintLabels.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Shadows ReadOnly decimalFields As String()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
new public static readonly string[] decimalFields
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static array< String^ >^ decimalFields;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static readonly decimalFields : String[]
This language is not supported or no code example is available.

Field Value

Type: string[]
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RequestData Class
RequestData Members
CompuTec.ProcessForce.API.PrintLabels.Data Namespace


RequestData.CreateRequests Method

Namespace: CompuTec.ProcessForce.API.PrintLabels.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function CreateRequests( _
   ByVal rec As CTRecordset _
) As List(Of RequestData)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static List<RequestData> CreateRequests(
   CTRecordset rec
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static List<RequestData^>^ CreateRequests(
   CTRecordset^ rec
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

rec

Type: CTRecordset

Return Value

Type: List<RequestData>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RequestData Class
RequestData Members
CompuTec.ProcessForce.API.PrintLabels.Data Namespace


RequestData.GetDefinitions Method

Namespace: CompuTec.ProcessForce.API.PrintLabels.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetDefinitions( _
   ByVal rec As CTRecordset _
) As List(Of ExtendedDictionaryKeyValue)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static List<ExtendedDictionaryKeyValue> GetDefinitions(
   CTRecordset rec
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static List<ExtendedDictionaryKeyValue^>^ GetDefinitions(
   CTRecordset^ rec
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

rec

Type: CTRecordset

Return Value

Type: List<ExtendedDictionaryKeyValue>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RequestData Class
RequestData Members
CompuTec.ProcessForce.API.PrintLabels.Data Namespace


IProcessForceCompany.CreatePFAction Method

Factory methood to create ProcessForce obect to perform an action

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CreatePFAction( _
   ByVal actionType As ActionType _
) As Object
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
object CreatePFAction(
   ActionType actionType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

object^ CreatePFAction(
   ActionType actionType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CreatePFAction(
    actionType : ActionType
) : object;
This language is not supported or no code example is available.

Parameters

actionType

Type: ActionType

Type of action

Return Value

Type: object

IAction Object

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


UserPrinter.EmployeeDepartmentId Property

Namespace: CompuTec.ProcessForce.API.PrintLabels
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property EmployeeDepartmentId() As Integer
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int EmployeeDepartmentId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int EmployeeDepartmentId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get EmployeeDepartmentId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UserPrinter Class
UserPrinter Members
CompuTec.ProcessForce.API.PrintLabels Namespace


UserPrinter.PrinterNameInSAP Property

Namespace: CompuTec.ProcessForce.API.PrintLabels
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property PrinterNameInSAP() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string PrinterNameInSAP {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ PrinterNameInSAP {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get PrinterNameInSAP() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UserPrinter Class
UserPrinter Members
CompuTec.ProcessForce.API.PrintLabels Namespace


UserPrinter(String) Constructor

Namespace: CompuTec.ProcessForce.API.PrintLabels
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public UserPrinter(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
UserPrinter(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UserPrinter(
    token : String
);
This language is not supported or no code example is available.

Parameters

token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UserPrinter Class
UserPrinter Members
CompuTec.ProcessForce.API.PrintLabels Namespace


UserPrinter Constructor

UserPrinter Class See Also

Overload List
Name | Description
UserPrinter(string) |
UserPrinter(string, int, string, int, int) |
See Also

Reference

UserPrinter Class
UserPrinter Members
CompuTec.ProcessForce.API.PrintLabels Namespace


UserPrinter(String, Int32, String, Int32, Int32) Constructor

Namespace: CompuTec.ProcessForce.API.PrintLabels
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal userName As String, _
   ByVal userId As Integer, _
   ByVal companyName As String, _
   ByVal employeeId As Integer, _
   ByVal employeeDepartmentId As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public UserPrinter(
   string userName,
   int userId,
   string companyName,
   int employeeId,
   int employeeDepartmentId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
UserPrinter(
   String^ userName,
   int userId,
   String^ companyName,
   int employeeId,
   int employeeDepartmentId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UserPrinter(
    userName : String,
    userId : int,
    companyName : String,
    employeeId : int,
    employeeDepartmentId : int
);
This language is not supported or no code example is available.

Parameters

userName

Type: string

userId

Type: int

companyName

Type: string

employeeId

Type: int

employeeDepartmentId

Type: int

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UserPrinter Class
UserPrinter Members
CompuTec.ProcessForce.API.PrintLabels Namespace


UserPrinter.SetPrinterNameInSAP Method

Namespace: CompuTec.ProcessForce.API.PrintLabels
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function SetPrinterNameInSAP() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string SetPrinterNameInSAP()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ SetPrinterNameInSAP()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SetPrinterNameInSAP() : String;
This language is not supported or no code example is available.

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UserPrinter Class
UserPrinter Members
CompuTec.ProcessForce.API.PrintLabels Namespace


ProcessForceCompanyInitializator Class

Members See Also

Class With Factory metohood to create ProcessForceCompany Class;

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ProcessForceCompanyInitializator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ProcessForceCompanyInitializator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ProcessForceCompanyInitializator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ProcessForceCompanyInitializator
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.ProcessForceCompanyInitializator
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProcessForceCompanyInitializator Members
CompuTec.ProcessForce.API Namespace


ProcessForceCompanyInitializator Members

ProcessForceCompanyInitializator Class Methods See Also

Class With Factory metohood to create ProcessForceCompany Class;

The following tables list the members exposed by the ProcessForceCompanyInitializator type.

Methods
 | Name | Description
 | ConnectUI | (Overloaded) Connects to UI where CommmandLine parameter if exists must be SAP Connection String
 | CreateCompany | Methood for creating Process Force Company
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ProcessForceCompanyInitializator Class
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.GenerateBatchNumber Method

This Methood is used to generate next Batch Number for an Item

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GenerateBatchNumber( _
   ByVal ItemCode As String, _
   ByVal Classification As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string GenerateBatchNumber(
   string ItemCode,
   string Classification
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

String^ GenerateBatchNumber(
   String^ ItemCode,
   String^ Classification
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GenerateBatchNumber(
    ItemCode : String,
    Classification : String
) : String;
This language is not supported or no code example is available.

Parameters

ItemCode

Type: string

Item Code of an item

Classification

Type: string

Classification parameter

Return Value

Type: string

Generated String

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.GenerateSerial Method

This Methood is used to generate next Serial nmbers for an Item

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GenerateSerial( _
   ByVal ItemCode As String, _
   ByVal Classification As String, _
   ByRef lotnumber As String, _
   ByRef manNumber As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string GenerateSerial(
   string ItemCode,
   string Classification,
   out string lotnumber,
   out string manNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

String^ GenerateSerial(
   String^ ItemCode,
   String^ Classification,
   String^& lotnumber,
   String^& manNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GenerateSerial(
    ItemCode : String,
    Classification : String,
    lotnumber : String,
    manNumber : String
) : String;
This language is not supported or no code example is available.

Parameters

ItemCode

Type: string

Cod of an item

Classification

Type: string

Classification

lotnumber

Type: string

Out Generated Lot Number

manNumber

Type: string

Out Generated Namufacturing Number

Return Value

Type: string

Returns Dist Number

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


CompuTec.ProcessForce.API.Queries Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | Query |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IProcessForceCompany.GenerateQCTestDocuments Method

This Methood is used to generate Quality Control Test Documents

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GenerateQCTestDocuments( _
   ByVal DocumentType As String, _
   ByVal DocEntry As Integer _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Result GenerateQCTestDocuments(
   string DocumentType,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Result^ GenerateQCTestDocuments(
   String^ DocumentType,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GenerateQCTestDocuments(
    DocumentType : String,
    DocEntry : int
) : Result;
This language is not supported or no code example is available.

Parameters

DocumentType

Type: string

Type of document

DocEntry

Type: int

Document DocEntry

Return Value

Type: Result

Generated String

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.getLastErrorDescription Method

returns Last Error Message

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function getLastErrorDescription() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string getLastErrorDescription()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

String^ getLastErrorDescription()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function getLastErrorDescription() : String;
This language is not supported or no code example is available.

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.GenerateAdditionalBatchDetails Method

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GenerateAdditionalBatchDetails( _
   ByVal docEntry As Integer, _
   ByVal objectType As Integer _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Result GenerateAdditionalBatchDetails(
   int docEntry,
   int objectType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Result^ GenerateAdditionalBatchDetails(
   int docEntry,
   int objectType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GenerateAdditionalBatchDetails(
    docEntry : int,
    objectType : int
) : Result;
This language is not supported or no code example is available.

Parameters

docEntry

Type: int

objectType

Type: int

Return Value

Type: Result
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.RestoreBillOfMaterials Method

Restores Bill of materials synchronization Data NON MRP synchronization

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function RestoreBillOfMaterials() As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Result RestoreBillOfMaterials()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Result^ RestoreBillOfMaterials()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function RestoreBillOfMaterials() : Result;
This language is not supported or no code example is available.

Return Value

Type: Result
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.PerformRollUp (List<RollingUpBillOfMaterials>, List<String>, String, List<String>) Method

Methods that perform Cost Roll Up

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function PerformRollUp( _
   ByVal billOfMaterials As List(Of RollingUpBillOfMaterials), _
   ByVal rawMaterials As List(Of String), _
   ByVal costCategory As String, _
   ByVal warehouses As List(Of String) _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Result PerformRollUp(
   List<RollingUpBillOfMaterials> billOfMaterials,
   List<string> rawMaterials,
   string costCategory,
   List<string> warehouses
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Result^ PerformRollUp(
   List<RollingUpBillOfMaterials^>^ billOfMaterials,
   List<String^>^ rawMaterials,
   String^ costCategory,
   List<String^>^ warehouses
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

billOfMaterials

Type: List<RollingUpBillOfMaterials>

List of Bill Of Materials on with roll up will affect

rawMaterials

Type: List<string>

List of Materials (not BOM) on with roll up will affect

costCategory

Type: string

warehouses

Type: List<string>

Return Value

Type: Result
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


IProcessForceCompany.PerformRollUp Method

IProcessForceCompany Interface See Also

Methods that perform Cost Roll Up

Overload List
Name | Description
PerformRollUp(List<RollingUpBillOfMaterials>, List<String>, string, List<String>) | Methods that perform Cost Roll Up
PerformRollUp(List<RollingUpBillOfMaterials>, List<String>, string, List<String>, bool) | Methods that perform Cost Roll Up
See Also

Reference

IProcessForceCompany Interface
IProcessForceCompany Members
CompuTec.ProcessForce.API Namespace


CompuTec.ProcessForce.API.PrintLabels.Data Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | ExtendedDictionaryKeyValue |
Public class | RequestData |
Top
Enumerations
 | Name | Description
Public enumeration | ActionEnum |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ActionEnum Enumeration

Namespace: CompuTec.ProcessForce.API.PrintLabels.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
NoAction |
Add |
OnChange |
See Also

Reference

CompuTec.ProcessForce.API.PrintLabels.Data Namespace


ExtendedDictionaryKeyValue Class

Members See Also

Namespace: CompuTec.ProcessForce.API.PrintLabels.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ExtendedDictionaryKeyValue
    Inherits DictionaryKeyValue
    Implements ICloneable
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ExtendedDictionaryKeyValue : DictionaryKeyValue,
   ICloneable
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ExtendedDictionaryKeyValue : public DictionaryKeyValue^,
   public ICloneable^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ExtendedDictionaryKeyValue
   extends DictionaryKeyValue
   implements ICloneable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.LabelPrinting.WebApiData.DictionaryKeyValue
CompuTec.ProcessForce.API.PrintLabels.Data.ExtendedDictionaryKeyValue
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExtendedDictionaryKeyValue Members
CompuTec.ProcessForce.API.PrintLabels.Data Namespace


ExtendedDictionaryKeyValue Members

ExtendedDictionaryKeyValue Class Methods Properties See Also

The following tables list the members exposed by the ExtendedDictionaryKeyValue type.

Properties
 | Name | Description
Public property | IsStandard |
Public property | ParameterKey | (inherited from DictionaryKeyValue).
Public property | ParameterType | (inherited from DictionaryKeyValue).
Public property | ParameterValue | (inherited from DictionaryKeyValue).
Public property | Value |
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | GetValue |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ExtendedDictionaryKeyValue Class
CompuTec.ProcessForce.API.PrintLabels.Data Namespace


ExtendedDictionaryKeyValue.IsStandard Property

Namespace: CompuTec.ProcessForce.API.PrintLabels.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property IsStandard() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool IsStandard {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool IsStandard {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get IsStandard() : boolean;
public function set IsStandard(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExtendedDictionaryKeyValue Class
ExtendedDictionaryKeyValue Members
CompuTec.ProcessForce.API.PrintLabels.Data Namespace


ExtendedDictionaryKeyValue.Value Property

Namespace: CompuTec.ProcessForce.API.PrintLabels.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Value() As Object
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public object Value {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property object^ Value {
 object^ get( );
 void set(
   object^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Value() : object;
public function set Value(value : object);
This language is not supported or no code example is available.

Property Value

Type: object
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExtendedDictionaryKeyValue Class
ExtendedDictionaryKeyValue Members
CompuTec.ProcessForce.API.PrintLabels.Data Namespace


ExtendedDictionaryKeyValue.Clone Method

Creates a new object that is a copy of the current instance.

Namespace: CompuTec.ProcessForce.API.PrintLabels.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function Clone() As Object Implements  _
   ICloneable.Clone
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public object Clone()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
object^ Clone()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Clone() : object;
This language is not supported or no code example is available.

Return Value

Type: object

A new object that is a copy of this instance.

Implements

ICloneable.Clone
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExtendedDictionaryKeyValue Class
ExtendedDictionaryKeyValue Members
CompuTec.ProcessForce.API.PrintLabels.Data Namespace


ExtendedDictionaryKeyValue.GetValue Method

Namespace: CompuTec.ProcessForce.API.PrintLabels.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetValue() As Object
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public object GetValue()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
object^ GetValue()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetValue() : object;
This language is not supported or no code example is available.

Return Value

Type: object
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExtendedDictionaryKeyValue Class
ExtendedDictionaryKeyValue Members
CompuTec.ProcessForce.API.PrintLabels.Data Namespace


RequestData.Properties Property

Namespace: CompuTec.ProcessForce.API.PrintLabels.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Properties() As Dictionary(Of String, ExtendedDictionaryKeyValue)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Dictionary<string, ExtendedDictionaryKeyValue> Properties {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property Dictionary<String^, ExtendedDictionaryKeyValue^>^ Properties {
 Dictionary<String^, ExtendedDictionaryKeyValue^>^ get( );
 void set(
   Dictionary<String^, ExtendedDictionaryKeyValue^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: Dictionary<string, ExtendedDictionaryKeyValue>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RequestData Class
RequestData Members
CompuTec.ProcessForce.API.PrintLabels.Data Namespace


RequestData.Item Property

Namespace: CompuTec.ProcessForce.API.PrintLabels.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property Item( _
   ByVal propertyName As String _
) As Object
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public object this[
   string propertyName
] {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property object^ Item[String] {
 object^ get(
   String^ propertyName
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript suports the use of indexed properties, but not the declaration of new ones.
This language is not supported or no code example is available.

Parameters

propertyName

Type: string

Property Value

Type: object
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RequestData Class
RequestData Members
CompuTec.ProcessForce.API.PrintLabels.Data Namespace


RequestData.Send Method

Namespace: CompuTec.ProcessForce.API.PrintLabels.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function Send( _
   ByVal PrintingClient As PrintingClient, _
   ByVal user As UserPrinter _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool Send(
   PrintingClient PrintingClient,
   UserPrinter user
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool Send(
   PrintingClient^ PrintingClient,
   UserPrinter^ user
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Send(
    PrintingClient : PrintingClient,
    user : UserPrinter
) : boolean;
This language is not supported or no code example is available.

Parameters

PrintingClient

Type: PrintingClient

user

Type: UserPrinter

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RequestData Class
RequestData Members
CompuTec.ProcessForce.API.PrintLabels.Data Namespace


CompuTec.ProcessForce.API.PrintLabels Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | UserPrinter |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


UserPrinter Class

Members See Also

Namespace: CompuTec.ProcessForce.API.PrintLabels
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class UserPrinter
    Implements IUserPrinter
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class UserPrinter : IUserPrinter
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class UserPrinter  : public IUserPrinter^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class UserPrinter
   implements IUserPrinter
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.PrintLabels.UserPrinter
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UserPrinter Members
CompuTec.ProcessForce.API.PrintLabels Namespace


UserPrinter Members

UserPrinter Class Constructors Methods Properties See Also

The following tables list the members exposed by the UserPrinter type.

Constructors
 | Name | Description
Public constructor | UserPrinter | (Overloaded)
Top
Properties
 | Name | Description
Public property | CompanyName |
Public property | EmployeeDepartmentId |
Public property | EmployeeId |
Public property | PrinterNameInSAP |
Public property | Token |
Public property | UserId |
Public property | UserName |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | SetPrinterNameInSAP |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

UserPrinter Class
CompuTec.ProcessForce.API.PrintLabels Namespace


UserPrinter.Token Property

Namespace: CompuTec.ProcessForce.API.PrintLabels
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Token() As String
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Token {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Token {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Token() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UserPrinter Class
UserPrinter Members
CompuTec.ProcessForce.API.PrintLabels Namespace


UserPrinter.UserName Property

Namespace: CompuTec.ProcessForce.API.PrintLabels
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property UserName() As String
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string UserName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ UserName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get UserName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UserPrinter Class
UserPrinter Members
CompuTec.ProcessForce.API.PrintLabels Namespace


UserPrinter.UserId Property

Namespace: CompuTec.ProcessForce.API.PrintLabels
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property UserId() As Integer
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int UserId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int UserId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get UserId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UserPrinter Class
UserPrinter Members
CompuTec.ProcessForce.API.PrintLabels Namespace


UserPrinter.CompanyName Property

Namespace: CompuTec.ProcessForce.API.PrintLabels
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property CompanyName() As String
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string CompanyName {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ CompanyName {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get CompanyName() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UserPrinter Class
UserPrinter Members
CompuTec.ProcessForce.API.PrintLabels Namespace


UserPrinter.EmployeeId Property

Namespace: CompuTec.ProcessForce.API.PrintLabels
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property EmployeeId() As Integer
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int EmployeeId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int EmployeeId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get EmployeeId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UserPrinter Class
UserPrinter Members
CompuTec.ProcessForce.API.PrintLabels Namespace


ProcessForceCompanyInitializator.CreateCompany Method

Example See Also

Methood for creating Process Force Company

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function CreateCompany() As IProcessForceCompany
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static IProcessForceCompany CreateCompany()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static IProcessForceCompany^ CreateCompany()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function CreateCompany() : IProcessForceCompany;
This language is not supported or no code example is available.

Return Value

Type: IProcessForceCompany

IProcessForceClass that is used for connectiong and working with PF and SAP object

Example
IProcessForceCompany pfcomp=ProcessForceCompanyInitializator.CreateCompany();
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProcessForceCompanyInitializator Class
ProcessForceCompanyInitializator Members
CompuTec.ProcessForce.API Namespace


ProcessForceCompanyInitializator.ConnectUI (Application) Method

Connects to UI where CommmandLine parameter if exists must be SAP Connection String

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function ConnectUI( _
   ByRef app As Application _
) As IProcessForceCompany
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static IProcessForceCompany ConnectUI(
   out Application app
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static IProcessForceCompany^ ConnectUI(
   Application^& app
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function ConnectUI(
    app : Application
) : IProcessForceCompany;
This language is not supported or no code example is available.

Parameters

app

Type: Application

SAPBOUI.Application

Return Value

Type: IProcessForceCompany

ProcessForceCompany interface

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProcessForceCompanyInitializator Class
ProcessForceCompanyInitializator Members
CompuTec.ProcessForce.API Namespace


ProcessForceCompanyInitializator.ConnectUI Method

ProcessForceCompanyInitializator Class See Also

Connects to UI where CommmandLine parameter if exists must be SAP Connection String

Overload List
Name | Description
ConnectUI(out Application) | Connects to UI where CommmandLine parameter if exists must be SAP Connection String
ConnectUI(out Application, bool) | Connects to UI where CommmandLine parameter if exists must be SAP Connection String if UseDeveloperConnection strings is false
See Also

Reference

ProcessForceCompanyInitializator Class
ProcessForceCompanyInitializator Members
CompuTec.ProcessForce.API Namespace


ProcessForceCompanyInitializator.ConnectUI (Application, Boolean) Method

Connects to UI where CommmandLine parameter if exists must be SAP Connection String if UseDeveloperConnection strings is false

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function ConnectUI( _
   ByRef app As Application, _
   ByVal useDeveloerConnectionString As Boolean _
) As IProcessForceCompany
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static IProcessForceCompany ConnectUI(
   out Application app,
   bool useDeveloerConnectionString
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static IProcessForceCompany^ ConnectUI(
   Application^& app,
   bool useDeveloerConnectionString
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function ConnectUI(
    app : Application,
    useDeveloerConnectionString : boolean
) : IProcessForceCompany;
This language is not supported or no code example is available.

Parameters

app

Type: Application

SAPBOUI.Application

useDeveloerConnectionString

Type: bool

if True Uses Developer Connection string

Return Value

Type: IProcessForceCompany

ProcessForceCompany interface

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProcessForceCompanyInitializator Class
ProcessForceCompanyInitializator Members
CompuTec.ProcessForce.API Namespace


MRPBaseQueries.BaseSalesOrderLoader (String, Boolean, String) Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function BaseSalesOrderLoader( _
   ByVal Token As String, _
   ByVal includerevisions As Boolean, _
   ByVal scenarioCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset BaseSalesOrderLoader(
   string Token,
   bool includerevisions,
   string scenarioCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ BaseSalesOrderLoader(
   String^ Token,
   bool includerevisions,
   String^ scenarioCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BaseSalesOrderLoader(
    Token : String,
    includerevisions : boolean,
    scenarioCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

includerevisions

Type: bool

scenarioCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


MRPBaseQueries.BaseSalesOrderLoader (String, Boolean, Boolean, Boolean, IEnumerable<String>, IEnumerable<String>, IEnumerable<Int32>) Method

Namespace: CompuTec.ProcessForce.API.Queries.MRP
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function BaseSalesOrderLoader( _
   ByVal Token As String, _
   ByVal allItems As Boolean, _
   ByVal AllWhs As Boolean, _
   ByVal AllDocuments As Boolean, _
   ByVal items As IEnumerable(Of String), _
   ByVal whss As IEnumerable(Of String), _
   ByVal docs As IEnumerable(Of Integer) _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset BaseSalesOrderLoader(
   string Token,
   bool allItems,
   bool AllWhs,
   bool AllDocuments,
   IEnumerable<string> items,
   IEnumerable<string> whss,
   IEnumerable<int> docs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ BaseSalesOrderLoader(
   String^ Token,
   bool allItems,
   bool AllWhs,
   bool AllDocuments,
   IEnumerable<String^>^ items,
   IEnumerable<String^>^ whss,
   IEnumerable<int>^ docs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

allItems

Type: bool

AllWhs

Type: bool

AllDocuments

Type: bool

items

Type: IEnumerable<string>

whss

Type: IEnumerable<string>

docs

Type: IEnumerable<int>

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPBaseQueries Class
MRPBaseQueries Members
CompuTec.ProcessForce.API.Queries.MRP Namespace


Query Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Queries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineQueryManger()> _
Public Class Query
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQueryManger()]
public class Query
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineQueryManger()]
public ref class Query
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineQueryManger()
class Query
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Queries.Query
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Query Members
CompuTec.ProcessForce.API.Queries Namespace


Query Members

Query Class Methods Properties See Also

The following tables list the members exposed by the Query type.

Properties
Name | Description
CostingQueries |
IngredientsQueries |
ItemDetailsQueries |
MRPQueries |
MaintananceBaseQueries |
PickAndPackQueries |
QualityControlQueries |
SchedulingQueries |
SystemQueries |
TechnologyQueries |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Query Class
CompuTec.ProcessForce.API.Queries Namespace


Query.CostingQueries Property

Namespace: CompuTec.ProcessForce.API.Queries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Shared Property CostingQueries() As ICostingQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static ICostingQueries CostingQueries {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property ICostingQueries^ CostingQueries {
 ICostingQueries^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get CostingQueries() : ICostingQueries;
This language is not supported or no code example is available.

Property Value

Type: ICostingQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Query Class
Query Members
CompuTec.ProcessForce.API.Queries Namespace


Query.TechnologyQueries Property

Namespace: CompuTec.ProcessForce.API.Queries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Shared Property TechnologyQueries() As ITechnologyQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static ITechnologyQueries TechnologyQueries {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property ITechnologyQueries^ TechnologyQueries {
 ITechnologyQueries^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get TechnologyQueries() : ITechnologyQueries;
This language is not supported or no code example is available.

Property Value

Type: ITechnologyQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Query Class
Query Members
CompuTec.ProcessForce.API.Queries Namespace


Query.MRPQueries Property

Namespace: CompuTec.ProcessForce.API.Queries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Shared Property MRPQueries() As IMRPQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static IMRPQueries MRPQueries {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property IMRPQueries^ MRPQueries {
 IMRPQueries^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get MRPQueries() : IMRPQueries;
This language is not supported or no code example is available.

Property Value

Type: IMRPQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Query Class
Query Members
CompuTec.ProcessForce.API.Queries Namespace


Query.SystemQueries Property

Namespace: CompuTec.ProcessForce.API.Queries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Shared Property SystemQueries() As ISystemQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static ISystemQueries SystemQueries {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property ISystemQueries^ SystemQueries {
 ISystemQueries^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get SystemQueries() : ISystemQueries;
This language is not supported or no code example is available.

Property Value

Type: ISystemQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Query Class
Query Members
CompuTec.ProcessForce.API.Queries Namespace


Query.ItemDetailsQueries Property

Namespace: CompuTec.ProcessForce.API.Queries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Shared Property ItemDetailsQueries() As IItemDetailsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static IItemDetailsQueries ItemDetailsQueries {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property IItemDetailsQueries^ ItemDetailsQueries {
 IItemDetailsQueries^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get ItemDetailsQueries() : IItemDetailsQueries;
This language is not supported or no code example is available.

Property Value

Type: IItemDetailsQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Query Class
Query Members
CompuTec.ProcessForce.API.Queries Namespace


Query.IngredientsQueries Property

Namespace: CompuTec.ProcessForce.API.Queries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Shared Property IngredientsQueries() As IIngredientsQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static IIngredientsQueries IngredientsQueries {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property IIngredientsQueries^ IngredientsQueries {
 IIngredientsQueries^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get IngredientsQueries() : IIngredientsQueries;
This language is not supported or no code example is available.

Property Value

Type: IIngredientsQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Query Class
Query Members
CompuTec.ProcessForce.API.Queries Namespace


Query.MaintananceBaseQueries Property

Namespace: CompuTec.ProcessForce.API.Queries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Shared Property MaintananceBaseQueries() As IMaintananceBaseQuery
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static IMaintananceBaseQuery MaintananceBaseQueries {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property IMaintananceBaseQuery^ MaintananceBaseQueries {
 IMaintananceBaseQuery^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get MaintananceBaseQueries() : IMaintananceBaseQuery;
This language is not supported or no code example is available.

Property Value

Type: IMaintananceBaseQuery
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Query Class
Query Members
CompuTec.ProcessForce.API.Queries Namespace


Query.PickAndPackQueries Property

Namespace: CompuTec.ProcessForce.API.Queries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Shared Property PickAndPackQueries() As IPickAndPackQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static IPickAndPackQueries PickAndPackQueries {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property IPickAndPackQueries^ PickAndPackQueries {
 IPickAndPackQueries^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get PickAndPackQueries() : IPickAndPackQueries;
This language is not supported or no code example is available.

Property Value

Type: IPickAndPackQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Query Class
Query Members
CompuTec.ProcessForce.API.Queries Namespace


Query.SchedulingQueries Property

Namespace: CompuTec.ProcessForce.API.Queries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Shared Property SchedulingQueries() As ISchedulingQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static ISchedulingQueries SchedulingQueries {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property ISchedulingQueries^ SchedulingQueries {
 ISchedulingQueries^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get SchedulingQueries() : ISchedulingQueries;
This language is not supported or no code example is available.

Property Value

Type: ISchedulingQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Query Class
Query Members
CompuTec.ProcessForce.API.Queries Namespace


Query.QualityControlQueries Property

Namespace: CompuTec.ProcessForce.API.Queries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Shared Property QualityControlQueries() As IQualityControlQueries
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static IQualityControlQueries QualityControlQueries {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property IQualityControlQueries^ QualityControlQueries {
 IQualityControlQueries^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get QualityControlQueries() : IQualityControlQueries;
This language is not supported or no code example is available.

Property Value

Type: IQualityControlQueries
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Query Class
Query Members
CompuTec.ProcessForce.API.Queries Namespace


ISchedulingQueries.GetValueOfInternalLeadTime (String, String, String, String, String, String, DateTime, Boolean) Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetValueOfInternalLeadTime( _
   ByVal Token As String, _
   ByVal shipToAddressValue As String, _
   ByVal customerCodeValue As String, _
   ByVal itemCodeValue As String, _
   ByVal revisionCodeValue As String, _
   ByVal warehouseValue As String, _
   ByVal dateTime As Date, _
   Optional ByVal trueForFutureFalseForPast As Boolean = true _
) As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan GetValueOfInternalLeadTime(
   string Token,
   string shipToAddressValue,
   string customerCodeValue,
   string itemCodeValue,
   string revisionCodeValue,
   string warehouseValue,
   DateTime dateTime,
   bool trueForFutureFalseForPast = true
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

TimeSpan GetValueOfInternalLeadTime(
   String^ Token,
   String^ shipToAddressValue,
   String^ customerCodeValue,
   String^ itemCodeValue,
   String^ revisionCodeValue,
   String^ warehouseValue,
   DateTime dateTime,
   bool trueForFutureFalseForPast
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetValueOfInternalLeadTime(
    Token : String,
    shipToAddressValue : String,
    customerCodeValue : String,
    itemCodeValue : String,
    revisionCodeValue : String,
    warehouseValue : String,
    dateTime : DateTime,
    trueForFutureFalseForPast : boolean
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

Token

Type: string

shipToAddressValue

Type: string

customerCodeValue

Type: string

itemCodeValue

Type: string

revisionCodeValue

Type: string

warehouseValue

Type: string

dateTime

Type: DateTime

trueForFutureFalseForPast

Type: bool

Return Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetValueOfInternalLeadTime (String, String, String, String, String, DateTime, Boolean) Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetValueOfInternalLeadTime( _
   ByVal Token As String, _
   ByVal customerCodeValue As String, _
   ByVal itemCodeValue As String, _
   ByVal revisionCodeValue As String, _
   ByVal warehouseValue As String, _
   ByVal dateTime As Date, _
   Optional ByVal trueForFutureFalseForPast As Boolean = true _
) As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan GetValueOfInternalLeadTime(
   string Token,
   string customerCodeValue,
   string itemCodeValue,
   string revisionCodeValue,
   string warehouseValue,
   DateTime dateTime,
   bool trueForFutureFalseForPast = true
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

TimeSpan GetValueOfInternalLeadTime(
   String^ Token,
   String^ customerCodeValue,
   String^ itemCodeValue,
   String^ revisionCodeValue,
   String^ warehouseValue,
   DateTime dateTime,
   bool trueForFutureFalseForPast
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetValueOfInternalLeadTime(
    Token : String,
    customerCodeValue : String,
    itemCodeValue : String,
    revisionCodeValue : String,
    warehouseValue : String,
    dateTime : DateTime,
    trueForFutureFalseForPast : boolean
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

Token

Type: string

customerCodeValue

Type: string

itemCodeValue

Type: string

revisionCodeValue

Type: string

warehouseValue

Type: string

dateTime

Type: DateTime

trueForFutureFalseForPast

Type: bool

Return Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetValueOfDeliveryTime (String, String, String) Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetValueOfDeliveryTime( _
   ByVal Token As String, _
   ByVal shipToAddressValue As String, _
   ByVal customerCodeValue As String _
) As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime GetValueOfDeliveryTime(
   string Token,
   string shipToAddressValue,
   string customerCodeValue
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

DateTime GetValueOfDeliveryTime(
   String^ Token,
   String^ shipToAddressValue,
   String^ customerCodeValue
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetValueOfDeliveryTime(
    Token : String,
    shipToAddressValue : String,
    customerCodeValue : String
) : DateTime;
This language is not supported or no code example is available.

Parameters

Token

Type: string

shipToAddressValue

Type: string

customerCodeValue

Type: string

Return Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


ISchedulingQueries.GetValueOfDeliveryTime (String, String) Method

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetValueOfDeliveryTime( _
   ByVal Token As String, _
   ByVal customerCodeValue As String _
) As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime GetValueOfDeliveryTime(
   string Token,
   string customerCodeValue
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

DateTime GetValueOfDeliveryTime(
   String^ Token,
   String^ customerCodeValue
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetValueOfDeliveryTime(
    Token : String,
    customerCodeValue : String
) : DateTime;
This language is not supported or no code example is available.

Parameters

Token

Type: string

customerCodeValue

Type: string

Return Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISchedulingQueries Interface
ISchedulingQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetValueOfInternalLeadTime (String, String, String, String, String, String, DateTime, Boolean) Method

The method is going to receive value of internal lead time as is mentioned in hierarchy. First is going to check in business partner address, then business partner general. The next tries would be in item details revision and the other one in item master data in case row contains item, not the bom. Then warehouse is going to be check, but only in case if the operation was triggered from line, not the header. Last place which is going to be be check is document settings. If there is no value then empty string is going to be received.

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetValueOfInternalLeadTime( _
   ByVal Token As String, _
   ByVal shipToAddressValue As String, _
   ByVal customerCodeValue As String, _
   ByVal itemCodeValue As String, _
   ByVal revisionCodeValue As String, _
   ByVal warehouseValue As String, _
   ByVal dateTime As Date, _
   Optional ByVal trueForFutureFalseForPast As Boolean = true _
) As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan GetValueOfInternalLeadTime(
   string Token,
   string shipToAddressValue,
   string customerCodeValue,
   string itemCodeValue,
   string revisionCodeValue,
   string warehouseValue,
   DateTime dateTime,
   bool trueForFutureFalseForPast = true
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeSpan GetValueOfInternalLeadTime(
   String^ Token,
   String^ shipToAddressValue,
   String^ customerCodeValue,
   String^ itemCodeValue,
   String^ revisionCodeValue,
   String^ warehouseValue,
   DateTime dateTime,
   bool trueForFutureFalseForPast
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetValueOfInternalLeadTime(
    Token : String,
    shipToAddressValue : String,
    customerCodeValue : String,
    itemCodeValue : String,
    revisionCodeValue : String,
    warehouseValue : String,
    dateTime : DateTime,
    trueForFutureFalseForPast : boolean
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

Token

Type: string

shipToAddressValue

Type: string

customerCodeValue

Type: string

itemCodeValue

Type: string

revisionCodeValue

Type: string

warehouseValue

Type: string

dateTime

Type: DateTime

trueForFutureFalseForPast

Type: bool

Return Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetValueOfInternalLeadTime (String, String, String, String, String, DateTime, Boolean) Method

The method is going to receive value of internal lead time as is mentioned in hierarchy. First is going to check in business partner address, then business partner general. The next try would be in item mater data in case row contains item, not the bom. Then warehouse is going to be check, but only in case if the operation was triggered from line, not the header. Last place which is going to be be check is document settings. If there is no value then empty string is going to be received.

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetValueOfInternalLeadTime( _
   ByVal Token As String, _
   ByVal customerCodeValue As String, _
   ByVal itemCodeValue As String, _
   ByVal revisionCodeValue As String, _
   ByVal warehouseValue As String, _
   ByVal dateTime As Date, _
   Optional ByVal trueForFutureFalseForPast As Boolean = true _
) As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan GetValueOfInternalLeadTime(
   string Token,
   string customerCodeValue,
   string itemCodeValue,
   string revisionCodeValue,
   string warehouseValue,
   DateTime dateTime,
   bool trueForFutureFalseForPast = true
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeSpan GetValueOfInternalLeadTime(
   String^ Token,
   String^ customerCodeValue,
   String^ itemCodeValue,
   String^ revisionCodeValue,
   String^ warehouseValue,
   DateTime dateTime,
   bool trueForFutureFalseForPast
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetValueOfInternalLeadTime(
    Token : String,
    customerCodeValue : String,
    itemCodeValue : String,
    revisionCodeValue : String,
    warehouseValue : String,
    dateTime : DateTime,
    trueForFutureFalseForPast : boolean
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

Token

Type: string

customerCodeValue

Type: string

itemCodeValue

Type: string

revisionCodeValue

Type: string

warehouseValue

Type: string

dateTime

Type: DateTime

trueForFutureFalseForPast

Type: bool

Return Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetValueOfDeliveryTime (String, String, String) Method

Method is receiving delivery time as in hierarchy. First is going go check in business partner address and if there is no, then is trying to get this information from header of business partner. If there is no value in business partner address, neither in business partner then method is going to receive empty string.

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetValueOfDeliveryTime( _
   ByVal Token As String, _
   ByVal shipToAddressValue As String, _
   ByVal customerCodeValue As String _
) As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime GetValueOfDeliveryTime(
   string Token,
   string shipToAddressValue,
   string customerCodeValue
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DateTime GetValueOfDeliveryTime(
   String^ Token,
   String^ shipToAddressValue,
   String^ customerCodeValue
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetValueOfDeliveryTime(
    Token : String,
    shipToAddressValue : String,
    customerCodeValue : String
) : DateTime;
This language is not supported or no code example is available.

Parameters

Token

Type: string

shipToAddressValue

Type: string

customerCodeValue

Type: string

Return Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


SchedulingBaseQueries.GetValueOfDeliveryTime (String, String) Method

This version of method is going to check requested business partner's default ship to address and then business partner header. Original description: Method is receiving delivery time as in hierarchy. First is going go check in business partner address and if there is no, then is trying to get this information from header of business partner. If there is no value in business partner address, neither in business partner then method is going to receive empty string.

Namespace: CompuTec.ProcessForce.API.Queries.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetValueOfDeliveryTime( _
   ByVal Token As String, _
   ByVal customerCodeValue As String _
) As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime GetValueOfDeliveryTime(
   string Token,
   string customerCodeValue
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DateTime GetValueOfDeliveryTime(
   String^ Token,
   String^ customerCodeValue
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetValueOfDeliveryTime(
    Token : String,
    customerCodeValue : String
) : DateTime;
This language is not supported or no code example is available.

Parameters

Token

Type: string

customerCodeValue

Type: string

Return Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SchedulingBaseQueries Class
SchedulingBaseQueries Members
CompuTec.ProcessForce.API.Queries.Scheduling Namespace


BaseTechnologyQueries.GetProductionOrdersThatHaveIssuedItems (String, Int32) Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetProductionOrdersThatHaveIssuedItems( _
   ByVal token As String, _
   ByVal docEntry As Integer _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetProductionOrdersThatHaveIssuedItems(
   string token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetProductionOrdersThatHaveIssuedItems(
   String^ token,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetProductionOrdersThatHaveIssuedItems(
    token : String,
    docEntry : int
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

docEntry

Type: int

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetProductionOrdersThatHaveIssuedItems (String) Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetProductionOrdersThatHaveIssuedItems( _
   ByVal token As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetProductionOrdersThatHaveIssuedItems(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetProductionOrdersThatHaveIssuedItems(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetProductionOrdersThatHaveIssuedItems(
    token : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetAlternativeResourcesGant (String, String, String, Int32, String, String, String) Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAlternativeResourcesGant( _
   ByVal Token As String, _
   ByVal BomCode As String, _
   ByVal Revision As String, _
   ByVal RtgOprCode As Integer, _
   ByVal RtgCode As String, _
   ByVal OprCode As String, _
   ByVal RscType As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAlternativeResourcesGant(
   string Token,
   string BomCode,
   string Revision,
   int RtgOprCode,
   string RtgCode,
   string OprCode,
   string RscType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAlternativeResourcesGant(
   String^ Token,
   String^ BomCode,
   String^ Revision,
   int RtgOprCode,
   String^ RtgCode,
   String^ OprCode,
   String^ RscType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAlternativeResourcesGant(
    Token : String,
    BomCode : String,
    Revision : String,
    RtgOprCode : int,
    RtgCode : String,
    OprCode : String,
    RscType : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

BomCode

Type: string

Revision

Type: string

RtgOprCode

Type: int

RtgCode

Type: string

OprCode

Type: string

RscType

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


BaseTechnologyQueries.GetAlternativeResourcesGant (String, String, String, Int32, String, String) Method

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAlternativeResourcesGant( _
   ByVal Token As String, _
   ByVal BomCode As String, _
   ByVal Revision As String, _
   ByVal RtgOprCode As Integer, _
   ByVal RtgCode As String, _
   ByVal OprCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CTRecordset GetAlternativeResourcesGant(
   string Token,
   string BomCode,
   string Revision,
   int RtgOprCode,
   string RtgCode,
   string OprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CTRecordset^ GetAlternativeResourcesGant(
   String^ Token,
   String^ BomCode,
   String^ Revision,
   int RtgOprCode,
   String^ RtgCode,
   String^ OprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAlternativeResourcesGant(
    Token : String,
    BomCode : String,
    Revision : String,
    RtgOprCode : int,
    RtgCode : String,
    OprCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

BomCode

Type: string

Revision

Type: string

RtgOprCode

Type: int

RtgCode

Type: string

OprCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseTechnologyQueries Class
BaseTechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetAlternativeResourcesGant (String, String, String, Int32, String, String, String) Method

snull(t1.U_RscCode,'') [AltTOOL], T0.*

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAlternativeResourcesGant( _
   ByVal Token As String, _
   ByVal BomCode As String, _
   ByVal Revision As String, _
   ByVal RtgOprCode As Integer, _
   ByVal RtgCode As String, _
   ByVal OprCode As String, _
   ByVal RscType As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetAlternativeResourcesGant(
   string Token,
   string BomCode,
   string Revision,
   int RtgOprCode,
   string RtgCode,
   string OprCode,
   string RscType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetAlternativeResourcesGant(
   String^ Token,
   String^ BomCode,
   String^ Revision,
   int RtgOprCode,
   String^ RtgCode,
   String^ OprCode,
   String^ RscType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetAlternativeResourcesGant(
    Token : String,
    BomCode : String,
    Revision : String,
    RtgOprCode : int,
    RtgCode : String,
    OprCode : String,
    RscType : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

BomCode

Type: string

Revision

Type: string

RtgOprCode

Type: int

RtgCode

Type: string

OprCode

Type: string

RscType

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


ITechnologyQueries.GetAlternativeResourcesGant (String, String, String, Int32, String, String) Method

U_RscCode

Namespace: CompuTec.ProcessForce.API.Queries.TechnologyQueries
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAlternativeResourcesGant( _
   ByVal Token As String, _
   ByVal BomCode As String, _
   ByVal Revision As String, _
   ByVal RtgOprCode As Integer, _
   ByVal RtgCode As String, _
   ByVal OprCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
CTRecordset GetAlternativeResourcesGant(
   string Token,
   string BomCode,
   string Revision,
   int RtgOprCode,
   string RtgCode,
   string OprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

CTRecordset^ GetAlternativeResourcesGant(
   String^ Token,
   String^ BomCode,
   String^ Revision,
   int RtgOprCode,
   String^ RtgCode,
   String^ OprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetAlternativeResourcesGant(
    Token : String,
    BomCode : String,
    Revision : String,
    RtgOprCode : int,
    RtgCode : String,
    OprCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

Token

Type: string

BomCode

Type: string

Revision

Type: string

RtgOprCode

Type: int

RtgCode

Type: string

OprCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITechnologyQueries Interface
ITechnologyQueries Members
CompuTec.ProcessForce.API.Queries.TechnologyQueries Namespace


CompuTec.ProcessForce.API.Scheduling Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | BaseSchedule | .This Class Implements base factory calendar Schedule without Avalibility
Public class | DateOutOfRangeException |
Public class | InvaildDatesParametersException |
Public class | MultiResourceScheduler |
Public class | MultiScheduleParameters | This Class is used to Schedule manu mors in one interval
Public class | ProjectionScenario |
Public class | ResourceAndLinkedTools |
Public class | SapCalendar | This Class Implements Standard Schedule Of An Resource it Should implement All Avaliblility of resource
Public class | Schedule | This Class Implements Standard Schedule Of An Resource it Should implement All Avaliblility of resource
Public class | ScheduleInterval | This Class Is Used To Store information of Time Interval in one day used in Schedule but not in operations
Public class | ScheduleManager |
Public class | ScheduleResults |
Public class | SetOfScenarios |
Public class | TimeInterval |
Public class | TimeIntervals | Class that Holds TimeInterval Collection
Top
Interfaces
 | Name | Description
Public interface | ITimeInterval |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


BaseSchedule Class

Members See Also

.This Class Implements base factory calendar Schedule without Avalibility

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BaseSchedule
    Inherits CoreSchedule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BaseSchedule : CoreSchedule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BaseSchedule : public CoreSchedule^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BaseSchedule
   extends CoreSchedule
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Scheduling.Core.CoreSchedule
CompuTec.ProcessForce.API.Scheduling.BaseSchedule
CompuTec.ProcessForce.API.Scheduling.SapCalendar
CompuTec.ProcessForce.API.Scheduling.Schedule
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSchedule Members
CompuTec.ProcessForce.API.Scheduling Namespace


BaseSchedule Members

BaseSchedule Class Constructors Methods Fields Properties See Also

.This Class Implements base factory calendar Schedule without Avalibility

The following tables list the members exposed by the BaseSchedule type.

Constructors
 | Name | Description
Public constructor | BaseSchedule | (Overloaded)
Top
Properties
 | Name | Description
Public property | Resource |
Public property | ResourceCalendar |
Public property | ResourceCode | (inherited from CoreSchedule).
Public property | ResourceName | (inherited from CoreSchedule).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAvailbleEffort | This Function Checks Resource calendar and calculates What effort is availble between these two dates (inherited from CoreSchedule).
Public method | GetFinish | (inherited from CoreSchedule).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetIntervalsForSpecificDays | (inherited from CoreSchedule).
Public method | GetIntervalsForSpecificRange | (inherited from CoreSchedule).
Public method | GetNextWorkingTime | (inherited from CoreSchedule).
Public method | GetPreviousWorkingTime | (inherited from CoreSchedule).
Public method | GetStart | (inherited from CoreSchedule).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
 | Name | Description
 | DayOfWeekTable | (inherited from CoreSchedule).
Public field | holidays | (inherited from CoreSchedule).
Public field | standardweek | (inherited from CoreSchedule).
Public field | workexceptions | (inherited from CoreSchedule).
Top
See Also

Reference

BaseSchedule Class
CompuTec.ProcessForce.API.Scheduling Namespace


BaseSchedule(String) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BaseSchedule(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BaseSchedule(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BaseSchedule(
    token : String
);
This language is not supported or no code example is available.

Parameters

token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSchedule Class
BaseSchedule Members
CompuTec.ProcessForce.API.Scheduling Namespace


BaseSchedule Constructor

BaseSchedule Class See Also

Overload List
Name | Description
BaseSchedule(string) |
BaseSchedule(string, List<DateTime>, Dictionary<DayOfWeekTimeIntervals>, Dictionary<DateTimeTimeIntervals>) |
BaseSchedule(string, string) |
See Also

Reference

BaseSchedule Class
BaseSchedule Members
CompuTec.ProcessForce.API.Scheduling Namespace


BaseSchedule(String, List<DateTime>, Dictionary<DayOfWeekTimeIntervals>, Dictionary<DateTimeTimeIntervals>) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String, _
   ByVal _holidays As List(Of Date), _
   ByVal _standardWeek As Dictionary(Of DayOfWeek, TimeIntervals), _
   ByVal _workexceptions As Dictionary(Of Date, TimeIntervals) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BaseSchedule(
   string token,
   List<DateTime> _holidays,
   Dictionary<DayOfWeek, TimeIntervals> _standardWeek,
   Dictionary<DateTime, TimeIntervals> _workexceptions
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BaseSchedule(
   String^ token,
   List<DateTime>^ _holidays,
   Dictionary<DayOfWeek, TimeIntervals^>^ _standardWeek,
   Dictionary<DateTime, TimeIntervals^>^ _workexceptions
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

_holidays

Type: List<DateTime>

_standardWeek

Type: Dictionary<DayOfWeek, TimeIntervals>

_workexceptions

Type: Dictionary<DateTime, TimeIntervals>

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSchedule Class
BaseSchedule Members
CompuTec.ProcessForce.API.Scheduling Namespace


BaseSchedule(String, String) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String, _
   ByVal resourceCode As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BaseSchedule(
   string token,
   string resourceCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BaseSchedule(
   String^ token,
   String^ resourceCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BaseSchedule(
    token : String,
    resourceCode : String
);
This language is not supported or no code example is available.

Parameters

token

Type: string

resourceCode

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSchedule Class
BaseSchedule Members
CompuTec.ProcessForce.API.Scheduling Namespace


BaseSchedule.Resource Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property Resource() As IResource
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IResource Resource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IResource^ Resource {
 IResource^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Resource() : IResource;
This language is not supported or no code example is available.

Property Value

Type: IResource
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSchedule Class
BaseSchedule Members
CompuTec.ProcessForce.API.Scheduling Namespace


BaseSchedule.ResourceCalendar Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property ResourceCalendar() As IResourceCalendar
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IResourceCalendar ResourceCalendar {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property IResourceCalendar^ ResourceCalendar {
 IResourceCalendar^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ResourceCalendar() : IResourceCalendar;
This language is not supported or no code example is available.

Property Value

Type: IResourceCalendar
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseSchedule Class
BaseSchedule Members
CompuTec.ProcessForce.API.Scheduling Namespace


DateOutOfRangeException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class DateOutOfRangeException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class DateOutOfRangeException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class DateOutOfRangeException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class DateOutOfRangeException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Scheduling.DateOutOfRangeException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DateOutOfRangeException Members
CompuTec.ProcessForce.API.Scheduling Namespace


DateOutOfRangeException Members

DateOutOfRangeException Class Constructors Methods Properties See Also

The following tables list the members exposed by the DateOutOfRangeException type.

Constructors
 | Name | Description
Public constructor | DateOutOfRangeException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

DateOutOfRangeException Class
CompuTec.ProcessForce.API.Scheduling Namespace


DateOutOfRangeException Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateOutOfRangeException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DateOutOfRangeException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DateOutOfRangeException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DateOutOfRangeException Class
DateOutOfRangeException Members
CompuTec.ProcessForce.API.Scheduling Namespace


DateOutOfRangeException Constructor

DateOutOfRangeException Class See Also

Overload List
Name | Description
DateOutOfRangeException() |
DateOutOfRangeException(string) |
DateOutOfRangeException(string, Exception) |
See Also

Reference

DateOutOfRangeException Class
DateOutOfRangeException Members
CompuTec.ProcessForce.API.Scheduling Namespace


DateOutOfRangeException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateOutOfRangeException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DateOutOfRangeException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DateOutOfRangeException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DateOutOfRangeException Class
DateOutOfRangeException Members
CompuTec.ProcessForce.API.Scheduling Namespace


DateOutOfRangeException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateOutOfRangeException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DateOutOfRangeException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DateOutOfRangeException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DateOutOfRangeException Class
DateOutOfRangeException Members
CompuTec.ProcessForce.API.Scheduling Namespace


InvaildDatesParametersException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class InvaildDatesParametersException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class InvaildDatesParametersException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class InvaildDatesParametersException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class InvaildDatesParametersException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Scheduling.InvaildDatesParametersException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InvaildDatesParametersException Members
CompuTec.ProcessForce.API.Scheduling Namespace


InvaildDatesParametersException Members

InvaildDatesParametersException Class Constructors Methods Properties See Also

The following tables list the members exposed by the InvaildDatesParametersException type.

Constructors
 | Name | Description
Public constructor | InvaildDatesParametersException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

InvaildDatesParametersException Class
CompuTec.ProcessForce.API.Scheduling Namespace


InvaildDatesParametersException Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public InvaildDatesParametersException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
InvaildDatesParametersException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function InvaildDatesParametersException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InvaildDatesParametersException Class
InvaildDatesParametersException Members
CompuTec.ProcessForce.API.Scheduling Namespace


InvaildDatesParametersException Constructor

InvaildDatesParametersException Class See Also

Overload List
Name | Description
InvaildDatesParametersException() |
InvaildDatesParametersException(string) |
InvaildDatesParametersException(string, Exception) |
See Also

Reference

InvaildDatesParametersException Class
InvaildDatesParametersException Members
CompuTec.ProcessForce.API.Scheduling Namespace


InvaildDatesParametersException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public InvaildDatesParametersException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
InvaildDatesParametersException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function InvaildDatesParametersException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InvaildDatesParametersException Class
InvaildDatesParametersException Members
CompuTec.ProcessForce.API.Scheduling Namespace


InvaildDatesParametersException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public InvaildDatesParametersException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
InvaildDatesParametersException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function InvaildDatesParametersException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InvaildDatesParametersException Class
InvaildDatesParametersException Members
CompuTec.ProcessForce.API.Scheduling Namespace


ITimeInterval Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ITimeInterval
    Inherits IEquatable(Of ITimeInterval), _
             ICloneable
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ITimeInterval : IEquatable<ITimeInterval>,
   ICloneable
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ITimeInterval : public IEquatable<ITimeInterval^>^,
   public ICloneable^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ITimeInterval Members

ITimeInterval Interface Methods Properties See Also

The following tables list the members exposed by the ITimeInterval type.

Properties
 | Name | Description
Public property | Duration |
Public property | FromDate |
Public property | Reference |
Public property | Remarks |
Public property | ToDate |
Top
Methods
 | Name | Description
Public method | Validate |
Top
See Also

Reference

ITimeInterval Interface
CompuTec.ProcessForce.API.Scheduling Namespace


ITimeInterval.Duration Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Duration() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan Duration {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property TimeSpan Duration {
 TimeSpan get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Duration() : TimeSpan;
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeInterval Interface
ITimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ITimeInterval.Remarks Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Remarks() : String;
function set Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeInterval Interface
ITimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ITimeInterval.FromDate Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property FromDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime FromDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime FromDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get FromDate() : DateTime;
function set FromDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeInterval Interface
ITimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ITimeInterval.ToDate Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ToDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime ToDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime ToDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ToDate() : DateTime;
function set ToDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeInterval Interface
ITimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ITimeInterval.Reference Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Reference() As Object
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
object Reference {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property object^ Reference {
 object^ get( );
 void set(
   object^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Reference() : object;
function set Reference(value : object);
This language is not supported or no code example is available.

Property Value

Type: object
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeInterval Interface
ITimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ITimeInterval.Validate Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Validate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Validate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Validate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Validate();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ITimeInterval Interface
ITimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


MultiResourceScheduler Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MultiResourceScheduler
    Inherits Schedule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MultiResourceScheduler : Schedule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MultiResourceScheduler : public Schedule^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MultiResourceScheduler
   extends Schedule
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Scheduling.Core.CoreSchedule
CompuTec.ProcessForce.API.Scheduling.BaseSchedule
CompuTec.ProcessForce.API.Scheduling.Schedule
CompuTec.ProcessForce.API.Scheduling.MultiResourceScheduler
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultiResourceScheduler Members
CompuTec.ProcessForce.API.Scheduling Namespace


MultiResourceScheduler Members

MultiResourceScheduler Class Constructors Methods Fields Properties See Also

The following tables list the members exposed by the MultiResourceScheduler type.

Constructors
 | Name | Description
Public constructor | MultiResourceScheduler |
Top
Properties
 | Name | Description
Public property | Resource | (inherited from BaseSchedule).
Public property | ResourceCalendar | (inherited from BaseSchedule).
Public property | ResourceCode | (inherited from CoreSchedule).
Public property | ResourceInfinite | (inherited from Schedule).
Public property | ResourceName | (inherited from CoreSchedule).
Public property | RscType | This Costructor Creates aoverlap aff all S chedulers for calendar and AVALIBLILITY (inherited from Schedule).
Top
Methods
 | Name | Description
Public method | AddInterval | (inherited from Schedule).
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAssignedOperations | (inherited from Schedule).
Public method | GetAvailbleEffort | This Function Checks Resource calendar and calculates What effort is availble between these two dates (inherited from CoreSchedule).
Public method | GetExceptionDay |
Public method | GetFinish | (inherited from CoreSchedule).
Public method | GetFreeTimeFromDate | Returns resource free time from specific DateTime including planned Tasks
Public method | GetFreeTimeToDate | Returns resource free time To specific DateTime including planned Tasks Backward Scheduling
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetIntervalsForSpecificDays |
Public method | GetIntervalsForSpecificRange | (inherited from CoreSchedule).
Public method | GetNextWorkingTime | (inherited from CoreSchedule).
Public method | GetPreviousWorkingTime | (inherited from CoreSchedule).
Public method | GetStart | (inherited from CoreSchedule).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadAvalibility | (Overloaded)
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
 | Name | Description
 | DayOfWeekTable | (inherited from CoreSchedule).
Public field | holidays | (inherited from CoreSchedule).
Public field | standardweek | (inherited from CoreSchedule).
Public field | workexceptions | (inherited from CoreSchedule).
Top
See Also

Reference

MultiResourceScheduler Class
CompuTec.ProcessForce.API.Scheduling Namespace


MultiResourceScheduler Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String, _
   ByVal resourcecodes As List(Of String) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MultiResourceScheduler(
   string token,
   List<string> resourcecodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
MultiResourceScheduler(
   String^ token,
   List<String^>^ resourcecodes
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

resourcecodes

Type: List<string>

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultiResourceScheduler Class
MultiResourceScheduler Members
CompuTec.ProcessForce.API.Scheduling Namespace


MultiResourceScheduler.LoadAvalibility Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub LoadAvalibility( _
   ByVal schedules As List(Of Schedule) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void LoadAvalibility(
   List<Schedule> schedules
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void LoadAvalibility(
   List<Schedule^>^ schedules
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

schedules

Type: List<Schedule>

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultiResourceScheduler Class
MultiResourceScheduler Members
CompuTec.ProcessForce.API.Scheduling Namespace


MultiResourceScheduler.LoadAvalibility Method

MultiResourceScheduler Class See Also

Overload List
Name | Description
LoadAvalibility(List<Int32>, DateTime) | It takes all other manufacturing orders in statuses :Schedule,Released,Started excluding Manufacturing Order Docentrys From parameter (inherited from Schedule).
LoadAvalibility(List<Schedule>) |
See Also

Reference

MultiResourceScheduler Class
MultiResourceScheduler Members
CompuTec.ProcessForce.API.Scheduling Namespace


MultiResourceScheduler.GetFreeTimeFromDate Method

Returns resource free time from specific DateTime including planned Tasks

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overrides Function GetFreeTimeFromDate( _
   ByVal date As Date, _
   ByVal Effort As TimeSpan, _
   Optional ByVal references As String = "" _
) As TimeInterval
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public override TimeInterval GetFreeTimeFromDate(
   DateTime date,
   TimeSpan Effort,
   string references = ""
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeInterval^ GetFreeTimeFromDate(
   DateTime date,
   TimeSpan Effort,
   String^ references
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetFreeTimeFromDate(
    date : DateTime,
    Effort : TimeSpan,
    references : String
) : TimeInterval;
This language is not supported or no code example is available.

Parameters

date

Type: DateTime

Effort

Type: TimeSpan

references

Type: string

Return Value

Type: TimeInterval
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultiResourceScheduler Class
MultiResourceScheduler Members
CompuTec.ProcessForce.API.Scheduling Namespace


MultiResourceScheduler.GetFreeTimeToDate Method

Returns resource free time To specific DateTime including planned Tasks Backward Scheduling

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overrides Function GetFreeTimeToDate( _
   ByVal fromDate As Date, _
   ByVal Effort As TimeSpan, _
   Optional ByVal references As String = "" _
) As TimeInterval
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public override TimeInterval GetFreeTimeToDate(
   DateTime fromDate,
   TimeSpan Effort,
   string references = ""
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeInterval^ GetFreeTimeToDate(
   DateTime fromDate,
   TimeSpan Effort,
   String^ references
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetFreeTimeToDate(
    fromDate : DateTime,
    Effort : TimeSpan,
    references : String
) : TimeInterval;
This language is not supported or no code example is available.

Parameters

fromDate

Type: DateTime

Effort

Type: TimeSpan

references

Type: string

Return Value

Type: TimeInterval
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultiResourceScheduler Class
MultiResourceScheduler Members
CompuTec.ProcessForce.API.Scheduling Namespace


MultiResourceScheduler.GetExceptionDay Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetExceptionDay( _
   ByVal day As Date _
) As TimeIntervals
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeIntervals GetExceptionDay(
   DateTime day
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeIntervals^ GetExceptionDay(
   DateTime day
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetExceptionDay(
    day : DateTime
) : TimeIntervals;
This language is not supported or no code example is available.

Parameters

day

Type: DateTime

Return Value

Type: TimeIntervals
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultiResourceScheduler Class
MultiResourceScheduler Members
CompuTec.ProcessForce.API.Scheduling Namespace


MultiResourceScheduler.GetIntervalsForSpecificDays Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overrides Function GetIntervalsForSpecificDays( _
   ByVal day As Date _
) As TimeIntervals
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public override TimeIntervals GetIntervalsForSpecificDays(
   DateTime day
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeIntervals^ GetIntervalsForSpecificDays(
   DateTime day
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetIntervalsForSpecificDays(
    day : DateTime
) : TimeIntervals;
This language is not supported or no code example is available.

Parameters

day

Type: DateTime

Return Value

Type: TimeIntervals
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultiResourceScheduler Class
MultiResourceScheduler Members
CompuTec.ProcessForce.API.Scheduling Namespace


MultiScheduleParameters Class

Members See Also

This Class is used to Schedule manu mors in one interval

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MultiScheduleParameters
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MultiScheduleParameters
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MultiScheduleParameters
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MultiScheduleParameters
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Scheduling.MultiScheduleParameters
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultiScheduleParameters Members
CompuTec.ProcessForce.API.Scheduling Namespace


MultiScheduleParameters Members

MultiScheduleParameters Class Methods Fields Properties See Also

This Class is used to Schedule manu mors in one interval

The following tables list the members exposed by the MultiScheduleParameters type.

Properties
 | Name | Description
Public property | FromMRP |
Top
Methods
 | Name | Description
Public method | Add | (Overloaded) If we are scheduling morwith semi items please make sure that we put Mor i right order First parent then child with reference to parent it will keep references in right order in scheduling
Public method | AddParentRecursive |
Public method | CreateLowerlevelChildren | This fuction Checks wether on created mor new semi Mors should Create and for not created one puts missing one in queue
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | InitInternalAndDeliveryInformations |
Public method | SortMor |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateParents |
Top
Fields
 | Name | Description
Public field | Token |
Top
See Also

Reference

MultiScheduleParameters Class
CompuTec.ProcessForce.API.Scheduling Namespace


Token Field

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Token As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Token
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ Token;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Token : String
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultiScheduleParameters Class
MultiScheduleParameters Members
CompuTec.ProcessForce.API.Scheduling Namespace


MultiScheduleParameters.FromMRP Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property FromMRP() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool FromMRP {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool FromMRP {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get FromMRP() : boolean;
public function set FromMRP(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultiScheduleParameters Class
MultiScheduleParameters Members
CompuTec.ProcessForce.API.Scheduling Namespace


MultiScheduleParameters.CreateLowerlevelChildren Method

This fuction Checks wether on created mor new semi Mors should Create and for not created one puts missing one in queue

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub CreateLowerlevelChildren()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void CreateLowerlevelChildren()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void CreateLowerlevelChildren()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CreateLowerlevelChildren();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultiScheduleParameters Class
MultiScheduleParameters Members
CompuTec.ProcessForce.API.Scheduling Namespace


MultiScheduleParameters.Add (IManufacturingOrder, IManufacturingOrder) Method

If we are scheduling morwith semi items please make sure that we put Mor i right order First parent then child with reference to parent it will keep references in right order in scheduling

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Add( _
   ByVal mor As IManufacturingOrder, _
   ByVal parentMor As IManufacturingOrder _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Add(
   IManufacturingOrder mor,
   IManufacturingOrder parentMor
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Add(
   IManufacturingOrder^ mor,
   IManufacturingOrder^ parentMor
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Add(
    mor : IManufacturingOrder,
    parentMor : IManufacturingOrder
);
This language is not supported or no code example is available.

Parameters

mor

Type: IManufacturingOrder

This mor will be add to queue

parentMor

Type: IManufacturingOrder

this is reference to parent mor must be already added into collection

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultiScheduleParameters Class
MultiScheduleParameters Members
CompuTec.ProcessForce.API.Scheduling Namespace


MultiScheduleParameters.Add Method

MultiScheduleParameters Class See Also

If we are scheduling morwith semi items please make sure that we put Mor i right order First parent then child with reference to parent it will keep references in right order in scheduling

Overload List
Name | Description
Add(IManufacturingOrder) |
Add(IManufacturingOrder, IManufacturingOrder) | If we are scheduling morwith semi items please make sure that we put Mor i right order First parent then child with reference to parent it will keep references in right order in scheduling
See Also

Reference

MultiScheduleParameters Class
MultiScheduleParameters Members
CompuTec.ProcessForce.API.Scheduling Namespace


MultiScheduleParameters.UpdateParents Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub UpdateParents()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void UpdateParents()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void UpdateParents()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UpdateParents();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultiScheduleParameters Class
MultiScheduleParameters Members
CompuTec.ProcessForce.API.Scheduling Namespace


MultiScheduleParameters.InitInternalAndDeliveryInformations Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub InitInternalAndDeliveryInformations()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void InitInternalAndDeliveryInformations()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void InitInternalAndDeliveryInformations()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function InitInternalAndDeliveryInformations();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultiScheduleParameters Class
MultiScheduleParameters Members
CompuTec.ProcessForce.API.Scheduling Namespace


MultiScheduleParameters.SortMor Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub SortMor()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void SortMor()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void SortMor()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SortMor();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultiScheduleParameters Class
MultiScheduleParameters Members
CompuTec.ProcessForce.API.Scheduling Namespace


MultiScheduleParameters.AddParentRecursive Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub AddParentRecursive( _
   ByRef list As List(Of IManufacturingOrder), _
   ByVal mor As IManufacturingOrder _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void AddParentRecursive(
   ref List<IManufacturingOrder> list,
   IManufacturingOrder mor
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void AddParentRecursive(
   List<IManufacturingOrder^>^& list,
   IManufacturingOrder^ mor
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

list

Type: List<IManufacturingOrder>

mor

Type: IManufacturingOrder

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultiScheduleParameters Class
MultiScheduleParameters Members
CompuTec.ProcessForce.API.Scheduling Namespace


MultiScheduleParameters.Add (IManufacturingOrder) Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Add( _
   ByVal mor As IManufacturingOrder _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Add(
   IManufacturingOrder mor
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Add(
   IManufacturingOrder^ mor
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Add(
    mor : IManufacturingOrder
);
This language is not supported or no code example is available.

Parameters

mor

Type: IManufacturingOrder

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MultiScheduleParameters Class
MultiScheduleParameters Members
CompuTec.ProcessForce.API.Scheduling Namespace


SapCalendar Class

Members See Also

This Class Implements Standard Schedule Of An Resource it Should implement All Avaliblility of resource

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SapCalendar
    Inherits BaseSchedule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SapCalendar : BaseSchedule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SapCalendar : public BaseSchedule^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SapCalendar
   extends BaseSchedule
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Scheduling.Core.CoreSchedule
CompuTec.ProcessForce.API.Scheduling.BaseSchedule
CompuTec.ProcessForce.API.Scheduling.SapCalendar
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SapCalendar Members
CompuTec.ProcessForce.API.Scheduling Namespace


SapCalendar Members

SapCalendar Class Constructors Methods Fields Properties See Also

This Class Implements Standard Schedule Of An Resource it Should implement All Avaliblility of resource

The following tables list the members exposed by the SapCalendar type.

Constructors
 | Name | Description
Public constructor | SapCalendar | (Overloaded)
Top
Properties
 | Name | Description
Public property | Resource | (inherited from BaseSchedule).
Public property | ResourceCalendar | (inherited from BaseSchedule).
Public property | ResourceCode | (inherited from CoreSchedule).
Public property | ResourceName | (inherited from CoreSchedule).
Top
Methods
 | Name | Description
Public method | CorrectTimeSpanWithHolidayCallendar |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAvailbleEffort | This Function Checks Resource calendar and calculates What effort is availble between these two dates (inherited from CoreSchedule).
Public method | GetFinish | (inherited from CoreSchedule).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetIntervalsForSpecificDays | (inherited from CoreSchedule).
Public method | GetIntervalsForSpecificRange | (inherited from CoreSchedule).
Public method | GetNextWorkingTime | (inherited from CoreSchedule).
Public method | GetNotWorkingDaysTo |
Public method | GetPreviousWorkingTime | (inherited from CoreSchedule).
Public method | GetStart | (inherited from CoreSchedule).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
 | Name | Description
 | DayOfWeekTable | (inherited from CoreSchedule).
Public field | holidays | (inherited from CoreSchedule).
Public field | standardweek | (inherited from CoreSchedule).
Public field | workexceptions | (inherited from CoreSchedule).
Top
See Also

Reference

SapCalendar Class
CompuTec.ProcessForce.API.Scheduling Namespace


SapCalendar(String, String) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal resourceCode As String, _
   ByVal holidayCode As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SapCalendar(
   string resourceCode,
   string holidayCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SapCalendar(
   String^ resourceCode,
   String^ holidayCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SapCalendar(
    resourceCode : String,
    holidayCode : String
);
This language is not supported or no code example is available.

Parameters

resourceCode

Type: string

holidayCode

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SapCalendar Class
SapCalendar Members
CompuTec.ProcessForce.API.Scheduling Namespace


SapCalendar Constructor

SapCalendar Class See Also

Overload List
Name | Description
SapCalendar(string, string) |
SapCalendar(string) |
See Also

Reference

SapCalendar Class
SapCalendar Members
CompuTec.ProcessForce.API.Scheduling Namespace


SapCalendar(String) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SapCalendar(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SapCalendar(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SapCalendar(
    token : String
);
This language is not supported or no code example is available.

Parameters

token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SapCalendar Class
SapCalendar Members
CompuTec.ProcessForce.API.Scheduling Namespace


SapCalendar.GetNotWorkingDaysTo Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetNotWorkingDaysTo( _
   ByVal from As Date, _
   ByVal delta As Integer _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int GetNotWorkingDaysTo(
   DateTime from,
   int delta
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int GetNotWorkingDaysTo(
   DateTime from,
   int delta
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetNotWorkingDaysTo(
    from : DateTime,
    delta : int
) : int;
This language is not supported or no code example is available.

Parameters

from

Type: DateTime

delta

Type: int

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SapCalendar Class
SapCalendar Members
CompuTec.ProcessForce.API.Scheduling Namespace


SapCalendar.CorrectTimeSpanWithHolidayCallendar Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CorrectTimeSpanWithHolidayCallendar( _
   ByVal from As Date, _
   ByVal timeSpan As TimeSpan, _
   ByVal trueForFutureFalseForPast As Boolean _
) As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan CorrectTimeSpanWithHolidayCallendar(
   DateTime from,
   TimeSpan timeSpan,
   bool trueForFutureFalseForPast
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeSpan CorrectTimeSpanWithHolidayCallendar(
   DateTime from,
   TimeSpan timeSpan,
   bool trueForFutureFalseForPast
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CorrectTimeSpanWithHolidayCallendar(
    from : DateTime,
    timeSpan : TimeSpan,
    trueForFutureFalseForPast : boolean
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

from

Type: DateTime

timeSpan

Type: TimeSpan

trueForFutureFalseForPast

Type: bool

Return Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SapCalendar Class
SapCalendar Members
CompuTec.ProcessForce.API.Scheduling Namespace


Schedule Class

Members See Also

This Class Implements Standard Schedule Of An Resource it Should implement All Avaliblility of resource

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class Schedule
    Inherits BaseSchedule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Schedule : BaseSchedule
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class Schedule : public BaseSchedule^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Schedule
   extends BaseSchedule
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Scheduling.Core.CoreSchedule
CompuTec.ProcessForce.API.Scheduling.BaseSchedule
CompuTec.ProcessForce.API.Scheduling.Schedule
CompuTec.ProcessForce.API.Scheduling.MultiResourceScheduler
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Schedule Members
CompuTec.ProcessForce.API.Scheduling Namespace


Schedule Members

Schedule Class Constructors Methods Fields Properties See Also

This Class Implements Standard Schedule Of An Resource it Should implement All Avaliblility of resource

The following tables list the members exposed by the Schedule type.

Constructors
 | Name | Description
Public constructor | Schedule | (Overloaded)
Top
Properties
 | Name | Description
Public property | Resource | (inherited from BaseSchedule).
Public property | ResourceCalendar | (inherited from BaseSchedule).
Public property | ResourceCode | (inherited from CoreSchedule).
Public property | ResourceInfinite |
Public property | ResourceName | (inherited from CoreSchedule).
Public property | RscType | This Costructor Creates aoverlap aff all S chedulers for calendar and AVALIBLILITY
Top
Methods
 | Name | Description
Public method | AddInterval |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetAssignedOperations |
Public method | GetAvailbleEffort | This Function Checks Resource calendar and calculates What effort is availble between these two dates (inherited from CoreSchedule).
Public method | GetFinish | (inherited from CoreSchedule).
Public method | GetFreeTimeFromDate | Returns resource free time from specific DateTime including planned Tasks
Public method | GetFreeTimeToDate | Returns resource free time To specific DateTime including planned Tasks Backward Scheduling
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetIntervalsForSpecificDays | (inherited from CoreSchedule).
Public method | GetIntervalsForSpecificRange | (inherited from CoreSchedule).
Public method | GetNextWorkingTime | (inherited from CoreSchedule).
Public method | GetPreviousWorkingTime | (inherited from CoreSchedule).
Public method | GetStart | (inherited from CoreSchedule).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | LoadAvalibility | It takes all other manufacturing orders in statuses :Schedule,Released,Started excluding Manufacturing Order Docentrys From parameter
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
 | Name | Description
 | DayOfWeekTable | (inherited from CoreSchedule).
Public field | holidays | (inherited from CoreSchedule).
Public field | standardweek | (inherited from CoreSchedule).
Public field | workexceptions | (inherited from CoreSchedule).
Top
See Also

Reference

Schedule Class
CompuTec.ProcessForce.API.Scheduling Namespace


Schedule.RscType Property

This Costructor Creates aoverlap aff all S chedulers for calendar and AVALIBLILITY

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property RscType() As ResourceType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceType RscType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property ResourceType RscType {
 ResourceType get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get RscType() : ResourceType;
This language is not supported or no code example is available.

Property Value

Type: ResourceType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Schedule Class
Schedule Members
CompuTec.ProcessForce.API.Scheduling Namespace


Schedule(String, String, List<Int32>, DateTime) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String, _
   ByVal resourceCode As String, _
   ByVal ExcludingDocEntryList As List(Of Integer), _
   ByVal FromDate As Date _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Schedule(
   string token,
   string resourceCode,
   List<int> ExcludingDocEntryList,
   DateTime FromDate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Schedule(
   String^ token,
   String^ resourceCode,
   List<int>^ ExcludingDocEntryList,
   DateTime FromDate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

resourceCode

Type: string

ExcludingDocEntryList

Type: List<int>

FromDate

Type: DateTime

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Schedule Class
Schedule Members
CompuTec.ProcessForce.API.Scheduling Namespace


Schedule Constructor

Schedule Class See Also

Overload List
Name | Description
Schedule(string, List<DateTime>, Dictionary<DayOfWeekTimeIntervals>, Dictionary<DateTimeTimeIntervals>, List<ITimeInterval>) |
Schedule(string) |
Schedule(string, string, List<Int32>, DateTime) |
See Also

Reference

Schedule Class
Schedule Members
CompuTec.ProcessForce.API.Scheduling Namespace


Schedule(String) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal resourceCode As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Schedule(
   string resourceCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Schedule(
   String^ resourceCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Schedule(
    resourceCode : String
);
This language is not supported or no code example is available.

Parameters

resourceCode

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Schedule Class
Schedule Members
CompuTec.ProcessForce.API.Scheduling Namespace


Schedule(String, List<DateTime>, Dictionary<DayOfWeekTimeIntervals>, Dictionary<DateTimeTimeIntervals>, List<ITimeInterval>) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal _Token As String, _
   ByVal _holidays As List(Of Date), _
   ByVal _standardWeek As Dictionary(Of DayOfWeek, TimeIntervals), _
   ByVal _workexceptions As Dictionary(Of Date, TimeIntervals), _
   ByVal _avalibility As List(Of ITimeInterval) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Schedule(
   string _Token,
   List<DateTime> _holidays,
   Dictionary<DayOfWeek, TimeIntervals> _standardWeek,
   Dictionary<DateTime, TimeIntervals> _workexceptions,
   List<ITimeInterval> _avalibility
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Schedule(
   String^ _Token,
   List<DateTime>^ _holidays,
   Dictionary<DayOfWeek, TimeIntervals^>^ _standardWeek,
   Dictionary<DateTime, TimeIntervals^>^ _workexceptions,
   List<ITimeInterval^>^ _avalibility
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

_Token

Type: string

_holidays

Type: List<DateTime>

_standardWeek

Type: Dictionary<DayOfWeek, TimeIntervals>

_workexceptions

Type: Dictionary<DateTime, TimeIntervals>

_avalibility

Type: List<ITimeInterval>

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Schedule Class
Schedule Members
CompuTec.ProcessForce.API.Scheduling Namespace


Schedule.ResourceInfinite Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ResourceInfinite() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool ResourceInfinite {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property bool ResourceInfinite {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ResourceInfinite() : boolean;
public function set ResourceInfinite(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Schedule Class
Schedule Members
CompuTec.ProcessForce.API.Scheduling Namespace


Schedule.GetAssignedOperations Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAssignedOperations() As List(Of ITimeInterval)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<ITimeInterval> GetAssignedOperations()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<ITimeInterval^>^ GetAssignedOperations()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Return Value

Type: List<ITimeInterval>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Schedule Class
Schedule Members
CompuTec.ProcessForce.API.Scheduling Namespace


Schedule.GetFreeTimeToDate Method

Returns resource free time To specific DateTime including planned Tasks Backward Scheduling

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overridable Function GetFreeTimeToDate( _
   ByVal fromDate As Date, _
   ByVal Effort As TimeSpan, _
   Optional ByVal references As String = "" _
) As TimeInterval
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public virtual TimeInterval GetFreeTimeToDate(
   DateTime fromDate,
   TimeSpan Effort,
   string references = ""
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
virtual TimeInterval^ GetFreeTimeToDate(
   DateTime fromDate,
   TimeSpan Effort,
   String^ references
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetFreeTimeToDate(
    fromDate : DateTime,
    Effort : TimeSpan,
    references : String
) : TimeInterval;
This language is not supported or no code example is available.

Parameters

fromDate

Type: DateTime

Effort

Type: TimeSpan

references

Type: string

Return Value

Type: TimeInterval
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Schedule Class
Schedule Members
CompuTec.ProcessForce.API.Scheduling Namespace


Schedule.GetFreeTimeFromDate Method

Returns resource free time from specific DateTime including planned Tasks

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overridable Function GetFreeTimeFromDate( _
   ByVal date As Date, _
   ByVal Effort As TimeSpan, _
   Optional ByVal references As String = "" _
) As TimeInterval
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public virtual TimeInterval GetFreeTimeFromDate(
   DateTime date,
   TimeSpan Effort,
   string references = ""
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
virtual TimeInterval^ GetFreeTimeFromDate(
   DateTime date,
   TimeSpan Effort,
   String^ references
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetFreeTimeFromDate(
    date : DateTime,
    Effort : TimeSpan,
    references : String
) : TimeInterval;
This language is not supported or no code example is available.

Parameters

date

Type: DateTime

Effort

Type: TimeSpan

references

Type: string

Return Value

Type: TimeInterval
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Schedule Class
Schedule Members
CompuTec.ProcessForce.API.Scheduling Namespace


Schedule.AddInterval Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub AddInterval( _
   ByVal interval As TimeInterval _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void AddInterval(
   TimeInterval interval
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void AddInterval(
   TimeInterval^ interval
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function AddInterval(
    interval : TimeInterval
);
This language is not supported or no code example is available.

Parameters

interval

Type: TimeInterval

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Schedule Class
Schedule Members
CompuTec.ProcessForce.API.Scheduling Namespace


Schedule.LoadAvalibility Method

It takes all other manufacturing orders in statuses :Schedule,Released,Started excluding Manufacturing Order Docentrys From parameter

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overridable Sub LoadAvalibility( _
   ByVal excludingDocentrys As List(Of Integer), _
   ByVal From_Date As Date _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public virtual void LoadAvalibility(
   List<int> excludingDocentrys,
   DateTime From_Date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
virtual void LoadAvalibility(
   List<int>^ excludingDocentrys,
   DateTime From_Date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

excludingDocentrys

Type: List<int>

From_Date

Type: DateTime

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Schedule Class
Schedule Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval Class

Members See Also

This Class Is Used To Store information of Time Interval in one day used in Schedule but not in operations

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class ScheduleInterval
    Implements ITimeInterval
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class ScheduleInterval : ITimeInterval
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class ScheduleInterval  : public ITimeInterval^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class ScheduleInterval
   implements ITimeInterval
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Scheduling.ScheduleInterval
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval Members

ScheduleInterval Class Constructors Methods Properties See Also

This Class Is Used To Store information of Time Interval in one day used in Schedule but not in operations

The following tables list the members exposed by the ScheduleInterval type.

Constructors
 | Name | Description
Public constructor | ScheduleInterval | (Overloaded)
Top
Properties
 | Name | Description
Public property | Duration |
Public property | FromDate |
Public property | Reference |
Public property | Remarks |
Public property | ToDate |
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | (Overloaded)
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object.
Public method | Validate |
Top
See Also

Reference

ScheduleInterval Class
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ScheduleInterval()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ScheduleInterval()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ScheduleInterval();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleInterval Class
ScheduleInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval Constructor

ScheduleInterval Class See Also

Overload List
Name | Description
ScheduleInterval(DateTime, TimeSpan) |
ScheduleInterval() |
ScheduleInterval(DateTime, DateTime) |
ScheduleInterval(DateTime, DateTime, string) |
ScheduleInterval(DateTime, DateTime, string, object) |
ScheduleInterval(DateTime, TimeSpan, string) |
ScheduleInterval(DateTime, TimeSpan, string, object) |
See Also

Reference

ScheduleInterval Class
ScheduleInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval(DateTime, TimeSpan) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal fromDate As Date, _
   ByVal duratuion As TimeSpan _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ScheduleInterval(
   DateTime fromDate,
   TimeSpan duratuion
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ScheduleInterval(
   DateTime fromDate,
   TimeSpan duratuion
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ScheduleInterval(
    fromDate : DateTime,
    duratuion : TimeSpan
);
This language is not supported or no code example is available.

Parameters

fromDate

Type: DateTime

duratuion

Type: TimeSpan

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleInterval Class
ScheduleInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval.Validate Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Validate() Implements  _
   ITimeInterval.Validate
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Validate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Validate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Validate();
This language is not supported or no code example is available.

Implements

ITimeInterval.Validate
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleInterval Class
ScheduleInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval(DateTime, TimeSpan, String) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal fromDate As Date, _
   ByVal duratuion As TimeSpan, _
   ByVal remarks As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ScheduleInterval(
   DateTime fromDate,
   TimeSpan duratuion,
   string remarks
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ScheduleInterval(
   DateTime fromDate,
   TimeSpan duratuion,
   String^ remarks
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ScheduleInterval(
    fromDate : DateTime,
    duratuion : TimeSpan,
    remarks : String
);
This language is not supported or no code example is available.

Parameters

fromDate

Type: DateTime

duratuion

Type: TimeSpan

remarks

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleInterval Class
ScheduleInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval(DateTime, TimeSpan, String, Object) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal fromDate As Date, _
   ByVal duratuion As TimeSpan, _
   ByVal remarks As String, _
   ByVal refrerences As Object _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ScheduleInterval(
   DateTime fromDate,
   TimeSpan duratuion,
   string remarks,
   object refrerences
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ScheduleInterval(
   DateTime fromDate,
   TimeSpan duratuion,
   String^ remarks,
   object^ refrerences
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ScheduleInterval(
    fromDate : DateTime,
    duratuion : TimeSpan,
    remarks : String,
    refrerences : object
);
This language is not supported or no code example is available.

Parameters

fromDate

Type: DateTime

duratuion

Type: TimeSpan

remarks

Type: string

refrerences

Type: object

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleInterval Class
ScheduleInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval(DateTime, DateTime) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal fromDate As Date, _
   ByVal toDate As Date _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ScheduleInterval(
   DateTime fromDate,
   DateTime toDate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ScheduleInterval(
   DateTime fromDate,
   DateTime toDate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ScheduleInterval(
    fromDate : DateTime,
    toDate : DateTime
);
This language is not supported or no code example is available.

Parameters

fromDate

Type: DateTime

toDate

Type: DateTime

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleInterval Class
ScheduleInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval(DateTime, DateTime, String) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal fromDate As Date, _
   ByVal toDate As Date, _
   ByVal remarks As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ScheduleInterval(
   DateTime fromDate,
   DateTime toDate,
   string remarks
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ScheduleInterval(
   DateTime fromDate,
   DateTime toDate,
   String^ remarks
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ScheduleInterval(
    fromDate : DateTime,
    toDate : DateTime,
    remarks : String
);
This language is not supported or no code example is available.

Parameters

fromDate

Type: DateTime

toDate

Type: DateTime

remarks

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleInterval Class
ScheduleInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval(DateTime, DateTime, String, Object) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal fromDate As Date, _
   ByVal toDate As Date, _
   ByVal remarks As String, _
   ByVal refrerences As Object _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ScheduleInterval(
   DateTime fromDate,
   DateTime toDate,
   string remarks,
   object refrerences
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ScheduleInterval(
   DateTime fromDate,
   DateTime toDate,
   String^ remarks,
   object^ refrerences
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ScheduleInterval(
    fromDate : DateTime,
    toDate : DateTime,
    remarks : String,
    refrerences : object
);
This language is not supported or no code example is available.

Parameters

fromDate

Type: DateTime

toDate

Type: DateTime

remarks

Type: string

refrerences

Type: object

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleInterval Class
ScheduleInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval.Remarks Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Remarks() As String Implements  _
   ITimeInterval.Remarks
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Remarks() : String;
public function set Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

ITimeInterval.Remarks
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleInterval Class
ScheduleInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval.FromDate Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property FromDate() As Date Implements  _
   ITimeInterval.FromDate
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime FromDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime FromDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get FromDate() : DateTime;
public function set FromDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime

Implements

ITimeInterval.FromDate
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleInterval Class
ScheduleInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval.ToDate Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ToDate() As Date Implements  _
   ITimeInterval.ToDate
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime ToDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime ToDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ToDate() : DateTime;
public function set ToDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime

Implements

ITimeInterval.ToDate
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleInterval Class
ScheduleInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval.Duration Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property Duration() As TimeSpan Implements  _
   ITimeInterval.Duration
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan Duration {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property TimeSpan Duration {
 TimeSpan get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Duration() : TimeSpan;
This language is not supported or no code example is available.

Property Value

Type: TimeSpan

Implements

ITimeInterval.Duration
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleInterval Class
ScheduleInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval.Reference Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Reference() As Object Implements  _
   ITimeInterval.Reference
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public object Reference {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property object^ Reference {
 object^ get( );
 void set(
   object^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Reference() : object;
public function set Reference(value : object);
This language is not supported or no code example is available.

Property Value

Type: object

Implements

ITimeInterval.Reference
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleInterval Class
ScheduleInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval.ToString Method

Returns a string that represents the current object.

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overrides Function ToString() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public override string ToString()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ ToString()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ToString() : String;
This language is not supported or no code example is available.

Return Value

Type: string

A string that represents the current object.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleInterval Class
ScheduleInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval.Equals Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function Equals( _
   ByVal other As ITimeInterval _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool Equals(
   ITimeInterval other
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool Equals(
   ITimeInterval^ other
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Equals(
    other : ITimeInterval
) : boolean;
This language is not supported or no code example is available.

Parameters

other

Type: ITimeInterval

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleInterval Class
ScheduleInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval.Equals Method

ScheduleInterval Class See Also

Overload List
Name | Description
Equals(Object) | Determines whether the specified object is equal to the current object. (System.Object).
Equals(ITimeInterval) |
See Also

Reference

ScheduleInterval Class
ScheduleInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleInterval.Clone Method

Creates a new object that is a copy of the current instance.

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function Clone() As Object Implements  _
   ITimeInterval.Clone
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public object Clone()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
object^ Clone()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Clone() : object;
This language is not supported or no code example is available.

Return Value

Type: object

A new object that is a copy of this instance.

Implements

ITimeInterval.Clone
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleInterval Class
ScheduleInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleManager Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ScheduleManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ScheduleManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ScheduleManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ScheduleManager
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Scheduling.ScheduleManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleManager Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleManager Members

ScheduleManager Class Constructors Methods See Also

The following tables list the members exposed by the ScheduleManager type.

Constructors
 | Name | Description
Public constructor | ScheduleManager |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | FillReceiptedQtyOnMor | (Overloaded)
Public method | ForwardCalculations | Calucates manufacturingOrder with Operation Overlapping And Resource Avalivility and Resource calendars
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | Schedule | (Overloaded) Schedule single ManufacturingOrder
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | UpdateResourceHistoricalTimes |
Top
See Also

Reference

ScheduleManager Class
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleManager Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ScheduleManager(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ScheduleManager(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ScheduleManager(
    token : String
);
This language is not supported or no code example is available.

Parameters

token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleManager Class
ScheduleManager Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleManager.Schedule (Int32) Method

Schedule single ManufacturingOrder

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Schedule( _
   ByVal DocEntry As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Schedule(
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Schedule(
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Schedule(
    DocEntry : int
);
This language is not supported or no code example is available.

Parameters

DocEntry

Type: int

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleManager Class
ScheduleManager Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleManager.Schedule Method

ScheduleManager Class See Also

Schedule single ManufacturingOrder

Overload List
Name | Description
Schedule(MultiScheduleParameters) |
Schedule(IManufacturingOrder, bool, bool) | Main Schedule Functionman
Schedule(int) | Schedule single ManufacturingOrder
See Also

Reference

ScheduleManager Class
ScheduleManager Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleManager.Schedule (MultiScheduleParameters) Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function Schedule( _
   ByVal parameters As MultiScheduleParameters _
) As ScheduleResults
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ScheduleResults Schedule(
   MultiScheduleParameters parameters
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ScheduleResults^ Schedule(
   MultiScheduleParameters^ parameters
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Schedule(
    parameters : MultiScheduleParameters
) : ScheduleResults;
This language is not supported or no code example is available.

Parameters

parameters

Type: MultiScheduleParameters

Return Value

Type: ScheduleResults
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleManager Class
ScheduleManager Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleManager.Schedule (IManufacturingOrder, Boolean, Boolean) Method

Main Schedule Functionman

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Schedule( _
   ByVal mor As IManufacturingOrder, _
   Optional ByVal changeStatus As Boolean = true, _
   Optional ByVal scheduleSingleMor As Boolean = true _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Schedule(
   IManufacturingOrder mor,
   bool changeStatus = true,
   bool scheduleSingleMor = true
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Schedule(
   IManufacturingOrder^ mor,
   bool changeStatus,
   bool scheduleSingleMor
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Schedule(
    mor : IManufacturingOrder,
    changeStatus : boolean,
    scheduleSingleMor : boolean
);
This language is not supported or no code example is available.

Parameters

mor

Type: IManufacturingOrder

changeStatus

Type: bool

scheduleSingleMor

Type: bool

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleManager Class
ScheduleManager Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleManager.FillReceiptedQtyOnMor (IManufacturingOrder) Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function FillReceiptedQtyOnMor( _
   ByRef mor As IManufacturingOrder _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool FillReceiptedQtyOnMor(
   ref IManufacturingOrder mor
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool FillReceiptedQtyOnMor(
   IManufacturingOrder^& mor
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function FillReceiptedQtyOnMor(
    mor : IManufacturingOrder
) : boolean;
This language is not supported or no code example is available.

Parameters

mor

Type: IManufacturingOrder

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleManager Class
ScheduleManager Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleManager.FillReceiptedQtyOnMor Method

ScheduleManager Class See Also

Overload List
Name | Description
FillReceiptedQtyOnMor(ref IManufacturingOrder) |
FillReceiptedQtyOnMor(ref IManufacturingOrder, List<TaskStatusHelper>) |
See Also

Reference

ScheduleManager Class
ScheduleManager Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleManager.FillReceiptedQtyOnMor (IManufacturingOrder, List<TaskStatusHelper>) Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function FillReceiptedQtyOnMor( _
   ByRef mor As IManufacturingOrder, _
   ByVal taskStatuses As List(Of TaskStatusHelper) _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool FillReceiptedQtyOnMor(
   ref IManufacturingOrder mor,
   List<TaskStatusHelper> taskStatuses
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool FillReceiptedQtyOnMor(
   IManufacturingOrder^& mor,
   List<TaskStatusHelper^>^ taskStatuses
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

mor

Type: IManufacturingOrder

taskStatuses

Type: List<TaskStatusHelper>

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleManager Class
ScheduleManager Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleManager.UpdateResourceHistoricalTimes Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub UpdateResourceHistoricalTimes( _
   ByVal resource As IManufacturingOrderRoutingOperationResources, _
   ByVal mor As IManufacturingOrder _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void UpdateResourceHistoricalTimes(
   IManufacturingOrderRoutingOperationResources resource,
   IManufacturingOrder mor
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void UpdateResourceHistoricalTimes(
   IManufacturingOrderRoutingOperationResources^ resource,
   IManufacturingOrder^ mor
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UpdateResourceHistoricalTimes(
    resource : IManufacturingOrderRoutingOperationResources,
    mor : IManufacturingOrder
);
This language is not supported or no code example is available.

Parameters

resource

Type: IManufacturingOrderRoutingOperationResources

mor

Type: IManufacturingOrder

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleManager Class
ScheduleManager Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleManager.ForwardCalculations Method

Calucates manufacturingOrder with Operation Overlapping And Resource Avalivility and Resource calendars

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub ForwardCalculations( _
   ByVal mor As IManufacturingOrder, _
   ByVal schedulingContainer As SchedulingContainer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void ForwardCalculations(
   IManufacturingOrder mor,
   SchedulingContainer schedulingContainer
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void ForwardCalculations(
   IManufacturingOrder^ mor,
   SchedulingContainer^ schedulingContainer
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ForwardCalculations(
    mor : IManufacturingOrder,
    schedulingContainer : SchedulingContainer
);
This language is not supported or no code example is available.

Parameters

mor

Type: IManufacturingOrder

schedulingContainer

Type: SchedulingContainer

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleManager Class
ScheduleManager Members
CompuTec.ProcessForce.API.Scheduling Namespace


SetOfScenarios Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SetOfScenarios
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SetOfScenarios
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SetOfScenarios
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SetOfScenarios
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Scheduling.SetOfScenarios
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SetOfScenarios Members
CompuTec.ProcessForce.API.Scheduling Namespace


SetOfScenarios Members

SetOfScenarios Class Constructors Methods Properties See Also

The following tables list the members exposed by the SetOfScenarios type.

Constructors
 | Name | Description
Public constructor | SetOfScenarios | (Overloaded)
Top
Properties
 | Name | Description
Public property | listOfScenarios |
Public property | timeInterval |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

SetOfScenarios Class
CompuTec.ProcessForce.API.Scheduling Namespace


SetOfScenarios.listOfScenarios Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property listOfScenarios() As List(Of ProjectionScenario)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<ProjectionScenario> listOfScenarios {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<ProjectionScenario^>^ listOfScenarios {
 List<ProjectionScenario^>^ get( );
 void set(
   List<ProjectionScenario^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<ProjectionScenario>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SetOfScenarios Class
SetOfScenarios Members
CompuTec.ProcessForce.API.Scheduling Namespace


SetOfScenarios.timeInterval Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property timeInterval() As TimeInterval
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeInterval timeInterval {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property TimeInterval^ timeInterval {
 TimeInterval^ get( );
 void set(
   TimeInterval^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get timeInterval() : TimeInterval;
public function set timeInterval(value : TimeInterval);
This language is not supported or no code example is available.

Property Value

Type: TimeInterval
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SetOfScenarios Class
SetOfScenarios Members
CompuTec.ProcessForce.API.Scheduling Namespace


SetOfScenarios Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SetOfScenarios()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SetOfScenarios()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SetOfScenarios();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SetOfScenarios Class
SetOfScenarios Members
CompuTec.ProcessForce.API.Scheduling Namespace


SetOfScenarios Constructor

SetOfScenarios Class See Also

Overload List
Name | Description
SetOfScenarios() |
SetOfScenarios(List<ProjectionScenario>) |
See Also

Reference

SetOfScenarios Class
SetOfScenarios Members
CompuTec.ProcessForce.API.Scheduling Namespace


SetOfScenarios(List<ProjectionScenario>) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal list As List(Of ProjectionScenario) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SetOfScenarios(
   List<ProjectionScenario> list
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SetOfScenarios(
   List<ProjectionScenario^>^ list
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

list

Type: List<ProjectionScenario>

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SetOfScenarios Class
SetOfScenarios Members
CompuTec.ProcessForce.API.Scheduling Namespace


CompuTec.ProcessForce.API.Actions Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | AprovalProceduresEnabledException |
Public class | DocRef | Represents a single document reference
Public class | SettlementAccountEnabledButNotFullyConfiguredException |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


BomComponent Constructor

Initializes a new instance of BomComponent object.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BomComponent()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BomComponent()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BomComponent();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BomComponent Class
BomComponent Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


BomComponent(Int32, String) Constructor

Initializes a new instance of BomComponent object.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal seq As Integer, _
   ByVal itemCode As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BomComponent(
   int seq,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BomComponent(
   int seq,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BomComponent(
    seq : int,
    itemCode : String
);
This language is not supported or no code example is available.

Parameters

seq

Type: int

Sequence no.

itemCode

Type: string

Item code.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BomComponent Class
BomComponent Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


BomComponent.Equals Method

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function Equals( _
   ByVal other As BomComponent _
) As Boolean Implements  _
   IEquatable.Equals
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool Equals(
   BomComponent other
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool Equals(
   BomComponent^ other
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Equals(
    other : BomComponent
) : boolean;
This language is not supported or no code example is available.

Parameters

other

Type: BomComponent

Return Value

Type: bool

Implements

IEquatable.Equals
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BomComponent Class
BomComponent Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


DocRef Class

Members See Also

Represents a single document reference

Namespace: CompuTec.ProcessForce.API.Actions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class DocRef
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DocRef
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class DocRef
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class DocRef
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Actions.DocRef
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocRef Members
CompuTec.ProcessForce.API.Actions Namespace


DocRef Members

DocRef Class Methods Properties See Also

Represents a single document reference

The following tables list the members exposed by the DocRef type.

Properties
 | Name | Description
Public property | DocEntry | Referenced Document Key
Public property | DocumentType | Referenced Document Type
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

DocRef Class
CompuTec.ProcessForce.API.Actions Namespace


DocRef.DocumentType Property

Referenced Document Type

Namespace: CompuTec.ProcessForce.API.Actions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DocumentType() As String
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string DocumentType {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ DocumentType {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocumentType() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocRef Class
DocRef Members
CompuTec.ProcessForce.API.Actions Namespace


DocRef.DocEntry Property

Referenced Document Key

Namespace: CompuTec.ProcessForce.API.Actions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property DocEntry() As Long
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public long DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property long DocEntry {
 long get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get DocEntry() : long;
This language is not supported or no code example is available.

Property Value

Type: long
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocRef Class
DocRef Members
CompuTec.ProcessForce.API.Actions Namespace


IItemCosting.NeutralizeRolledCosts Method

Neutralizes tje rolled costs.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub NeutralizeRolledCosts()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void NeutralizeRolledCosts()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void NeutralizeRolledCosts()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function NeutralizeRolledCosts();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.NeutralizeRolledCosts (List<String>) Method

Neutralizes the rolled costs for provided warehouses.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub NeutralizeRolledCosts( _
   ByVal warehouses As List(Of String) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void NeutralizeRolledCosts(
   List<string> warehouses
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void NeutralizeRolledCosts(
   List<String^>^ warehouses
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

warehouses

Type: List<string>

Warehouses for which the rolled costs must be neutralized.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.RecalculateRolledCosts Method

Recalculates the rolled costs.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub RecalculateRolledCosts()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void RecalculateRolledCosts()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void RecalculateRolledCosts()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function RecalculateRolledCosts();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.RecalculateRolledCosts (List<String>) Method

Recalculates the rolled costs for provided warehouses.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub RecalculateRolledCosts( _
   ByVal warehouses As List(Of String) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void RecalculateRolledCosts(
   List<string> warehouses
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void RecalculateRolledCosts(
   List<String^>^ warehouses
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

warehouses

Type: List<string>

Warehouses for which the rolled costs must be recalculated.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.Revaluate (Double, String) Method

Revaluates the item costing data for defined warehouses.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Revaluate( _
   ByVal price As Double, _
   ByVal warehouse As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Revaluate(
   double price,
   string warehouse
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Revaluate(
   double price,
   String^ warehouse
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Revaluate(
    price : double,
    warehouse : String
);
This language is not supported or no code example is available.

Parameters

price

Type: double

Price defined during the material revaluation process.

warehouse

Type: string

Warehouse for which the costing data must be revaluated.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


IItemCosting.Revaluate (Double) Method

Revaluates the item costing data for all warehouses.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.ItemCosting
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Revaluate( _
   ByVal price As Double _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Revaluate(
   double price
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Revaluate(
   double price
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Revaluate(
    price : double
);
This language is not supported or no code example is available.

Parameters

price

Type: double

Price defined during the material revaluation process.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IItemCosting Interface
IItemCosting Members
CompuTec.ProcessForce.API.Documents.Costing.ItemCosting Namespace


AprovalProceduresEnabledException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Actions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class AprovalProceduresEnabledException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class AprovalProceduresEnabledException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class AprovalProceduresEnabledException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class AprovalProceduresEnabledException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Actions.AprovalProceduresEnabledException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AprovalProceduresEnabledException Members
CompuTec.ProcessForce.API.Actions Namespace


AprovalProceduresEnabledException Members

AprovalProceduresEnabledException Class Constructors Methods Properties See Also

The following tables list the members exposed by the AprovalProceduresEnabledException type.

Constructors
 | Name | Description
Public constructor | AprovalProceduresEnabledException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

AprovalProceduresEnabledException Class
CompuTec.ProcessForce.API.Actions Namespace


SettlementAccountEnabledButNotFullyConfiguredException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Actions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SettlementAccountEnabledButNotFullyConfiguredException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SettlementAccountEnabledButNotFullyConfiguredException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SettlementAccountEnabledButNotFullyConfiguredException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SettlementAccountEnabledButNotFullyConfiguredException Class
SettlementAccountEnabledButNotFullyConfiguredException Members
CompuTec.ProcessForce.API.Actions Namespace


SettlementAccountEnabledButNotFullyConfiguredException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Actions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SettlementAccountEnabledButNotFullyConfiguredException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SettlementAccountEnabledButNotFullyConfiguredException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SettlementAccountEnabledButNotFullyConfiguredException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SettlementAccountEnabledButNotFullyConfiguredException Class
SettlementAccountEnabledButNotFullyConfiguredException Members
CompuTec.ProcessForce.API.Actions Namespace


CompuTec.ProcessForce.API.Assigners Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | BadManageTypeException |
Public class | QuantityOverflowException |
Top
Interfaces
 | Name | Description
Public interface | IPickedItems |
Public interface | IRelations |
Public interface | IRequiredItems |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


BadManageTypeException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BadManageTypeException
    Inherits ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BadManageTypeException : ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BadManageTypeException : public ApplicationException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BadManageTypeException
   extends ApplicationException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
CompuTec.ProcessForce.API.Assigners.BadManageTypeException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BadManageTypeException Members
CompuTec.ProcessForce.API.Assigners Namespace


BadManageTypeException Members

BadManageTypeException Class Constructors Methods Properties See Also

The following tables list the members exposed by the BadManageTypeException type.

Constructors
 | Name | Description
Public constructor | BadManageTypeException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

BadManageTypeException Class
CompuTec.ProcessForce.API.Assigners Namespace


BadManageTypeException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BadManageTypeException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BadManageTypeException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BadManageTypeException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BadManageTypeException Class
BadManageTypeException Members
CompuTec.ProcessForce.API.Assigners Namespace


BadManageTypeException Constructor

BadManageTypeException Class See Also

Overload List
Name | Description
BadManageTypeException(string) |
BadManageTypeException(string, Exception) |
See Also

Reference

BadManageTypeException Class
BadManageTypeException Members
CompuTec.ProcessForce.API.Assigners Namespace


IPickedItems Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IPickedItems
    Inherits IUDOChildBean, _
             IEnumerable(Of IPickedItems)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IPickedItems : IUDOChildBean,
   IEnumerable<IPickedItems>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IPickedItems : public IUDOChildBean^,
   public IEnumerable<IPickedItems^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickedItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IPickedItems Members

IPickedItems Interface Methods Properties See Also

The following tables list the members exposed by the IPickedItems type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BnDistNumber | Batch Number for Batch Numbers.
Public property | U_ItemCode |
Public property | U_LicPlateItemCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_LplCode |
Public property | U_LplsPath |
Public property | U_Quantity |
Public property | U_Receipted |
Public property | U_ReceiptedQty |
Public property | U_ReqItmLn |
Public property | U_SnDistNumber | Internal Serial Number for Serial Numbers.
Public property | U_SnLotNumber | Batch ID for Serial Numbers.
Public property | U_SnMnfNumber | Manufacturer Serial Number for Serial Numbers.
Public property | U_SnSysNumber | System Serial Number for Serial Numbers.
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IPickedItems Interface
CompuTec.ProcessForce.API.Assigners Namespace


IPickedItems.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickedItems Interface
IPickedItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IPickedItems.U_LicPlateItemCode Property

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LicPlateItemCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_LicPlateItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_LicPlateItemCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LicPlateItemCode() : int;
function set U_LicPlateItemCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickedItems Interface
IPickedItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IPickedItems.U_SnSysNumber Property

System Serial Number for Serial Numbers.

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SnSysNumber() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SnSysNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SnSysNumber {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SnSysNumber() : int;
function set U_SnSysNumber(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickedItems Interface
IPickedItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IPickedItems.U_SnDistNumber Property

Internal Serial Number for Serial Numbers.

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SnDistNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SnDistNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SnDistNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SnDistNumber() : String;
function set U_SnDistNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickedItems Interface
IPickedItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IPickedItems.U_SnMnfNumber Property

Manufacturer Serial Number for Serial Numbers.

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SnMnfNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SnMnfNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SnMnfNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SnMnfNumber() : String;
function set U_SnMnfNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickedItems Interface
IPickedItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IRelations.U_PickItemLineNo Property

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PickItemLineNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_PickItemLineNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_PickItemLineNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PickItemLineNo() : int;
function set U_PickItemLineNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRelations Interface
IRelations Members
CompuTec.ProcessForce.API.Assigners Namespace


IRequiredItems Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IRequiredItems
    Inherits IUDOChildBean, _
             IEnumerable(Of IRequiredItems)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IRequiredItems : IUDOChildBean,
   IEnumerable<IRequiredItems>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IRequiredItems : public IUDOChildBean^,
   public IEnumerable<IRequiredItems^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRequiredItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IRequiredItems Members

IRequiredItems Interface Methods Properties See Also

The following tables list the members exposed by the IRequiredItems type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_DstWhsCode |
Public property | U_ItemCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PickedQty |
Public property | U_PlannedQty |
Public property | U_RefLine |
Public property | U_SrcWhsCode |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IRequiredItems Interface
CompuTec.ProcessForce.API.Assigners Namespace


IRequiredItems.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRequiredItems Interface
IRequiredItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IRequiredItems.U_PlannedQty Property

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PlannedQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PlannedQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PlannedQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PlannedQty() : double;
function set U_PlannedQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRequiredItems Interface
IRequiredItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IRequiredItems.U_PickedQty Property

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PickedQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PickedQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PickedQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PickedQty() : double;
function set U_PickedQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRequiredItems Interface
IRequiredItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IRequiredItems.U_SrcWhsCode Property

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SrcWhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SrcWhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SrcWhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SrcWhsCode() : String;
function set U_SrcWhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRequiredItems Interface
IRequiredItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IConfiguration.ShelfTime Property

Gets or sets the shelf time.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ShelfTime() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string ShelfTime {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ ShelfTime {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ShelfTime() : String;
function set ShelfTime(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.ReceiptEvaluationType Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ReceiptEvaluationType() As ReceiptEvaluationType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ReceiptEvaluationType ReceiptEvaluationType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ReceiptEvaluationType ReceiptEvaluationType {
 ReceiptEvaluationType get( );
 void set(
   ReceiptEvaluationType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ReceiptEvaluationType() : ReceiptEvaluationType;
function set ReceiptEvaluationType(value : ReceiptEvaluationType);
This language is not supported or no code example is available.

Property Value

Type: ReceiptEvaluationType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.UseTcTotalPrice Property

Gets or sets the indication whether the TC Total price must be used during receiving the item on stock.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property UseTcTotalPrice() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool UseTcTotalPrice {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool UseTcTotalPrice {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UseTcTotalPrice() : boolean;
function set UseTcTotalPrice(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.PostResourcesConfirmation Property

Gets or setrs If resources confirmation are posted

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property PostResourcesConfirmation() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool PostResourcesConfirmation {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool PostResourcesConfirmation {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get PostResourcesConfirmation() : boolean;
function set PostResourcesConfirmation(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.QcResourceGroupCode Property

Gets or sets default item group code for QC resources.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property QcResourceGroupCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int QcResourceGroupCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int QcResourceGroupCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get QcResourceGroupCode() : int;
function set QcResourceGroupCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.QcItemGroupCode Property

Gets or sets default item group code for QC items

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property QcItemGroupCode() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int QcItemGroupCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int QcItemGroupCode {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get QcItemGroupCode() : int;
function set QcItemGroupCode(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


RelationPackage Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RelationPackage()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RelationPackage()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RelationPackage();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RelationPackage Class
RelationPackage Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


RelationPackage(IManufacturingRelations, String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal relation As IManufacturingRelations, _
   ByVal token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RelationPackage(
   IManufacturingRelations relation,
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RelationPackage(
   IManufacturingRelations^ relation,
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RelationPackage(
    relation : IManufacturingRelations,
    token : String
);
This language is not supported or no code example is available.

Parameters

relation

Type: IManufacturingRelations

token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RelationPackage Class
RelationPackage Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


RelationPackage(IManufacturingRelations, IManufacturingOrder, IManufacturingOrder) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal relation As IManufacturingRelations, _
   ByVal child As IManufacturingOrder, _
   ByVal parent As IManufacturingOrder _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RelationPackage(
   IManufacturingRelations relation,
   IManufacturingOrder child,
   IManufacturingOrder parent
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RelationPackage(
   IManufacturingRelations^ relation,
   IManufacturingOrder^ child,
   IManufacturingOrder^ parent
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RelationPackage(
    relation : IManufacturingRelations,
    child : IManufacturingOrder,
    parent : IManufacturingOrder
);
This language is not supported or no code example is available.

Parameters

relation

Type: IManufacturingRelations

child

Type: IManufacturingOrder

parent

Type: IManufacturingOrder

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RelationPackage Class
RelationPackage Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


BaseDocumentIsClosedException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BaseDocumentIsClosedException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BaseDocumentIsClosedException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BaseDocumentIsClosedException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentIsClosedException Class
BaseDocumentIsClosedException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


BaseDocumentIsClosedException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BaseDocumentIsClosedException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BaseDocumentIsClosedException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BaseDocumentIsClosedException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentIsClosedException Class
BaseDocumentIsClosedException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


BaseDocumentIsClosedException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BaseDocumentIsClosedException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BaseDocumentIsClosedException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BaseDocumentIsClosedException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BaseDocumentIsClosedException Class
BaseDocumentIsClosedException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


CantChangeAdjustmentException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CantChangeAdjustmentException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CantChangeAdjustmentException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CantChangeAdjustmentException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantChangeAdjustmentException Class
CantChangeAdjustmentException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


CantChangeAdjustmentException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CantChangeAdjustmentException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CantChangeAdjustmentException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CantChangeAdjustmentException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantChangeAdjustmentException Class
CantChangeAdjustmentException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


CantChangeAdjustmentException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CantChangeAdjustmentException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CantChangeAdjustmentException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CantChangeAdjustmentException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantChangeAdjustmentException Class
CantChangeAdjustmentException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecordingAdjustment Namespace


ExtendedUDOException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class ExtendedUDOException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class ExtendedUDOException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class ExtendedUDOException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class ExtendedUDOException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Core.ExtendedUDOException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExtendedUDOException Members
CompuTec.ProcessForce.API.Core Namespace


ExtendedUDOException Members

ExtendedUDOException Class Constructors Methods Properties See Also

The following tables list the members exposed by the ExtendedUDOException type.

Constructors
 | Name | Description
Public constructor | ExtendedUDOException | (Overloaded)
Top
Properties
 | Name | Description
Public property | ChildType |
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | FieldName |
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | ObjectCode |
Public property | Row |
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

ExtendedUDOException Class
CompuTec.ProcessForce.API.Core Namespace


ExtendedUDOException.ObjectCode Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ObjectCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ObjectCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ObjectCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ObjectCode() : String;
public function set ObjectCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExtendedUDOException Class
ExtendedUDOException Members
CompuTec.ProcessForce.API.Core Namespace


ExtendedUDOException.ChildType Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ChildType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ChildType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ChildType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ChildType() : String;
public function set ChildType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExtendedUDOException Class
ExtendedUDOException Members
CompuTec.ProcessForce.API.Core Namespace


ExtendedUDOException.FieldName Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property FieldName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string FieldName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ FieldName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get FieldName() : String;
public function set FieldName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExtendedUDOException Class
ExtendedUDOException Members
CompuTec.ProcessForce.API.Core Namespace


ExtendedUDOException.Row Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Row() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int Row {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int Row {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Row() : int;
public function set Row(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExtendedUDOException Class
ExtendedUDOException Members
CompuTec.ProcessForce.API.Core Namespace


ExtendedUDOException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ExtendedUDOException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ExtendedUDOException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ExtendedUDOException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExtendedUDOException Class
ExtendedUDOException Members
CompuTec.ProcessForce.API.Core Namespace


ExtendedUDOException Constructor

ExtendedUDOException Class See Also

Overload List
Name | Description
ExtendedUDOException(string, Exception) |
ExtendedUDOException(string, string, string, string, int) |
See Also

Reference

ExtendedUDOException Class
ExtendedUDOException Members
CompuTec.ProcessForce.API.Core Namespace


UDOFormulaException.Row Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Row() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int Row {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property int Row {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Row() : int;
public function set Row(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UDOFormulaException Class
UDOFormulaException Members
CompuTec.ProcessForce.API.Core Namespace


UDOFormulaException Constructor

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public UDOFormulaException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
UDOFormulaException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UDOFormulaException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UDOFormulaException Class
UDOFormulaException Members
CompuTec.ProcessForce.API.Core Namespace


UDOFormulaException Constructor

UDOFormulaException Class See Also

Overload List
Name | Description
UDOFormulaException() |
UDOFormulaException(string) |
UDOFormulaException(string, Exception) |
UDOFormulaException(string, string, string, string, int) |
See Also

Reference

UDOFormulaException Class
UDOFormulaException Members
CompuTec.ProcessForce.API.Core Namespace


UDOFormulaException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public UDOFormulaException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
UDOFormulaException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UDOFormulaException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UDOFormulaException Class
UDOFormulaException Members
CompuTec.ProcessForce.API.Core Namespace


UDOFormulaException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public UDOFormulaException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
UDOFormulaException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UDOFormulaException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UDOFormulaException Class
UDOFormulaException Members
CompuTec.ProcessForce.API.Core Namespace


UDOFormulaException(String, String, String, String, Int32) Constructor

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal UdoType As String, _
   ByVal childType As String, _
   ByVal fieldName As String, _
   ByVal row As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public UDOFormulaException(
   string message,
   string UdoType,
   string childType,
   string fieldName,
   int row
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
UDOFormulaException(
   String^ message,
   String^ UdoType,
   String^ childType,
   String^ fieldName,
   int row
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UDOFormulaException(
    message : String,
    UdoType : String,
    childType : String,
    fieldName : String,
    row : int
);
This language is not supported or no code example is available.

Parameters

message

Type: string

UdoType

Type: string

childType

Type: string

fieldName

Type: string

row

Type: int

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UDOFormulaException Class
UDOFormulaException Members
CompuTec.ProcessForce.API.Core Namespace


IBatchNumbers.ManufacturingDate Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ManufacturingDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime ManufacturingDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime ManufacturingDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ManufacturingDate() : DateTime;
function set ManufacturingDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchNumbers Interface
IBatchNumbers Members
CompuTec.ProcessForce.API.Core Namespace


IBatchNumbers.Notes Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Notes() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Notes {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Notes {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Notes() : String;
function set Notes(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchNumbers Interface
IBatchNumbers Members
CompuTec.ProcessForce.API.Core Namespace


IBatchNumbers.Quantity Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Quantity() : double;
function set Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchNumbers Interface
IBatchNumbers Members
CompuTec.ProcessForce.API.Core Namespace


IBatchNumbers.Locked Property

Indicates If Values Are Blocked ( in case that they are Already Receipted Or Issued

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Locked() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool Locked {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool Locked {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Locked() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchNumbers Interface
IBatchNumbers Members
CompuTec.ProcessForce.API.Core Namespace


IBatchNumbers.TotalQuantity Method

Calculates Total batch Wuantity for Current Document Line that is not Receipted or Issued

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function TotalQuantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double TotalQuantity()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

double TotalQuantity()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function TotalQuantity() : double;
This language is not supported or no code example is available.

Return Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchNumbers Interface
IBatchNumbers Members
CompuTec.ProcessForce.API.Core Namespace


IBatchNumbers.AddBatchToReferences Method

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub AddBatchToReferences()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void AddBatchToReferences()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void AddBatchToReferences()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function AddBatchToReferences();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchNumbers Interface
IBatchNumbers Members
CompuTec.ProcessForce.API.Core Namespace


ISerialNumbers.ReceptionDate Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ReceptionDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime ReceptionDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime ReceptionDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ReceptionDate() : DateTime;
function set ReceptionDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialNumbers Interface
ISerialNumbers Members
CompuTec.ProcessForce.API.Core Namespace


ISerialNumbers.SystemSerialNumber Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property SystemSerialNumber() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int SystemSerialNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int SystemSerialNumber {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get SystemSerialNumber() : int;
function set SystemSerialNumber(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialNumbers Interface
ISerialNumbers Members
CompuTec.ProcessForce.API.Core Namespace


ISerialNumbers.WarrantyEnd Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property WarrantyEnd() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime WarrantyEnd {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime WarrantyEnd {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WarrantyEnd() : DateTime;
function set WarrantyEnd(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialNumbers Interface
ISerialNumbers Members
CompuTec.ProcessForce.API.Core Namespace


ISerialNumbers.WarrantyStart Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property WarrantyStart() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime WarrantyStart {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime WarrantyStart {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get WarrantyStart() : DateTime;
function set WarrantyStart(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialNumbers Interface
ISerialNumbers Members
CompuTec.ProcessForce.API.Core Namespace


ISerialNumbers.TotalCount Method

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function TotalCount() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int TotalCount()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int TotalCount()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function TotalCount() : int;
This language is not supported or no code example is available.

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialNumbers Interface
ISerialNumbers Members
CompuTec.ProcessForce.API.Core Namespace


ISerialNumbers.BinAbsEntry Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BinAbsEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int BinAbsEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int BinAbsEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BinAbsEntry() : int;
function set BinAbsEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialNumbers Interface
ISerialNumbers Members
CompuTec.ProcessForce.API.Core Namespace


IExtendedUDO.RecalcRequired (String, String, Int32) Method

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function RecalcRequired( _
   ByVal tableName As String, _
   ByVal Fieldname As String, _
   ByVal Row As Integer _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool RecalcRequired(
   string tableName,
   string Fieldname,
   int Row
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool RecalcRequired(
   String^ tableName,
   String^ Fieldname,
   int Row
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function RecalcRequired(
    tableName : String,
    Fieldname : String,
    Row : int
) : boolean;
This language is not supported or no code example is available.

Parameters

tableName

Type: string

Fieldname

Type: string

Row

Type: int

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExtendedUDO Interface
IExtendedUDO Members
CompuTec.ProcessForce.API.Core Namespace


CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Interfaces
 | Name | Description
Public interface | IQualityControlTest2 | Quality control test document
Public interface | IQualityControlTestAttachments | Attachments for quality control test document
Public interface | IQualityControlTestBatches | Batches for quality control test document
Public interface | IQualityControlTestDefects | Defects for quality control test document
Public interface | IQualityControlTestItemProperties | Item properties for quality control test document
Public interface | IQualityControlTestItems | Test items for quality control test document
Public interface | IQualityControlTestMultipleTestResults | Multiple test results for quality control test document
Public interface | IQualityControlTestResources | Resources for quality control test document
Public interface | IQualityControlTestSerialNumbers | Serial numbers for quality control test document
Public interface | IQualityControlTestTestResults | Test results for Quality control test document
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IQualityControlTest2 Interface

Members See Also

Quality control test document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOBean(Ignore = false, ObjectType = "QualityControlTest", TableName = "@CT_PF_OQCT", ExludedHttpMethods = "DELETE")> _
Public Interface IQualityControlTest2
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "QualityControlTest", TableName = "@CT_PF_OQCT", ExludedHttpMethods = "DELETE")]
public interface IQualityControlTest2 : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOBean(Ignore = false, ObjectType = "QualityControlTest", TableName = "@CT_PF_OQCT", ExludedHttpMethods = "DELETE")]
public interface class IQualityControlTest2 : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   AppEngineUDOBean(Ignore = false, ObjectType = "QualityControlTest", TableName = "@CT_PF_OQCT", ExludedHttpMethods = "DELETE")
interface IQualityControlTest2
   implements IUDOBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_OQCT
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2 Members

IQualityControlTest2 Interface Methods Properties See Also

Quality control test document

The following tables list the members exposed by the IQualityControlTest2 type.

Properties
 | Name | Description
Public property | Attachments |
Public property | Batches |
Public property | Canceled |
Public property | CreateDate |
Public property | DS_ComplaintDocEntry |
Public property | DS_ComplaintDocNo |
Public property | DS_ComplaintNo |
Public property | DS_ComplaintSeries |
Public property | DS_InspectorTableCode |
Public property | DS_ItemName |
Public property | DS_ItemUoM |
Public property | DS_ManufacturingDocNum |
Public property | DS_ManufacturingOperationName |
Public property | DS_ManufacturingOperationStatus |
Public property | DS_ManufacturingOperationTableCode |
Public property | DS_ManufacturingSeries |
Public property | DS_NcmrInspectorTableCode |
Public property | DS_NcmrTransactionDocNumber |
Public property | DS_NcmrTransactionSeries |
Public property | DS_TestProtocolTableCode |
Public property | DS_UsedCount |
Public property | DataSource |
Public property | Defects |
Public property | DocEntry |
Public property | DocNum |
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Handwrtten |
Public property | Instance |
Public property | ItemProperties |
Public property | ItemPropertyBusinessPartnerRelations |
Public property | Items |
Public property | LogInst |
Public property | MultipleTestResults |
Public property | Object |
Public property | Period |
Public property | ReleaseBatchesOnQCTestPass |
Public property | Resources |
Public property | SerialNumbers |
Public property | Series |
Public property | Status |
Public property | TestResultBusinessPartnerRelations |
Public property | TestResults |
Public property | Token | (inherited from IUDOBean).
Public property | Transfered |
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | U_AcReObligatory |
Public property | U_AcceptanceNumber |
Public property | U_AutoCreate |
Public property | U_BinCode |
Public property | U_BpCode |
Public property | U_Closed |
Public property | U_ComplaintNo |
Public property | U_CreateQCTestPool |
Public property | U_Created |
Public property | U_DefectQty |
Public property | U_Description |
Public property | U_ElectronicSign |
Public property | U_Footer |
Public property | U_Header |
Public property | U_InsCode |
Public property | U_Instructions |
Public property | U_InvMove |
Public property | U_ItemCode |
Public property | U_MnfOprCode |
Public property | U_MnfOrder |
Public property | U_Ncmr |
Public property | U_NcmrInsCode |
Public property | U_NcmrNo |
Public property | U_NumberOfSamples |
Public property | U_OnHold |
Public property | U_PFDBVersion |
Public property | U_PFVersion |
Public property | U_PassFailDate |
Public property | U_PassedQty |
Public property | U_PrjCode |
Public property | U_QcPoolNo |
Public property | U_QcTestNo |
Public property | U_RefersTo |
Public property | U_RejectionNumber |
Public property | U_Remarks |
Public property | U_RevCode |
Public property | U_SampleId |
Public property | U_SampleSize |
Public property | U_Start |
Public property | U_Status |
Public property | U_TestProtocolNo |
Public property | U_TestStatus |
Public property | U_TransType |
Public property | U_UoM |
Public property | U_WaitingNcmr |
Public property | U_WhsCode |
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Public property | UpdateDate |
Public property | UpdateTime |
Public property | UserSign |
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | CheckIfTestStatusOfQCTestIsCorrect | Check if Status of Quality Control Test Pool document is correct.
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | SetDefaultSeries | Sets the default series for Quality Control Test document.
Public method | SetQCTestsStatus | Sets QC Status for Quality Control Test document.
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IQualityControlTest2 Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineProperty(IsMasterKey = true)> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineProperty(IsMasterKey = true)]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEngineProperty(IsMasterKey = true)
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.DocNum Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocNum() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocNum {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocNum {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocNum() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.Period Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Period() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Period {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Period {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Period() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.Instance Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Instance() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Instance {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Instance {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Instance() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.Series Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Series() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Series {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Series {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Series() : int;
function set Series(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.Handwrtten Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Handwrtten() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Handwrtten {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Handwrtten {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Handwrtten() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.Canceled Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Canceled() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Canceled {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Canceled {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Canceled() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.UserSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property UserSign() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int UserSign {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int UserSign {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get UserSign() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IPFAction Interface

Members See Also

Base Type for Every Action

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IPFAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IPFAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IPFAction
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IPFAction
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPFAction Members
CompuTec.ProcessForce.API.Core Namespace


IQualityControlTest2.Transfered Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Transfered() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Transfered {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Transfered {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Transfered() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.Status Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Status {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Status {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Status() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property CreateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime CreateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime CreateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get CreateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateDate {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateDate {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateDate() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.UpdateTime Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property UpdateTime() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime UpdateTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime UpdateTime {
 DateTime get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get UpdateTime() : DateTime;
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.DataSource Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DataSource() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DataSource {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DataSource {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DataSource() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_PFVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFVersion() : String;
function set U_PFVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_PFDBVersion Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PFDBVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PFDBVersion {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PFDBVersion {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PFDBVersion() : String;
function set U_PFDBVersion(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_QcTestNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QcTestNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_QcTestNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_QcTestNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QcTestNo() : int;
function set U_QcTestNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_QcPoolNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QcPoolNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_QcPoolNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_QcPoolNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QcPoolNo() : int;
function set U_QcPoolNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IPFAction Members

IPFAction Interface Methods See Also

Base Type for Every Action

The following tables list the members exposed by the IPFAction type.

Methods
 | Name | Description
Public method | DoAction | Excecutes an action
Public method | GetCreatedDocumentReferences | This method returns Created Document References while do action
Top
See Also

Reference

IPFAction Interface
CompuTec.ProcessForce.API.Core Namespace


IQualityControlTest2.U_TestProtocolNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestProtocolNo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TestProtocolNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TestProtocolNo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestProtocolNo() : String;
function set U_TestProtocolNo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_Description Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Description() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Description {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Description {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Description() : String;
function set U_Description(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_RevCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RevCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RevCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RevCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RevCode() : String;
function set U_RevCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_WhsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_BinCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BinCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BinCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BinCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BinCode() : String;
function set U_BinCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_ComplaintNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ComplaintNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ComplaintNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ComplaintNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ComplaintNo() : int;
function set U_ComplaintNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_PrjCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrjCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrjCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrjCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrjCode() : String;
function set U_PrjCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_InsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InsCode() : String;
function set U_InsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_ElectronicSign Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ElectronicSign() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ElectronicSign {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ElectronicSign {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ElectronicSign() : String;
function set U_ElectronicSign(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_Status Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Status() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Status {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Status {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Status() : String;
function set U_Status(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_Created Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property U_Created() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime U_Created {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime U_Created {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_Created() : DateTime;

   AppEnginePropertyIgnore()
function set U_Created(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_Start Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property U_Start() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
DateTime U_Start {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property DateTime U_Start {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get U_Start() : DateTime;

   AppEnginePropertyIgnore()
function set U_Start(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_OnHold Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_OnHold() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_OnHold {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_OnHold {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_OnHold() : DateTime;
function set U_OnHold(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_WaitingNcmr Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WaitingNcmr() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_WaitingNcmr {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_WaitingNcmr {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WaitingNcmr() : DateTime;
function set U_WaitingNcmr(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_Closed Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Closed() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Closed {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Closed {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Closed() : DateTime;
function set U_Closed(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_TestStatus Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestStatus() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TestStatus {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TestStatus {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestStatus() : String;
function set U_TestStatus(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_PassFailDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PassFailDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_PassFailDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_PassFailDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PassFailDate() : DateTime;
function set U_PassFailDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_TransType Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TransType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TransType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TransType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TransType() : String;
function set U_TransType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_SampleSize Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SampleSize() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_SampleSize {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_SampleSize {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SampleSize() : double;
function set U_SampleSize(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_SampleId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SampleId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SampleId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SampleId {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SampleId() : int;
function set U_SampleId(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_NumberOfSamples Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_NumberOfSamples() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_NumberOfSamples {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_NumberOfSamples {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_NumberOfSamples() : int;
function set U_NumberOfSamples(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_AcceptanceNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AcceptanceNumber() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_AcceptanceNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_AcceptanceNumber {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AcceptanceNumber() : int;
function set U_AcceptanceNumber(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_RejectionNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RejectionNumber() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_RejectionNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_RejectionNumber {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RejectionNumber() : int;
function set U_RejectionNumber(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_RefersTo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RefersTo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RefersTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RefersTo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RefersTo() : String;
function set U_RefersTo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_AutoCreate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AutoCreate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AutoCreate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AutoCreate {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AutoCreate() : String;
function set U_AutoCreate(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_CreateQCTestPool Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_CreateQCTestPool() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_CreateQCTestPool {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_CreateQCTestPool {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_CreateQCTestPool() : String;
function set U_CreateQCTestPool(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_AcReObligatory Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AcReObligatory() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_AcReObligatory {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_AcReObligatory {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AcReObligatory() : String;
function set U_AcReObligatory(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_UoM Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UoM() : String;
function set U_UoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_PassedQty Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PassedQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PassedQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PassedQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PassedQty() : double;
function set U_PassedQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_DefectQty Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DefectQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_DefectQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_DefectQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DefectQty() : double;
function set U_DefectQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_InvMove Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InvMove() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InvMove {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InvMove {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InvMove() : String;
function set U_InvMove(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_Ncmr Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Ncmr() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Ncmr {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Ncmr {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Ncmr() : String;
function set U_Ncmr(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_NcmrInsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_NcmrInsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_NcmrInsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_NcmrInsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_NcmrInsCode() : String;
function set U_NcmrInsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_NcmrNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_NcmrNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_NcmrNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_NcmrNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_NcmrNo() : int;
function set U_NcmrNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_Instructions Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Instructions() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Instructions {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Instructions {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Instructions() : String;
function set U_Instructions(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_BpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BpCode() : String;
function set U_BpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IUDFItem Interface

Members See Also

Representation of UdfField ( name and Value)

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IUDFItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IUDFItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IUDFItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IUDFItem
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDFItem Members
CompuTec.ProcessForce.API.Core Namespace


IQualityControlTest2.U_MnfOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MnfOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_MnfOrder {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_MnfOrder {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MnfOrder() : int;
function set U_MnfOrder(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_MnfOprCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_MnfOprCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_MnfOprCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_MnfOprCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_MnfOprCode() : String;
function set U_MnfOprCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_Footer Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Footer() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Footer {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Footer {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Footer() : String;
function set U_Footer(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.U_Header Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Header() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Header {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Header {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Header() : String;
function set U_Header(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.DS_ItemName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemName() : String;

   AppEnginePropertyIgnore()
function set DS_ItemName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.DS_ItemUoM Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ItemUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemUoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemUoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemUoM() : String;

   AppEnginePropertyIgnore()
function set DS_ItemUoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.DS_UsedCount Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_UsedCount() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_UsedCount {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_UsedCount {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_UsedCount() : String;

   AppEnginePropertyIgnore()
function set DS_UsedCount(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.DS_TestProtocolTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_TestProtocolTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_TestProtocolTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_TestProtocolTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_TestProtocolTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_TestProtocolTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.DS_ComplaintNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ComplaintNo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ComplaintNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ComplaintNo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ComplaintNo() : String;

   AppEnginePropertyIgnore()
function set DS_ComplaintNo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.DS_ComplaintDocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ComplaintDocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DS_ComplaintDocEntry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DS_ComplaintDocEntry {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ComplaintDocEntry() : int;

   AppEnginePropertyIgnore()
function set DS_ComplaintDocEntry(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IUDFItem Members

IUDFItem Interface Methods Properties See Also

Representation of UdfField ( name and Value)

The following tables list the members exposed by the IUDFItem type.

Properties
 | Name | Description
Public property | DefaultValue |
Public property | Description | Description Of an UDF item
Public property | HasValidValues | Does Udf has Valid Values
Public property | IsTime |
Public property | Name | Name of UDF Field
Public property | Value | Get,Set UDF Value
Top
Methods
 | Name | Description
Public method | GetValueType | Type of Value
Top
See Also

Reference

IUDFItem Interface
CompuTec.ProcessForce.API.Core Namespace


IQualityControlTest2.DS_ComplaintDocNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ComplaintDocNo() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ComplaintDocNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ComplaintDocNo {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ComplaintDocNo() : String;

   AppEnginePropertyIgnore()
function set DS_ComplaintDocNo(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.DS_ComplaintSeries Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ComplaintSeries() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ComplaintSeries {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ComplaintSeries {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ComplaintSeries() : String;

   AppEnginePropertyIgnore()
function set DS_ComplaintSeries(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.DS_InspectorTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_InspectorTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_InspectorTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_InspectorTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_InspectorTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_InspectorTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.DS_NcmrInspectorTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_NcmrInspectorTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_NcmrInspectorTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_NcmrInspectorTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_NcmrInspectorTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_NcmrInspectorTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.DS_NcmrTransactionDocNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_NcmrTransactionDocNumber() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DS_NcmrTransactionDocNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DS_NcmrTransactionDocNumber {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_NcmrTransactionDocNumber() : int;

   AppEnginePropertyIgnore()
function set DS_NcmrTransactionDocNumber(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.DS_NcmrTransactionSeries Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_NcmrTransactionSeries() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DS_NcmrTransactionSeries {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DS_NcmrTransactionSeries {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_NcmrTransactionSeries() : int;

   AppEnginePropertyIgnore()
function set DS_NcmrTransactionSeries(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IUDFItems.Item Method

Example See Also

Gets Current UdfObject

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function Item( _
   ByVal name As String _
) As IUDFItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IUDFItem Item(
   string name
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

IUDFItem^ Item(
   String^ name
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Item(
    name : String
) : IUDFItem;
This language is not supported or no code example is available.

Parameters

name

Type: string

Name of UDF field

Return Value

Type: IUDFItem

UDF Representation

Example
VB
C#
F#
C++
JScript
Copy
CompuTec.ProcessForce.API.Documents.BillOfMaterials.IBillOfMaterial bom=pfcompany.CreatePFObject(ObjectTypes.BillOfMaterial);
 string udfValue = bom.UDFItems.Item("U_test").Value; //recive current value
 bom.UDFItems.Item("U_test").Value="new value" ;// set new value
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDFItems Interface
IUDFItems Members
CompuTec.ProcessForce.API.Core Namespace


IUDFItems.getUDFNames Method

Example See Also

Returns List of UDF Fields

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function getUDFNames() As String()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string[] getUDFNames()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

array< String^ >^ getUDFNames()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function getUDFNames() : String[];
This language is not supported or no code example is available.

Return Value

Type: string[]

Table of filed names

Example
VB
C#
F#
C++
JScript
Copy
CompuTec.ProcessForce.API.Documents.BillOfMaterials.IBillOfMaterial bom=pfcompany.CreatePFObject(ObjectTypes.BillOfMaterial);
 string[] udfFieldNames = bom.UDFItems.getUDFNames();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDFItems Interface
IUDFItems Members
CompuTec.ProcessForce.API.Core Namespace


IUDOBean Interface

Members See Also

This Interface delivers Basic Operaton On our UDO

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IUDOBean
    Inherits IDisposable
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IUDOBean : IDisposable
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IUDOBean : public IDisposable^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IUDOBean
   implements IDisposable
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOBean Members
CompuTec.ProcessForce.API.Core Namespace


IUDOBean Members

IUDOBean Interface Methods Properties See Also

This Interface delivers Basic Operaton On our UDO

The following tables list the members exposed by the IUDOBean type.

Properties
 | Name | Description
Public property | ErrorDescription | Error Information if any
Public property | Token |
Public property | UDFItems | User Defined Items
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse
Public property | UdoName | gets UDOName of current object
Public property | UdoTableName | Gets Correspondend Table name in databse
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database
Public method | CanDelete | Gets Can Delete information
Public method | Clean |
Public method | Delete | Deletes an object
Public method | GetAsXML |
Public method | GetByKey | Loads object with values From Database
Public method | GetLastObjectCode | Returns Object Code form newly added item
Public method | RefreshHeaderData |
Public method | Update | Update An object
Top
See Also

Reference

IUDOBean Interface
CompuTec.ProcessForce.API.Core Namespace


IAdvancedUDOBean Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IAdvancedUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IAdvancedUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IAdvancedUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IAdvancedUDOBean
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdvancedUDOBean Members
CompuTec.ProcessForce.API.Core Namespace


IAdvancedUDOBean Members

IAdvancedUDOBean Interface Methods See Also

The following tables list the members exposed by the IAdvancedUDOBean type.

Methods
 | Name | Description
Public method | SetChangingFromUdo |
Top
See Also

Reference

IAdvancedUDOBean Interface
CompuTec.ProcessForce.API.Core Namespace


IAdvancedUDOBean.SetChangingFromUdo Method

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub SetChangingFromUdo( _
   ByVal value As Boolean _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void SetChangingFromUdo(
   bool value
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void SetChangingFromUdo(
   bool value
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function SetChangingFromUdo(
    value : boolean
);
This language is not supported or no code example is available.

Parameters

value

Type: bool

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IAdvancedUDOBean Interface
IAdvancedUDOBean Members
CompuTec.ProcessForce.API.Core Namespace


IUDOChildBean Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IUDOChildBean
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOChildBean Members
CompuTec.ProcessForce.API.Core Namespace


IUDOChildBean Members

IUDOChildBean Interface Methods Properties See Also

The following tables list the members exposed by the IUDOChildBean type.

Properties
 | Name | Description
Public property | Count | Number of Childs
Public property | CurrentChild |
Public property | UDFItems | UDF Items for current object
Public property | U_LineNum | Gets ProcessForce Line Num
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end
Public method | AddRowAtPos | Adds Row At specific position
Public method | Clear |
Public method | DelRowAtPos | Del rows of specific Position
Public method | SetCurrentLine | Sets Line on specific Position from o to Count
Top
See Also

Reference

IUDOChildBean Interface
CompuTec.ProcessForce.API.Core Namespace


Technology.GetOperationName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetOperationName( _
   ByVal Tokem As String, _
   ByVal OprCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetOperationName(
   string Tokem,
   string OprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetOperationName(
   String^ Tokem,
   String^ OprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetOperationName(
    Tokem : String,
    OprCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Tokem

Type: string

OprCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetBomCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetBomCode( _
   ByVal Token As String, _
   ByVal itemCode As String, _
   ByVal Revision As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetBomCode(
   string Token,
   string itemCode,
   string Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetBomCode(
   String^ Token,
   String^ itemCode,
   String^ Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetBomCode(
    Token : String,
    itemCode : String,
    Revision : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemCode

Type: string

Revision

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetBillOfMaterialCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetBillOfMaterialCode( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CTRecordset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static CTRecordset GetBillOfMaterialCode(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static CTRecordset^ GetBillOfMaterialCode(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetBillOfMaterialCode(
    token : String,
    itemCode : String
) : CTRecordset;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CTRecordset
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetOperationCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetOperationCode( _
   ByVal Token As String, _
   ByVal OprCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetOperationCode(
   string Token,
   string OprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetOperationCode(
   String^ Token,
   String^ OprCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetOperationCode(
    Token : String,
    OprCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

OprCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.BillOfMaterialExists Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function BillOfMaterialExists( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal Revision As String, _
   Optional ByVal returnOnlnewMors As Boolean = false _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool BillOfMaterialExists(
   string Token,
   string ItemCode,
   string Revision,
   bool returnOnlnewMors = false
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool BillOfMaterialExists(
   String^ Token,
   String^ ItemCode,
   String^ Revision,
   bool returnOnlnewMors
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function BillOfMaterialExists(
    Token : String,
    ItemCode : String,
    Revision : String,
    returnOnlnewMors : boolean
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Revision

Type: string

returnOnlnewMors

Type: bool

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetRoutingName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetRoutingName( _
   ByVal Token As String, _
   ByVal RtgCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetRoutingName(
   string Token,
   string RtgCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetRoutingName(
   String^ Token,
   String^ RtgCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetRoutingName(
    Token : String,
    RtgCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

RtgCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetRoutingCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetRoutingCode( _
   ByVal Token As String, _
   ByVal RtgCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetRoutingCode(
   string Token,
   string RtgCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetRoutingCode(
   String^ Token,
   String^ RtgCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetRoutingCode(
    Token : String,
    RtgCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

RtgCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetIOPropertyName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetIOPropertyName( _
   ByVal Token As String, _
   ByVal prpCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetIOPropertyName(
   string Token,
   string prpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetIOPropertyName(
   String^ Token,
   String^ prpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetIOPropertyName(
    Token : String,
    prpCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

prpCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetIOPropertyCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetIOPropertyCode( _
   ByVal Token As String, _
   ByVal prpCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetIOPropertyCode(
   string Token,
   string prpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetIOPropertyCode(
   String^ Token,
   String^ prpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetIOPropertyCode(
    Token : String,
    prpCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

prpCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetNumberOfResources Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetNumberOfResources( _
   ByVal Token As String, _
   ByVal ResourceCode As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int GetNumberOfResources(
   string Token,
   string ResourceCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static int GetNumberOfResources(
   String^ Token,
   String^ ResourceCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetNumberOfResources(
    Token : String,
    ResourceCode : String
) : int;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ResourceCode

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetResourceType Method

Returns Resource Type for requested resource Code

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResourceType( _
   ByVal Token As String, _
   ByVal rscCode As String _
) As ResourceType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static ResourceType GetResourceType(
   string Token,
   string rscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static ResourceType GetResourceType(
   String^ Token,
   String^ rscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResourceType(
    Token : String,
    rscCode : String
) : ResourceType;
This language is not supported or no code example is available.

Parameters

Token

Type: string

rscCode

Type: string

Return Value

Type: ResourceType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetBillOfMaterialsBatchSize Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetBillOfMaterialsBatchSize( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String _
) As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static double GetBillOfMaterialsBatchSize(
   string token,
   string itemCode,
   string revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static double GetBillOfMaterialsBatchSize(
   String^ token,
   String^ itemCode,
   String^ revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetBillOfMaterialsBatchSize(
    token : String,
    itemCode : String,
    revCode : String
) : double;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

Return Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetSpecificFormula Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetSpecificFormula( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal ftype As FormulaType _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetSpecificFormula(
   string token,
   string itemCode,
   FormulaType ftype
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetSpecificFormula(
   String^ token,
   String^ itemCode,
   FormulaType ftype
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetSpecificFormula(
    token : String,
    itemCode : String,
    ftype : FormulaType
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

ftype

Type: FormulaType

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetYieldFormulas Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetYieldFormulas( _
   ByVal token As String, _
   ByVal itemCode As String _
) As YieldFormulasClass
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static YieldFormulasClass GetYieldFormulas(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static YieldFormulasClass^ GetYieldFormulas(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetYieldFormulas(
    token : String,
    itemCode : String
) : YieldFormulasClass;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: YieldFormulasClass
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Costing Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class Costing
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Costing
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class Costing
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Costing
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.ItemUtils.Costing
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Costing Members
CompuTec.ProcessForce.API.Tools Namespace


Costing Members

Costing Class Methods See Also

The following tables list the members exposed by the Costing type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | GetCostCategoryTableCode |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetReceiptPriceEx |
 | GetReceiptPriceExForHeader |
 | GetResourceCost |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | IsItemOnStock |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Classes
 | Name | Description
Public class | ResourceCostEntry |
Public class | ResourceCostingData |
Top
See Also

Reference

Costing Class
CompuTec.ProcessForce.API.Tools Namespace


ResourceCostingData Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ResourceCostingData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ResourceCostingData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ResourceCostingData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ResourceCostingData
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.ItemUtils.Costing.ResourceCostingData
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCostingData Members
CompuTec.ProcessForce.API.Tools Namespace


ResourceCostingData Members

ResourceCostingData Class Constructors Methods Properties See Also

The following tables list the members exposed by the ResourceCostingData type.

Constructors
 | Name | Description
Public constructor | ResourceCostingData |
Top
Properties
 | Name | Description
Public property | QueueCost |
Public property | RunCost |
Public property | SetupCost |
Public property | StockCost |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ResourceCostingData Class
CompuTec.ProcessForce.API.Tools Namespace


ResourceCostingData.QueueCost Property

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property QueueCost() As ResourceCostEntry
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceCostEntry QueueCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property ResourceCostEntry^ QueueCost {
 ResourceCostEntry^ get( );
 void set(
   ResourceCostEntry^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get QueueCost() : ResourceCostEntry;
public function set QueueCost(value : ResourceCostEntry);
This language is not supported or no code example is available.

Property Value

Type: ResourceCostEntry
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCostingData Class
ResourceCostingData Members
CompuTec.ProcessForce.API.Tools Namespace


ResourceCostingData.SetupCost Property

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property SetupCost() As ResourceCostEntry
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceCostEntry SetupCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property ResourceCostEntry^ SetupCost {
 ResourceCostEntry^ get( );
 void set(
   ResourceCostEntry^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get SetupCost() : ResourceCostEntry;
public function set SetupCost(value : ResourceCostEntry);
This language is not supported or no code example is available.

Property Value

Type: ResourceCostEntry
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCostingData Class
ResourceCostingData Members
CompuTec.ProcessForce.API.Tools Namespace


ResourceCostingData.RunCost Property

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property RunCost() As ResourceCostEntry
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceCostEntry RunCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property ResourceCostEntry^ RunCost {
 ResourceCostEntry^ get( );
 void set(
   ResourceCostEntry^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get RunCost() : ResourceCostEntry;
public function set RunCost(value : ResourceCostEntry);
This language is not supported or no code example is available.

Property Value

Type: ResourceCostEntry
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCostingData Class
ResourceCostingData Members
CompuTec.ProcessForce.API.Tools Namespace


ResourceCostingData.StockCost Property

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property StockCost() As ResourceCostEntry
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceCostEntry StockCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property ResourceCostEntry^ StockCost {
 ResourceCostEntry^ get( );
 void set(
   ResourceCostEntry^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get StockCost() : ResourceCostEntry;
public function set StockCost(value : ResourceCostEntry);
This language is not supported or no code example is available.

Property Value

Type: ResourceCostEntry
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCostingData Class
ResourceCostingData Members
CompuTec.ProcessForce.API.Tools Namespace


ResourceCostingData Constructor

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceCostingData()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceCostingData()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceCostingData();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCostingData Class
ResourceCostingData Members
CompuTec.ProcessForce.API.Tools Namespace


ResourceCostEntry Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ResourceCostEntry
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ResourceCostEntry
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ResourceCostEntry
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ResourceCostEntry
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.ItemUtils.Costing.ResourceCostEntry
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCostEntry Members
CompuTec.ProcessForce.API.Tools Namespace


ResourceCostEntry Members

ResourceCostEntry Class Constructors Methods Properties See Also

The following tables list the members exposed by the ResourceCostEntry type.

Constructors
 | Name | Description
Public constructor | ResourceCostEntry |
Top
Properties
 | Name | Description
Public property | FixedCost |
Public property | HourRate |
Public property | VariableCost |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ResourceCostEntry Class
CompuTec.ProcessForce.API.Tools Namespace


ResourceCostEntry.HourRate Property

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property HourRate() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double HourRate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property double HourRate {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get HourRate() : double;
public function set HourRate(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCostEntry Class
ResourceCostEntry Members
CompuTec.ProcessForce.API.Tools Namespace


ResourceCostEntry.FixedCost Property

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property FixedCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double FixedCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property double FixedCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get FixedCost() : double;
public function set FixedCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCostEntry Class
ResourceCostEntry Members
CompuTec.ProcessForce.API.Tools Namespace


ResourceCostEntry.VariableCost Property

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property VariableCost() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double VariableCost {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property double VariableCost {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get VariableCost() : double;
public function set VariableCost(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCostEntry Class
ResourceCostEntry Members
CompuTec.ProcessForce.API.Tools Namespace


ResourceCostEntry Constructor

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceCostEntry()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceCostEntry()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceCostEntry();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCostEntry Class
ResourceCostEntry Members
CompuTec.ProcessForce.API.Tools Namespace


Costing.GetResourceCost Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResourceCost( _
   ByVal Token As String, _
   ByVal ResurceCode As String _
) As ResourceCostingData
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static ResourceCostingData GetResourceCost(
   string Token,
   string ResurceCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static ResourceCostingData^ GetResourceCost(
   String^ Token,
   String^ ResurceCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResourceCost(
    Token : String,
    ResurceCode : String
) : ResourceCostingData;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ResurceCode

Type: string

Return Value

Type: ResourceCostingData
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Costing Class
Costing Members
CompuTec.ProcessForce.API.Tools Namespace


Costing.GetReceiptPriceExForHeader Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetReceiptPriceExForHeader( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String, _
   ByVal revCode As String, _
   ByVal Routing As String _
) As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static double GetReceiptPriceExForHeader(
   string Token,
   string ItemCode,
   string WhsCode,
   string revCode,
   string Routing
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static double GetReceiptPriceExForHeader(
   String^ Token,
   String^ ItemCode,
   String^ WhsCode,
   String^ revCode,
   String^ Routing
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetReceiptPriceExForHeader(
    Token : String,
    ItemCode : String,
    WhsCode : String,
    revCode : String,
    Routing : String
) : double;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

WhsCode

Type: string

revCode

Type: string

Routing

Type: string

Return Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Costing Class
Costing Members
CompuTec.ProcessForce.API.Tools Namespace


Costing.GetReceiptPriceEx Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetReceiptPriceEx( _
   ByVal Token As String, _
   ByVal ItemCode As String, _
   ByVal WhsCode As String, _
   ByVal revCode As String _
) As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static double GetReceiptPriceEx(
   string Token,
   string ItemCode,
   string WhsCode,
   string revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static double GetReceiptPriceEx(
   String^ Token,
   String^ ItemCode,
   String^ WhsCode,
   String^ revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetReceiptPriceEx(
    Token : String,
    ItemCode : String,
    WhsCode : String,
    revCode : String
) : double;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

WhsCode

Type: string

revCode

Type: string

Return Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Costing Class
Costing Members
CompuTec.ProcessForce.API.Tools Namespace


Costing.IsItemOnStock Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function IsItemOnStock( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal warehouse As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool IsItemOnStock(
   string token,
   string itemCode,
   string warehouse
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool IsItemOnStock(
   String^ token,
   String^ itemCode,
   String^ warehouse
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function IsItemOnStock(
    token : String,
    itemCode : String,
    warehouse : String
) : boolean;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

warehouse

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Costing Class
Costing Members
CompuTec.ProcessForce.API.Tools Namespace


Costing.GetCostCategoryTableCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetCostCategoryTableCode( _
   ByVal token As String, _
   ByVal categoryCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetCostCategoryTableCode(
   string token,
   string categoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetCostCategoryTableCode(
   String^ token,
   String^ categoryCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetCostCategoryTableCode(
    token : String,
    categoryCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

categoryCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Costing Class
Costing Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.IsStockItem Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function IsStockItem( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool IsStockItem(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool IsStockItem(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function IsStockItem(
    Token : String,
    ItemCode : String
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.IsNotStockAndPPurchaseItem Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function IsNotStockAndPPurchaseItem( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool IsNotStockAndPPurchaseItem(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool IsNotStockAndPPurchaseItem(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function IsNotStockAndPPurchaseItem(
    Token : String,
    ItemCode : String
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.IsurchaseItem Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function IsurchaseItem( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool IsurchaseItem(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool IsurchaseItem(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function IsurchaseItem(
    Token : String,
    ItemCode : String
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


SubContracting Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SubContracting
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SubContracting
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SubContracting
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SubContracting
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.ItemUtils.SubContracting
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SubContracting Members
CompuTec.ProcessForce.API.Tools Namespace


SubContracting Members

SubContracting Class Methods See Also

The following tables list the members exposed by the SubContracting type.

Methods
 | Name | Description
 | CreateProcurmentDocuments |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | GetGoodsReceiptPOSeries |
 | GetGoodsReturnSeries |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetProcurmentDocumentType |
 | GetProcurmentOrderSeries |
 | GetProcurmentRequestSeries |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Enumerations
 | Name | Description
Public enumeration | ProcurmentDocumentType |
Top
See Also

Reference

SubContracting Class
CompuTec.ProcessForce.API.Tools Namespace


ProcurmentDocumentType Enumeration

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
Order |
Request |
See Also

Reference

SubContracting Class
SubContracting Members
CompuTec.ProcessForce.API.Tools Namespace


SubContracting.CreateProcurmentDocuments Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function CreateProcurmentDocuments( _
   ByVal token As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool CreateProcurmentDocuments(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool CreateProcurmentDocuments(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function CreateProcurmentDocuments(
    token : String
) : boolean;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SubContracting Class
SubContracting Members
CompuTec.ProcessForce.API.Tools Namespace


SubContracting.GetProcurmentDocumentType Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetProcurmentDocumentType( _
   ByVal token As String _
) As ProcurmentDocumentType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static ProcurmentDocumentType GetProcurmentDocumentType(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static ProcurmentDocumentType GetProcurmentDocumentType(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetProcurmentDocumentType(
    token : String
) : ProcurmentDocumentType;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: ProcurmentDocumentType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SubContracting Class
SubContracting Members
CompuTec.ProcessForce.API.Tools Namespace


SubContracting.GetProcurmentRequestSeries Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetProcurmentRequestSeries( _
   ByVal token As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int GetProcurmentRequestSeries(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static int GetProcurmentRequestSeries(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetProcurmentRequestSeries(
    token : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SubContracting Class
SubContracting Members
CompuTec.ProcessForce.API.Tools Namespace


SubContracting.GetProcurmentOrderSeries Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetProcurmentOrderSeries( _
   ByVal token As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int GetProcurmentOrderSeries(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static int GetProcurmentOrderSeries(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetProcurmentOrderSeries(
    token : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SubContracting Class
SubContracting Members
CompuTec.ProcessForce.API.Tools Namespace


SubContracting.GetGoodsReceiptPOSeries Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetGoodsReceiptPOSeries( _
   ByVal token As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int GetGoodsReceiptPOSeries(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static int GetGoodsReceiptPOSeries(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetGoodsReceiptPOSeries(
    token : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SubContracting Class
SubContracting Members
CompuTec.ProcessForce.API.Tools Namespace


SubContracting.GetGoodsReturnSeries Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetGoodsReturnSeries( _
   ByVal token As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int GetGoodsReturnSeries(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static int GetGoodsReturnSeries(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetGoodsReturnSeries(
    token : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SubContracting Class
SubContracting Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.IsBom Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function IsBom( _
   ByVal token As String, _
   ByVal Itemcode As String, _
   ByVal Revision As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool IsBom(
   string token,
   string Itemcode,
   string Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool IsBom(
   String^ token,
   String^ Itemcode,
   String^ Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function IsBom(
    token : String,
    Itemcode : String,
    Revision : String
) : boolean;
This language is not supported or no code example is available.

Parameters

token

Type: string

Itemcode

Type: string

Revision

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.IsRevisionUsedInBOM Method

Checks if specific ItemCode and Revisoon is used in BOM object

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function IsRevisionUsedInBOM( _
   ByVal token As String, _
   ByVal Itemcode As String, _
   ByVal Revision As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool IsRevisionUsedInBOM(
   string token,
   string Itemcode,
   string Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool IsRevisionUsedInBOM(
   String^ token,
   String^ Itemcode,
   String^ Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function IsRevisionUsedInBOM(
    token : String,
    Itemcode : String,
    Revision : String
) : boolean;
This language is not supported or no code example is available.

Parameters

token

Type: string

Itemcode

Type: string

Revision

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetReworkReasonName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetReworkReasonName( _
   ByVal Token As String, _
   ByVal Code As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetReworkReasonName(
   string Token,
   string Code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetReworkReasonName(
   String^ Token,
   String^ Code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetReworkReasonName(
    Token : String,
    Code : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Code

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetScrapReasonName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetScrapReasonName( _
   ByVal Token As String, _
   ByVal Code As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetScrapReasonName(
   string Token,
   string Code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetScrapReasonName(
   String^ Token,
   String^ Code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetScrapReasonName(
    Token : String,
    Code : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Code

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetRevisionName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetRevisionName( _
   ByVal itemcode As String, _
   ByVal revisionCode As String, _
   ByVal Token As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetRevisionName(
   string itemcode,
   string revisionCode,
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetRevisionName(
   String^ itemcode,
   String^ revisionCode,
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetRevisionName(
    itemcode : String,
    revisionCode : String,
    Token : String
) : String;
This language is not supported or no code example is available.

Parameters

itemcode

Type: string

revisionCode

Type: string

Token

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetReceiptReevaluationType Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetReceiptReevaluationType( _
   ByVal Token As String _
) As ReceiptEvaluationType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static ReceiptEvaluationType GetReceiptReevaluationType(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static ReceiptEvaluationType GetReceiptReevaluationType(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetReceiptReevaluationType(
    Token : String
) : ReceiptEvaluationType;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: ReceiptEvaluationType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetScrapReevaluationType Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetScrapReevaluationType( _
   ByVal Token As String _
) As ReceiptEvaluationType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static ReceiptEvaluationType GetScrapReevaluationType(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static ReceiptEvaluationType GetScrapReevaluationType(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetScrapReevaluationType(
    Token : String
) : ReceiptEvaluationType;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: ReceiptEvaluationType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetCoproductReevaluationType Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetCoproductReevaluationType( _
   ByVal Token As String _
) As ReceiptEvaluationType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static ReceiptEvaluationType GetCoproductReevaluationType(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static ReceiptEvaluationType GetCoproductReevaluationType(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetCoproductReevaluationType(
    Token : String
) : ReceiptEvaluationType;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: ReceiptEvaluationType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetBatchQueueType Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetBatchQueueType( _
   ByVal Token As String, _
   ByVal itemCode As String _
) As BatchQueueType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static BatchQueueType GetBatchQueueType(
   string Token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static BatchQueueType GetBatchQueueType(
   String^ Token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetBatchQueueType(
    Token : String,
    itemCode : String
) : BatchQueueType;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemCode

Type: string

Return Value

Type: BatchQueueType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetAdditionalBatchDetailsTableCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetAdditionalBatchDetailsTableCode( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal batch As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetAdditionalBatchDetailsTableCode(
   string token,
   string itemCode,
   string batch
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetAdditionalBatchDetailsTableCode(
   String^ token,
   String^ itemCode,
   String^ batch
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetAdditionalBatchDetailsTableCode(
    token : String,
    itemCode : String,
    batch : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

batch

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.CheckDefaultWarehouse Method

Checks if a default warehouse is defined for an item.

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function CheckDefaultWarehouse( _
   ByVal Token As String, _
   ByVal itemCode As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool CheckDefaultWarehouse(
   string Token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool CheckDefaultWarehouse(
   String^ Token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function CheckDefaultWarehouse(
    Token : String,
    itemCode : String
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemCode

Type: string

Item code.

Return Value

Type: bool

A Boolean value that indicates whether the default warehouse is defined for an item (true) or not (false).

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.CheckRevisionUsability Method

Checks if the combination of an item and revision corresponds to any of available bill of materials.

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function CheckRevisionUsability( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool CheckRevisionUsability(
   string token,
   string itemCode,
   string revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool CheckRevisionUsability(
   String^ token,
   String^ itemCode,
   String^ revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function CheckRevisionUsability(
    token : String,
    itemCode : String,
    revCode : String
) : boolean;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

The item code.

revCode

Type: string

The revision code of an item.

Return Value

Type: bool

A Boolean value that indicates whether the combination of an item and revision corresponds to any of available bill of materials or not.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.ExistsItemIngredientMasterData Method

Checks if specific ItemCode and Revisoon have ItemIngredientData object

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function ExistsItemIngredientMasterData( _
   ByVal token As String, _
   ByVal Itemcode As String, _
   ByVal Revision As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool ExistsItemIngredientMasterData(
   string token,
   string Itemcode,
   string Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool ExistsItemIngredientMasterData(
   String^ token,
   String^ Itemcode,
   String^ Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function ExistsItemIngredientMasterData(
    token : String,
    Itemcode : String,
    Revision : String
) : boolean;
This language is not supported or no code example is available.

Parameters

token

Type: string

Itemcode

Type: string

itemCode to check

Revision

Type: string

revision to check

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetItemCostForCostCategory000 Method

Gets the total cost defined for a specified item and for the cost category '000'.

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemCostForCostCategory000( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String, _
   ByVal whsCode As String _
) As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static double GetItemCostForCostCategory000(
   string token,
   string itemCode,
   string revCode,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static double GetItemCostForCostCategory000(
   String^ token,
   String^ itemCode,
   String^ revCode,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemCostForCostCategory000(
    token : String,
    itemCode : String,
    revCode : String,
    whsCode : String
) : double;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Item code.

revCode

Type: string

Revision code.

whsCode

Type: string

Warehouse code.

Return Value

Type: double

Total cost defined for a specified item and for the cost category '000'. If no costing entries were found, then 0 is returned.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetDoublePrcesision Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetDoublePrcesision( _
   ByVal strProperty As String _
) As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static double GetDoublePrcesision(
   string strProperty
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static double GetDoublePrcesision(
   String^ strProperty
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetDoublePrcesision(
    strProperty : String
) : double;
This language is not supported or no code example is available.

Parameters

strProperty

Type: string

Return Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetItemGroupCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemGroupCode( _
   ByVal token As String, _
   ByVal itemCode As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int GetItemGroupCode(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static int GetItemGroupCode(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemGroupCode(
    token : String,
    itemCode : String
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetItemGroups Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemGroups( _
   ByVal token As String _
) As List(Of CodeDescriptionContainer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static List<CodeDescriptionContainer> GetItemGroups(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static List<CodeDescriptionContainer^>^ GetItemGroups(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: List<CodeDescriptionContainer>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetNonDropShipWarehouses Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetNonDropShipWarehouses( _
   ByVal token As String _
) As List(Of CodeDescriptionContainer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static List<CodeDescriptionContainer> GetNonDropShipWarehouses(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static List<CodeDescriptionContainer^>^ GetNonDropShipWarehouses(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: List<CodeDescriptionContainer>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetWarehouseName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetWarehouseName( _
   ByVal token As String, _
   ByVal whsCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetWarehouseName(
   string token,
   string whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetWarehouseName(
   String^ token,
   String^ whsCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetWarehouseName(
    token : String,
    whsCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

whsCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetItemEvaluationType Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemEvaluationType( _
   ByVal token As String, _
   ByVal itemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemEvaluationType(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemEvaluationType(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemEvaluationType(
    token : String,
    itemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetItemUoM Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemUoM( _
   ByVal token As String, _
   ByVal itemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemUoM(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemUoM(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemUoM(
    token : String,
    itemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetItemProcurementMethod Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemProcurementMethod( _
   ByVal token As String, _
   ByVal itemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemProcurementMethod(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemProcurementMethod(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemProcurementMethod(
    token : String,
    itemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetItemNonDropShipWarehouses Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemNonDropShipWarehouses( _
   ByVal token As String, _
   ByVal itemCode As String _
) As List(Of String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static List<string> GetItemNonDropShipWarehouses(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static List<String^>^ GetItemNonDropShipWarehouses(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: List<string>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetPriceLists Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetPriceLists( _
   ByVal token As String _
) As List(Of CodeDescriptionContainer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static List<CodeDescriptionContainer> GetPriceLists(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static List<CodeDescriptionContainer^>^ GetPriceLists(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: List<CodeDescriptionContainer>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetBusinessPartnerName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetBusinessPartnerName( _
   ByVal token As String, _
   ByVal bpCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetBusinessPartnerName(
   string token,
   string bpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetBusinessPartnerName(
   String^ token,
   String^ bpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetBusinessPartnerName(
    token : String,
    bpCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

bpCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetMorBranchCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetMorBranchCode( _
   ByVal Token As String, _
   ByVal DocEntry As Integer _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int GetMorBranchCode(
   string Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static int GetMorBranchCode(
   String^ Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetMorBranchCode(
    Token : String,
    DocEntry : int
) : int;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetMorBranchName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetMorBranchName( _
   ByVal Token As String, _
   ByVal DocEntry As Integer _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetMorBranchName(
   string Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetMorBranchName(
   String^ Token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetMorBranchName(
    Token : String,
    DocEntry : int
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

DocEntry

Type: int

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetBusinessPartnerContactName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetBusinessPartnerContactName( _
   ByVal token As String, _
   ByVal contactId As Integer _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetBusinessPartnerContactName(
   string token,
   int contactId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetBusinessPartnerContactName(
   String^ token,
   int contactId
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetBusinessPartnerContactName(
    token : String,
    contactId : int
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

contactId

Type: int

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.AutoIssue Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function AutoIssue( _
   ByVal token As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool AutoIssue(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool AutoIssue(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function AutoIssue(
    token : String
) : boolean;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.AutoReceipt Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function AutoReceipt( _
   ByVal token As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool AutoReceipt(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool AutoReceipt(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function AutoReceipt(
    token : String
) : boolean;
This language is not supported or no code example is available.

Parameters

token

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.ValidateWarehouses Method

Returns Information about warehouse collection

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function ValidateWarehouses( _
   ByVal token As String, _
   ByVal whsList As IEnumerable(Of String) _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Result ValidateWarehouses(
   string token,
   IEnumerable<string> whsList
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static Result^ ValidateWarehouses(
   String^ token,
   IEnumerable<String^>^ whsList
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

whsList

Type: IEnumerable<string>

Return Value

Type: Result
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemRevisionInfo Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ItemRevisionInfo
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemRevisionInfo
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ItemRevisionInfo
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemRevisionInfo
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.ItemUtils.ItemRevisionInfo
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemRevisionInfo Members
CompuTec.ProcessForce.API.Tools Namespace


ItemRevisionInfo Members

ItemRevisionInfo Class Constructors Methods Properties See Also

The following tables list the members exposed by the ItemRevisionInfo type.

Constructors
 | Name | Description
Public constructor | ItemRevisionInfo |
Top
Properties
 | Name | Description
Public property | ErrorMessage | Reference is used for formatiine Result for examole item Code and Revision does not Exist in Items Tab sequence 40
Public property | ItemCode |
Public property | RevisionCode |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ItemRevisionInfo Class
CompuTec.ProcessForce.API.Tools Namespace


ItemRevisionInfo.ItemCode Property

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ItemCode() As String
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ItemCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ItemCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ItemCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemRevisionInfo Class
ItemRevisionInfo Members
CompuTec.ProcessForce.API.Tools Namespace


ItemRevisionInfo.RevisionCode Property

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property RevisionCode() As String
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string RevisionCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ RevisionCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get RevisionCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemRevisionInfo Class
ItemRevisionInfo Members
CompuTec.ProcessForce.API.Tools Namespace


ItemRevisionInfo.ErrorMessage Property

Reference is used for formatiine Result for examole item Code and Revision does not Exist in Items Tab sequence 40

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ErrorMessage() As String
    Get

This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ErrorMessage {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ErrorMessage {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ErrorMessage() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemRevisionInfo Class
ItemRevisionInfo Members
CompuTec.ProcessForce.API.Tools Namespace


ItemRevisionInfo Constructor

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal itemCode As String, _
   ByVal revCode As String, _
   ByVal errorMessage As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemRevisionInfo(
   string itemCode,
   string revCode,
   string errorMessage
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemRevisionInfo(
   String^ itemCode,
   String^ revCode,
   String^ errorMessage
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemRevisionInfo(
    itemCode : String,
    revCode : String,
    errorMessage : String
);
This language is not supported or no code example is available.

Parameters

itemCode

Type: string

revCode

Type: string

errorMessage

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemRevisionInfo Class
ItemRevisionInfo Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.ValidateItemAndRevisions Method

Returns Information about warehouse collection

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function ValidateItemAndRevisions( _
   ByVal token As String, _
   ByVal colection As IEnumerable(Of ItemRevisionInfo) _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Result ValidateItemAndRevisions(
   string token,
   IEnumerable<ItemRevisionInfo> colection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static Result^ ValidateItemAndRevisions(
   String^ token,
   IEnumerable<ItemRevisionInfo^>^ colection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

colection

Type: IEnumerable<ItemRevisionInfo>

Return Value

Type: Result
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.ValidateDistributionRules Method

Returns Information about warehouse collection

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function ValidateDistributionRules( _
   ByVal token As String, _
   ByVal distrulesList As IEnumerable(Of String) _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Result ValidateDistributionRules(
   string token,
   IEnumerable<string> distrulesList
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static Result^ ValidateDistributionRules(
   String^ token,
   IEnumerable<String^>^ distrulesList
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

distrulesList

Type: IEnumerable<string>

Return Value

Type: Result
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.ValidateResources Method

Returns Information about warehouse collection

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function ValidateResources( _
   ByVal token As String, _
   ByVal resources As IEnumerable(Of String) _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Result ValidateResources(
   string token,
   IEnumerable<string> resources
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static Result^ ValidateResources(
   String^ token,
   IEnumerable<String^>^ resources
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

resources

Type: IEnumerable<string>

Return Value

Type: Result
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.ValidateOperations Method

Returns Information about warehouse collection

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function ValidateOperations( _
   ByVal token As String, _
   ByVal operations As IEnumerable(Of String) _
) As Result
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Result ValidateOperations(
   string token,
   IEnumerable<string> operations
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static Result^ ValidateOperations(
   String^ token,
   IEnumerable<String^>^ operations
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

operations

Type: IEnumerable<string>

Return Value

Type: Result
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


DocumentManager.GetDocument (String, String) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDocument( _
   ByVal type As String, _
   ByVal docentry As String _
) As IDoc
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IDoc GetDocument(
   string type,
   string docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IDoc^ GetDocument(
   String^ type,
   String^ docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDocument(
    type : String,
    docentry : String
) : IDoc;
This language is not supported or no code example is available.

Parameters

type

Type: string

docentry

Type: string

Return Value

Type: IDoc
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentManager Class
DocumentManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


DocumentManager.GetDocument (String, Int32) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetDocument( _
   ByVal type As String, _
   ByVal docentry As Integer _
) As IDoc
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IDoc GetDocument(
   string type,
   int docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IDoc^ GetDocument(
   String^ type,
   int docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetDocument(
    type : String,
    docentry : int
) : IDoc;
This language is not supported or no code example is available.

Parameters

type

Type: string

docentry

Type: int

Return Value

Type: IDoc
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentManager Class
DocumentManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


UDOCodeGeneratorEx.NextCode Method

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function NextCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string NextCode()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ NextCode()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function NextCode() : String;
This language is not supported or no code example is available.

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UDOCodeGeneratorEx Class
UDOCodeGeneratorEx Members
CompuTec.ProcessForce.API.Core Namespace


Labels Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Labels As String = "CT_PF_61"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Labels = @"CT_PF_61"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Labels = "CT_PF_61";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Labels : String = "CT_PF_61"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Ingredients Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Ingredients As String = "CT_PF_IDTIGD"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Ingredients = @"CT_PF_IDTIGD"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Ingredients = "CT_PF_IDTIGD";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Ingredients : String = "CT_PF_IDTIGD"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


IngredientsCategory Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const IngredientsCategory As String = "CT_PF_IDTIGC"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string IngredientsCategory = @"CT_PF_IDTIGC"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ IngredientsCategory = "CT_PF_IDTIGC";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const IngredientsCategory : String = "CT_PF_IDTIGC"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Allergen Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Allergen As String = "CT_PF_IDTALG"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Allergen = @"CT_PF_IDTALG"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Allergen = "CT_PF_IDTALG";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Allergen : String = "CT_PF_IDTALG"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


IngredientMasterData Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const IngredientMasterData As String = "CT_PF_IDTIMD"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string IngredientMasterData = @"CT_PF_IDTIMD"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ IngredientMasterData = "CT_PF_IDTIMD";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const IngredientMasterData : String = "CT_PF_IDTIMD"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


IngredientDailyValue Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const IngredientDailyValue As String = "CT_PF_IDTIDV"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string IngredientDailyValue = @"CT_PF_IDTIDV"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ IngredientDailyValue = "CT_PF_IDTIDV";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const IngredientDailyValue : String = "CT_PF_IDTIDV"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


IngredientTemplate Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const IngredientTemplate As String = "CT_PF_IDTIGT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string IngredientTemplate = @"CT_PF_IDTIGT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ IngredientTemplate = "CT_PF_IDTIGT";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const IngredientTemplate : String = "CT_PF_IDTIGT"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


IngredientClassificationType Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const IngredientClassificationType As String = "CT_PF_IDTCTE"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string IngredientClassificationType = @"CT_PF_IDTCTE"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ IngredientClassificationType = "CT_PF_IDTCTE";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const IngredientClassificationType : String = "CT_PF_IDTCTE"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


IngredientClassification Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const IngredientClassification As String = "CT_PF_IDTCSS"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string IngredientClassification = @"CT_PF_IDTCSS"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ IngredientClassification = "CT_PF_IDTCSS";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const IngredientClassification : String = "CT_PF_IDTCSS"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


NutrientMasterData Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const NutrientMasterData As String = "CT_PF_IDTNUT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string NutrientMasterData = @"CT_PF_IDTNUT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ NutrientMasterData = "CT_PF_IDTNUT";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const NutrientMasterData : String = "CT_PF_IDTNUT"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


UDOCodeGeneratorEx.NextCode Method

UDOCodeGeneratorEx Class See Also

Overload List
Name | Description
NextCode() |
NextCode(string) |
See Also

Reference

UDOCodeGeneratorEx Class
UDOCodeGeneratorEx Members
CompuTec.ProcessForce.API.Core Namespace


ItemIngredientData Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ItemIngredientData As String = "CT_PF_IDTIID"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ItemIngredientData = @"CT_PF_IDTIID"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ItemIngredientData = "CT_PF_IDTIID";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ItemIngredientData : String = "CT_PF_IDTIID"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


BillOfMaterials Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const BillOfMaterials As String = "CT_PF_2"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string BillOfMaterials = @"CT_PF_2"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ BillOfMaterials = "CT_PF_2";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const BillOfMaterials : String = "CT_PF_2"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


BillOfMaterialsTechnology Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const BillOfMaterialsTechnology As String = "CT_PF_81"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string BillOfMaterialsTechnology = @"CT_PF_81"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ BillOfMaterialsTechnology = "CT_PF_81";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const BillOfMaterialsTechnology : String = "CT_PF_81"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ItemMassReplace Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ItemMassReplace As String = "CT_PF_3"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ItemMassReplace = @"CT_PF_3"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ItemMassReplace = "CT_PF_3";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ItemMassReplace : String = "CT_PF_3"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Resources Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Resources As String = "CT_PF_12"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Resources = @"CT_PF_12"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Resources = "CT_PF_12";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Resources : String = "CT_PF_12"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ResourceGroups Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ResourceGroups As String = "CT_PF_11"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ResourceGroups = @"CT_PF_11"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ResourceGroups = "CT_PF_11";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ResourceGroups : String = "CT_PF_11"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


UDOCodeGeneratorEx.NextCode (String) Method

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function NextCode( _
   ByVal prevcode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string NextCode(
   string prevcode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ NextCode(
   String^ prevcode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function NextCode(
    prevcode : String
) : String;
This language is not supported or no code example is available.

Parameters

prevcode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UDOCodeGeneratorEx Class
UDOCodeGeneratorEx Members
CompuTec.ProcessForce.API.Core Namespace


ResourceProperties Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ResourceProperties As String = "CT_PF_17"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ResourceProperties = @"CT_PF_17"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ResourceProperties = "CT_PF_17";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ResourceProperties : String = "CT_PF_17"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Operations Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Operations As String = "CT_PF_14"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Operations = @"CT_PF_14"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Operations = "CT_PF_14";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Operations : String = "CT_PF_14"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


OperationProperties Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const OperationProperties As String = "CT_PF_16"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string OperationProperties = @"CT_PF_16"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ OperationProperties = "CT_PF_16";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const OperationProperties : String = "CT_PF_16"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


OperationRelationPert Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const OperationRelationPert As String = "CT_PF_OpRlPrt"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string OperationRelationPert = @"CT_PF_OpRlPrt"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ OperationRelationPert = "CT_PF_OpRlPrt";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const OperationRelationPert : String = "CT_PF_OpRlPrt"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


OperationInputOutputProperties Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const OperationInputOutputProperties As String = "CT_PF_18"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string OperationInputOutputProperties = @"CT_PF_18"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ OperationInputOutputProperties = "CT_PF_18";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const OperationInputOutputProperties : String = "CT_PF_18"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Routings Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Routings As String = "CT_PF_13"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Routings = @"CT_PF_13"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Routings = "CT_PF_13";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Routings : String = "CT_PF_13"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


OrderlessProductionTemplate Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const OrderlessProductionTemplate As String = "CT_PF_OlProdTepl"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string OrderlessProductionTemplate = @"CT_PF_OlProdTepl"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ OrderlessProductionTemplate = "CT_PF_OlProdTepl";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const OrderlessProductionTemplate : String = "CT_PF_OlProdTepl"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


OrderlessProductionDocument Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const OrderlessProductionDocument As String = "CT_PF_OlProd"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string OrderlessProductionDocument = @"CT_PF_OlProd"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ OrderlessProductionDocument = "CT_PF_OlProd";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const OrderlessProductionDocument : String = "CT_PF_OlProd"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ActivitiReport Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ActivitiReport As String = "CT_PF_ActivRpt"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ActivitiReport = @"CT_PF_ActivRpt"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ActivitiReport = "CT_PF_ActivRpt";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ActivitiReport : String = "CT_PF_ActivRpt"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Squads Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Squads As String = "CT_PF_19"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Squads = @"CT_PF_19"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Squads = "CT_PF_19";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Squads : String = "CT_PF_19"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Shifts Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Shifts As String = "CT_PF_21"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Shifts = @"CT_PF_21"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Shifts = "CT_PF_21";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Shifts : String = "CT_PF_21"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ManufacturingOrders Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ManufacturingOrders As String = "CT_PF_6"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ManufacturingOrders = @"CT_PF_6"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ManufacturingOrders = "CT_PF_6";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ManufacturingOrders : String = "CT_PF_6"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ManufacturingOrderManager Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ManufacturingOrderManager As String = "CT_PF_MORM"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ManufacturingOrderManager = @"CT_PF_MORM"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ManufacturingOrderManager = "CT_PF_MORM";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ManufacturingOrderManager : String = "CT_PF_MORM"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ManufacturingOrderTimeRecordingReport Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ManufacturingOrderTimeRecordingReport As String = "CT_PF_MORTimeRep"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ManufacturingOrderTimeRecordingReport = @"CT_PF_MORTimeRep"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ManufacturingOrderTimeRecordingReport = "CT_PF_MORTimeRep";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ManufacturingOrderTimeRecordingReport : String = "CT_PF_MORTimeRep"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ManufacturingOrderActualTaskReportReport Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ManufacturingOrderActualTaskReportReport As String = "CT_PF_MORATRpt"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ManufacturingOrderActualTaskReportReport = @"CT_PF_MORATRpt"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ManufacturingOrderActualTaskReportReport = "CT_PF_MORATRpt";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ManufacturingOrderActualTaskReportReport : String = "CT_PF_MORATRpt"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ManufacturingOrderResourceRecorderValuesReport Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ManufacturingOrderResourceRecorderValuesReport As String = "CT_PF_MORRsRecRep"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ManufacturingOrderResourceRecorderValuesReport = @"CT_PF_MORRsRecRep"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ManufacturingOrderResourceRecorderValuesReport = "CT_PF_MORRsRecRep";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ManufacturingOrderResourceRecorderValuesReport : String = "CT_PF_MORRsRecRep"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


UDOCodeGeneratorEx.IncrementNewCode Method

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function IncrementNewCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string IncrementNewCode()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ IncrementNewCode()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function IncrementNewCode() : String;
This language is not supported or no code example is available.

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UDOCodeGeneratorEx Class
UDOCodeGeneratorEx Members
CompuTec.ProcessForce.API.Core Namespace


ManufacturingOrderOperationRecordedValuesReport Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ManufacturingOrderOperationRecordedValuesReport As String = "CT_PF_MOROpRecRep"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ManufacturingOrderOperationRecordedValuesReport = @"CT_PF_MOROpRecRep"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ManufacturingOrderOperationRecordedValuesReport = "CT_PF_MOROpRecRep";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ManufacturingOrderOperationRecordedValuesReport : String = "CT_PF_MOROpRecRep"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ManufacturingOrderOperationBindigsRecordedValuesReport Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ManufacturingOrderOperationBindigsRecordedValuesReport As String = "CT_PF_MOROpBindRecRep"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ManufacturingOrderOperationBindigsRecordedValuesReport = @"CT_PF_MOROpBindRecRep"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ManufacturingOrderOperationBindigsRecordedValuesReport = "CT_PF_MOROpBindRecRep";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ManufacturingOrderOperationBindigsRecordedValuesReport : String = "CT_PF_MOROpBindRecRep"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


PickOrders Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const PickOrders As String = "CT_PF_24"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string PickOrders = @"CT_PF_24"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ PickOrders = "CT_PF_24";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const PickOrders : String = "CT_PF_24"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


PickReceipt Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const PickReceipt As String = "CT_PF_53"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string PickReceipt = @"CT_PF_53"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ PickReceipt = "CT_PF_53";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const PickReceipt : String = "CT_PF_53"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


SimpleProductionPlanning Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const SimpleProductionPlanning As String = "CT_PF_23"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string SimpleProductionPlanning = @"CT_PF_23"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ SimpleProductionPlanning = "CT_PF_23";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const SimpleProductionPlanning : String = "CT_PF_23"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


CapacityCalendar Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const CapacityCalendar As String = "CT_PF_22"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string CapacityCalendar = @"CT_PF_22"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ CapacityCalendar = "CT_PF_22";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const CapacityCalendar : String = "CT_PF_22"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


WorkRegistration Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const WorkRegistration As String = "CT_PF_54"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string WorkRegistration = @"CT_PF_54"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ WorkRegistration = "CT_PF_54";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const WorkRegistration : String = "CT_PF_54"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


OperationTimeRecording Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const OperationTimeRecording As String = "CT_PF_86"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string OperationTimeRecording = @"CT_PF_86"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ OperationTimeRecording = "CT_PF_86";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const OperationTimeRecording : String = "CT_PF_86"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


OperationTimeRecordingAdjustment Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const OperationTimeRecordingAdjustment As String = "CT_PF_87"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string OperationTimeRecordingAdjustment = @"CT_PF_87"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ OperationTimeRecordingAdjustment = "CT_PF_87";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const OperationTimeRecordingAdjustment : String = "CT_PF_87"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


CalendarTemplate Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const CalendarTemplate As String = "CT_PF_CLTMP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string CalendarTemplate = @"CT_PF_CLTMP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ CalendarTemplate = "CT_PF_CLTMP";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const CalendarTemplate : String = "CT_PF_CLTMP"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ResourceCalendar Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ResourceCalendar As String = "CT_PF_RSCAL"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ResourceCalendar = @"CT_PF_RSCAL"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ResourceCalendar = "CT_PF_RSCAL";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ResourceCalendar : String = "CT_PF_RSCAL"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


EmployeeCalendar Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const EmployeeCalendar As String = "CT_PF_EMCAL"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string EmployeeCalendar = @"CT_PF_EMCAL"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ EmployeeCalendar = "CT_PF_EMCAL";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const EmployeeCalendar : String = "CT_PF_EMCAL"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ResourceCalendarTool Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ResourceCalendarTool As String = "CT_PF_RSCLT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ResourceCalendarTool = @"CT_PF_RSCLT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ResourceCalendarTool = "CT_PF_RSCLT";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ResourceCalendarTool : String = "CT_PF_RSCLT"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


EmployeeCalendarTool Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const EmployeeCalendarTool As String = "CT_PF_EMCLT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string EmployeeCalendarTool = @"CT_PF_EMCLT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ EmployeeCalendarTool = "CT_PF_EMCLT";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const EmployeeCalendarTool : String = "CT_PF_EMCLT"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Scheduling Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Scheduling As String = "CT_PF_MORSched"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Scheduling = @"CT_PF_MORSched"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Scheduling = "CT_PF_MORSched";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Scheduling : String = "CT_PF_MORSched"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


MORScheduleResultsForm Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const MORScheduleResultsForm As String = "CT_PF_MORSEMRESH"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string MORScheduleResultsForm = @"CT_PF_MORSEMRESH"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ MORScheduleResultsForm = "CT_PF_MORSEMRESH";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const MORScheduleResultsForm : String = "CT_PF_MORSEMRESH"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ManufacturingRelations Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ManufacturingRelations As String = "CT_PF_OMAR"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ManufacturingRelations = @"CT_PF_OMAR"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ManufacturingRelations = "CT_PF_OMAR";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ManufacturingRelations : String = "CT_PF_OMAR"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


AddMorRowsToScheduling Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const AddMorRowsToScheduling As String = "CT_PF_ADDMORROWS"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string AddMorRowsToScheduling = @"CT_PF_ADDMORROWS"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ AddMorRowsToScheduling = "CT_PF_ADDMORROWS";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const AddMorRowsToScheduling : String = "CT_PF_ADDMORROWS"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


RoutingOperationRelations Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const RoutingOperationRelations As String = "CT_PF_MOR_OPR_REL"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string RoutingOperationRelations = @"CT_PF_MOR_OPR_REL"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ RoutingOperationRelations = "CT_PF_MOR_OPR_REL";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const RoutingOperationRelations : String = "CT_PF_MOR_OPR_REL"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


DocumentStatusChangeWizzard Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const DocumentStatusChangeWizzard As String = "CT_PF_DocStaChaWiz"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string DocumentStatusChangeWizzard = @"CT_PF_DocStaChaWiz"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ DocumentStatusChangeWizzard = "CT_PF_DocStaChaWiz";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const DocumentStatusChangeWizzard : String = "CT_PF_DocStaChaWiz"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


TimeQuantityRegistration Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const TimeQuantityRegistration As String = "CT_PF_TQR"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string TimeQuantityRegistration = @"CT_PF_TQR"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ TimeQuantityRegistration = "CT_PF_TQR";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const TimeQuantityRegistration : String = "CT_PF_TQR"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


VisualiztionMorsRelations Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const VisualiztionMorsRelations As String = "CT_PF_VisMorRel"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string VisualiztionMorsRelations = @"CT_PF_VisMorRel"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ VisualiztionMorsRelations = "CT_PF_VisMorRel";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const VisualiztionMorsRelations : String = "CT_PF_VisMorRel"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


VisualiztionSchedulingBoard Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const VisualiztionSchedulingBoard As String = "CT_PF_VisSchBrd"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string VisualiztionSchedulingBoard = @"CT_PF_VisSchBrd"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ VisualiztionSchedulingBoard = "CT_PF_VisSchBrd";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const VisualiztionSchedulingBoard : String = "CT_PF_VisSchBrd"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ManufacturingOrderSplit Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ManufacturingOrderSplit As String = "CT_PF_CT_PF_MORSPLIT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ManufacturingOrderSplit = @"CT_PF_CT_PF_MORSPLIT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ManufacturingOrderSplit = "CT_PF_CT_PF_MORSPLIT";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ManufacturingOrderSplit : String = "CT_PF_CT_PF_MORSPLIT"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


CostCategory Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const CostCategory As String = "CT_PF_70"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string CostCategory = @"CT_PF_70"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ CostCategory = "CT_PF_70";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const CostCategory : String = "CT_PF_70"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


CostingConfiguration Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const CostingConfiguration As String = "CT_PF_71"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string CostingConfiguration = @"CT_PF_71"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ CostingConfiguration = "CT_PF_71";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const CostingConfiguration : String = "CT_PF_71"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


LabourGroup Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const LabourGroup As String = "CT_PF_74"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string LabourGroup = @"CT_PF_74"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ LabourGroup = "CT_PF_74";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const LabourGroup : String = "CT_PF_74"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


LabourRates Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const LabourRates As String = "CT_PF_75"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string LabourRates = @"CT_PF_75"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ LabourRates = "CT_PF_75";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const LabourRates : String = "CT_PF_75"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ResourceRates Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ResourceRates As String = "CT_PF_76"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ResourceRates = @"CT_PF_76"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ResourceRates = "CT_PF_76";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ResourceRates : String = "CT_PF_76"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


CostedResource Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const CostedResource As String = "CT_PF_77"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string CostedResource = @"CT_PF_77"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ CostedResource = "CT_PF_77";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const CostedResource : String = "CT_PF_77"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


CostedBillOfMaterials Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const CostedBillOfMaterials As String = "CostedBom"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string CostedBillOfMaterials = @"CostedBom"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ CostedBillOfMaterials = "CostedBom";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const CostedBillOfMaterials : String = "CostedBom"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


CostedBillOfMaterialsSelectionCriteria Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const CostedBillOfMaterialsSelectionCriteria As String = "CostedBomC"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string CostedBillOfMaterialsSelectionCriteria = @"CostedBomC"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ CostedBillOfMaterialsSelectionCriteria = "CostedBomC";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const CostedBillOfMaterialsSelectionCriteria : String = "CostedBomC"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Locations Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Locations As String = "CT_PF_26"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Locations = @"CT_PF_26"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Locations = "CT_PF_26";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Locations : String = "CT_PF_26"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


LocationAttribute Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const LocationAttribute As String = "CT_PF_27"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string LocationAttribute = @"CT_PF_27"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ LocationAttribute = "CT_PF_27";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const LocationAttribute : String = "CT_PF_27"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ItemMasterDataLocations Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ItemMasterDataLocations As String = "CT_PF_29"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ItemMasterDataLocations = @"CT_PF_29"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ItemMasterDataLocations = "CT_PF_29";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ItemMasterDataLocations : String = "CT_PF_29"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


LicensePlates Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const LicensePlates As String = "CT_PF_8"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string LicensePlates = @"CT_PF_8"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ LicensePlates = "CT_PF_8";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const LicensePlates : String = "CT_PF_8"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


LicensePlateGroups Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const LicensePlateGroups As String = "CT_PF_20"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string LicensePlateGroups = @"CT_PF_20"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ LicensePlateGroups = "CT_PF_20";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const LicensePlateGroups : String = "CT_PF_20"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


InventoryRegistry Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const InventoryRegistry As String = "CT_PF_OIRG"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string InventoryRegistry = @"CT_PF_OIRG"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ InventoryRegistry = "CT_PF_OIRG";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const InventoryRegistry : String = "CT_PF_OIRG"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Defects Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Defects As String = "CT_PF_42"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Defects = @"CT_PF_42"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Defects = "CT_PF_42";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Defects : String = "CT_PF_42"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


DefectGroup Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const DefectGroup As String = "CT_PF_43"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string DefectGroup = @"CT_PF_43"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ DefectGroup = "CT_PF_43";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const DefectGroup : String = "CT_PF_43"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Reasons Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Reasons As String = "CT_PF_44"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Reasons = @"CT_PF_44"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Reasons = "CT_PF_44";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Reasons : String = "CT_PF_44"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


NcmrReasons Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const NcmrReasons As String = "CT_PF_5"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string NcmrReasons = @"CT_PF_5"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ NcmrReasons = "CT_PF_5";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const NcmrReasons : String = "CT_PF_5"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ReasonGroup Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ReasonGroup As String = "CT_PF_45"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ReasonGroup = @"CT_PF_45"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ReasonGroup = "CT_PF_45";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ReasonGroup : String = "CT_PF_45"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Inspectors Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Inspectors As String = "CT_PF_46"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Inspectors = @"CT_PF_46"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Inspectors = "CT_PF_46";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Inspectors : String = "CT_PF_46"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


NcmrInspectors Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const NcmrInspectors As String = "CT_PF_4"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string NcmrInspectors = @"CT_PF_4"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ NcmrInspectors = "CT_PF_4";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const NcmrInspectors : String = "CT_PF_4"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


QCTReport Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const QCTReport As String = "CT_PF_QCTREP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string QCTReport = @"CT_PF_QCTREP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ QCTReport = "CT_PF_QCTREP";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const QCTReport : String = "CT_PF_QCTREP"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


InspectorGroup Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const InspectorGroup As String = "CT_PF_47"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string InspectorGroup = @"CT_PF_47"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ InspectorGroup = "CT_PF_47";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const InspectorGroup : String = "CT_PF_47"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


QualityControlTest Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const QualityControlTest As String = "CT_PF_OQCT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string QualityControlTest = @"CT_PF_OQCT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ QualityControlTest = "CT_PF_OQCT";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const QualityControlTest : String = "CT_PF_OQCT"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


QualityControlTestReport Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const QualityControlTestReport As String = "CT_PF_QCTREP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string QualityControlTestReport = @"CT_PF_QCTREP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ QualityControlTestReport = "CT_PF_QCTREP";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const QualityControlTestReport : String = "CT_PF_QCTREP"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


NcmrTransaction Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const NcmrTransaction As String = "CT_PF_ONTR"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string NcmrTransaction = @"CT_PF_ONTR"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ NcmrTransaction = "CT_PF_ONTR";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const NcmrTransaction : String = "CT_PF_ONTR"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


QualityControlTestsCreationWizard Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const QualityControlTestsCreationWizard As String = "CT_PF_QCTestWiz"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string QualityControlTestsCreationWizard = @"CT_PF_QCTestWiz"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ QualityControlTestsCreationWizard = "CT_PF_QCTestWiz";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const QualityControlTestsCreationWizard : String = "CT_PF_QCTestWiz"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ItemsTestProtocols Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ItemsTestProtocols As String = "CT_PF_ItmsTestPrtls"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ItemsTestProtocols = @"CT_PF_ItmsTestPrtls"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ItemsTestProtocols = "CT_PF_ItmsTestPrtls";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ItemsTestProtocols : String = "CT_PF_ItmsTestPrtls"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


QualityControlTestPool Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const QualityControlTestPool As String = "CT_PF_QCPool"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string QualityControlTestPool = @"CT_PF_QCPool"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ QualityControlTestPool = "CT_PF_QCPool";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const QualityControlTestPool : String = "CT_PF_QCPool"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


TestProperty Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const TestProperty As String = "CT_PF_49"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string TestProperty = @"CT_PF_49"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ TestProperty = "CT_PF_49";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const TestProperty : String = "CT_PF_49"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


TestPropertyGroup Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const TestPropertyGroup As String = "CT_PF_50"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string TestPropertyGroup = @"CT_PF_50"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ TestPropertyGroup = "CT_PF_50";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const TestPropertyGroup : String = "CT_PF_50"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


TestProtocol Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const TestProtocol As String = "CT_PF_51"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string TestProtocol = @"CT_PF_51"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ TestProtocol = "CT_PF_51";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const TestProtocol : String = "CT_PF_51"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


TestProtocolGroup Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const TestProtocolGroup As String = "CT_PF_52"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string TestProtocolGroup = @"CT_PF_52"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ TestProtocolGroup = "CT_PF_52";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const TestProtocolGroup : String = "CT_PF_52"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


TestProtocolTemplates Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const TestProtocolTemplates As String = "CT_PF_60"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string TestProtocolTemplates = @"CT_PF_60"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ TestProtocolTemplates = "CT_PF_60";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const TestProtocolTemplates : String = "CT_PF_60"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Complaint Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Complaint As String = "CT_PF_CPL"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Complaint = @"CT_PF_CPL"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Complaint = "CT_PF_CPL";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Complaint : String = "CT_PF_CPL"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ComplaintGroup Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ComplaintGroup As String = "CT_PF_CGR"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ComplaintGroup = @"CT_PF_CGR"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ComplaintGroup = "CT_PF_CGR";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ComplaintGroup : String = "CT_PF_CGR"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ComplaintReason Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ComplaintReason As String = "CT_PF_CRS"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ComplaintReason = @"CT_PF_CRS"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ComplaintReason = "CT_PF_CRS";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ComplaintReason : String = "CT_PF_CRS"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


BussinesPartnerRelation Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const BussinesPartnerRelation As String = "CT_PF_QCBPRel"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string BussinesPartnerRelation = @"CT_PF_QCBPRel"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ BussinesPartnerRelation = "CT_PF_QCBPRel";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const BussinesPartnerRelation : String = "CT_PF_QCBPRel"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


VehicleInspectionCheck Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const VehicleInspectionCheck As String = "CT_PF_VIC"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string VehicleInspectionCheck = @"CT_PF_VIC"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ VehicleInspectionCheck = "CT_PF_VIC";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const VehicleInspectionCheck : String = "CT_PF_VIC"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


VehicleInspectionCheckSales Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const VehicleInspectionCheckSales As String = "CT_PF_VIC_Sales"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string VehicleInspectionCheckSales = @"CT_PF_VIC_Sales"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ VehicleInspectionCheckSales = "CT_PF_VIC_Sales";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const VehicleInspectionCheckSales : String = "CT_PF_VIC_Sales"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


RollOverItem Constructor

Initializes a new instance of the RollOverItem class.

Namespace: CompuTec.ProcessForce.API.Costing.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RollOverItem()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RollOverItem()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RollOverItem();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollOverItem Class
RollOverItem Members
CompuTec.ProcessForce.API.Costing.Data Namespace


RollOverItem(String, List<Revision>, ValuationMethod) Constructor

Initializes a new instance of the RollOverItem class.

Namespace: CompuTec.ProcessForce.API.Costing.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal itemCode As String, _
   ByVal revisions As List(Of Revision), _
   ByVal valuationMethod As ValuationMethod _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RollOverItem(
   string itemCode,
   List<Revision> revisions,
   ValuationMethod valuationMethod
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RollOverItem(
   String^ itemCode,
   List<Revision^>^ revisions,
   ValuationMethod valuationMethod
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

itemCode

Type: string

Item code.

revisions

Type: List<Revision>

A collection of revisions.

valuationMethod

Type: ValuationMethod

Valuation method.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollOverItem Class
RollOverItem Members
CompuTec.ProcessForce.API.Costing.Data Namespace


CostRollOverExecutor(String) Constructor

Initializes a new instance of the CostRollOverExecutor class.

Namespace: CompuTec.ProcessForce.API.Costing.Executors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CostRollOverExecutor(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CostRollOverExecutor(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CostRollOverExecutor(
    token : String
);
This language is not supported or no code example is available.

Parameters

token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostRollOverExecutor Class
CostRollOverExecutor Members
CompuTec.ProcessForce.API.Costing.Executors Namespace


CostRollOverExecutor(String, RollOverItem, List<String>, String, String) Constructor

Initializes a new instance of the CostRollOverExecutor class.

Namespace: CompuTec.ProcessForce.API.Costing.Executors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String, _
   ByVal item As RollOverItem, _
   ByVal warehouses As List(Of String), _
   ByVal fromCostCategory As String, _
   ByVal toCostCategory As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CostRollOverExecutor(
   string token,
   RollOverItem item,
   List<string> warehouses,
   string fromCostCategory,
   string toCostCategory
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CostRollOverExecutor(
   String^ token,
   RollOverItem^ item,
   List<String^>^ warehouses,
   String^ fromCostCategory,
   String^ toCostCategory
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

item

Type: RollOverItem

Item for which the roll-over process must be performed.

warehouses

Type: List<string>

Warehouses for which the roll-over process must be performed.

fromCostCategory

Type: string

Source cost category.

toCostCategory

Type: string

Destination cost category.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CostRollOverExecutor Class
CostRollOverExecutor Members
CompuTec.ProcessForce.API.Costing.Executors Namespace


ICreateGoodsIssueFromPickOrderBasedOnProductionIssue.DoAction Method

Goods issue only for listed lines in line references parameter

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function DoAction( _
   ByRef documentNumer As Object, _
   ByVal linereferences As IEnumerable(Of Integer) _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool DoAction(
   out object documentNumer,
   IEnumerable<int> linereferences
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool DoAction(
   object^& documentNumer,
   IEnumerable<int>^ linereferences
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

documentNumer

Type: object

Goods issue document number

linereferences

Type: IEnumerable<int>

List of Lines ( Required items ) - please put U_LineNum reference in this collection

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Interface
ICreateGoodsIssueFromPickOrderBasedOnProductionIssue Members
CompuTec.ProcessForce.API.Actions.CreateGoodsIssueFromPickOrderBasedOnProductionIssue Namespace


OperationOverlayValueRnageException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public OperationOverlayValueRnageException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
OperationOverlayValueRnageException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function OperationOverlayValueRnageException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OperationOverlayValueRnageException Class
OperationOverlayValueRnageException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


OperationOverlayValueRnageException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public OperationOverlayValueRnageException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
OperationOverlayValueRnageException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function OperationOverlayValueRnageException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OperationOverlayValueRnageException Class
OperationOverlayValueRnageException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


OperationOverlayValueRnageException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public OperationOverlayValueRnageException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
OperationOverlayValueRnageException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function OperationOverlayValueRnageException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OperationOverlayValueRnageException Class
OperationOverlayValueRnageException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


OperationResourceInvalidCycleValueException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public OperationResourceInvalidCycleValueException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
OperationResourceInvalidCycleValueException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function OperationResourceInvalidCycleValueException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OperationResourceInvalidCycleValueException Class
OperationResourceInvalidCycleValueException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


OperationResourceInvalidCycleValueException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public OperationResourceInvalidCycleValueException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
OperationResourceInvalidCycleValueException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function OperationResourceInvalidCycleValueException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OperationResourceInvalidCycleValueException Class
OperationResourceInvalidCycleValueException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RevisonMissingForBOMException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RevisonMissingForBOMException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RevisonMissingForBOMException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RevisonMissingForBOMException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RevisonMissingForBOMException Class
RevisonMissingForBOMException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RevisonMissingForBOMException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RevisonMissingForBOMException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RevisonMissingForBOMException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RevisonMissingForBOMException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RevisonMissingForBOMException Class
RevisonMissingForBOMException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RevisonMissingForBOMException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RevisonMissingForBOMException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RevisonMissingForBOMException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RevisonMissingForBOMException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RevisonMissingForBOMException Class
RevisonMissingForBOMException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RevisonMissingForChildException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RevisonMissingForChildException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RevisonMissingForChildException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RevisonMissingForChildException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RevisonMissingForChildException Class
RevisonMissingForChildException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RevisonMissingForChildException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RevisonMissingForChildException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RevisonMissingForChildException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RevisonMissingForChildException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RevisonMissingForChildException Class
RevisonMissingForChildException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


ManufacturiongOrderIsClosedException Constructor

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ManufacturiongOrderIsClosedException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ManufacturiongOrderIsClosedException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ManufacturiongOrderIsClosedException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ManufacturiongOrderIsClosedException Class
ManufacturiongOrderIsClosedException Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ManufacturiongOrderIsClosedException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ManufacturiongOrderIsClosedException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ManufacturiongOrderIsClosedException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ManufacturiongOrderIsClosedException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ManufacturiongOrderIsClosedException Class
ManufacturiongOrderIsClosedException Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ManufacturiongOrderIsClosedException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ManufacturiongOrderIsClosedException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ManufacturiongOrderIsClosedException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ManufacturiongOrderIsClosedException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ManufacturiongOrderIsClosedException Class
ManufacturiongOrderIsClosedException Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


QuantityToLowForBackflushItemsException Constructor

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QuantityToLowForBackflushItemsException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QuantityToLowForBackflushItemsException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QuantityToLowForBackflushItemsException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QuantityToLowForBackflushItemsException Class
QuantityToLowForBackflushItemsException Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


QuantityToLowForBackflushItemsException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QuantityToLowForBackflushItemsException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QuantityToLowForBackflushItemsException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QuantityToLowForBackflushItemsException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QuantityToLowForBackflushItemsException Class
QuantityToLowForBackflushItemsException Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


QuantityToLowForBackflushItemsException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QuantityToLowForBackflushItemsException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QuantityToLowForBackflushItemsException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QuantityToLowForBackflushItemsException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QuantityToLowForBackflushItemsException Class
QuantityToLowForBackflushItemsException Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt.DoAction Method

Goods Receipt only for listed lines in line references parameter

Namespace: CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function DoAction( _
   ByRef documentNumer As Object, _
   ByVal linereferences As IEnumerable(Of Integer) _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool DoAction(
   out object documentNumer,
   IEnumerable<int> linereferences
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool DoAction(
   object^& documentNumer,
   IEnumerable<int>^ linereferences
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

documentNumer

Type: object

Goods issue document number

linereferences

Type: IEnumerable<int>

List of Lines ( Required items ) - please put U_LineNum reference in this collection

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Interface
ICreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Members
CompuTec.ProcessForce.API.Actions.CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt Namespace


ICreatePickOrderForProductionIssue.DoAction Method

Create Pick Order For specific Items on Manufacturing Order

Namespace: CompuTec.ProcessForce.API.Actions.CreatePickOrderForProductionIssue
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function DoAction( _
   ByVal lst As Dictionary(Of Integer, List(Of Integer)) _
) As Object
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
object DoAction(
   Dictionary<int, List<int>> lst
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

object^ DoAction(
   Dictionary<int, List<int>^>^ lst
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

lst

Type: Dictionary<int, List<int>>

key- DocEntry , on list put all LineNumbers to be copied to pick order

Return Value

Type: object

Document Entry of Pick Order

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreatePickOrderForProductionIssue Interface
ICreatePickOrderForProductionIssue Members
CompuTec.ProcessForce.API.Actions.CreatePickOrderForProductionIssue Namespace


EmployeeCalendarUpdater(String) Constructor

Initializes a new instance of the EmployeeCalendarUpdater class.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.Updater
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public EmployeeCalendarUpdater(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
EmployeeCalendarUpdater(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function EmployeeCalendarUpdater(
    token : String
);
This language is not supported or no code example is available.

Parameters

token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EmployeeCalendarUpdater Class
EmployeeCalendarUpdater Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.Updater Namespace


EmployeeCalendarUpdater(String, String, List<Int32>) Constructor

Initializes a new instance of the EmployeeCalendarUpdater class.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.Updater
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String, _
   ByVal templateCode As String, _
   ByVal employees As List(Of Integer) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public EmployeeCalendarUpdater(
   string token,
   string templateCode,
   List<int> employees
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
EmployeeCalendarUpdater(
   String^ token,
   String^ templateCode,
   List<int>^ employees
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

templateCode

Type: string

The database code of a calendar template.

employees

Type: List<int>

A list with the IDs of the employees.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

EmployeeCalendarUpdater Class
EmployeeCalendarUpdater Members
CompuTec.ProcessForce.API.Documents.Calendars.EmployeeCalendar.Updater Namespace


ICreatePickReceiptForProductionReceipt.DoAction Method

This Extends starndard Do Action By Allowing to determine what items will apeare on Pick List

Namespace: CompuTec.ProcessForce.API.Actions.CreatePickReceiptForProductionReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function DoAction( _
   ByVal coproducts As Dictionary(Of Integer, List(Of Integer)), _
   ByVal Scraps As Dictionary(Of Integer, List(Of Integer)), _
   Optional ByVal ommitHeader As Boolean = false _
) As Object
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
object DoAction(
   Dictionary<int, List<int>> coproducts,
   Dictionary<int, List<int>> Scraps,
   bool ommitHeader = false
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

object^ DoAction(
   Dictionary<int, List<int>^>^ coproducts,
   Dictionary<int, List<int>^>^ Scraps,
   bool ommitHeader
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

coproducts

Type: Dictionary<int, List<int>>

list of manufacturing Doe Entry and a list of U_LineNum for coproducts that will apeare on Pick List

Scraps

Type: Dictionary<int, List<int>>

list of manufacturing Doe Entry and a list of U_LineNum for scraps that will apeare on Pick List

ommitHeader

Type: bool

true if you dont want to add Final Good

Return Value

Type: object
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ICreatePickReceiptForProductionReceipt Interface
ICreatePickReceiptForProductionReceipt Members
CompuTec.ProcessForce.API.Actions.CreatePickReceiptForProductionReceipt Namespace


AprovalProceduresEnabledException Constructor

Namespace: CompuTec.ProcessForce.API.Actions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public AprovalProceduresEnabledException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
AprovalProceduresEnabledException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function AprovalProceduresEnabledException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AprovalProceduresEnabledException Class
AprovalProceduresEnabledException Members
CompuTec.ProcessForce.API.Actions Namespace


AprovalProceduresEnabledException Constructor

AprovalProceduresEnabledException Class See Also

Overload List
Name | Description
AprovalProceduresEnabledException() |
AprovalProceduresEnabledException(string) |
AprovalProceduresEnabledException(string, Exception) |
See Also

Reference

AprovalProceduresEnabledException Class
AprovalProceduresEnabledException Members
CompuTec.ProcessForce.API.Actions Namespace


AprovalProceduresEnabledException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Actions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public AprovalProceduresEnabledException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
AprovalProceduresEnabledException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function AprovalProceduresEnabledException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AprovalProceduresEnabledException Class
AprovalProceduresEnabledException Members
CompuTec.ProcessForce.API.Actions Namespace


AprovalProceduresEnabledException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Actions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public AprovalProceduresEnabledException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
AprovalProceduresEnabledException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function AprovalProceduresEnabledException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AprovalProceduresEnabledException Class
AprovalProceduresEnabledException Members
CompuTec.ProcessForce.API.Actions Namespace


LineReferencesCannotBeEmptyException Constructor

Namespace: CompuTec.ProcessForce.API.Actions.Exceptions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public LineReferencesCannotBeEmptyException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
LineReferencesCannotBeEmptyException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function LineReferencesCannotBeEmptyException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LineReferencesCannotBeEmptyException Class
LineReferencesCannotBeEmptyException Members
CompuTec.ProcessForce.API.Actions.Exceptions Namespace


LineReferencesCannotBeEmptyException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Actions.Exceptions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public LineReferencesCannotBeEmptyException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
LineReferencesCannotBeEmptyException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function LineReferencesCannotBeEmptyException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LineReferencesCannotBeEmptyException Class
LineReferencesCannotBeEmptyException Members
CompuTec.ProcessForce.API.Actions.Exceptions Namespace


LineReferencesCannotBeEmptyException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Actions.Exceptions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public LineReferencesCannotBeEmptyException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
LineReferencesCannotBeEmptyException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function LineReferencesCannotBeEmptyException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

LineReferencesCannotBeEmptyException Class
LineReferencesCannotBeEmptyException Members
CompuTec.ProcessForce.API.Actions.Exceptions Namespace


SettlementAccountEnabledButNotFullyConfiguredException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Actions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class SettlementAccountEnabledButNotFullyConfiguredException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class SettlementAccountEnabledButNotFullyConfiguredException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class SettlementAccountEnabledButNotFullyConfiguredException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class SettlementAccountEnabledButNotFullyConfiguredException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Actions.SettlementAccountEnabledButNotFullyConfiguredException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SettlementAccountEnabledButNotFullyConfiguredException Members
CompuTec.ProcessForce.API.Actions Namespace


SettlementAccountEnabledButNotFullyConfiguredException Members

SettlementAccountEnabledButNotFullyConfiguredException Class Constructors Methods Properties See Also

The following tables list the members exposed by the SettlementAccountEnabledButNotFullyConfiguredException type.

Constructors
 | Name | Description
Public constructor | SettlementAccountEnabledButNotFullyConfiguredException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

SettlementAccountEnabledButNotFullyConfiguredException Class
CompuTec.ProcessForce.API.Actions Namespace


SettlementAccountEnabledButNotFullyConfiguredException Constructor

Namespace: CompuTec.ProcessForce.API.Actions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SettlementAccountEnabledButNotFullyConfiguredException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SettlementAccountEnabledButNotFullyConfiguredException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SettlementAccountEnabledButNotFullyConfiguredException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SettlementAccountEnabledButNotFullyConfiguredException Class
SettlementAccountEnabledButNotFullyConfiguredException Members
CompuTec.ProcessForce.API.Actions Namespace


SettlementAccountEnabledButNotFullyConfiguredException Constructor

SettlementAccountEnabledButNotFullyConfiguredException Class See Also

Overload List
Name | Description
SettlementAccountEnabledButNotFullyConfiguredException() |
SettlementAccountEnabledButNotFullyConfiguredException(string) |
SettlementAccountEnabledButNotFullyConfiguredException(string, Exception) |
See Also

Reference

SettlementAccountEnabledButNotFullyConfiguredException Class
SettlementAccountEnabledButNotFullyConfiguredException Members
CompuTec.ProcessForce.API.Actions Namespace


BadManageTypeException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal ex As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BadManageTypeException(
   string message,
   Exception ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BadManageTypeException(
   String^ message,
   Exception^ ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BadManageTypeException(
    message : String,
    ex : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

ex

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BadManageTypeException Class
BadManageTypeException Members
CompuTec.ProcessForce.API.Assigners Namespace


DocumentNotFoundException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Assigners.Base
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DocumentNotFoundException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DocumentNotFoundException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DocumentNotFoundException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentNotFoundException Class
DocumentNotFoundException Members
CompuTec.ProcessForce.API.Assigners.Base Namespace


DocumentNotFoundException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Assigners.Base
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal ex As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DocumentNotFoundException(
   string message,
   Exception ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DocumentNotFoundException(
   String^ message,
   Exception^ ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DocumentNotFoundException(
    message : String,
    ex : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

ex

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentNotFoundException Class
DocumentNotFoundException Members
CompuTec.ProcessForce.API.Assigners.Base Namespace


OperationFailedException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Assigners.Base
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public OperationFailedException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
OperationFailedException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function OperationFailedException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OperationFailedException Class
OperationFailedException Members
CompuTec.ProcessForce.API.Assigners.Base Namespace


OperationFailedException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Assigners.Base
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal ex As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public OperationFailedException(
   string message,
   Exception ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
OperationFailedException(
   String^ message,
   Exception^ ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function OperationFailedException(
    message : String,
    ex : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

ex

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OperationFailedException Class
OperationFailedException Members
CompuTec.ProcessForce.API.Assigners.Base Namespace


QuantityOverflowException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class QuantityOverflowException
    Inherits ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QuantityOverflowException : ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class QuantityOverflowException : public ApplicationException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class QuantityOverflowException
   extends ApplicationException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
CompuTec.ProcessForce.API.Assigners.QuantityOverflowException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QuantityOverflowException Members
CompuTec.ProcessForce.API.Assigners Namespace


QuantityOverflowException Members

QuantityOverflowException Class Constructors Methods Properties See Also

The following tables list the members exposed by the QuantityOverflowException type.

Constructors
 | Name | Description
Public constructor | QuantityOverflowException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

QuantityOverflowException Class
CompuTec.ProcessForce.API.Assigners Namespace


QuantityOverflowException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QuantityOverflowException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QuantityOverflowException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QuantityOverflowException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QuantityOverflowException Class
QuantityOverflowException Members
CompuTec.ProcessForce.API.Assigners Namespace


QuantityOverflowException Constructor

QuantityOverflowException Class See Also

Overload List
Name | Description
QuantityOverflowException(string) |
QuantityOverflowException(string, Exception) |
See Also

Reference

QuantityOverflowException Class
QuantityOverflowException Members
CompuTec.ProcessForce.API.Assigners Namespace


QuantityOverflowException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal ex As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public QuantityOverflowException(
   string message,
   Exception ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
QuantityOverflowException(
   String^ message,
   Exception^ ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function QuantityOverflowException(
    message : String,
    ex : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

ex

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

QuantityOverflowException Class
QuantityOverflowException Members
CompuTec.ProcessForce.API.Assigners Namespace


IPickedItems.U_SnLotNumber Property

Batch ID for Serial Numbers.

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SnLotNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SnLotNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SnLotNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SnLotNumber() : String;
function set U_SnLotNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickedItems Interface
IPickedItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IssueMethodCannotBeChangedException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Exceptions.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IssueMethodCannotBeChangedException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IssueMethodCannotBeChangedException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function IssueMethodCannotBeChangedException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IssueMethodCannotBeChangedException Class
IssueMethodCannotBeChangedException Members
CompuTec.ProcessForce.API.Exceptions.Documents Namespace


IssueMethodCannotBeChangedException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Exceptions.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IssueMethodCannotBeChangedException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IssueMethodCannotBeChangedException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function IssueMethodCannotBeChangedException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IssueMethodCannotBeChangedException Class
IssueMethodCannotBeChangedException Members
CompuTec.ProcessForce.API.Exceptions.Documents Namespace


CompuTec.ProcessForce.API.Documents Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | NotAuthorizedCallException | This Exception Is thorwn when Methood cant be call using ProcessForce Data Interface
Public class | NumberOfResourceslessZeroException |
Top
Interfaces
 | Name | Description
Public interface | IDownTimeReason | Downtime reason object
Public interface | IDownTimeReasonGroups | Downtime reason groups object
Public interface | IReworkReason | Rework reason object
Public interface | IReworkReasonGroups | Groups for rework reason object
Public interface | IScrapReasonGroups | Scaps for reason groups object
Public interface | IScrapReasons | Scrap reasons object
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


NotAuthorizedCallException Class

Members See Also

This Exception Is thorwn when Methood cant be call using ProcessForce Data Interface

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class NotAuthorizedCallException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class NotAuthorizedCallException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class NotAuthorizedCallException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class NotAuthorizedCallException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.NotAuthorizedCallException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

NotAuthorizedCallException Members
CompuTec.ProcessForce.API.Documents Namespace


NotAuthorizedCallException Members

NotAuthorizedCallException Class Constructors Methods Properties See Also

This Exception Is thorwn when Methood cant be call using ProcessForce Data Interface

The following tables list the members exposed by the NotAuthorizedCallException type.

Constructors
 | Name | Description
Public constructor | NotAuthorizedCallException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

NotAuthorizedCallException Class
CompuTec.ProcessForce.API.Documents Namespace


NotAuthorizedCallException Constructor

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public NotAuthorizedCallException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
NotAuthorizedCallException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function NotAuthorizedCallException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

NotAuthorizedCallException Class
NotAuthorizedCallException Members
CompuTec.ProcessForce.API.Documents Namespace


NotAuthorizedCallException Constructor

NotAuthorizedCallException Class See Also

Overload List
Name | Description
NotAuthorizedCallException() |
NotAuthorizedCallException(string) |
NotAuthorizedCallException(string, Exception) |
See Also

Reference

NotAuthorizedCallException Class
NotAuthorizedCallException Members
CompuTec.ProcessForce.API.Documents Namespace


NotAuthorizedCallException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public NotAuthorizedCallException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
NotAuthorizedCallException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function NotAuthorizedCallException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

NotAuthorizedCallException Class
NotAuthorizedCallException Members
CompuTec.ProcessForce.API.Documents Namespace


IPickedItems.U_BnDistNumber Property

Batch Number for Batch Numbers.

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BnDistNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BnDistNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BnDistNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BnDistNumber() : String;
function set U_BnDistNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickedItems Interface
IPickedItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IPickedItems.U_Quantity Property

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_Quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_Quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Quantity() : double;
function set U_Quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickedItems Interface
IPickedItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IPickedItems.U_LplCode Property

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LplCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LplCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LplCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LplCode() : String;
function set U_LplCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickedItems Interface
IPickedItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IPickedItems.U_LplsPath Property

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_LplsPath() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_LplsPath {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_LplsPath {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_LplsPath() : String;
function set U_LplsPath(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickedItems Interface
IPickedItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IPickedItems.U_ReqItmLn Property

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReqItmLn() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ReqItmLn {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ReqItmLn {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReqItmLn() : int;
function set U_ReqItmLn(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickedItems Interface
IPickedItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IPickedItems.U_ReceiptedQty Property

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReceiptedQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ReceiptedQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ReceiptedQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReceiptedQty() : double;
function set U_ReceiptedQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickedItems Interface
IPickedItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IPickedItems.U_Receipted Property

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Receipted() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Receipted {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Receipted {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Receipted() : String;
function set U_Receipted(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPickedItems Interface
IPickedItems Members
CompuTec.ProcessForce.API.Assigners Namespace


IRelations Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IRelations
    Inherits IUDOChildBean, _
             IEnumerable(Of IRelations)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IRelations : IUDOChildBean,
   IEnumerable<IRelations>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IRelations : public IUDOChildBean^,
   public IEnumerable<IRelations^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRelations Members
CompuTec.ProcessForce.API.Assigners Namespace


IRelations Members

IRelations Interface Methods Properties See Also

The following tables list the members exposed by the IRelations type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PickItemLineNo |
Public property | U_ReqItemLineNo |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IRelations Interface
CompuTec.ProcessForce.API.Assigners Namespace


IRelations.U_ReqItemLineNo Property

Namespace: CompuTec.ProcessForce.API.Assigners
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ReqItemLineNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_ReqItemLineNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_ReqItemLineNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ReqItemLineNo() : int;
function set U_ReqItemLineNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IRelations Interface
IRelations Members
CompuTec.ProcessForce.API.Assigners Namespace


IConfiguration.IsBatchSerialNoSupportForLocationsEnabled Property

Gets or sets the indication whether the batch and serial number support for locations is enabled (true) or disabled (false).

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property IsBatchSerialNoSupportForLocationsEnabled() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool IsBatchSerialNoSupportForLocationsEnabled {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool IsBatchSerialNoSupportForLocationsEnabled {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get IsBatchSerialNoSupportForLocationsEnabled() : boolean;
function set IsBatchSerialNoSupportForLocationsEnabled(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.MrpCoproductProductionOrderSeries Property

Gets or sets the default series code for coproducts based MRP production orders.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property MrpCoproductProductionOrderSeries() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int MrpCoproductProductionOrderSeries {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int MrpCoproductProductionOrderSeries {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get MrpCoproductProductionOrderSeries() : int;
function set MrpCoproductProductionOrderSeries(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.MrpCoproductProductionOrderComponent Property

Gets or sets the default component for coproducts based MRP production orders.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property MrpCoproductProductionOrderComponent() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string MrpCoproductProductionOrderComponent {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ MrpCoproductProductionOrderComponent {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get MrpCoproductProductionOrderComponent() : String;
function set MrpCoproductProductionOrderComponent(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.MrpManufacturingOrderSeries Property

Gets or sets the default series code for MRP based manufacturing orders.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property MrpManufacturingOrderSeries() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int MrpManufacturingOrderSeries {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int MrpManufacturingOrderSeries {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get MrpManufacturingOrderSeries() : int;
function set MrpManufacturingOrderSeries(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.MrpProductionOrderSeries Property

Gets or sets the default series code for MRP based production orders.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property MrpProductionOrderSeries() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int MrpProductionOrderSeries {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int MrpProductionOrderSeries {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get MrpProductionOrderSeries() : int;
function set MrpProductionOrderSeries(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.InspectionDays Property

Gets or sets the days between inspections.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property InspectionDays() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int InspectionDays {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int InspectionDays {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get InspectionDays() : int;
function set InspectionDays(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.ExpiryWarning Property

Gets or sets the expiry days warning.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ExpiryWarning() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int ExpiryWarning {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int ExpiryWarning {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ExpiryWarning() : int;
function set ExpiryWarning(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.ConsumeWarning Property

Gets or sets the consume days warning.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ConsumeWarning() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int ConsumeWarning {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int ConsumeWarning {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ConsumeWarning() : int;
function set ConsumeWarning(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.IsExpiry Property

Gets or sets the indication whether the shelf time is expiry date.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property IsExpiry() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool IsExpiry {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool IsExpiry {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get IsExpiry() : boolean;
function set IsExpiry(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.IsConsume Property

Gets or sets the indication whether the shelf time is consume date.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property IsConsume() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool IsConsume {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool IsConsume {
 bool get( );
 void set(
   bool value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get IsConsume() : boolean;
function set IsConsume(value : boolean);
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.CostAccountingDimensionId Property

Gets or sets a dimension used for Cost Accounting.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property CostAccountingDimensionId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int CostAccountingDimensionId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int CostAccountingDimensionId {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get CostAccountingDimensionId() : int;
function set CostAccountingDimensionId(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


ResourceAlternative Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceAlternative()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceAlternative()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceAlternative();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal Resource As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceAlternative(
   string Resource
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceAlternative(
   String^ Resource
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceAlternative(
    Resource : String
);
This language is not supported or no code example is available.

Parameters

Resource

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative(String, ResourceType, Boolean, Boolean, String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal Resource As String, _
   ByVal ResourceType As ResourceType, _
   ByVal Default As Boolean, _
   ByVal Infinite As Boolean, _
   ByVal ReferenceForMachine As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceAlternative(
   string Resource,
   ResourceType ResourceType,
   bool Default,
   bool Infinite,
   string ReferenceForMachine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceAlternative(
   String^ Resource,
   ResourceType ResourceType,
   bool Default,
   bool Infinite,
   String^ ReferenceForMachine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceAlternative(
    Resource : String,
    ResourceType : ResourceType,
    Default : boolean,
    Infinite : boolean,
    ReferenceForMachine : String
);
This language is not supported or no code example is available.

Parameters

Resource

Type: string

ResourceType

Type: ResourceType

Default

Type: bool

Infinite

Type: bool

ReferenceForMachine

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


ResourceAlternative(String, ResourceType, Boolean, Boolean, String, Double, RateType, Double, RateType, Double, RateType, Double, RateType, YesNoType, Double, Int32, TimeSpan, TimeSpan, TimeSpan, TimeSpan, TimeSpan) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal Resource As String, _
   ByVal ResourceType As ResourceType, _
   ByVal Default As Boolean, _
   ByVal Infinite As Boolean, _
   ByVal ReferenceForMachine As String, _
   ByVal QueueTime As Double, _
   ByVal QueueRate As RateType, _
   ByVal SetupTime As Double, _
   ByVal SetupRate As RateType, _
   ByVal StockTime As Double, _
   ByVal StockRate As RateType, _
   ByVal RunTime As Double, _
   ByVal RunRate As RateType, _
   ByVal HasCycles As YesNoType, _
   ByVal CycleCap As Double, _
   ByVal NrOfResources As Integer, _
   Optional ByVal QueueTotal As TimeSpan = new TimeSpan(), _
   Optional ByVal StockTotal As TimeSpan = new TimeSpan(), _
   Optional ByVal SetupTotal As TimeSpan = new TimeSpan(), _
   Optional ByVal RunTotal As TimeSpan = new TimeSpan(), _
   Optional ByVal SetupAndRunTotal As TimeSpan = new TimeSpan() _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceAlternative(
   string Resource,
   ResourceType ResourceType,
   bool Default,
   bool Infinite,
   string ReferenceForMachine,
   double QueueTime,
   RateType QueueRate,
   double SetupTime,
   RateType SetupRate,
   double StockTime,
   RateType StockRate,
   double RunTime,
   RateType RunRate,
   YesNoType HasCycles,
   double CycleCap,
   int NrOfResources,
   TimeSpan QueueTotal = new TimeSpan(),
   TimeSpan StockTotal = new TimeSpan(),
   TimeSpan SetupTotal = new TimeSpan(),
   TimeSpan RunTotal = new TimeSpan(),
   TimeSpan SetupAndRunTotal = new TimeSpan()
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceAlternative(
   String^ Resource,
   ResourceType ResourceType,
   bool Default,
   bool Infinite,
   String^ ReferenceForMachine,
   double QueueTime,
   RateType QueueRate,
   double SetupTime,
   RateType SetupRate,
   double StockTime,
   RateType StockRate,
   double RunTime,
   RateType RunRate,
   YesNoType HasCycles,
   double CycleCap,
   int NrOfResources,
   TimeSpan QueueTotal,
   TimeSpan StockTotal,
   TimeSpan SetupTotal,
   TimeSpan RunTotal,
   TimeSpan SetupAndRunTotal
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceAlternative(
    Resource : String,
    ResourceType : ResourceType,
    Default : boolean,
    Infinite : boolean,
    ReferenceForMachine : String,
    QueueTime : double,
    QueueRate : RateType,
    SetupTime : double,
    SetupRate : RateType,
    StockTime : double,
    StockRate : RateType,
    RunTime : double,
    RunRate : RateType,
    HasCycles : YesNoType,
    CycleCap : double,
    NrOfResources : int,
    QueueTotal : TimeSpan,
    StockTotal : TimeSpan,
    SetupTotal : TimeSpan,
    RunTotal : TimeSpan,
    SetupAndRunTotal : TimeSpan
);
This language is not supported or no code example is available.

Parameters

Resource

Type: string

ResourceType

Type: ResourceType

Default

Type: bool

Infinite

Type: bool

ReferenceForMachine

Type: string

QueueTime

Type: double

QueueRate

Type: RateType

SetupTime

Type: double

SetupRate

Type: RateType

StockTime

Type: double

StockRate

Type: RateType

RunTime

Type: double

RunRate

Type: RateType

HasCycles

Type: YesNoType

CycleCap

Type: double

NrOfResources

Type: int

QueueTotal

Type: TimeSpan

StockTotal

Type: TimeSpan

SetupTotal

Type: TimeSpan

RunTotal

Type: TimeSpan

SetupAndRunTotal

Type: TimeSpan

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAlternative Class
ResourceAlternative Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder Namespace


IConfiguration.LicenseServerAddress Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property LicenseServerAddress() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string LicenseServerAddress {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ LicenseServerAddress {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LicenseServerAddress() : String;
function set LicenseServerAddress(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


DocumentCreatingException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal ex As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DocumentCreatingException(
   string message,
   Exception ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DocumentCreatingException(
   String^ message,
   Exception^ ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DocumentCreatingException(
    message : String,
    ex : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

ex

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentCreatingException Class
DocumentCreatingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentExistingException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DocumentExistingException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DocumentExistingException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DocumentExistingException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentExistingException Class
DocumentExistingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentExistingException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal ex As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DocumentExistingException(
   string message,
   Exception ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DocumentExistingException(
   String^ message,
   Exception^ ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DocumentExistingException(
    message : String,
    ex : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

ex

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentExistingException Class
DocumentExistingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


IConfiguration.LicenseServerPort Property

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property LicenseServerPort() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string LicenseServerPort {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ LicenseServerPort {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LicenseServerPort() : String;
function set LicenseServerPort(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


SynchronizationException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SynchronizationException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SynchronizationException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SynchronizationException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SynchronizationException Class
SynchronizationException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


SynchronizationException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal ex As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SynchronizationException(
   string message,
   Exception ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SynchronizationException(
   String^ message,
   Exception^ ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SynchronizationException(
    message : String,
    ex : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

ex

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SynchronizationException Class
SynchronizationException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


IConfiguration.UpdateConfiguration Method

Updates the configuration data of ProcessForce.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub UpdateConfiguration()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void UpdateConfiguration()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void UpdateConfiguration()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function UpdateConfiguration();
This language is not supported or no code example is available.
Exceptions
Exception type | Condition
ConfigurationUpdateException | ConfigurationUpdateException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


IConfiguration.Refresh Method

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Refresh()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Refresh()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Refresh()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Refresh();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IConfiguration Interface
IConfiguration Members
CompuTec.ProcessForce.API.Configuration Namespace


AtLeastOneRowMustBeFilledException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public AtLeastOneRowMustBeFilledException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
AtLeastOneRowMustBeFilledException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function AtLeastOneRowMustBeFilledException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AtLeastOneRowMustBeFilledException Class
AtLeastOneRowMustBeFilledException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


CantAddDocumentWithDuplicatedEntriesException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CantAddDocumentWithDuplicatedEntriesException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CantAddDocumentWithDuplicatedEntriesException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CantAddDocumentWithDuplicatedEntriesException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantAddDocumentWithDuplicatedEntriesException Class
CantAddDocumentWithDuplicatedEntriesException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


CantAddDocumentWithDuplicatedEntriesException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CantAddDocumentWithDuplicatedEntriesException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CantAddDocumentWithDuplicatedEntriesException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CantAddDocumentWithDuplicatedEntriesException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantAddDocumentWithDuplicatedEntriesException Class
CantAddDocumentWithDuplicatedEntriesException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


CantAddDocumentWithDuplicatedEntriesException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CantAddDocumentWithDuplicatedEntriesException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CantAddDocumentWithDuplicatedEntriesException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CantAddDocumentWithDuplicatedEntriesException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantAddDocumentWithDuplicatedEntriesException Class
CantAddDocumentWithDuplicatedEntriesException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


InvalidConfigurationValueException Class

Members See Also

The exception that is thrown when the value of ProcessForce's configuration setting is invalid.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class InvalidConfigurationValueException
    Inherits ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class InvalidConfigurationValueException : ApplicationException
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class InvalidConfigurationValueException : public ApplicationException^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class InvalidConfigurationValueException
   extends ApplicationException
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
CompuTec.ProcessForce.API.Configuration.InvalidConfigurationValueException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InvalidConfigurationValueException Members
CompuTec.ProcessForce.API.Configuration Namespace


InvalidConfigurationValueException Members

InvalidConfigurationValueException Class Constructors Methods Properties See Also

The exception that is thrown when the value of ProcessForce's configuration setting is invalid.

The following tables list the members exposed by the InvalidConfigurationValueException type.

Constructors
 | Name | Description
Public constructor | InvalidConfigurationValueException | (Overloaded) Initializes a new instance of InvalidConfigurationValueException class with a specified error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

InvalidConfigurationValueException Class
CompuTec.ProcessForce.API.Configuration Namespace


ResourceNotFoundException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceNotFoundException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceNotFoundException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceNotFoundException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceNotFoundException Class
ResourceNotFoundException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


InvalidConfigurationValueException(String) Constructor

Initializes a new instance of InvalidConfigurationValueException class with a specified error message.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public InvalidConfigurationValueException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
InvalidConfigurationValueException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function InvalidConfigurationValueException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

A message that describes the error.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InvalidConfigurationValueException Class
InvalidConfigurationValueException Members
CompuTec.ProcessForce.API.Configuration Namespace


InvalidConfigurationValueException Constructor

InvalidConfigurationValueException Class See Also

Initializes a new instance of InvalidConfigurationValueException class with a specified error message.

Overload List
Name | Description
InvalidConfigurationValueException(string) | Initializes a new instance of InvalidConfigurationValueException class with a specified error message.
InvalidConfigurationValueException(string, Exception) | Initializes a new instance of InvalidConfigurationValueException class with a specified error message and a reference to the inner exception that is the cause of this exception.
See Also

Reference

InvalidConfigurationValueException Class
InvalidConfigurationValueException Members
CompuTec.ProcessForce.API.Configuration Namespace


InvalidConfigurationValueException(String, Exception) Constructor

Initializes a new instance of InvalidConfigurationValueException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: CompuTec.ProcessForce.API.Configuration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public InvalidConfigurationValueException(
   string message,
   Exception innerException
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
InvalidConfigurationValueException(
   String^ message,
   Exception^ innerException
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function InvalidConfigurationValueException(
    message : String,
    innerException : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

A message that describes the error.

innerException

Type: Exception

The exception that is the cause of the current exception.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

InvalidConfigurationValueException Class
InvalidConfigurationValueException Members
CompuTec.ProcessForce.API.Configuration Namespace


CompuTec.ProcessForce.API.Core Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | AnoutherUserChangedObjecException |
Public class | ExtendedUDOException |
Public class | UDOCodeGeneratorEx |
Public class | UDOException |
Public class | UDOFormulaException |
Top
Interfaces
 | Name | Description
Public interface | IAdvancedUDOBean |
Public interface | IAdvancedUDOChildBean |
Public interface | IBatchNumbers |
Public interface | IExtendedUDO | Class Adds Formula Implementation
Public interface | IPFAction | Base Type for Every Action
Public interface | ISerialNumbers |
Public interface | IUDFItem | Representation of UdfField ( name and Value)
Public interface | IUDFItems | Object For User User Defined Fields
Public interface | IUDOBean | This Interface delivers Basic Operaton On our UDO
Public interface | IUDOChildBean |
Public interface | IUDOSubLine |
Top
Enumerations
 | Name | Description
Public enumeration | ActionType |
Public enumeration | ObjectTypes |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


ActionType Enumeration

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
CopyFromDocument |
CreatePickOrderForProductionIssue |
CreateGoodsIssueFromPickOrderBasedOnProductionIssue |
CreatePickReceiptForProductionReceipt |
CreateGoodsReceiptFromPickReceiptBasedOnProductionReceipt |
CreateDeliveryNoteFromPickOrder |
CreateAdjustment |
CreateSubContractingProcurmentDocuments |
See Also

Reference

CompuTec.ProcessForce.API.Core Namespace


PickedItem Constructor

Initializes a new instance of CompuTec.ProcessForce.API.Documents.PickOrder.PickedItem object.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public PickedItem()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
PickedItem()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function PickedItem();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickedItem Class
PickedItem Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


RequiredItemQuantityHolder Constructor

Initializes a new instance of CompuTec.ProcessForce.API.Documents.PickOrder.Assigner.RequiredItemQuantityHolder object.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RequiredItemQuantityHolder()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RequiredItemQuantityHolder()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RequiredItemQuantityHolder();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RequiredItemQuantityHolder Class
RequiredItemQuantityHolder Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


RequiredItemQuantityHolder(List<Int32>) Constructor

Initializes a new instance of CompuTec.ProcessForce.API.Documents.PickOrder.Assigner.RequiredItemQuantityHolder object.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal requiredItemsLineNumbers As List(Of Integer) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RequiredItemQuantityHolder(
   List<int> requiredItemsLineNumbers
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RequiredItemQuantityHolder(
   List<int>^ requiredItemsLineNumbers
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

requiredItemsLineNumbers

Type: List<int>

A collection with U_LineNum values of Pick Order UDO's Required Items.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RequiredItemQuantityHolder Class
RequiredItemQuantityHolder Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


BatchNumberQuantityMissMatchException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchNumberQuantityMissMatchException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchNumberQuantityMissMatchException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchNumberQuantityMissMatchException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberQuantityMissMatchException Class
BatchNumberQuantityMissMatchException Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


BatchNumberQuantityMissMatchException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchNumberQuantityMissMatchException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchNumberQuantityMissMatchException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchNumberQuantityMissMatchException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberQuantityMissMatchException Class
BatchNumberQuantityMissMatchException Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


BatchNumberQuantityMissMatchException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BatchNumberQuantityMissMatchException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BatchNumberQuantityMissMatchException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BatchNumberQuantityMissMatchException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BatchNumberQuantityMissMatchException Class
BatchNumberQuantityMissMatchException Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


AnoutherUserChangedObjecException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class AnoutherUserChangedObjecException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class AnoutherUserChangedObjecException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class AnoutherUserChangedObjecException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class AnoutherUserChangedObjecException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Core.AnoutherUserChangedObjecException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AnoutherUserChangedObjecException Members
CompuTec.ProcessForce.API.Core Namespace


AnoutherUserChangedObjecException Members

AnoutherUserChangedObjecException Class Constructors Methods Properties See Also

The following tables list the members exposed by the AnoutherUserChangedObjecException type.

Constructors
 | Name | Description
Public constructor | AnoutherUserChangedObjecException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

AnoutherUserChangedObjecException Class
CompuTec.ProcessForce.API.Core Namespace


AnoutherUserChangedObjecException Constructor

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public AnoutherUserChangedObjecException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
AnoutherUserChangedObjecException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function AnoutherUserChangedObjecException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AnoutherUserChangedObjecException Class
AnoutherUserChangedObjecException Members
CompuTec.ProcessForce.API.Core Namespace


AnoutherUserChangedObjecException Constructor

AnoutherUserChangedObjecException Class See Also

Overload List
Name | Description
AnoutherUserChangedObjecException() |
AnoutherUserChangedObjecException(string) |
AnoutherUserChangedObjecException(string, Exception) |
See Also

Reference

AnoutherUserChangedObjecException Class
AnoutherUserChangedObjecException Members
CompuTec.ProcessForce.API.Core Namespace


AnoutherUserChangedObjecException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public AnoutherUserChangedObjecException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
AnoutherUserChangedObjecException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function AnoutherUserChangedObjecException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AnoutherUserChangedObjecException Class
AnoutherUserChangedObjecException Members
CompuTec.ProcessForce.API.Core Namespace


AnoutherUserChangedObjecException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public AnoutherUserChangedObjecException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
AnoutherUserChangedObjecException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function AnoutherUserChangedObjecException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AnoutherUserChangedObjecException Class
AnoutherUserChangedObjecException Members
CompuTec.ProcessForce.API.Core Namespace


ExtendedUDOException(String, String, String, String, Int32) Constructor

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal UdoType As String, _
   ByVal childType As String, _
   ByVal fieldName As String, _
   ByVal row As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ExtendedUDOException(
   string message,
   string UdoType,
   string childType,
   string fieldName,
   int row
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ExtendedUDOException(
   String^ message,
   String^ UdoType,
   String^ childType,
   String^ fieldName,
   int row
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ExtendedUDOException(
    message : String,
    UdoType : String,
    childType : String,
    fieldName : String,
    row : int
);
This language is not supported or no code example is available.

Parameters

message

Type: string

UdoType

Type: string

childType

Type: string

fieldName

Type: string

row

Type: int

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ExtendedUDOException Class
ExtendedUDOException Members
CompuTec.ProcessForce.API.Core Namespace


UDOException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class UDOException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class UDOException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class UDOException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class UDOException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Core.UDOException
CompuTec.ProcessForce.API.Documents.BillOfMaterials.BillOfMaterialValidationException
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.RunTimeIsZeroException
CompuTec.ProcessForce.API.Documents._Production_Planing_._Manufacturing_Order_.ManufacturingOrder.Exception.RoutingNotActiveException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UDOException Members
CompuTec.ProcessForce.API.Core Namespace


UDOException Members

UDOException Class Constructors Methods Properties See Also

The following tables list the members exposed by the UDOException type.

Constructors
 | Name | Description
Public constructor | UDOException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | ObjectCode |
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

UDOException Class
CompuTec.ProcessForce.API.Core Namespace


UDOException Constructor

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public UDOException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
UDOException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UDOException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UDOException Class
UDOException Members
CompuTec.ProcessForce.API.Core Namespace


UDOException Constructor

UDOException Class See Also

Overload List
Name | Description
UDOException() |
UDOException(string, Exception) |
UDOException(string, string) |
See Also

Reference

UDOException Class
UDOException Members
CompuTec.ProcessForce.API.Core Namespace


UDOException(String, String) Constructor

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal udotype As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public UDOException(
   string message,
   string udotype
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
UDOException(
   String^ message,
   String^ udotype
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UDOException(
    message : String,
    udotype : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

udotype

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UDOException Class
UDOException Members
CompuTec.ProcessForce.API.Core Namespace


UDOException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public UDOException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
UDOException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UDOException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UDOException Class
UDOException Members
CompuTec.ProcessForce.API.Core Namespace


UDOFormulaException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class UDOFormulaException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class UDOFormulaException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class UDOFormulaException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class UDOFormulaException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Core.UDOFormulaException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UDOFormulaException Members
CompuTec.ProcessForce.API.Core Namespace


UDOFormulaException Members

UDOFormulaException Class Constructors Methods Properties See Also

The following tables list the members exposed by the UDOFormulaException type.

Constructors
 | Name | Description
Public constructor | UDOFormulaException | (Overloaded)
Top
Properties
 | Name | Description
Public property | ChildType |
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | FieldName |
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | ObjectCode |
Public property | Row |
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

UDOFormulaException Class
CompuTec.ProcessForce.API.Core Namespace


UDOFormulaException.ObjectCode Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ObjectCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ObjectCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ObjectCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ObjectCode() : String;
public function set ObjectCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UDOFormulaException Class
UDOFormulaException Members
CompuTec.ProcessForce.API.Core Namespace


UDOFormulaException.ChildType Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ChildType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ChildType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ChildType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ChildType() : String;
public function set ChildType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UDOFormulaException Class
UDOFormulaException Members
CompuTec.ProcessForce.API.Core Namespace


UDOFormulaException.FieldName Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property FieldName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string FieldName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ FieldName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get FieldName() : String;
public function set FieldName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UDOFormulaException Class
UDOFormulaException Members
CompuTec.ProcessForce.API.Core Namespace


IBatchNumbers Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IBatchNumbers
    Inherits IUDOSubLine
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IBatchNumbers : IUDOSubLine
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IBatchNumbers : public IUDOSubLine^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IBatchNumbers
   implements IUDOSubLine
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchNumbers Members
CompuTec.ProcessForce.API.Core Namespace


IBatchNumbers Members

IBatchNumbers Interface Methods Properties See Also

The following tables list the members exposed by the IBatchNumbers type.

Properties
 | Name | Description
Public property | AddmisionDate |
Public property | BatchNumber | mandatory
Public property | BinAllocated |
Public property | Count | (inherited from IUDOSubLine).
Public property | ExpiryDate |
Public property | InterialSerialNumber |
Public property | Location |
Public property | Locked | Indicates If Values Are Blocked ( in case that they are Already Receipted Or Issued
Public property | ManufacturingDate |
Public property | Notes |
Public property | Quantity |
Public property | manufacturerSerialNumber |
Top
Methods
 | Name | Description
Public method | Add | (inherited from IUDOSubLine).
Public method | AddBatchToReferences |
Public method | Remove | (inherited from IUDOSubLine).
Public method | SetCurrentLine | (inherited from IUDOSubLine).
Public method | TotalQuantity | Calculates Total batch Wuantity for Current Document Line that is not Receipted or Issued
Top
See Also

Reference

IBatchNumbers Interface
CompuTec.ProcessForce.API.Core Namespace


IBatchNumbers.AddmisionDate Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property AddmisionDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime AddmisionDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime AddmisionDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get AddmisionDate() : DateTime;
function set AddmisionDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchNumbers Interface
IBatchNumbers Members
CompuTec.ProcessForce.API.Core Namespace


IBatchNumbers.BatchNumber Property

mandatory

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BatchNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string BatchNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ BatchNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BatchNumber() : String;
function set BatchNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchNumbers Interface
IBatchNumbers Members
CompuTec.ProcessForce.API.Core Namespace


IBatchNumbers.ExpiryDate Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ExpiryDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime ExpiryDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime ExpiryDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ExpiryDate() : DateTime;
function set ExpiryDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchNumbers Interface
IBatchNumbers Members
CompuTec.ProcessForce.API.Core Namespace


IBatchNumbers.InterialSerialNumber Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property InterialSerialNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string InterialSerialNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ InterialSerialNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get InterialSerialNumber() : String;
function set InterialSerialNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchNumbers Interface
IBatchNumbers Members
CompuTec.ProcessForce.API.Core Namespace


IBatchNumbers.Location Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Location() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Location {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Location {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Location() : String;
function set Location(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchNumbers Interface
IBatchNumbers Members
CompuTec.ProcessForce.API.Core Namespace


IBatchNumbers.manufacturerSerialNumber Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property manufacturerSerialNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string manufacturerSerialNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ manufacturerSerialNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get manufacturerSerialNumber() : String;
function set manufacturerSerialNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchNumbers Interface
IBatchNumbers Members
CompuTec.ProcessForce.API.Core Namespace


IBatchNumbers.BinAllocated Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property BinAllocated() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double BinAllocated {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double BinAllocated {
 double get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BinAllocated() : double;
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IBatchNumbers Interface
IBatchNumbers Members
CompuTec.ProcessForce.API.Core Namespace


ISerialNumbers Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface ISerialNumbers
    Inherits IUDOSubLine
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ISerialNumbers : IUDOSubLine
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class ISerialNumbers : public IUDOSubLine^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface ISerialNumbers
   implements IUDOSubLine
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialNumbers Members
CompuTec.ProcessForce.API.Core Namespace


ISerialNumbers Members

ISerialNumbers Interface Methods Properties See Also

The following tables list the members exposed by the ISerialNumbers type.

Properties
 | Name | Description
Public property | BatchID |
Public property | BinAbsEntry |
Public property | BinCode |
Public property | Count | (inherited from IUDOSubLine).
Public property | ExpiryDate |
Public property | InterialSerialNumber |
Public property | Location |
Public property | Locked |
Public property | ManufacturingDate |
Public property | Notes |
Public property | ReceptionDate |
Public property | SystemSerialNumber |
Public property | WarrantyEnd |
Public property | WarrantyStart |
Public property | manufacturerSerialNumber |
Top
Methods
 | Name | Description
Public method | Add | (inherited from IUDOSubLine).
Public method | Remove | (inherited from IUDOSubLine).
Public method | SetCurrentLine | (inherited from IUDOSubLine).
Public method | TotalCount |
Top
See Also

Reference

ISerialNumbers Interface
CompuTec.ProcessForce.API.Core Namespace


ISerialNumbers.BatchID Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property BatchID() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string BatchID {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ BatchID {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BatchID() : String;
function set BatchID(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialNumbers Interface
ISerialNumbers Members
CompuTec.ProcessForce.API.Core Namespace


ISerialNumbers.ExpiryDate Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ExpiryDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime ExpiryDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime ExpiryDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ExpiryDate() : DateTime;
function set ExpiryDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialNumbers Interface
ISerialNumbers Members
CompuTec.ProcessForce.API.Core Namespace


ISerialNumbers.InterialSerialNumber Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property InterialSerialNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string InterialSerialNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ InterialSerialNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get InterialSerialNumber() : String;
function set InterialSerialNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialNumbers Interface
ISerialNumbers Members
CompuTec.ProcessForce.API.Core Namespace


ISerialNumbers.Location Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Location() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Location {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Location {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Location() : String;
function set Location(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialNumbers Interface
ISerialNumbers Members
CompuTec.ProcessForce.API.Core Namespace


ISerialNumbers.manufacturerSerialNumber Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property manufacturerSerialNumber() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string manufacturerSerialNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ manufacturerSerialNumber {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get manufacturerSerialNumber() : String;
function set manufacturerSerialNumber(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialNumbers Interface
ISerialNumbers Members
CompuTec.ProcessForce.API.Core Namespace


ISerialNumbers.ManufacturingDate Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ManufacturingDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime ManufacturingDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime ManufacturingDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ManufacturingDate() : DateTime;
function set ManufacturingDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialNumbers Interface
ISerialNumbers Members
CompuTec.ProcessForce.API.Core Namespace


ISerialNumbers.Notes Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Notes() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Notes {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Notes {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Notes() : String;
function set Notes(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialNumbers Interface
ISerialNumbers Members
CompuTec.ProcessForce.API.Core Namespace


ISerialNumbers.Locked Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Locked() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool Locked {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool Locked {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Locked() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialNumbers Interface
ISerialNumbers Members
CompuTec.ProcessForce.API.Core Namespace


ISerialNumbers.BinCode Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property BinCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string BinCode {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ BinCode {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get BinCode() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISerialNumbers Interface
ISerialNumbers Members
CompuTec.ProcessForce.API.Core Namespace


IUDOSubLine Interface

Members See Also

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IUDOSubLine
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IUDOSubLine
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IUDOSubLine
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IUDOSubLine
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOSubLine Members
CompuTec.ProcessForce.API.Core Namespace


IUDOSubLine Members

IUDOSubLine Interface Methods Properties See Also

The following tables list the members exposed by the IUDOSubLine type.

Properties
 | Name | Description
Public property | Count |
Top
Methods
 | Name | Description
Public method | Add |
Public method | Remove |
Public method | SetCurrentLine |
Top
See Also

Reference

IUDOSubLine Interface
CompuTec.ProcessForce.API.Core Namespace


IUDOSubLine.Count Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Count() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Count {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Count {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Count() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOSubLine Interface
IUDOSubLine Members
CompuTec.ProcessForce.API.Core Namespace


IUDOSubLine.Add Method

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Add()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Add()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Add()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Add();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOSubLine Interface
IUDOSubLine Members
CompuTec.ProcessForce.API.Core Namespace


IUDOSubLine.Remove Method

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub Remove()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void Remove()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void Remove()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Remove();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOSubLine Interface
IUDOSubLine Members
CompuTec.ProcessForce.API.Core Namespace


IUDOSubLine.SetCurrentLine Method

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub SetCurrentLine( _
   ByVal position As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void SetCurrentLine(
   int position
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void SetCurrentLine(
   int position
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function SetCurrentLine(
    position : int
);
This language is not supported or no code example is available.

Parameters

position

Type: int

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDOSubLine Interface
IUDOSubLine Members
CompuTec.ProcessForce.API.Core Namespace


IExtendedUDO Interface

Members See Also

Class Adds Formula Implementation

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IExtendedUDO
    Inherits IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IExtendedUDO : IUDOBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IExtendedUDO : public IUDOBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IExtendedUDO
   implements IUDOBean
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExtendedUDO Members
CompuTec.ProcessForce.API.Core Namespace


IExtendedUDO Members

IExtendedUDO Interface Methods Properties See Also

Class Adds Formula Implementation

The following tables list the members exposed by the IExtendedUDO type.

Properties
 | Name | Description
Public property | ErrorDescription | Error Information if any (inherited from IUDOBean).
Public property | Token | (inherited from IUDOBean).
Public property | UDFItems | User Defined Items (inherited from IUDOBean).
Public property | UdoLogTableName | Gets Correspondend Log Table name in databse (inherited from IUDOBean).
Public property | UdoName | gets UDOName of current object (inherited from IUDOBean).
Public property | UdoTableName | Gets Correspondend Table name in databse (inherited from IUDOBean).
Top
Methods
 | Name | Description
Public method | Add | methood adds Object To Database (inherited from IUDOBean).
Public method | CanDelete | Gets Can Delete information (inherited from IUDOBean).
Public method | Clean | (inherited from IUDOBean).
Public method | Delete | Deletes an object (inherited from IUDOBean).
Public method | GetAsXML | (inherited from IUDOBean).
Public method | GetByKey | Loads object with values From Database (inherited from IUDOBean).
Public method | GetLastObjectCode | Returns Object Code form newly added item (inherited from IUDOBean).
Public method | RecalcFormulas | Connect Function to Activate Recalculation Engine on object
Public method | RecalcFormulasNew |
Public method | RecalcRequired | (Overloaded)
Public method | RefreshHeaderData | (inherited from IUDOBean).
Public method | Update | Update An object (inherited from IUDOBean).
Top
See Also

Reference

IExtendedUDO Interface
CompuTec.ProcessForce.API.Core Namespace


IExtendedUDO.RecalcRequired Method

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function RecalcRequired() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool RecalcRequired()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool RecalcRequired()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function RecalcRequired() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IExtendedUDO Interface
IExtendedUDO Members
CompuTec.ProcessForce.API.Core Namespace


IUDFItem.HasValidValues Property

Does Udf has Valid Values

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property HasValidValues() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool HasValidValues {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool HasValidValues {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get HasValidValues() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDFItem Interface
IUDFItem Members
CompuTec.ProcessForce.API.Core Namespace


IQualityControlTest2.Items Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Items() As IQualityControlTestItems
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IQualityControlTestItems Items {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IQualityControlTestItems^ Items {
 IQualityControlTestItems^ get( );
 void set(
   IQualityControlTestItems^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Items() : IQualityControlTestItems;
function set Items(value : IQualityControlTestItems);
This language is not supported or no code example is available.

Property Value

Type: IQualityControlTestItems
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.Attachments Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Attachments() As IQualityControlTestAttachments
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IQualityControlTestAttachments Attachments {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IQualityControlTestAttachments^ Attachments {
 IQualityControlTestAttachments^ get( );
 void set(
   IQualityControlTestAttachments^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Attachments() : IQualityControlTestAttachments;
function set Attachments(value : IQualityControlTestAttachments);
This language is not supported or no code example is available.

Property Value

Type: IQualityControlTestAttachments
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.ItemProperties Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ItemProperties() As IQualityControlTestItemProperties
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IQualityControlTestItemProperties ItemProperties {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IQualityControlTestItemProperties^ ItemProperties {
 IQualityControlTestItemProperties^ get( );
 void set(
   IQualityControlTestItemProperties^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ItemProperties() : IQualityControlTestItemProperties;
function set ItemProperties(value : IQualityControlTestItemProperties);
This language is not supported or no code example is available.

Property Value

Type: IQualityControlTestItemProperties
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.MultipleTestResults Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property MultipleTestResults() As IQualityControlTestMultipleTestResults
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IQualityControlTestMultipleTestResults MultipleTestResults {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IQualityControlTestMultipleTestResults^ MultipleTestResults {
 IQualityControlTestMultipleTestResults^ get( );
 void set(
   IQualityControlTestMultipleTestResults^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get MultipleTestResults() : IQualityControlTestMultipleTestResults;
function set MultipleTestResults(value : IQualityControlTestMultipleTestResults);
This language is not supported or no code example is available.

Property Value

Type: IQualityControlTestMultipleTestResults
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.TestResultBusinessPartnerRelations Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property TestResultBusinessPartnerRelations() As IBusinessPartnerRelationsThridLevel
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBusinessPartnerRelationsThridLevel TestResultBusinessPartnerRelations {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBusinessPartnerRelationsThridLevel^ TestResultBusinessPartnerRelations {
 IBusinessPartnerRelationsThridLevel^ get( );
 void set(
   IBusinessPartnerRelationsThridLevel^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get TestResultBusinessPartnerRelations() : IBusinessPartnerRelationsThridLevel;
function set TestResultBusinessPartnerRelations(value : IBusinessPartnerRelationsThridLevel);
This language is not supported or no code example is available.

Property Value

Type: IBusinessPartnerRelationsThridLevel
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.ItemPropertyBusinessPartnerRelations Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property ItemPropertyBusinessPartnerRelations() As IBusinessPartnerRelationsThridLevel
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IBusinessPartnerRelationsThridLevel ItemPropertyBusinessPartnerRelations {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IBusinessPartnerRelationsThridLevel^ ItemPropertyBusinessPartnerRelations {
 IBusinessPartnerRelationsThridLevel^ get( );
 void set(
   IBusinessPartnerRelationsThridLevel^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ItemPropertyBusinessPartnerRelations() : IBusinessPartnerRelationsThridLevel;
function set ItemPropertyBusinessPartnerRelations(value : IBusinessPartnerRelationsThridLevel);
This language is not supported or no code example is available.

Property Value

Type: IBusinessPartnerRelationsThridLevel
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IUDFItem.Description Property

Description Of an UDF item

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Description() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Description {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Description {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Description() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDFItem Interface
IUDFItem Members
CompuTec.ProcessForce.API.Core Namespace


IQualityControlTestAttachments.U_Path Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Path() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Path {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Path {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Path() : String;
function set U_Path(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestAttachments Interface
IQualityControlTestAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestAttachments.U_FileName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_FileName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_FileName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_FileName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_FileName() : String;
function set U_FileName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestAttachments Interface
IQualityControlTestAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestAttachments.U_AttDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_AttDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_AttDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_AttDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_AttDate() : DateTime;
function set U_AttDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestAttachments Interface
IQualityControlTestAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestBatches Interface

Members See Also

Batches for quality control test document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IQualityControlTestBatches
    Inherits IUDOChildBean, _
             IEnumerable(Of IQualityControlTestBatches)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IQualityControlTestBatches : IUDOChildBean,
   IEnumerable<IQualityControlTestBatches>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IQualityControlTestBatches : public IUDOChildBean^,
   public IEnumerable<IQualityControlTestBatches^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_QCT2
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestBatches Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestBatches Members

IQualityControlTestBatches Interface Methods Properties See Also

Batches for quality control test document

The following tables list the members exposed by the IQualityControlTestBatches type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Batch |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_QcTestNo |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IQualityControlTestBatches Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestBatches.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestBatches Interface
IQualityControlTestBatches Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestBatches.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestBatches Interface
IQualityControlTestBatches Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IUDFItem.Name Property

Name of UDF Field

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Name() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Name {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Name {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Name() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDFItem Interface
IUDFItem Members
CompuTec.ProcessForce.API.Core Namespace


IQualityControlTestDefects.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestDefects Interface
IQualityControlTestDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestDefects.U_QcTestNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QcTestNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_QcTestNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_QcTestNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QcTestNo() : int;
function set U_QcTestNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestDefects Interface
IQualityControlTestDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestDefects.U_DefCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_DefCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_DefCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_DefCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_DefCode() : String;
function set U_DefCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestDefects Interface
IQualityControlTestDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestDefects.DS_DefTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_DefTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_DefTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_DefTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_DefTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_DefTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestDefects Interface
IQualityControlTestDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestDefects.DS_DefName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_DefName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_DefName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_DefName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_DefName() : String;

   AppEnginePropertyIgnore()
function set DS_DefName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestDefects Interface
IQualityControlTestDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties Interface

Members See Also

Item properties for quality control test document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IQualityControlTestItemProperties
    Inherits IUDOChildBean, _
             IEnumerable(Of IQualityControlTestItemProperties)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IQualityControlTestItemProperties : IUDOChildBean,
   IEnumerable<IQualityControlTestItemProperties>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IQualityControlTestItemProperties : public IUDOChildBean^,
   public IEnumerable<IQualityControlTestItemProperties^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_QCT8
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties Members

IQualityControlTestItemProperties Interface Methods Properties See Also

Item properties for quality control test document

The following tables list the members exposed by the IQualityControlTestItemProperties type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_CreateDate |
Public property | DS_PropertyName |
Public property | DS_PropertyTableCode |
Public property | DS_ReferenceName |
Public property | DS_ReferenceTableCode |
Public property | DS_RsnName |
Public property | DS_RsnTableCode |
Public property | DS_UnitOfMeasure |
Public property | DS_UpdateDate |
Public property | DS_WrdName |
Public property | DS_WrdTableCode |
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Expression |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PassFail |
Public property | U_PrpCode |
Public property | U_RangeValueFrom |
Public property | U_RangeValueTo |
Public property | U_RefCode |
Public property | U_Remarks |
Public property | U_RsnCode |
Public property | U_TestedRefCode |
Public property | U_TestedValue |
Public property | U_ValidFromDate |
Public property | U_ValidToDate |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IQualityControlTestItemProperties Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IUDFItem.DefaultValue Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DefaultValue() As Object
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
object DefaultValue {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property object^ DefaultValue {
 object^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DefaultValue() : object;
This language is not supported or no code example is available.

Property Value

Type: object
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDFItem Interface
IUDFItem Members
CompuTec.ProcessForce.API.Core Namespace


IQualityControlTestItemProperties.U_ValidToDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidToDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidToDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidToDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidToDate() : DateTime;
function set U_ValidToDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.U_RefCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RefCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RefCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RefCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RefCode() : String;
function set U_RefCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.U_TestedValue Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestedValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_TestedValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_TestedValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestedValue() : double;
function set U_TestedValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.U_TestedRefCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestedRefCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TestedRefCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TestedRefCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestedRefCode() : String;
function set U_TestedRefCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.U_PassFail Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PassFail() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PassFail {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PassFail {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PassFail() : String;
function set U_PassFail(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.U_RsnCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RsnCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RsnCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RsnCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RsnCode() : String;
function set U_RsnCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IUDFItem.GetValueType Method

Type of Value

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetValueType() As Type
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
Type GetValueType()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Type^ GetValueType()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetValueType() : Type;
This language is not supported or no code example is available.

Return Value

Type: Type
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDFItem Interface
IUDFItem Members
CompuTec.ProcessForce.API.Core Namespace


IQualityControlTestItemProperties.DS_CreateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_CreateDate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_CreateDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_CreateDate {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_CreateDate() : String;

   AppEnginePropertyIgnore()
function set DS_CreateDate(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.DS_UpdateDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_UpdateDate() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_UpdateDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_UpdateDate {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_UpdateDate() : String;

   AppEnginePropertyIgnore()
function set DS_UpdateDate(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItems Interface

Members See Also

Test items for quality control test document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IQualityControlTestItems
    Inherits IUDOChildBean, _
             IEnumerable(Of IQualityControlTestItems)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IQualityControlTestItems : IUDOChildBean,
   IEnumerable<IQualityControlTestItems>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IQualityControlTestItems : public IUDOChildBean^,
   public IEnumerable<IQualityControlTestItems^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_QCT6
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItems Members

IQualityControlTestItems Interface Methods Properties See Also

Test items for quality control test document

The following tables list the members exposed by the IQualityControlTestItems type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_ItemName |
Public property | DS_ItemUoM |
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ActualQty |
Public property | U_ItemCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PlannedQty |
Public property | U_Remarks |
Public property | U_WhsCode |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IQualityControlTestItems Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItems.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItems Interface
IQualityControlTestItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItems.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItems Interface
IQualityControlTestItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItems.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItems Interface
IQualityControlTestItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IUDFItem.IsTime Property

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property IsTime() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool IsTime {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool IsTime {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get IsTime() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDFItem Interface
IUDFItem Members
CompuTec.ProcessForce.API.Core Namespace


IQualityControlTestMultipleTestResults.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestMultipleTestResults Interface
IQualityControlTestMultipleTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestMultipleTestResults.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestMultipleTestResults Interface
IQualityControlTestMultipleTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestMultipleTestResults.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestMultipleTestResults Interface
IQualityControlTestMultipleTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestMultipleTestResults.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestMultipleTestResults Interface
IQualityControlTestMultipleTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestMultipleTestResults.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestMultipleTestResults Interface
IQualityControlTestMultipleTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestMultipleTestResults.U_TestLineNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestLineNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_TestLineNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_TestLineNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestLineNo() : int;
function set U_TestLineNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestMultipleTestResults Interface
IQualityControlTestMultipleTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IUDFItem.Value Property

Get,Set UDF Value

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Value() As Object
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
object Value {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property object^ Value {
 object^ get( );
 void set(
   object^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Value() : object;
function set Value(value : object);
This language is not supported or no code example is available.

Property Value

Type: object
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDFItem Interface
IUDFItem Members
CompuTec.ProcessForce.API.Core Namespace


IQualityControlTestMultipleTestResults.DS_Passed Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_Passed() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_Passed {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_Passed {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_Passed() : String;

   AppEnginePropertyIgnore()
function set DS_Passed(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestMultipleTestResults Interface
IQualityControlTestMultipleTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestMultipleTestResults.DS_TestedReferenceName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_TestedReferenceName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_TestedReferenceName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_TestedReferenceName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_TestedReferenceName() : String;

   AppEnginePropertyIgnore()
function set DS_TestedReferenceName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestMultipleTestResults Interface
IQualityControlTestMultipleTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestResources Interface

Members See Also

Resources for quality control test document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IQualityControlTestResources
    Inherits IUDOChildBean, _
             IEnumerable(Of IQualityControlTestResources)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IQualityControlTestResources : IUDOChildBean,
   IEnumerable<IQualityControlTestResources>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IQualityControlTestResources : public IUDOChildBean^,
   public IEnumerable<IQualityControlTestResources^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_QCT5
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestResources Members

IQualityControlTestResources Interface Methods Properties See Also

Resources for quality control test document

The following tables list the members exposed by the IQualityControlTestResources type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_RscName |
Public property | DS_RscUoM |
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_ActualQty |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PlannedQty |
Public property | U_Remarks |
Public property | U_RscCode |
Public property | U_WhsCode |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IQualityControlTestResources Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestResources.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestResources Interface
IQualityControlTestResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestResources.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestResources Interface
IQualityControlTestResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestResources.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestResources Interface
IQualityControlTestResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IUDFItems Interface

Members See Also

Object For User User Defined Fields

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IUDFItems
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IUDFItems
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IUDFItems
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IUDFItems
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDFItems Members
CompuTec.ProcessForce.API.Core Namespace


IUDFItems Members

IUDFItems Interface Methods Properties See Also

Object For User User Defined Fields

The following tables list the members exposed by the IUDFItems type.

Properties
 | Name | Description
Public property | Count | Gets Number of UDF fields in this object
Top
Methods
 | Name | Description
Public method | Contains |
Public method | Item | Gets Current UdfObject
Public method | getUDFNames | Returns List of UDF Fields
Top
See Also

Reference

IUDFItems Interface
CompuTec.ProcessForce.API.Core Namespace


IQualityControlTestSerialNumbers.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestSerialNumbers Interface
IQualityControlTestSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestSerialNumbers.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestSerialNumbers Interface
IQualityControlTestSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestSerialNumbers.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestSerialNumbers Interface
IQualityControlTestSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestSerialNumbers.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestSerialNumbers Interface
IQualityControlTestSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestSerialNumbers.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestSerialNumbers Interface
IQualityControlTestSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestSerialNumbers.U_QcTestNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QcTestNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_QcTestNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_QcTestNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QcTestNo() : int;
function set U_QcTestNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestSerialNumbers Interface
IQualityControlTestSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IUDFItems.Count Property

Gets Number of UDF fields in this object

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Count() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int Count {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int Count {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Count() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDFItems Interface
IUDFItems Members
CompuTec.ProcessForce.API.Core Namespace


IQualityControlTestTestResults.U_PrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpCode() : String;
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.U_Expression Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Expression() As ConditionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ConditionType U_Expression {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ConditionType U_Expression {
 ConditionType get( );
 void set(
   ConditionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Expression() : ConditionType;
function set U_Expression(value : ConditionType);
This language is not supported or no code example is available.

Property Value

Type: ConditionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.U_RangeValueFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RangeValueFrom() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RangeValueFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RangeValueFrom {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RangeValueFrom() : double;
function set U_RangeValueFrom(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.U_RangeValueTo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RangeValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RangeValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RangeValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RangeValueTo() : double;
function set U_RangeValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.U_UnitOfMeasure Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_UnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_UnitOfMeasure {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_UnitOfMeasure {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_UnitOfMeasure() : String;
function set U_UnitOfMeasure(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.U_RefCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RefCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RefCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RefCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RefCode() : String;
function set U_RefCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IUDFItems.Contains Method

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function Contains( _
   ByVal name As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool Contains(
   string name
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool Contains(
   String^ name
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function Contains(
    name : String
) : boolean;
This language is not supported or no code example is available.

Parameters

name

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IUDFItems Interface
IUDFItems Members
CompuTec.ProcessForce.API.Core Namespace


IQualityControlTestTestResults.DS_RsnName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_RsnName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_RsnName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_RsnName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_RsnName() : String;

   AppEnginePropertyIgnore()
function set DS_RsnName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.DS_WrdTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_WrdTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_WrdTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_WrdTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_WrdTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_WrdTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.DS_WrdName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_WrdName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_WrdName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_WrdName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_WrdName() : String;

   AppEnginePropertyIgnore()
function set DS_WrdName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


ResourceAndLinkedTools Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ResourceAndLinkedTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ResourceAndLinkedTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ResourceAndLinkedTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ResourceAndLinkedTools
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Scheduling.ResourceAndLinkedTools
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAndLinkedTools Members
CompuTec.ProcessForce.API.Scheduling Namespace


ResourceAndLinkedTools Members

ResourceAndLinkedTools Class Constructors Methods Fields See Also

The following tables list the members exposed by the ResourceAndLinkedTools type.

Constructors
 | Name | Description
Public constructor | ResourceAndLinkedTools | (Overloaded)
Top
Methods
 | Name | Description
Public method | AddTool |
Public method | AddTools |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | LinkedTools |
Public field | Resource |
Top
See Also

Reference

ResourceAndLinkedTools Class
CompuTec.ProcessForce.API.Scheduling Namespace


Resource Field

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Resource As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Resource
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ Resource;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Resource : String
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAndLinkedTools Class
ResourceAndLinkedTools Members
CompuTec.ProcessForce.API.Scheduling Namespace


LinkedTools Field

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public LinkedTools As List(Of String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<string> LinkedTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<String^>^ LinkedTools;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Field Value

Type: List<string>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAndLinkedTools Class
ResourceAndLinkedTools Members
CompuTec.ProcessForce.API.Scheduling Namespace


ResourceAndLinkedTools Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceAndLinkedTools()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceAndLinkedTools()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceAndLinkedTools();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAndLinkedTools Class
ResourceAndLinkedTools Members
CompuTec.ProcessForce.API.Scheduling Namespace


ResourceAndLinkedTools Constructor

ResourceAndLinkedTools Class See Also

Overload List
Name | Description
ResourceAndLinkedTools() |
ResourceAndLinkedTools(string, List<String>) |
See Also

Reference

ResourceAndLinkedTools Class
ResourceAndLinkedTools Members
CompuTec.ProcessForce.API.Scheduling Namespace


ResourceAndLinkedTools(String, List<String>) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal Resource As String, _
   ByVal LinkedTools As List(Of String) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceAndLinkedTools(
   string Resource,
   List<string> LinkedTools
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceAndLinkedTools(
   String^ Resource,
   List<String^>^ LinkedTools
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Resource

Type: string

LinkedTools

Type: List<string>

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAndLinkedTools Class
ResourceAndLinkedTools Members
CompuTec.ProcessForce.API.Scheduling Namespace


ResourceAndLinkedTools.AddTool Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub AddTool( _
   ByVal Tool As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void AddTool(
   string Tool
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void AddTool(
   String^ Tool
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function AddTool(
    Tool : String
);
This language is not supported or no code example is available.

Parameters

Tool

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAndLinkedTools Class
ResourceAndLinkedTools Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval(DateTime, DateTime) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal fromDate As Date, _
   ByVal toDate As Date _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeInterval(
   DateTime fromDate,
   DateTime toDate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeInterval(
   DateTime fromDate,
   DateTime toDate
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function TimeInterval(
    fromDate : DateTime,
    toDate : DateTime
);
This language is not supported or no code example is available.

Parameters

fromDate

Type: DateTime

toDate

Type: DateTime

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeInterval Class
TimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval(DateTime, DateTime, String) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal fromDate As Date, _
   ByVal toDate As Date, _
   ByVal remarks As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeInterval(
   DateTime fromDate,
   DateTime toDate,
   string remarks
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeInterval(
   DateTime fromDate,
   DateTime toDate,
   String^ remarks
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function TimeInterval(
    fromDate : DateTime,
    toDate : DateTime,
    remarks : String
);
This language is not supported or no code example is available.

Parameters

fromDate

Type: DateTime

toDate

Type: DateTime

remarks

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeInterval Class
TimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval(DateTime, DateTime, String, Object) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal fromDate As Date, _
   ByVal toDate As Date, _
   ByVal remarks As String, _
   ByVal refrerences As Object _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeInterval(
   DateTime fromDate,
   DateTime toDate,
   string remarks,
   object refrerences
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeInterval(
   DateTime fromDate,
   DateTime toDate,
   String^ remarks,
   object^ refrerences
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function TimeInterval(
    fromDate : DateTime,
    toDate : DateTime,
    remarks : String,
    refrerences : object
);
This language is not supported or no code example is available.

Parameters

fromDate

Type: DateTime

toDate

Type: DateTime

remarks

Type: string

refrerences

Type: object

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeInterval Class
TimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval.Remarks Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Remarks() As String Implements  _
   ITimeInterval.Remarks
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Remarks() : String;
public function set Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string

Implements

ITimeInterval.Remarks
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeInterval Class
TimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval.FromDate Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property FromDate() As Date Implements  _
   ITimeInterval.FromDate
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime FromDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime FromDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get FromDate() : DateTime;
public function set FromDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime

Implements

ITimeInterval.FromDate
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeInterval Class
TimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval.ToDate Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ToDate() As Date Implements  _
   ITimeInterval.ToDate
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DateTime ToDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property DateTime ToDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ToDate() : DateTime;
public function set ToDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime

Implements

ITimeInterval.ToDate
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeInterval Class
TimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeIntervals.Add Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Add( _
   ByVal interval As ITimeInterval _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Add(
   ITimeInterval interval
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Add(
   ITimeInterval^ interval
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Add(
    interval : ITimeInterval
);
This language is not supported or no code example is available.

Parameters

interval

Type: ITimeInterval

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeIntervals Class
TimeIntervals Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeIntervals.AddRange Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub AddRange( _
   ByVal collection As IEnumerable(Of ITimeInterval) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void AddRange(
   IEnumerable<ITimeInterval> collection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void AddRange(
   IEnumerable<ITimeInterval^>^ collection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

collection

Type: IEnumerable<ITimeInterval>

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeIntervals Class
TimeIntervals Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeIntervals.GetEffortToSpecificDateTime Method

Calulates Effrot To Specific Time

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetEffortToSpecificDateTime( _
   ByVal totime As Date _
) As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan GetEffortToSpecificDateTime(
   DateTime totime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeSpan GetEffortToSpecificDateTime(
   DateTime totime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetEffortToSpecificDateTime(
    totime : DateTime
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

totime

Type: DateTime

Return Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeIntervals Class
TimeIntervals Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeIntervals.GetEffortFromSpecificDateTime Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetEffortFromSpecificDateTime( _
   ByVal fromTime As Date _
) As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan GetEffortFromSpecificDateTime(
   DateTime fromTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeSpan GetEffortFromSpecificDateTime(
   DateTime fromTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetEffortFromSpecificDateTime(
    fromTime : DateTime
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

fromTime

Type: DateTime

Return Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeIntervals Class
TimeIntervals Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeIntervals.GetFinish Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetFinish( _
   ByVal fromTime As Date, _
   ByVal Effort As TimeSpan _
) As Nullable(Of Date)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Nullable<DateTime> GetFinish(
   DateTime fromTime,
   TimeSpan Effort
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Nullable<DateTime> GetFinish(
   DateTime fromTime,
   TimeSpan Effort
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

fromTime

Type: DateTime

Effort

Type: TimeSpan

Return Value

Type: Nullable<DateTime>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeIntervals Class
TimeIntervals Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeIntervals.TrimIntervals Method

This method Trims interval ba start and End Date

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function TrimIntervals( _
   ByVal start As Date, _
   ByVal finish As Date _
) As TimeIntervals
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeIntervals TrimIntervals(
   DateTime start,
   DateTime finish
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeIntervals^ TrimIntervals(
   DateTime start,
   DateTime finish
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function TrimIntervals(
    start : DateTime,
    finish : DateTime
) : TimeIntervals;
This language is not supported or no code example is available.

Parameters

start

Type: DateTime

finish

Type: DateTime

Return Value

Type: TimeIntervals
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeIntervals Class
TimeIntervals Members
CompuTec.ProcessForce.API.Scheduling Namespace


BulkUdoConverter.GetBulkObjects<T, K> (String, ObjectTypes, IEnumerable<T>) Method

Gets list Of Udo Object of specified type based on Key collection

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetBulkObjects(Of  _
   K)( _
   ByVal Token As String, _
   ByVal type As ObjectTypes, _
   ByVal keys As IEnumerable(Of T) _
) As List(Of K)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static List<K> GetBulkObjects<K>(
   string Token,
   ObjectTypes type,
   IEnumerable<T> keys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
generic<typename K>
public:
static List<K^>^ GetBulkObjects(
   String^ Token,
   ObjectTypes type,
   IEnumerable<T^>^ keys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Type Parameters

K

Parameters

Token

Type: string

Database Token

type

Type: ObjectTypes

Type of Udo object

keys

Type: IEnumerable<T>

Keys collection Code or DocEntry

Return Value

Type: List<K>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BulkUdoConverter Class
BulkUdoConverter Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ItemUtils
    Inherits ItemUtils
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemUtils : ItemUtils
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ItemUtils : public ItemUtils^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemUtils
   extends ItemUtils
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils Members

ItemUtils Class Methods See Also

The following tables list the members exposed by the ItemUtils type.

Methods
Name | Description
AutoIssue |
AutoReceipt |
CheckDefaultWarehouse | Checks if a default warehouse is defined for an item.
CheckRevisionUsability | Checks if the combination of an item and revision corresponds to any of available bill of materials.
ExistsItemIngredientMasterData | Checks if specific ItemCode and Revisoon have ItemIngredientData object
GetAdditionalBatchDetailsTableCode |
GetBatchQueueType |
GetBusinessPartnerContactName |
GetBusinessPartnerName |
GetCoproductReevaluationType |
GetDoublePrcesision |
GetItemCostForCostCategory000 | Gets the total cost defined for a specified item and for the cost category '000'.
GetItemEvaluationType |
GetItemGroupCode |
GetItemGroups |
GetItemNonDropShipWarehouses |
GetItemProcurementMethod |
GetItemUoM |
GetMinMaxQty |
GetMorBranchCode |
GetMorBranchName |
GetNonDropShipWarehouses |
GetPriceLists |
GetReceiptReevaluationType |
GetRevisionName |
GetReworkReasonName |
GetScrapReasonName |
GetScrapReevaluationType |
GetWarehouseName |
IsBom |
IsNotStockAndPPurchaseItem |
IsRevisionUsedInBOM | Checks if specific ItemCode and Revisoon is used in BOM object
IsStockItem |
IsurchaseItem |
ValidateDistributionRules | Returns Information about warehouse collection
ValidateItemAndRevisions | Returns Information about warehouse collection
ValidateOperations | Returns Information about warehouse collection
ValidateResources | Returns Information about warehouse collection
ValidateWarehouses | Returns Information about warehouse collection
Top
Classes
 | Name | Description
Public class | Costing |
Public class | ItemDetails |
Public class | ItemRevisionInfo |
Public class | Maintanance |
Public class | SubContracting |
Public class | Technology |
Top
See Also

Reference

ItemUtils Class
CompuTec.ProcessForce.API.Tools Namespace


ItemUtils.GetMinMaxQty Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub GetMinMaxQty( _
   ByVal Token As String, _
   ByVal ItemCOde As String, _
   ByRef minOrderQty As Double, _
   ByRef maxOrderQty As Double, _
   ByRef ordrMultiQty As Double _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void GetMinMaxQty(
   string Token,
   string ItemCOde,
   ref double minOrderQty,
   ref double maxOrderQty,
   ref double ordrMultiQty
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void GetMinMaxQty(
   String^ Token,
   String^ ItemCOde,
   double& minOrderQty,
   double& maxOrderQty,
   double& ordrMultiQty
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetMinMaxQty(
    Token : String,
    ItemCOde : String,
    minOrderQty : double,
    maxOrderQty : double,
    ordrMultiQty : double
);
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCOde

Type: string

minOrderQty

Type: double

maxOrderQty

Type: double

ordrMultiQty

Type: double

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemUtils Class
ItemUtils Members
CompuTec.ProcessForce.API.Tools Namespace


Maintanance Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class Maintanance
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Maintanance
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class Maintanance
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Maintanance
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.ItemUtils.Maintanance
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Maintanance Members
CompuTec.ProcessForce.API.Tools Namespace


Maintanance Members

Maintanance Class Methods See Also

The following tables list the members exposed by the Maintanance type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | GetDownTimeReasonName |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

Maintanance Class
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemPhraseTableCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemPhraseTableCode( _
   ByVal token As String, _
   ByVal code As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemPhraseTableCode(
   string token,
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemPhraseTableCode(
   String^ token,
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemPhraseTableCode(
    token : String,
    code : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

code

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemPhraseName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemPhraseName( _
   ByVal token As String, _
   ByVal code As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemPhraseName(
   string token,
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemPhraseName(
   String^ token,
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemPhraseName(
    token : String,
    code : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

code

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemClassificationGroupTableCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemClassificationGroupTableCode( _
   ByVal token As String, _
   ByVal groupCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemClassificationGroupTableCode(
   string token,
   string groupCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemClassificationGroupTableCode(
   String^ token,
   String^ groupCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemClassificationGroupTableCode(
    token : String,
    groupCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

groupCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemClassificationGroupName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemClassificationGroupName( _
   ByVal token As String, _
   ByVal groupCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemClassificationGroupName(
   string token,
   string groupCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemClassificationGroupName(
   String^ token,
   String^ groupCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemClassificationGroupName(
    token : String,
    groupCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

groupCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemGroupGroupTableCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemGroupGroupTableCode( _
   ByVal token As String, _
   ByVal groupCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemGroupGroupTableCode(
   string token,
   string groupCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemGroupGroupTableCode(
   String^ token,
   String^ groupCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemGroupGroupTableCode(
    token : String,
    groupCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

groupCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemGroupGroupName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemGroupGroupName( _
   ByVal token As String, _
   ByVal groupCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemGroupGroupName(
   string token,
   string groupCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemGroupGroupName(
   String^ token,
   String^ groupCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemGroupGroupName(
    token : String,
    groupCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

groupCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemDetailPropertyName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemDetailPropertyName( _
   ByVal Token As String, _
   ByVal PropertyCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemDetailPropertyName(
   string Token,
   string PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemDetailPropertyName(
   String^ Token,
   String^ PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemDetailPropertyName(
    Token : String,
    PropertyCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

PropertyCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemDetailPropertyTableCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemDetailPropertyTableCode( _
   ByVal Token As String, _
   ByVal PropertyCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemDetailPropertyTableCode(
   string Token,
   string PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemDetailPropertyTableCode(
   String^ Token,
   String^ PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemDetailPropertyTableCode(
    Token : String,
    PropertyCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

PropertyCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemDetailPropertyUOM Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemDetailPropertyUOM( _
   ByVal Token As String, _
   ByVal PropertyCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemDetailPropertyUOM(
   string Token,
   string PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemDetailPropertyUOM(
   String^ Token,
   String^ PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemDetailPropertyUOM(
    Token : String,
    PropertyCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

PropertyCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetWordCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetWordCode( _
   ByVal Token As String, _
   ByVal WordCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetWordCode(
   string Token,
   string WordCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetWordCode(
   String^ Token,
   String^ WordCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetWordCode(
    Token : String,
    WordCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

WordCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemDetailCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemDetailCode( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemDetailCode(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemDetailCode(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemDetailCode(
    Token : String,
    ItemCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemDetailWordName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemDetailWordName( _
   ByVal Token As String, _
   ByVal PropertyCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemDetailWordName(
   string Token,
   string PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemDetailWordName(
   String^ Token,
   String^ PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemDetailWordName(
    Token : String,
    PropertyCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

PropertyCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


YieldFormulasClass.YieldFormula Property

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property YieldFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string YieldFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ YieldFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get YieldFormula() : String;
public function set YieldFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

YieldFormulasClass Class
YieldFormulasClass Members
CompuTec.ProcessForce.API.Tools Namespace


YieldFormulasClass.CoProductYieldFormula Property

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property CoProductYieldFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string CoProductYieldFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ CoProductYieldFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get CoProductYieldFormula() : String;
public function set CoProductYieldFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

YieldFormulasClass Class
YieldFormulasClass Members
CompuTec.ProcessForce.API.Tools Namespace


YieldFormulasClass.ByProductYieldFormula Property

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ByProductYieldFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ByProductYieldFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ByProductYieldFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ByProductYieldFormula() : String;
public function set ByProductYieldFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

YieldFormulasClass Class
YieldFormulasClass Members
CompuTec.ProcessForce.API.Tools Namespace


YieldFormulasClass.ScrapYieldFormula Property

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property ScrapYieldFormula() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string ScrapYieldFormula {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ ScrapYieldFormula {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get ScrapYieldFormula() : String;
public function set ScrapYieldFormula(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

YieldFormulasClass Class
YieldFormulasClass Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetSubChildQty (String, String, Double) Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetSubChildQty( _
   ByVal token As String, _
   ByVal itemcode As String, _
   ByVal quantity As Double _
) As List(Of Double)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static List<double> GetSubChildQty(
   string token,
   string itemcode,
   double quantity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static List<double>^ GetSubChildQty(
   String^ token,
   String^ itemcode,
   double quantity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

itemcode

Type: string

quantity

Type: double

Return Value

Type: List<double>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetSubChildQty Method

Technology Class See Also

Overload List
Name | Description
GetSubChildQty(string, string, double) |
GetSubChildQty(string, string, double, bool, bool) |
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetSubChildQty (String, String, Double, Boolean, Boolean) Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetSubChildQty( _
   ByVal token As String, _
   ByVal itemcode As String, _
   ByVal quantity As Double, _
   ByVal includeMRPsetting As Boolean, _
   ByVal includeMaxQty As Boolean _
) As List(Of Double)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static List<double> GetSubChildQty(
   string token,
   string itemcode,
   double quantity,
   bool includeMRPsetting,
   bool includeMaxQty
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static List<double>^ GetSubChildQty(
   String^ token,
   String^ itemcode,
   double quantity,
   bool includeMRPsetting,
   bool includeMaxQty
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

itemcode

Type: string

quantity

Type: double

includeMRPsetting

Type: bool

includeMaxQty

Type: bool

Return Value

Type: List<double>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetResourcePropertyCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResourcePropertyCode( _
   ByVal Token As String, _
   ByVal RscPrpCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResourcePropertyCode(
   string Token,
   string RscPrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResourcePropertyCode(
   String^ Token,
   String^ RscPrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResourcePropertyCode(
    Token : String,
    RscPrpCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

RscPrpCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetResourceName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResourceName( _
   ByVal Token As String, _
   ByVal RscCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResourceName(
   string Token,
   string RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResourceName(
   String^ Token,
   String^ RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResourceName(
    Token : String,
    RscCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

RscCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetResourceCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResourceCode( _
   ByVal Token As String, _
   ByVal RscCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResourceCode(
   string Token,
   string RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResourceCode(
   String^ Token,
   String^ RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResourceCode(
    Token : String,
    RscCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

RscCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetIssueMethod Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetIssueMethod( _
   ByVal Token As String, _
   ByVal RscCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetIssueMethod(
   string Token,
   string RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetIssueMethod(
   String^ Token,
   String^ RscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetIssueMethod(
    Token : String,
    RscCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

RscCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetOperationPropertyName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetOperationPropertyName( _
   ByVal Token As String, _
   ByVal PrpCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetOperationPropertyName(
   string Token,
   string PrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetOperationPropertyName(
   String^ Token,
   String^ PrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetOperationPropertyName(
    Token : String,
    PrpCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

PrpCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetOperationPropertyCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetOperationPropertyCode( _
   ByVal Token As String, _
   ByVal PrpCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetOperationPropertyCode(
   string Token,
   string PrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetOperationPropertyCode(
   String^ Token,
   String^ PrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetOperationPropertyCode(
    Token : String,
    PrpCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

PrpCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


ISupplyGenerator.CanGenerateSupply (LinkedListNode<IMRPEntity>, IScenario) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CanGenerateSupply( _
   ByVal entity As LinkedListNode(Of IMRPEntity), _
   ByVal configuration As IScenario _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool CanGenerateSupply(
   LinkedListNode<IMRPEntity> entity,
   IScenario configuration
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool CanGenerateSupply(
   LinkedListNode<IMRPEntity^>^ entity,
   IScenario^ configuration
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

entity

Type: LinkedListNode<IMRPEntity>

configuration

Type: IScenario

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplyGenerator Interface
ISupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


PurchaseGenerator.CanGenerateSupply (ItemManager, IScenario) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CanGenerateSupply( _
   ByVal pathItem As ItemManager, _
   ByVal scenario As IScenario _
) As Boolean Implements  _
   ISupplyGenerator.CanGenerateSupply
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool CanGenerateSupply(
   ItemManager pathItem,
   IScenario scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool CanGenerateSupply(
   ItemManager^ pathItem,
   IScenario^ scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CanGenerateSupply(
    pathItem : ItemManager,
    scenario : IScenario
) : boolean;
This language is not supported or no code example is available.

Parameters

pathItem

Type: ItemManager

scenario

Type: IScenario

Return Value

Type: bool

Implements

ISupplyGenerator.CanGenerateSupply
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseGenerator Class
PurchaseGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


PurchaseGenerator.CanGenerateSupply (LinkedListNode<IMRPEntity>, IScenario) Method

Working

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CanGenerateSupply( _
   ByVal entity As LinkedListNode(Of IMRPEntity), _
   ByVal configuration As IScenario _
) As Boolean Implements  _
   ISupplyGenerator.CanGenerateSupply
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool CanGenerateSupply(
   LinkedListNode<IMRPEntity> entity,
   IScenario configuration
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool CanGenerateSupply(
   LinkedListNode<IMRPEntity^>^ entity,
   IScenario^ configuration
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

entity

Type: LinkedListNode<IMRPEntity>

configuration

Type: IScenario

Return Value

Type: bool

Implements

ISupplyGenerator.CanGenerateSupply
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseGenerator Class
PurchaseGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


WrongItemManagerException Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Exceptions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public WrongItemManagerException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
WrongItemManagerException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function WrongItemManagerException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WrongItemManagerException Class
WrongItemManagerException Members
CompuTec.ProcessForce.API.Tools.MRP.Exceptions Namespace


WrongItemManagerException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Exceptions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public WrongItemManagerException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
WrongItemManagerException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function WrongItemManagerException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WrongItemManagerException Class
WrongItemManagerException Members
CompuTec.ProcessForce.API.Tools.MRP.Exceptions Namespace


WrongItemManagerException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Exceptions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public WrongItemManagerException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
WrongItemManagerException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function WrongItemManagerException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WrongItemManagerException Class
WrongItemManagerException Members
CompuTec.ProcessForce.API.Tools.MRP.Exceptions Namespace


ItemPath.RecalculateCumulaiveQuantity (LinkedListNode<IMRPEntity>) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub RecalculateCumulaiveQuantity( _
   ByVal startItem As LinkedListNode(Of IMRPEntity) _
) Implements  _
   IPathItem.RecalculateCumulaiveQuantity
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void RecalculateCumulaiveQuantity(
   LinkedListNode<IMRPEntity> startItem
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void RecalculateCumulaiveQuantity(
   LinkedListNode<IMRPEntity^>^ startItem
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

startItem

Type: LinkedListNode<IMRPEntity>

Implements

IPathItem.RecalculateCumulaiveQuantity
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath.GetAvailbleQuantityForDate (DateTime) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAvailbleQuantityForDate( _
   ByVal dateTime As Date _
) As Decimal Implements  _
   IPathItem.GetAvailbleQuantityForDate
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal GetAvailbleQuantityForDate(
   DateTime dateTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Decimal GetAvailbleQuantityForDate(
   DateTime dateTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAvailbleQuantityForDate(
    dateTime : DateTime
) : decimal;
This language is not supported or no code example is available.

Parameters

dateTime

Type: DateTime

Return Value

Type: decimal

Implements

IPathItem.GetAvailbleQuantityForDate
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath.GetAvailbleQuantityForDate (DateTime, IMRPEntity) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetAvailbleQuantityForDate( _
   ByVal date As Date, _
   ByVal entity As IMRPEntity _
) As Decimal Implements  _
   IPathItem.GetAvailbleQuantityForDate
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public decimal GetAvailbleQuantityForDate(
   DateTime date,
   IMRPEntity entity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Decimal GetAvailbleQuantityForDate(
   DateTime date,
   IMRPEntity^ entity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetAvailbleQuantityForDate(
    date : DateTime,
    entity : IMRPEntity
) : decimal;
This language is not supported or no code example is available.

Parameters

date

Type: DateTime

entity

Type: IMRPEntity

Return Value

Type: decimal

Implements

IPathItem.GetAvailbleQuantityForDate
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ByCompanyPathSelectorRule.GetPath (ItemManager, String, String, String) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetPath( _
   ByVal itemManager As ItemManager, _
   ByVal itemCode As String, _
   ByVal revision As String, _
   ByVal whs As String _
) As IPathItem Implements  _
   IPathSelectorRule.GetPath
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IPathItem GetPath(
   ItemManager itemManager,
   string itemCode,
   string revision,
   string whs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IPathItem^ GetPath(
   ItemManager^ itemManager,
   String^ itemCode,
   String^ revision,
   String^ whs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetPath(
    itemManager : ItemManager,
    itemCode : String,
    revision : String,
    whs : String
) : IPathItem;
This language is not supported or no code example is available.

Parameters

itemManager

Type: ItemManager

itemCode

Type: string

revision

Type: string

whs

Type: string

Return Value

Type: IPathItem

Implements

IPathSelectorRule.GetPath
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ByCompanyPathSelectorRule Class
ByCompanyPathSelectorRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


ByCompanyPathSelectorRule.GetPath (MRPManager, String, String, String) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetPath( _
   ByVal manager As MRPManager, _
   ByVal itemCode As String, _
   ByVal revision As String, _
   ByVal whs As String _
) As IPathItem Implements  _
   IPathSelectorRule.GetPath
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IPathItem GetPath(
   MRPManager manager,
   string itemCode,
   string revision,
   string whs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IPathItem^ GetPath(
   MRPManager^ manager,
   String^ itemCode,
   String^ revision,
   String^ whs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetPath(
    manager : MRPManager,
    itemCode : String,
    revision : String,
    whs : String
) : IPathItem;
This language is not supported or no code example is available.

Parameters

manager

Type: MRPManager

itemCode

Type: string

revision

Type: string

whs

Type: string

Return Value

Type: IPathItem

Implements

IPathSelectorRule.GetPath
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ByCompanyPathSelectorRule Class
ByCompanyPathSelectorRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


BasicValueValidatorException Constructor

Namespace: CompuTec.ProcessForce.API.Core.Structures
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BasicValueValidatorException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BasicValueValidatorException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BasicValueValidatorException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BasicValueValidatorException Class
BasicValueValidatorException Members
CompuTec.ProcessForce.API.Core.Structures Namespace


SalesInternalLeadTimeRule.CalculateLeadTime (IPathItem, IDocLine) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CalculateLeadTime( _
   ByVal path As IPathItem, _
   ByVal docLine As IDocLine _
) As TimeSpan Implements  _
   IInternalLeadTimeRule.CalculateLeadTime
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan CalculateLeadTime(
   IPathItem path,
   IDocLine docLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeSpan CalculateLeadTime(
   IPathItem^ path,
   IDocLine^ docLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CalculateLeadTime(
    path : IPathItem,
    docLine : IDocLine
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

path

Type: IPathItem

docLine

Type: IDocLine

Return Value

Type: TimeSpan

Implements

IInternalLeadTimeRule.CalculateLeadTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SalesInternalLeadTimeRule Class
SalesInternalLeadTimeRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


WhsIntenalLeadTimeCalculator.CalculateLeadTime (ItemManager, IDocLine) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CalculateLeadTime( _
   ByVal itemManager As ItemManager, _
   ByVal docLine As IDocLine _
) As TimeSpan Implements  _
   IInternalLeadTimeRule.CalculateLeadTime
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan CalculateLeadTime(
   ItemManager itemManager,
   IDocLine docLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeSpan CalculateLeadTime(
   ItemManager^ itemManager,
   IDocLine^ docLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CalculateLeadTime(
    itemManager : ItemManager,
    docLine : IDocLine
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

itemManager

Type: ItemManager

docLine

Type: IDocLine

Return Value

Type: TimeSpan

Implements

IInternalLeadTimeRule.CalculateLeadTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WhsIntenalLeadTimeCalculator Class
WhsIntenalLeadTimeCalculator Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


WhsIntenalLeadTimeCalculator.CalculateLeadTime (IPathItem, IDocLine) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CalculateLeadTime( _
   ByVal path As IPathItem, _
   ByVal docLine As IDocLine _
) As TimeSpan Implements  _
   IInternalLeadTimeRule.CalculateLeadTime
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan CalculateLeadTime(
   IPathItem path,
   IDocLine docLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeSpan CalculateLeadTime(
   IPathItem^ path,
   IDocLine^ docLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CalculateLeadTime(
    path : IPathItem,
    docLine : IDocLine
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

path

Type: IPathItem

docLine

Type: IDocLine

Return Value

Type: TimeSpan

Implements

IInternalLeadTimeRule.CalculateLeadTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WhsIntenalLeadTimeCalculator Class
WhsIntenalLeadTimeCalculator Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


BasicValueValidatorException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Core.Structures
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BasicValueValidatorException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BasicValueValidatorException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BasicValueValidatorException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BasicValueValidatorException Class
BasicValueValidatorException Members
CompuTec.ProcessForce.API.Core.Structures Namespace


UdoTools Class

Members See Also

Tools used on udo

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class UdoTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static class UdoTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class UdoTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class UdoTools
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.UdoTools
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UdoTools Members
CompuTec.ProcessForce.API.Tools Namespace


UdoTools Members

UdoTools Class Methods See Also

Tools used on udo

The following tables list the members exposed by the UdoTools type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Classes
 | Name | Description
Public class | SapDataTableBox | Box for SAPbouiCOM.DataTable object
Top
Enumerations
 | Name | Description
Public enumeration | BoLoadToMode | Specifies way to "loadToForm"
Top
See Also

Reference

UdoTools Class
CompuTec.ProcessForce.API.Tools Namespace


SapDataTableBox Class

Members See Also

Box for SAPbouiCOM.DataTable object

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SapDataTableBox
    Implements IDisposable
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SapDataTableBox : IDisposable
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SapDataTableBox  : public IDisposable^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SapDataTableBox
   implements IDisposable
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.UdoTools.SapDataTableBox
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SapDataTableBox Members
CompuTec.ProcessForce.API.Tools Namespace


SapDataTableBox Members

SapDataTableBox Class Constructors Methods Fields See Also

Box for SAPbouiCOM.DataTable object

The following tables list the members exposed by the SapDataTableBox type.

Constructors
 | Name | Description
Public constructor | SapDataTableBox |
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | dt |
Top
See Also

Reference

SapDataTableBox Class
CompuTec.ProcessForce.API.Tools Namespace


dt Field

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public dt As DataTable
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DataTable dt
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DataTable^ dt;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public dt : DataTable
This language is not supported or no code example is available.

Field Value

Type: DataTable
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SapDataTableBox Class
SapDataTableBox Members
CompuTec.ProcessForce.API.Tools Namespace


SapDataTableBox Constructor

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal dt As DataTable _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SapDataTableBox(
   DataTable dt
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SapDataTableBox(
   DataTable^ dt
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SapDataTableBox(
    dt : DataTable
);
This language is not supported or no code example is available.

Parameters

dt

Type: DataTable

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SapDataTableBox Class
SapDataTableBox Members
CompuTec.ProcessForce.API.Tools Namespace


SapDataTableBox.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Dispose() Implements  _
   IDisposable.Dispose
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Dispose()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Dispose()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Dispose();
This language is not supported or no code example is available.

Implements

IDisposable.Dispose
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SapDataTableBox Class
SapDataTableBox Members
CompuTec.ProcessForce.API.Tools Namespace


BasicValueValidatorException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Core.Structures
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BasicValueValidatorException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BasicValueValidatorException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BasicValueValidatorException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BasicValueValidatorException Class
BasicValueValidatorException Members
CompuTec.ProcessForce.API.Core.Structures Namespace


CompuTec.ProcessForce.API.UI Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | FormOpener |
Public class | MenuUniqueIds | Represents the unique ID values of ProcessForce's menu items in SAP Business One main menu.
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


FormOpener Class

Members See Also

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class FormOpener
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class FormOpener
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class FormOpener
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class FormOpener
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.UI.FormOpener
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


FormOpener Members

FormOpener Class Methods Fields See Also

The following tables list the members exposed by the FormOpener type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | FindFormAndRefresh | This method serches forms by FormType And Load the same value Again
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | OpanItemMasterData |
 | OpenBatchNumberTransactionReport |
 | OpenBillOfMaterials | Opens Bill Of Materials given item code and revision
 | OpenBillOfMaterialsTechnology |
 | OpenBinLocContentList |
 | OpenDocumentForm | (Overloaded)
 | OpenFormByMenuUID |
 | OpenItemDetails | Opens Item Details given item code
 | OpenMasterDataForm | (Overloaded)
 | OpenSupplierScoreCard |
 | OpenSupplierScoreCardReturnForm |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
Name | Description
HideSelection |
Top
See Also

Reference

FormOpener Class
CompuTec.ProcessForce.API.UI Namespace


FormOpener.OpanItemMasterData Method

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub OpanItemMasterData( _
   ByVal ItemCode As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void OpanItemMasterData(
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void OpanItemMasterData(
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function OpanItemMasterData(
    ItemCode : String
);
This language is not supported or no code example is available.

Parameters

ItemCode

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FormOpener Class
FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


FormOpener.OpenBinLocContentList Method

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub OpenBinLocContentList( _
   ByVal BinLocation As String, _
   ByVal ItemCode As String, _
   ByVal DistNumber As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void OpenBinLocContentList(
   string BinLocation,
   string ItemCode,
   string DistNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void OpenBinLocContentList(
   String^ BinLocation,
   String^ ItemCode,
   String^ DistNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function OpenBinLocContentList(
    BinLocation : String,
    ItemCode : String,
    DistNumber : String
);
This language is not supported or no code example is available.

Parameters

BinLocation

Type: string

ItemCode

Type: string

DistNumber

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FormOpener Class
FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


HideSelection Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared HideSelection As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool HideSelection
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool HideSelection;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static HideSelection : boolean
This language is not supported or no code example is available.

Field Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FormOpener Class
FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


UDOCodeGeneratorEx Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class UDOCodeGeneratorEx
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class UDOCodeGeneratorEx
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class UDOCodeGeneratorEx
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class UDOCodeGeneratorEx
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Core.UDOCodeGeneratorEx
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UDOCodeGeneratorEx Members
CompuTec.ProcessForce.API.Core Namespace


UDOCodeGeneratorEx Members

UDOCodeGeneratorEx Class Constructors Methods See Also

The following tables list the members exposed by the UDOCodeGeneratorEx type.

Constructors
 | Name | Description
Public constructor | UDOCodeGeneratorEx |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | IncrementNewCode |
Public method | NextCode | (Overloaded)
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

UDOCodeGeneratorEx Class
CompuTec.ProcessForce.API.Core Namespace


FormOpener.OpenBillOfMaterialsTechnology Method

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub OpenBillOfMaterialsTechnology( _
   ByVal itemCode As String, _
   ByVal revision As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void OpenBillOfMaterialsTechnology(
   string itemCode,
   string revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void OpenBillOfMaterialsTechnology(
   String^ itemCode,
   String^ revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function OpenBillOfMaterialsTechnology(
    itemCode : String,
    revision : String
);
This language is not supported or no code example is available.

Parameters

itemCode

Type: string

revision

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FormOpener Class
FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


FormOpener.OpenSupplierScoreCard Method

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub OpenSupplierScoreCard( _
   ByVal bpcode As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void OpenSupplierScoreCard(
   string bpcode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void OpenSupplierScoreCard(
   String^ bpcode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function OpenSupplierScoreCard(
    bpcode : String
);
This language is not supported or no code example is available.

Parameters

bpcode

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FormOpener Class
FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


FormOpener.OpenSupplierScoreCardReturnForm Method

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function OpenSupplierScoreCardReturnForm( _
   ByVal bpcode As String _
) As Form
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Form OpenSupplierScoreCardReturnForm(
   string bpcode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static Form^ OpenSupplierScoreCardReturnForm(
   String^ bpcode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function OpenSupplierScoreCardReturnForm(
    bpcode : String
) : Form;
This language is not supported or no code example is available.

Parameters

bpcode

Type: string

Return Value

Type: Form
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FormOpener Class
FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


FormOpener.OpenBillOfMaterials Method

Opens Bill Of Materials given item code and revision

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub OpenBillOfMaterials( _
   ByVal itemCode As String, _
   ByVal revision As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void OpenBillOfMaterials(
   string itemCode,
   string revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void OpenBillOfMaterials(
   String^ itemCode,
   String^ revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function OpenBillOfMaterials(
    itemCode : String,
    revision : String
);
This language is not supported or no code example is available.

Parameters

itemCode

Type: string

revision

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FormOpener Class
FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


MenuUniqueIds Class

Members See Also

Represents the unique ID values of ProcessForce's menu items in SAP Business One main menu.

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MenuUniqueIds
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MenuUniqueIds
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MenuUniqueIds
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MenuUniqueIds
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.UI.MenuUniqueIds
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


MenuUniqueIds Members

MenuUniqueIds Class Methods Fields See Also

Represents the unique ID values of ProcessForce's menu items in SAP Business One main menu.

The following tables list the members exposed by the MenuUniqueIds type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Classes
 | Name | Description
Public class | GlobalContextMenu | Represents the unique ID values of ProcessForce's global context menu items.
Top
Fields
 | Name | Description
Public field | AboutScreen |
Public field | ActivitiReport |
Public field | AddMorRowsToScheduling |
Public field | AdditionalBatchDetails |
Public field | Allergen |
Public field | BatchGenerator |
Public field | BatchTemplate |
Public field | BatchTraceHistory |
Public field | BatchTraceabilityDetails |
Public field | BatchTraceabilityPert |
Public field | BatchTraceabilitySelectionCriteria |
Public field | BillOfMaterialReport |
Public field | BillOfMaterialReportCriteria |
Public field | BillOfMaterialReportCriteria2 |
Public field | BillOfMaterials |
Public field | BillOfMaterialsTechnology |
Public field | BusinessPartnerRelations |
Public field | BussinesPartnerRelation |
Public field | CalendarTemplate |
Public field | CapacityCalendar |
Public field | Category |
Public field | Class |
Public field | Complaint |
Public field | ComplaintGroup |
Public field | ComplaintReason |
Public field | Configuration |
Public field | CostCategory |
Public field | CostRollOver |
Public field | CostRollUp |
Public field | CostRollUpSummary |
Public field | CostedBillOfMaterials |
Public field | CostedBillOfMaterialsSelectionCriteria |
Public field | CostedManufacturingOrder |
Public field | CostedResource |
Public field | CostingConfiguration |
Public field | CostingCostCategory |
Public field | CostsComparison |
Public field | CreatedRecommendations |
Public field | DefectGroup |
Public field | Defects |
Public field | Details |
Public field | DocumentStatusChangeWizzard |
Public field | DownTime |
Public field | DownTimeReasonCodes |
Public field | EmployeeCalendar |
Public field | EmployeeCalendarTool |
Public field | EmployeeCalendarView |
Public field | ExpityDateTemplate |
Public field | ExpityDateValidation |
Public field | Forecast |
Public field | GenerateForecast |
Public field | HelpConfig |
Public field | IngredientClassification |
Public field | IngredientClassificationType |
Public field | IngredientDailyValue |
Public field | IngredientMasterData |
Public field | IngredientTemplate |
Public field | Ingredients |
Public field | IngredientsCategory |
Public field | InitialDataCreator |
Public field | InspectorGroup |
Public field | Inspectors |
Public field | InstallationHistory |
Public field | InventoryRegistry |
Public field | ItemClassification |
Public field | ItemClassificationGroup |
Public field | ItemCosting |
Public field | ItemCostingOverheadCosts |
Public field | ItemDetails |
Public field | ItemGroup |
Public field | ItemGroupGroup |
Public field | ItemIngredientData |
Public field | ItemMassReplace |
Public field | ItemMasterDataLocations |
Public field | ItemPhrases |
Public field | ItemPhrasesGroup |
Public field | ItemPropertiesSelector |
Public field | ItemProperty |
Public field | ItemPropertyGroups |
Public field | ItemText |
Public field | ItemTextGroup |
Public field | ItemsPropertiesSelector |
Public field | ItemsTestProtocols |
Public field | Labels |
Public field | LabourGroup |
Public field | LabourRates |
Public field | LicenceAssignment |
Public field | LicensePlateGroups |
Public field | LicensePlates |
Public field | LocationAttribute |
Public field | Locations |
Public field | MORScheduleResultsForm |
Public field | ManufacturingOrderActualTaskReportReport |
Public field | ManufacturingOrderManager |
Public field | ManufacturingOrderOperationBindigsRecordedValuesReport |
Public field | ManufacturingOrderOperationRecordedValuesReport |
Public field | ManufacturingOrderResourceRecorderValuesReport |
Public field | ManufacturingOrderSplit |
Public field | ManufacturingOrderTimeRecordingReport |
Public field | ManufacturingOrders |
Public field | ManufacturingRelations |
Public field | MenuConfigurator |
Public field | MrpRecommendations |
Public field | MrpSelectionCriteria |
Public field | MultipleManufacturingOrderUpdate |
Public field | MultipleTestResults |
Public field | NcmrInspectors |
Public field | NcmrReasons |
Public field | NcmrTransaction |
Public field | NutrientMasterData |
Public field | OpeningAndClosingRemarks |
Public field | OperationInputOutputProperties |
Public field | OperationProperties |
Public field | OperationRelationPert |
Public field | OperationTimeRecording |
Public field | OperationTimeRecordingAdjReasons |
Public field | OperationTimeRecordingAdjustment |
Public field | OperationTimeRecordingReasons |
Public field | Operations |
Public field | OrderRecommendationErrors |
Public field | OrderlessProductionDocument |
Public field | OrderlessProductionTemplate |
Public field | PDCSettings |
Public field | PickOrders |
Public field | PickReceipt |
Public field | PreferredVendors |
Public field | PrintParams |
Public field | PrinterLabelDefintion |
Public field | PrinterMasterDataUniqueId |
Public field | ProductionReceipts |
Public field | QCMaterialReportForm |
Public field | QCPoolBatchReportForm |
Public field | QCTReport |
Public field | QCTResult |
Public field | QualityControlReports |
Public field | QualityControlTest |
Public field | QualityControlTestPool |
Public field | QualityControlTestReport |
Public field | QualityControlTestsCreationWizard |
Public field | ReasonCodes |
Public field | ReasonGroup |
Public field | ReasonGroups |
Public field | Reasons |
Public field | ResourceCalendar |
Public field | ResourceCalendarStandardHours |
Public field | ResourceCalendarTool |
Public field | ResourceCalendarView |
Public field | ResourceCosting |
Public field | ResourceCostingOverheadCosts |
Public field | ResourceGroups |
Public field | ResourcePlanningInfoForm |
Public field | ResourceProperties |
Public field | ResourceRates |
Public field | Resources |
Public field | ResourcesAccounting |
Public field | RestoreActualCostsForAllMORs |
Public field | RestoreAditionalBatchDetails |
Public field | RestoreBillOfMaterials |
Public field | RestoreEmployeeCalendars |
Public field | RestoreItemCosting |
Public field | RestoreItemDetails |
Public field | RestorePickDocumentReferences |
Public field | RestoreResourceCalendars |
Public field | RestoreResourceCosting |
Public field | ReworkReasonCodes |
Public field | RoutingOperationRelations |
Public field | Routings |
Public field | RunItemRevaluationForLastFailedRollOver |
Public field | Scheduling |
Public field | ScrapReasonCodes |
Public field | SemiCreationReportForm |
Public field | SerialGenerator |
Public field | SerialTemplate |
Public field | SeriesConfiguration |
Public field | Shifts |
Public field | SimpleProductionPlanning |
Public field | Squads |
Public field | SubcontractingMaterialReportForm |
Public field | SubcontractingProcurmentReportForm |
Public field | Substitutes |
Public field | SupplierScoreCard |
Public field | SynchronizeManufacturingOrders |
Public field | TestPropertiesSelector |
Public field | TestProperty |
Public field | TestPropertyGroup |
Public field | TestProtocol |
Public field | TestProtocolGroup |
Public field | TestProtocolTemplates |
Public field | TestReport |
Public field | TimeQuantityRegistration |
Public field | UpdateYield |
Public field | VehicleInspectionCheck |
Public field | VehicleInspectionCheckSales |
Public field | VehicleInspectionGroup |
Public field | VehicleInspectionReasons |
Public field | VisualiztionMorsRelations |
Public field | VisualiztionSchedulingBoard |
Public field | Wordbook |
Public field | WorkRegistration |
Top
See Also

Reference

MenuUniqueIds Class
CompuTec.ProcessForce.API.UI Namespace


GlobalContextMenu Class

Members See Also

Represents the unique ID values of ProcessForce's global context menu items.

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class GlobalContextMenu
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class GlobalContextMenu
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class GlobalContextMenu
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class GlobalContextMenu
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.UI.MenuUniqueIds.GlobalContextMenu
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GlobalContextMenu Members
CompuTec.ProcessForce.API.UI Namespace


GlobalContextMenu Members

GlobalContextMenu Class Methods Fields See Also

Represents the unique ID values of ProcessForce's global context menu items.

The following tables list the members exposed by the GlobalContextMenu type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | WhatsThis |
Top
See Also

Reference

GlobalContextMenu Class
CompuTec.ProcessForce.API.UI Namespace


UDOCodeGeneratorEx Constructor

Namespace: CompuTec.ProcessForce.API.Core
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal udoObject As IUDOBean, _
   Optional ByVal useLog As Boolean = true, _
   Optional ByVal fieldName As String = "Code" _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public UDOCodeGeneratorEx(
   IUDOBean udoObject,
   bool useLog = true,
   string fieldName = "Code"
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
UDOCodeGeneratorEx(
   IUDOBean^ udoObject,
   bool useLog,
   String^ fieldName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UDOCodeGeneratorEx(
    udoObject : IUDOBean,
    useLog : boolean,
    fieldName : String
);
This language is not supported or no code example is available.

Parameters

udoObject

Type: IUDOBean

useLog

Type: bool

fieldName

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UDOCodeGeneratorEx Class
UDOCodeGeneratorEx Members
CompuTec.ProcessForce.API.Core Namespace


ItemPhrases Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ItemPhrases As String = "CT_PF_35"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ItemPhrases = @"CT_PF_35"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ItemPhrases = "CT_PF_35";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ItemPhrases : String = "CT_PF_35"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ItemPhrasesGroup Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ItemPhrasesGroup As String = "CT_PF_36"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ItemPhrasesGroup = @"CT_PF_36"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ItemPhrasesGroup = "CT_PF_36";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ItemPhrasesGroup : String = "CT_PF_36"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ItemGroup Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ItemGroup As String = "CT_PF_37"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ItemGroup = @"CT_PF_37"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ItemGroup = "CT_PF_37";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ItemGroup : String = "CT_PF_37"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ItemGroupGroup Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ItemGroupGroup As String = "CT_PF_38"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ItemGroupGroup = @"CT_PF_38"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ItemGroupGroup = "CT_PF_38";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ItemGroupGroup : String = "CT_PF_38"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ItemText Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ItemText As String = "CT_PF_39"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ItemText = @"CT_PF_39"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ItemText = "CT_PF_39";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ItemText : String = "CT_PF_39"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ItemTextGroup Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ItemTextGroup As String = "CT_PF_40"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ItemTextGroup = @"CT_PF_40"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ItemTextGroup = "CT_PF_40";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ItemTextGroup : String = "CT_PF_40"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


TestReport Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const TestReport As String = "CT_PF_Test_Rep"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string TestReport = @"CT_PF_Test_Rep"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ TestReport = "CT_PF_Test_Rep";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const TestReport : String = "CT_PF_Test_Rep"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


PrintParams Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const PrintParams As String = "CT_PF_66"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string PrintParams = @"CT_PF_66"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ PrintParams = "CT_PF_66";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const PrintParams : String = "CT_PF_66"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


LicenceAssignment Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const LicenceAssignment As String = "CT_PF_67"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string LicenceAssignment = @"CT_PF_67"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ LicenceAssignment = "CT_PF_67";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const LicenceAssignment : String = "CT_PF_67"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ResourceCalendarView Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ResourceCalendarView As String = "CT_PF_RCVW"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ResourceCalendarView = @"CT_PF_RCVW"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ResourceCalendarView = "CT_PF_RCVW";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ResourceCalendarView : String = "CT_PF_RCVW"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


EmployeeCalendarView Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const EmployeeCalendarView As String = "CT_PF_ECVW"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string EmployeeCalendarView = @"CT_PF_ECVW"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ EmployeeCalendarView = "CT_PF_ECVW";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const EmployeeCalendarView : String = "CT_PF_ECVW"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ItemPropertiesSelector Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ItemPropertiesSelector As String = "CT_PF_IPSF"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ItemPropertiesSelector = @"CT_PF_IPSF"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ItemPropertiesSelector = "CT_PF_IPSF";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ItemPropertiesSelector : String = "CT_PF_IPSF"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


PrinterMasterDataUniqueId Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const PrinterMasterDataUniqueId As String = "CT_PF_62"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string PrinterMasterDataUniqueId = @"CT_PF_62"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ PrinterMasterDataUniqueId = "CT_PF_62";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const PrinterMasterDataUniqueId : String = "CT_PF_62"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


PrinterLabelDefintion Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const PrinterLabelDefintion As String = "CT_PF_63"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string PrinterLabelDefintion = @"CT_PF_63"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ PrinterLabelDefintion = "CT_PF_63";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const PrinterLabelDefintion : String = "CT_PF_63"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


BatchTemplate Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const BatchTemplate As String = "CT_PF_68"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string BatchTemplate = @"CT_PF_68"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ BatchTemplate = "CT_PF_68";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const BatchTemplate : String = "CT_PF_68"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


SerialTemplate Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const SerialTemplate As String = "CT_PF_69"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string SerialTemplate = @"CT_PF_69"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ SerialTemplate = "CT_PF_69";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const SerialTemplate : String = "CT_PF_69"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


CostingCostCategory Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const CostingCostCategory As String = "CT_PF_CCCT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string CostingCostCategory = @"CT_PF_CCCT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ CostingCostCategory = "CT_PF_CCCT";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const CostingCostCategory : String = "CT_PF_CCCT"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ItemCosting Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ItemCosting As String = "CT_PF_CITC"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ItemCosting = @"CT_PF_CITC"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ItemCosting = "CT_PF_CITC";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ItemCosting : String = "CT_PF_CITC"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Revision Constructor

Initializes a new instance of the Revision class.

Namespace: CompuTec.ProcessForce.API.Costing.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Revision()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Revision()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Revision();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Revision Class
Revision Members
CompuTec.ProcessForce.API.Costing.Data Namespace


RestoreResourceCosting Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const RestoreResourceCosting As String = "CT_PF_RestRCT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string RestoreResourceCosting = @"CT_PF_RestRCT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ RestoreResourceCosting = "CT_PF_RestRCT";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const RestoreResourceCosting : String = "CT_PF_RestRCT"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


RestoreResourceCalendars Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const RestoreResourceCalendars As String = "CT_PF_RestRCL"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string RestoreResourceCalendars = @"CT_PF_RestRCL"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ RestoreResourceCalendars = "CT_PF_RestRCL";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const RestoreResourceCalendars : String = "CT_PF_RestRCL"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


RestoreEmployeeCalendars Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const RestoreEmployeeCalendars As String = "CT_PF_RestECL"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string RestoreEmployeeCalendars = @"CT_PF_RestECL"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ RestoreEmployeeCalendars = "CT_PF_RestECL";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const RestoreEmployeeCalendars : String = "CT_PF_RestECL"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


RestoreAditionalBatchDetails Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const RestoreAditionalBatchDetails As String = "CT_PF_RestADB"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string RestoreAditionalBatchDetails = @"CT_PF_RestADB"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ RestoreAditionalBatchDetails = "CT_PF_RestADB";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const RestoreAditionalBatchDetails : String = "CT_PF_RestADB"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


RestoreBillOfMaterials Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const RestoreBillOfMaterials As String = "CT_PF_RestBOMD"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string RestoreBillOfMaterials = @"CT_PF_RestBOMD"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ RestoreBillOfMaterials = "CT_PF_RestBOMD";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const RestoreBillOfMaterials : String = "CT_PF_RestBOMD"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


SynchronizeManufacturingOrders Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const SynchronizeManufacturingOrders As String = "CT_PF_SyncMor"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string SynchronizeManufacturingOrders = @"CT_PF_SyncMor"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ SynchronizeManufacturingOrders = "CT_PF_SyncMor";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const SynchronizeManufacturingOrders : String = "CT_PF_SyncMor"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Revision(String, Boolean) Constructor

Initializes a new instance of the Revision class.

Namespace: CompuTec.ProcessForce.API.Costing.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal code As String, _
   ByVal isDefault As Boolean _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Revision(
   string code,
   bool isDefault
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Revision(
   String^ code,
   bool isDefault
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Revision(
    code : String,
    isDefault : boolean
);
This language is not supported or no code example is available.

Parameters

code

Type: string

Revision code.

isDefault

Type: bool

Determines whether revision is a default revision for a roll-over process.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Revision Class
Revision Members
CompuTec.ProcessForce.API.Costing.Data Namespace


SubcontractingProcurmentReportForm Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const SubcontractingProcurmentReportForm As String = "CT_PF_SUBCRpt"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string SubcontractingProcurmentReportForm = @"CT_PF_SUBCRpt"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ SubcontractingProcurmentReportForm = "CT_PF_SUBCRpt";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const SubcontractingProcurmentReportForm : String = "CT_PF_SUBCRpt"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


SubcontractingMaterialReportForm Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const SubcontractingMaterialReportForm As String = "CT_PF_SUBCMRpt"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string SubcontractingMaterialReportForm = @"CT_PF_SUBCMRpt"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ SubcontractingMaterialReportForm = "CT_PF_SUBCMRpt";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const SubcontractingMaterialReportForm : String = "CT_PF_SUBCMRpt"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


QCMaterialReportForm Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const QCMaterialReportForm As String = "CT_PF_QCCMRpt"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string QCMaterialReportForm = @"CT_PF_QCCMRpt"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ QCMaterialReportForm = "CT_PF_QCCMRpt";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const QCMaterialReportForm : String = "CT_PF_QCCMRpt"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


AboutScreen Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const AboutScreen As String = "CT_PF_AboutScreen"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string AboutScreen = @"CT_PF_AboutScreen"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ AboutScreen = "CT_PF_AboutScreen";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const AboutScreen : String = "CT_PF_AboutScreen"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


InstallationHistory Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const InstallationHistory As String = "CT_PF_InstallationHistory"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string InstallationHistory = @"CT_PF_InstallationHistory"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ InstallationHistory = "CT_PF_InstallationHistory";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const InstallationHistory : String = "CT_PF_InstallationHistory"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


BatchGenerator Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const BatchGenerator As String = "CT_PF_BatchGenSP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string BatchGenerator = @"CT_PF_BatchGenSP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ BatchGenerator = "CT_PF_BatchGenSP";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const BatchGenerator : String = "CT_PF_BatchGenSP"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


SeriesConfiguration Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const SeriesConfiguration As String = "CT_PF_SrsConf"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string SeriesConfiguration = @"CT_PF_SrsConf"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ SeriesConfiguration = "CT_PF_SrsConf";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const SeriesConfiguration : String = "CT_PF_SrsConf"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


MultipleTestResults Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const MultipleTestResults As String = "CT_PF_MulTsRes"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string MultipleTestResults = @"CT_PF_MulTsRes"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ MultipleTestResults = "CT_PF_MulTsRes";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const MultipleTestResults : String = "CT_PF_MulTsRes"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


CostsComparison Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const CostsComparison As String = "CT_PF_OCMP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string CostsComparison = @"CT_PF_OCMP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ CostsComparison = "CT_PF_OCMP";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const CostsComparison : String = "CT_PF_OCMP"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


CostedManufacturingOrder Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const CostedManufacturingOrder As String = "CT_PF_CostedMor"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string CostedManufacturingOrder = @"CT_PF_CostedMor"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ CostedManufacturingOrder = "CT_PF_CostedMor";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const CostedManufacturingOrder : String = "CT_PF_CostedMor"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


CostRollUpSummary Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const CostRollUpSummary As String = "CT_PF_CostRollUpSummary"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string CostRollUpSummary = @"CT_PF_CostRollUpSummary"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ CostRollUpSummary = "CT_PF_CostRollUpSummary";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const CostRollUpSummary : String = "CT_PF_CostRollUpSummary"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


OrderRecommendationErrors Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const OrderRecommendationErrors As String = "CT_PF_OrdRecErrors"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string OrderRecommendationErrors = @"CT_PF_OrdRecErrors"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ OrderRecommendationErrors = "CT_PF_OrdRecErrors";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const OrderRecommendationErrors : String = "CT_PF_OrdRecErrors"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


VersionInfo Class

Members See Also

Allows retrieving an assembly and database version values of ProcessForce's current installation.

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class VersionInfo
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class VersionInfo
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class VersionInfo
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class VersionInfo
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.VersionInfo
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VersionInfo Members
CompuTec.ProcessForce.API Namespace


VersionInfo Members

VersionInfo Class Methods Fields Properties See Also

Allows retrieving an assembly and database version values of ProcessForce's current installation.

The following tables list the members exposed by the VersionInfo type.

Properties
Name | Description
AssemblyVersion | Gets an assembly version value of the CompuTec.ProcessForce.API.dll file.
DatabaseVersion | Gets ProcessForce's database version value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
 | Name | Description
 | APIVersion |
Public field | AssemblyVersionField | The name of a database column that represents the ProcessForce's assembly version.
Public field | DatabaseVersionField | The name of a database column that represents the ProcessForce's database version.
Top
See Also

Reference

VersionInfo Class
CompuTec.ProcessForce.API Namespace


RollingUpBillOfMaterials Constructor

Initializes a new instance of RollingUpBillOfMaterials object.

Namespace: CompuTec.ProcessForce.API.Costing.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RollingUpBillOfMaterials()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RollingUpBillOfMaterials()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RollingUpBillOfMaterials();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollingUpBillOfMaterials Class
RollingUpBillOfMaterials Members
CompuTec.ProcessForce.API.Costing.Data Namespace


RollingUpBillOfMaterials(String, String) Constructor

Initializes a new instance of RollingUpBillOfMaterials object

Namespace: CompuTec.ProcessForce.API.Costing.Data
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal itemCode As String, _
   ByVal revisionCode As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RollingUpBillOfMaterials(
   string itemCode,
   string revisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RollingUpBillOfMaterials(
   String^ itemCode,
   String^ revisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RollingUpBillOfMaterials(
    itemCode : String,
    revisionCode : String
);
This language is not supported or no code example is available.

Parameters

itemCode

Type: string

Item code.

revisionCode

Type: string

Revision code.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollingUpBillOfMaterials Class
RollingUpBillOfMaterials Members
CompuTec.ProcessForce.API.Costing.Data Namespace


BillOfMaterialsExtractionException(String) Constructor

Initializes a new instance of BillOfMaterialsExtractionException class with a specified error message.

Namespace: CompuTec.ProcessForce.API.Costing.Extractors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BillOfMaterialsExtractionException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BillOfMaterialsExtractionException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BillOfMaterialsExtractionException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

A message that describes the error.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialsExtractionException Class
BillOfMaterialsExtractionException Members
CompuTec.ProcessForce.API.Costing.Extractors Namespace


BillOfMaterialsExtractionException(String, Exception) Constructor

Initializes a new instance of BillOfMaterialsExtractionException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: CompuTec.ProcessForce.API.Costing.Extractors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal ex As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BillOfMaterialsExtractionException(
   string message,
   Exception ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BillOfMaterialsExtractionException(
   String^ message,
   Exception^ ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BillOfMaterialsExtractionException(
    message : String,
    ex : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

A message that describes the error.

ex

Type: Exception

The exception that is the cause of the current exception.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialsExtractionException Class
BillOfMaterialsExtractionException Members
CompuTec.ProcessForce.API.Costing.Extractors Namespace


BillOfMaterialsInitializationException(String) Constructor

Initializes a new instance of BillOfMaterialsInitializationException class with a specified error message.

Namespace: CompuTec.ProcessForce.API.Costing.Extractors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BillOfMaterialsInitializationException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BillOfMaterialsInitializationException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BillOfMaterialsInitializationException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

A message that describes the error.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialsInitializationException Class
BillOfMaterialsInitializationException Members
CompuTec.ProcessForce.API.Costing.Extractors Namespace


BillOfMaterialsInitializationException(String, Exception) Constructor

Initializes a new instance of BillOfMaterialsInitializationException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: CompuTec.ProcessForce.API.Costing.Extractors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal ex As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public BillOfMaterialsInitializationException(
   string message,
   Exception ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
BillOfMaterialsInitializationException(
   String^ message,
   Exception^ ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function BillOfMaterialsInitializationException(
    message : String,
    ex : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

A message that describes the error.

ex

Type: Exception

The exception that is the cause of the current exception.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BillOfMaterialsInitializationException Class
BillOfMaterialsInitializationException Members
CompuTec.ProcessForce.API.Costing.Extractors Namespace


ComponentCheckingException(String) Constructor

Initializes a new instance of ComponentCheckingException class with a specified error message.

Namespace: CompuTec.ProcessForce.API.Costing.Extractors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ComponentCheckingException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ComponentCheckingException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ComponentCheckingException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

A message that describes the error.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ComponentCheckingException Class
ComponentCheckingException Members
CompuTec.ProcessForce.API.Costing.Extractors Namespace


ComponentCheckingException(String, Exception) Constructor

Initializes a new instance of ComponentCheckingException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: CompuTec.ProcessForce.API.Costing.Extractors
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal ex As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ComponentCheckingException(
   string message,
   Exception ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ComponentCheckingException(
   String^ message,
   Exception^ ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ComponentCheckingException(
    message : String,
    ex : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

A message that describes the error.

ex

Type: Exception

The exception that is the cause of the current exception.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ComponentCheckingException Class
ComponentCheckingException Members
CompuTec.ProcessForce.API.Costing.Extractors Namespace


RollUpPerformer(String) Constructor

Initializes a new instance of RollUpPerformer class.

Namespace: CompuTec.ProcessForce.API.Costing.Performers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RollUpPerformer(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RollUpPerformer(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RollUpPerformer(
    token : String
);
This language is not supported or no code example is available.

Parameters

token

Type: string

Token.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollUpPerformer Class
RollUpPerformer Members
CompuTec.ProcessForce.API.Costing.Performers Namespace


RollUpPerformer(String, List<RollingUpBillOfMaterials>, List<String>, String) Constructor

Initializes a new instance of RollUpPerformer class.

Namespace: CompuTec.ProcessForce.API.Costing.Performers
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String, _
   ByVal billOfMaterials As List(Of RollingUpBillOfMaterials), _
   ByVal rawMaterials As List(Of String), _
   ByVal costCategory As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RollUpPerformer(
   string token,
   List<RollingUpBillOfMaterials> billOfMaterials,
   List<string> rawMaterials,
   string costCategory
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RollUpPerformer(
   String^ token,
   List<RollingUpBillOfMaterials^>^ billOfMaterials,
   List<String^>^ rawMaterials,
   String^ costCategory
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

Token.

billOfMaterials

Type: List<RollingUpBillOfMaterials>

Bill of materials to roll-up.

rawMaterials

Type: List<string>

Raw materials to roll-up.

costCategory

Type: string

Cost category.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RollUpPerformer Class
RollUpPerformer Members
CompuTec.ProcessForce.API.Costing.Performers Namespace


ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Class
ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal messaage As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion(
   string messaage
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion(
   String^ messaage
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion(
    messaage : String
);
This language is not supported or no code example is available.

Parameters

messaage

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Class
ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion(
   string message,
   Exception innerException
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion(
   String^ message,
   Exception^ innerException
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion(
    message : String,
    innerException : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

innerException

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Class
ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion(SerializationInfo, StreamingContext) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal serializationInfo As SerializationInfo, _
   ByVal streamingContext As StreamingContext _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion(
   SerializationInfo serializationInfo,
   StreamingContext streamingContext
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion(
   SerializationInfo^ serializationInfo,
   StreamingContext streamingContext
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion(
    serializationInfo : SerializationInfo,
    streamingContext : StreamingContext
);
This language is not supported or no code example is available.

Parameters

serializationInfo

Type: SerializationInfo

streamingContext

Type: StreamingContext

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Class
ItemCodeAlreadyUsedInParentBillOfMaterialsExcpetion Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


OperationResourceInvalidCycleValueException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public OperationResourceInvalidCycleValueException(
   string message,
   Exception innerException
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
OperationResourceInvalidCycleValueException(
   String^ message,
   Exception^ innerException
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function OperationResourceInvalidCycleValueException(
    message : String,
    innerException : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

innerException

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

OperationResourceInvalidCycleValueException Class
OperationResourceInvalidCycleValueException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RelatedOverlayOperationDetectedException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RelatedOverlayOperationDetectedException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RelatedOverlayOperationDetectedException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RelatedOverlayOperationDetectedException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RelatedOverlayOperationDetectedException Class
RelatedOverlayOperationDetectedException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RelatedOverlayOperationDetectedException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RelatedOverlayOperationDetectedException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RelatedOverlayOperationDetectedException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RelatedOverlayOperationDetectedException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RelatedOverlayOperationDetectedException Class
RelatedOverlayOperationDetectedException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RelatedOverlayOperationDetectedException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RelatedOverlayOperationDetectedException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RelatedOverlayOperationDetectedException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RelatedOverlayOperationDetectedException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RelatedOverlayOperationDetectedException Class
RelatedOverlayOperationDetectedException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


ResourceTimesNotValidException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceTimesNotValidException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceTimesNotValidException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceTimesNotValidException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceTimesNotValidException Class
ResourceTimesNotValidException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


ResourceTimesNotValidException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceTimesNotValidException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceTimesNotValidException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceTimesNotValidException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceTimesNotValidException Class
ResourceTimesNotValidException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


ResourceTimesNotValidException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceTimesNotValidException(
   string message,
   Exception innerException
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceTimesNotValidException(
   String^ message,
   Exception^ innerException
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceTimesNotValidException(
    message : String,
    innerException : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

innerException

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceTimesNotValidException Class
ResourceTimesNotValidException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RevisonMissingForChildException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RevisonMissingForChildException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RevisonMissingForChildException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RevisonMissingForChildException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RevisonMissingForChildException Class
RevisonMissingForChildException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


RunRateNotValidValueException Constructor

Namespace: CompuTec.ProcessForce.API.Documents._Bill_Of_Materials_.BillOfMaterials.Exceptions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RunRateNotValidValueException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RunRateNotValidValueException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RunRateNotValidValueException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RunRateNotValidValueException Class
RunRateNotValidValueException Members
CompuTec.ProcessForce.API.Documents._Bill_Of_Materials_.BillOfMaterials.Exceptions Namespace


RunRateNotValidValueException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents._Bill_Of_Materials_.BillOfMaterials.Exceptions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RunRateNotValidValueException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RunRateNotValidValueException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RunRateNotValidValueException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RunRateNotValidValueException Class
RunRateNotValidValueException Members
CompuTec.ProcessForce.API.Documents._Bill_Of_Materials_.BillOfMaterials.Exceptions Namespace


RunRateNotValidValueException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents._Bill_Of_Materials_.BillOfMaterials.Exceptions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public RunRateNotValidValueException(
   string message,
   Exception innerException
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
RunRateNotValidValueException(
   String^ message,
   Exception^ innerException
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RunRateNotValidValueException(
    message : String,
    innerException : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

innerException

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

RunRateNotValidValueException Class
RunRateNotValidValueException Members
CompuTec.ProcessForce.API.Documents._Bill_Of_Materials_.BillOfMaterials.Exceptions Namespace


WarehouseNotSetForItemException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public WarehouseNotSetForItemException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
WarehouseNotSetForItemException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function WarehouseNotSetForItemException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WarehouseNotSetForItemException Class
WarehouseNotSetForItemException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


WarehouseNotSetForItemException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public WarehouseNotSetForItemException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
WarehouseNotSetForItemException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function WarehouseNotSetForItemException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WarehouseNotSetForItemException Class
WarehouseNotSetForItemException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


WarehouseNotSetForItemException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.BillOfMaterials
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public WarehouseNotSetForItemException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
WarehouseNotSetForItemException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function WarehouseNotSetForItemException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

WarehouseNotSetForItemException Class
WarehouseNotSetForItemException Members
CompuTec.ProcessForce.API.Documents.BillOfMaterials Namespace


ResourceCalendarUpdater(String) Constructor

Initializes a new instance of the ResourceCalendarUpdater class.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.Updater
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceCalendarUpdater(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceCalendarUpdater(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceCalendarUpdater(
    token : String
);
This language is not supported or no code example is available.

Parameters

token

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCalendarUpdater Class
ResourceCalendarUpdater Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.Updater Namespace


ResourceCalendarUpdater(String, String, List<String>) Constructor

Initializes a new instance of the ResourceCalendarUpdater class.

Namespace: CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.Updater
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal token As String, _
   ByVal templateCode As String, _
   ByVal resources As List(Of String) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceCalendarUpdater(
   string token,
   string templateCode,
   List<string> resources
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceCalendarUpdater(
   String^ token,
   String^ templateCode,
   List<String^>^ resources
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

templateCode

Type: string

The database code of a calendar template.

resources

Type: List<string>

A list with database codes of resources.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceCalendarUpdater Class
ResourceCalendarUpdater Members
CompuTec.ProcessForce.API.Documents.Calendars.ResourceCalendar.Updater Namespace


ItemCostingSynchronizer.SynchronizeWarehouses Method

Synchronizes the warehouses for an item costing entries.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function SynchronizeWarehouses() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool SynchronizeWarehouses()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool SynchronizeWarehouses()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SynchronizeWarehouses() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool

true if the synchronization has been completed successfully; otherwise false is returned.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingSynchronizer Class
ItemCostingSynchronizer Members
CompuTec.ProcessForce.API.Documents.Costing.Synchronization Namespace


ItemCostingSynchronizer.SynchronizeWarehouses (String) Method

Synchronizes the warehouses for an item costing entries.

Namespace: CompuTec.ProcessForce.API.Documents.Costing.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function SynchronizeWarehouses( _
   ByVal itemCode As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool SynchronizeWarehouses(
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool SynchronizeWarehouses(
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SynchronizeWarehouses(
    itemCode : String
) : boolean;
This language is not supported or no code example is available.

Parameters

itemCode

Type: string

Item code.

Return Value

Type: bool

true if the synchronization has been completed successfully; otherwise false is returned.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemCostingSynchronizer Class
ItemCostingSynchronizer Members
CompuTec.ProcessForce.API.Documents.Costing.Synchronization Namespace


CompuTec.ProcessForce.API.Exceptions.Documents Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | IssueMethodCannotBeChangedException |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


IssueMethodCannotBeChangedException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Exceptions.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class IssueMethodCannotBeChangedException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class IssueMethodCannotBeChangedException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class IssueMethodCannotBeChangedException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class IssueMethodCannotBeChangedException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Exceptions.Documents.IssueMethodCannotBeChangedException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IssueMethodCannotBeChangedException Members
CompuTec.ProcessForce.API.Exceptions.Documents Namespace


IssueMethodCannotBeChangedException Members

IssueMethodCannotBeChangedException Class Constructors Methods Properties See Also

The following tables list the members exposed by the IssueMethodCannotBeChangedException type.

Constructors
 | Name | Description
Public constructor | IssueMethodCannotBeChangedException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

IssueMethodCannotBeChangedException Class
CompuTec.ProcessForce.API.Exceptions.Documents Namespace


IssueMethodCannotBeChangedException Constructor

Namespace: CompuTec.ProcessForce.API.Exceptions.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IssueMethodCannotBeChangedException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IssueMethodCannotBeChangedException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function IssueMethodCannotBeChangedException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IssueMethodCannotBeChangedException Class
IssueMethodCannotBeChangedException Members
CompuTec.ProcessForce.API.Exceptions.Documents Namespace


IssueMethodCannotBeChangedException Constructor

IssueMethodCannotBeChangedException Class See Also

Overload List
Name | Description
IssueMethodCannotBeChangedException() |
IssueMethodCannotBeChangedException(string) |
IssueMethodCannotBeChangedException(string, Exception) |
See Also

Reference

IssueMethodCannotBeChangedException Class
IssueMethodCannotBeChangedException Members
CompuTec.ProcessForce.API.Exceptions.Documents Namespace


NotAuthorizedCallException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public NotAuthorizedCallException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
NotAuthorizedCallException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function NotAuthorizedCallException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

NotAuthorizedCallException Class
NotAuthorizedCallException Members
CompuTec.ProcessForce.API.Documents Namespace


NumberOfResourceslessZeroException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class NumberOfResourceslessZeroException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class NumberOfResourceslessZeroException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class NumberOfResourceslessZeroException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class NumberOfResourceslessZeroException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Documents.NumberOfResourceslessZeroException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

NumberOfResourceslessZeroException Members
CompuTec.ProcessForce.API.Documents Namespace


NumberOfResourceslessZeroException Members

NumberOfResourceslessZeroException Class Constructors Methods Properties See Also

The following tables list the members exposed by the NumberOfResourceslessZeroException type.

Constructors
 | Name | Description
Public constructor | NumberOfResourceslessZeroException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

NumberOfResourceslessZeroException Class
CompuTec.ProcessForce.API.Documents Namespace


NumberOfResourceslessZeroException Constructor

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public NumberOfResourceslessZeroException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
NumberOfResourceslessZeroException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function NumberOfResourceslessZeroException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

NumberOfResourceslessZeroException Class
NumberOfResourceslessZeroException Members
CompuTec.ProcessForce.API.Documents Namespace


NumberOfResourceslessZeroException Constructor

NumberOfResourceslessZeroException Class See Also

Overload List
Name | Description
NumberOfResourceslessZeroException() |
NumberOfResourceslessZeroException(string) |
NumberOfResourceslessZeroException(string, Exception) |
See Also

Reference

NumberOfResourceslessZeroException Class
NumberOfResourceslessZeroException Members
CompuTec.ProcessForce.API.Documents Namespace


NumberOfResourceslessZeroException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public NumberOfResourceslessZeroException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
NumberOfResourceslessZeroException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function NumberOfResourceslessZeroException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

NumberOfResourceslessZeroException Class
NumberOfResourceslessZeroException Members
CompuTec.ProcessForce.API.Documents Namespace


NumberOfResourceslessZeroException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public NumberOfResourceslessZeroException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
NumberOfResourceslessZeroException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function NumberOfResourceslessZeroException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

NumberOfResourceslessZeroException Class
NumberOfResourceslessZeroException Members
CompuTec.ProcessForce.API.Documents Namespace


DocumentCreatingException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DocumentCreatingException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DocumentCreatingException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DocumentCreatingException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentCreatingException Class
DocumentCreatingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentCreatingException(String, Int32) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal docEntry As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DocumentCreatingException(
   string message,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DocumentCreatingException(
   String^ message,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DocumentCreatingException(
    message : String,
    docEntry : int
);
This language is not supported or no code example is available.

Parameters

message

Type: string

docEntry

Type: int

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentCreatingException Class
DocumentCreatingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentRetrievingException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DocumentRetrievingException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DocumentRetrievingException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DocumentRetrievingException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentRetrievingException Class
DocumentRetrievingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentRetrievingException(String, Int32) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal docEntry As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DocumentRetrievingException(
   string message,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DocumentRetrievingException(
   String^ message,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DocumentRetrievingException(
    message : String,
    docEntry : int
);
This language is not supported or no code example is available.

Parameters

message

Type: string

docEntry

Type: int

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentRetrievingException Class
DocumentRetrievingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentRetrievingException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal ex As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DocumentRetrievingException(
   string message,
   Exception ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DocumentRetrievingException(
   String^ message,
   Exception^ ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DocumentRetrievingException(
    message : String,
    ex : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

ex

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentRetrievingException Class
DocumentRetrievingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentUpdatingException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DocumentUpdatingException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DocumentUpdatingException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DocumentUpdatingException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentUpdatingException Class
DocumentUpdatingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentUpdatingException(String, Int32) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal docEntry As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DocumentUpdatingException(
   string message,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DocumentUpdatingException(
   String^ message,
   int docEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DocumentUpdatingException(
    message : String,
    docEntry : int
);
This language is not supported or no code example is available.

Parameters

message

Type: string

docEntry

Type: int

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentUpdatingException Class
DocumentUpdatingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


DocumentUpdatingException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal ex As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DocumentUpdatingException(
   string message,
   Exception ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DocumentUpdatingException(
   String^ message,
   Exception^ ex
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DocumentUpdatingException(
    message : String,
    ex : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

ex

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocumentUpdatingException Class
DocumentUpdatingException Members
CompuTec.ProcessForce.API.Documents.ManufacturingOrder.Synchronization Namespace


AtLeastOneRowMustBeFilledException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public AtLeastOneRowMustBeFilledException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
AtLeastOneRowMustBeFilledException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function AtLeastOneRowMustBeFilledException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AtLeastOneRowMustBeFilledException Class
AtLeastOneRowMustBeFilledException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


AtLeastOneRowMustBeFilledException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public AtLeastOneRowMustBeFilledException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
AtLeastOneRowMustBeFilledException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function AtLeastOneRowMustBeFilledException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

AtLeastOneRowMustBeFilledException Class
AtLeastOneRowMustBeFilledException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


CantAddJournalEntryException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CantAddJournalEntryException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CantAddJournalEntryException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CantAddJournalEntryException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantAddJournalEntryException Class
CantAddJournalEntryException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


CantAddJournalEntryException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CantAddJournalEntryException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CantAddJournalEntryException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CantAddJournalEntryException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantAddJournalEntryException Class
CantAddJournalEntryException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


CantAddJournalEntryException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CantAddJournalEntryException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CantAddJournalEntryException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CantAddJournalEntryException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantAddJournalEntryException Class
CantAddJournalEntryException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


DocDateMissingException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DocDateMissingException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DocDateMissingException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DocDateMissingException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocDateMissingException Class
DocDateMissingException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


DocDateMissingException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DocDateMissingException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DocDateMissingException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DocDateMissingException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocDateMissingException Class
DocDateMissingException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


DocDateMissingException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DocDateMissingException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DocDateMissingException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DocDateMissingException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DocDateMissingException Class
DocDateMissingException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


ResourceNotFoundException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceNotFoundException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceNotFoundException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceNotFoundException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceNotFoundException Class
ResourceNotFoundException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


ResourceNotFoundException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.OperationTimeRecording
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ResourceNotFoundException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ResourceNotFoundException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResourceNotFoundException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceNotFoundException Class
ResourceNotFoundException Members
CompuTec.ProcessForce.API.Documents.OperationTimeRecording Namespace


PickedItem(String, Boolean, Double) Constructor

Initializes a new instance of CompuTec.ProcessForce.API.Documents.PickOrder.PickedItem object.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal itemCode As String, _
   ByVal isLicensePlate As Boolean, _
   ByVal quantity As Double _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public PickedItem(
   string itemCode,
   bool isLicensePlate,
   double quantity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
PickedItem(
   String^ itemCode,
   bool isLicensePlate,
   double quantity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function PickedItem(
    itemCode : String,
    isLicensePlate : boolean,
    quantity : double
);
This language is not supported or no code example is available.

Parameters

itemCode

Type: string

The code of a Picked Item.

isLicensePlate

Type: bool

Indicates whether Picked Item is an Item Master Data or a License Plate.

quantity

Type: double

The quantity of a Picked Item.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickedItem Class
PickedItem Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


PickedItem(String, Boolean, Int32, String, String, String, String, Double) Constructor

Initializes a new instance of CompuTec.ProcessForce.API.Documents.PickOrder.PickedItem object.

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder.Assigner
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal itemCode As String, _
   ByVal isLicensePlate As Boolean, _
   ByVal snSysNumber As Integer, _
   ByVal snDistNumber As String, _
   ByVal snMnfNumber As String, _
   ByVal snLotNumber As String, _
   ByVal bnDistNumber As String, _
   ByVal quantity As Double _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public PickedItem(
   string itemCode,
   bool isLicensePlate,
   int snSysNumber,
   string snDistNumber,
   string snMnfNumber,
   string snLotNumber,
   string bnDistNumber,
   double quantity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
PickedItem(
   String^ itemCode,
   bool isLicensePlate,
   int snSysNumber,
   String^ snDistNumber,
   String^ snMnfNumber,
   String^ snLotNumber,
   String^ bnDistNumber,
   double quantity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function PickedItem(
    itemCode : String,
    isLicensePlate : boolean,
    snSysNumber : int,
    snDistNumber : String,
    snMnfNumber : String,
    snLotNumber : String,
    bnDistNumber : String,
    quantity : double
);
This language is not supported or no code example is available.

Parameters

itemCode

Type: string

The code of a Picked Item.

isLicensePlate

Type: bool

Indicates whether Picked Item represents an Item Master Data or a License Plate object.

snSysNumber

Type: int

The System Serial Number value of Serial Number.

snDistNumber

Type: string

The Internal Serial Number value of Serial Number.

snMnfNumber

Type: string

The Manufacturer Serial Number value of Serial Number.

snLotNumber

Type: string

The Batch ID value of Serial Number.

bnDistNumber

Type: string

The Batch Number value of Batch.

quantity

Type: double

The quantity of a Picked Item.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PickedItem Class
PickedItem Members
CompuTec.ProcessForce.API.Documents.PickOrder.Assigner Namespace


SeriesNullException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SeriesNullException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SeriesNullException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SeriesNullException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SeriesNullException Class
SeriesNullException Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


SeriesNullException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SeriesNullException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SeriesNullException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SeriesNullException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SeriesNullException Class
SeriesNullException Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


SeriesNullException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.PickOrder
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SeriesNullException(
   string message,
   Exception innerException
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SeriesNullException(
   String^ message,
   Exception^ innerException
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SeriesNullException(
    message : String,
    innerException : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

innerException

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SeriesNullException Class
SeriesNullException Members
CompuTec.ProcessForce.API.Documents.PickOrder Namespace


SerialNumberQuantityMissMatchException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SerialNumberQuantityMissMatchException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SerialNumberQuantityMissMatchException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SerialNumberQuantityMissMatchException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SerialNumberQuantityMissMatchException Class
SerialNumberQuantityMissMatchException Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


SerialNumberQuantityMissMatchException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SerialNumberQuantityMissMatchException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SerialNumberQuantityMissMatchException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SerialNumberQuantityMissMatchException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SerialNumberQuantityMissMatchException Class
SerialNumberQuantityMissMatchException Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


SerialNumberQuantityMissMatchException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SerialNumberQuantityMissMatchException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SerialNumberQuantityMissMatchException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SerialNumberQuantityMissMatchException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SerialNumberQuantityMissMatchException Class
SerialNumberQuantityMissMatchException Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


SerialNumbersAreNotUniqueException Constructor

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SerialNumbersAreNotUniqueException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SerialNumbersAreNotUniqueException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SerialNumbersAreNotUniqueException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SerialNumbersAreNotUniqueException Class
SerialNumbersAreNotUniqueException Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


SerialNumbersAreNotUniqueException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SerialNumbersAreNotUniqueException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SerialNumbersAreNotUniqueException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SerialNumbersAreNotUniqueException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SerialNumbersAreNotUniqueException Class
SerialNumbersAreNotUniqueException Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


SerialNumbersAreNotUniqueException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Documents.PickReceipt
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SerialNumbersAreNotUniqueException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SerialNumbersAreNotUniqueException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SerialNumbersAreNotUniqueException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SerialNumbersAreNotUniqueException Class
SerialNumbersAreNotUniqueException Members
CompuTec.ProcessForce.API.Documents.PickReceipt Namespace


IWorkRegistration.AssignEmployee (Int32, DateTime, DateTime) Method

Assigns an employee.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function AssignEmployee( _
   ByVal empId As Integer, _
   ByVal start As Date, _
   ByVal end As Date _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool AssignEmployee(
   int empId,
   DateTime start,
   DateTime end
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool AssignEmployee(
   int empId,
   DateTime start,
   DateTime end
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function AssignEmployee(
    empId : int,
    start : DateTime,
    end : DateTime
) : boolean;
This language is not supported or no code example is available.

Parameters

empId

Type: int

start

Type: DateTime

end

Type: DateTime

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.AssignEmployee (Int32, SapDateTime, SapDateTime) Method

Assigns an employee for current day.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function AssignEmployee( _
   ByVal empId As Integer, _
   ByVal start As SapDateTime, _
   ByVal end As SapDateTime _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool AssignEmployee(
   int empId,
   SapDateTime start,
   SapDateTime end
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool AssignEmployee(
   int empId,
   SapDateTime^ start,
   SapDateTime^ end
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function AssignEmployee(
    empId : int,
    start : SapDateTime,
    end : SapDateTime
) : boolean;
This language is not supported or no code example is available.

Parameters

empId

Type: int

Employee ID.

start

Type: SapDateTime

Work start time.

end

Type: SapDateTime

Work end time.

Return Value

Type: bool

A Boolean value that indicates whether the employee was assigned successfully or not.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IWorkRegistration.AssignEmployee (Int32, Int32) Method

Assigns an employee for current day.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function AssignEmployee( _
   ByVal empId As Integer, _
   ByVal qualityTime As Integer _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool AssignEmployee(
   int empId,
   int qualityTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool AssignEmployee(
   int empId,
   int qualityTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function AssignEmployee(
    empId : int,
    qualityTime : int
) : boolean;
This language is not supported or no code example is available.

Parameters

empId

Type: int

Employee ID.

qualityTime

Type: int

Work quality time.

Return Value

Type: bool

A Boolean value that indicates whether the employee was assigned successfully or not.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IWorkRegistration Interface
IWorkRegistration Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


SapDateTime(DateTime) Constructor

Initializes a new instance of CompuTec.ProcessForce.API.Documents.WorkRegistration.SapDateTime object.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal date As Date _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SapDateTime(
   DateTime date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SapDateTime(
   DateTime date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SapDateTime(
    date : DateTime
);
This language is not supported or no code example is available.

Parameters

date

Type: DateTime

System.DateTime object that represents the date and time.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SapDateTime Class
SapDateTime Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


SapDateTime Constructor

Initializes a new instance of CompuTec.ProcessForce.API.Documents.WorkRegistration.SapDateTime object.

Namespace: CompuTec.ProcessForce.API.Documents.WorkRegistration
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SapDateTime()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SapDateTime()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SapDateTime();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SapDateTime Class
SapDateTime Members
CompuTec.ProcessForce.API.Documents.WorkRegistration Namespace


IQualityControlTest2.DS_ManufacturingSeries Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ManufacturingSeries() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ManufacturingSeries {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ManufacturingSeries {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ManufacturingSeries() : String;

   AppEnginePropertyIgnore()
function set DS_ManufacturingSeries(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.DS_ManufacturingDocNum Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ManufacturingDocNum() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ManufacturingDocNum {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ManufacturingDocNum {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ManufacturingDocNum() : String;

   AppEnginePropertyIgnore()
function set DS_ManufacturingDocNum(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.DS_ManufacturingOperationTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ManufacturingOperationTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ManufacturingOperationTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ManufacturingOperationTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ManufacturingOperationTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_ManufacturingOperationTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.DS_ManufacturingOperationName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ManufacturingOperationName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ManufacturingOperationName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ManufacturingOperationName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ManufacturingOperationName() : String;

   AppEnginePropertyIgnore()
function set DS_ManufacturingOperationName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.DS_ManufacturingOperationStatus Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ManufacturingOperationStatus() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ManufacturingOperationStatus {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ManufacturingOperationStatus {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ManufacturingOperationStatus() : String;

   AppEnginePropertyIgnore()
function set DS_ManufacturingOperationStatus(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.TestResults Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property TestResults() As IQualityControlTestTestResults
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IQualityControlTestTestResults TestResults {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IQualityControlTestTestResults^ TestResults {
 IQualityControlTestTestResults^ get( );
 void set(
   IQualityControlTestTestResults^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get TestResults() : IQualityControlTestTestResults;
function set TestResults(value : IQualityControlTestTestResults);
This language is not supported or no code example is available.

Property Value

Type: IQualityControlTestTestResults
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.Batches Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Batches() As IQualityControlTestBatches
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IQualityControlTestBatches Batches {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IQualityControlTestBatches^ Batches {
 IQualityControlTestBatches^ get( );
 void set(
   IQualityControlTestBatches^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Batches() : IQualityControlTestBatches;
function set Batches(value : IQualityControlTestBatches);
This language is not supported or no code example is available.

Property Value

Type: IQualityControlTestBatches
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.SerialNumbers Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property SerialNumbers() As IQualityControlTestSerialNumbers
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IQualityControlTestSerialNumbers SerialNumbers {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IQualityControlTestSerialNumbers^ SerialNumbers {
 IQualityControlTestSerialNumbers^ get( );
 void set(
   IQualityControlTestSerialNumbers^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get SerialNumbers() : IQualityControlTestSerialNumbers;
function set SerialNumbers(value : IQualityControlTestSerialNumbers);
This language is not supported or no code example is available.

Property Value

Type: IQualityControlTestSerialNumbers
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.Defects Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Defects() As IQualityControlTestDefects
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IQualityControlTestDefects Defects {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IQualityControlTestDefects^ Defects {
 IQualityControlTestDefects^ get( );
 void set(
   IQualityControlTestDefects^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Defects() : IQualityControlTestDefects;
function set Defects(value : IQualityControlTestDefects);
This language is not supported or no code example is available.

Property Value

Type: IQualityControlTestDefects
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.Resources Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property Resources() As IQualityControlTestResources
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IQualityControlTestResources Resources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property IQualityControlTestResources^ Resources {
 IQualityControlTestResources^ get( );
 void set(
   IQualityControlTestResources^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Resources() : IQualityControlTestResources;
function set Resources(value : IQualityControlTestResources);
This language is not supported or no code example is available.

Property Value

Type: IQualityControlTestResources
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.SetDefaultSeries Method

Sets the default series for Quality Control Test document.

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub SetDefaultSeries()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void SetDefaultSeries()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void SetDefaultSeries()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function SetDefaultSeries();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.ReleaseBatchesOnQCTestPass Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property ReleaseBatchesOnQCTestPass() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool ReleaseBatchesOnQCTestPass {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property bool ReleaseBatchesOnQCTestPass {
 bool get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get ReleaseBatchesOnQCTestPass() : boolean;
This language is not supported or no code example is available.

Property Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.CheckIfTestStatusOfQCTestIsCorrect Method

Check if Status of Quality Control Test Pool document is correct.

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CheckIfTestStatusOfQCTestIsCorrect() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int CheckIfTestStatusOfQCTestIsCorrect()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

int CheckIfTestStatusOfQCTestIsCorrect()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CheckIfTestStatusOfQCTestIsCorrect() : int;
This language is not supported or no code example is available.

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTest2.SetQCTestsStatus Method

Sets QC Status for Quality Control Test document.

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function SetQCTestsStatus() As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool SetQCTestsStatus()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool SetQCTestsStatus()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function SetQCTestsStatus() : boolean;
This language is not supported or no code example is available.

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTest2 Interface
IQualityControlTest2 Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestAttachments Interface

Members See Also

Attachments for quality control test document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Interface IQualityControlTestAttachments
    Inherits IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IQualityControlTestAttachments : IUDOChildBean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface class IQualityControlTestAttachments : public IUDOChildBean^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public interface IQualityControlTestAttachments
   implements IUDOChildBean
This language is not supported or no code example is available.
Name of table in database
CT_PF_QCT7
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestAttachments Members

IQualityControlTestAttachments Interface Methods Properties See Also

Attachments for quality control test document

The following tables list the members exposed by the IQualityControlTestAttachments type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_AttDate |
Public property | U_FileName |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_Path |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
See Also

Reference

IQualityControlTestAttachments Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestAttachments.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestAttachments Interface
IQualityControlTestAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestAttachments.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestAttachments Interface
IQualityControlTestAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestAttachments.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestAttachments Interface
IQualityControlTestAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestAttachments.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestAttachments Interface
IQualityControlTestAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestAttachments.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestAttachments Interface
IQualityControlTestAttachments Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestBatches.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestBatches Interface
IQualityControlTestBatches Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestBatches.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestBatches Interface
IQualityControlTestBatches Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestBatches.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestBatches Interface
IQualityControlTestBatches Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestBatches.U_QcTestNo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_QcTestNo() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_QcTestNo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_QcTestNo {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_QcTestNo() : int;
function set U_QcTestNo(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestBatches Interface
IQualityControlTestBatches Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestBatches.U_Batch Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Batch() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Batch {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Batch {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Batch() : String;
function set U_Batch(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestBatches Interface
IQualityControlTestBatches Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestDefects Interface

Members See Also

Defects for quality control test document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IQualityControlTestDefects
    Inherits IUDOChildBean, _
             IEnumerable(Of IQualityControlTestDefects)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IQualityControlTestDefects : IUDOChildBean,
   IEnumerable<IQualityControlTestDefects>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IQualityControlTestDefects : public IUDOChildBean^,
   public IEnumerable<IQualityControlTestDefects^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_QCT4
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestDefects Members

IQualityControlTestDefects Interface Methods Properties See Also

Defects for quality control test document

The following tables list the members exposed by the IQualityControlTestDefects type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_DefName |
Public property | DS_DefTableCode |
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_DefCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_QcTestNo |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IQualityControlTestDefects Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestDefects.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestDefects Interface
IQualityControlTestDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestDefects.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestDefects Interface
IQualityControlTestDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestDefects.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestDefects Interface
IQualityControlTestDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestDefects.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestDefects Interface
IQualityControlTestDefects Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.U_PrpCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PrpCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PrpCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PrpCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PrpCode() : String;
function set U_PrpCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.U_Expression Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Expression() As ConditionType
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
ConditionType U_Expression {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property ConditionType U_Expression {
 ConditionType get( );
 void set(
   ConditionType value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Expression() : ConditionType;
function set U_Expression(value : ConditionType);
This language is not supported or no code example is available.

Property Value

Type: ConditionType
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.U_RangeValueFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RangeValueFrom() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RangeValueFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RangeValueFrom {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RangeValueFrom() : double;
function set U_RangeValueFrom(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.U_RangeValueTo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RangeValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_RangeValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_RangeValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RangeValueTo() : double;
function set U_RangeValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.U_ValidFromDate Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ValidFromDate() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_ValidFromDate {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_ValidFromDate {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ValidFromDate() : DateTime;
function set U_ValidFromDate(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.DS_PropertyTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_PropertyTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_PropertyTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_PropertyTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_PropertyTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_PropertyTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.DS_PropertyName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_PropertyName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_PropertyName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_PropertyName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_PropertyName() : String;

   AppEnginePropertyIgnore()
function set DS_PropertyName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.DS_ReferenceTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ReferenceTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ReferenceTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ReferenceTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ReferenceTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_ReferenceTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.DS_ReferenceName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ReferenceName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ReferenceName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ReferenceName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ReferenceName() : String;

   AppEnginePropertyIgnore()
function set DS_ReferenceName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.DS_UnitOfMeasure Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_UnitOfMeasure() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_UnitOfMeasure {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_UnitOfMeasure {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_UnitOfMeasure() : String;

   AppEnginePropertyIgnore()
function set DS_UnitOfMeasure(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.DS_RsnTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_RsnTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_RsnTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_RsnTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_RsnTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_RsnTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.DS_RsnName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_RsnName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_RsnName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_RsnName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_RsnName() : String;

   AppEnginePropertyIgnore()
function set DS_RsnName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.DS_WrdTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_WrdTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_WrdTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_WrdTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_WrdTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_WrdTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItemProperties.DS_WrdName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_WrdName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_WrdName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_WrdName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_WrdName() : String;

   AppEnginePropertyIgnore()
function set DS_WrdName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItemProperties Interface
IQualityControlTestItemProperties Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItems.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItems Interface
IQualityControlTestItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItems.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItems Interface
IQualityControlTestItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItems.U_ItemCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ItemCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_ItemCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_ItemCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ItemCode() : String;
function set U_ItemCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItems Interface
IQualityControlTestItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItems.U_WhsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItems Interface
IQualityControlTestItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItems.U_PlannedQty Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PlannedQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PlannedQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PlannedQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PlannedQty() : double;
function set U_PlannedQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItems Interface
IQualityControlTestItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItems.U_ActualQty Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActualQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ActualQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ActualQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActualQty() : double;
function set U_ActualQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItems Interface
IQualityControlTestItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItems.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItems Interface
IQualityControlTestItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItems.DS_ItemName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ItemName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemName() : String;

   AppEnginePropertyIgnore()
function set DS_ItemName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItems Interface
IQualityControlTestItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestItems.DS_ItemUoM Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ItemUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ItemUoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ItemUoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ItemUoM() : String;

   AppEnginePropertyIgnore()
function set DS_ItemUoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestItems Interface
IQualityControlTestItems Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestMultipleTestResults Interface

Members See Also

Multiple test results for quality control test document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IQualityControlTestMultipleTestResults
    Inherits IUDOChildBean, _
             IEnumerable(Of IQualityControlTestMultipleTestResults)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IQualityControlTestMultipleTestResults : IUDOChildBean,
   IEnumerable<IQualityControlTestMultipleTestResults>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IQualityControlTestMultipleTestResults : public IUDOChildBean^,
   public IEnumerable<IQualityControlTestMultipleTestResults^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_QCT9
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestMultipleTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestMultipleTestResults Members

IQualityControlTestMultipleTestResults Interface Methods Properties See Also

Multiple test results for quality control test document

The following tables list the members exposed by the IQualityControlTestMultipleTestResults type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_ExpectedReferenceCode |
Public property | DS_ExpectedValueFrom |
Public property | DS_ExpectedValueTo |
Public property | DS_Expression |
Public property | DS_Passed |
Public property | DS_TestedReferenceName |
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Date |
Public property | U_InsCode |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_TestLineNo |
Public property | U_TestType |
Public property | U_TestedRefCode |
Public property | U_TestedValue |
Public property | U_Time |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IQualityControlTestMultipleTestResults Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestMultipleTestResults.U_TestType Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestType() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TestType {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TestType {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestType() : String;
function set U_TestType(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestMultipleTestResults Interface
IQualityControlTestMultipleTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestMultipleTestResults.U_TestedValue Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestedValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_TestedValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_TestedValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestedValue() : double;
function set U_TestedValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestMultipleTestResults Interface
IQualityControlTestMultipleTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestMultipleTestResults.U_TestedRefCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestedRefCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TestedRefCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TestedRefCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestedRefCode() : String;
function set U_TestedRefCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestMultipleTestResults Interface
IQualityControlTestMultipleTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestMultipleTestResults.U_Date Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Date() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Date {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Date {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Date() : DateTime;
function set U_Date(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestMultipleTestResults Interface
IQualityControlTestMultipleTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestMultipleTestResults.U_Time Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Time() As Date
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
DateTime U_Time {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property DateTime U_Time {
 DateTime get( );
 void set(
   DateTime value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Time() : DateTime;
function set U_Time(value : DateTime);
This language is not supported or no code example is available.

Property Value

Type: DateTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestMultipleTestResults Interface
IQualityControlTestMultipleTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestMultipleTestResults.U_InsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_InsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_InsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_InsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_InsCode() : String;
function set U_InsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestMultipleTestResults Interface
IQualityControlTestMultipleTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestMultipleTestResults.DS_Expression Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_Expression() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_Expression {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_Expression {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_Expression() : String;

   AppEnginePropertyIgnore()
function set DS_Expression(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestMultipleTestResults Interface
IQualityControlTestMultipleTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestMultipleTestResults.DS_ExpectedValueFrom Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ExpectedValueFrom() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
double DS_ExpectedValueFrom {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property double DS_ExpectedValueFrom {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ExpectedValueFrom() : double;

   AppEnginePropertyIgnore()
function set DS_ExpectedValueFrom(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestMultipleTestResults Interface
IQualityControlTestMultipleTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestMultipleTestResults.DS_ExpectedValueTo Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ExpectedValueTo() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
double DS_ExpectedValueTo {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property double DS_ExpectedValueTo {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ExpectedValueTo() : double;

   AppEnginePropertyIgnore()
function set DS_ExpectedValueTo(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestMultipleTestResults Interface
IQualityControlTestMultipleTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestMultipleTestResults.DS_ExpectedReferenceCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_ExpectedReferenceCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_ExpectedReferenceCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_ExpectedReferenceCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_ExpectedReferenceCode() : String;

   AppEnginePropertyIgnore()
function set DS_ExpectedReferenceCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestMultipleTestResults Interface
IQualityControlTestMultipleTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestResources.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestResources Interface
IQualityControlTestResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestResources.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestResources Interface
IQualityControlTestResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestResources.U_RscCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RscCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RscCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RscCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RscCode() : String;
function set U_RscCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestResources Interface
IQualityControlTestResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestResources.U_WhsCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_WhsCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_WhsCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_WhsCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_WhsCode() : String;
function set U_WhsCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestResources Interface
IQualityControlTestResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestResources.U_PlannedQty Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PlannedQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_PlannedQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_PlannedQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PlannedQty() : double;
function set U_PlannedQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestResources Interface
IQualityControlTestResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestResources.U_ActualQty Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_ActualQty() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_ActualQty {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_ActualQty {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_ActualQty() : double;
function set U_ActualQty(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestResources Interface
IQualityControlTestResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestResources.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestResources Interface
IQualityControlTestResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestResources.DS_RscName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_RscName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_RscName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_RscName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_RscName() : String;

   AppEnginePropertyIgnore()
function set DS_RscName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestResources Interface
IQualityControlTestResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestResources.DS_RscUoM Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_RscUoM() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_RscUoM {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_RscUoM {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_RscUoM() : String;

   AppEnginePropertyIgnore()
function set DS_RscUoM(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestResources Interface
IQualityControlTestResources Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestSerialNumbers Interface

Members See Also

Serial numbers for quality control test document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IQualityControlTestSerialNumbers
    Inherits IUDOChildBean, _
             IEnumerable(Of IQualityControlTestSerialNumbers)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IQualityControlTestSerialNumbers : IUDOChildBean,
   IEnumerable<IQualityControlTestSerialNumbers>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IQualityControlTestSerialNumbers : public IUDOChildBean^,
   public IEnumerable<IQualityControlTestSerialNumbers^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_QCT3
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestSerialNumbers Members

IQualityControlTestSerialNumbers Interface Methods Properties See Also

Serial numbers for quality control test document

The following tables list the members exposed by the IQualityControlTestSerialNumbers type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_BatchId |
Public property | U_IntrSerial |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_QcTestNo |
Public property | U_SuppSerial |
Public property | U_SysNumber |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IQualityControlTestSerialNumbers Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestSerialNumbers.U_SysNumber Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SysNumber() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int U_SysNumber {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int U_SysNumber {
 int get( );
 void set(
   int value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SysNumber() : int;
function set U_SysNumber(value : int);
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestSerialNumbers Interface
IQualityControlTestSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestSerialNumbers.U_BatchId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_BatchId() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_BatchId {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_BatchId {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_BatchId() : String;
function set U_BatchId(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestSerialNumbers Interface
IQualityControlTestSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestSerialNumbers.U_SuppSerial Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_SuppSerial() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_SuppSerial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_SuppSerial {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_SuppSerial() : String;
function set U_SuppSerial(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestSerialNumbers Interface
IQualityControlTestSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestSerialNumbers.U_IntrSerial Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_IntrSerial() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_IntrSerial {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_IntrSerial {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_IntrSerial() : String;
function set U_IntrSerial(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestSerialNumbers Interface
IQualityControlTestSerialNumbers Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults Interface

Members See Also

Test results for Quality control test document

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEngineUDOChildBean()> _
Public Interface IQualityControlTestTestResults
    Inherits IUDOChildBean, _
             IEnumerable(Of IQualityControlTestTestResults)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface IQualityControlTestTestResults : IUDOChildBean,
   IEnumerable<IQualityControlTestTestResults>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEngineUDOChildBean()]
public interface class IQualityControlTestTestResults : public IUDOChildBean^,
   public IEnumerable<IQualityControlTestTestResults^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Name of table in database
CT_PF_QCT1
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults Members

IQualityControlTestTestResults Interface Methods Properties See Also

Test results for Quality control test document

The following tables list the members exposed by the IQualityControlTestTestResults type.

Properties
 | Name | Description
Public property | Count | Number of Childs (inherited from IUDOChildBean).
Public property | CurrentChild | (inherited from IUDOChildBean).
Public property | DS_PrpName |
Public property | DS_PrpTableCode |
Public property | DS_RefName |
Public property | DS_RefTableCode |
Public property | DS_RsnName |
Public property | DS_RsnTableCode |
Public property | DS_WrdName |
Public property | DS_WrdTableCode |
Public property | DocEntry |
Public property | LineId |
Public property | LogInst |
Public property | Object |
Public property | UDFItems | UDF Items for current object (inherited from IUDOChildBean).
Public property | U_Expression |
Public property | U_LineNum | Gets ProcessForce Line Num (inherited from IUDOChildBean).
Public property | U_PassFail |
Public property | U_PrpCode |
Public property | U_RangeValueFrom |
Public property | U_RangeValueTo |
Public property | U_RefCode |
Public property | U_Remarks |
Public property | U_RsnCode |
Public property | U_TestedRefCode |
Public property | U_TestedValue |
Public property | U_UnitOfMeasure |
Public property | VisOrder |
Top
Methods
 | Name | Description
Public method | Add | Adds Row ot the end (inherited from IUDOChildBean).
Public method | AddRowAtPos | Adds Row At specific position (inherited from IUDOChildBean).
Public method | Clear | (inherited from IUDOChildBean).
Public method | DelRowAtPos | Del rows of specific Position (inherited from IUDOChildBean).
Public method | SetCurrentLine | Sets Line on specific Position from o to Count (inherited from IUDOChildBean).
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
See Also

Reference

IQualityControlTestTestResults Interface
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.DocEntry Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property DocEntry() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
int DocEntry {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property int DocEntry {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DocEntry() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.LineId Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LineId() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LineId {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LineId {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LineId() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.VisOrder Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property VisOrder() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int VisOrder {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int VisOrder {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get VisOrder() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.Object Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
ReadOnly Property Object() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string Object {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ Object {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get Object() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.LogInst Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
ReadOnly Property LogInst() As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
int LogInst {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property int LogInst {
 int get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get LogInst() : int;
This language is not supported or no code example is available.

Property Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.U_TestedValue Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestedValue() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
double U_TestedValue {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property double U_TestedValue {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestedValue() : double;
function set U_TestedValue(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.U_TestedRefCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_TestedRefCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_TestedRefCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_TestedRefCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_TestedRefCode() : String;
function set U_TestedRefCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.U_PassFail Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_PassFail() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_PassFail {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_PassFail {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_PassFail() : String;
function set U_PassFail(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.U_RsnCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_RsnCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_RsnCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_RsnCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_RsnCode() : String;
function set U_RsnCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.U_Remarks Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Property U_Remarks() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
string U_Remarks {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

property String^ U_Remarks {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function get U_Remarks() : String;
function set U_Remarks(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.DS_PrpTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_PrpTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_PrpTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_PrpTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_PrpTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_PrpTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.DS_PrpName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_PrpName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_PrpName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_PrpName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_PrpName() : String;

   AppEnginePropertyIgnore()
function set DS_PrpName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.DS_RefTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_RefTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_RefTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_RefTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_RefTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_RefTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.DS_RefName Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_RefName() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_RefName {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_RefName {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_RefName() : String;

   AppEnginePropertyIgnore()
function set DS_RefName(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


IQualityControlTestTestResults.DS_RsnTableCode Property

Namespace: CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<AppEnginePropertyIgnore()> _
Property DS_RsnTableCode() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]
string DS_RsnTableCode {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[AppEnginePropertyIgnore()]

property String^ DS_RsnTableCode {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

   AppEnginePropertyIgnore()
function get DS_RsnTableCode() : String;

   AppEnginePropertyIgnore()
function set DS_RsnTableCode(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IQualityControlTestTestResults Interface
IQualityControlTestTestResults Members
CompuTec.ProcessForce.API.Documents.QualityControl.Test.QualityControlTest2 Namespace


ProjectionScenario Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ProjectionScenario
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ProjectionScenario
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ProjectionScenario
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ProjectionScenario
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Scheduling.ProjectionScenario
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProjectionScenario Members
CompuTec.ProcessForce.API.Scheduling Namespace


ProjectionScenario Members

ProjectionScenario Class Constructors Methods Properties See Also

The following tables list the members exposed by the ProjectionScenario type.

Constructors
 | Name | Description
Public constructor | ProjectionScenario | (Overloaded)
Top
Properties
 | Name | Description
Public property | quantity |
Public property | timeInterval |
Public property | usedResources |
Top
Methods
 | Name | Description
Public method | AddResourceToList | (Overloaded)
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | FillTimeInterval |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ProjectionScenario Class
CompuTec.ProcessForce.API.Scheduling Namespace


ProjectionScenario.quantity Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property quantity() As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public double quantity {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property double quantity {
 double get( );
 void set(
   double value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get quantity() : double;
public function set quantity(value : double);
This language is not supported or no code example is available.

Property Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProjectionScenario Class
ProjectionScenario Members
CompuTec.ProcessForce.API.Scheduling Namespace


ProjectionScenario.usedResources Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property usedResources() As List(Of ResourceAlternative)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<ResourceAlternative> usedResources {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property List<ResourceAlternative^>^ usedResources {
 List<ResourceAlternative^>^ get( );
 void set(
   List<ResourceAlternative^>^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Property Value

Type: List<ResourceAlternative>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProjectionScenario Class
ProjectionScenario Members
CompuTec.ProcessForce.API.Scheduling Namespace


ProjectionScenario.timeInterval Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property timeInterval() As TimeInterval
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeInterval timeInterval {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property TimeInterval^ timeInterval {
 TimeInterval^ get( );
 void set(
   TimeInterval^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get timeInterval() : TimeInterval;
public function set timeInterval(value : TimeInterval);
This language is not supported or no code example is available.

Property Value

Type: TimeInterval
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProjectionScenario Class
ProjectionScenario Members
CompuTec.ProcessForce.API.Scheduling Namespace


ProjectionScenario Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ProjectionScenario()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ProjectionScenario()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ProjectionScenario();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProjectionScenario Class
ProjectionScenario Members
CompuTec.ProcessForce.API.Scheduling Namespace


ProjectionScenario Constructor

ProjectionScenario Class See Also

Overload List
Name | Description
ProjectionScenario() |
ProjectionScenario(List<ResourceAlternative>, double) |
ProjectionScenario(ResourceAlternative, double) |
See Also

Reference

ProjectionScenario Class
ProjectionScenario Members
CompuTec.ProcessForce.API.Scheduling Namespace


ProjectionScenario(List<ResourceAlternative>, Double) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal resources As List(Of ResourceAlternative), _
   Optional ByVal qty As Double = 0 _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ProjectionScenario(
   List<ResourceAlternative> resources,
   double qty = 0
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ProjectionScenario(
   List<ResourceAlternative^>^ resources,
   double qty
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

resources

Type: List<ResourceAlternative>

qty

Type: double

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProjectionScenario Class
ProjectionScenario Members
CompuTec.ProcessForce.API.Scheduling Namespace


ProjectionScenario(ResourceAlternative, Double) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal resource As ResourceAlternative, _
   Optional ByVal qty As Double = 0 _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ProjectionScenario(
   ResourceAlternative resource,
   double qty = 0
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ProjectionScenario(
   ResourceAlternative^ resource,
   double qty
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ProjectionScenario(
    resource : ResourceAlternative,
    qty : double
);
This language is not supported or no code example is available.

Parameters

resource

Type: ResourceAlternative

qty

Type: double

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProjectionScenario Class
ProjectionScenario Members
CompuTec.ProcessForce.API.Scheduling Namespace


ProjectionScenario.AddResourceToList (ResourceAlternative) Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub AddResourceToList( _
   ByVal resource As ResourceAlternative _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void AddResourceToList(
   ResourceAlternative resource
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void AddResourceToList(
   ResourceAlternative^ resource
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function AddResourceToList(
    resource : ResourceAlternative
);
This language is not supported or no code example is available.

Parameters

resource

Type: ResourceAlternative

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProjectionScenario Class
ProjectionScenario Members
CompuTec.ProcessForce.API.Scheduling Namespace


ProjectionScenario.AddResourceToList Method

ProjectionScenario Class See Also

Overload List
Name | Description
AddResourceToList(ResourceAlternative) |
AddResourceToList(ResourceAlternative, double) |
See Also

Reference

ProjectionScenario Class
ProjectionScenario Members
CompuTec.ProcessForce.API.Scheduling Namespace


ProjectionScenario.AddResourceToList (ResourceAlternative, Double) Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub AddResourceToList( _
   ByVal resource As ResourceAlternative, _
   ByVal qty As Double _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void AddResourceToList(
   ResourceAlternative resource,
   double qty
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void AddResourceToList(
   ResourceAlternative^ resource,
   double qty
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function AddResourceToList(
    resource : ResourceAlternative,
    qty : double
);
This language is not supported or no code example is available.

Parameters

resource

Type: ResourceAlternative

qty

Type: double

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProjectionScenario Class
ProjectionScenario Members
CompuTec.ProcessForce.API.Scheduling Namespace


ProjectionScenario.FillTimeInterval Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub FillTimeInterval( _
   ByVal timeInterval As TimeInterval _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void FillTimeInterval(
   TimeInterval timeInterval
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void FillTimeInterval(
   TimeInterval^ timeInterval
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function FillTimeInterval(
    timeInterval : TimeInterval
);
This language is not supported or no code example is available.

Parameters

timeInterval

Type: TimeInterval

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProjectionScenario Class
ProjectionScenario Members
CompuTec.ProcessForce.API.Scheduling Namespace


ResourceAndLinkedTools.AddTools Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub AddTools( _
   ByVal Tools As List(Of String) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void AddTools(
   List<string> Tools
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void AddTools(
   List<String^>^ Tools
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Tools

Type: List<string>

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ResourceAndLinkedTools Class
ResourceAndLinkedTools Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleResults Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ScheduleResults
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ScheduleResults
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ScheduleResults
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ScheduleResults
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Scheduling.ScheduleResults
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleResults Members
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleResults Members

ScheduleResults Class Constructors Methods Fields See Also

The following tables list the members exposed by the ScheduleResults type.

Constructors
 | Name | Description
Public constructor | ScheduleResults |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Fields
 | Name | Description
Public field | Results |
Top
See Also

Reference

ScheduleResults Class
CompuTec.ProcessForce.API.Scheduling Namespace


ScheduleResults Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ScheduleResults()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ScheduleResults()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ScheduleResults();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleResults Class
ScheduleResults Members
CompuTec.ProcessForce.API.Scheduling Namespace


Results Field

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Results As List(Of IManufacturingOrder)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<IManufacturingOrder> Results
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<IManufacturingOrder^>^ Results;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Field Value

Type: List<IManufacturingOrder>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ScheduleResults Class
ScheduleResults Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class TimeInterval
    Implements ITimeInterval
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class TimeInterval : ITimeInterval
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class TimeInterval  : public ITimeInterval^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Serializable()
class TimeInterval
   implements ITimeInterval
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Scheduling.TimeInterval
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval Members

TimeInterval Class Constructors Methods Properties See Also

The following tables list the members exposed by the TimeInterval type.

Constructors
 | Name | Description
Public constructor | TimeInterval | (Overloaded)
Top
Properties
 | Name | Description
Public property | Duration |
Public property | FromDate |
Public property | Reference |
Public property | Remarks |
Public property | ToDate |
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | (Overloaded)
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object.
Public method | Validate |
Top
See Also

Reference

TimeInterval Class
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeInterval()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeInterval()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function TimeInterval();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeInterval Class
TimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval Constructor

TimeInterval Class See Also

Overload List
Name | Description
TimeInterval(DateTime, TimeSpan) |
TimeInterval() |
TimeInterval(DateTime, DateTime) |
TimeInterval(DateTime, DateTime, string) |
TimeInterval(DateTime, DateTime, string, object) |
TimeInterval(DateTime, TimeSpan, string) |
TimeInterval(DateTime, TimeSpan, string, object) |
See Also

Reference

TimeInterval Class
TimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval(DateTime, TimeSpan) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal fromDate As Date, _
   ByVal duratuion As TimeSpan _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeInterval(
   DateTime fromDate,
   TimeSpan duratuion
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeInterval(
   DateTime fromDate,
   TimeSpan duratuion
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function TimeInterval(
    fromDate : DateTime,
    duratuion : TimeSpan
);
This language is not supported or no code example is available.

Parameters

fromDate

Type: DateTime

duratuion

Type: TimeSpan

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeInterval Class
TimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval.Validate Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Validate() Implements  _
   ITimeInterval.Validate
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Validate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Validate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Validate();
This language is not supported or no code example is available.

Implements

ITimeInterval.Validate
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeInterval Class
TimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval(DateTime, TimeSpan, String) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal fromDate As Date, _
   ByVal duratuion As TimeSpan, _
   ByVal remarks As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeInterval(
   DateTime fromDate,
   TimeSpan duratuion,
   string remarks
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeInterval(
   DateTime fromDate,
   TimeSpan duratuion,
   String^ remarks
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function TimeInterval(
    fromDate : DateTime,
    duratuion : TimeSpan,
    remarks : String
);
This language is not supported or no code example is available.

Parameters

fromDate

Type: DateTime

duratuion

Type: TimeSpan

remarks

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeInterval Class
TimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval(DateTime, TimeSpan, String, Object) Constructor

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal fromDate As Date, _
   ByVal duratuion As TimeSpan, _
   ByVal remarks As String, _
   ByVal refrerences As Object _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeInterval(
   DateTime fromDate,
   TimeSpan duratuion,
   string remarks,
   object refrerences
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeInterval(
   DateTime fromDate,
   TimeSpan duratuion,
   String^ remarks,
   object^ refrerences
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function TimeInterval(
    fromDate : DateTime,
    duratuion : TimeSpan,
    remarks : String,
    refrerences : object
);
This language is not supported or no code example is available.

Parameters

fromDate

Type: DateTime

duratuion

Type: TimeSpan

remarks

Type: string

refrerences

Type: object

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeInterval Class
TimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval.Duration Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Property Duration() As TimeSpan Implements  _
   ITimeInterval.Duration
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan Duration {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property TimeSpan Duration {
 TimeSpan get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Duration() : TimeSpan;
This language is not supported or no code example is available.

Property Value

Type: TimeSpan

Implements

ITimeInterval.Duration
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeInterval Class
TimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval.Reference Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Reference() As Object Implements  _
   ITimeInterval.Reference
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public object Reference {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property object^ Reference {
 object^ get( );
 void set(
   object^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Reference() : object;
public function set Reference(value : object);
This language is not supported or no code example is available.

Property Value

Type: object

Implements

ITimeInterval.Reference
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeInterval Class
TimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval.ToString Method

Returns a string that represents the current object.

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overrides Function ToString() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public override string ToString()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ ToString()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ToString() : String;
This language is not supported or no code example is available.

Return Value

Type: string

A string that represents the current object.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeInterval Class
TimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval.Equals Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function Equals( _
   ByVal other As ITimeInterval _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool Equals(
   ITimeInterval other
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool Equals(
   ITimeInterval^ other
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Equals(
    other : ITimeInterval
) : boolean;
This language is not supported or no code example is available.

Parameters

other

Type: ITimeInterval

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeInterval Class
TimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval.Equals Method

TimeInterval Class See Also

Overload List
Name | Description
Equals(Object) | Determines whether the specified object is equal to the current object. (System.Object).
Equals(ITimeInterval) |
See Also

Reference

TimeInterval Class
TimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeInterval.Clone Method

Creates a new object that is a copy of the current instance.

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function Clone() As Object Implements  _
   ITimeInterval.Clone
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public object Clone()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
object^ Clone()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Clone() : object;
This language is not supported or no code example is available.

Return Value

Type: object

A new object that is a copy of this instance.

Implements

ITimeInterval.Clone
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeInterval Class
TimeInterval Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeIntervals Class

Members See Also

Class that Holds TimeInterval Collection

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Serializable()> _
Public Class TimeIntervals
    Implements IEnumerable(Of ITimeInterval)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public class TimeIntervals : IEnumerable<ITimeInterval>
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Serializable()]
public ref class TimeIntervals  : public IEnumerable<ITimeInterval^>^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Scheduling.TimeIntervals
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeIntervals Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeIntervals Members

TimeIntervals Class Methods Fields Properties See Also

Class that Holds TimeInterval Collection

The following tables list the members exposed by the TimeIntervals type.

Properties
 | Name | Description
Public property | Item |
Public property | TotalDuration |
Top
Methods
 | Name | Description
Public method | Add |
Public method | AddRange |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetEffortForSpecificTimes |
Public method | GetEffortFromSpecificDateTime |
Public method | GetEffortToSpecificDateTime | Calulates Effrot To Specific Time
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetFinish |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetStart |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Public method | TrimIntervals | This method Trims interval ba start and End Date
Top
Extension Methods
 | Name | Description
Public extension method | Aggregate<TSource>(Func<TSource, TSource, TSource>) | Applies an accumulator function over a sequence. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value. (Defined by Enumerable).
Public extension method | Aggregate<TSource, TAccumulate, TResult>(TAccumulate, Func<TAccumulate, TSource, TAccumulate>, Func<TAccumulate, TResult>) | Applies an accumulator function over a sequence. The specified seed value is used as the initial accumulator value, and the specified function is used to select the result value. (Defined by Enumerable).
Public extension method | All<TSource>(Func<TSource, Boolean>) | Determines whether all elements of a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Ancestors<T>(XName) | Returns a filtered collection of elements that contains the ancestors of every node in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Ancestors<T>() | Returns a collection of elements that contains the ancestors of every node in the source collection. (Defined by Extensions).
Public extension method | Any<TSource>() | Determines whether a sequence contains any elements. (Defined by Enumerable).
Public extension method | Any<TSource>(Func<TSource, Boolean>) | Determines whether any element of a sequence satisfies a condition. (Defined by Enumerable).
Public extension method | Append<TSource>(TSource) | Appends a value to the end of the sequence. (Defined by Enumerable).
Public extension method | AsEnumerable<TSource>() | Returns the input typed as IEnumerable<T>. (Defined by Enumerable).
Public extension method | AsParallel() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsParallel<TSource>() | Enables parallelization of a query. (Defined by ParallelEnumerable).
Public extension method | AsQueryable<TElement>() | Converts a generic IEnumerable<T> to a generic IQueryable<T>. (Defined by Queryable).
Public extension method | AsQueryable() | Converts an IEnumerable to an IQueryable. (Defined by Queryable).
Public extension method | Average<TSource>(Func<TSource, Int32>) | Computes the average of a sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int32>>) | Computes the average of a sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Int64>>) | Computes the average of a sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Single>) | Computes the average of a sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Single>>) | Computes the average of a sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Double>) | Computes the average of a sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Double>>) | Computes the average of a sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Decimal>) | Computes the average of a sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the average of a sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Average<TSource>(Func<TSource, Int64>) | Computes the average of a sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Cast<TResult>() | Casts the elements of an IEnumerable to the specified type. (Defined by Enumerable).
Public extension method | Concat<TSource>(IEnumerable<TSource>) | Concatenates two sequences. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource, IEqualityComparer<TSource>) | Determines whether a sequence contains a specified element by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Contains<TSource>(TSource) | Determines whether a sequence contains a specified element by using the default equality comparer. (Defined by Enumerable).
Public extension method | CopyToDataTable<T>() | Returns a DataTable that contains copies of the DataRow objects, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | CopyToDataTable<T>(DataTable, LoadOption, FillErrorEventHandler) | Copies DataRow objects to the specified DataTable, given an input IEnumerable<T> object where the generic parameter T is DataRow. (Defined by DataTableExtensions).
Public extension method | Count<TSource>(Func<TSource, Boolean>) | Returns a number that represents how many elements in the specified sequence satisfy a condition. (Defined by Enumerable).
Public extension method | Count<TSource>() | Returns the number of elements in a sequence. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>(TSource) | Returns the elements of the specified sequence or the specified value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DefaultIfEmpty<TSource>() | Returns the elements of the specified sequence or the type parameter's default value in a singleton collection if the sequence is empty. (Defined by Enumerable).
Public extension method | DescendantNodes<T>() | Returns a collection of the descendant nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | Descendants<T>(XName) | Returns a filtered collection of elements that contains the descendant elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Descendants<T>() | Returns a collection of elements that contains the descendant elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Distinct<TSource>(IEqualityComparer<TSource>) | Returns distinct elements from a sequence by using a specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Distinct<TSource>() | Returns distinct elements from a sequence by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | ElementAt<TSource>(Int32) | Returns the element at a specified index in a sequence. (Defined by Enumerable).
Public extension method | ElementAtOrDefault<TSource>(Int32) | Returns the element at a specified index in a sequence or a default value if the index is out of range. (Defined by Enumerable).
Public extension method | Elements<T>() | Returns a collection of the child elements of every element and document in the source collection. (Defined by Extensions).
Public extension method | Elements<T>(XName) | Returns a filtered collection of the child elements of every element and document in the source collection. Only elements that have a matching XName are included in the collection. (Defined by Extensions).
Public extension method | Except<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set difference of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Except<TSource>(IEnumerable<TSource>) | Produces the set difference of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | First<TSource>(Func<TSource, Boolean>) | Returns the first element in a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | First<TSource>() | Returns the first element of a sequence. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>(Func<TSource, Boolean>) | Returns the first element of the sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | FirstOrDefault<TSource>() | Returns the first element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The keys are compared by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and compares the keys by using a specified comparer. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Groups the elements of a sequence according to a specified key selector function and projects the elements for each group by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a key selector function. The keys are compared by using a comparer and each group's elements are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey>(Func<TSource, TKey>) | Groups the elements of a sequence according to a specified key selector function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>, IEqualityComparer<TKey>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. Key values are compared by using a specified comparer, and the elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TElement, TResult>(Func<TSource, TKey>, Func<TSource, TElement>, Func<TKey, IEnumerable<TElement>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. The elements of each group are projected by using a specified function. (Defined by Enumerable).
Public extension method | GroupBy<TSource, TKey, TResult>(Func<TSource, TKey>, Func<TKey, IEnumerable<TSource>, TResult>) | Groups the elements of a sequence according to a specified key selector function and creates a result value from each group and its key. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>) | Correlates the elements of two sequences based on equality of keys and groups the results. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | GroupJoin<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, IEnumerable<TInner>, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on key equality and groups the results. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | InDocumentOrder<T>() | Returns a collection of nodes that contains all nodes in the source collection, sorted in document order. (Defined by Extensions).
Public extension method | Intersect<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set intersection of two sequences by using the specified IEqualityComparer<T> to compare values. (Defined by Enumerable).
Public extension method | Intersect<TSource>(IEnumerable<TSource>) | Produces the set intersection of two sequences by using the default equality comparer to compare values. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>) | Correlates the elements of two sequences based on matching keys. The default equality comparer is used to compare keys. (Defined by Enumerable).
Public extension method | Join<TOuter, TInner, TKey, TResult>(IEnumerable<TInner>, Func<TOuter, TKey>, Func<TInner, TKey>, Func<TOuter, TInner, TResult>, IEqualityComparer<TKey>) | Correlates the elements of two sequences based on matching keys. A specified IEqualityComparer<T> is used to compare keys. (Defined by Enumerable).
Public extension method | Last<TSource>() | Returns the last element of a sequence. (Defined by Enumerable).
Public extension method | Last<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a specified condition. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>(Func<TSource, Boolean>) | Returns the last element of a sequence that satisfies a condition or a default value if no such element is found. (Defined by Enumerable).
Public extension method | LastOrDefault<TSource>() | Returns the last element of a sequence, or a default value if the sequence contains no elements. (Defined by Enumerable).
Public extension method | LongCount<TSource>(Func<TSource, Boolean>) | Returns an Int64 that represents how many elements in a sequence satisfy a condition. (Defined by Enumerable).
Public extension method | LongCount<TSource>() | Returns an Int64 that represents the total number of elements in a sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the maximum Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>() | Returns the maximum value in a generic sequence. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the maximum Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Decimal value. (Defined by Enumerable).
Public extension method | Max<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the maximum resulting value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int32 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the maximum Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Int64 value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the maximum Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the maximum Double value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Single value. (Defined by Enumerable).
Public extension method | Max<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the maximum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int32>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource, TResult>(Func<TSource, TResult>) | Invokes a transform function on each element of a generic sequence and returns the minimum resulting value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Decimal>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Decimal>) | Invokes a transform function on each element of a sequence and returns the minimum Decimal value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Double>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Double>) | Invokes a transform function on each element of a sequence and returns the minimum Double value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Single>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Single>) | Invokes a transform function on each element of a sequence and returns the minimum Single value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int64>) | Invokes a transform function on each element of a sequence and returns the minimum Int64 value. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Int32>) | Invokes a transform function on each element of a sequence and returns the minimum Int32 value. (Defined by Enumerable).
Public extension method | Min<TSource>() | Returns the minimum value in a generic sequence. (Defined by Enumerable).
Public extension method | Min<TSource>(Func<TSource, Nullable<Int64>>) | Invokes a transform function on each element of a sequence and returns the minimum nullable Int64 value. (Defined by Enumerable).
Public extension method | Nodes<T>() | Returns a collection of the child nodes of every document and element in the source collection. (Defined by Extensions).
Public extension method | OfType<TResult>() | Filters the elements of an IEnumerable based on a specified type. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in ascending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderBy<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in ascending order according to a key. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>, IComparer<TKey>) | Sorts the elements of a sequence in descending order by using a specified comparer. (Defined by Enumerable).
Public extension method | OrderByDescending<TSource, TKey>(Func<TSource, TKey>) | Sorts the elements of a sequence in descending order according to a key. (Defined by Enumerable).
Public extension method | Prepend<TSource>(TSource) | Adds a value to the beginning of the sequence. (Defined by Enumerable).
Public extension method | Remove<T>() | Removes every node in the source collection from its parent node. (Defined by Extensions).
Public extension method | Reverse<TSource>() | Inverts the order of the elements in a sequence. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, Int32, TResult>) | Projects each element of a sequence into a new form by incorporating the element's index. (Defined by Enumerable).
Public extension method | Select<TSource, TResult>(Func<TSource, TResult>) | Projects each element of a sequence into a new form. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TCollection, TResult>(Func<TSource, Int32, IEnumerable<TCollection>>, Func<TSource, TCollection, TResult>) | Projects each element of a sequence to an IEnumerable<T>, flattens the resulting sequences into one sequence, and invokes a result selector function on each element therein. The index of each source element is used in the intermediate projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, Int32, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T>, and flattens the resulting sequences into one sequence. The index of each source element is used in the projected form of that element. (Defined by Enumerable).
Public extension method | SelectMany<TSource, TResult>(Func<TSource, IEnumerable<TResult>>) | Projects each element of a sequence to an IEnumerable<T> and flattens the resulting sequences into one sequence. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Determines whether two sequences are equal by comparing their elements by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | SequenceEqual<TSource>(IEnumerable<TSource>) | Determines whether two sequences are equal by comparing the elements by using the default equality comparer for their type. (Defined by Enumerable).
Public extension method | Single<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition, and throws an exception if more than one such element exists. (Defined by Enumerable).
Public extension method | Single<TSource>() | Returns the only element of a sequence, and throws an exception if there is not exactly one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>() | Returns the only element of a sequence, or a default value if the sequence is empty; this method throws an exception if there is more than one element in the sequence. (Defined by Enumerable).
Public extension method | SingleOrDefault<TSource>(Func<TSource, Boolean>) | Returns the only element of a sequence that satisfies a specified condition or a default value if no such element exists; this method throws an exception if more than one element satisfies the condition. (Defined by Enumerable).
Public extension method | Skip<TSource>(Int32) | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. (Defined by Enumerable).
Public extension method | SkipWhile<TSource>(Func<TSource, Int32, Boolean>) | Bypasses elements in a sequence as long as a specified condition is true and then returns the remaining elements. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int32>>) | Computes the sum of the sequence of nullable Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Decimal>>) | Computes the sum of the sequence of nullable Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Decimal>) | Computes the sum of the sequence of Decimal values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Double>>) | Computes the sum of the sequence of nullable Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Double>) | Computes the sum of the sequence of Double values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Single>>) | Computes the sum of the sequence of nullable Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Single>) | Computes the sum of the sequence of Single values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Nullable<Int64>>) | Computes the sum of the sequence of nullable Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int64>) | Computes the sum of the sequence of Int64 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Sum<TSource>(Func<TSource, Int32>) | Computes the sum of the sequence of Int32 values that are obtained by invoking a transform function on each element of the input sequence. (Defined by Enumerable).
Public extension method | Take<TSource>(Int32) | Returns a specified number of contiguous elements from the start of a sequence. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Int32, Boolean>) | Returns elements from a sequence as long as a specified condition is true. The element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | TakeWhile<TSource>(Func<TSource, Boolean>) | Returns elements from a sequence as long as a specified condition is true. (Defined by Enumerable).
Public extension method | ToArray<TSource>() | Creates an array from a IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function, a comparer, and an element selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToDictionary<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Dictionary<TKey, TValue> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToHashSet<TSource>(IEqualityComparer<TSource>) | (Defined by Enumerable).
Public extension method | ToHashSet<TSource>() | (Defined by Enumerable).
Public extension method | ToList<TSource>() | Creates a List<T> from an IEnumerable<T>. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function, a comparer and an element selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey>(Func<TSource, TKey>, IEqualityComparer<TKey>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to a specified key selector function and key comparer. (Defined by Enumerable).
Public extension method | ToLookup<TSource, TKey, TElement>(Func<TSource, TKey>, Func<TSource, TElement>) | Creates a Lookup<TKey, TElement> from an IEnumerable<T> according to specified key selector and element selector functions. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>, IEqualityComparer<TSource>) | Produces the set union of two sequences by using a specified IEqualityComparer<T>. (Defined by Enumerable).
Public extension method | Union<TSource>(IEnumerable<TSource>) | Produces the set union of two sequences by using the default equality comparer. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Int32, Boolean>) | Filters a sequence of values based on a predicate. Each element's index is used in the logic of the predicate function. (Defined by Enumerable).
Public extension method | Where<TSource>(Func<TSource, Boolean>) | Filters a sequence of values based on a predicate. (Defined by Enumerable).
Public extension method | Zip<TFirst, TSecond, TResult>(IEnumerable<TSecond>, Func<TFirst, TSecond, TResult>) | Applies a specified function to the corresponding elements of two sequences, producing a sequence of the results. (Defined by Enumerable).
Top
Fields
 | Name | Description
Public field | _times | Times Collection
Top
See Also

Reference

TimeIntervals Class
CompuTec.ProcessForce.API.Scheduling Namespace


_times Field

Times Collection

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shadows _times As List(Of ITimeInterval)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
new public List<ITimeInterval> _times
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<ITimeInterval^>^ _times;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Field Value

Type: List<ITimeInterval>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeIntervals Class
TimeIntervals Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeIntervals.GetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetEnumerator() As IEnumerator(Of ITimeInterval) Implements  _
   IEnumerable.GetEnumerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IEnumerator<ITimeInterval> GetEnumerator()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IEnumerator<ITimeInterval^>^ GetEnumerator()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Return Value

Type: IEnumerator<ITimeInterval>

An enumerator that can be used to iterate through the collection.

Implements

IEnumerable.GetEnumerator
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeIntervals Class
TimeIntervals Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeIntervals.Item Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<XmlIgnore()> _
Public Property Item( _
   ByVal pos As Integer _
) As ITimeInterval
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlIgnore()]
public ITimeInterval this[
   int pos
] {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlIgnore()]
public:
property ITimeInterval^ Item[int] {
 ITimeInterval^ get(
   int pos
 );
 void set(
   int pos,
   ITimeInterval^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript suports the use of indexed properties, but not the declaration of new ones.
This language is not supported or no code example is available.

Parameters

pos

Type: int

Property Value

Type: ITimeInterval
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeIntervals Class
TimeIntervals Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeIntervals.TotalDuration Property

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<XmlIgnore()> _
Public ReadOnly Property TotalDuration() As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlIgnore()]
public TimeSpan TotalDuration {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[XmlIgnore()]
public:
property TimeSpan TotalDuration {
 TimeSpan get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   XmlIgnore()
function get TotalDuration() : TimeSpan;
This language is not supported or no code example is available.

Property Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeIntervals Class
TimeIntervals Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeIntervals.GetStart Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetStart( _
   ByVal finish As Date, _
   ByVal Effort As TimeSpan _
) As Nullable(Of Date)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Nullable<DateTime> GetStart(
   DateTime finish,
   TimeSpan Effort
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Nullable<DateTime> GetStart(
   DateTime finish,
   TimeSpan Effort
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

finish

Type: DateTime

Effort

Type: TimeSpan

Return Value

Type: Nullable<DateTime>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeIntervals Class
TimeIntervals Members
CompuTec.ProcessForce.API.Scheduling Namespace


TimeIntervals.GetEffortForSpecificTimes Method

Namespace: CompuTec.ProcessForce.API.Scheduling
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetEffortForSpecificTimes( _
   ByVal fromTime As Date, _
   ByVal ToTime As Date _
) As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan GetEffortForSpecificTimes(
   DateTime fromTime,
   DateTime ToTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeSpan GetEffortForSpecificTimes(
   DateTime fromTime,
   DateTime ToTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetEffortForSpecificTimes(
    fromTime : DateTime,
    ToTime : DateTime
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

fromTime

Type: DateTime

ToTime

Type: DateTime

Return Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

TimeIntervals Class
TimeIntervals Members
CompuTec.ProcessForce.API.Scheduling Namespace


CompuTec.ProcessForce.API.Tools Namespace

Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Classes
 | Name | Description
Public class | BulkUdoConverter | Class to faster getting List Of UDo Object from system Udo taken by this method is not suppported for updating ( not tested)!!!!
Public class | CantFindBOMCodeException |
Public class | CodeDescriptionContainer |
Public class | ItemUtils |
 | PDCTools |
 | UdoTools | Tools used on udo
Public class | UnitConverter |
Top
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1


CantFindBOMCodeException Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class CantFindBOMCodeException
    Inherits Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CantFindBOMCodeException : Exception
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class CantFindBOMCodeException : public Exception^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CantFindBOMCodeException
   extends Exception
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
System.Exception
CompuTec.ProcessForce.API.Tools.CantFindBOMCodeException
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantFindBOMCodeException Members
CompuTec.ProcessForce.API.Tools Namespace


CantFindBOMCodeException Members

CantFindBOMCodeException Class Constructors Methods Properties See Also

The following tables list the members exposed by the CantFindBOMCodeException type.

Constructors
 | Name | Description
Public constructor | CantFindBOMCodeException | (Overloaded)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (inherited from Exception).
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception).
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception).
Public property | Message | Gets a message that describes the current exception. (inherited from Exception).
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception).
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (inherited from Exception).
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception).
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception).
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception).
Top
See Also

Reference

CantFindBOMCodeException Class
CompuTec.ProcessForce.API.Tools Namespace


CantFindBOMCodeException Constructor

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CantFindBOMCodeException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CantFindBOMCodeException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CantFindBOMCodeException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantFindBOMCodeException Class
CantFindBOMCodeException Members
CompuTec.ProcessForce.API.Tools Namespace


CantFindBOMCodeException Constructor

CantFindBOMCodeException Class See Also

Overload List
Name | Description
CantFindBOMCodeException() |
CantFindBOMCodeException(string) |
CantFindBOMCodeException(string, Exception) |
See Also

Reference

CantFindBOMCodeException Class
CantFindBOMCodeException Members
CompuTec.ProcessForce.API.Tools Namespace


CantFindBOMCodeException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CantFindBOMCodeException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CantFindBOMCodeException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CantFindBOMCodeException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantFindBOMCodeException Class
CantFindBOMCodeException Members
CompuTec.ProcessForce.API.Tools Namespace


CantFindBOMCodeException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CantFindBOMCodeException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CantFindBOMCodeException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CantFindBOMCodeException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CantFindBOMCodeException Class
CantFindBOMCodeException Members
CompuTec.ProcessForce.API.Tools Namespace


BulkUdoConverter Class

Members See Also

Class to faster getting List Of UDo Object from system Udo taken by this method is not suppported for updating ( not tested)!!!!

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class BulkUdoConverter
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BulkUdoConverter
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class BulkUdoConverter
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class BulkUdoConverter
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.BulkUdoConverter
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BulkUdoConverter Members
CompuTec.ProcessForce.API.Tools Namespace


BulkUdoConverter Members

BulkUdoConverter Class Methods See Also

Class to faster getting List Of UDo Object from system Udo taken by this method is not suppported for updating ( not tested)!!!!

The following tables list the members exposed by the BulkUdoConverter type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | GetBulkObjects<T, K> | (Overloaded)
 | GetBulkObjects<T> | Gets list Of Udo Object of specified type based on Key collection
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

BulkUdoConverter Class
CompuTec.ProcessForce.API.Tools Namespace


BulkUdoConverter.GetBulkObjects<T> Method

Gets list Of Udo Object of specified type based on Key collection

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetBulkObjects(Of  _
   Core.IUDOBean)( _
   ByVal Token As String, _
   ByVal type As ObjectTypes, _
   ByVal keys As IEnumerable(Of T) _
) As List(Of IUDOBean)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static List<IUDOBean> GetBulkObjects<Core.IUDOBean>(
   string Token,
   ObjectTypes type,
   IEnumerable<T> keys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
generic<typename Core.IUDOBean>
public:
static List<IUDOBean^>^ GetBulkObjects(
   String^ Token,
   ObjectTypes type,
   IEnumerable<T^>^ keys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Type Parameters

Core.IUDOBean

Parameters

Token

Type: string

Database Token

type

Type: ObjectTypes

Type of Udo object

keys

Type: IEnumerable<T>

Keys collection Code or DocEntry

Return Value

Type: List<IUDOBean>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BulkUdoConverter Class
BulkUdoConverter Members
CompuTec.ProcessForce.API.Tools Namespace


BulkUdoConverter.GetBulkObjects<T, K> (String, ObjectTypes, IEnumerable<K>) Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetBulkObjects(Of  _
   T)( _
   ByVal Token As String, _
   ByVal type As ObjectTypes, _
   ByVal keys As IEnumerable(Of K) _
) As List(Of T)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static List<T> GetBulkObjects<T>(
   string Token,
   ObjectTypes type,
   IEnumerable<K> keys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
generic<typename T>
public:
static List<T^>^ GetBulkObjects(
   String^ Token,
   ObjectTypes type,
   IEnumerable<K^>^ keys
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Type Parameters

T

Parameters

Token

Type: string

type

Type: ObjectTypes

keys

Type: IEnumerable<K>

Return Value

Type: List<T>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

BulkUdoConverter Class
BulkUdoConverter Members
CompuTec.ProcessForce.API.Tools Namespace


BulkUdoConverter.GetBulkObjects<T, K> Method

BulkUdoConverter Class See Also

Overload List
Name | Description
GetBulkObjects<K>(string, ObjectTypes, IEnumerable<T>) | Gets list Of Udo Object of specified type based on Key collection
GetBulkObjects<T>(string, ObjectTypes, IEnumerable<K>) |
See Also

Reference

BulkUdoConverter Class
BulkUdoConverter Members
CompuTec.ProcessForce.API.Tools Namespace


CodeDescriptionContainer Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class CodeDescriptionContainer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CodeDescriptionContainer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class CodeDescriptionContainer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CodeDescriptionContainer
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.CodeDescriptionContainer
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CodeDescriptionContainer Members
CompuTec.ProcessForce.API.Tools Namespace


CodeDescriptionContainer Members

CodeDescriptionContainer Class Constructors Methods Properties See Also

The following tables list the members exposed by the CodeDescriptionContainer type.

Constructors
 | Name | Description
Public constructor | CodeDescriptionContainer | (Overloaded)
Top
Properties
 | Name | Description
Public property | Code |
Public property | Description |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

CodeDescriptionContainer Class
CompuTec.ProcessForce.API.Tools Namespace


CodeDescriptionContainer.Code Property

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Code() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Code {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Code {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Code() : String;
public function set Code(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CodeDescriptionContainer Class
CodeDescriptionContainer Members
CompuTec.ProcessForce.API.Tools Namespace


CodeDescriptionContainer.Description Property

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Property Description() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string Description {get; set;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
property String^ Description {
 String^ get( );
 void set(
   String^ value
 );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function get Description() : String;
public function set Description(value : String);
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CodeDescriptionContainer Class
CodeDescriptionContainer Members
CompuTec.ProcessForce.API.Tools Namespace


CodeDescriptionContainer Constructor

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CodeDescriptionContainer()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CodeDescriptionContainer()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CodeDescriptionContainer();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CodeDescriptionContainer Class
CodeDescriptionContainer Members
CompuTec.ProcessForce.API.Tools Namespace


CodeDescriptionContainer Constructor

CodeDescriptionContainer Class See Also

Overload List
Name | Description
CodeDescriptionContainer() |
CodeDescriptionContainer(string, string) |
See Also

Reference

CodeDescriptionContainer Class
CodeDescriptionContainer Members
CompuTec.ProcessForce.API.Tools Namespace


CodeDescriptionContainer(String, String) Constructor

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal code As String, _
   ByVal description As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CodeDescriptionContainer(
   string code,
   string description
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CodeDescriptionContainer(
   String^ code,
   String^ description
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CodeDescriptionContainer(
    code : String,
    description : String
);
This language is not supported or no code example is available.

Parameters

code

Type: string

description

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

CodeDescriptionContainer Class
CodeDescriptionContainer Members
CompuTec.ProcessForce.API.Tools Namespace


Maintanance.GetDownTimeReasonName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetDownTimeReasonName( _
   ByVal token As String, _
   ByVal code As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetDownTimeReasonName(
   string token,
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetDownTimeReasonName(
   String^ token,
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetDownTimeReasonName(
    token : String,
    code : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

code

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Maintanance Class
Maintanance Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class ItemDetails
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemDetails
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class ItemDetails
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class ItemDetails
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.ItemUtils.ItemDetails
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails Members

ItemDetails Class Methods See Also

The following tables list the members exposed by the ItemDetails type.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | GetDefaultRevision |
 | GetDefaultRevisionForItem |
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetItemClassificationGroupName |
 | GetItemClassificationGroupTableCode |
 | GetItemClassificationName |
 | GetItemClassificationTableCode |
 | GetItemDefauldYield |
 | GetItemDetailCode |
 | GetItemDetailPropertyCode |
 | GetItemDetailPropertyCreateDate |
 | GetItemDetailPropertyGroupDscription |
 | GetItemDetailPropertyGroupName |
 | GetItemDetailPropertyName |
 | GetItemDetailPropertySubGroupCode |
 | GetItemDetailPropertySubGroupDscription |
 | GetItemDetailPropertySubGroupName |
 | GetItemDetailPropertyTableCode |
 | GetItemDetailPropertyUOM |
 | GetItemDetailPropertyUpdateDate |
 | GetItemDetailWordName |
 | GetItemDetailWordRemarks |
 | GetItemGroupGroupName |
 | GetItemGroupGroupTableCode |
 | GetItemGroupName |
 | GetItemGroupTableCode |
 | GetItemPhraseGroupName |
 | GetItemPhraseGroupTableCode |
 | GetItemPhraseName |
 | GetItemPhraseTableCode |
 | GetItemTextName |
 | GetItemTextTableCode |
 | GetListOfRevisonsForItem |
 | GetListOfWordCodesForProperty |
 | GetMrpDumbItemCode | Gets the dumb item configured for MRP functionality.
 | GetRevisionName |
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | GetWordCode |
 | IgnoreYieldForItem |
 | IsRevisionDefaultForMrp |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

ItemDetails Class
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemDefauldYield Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemDefauldYield( _
   ByVal tokn As String, _
   ByVal ItemCode As String _
) As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static double GetItemDefauldYield(
   string tokn,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static double GetItemDefauldYield(
   String^ tokn,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemDefauldYield(
    tokn : String,
    ItemCode : String
) : double;
This language is not supported or no code example is available.

Parameters

tokn

Type: string

ItemCode

Type: string

Return Value

Type: double
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.IgnoreYieldForItem Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function IgnoreYieldForItem( _
   ByVal tokn As String, _
   ByVal ItemCode As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool IgnoreYieldForItem(
   string tokn,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool IgnoreYieldForItem(
   String^ tokn,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function IgnoreYieldForItem(
    tokn : String,
    ItemCode : String
) : boolean;
This language is not supported or no code example is available.

Parameters

tokn

Type: string

ItemCode

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemTextTableCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemTextTableCode( _
   ByVal token As String, _
   ByVal code As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemTextTableCode(
   string token,
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemTextTableCode(
   String^ token,
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemTextTableCode(
    token : String,
    code : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

code

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemTextName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemTextName( _
   ByVal token As String, _
   ByVal code As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemTextName(
   string token,
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemTextName(
   String^ token,
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemTextName(
    token : String,
    code : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

code

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemClassificationTableCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemClassificationTableCode( _
   ByVal token As String, _
   ByVal code As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemClassificationTableCode(
   string token,
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemClassificationTableCode(
   String^ token,
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemClassificationTableCode(
    token : String,
    code : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

code

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemClassificationName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemClassificationName( _
   ByVal token As String, _
   ByVal code As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemClassificationName(
   string token,
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemClassificationName(
   String^ token,
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemClassificationName(
    token : String,
    code : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

code

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemGroupTableCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemGroupTableCode( _
   ByVal token As String, _
   ByVal code As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemGroupTableCode(
   string token,
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemGroupTableCode(
   String^ token,
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemGroupTableCode(
    token : String,
    code : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

code

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemGroupName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemGroupName( _
   ByVal token As String, _
   ByVal code As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemGroupName(
   string token,
   string code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemGroupName(
   String^ token,
   String^ code
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemGroupName(
    token : String,
    code : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

code

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemPhraseGroupTableCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemPhraseGroupTableCode( _
   ByVal token As String, _
   ByVal groupCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemPhraseGroupTableCode(
   string token,
   string groupCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemPhraseGroupTableCode(
   String^ token,
   String^ groupCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemPhraseGroupTableCode(
    token : String,
    groupCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

groupCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemPhraseGroupName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemPhraseGroupName( _
   ByVal token As String, _
   ByVal groupCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemPhraseGroupName(
   string token,
   string groupCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemPhraseGroupName(
   String^ token,
   String^ groupCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemPhraseGroupName(
    token : String,
    groupCode : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

groupCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetDefaultRevision Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetDefaultRevision( _
   ByVal token As String, _
   ByVal itemCode As String _
) As CodeDescriptionContainer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static CodeDescriptionContainer GetDefaultRevision(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static CodeDescriptionContainer^ GetDefaultRevision(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetDefaultRevision(
    token : String,
    itemCode : String
) : CodeDescriptionContainer;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: CodeDescriptionContainer
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.IsRevisionDefaultForMrp Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function IsRevisionDefaultForMrp( _
   ByVal token As String, _
   ByVal itemCode As String, _
   ByVal revCode As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool IsRevisionDefaultForMrp(
   string token,
   string itemCode,
   string revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool IsRevisionDefaultForMrp(
   String^ token,
   String^ itemCode,
   String^ revCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function IsRevisionDefaultForMrp(
    token : String,
    itemCode : String,
    revCode : String
) : boolean;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

revCode

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetMrpDumbItemCode Method

Gets the dumb item configured for MRP functionality.

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetMrpDumbItemCode( _
   ByVal token As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetMrpDumbItemCode(
   string token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetMrpDumbItemCode(
   String^ token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetMrpDumbItemCode(
    token : String
) : String;
This language is not supported or no code example is available.

Parameters

token

Type: string

Token.

Return Value

Type: string

String object that represents the dumb item code used for MRP functionality.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemDetailPropertyGroupName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemDetailPropertyGroupName( _
   ByVal Token As String, _
   ByVal GroupCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemDetailPropertyGroupName(
   string Token,
   string GroupCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemDetailPropertyGroupName(
   String^ Token,
   String^ GroupCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemDetailPropertyGroupName(
    Token : String,
    GroupCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

GroupCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemDetailPropertySubGroupDscription Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemDetailPropertySubGroupDscription( _
   ByVal Token As String, _
   ByVal GroupCode As String, _
   ByVal LineNum As Integer _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemDetailPropertySubGroupDscription(
   string Token,
   string GroupCode,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemDetailPropertySubGroupDscription(
   String^ Token,
   String^ GroupCode,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemDetailPropertySubGroupDscription(
    Token : String,
    GroupCode : String,
    LineNum : int
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

GroupCode

Type: string

LineNum

Type: int

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemDetailPropertySubGroupName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemDetailPropertySubGroupName( _
   ByVal Token As String, _
   ByVal GroupCode As String, _
   ByVal LineNum As Integer _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemDetailPropertySubGroupName(
   string Token,
   string GroupCode,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemDetailPropertySubGroupName(
   String^ Token,
   String^ GroupCode,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemDetailPropertySubGroupName(
    Token : String,
    GroupCode : String,
    LineNum : int
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

GroupCode

Type: string

LineNum

Type: int

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemDetailPropertySubGroupCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemDetailPropertySubGroupCode( _
   ByVal Token As String, _
   ByVal GroupCode As String, _
   ByVal LineNum As Integer _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemDetailPropertySubGroupCode(
   string Token,
   string GroupCode,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemDetailPropertySubGroupCode(
   String^ Token,
   String^ GroupCode,
   int LineNum
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemDetailPropertySubGroupCode(
    Token : String,
    GroupCode : String,
    LineNum : int
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

GroupCode

Type: string

LineNum

Type: int

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemDetailPropertyGroupDscription Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemDetailPropertyGroupDscription( _
   ByVal Token As String, _
   ByVal GroupCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemDetailPropertyGroupDscription(
   string Token,
   string GroupCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemDetailPropertyGroupDscription(
   String^ Token,
   String^ GroupCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemDetailPropertyGroupDscription(
    Token : String,
    GroupCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

GroupCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemDetailWordRemarks Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemDetailWordRemarks( _
   ByVal Token As String, _
   ByVal PropertyCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemDetailWordRemarks(
   string Token,
   string PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemDetailWordRemarks(
   String^ Token,
   String^ PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemDetailWordRemarks(
    Token : String,
    PropertyCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

PropertyCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemDetailPropertyCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemDetailPropertyCode( _
   ByVal Token As String, _
   ByVal PropertyCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemDetailPropertyCode(
   string Token,
   string PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemDetailPropertyCode(
   String^ Token,
   String^ PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemDetailPropertyCode(
    Token : String,
    PropertyCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

PropertyCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemDetailPropertyCreateDate Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemDetailPropertyCreateDate( _
   ByVal Token As String, _
   ByVal PropertyCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemDetailPropertyCreateDate(
   string Token,
   string PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemDetailPropertyCreateDate(
   String^ Token,
   String^ PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemDetailPropertyCreateDate(
    Token : String,
    PropertyCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

PropertyCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetItemDetailPropertyUpdateDate Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetItemDetailPropertyUpdateDate( _
   ByVal Token As String, _
   ByVal PropertyCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetItemDetailPropertyUpdateDate(
   string Token,
   string PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetItemDetailPropertyUpdateDate(
   String^ Token,
   String^ PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetItemDetailPropertyUpdateDate(
    Token : String,
    PropertyCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

PropertyCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetRevisionName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetRevisionName( _
   ByVal Token As String, _
   ByVal itemCode As String, _
   ByVal RevisionCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetRevisionName(
   string Token,
   string itemCode,
   string RevisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetRevisionName(
   String^ Token,
   String^ itemCode,
   String^ RevisionCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetRevisionName(
    Token : String,
    itemCode : String,
    RevisionCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemCode

Type: string

RevisionCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetListOfWordCodesForProperty Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetListOfWordCodesForProperty( _
   ByVal Token As String, _
   ByVal PropertyCode As String _
) As List(Of String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static List<string> GetListOfWordCodesForProperty(
   string Token,
   string PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static List<String^>^ GetListOfWordCodesForProperty(
   String^ Token,
   String^ PropertyCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

PropertyCode

Type: string

Return Value

Type: List<string>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetDefaultRevisionForItem Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetDefaultRevisionForItem( _
   ByVal Token As String, _
   ByVal itemcode As String, _
   ByRef RevisionName As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetDefaultRevisionForItem(
   string Token,
   string itemcode,
   out string RevisionName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetDefaultRevisionForItem(
   String^ Token,
   String^ itemcode,
   String^& RevisionName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetDefaultRevisionForItem(
    Token : String,
    itemcode : String,
    RevisionName : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

itemcode

Type: string

RevisionName

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


ItemDetails.GetListOfRevisonsForItem Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetListOfRevisonsForItem( _
   ByVal Token As String, _
   ByVal ItemCode As String _
) As Dictionary(Of String, String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Dictionary<string, string> GetListOfRevisonsForItem(
   string Token,
   string ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static Dictionary<String^, String^>^ GetListOfRevisonsForItem(
   String^ Token,
   String^ ItemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

Token

Type: string

ItemCode

Type: string

Return Value

Type: Dictionary<string, string>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemDetails Class
ItemDetails Members
CompuTec.ProcessForce.API.Tools Namespace


Technology Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class Technology
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Technology
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class Technology
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Technology
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.ItemUtils.Technology
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology Members

Technology Class Methods See Also

The following tables list the members exposed by the Technology type.

Methods
 | Name | Description
 | BillOfMaterialExists |
 | CheckItemAgainstBillOfMaterialsDefinitions |
 | ContainsChildMors |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
 | GetBillOfMaterialCode |
 | GetBillOfMaterialsBatchSize |
 | GetBomCode |
 | GetBomHeaderItemInfo | Returns Item Code and Name from BOM based on Code
 | GetChildMors |
 | GetFirstMor | Rerutns top parent Mor Docentry for Semi MORS
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetIOPropertyCode |
 | GetIOPropertyName |
 | GetIssueMethod |
 | GetNumberOfResources |
 | GetOperationCode |
 | GetOperationName |
 | GetOperationPropertyCode |
 | GetOperationPropertyName |
 | GetResourceCode |
 | GetResourceGroupCode |
 | GetResourceGroupName |
 | GetResourceName |
 | GetResourcePropertyCode |
 | GetResourcePropertyName |
 | GetResourceType | Returns Resource Type for requested resource Code
 | GetRoutingCode |
 | GetRoutingName |
 | GetSpecificFormula |
 | GetSubChildQty | (Overloaded)
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | GetWordName |
 | GetYieldFormulas |
 | IsRoutingActive | Chcks if Routing is Active and Can Be used
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
Classes
 | Name | Description
Public class | YieldFormulasClass |
Top
See Also

Reference

Technology Class
CompuTec.ProcessForce.API.Tools Namespace


YieldFormulasClass Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class YieldFormulasClass
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class YieldFormulasClass
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class YieldFormulasClass
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class YieldFormulasClass
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.ItemUtils.Technology.YieldFormulasClass
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

YieldFormulasClass Members
CompuTec.ProcessForce.API.Tools Namespace


YieldFormulasClass Members

YieldFormulasClass Class Methods Properties See Also

The following tables list the members exposed by the YieldFormulasClass type.

Properties
 | Name | Description
Public property | ByProductYieldFormula |
Public property | CoProductYieldFormula |
Public property | ScrapYieldFormula |
Public property | YieldFormula |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

YieldFormulasClass Class
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetBomHeaderItemInfo Method

Returns Item Code and Name from BOM based on Code

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetBomHeaderItemInfo( _
   ByVal Token As String, _
   ByVal Code As String, _
   ByRef ItemCode As String, _
   ByRef Revision As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool GetBomHeaderItemInfo(
   string Token,
   string Code,
   out string ItemCode,
   out string Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool GetBomHeaderItemInfo(
   String^ Token,
   String^ Code,
   String^& ItemCode,
   String^& Revision
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetBomHeaderItemInfo(
    Token : String,
    Code : String,
    ItemCode : String,
    Revision : String
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Code

Type: string

ItemCode

Type: string

Revision

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.ContainsChildMors Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function ContainsChildMors( _
   ByVal token As String, _
   ByVal DocEntry As Integer _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool ContainsChildMors(
   string token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool ContainsChildMors(
   String^ token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function ContainsChildMors(
    token : String,
    DocEntry : int
) : boolean;
This language is not supported or no code example is available.

Parameters

token

Type: string

DocEntry

Type: int

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetChildMors Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetChildMors( _
   ByVal token As String, _
   ByVal DocEntry As Integer _
) As List(Of Integer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static List<int> GetChildMors(
   string token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static List<int>^ GetChildMors(
   String^ token,
   int DocEntry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

token

Type: string

DocEntry

Type: int

Return Value

Type: List<int>
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetFirstMor Method

Rerutns top parent Mor Docentry for Semi MORS

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetFirstMor( _
   ByVal token As String, _
   ByVal docentry As Integer _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int GetFirstMor(
   string token,
   int docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static int GetFirstMor(
   String^ token,
   int docentry
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetFirstMor(
    token : String,
    docentry : int
) : int;
This language is not supported or no code example is available.

Parameters

token

Type: string

docentry

Type: int

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.CheckItemAgainstBillOfMaterialsDefinitions Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function CheckItemAgainstBillOfMaterialsDefinitions( _
   ByVal token As String, _
   ByVal itemCode As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool CheckItemAgainstBillOfMaterialsDefinitions(
   string token,
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool CheckItemAgainstBillOfMaterialsDefinitions(
   String^ token,
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function CheckItemAgainstBillOfMaterialsDefinitions(
    token : String,
    itemCode : String
) : boolean;
This language is not supported or no code example is available.

Parameters

token

Type: string

itemCode

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.IsRoutingActive Method

Chcks if Routing is Active and Can Be used

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function IsRoutingActive( _
   ByVal Token As String, _
   ByVal RoutingCode As String _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static bool IsRoutingActive(
   string Token,
   string RoutingCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static bool IsRoutingActive(
   String^ Token,
   String^ RoutingCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function IsRoutingActive(
    Token : String,
    RoutingCode : String
) : boolean;
This language is not supported or no code example is available.

Parameters

Token

Type: string

RoutingCode

Type: string

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetResourceGroupName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResourceGroupName( _
   ByVal Token As String, _
   ByVal RscGrpCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResourceGroupName(
   string Token,
   string RscGrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResourceGroupName(
   String^ Token,
   String^ RscGrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResourceGroupName(
    Token : String,
    RscGrpCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

RscGrpCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetResourceGroupCode Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResourceGroupCode( _
   ByVal Token As String, _
   ByVal RscGrpCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResourceGroupCode(
   string Token,
   string RscGrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResourceGroupCode(
   String^ Token,
   String^ RscGrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResourceGroupCode(
    Token : String,
    RscGrpCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

RscGrpCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetResourcePropertyName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetResourcePropertyName( _
   ByVal Token As String, _
   ByVal RscPrpCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetResourcePropertyName(
   string Token,
   string RscPrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetResourcePropertyName(
   String^ Token,
   String^ RscPrpCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetResourcePropertyName(
    Token : String,
    RscPrpCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

RscPrpCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


Technology.GetWordName Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetWordName( _
   ByVal Token As String, _
   ByVal RscWrdCode As String _
) As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string GetWordName(
   string Token,
   string RscWrdCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ GetWordName(
   String^ Token,
   String^ RscWrdCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetWordName(
    Token : String,
    RscWrdCode : String
) : String;
This language is not supported or no code example is available.

Parameters

Token

Type: string

RscWrdCode

Type: string

Return Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

Technology Class
Technology Members
CompuTec.ProcessForce.API.Tools Namespace


IInternalLeadTimeRule.CalculateLeadTime (ItemManager, IDocLine) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CalculateLeadTime( _
   ByVal itemManager As ItemManager, _
   ByVal docLine As IDocLine _
) As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan CalculateLeadTime(
   ItemManager itemManager,
   IDocLine docLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

TimeSpan CalculateLeadTime(
   ItemManager^ itemManager,
   IDocLine^ docLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CalculateLeadTime(
    itemManager : ItemManager,
    docLine : IDocLine
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

itemManager

Type: ItemManager

docLine

Type: IDocLine

Return Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInternalLeadTimeRule Interface
IInternalLeadTimeRule Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


IInternalLeadTimeRule.CalculateLeadTime (IPathItem, IDocLine) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CalculateLeadTime( _
   ByVal path As IPathItem, _
   ByVal docLine As IDocLine _
) As TimeSpan
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
TimeSpan CalculateLeadTime(
   IPathItem path,
   IDocLine docLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

TimeSpan CalculateLeadTime(
   IPathItem^ path,
   IDocLine^ docLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CalculateLeadTime(
    path : IPathItem,
    docLine : IDocLine
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

path

Type: IPathItem

docLine

Type: IDocLine

Return Value

Type: TimeSpan
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IInternalLeadTimeRule Interface
IInternalLeadTimeRule Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.GetItemManager (String) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemManager( _
   ByVal itemcode As String _
) As ItemManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ItemManager GetItemManager(
   string itemcode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
ItemManager^ GetItemManager(
   String^ itemcode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemManager(
    itemcode : String
) : ItemManager;
This language is not supported or no code example is available.

Parameters

itemcode

Type: string

Return Value

Type: ItemManager
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


MRPManager.GetItemManager (String, ItemManager) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetItemManager( _
   ByVal itemcode As String, _
   ByRef manager As ItemManager _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool GetItemManager(
   string itemcode,
   out ItemManager manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool GetItemManager(
   String^ itemcode,
   ItemManager^& manager
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetItemManager(
    itemcode : String,
    manager : ItemManager
) : boolean;
This language is not supported or no code example is available.

Parameters

itemcode

Type: string

manager

Type: ItemManager

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MRPManager Class
MRPManager Members
CompuTec.ProcessForce.API.Tools.MRP.Engine Namespace


ISupplyGenerator.CanGenerateSupply (ItemManager, IScenario) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function CanGenerateSupply( _
   ByVal pathItem As ItemManager, _
   ByVal scenario As IScenario _
) As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
bool CanGenerateSupply(
   ItemManager pathItem,
   IScenario scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

bool CanGenerateSupply(
   ItemManager^ pathItem,
   IScenario^ scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function CanGenerateSupply(
    pathItem : ItemManager,
    scenario : IScenario
) : boolean;
This language is not supported or no code example is available.

Parameters

pathItem

Type: ItemManager

scenario

Type: IScenario

Return Value

Type: bool
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ISupplyGenerator Interface
ISupplyGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ProductionGenerator.CanGenerateSupply (ItemManager, IScenario) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CanGenerateSupply( _
   ByVal pathItem As ItemManager, _
   ByVal scenario As IScenario _
) As Boolean Implements  _
   ISupplyGenerator.CanGenerateSupply
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool CanGenerateSupply(
   ItemManager pathItem,
   IScenario scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool CanGenerateSupply(
   ItemManager^ pathItem,
   IScenario^ scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CanGenerateSupply(
    pathItem : ItemManager,
    scenario : IScenario
) : boolean;
This language is not supported or no code example is available.

Parameters

pathItem

Type: ItemManager

scenario

Type: IScenario

Return Value

Type: bool

Implements

ISupplyGenerator.CanGenerateSupply
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProductionGenerator Class
ProductionGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


ProductionGenerator.CanGenerateSupply (LinkedListNode<IMRPEntity>, IScenario) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CanGenerateSupply( _
   ByVal entity As LinkedListNode(Of IMRPEntity), _
   ByVal configuration As IScenario _
) As Boolean Implements  _
   ISupplyGenerator.CanGenerateSupply
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool CanGenerateSupply(
   LinkedListNode<IMRPEntity> entity,
   IScenario configuration
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool CanGenerateSupply(
   LinkedListNode<IMRPEntity^>^ entity,
   IScenario^ configuration
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

entity

Type: LinkedListNode<IMRPEntity>

configuration

Type: IScenario

Return Value

Type: bool

Implements

ISupplyGenerator.CanGenerateSupply
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ProductionGenerator Class
ProductionGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


StockTransferGenerator.CanGenerateSupply (ItemManager, IScenario) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CanGenerateSupply( _
   ByVal pathItem As ItemManager, _
   ByVal scenario As IScenario _
) As Boolean Implements  _
   ISupplyGenerator.CanGenerateSupply
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool CanGenerateSupply(
   ItemManager pathItem,
   IScenario scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool CanGenerateSupply(
   ItemManager^ pathItem,
   IScenario^ scenario
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CanGenerateSupply(
    pathItem : ItemManager,
    scenario : IScenario
) : boolean;
This language is not supported or no code example is available.

Parameters

pathItem

Type: ItemManager

scenario

Type: IScenario

Return Value

Type: bool

Implements

ISupplyGenerator.CanGenerateSupply
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferGenerator Class
StockTransferGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


StockTransferGenerator.CanGenerateSupply (LinkedListNode<IMRPEntity>, IScenario) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CanGenerateSupply( _
   ByVal entity As LinkedListNode(Of IMRPEntity), _
   ByVal configuration As IScenario _
) As Boolean Implements  _
   ISupplyGenerator.CanGenerateSupply
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public bool CanGenerateSupply(
   LinkedListNode<IMRPEntity> entity,
   IScenario configuration
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
bool CanGenerateSupply(
   LinkedListNode<IMRPEntity^>^ entity,
   IScenario^ configuration
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

entity

Type: LinkedListNode<IMRPEntity>

configuration

Type: IScenario

Return Value

Type: bool

Implements

ISupplyGenerator.CanGenerateSupply
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

StockTransferGenerator Class
StockTransferGenerator Members
CompuTec.ProcessForce.API.Tools.MRP.Engine.SupplyGenerators Namespace


PathNotFoundForInputDataException Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Exceptions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public PathNotFoundForInputDataException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
PathNotFoundForInputDataException()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function PathNotFoundForInputDataException();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PathNotFoundForInputDataException Class
PathNotFoundForInputDataException Members
CompuTec.ProcessForce.API.Tools.MRP.Exceptions Namespace


PathNotFoundForInputDataException(String) Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Exceptions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public PathNotFoundForInputDataException(
   string message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
PathNotFoundForInputDataException(
   String^ message
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function PathNotFoundForInputDataException(
    message : String
);
This language is not supported or no code example is available.

Parameters

message

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PathNotFoundForInputDataException Class
PathNotFoundForInputDataException Members
CompuTec.ProcessForce.API.Tools.MRP.Exceptions Namespace


PathNotFoundForInputDataException(String, Exception) Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Exceptions
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public PathNotFoundForInputDataException(
   string message,
   Exception inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
PathNotFoundForInputDataException(
   String^ message,
   Exception^ inner
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function PathNotFoundForInputDataException(
    message : String,
    inner : Exception
);
This language is not supported or no code example is available.

Parameters

message

Type: string

inner

Type: Exception

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PathNotFoundForInputDataException Class
PathNotFoundForInputDataException Members
CompuTec.ProcessForce.API.Tools.MRP.Exceptions Namespace


IPathItem.RecalculateCumulaiveQuantity Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub RecalculateCumulaiveQuantity()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void RecalculateCumulaiveQuantity()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void RecalculateCumulaiveQuantity()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function RecalculateCumulaiveQuantity();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem.RecalculateCumulaiveQuantity (LinkedListNode<IMRPEntity>) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Sub RecalculateCumulaiveQuantity( _
   ByVal startItem As LinkedListNode(Of IMRPEntity) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
void RecalculateCumulaiveQuantity(
   LinkedListNode<IMRPEntity> startItem
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

void RecalculateCumulaiveQuantity(
   LinkedListNode<IMRPEntity^>^ startItem
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

startItem

Type: LinkedListNode<IMRPEntity>

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem.GetAvailbleQuantityForDate (DateTime, IMRPEntity) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAvailbleQuantityForDate( _
   ByVal date As Date, _
   ByVal entity As IMRPEntity _
) As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal GetAvailbleQuantityForDate(
   DateTime date,
   IMRPEntity entity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Decimal GetAvailbleQuantityForDate(
   DateTime date,
   IMRPEntity^ entity
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetAvailbleQuantityForDate(
    date : DateTime,
    entity : IMRPEntity
) : decimal;
This language is not supported or no code example is available.

Parameters

date

Type: DateTime

entity

Type: IMRPEntity

Return Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


IPathItem.GetAvailbleQuantityForDate (DateTime) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetAvailbleQuantityForDate( _
   ByVal dateTime As Date _
) As Decimal
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
decimal GetAvailbleQuantityForDate(
   DateTime dateTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

Decimal GetAvailbleQuantityForDate(
   DateTime dateTime
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetAvailbleQuantityForDate(
    dateTime : DateTime
) : decimal;
This language is not supported or no code example is available.

Parameters

dateTime

Type: DateTime

Return Value

Type: decimal
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathItem Interface
IPathItem Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ItemPath.RecalculateCumulaiveQuantity Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub RecalculateCumulaiveQuantity() Implements  _
   IPathItem.RecalculateCumulaiveQuantity
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void RecalculateCumulaiveQuantity()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void RecalculateCumulaiveQuantity()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function RecalculateCumulaiveQuantity();
This language is not supported or no code example is available.

Implements

IPathItem.RecalculateCumulaiveQuantity
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ItemPath Class
ItemPath Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity(IPathItem, IDocLine) Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal path As IPathItem, _
   ByVal line As IDocLine _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MrpEntity(
   IPathItem path,
   IDocLine line
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
MrpEntity(
   IPathItem^ path,
   IDocLine^ line
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function MrpEntity(
    path : IPathItem,
    line : IDocLine
);
This language is not supported or no code example is available.

Parameters

path

Type: IPathItem

line

Type: IDocLine

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity(IPathItem, IDocLine, SupplyType) Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal path As IPathItem, _
   ByVal line As IDocLine, _
   ByVal supplyType As SupplyType _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MrpEntity(
   IPathItem path,
   IDocLine line,
   SupplyType supplyType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
MrpEntity(
   IPathItem^ path,
   IDocLine^ line,
   SupplyType supplyType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function MrpEntity(
    path : IPathItem,
    line : IDocLine,
    supplyType : SupplyType
);
This language is not supported or no code example is available.

Parameters

path

Type: IPathItem

line

Type: IDocLine

supplyType

Type: SupplyType

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity(Decimal, Direction, DateTime, SupplyType) Constructor

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal qty As Decimal, _
   ByVal dir As Direction, _
   ByVal date As Date, _
   ByVal supplyType As SupplyType _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MrpEntity(
   decimal qty,
   Direction dir,
   DateTime date,
   SupplyType supplyType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
MrpEntity(
   Decimal qty,
   Direction dir,
   DateTime date,
   SupplyType supplyType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function MrpEntity(
    qty : decimal,
    dir : Direction,
    date : DateTime,
    supplyType : SupplyType
);
This language is not supported or no code example is available.

Parameters

qty

Type: decimal

dir

Type: Direction

date

Type: DateTime

supplyType

Type: SupplyType

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


MrpEntity(IMRPEntity, IDocLine, TimeSpan, DateTime) Constructor

ForCreationOfAvailbility

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Obj
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal entity As IMRPEntity, _
   ByVal line As IDocLine, _
   ByVal time As TimeSpan, _
   ByVal date As Date _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public MrpEntity(
   IMRPEntity entity,
   IDocLine line,
   TimeSpan time,
   DateTime date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
MrpEntity(
   IMRPEntity^ entity,
   IDocLine^ line,
   TimeSpan time,
   DateTime date
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function MrpEntity(
    entity : IMRPEntity,
    line : IDocLine,
    time : TimeSpan,
    date : DateTime
);
This language is not supported or no code example is available.

Parameters

entity

Type: IMRPEntity

line

Type: IDocLine

time

Type: TimeSpan

date

Type: DateTime

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MrpEntity Class
MrpEntity Members
CompuTec.ProcessForce.API.Tools.MRP.Obj Namespace


ByWhsPathSelectorRule.GetPath (ItemManager, String, String, String) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetPath( _
   ByVal itemManager As ItemManager, _
   ByVal itemCode As String, _
   ByVal revision As String, _
   ByVal whs As String _
) As IPathItem Implements  _
   IPathSelectorRule.GetPath
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IPathItem GetPath(
   ItemManager itemManager,
   string itemCode,
   string revision,
   string whs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IPathItem^ GetPath(
   ItemManager^ itemManager,
   String^ itemCode,
   String^ revision,
   String^ whs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetPath(
    itemManager : ItemManager,
    itemCode : String,
    revision : String,
    whs : String
) : IPathItem;
This language is not supported or no code example is available.

Parameters

itemManager

Type: ItemManager

itemCode

Type: string

revision

Type: string

whs

Type: string

Return Value

Type: IPathItem

Implements

IPathSelectorRule.GetPath
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ByWhsPathSelectorRule Class
ByWhsPathSelectorRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


ByWhsPathSelectorRule.GetPath (MRPManager, String, String, String) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function GetPath( _
   ByVal manager As MRPManager, _
   ByVal itemCode As String, _
   ByVal revision As String, _
   ByVal whs As String _
) As IPathItem Implements  _
   IPathSelectorRule.GetPath
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IPathItem GetPath(
   MRPManager manager,
   string itemCode,
   string revision,
   string whs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IPathItem^ GetPath(
   MRPManager^ manager,
   String^ itemCode,
   String^ revision,
   String^ whs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function GetPath(
    manager : MRPManager,
    itemCode : String,
    revision : String,
    whs : String
) : IPathItem;
This language is not supported or no code example is available.

Parameters

manager

Type: MRPManager

itemCode

Type: string

revision

Type: string

whs

Type: string

Return Value

Type: IPathItem

Implements

IPathSelectorRule.GetPath
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

ByWhsPathSelectorRule Class
ByWhsPathSelectorRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


PurchaseInternalLeadTimeRule.CalculateLeadTime (ItemManager, IDocLine) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CalculateLeadTime( _
   ByVal itemManager As ItemManager, _
   ByVal docLine As IDocLine _
) As TimeSpan Implements  _
   IInternalLeadTimeRule.CalculateLeadTime
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan CalculateLeadTime(
   ItemManager itemManager,
   IDocLine docLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeSpan CalculateLeadTime(
   ItemManager^ itemManager,
   IDocLine^ docLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CalculateLeadTime(
    itemManager : ItemManager,
    docLine : IDocLine
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

itemManager

Type: ItemManager

docLine

Type: IDocLine

Return Value

Type: TimeSpan

Implements

IInternalLeadTimeRule.CalculateLeadTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseInternalLeadTimeRule Class
PurchaseInternalLeadTimeRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


PurchaseInternalLeadTimeRule.CalculateLeadTime (IPathItem, IDocLine) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CalculateLeadTime( _
   ByVal path As IPathItem, _
   ByVal docLine As IDocLine _
) As TimeSpan Implements  _
   IInternalLeadTimeRule.CalculateLeadTime
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan CalculateLeadTime(
   IPathItem path,
   IDocLine docLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeSpan CalculateLeadTime(
   IPathItem^ path,
   IDocLine^ docLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CalculateLeadTime(
    path : IPathItem,
    docLine : IDocLine
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

path

Type: IPathItem

docLine

Type: IDocLine

Return Value

Type: TimeSpan

Implements

IInternalLeadTimeRule.CalculateLeadTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PurchaseInternalLeadTimeRule Class
PurchaseInternalLeadTimeRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


SalesInternalLeadTimeRule.CalculateLeadTime (ItemManager, IDocLine) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function CalculateLeadTime( _
   ByVal itemManager As ItemManager, _
   ByVal docLine As IDocLine _
) As TimeSpan Implements  _
   IInternalLeadTimeRule.CalculateLeadTime
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TimeSpan CalculateLeadTime(
   ItemManager itemManager,
   IDocLine docLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
TimeSpan CalculateLeadTime(
   ItemManager^ itemManager,
   IDocLine^ docLine
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CalculateLeadTime(
    itemManager : ItemManager,
    docLine : IDocLine
) : TimeSpan;
This language is not supported or no code example is available.

Parameters

itemManager

Type: ItemManager

docLine

Type: IDocLine

Return Value

Type: TimeSpan

Implements

IInternalLeadTimeRule.CalculateLeadTime
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

SalesInternalLeadTimeRule Class
SalesInternalLeadTimeRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


IPathSelectorRule.GetPath (ItemManager, String, String, String) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetPath( _
   ByVal itemManager As ItemManager, _
   ByVal itemCode As String, _
   ByVal revision As String, _
   ByVal whs As String _
) As IPathItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IPathItem GetPath(
   ItemManager itemManager,
   string itemCode,
   string revision,
   string whs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

IPathItem^ GetPath(
   ItemManager^ itemManager,
   String^ itemCode,
   String^ revision,
   String^ whs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetPath(
    itemManager : ItemManager,
    itemCode : String,
    revision : String,
    whs : String
) : IPathItem;
This language is not supported or no code example is available.

Parameters

itemManager

Type: ItemManager

itemCode

Type: string

revision

Type: string

whs

Type: string

Return Value

Type: IPathItem
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathSelectorRule Interface
IPathSelectorRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


IPathSelectorRule.GetPath (MRPManager, String, String, String) Method

Namespace: CompuTec.ProcessForce.API.Tools.MRP.Rules
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Function GetPath( _
   ByVal itemManager As MRPManager, _
   ByVal itemCode As String, _
   ByVal revision As String, _
   ByVal whs As String _
) As IPathItem
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
IPathItem GetPath(
   MRPManager itemManager,
   string itemCode,
   string revision,
   string whs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy

IPathItem^ GetPath(
   MRPManager^ itemManager,
   String^ itemCode,
   String^ revision,
   String^ whs
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
function GetPath(
    itemManager : MRPManager,
    itemCode : String,
    revision : String,
    whs : String
) : IPathItem;
This language is not supported or no code example is available.

Parameters

itemManager

Type: MRPManager

itemCode

Type: string

revision

Type: string

whs

Type: string

Return Value

Type: IPathItem
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

IPathSelectorRule Interface
IPathSelectorRule Members
CompuTec.ProcessForce.API.Tools.MRP.Rules Namespace


PDCTools Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class PDCTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static class PDCTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class PDCTools
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PDCTools
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.PDCTools
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDCTools Members
CompuTec.ProcessForce.API.Tools Namespace


PDCTools Members

PDCTools Class Methods See Also

The following tables list the members exposed by the PDCTools type.

Methods
 | Name | Description
 | ChangeResourceOnMOR |
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
 | GetUDFs |
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

PDCTools Class
CompuTec.ProcessForce.API.Tools Namespace


PDCTools.GetUDFs Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetUDFs( _
   ByVal obj As Object, _
   ByVal tableName As String _
) As IUDFItems
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static IUDFItems GetUDFs(
   object obj,
   string tableName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static IUDFItems^ GetUDFs(
   object^ obj,
   String^ tableName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetUDFs(
    obj : object,
    tableName : String
) : IUDFItems;
This language is not supported or no code example is available.

Parameters

obj

Type: object

tableName

Type: string

Return Value

Type: IUDFItems
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDCTools Class
PDCTools Members
CompuTec.ProcessForce.API.Tools Namespace


PDCTools.ChangeResourceOnMOR Method

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function ChangeResourceOnMOR( _
   ByVal MORObject As Object, _
   ByVal oldResourceLine As Integer, _
   ByVal newRscCode As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int ChangeResourceOnMOR(
   object MORObject,
   int oldResourceLine,
   string newRscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static int ChangeResourceOnMOR(
   object^ MORObject,
   int oldResourceLine,
   String^ newRscCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function ChangeResourceOnMOR(
    MORObject : object,
    oldResourceLine : int,
    newRscCode : String
) : int;
This language is not supported or no code example is available.

Parameters

MORObject

Type: object

oldResourceLine

Type: int

newRscCode

Type: string

Return Value

Type: int
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

PDCTools Class
PDCTools Members
CompuTec.ProcessForce.API.Tools Namespace


BoLoadToMode Enumeration

Specifies way to "loadToForm"

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Members
Member name | Description
LoadToForm |
LoadToFormAfterLoad |
LoadToFormBeforeAdd |
LoadToFormBeforeUpdate |
LoadToFormWithDuplicate |
See Also

Reference

UdoTools Class
UdoTools Members
CompuTec.ProcessForce.API.Tools Namespace


UnitConverter Class

Members See Also

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class UnitConverter
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class UnitConverter
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class UnitConverter
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class UnitConverter
This language is not supported or no code example is available.
Inheritance Hierarchy
System.Object
CompuTec.ProcessForce.API.Tools.UnitConverter
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UnitConverter Members
CompuTec.ProcessForce.API.Tools Namespace


UnitConverter Members

UnitConverter Class Methods See Also

The following tables list the members exposed by the UnitConverter type.

Methods
 | Name | Description
 | ConvertCaloriesToJoules | concerts energy in calories to energy in Joules
 | ConvertJoulesToCalories | converts energy in joules (J) to Calories(cal)
Public method | Equals | Determines whether the specified object is equal to the current object. (inherited from Object).
Public method | GetHashCode | Serves as the default hash function. (inherited from Object).
 | GetQuantityDecimalPrecision | Gets the decimal precision for Quantity related fields.
Public method | GetType | Gets the Type of the current instance. (inherited from Object).
Public method | ToString | Returns a string that represents the current object. (inherited from Object).
Top
See Also

Reference

UnitConverter Class
CompuTec.ProcessForce.API.Tools Namespace


UnitConverter.ConvertJoulesToCalories Method

converts energy in joules (J) to Calories(cal)

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function ConvertJoulesToCalories( _
   ByVal energyInJoules As Double _
) As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static double ConvertJoulesToCalories(
   double energyInJoules
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static double ConvertJoulesToCalories(
   double energyInJoules
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function ConvertJoulesToCalories(
    energyInJoules : double
) : double;
This language is not supported or no code example is available.

Parameters

energyInJoules

Type: double

energy in Joules

Return Value

Type: double

energy in Calories

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UnitConverter Class
UnitConverter Members
CompuTec.ProcessForce.API.Tools Namespace


UnitConverter.ConvertCaloriesToJoules Method

concerts energy in calories to energy in Joules

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function ConvertCaloriesToJoules( _
   ByVal energyInCalories As Double _
) As Double
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static double ConvertCaloriesToJoules(
   double energyInCalories
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static double ConvertCaloriesToJoules(
   double energyInCalories
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function ConvertCaloriesToJoules(
    energyInCalories : double
) : double;
This language is not supported or no code example is available.

Parameters

energyInCalories

Type: double

energy in calories

Return Value

Type: double

energy in Joules

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UnitConverter Class
UnitConverter Members
CompuTec.ProcessForce.API.Tools Namespace


UnitConverter.GetQuantityDecimalPrecision Method

Gets the decimal precision for Quantity related fields.

Namespace: CompuTec.ProcessForce.API.Tools
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function GetQuantityDecimalPrecision( _
   ByVal Token As String _
) As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static int GetQuantityDecimalPrecision(
   string Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static int GetQuantityDecimalPrecision(
   String^ Token
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function GetQuantityDecimalPrecision(
    Token : String
) : int;
This language is not supported or no code example is available.

Parameters

Token

Type: string

Return Value

Type: int

System.Int32 object that represents the decimal precision for SAP Business One Quantity related fields.

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

UnitConverter Class
UnitConverter Members
CompuTec.ProcessForce.API.Tools Namespace


FormOpener.OpenBatchNumberTransactionReport Method

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub OpenBatchNumberTransactionReport( _
   ByVal ItemCode As String, _
   ByVal DistNumber As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void OpenBatchNumberTransactionReport(
   string ItemCode,
   string DistNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void OpenBatchNumberTransactionReport(
   String^ ItemCode,
   String^ DistNumber
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function OpenBatchNumberTransactionReport(
    ItemCode : String,
    DistNumber : String
);
This language is not supported or no code example is available.

Parameters

ItemCode

Type: string

DistNumber

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FormOpener Class
FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


FormOpener.FindFormAndRefresh Method

This method serches forms by FormType And Load the same value Again

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub FindFormAndRefresh( _
   ByVal FormType As String, _
   ByVal Datasource As String, _
   ByVal Field As String, _
   ByVal Value As String, _
   ByVal udotype As ObjectTypes _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void FindFormAndRefresh(
   string FormType,
   string Datasource,
   string Field,
   string Value,
   ObjectTypes udotype
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void FindFormAndRefresh(
   String^ FormType,
   String^ Datasource,
   String^ Field,
   String^ Value,
   ObjectTypes udotype
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function FindFormAndRefresh(
    FormType : String,
    Datasource : String,
    Field : String,
    Value : String,
    udotype : ObjectTypes
);
This language is not supported or no code example is available.

Parameters

FormType

Type: string

FormTypeToFind

Datasource

Type: string

DatasourceUID where key is present

Field

Type: string

Key Name

Value

Type: string

Key Value

udotype

Type: ObjectTypes

Type Of UDO to refresh

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FormOpener Class
FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


FormOpener.OpenMasterDataForm (String, String, Boolean) Method

NOTE: This member is now obsolete.

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Obsolete()> _
Public Shared Function OpenMasterDataForm( _
   ByVal menuUid As String, _
   ByVal CodeValue As String, _
   ByVal LoadMatrix As Boolean _
) As Form
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete()]
public static Form OpenMasterDataForm(
   string menuUid,
   string CodeValue,
   bool LoadMatrix
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete()]
public:
static Form^ OpenMasterDataForm(
   String^ menuUid,
   String^ CodeValue,
   bool LoadMatrix
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Obsolete()
static function OpenMasterDataForm(
    menuUid : String,
    CodeValue : String,
    LoadMatrix : boolean
) : Form;
This language is not supported or no code example is available.

Parameters

menuUid

Type: string

CodeValue

Type: string

LoadMatrix

Type: bool

Return Value

Type: Form
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FormOpener Class
FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


FormOpener.OpenMasterDataForm Method

FormOpener Class See Also

NOTE: This member is now obsolete.

Overload List
Name | Description
OpenMasterDataForm(Form, string, ObjectTypes) | Obsolete.
OpenMasterDataForm(string, string, bool) | Obsolete.
OpenMasterDataForm(string, string, ObjectTypes, bool) |
See Also

Reference

FormOpener Class
FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


FormOpener.OpenMasterDataForm (String, String, ObjectTypes, Boolean) Method

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function OpenMasterDataForm( _
   ByVal menuUid As String, _
   ByVal CodeValue As String, _
   ByVal type As ObjectTypes, _
   Optional ByVal loadInDisposableWay As Boolean = false _
) As Form
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Form OpenMasterDataForm(
   string menuUid,
   string CodeValue,
   ObjectTypes type,
   bool loadInDisposableWay = false
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static Form^ OpenMasterDataForm(
   String^ menuUid,
   String^ CodeValue,
   ObjectTypes type,
   bool loadInDisposableWay
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function OpenMasterDataForm(
    menuUid : String,
    CodeValue : String,
    type : ObjectTypes,
    loadInDisposableWay : boolean
) : Form;
This language is not supported or no code example is available.

Parameters

menuUid

Type: string

CodeValue

Type: string

type

Type: ObjectTypes

loadInDisposableWay

Type: bool

Return Value

Type: Form
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FormOpener Class
FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


FormOpener.OpenDocumentForm (String, String, Boolean) Method

NOTE: This member is now obsolete.

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Obsolete()> _
Public Shared Function OpenDocumentForm( _
   ByVal MenuUID As String, _
   ByVal docEntry As String, _
   ByVal LoadMatrix As Boolean _
) As Form
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete()]
public static Form OpenDocumentForm(
   string MenuUID,
   string docEntry,
   bool LoadMatrix
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete()]
public:
static Form^ OpenDocumentForm(
   String^ MenuUID,
   String^ docEntry,
   bool LoadMatrix
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Obsolete()
static function OpenDocumentForm(
    MenuUID : String,
    docEntry : String,
    LoadMatrix : boolean
) : Form;
This language is not supported or no code example is available.

Parameters

MenuUID

Type: string

docEntry

Type: string

LoadMatrix

Type: bool

Return Value

Type: Form
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FormOpener Class
FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


FormOpener.OpenDocumentForm Method

FormOpener Class See Also

NOTE: This member is now obsolete.

Overload List
Name | Description
OpenDocumentForm(string, string, bool) | Obsolete.
OpenDocumentForm(Form, string, ObjectTypes) |
OpenDocumentForm(string, string, ObjectTypes) |
See Also

Reference

FormOpener Class
FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


FormOpener.OpenFormByMenuUID Method

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function OpenFormByMenuUID( _
   ByVal MenuUID As String _
) As Form
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Form OpenFormByMenuUID(
   string MenuUID
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static Form^ OpenFormByMenuUID(
   String^ MenuUID
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function OpenFormByMenuUID(
    MenuUID : String
) : Form;
This language is not supported or no code example is available.

Parameters

MenuUID

Type: string

Return Value

Type: Form
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FormOpener Class
FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


FormOpener.OpenDocumentForm (String, String, ObjectTypes) Method

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function OpenDocumentForm( _
   ByVal MenuUID As String, _
   ByVal docEntry As String, _
   ByVal udoType As ObjectTypes _
) As Form
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Form OpenDocumentForm(
   string MenuUID,
   string docEntry,
   ObjectTypes udoType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static Form^ OpenDocumentForm(
   String^ MenuUID,
   String^ docEntry,
   ObjectTypes udoType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function OpenDocumentForm(
    MenuUID : String,
    docEntry : String,
    udoType : ObjectTypes
) : Form;
This language is not supported or no code example is available.

Parameters

MenuUID

Type: string

docEntry

Type: string

udoType

Type: ObjectTypes

Return Value

Type: Form
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FormOpener Class
FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


FormOpener.OpenDocumentForm (Form, String, ObjectTypes) Method

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Function OpenDocumentForm( _
   ByVal frm As Form, _
   ByVal docEntry As String, _
   ByVal udoType As ObjectTypes _
) As Form
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Form OpenDocumentForm(
   Form frm,
   string docEntry,
   ObjectTypes udoType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static Form^ OpenDocumentForm(
   Form^ frm,
   String^ docEntry,
   ObjectTypes udoType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function OpenDocumentForm(
    frm : Form,
    docEntry : String,
    udoType : ObjectTypes
) : Form;
This language is not supported or no code example is available.

Parameters

frm

Type: Form

docEntry

Type: string

udoType

Type: ObjectTypes

Return Value

Type: Form
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FormOpener Class
FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


FormOpener.OpenMasterDataForm (Form, String, ObjectTypes) Method

NOTE: This member is now obsolete.

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Obsolete()> _
Public Shared Function OpenMasterDataForm( _
   ByVal frm As Form, _
   ByVal code As String, _
   ByVal udoType As ObjectTypes _
) As Form
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete()]
public static Form OpenMasterDataForm(
   Form frm,
   string code,
   ObjectTypes udoType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Obsolete()]
public:
static Form^ OpenMasterDataForm(
   Form^ frm,
   String^ code,
   ObjectTypes udoType
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Obsolete()
static function OpenMasterDataForm(
    frm : Form,
    code : String,
    udoType : ObjectTypes
) : Form;
This language is not supported or no code example is available.

Parameters

frm

Type: Form

code

Type: string

udoType

Type: ObjectTypes

Return Value

Type: Form
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FormOpener Class
FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


FormOpener.OpenItemDetails Method

Opens Item Details given item code

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub OpenItemDetails( _
   ByVal itemCode As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void OpenItemDetails(
   string itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void OpenItemDetails(
   String^ itemCode
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function OpenItemDetails(
    itemCode : String
);
This language is not supported or no code example is available.

Parameters

itemCode

Type: string

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

FormOpener Class
FormOpener Members
CompuTec.ProcessForce.API.UI Namespace


WhatsThis Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const WhatsThis As String = "whtThsCtx"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string WhatsThis = @"whtThsCtx"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ WhatsThis = "whtThsCtx";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const WhatsThis : String = "whtThsCtx"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

GlobalContextMenu Class
GlobalContextMenu Members
CompuTec.ProcessForce.API.UI Namespace


SemiCreationReportForm Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const SemiCreationReportForm As String = "CT_PF_SEMI_CREA_RPT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string SemiCreationReportForm = @"CT_PF_SEMI_CREA_RPT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ SemiCreationReportForm = "CT_PF_SEMI_CREA_RPT";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const SemiCreationReportForm : String = "CT_PF_SEMI_CREA_RPT"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ResourcePlanningInfoForm Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ResourcePlanningInfoForm As String = "CT_PF_RscPlanInfFrm"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ResourcePlanningInfoForm = @"CT_PF_RscPlanInfFrm"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ResourcePlanningInfoForm = "CT_PF_RscPlanInfFrm";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ResourcePlanningInfoForm : String = "CT_PF_RscPlanInfFrm"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Substitutes Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Substitutes As String = "CT_PF_Substitutes"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Substitutes = @"CT_PF_Substitutes"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Substitutes = "CT_PF_Substitutes";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Substitutes : String = "CT_PF_Substitutes"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ItemDetails Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ItemDetails As String = "CT_PF_1"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ItemDetails = @"CT_PF_1"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ItemDetails = "CT_PF_1";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ItemDetails : String = "CT_PF_1"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ItemProperty Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ItemProperty As String = "CT_PF_33"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ItemProperty = @"CT_PF_33"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ItemProperty = "CT_PF_33";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ItemProperty : String = "CT_PF_33"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ItemPropertyGroups Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ItemPropertyGroups As String = "CT_PF_30"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ItemPropertyGroups = @"CT_PF_30"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ItemPropertyGroups = "CT_PF_30";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ItemPropertyGroups : String = "CT_PF_30"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Wordbook Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Wordbook As String = "CT_PF_34"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Wordbook = @"CT_PF_34"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Wordbook = "CT_PF_34";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Wordbook : String = "CT_PF_34"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ItemClassification Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ItemClassification As String = "CT_PF_32"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ItemClassification = @"CT_PF_32"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ItemClassification = "CT_PF_32";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ItemClassification : String = "CT_PF_32"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ItemClassificationGroup Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ItemClassificationGroup As String = "CT_PF_31"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ItemClassificationGroup = @"CT_PF_31"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ItemClassificationGroup = "CT_PF_31";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ItemClassificationGroup : String = "CT_PF_31"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


VehicleInspectionGroup Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const VehicleInspectionGroup As String = "CT_PF_VIG"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string VehicleInspectionGroup = @"CT_PF_VIG"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ VehicleInspectionGroup = "CT_PF_VIG";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const VehicleInspectionGroup : String = "CT_PF_VIG"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


VehicleInspectionReasons Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const VehicleInspectionReasons As String = "CT_PF_VIR"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string VehicleInspectionReasons = @"CT_PF_VIR"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ VehicleInspectionReasons = "CT_PF_VIR";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const VehicleInspectionReasons : String = "CT_PF_VIR"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


QCPoolBatchReportForm Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const QCPoolBatchReportForm As String = "CT_PF_QCPoolBatchRpt"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string QCPoolBatchReportForm = @"CT_PF_QCPoolBatchRpt"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ QCPoolBatchReportForm = "CT_PF_QCPoolBatchRpt";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const QCPoolBatchReportForm : String = "CT_PF_QCPoolBatchRpt"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


AdditionalBatchDetails Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const AdditionalBatchDetails As String = "CT_PF_85"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string AdditionalBatchDetails = @"CT_PF_85"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ AdditionalBatchDetails = "CT_PF_85";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const AdditionalBatchDetails : String = "CT_PF_85"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


BatchTraceHistory Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const BatchTraceHistory As String = "CT_PF_BTH"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string BatchTraceHistory = @"CT_PF_BTH"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ BatchTraceHistory = "CT_PF_BTH";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const BatchTraceHistory : String = "CT_PF_BTH"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


MultipleManufacturingOrderUpdate Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const MultipleManufacturingOrderUpdate As String = "CT_PF_78"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string MultipleManufacturingOrderUpdate = @"CT_PF_78"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ MultipleManufacturingOrderUpdate = "CT_PF_78";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const MultipleManufacturingOrderUpdate : String = "CT_PF_78"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ReasonCodes Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ReasonCodes As String = "CT_PF_79"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ReasonCodes = @"CT_PF_79"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ReasonCodes = "CT_PF_79";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ReasonCodes : String = "CT_PF_79"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ReasonGroups Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ReasonGroups As String = "CT_PF_80"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ReasonGroups = @"CT_PF_80"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ReasonGroups = "CT_PF_80";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ReasonGroups : String = "CT_PF_80"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ProductionReceipts Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ProductionReceipts As String = "CT_PF_7"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ProductionReceipts = @"CT_PF_7"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ProductionReceipts = "CT_PF_7";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ProductionReceipts : String = "CT_PF_7"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Configuration Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Configuration As String = "CT_PF_10"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Configuration = @"CT_PF_10"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Configuration = "CT_PF_10";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Configuration : String = "CT_PF_10"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


TestPropertiesSelector Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const TestPropertiesSelector As String = "CT_PF_TPSF"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string TestPropertiesSelector = @"CT_PF_TPSF"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ TestPropertiesSelector = "CT_PF_TPSF";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const TestPropertiesSelector : String = "CT_PF_TPSF"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ItemsPropertiesSelector Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ItemsPropertiesSelector As String = "CT_PF_ITSF"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ItemsPropertiesSelector = @"CT_PF_ITSF"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ItemsPropertiesSelector = "CT_PF_ITSF";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ItemsPropertiesSelector : String = "CT_PF_ITSF"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


QCTResult Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const QCTResult As String = "CT_PF_QCTR"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string QCTResult = @"CT_PF_QCTR"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ QCTResult = "CT_PF_QCTR";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const QCTResult : String = "CT_PF_QCTR"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


BusinessPartnerRelations Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const BusinessPartnerRelations As String = "CT_PF_BusinessPartnerRel"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string BusinessPartnerRelations = @"CT_PF_BusinessPartnerRel"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ BusinessPartnerRelations = "CT_PF_BusinessPartnerRel";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const BusinessPartnerRelations : String = "CT_PF_BusinessPartnerRel"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


SupplierScoreCard Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const SupplierScoreCard As String = "CT_PF_SSC"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string SupplierScoreCard = @"CT_PF_SSC"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ SupplierScoreCard = "CT_PF_SSC";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const SupplierScoreCard : String = "CT_PF_SSC"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Details Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Details As String = "CT_PF_Details"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Details = @"CT_PF_Details"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Details = "CT_PF_Details";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Details : String = "CT_PF_Details"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


OpeningAndClosingRemarks Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const OpeningAndClosingRemarks As String = "CT_PF_OpnAndClsRemarks"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string OpeningAndClosingRemarks = @"CT_PF_OpnAndClsRemarks"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ OpeningAndClosingRemarks = "CT_PF_OpnAndClsRemarks";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const OpeningAndClosingRemarks : String = "CT_PF_OpnAndClsRemarks"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


InitialDataCreator Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const InitialDataCreator As String = "CT_PF_15"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string InitialDataCreator = @"CT_PF_15"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ InitialDataCreator = "CT_PF_15";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const InitialDataCreator : String = "CT_PF_15"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


MenuConfigurator Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const MenuConfigurator As String = "CT_PF_25"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string MenuConfigurator = @"CT_PF_25"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ MenuConfigurator = "CT_PF_25";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const MenuConfigurator : String = "CT_PF_25"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


HelpConfig Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const HelpConfig As String = "CT_PF_65"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string HelpConfig = @"CT_PF_65"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ HelpConfig = "CT_PF_65";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const HelpConfig : String = "CT_PF_65"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ResourceCosting Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ResourceCosting As String = "CT_PF_CRCT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ResourceCosting = @"CT_PF_CRCT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ResourceCosting = "CT_PF_CRCT";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ResourceCosting : String = "CT_PF_CRCT"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


CostRollUp Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const CostRollUp As String = "CT_PF_CRUP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string CostRollUp = @"CT_PF_CRUP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ CostRollUp = "CT_PF_CRUP";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const CostRollUp : String = "CT_PF_CRUP"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


CostRollOver Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const CostRollOver As String = "CT_PF_CROV"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string CostRollOver = @"CT_PF_CROV"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ CostRollOver = "CT_PF_CROV";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const CostRollOver : String = "CT_PF_CROV"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ResourcesAccounting Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ResourcesAccounting As String = "CT_PF_ORAC"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ResourcesAccounting = @"CT_PF_ORAC"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ResourcesAccounting = "CT_PF_ORAC";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ResourcesAccounting : String = "CT_PF_ORAC"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


PDCSettings Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const PDCSettings As String = "CT_PF_PDCSettings"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string PDCSettings = @"CT_PF_PDCSettings"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ PDCSettings = "CT_PF_PDCSettings";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const PDCSettings : String = "CT_PF_PDCSettings"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


BillOfMaterialReportCriteria Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const BillOfMaterialReportCriteria As String = "CT_PF_BOMREPCR"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string BillOfMaterialReportCriteria = @"CT_PF_BOMREPCR"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ BillOfMaterialReportCriteria = "CT_PF_BOMREPCR";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const BillOfMaterialReportCriteria : String = "CT_PF_BOMREPCR"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


BillOfMaterialReportCriteria2 Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const BillOfMaterialReportCriteria2 As String = "CT_PF_BOMREPCR2"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string BillOfMaterialReportCriteria2 = @"CT_PF_BOMREPCR2"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ BillOfMaterialReportCriteria2 = "CT_PF_BOMREPCR2";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const BillOfMaterialReportCriteria2 : String = "CT_PF_BOMREPCR2"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


BillOfMaterialReport Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const BillOfMaterialReport As String = "CT_PF_BOMREP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string BillOfMaterialReport = @"CT_PF_BOMREP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ BillOfMaterialReport = "CT_PF_BOMREP";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const BillOfMaterialReport : String = "CT_PF_BOMREP"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


RestoreItemDetails Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const RestoreItemDetails As String = "CT_PF_RestIDT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string RestoreItemDetails = @"CT_PF_RestIDT"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ RestoreItemDetails = "CT_PF_RestIDT";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const RestoreItemDetails : String = "CT_PF_RestIDT"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


RestoreItemCosting Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const RestoreItemCosting As String = "CT_PF_RestITC"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string RestoreItemCosting = @"CT_PF_RestITC"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ RestoreItemCosting = "CT_PF_RestITC";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const RestoreItemCosting : String = "CT_PF_RestITC"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


RestorePickDocumentReferences Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const RestorePickDocumentReferences As String = "CT_PF_RestPickRef"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string RestorePickDocumentReferences = @"CT_PF_RestPickRef"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ RestorePickDocumentReferences = "CT_PF_RestPickRef";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const RestorePickDocumentReferences : String = "CT_PF_RestPickRef"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


RestoreActualCostsForAllMORs Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const RestoreActualCostsForAllMORs As String = "CT_PF_RacaMORs"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string RestoreActualCostsForAllMORs = @"CT_PF_RacaMORs"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ RestoreActualCostsForAllMORs = "CT_PF_RacaMORs";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const RestoreActualCostsForAllMORs : String = "CT_PF_RacaMORs"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


RunItemRevaluationForLastFailedRollOver Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const RunItemRevaluationForLastFailedRollOver As String = "CT_PF_RestROR"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string RunItemRevaluationForLastFailedRollOver = @"CT_PF_RestROR"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ RunItemRevaluationForLastFailedRollOver = "CT_PF_RestROR";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const RunItemRevaluationForLastFailedRollOver : String = "CT_PF_RestROR"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


QualityControlReports Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const QualityControlReports As String = "CT_PF_QCTREP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string QualityControlReports = @"CT_PF_QCTREP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ QualityControlReports = "CT_PF_QCTREP";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const QualityControlReports : String = "CT_PF_QCTREP"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


BatchTraceabilitySelectionCriteria Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const BatchTraceabilitySelectionCriteria As String = "CT_PF_BTCr"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string BatchTraceabilitySelectionCriteria = @"CT_PF_BTCr"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ BatchTraceabilitySelectionCriteria = "CT_PF_BTCr";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const BatchTraceabilitySelectionCriteria : String = "CT_PF_BTCr"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


BatchTraceabilityPert Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const BatchTraceabilityPert As String = "CT_PF_BTPt"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string BatchTraceabilityPert = @"CT_PF_BTPt"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ BatchTraceabilityPert = "CT_PF_BTPt";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const BatchTraceabilityPert : String = "CT_PF_BTPt"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


BatchTraceabilityDetails Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const BatchTraceabilityDetails As String = "CT_PF_BTDt"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string BatchTraceabilityDetails = @"CT_PF_BTDt"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ BatchTraceabilityDetails = "CT_PF_BTDt";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const BatchTraceabilityDetails : String = "CT_PF_BTDt"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


UpdateYield Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const UpdateYield As String = "CT_PF_UpdateYield"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string UpdateYield = @"CT_PF_UpdateYield"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ UpdateYield = "CT_PF_UpdateYield";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const UpdateYield : String = "CT_PF_UpdateYield"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ExpityDateTemplate Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ExpityDateTemplate As String = "CT_PF_ExpExtTempl"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ExpityDateTemplate = @"CT_PF_ExpExtTempl"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ExpityDateTemplate = "CT_PF_ExpExtTempl";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ExpityDateTemplate : String = "CT_PF_ExpExtTempl"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ExpityDateValidation Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ExpityDateValidation As String = "CT_PF_ExpValidation"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ExpityDateValidation = @"CT_PF_ExpValidation"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ExpityDateValidation = "CT_PF_ExpValidation";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ExpityDateValidation : String = "CT_PF_ExpValidation"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


SerialGenerator Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const SerialGenerator As String = "CT_PF_SerGenSP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string SerialGenerator = @"CT_PF_SerGenSP"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ SerialGenerator = "CT_PF_SerGenSP";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const SerialGenerator : String = "CT_PF_SerGenSP"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


DownTimeReasonCodes Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const DownTimeReasonCodes As String = "CT_PF_DTReason"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string DownTimeReasonCodes = @"CT_PF_DTReason"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ DownTimeReasonCodes = "CT_PF_DTReason";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const DownTimeReasonCodes : String = "CT_PF_DTReason"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ScrapReasonCodes Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ScrapReasonCodes As String = "CT_PF_SCReason"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ScrapReasonCodes = @"CT_PF_SCReason"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ScrapReasonCodes = "CT_PF_SCReason";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ScrapReasonCodes : String = "CT_PF_SCReason"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ReworkReasonCodes Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ReworkReasonCodes As String = "CT_PF_RWReason"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ReworkReasonCodes = @"CT_PF_RWReason"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ReworkReasonCodes = "CT_PF_RWReason";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ReworkReasonCodes : String = "CT_PF_RWReason"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


DownTime Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const DownTime As String = "CT_PF_DownTime"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string DownTime = @"CT_PF_DownTime"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ DownTime = "CT_PF_DownTime";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const DownTime : String = "CT_PF_DownTime"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


OperationTimeRecordingReasons Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const OperationTimeRecordingReasons As String = "CT_PF_OTRReason"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string OperationTimeRecordingReasons = @"CT_PF_OTRReason"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ OperationTimeRecordingReasons = "CT_PF_OTRReason";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const OperationTimeRecordingReasons : String = "CT_PF_OTRReason"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


OperationTimeRecordingAdjReasons Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const OperationTimeRecordingAdjReasons As String = "CT_PF_OTRReasonAdj"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string OperationTimeRecordingAdjReasons = @"CT_PF_OTRReasonAdj"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ OperationTimeRecordingAdjReasons = "CT_PF_OTRReasonAdj";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const OperationTimeRecordingAdjReasons : String = "CT_PF_OTRReasonAdj"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


PreferredVendors Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const PreferredVendors As String = "PreferredVendors"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string PreferredVendors = @"PreferredVendors"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ PreferredVendors = "PreferredVendors";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const PreferredVendors : String = "PreferredVendors"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ItemCostingOverheadCosts Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ItemCostingOverheadCosts As String = "ITCOvrCst"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ItemCostingOverheadCosts = @"ITCOvrCst"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ItemCostingOverheadCosts = "ITCOvrCst";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ItemCostingOverheadCosts : String = "ITCOvrCst"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ResourceCostingOverheadCosts Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ResourceCostingOverheadCosts As String = "RCTOvrCst"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ResourceCostingOverheadCosts = @"RCTOvrCst"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ResourceCostingOverheadCosts = "RCTOvrCst";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ResourceCostingOverheadCosts : String = "RCTOvrCst"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Class Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Class As String = "CT_PF_Class"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Class = @"CT_PF_Class"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Class = "CT_PF_Class";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Class : String = "CT_PF_Class"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Category Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Category As String = "CT_PF_Category"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Category = @"CT_PF_Category"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Category = "CT_PF_Category";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Category : String = "CT_PF_Category"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


CreatedRecommendations Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const CreatedRecommendations As String = "CT_PF_CrRecomms"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string CreatedRecommendations = @"CT_PF_CrRecomms"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ CreatedRecommendations = "CT_PF_CrRecomms";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const CreatedRecommendations : String = "CT_PF_CrRecomms"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


ResourceCalendarStandardHours Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const ResourceCalendarStandardHours As String = "CT_PF_RscCalStdHrs"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string ResourceCalendarStandardHours = @"CT_PF_RscCalStdHrs"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ ResourceCalendarStandardHours = "CT_PF_RscCalStdHrs";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const ResourceCalendarStandardHours : String = "CT_PF_RscCalStdHrs"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


Forecast Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const Forecast As String = "CT_PF_Forecast"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string Forecast = @"CT_PF_Forecast"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ Forecast = "CT_PF_Forecast";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const Forecast : String = "CT_PF_Forecast"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


GenerateForecast Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const GenerateForecast As String = "CT_PF_GenForcst"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string GenerateForecast = @"CT_PF_GenForcst"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ GenerateForecast = "CT_PF_GenForcst";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const GenerateForecast : String = "CT_PF_GenForcst"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


MrpSelectionCriteria Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const MrpSelectionCriteria As String = "CT_PF_MrpSelCrit"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string MrpSelectionCriteria = @"CT_PF_MrpSelCrit"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ MrpSelectionCriteria = "CT_PF_MrpSelCrit";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const MrpSelectionCriteria : String = "CT_PF_MrpSelCrit"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


MrpRecommendations Field

Namespace: CompuTec.ProcessForce.API.UI
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const MrpRecommendations As String = "CT_PF_MrpRec"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string MrpRecommendations = @"CT_PF_MrpRec"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ MrpRecommendations = "CT_PF_MrpRec";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const MrpRecommendations : String = "CT_PF_MrpRec"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

MenuUniqueIds Class
MenuUniqueIds Members
CompuTec.ProcessForce.API.UI Namespace


DataTableRow Constructor

Namespace: CompuTec.ProcessForce.API.UI.Tools.DataTables
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DataTableRow()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DataTableRow()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DataTableRow();
This language is not supported or no code example is available.
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataTableRow Class
DataTableRow Members
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


DataTableRow(String, String, String, Int32, Int32) Constructor

Namespace: CompuTec.ProcessForce.API.UI.Tools.DataTables
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub New( _
   ByVal ItemType As String, _
   ByVal itemcode As String, _
   ByVal ItemName As String, _
   ByVal seq As Integer, _
   ByVal baseline As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public DataTableRow(
   string ItemType,
   string itemcode,
   string ItemName,
   int seq,
   int baseline
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
DataTableRow(
   String^ ItemType,
   String^ itemcode,
   String^ ItemName,
   int seq,
   int baseline
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function DataTableRow(
    ItemType : String,
    itemcode : String,
    ItemName : String,
    seq : int,
    baseline : int
);
This language is not supported or no code example is available.

Parameters

ItemType

Type: string

itemcode

Type: string

ItemName

Type: string

seq

Type: int

baseline

Type: int

Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

DataTableRow Class
DataTableRow Members
CompuTec.ProcessForce.API.UI.Tools.DataTables Namespace


APIVersion Field

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Shadows APIVersion As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
new public static string APIVersion
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static String^ APIVersion;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static APIVersion : String
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VersionInfo Class
VersionInfo Members
CompuTec.ProcessForce.API Namespace


AssemblyVersionField Field

The name of a database column that represents the ProcessForce's assembly version.

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const AssemblyVersionField As String = "U_PFVersion"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string AssemblyVersionField = @"U_PFVersion"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ AssemblyVersionField = "U_PFVersion";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const AssemblyVersionField : String = "U_PFVersion"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VersionInfo Class
VersionInfo Members
CompuTec.ProcessForce.API Namespace


DatabaseVersionField Field

The name of a database column that represents the ProcessForce's database version.

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Const DatabaseVersionField As String = "U_PFDBVersion"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const string DatabaseVersionField = @"U_PFDBVersion"
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
const String^ DatabaseVersionField = "U_PFDBVersion";
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public const DatabaseVersionField : String = "U_PFDBVersion"
This language is not supported or no code example is available.

Field Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VersionInfo Class
VersionInfo Members
CompuTec.ProcessForce.API Namespace


VersionInfo.AssemblyVersion Property

Gets an assembly version value of the CompuTec.ProcessForce.API.dll file.

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Shared Property AssemblyVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string AssemblyVersion {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property String^ AssemblyVersion {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get AssemblyVersion() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VersionInfo Class
VersionInfo Members
CompuTec.ProcessForce.API Namespace


VersionInfo.DatabaseVersion Property

Gets ProcessForce's database version value.

Namespace: CompuTec.ProcessForce.API
Assembly: CompuTec.ProcessForce.API (in CompuTec.ProcessForce.API.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ReadOnly Shared Property DatabaseVersion() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static string DatabaseVersion {get;}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static property String^ DatabaseVersion {
 String^ get( );
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function get DatabaseVersion() : String;
This language is not supported or no code example is available.

Property Value

Type: string
Platforms

Windows Phone 8.1, Windows Phone 8, Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows 7, Windows Vista SP2, Windows Server 2008 (Server Core Role not supported), Windows Server 2008 R2 (Server Core Role supported with SP1 or later; Itanium not supported)

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.7 4.6, 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Framework Client Profile

Supported in: 4, 3.5 SP1
See Also

Reference

VersionInfo Class
VersionInfo Members
CompuTec.ProcessForce.API Namespace